База знаний (май-ноябрь 2004) | mista.ru

Информационные системы
База знаний (май-ноябрь 2004)

1С:Предприятие

Учебник
Рассылка
Курс лекций
Статьи
Программы
Ссылки

Информационные технологии

Инф. системы
 Технология .Net
Модель города
 Книги и статьи
ЭРА

Интересное

Психология
Философия
Фантастика
Помощь студенту
Гостевая книга
Ссылки

Форум

База знаний

Статическая
Динамическая
mista.ru / База знаний

База знаний составлена по материалам форума www.forum.mista.ru
Составитель - Станислав Митичкин (Волшебник), а также инженеры знаний Волшебного форума.

Динамическая версия базы знаний (обновляется каждый день)

Статическая версия базы знаний (отсортирована по рубрикам)

База знаний включает только выбранные темы и сообщения форума, содержащие только знания и ничего больше. Сообщения отсортированы по темам. Отбором сообщений занимаются доверенные люди - инженеры знаний. В этот выпуск базы знаний включены сообщения за май-ноябрь 2004 года. Если вы хотите помочь в наполнении базы знаний, посещайте форум www.forum.mista.ru, рекомендуйте полезные ветки для добавления в базу знаний, станьте настоящим инженером знаний или станьте экспертом - человеком, который творит знание.

Если вы хотите все время быть в курсе новых тем, добавляемых в базу знаний, то для этого воспользуйтесь экспортом веток и сообщений базы знаний www.forum.mista.ru, о чем подробно написано на этой странице.

Благодарности:

  • Выражаю свою огромную благодарность профессионалам, которые отвечали на вопросы новичков, решали чужие проблемы, писали интересные сообщения и высказывались на самые различные темы. Именно эти люди сотворили это знание, которое сейчас предлагается вам для чтения.
  • Благодарю инженеров знаний и людей, порекомендовавших полезные ветки.
  • Благодарю начинающих пользователей, которые задавали вопросы, заставляя профессионалов напрягать извилины.

Эту базу знаний можно целиком скачать в формате HTML и CHM.

1. Коллекция HTML-файлов. Для запуска базы данных нужно распаковать архив и запустить файл index.htm
http://mista.ru/kb/mista_kb.rar - RAR 520К

2. Один CHM-файл. Очень удобная вещь, есть возможность поиска по базе знаний.
http://mista.ru/kb/mista_kb.chm - 2М

Разделы базы знаний:

  • Объекты конфигурации
  • Приемы программирования
  • Типовые конфигурации
  • Администрирование
  • Общие вопросы

Объекты конфигурации

Остальное

В каком файлике хранятся настроки шаблонов для 7.7 ?
Графовое представление MD
А можно создать программно новый объект метаданных?
что такое "обработка" ?
Копирование документов (модуль,формы)
А никто не думал? Может быть, Орефков, или ФЕЗ ?
Как программно узнать параметры справочника
v8: Будни: Как определить, что ссылка на справочник или документ?

Справочники

Как програмно перенести существующий элемент справочника в другую группу?
История курсов валют
Куда деваются описания периодических полей справочника(файл *.dd)
Системные справочники в 1С:Зарплата и Кадры
Можно ли осуществить программно поиск в справочнике по фрагменту...
Ошибка "Не задан вид"
Периодический сохраняет значения с точностью до дня?
получить даты периодических реквизитов
Выбор из справочника
Чем можно заменить функцию Активизация()?
При выборе значения из справочника заходить сразу в опред. группу
ИспользоватьВладельца() ?
как распечатать справочник?
Переход по элементам???
А как найти этот следующий??
справочники стандартный отбор версия 8.0
Почему код элемента справочника всё время одиноковый
Получение данных из справочника
Запретить удаление и добавление объектов в справочник
УстановитьАтрибут(,) - ошибка, если реквизит периодический :(
НайтиПоРеквизиту?
сохранить справочник
составной уникальный индекс
интерактивный множественный выбор (эл.справ.) с группами...
Вопрос по присвоению реквизита.
Группы справочников... Как узнать узел листа?
Господа, что я делаю не так? (Начинающий)
Недопустимая операция, при попытке установить значение переодического рекв.
Подчиненный справочник
Не записывается атрибут типа Перечисление в подчиненном справочнике
Обход подчиненного справочника (вопрос №2)
Обход подчиненного справочника (вопрос)
Фильтр в справочнике
Перенос клиентов в ТиС
Помогите разобраться с методом справочника "ПринадлежитГруппе"
Помогите составить запрос к справочнику "номенклатура"
синхронизация данных в справочниках
проблема с экспортом справочников из 7.7
Корректен ли следующий код?
Учет в ювелирном магазине
Тип поля: Справочник. Неопределенный
Работа с транзакциями
как быстро найти договор в двухуровневом подчиненном спр.?
Копирование эл.справочника с подчиненными
Сортировка справочника в 1C 7.7
Как засунуть элемент справочника в группу ПРОГРАММНО ???
Запрет на добавление нового элемента в справочнике, что за...?
Удаление подчиненного элемента справочника
Периодический реквизит - не периодический??
Можно ли приручить "дерево групп" в справочнике?
Спр. Номенклатура "убрать повторы"
Сортировка справочника с символами "-"...
v8: 8.0. Отбор в иерерхическом справочнике

Документы

Программно узнать, введен ли документ на основании другого
Программно изменить время при проведении документа без сообщения
Как установить отбор по значению в обычном журнале?
Как убрать сообщение "Провести задним числом?"
не работает процедура как описана в учебнике
Как получить количество реквизитов шапки документа ?
Возможно ли изменить панель инструментов для расходной накладной
Количество строк табличной части документа >10000
Как добавить строки в многострочную часть документа из другого документа?
Автоподстановка номеров
Как разместить документ между двумя другими?..
Как заполнить документ из отчета?
Как реализовать две табличные части в документе
Перепроведение
Перенос реквизитов документа
Вопрос по табличной части документа
Журнал
Как быстро удалить документы?
Допроведение документа
Непосредственное удаление документов!
Как запретить проводку документа
Нули в номере документа, как их забабацат ?
Непосредственное удаление в 77
Метод УстановитьОтбор() в журнале. Как его использовать?
Отбор документов по общему реквизиту и виду документа одновременно
Так возможны ли две табличные части.???
cvvПроведение документов НЕ используя СТАНДАРТНЫЕ средства 1С
программное создание и заполнение документа... ?
Как правильно подготовить данные для отчета по подчиненным документам?
"время проведения документа" и "уникальный номер"... почему не само-соб
починить последовательность
Кто делал дерево документов на 8.0?
Сбилось поле автонумерации
как увеличить количество строк в табличной части документа?
Время документа, откуда 1С его берет?
Сохранение документа из модуля документа после проводки в 7.7
"Сделать документ не проведенным" как отменить изменения в документах?
Ввод на основании... шо оно такое? // ламерский вопрос
Повторное проведение документа
Как получить Представлениевида числового реквизита документа?
Название документа в торговле
Подчиненные документы
Групповая печать документов
Восстановление удаленных строк в документе?
Интервала видимости в журнале документов
табличная часть документа 7.7
Дыры в номерах документов
Табличная часть документа
Передача параметра в модуль док-та
Проведение документов
Обработка дублирования значений т.части документа
Групповая печать документов
Ошибка, при отборе документов
Как запретить удаление документа (или пометку на удаление) ?
Нумерация документов в 1с (Сложный случай) Срочно нужна помощь.
Дважды обрабатывается проведение документа???
Как с наименьшей кровью суммировать числовой реквизит отдельных строк МЧ?
В продолжение темы о безалаберности пользователей...
сообщить(Докум.ТекущийДокумент()) проблема
Реквизит табличной части в отдельном поле ввода
Доступность формы документа.
Почему для рекв. таб. части док. неопред. вида не действует НазначитьТип()
Можно ли что-то обработать в Журнале Документов
v8: Структура подчиненности обработка?

Отчеты

Расшифровка в печатной форме отчета, помогите разобраться ...
Товарный отчет с фильтрацией по складу
Может есть готовое решение?
Формирование отчётов
Преобразование таблицы в текст
1C 8.0 - Помогите с ТабличнымДокументом
Печать на указанный принтер
Работа с таблицей в режиме ввода данных
Напечатать текст "вверх ногами"
Как запретить печать выходной формы отчета
Печать справочника "контрагенты"
Как в таблице программно скрыть/показать часть столбцов?
Можно ли в таблице закрепить области?
Таблица в режиме ввода данных. HELP!!!
Как получить текст расшифровки в таблице отчета.
Сортировать по алфавиту отчет Реестр Документов
Шапка на каждой новой странице отчета
Как добраться до печатных форм....
ИТОГ по колонке
Как отобразить в отчете часть ячейки полужирным шрифтом? (ЗиК 7.7)
Как значения несколких разных отчетов собрать в своем отделно сделанном?
Режим ввода данных
Расшифровка
ОбработкаЯчейкиТаблицы() с закрытой формой
1C:8.0
Разделитель стараницы и Co
Рассчет высоты таблицы при печати...
Рисунок на заднем фоне печатной формы.
таблица в режиме ввода данных - как записать ссылку на элемент справочника
В отчетах "9'999'999.99" вместо суммы...
Как автоматически подгонать высоту ячейки в соответствии с кол-вом текста?
Как задать область таблицы в режиме ввода, чтобы м.б. исп-ть .Рамка(,,,,) ?
Как узнать сколько строк в отчете?
Как работать с гиперссылкой в 8.0 ?
Поменять програмно шрифт
Таблица в режиме ввода данных
Как построить отчет по регистру сведений v.8?
Можно ли запустить отчет 1С из Windows
Вывод отчета
Создание регламентированных отчетов
Рейтинг продаж и закупок
Еще раз о таблицах в режиме ввода данных...
Есть примеры работы с таблицей в режиме ввода?
Область печати для таблицы.
Таблица в режиме ввода данных
отчёты в фоновом режиме
v8: html Макет в v8

Регистры

Оперативные итоги
Глюк объекта "Регистры" ?
Как вывести список названий всех имеющихся регистров конфы?
V8: Планы видов характеристик
Как получить вид движения
РассчитатьРегистрыНа! Ну ёлы-палы!
Ре... Ре... Регистр ! Ы !
Переодический реквизит в справочнике V8
Ведения учета ресурсов принципиально не выводимых в ноль
Работа с регистрами остатков - где найти подробное описание
Задваиваются значения по оборотному регистру
Отчет по Торговле
Регистры в 1С:Предприятии 7.7
ТА и оборотный регистр
Подскажите где можно почитать о регистрах 8 версии
1Cv8: Неоперативное проведение
Использование регистров в запросе
Как при проведении прописать движения рег., имея переменную с его именем?
Как привязать строку таб части документа к движению регистров этого же док

Бухгалтерский учет

Как то не получается с вычислением ОБ("","")!!!!
Бухгалтерские запросы в 1С 8.0
Выбор плана счетов. v7.7
БухИтого - установка периода
Ошибка при проведении документа
Оборотно-сальдовая по счету...
Субконто: "разворачивать" и "отбирать"
Не работает фильтр в бухгалтерских итогах
Разделитель учета в бухгалтерии
Отрицательная сумма в колонке ТЗ.
продолжаем получать себестоимость...
Подскажите начинающему, как определить оборот по счету по определенным субк
Как называется функция метаданных для проверки принадлежности к бухучету
1C SQL 77. Тормозит стандартный запрос по счету по ГРУППЕ субконто
Проблема с корреспондирующими счетами
глюк при пересчете бухгалтерских итогов 7.7
Проводки по рег-ам бухгалтерии в 8.0
Бухия. Бухгалтерские Итоги. Обращение к результатам запроса.
Не получается у меня ИспользоватьСубконто() :(
Работа с корсчетами в бухгалтерских итогах
Как получить субконто при переборе по Идентификатору?
Остатки по зарплате
Информация о сотруднике в документе
Субконто
как в карточке счета выстроить значение по номенклатурному номеру
Журнал проводок и журнал операций
ВыполнитьЗапрос() по валютам
Номер журнала в 1с
PROBLEM План счетов ПЕРЕСЧЕТ БУХ ИТОГОВ
За данный период бухгалтерские итоги не рассчитаны!
Знатокам и/или столкнувшимся: Два пл.счетов - два учета - управленч. и бух.

Расчет

Пиктограмма в журнале расчета
в торговле праздничные дни
1cv8.конфигурирование: перерасчеты
Налоговые вычеты
8.0, Расчет зарплаты, подход к выполнению перерасчетов.
Вопрос про ЗиК. Как установить определенный порядок вычисления расчетов.
Календари
Скорость работы журнала расчетов
Какое различие между документом-основанием и документом-родителем записи
v8: V8 Что означает базовый период в регистре расчета?

Приемы программирования

Остальное

Показывать только существующие позиции.... как?
Передача параметра в открываемую форму
Учет товара по серийным номерам
1c-сметы
Объединение двух Глобальных модулей
каждой конфигурации свой " ...\ExtForms" из конфигуратора
Как заполнять перечисления
Запуск внещних приложений из 1с (встроенный язык - вопрос)
Как вести учет по серийному номеру в торговле 9.2
Количество страниц ...
Два одинаковых контрагента или две карточки товара. Как объединить?
Как отследить смену рабочей даты?
алгоритм проверки связности ортграфа
Уникальность ИНН Контрагента
номер страницы
Как подготовить демо версию
Работа с графической информацией в 1С
запрет продажи при рентабельности ниже Х%
Учёт товаров по серийным номерам.
Подскажите как мне организовать поиск данных?
Накопительный счетчик - обработка статистики
скрыть элементы справочника
Организовать в журнале отбор по графе только для одного вида документа
Как установить первоначальное значение "Поля выбора" в 1С 8.0?
Программное изменение заголовка окна 1С 7.7
Контекстный поиск во внешних файлах
Выснить разрешение экрана на пользовательской машине
Как завершить сеанс 1с (закрыть программу)
Сортировка по алфавиту
Как проверить наличие объекта (реквизита) ?
Работа с XBase
Пиктограммы
просмотр и печать jpg из 1С
Как скрыть окно сообщений програмно?
Где описание внешнего формата для файла выгружаемого по ЗначениеВФайл?
Как запустить выполнение Процедуры в определенное время?
Обработка клавы
Транслит в 1С
Однотипная партия товаров. Идентифик код
Как убрать меню СЕРВИС из 1C
Поиск элементов по реквизиту
Нумерация страниц в отчете 1с
Создание из 1С файла excel со структурой
Как узнать какая высота выведенной строки?
Нумерация для нескольких видов документов
Присвоение значения сгенерированному реквизиту формы
Как загрузить или получить доступ к данным из таблиц Paradox в 1С 7.7
Непонятная перекодировка(Украина)
v8: Как правильно прочитать XML?

Встроенный язык

Где в 1С хранятся процедуры обработки быстрых клавиш?
Как программно определить длину реквизита, задаваемую в конфигураторе?
Как сделать 1С-ке генератор случайных чисел ?
Смысл метода ВключитьПроводки()
ФИО в родительном падеже как?
Масивы в 1С
выбор и печать из перечислений
есть ли программный аналог операции/поиск ссылок на объекты?
Управление размером шрифта при печати ценников
Как получить значение из обработки?
Как разобрать Имя, Фамилию, Отчество на отдельные состовляющие
ПустоеЗначение()
Может у когонить уже есть готовая функция склонения
Математика в 1С
Стиль работы с типом Булево на платформе v8
Особенность преобразования числа к типу "Строка" в 1Cv8
форматирование чисел типа #N019.4
Как лучше найти ссылки на элемент справочника в документе?
Как передать список выражений в функцию Мин() или Мак()
Как прервать выполнение обработки в 8.0
Процедура вызывается как функция... Кто поможет?
О функции "Формат(<Параметр>,<Форматная строка>)
Есть ли в 1С-ине конструкция подобная case ... switch
Вызов процедуры с помощью контекста
Вопрос по синтаксису языка 1с
Как автоматически обойти 30 однотипных реквизитов в табличной части ?
Можно ли программно поменять номер операции?
Интерпретатор 1С ???
Программный доступ к интерфейсу
А где в 1С квадратные корни, степени и прочая подобная лабуда?
v8: "ИерархияГруппИЭлементов" или "ИерархияЭлементов"
v8: Как скопировать строку в буфер обмена Windows?
v8: Переход от объекта "Отбор" к объекту "Структура"
v8: v8: аналог СтатусВозврата(0) из 7.7 в 8.0
v8: Выборка и значения реквизитов табличной части

Дата, время

Помогите с 1С версии 6.0.
Отображения интервала между датами в виде "1 год 4 месяца 25 дней"
Получить ВремяДок на форме.
Установить время документу
Точка актуальности (вопрос)
Как убрать время документа???
ПустоеЗначение() типа дата
Как сложить время? Например 12:26 + 05:06 = 17:32
8.0 Дата&время. Пусть рассудит Волшебник
Операции с датами
Дата записи документа
Международное время, а как?
Как подсчитать количество месяцев между произвольными датами
Как избавиться от "Сменилась текущая дата..."
Скачет время проведения.
очень простой вопрос ламера: что надо прописать в формуле поля ввода
Работа с датой
Считать возраст

Запросы

Обращение к строке документа через регистр (НомерСтроки)
V8 Запрос, аналог Получить в 7.7
Пока Запрос.Группировка() = 1 Цикл
Проблема с запросом с подчиненным справочником
Ислючение родителя в запросе
Условие в запросе к двум справочникам
Обход подчиненного справочника (вопрос №3)
Тут вижу тут не вижу ИЛИ Запрос и все, все, все
Два регистра остатка в одной строке
Сортировка документов в отчете по дням
Простецкий запрос по справочнику
Упорядочивание в запросе
V8 условие в запросе
Периодические реквизиты в запросах

Таблица значений

Две таблицы значений - поиск одинаковых значений реквизитов
НайтиЗначение() в ТЗ по двум колонкам. Возможно ли?
Как увеличить окно выборки ТЗ?
как задать процедуру обработки при нажитии на колонке таблицы
Как объединить 2 таблицы значений в одну?
копирование таблицы значений...
Чем можно заменить динамические массивы?
Сортировка в таблице значений
Поиск по таблице значений
Максимум
метод Свернуть() в ТЗ
Обнуление ячейки Таблицы значений
Необходимость задания типа для колонки таблицы значений
Работа с таблицей значений
1с. Идентификатор Таблицы Значений полученной из Списка Значений.
визуальная ТЗ, не работает
Какой самый быстрый метод удаление строк в ТЗ

Список значений

Создание локального меню по нажатию на кнопку
Как получить текущее значение выпадающего списка???
как программно выбрать элемент спискаЗначений типа "Выпадающий список" ?
Список значений в таблице значений
У меняВ Расшифровке обычная переменная - передается, а список значений нет?

Формы

Интерфейс группировки строк документа
раздвинуть ячейку таблицы
Полосы прокрутки в форме
Как программно открыть форму ввода нового элемента справочника?
Как в Форме Списка подчиненного справочника получить ссылку на владельца...
контекст, переменная...
Параметры формы
Показать несколько фото
Внешний отчет, как закрыть форму при нажатии кнопки печать
Не работает ПЕРЕКЛЮЧАТЕЛЬ на закладке ДИАЛОГ в форме ДОКУМЕНТ.
ОткрытьФорму(,Конт) не могу достучатся до контекста открытой формы....
как добавить воможность выбора группы из справочника при создании отчета
Использование формулы в реквизите диалога для ввода
V8: Составной тип данных
Как проверить наличие кнопки на форме
Обработка событий в 8-ке
В данной формуле не может быть вызвана эта процедура(функция)
Ручное редактирование табличного поля.
форма документа открыта для изменения
Кнопки в поле ввода (V8)
Переключатели в форме
Добавление новой колонки в таблицу формы списка (справочник) - КАК ?
Закрытие окна диалога
"Редактирование в диалоге" - Заблокировано! Почему? // список элементов с
Как открыть форму элемента по гиперссылке (v8)
Как вставить реквизит документа в форму не в виде поля ввода
Недоступность новой колонки в табличной части документа
Как поменять размер формы программно в 1Cv77?
Вычисление в таблице
Общие формы в 8.0
Скрытие строки символами ******
Можно ли предотвратить изменение флага модифицированности документа в 7.7?
Контекстное меню над табл. в форме вн. отчета?
Выбор строк таблицы при помощи флажков - возможно ли это?
Расширить во весь экран
Как поместить на форму документа поле для ввода комментария?
Как изменить активность формы?
Управление закладками
Как плоучить "старые" значения реквизитов документа в форме? Вопрос по 8
Как достать элемент диалога из модуля проведения документа
Картинки на кнопках формы
Как передать параметры в форму списка справочника при открытии из документа
Форма документа
Открыть документ из документа
Как вставить формулу в элемент диалога Поле со списком
Как сделать редактируемое поле в ТЧ документа?
Процедура ПриОткрытии() и функции для расчета текстов на форме.
Отлов изменений размера окна пользорвателем
При удалении строки табличной части хочу матюк
Как открыть документ (интерактивно) в режиме просмотра
запретить выбор одной из радиокнопок?
Как получить список колонок многострочной части формы списка справочника?
Помогите заставить работать переключатель в документе
Горячие клавиши и 1С - недружат?
Про журналы подчиненых документов...
Как в табличную часть формы списка справочника добавить колонку
Checkbox'ы в табличной части документа
v8: Как в форме списка справочника владельца отобразить элементы подчиненного?
v8: Открытие подч. справ. в табличной части на основе род. справ. в шапке
v8: Будни: Организация подбора на 8.0

Файловая система

Подскажите пожалуйста, синтаксис конструкции? Метод СуществуетФайл.

Внешние обработки

Автоматическое тестирование функционала конфигураций 1С
Скрипты
Запуск внешней обработки для 7.7 из Windows с параметрами
Сравнение прайсов
Нужна внешняя обработка
Обработка .epf
Распечатка документов
Как из внешней обработки открыть существующий документ?

Внешние компоненты

Работа с FormEx
Вопрос по ActiveMD
Что такое проект "Rainbow"
Нужен DocFile Browser для Far
Внешняя компонента для работы с файлами
Как подключить внешнюю компоненту в 1С?
Помогите с внешней компоненетой!!!
RainBow : как получить ID поля даты документа?
Не удается загрузить внешнюю компоненту
1C и буфер обмена
Как получить список работающих пользователей?
FormEx и раскраска кнопки

Интернет-технологии

v7plus.dll
Отправка файла
Положить прайс zip на сайт с помошью v7plus
прием Экселевского документа по почте из 1С...
Отправка почты
WEB-компонента
работа 1с в сети Интернет?
Как можно на фтпэшник закинуть файл из среды 1С?
1С Предприятие 7.7 , нужно из 1С по кнопке открывать страничку в Интернете.
Как V7HttpReader передаёт запрос http серверу

Обмен данными, УРБД

Работа с компонентой УРБД в 1С 7.7 (пошаговая инструкция+скрипт)
Запуск 1С в пекетном режиме через планировщик
Помогите с обменом инфой между 1С и Супермаг
1c и MySQL
УРБД в 1С Предприятие 8.
УРБД, перенос документов только с определенным реквизитом
DBF файл
импорт из txt в 1С
Срочно нужно Описание УРБД
перенос доков из нераспределнки в УРИБ
Пополнение базы
При попытке сделать автообмен 1С закрывается
А я всё - по выгрузке из Т+С в бух...
Можно ли править переферийную конфигурацию?
Отгрузка ЗиК->Бух. Как правильно?
Синхронизация и перенос между двумя конфигурациями данных.
Как объединить 13-ть организаций в одно информационное пространство?
Выгрузка данных из "1С-Бух"
УРБД. Как программно получить дату последнего успешного обмена?
УРБД. Корректировка старых документов и перерасчет базы "с разных концов"
Конвертация данных
Проблема с УРБД для 1С: Зарплата
Запуск (!)1С:Предприятия(!) в пакетном режиме и выполнение там обработок
Проблема с открытие больших MXL-файлов в Excel
Закачка данных в бух.7.7 из УТ 8.0
помогите в составлении скриптов
Из 1С:Бухгалтерия в 1C:Предприниматель
нужна обработка переноса справочника номенклатура
Не получается из ТиС выгрузить счета в бух.
Синхронизация баз 1С
КД. Перенос подчиненных
Нужно перегрузить данные из Торговли в Бухгалтерию
Как перейти с Бухучета 4.5 на УСН 1.3 ?
Планы обмена в 1Сv8 - личный опыт
1С и подготвка данных для OLAP
Знатокам VBA
Загрузка прайса в Ехселе в справочник
Импорт данных из Паруса
Перенос справочников
Access -> 1C ... готовые решения?
Помогите! Расстояние между магазинами 7км ,а работать в 1с надо
Организация учета
Обработка ERT 1С, Exel и команда OpenText.
Подстановка данных из справочника при импорте
перекодировка из DOS -> UTF-8
Как создать обработку по выгрузке данных из Exel в 1С 7.7
Чем лучше всего переносить данные в разных конф. 1С?
Финансовое планирование
Справочник контрагенты
Вопрос по УРИБ
Импорт справочников из Excel
Новая база с заполненным справочником товаров
Использование УРБД
УРБД, Запуск в пакетном режиме
про .dbf
В 1С есть механизм выгрузки в формат 3.0, а механизм загрузки...
Конвертация из формата отчетности (версия 3.0) в формат Excel
Как настоить обмен данными 1С Предприятие 7.7 - Клиент-банк Сбербанк ?
XBASE
Конвертация 7 в 6?
При переносе текста из отчетов 1с в ворд появляются кракозябры
ДБФ XBAse
Префикс номера документа
Выгрузка "пустых " значений.
Выгрузка данных из Паруса 4.4
настройка УРБД
Cтандарт 1C-XML -файла
Разграничение прав в УРБД. Как???
Объединение двух переферийных баз в одну
УРБД и XML
v8: УРБД на v8 за четыре шага.
v8: опять...Есть ли обработки которые из 7.7 переносят данные в V8 ?

OLE, COM

1C и С++
Как закрыть файл Excel без запроса на сохранения из 1С?
Агенты в 1С
Как закрыть приложение открытое через OLE
нужно из другой базы сделать выборку документов
Проигрывание WAV ?
Зависает процесс 1С ОЛЕ только при работе более 20 мин....
Как вызвать процедуру из глобального модуля из Delphi
Перенос документов из Excel в 1С
При печати через шаблон в Word, как задать путь к файлу с картинкой ?
Не могу получить значение поля, являющегося перечисленем
Работа с Office через OLE
Word из 1С
Не получается заполнить таблицу Word-овского шаблона :-(
Как через Ole-Automation связаться с базой Oracle 9.2. Очень надо!!!
OLE: Вызов Word с конкретным именем файла, по образцу Excel (как в учебнике
OLE
VB vs 1C или как скрестить ежика с гиеной
OLE-OLE-OLE
OLE
1C+Excel
Нужна обработка по переносу документов по ОЛЕ из одной базы в другую
Как под SQL в версии 1С 7 запускать хранимые процедуры?
ввод документов в 1С
OLE Automation и 1С
связь AutoCAD с 1С с помощью VBA
Вызов внешнего приложения из 1С
1с7: Как делается перебор строк в файле Excel?
1С и Visual Basic 6.0
DBF: есть ли способ работать с полями MEMO?
v8: Траблы с вызовом Excel

Торговое оборудование

Использование .ocx в 1С,или подключение ШтрихТерминала PiccoLink
Вопрос по весам (торговое оборудование)
Кто-нибудь подключал к 1С сканеры штрих-кодов?
Вопрос по Феликс-РФ
Подключение сканера штрих-кодов в терминале
а как сделать чтоб при сканировании сканером штрих кода определялся товар
Дисконтные карты
Citrix XP как увеличить количество com-портов (более сом9)?
Виснет компьютер при работе с ККМ 100Ф
Подключение GEG POS-Мастер 100Ф
OffLine, OnLine
Штрих-код весового товара

Типовые конфигурации

Остальное

Существует ли конфигурация для коммунальной энергетики?
Амортизация ОС! Срок пол.действ. закончен, а амортизация начисляется!
Вопрос по книге учета доходов и расходов в упращенке
Упрощенка, кто подскажет установки
Объединение конфигураций
Решения по управленческому учету
Вопрос по ПУБу
Комплексная. Продлема с проводками.
Форма счета-фактуры в комплексной
ПО для ведения бухучета на производстве
По поводу представления отчетов в ИМНС в электронном виде...
Есть ли готовое решение для КСК (Коммунальных хозяйств)?
Вопрос по организации Счет-Фактур в 1с
В ЗиК необходимо добавить 70 счету еще одно субконто
Разобрать комплексную на отдельные конфы.
Вышла 1С-Логистика:Управление складом
Куда деваются ГТД после выгрузки из Т+С в Бух?
Автозаполняемая декларация по НДС
Принятие расходов в УСН
С помощью какого документа можно ввести акт оказания услуг в комплексной?
Комиссия в комплексной 4.5 (отчет комиссионера и возврат)
Формирование проводок в Комплексной конфигурации
Налоги: Ошибка с Резидентом ???
Чем базовая конфигурация отличается от типовой?

Бухгалтерия 7.7

Книга продаж
Остатки ОС к НУ
Бух. и ЗиК для бюджетников
Зачем нужен "лимит" в кассе, и нужен ли вообще в 1С:Бухгалтерии
Перемещание материалов в 1С:Бухгалтерия
НОВЫЙ ПЛАН СЧЕТОВ
Ввести разделитель учета в типовую бухгалтерию.
Автоматическое формирование книги покупок
настройка отчета
Как обновить в Бухгалтерии ставки РеФинансирования ч.з Инет?
Новое субконто
конец месяца. кто его делает?
Приглашаю обсудить технологию ввода остатков ОС в НУ.
Расчет себестоимости продукции в бухгалтерии?
Ввод ОС в эксплуатацию
Невозможно провести запись в книге продаж
Ошибка при переходе с редакции 4.4 на 4.5. 1С:Предприятие7.7
На сайте Бух.1С открыт раздел, посвященный регламентированной отчетности
Увеличение разрядности цены и количества до 5 после запятой
НДФЛ и ЕСН при обновлении неправильно рассчитываются
списание тмц. Какие проводки должны выполняться? (для Украины)
Сортировка в кассовой книге
Вопрос по релизу 7.70.454
Обмен опытом: Погашение стоимости остатков спецодежды.
Бухия: черный учет
Связать с/фактуры с оплатой за продукцию
Неправильно указывается документ в оборотно-сальдовой ведомости
Разница в доходах НУ и БУ
Переход на новый НДС 18%
ИНН предпринимателя
Бух: суммовой учет по складам
проблема переноса книги расходов и доходов на бухгалтерию
Запуталась в комиссии
Отчет по ОС
Как распечатать баланс с пустыми строками?
Списание себестоимости товара
"Закрытие месяца" сторнирует остатки сч. 69!!!
1c-амортизация
Отчётность
ФИО сотрудника перестала появляться в списках по кнопке ЗАПОЛНИТЬ
ОСВ по 41.1---пустые строки---Что бы это значило?
Обновление бухгалтерии 461 релиз
Хелп по бухгалтерии!!!!!!!!
Выскакивает код ошибки 10. Как исправить?
OFF: проблема с округлением
Какая есть команда в 1с чтобы сделать присвоение по сравнению?
А кто в бехгалтерии реализовал партионный учет с на 41 +учет наценок на 44?

Торговля и склад 7.7

Торговля, ЧерноБелая
Как изменить настройку валюты "вести учет" в Торговля-Склад
Как убрать окно Время документа при проведении документа?
Помогите с Запросом !!!
Перемещение ТМЦ
Хочу упростить оформление договоров...
Учет оплаты кредитов
Вопрос по запросу для отчета
Могут ли находится в близких отношениях Товар принятый и Книга продаж?
Документ "ОприходованиеТМЦ" - проведение по регистрам.
Ведомость по контрагентам в торговле 7.70.926
Помогите с отчетом "Остатки ТМЦ" в 1С ТиС
Клиент банка
Две позиции товара с разной ценой в РН?
Кто работал с торговлей???
Вопрос по 1с: Торговля и склад
Пользовательский вопрос по Торговле
1С Торговля+Склад Release R770934
Как правильно в ТиС оформить возврат от подотчетника?
HELP! ТиС не правильно расчитывается сальдо
Новый СФ в ТиС?
Поступление ТМЦ (импорт)
Помогите разобраться с формированием отчета по наличию остатков на складе
1Cv7.md без 1Cv7.DD
Кнопки настройка и обновить для внешнего отчёта

Зарплата и кадры 7.7

ЗиК 246 - лицевой счёт Т-54
ЗиК. Как начислять премию от оклада?
Компенсация отпуска
Можно ли ЗиК безболезнено обрезать, для уменьшения базы
Вопрос по расчету бригадных нарядов
Как в общем организован многовалютный учет в 1С
Обновление ЗиК
ЗиК, бюджет
ЗиК... задолженность
проблемы с сетевой ZIK 7.7
ЗиК: отражение задолженности сотрудника перед предприятием
ЗиК Прием сотрудников по срочному договору без изменения штатного расп-я
Проводки в Зарплате 7.7
ЗиК и этот районный коэффициент
Проблема с уволенным сотрудником
Начало работы с ЗиК 2.36
Как указать счет учета ЕСН в части ФСС?
как указать нерезидентов
Зи К
ЗИК: Опять районные коэффициенты.
Табель в ЗиК. Зачем по дням ?
Зарплата и кадры - соцстрах
Форма Т-2
ЗиК: Денежное вознаграждение за квалификацию.
ЗиК. Как правильно использовать Удержание за неиспользованный отпуск?
ЗиК. СуммаСреднегоЗароботкаОтпуска
Ещё не лучше: оклад военнослужащего в ЗиК...
Шаблон проводки в ЗиК
Зик. ВР который не обл только ФСС (4%)
ЗиК: Забыли сотру начислить оплату по договору подряда
Смена системы оплаты не сначала месяца (ЗиК)
Проблема с рассчетом НДФЛ. HELP!
Как включить вычет на ребенка при рассчете НДФЛ?
Неправильное начисление вечерних (ЗиК 244)
Разовая премия в расчете среднего заработка
2-НДФЛ
ЗиК. Сменная работа.
Вопрос по Зарплата+Кадры 7.70.248
сотрудница изменила фамилию

Управление торговлей 8.0

Упр.торговли 8.0 Передача товара от одной организации в другую.
Сменить родителя.
УТ 10.1 - регламентированный учет отсутствует?
OFF Анализ торговли
v8: скрипт автоматического входа в 1с 8.0
v8: Не могу изменить конфу !

УПП 8.0

v8: как отправить выгруженный в файл документ по почте?
v8: Обработки.ОбзорКонфигурации - специфика терминальной сессии?

Администрирование

Остальное

Проблема при работе 1c+Sql+Terminal Server
Сообщение unable to log you on because of an account restriction
Структура users.usr
1С + Терминал 2003
1c: Терминал сервер или файл сервер
Как отключить отображение окна загрузки 1С?
Подскажите, как поставить пароль на конфигуратор?
Очистка баз
Ошибка сохранения базы
Нарушена структура таблицы данных - как спасти базу???? Хелп!
Непонятная ошибка при отборе операций по значению добавленного реквизита
Загрузка БД 1С+SQL
Терминал
Не могу запусить 1С 8 из командной строки
Как перевести базу из сетевой в SQL 2000?
Скрипт автоматичекого входа в 1С
Вопрос по перемещению списка баз
Ошибка открытия базы данных
Вопрос по автоматизации в 1С (если такое возможно)
Порядок сортировки базы данных отличается.
Почему после измений в конфигураторе исчезли все данные
Невосстановимая ошибка базы данных!!! Please HELP!!!!!!
Использование встроенного архиватора
Терминал расскажите чайнику
Помогите дилетанту
Неисправимая ошибка
Ошибка при анализе изменений структуры данных
Кнопка Восстановить недоступна
Помогите нужна программа автосохранения 1С
запуск конфигуратора в пакетном режиме из VB
VB-cкрипты, обработки для 1С
Ошибка: abnormal program termination
Выгрузка из DBF в SQL
Как создать DD-файл?
Проблема с сервором терминалов.
Как дистанционно кикнуть юзера ?
проблема с открытием базы. Need help!!!
Переиндексация при запуске...
ошибка при загруке данных из DBF в SQL в конфигураторе 1С
Трабла с запуском 1С :-(
Вываливается периодически 1С с ошибками о невозможности записать файлы???
Ошибка загрузки данных
Как исправить ошибку -210?
Удаленное управление 1с
Вывод на печать
Сетевая 1С БАГ
Не работают кнопки на стандартных панелях!
Ошибка блокировки данных, а в базе нет никого...
"!!!Неустранимая ошибка" при тестировании и исправлении ИБ
По совместной работе в WIN2000-98
Перезагружается компьютер при работе в 1С
Как перевести базу из dbf в sql со всеми справониками и документами?
Как исправить БД?
Спецы по 1С (SQL) отзовитесь!
И опять SQL.... (II)
откуда md в 123 метра???
Как выйти из ...
Автоматическая архивация 1С
Ошибка при загрузке модуля config.dll ???
Проблема с сохранением конфигурации
Ламерская проблема с запуском 1С
Глюки в 1С
Изменение кодовой страницы таблий информационной базы
Как оживить базу
автоматическое создание резервной копии
Выдается соб - База данных не может быть открыта в однопользовательском реж
Возможно ли запретить запуск конфигуратора определенным пользователям
v7.7 Как програмно можно определить активных пользователей (база dbf)?
Как получить список паролей пользоватей и файла users.usr?
Пакетный режим
Как распечатать журнал регистрации?
Вылетает 1С при вводе нового документа
1С + SQL не подключается
При загрузке дает ошибку доступа к таблице DH(номер)
1С под Линукс. Не пинайте
Ожидание блокровки журнала
Помогите! Как ограничить доступ к элементам справочника?
Архивация базы
Подавление вопроса "Вы действительно хотите закончить работу с программой"
Ошибка SQL State: 23000 Native: 1505 - мое решение проблемы
Можно ли в терминале установить больше, чем 256 цветов?
v8: Не ведется журнал регистрации в V8 (он пустой) - в чем может быть причина?
v8: Чем ремонтировать файл БД?
v8: v8 Вылетает при обновлении

Установка

Установка 1С
Ошибка открытия словаря базы данных?!??!
1C по сети
Требуется помощь: НеМогуУстановить1С:Булгалтерию 6.0 на WindowsXP
Конфигурация
Подключение SQL-базы
Переинстоляция сервера?
Настройки 1с+Терминал2000
Установка 1С
Пожалуйста помогите создать чистую базу.
Ошибка при регистрации COM-объекта при установке (вер. 8.0.6.3)
Немогу установить сервер 1С:Предприятия 8,0

Ключи защиты

Вопрос для собаку съевшего на хаспах, БорисаГ
Установка HASP-ключей
Ключ для 1С:Предприятие 7.7.17
Проблемма нахождения HASP в VPN
Проблема со службой ключа 1С
Ключ защиты
NHSRV.ini - что это за файл такой
1С + WIN 2003
Менеджер лицензий
2003 сервер и HASP
Ключ+Принтер Не печатает
Можно ли ограничить доступ к ключу HASP
Работа в сети
Server Hasp не видит драйвер после рестарта
1C+SQL Не обнаружен ключ защиты программы!!!
ЮСБи ключи в чем отличие от ключей ЛПТэ?
W2003Server Не устанавливается драйвер для Hasp (lpt)
Номер на Hasp
Ключ защиты
HASP HASP

Безопасность

Помогите с ограничением прав доступа
Как быстро прописать права пользователей?
Защита баз в одноранговой сети - 2
Как сделать так, чтобы пользователь(менеджер) видел только своих клиентов?
Есть компонента для скрытия системных меню?
Конфигурирование пользователей в Торговле (проблема)
ПравоДоступа("Название права")
Защита данных в 1С
Механизм Row Level Security - проблемы...
Защита информации в 1С
Контроль безалаберности пользователей
Разграничение доступа на группы номенклатуры
Разграничение прав на группу элементов списка справочника?
Вопрос: Проблема безопасности в терминальном режиме
Пароли пользователей в 7.7 - фикция?

Производительность, масштабируемость

Есть ли ограничения на число клиентов в XP Professional?
Стала тормозить SQL база на 1-м компьютере в сети
НайтиСсылки() - как увеличить скорость выполнения этой функции
Тормоза при прокрутке справочника ОС
Истекло время ожидания в SQL версии
Закрытие месяца
HELP 1C SQL 2000 Бух учет тормозит
Настройка сервера под 1С Предприятие
Производительность БД & скорость работы отчётов
250 000 наименований товара - это смерть для 1С (дбф)
Кто блокирует журнал документов в 7.7?

Особенности версий SQL/DBF, релизов, ОС

Где почитать про глюки 19 релиза
Релиз 023 программных файлов 1С
SQL и DBF версиии 7.7 Разные результаты выполнения запроса
базовая зарплата и конфигуратор
В чем отличие типовой и базовой конф?

Железо, сети

сетевая проблема
Canon LBP-1000 печатает вопросы
Кто нибудь помогите настроить сервер???????
to BorisG... Вопросик по 2003 серванту ....
1С, сети.

Общие вопросы

Остальное

1C+Linux
Что лучше Акцент или 1С
Продажа 1С -Предприятия
Увязать 1С и ОЛАП
FAQ и полезности по 1С
Удалить помеченные объекты
общмй вопросы по 1С
Ошибка загрузки метаданных
Предлагаю собрать ссылки на 1С-сайты
Информационные технологии в торговле 2004 (Обзор CNews.ru)
Что выбрать: v77 или v8
Исчезли все кнопки
1C 8.0 перейти не перейти?
Тупые бухгалтеры
1С в пингвине
Инструменты для локализации МД-шника
Построитель графов DOT - анализ структуры любой конфигурации 7.7 и 8.0
Как прервать поиск по конфигурации в v8.0
Испоьлзование клавиатуры в 1С
ЖР юзеров
Журнал регистрации: как получить объект?
Что это "Общая файловая ошибка при доступе к C:\...\ Main metadata Strea
1С это язык скриптов или все же программирования?

Архитектура 1С:Предприятия

Индекс размером > 2G
*.DBF и *.CDX ?!
Как в SQL ouery посмотреть связь таблиц?
Максимальное значение ID
Состав ИБ
Вопрос по DBF-ам помогите если это возможно
Какие средства используете для проектирования конфигураций 1С?
Сетевая версия 1С 7.7 ?
общие вопросы 1С: компоненты...
метод СохранитьЗначение() куда сохраняет?
Диаграмма процессов
Проблема с базами... ругаются на оперативный учет
Что будет? Если 2-е конфигурации на одну базу.
Новая статья на сайте www.perlscript.ru
Как добавит в меню операции пункт: "Управление оперативными итогами"???
DBF и CDX отдельно
1С - список ИБ
В каком файле находится список активных пользователей 1С?
Trial конфигурация 1с
Где храниться информация о зарегистривонных (подключенных) базах
v8: Вытаскиваем содержимое синтакс-помощника 8.0 (типа будни)

Политические вопросы

Отключить пользователя 1С с другого ПК
Почему в 8.0 нет ООП?
ОБЭП подкрался незаметно...
Опять про лит-ру в эл. виде
О лицензировании УСН
OFF: Может один сертифициорованный программист 1С работать в двух фра?
1c ЖКК
Условия обмена v7.7 на v8.0 ?
v8: Есть ли какой серийник у конфиги?

Обучение, сертификация

2 Волшебник - Сертификационные вопросы по 8.0
Задание на 1С:Специалисть 8.0
Сертификация 1с:профессионал
Бухгалтерия для комьютерщика
Задача2 сертификация 1с77
1С: Специалист (платформа v8) - Задача по расчету з/п
Литература для первых шагов в 1С
Подготовка к экзамену на 1С:Специалист по 8.0
С чего начинать изучение 1С
Нужна конфигурашка 1с
Книги по 1С с примерами
Подскажите книжку по 1С
А вот скажите, считается ли неэффективным...
Вопрос о заключении Договора Франчайзинга (Украина)
сертификационные задания
люди добрые поможите 1с професионал сдать

Законодательство

Компенсация за неиспользованный отпуск
Где поискать статьи по учету НДС в 1С?
ЗиК Досрочный выход из отпуска по уходу за ребенком
себестоимость = ?
Способы расчета заработной платы
Многосменные графики
ЗиК. Чем отличается отпуск без сохранения краткосрочный и долгосрочный?
Ключ защиты 1С с точки зрения бухучета
Как взять на приход животных?
Как принять в квычету НДС при расходах будущих периодов?
Учетная политика

Обновления, ИТС

Смещение элементов диалога при обновлении конфигурации
Странная продажа коробок 1С (часть2, серьёзная)
Обновление сильно правленной конфигурации. Help!
где располагается справочник валют на ИТС?
Обновление настроенной конфигурации на след. релиз в v8
Как лучше обновить?
Релиз Предприятия
Где брать актуальный справочник БИК?
управление торговлей 8.0
Открыти базы после обновления 1с
"Error#:-210", Help!!!

Конкуренты

1C стоит того чтобы начать изучать? Чем она лучше Фокса?
Слышали ли вы про комплекс "Бухта"?
Может ли 1С Предприятие 8.0 соперничать с Axapta?
© Волшебник Станислав,
www.mista.ru, 1997-2003
1C:TOP-100
Наверх ^


Как програмно перенести существующий элемент справочника в другую группу? | База знаний | mista.ru

Как програмно перенести существующий элемент справочника в другую группу?

koshechka
20.08.2004 13:08 		Имеется справочник ТМЦ, в нем жуть как много позиций, многие уже не используются. Сворачиваю в ТЗ то, что мне не нужно. Все получается. Потом хочу перенести и оп-ля переносится только одна позиция, или не переносится вааще. Помогите, плиз.
Процедура Перенести()
СПР1=СоздатьОбъект("Справочник.ТМЦ");
СПР1.ИспользоватьДату(Дата1);
СПР1.НайтиПоКоду("999999");
Род=СПР1.ТекущийЭлемент();
ТЗ.ВыбратьСтроки();
С=СоздатьОбъект("Справочник.ТМЦ");
С.ИспользоватьДату(Дата1);
С.ВыбратьЭлементы();
Пока С.ПолучитьЭлемент()=1 Цикл
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку()=1 Цикл
Если С.ТекущийЭлемент()=ТЗ.ТМЦ Тогда
С.УстановитьАтрибут("Родитель",Род);
С.Удалить(0);
КонецЕсли; КонецЦикла;

С.Записать();
КонецЦикла;
КонецПроцедуры
Эмблема форума
4 - 20.08.2004 13:15 		Вы чё? Не сможет она присвоить родителя ч/з УстановитьАтрибут() ...
Michael99
8 - 20.08.2004 13:40 		(0) Чтото наворочено всего
Если для элементов из ТЗ надо присвоить нового родителя
То После того как с родителем определлилась:
СПР=СоздатьОбъект("Справочник.ТМЦ");
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку()>0 Цикл
Если СПР.НайтиЭлемент(ТЗ.ТМЦ)>0 Тогда
СПР.Родитель=Род;
СПР.Записать();
КонецЕсли;
КонецЦикла;
И с удалением не очень понятно.
SnarkHunter
9 - 20.08.2004 13:50 		(8)Это не удаление, а пометка на удаление... Переносит ненужные в определенную группу и помечает на удаление...
Michael99
10 - 20.08.2004 13:54 		(9) Это я понял , а смысл переноса в группу ?
чтоб помучались :-) Тогда после СПР.Записать() - СПР.Удалить(0);

Страница знаний на сайте www.mista.ru
Исходная ветка форума 		Список тем базы знаний

База знаний | Волшебный форум | Mista.ru
© Станислав Митичкин, 2003-2004


История курсов валют | База знаний | mista.ru

История курсов валют

koshechka 05.08.2004 09:59 | Господа, куда за ночь может исчезнуть история курсов валют ВСЯ????????? Плииииз ответьте, как можно скорее, потому что тут уже критическая ситуация назрела
aka graham 3 - 05.08.2004 10:21 | Что быол в эту ночь? Изменения в конфигурации деле кто-нибудь? Обработки запускались? Журнал регистрации посмотри. З.Ы. Резервное копирование никто ещё не отменял?
koshechka 4 - 05.08.2004 10:28 | более того, пропала история по ОДНОЙ валюте
NS 6 - 05.08.2004 10:32 | (5) Историю курса валюты? Скачать.
Manfred 19 - 05.08.2004 10:57 | (18) В качестве сиюминутного роешения: из резервной копии в отдельную базу и обработкой перенести в основную... наверное
aka graham 20 - 05.08.2004 11:12 | Manfred прав. Чтобы сильно не заморачиваться сформируй в копии таблицу значений с колонками "дата" и "курс" и сохраняй ее в файл. Потом в рабочей сделай восстановление из файла и запиши курсы в справочник валют. Тебе же только по одной валюте требуется сделать перенос?


Куда деваются описания периодических полей справочника(файл *.dd) | База знаний | mista.ru

Куда деваются описания периодических полей справочника(файл *.dd)

Iraida 04.08.2004 16:30 | В 1Cv7.dd при описании полей баз данных почему то нет периодических полей. Где их можно найти?
@LoNg 1 - 04.08.2004 16:39 | "Значения полей, имеющих этот признак (признак "периодический" - @L), хранятся в файле 1SCONST.DBF, который связан с таблицами SCxxx отношением 1:M со стороны M." (c) А. Малкин, "Доступ к данным V7 из других систем. Логическая структура файлов V7."


Системные справочники в 1С:Зарплата и Кадры | База знаний | mista.ru

Системные справочники в 1С:Зарплата и Кадры

Натали 22.07.2004 07:52 | Пожалуйста, помогите войти в системные справочники в 1С:ЗиК, такие как города и улицы. Мне надо внести туда изменения, а программа не пускает. заранее большое спасибо!
BorisG 4 - 22.07.2004 08:42 | (0) Просто нужно загрузить новый классификатор, и все. Ссылка ниже. (2) Да... "подсунула" вообще классификатор из нашей налоговой" Может для тебя и будет открытием, но адресный классификатор МНС и поддерживает ;-)), точнее ее вычислительный центр - ГНИВЦ МНС России. Кстати, с 01 июля 2004 года классификатор новый... http://www.gnivc.ru/techno/56.htm
Ninon 5 - 22.07.2004 08:57 | (4)Я только знаю, что у нас все ТРИ классификатора РАЗНЫЕ (ЗиК, ИМНС и ПФР). Вот и "подсовывала" тот, что ближе для сдачи в ПФР и ИМНС. Я ж написала не для действия, а для примера - если ОЧЕНЬ надо - то его МОЖНО изменить. А что и как делать (0) выбирать. ЗЫ:представляете у нас у 200 человек улица Верхняя Дуброва, а для ПФР нужно Дуброва Верхняя (это только один пример).Мне быстрее классификатор поменять, чем в 5 базах править текстовый файл для ПФР на все эти "загибоны" - бухш бесполезно учить пользоваться ЗАМЕНОЙ в текстовом файле - всё равно ко мне прибегут столько раз - сколько будут пытаться сдать файлы в ПФР и ИМНС..:-))
BorisG 6 - 22.07.2004 10:37 | (5) "Я только знаю, что у нас все ТРИ классификатора РАЗНЫЕ" Еще раз, так НЕ ДОЛЖНО БЫТЬ. В ЗиК просто нужно загрузить новый классификатор, откуда взять - см. выше. А в ИМНС и ПФР решается простым звоком, если Вы уверены, что у Вас последний. Для ИМНС ГНИВЦ - это головной ВЦ, так что проблем нет, а для ПФР ссылка на КЛАДР от ГНИВЦ есть в 122п, так что тоже обязательно для исполнения. Такое бывает, когда КЛАДР меняется, а на местах еще не обновили.
Ninon 7 - 22.07.2004 10:53 | (6)Извини за назойливость: я ведь не сразу предприняла такие шаги, а когда все расчетчики "заворачивались" обратно из ИМНС и ПФР с ошибками в адресах и начали на меня орать (в фикси виноват во всем программист). Я сравнила классификаторы и пришлось извратиться. (видимо у нас в области эти организации правят их "под себя". Никому не навязываю свое решение. Просто иногда это быстрее (всем ведь всегда надо "ещё вчера"...;-))
BorisG 8 - 22.07.2004 11:36 | (7) Еще раз, НЕ ПРАВЯТ их под себя. Просто не успевают обновить классификаторы, или не следят за обновлениями. ПФР гораздо чаше, чем МНС. И все.


Можно ли осуществить программно поиск в справочнике по фрагменту... | База знаний | mista.ru

Можно ли осуществить программно поиск в справочнике по фрагменту...

Aiuan
25.07.2004 19:18 		т.е. в справочнике ищутся все позиции в которые входит данный фрагмент, а потом все найденые позиции выводятся для выбора...
Матрейя
7 - 25.07.2004 20:51 		Соединение = СоздатьОбъект("ADODB.Connection");
ConnectionString = "driver={SQL Server};server="+"ACER-W6ARR1O5HS"+";uid="+"sa"+";pwd="+""+";Database="+"souztem";
Соединение.ConnectionTimeOut =20;
Соединение.CursorLocation = 1;
Соединение.Mode=1;
Соединение.Open(ConnectionString);
Cmd = СоздатьОбъект("ADODB.Command");
Cmd.ActiveConnection = Соединение;
Rs = CreateObject("ADODB.RecordSet");
ТекстЗапроса="Select descr, code from sc133 where ((descr LIKE '%"+Стр+"%') and (isfolder=2))";
Cmd.CommandText=ТекстЗапроса;
Rs = Cmd.Execute; //Выполнение и получение набора данных

Сч=0;
Пока Rs.EOF() = 0 do
Value1 = Rs.Fields("descr").Value;
Value2 = Rs.Fields("Code").Value;
Rs.MoveNext();
Сч=Сч+1;
Тз.НоваяСтрока();
Спр.НайтиПоКоду(Value2,0);
Тз.Наименование=Спр.ТекущийЭлемент();
Состояние("Обработка: "+Сч);
КонецЦикла;
Матрейя
8 - 25.07.2004 20:53 		+7. ConnectionString - нужно изменить под себя. Имя таблицы справочника можно узнать, посмотрев файл 1cv7.dd(dds) в блокноте апример.
Валентин
9 - 25.07.2004 20:55 		(7) Группы тоже могут понадобиться. Не стоит их так безоглядно отсекать. Или вообще не будет групп в таблице. Тогда косяк.
То что ты предлагаешь на hippo позиционируется обработкой ё-SQL. Просто и со вкусом.
Кстати, что сказал что Aiuan под SQL имеет базу?
Матрейя
10 - 25.07.2004 20:59 		9. Не обязательно иметь SQL базу. (я написал, что "ConnectionString - нужно изменить под себя"). Был просто дан пример, у меня допустим формирование ТекстаЗапроса происходит по условиям (то есть составным образом).
Warlock
11 - 25.07.2004 20:59 		Вот пример, реализованный на встроенном языке 1С:

СЗНайденныеЭлементы = СоздатьОбъект("СписокЗначений");
Спр = СоздатьОбъект("Справочник.НужныйСправочник");
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()=1 Цикл
Если Спр.ПометкаУдаления() = 1 Тогда
Продолжить;
КонецЕсли;
Если Найти(ВРег(Спр.Наименование),ВРег(СокрЛП(ИскомоеЗначение))) <> 0 Тогда
СЗНайденныеЭлементы.ДобавитьЗначение(Спр.ТекущийЭлемент());
КонецЕсли;
КонецЦикла;

В СЗНайденныеЭлементы - список найденных элементов. Можно и в ТаблицуЗначений - по вкусу...


Периодический сохраняет значения с точностью до дня? | База знаний | mista.ru

Периодический сохраняет значения с точностью до дня?

Crystalizer 21.07.2004 14:06 | т.е. сколько бы за день ни изменялся аттрибут история этих изменений не будет сохраняться?
Волшебник 1 - 21.07.2004 14:09 | Если изменяется документами с привязкой к документу, то на один день может быть несколько значений.
Валентин 3 - 21.07.2004 14:11 | При условиях в (1) с точностью до документа только получать значение надо на документ
GrayT 6 - 21.07.2004 14:46 | пер=создатьобъект("Периодический"); пер.ИспользоватьОбъект("Проба",спр); док = СоздатьОбъект("Документ.Проба"); док.ВыбратьДокументы(); Пока Док.ПолучитьДокумент()=1 Цикл пер.ВыбратьПоДокументу(Док.ТекущийДокумент()); пока пер.ПолучитьЗначение()=1 цикл сообщить(""+Док+" Значение: "+пер.Значение); КонецЦикла; КонецЦикла; --------------------- Проба 1 Значение: Стр1 Проба 2 Значение: Стр2 Проба 3 Значение: Стр3 (документы одной датой)


получить даты периодических реквизитов | База знаний | mista.ru

получить даты периодических реквизитов

Crystalizer
21.07.2004 11:20 		как-то кажется делал - получение значения периодического реквизита справочника с соответствующей датой изменения. т.е. последовательный выбор всех значений с датой их установки.
сейчас не могу вспомнить - как это делал вообще? не могу найти соответствующих методов...

подскажите, пжлст, как это делается?
NS
1 - 21.07.2004 11:26 		пер=создатьобъект("Периодический");
спр=создатьобъект("Справочник.Номенклатура");
спр.Найтипонаименованию("Картофель");
пер.ИспользоватьОбъект("Цена",спр.ТекущийЭлемент());
пер.выбратьзначения();
пока пер.получитьЗначение()=1 цикл
сообщить(""+пер.ДатаЗнач+" Значение: "+пер.Значение);
КонецЦикла;


Выбор из справочника | База знаний | mista.ru

Выбор из справочника

BudyLamer 08.07.2004 13:26 | Простите ламера, но есть форма документа и на нем реквизит типа справочник.товар как сделать чтобы при открытии формы сразу вываливался справочник товара (как бы нажали кнопку с точками у реквизита. я пока сделал создатьобъект - выбрать, но при этом пропадает возможность посмотреть элемент справочника или отредактировать. всем написавшим дельное заранее спасибо
Warlock 1 - 08.07.2004 13:39 | Процедура ПриОткрытии() Активизировать("Товар",1); КонецПроцедуры А смысл? Может достаточно настроить правильный порядок обхода?
3V 2 - 08.07.2004 13:42 | Активизировать(<?>,); Activate(<?>,); Синтаксис: Активизировать(<ИмяРеквизита>,<Режим>) Назначение: Высветить для редактирования поле диалога. Параметры: <ИмяРеквизита> - строка с именем поля диалога, которое нужно активизировать; <Режим> - число: 1 - войти в режим редактирования, 0 - не входить (необязателен, по умолчанию - 1, имеет смысл только для строк списков). Замечание: Доступ к методу возможен только в контексте Модуля формы.
BudyLamer 4 - 08.07.2004 14:15 | дык .... фокус он получает (я так делал), но вот надо еще F4 жать а хоца без этого телодвижения
SnarkHunter 7 - 08.07.2004 14:45 | Значит так... 1.На форму кладешь поле ввода агрегатного объекта, делаешь его невидимым, выставляешь галку "Пропускать при вводе", делаешь его ПЕРВЫМ в порядке обхода. 2. Свой реквизит делаешь ВТОРЫМ в порядке обхода, ставишь галку "Авто. выбор" 3. Наслаждаешься
3V 9 - 14.07.2004 14:24 | (+2) Режим = 1
Warlock 10 - 14.07.2004 22:28 | (9)При Режим = 1 произойдет выбор только в случае, если ПустоеЗначение(Реквизит) = 1. Проверил.


Чем можно заменить функцию Активизация()? | База знаний | mista.ru

Чем можно заменить функцию Активизация()?

OlegKZ 25.06.2004 22:26 | У меня в справочнике на реквизите в дополнитеьно-формула стоит: WH.SendKeys("{DOWN}"); Активизация(Форма.ТекущаяКолонка(),1); err: в формуле не может быть выполнена функция(процедура). Как сделать, чтобы работало?
OlegKZ 2 - 25.06.2004 22:52 | Надо чтобы при нажатии Энтер курсор переходил на следующий элемент и активизировал его в текущем столбце.
Матрейя 3 - 25.06.2004 23:04 | WH.SendKeys("{DOWN}{LEFT}{Down}");
OlegKZ 5 - 25.06.2004 23:12 | Прмер: Код : Наименование : Реквизит 001 : элемент1 : 0.00 - активизирован Реквизит 002 : элемент2 : 003 : элемент3 : Ввожу 5 Если я напишу WH.SendKeys("{DOWN}{LEFT}{Down}"); то у меня получиться Код : Наименование : Реквизит 001 : элемент1 : 5 002 : элемент2 : 0.00 - активизирован Реквизит 003 : элемент3 :
OlegKZ 6 - 25.06.2004 23:13 | Дома нет 1С поэтому не могу попробовать. Только завтра на работе.
Матрейя 8 - 25.06.2004 23:24 | 7. WSH - Windows Script Host. С помощью него можно эмулировать нажатия клавиш, создавать и запускать файлы, получать информацию о системе и т.д.
OlegKZ 9 - 25.06.2004 23:31 | http://www.networkdoc.ru/files/insop/whs/read.html?whs-yp.html


При выборе значения из справочника заходить сразу в опред. группу | База знаний | mista.ru

При выборе значения из справочника заходить сразу в опред. группу

SiMazx
25.06.2004 15:01 		Документ. Шапка. Реквизит. Типа. Справочник.
При открытии нужно сразу проваливаться в нужную группу.
Туплю.
Напомните. Как.
Спасибо.
Tyпoй Mля
1 - 25.06.2004 15:04 		использовать родителя при начале выбора значения?
SiMazx
2 - 25.06.2004 15:16 		Все равно туплю... Так?
В модуле формы документа:
Процедура ПриНачалеВыбораЗначения(Парам)
Если Парам = "Водитель" Тогда
Груз = СоздатьОбъект("Справочник.Персонал");
Груз.НайтиПоНаименованию("Водители");
????? ИспользоватьРодителя(Груз.ТекущийЭлемент());
КонецЕсли;
КонецПроцедуры
SiMazx
3 - 25.06.2004 15:25 		В качестве апа расскажу подробнее...
Есть справочник "Персонал" с папками "Грузчики" и "Водители".
При открытии из одного документа форма списка справочника должна открываться в папке "Грузчики", из другого документа - в папке "Водители".
В одном документе делал через подбор, там передача параметра в форму подбора и Фрм.ИспользоватьРодителя(МойРодитель) проблему решают...
Во втором документе мне подбором нафих не нуно...Там банальный реквизит типа Справочник.Персонал...
SiMazx
4 - 25.06.2004 15:28 		Снарк... Ну хоть ты не издевайся... Лана остальные не знают... Подскажи и я тихо-мирно свалю... Не буду позорицца... Туплю и все тут...
It is me
5 - 25.06.2004 15:29 		Попробуй передавать родителя в форму списка и там ИспользоватьРодителя в процедуре ПриОткрытии...
lexa
8 - 25.06.2004 15:34 		Процедура ПриНачалеВыбораЗначения(Парам)
Если Парам = "Водитель" Тогда
Груз = СоздатьОбъект("Справочник.Персонал");
Груз.НайтиПоНаименованию("Водители");
Водитель.ИспользоватьРодителя(Груз.ТекущийЭлемент());
КонецЕсли;
КонецПроцедуры
Груз.ИспользоватьРодителя(Груз.ТекущийЭлемент());
SiMazx
9 - 25.06.2004 15:34 		Мне вопчем-то не облизательно в форму передавать родителя... Родителя я при открытии справочника могу найти.. Мне надо передать в форму списка справочника весточку о том, что это вызов из документа такого-то типа...
lexa
10 - 25.06.2004 15:34 		Процедура ПриНачалеВыбораЗначения(Парам)
Если Парам = "Водитель" Тогда
Груз = СоздатьОбъект("Справочник.Персонал");
Груз.НайтиПоНаименованию("Водители");
Водитель.ИспользоватьРодителя(Груз.ТекущийЭлемент());
КонецЕсли;
КонецПроцедуры
Tyпoй Mля
11 - 25.06.2004 15:35 		Короче... Страшилы Мудрые...

Процедура ПриНачалеВыбораЗначения(Парам)
Если Парам = "Водитель" Тогда
Груз = СоздатьОбъект("Справочник.Персонал");
Груз.НайтиПоНаименованию("Водители");
ИДТВОЕГОРЕВИЗИТА.ИспользоватьРодителя(Груз);
КонецЕсли;
КонецПроцедуры


ИспользоватьВладельца() ? | База знаний | mista.ru

ИспользоватьВладельца() ?

Zov1 25.06.2004 13:20 | Почему в одном месте ИспользоватьВладельца() работает, а в другом нет. Оба справочника подчинены Контрагентам. В первом случае отображаются подчиненные элементы, а во втором весь справочник. ИначеЕсли Значение = "Доставка" Тогда ОсновнойПунктРазгрузки.ИспользоватьВладельца(ТекущийЭлемент()); ОбновитьСписокДоставки(); Форма.ИспользоватьСлой("Доставка, Имена, Кнопки ",2); ИначеЕсли Значение="Сотрудники" Тогда Руководитель.ИспользоватьВладельца(ТекущийЭлемент()); Форма.ИспользоватьСлой("Сотрудники, Имена, Кнопки", 2 );
Crystalizer 1 - 25.06.2004 13:25 | а можно так гнать - "ТекущийЭлемент()" ? может надо всё же указать какой именно элемент?
ZOV1 2 - 25.06.2004 13:31 | Когда смотришь ТекущийЭлемент() - он тот, что надо. Выбранный до того. Два слоя совершенно одинаковые по механизму работы.
Crystalizer 4 - 25.06.2004 13:39 | ZOV1: ну а ты уверен что есть приписанные к владельцу во втором случае?
ZOV1 5 - 25.06.2004 13:45 | Ну, может я и не понимаю ... В первом случае если нет элементов приписанных, то открывается ФормаСписка - пустая. А во втором случае - открывается весь справочник не зависимо от того есть зависимые (приписанные) элементы или нет.
ZOV1 7 - 25.06.2004 14:27 | ИерархическийСписок(1,1);


как распечатать справочник? | База знаний | mista.ru

как распечатать справочник?

Aiuan 24.06.2004 13:12 | как распечатать справочник?
Волшебник 2 - 24.06.2004 13:17 | В версии 8.0 щелкни правой кнопкой на списке и выбери "Вывести список". В версии 7.7 воспользуйся универсальным отчетом "Печать справочника", поставляемого на ИТС.
Valery 3 - 24.06.2004 13:19 | В какой-то фигурации я видел такую штуку, помоему в ТиС. А вообще процедуру печати справочника можно посмотреть в ЖКК. Работа с запросами. Можно взять за основу.
Gavrila 4 - 24.06.2004 13:24 | +(2) для 7.7 - refprint.ert помойму так называется


Переход по элементам??? | База знаний | mista.ru

Переход по элементам???

OlegKZ 21.06.2004 22:17 | В многострочной части справочника нужен переход по элементам одним нажатием Энтер по одному реквизиту, при этом происходит запись предыдущего, если были изменения, и активизация следующего. Как это сделать??? Помогите пожалуйста :(
Warlock 1 - 21.06.2004 22:20 | Мой знакомый реализовал что-то подобное (вроде навигатора по справочнику с функциями: следующий, предыдущий, в начало, в конец, новый, записать), но в виде обработки. Может и тебе так стоит?
OlegKZ 2 - 21.06.2004 22:25 | Если не жалко, подскажи что примерно в этих функциях? Как мне найти текущий, чтобы перейти именно на СЛЕДУЮЩИЙ??
romix 3 - 22.06.2004 00:51 | Я бы не сказал, что это грамотный режим, который непременно надо реализовывать. Наверняка, заказчик привык к чему-то дельфийскому, и вынь ему да положь. Можно попробовать через ТаблицуЗначений (там есть понятие "верха" и "низа"), через Таблицу в режиме ввода данных или через Excel. А по-хорошему так делать нельзя: если хотят выставить один и тот же реквизит у 50 (или 250) элементов, почему бы не сделать это через документы и регистры? Получится и грамотнее, и безошибочнее. А делать все в большом красивом и удобном справочнике с 150 колонками - это добро пожаловать в Дельфи... Первая нормальная форма Кодда (база данных при этом находится в противозачаточном состоянии).
NS 4 - 22.06.2004 00:54 | Это издевательство? На первой странице ветка, где я ответил на этот вопрос.. Всё легко делается через SendKeys()
romix 5 - 22.06.2004 01:02 | (4) Нажатие "стрелка вниз" сымитировать через Wscript.Sendkeys? Вообще-то это идея... Только вот что-то сама 1С никогда так не делает...
romix 7 - 22.06.2004 01:14 | (6) Еще можно кнопку "Продолжить", которая дублирует предыдущее значение вниз.
romix 8 - 22.06.2004 01:31 | Я правда так всегда делаю в форме документа (кнопка Продолжить). А в списке - юзер просто 10% ошибок в таком режиме ввода допустит...


А как найти этот следующий?? | База знаний | mista.ru

А как найти этот следующий??

OlegKZ 21.06.2004 22:31 | OlegKZ 21.06.04 - 22:17 В многострочной части справочника нужен переход по элементам одним нажатием Энтер по одному реквизиту, при этом происходит запись предыдущего, если были изменения, и активизация следующего. Как это сделать??? Помогите пожалуйста :( Warlock_WW 1 - 21.06.04 - 22:20 Мой знакомый реализовал что-то подобное (вроде навигатора по справочнику с функциями: следующий, предыдущий, в начало, в конец, новый, записать), но в виде обработки. Может и тебе так стоит? OlegKZ 2 - 21.06.04 - 22:25 Если не жалко, подскажи что примерно в этих функциях? Как мне найти текущий, чтобы перейти именно на СЛЕДУЮЩИЙ??
Warlock 1 - 21.06.2004 22:37 | А ты в курсе, что можно было ту ветку продолжать? Моя идея - это открывать выборку каждый раз с методом ОбратныйПорядок(0 или 1). Но это хорошо сработает для небольшого справочника, у тебя, я думаю, как раз наооборот. Но я спрошу у друга, как он это сделал...
427 4 - 21.06.2004 23:20 | ТекущийЭлемент....
NS 6 - 22.06.2004 00:19 | SendKeys.... wScript...


справочники стандартный отбор версия 8.0 | База знаний | mista.ru

справочники стандартный отбор версия 8.0

rostov/don 21.06.2004 14:35 | Доброго всем времени!) при работе с справочником можно ли полученные стандартные отборы как то использовать например напечатать? ну очень начинающий в 1с)
rostov/don 3 - 21.06.2004 14:43 | при просмотре формы списка справочник существуют кнопки - отбор и т.д. после этого выдается записи по выбранным критериям - можно ли этт выбор использовать в дальнейшем - печатать например?
Волшебник 4 - 21.06.2004 14:44 | Щелкни правой кнопкой и выбери "Вывести список".


Почему код элемента справочника всё время одиноковый | База знаний | mista.ru

Почему код элемента справочника всё время одиноковый

Nik-Scorp 21.06.2004 09:31 | В конфигурации ТиС 9.2 При создании нового элемента справочника код всегда один и тотже. В модуле не видно изменения кода.
SnarkHunter 1 - 21.06.2004 09:52 | Вместо великой реки Ориноко пик Ориноко торчит одиноко... Уникальность кода выставлена?
Nik-Scorp 2 - 21.06.2004 09:55 | Да, уникальность кода и авто нумерация выставлена
SnarkHunter 3 - 21.06.2004 10:11 | Телепатирую... Тип кода - текстовый, а длина "одинокового" кода меньше длины кода, установленной в конфигураторе... Угадал?
Nik-Scorp 4 - 21.06.2004 10:49 | Да угадал. Спасибо большое.


Получение данных из справочника | База знаний | mista.ru

Получение данных из справочника

Женя 19.06.2004 16:39 | Есть справочник Договоры Получаю: СписокДоговоров = СоздатьОбъект("Справочник.Договоры"); После этого СписокДоговоров - пустой справочник. Как связать мой объект(переменную) СписокДоговоров с реальным справочником?
Asmody 1 - 19.06.2004 16:54 | читать сюда http://www.mista.ru/tutor_1c/sprav.htm
Орк 2 - 19.06.2004 19:18 | СписокДоговоров не пустой справочник, а ссылка на спровочник вообще (или справочник "в себе") как кому нравиться. После всего нужно : ВыбратьЭлементы(); ПолучитьЭлемент()...


Запретить удаление и добавление объектов в справочник | База знаний | mista.ru

Запретить удаление и добавление объектов в справочник

Руслан 15.06.2004 16:58 | Имеется справочник. Имеется модуль формы к нему. Просмотр содержимого осущ. через список... Так вот вверху на форме есть кнопки добавить и удалить элемент. Необходимо, чтобы при соблюдении некоторых условий, эти кнопки были недоступны... т.е., чтобы нельзя было добавить или удалить элемент справочника.
AlexMan 1 - 15.06.2004 17:16 | Вроде штатными средствами не возможно "потушить" пиктограммы (кроме настройки прав) но можно тем не менее запретить ввод нового и т.д. например: Процедура ВводНового(,) Если <Условие> Тогда СтатусВозврата(0); КонецЕсли; КонецПроцедуры
Vvv1 2 - 15.06.2004 19:32 | То 2. Поскольку просмотр осуществляется ч-з форму списка то нужно пользовать в этой-же форме процедуру ПриВводеСтроки() начинка та же. Чтобы запретить пометку удаления нужно пользовать процедуру глобального модуля ПриУдаленииЭлемента().
AlexMan 3 - 15.06.2004 21:31 | (2) Причем здесь ПриВводеСтроки() ??? а вот ПриУдаленииЭлемента() - это ты верно подметил.
mszsuz 6 - 18.06.2004 16:17 | Форма.ТолькоПросмотр(1);
romix 7 - 18.06.2004 17:00 | Вообще-то хороший способ все запрещать - отлавливать предопределенные процедуры (см. желто-красные книжки). И писать юзеру сообщение типа "Извините, недостаточно прав доступа". А когда просто блокируют доступ (делают "серым"), то это не есть гуд... Поди потом разбери, почему та или иная пимпочка не работает - юзера достанут звонить. Так что я всегда пишу предупреждения, что так мол и так.


УстановитьАтрибут(,) - ошибка, если реквизит периодический :( | База знаний | mista.ru

УстановитьАтрибут(,) - ошибка, если реквизит периодический :(

Gavrila 17.06.2004 18:20 | никогда не делал, а тут пришлось, и вот :( НовСпр.УстановитьАтрибут(ИмяРеквизита, НовЗначение); где НовСпр - новый элемент справочника базы подключенной через OLE ИмяРеквизита - тип строка, название реквизита; НовЗначение - число; на периодическом реквизите вываливается ошибка "Плохой тип переменной" что это за хрень и как с ней бороться, подскажите плз
alxkorvin 1 - 17.06.2004 18:22 | НовСпр.ИспользоватьДату(ТвояДата) перед установить атрибут
Manfred 4 - 17.06.2004 18:49 | Пользуйся объектом "Периодический"
Gavrila 7 - 17.06.2004 19:28 | (6) НовСпр.УстановитьАтрибут(ИмяРеквизита, НовЗначение); просто "НовЗначение" - это значение периодического реквизита справочника текущей базы, добавил Спр.ИспользоватьДату(РабочаяДата()) перед НовЗначение = Спр.ПолучитьАтрибут(ИмяРеквизита); и все работает :)


НайтиПоРеквизиту? | База знаний | mista.ru

НайтиПоРеквизиту?

ivanoff 09.06.2004 04:45 | Хочеться спросить как искать строку в справочнике по значениям нескольких реквизитов (допустим - трех)?
ivanoff 3 - 09.06.2004 05:39 | У меня справочника с примерами нету, вот и интересен синтаксис поиска а реквизиты - ссылки на другие справочники. VladZagorsky: тот ответ меня устроил, сейчас интересен синтаксис :))
SnarkHunter 4 - 09.06.2004 05:44 | (3)Если это ссылки, то можно добавить строковый реквизит (длина 27), в который записывать ID твоих трех реквизитов... Установить отбор по этому реквизиту и, тем самым, ты фактически получаешь твой любимый уникальный составной индекс... Дальше можно пользоваться либо НайтиПоРеквизиту, либо ВыбратьЭлементыПоРеквизиту()...
VladZagorsky 5 - 09.06.2004 05:48 | А здесь смотрел? http://mista.ru/tutor_1c/sprav.htm


сохранить справочник | База знаний | mista.ru

сохранить справочник

Юрий 05.06.2004 23:30 | При создании новой базы хотелосьбы оставить старый справочник как ?
Волшебник 1 - 05.06.2004 23:35 | Варианты: 1. обработка Копирование справочников 2. transfer.ert 3. написать свою обработку и перенести нужные данные через OLE 4. самый простой вариант - скопировать dbf-файл структура должна быть идентичной. Имя dbf-файла см. по файлу dd 5. Удалить все, кроме этого справочника
SnarkHunter 2 - 06.06.2004 08:23 | (1)В варианте (4) кроме файла самого справочника зачастую необходимы и другие файлы... Если есть периодические реквизиты... Или подчиненные справочники...


составной уникальный индекс | База знаний | mista.ru

составной уникальный индекс

ivanoff 08.06.2004 10:24 | Подскажите - имеется ли возможность задать в справочнике уникальный индекс по нескольким полям?
ivanoff 3 - 08.06.2004 10:29 | у меня 1с 8 версии
ivanoff 4 - 08.06.2004 10:35 | Детально: Имеется 3 реквизита (рек1,рек2, рек3) помимо кода и наименования. Нужно чтобы при попытке введения новой записи при дублировании рек1 и рек2 выдавалось предупреждение, и чтобы значения этих реквизитов не были пустыми. как в 1с реализуется данная задача?
SnarkHunter 7 - 08.06.2004 11:23 | Ну если в лоб, то на все три реквизита вешаешь отбор по реквизиту.... При записи делаешь проверки на пустое значение и три поиска по реквизиту...
VladZagorsky 9 - 08.06.2004 11:54 | Выгрузи в DBF-файл и делай с ним все, что захочешь...
GrayT 10 - 08.06.2004 11:54 | (0)А он тебе зачем? Индекс там уже есть созданный автоматом. (см 1)
VladZagorsky 11 - 08.06.2004 11:56 | А если серьезно, то в процедуре ПриЗаписи сделать проверку через запрос. А то, что ты имеешь в виду, в 1С нет. 1С - это не база данных, это... Это нечто большее. :)
¶ 12 - 08.06.2004 12:16 | (8) В 8.0 нет такого средства. Вообще, если быть точным, 1С - не реляционная, а объектная СУБД (что движок реляционный, не имеет значения - для программиста она выступает как объектная СУБД, хотя и не вполне полномасштабная). (8) То, что ты понимаешь под "нормальной БД" - это реляционная БД, отсюда и недоразумения. Думаю, что вообще упоминания об "индексах" и "индексировании" в руководстве по конфигурированию - терминологически неправильно, следовало бы назвать это как-то иначе. Не нужно было дезориентировать пользователя реляционной терминологией.
ivanoff 13 - 08.06.2004 13:07 | 1. Это точно, тут я сплоховал (то что начал не той терминологией без предупреждения пользоваться). Хотя на мой взгляд не удобно такое положение с индексами. 2. По поводу инекса созданного автоматом: НЕ ХВАТАЕТ. У меня в справочнике, как минимум три поля ссылки на другие справочники и при этом сочетание этих значений должны быть уникальными. Или у меня эти замороки, тока от того что я пытаюсь строить реляционную структуру в объектной БД? (и все таки отсутствие составных индексов неприятно меня удивило :( )
¶ 14 - 08.06.2004 13:31 | (13) Да, когда проектируешь объекты МД, лучше забыть о "составных индексах", да и о пяти нормальных формах пореже вспоминать, и вообще не думать, что внутри платформы реляционка. Лучше делать программно все проверки самому. В 8.0 есть много возможностей проверки довольно нужных условий из конкретной предметной области (например, автоматическая проверка баланса по ресурсу бухрегистра), а вот некоторых привычных нам возможностей, увы, нет по определению.


интерактивный множественный выбор (эл.справ.) с группами... | База знаний | mista.ru

интерактивный множественный выбор (эл.справ.) с группами...

Crystalizer
02.06.2004 11:58 		Необходимо по нажатию кнопки вызывать форму выбора элементов справочника с группами. Выбор должен быть множественный. Т.е. чтобы форма не закрывалась после выбора элемента.

есть 2 подхода - ни один не делает всё.

1)
процедура выбрать()
спр=создатьобъект("справочник.контрагенты");
спр.ВыборГруппы(1);
спр.выбрать("выберите клиентов исключаемых из рассмотрения",);
если спис.Принадлежит(спр.текущийэлемент())=0 тогда
спис.добавитьзначение(спр.текущийЭлемент());
конецесли;
конецпроцедуры

недостаток: выбирает по одному

2)
Процедура обработкаподбора(выбор)
тмц_спис.ДобавитьЗначение(выбор);
КонецПроцедуры

Процедура Добавить_ТМЦ_Список()
ОткрытьПодбор("Справочник.ТМЦ", "Выбор ТМЦ для отчета", Контекст, 1);
КонецПроцедуры

недостаток: не выбирает группы

--------

Как сделать чтобы выполнялись все условия?
и подобор групп и множественный выбор...
GrayT
1 - 02.06.2004 12:08 		А что, указать ВыборГруппы при открытии "Выбор ТМЦ для отчета" нельзя?
Crystalizer
2 - 02.06.2004 12:11 		это приписывается к справочнику
в том случае справочник не используется
lexa
3 - 02.06.2004 12:13 		смотри модуль формы для подбора справочника ТМЦ - там наверняка есть что то типа
Если ТекЭлем.ЭтоГруппа() = 1 Тогда
Предупреждение("Группы подбирать нельзя!",60);
Возврат 0;
КонецЕсли;
SnarkHunter
4 - 02.06.2004 12:13 		Процедура Добавить_ТМЦ_Список()
ОткрытьПодбор("Справочник.ТМЦ", "Выбор ТМЦ для отчета", Контекст, 1);
Конекст.ВыборГруппы(1); <== Так не пробовал?
КонецПроцедуры
SnarkHunter
5 - 02.06.2004 12:14 		(+4)Описка: "Конекст" читать "Контекст"
Crystalizer
6 - 02.06.2004 12:18 		SnarkHunter: не катит
lexa: хм... он просто "входит" а не "выбирает"
GrayT
7 - 02.06.2004 12:20 		Вы чего???
В обработке:
//_____________________________________________________________________________
Процедура ПОКнопке()
ОткрытьПодбор("Справочник.Контрагенты", "ФормаСписка",,1);
КонецПроцедуры //ПОКнопке

//_____________________________________________________________________________
Процедура ОбработкаПодбора(Зн)
Сообщить(?(Зн.ЭтоГруппа()=1, "Группа", "Элемент"));
КонецПроцедуры //ОбработкаПодбора

В Форме Контрагентов
Процедура ПриОткрытии()
ВыборГруппы(1);
КонецПроцедуры //ПриОткрытии
Crystalizer
8 - 02.06.2004 12:25 		ГрэйТ:

В Форме Контрагентов
Процедура ПриОткрытии()
ВыборГруппы(1);
КонецПроцедуры //ПриОткрытии

это в форме самого справочника?
мне нужно исправить только отчет.
он должен работать на выбор группы только в этом отчете.


Вопрос по присвоению реквизита. | База знаний | mista.ru

Вопрос по присвоению реквизита.

Игорь 02.06.2004 11:42 | У меня есть документ: "Выписка". В этом документе есть реквизит "видДвижения". Данный реквизит ссылается на Справочник.Движения ДенежныхСредств При импортировании выписки для нее выбирается план счетов, например 62.1. Вопрос: Каким образом можно присвоить реквизиту "Выписка.ВидДвижения" значение конкретного вида. Те. Я в нужном (как мне кажется) месте ставлю : СпрДДС = СоздатьОбъект("Справочник.ДвиженияДенежныхСредств"); СпрДДС.НайтиПоКоду("00002"); Конт.ВидДвижения = СпрДДС.ВидДвижения; Но увы при выполнении процедуры импорта ничего не происходит...:(
VladZagorsky 1 - 02.06.2004 11:44 | ВидДвижения=СпрДДС.ТекущийЭлемент()
lexa 5 - 02.06.2004 11:53 | если импорт осуществляется обработкой, то кинь реквизит диалога - вид движения и выбирай, а при открытии присвой ему нужное тебе значение


Группы справочников... Как узнать узел листа? | База знаний | mista.ru

Группы справочников... Как узнать узел листа?

Crystalizer
01.06.2004 11:35 		Есть справочник.
Элементы разбиты по группам.
Как узнать Узел данного элемента или по-другому к какой группе принадлежит данный элемент справочника?

п.с. "а шо ще дали буде" (С) Л.П.
Crystalizer
20 - 01.06.2004 14:23 		да надо ещё движения
//тут щас с глюком бьюсь
Crystalizer
22 - 01.06.2004 14:41 		427: ок

GrayT или кто знает в чём тут могут быть грабли? почему ТМЦ не выбираются??

товары = списокзначений. заполняется нормально. проверил.

Запрос2 = СоздатьОбъект("Запрос");
ТекстЗапроса2 =
"//{{ЗАПРОС(Сформировать)
|ТМЦ = Справочник.ТМЦ;
|ГруппаТМЦ = Справочник.ТМЦ.ГруппыТоваров;
|Условие (ТМЦ в товары);
|Группировка ГруппаТМЦ;
|Группировка ТМЦ;
|";

Если Запрос2.Выполнить(ТекстЗапроса2) = 0 Тогда
Сообщить("Ошибка во время выполнения запроса 911");
Возврат;
КонецЕсли;

.....

Пока Запрос2.Группировка(1) = 1 Цикл
имя_группы = Запрос2.ГруппаТМЦ;
Таб.ВывестиСекцию("группа_группа|Начало");
Таб.ПрисоединитьСекцию("группа|Итог");
Сообщить(имя_группы);
Пока Запрос2.Группировка(2) = 1 Цикл /// НЕ ЗАХОДИТ СЮДА ВООБЩЕ!!!
Сообщить("-----");
спр_тмц = Запрос2.ЗначениеУпорядочивания(2,1);
сообщить(спр_тмц);
с=0;
Если Таб2.НайтиЗначение( спр_тмц, с, "имя")=0 Тогда
Сообщить(" Ошибка при поиске соответствия ... /2/");
Иначе
Таб2.ПолучитьСтрокуПоНомеру(с);
Кво = Таб2.ТекКолво;
КонецЕсли;
Таб.ВывестиСекцию("группа_тмц|Начало");
Таб.ПрисоединитьСекцию("группа_тмц|Итог");
КонецЦикла;
КонецЦикла;
GrayT
23 - 01.06.2004 14:50 		ТМЦ = Справочник.ТМЦ.ТеекущийЭлемент попробуй
SnarkHunter
25 - 01.06.2004 15:09 		Справочник.ТМЦ.ГруппыТоваров <== Что бы это значило?
Crystalizer
27 - 01.06.2004 15:28 		SnarkHunter: так и есть. не я это делал. там есть ещё дополнительная разновидность товара. В принципе удобно (пользоваться) - 2 вида сортировки;
Crystalizer
29 - 01.06.2004 16:05 		работает
но не всегда корректно получается, т.к. вложенность может предшествовать
прока оставлю так
427
39 - 01.06.2004 17:10 		Ну вот... практически весь лтчет без запроса и таблицы

как будешь заполнять тз с остатками и движениями
как говорится - твои проблемы.... Можешь запросом по БИ в ТиС
или обычным в Бух

спавочник Групп будет так и называть

тзТовар - остатки товара на складах
колонки
----------------------------
Склад
Товар
ДляСортировки - служебная
КоличествоНН - кол-во на начало,
КоличествоНК - кол-во на конец периода,
Приход - приход на склад
Расход - расход со склада
Группа - Группа

тзСклад - документы движения по товару
колонки
---------------------------------------
Товар
Склад
Приход - приход на склад
Расход - расход со склада
Док - док движения

Обе ТЗ элементарно заполняются по обычному запросу или по БухЗапросу

//-------------------------------------------------------
// названия складов - добавим потом в итоговую ТЗ
//-------------------------------------------------------
Скл = CreateObject("ValueTable");
тзТовар.Unload(Скл);
Скл.GroupBy("Склад","КоличествоНН");

//-------------------------------------------------------
// добавим колонки для последующей сортировки
//-------------------------------------------------------
тзТовар.NewColumn( "СС","Строка" ,
Metadata.Reference("Группы").DescriptionLength*
Metadata.Reference("Группы").LevelsLimit +
Metadata.Reference("Материалы").DescriptionLength +
Metadata.Reference("местаХранения").DescriptionLength +
100, , "СС" );

тзТовар.NewColumn( "УровеньЭлемента","Число" , 2 , 0, "УровеньЭлемент" );
тзТовар.NewColumn( "Род","Reference.Группы" , , , "Род" );
тзТовар.NewColumn( "Док","Документ" , , , "Док" );

МахУровень = 0;
//-----------------------------------------
for Индекс = 1 to тзТовар.LinesCnt() do // цикл по ТЗ тзСклад
тзТовар.GetLineByNumber(Индекс);
if тзТовар.Товар.Selected() <> 1 then Continue; endIf;
тзТовар.ДляСортировки = 30;
тзТовар.Группа = тзТовар.Товар.Группа;
тзТовар.УровеньЭлемента = тзТовар.Группа.Level();

if тзТовар.УровеньЭлемента > МахУровень then
МахУровень = тзТовар.УровеньЭлемента;
endIf;

тзТовар.Род = тзТовар.Группа.Parent;
тзТовар.СС = TrimAll(тзТовар.Склад.Description) +" "+
тзТовар.Группа.Parent.FullDescr() +" "+
тзТовар.товар.Description +" "+
ValueToStringInternal(тзТовар.Товар);
endDo;

//-------------------------------------------------------
тзУровней = CreateObject("ValueTable");
тзТовар.Unload(тзУровней);

//-------------------------------------------------------
// добавим движения
//-------------------------------------------------------

for Индекс = 1 to тзСклад.LinesCnt() do
тзСклад.GetLineByNumber(Индекс);
if тзСклад.Товар.Selected() <> 1 then Continue; endIf;
тзТовар.NewLine();

тзТовар.Товар = тзСклад.Товар;
тзТовар.Склад = тзСклад.Склад ;
тзТовар.Приход = тзСклад.Приход;
тзТовар.Расход = тзСклад.Расход;
тзТовар.Группа = тзСклад.Товар.Группа;
тзТовар.УровеньЭлемента = тзСклад.Группа.Level();

тзТовар.Род = тзТовар.Группа.Parent;
тзТовар.Док = тзСклад.Док;
тзТовар.ДляСортировки = 41;
тзТовар.СС = TrimAll(тзТовар.Склад.Description) +" "+
тзТовар.Группа.Parent.FullDescr() +" "+
тзТовар.товар.Description +" "+
ValueToStringInternal(тзТовар.Товар);
endDo;

УказательЦикла = 0;
СчетчикЦикла = 15; // максимально возможное количество уровней в
// справочнике Групп... как говорится, с запасом

if МахУровень > 1 then МахУровень = МахУровень-1; endIf;

while МахУровень > 0 do
тзУровней.GroupBy("Склад,Род","КоличествоНК");
СчетчикЦикла = СчетчикЦикла - 1;
for Индекс = 1 to тзУровней.LinesCnt() do // цикл по ТЗ ПоСкладам.LinesCnt()
тзУровней.GetLineByNumber(Индекс);
if тзУровней.Род.Selected() <> 1 then Continue; endIf;
if тзУровней.Род.Level() <> МахУровень then Continue; endIf;
тзТовар.NewLine();
тзТовар.Склад = тзУровней.Склад;
тзТовар.Род = тзУровней.Род;

тзТовар.СС = TrimAll(тзТовар.Склад.Description)+" "+тзУровней.Род.FullDescr()+" ";
тзТовар.ДляСортировки= СчетчикЦикла;
тзУровней.Род = тзУровней.Род.Parent;
endDo;
МахУровень = МахУровень - 1;
endDo;

//-------------------------------------------------------
// добавим склады - для вывода в таблицу
//-------------------------------------------------------

for Индекс = 1 to Скл.LinesCnt() do // цикл по ТЗ Скл
Скл.GetLineByNumber(Индекс);
тзТовар.NewLine();
тзТовар.Склад = Скл.Склад;
тзТовар.ДляСортировки=1;
тзТовар.СС = TrimAll(тзТовар.Склад.Description)+" ";
endDo;

// сортировка

тзТовар.Sort("Склад,СС,Док",1);

//===========================================================
т = CreateObject("Table");
т.SourceTable("Таблица3");

СЗ = CreateObject("ValueList");
т.PutSection("Шапка"); // в таблице д.б. секция шапка

for Индекс = 1 to тзТовар.LinesCnt() do // цикл по ТЗ тзСклад
тзТовар.GetLineByNumber(Индекс);
if тзТовар.ДляСортировки =1 then
пСклад = тзТовар.Склад;
т.PutSection("Склад");
elsIf тзТовар.ДляСортировки = 30 then
// это строка самого ТМЦ
Товар = тзТовар.Товар;
рТовар = тзТовар.Товар;
ед = тзТовар.Товар.ЕдиницаИзмерения;
пНаНач = КоличествоВОтчет(тзТовар.КоличествоНН);
пПриход = КоличествоВОтчет(тзТовар.Приход);
пРасход = КоличествоВОтчет(тзТовар.Расход);
пНаКон = КоличествоВОтчет(тзТовар.КоличествоНК);

Ур=тзТовар.Товар.Level()-1;
т.PutSection("Товар"+_А+string(Ур));

elsIf тзТовар.ДляСортировки = 41 then
// вывод документа движения
РасД = тзТовар.Док;
пДок = РасД.Kind()+" "+расД.DocNum;
пДата = РасД.DocDate;
СЗ.RemoveAll();
СЗ.Set ("ОткрытьЖурналДокументов", 1);
СЗ.Set ("ДокументЖурнала", РасД);
Расшифровка = СЗ;
пПриход1 = КоличествоВОтчет(тзТовар.Приход);
пРасход1 = КоличествоВОтчет(тзТовар.Расход);
Ур=тзТовар.Товар.Level()-1;
т.PutSection("Док"+string(Ур));
else
// печатаем Level();
пУровень = тзТовар.Род;
Ур=тзТовар.Род.Level();
т.PutSection("Уровень"+string(Ур));
endIf;
endDo; // конец цикла по ТЗ тзСклад
//-----------------------------------------

т.PutSection("Подвал");
т.ReadOnly(1);
т.Options(0,0,4,6 ,"ОстП ", "ОстП" );
т.PageSetup(2 , , , , , , , , , 1 , 1 );
т.Show("Движение товаров за "+PeriodStr(НачДата,КонДата));

секции в таблице ДокХ, ТоварХ, УровеньХ сформированы следующим образов

ИмяСекции1 пУровень
ИмяСекции2 пУровень
ИмяСекции3 пУровень
ИмяСекции4 пУровень
ИмяСекции5 пУровень

чтобы структура отчета по группам была похожа на дерево групп в справочнике групп


Господа, что я делаю не так? (Начинающий) | База знаний | mista.ru

Господа, что я делаю не так? (Начинающий)

serik
31.05.2004 14:28 		Клн.КБе=КБе;
Клн.СвидетельствоПоНДС=СвидетельствоПоНДС;
Клн.КонтактноеЛицо=КонтактноеЛицо;
Клн.ОснованиеПоУмолчанию=ОснованиеПоУмолчанию;
Клн.ОсновнойРасчетныйСчет=ОсновнойРасчетныйСчет;
РасСчет=СоздатьОбъект("Справочник.РасчетныеСчета");
РасСчет.ИспользоватьДату(РабочаяДата());
РасСчет.ИспользоватьВладельца(Клн);
РасСчет.Новый();
РасСчет.ВыбратьЭлементы();
РасСчет.Код = "1";
РасСчет.Наименование ="Основной";
РасСчет.НомерСчета =НомерРасчетногоСчета ;
РасСчет.Записать();

Сообщение об ошибке:
РасСчет.Код = "1";
{Обработка.Загрузка_Контрагентов.Форма.Модуль(117)}: Не выбран элемент!
lexa
1 - 31.05.2004 14:30 		а Клн у тебя записан?
SnarkHunter
2 - 31.05.2004 14:31 		РасСчет.ВыбратьЭлементы(); <-- Убери...
lexa
3 - 31.05.2004 14:34 		РасСчет.Код = "1"; это у тебя для всех один код? Тоже убери код присвоится автоматически
Hd
4 - 31.05.2004 14:35 		РасСчет.ВыбратьЭлементы() - вообще не неужен здесь если элемент только создается, а если исправляется старый элемент то его надо Получить(). RTFM (Read This Fucking Maual) от 1Са
serik
4 - 31.05.2004 14:35 		Если убираю строку РасСчет.ВыбратьЭлементы();
Получаю ошибку
РасСчет.Записать();
{Обработка.Загрузка_Контрагентов.Форма.Модуль(163)}: Не выбран элемент справочника-хозяина! Элемент не может быть записан!
serik
6 - 31.05.2004 14:37 		Клн не записан, т.к. я вроде как наполняю его, и через него справочник расчетных счетов
SnarkHunter
7 - 31.05.2004 14:37 		Ну стало быть проблема с твоим Клн...
SnarkHunter
8 - 31.05.2004 14:38 		Ну так запиши, прежде чем создавать подчиненный элемент...
lexa
9 - 31.05.2004 14:39 		У тебя Клн - владелец РасСчет, а Клн у тебя не выбран. Ты его вначале запиши, а потом используй
427
11 - 31.05.2004 14:40 		Найди одно отличие

Клн.КБе=КБе;
Клн.СвидетельствоПоНДС=СвидетельствоПоНДС;
Клн.КонтактноеЛицо=КонтактноеЛицо;
Клн.ОснованиеПоУмолчанию=ОснованиеПоУмолчанию;
Клн.ОсновнойРасчетныйСчет=ОсновнойРасчетныйСчет;
РасСчет=СоздатьОбъект("Справочник.РасчетныеСчета");
РасСчет.ИспользоватьДату(РабочаяДата());
РасСчет.ИспользоватьВладельца(Клн);
РасСчет.Новый();
РасСчет.Код = "1";
РасСчет.Наименование ="Основной";
РасСчет.НомерСчета =НомерРасчетногоСчета ;
РасСчет.Записать();

При втором переносе/запуске вся это констукция обнется с выдачей сообщения... соответствующего сообщения... Если код определен как уникальный ... в любом виде ...
serik
12 - 31.05.2004 14:41 		(9) Это яполучается я должен в два приема заполнять справочник?
lexa
13 - 31.05.2004 14:44 		Клн.Новый();
Клн.КБе=КБе;
Клн.СвидетельствоПоНДС=СвидетельствоПоНДС;
Клн.КонтактноеЛицо=КонтактноеЛицо;
Клн.ОснованиеПоУмолчанию=ОснованиеПоУмолчанию;
Клн.Записать();
РасСчет=СоздатьОбъект("Справочник.РасчетныеСчета");
РасСчет.ИспользоватьДату(РабочаяДата());
РасСчет.ИспользоватьВладельца(Клн);
РасСчет.Новый();
РасСчет.Наименование ="Основной";
РасСчет.НомерСчета =НомерРасчетногоСчета ;
РасСчет.Записать();
Клн.ОсновнойРасчетныйСчет=РасСчет.ТекущийЭлемент;
lexa
14 - 31.05.2004 14:47 		Поправка вместо
РасСчет.ИспользоватьВладельца(Клн);
надо
РасСчет.ИспользоватьВладельца(Клн.ТекущийЭлемент());
и вместо
Клн.ОсновнойРасчетныйСчет=РасСчет.ТекущийЭлемент;
надо
Клн.ОсновнойРасчетныйСчет=РасСчет.ТекущийЭлемент();


Недопустимая операция, при попытке установить значение переодического рекв. | База знаний | mista.ru

Недопустимая операция, при попытке установить значение переодического рекв.

Lazarus
27.05.2004 12:56 		Подскажите где грабли? Не могу понять, почему ошибку выдает?

СпрНДС=СоздатьОбъект("Справочник.СтавкиНДС");
Если СпрНДС.НайтиПоНаименованию("18%",0)=1 тогда
Ставка=СпрНДС.ТекущийЭлемент();
иначе
сообщить("Не найдена ставка НДС");
конецесли;
СпрТов=СоздатьОбъект("Справочник.Номенклатура");
СпрТов.ВыбратьЭлементы(0);

Пока СпрТов.ПолучитьЭлемент()=1 Цикл
Тек=СпрТов.ТекущийЭлемент();
Если Тек.ЭтоГруппа()=0 тогда
Тек.СтавкаНДС.Установить(РабочаяДата(),Ставка);
конецесли;
Конеццикла;
Lazarus
1 - 27.05.2004 13:08 		упс.. подумал немного и нашел косяк. Вопрос снимается!
Евгений
2 - 27.05.2004 13:26 		Да вроде по коду все правильно (разве тек.Записать() не хватает).
Мне только не понятно по смыслу: получается что у тебя ставка НДС на конкретный товар - реквизит периодический? то есть с течением времени может меняться? А сама ставка НДС - величина постоянная? По идее должно быть наооборот.
Проверь на реквизиты. Может и тебя СтавкаНДС в справочнике ставок - реквизит периодический (тогда ты не спозиционировался по времени) или СтавкаНДС в справочнике номенклатуры - число, а ты загоняешь объект. Или что-то в этом роде...
Lazarus
3 - 27.05.2004 13:41 		Проблема была вот здесь
нельзя вот так:
Тек.СтавкаНДС.Установить(РабочаяДата(),Ставка);
надо
СпрТов.СтавкаНДС.Установить(РабочаяДата(),Ставка);

Да, ставка НДС на конкретный товар действительно переодический реквизит, при том это стандартная Конфигурация Бухгалтерии 7.70.443 и в принципе это правильный подход, так как это позволяет решить проблему смены НДС у конкретного товара, например с 18% на 10%, а такое в моей практике уже было... но в другой конфигурации, где НДС был не переодическим. Пришлось переделывать...


Подчиненный справочник | База знаний | mista.ru

Подчиненный справочник

Freelancer 26.05.2004 11:41 | На форме документа в 1С есть поле ввода которое имеет тип Справочник. Сам справочник является подчиненным. Как сделать чтобы открывался сразу именно подчиненный справочник для данного клиента, а не родительский?
SnarkHunter 1 - 26.05.2004 11:45 | В свойствах на закладке "Дополнительно" в поле "Связан с" укажи идентификатор реквизита, в котором выбирается владелец...
427 5 - 26.05.2004 11:56 | Связан С ..... в свойствах заполни
SnarkHunter 8 - 26.05.2004 12:01 | Вообще-то в поле "Связан с" нужно указать ИДЕНТИФИКАТОР реквизита...
lexa 16 - 26.05.2004 12:17 | Процедура ПриНачалеВыбораЗначения(ИдентЭлемДиалога,ФлагСтандОбр) Если ИдентЭлемДиалога = "ТвойРеквизит" Тогда ТвойРеквизит.ИспользоватьВладельца(Владелец); КонецЕсли;
Макс 17 - 26.05.2004 12:20 | (13) Не занимайся фигней, что я тебе посоветовал.. все работает. Я сделал новый документ - в шапку засунул реквизит "МойНужныйРеквизитТовар" - это Справочник.Товары, в табличную часть засунул реквизит "Цена" - это Справочник.ЦеныТоваров - он подчинен справочнику Справочник.Товары... Потом в поле реквизита Цена в форме указал в "Связан с" - "МойНужныйРеквизитТовар". именно "Товар" - идентификатор реквизита шапки, а не "справочник.Товары", не "Товары". и усе.


Не записывается атрибут типа Перечисление в подчиненном справочнике | База знаний | mista.ru

Не записывается атрибут типа Перечисление в подчиненном справочнике

ary
26.05.2004 11:42 		Сабж.
При вызове процедуры на запись нового элемента справочника из формы обработки не записывается поле типа Перечисление ;(
Процедура ЗаписатьЭл(.., Статья, ...)
//статья - тип "перечисление.Доходы
Спр = СоздатьОбъект("Справочник.ПланПоДоходам");
Спр.Новый();
Спр.УстановитьАтрибут("СтатьяДоходов", Статья);
//или же пробовал так
Спр.СтатьяДоходов = Статья;
//перепробовал все методы для справочника, как тока не извращился, все равно после записи эл-та в справочнике поле "статьяДоходов" (тип Перечисление.Доходы) остается пустым ;(

Спр.Владелец = Владелец;
Спр.УстановитьНовыйКод();
Спр.Записать();
КонецПроцедуры

Что же в конце концов я делаю не так?... или может быть так вообще делать нельзя? ;)
lexa
1 - 26.05.2004 11:52 		ИспользоватьВладельца
Установить выборку подчиненного справочника.

Синтаксис:

ИспользоватьВладельца(<Владелец>, <ФлагИзменения>)

Англоязычный синоним:

UseOwner

Параметры:

<Владелец>
Необязательный параметр. Выражение со значением элемента справочника-владельца.

<ФлагИзменения>
Необязательный параметр. Этим флагом регулируется возможность интерактивного изменения владельца. 1 — пользователь может изменить владельца интерактивно, 0 — пользователь не может интерактивно изменить владельца. Этот параметр используется в случае использовсния данного метода для объектов типа «справочник», которые являются реквизитами формы или реквизитами диалога.

Возвращаемое значение:

Значение элемента справочника-владельца для текущего подчиненного справочника (на момент до исполнения метода).

Описание:

Метод ИспользоватьВладельца может применяться к объектам типа «справочник» в двух случаях:

Для объектов, созданных функцией СоздатьОбъект, метод ИспользоватьВладельца устанавливает элемент справочника-владельца (которому подчинен текущий подчиненный справочник) в качестве параметра выборки. Данный метод используется до вызова метода ВыбратьЭлементы, который фактически открывает выборку. Дальнейшая выборка при помощи метода ПолучитьЭлемент будет происходить только среди тех элементов текущего подчиненного справочника, для которых владельцем является заданное значение элемента справочника-владельца <Владелец>. При записи нового элемента текущего справочника данный метод также задает владельца для нового элемента.
Для объектов типа «справочник», которые являются реквизитами формы (например, в форме документа — реквизит документа типа «справочник») или реквизитами диалога (например, в форме отчета — реквизит диалога типа «справочник») метод ИспользоватьВладельца позволяет программно установить некоторое значение справочника-владельца в качестве владельца, который будет использован при интерактивном выборе значения данного реквизита.
Пример:

// Процедура выводит список детей сотрудника

// Справочник детей подчинен справочнику сотрудников

Процедура ВыводСпискаДетей(Сотр)

СпрД = СоздатьОбъект("Справочник.Дети");

// в качестве параметра функции ИспользоватьВладельца

// передаем параметр, переданный в процедуру

СпрД.ИспользоватьВладельца(Сотр);

Сообщить("Дети сотрудника " + Сотр.Наименование);

СпрД.ВыбратьЭлементы();

Пока СпрД.ПолучитьЭлемент() > 0 Цикл

Сообщить(СпрД.Наименование);

КонецЦикла;

КонецПроцедуры
________________________
перед Спр.Новый();
SnarkHunter
2 - 26.05.2004 11:55 		Спр = СоздатьОбъект("Справочник.ПланПоДоходам");
Спр.ИспользоватьВладельца(Владелец); < --
Спр.Новый();
Спр.СтатьяДоходов = Статья;
Спр.Записать();
ary
3 - 26.05.2004 11:57 		конечно хорошо копировать из хелпа по 1с, эт я тоже могу и читал...
но вопрос стоял не в том как установить владельца, а в том почему не записывается реквезит справочника типа "Перечисление.Доходы"?
К тому же владелец мне не для выборки нужен... это совсем другая сказка
ary
7 - 26.05.2004 12:07 		2 lexa
у меня точно такое же в 1c.chm (бааааальшой такой хэлп)
Сори если резко так ответил... день тяжелый был... усе .. я разобрался (неужели?? ;) )
Все заработало...
В коде была куча условий и в каждом создавался новый элемент (в каждом соответственно разные), а ПОСЛЕ ВСЕХ ЭТИХ условие стояло еще раз Спр.Новый(), так вот он и затирал все, что создавалось до этого.. прощелкал однако...
А вот насчет того, что следовало использовать Спр.ИспользоватьВладельца(Владелец) до Спр.Новый() я не знал... (а почему оно до этого работало все нормально? - странно)


Обход подчиненного справочника (вопрос №2) | База знаний | mista.ru

Обход подчиненного справочника (вопрос №2)

Danila 25.05.2004 20:34 | Вот код в который из формы передается значение <ВыбНоменклатура> (не группа) из справочника "номенклатура". Далее производится обход подчиненного справочника "цены". В результате работы этого отчета я вижу тип цены, а там где должна выводиться цена сообщение "неизвестный объект", т.е. СпрЦены.Цена - не определена... В то время как у справочника "цены" есть реквизиьть Цена. В чем глюк? Спасибо! Код ниже. Процедура Сформировать() ОчиститьОкноСообщений(); Сообщить("Выбрано:"+ВыбНоменклатура); СпрЦены = СоздатьОбъект("Справочник.Цены"); СпрЦены.ИспользоватьВладельца(ВыбНоменклатура); СпрЦены.ВыбратьЭлементы(); Пока СпрЦены.ПолучитьЭлемент() = 1 Цикл Сообщить(СпрЦены.ТипЦен); Сообщить(СпрЦены.Цена); КонецЦикла; КонецПроцедуры
Danila 4 - 25.05.2004 20:50 | 2 Именно для периодических реквизитов такая ошибка выдается. Там есть еще реквизит ЕДИНИЦА - он тоже периодический и доя него аналогичная ошибка. Как с этим справиться?
Волшебник 6 - 25.05.2004 20:52 | СпрЦены.Цена.Получить(<Дата>) Или перед циклом сделать: СпрЦены.ИспользоватьДату(<Дата>)
Danila 7 - 25.05.2004 20:56 | 6 А как получить последнее значение периодического реквизита, не указывая даты. Последний в хронологической последовательности.
Волшебник 8 - 25.05.2004 21:03 | (7) Укажи очень позднюю дату.
427 9 - 25.05.2004 21:03 | СпрЦены.ИспользоватьДату('09.09.2999') в ближайшие полгода так точно работать будет .....


Обход подчиненного справочника (вопрос) | База знаний | mista.ru

Обход подчиненного справочника (вопрос)

Danila 25.05.2004 19:48 | Рассматривается типовая конфигурация Торговля + Склад 933 релиз. Есть некая форма, в которой переменной ТОВАР присваивается значение взятое из справочника "номенклатура" (значение обязательно не группа). Есть справочник "цены", он является подчиненным к справочнику номенклатура. Хочется сделать перебор элементов справочника "цены", для которого родителем будет ТОВАР. Подскажите как это сделать. Далее код, подправте, если это возможно. СпрЦены = СоздатьОбъект("Справочник.Цены"); СпрЦены.Владелец = ТОВАР; // КАК ПРАВИЛЬНО УСТАНОВИТЬ ВЛАДЕЛЬЦА? СпрЦены.ВыбратьЭлементы(); Пока СпрЦены.ПолучитьЭлемент() = 1 Цикл ... //действия с очередным элементом КонецЦикла; Заранее СПАСИБО!
Mazay 3 - 25.05.2004 20:01 | СпрЦены.ИспользоватьВладельца(ТОВАР)


Фильтр в справочнике | База знаний | mista.ru

Фильтр в справочнике

Bob
25.05.2004 11:54 		Есть справочник. Его отфильтровать по двум и более реквизитам. Есть метод - УстановитьОтбор() - но в данном случае она не подойдет - работает только для одного реквизита. Что делать?
В том смысле, есть ли какие то извраты? Показать надо не в отчете, а в самом справочнике.
lexa
1 - 25.05.2004 11:58 		ИспользоватьСписокЭлементов
Реализует фильтрацию элементов справочника используя нединамический фильтр.

Синтаксис:

ИспользоватьСписокЭлементов (<СписокЗначений>)

Англоязычный синоним:

UseItemList

Параметры:

<СписокЗначений>
Необязательный параметр. Значение типа «СписокЗначений». Должен представлять собой список элементов справочника, выбранных для просмотра. Если это значение пустое, то фильтр отключается.

Описание:

Метод ИспользоватьСписокЭлементов реализует фильтрацию элементов справочника. Устанавливает нединамический фильтр.

Рекомендуется применять в предопределенных процедурах ПриСменеРодителя, ПриОткрытии, ПриСменеИерархии. При этом формируется список «разрешенных» элементов, который передается форме списка справочника при помощи данного метода. Данный список должен являться подмножеством тех элементов, которые обычно отображаются в форме списка без применения фильтра.

После вызова метода ИспользоватьСписокЭлементов форма списка справочника не позволяет вводить новый элемент, копировать и т. п.

Данный метод доступен в контексте Модуля формы списка справочника (см. «Виды программных модулей»). Действие данного метода относится ко всему текущему списку справочника, который доступен в локальном контексте Модуля формы списка справочника.

Пример:

Процедура УстановитьФильтр(ВыбПризнак)

Список.СоздатьОбъект("СписокЗначений");

Буфер = СоздатьОбъект("Справочник.Главн");

// отбираем только те элементы, которые могут отображаться в текущем списке

Буфер.ИспользоватьРодителя(ИспользоватьРодителя());

Буфер.ВключатьПодчиненные(0);

Буфер.ВыбратьЭлементы();

Пока Буфер.ПолучитьЭлемент() = 1 Цикл

// отбираем только те элементы, которые удовлетворяют заданному признаку

Если (Буфер.Признак = ВыбПризнак) Тогда

Список.ДобавитьЗначение(Буфер.ТекущийЭлемент());

КонецЕсли;

КонецЦикла;

ИспользоватьСписокЭлементов(Список);

КонецПроцедуры


Перенос клиентов в ТиС | База знаний | mista.ru

Перенос клиентов в ТиС

Arif
24.05.2004 14:13 		ТиС.Есть сотрудник А, нужно его клиентскую базу (котрагенты.покупатели перенести сотруднику Б. (Торможу-не знаю с чего начать, не вижу пока алгоритма решения).Help
Arif
3 - 24.05.2004 14:31 		Есть справочник Контрагенты.Клиенты (У каждого менеджера есть своя база клиентов) Сотрудника А-уволили, взяли сотрудника Б. Нужно клиентов Сотрудника А перекинуть сотруднику Б. Имеем 2 справочника (Контрагенты, Сотрудники) В справочнике Контрагенты есть идентификатор Сотрудники. Вот и усё. Я почти догадался но ещё не всё дошло. Мешают сосредоточиться черти.
lexa
5 - 24.05.2004 14:35 		А реквизит Сотрудники справочника Контрагенты периодический или нет?
Arif
6 - 24.05.2004 14:43 		Не периодический.
lexa
7 - 24.05.2004 15:18 		Клиенты = СоздатьОбъект("Справочник.Контрагенты");
Клиенты.ВыбратьЭлементы();
Пока Клиенты.ПолучитьЭлемент() = 1 Цикл
Если Клиент.Сотрудник = СотрудникА Тогда
Клиент.Сотрудник = СотрудникБ;
Клиенты.Записать();
КонецЕсли;
КонецЦикла;


Помогите разобраться с методом справочника "ПринадлежитГруппе" | База знаний | mista.ru

Помогите разобраться с методом справочника "ПринадлежитГруппе"

Allan Stark
24.05.2004 10:16 		1С версия 7.7 (7.70.020)
Есть ф-ция, которая должна выдавать ставки начислений (исп. в зарплате).
Конфигурация 1С - комплексная (все компоненты)

Код ф-ции:

Функция ПолучитьСтавку(ГруппаКод, СуммаЗП)
СпрШкалаСтавок = СоздатьОбъект("Справочник.ШкалаСтавок");
СпрШкалаСтавок.ИспользоватьДату(ДатаДок);
СпрШкалаСтавок.ВыбратьЭлементы();
Пока СпрШкалаСтавок.ПолучитьЭлемент() = 1 Цикл
Если (СпрШкалаСтавок.ПринадлежитГруппе(ГруппаКод) = 1) И (СуммаЗП < СпрШкалаСтавок.Предел)
Тогда Возврат СпрШкалаСтавок.Ставка;
КонецЕсли;
КонецЦикла;
Возврат 0;
КонецФункции

Ставки хранятся в соотв. справочнике. Поскольку ставка зависит от суммы начисленной зарплаты, нужно организовать подбор подходящей ставки внутри группы отчислений.

Все замечательно, только метод справочника "ПринадлежитГруппе" работает некорректно - не сравнивает с группой...

Помогите пожалуйста...
SnarkHunter
1 - 24.05.2004 10:33 		Метод ПринадлежитГруппе работает корректно... Просто его в данном контексте используют некорректно... Параметр некорректный, если уж на то пошлО...
Allan Stark
3 - 24.05.2004 11:33 		В документации сказано, что ему (ПринадлежитГруппе) передается параметр, "содержащий выражение со значением группы справочника".
как это интерпретировать ? Пробовал в качестве параметра и Код справочника и его Наименование - результат отрицательный...

В общем нужно сделать так, чтоб функция просматривала все элементы справочника и если элемент входит в заданную группу и значение начисления зарплаты ниже пороговой ставки - то возвращался этот Код элемента справочника ставок.
SnarkHunter
4 - 24.05.2004 11:35 		Это нужно интерпретировать, как "ссылка на элемент справочника"...
Allan Stark
6 - 24.05.2004 11:43 		Ну и ? Что, нужно вначале взять некую переменную и найти в нее элемент справочника, который есть группа (НайтиПоКоду) ?

Например:

...........
ЭлементГруппа = СпрШкалаСтавок.НайтиПоКоду(ГруппаКод);
Если (СпрШкалаСтавок.ПринадлежитГруппе(ЭлементГруппа) = 1) И (СуммаЗП < СпрШкалаСтавок.Предел)
Тогда Возврат СпрШкалаСтавок.Ставка;
...........

???
lexa
7 - 24.05.2004 11:46 		А если код не уникальный?
SnarkHunter
8 - 24.05.2004 11:54 		(7)А если это родитель более высокого уровня?
Allan Stark
9 - 24.05.2004 11:56 		Lexa

В смысле не уникальный ? Так проверить еще дополнительно с помощью .ЭтоГруппа()
А тот факт, что найдутся две группы с одинаковым кодом можно считать недействительным.

Блин, только что попробовал - все равно не работает...

Я что-то вкурить не могу, что нужно этому ".ПринадлежитГруппе(...)" подсунуть...
Allan Stark
10 - 24.05.2004 11:58 		Да нет у него родителя... Просто есть отдельный неподчиненный никому справочник. Называется СпрШкалаСтавок. В нем - все ставки по налогам, отчислениям и пр.
Они там внутри него отсортированы по группам: по зарплате - отдельно, налоги с предприятия - отдельно, платежи в разные фонды и пошлины - тоже отдельно...
lexa
11 - 24.05.2004 12:03 		Тогда уж более кооректно передавать не "Код", а "ПолныйКод", хотя правильно передавать "ссылка на элемент справочника"
Allan Stark
12 - 24.05.2004 12:03 		Ой, что-то не то сморозил с Родителем... :-)
Да, в принципе там 3 уровня вложенности... Наприемр в группе "зарплата" есть еще подгруппы "С предприятия" и "С сотрудника"...
lexa
13 - 24.05.2004 12:06 		(10)
Родитель
Значение родительской группы элемента справочника.

Синтаксис:

Родитель

Англоязычный синоним:

Parent

Описание:

Атрибут Родитель предоставляет доступ к значению родительской группы выбранного элемента справочника.

Данный атрибут может быть изменен только для объектов, созданных функцией СоздатьОбъект.

Пример:

Функция ДатьРодителя(Элем)

// Справочник Товаров многоуровневый

// Получая в параметре функции значение товара,

// надо выдать имя группы товара

Спр = СоздатьОбъект("Справочник.Товары");

Спр.НайтиЭлемент(Элем);

Если Спр.Уровень() > 1 Тогда

Спр.НайтиЭлемент(Спр.Родитель);

Возврат "Этот товар принадлежит группе " + Спр.Наименование;

Иначе

Возврат "Это товар первого уровня - нет родителя!";

КонецЕсли;

КонецФункции

Все равно "Код" не является однозначным индентификатором, поэтому лучше передавать ГруппаКод, а Группа, как "ссылка на элемент справочника"
SnarkHunter
15 - 24.05.2004 12:09 		(6)Проверку делай после поиска по коду - найден/не найден...

(10)Не путай Родителя и Владельца...
Я тебе речь веду о строке в (7) - (СпрШкалаСтавок.Родитель.Код = ГруппаКод)... Это быть работать, если ГруппаКод - код группы, в которой непосредственно находится элемент и упадет, если задать код группы более высокого уровня, но в которой, тем не менее, элемент находится в этой группе...
lexa
16 - 24.05.2004 12:13 		Функция ПолучитьСтавку(Группа, СуммаЗП)
СпрШкалаСтавок = СоздатьОбъект("Справочник.ШкалаСтавок");
СпрШкалаСтавок.ИспользоватьДату(ДатаДок);
СпрШкалаСтавок.ВыбратьЭлементы();
Пока СпрШкалаСтавок.ПолучитьЭлемент() = 1 Цикл
Если (СпрШкалаСтавок.ПринадлежитГруппе(Группа) = 1) И (СуммаЗП < СпрШкалаСтавок.Предел)
Тогда Возврат СпрШкалаСтавок.Ставка;
КонецЕсли;
КонецЦикла;
Возврат 0;
КонецФункции
lexa
18 - 24.05.2004 12:48 		Ты в функцию передавай не значение реквизита Код элемента справочника, а сам элемент справочника. Покажи как ты вызываешь свою функцию и откуда берутся значения, передаваемые в эту функцию.


Помогите составить запрос к справочнику "номенклатура" | База знаний | mista.ru

Помогите составить запрос к справочнику "номенклатура"

Danila
23.05.2004 14:04 		Вот код который перебирает элементы справочника "номенклатура"
и выводит тип цен и соотвенно цену:

СпрНом= СоздатьОбъект("Справочник.Номенклатура");
СпрНом.ВыбратьЭлементы();
Пока СпрНом.ПолучитьЭлемент() = 1 Цикл
СпрЦ = СоздатьОбъект("Справочник.Цены");
СпрЦ.ИспользоватьВладельца(СпрНом);
Сообщить("Наим="+СпрНом.Наименование);
СпрЦ.ВыбратьЭлементы();

Пока СпрЦ.ПолучитьЭлемент() = 1 Цикл
Сообщить("ТипЦен="+СпрЦ.ТипЦен+" Цена="+СпрЦ.Цена);
КонецЦикла;
КонецЦикла;

Помогите составить запрос к справочнику "номенклатура", который делал бы то же самое...
Заранее благодарю!!!!
SnarkHunter
1 - 23.05.2004 14:09 		Используй язык запросов...
А вообще, запросы 1С к справочникам выполняются по времени, как правило, дольше, чем перебор...
Danila
4 - 23.05.2004 14:42 		Для (2). У меня еще во возникла такая проблема
Хочу выбрать из справочника "номенклатура" элементы у которых
Ставка Наименование = "Болт". Вот код

СпрНом= СоздатьОбъект("Справочник.Номенклатура");
СпрНом.ВыбратьЭлементыПоРеквизиту("Наименование","Болт",1,0);

Получаю ошибку "Неверное имя реквизита"
Где я облажался. Вроде в справочние "Номенклатура" есть реквизит "наименование", а программа такую ошибку дает.
GrayT
6 - 23.05.2004 14:56 		(3)Значит это не стандарт - в стандврте цена периодический рекв.
(4) И много у тебя болтов?
(0)
|Период с ВыбНачПериода по ВыбКонПериода;
|Владелец = Справочник.Цены.Владелец;
|ТипЦен = Справочник.Цены.ТипЦен;
|Цена = Справочник.Цены.Цена;
|Группировка Владелец упорядочить по Владелец.Наименование;
|Группировка ТипЦен;
|Группировка Цена;
Правда это не совсем то же самое. - групп нет :)
Danila
7 - 23.05.2004 15:02 		(6) У меня справочник Цены подчиненный (подчинен номенклатуре)
GrayT
9 - 23.05.2004 15:11 		Наименование - это АТРИБУТ справочника
SnarkHunter
15 - 23.05.2004 15:27 		Реквизиты ты можешь добавлять/удалять в конфигураторе, атрибуты - нет... У справочников два втрибута - Код и Наименование...
GrayT
16 - 23.05.2004 15:34 		+15 Которые присутствуют почти всегда.
Еще есть Родитель и Владелец
427
17 - 23.05.2004 15:41 		(15) У справочника есть еще минимум 2 атрибута ....


синхронизация данных в справочниках | База знаний | mista.ru

синхронизация данных в справочниках

nogar 02.12.2003 17:35 | есть два поля на форме с типом справочник в одном поля марка совпадают с наименованием марка во втором.Спровочники разные. вопрос как программно выбрав элемент в первом спровочнике,автоматически внести соответствующий элемент по марке во второй справочник?
skunk 1 - 02.12.2003 17:53 | Не совсем понятно, что ты имел ввиду. Но попрубуй так. Выбери для себя когда должен изменяться второй справочник. При сохранении изменений в первом, или не зависимо от того, что потом сделает пользователь сохранит внесенные изменения или нет - при изменении "поля марка". В первом случае используешь процедуру ПриЗаписи() и там изменяешь реквизиты второго справочника. Во втором ПриИзмененииРеквезитов().
puh 2 - 03.12.2003 07:56 | можно создать процедурку. при выборе объекта в первом создается второй справочник и в нем выбирается объект по заданным реквизитам и все это записывается в форму.


проблема с экспортом справочников из 7.7 | База знаний | mista.ru

проблема с экспортом справочников из 7.7

serik
21.05.2004 14:03 		Вот кусок кода
СписокПараметров.ДобавитьЗначение(СокрЛП(Клн.ПаспортныеДанные));
СписокПараметров.ДобавитьЗначение(СокрЛП(Клн.ПенсионныйФонд));
СписокПараметров.ДобавитьЗначение(СокрЛП(Клн.РНН));
СписокПараметров.ДобавитьЗначение(СокрЛП(Клн.СИК));
СписокПараметров.ДобавитьЗначение(СокрЛП(Клн.Телефон));
СписокПараметров.ДобавитьЗначение(СокрЛП(Клн.ЭлектроннаяПочта));
СписокПараметров.ДобавитьЗначение(СокрЛП(Клн.ЮридическийАдрес));
РасСЧета=СоздатьОбъект("Справочник.РасчетныеСчета");
РасСчета.ИспользоватьДату(РабочаяДата());
РасСчета.ИспользоватьРодителя(Клн);
РасСчета.ВыбратьЭлементы();
СписокПараметров.ДобавитьЗначение(СокрЛП(РасСчета.Код));
СписокПараметров.ДобавитьЗначение(СокрЛП(РасСчета.Наименование));
СписокПараметров.ДобавитьЗначение(СокрЛП(РасСчета.НомерСчета));
СписокПараметров.ДобавитьЗначение(СокрЛП(РасСчета.Банк));
Бнк=СоздатьОбъект("Справочник.Банки");
Бнк.ИспользоватьРодителя(РасСчета);
Бнк.ВыбратьЭлементы();
СписокПараметров.ДобавитьЗначение(СокрЛП(Бнк.Код));
СписокПараметров.ДобавитьЗначение(СокрЛП(Бнк.Наименование));
СписокПараметров.ДобавитьЗначение(СокрЛП(Бнк.КоррСчет));
СписокПараметров.ДобавитьЗначение(СокрЛП(Бнк.РНН));
СписокПараметров.ДобавитьЗначение(СокрЛП(Бнк.Адрес));
СписокПараметров.ДобавитьЗначение(СокрЛП(Бнк.Местонахождение));
СписокПараметров.ДобавитьЗначение(СокрЛП(Бнк.Страна));
СписокПараметров.ДобавитьЗначение(СокрЛП(Бнк.Телефоны));
СписокПараметров.ДобавитьЗначение(СокрЛП(Бнк.КодВнутриБанковскойСистемы));
СписокПараметров.ДобавитьЗначение(СокрЛП(Бнк.ПроцентКомиссииБанка));

Стр=СписокПараметров.ВСтрокуСРазделителями();

Почему-то из справочника Бнк берет все, а справочник РасСчет вставляет пестые значения, хотя они есть.
SnarkHunter
1 - 21.05.2004 14:10 		Потому что ПолучитьЭлемент()...


Корректен ли следующий код? | База знаний | mista.ru

Корректен ли следующий код?

SAP
20.05.2004 15:07 		Если СпрЮрЛица.НайтиПоРеквизиту("ИДКИС",ИДКИС,1)=1 Тогда
ИначеЕсли СпрЮрЛица.НайтиПоРеквизиту("ИНН",ИНН,1)=1 Тогда
Иначе
СпрЮрЛица.Новый();
СпрЮрЛица.Наименование=РабочееИмя;
СпрЮрЛица.ПолнНаименование=НаимКорр;
СпрЮрЛица.ИНН=ИНН;
СпрЮрЛица.ОКПО=ОКПО;
СпрЮрЛица.ЮрАдрес=ЮридическийАдрес;
СпрЮрЛица.ФактАдрес=Адрес;
СпрЮрЛица.Записать();
КонецЕсли;

Я читал, что 1С проверяет сразу все условия в "Если Тогда", в связи с этим в случае успешного поиска по "ИДКИС" буден ли выполняться поиск по "ИНН"?
mszsuz
1 - 20.05.2004 15:18 		Если СпрЮрЛица.НайтиПоРеквизиту("ИДКИС",ИДКИС,1)=0 Тогда
Если СпрЮрЛица.НайтиПоРеквизиту("ИНН",ИНН,1)=0 Тогда
СпрЮрЛица.Новый();
...
СпрЮрЛица.Записать();
КонецЕсли;
КонецЕсли;
SAP
6 - 20.05.2004 16:11 		Дело в том, что в случае удачного поиска мне надо получить найденный элемент, а как я понял такая конструкция все равно не позволит этого сделать, так что придется делать через флаг.
mszsuz
7 - 20.05.2004 16:25 		(6) Какой флаг?
Смотрим (1): ищем по "ИДКИС", если есть такой, то СпрЮрЛица.ТекущийЭлемент() и будет найденный элемент. Если поиск неудачный, тогда ищем по ИНН, если находим, то СпрЮрЛица.ТекущийЭлемент() опять же. Если и второй поиск неудачный, тогда уже создается новый...
Т.е. после кода в (1), СпрЮрЛица.ТекущийЭлемент() в любом случае отдаст тебе нужного ...
Outlander
11 - 20.05.2004 17:27 		(10) Тогда почему такой код работает вполне корректно:
.
Если (СпрК.НайтиПоРеквизиту("ОКПО",окпо0,1)=0) и
(СпрК.НайтиПоРеквизиту("ИНН",инн0,1)=0) Тогда
Сообщить("Клиент не найден...");
Иначе
Сообщить("Нашли!");
КонецЕсли;
.
Так кто прав?
mszsuz
13 - 20.05.2004 17:41 		(12) Дело не в нуле. Судя по твоим предположениям, правое условие в (10) никогда не должно выполниться, т.к. левое всегда ложно.
mszsuz
14 - 20.05.2004 17:47 		Пример в (10) не совсем удачный.
Вот другой:
ТЗ=0;
Если (ТипЗначенияСтр(ТЗ)="ТаблицаЗначений") И (ТЗ.КоличествоСтрок()>0) тогда
// и опять летаем по ошибке ...
OctoberHammer
17 - 20.05.2004 19:29 		2(16) Лучше было найти страницу, где сказано, что в77 вычисляет выражение в условии полностью. Но самому лень. :))


Учет в ювелирном магазине | База знаний | mista.ru

Учет в ювелирном магазине

Mauxion 20.05.2004 12:24 | Стоит задача: учет в ювелирном магазине. Поделитесь опытом кто делал. Сложность заключается в том, что справочник ведется по артикулам и каждое новое изделие - новая строка справочника. Т.е. справочник будет "разбухать" постоянно. Что можно придумать?
User63 2 - 20.05.2004 14:26 | Вариант чисто теоретический. Подобный вопрос возникал у меня на работе. Сам до ума не довел, но можно попробовать следующим образом. 1. Заведи справочник артикулы подчиненный номенклатуре. 2. Этот справочник сделай реквизитом справочника-партии. 3. В форме карточка партии ( имеется в виду ТИС 9..) укажи этот реквизит для ввода артикула. 4. Где-то есть функция формирования строки партии при выводе отчета. Там надо добавить вывод артикула. Ну и все. У меня был вариант с сериями которые для каждой номенклатуры. В твоем случае, по-моему, достаточно завести дополнительный реквизит типа строка в справочник партии. и все.


Тип поля: Справочник. Неопределенный | База знаний | mista.ru

Тип поля: Справочник. Неопределенный

jackee 19.05.2004 12:21 | Возможно ли узнать (и как) из какого справочника выбрано значение в данной записи, если справочник неопределен в конфигураторе? т.е. Реквизит: Тип: Справочник Вид:""
Таня 1 - 19.05.2004 12:27 | насколько я знаю, есть метод НазначитьТип(), который и определяет неопределенный тип или что-то подобное
jackee 2 - 19.05.2004 12:31 | (1) Мне надо не назначить а узнать. Например есть какой-то справочник в котором одно поле имеет тип <<Справочник>> И естественно может назначатся из разных справочников. Так вот можно ли узнать для каждой записи из какого справочника выбрано это значение
427 3 - 19.05.2004 12:39 | ТипЗначенияСТр Выбран ПустоеЗначение
jackee 4 - 19.05.2004 12:49 | (3) ТипЗначенияСТр Дает мне, что тип "Справочник". Это я и так знаю. Т.к. получил структуру справочника через Метаданные.Справочник("...").Реквизит(ном).Тип При этом ....Вид у него - пустой. Это я тоже знаю. Но возможно ли узнать что за справочник для каждой конкретной записи???? Спасибо.
Valery 5 - 19.05.2004 12:49 | Лучше ХХХ.Вид()
jackee 6 - 19.05.2004 12:55 | Так Вид, если подключится через Метаданные - Пустая строка
Valery 7 - 19.05.2004 12:59 | Про метаданные не понял. Если реквизиту уже присвоено значение, то Реквизит.Вид() должно быть так
427 8 - 19.05.2004 13:06 | А на кой тебе метаданные, если определять надо в каждом конкретном элементе для конкретного реквизита... Ибо конкретика выбирается в конкретном элементе .... Если ТипЗначенияСтр(...) = "Справочник" тогда Если ...Вид() = "НужныйСправочник" только по моему, нужно проверить сначала на непустое значение... чтобы на исключение не нарваться....
jackee 9 - 19.05.2004 13:10 | Справ - Имя справочника СпрН=СоздатьОбъект("Справочник."+Справ); Спр=Метаданные.Справочник(Справ); .... СпрН.ВыбратьЭлементы(); Пока СпрН.ПолучитьЭлемент()>0 Цикл Для ии=1 по КолвоРеквизитов цикл Если Спр.Реквизит(ии).Тип="Справочник" Тогда Сообщить(Спр.Реквизит(ии).Вид+" "+СпрН.ПолучитьАтрибут(Спр.Реквизит(ии).Идентификатор)); Иначе ..... КонецЕсли; Так вот. Если в конфигураторе справочник определен четко - Вид есть, Если не определен - то его нет (Пустая строка) Хотя значение передается. Сообщение: Торговый дом "ывавы"
jackee 10 - 19.05.2004 13:21 | Все спасибо, получилось. Не сообразил, что я же получаю тип справочник, и им можно пользоваться так же, как и обычным. Крутился вокруг да около.
GrayT 11 - 19.05.2004 13:24 | Все правильно - в конфигураторе вид не задан. Он определен у элемента. Попробуй: СпрН.ПолучитьАтрибут(Спр.Реквизит(ии).Идентификатор).ВИд())


Работа с транзакциями | База знаний | mista.ru

Работа с транзакциями

At 18.05.2004 14:27 | Можно ли использовать транзакцию при записи элементов в справочник? то есть будут ли записаны в справочник все новые элементы или только последний в случае если.. НачатьТранзакцию(); Пока Цикл Спр.Новый() КонецЦикла; Спр.Записать(); ЗафиксироватьТранзакцию();
SnarkHunter 1 - 18.05.2004 14:44 | Либо все, либо ни одного...
At 2 - 18.05.2004 15:20 | а у меня записала один и вывалилась с сообщением: ЗафиксироватьТранзакцию(); {Обработка.ЗагрузкаГТД.Форма.Модуль(79)}: Транзакция не активна почему такое могло случиться?
Fynjy 3 - 18.05.2004 16:40 | Записывается у тебя последний новый элемент справочника. В цикл включи запись... НачатьТранзакцию(); Пока Цикл Спр.Новый() ****** какие то действия ******* Спр.Записать(); КонецЦикла; ЗафиксироватьТранзакцию();
At 5 - 18.05.2004 17:17 | (4)Ок.. понятно внутри вроде бы всё нормально.. единственное на мой взгляд из-за чего это происходит (это я про ошибку) это то что у меня в цикле записываются два разных справочника одновременно...


как быстро найти договор в двухуровневом подчиненном спр.? | База знаний | mista.ru

как быстро найти договор в двухуровневом подчиненном спр.?

Kat
18.05.2004 14:18 		Функция ПолучитьДоговор(ТекКонтр,ТекКодДог)
Если ПустоеЗначение(ТекКодДог) =1 Тогда
Возврат 0;
КонецЕсли;
Спр = СоздатьОбъект("Справочник.Договора");
Спр.ИспользоватьВладельца(ТекКонтр);
спр.выбратьЭлементы(0);
пока спр.получитьЭлемент() = 1 цикл
если (спр.код = Строка(текКодДог)) и (спр.владелец = текКонтр) тогда
Возврат Спр.ТекущийЭлемент();
конецЕсли;
конецЦикла;
Сообщить("Не найден договор с кодом <"+СОКРЛП(ТекКодДог)+"> для контрагента <"+СОКРЛП(ТекКонтр)+">");
Возврат 0;
КонецФункции

перебором получается очень долго. А если искать просто по коду
Спр.ИспользоватьВладельца(ТекКонтр);
спр.НайтиПоКоду(ТекКодДог,0)- тогда поиск идет во всем справочнике, не учитывая владельца.
может надо искать по полному коду?
SnarkHunter
1 - 18.05.2004 14:30 		Как насчет
Спр.ИспользоватьВладельца(ТекКонтр);
спр.НайтиПоКоду(ТекКодДог,1);
lexa
2 - 18.05.2004 14:50 		НайтиПоКоду
Найти элемент справочника по коду.

Синтаксис:

НайтиПоКоду(<Код>, <ФлагПоиска>)

Англоязычный синоним:

FindByCode

Параметры:

<Код>
Выражение со значением искомого кода.

<ФлагПоиска>
Необязательный параметр. Числовое выражение — флаг поиска: 0 — поиск во всем справочнике вне зависимости от родителя; 1 — поиск внутри установленного подчинения (родителя); 2 — поиск по полному коду.

Значение по умолчанию: 0 — для справочников, у которых код уникален во всем справочнике; 2 — для справочников, у которых код уникален в группе.

Спр.ИспользоватьВладельца(ТекКонтр);
спр.НайтиПоКоду(ТекКодДог,1)


Копирование эл.справочника с подчиненными | База знаний | mista.ru

Копирование эл.справочника с подчиненными

Bzzzzz
14.05.2004 13:56 		В 1С 7.7 можно интерактивно скопировать эл.справочника с его подчиненными элементами, так сказать "легкими нажатием на кнопку панели инструментов". А программно?
lexa
1 - 14.05.2004 14:01 		Посмотри какую процедуру вызывает кнопка копировать (если она есть) и процедуру ВводНового() в форме справочника
Bzzzzz
3 - 14.05.2004 14:13 		(2) Читал когда-то. А щаз нужно получить ответ на вопрос. Метода Спр.Скопировать() не нашел ;-). Если можешь ответить, ответь пжл. А нет, так нет.
Valery
4 - 14.05.2004 14:17 		Если копирование "легкими нажатием на кнопку панели инструментов" имеется ввиду F9,то программно см. модуль формы справочника предопределенная процедура "приКопировании"
Bzzzzz
5 - 14.05.2004 14:20 		(4) Такой процедуры нет. Есть ВводНового, но она вызывается только при интерактивном копировании и туда передается скопированный объект.
lexa
6 - 14.05.2004 14:57 		ЭлементСправочника.Реквизит1 = ВремРеквизит1;
Спр = СоздатьОбъект("Справочник.НужныйСправочник");
СпрПодч = СоздатьОбъект("Справочник.ПодчСправочник");
СпрПодч.ИспользоватьВладельца(ЭлементСправочника);
СпрПодч.ВыбратьЭлементы();
ВремПодч = "";
Пока СпрПодч.ПолучитьЭлемент = 1 Цикл
ВремПодч = СпрПодч.ТекущийЭлемент()
КонецЦикла;
Спр.Новый();
Спр.Реквизит1 = ВремРеквизит1;
Спр.Записать();
Если ПустоеЗначение(ВремПодч) = 0 Тогда
СпрПодч.ИспользоватьВладельца(Спр.ТекущийЭлемент());
СпрПодч.Новый();
СпрПодч.Реквизит1 = ВремПодч.Реквизит1;
СпрПодч.Записать();
КонецЕсли;
427
9 - 14.05.2004 15:36 		Ну насчет кучи ты загнул.....
Копирование вместе с подчиненными - универсальная процедура )для любого справочника вместе с подчиненными ... примерно 50 строк кода ....
Bzzzzz
10 - 14.05.2004 15:51 		(9) Ну, согласись это тебе не Спр.Копировать(СпрНов); :*)
Просто, не хотелось "мудиться"
iceTiger
11 - 14.05.2004 15:56 		А вообще можно и через метаданные, там и подчиненные справочники, и их реквизиты.... усе шо хочешь.
Bzzzzz
12 - 14.05.2004 16:10 		(11) Как через метаданные получить все спр, подчиненные данному, без перебора?
Gavrila
13 - 14.05.2004 17:01 		(12) Никак помойму, а чем перебор не устраивает?
Bzzzzz
14 - 14.05.2004 17:31 		(13)Да устраивает. Я его и использовал. Просто хотел узнать - может есть способ эффективнее.
Например, для поиска эл.спр по Коду ты можешь использовать перебор, а можешь НайтиПоКоду :-))


Сортировка справочника в 1C 7.7 | База знаний | mista.ru

Сортировка справочника в 1C 7.7

maikl 13.05.2004 20:47 | Возможно ли отсортировать справочник по реквизиту(любому)
GrayT 1 - 13.05.2004 20:50 | Возможно. Там в свойствах реквизита есть
maikl 3 - 13.05.2004 21:01 | По наименованию и коду сортирует, а как отсортировать по любому другому реквизиту в свойствах ставлю сортировать, а он не сортирутет. Например Сортировка("цвет",0); Выдает неверное имя реквизита. Как быть......?
427 6 - 13.05.2004 21:17 | У реквизита д.б. галки Сортировка.... ОтборПоРеквизиту
GrayT 8 - 13.05.2004 21:34 | Моя очередь. Заходишь в конфигуратор, открываешь конфгиурацию, справочник, берешь нужный реквизит, жмешь изменить, переходишь на закладку дополнительно, там флажок сортировка. Включаешь. Или это развод?
GrayT 9 - 13.05.2004 21:57 | "..свойствах ставлю сортировать,..", Сорри, не заметил. Скопируй наименование в модуль. Можь ангельский символ затесался. А вообще наименование реквизита должно быть в точности таким же, возможно у тебя "Цвет" (кажеться)


Как засунуть элемент справочника в группу ПРОГРАММНО ??? | База знаний | mista.ru

Как засунуть элемент справочника в группу ПРОГРАММНО ???

Sh_s
11.05.2004 16:34 		Суть: Есть справочник_1, без подчинения, с группамы.
Цель: Добавить в него 2-3 сотни единиц из др. справочника_2,
причем добавлять в определенные группы справочника_1.
Реализация:
Спр1=СоздатьОбъект("Справочник.КодыПоставщики");
Спр=СоздатьОбъект("Справочник.Номенклатура");
Пока Запрос.Группировка() = 1 Цикл
Спр.НайтиЭлемент(Запрос.ТекущийЭлемент);
Если Запрос.ТекущийЭлемент.ЭтоГруппа()=0 Тогда
Спр1.Новый();
Спр1.УстановитьАтрибут("Наименование", Спр.Наименование);
Спр1.УстановитьАтрибут("Товар", Спр.Наименование);
Спр1.УстановитьАтрибут("Поставщик", ВыбКонтрагенты);
Спр1.УстановитьАтрибут("Родитель", Запрос.ТекущийЭлемент); _________________________________^^^^^^^^^^^^^Тут засада
Спр1.УстановитьАтрибут("КодПост" , Код_Пост(Спр.Наименование));
Спр1.Записать();
КонецЕсли;
КонецЦикла;

Ошибка: Вываливает сообщение что: "{C:\...\КОЛ-ВО В ГРУППЕ И ГРУППОВОЙ ПОСТАВЩИК.ERT(113)}: Неверный тип справочника".

Вопрос: Как засунуть элемент справочника в группу ПРОГРАММНО ???
Gavrila
1 - 11.05.2004 16:43 		Я так понимаю, что "Запрос.ТекущийЭлемент" - "Справочник.Номенклатура", а родитель Спр1 - "Справочник.КодыПоставщики", поэтому работать не будет уже из-за этого...
лучше добавь перед
Спр1.Новый();
строку
Спр1.ИспользоватьРодителя(какой-то_там_родитель);
, где какой-то_там_родитель - группа справочника "КодыПоставщики" :)
Valery
2 - 11.05.2004 16:47 		В логике непонятно. Присваиваешь родителю элемент не являющийся группой.
Sh_s
4 - 12.05.2004 10:38 		(1)Спр1.ИспользоватьРодителя(какой-то_там_родитель);

Я такое делал, ошибок не было, но все равно в группу не попадало. Все элементы попадали в корень, а не в указанную группу.
Frol
7 - 12.05.2004 12:30 		Вообщето, у тебя всё правильно с кодом. Единственное, строчку Спр1.УстановитьАтрибут("Родитель", Запрос.ТекущийЭлемент);
тебе надо поменять на:
код = Спр1.Код;
Спр1.УстановитьАтрибут("КодПост" , Код_Пост(Спр.Наименование));
Спр1.Записать();
Спр1.НоваяГруппа();
Спр1.Наименование = Запрос.ТекущийЭлемент;
Спр1.Записать();
Группа = Спр1.НайтиПоНаименованию(Запрос.ТекущийЭлемент,0,1);
Спр1.НайтиПоКоду(код,0);
Спр1.УстановитьАтрибут("Родитель",Группа);
Спр1.Записать();
Вот и все дела-то. Ну мож чуток не так, но идея правильная, у меня работало.
Sh_s
9 - 12.05.2004 23:46 		Как и ковырял ранее, все срослось, надо перед Новый()
Спр1.ИспользоватьРодителя(какой-то_там_родитель);
как и говорил (1) , что собственно я ранее и делал, но не работало.
Тепер понял что передавал в качестве Родителя строку с его именем, а надо передавать как объект, если слово объект здесь корректно. Ну в общем идея понятна. Все заработало как нуна. Всем спасибо.
P.S. Кто тут темы закрывает ....??????


Запрет на добавление нового элемента в справочнике, что за...? | База знаний | mista.ru

Запрет на добавление нового элемента в справочнике, что за...?

vva 11.05.2004 18:33 | Почему иногда в справочниках стоит запрет на добавление нового элемента/копирование. Это не демо база какая ни-ть.
vva 1 - 11.05.2004 18:34 | В общем, просто кнопки (Новый, Копировать) в форме справочника не доступны и все.
Gavrila 2 - 11.05.2004 18:35 | проверь шобы не был отключен иерархический список :)


Удаление подчиненного элемента справочника | База знаний | mista.ru

Удаление подчиненного элемента справочника

SNake 08.05.2004 09:20 | К примеру, имеется справочники: Механизмы(М) и Детали(Д). По кнопке в (М) вызывается подч. элементы из (Д). Необходимо по кнопке удаления в (Д) убрать из списка ненужную Деталь. Что делать, менять подчиненность элемента или непосредственно удалять? М.б., покрасивее как-нить?
Valery 1 - 08.05.2004 09:25 | Непонятно: 1. Почему элемент из подчиненного справочника удаляется по кнопке удаления, а не стандартными средствами? 2. Что значит убрать? Пометить на удаление или непосредственно?
GrayT 2 - 08.05.2004 09:30 | Непосредственно удалять можно только в том случае если Деталь заведомо ни где не будет использоваться как самостояетельная единица - детали приведены просто справочно. А дальше сам думай. Можно в другую группу. Можно отображать ТЗ деталей, в которую не попадают помеченные, короче смотря по обстаконовке :)
SNake 3 - 08.05.2004 10:44 | GrayT, Детали не должно быть в подчиненности текущего Механизма, это промеж. справочник подчиненности, она выбирается из основного спр. Номенклатура. А непосредственное удаление включается на все объекты, если не ошибаюсь, либо на созданные ф. СоздатьОбъект()? Может, для отображения списка подчиненности сразу ТЗ использовать? Valery, 1) есть форма списка, там станд.кнопа Удалить, куда уж стандартнее? 2) \"убрать\" - из формы списка, как угодно, но чтобы ее не было в этом списке. Вопрос как раз в том, как лучше. Хорошо бы иметь конечно фильтр только на непомеченные на удаление элементы
SiMazx 4 - 08.05.2004 11:09 | (2)Ой-вей... Шо ви говорите... То есть если у меня справочнику номенклатуры подчинен справочник единиц, и для одного товара я удалю из единиц штуки, они удаляться и у остальных товаров?
SNake 5 - 08.05.2004 11:16 | SiMazx, пускай на примере Единиц: у товара Соль есть список подчиненных ему ЕИ -кг и г, их просмотр идет из формы списка, необходимо удалить из списка кг, чтобы он не светился там как помеченный на удаление. Зачем его удалять у остальных товаров, ты что-то недопонимаешь?
Valery 6 - 08.05.2004 11:16 | Ясно. Непосредстенное удаление в рабочей базе плохо см.(2). Тогда необходимо принять вариант 1. менять подчиненность. По опыту могу сказать что удалять из базы что-либо хреново. пускай элемент остается помеченным на удаление, но висит в базе, таким образом остаются следы работы пользователя, иначе концов не найдешь в нужный момент.
SNake 7 - 08.05.2004 11:30 | Valery, кидать его в к-нить папку, типа "#Удаленные"? Вариант, спасибо за ответ
Valery 8 - 08.05.2004 11:43 | В своем первом вопросе ты уже дал ответ. От того что переместиш элемент в другую папку, подчиненность не изменится. Создаешь элемент справочника Механизмы н-р "удалено" и при удалении какого нибудь элемента подчиненного справочника просто меняешь Владельца на "удалено".
kvm 10 - 08.05.2004 23:37 | А что, спики и таблицы значений уже не нравяться. Например в ТиС 8.7 у номенклатуры есть в форме маленькая табличка, в которой в том числе есть и подчиненные справочники. Если нажать кнопку удалить, то он из списка исчезает:) А в базе висит помеченным. И никаких проблем.


Периодический реквизит - не периодический?? | База знаний | mista.ru

Периодический реквизит - не периодический??

Mohoshito
06.05.2004 16:11 		Есть справочник "ОС", в нем есть реквизит "НачислятьАмортизацию", число, т.е. на форме в виде галочки. Этот реквизит - периодический. Написал обработку, которая меняет значения реквизитов в справочнике, выбираю в списке спр-к ОС, в списке реквизитов: "Начислять амортизацию", обработка показывает, что он периодический, читает из МД. Дальше так:

Если (ПериодРекв = 1) Тогда //
Периодический = СоздатьОбъект("Периодический");
Периодический.ИспользоватьОбъект(СокрЛП(ВыбРеквизит),Спр.ТекущийЭлемент());
ТекущЗначРекв = Периодический.ЗначениеНаДату(ПериодДата);
КонецЕсли;

И вот что он мне пишет на строку, где стоит "ИспользоватьОбъект":

Периодический.ИспользоватьОбъект(СокрЛП(ВыбРеквизит),Спр.ТекущийЭлемент());
{\\*.ERT(80)}: НачислятьАмортизацию не является константой или периодическим параметром!

То ли лыжи не едут, то ли праздники во всем виноваты. :)
mszsuz
1 - 06.05.2004 16:21 		Наверняка это группа.


Можно ли приручить "дерево групп" в справочнике? | База знаний | mista.ru

Можно ли приручить "дерево групп" в справочнике?

At 05.05.2004 15:54 | Проблема заключается в следущем: Необходимо ограничить доступ в справочнике к группам. Я это сделал с помощью предопределённой процедуры <ПриВыбореРодителя()>. Все работает нормально, если пытаться проникнуть в группу через список(многострочную часть). Но не работает, когда для выбора используется дерево групп. Происходит это из-за того, что при выборе элемента в "дереве групп" не происходит позиционирование на этот элемент. Есть ли возможность исправить столь досадное недоразумение?
Rider 1 - 05.05.2004 16:23 | Убрать дерево
At 2 - 05.05.2004 16:32 | Других вариантов нету? А то жалко его... Красивое оно...
Rider 3 - 05.05.2004 16:35 | Еще один список сделать(без дерева) и открывать именно его.
At 4 - 05.05.2004 16:39 | Насколько я понял все варианты заключаются в том, что бы избавиться от дерева.. А "приручить" дерево все-таки никак не получится.
3ton 5 - 05.05.2004 16:47 | В формеСписка выбрать все элементы и(или) группы в список значений спЗнач, а далее ИспользоватьСписокЭлементов(спЗнач), но все равно будет гемор и в дереве группы остаются (но элементов в них нет - одни забавные значки), а так только (1)
At 6 - 05.05.2004 16:53 | Ок... лучше я дерево прибью!
3ton 7 - 05.05.2004 16:58 | (+5) кстати лучше воспользоваться пунктом (1), но вместо дерева подключить внешнюю компоненту 1C VisualTools (vtools), очень советую, там есть хорошее дерево (да и не только) :)
GrayT 8 - 05.05.2004 22:12 | (0)Как это не работает? Просмотреть все дерево конечно можно, но при выборе группы в дереве ПриВыбореРодителя прекрасно срабатывает. Или я чего то не догоняю?
At 9 - 06.05.2004 09:19 | (8) ага.. срабатывает. только немножко неправильно. при выборе группы в дереве не происходит позиционирование на выбираемом элементе справочника, т.е. мы работаем уже с новым элементом, а в справочнике текущим является другой.


Спр. Номенклатура "убрать повторы" | База знаний | mista.ru

Спр. Номенклатура "убрать повторы"

REM
02.05.2004 13:17 		1С Бух 4.46 Справочник Номенклатура
Повторы товаров, каждый создан копированием
Надо получить «сводный» остаток по товару
На одно наименование сделал
Можно ли организовать цикл по всему спр. , чтобы получить
Таблицу «Товар» – «Остаток»
Заранее благодарен за помощь
GrayT
1 - 02.05.2004 13:28 		А какие проблемы с циклом?
спр = СоздатьОбъект(\"Справочник.Номенклатура\");
спр.Выбрать();
Пока спр.ПолучитьЗначение()=1 Цикл
Если спр.ЭтоГруппа()=1 Тогда
Продолжить
КонецЕсли;
Если спр.ТипТовара<>Перечисление.ТипыНоменклатуры.Товар Тогда
Продолжить
КонецЕсли;
КонецЦикла;

Проблемы в другом....
Для чего повторы ищем?
REM
2 - 02.05.2004 13:41 		Пример справочника
Товар1 2шт
Товар1 6шт
Товар1 1 шт
Товар2 10шт
Товар2 12шт

А хочется получить ТЗ (или отчет) вида

Товар1 9шт
товар2 22шт
Сделал ТЗ, обрабатывается одно наименование (Товар1-ТекЭлем())
Хочу перебрать весь Спр????
REM
4 - 02.05.2004 13:59 		Ну давай возьмем 1с Бух 4.46 как платформу, и тогда что нам мешает в Спр иметь Остаток
GrayT
5 - 02.05.2004 14:03 		Ну по данному подходу я спорить не хочу - не интересно. А так, коль уж все равно сделал - у тебя есть ТЗ где несколько РАЗНЫХ товаров (элементов справочника) имеют ОДИНАКОВОЕ наименование. Загони в ТЗ Наименование и сверни.
Но в целом подход корявый, очень.....
GrayT
7 - 02.05.2004 14:12 		Идейку про што? Как в ТЗ один Товар1 получить - свернуть ТЗ по наименованию.
А остальное .... Тебе зачем остатки в справочнике?
REM
8 - 02.05.2004 14:15 		Чтоб "менегер" видел чего и скоко и программа не пускала товар в РНК
GrayT
10 - 02.05.2004 14:24 		(8)Для этого есть подборы, в которых расчитывается остаток. А как ты будешь остаток в справочник заносить? Запускать обработку перед выпиской РНК? А какая разница....
REM
11 - 02.05.2004 14:30 		А "подбор" это не СпрНоменкл... разве?
GrayT
12 - 02.05.2004 14:36 		Он родимый... Вот только остатки в справочнике храняться, а высчитываются в форме для подбора...
GrayT
13 - 02.05.2004 14:37 		см. Функция ОстатокНаСкладе(....
GrayT
14 - 02.05.2004 14:39 		А чтой то у вас так много товара с одинаковым именем... Ни как п разным ценам храните... Кстати "Сводный остаток" тебе мало поможет, списывать то один фих надо будет по разным товарам :(
REM
15 - 02.05.2004 14:49 		Списывать по разным, а вот для заказа было бы здорово
GrayT
16 - 02.05.2004 14:54 		Значит я был прав... Тернист будет твой путь.
Ты про заказ ни чего не говорил, говорил про РНК ;)
REM
17 - 02.05.2004 14:58 		Да я вообще то и про Остатки не говорил в принципе

ВОПРОС БЫЛ ПРО ТО КАК ОРГАНИЗОВАТЬ ОБХОД ЭЛЕМЕНТОВ СПРАВОЧНИКА (ЦИКЛ)
REM
19 - 02.05.2004 15:06 		Да обход я хотел сделать с удалением повторов
GrayT
20 - 02.05.2004 15:12 		Млин, я там натупил - поспешишь как говориться :(
ВыбратьЭлементы()
и ПолучитьЭлемент()
А с повторами. Щаз погоди..
GrayT
21 - 02.05.2004 15:22 		У тебя есть справочник номенклатуры, в котором есть товары с одинаковыми наименованием и реквизит Остаток. Нужно получить ТЗ где все будет свернуто по наименованию. Я все правильно понял?

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Без итогов;
|Товар = Справочник.Номенклатура.Наименование;
|ТипТовара = Справочник.Номенклатура.ТипТовара;
|Ост = Справочник.Номенклатура.Остаток;
|Функция Остаток = Сумма(Ост);
|Группировка Наименование без групп;
|Условие(ТипТовара=Перечисление.ТипыНоменклатуры.Товар);
|"
;
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
ТЗ=СоздатьОбъект("ТаблицаЗначений");
Запрос.ВЫгрузить(ТЗ);
427
22 - 02.05.2004 15:59 		Мдя .... а вот пусть (0) объяснит, на кой делали копирование и плодили записи в справочнике для одного и того же товара....

Есть ли в этом великий смысл или по дурости.... После этого можно искать пути исправления данной проблемы....
GrayT
23 - 02.05.2004 16:05 		(22) см 14,15 - Сдаеться мне, это партии......
REM
24 - 02.05.2004 17:08 		Не дурости ради, а токмо волею пославшей меня ГЛ.бухши
Предлагал сделать иначе - не прошло, теперь вот исхитряюсь. И не партии это, а вход по разной цене.
BorisG
25 - 02.05.2004 17:13 		Мда...
"Не дурости ради, а токмо волею пославшей меня ГЛ.бухши... И не партии это, а вход по разной цене."
Так партии это и есть... только зарплату то у твоей бухши стоит за это отобрать...
REM
26 - 02.05.2004 17:19 		Могу дать телефон директора
Про "Партии" Нету у нас такого слова
GrayT
27 - 02.05.2004 17:40 		(26)Да нет, ты с ним уж как-нить сам ;)
"Не тот глуп кто не знает, но тот, кто знать не хочет" (с)
427
28 - 02.05.2004 17:48 		Ну вот и все ясненько...

Главбухшу на рею ....
Прога в сад ....

Нанять знающего человека для организации нормального партионного учета ....

Вот только нужен ли он.... не проще ли по средней .....
kvm
29 - 02.05.2004 18:07 		По средней для торговцев - не хорошо. А партионный учет в бухгалтерии, уж извините, никакой. Там надо саиоиу счет писать и все документы переделывать. Другое дело, что плодить номенклатуру это очень плохо. Лучше сделать обработку, типа как в Закрытии месяца, которая будет делить партии.
427
30 - 02.05.2004 18:22 		Партионный учет в разрезе себестоимости (как у (0)) нужен только мелким лавочникам.....

При среднем опте он нах не нужен... Ибо в силу оформления документов задним числом там все равно туфта будет...

Партионный учет нужен в разрезе сроков годности партий, заводских номеров и т.д. Но в этом случае методика, примененная в ТиС... дает очень похабные результаты .... Нужно менять методику.... А это очень трудоемко и обновления тогда ..... в сад ...

На бухии делается достаточно легко... Изменения касаются привязок 41.1, прихода, расхода, перемещения и услуг сторонних организаций ... И закомментарить кусок в закрытии месяца ....
kvm
31 - 02.05.2004 18:32 		А потом обновить. Напоминаю: в отличии от ТиС, Бухгалтерию обновлять надо. НЕт, если программист свой, то лн все знает, а если приходящий, как я, например... Ну не помню я по строкам где что менял!
А проведение задним числом устраняется восстановлением последовательности.
Партии нужны в первую очередь для расчета прибыли, при учете по средней сам не заметишь, как попрут убытки.
Кроме того, есть такая организация МНС, или как он там называется. При проверке, хорошей, ессно, за нарушение учетной политики поимеют так, что мало не покажется.
skunk
32 - 03.05.2004 06:01 		а стоит ли бухшу пинать... ежили по чайнику ударили...

в энтом плане в ТиСе нормально сделали... почти нормально
427
33 - 03.05.2004 09:02 		"А потом обновить. Напоминаю: в отличии от ТиС, Бухгалтерию обновлять надо."

Достаточно сделать надпись... на бумажке.... Лично у меня пять пунктов... И обновление делается всего на 15 минут дольше... На автопилоте все... кроме переноса плана счетов... Вот он не объединяется на автопилоте..

"Ну не помню я по строкам где что менял!" ..... Однако ты .... птиса с дольшим клювом... А подписать изменения
// ФИО ДАТА Начало изменений
....
....
// ФИО ДАТА Конец изменений

Наверное, вера не позволяет.... Ну тогда помни все свои изменения....

"А проведение задним числом устраняется восстановлением последовательности."

Проведение задним числом СДВИНЕТ партии... И рентабельность по каждой партии - ЁК.... Ибо в маленьких лавках любят делать наценку от цены мизерной партии... А потом удивляются... Это самый больной вопрос в ТиС... Кстати, у меня в бухии заднее число не вызывает необходимости перепроведения - просто использован несколько иной механизм построения партий...

Ну и такой бред, в конце (31)

"Партии нужны в первую очередь для расчета прибыли, при учете по средней сам не заметишь, как попрут убытки."

Партии в опте и попрут убытки.... Ну, ну.... Скорее попрут убытки при партионном учете - когда сунут док задним числом... И цель партионного учета в опте - несколько иная...

"Кроме того, есть такая организация МНС, или как он там называется. При проверке, хорошей, ессно, за нарушение учетной политики поимеют так, что мало не покажется."

Учетная политика пишется организацией... И если ГБ дура.... то это навсегда...
Второй же тонкий вопрос в том, что половину тех пользователей, кто использует ТИПОВЫЕ ТиС и Бух и ТИПОВЫЕ правила переноса... можно иметь прямо сразу и сейчас... Ибо учет в ТиС ведется как правило, партионный... А в бухии нет партионного ... А выгрузка проводками... С себестоимостью партионной...

Так что грамотный инспектор эту фишку найдет сразу ... в бухии косяки ТИПОВОЙ выгрузки видно сразу - достаточно просмотреть ОСВ по счету .... и 15 штук для ГБ готовы к выписке ....
GrayT
34 - 03.05.2004 09:31 		(33)"План счетов не обновляеться автоматом". Чем плох такой подход?: Держу специальныю конфу, где от плана счетов оставил только то что изменил. Сперва (на промежуточной базе) объединяю со стандартом, а затем загружаю объединением "урезанную" с приоритетом загружаемой
REM
35 - 03.05.2004 10:48 		Народ! "А нет ли у вас закурить, а то так есть хочется, что и переночевать негде"Вопрос то был не в том кого на рею и тд.
"В чужой монастырь со своим уставом не ходят" Я на что пришел, то и имею.
Сделал конфу свою, без повторов, с периодикой и п.п. Не взяли, сказали "Бурундук -птичка, значит птичка"
GreyT, спасибо за запрос , еще не пробовал, потом отпишу.
Всех с праздником
С уваженьем... Тема НЕ закрыта... Ближе к теме пожалуйста
427
36 - 03.05.2004 10:59 		При добавлении партионного учета по товарам правился только счет 41.

Один из пунктов в памятке - довесить на 41 третье субконто... в обновлении перед накатом.... Это быстро.... А если изменений много - тогда (34)....
kvm
37 - 03.05.2004 23:29 		(33) Спасибо за комментарии. Серьезно.
У тебя пять пунктов, а у меня тридцать постоянных клиентов, у всех по пять пунктов. На бумажке получается плохо, да и где она, та бумажка. А комментарии я ставлю, только при серьезном изменении кода типовой помогает слабо. Но вопрос был не в этом. Мне платят по часам, и не поверишь, когда этих часов слишком много, клиенты обижаются. Поэтому я сказал, что лучше сделать дополнительную обработку.
kvm
38 - 03.05.2004 23:33 		(35) Выгрузи остатки в таблицу, сверни ее, отсортируй. Вот тебе и сводный остаток, если запрос (21) не нравится.


Сортировка справочника с символами "-"... | База знаний | mista.ru

Сортировка справочника с символами "-"...

User63 23.09.2004 15:00 | Обратил внимание, что в справочниках "Контрагенты", когда он отсортирован по наименованию, символ "-" не используется. База SQL, а в такой же базе DBF - все как и положено. Это правильно?
User63 2 - 23.09.2004 15:12 | Наименование типа: "М-Видео" (кавычек нет). Так вот, это наименование находится в списке наименований типа: МВхххх, М-Глобус в ряду наименований МГ... и т.д.
Рупор абсурда 3 - 23.09.2004 15:14 | Это неправильно ..., но бороться с этим не стОит ...
Рупор абсурда 4 - 23.09.2004 15:14 | (3)+ Т.е. игра не стОит свеч ...


8.0. Отбор в иерерхическом справочнике | База знаний | mista.ru

8.0. Отбор в иерерхическом справочнике

cons_adm 17.08.2004 15:31 | 1С предприятие 8.0.8.7 Форма списка справочника(иерарх). Имеется реквизит справочника - Для групп и элементов, индексированный. Программно устанавливаю отбор по этому реквизиту, типа: СправочникСписок.Отбор.МойРеквизит.Значение = ЗначРеквизита; СправочникСписок.Отбор..Использование = Истина; На элементы отбор устанавливается замечательно, а вот с группами - косяк. Все равно остаются в списке (хотя реквизит <> установленному). Нужно чтобы группы элементов тоже отбирались. Как быть?
44 1 - 17.08.2004 16:21 | Группы отбираються только при отключенном иерархическом просмотре
cons_adm 2 - 17.08.2004 16:33 | Плохо... :-( Получается, что при включенном иерархическом просмотре группами вообще игнорируется отбор? Верю - должен быть выход. или это недоделка 1с-ников?
44 3 - 17.08.2004 16:55 | Скорее всего это сделано сознательно. Представь, что элемент или группа, которые входят в отбор принадлежат группе, которая не входит в отбор - как их показать в иерархическом просмотре?


Программно узнать, введен ли документ на основании другого | База знаний | mista.ru

Программно узнать, введен ли документ на основании другого

Слеш 02.09.2004 17:10 | Можно ли реализовать сабж? Порылся в ЖКК - похоже, что нет.
Волшебник 1 - 02.09.2004 17:11 | При вводе на основании взводи флаг.
Сашуля 5 - 02.09.2004 17:33 | Как правило при вводе на основании в реквизит документа потомка :) пишется документ родитель. например, при вводе счета фактуры на основании, скажем отгрузки_материалов_на_сторону в реквизит счета фактуры ДокументОснование будет записан документ родитель. Вот этот то реквизит и проверяй, пустой он или нет.
IAm 6 - 02.09.2004 17:34 | 4 Нет, хотя проще не флаг ставить, а ссылку на документ-основание сохранять, тогда бдудет доступен метод ВыбратьПодчиненныеДокументы


Программно изменить время при проведении документа без сообщения | База знаний | mista.ru

Программно изменить время при проведении документа без сообщения

ЧеТоКакТо
25.08.2004 16:21 		Вопрос такой по 7.7:
Как сделать так чтобы при проведении записанного ранее документа не возникало сообщение "Время документа меньше точки актуальности. Существуют более поздние проведенные документы" и выбор "1. Провести задним числом. 2.Изменить время документа".
Галочки в параметрах бессильны
Методы АвтоВремяТекущее() и т.п. не помогают.
УстановитьВремя()-только для СоздатьОбъект(), а нужно в модуле самого дока.
Нажимать все время кнопку "ОК" напряжно так как доки проводятся зразу большой группой с пом обработки, поэтому палец отсохнет жать 100 раз на кнопку.
Проводить доки задним числом или изменить время на текущее-это непринципиально, но хотелось бы управлять этим.
Доки делают движения в регистрах, но за последовательность не стоит беспокоится.
Подскажите плз.
romix
2 - 25.08.2004 16:40 		ПриЗаписиПерепроводить();
АвтоВремяТекущее();
ПроводитьПослеТА()


Как установить отбор по значению в обычном журнале? | База знаний | mista.ru

Как установить отбор по значению в обычном журнале?

Diter 28.07.2004 14:52 | Дано - есть документ, у него есть реквизит. Этот реквизит прописан в графах отбора журналов документов При попытке установить отбор по этому реквизиту в обычном журнале ругается "Неправильный реквизит". В общем всё ОК. Как установить отбор по значению в обычном журнале? Только попрошу без издёвок, я действительно за всё время работы с 1С с такой ситуацией не сталкивался, поэтому попрошу поподробнее расписать технологию. Если это невозможно, то как выйти из такой ситуации - нужно, чтобы пользователь видел в журнале документов только те доки, движение которых произошло с определённого склада? Заранее спасибо P.S. Конфа ТиС старенькая и переписанная вдоль и поперёк.
Crew 1 - 28.07.2004 15:08 | (0) Добавь графу отбора в конфигураторе
Crew 2 - 28.07.2004 15:08 | (0)+ в обычном журнале ИМХО никак
Z1 5 - 28.07.2004 15:15 | В обычном журнале никак. Надо в общем журнале. Делай все тоже самое через общий журнал.
Crew 6 - 28.07.2004 15:20 | (3) Только что проверил добавил графу отбора по справочнику контрагенты. Вызвал общий журнал "Отбор по значению" - "Виды отбора" = Контра - "Значение Отбора"=Элемент справочника. Все работает.
Crew 9 - 28.07.2004 15:34 | (8) Ты ВнимАтельнО ответы читал? (2) и (5) А пробывал создавать графу отбора с значение ДокументА??? И не работает? И не выбирает определенные документ?
Z1 9 - 28.07.2004 15:34 | (8) Сделай в твоем общем журнале обязательный отбор. Т.е нельзя выключить отбор. И устанавливай отбор по своей графе отбора и будет тебе subj
Diter 11 - 28.07.2004 16:11 | ОК сделал всё работает, но вопрос - при выборе отбора по складу - вываливаются опять все виды доков. (9) - как это сделать?
Diter 12 - 28.07.2004 16:18 | Сделал не так как вы говорили, на Т1С идею подкинуи (или на 1С-ии я уже и не знаю). Теперь надо установить два отбора вместе (и по виду документа и по складу). Как?
Z1 13 - 28.07.2004 16:21 | (11) Запрети ручной отбор. В форме этого журнала пишешь Процедура ПриУстановкеОтбора(Зн1, Зн2) Сообщить("Так нельзя"); СтатусВозврата(0); КонецПроцедуры или можно по другому Процедура ПриОткрытии() ВидыОтбора(""); ................. КонецПроцедуры Ну можешь еще выборочно кому-то разрешать запрещать
Diter 14 - 28.07.2004 16:36 | (13) А можно установить два условия для отбора например отбирать документы вида РасходнаяНакладная у которых склад "Склад1"?
Crew 15 - 28.07.2004 16:49 | (14) Нет. Нужно писать свой отчет.
ws_mason 18 - 29.07.2004 05:09 | Заводишь в общем журнале колонку "Фильтр", тип "строка", длина > 99 (примерно). В эту колонку заносишь (для твоего случая): ""+ЗначениеВСтрокуВнутр(ТекущийДокумент())+"#"+ЗначениеВСтрокуВнутр(ТекущийДокумент().Склад) Примерно так. И отбор делаешь по этой фигне: ""+ЗначениеВСтрокуВнутр(ТекущийДокумент())+"#"+ЗначениеВСтрокуВнутр(ТекущийДокумент().Склад) Получается что-то типа составного фильтра. Причем лучше рассмотреть вопрос заполнения этой колонки из документа в процедуре ПриЗаписи() - больше гибкости в задани фильтра получишь.
ws_mason 19 - 29.07.2004 06:12 | В догонку http://www.sinor.ru/~my1c/knowhow/jur_otb.html


Как убрать сообщение "Провести задним числом?" | База знаний | mista.ru

Как убрать сообщение "Провести задним числом?"

SPMym 25.07.2004 23:52 | Делаю обработку проведения некоторых документов. Но все время появляется сообщение, которое справшивает как провести документ: задним или текущем временем. Как от нее избавится? Документы нужно проводить именно задним числом которым они записаны.
Волшебник 1 - 25.07.2004 23:52 | АвтоВремяТекущее()
SPMym 2 - 25.07.2004 23:57 | (1) В этом случае получится что документ будет проводится текущем временем. А мне нужно именно тем временем которым он записан, т.е. задним.
Demiurg 3 - 26.07.2004 00:00 | Может быть ПолучитьВремя()/УстановитьВремя()
Demiurg 5 - 26.07.2004 00:07 | ты программно проверяешь Проведен()?
Demiurg 7 - 26.07.2004 00:19 | (0) А ты сделай так :))) Процедура ПриИзмененииВремениДокумента(Док) СтатусВозврата(0); КонецПроцедур


не работает процедура как описана в учебнике | База знаний | mista.ru

не работает процедура как описана в учебнике

Алекс 20.07.2004 10:06 | Погогите начинающему Следую учебнику шаг за шагом, на первом споткнулся: Написал процедуру обработки документа ввода нового элемента справочника, ниже приведена моя, в учебнике точ такая же, но у меня не работает, в режиме 1С выдает: "процедура не обнаружена ОбработкаПроведения/Posting" Кто подскажет на чем я туплю? Процедура ОбработкаПроведения() СпрСотр = СоздатьОбъект("Справочник.Сотрудники"); СпрСотр.Новый(); СпрСотр.Наименование = ФИО; СпрСотр.Должность = Должность; СпрСотр.Оклад = Оклад; СпрСотр.ДатаПриема = ДатаПриема; СпрСотр.Записать(); КонецПроцедуры
3V 1 - 20.07.2004 10:16 | а ты где пишешь процедуру? в модуле формы документа или в модуле документа?
ChAlex 2 - 20.07.2004 10:19 | Процедура ОбработкаПроведения() должна находиться в модуле документа и для документа должен установлен хотя бы один из флажков - Бухгалтерский учет, оперативный учет или расчет
3V 3 - 20.07.2004 10:22 | (2) не правы, уважаемый, хватает только флага "Разрешить проведение документа" а на счет компонеты используемой при проведении, то это зависит уже от процедуры "ОбработкаПроведения"


Как получить количество реквизитов шапки документа ? | База знаний | mista.ru

Как получить количество реквизитов шапки документа ?

Kopyl 19.07.2004 11:08 | Как получить количество реквизитов шапки документа ?
Композитор 4 - 19.07.2004 11:17 | Для документа Реализация: КолРеквизитов = Метаданные.Документ("Реализация").РеквизитШапки();
Матрейя 5 - 19.07.2004 11:18 | Метаданные.Документ(ВидДока).РеквизитШапки() - возвратит количество


Возможно ли изменить панель инструментов для расходной накладной | База знаний | mista.ru

Возможно ли изменить панель инструментов для расходной накладной

Appon 14.07.2004 13:49 | Возможно ли изменить панель инструментов для расходной накладной.Конкретно интересует запрет копирования накладной. Ситуация такова. Написал я обработку автора накладной и соответственно запрет на открытие, тому кто не являеться автором.Но народ догадался что при копирование накладной ты становишься ее автором. Соответственно и просмотр возможен. Помогите кто может
Warlock_old 1 - 14.07.2004 14:04 | Беда не в панели инструментов (есть еще кнопка F9 для копирования). Это тебе поможет: Процедура ВводНового(ПризнКопирования) Если ПризнКопирования = 1 Тогда СтатусВозврата(0); КонецЕсли; КонецПроцедуры
At 4 - 14.07.2004 14:24 | Процедура ВводНового(<?>,) КонецПроцедуры Синтаксис: ВводНового(<ПризнКопирования>,<ОбъектКопирования>) Назначение: Предопределенная процедура при интерактивном вводе нового документа. Параметры: <ПризнКопирования> - признак того, что объект введен копированием. Число: 1 - объект введен копированием, 0 - просто новый объект. Данный признак может быть использован для анализа необходимости инициализации реквизитов нового объекта. <ОбъектКопирования> - объект, который был скопирован. Замечание: Данная процедура может располагаться только в модуле формы документа.


Количество строк табличной части документа >10000 | База знаний | mista.ru

Количество строк табличной части документа >10000

Fazer 02.07.2004 07:07 | Пишется нестандартная конфигурация и возникла необходимость ввода документов с количеством строк в табличной части больше 10000. Каждый раз править в DD размерность Lineno на N5 замучаешься. Как справиться с проблемой?
ChAlex 2 - 02.07.2004 10:04 | Лучше бить на документы по 9999 строк!. Все равно работать с таким документом смысла нет (любой бухгалтер пошлет все после первой тысячи строк!).
Fazer 3 - 02.07.2004 21:41 | В принципе, даже если размерность не править, то строки в документе все равно не теряются, но нарушается их порядок. Т.е. сначала идут строки с номерами 0 - это те, которые больше 9999, потом остальные. Можно при вводе добавить свое поле НомерСтроки, потом СортироватьСтроки и записать. Но я полагал что есть другой способ, просто увеличить размерность нумератора строк. Что касается разбивки документа на части, то это не очень удачный путь. Стоит задача импорта базы льготников собеса Xbase, по мере возможности на его основе обновить свой справочник льготников, те записи, которые не прошли обработку (не совпадает адрес, фио и пр.) дать обработать вручную. В конце месяца вывести в суммы компенсаций в исходный dbf.
427 4 - 02.07.2004 22:06 | В твоем случае надо выгрузить табличную часть дока в тз, отсортировать по значимому реквизиту (скорее всего это будет ФИО, затем адрес, затем еще что и загрузить обратно в табличную часть. А доки я все таки бы колотил на части. Например, по первой букве ФИО Док с ФИО -- Аххххх Док с ФИО -- Бххххх Док с ФИО -- Вххххх внутри сортировка по ФИО-адресу. Так людям будет понятнее. И при добавлении строки в док руками давал бы возможность вводить человека с фамилией только на эту букву (чтобы не кидали по докам) ... И еще - есть ограничение в количестве проводок в операции. 99999. Если ты будешь что либо формировать - учти это. К тому же если такой док будет проводиться - велика вероятность, что задержка будет значительной, и остальные юзеры не просто будут курить бамбук - они будут вываливаться по таймауту.
leosoft 5 - 02.07.2004 23:02 | А зачем все грузить в документ? Сделайте отдельный справочник для не прошедших и с ним работайте...


Как добавить строки в многострочную часть документа из другого документа? | База знаний | mista.ru

Как добавить строки в многострочную часть документа из другого документа?

Ars 31.05.2004 11:46 | Суть проблемы: Есть документ, который при расчете формирует несколько других документов на основе собственных вычислений, в том числе их табличную часть. Вот код: ОткрытьФорму("Документ.НарядБригадный#qq", NewFrmHandle); //Открываем новую форму NewFrmHandle.Приработок=Приработок; //Заполняем реквизиты шапки <---это работает ... //Заполнение табличной части for i=1 to grid_Бригада.КоличествоСтрок() do //grid_Бригада - исходная таблица NewFrmHandle.НоваяСтрока(); <-----А ВОТ ЭТО УЖЕ НЕ РАБОТАЕТ NewFrmHandle.Сотрудник=grid_Бригада.ПолучитьЗначение(i, "Сотрудник"); endDo; При выполнении метода НоваяСтрока() не происходит ровным счетом ничего. Это происходит очевидно из-за того, что имена реквизитов шапки соответствуют их полям ввода, поэтому проблемы с ними нет, НО КАК ДОБРАТЬСЯ ДО ТАБЛИЧНОЙ ЧАСТИ ДОКУМЕНТА если я знаю только идентификатор формы (NewFrmHandle)
SnarkHunter 1 - 31.05.2004 11:49 | Документ сначала нужно записать, после этого доберешься...
spock 2 - 31.05.2004 11:52 | Даже если документ будет записан добавить новые строки через контекст не выйдет... таким способом.
Stan from Piter 3 - 31.05.2004 11:52 | Заполнить, записать, открыть ...
spock 4 - 31.05.2004 11:54 | А подобная тема уже обсуждалась: http://www.forum.mista.ru/topic.php?id=2878
Ars 6 - 31.05.2004 12:05 | >Заполнить, записать, открыть Может возникнуть ситуация, что созданный таким образом документ будет не нужен в дальнейшем, т.е. его нужно будет только просмотреть. Поэтому и необходимо через контекст. Т.е. что, через контекст формы нельзя получить контекст документа???
spock 7 - 31.05.2004 12:08 | 2(6)Контекст документа получить можно, а вот добавлять строки нельзя... ну и некоторые другие действия подобного вида. А вот если ты откроешь документ модально, то сможешь добавить новые строки.
Asmody 8 - 31.05.2004 12:12 | А если вообще другим путем пойти? Передать в форму нового документа параметр, и обработать его в процедуре ВводНового()?
Композитор 9 - 31.05.2004 12:19 | (6) Зачем создавать и заполнять ненужный в будущем документ, если есть такая штука, как обработка?
lexa 10 - 31.05.2004 12:20 | Попробуй ЗагрузитьТабличнуюЧасть(). В типовой ТиС посмотри документ быстрая продажа.
Ars 11 - 31.05.2004 12:24 | >spock Модально к сожалению не подходит, т.к. документов формируется сразу несколько. >Композитор Ну, равновероятно он может оказаться и нужным :) >Asmody Да, это идея. Наверное так и придется делать. А вообще, почему ж так сделано-то, что строки нельзя добавлять, когда все остальное можно менять?
Композитор 13 - 31.05.2004 12:26 | (11) Дыры будут.
Asmody 14 - 31.05.2004 12:27 | (11) а куда добавлять строки? ИМХО, у тебя получается переменная типа "Контекст формы" читай "ссылка на объект форма" (грубо). А в форме у тебя неявно присутствует ссылка на объект типа "Документ". Кстати, в v8 эти понятия развели, чем очень облегчили понимание...
spock 21 - 31.05.2004 12:38 | 2(15)Так, ты читать умеешь? В примере из торговли используется технология заполнения ТЧ документ через СоздатьОбъект()... А (0) делает через ОткрытьФорму(). Разницу чувствуем? Согласен с (12) на 100%.
lexa 23 - 31.05.2004 12:44 | Да прошу прощения не въехал. Кстати я сам с подобным недавно мучился (мне то же самое pit советовал и то же не в тему). Тогда надо сформировать таблицу значений, аналогичную табличной части документа и передавать ее в качестве параметра (или элемента списка параметров) в ОткрытьФорму("Документ.НужныйДокумент", ТЗ) или ОткрытьФорму("Документ.НужныйДокумент", СписокПараметров), а модуле формы нужного документа в процедуре ВводНового() ЗагрузитьТабличнуюЧасть(ТЗ)


Автоподстановка номеров | База знаний | mista.ru

Автоподстановка номеров

statа 29.06.2004 15:38 | В последовательности выданных счетов-фактур последний документ (по дате) имеет один номер, при вводе новой сч-факт. стал подбрасываться другой номер, больший по значению и равный номеру счета-фактуры, выданной несколько месяцев назад + 1. В чем дело? Неужели каждый раз теперь придется вводить вручную? Было же все нормально...
laeg 1 - 29.06.2004 16:07 | Была сбита нумерация, кто то ввел номер документа СФ в ручную ... Нужно востановить нумерацию, тогда все будет ОК
stata 2 - 29.06.2004 16:30 | Ну а как ее восстановить? Поменять номера прошлых сч-факур нельзя.
Warlock 3 - 29.06.2004 18:48 | Штатными средствами - вряд ли... Разве что программным методом, но это чересчур геморройно..
NS 4 - 29.06.2004 18:53 | Префикс поменяй, да и всех делов.. Первый номер вобьешь вручную - дальше само попрет.
Домохозяйка 5 - 29.06.2004 18:57 | http://gendin.ru/faq1c/docnum.html


Как разместить документ между двумя другими?.. | База знаний | mista.ru

Как разместить документ между двумя другими?..

Львенок
11.05.2004 10:07 		Вопрос такой. Опять таки по экзаменационному заданию... Есть документы "Чек" разбросанные в пределах дня. Есть документ "ПриходнаяНакладная" созданный программно на их основе, приходующий на склад все товары проданные в "Чеках", находящейся где-то в начале дня. Есть документы "Перемещение", созданные также программно на основе "Чеков" и "ПриходнойНакладной" которые перемещает товар со склада в отдел где он был продан "чеком". По логике работы программы, "Перемещение" использует данные из регистров остатков, для определения возможности переместить товар и рассчета себестоимости перемещаемого товара, т.е. должен находиться после "ПриходнойНакладной", но до "Чеков". Чеки к моменту создания "Перемещения" уже существуют, "ПриходнаяНакладная" тоже должна существовать, иначе не будет хватать товара для перемещения.
Как наиболее просто сделать так, чтобы вновь создаваемые программно(!) документы "Перемещение" были дружно записаны после последней "ПриходнойНакладной" текущего дня, но до первого "Чека" текущего дня?
Можно, конечно, извратиться (как я и сделал за незнанием другого варианта) определить время последней "ПриходнойНакладной" за сегодня, и для каждого перемещения прибавить к нему одну секунду (при необходимости увеличить минуты и часы) и воспользоваться Док.УстановитьВремя(Часы,Минуты,Секунды);
А проще-то можно?
___
Искренне Ваш, Львенок.
Таня
1 - 11.05.2004 11:09 		Я также делала, но только у меня не 1 секунда прибавлялась а почему то сразу 10
Bzzzzz
2 - 11.05.2004 11:26 		Это задание, где документы должны создаваться программно обработкой?
Bzzzzz
3 - 11.05.2004 11:27 		Я использовал АвтоВремяНачалоДня()
Таня
4 - 11.05.2004 11:31 		Начало дня подходит только для Приходной накладной
Bzzzzz
5 - 11.05.2004 11:36 		Делаешь Запрос по регистру Продажи.
Создаешь документы Премещение (в начало дня).
Создаешь документы ПрихНакл ( в начало дня).
Программно проводишь все документы, в том числе и Чеки.
Львенок
6 - 11.05.2004 11:42 		(4) Самое обидное то, что все "ПриходнаяНакладные" формируются ТОЛЬКО в первом числе месяца (по заданию), т.е. АвтоВремяНачалоДня() подходит для всех "Перемещений", кроме(!) перемещений самого этого первого числа (потому что только в нем есть документ "Приходная...", который должен быть еще раньше)! И вот из-за этого одного особого дня, собственно и весь #$&^#@!..
Впрочем, сейчас в качестве эксперимента я вывернул логику работы программы на изнанку... и у меня сначала создаются (но не проводятся) все "перемещения" в начале дня, потом "приходы" тоже в начале дня. При этом проблем со временем нет... А потом все по очереди проводится, а заодно и последовательность восстанавливается (что тоже есть в задании)... Но это по прежнему удаление гланд через ж... а хочется красиво и элегантно...
___
Искренне Ваш, Львенок.
427
8 - 11.05.2004 13:13 		Охохохохо.... неверно построенный алгоритм формирования приходов задним числом ....
Львенок
9 - 11.05.2004 17:48 		(9) Дык я и не утверждал, что мой алгоритм верен, я просто не вижу принципиально иных алгоритмов и делаю так, как умею. Кстати, не ясно чего неверного-то? Результаты получаются вроде именно те, которые я ожидал.
Подскажи (намекни, уточни, тыкни пальцем) что не так, и как надо правильно, буду более чем признателен.
___
Искренне Ваш, Львенок.
Serg_bl
10 - 12.05.2004 04:03 		Как вариант, можно взять первый документ (который будет Приходная), второй (Чек), вычислить время первого и второго, и Перемещение вставить между ними.
Функция ПолучитьВремяДок(лДок)
Перем Ч,М,С;

лДок.ПолучитьВремя(Ч,М,С);
ВремяДок = С+М*60+Ч*3600;
Возврат ВремяДок;

КонецФункции //ПолучитьВремя
//--------------------------------------------------------
Процедура УстановитьВремяДок(лНужноеВремя,лНужныйДок)
Перем Ч,М,С;

ОстВрем = лНужноеВремя;
Ч = ЦЕЛ(ОстВрем/3600);
ОстВрем = ОстВрем - (Ч*3600);
М = ЦЕЛ(ОстВрем/60);
С = ОстВрем - (М*60);
лНужныйДок.АвтоВремяОтключить();
лНужныйДок.УстановитьВремя(Ч,М,С);

КонецПроцедуры
//--------------------------------------------------------
Процедура УстановитьВремяДокумента(ДокПер);

лДатаДок = ДокПер.ДатаДок;
Если лДатаДок <> НачМесяца(лДатаДок) Тогда
ДокПер.АвтоВремяНачалоДня();
Возврат;
КонецЕсли;
//если это первый день месяца, значит в начале дня есть приходные
//получим последний док приходную и следующий за ним товарный чек,
//а между ними запишем Перемещение

ДокПрих = СоздатьОбъект("Документ.ПриходнаяНакладная");
ДокПрих.ОбратныйПорядок(1);
ДокПрих.ВыбратьДокументы();
Пока ДокПрих.ПолучитьДокумент()=1 Цикл
Если (ДокПрих.ПометкаУдаления()=1) ИЛИ (ДокПрих.Проведен()=0) Тогда
Продолжить;
КонецЕсли;
ПоследнийДокПрих = ДокПрих.ТекущийДокумент();
Прервать;
КонецЦикла;

ПозДок = СформироватьПозициюДокумента(ПоследнийДокПрих,1);
ДокЧек = СоздатьОбъект("Документ");
ДокЧек.ВыбратьДокументы(ПозДок,);
Пока ДокЧек.ПолучитьДокумент()=1 Цикл
//перемещение запишем перед любым товарным чеком
//Если (ДокЧек.ПометкаУдаления()=1) ИЛИ (ДокЧек.Проведен()=0) Тогда
// Продолжить;
//КонецЕсли;

ПервыйДокЧек = ДокЧек.ТекущийДокумент();
Прервать;
КонецЦикла;
//получим время документов
ВремяДокПрих = ПолучитьВремяДок(ПоследнийДокПрих);
ВремяДокЧек = ПолучитьВремяДок(ПервыйДокЧек);
//запишем перемещение между ними
ВремяДокПер = (ВремяДокПрих+ВремяДокЧек)/2;
УстановитьВремяДок(ВремяДокПер,ДокПер);

КонецПроцедуры
//--------------------------------------------------------
Львенок
11 - 12.05.2004 09:27 		На самом деле в итоге у меня получился такой код (ничего _между_ не вставляется):
Процедура Выполнить()
// НачатьТранзакцию();
Если (КонМесяца(ВыбДата)>ПолучитьДатуТА()) Тогда
Сообщить ("Дата конца месяца больше даты ТА, рассчет будет произведен по дату ТА");
КонецЕсли;
ДатаНач=НачМесяца(ВыбДата); ДатаКон=МИН(КонМесяца(ВыбДата),ПолучитьДатуТА());

//--------------Запрос-------------------------------------------------------------
Сообщить ("Запрос к итогам...");
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ДатаНач по ДатаКон;
|Товар = Регистр.ПродажиТоваров.Товар;
|Отдел = Регистр.ПродажиТоваров.Отдел;
|Поставщик = Регистр.ПродажиТоваров.Поставщик;
|Количество = Регистр.ПродажиТоваров.Количество;
|Сумма = Регистр.ПродажиТоваров.Сумма;
|Функция КоличествоСумма = Сумма(Количество);
|Функция СуммаСумма = Сумма(Сумма);
|Группировка День;
|Группировка Поставщик;
|Группировка Отдел;
|Группировка Товар;";

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

ТаблИ=СоздатьОбъект("ТаблицаЗначений");
СписДок=СоздатьОбъект("СписокЗначений");

//--------------------- Перемещения -------------------------------------------
Сообщить("Формируем перемещения...");
Запрос.Выгрузить(ТаблИ,0,0);
ТаблИ.Свернуть("День,Отдел,Товар","КоличествоСумма");
ТаблИ.Сортировать("День+,Отдел+,Товар+");

Док=СоздатьОбъект("Документ.Перемещение");
Док.ВыбратьДокументы(ДатаНач,ДатаКон);
Пока Док.ПолучитьДокумент()=1 Цикл
Док.Удалить();//Это либо устаревший документ, либо вообще непонятно какой.
КонецЦикла;
Док.АвтоВремяНачалоДня();
Строк=ТаблИ.КоличествоСтрок();К=1;
Пока К<=Строк Цикл
ТаблИ.ПолучитьСтрокуПоНомеру(К);
День=ТаблИ.День;
Пока К<=Строк Цикл
ТаблИ.ПолучитьСтрокуПоНомеру(К);
Если (День<>ТаблИ.День) Тогда Прервать; КонецЕсли;
Отдел=ТаблИ.Отдел;
Док.Новый();
Док.ДатаДок=День;
Док.Откуда=Константа.Склад;
Док.Куда=Отдел;
Пока К<=Строк Цикл
ТаблИ.ПолучитьСтрокуПоНомеру(К);
Если (Отдел<>ТаблИ.Отдел) ИЛИ (День<>ТаблИ.День) Тогда Прервать; КонецЕсли;
Док.НоваяСтрока();
Док.Товар=ТаблИ.Товар;
Док.Количество=ТаблИ.КоличествоСумма;
К=К+1;
КонецЦикла;
Док.Записать();
СписДок.ДобавитьЗначение(Док.ТекущийДокумент());
КонецЦикла;
КонецЦикла;

//----------------------Закупка------------------------------
Сообщить("Формируем закупку...");
Запрос.Выгрузить(ТаблИ,0,0);
ТаблИ.Свернуть("Поставщик,Товар","КоличествоСумма,СуммаСумма");
ТаблИ.Сортировать("Поставщик,Товар");

Док=СоздатьОбъект("Документ.ПриходнаяНакладная");
Док.ВыбратьДокументы(ДатаНач,ДатаНач);
Пока Док.ПолучитьДокумент()=1 Цикл
Док.Удалить();//Это либо устаревший документ, либо вообще непонятно какой
КонецЦикла;
Док.АвтоВремяНачалоДня();

Строк=ТаблИ.КоличествоСтрок(); К=1;
Пока К<=Строк Цикл
ТаблИ.ПолучитьСтрокуПоНомеру(К);
Поставщик=ТаблИ.Поставщик;
Док.Новый();
Док.ДатаДок=ДатаНач;
Док.Поставщик=Поставщик;
Пока К<=Строк Цикл
ТаблИ.ПолучитьСтрокуПоНомеру(К);
Если (Поставщик<>ТаблИ.Поставщик) Тогда Прервать; КонецЕсли;
Док.НоваяСтрока();
Док.Товар=ТаблИ.Товар;
Док.Количество=ТаблИ.КоличествоСумма;
Док.Стоимость=ТаблИ.СуммаСумма*(100-Поставщик.Процент)/100;//Сумма - процент комисс вознагр
Док.Цена=?(Док.Количество<>0,Док.Стоимость/Док.Количество,0);
К=К+1;
КонецЦикла;
Док.Записать();
СписДок.ДобавитьЗначение(Док.ТекущийДокумент());
КонецЦикла;
//ЗафиксироватьТранзакцию();
//--------------Последовательность ------------------------------------------------
Сообщить("Восстанавливаем последовательность...");
Документ=СоздатьОбъект("Документ");

Документ.ВыбратьДокументы(МИН(Последовательность.Продажи.ПолучитьПозицию(),ДатаНач),);
Пока Документ.ПолучитьДокумент()>0 Цикл
Если (Документ.Проведен()=1) ИЛИ (СписДок.НайтиЗначение(Документ.ТекущийДокумент())>0) Тогда
Документ.Провести(0,1);
КонецЕсли;
КонецЦикла;
КонецПроцедуры


Как заполнить документ из отчета? | База знаний | mista.ru

Как заполнить документ из отчета?

exhibit
27.06.2004 13:00 		Необходимо заполнить документ из отчета, т.е двойной щелчок -запрос ввода количества-новая строка в документе
exhibit
9 - 27.06.2004 13:39 		Процедура ЗаполнениеДокумента(Количество,ТекРасшифровка)
Перем ТекстОш;
СпрНоменклатура= СоздатьОбъект("Справочник.Номенклатура");

Если МожноЗаполнятьТаблЧасть(ТекстОш,вКонтекст) = 0 Тогда
Предупреждение(ТекстОш, 60);
Возврат;
КонецЕсли;
СпрНоменклатура.НайтиЭлемент(ТекРасшифровка);
Номенклатура=СпрНоменклатура.ТекущийЭлемент();

ТипЦен=вКонтекст.ТипЦен;
Валюта=вКонтекст.Валюта;
Единица=вКонтекст.Единица;
УчитыватьНП=вКонтекст.УчитыватьНП;
УчитыватьНДС=вКонтекст.УчитыватьНДС;

вКонтекст.НоваяСтрока();
вКонтекст.Номенклатура = Номенклатура;
вКонтекст.Количество = КоличествоВосновные(Номенклатура, Количество);
Единица = Номенклатура.ОсновнаяЕдиница;
вКонтекст.Коэффициент = Единица.Коэффициент;

Если УчитыватьНДС = 1 Тогда
вКонтекст.СтавкаНДС = Номенклатура.СтавкаНДС;
КонецЕсли;

Если УчитыватьНП = 1 Тогда
вКонтекст.СтавкаНП = Номенклатура.СтавкаНП;
КонецЕсли;

Цена = глПолучитьЦену(Номенклатура, ТипЦен, вКонтекст.ДатаДок, Единица, Валюта);

глПересчитатьЦенуВДокументе(вКонтекст, УчитыватьНП, УчитыватьНДС, Цена, Валюта,ТипЦен.ЦенаВклНП, ТипЦен.ЦенаВклНДС);
глПересчетТаблЧасти(вКонтекст,"Цена");

КонецПроцедуры //ЗаполнениеДокумента

//******************************************************************************

Процедура ОбработкаЯчейкиТаблицы(Расшифровка,СтандартнаяОбработка,Таблица)

Перем Количество;

Если ТипЗначенияСтр(Расшифровка) = "СписокЗначений" Тогда
Номенклатура=Расшифровка.Получить("ТекРасшифровка");
Если ПустоеЗначение(Номенклатура)=0 Тогда
Если ВвестиЧисло(Количество,"Введите число",15,3)=1 Тогда
ЗаполнениеДокумента(Количество,Номенклатура);
КонецЕсли;
Иначе
глОбработкаРасшифровки(Расшифровка, СтандартнаяОбработка, Таблица)

КонецЕсли;

Иначе
СтандартнаяОбработка = 1;
Возврат;
КонецЕсли;

КонецПроцедуры

есть некоторые лишние куски с функциями - просьба не обращать внимание
exhibit
10 - 27.06.2004 13:43 		вКонтекст - переменная , при отркрытии ей присваевается из параметров, контекст документа, из которого открывали
Номенклатура- получена из расшифровки
Могу привести полный код, но вне больше 1200 строк

вКонтекст.Номенклатура = Номенклатура не присваевается значение, т.е.

вКонтекст.Номенклатура =""
427
12 - 27.06.2004 14:39 		Идея понятна... Но работать не будет....

-- документ м.б. закрыт....
-- таблица отчета активна, а форма м.б. закрыта....
-- новаяСтрока через контекст не работает

чтобы все это убрать, делай так

ОбработкаЯчейкиТаблицы
Параметр
ОткрытьФорму
ПриОткрытии
ПриПовторномОткрытии

В расшифровку ячейки клади СЗ - док, номенклатура, уникальнное значение для идентификации именно этого вызова

ОбработкуЯчейки в самом отчете не юзай - форму могут закрыть....
Используй ее в глобальнике

там вставка в начале

Если ТипЗначенияСтр(Расшифровка) = \"СписокЗначений\" Тогда
если Расшифровка.Получить(\"УникальныйИД\") = \"УникальныйИД\" тогда
ДД = Расшифровка.Получить(\"Документ\");
ОткрытьФОрму(дд,Расшифровка)
конецЕсли
конец

в документе
в процедурах ПриОткрытии и ПриПовторномОткрытии
делаешь анализ полученного параметра... и добавляешь строку, если надо...

ПриОткрытии - здесь сработает вставка, если документ закрыт
ПриПовторном - если документ уже открыт

надо вставить анализ на добавление номенклатуры второй раз - мало ли чего юзер натыкает


Как реализовать две табличные части в документе | База знаний | mista.ru

Как реализовать две табличные части в документе

evgen 23.06.2004 13:15 | Как реализовать две табличные части в одном документе в 7.7? Возможно уже поднимали тему - сорри
Тупой Мля 2 - 23.06.2004 13:21 | И не раз... В Яндексе в строке поиска набери "две табличные части" - тебе столько ссылок вывалится, читать - не пречитать.
gr13 4 - 23.06.2004 13:25 | http://www.mista.ru/articles1c/hare/article.74.html
gr13 5 - 23.06.2004 13:27 | http://1c.hippo.ru/clubmemb.html найди по поиску
gr13 6 - 23.06.2004 13:33 | http://www.forum.mista.ru/topic.php?id=359
Рупор абсурда 7 - 23.06.2004 13:34 | (3-6) С этим всё понятно уже ... А вот как реализовать ТРИ табличные части?
evgen 8 - 23.06.2004 13:35 | да вот нашел.. http://1c.realnet.ru/kuban/137262.html меня на собеседовании спрашивали =) умею ли я делать так вот - две части в смысле =) Решил посмотреть насколько енто сложно
gr13 10 - 23.06.2004 13:36 | http://www.forum.mista.ru/topic.php?id=1203
gr13 12 - 23.06.2004 13:37 | (7) и ты конечно знаешь как? (0) http://62.213.67.94/index.shtml?multitable


Перепроведение | База знаний | mista.ru

Перепроведение

Term2 22.06.2004 04:21 | В обработке документов стоит такой код Если Док.ПометкаУдаления() = 1 Тогда ИначеЕсли СписокНеПроводимыхДокументов.НайтиЗначение(Док.Вид()) = 0 Тогда Сообщить("Проведение "+Док); Если МонопольныйРежим() = 1 Тогда БИ.Рассчитать(, Док.ТекущийДокумент()); КонецЕсли; Если Док.Провести() = 0 Тогда Возврат; КонецЕсли; КонецЕсли; Интересуют следующие 3 стрики Если МонопольныйРежим() = 1 Тогда БИ.Рассчитать(, Док.ТекущийДокумент()); КонецЕсли; Для чего это? И изменятся ли итоги, если пероепроводить не в монопольном режиме?
Warlock 1 - 22.06.2004 08:41 | В теории такой командой должно рассчитывать итоги не зависимо от режима. Я так думаю, что в документах тоже где-то есть проверка на монопольный режим, и, в зависимости от проверки, используется или нет переменная БИ... Хотя все это странно и определенной логики я здесь не вижу...(не исключено, что она есть, надо копать глубже)
SnarkHunter 3 - 22.06.2004 08:59 | Обработка-то что делает?
Term2 4 - 22.06.2004 09:31 | (3) Перепроведение всех документов за указанный период
Asmodeus 5 - 22.06.2004 10:14 | А кстати, в тему... Я слышал, что одним из возможных решений перепроведения (восстановления последовательности) является создание бота, который будет при отставании ГП от ТА потихоньку перепроводить документы один за другим от ГП до ТА. Вопрос вот в чем: есть ли здесь какие-то "подводные камни", которые надо учитывать при написании такой программки? И как лучше ее использовать (как новый сеанс некоего пользователя или просто повесить в глобальном модуле на обработку ожидания)?
mszsuz 6 - 22.06.2004 11:10 | (0) Подтягивает итоги на тек. документ, чтобы остатки быстро получать. (5) Нету смысла восстановления ГП в фоновом режиме в течении рабочего дня. Получишь только доп.нагрузку на сервер при полном отсутствии гарантий того, что граница будет восстановлена и установлена в тот момент когда это потребуется.
Asmodeus 7 - 22.06.2004 12:04 | (6) Оно конечно так. :-( Смысл есть если рассматривать различные временные отрезки допустимости исправлений. Смотри, документы забиваются, затем исправляются - такова текущая работа и от этого никуда не денешься. Дата исправления (реально) колеблется, если рассматривать график распределения вероятности, с пиками в районе недели-двух назад (от текущего момента) и двумя-тремя последними днями. Проблема обычно в том, что изредка исправляются документы месячной, двухмесячной давности и более (например, остаток на начало года). Если недельные исправления вполне терпимы (например, для того, чтобы получить реальный отчет за прошлый месяц), то более ранние откидывают ГП слишком далеко назад, а каждый раз тратить время на восстановление нецелесообразно. Звучит логично?
mszsuz 8 - 22.06.2004 12:42 | (7) Читал, много думал ... Но не увидел как это пересекается с (5) и (6), а именно с "роботом по восстановлению ГП". У нас на предприятии Последовательность восстанавливается ежедневно по ночам в автономном режиме. Два/три месяца, если надо, за ночь успевают перепровестить, соответственно утром ГП практически всегда на ТА. Единственные случаи когда приходится делать это вручную - перед формированием "Книги покупок", в том случае когда ГП сбивается при внесении "последних штрихов к портрету".
Asmodeus 9 - 22.06.2004 13:02 | (8) *вздохнув*: Согласен, конечно... А если ночью, при проведении, документ не сможет провестись?


Перенос реквизитов документа | База знаний | mista.ru

Перенос реквизитов документа

SamS
18.06.2004 15:41 		При копировани документа пореквизитно, не удается назначить тип \"перечисление\" реквизиту с типом \"неопределенный\", и за тем установить аттрибут. Работает со всем, кроме перечислений, что делать?
Вот код:
Для х=1 по М.реквизитшапки() Цикл
Значен = докум.ПолучитьАтрибут(М.реквизитшапки(х));
Типз=ТипЗначенияСтр(Значен);
Если Типз <> ТипЗначенияСтр(спДокументов1.ПолучитьАтрибут(М.реквизитшапки(х)))Тогда
спДокументов1.НазначитьТип(М.реквизитшапки(х),Типз);
КонецЕсли;
спДокументов1.УстановитьАтрибут(М.реквизитшапки(х),Значен);
КонецЦикла;
It is me
1 - 18.06.2004 17:11 		Попробуй вместо:
спДокументов1.НазначитьТип(М.реквизитшапки(х),Типз);
следующее:
Если Типз="Перечисление" Тогда
Типз=Типз+"."+Значен.Вид();
Конецесли;
спДокументов1.НазначитьТип(М.реквизитшапки(х),Типз);


Вопрос по табличной части документа | База знаний | mista.ru

Вопрос по табличной части документа

UltraViolet 18.06.2004 13:26 | Народ, как сделать, чтобы при попадании курсора в определенную ячейку табличной части документа (тип - справочник), не раскрывался справочник, а выпадало мое меню? Проблема не в создании меню, а в замещении им формы справочника
Волшебник 1 - 18.06.2004 13:28 | В процедуре ПриНачалеВыбораЗначения вызвать СтатусВозврата(0)
Gavrila 2 - 18.06.2004 13:28 | Процедура ПриНачалеВыбораЗначения(<?>,) КонецПроцедуры Синтаксис: ПриНачалеВыбораЗначения(<ИдентЭлемДиалога>,<ФлагСтандОбр>) Назначение: Предопределенная процедура после выбора значения в форме выбора (выбор может быть инициирован в немодальном режиме интерактивно, при помощи элемента диалога с ''педалькой''). <ИдентЭлемДиалога> - идентификатор элемента диалога, которым инициализирован выбор значения. <ФлагСтандОбр> - флаг, изначально, при вызове процедуры равен 1, если в теле процедуры значение этого параметра поменять на 0, то стандартный процесс выбора значения не будет происходить. Замечание: Данная процедура может располагаться только в программном модуле формы.


Журнал | База знаний | mista.ru

Журнал

Sergey_ 17.06.2004 11:44 | Создаю обычный журнал к примеру ДоходРасход Документы - Доход и Расход В этих документах есть реквизит шапки Участник В экранной форме я хочу чтобы появилась графа участник в которой бы был Участник доков и Доход и Расход помогите пожалуйста заранее огромное спасибо Или как сделать общий реквизит для определенной группы доков???
Warlock 1 - 17.06.2004 11:54 | В журнале создать графу "Участник" и добавить в эту графу значения "Документ.Доход.Участник" и "Документ.Расход.Участник" и вывести графу на форму. Общий реквизит для группы сделать нельзя. Можно сделать общий реквизит и использовать его только в определнной группе.


Как быстро удалить документы? | База знаний | mista.ru

Как быстро удалить документы?

Tasha
16.06.2004 09:48 		здравствуйте. подскажите, пожалуйста, как dbf базу быстро очистить от документов. можно ли это сделать удалив dbf файлы? если да, то какие.
SnarkHunter
1 - 16.06.2004 09:51 		dh*,dt*,rg*,ra*
После этого ТиИ для чистки ссылок...
Tasha
2 - 16.06.2004 10:28 		удалять dbf файлы? остальные расширения не трогатьс таким началом?
в ТиИ галочки оставлять в выполняемых действиях?
SnarkHunter
3 - 16.06.2004 10:39 		И другие тоже...
При ТиИ поставь "Очищать ссылки"
SnarkHunter
7 - 16.06.2004 10:55 		Мдя... Протупил я, как обычно... Еще прибей 1sjourn.*, конечно же...
SnarkHunter
8 - 16.06.2004 10:56 		Если у тебя бухкомпонента, то там еще дополнительные файлики почикать нужно...
romix
15 - 16.06.2004 16:58 		(0) А можно и так:

док=СоздатьОбъект("Документ");
док.ВыбратьДокументы();
Пока док.ПолучитьДокумент()=1 Цикл
Сообщить("Удаляю: "+док);
док.Удалить(1);
док.ВыбратьДокументы();
КонецЦикла;


Допроведение документа | База знаний | mista.ru

Допроведение документа

Искатель 16.06.2004 17:13 | Кто как решал задачу допроведения документа(да я решаю атестационные задачи)? Хочется узнать мнения людей.
SiMazx 2 - 16.06.2004 18:23 | Для справки смотри в ЖКК - Провести, ГрупповаяОбработка...
SiMazx 4 - 16.06.2004 18:33 | (3)Вот и думай номер своей планеты в тинктуре... Внимательно посмотри на второй параметр в Провести(<Режим>,<Знач>)... И думай, как его можно использовать...


Непосредственное удаление документов! | База знаний | mista.ru

Непосредственное удаление документов!

wind_wail
15.06.2004 14:22 		Задача: сделать так, чтобы документ удалялся сразу из журнала документов без поментки на удаление. Нажал Del и документа нет.

Пробовал это сделать через предопределенную функцию глобального модуля:
1. Попытка сделать след образом:
Процедура ПриУдаленииДокумента(Докум,Режим)
Если (Докум.Вид()="ДокПоОтработаннымЧасам") тогда
Докум.Удалить(1);
КонецЕсли;
КонецПроцедуры

Результат:
Докум.Удалить(1);
{Глобальный модуль(5889)}: Не выбран документ!

Интересно как же это он может быть невыбран если условие Докум.Вид() успешно проходится. Ладно, читаю инструкцию, там написано что Удалить() можно применять только к объектам созданным с помощью СоздатьОбъект. Делаю след образом:
2. След попытка:
Процедура ПриУдаленииДокумента(Докум,Режим)
Если (Докум.Вид()="ДокПоОтработаннымЧасам") тогда
//Докум.Удалить(1);
МойДок = СоздатьОбъект("Документ");
Если МойДок.НайтиДокумент(Докум)=1 тогда
МойДок.Удалить(1);
КонецЕсли;
Сообщить(Докум);
КонецЕсли;
КонецПроцедуры

Результат:
МойДок.Удалить(0);
{Глобальный модуль(5892)}: Объект заблокирован: ЕДокПоОтработаннымЧасам ГЗ-0000001

Что ему теперь то не нравится?
Кто сталкивался с подобной проблемой помогите пожалуста!
Заранее признателен.
iceTiger
1 - 15.06.2004 14:35 		Блокировка. 1С уже его удаляет, а ты его еще раз хочешь удалить...
Сделай обработкой. Повесь на форму кнопку: "Удалить на века...", в нее передавай параметром текущий документ и сноси на здоровье... Только если этот док. уже где-то выбран - полезут бока...
Press
3 - 15.06.2004 14:49 		А как насчет галочки в конфигураторе?
wind_wail
4 - 15.06.2004 14:53 		(3) Если ты имеешь ввиду "Разрешить непосредственное удаление объектов",то она стоит.
(1) А как вызвать обратоку так, чтобы ее форма не открывалась ? или это нельзя сделать?
AlexMan
5 - 15.06.2004 14:54 		ОткрытьФормуМодально()
Рупор абсурда
6 - 15.06.2004 14:55 		Используй свой 2 вариант, только в добавь СтатусВозврата(0) ...
Press
7 - 15.06.2004 14:56 		И Сервис=>Параметры - Непосредственное удаление, тоже стоит?
iceTiger
8 - 15.06.2004 15:51 		(6) Просвети причем тут СтатусВозврата()... ;)
(7) Пимпочка не влияет на удаления в журналах, она лишь разрешает сносить связанные и помеченные на удаление объекты...
wind_wail
9 - 15.06.2004 15:51 		(6) Не помогло. Все то же самое.
(7) Эммм... не понимаю о чем ты, там нету такого.
(5) Спасибо. Но я наверно пойду другим путем. Попробую использовать процедуру ОбработкаОжидания :)
Press
10 - 15.06.2004 16:58 		(9)Сервис=>Параметры=>Общие - Режим удаления объектов (последняя строчка)
(8)Не понял на что там, эта пимпочка влияет, но условиям "зачачи" (0) она
удовлетворяет.
Орк
11 - 15.06.2004 20:36 		Процедура глобального модуля ПриУдаленииДокумента() вызывается
перед удалением документа и на время выполнения ее тела документ
блокируется. Т. е. к самому удалению не имеет никакго отношения.
Чтобы удалить документ из формы журнала нужно в форме повесить
кнопочку с вызовом примерно такой процедуры

Процедура УдалитьЗаявку()
Док=СоздатьОбъект("Документ");
Док.НайтиДокумент(ТекущийДокумент);
Док.Удалить(1);
КонецПроцедуры


Как запретить проводку документа | База знаний | mista.ru

Как запретить проводку документа

Aiuan 14.06.2004 15:40 | Как запретить проводку документа если не выбран ... склад например...
gr13 1 - 14.06.2004 15:43 | 1. сделай, чтобы при выборе склада появлялась кнопочка (была доступна) 2. при нажатии кнопочки провести- сделай проверку на наличие склада, и в случае отсутствия, возврат, с предупреждением
Crystalizer 3 - 14.06.2004 15:53 | в процедуре модуля документа "проверкаШапки" или "обработкапроведения" (но лучше в 1й: Если ПустоеЗначение(Склад)=1 Тогда глНеПроводить(Контекст,...); // посмотри такое название ф-ии в главном модуле // и вообще где в модуле док-та выз-ся такая ф-я КонецЕсли;
Crystalizer 5 - 14.06.2004 15:58 | метаданные: правая кнопка : модуль документа там все ф-ии к-е вызываются после "ок" первая выз-ся кажеца "обработкаПроведения" внизу кнопка с биноклем и текстом "проц" - выдаёт список ф-й для быстрого их нахождения
Психонутый ОРК 7 - 14.06.2004 20:44 | В модуле документа в процедуре ОбработкаПроведения() сл. код Если Склад.Выбран()=0 Тогда Предупреждение("Ах ты @#$%^&*((. Выбери склад"); НеПроводитьДокумент() //Здесь то и вставится фишка для проведения
SnarkHunter 9 - 14.06.2004 21:27 | Если база СКЛ, то методом Выбран в модуле проведения лучше не пользоваться...


Нули в номере документа, как их забабацат ? | База знаний | mista.ru

Нули в номере документа, как их забабацат ?

wind_wail 10.06.2004 14:40 | Добавил в конфигурацию новый документ, не могу никак добиться того чтобы в номере документа спереди стояли нули. Можно этого как-то добиться не прибегая к нумереторам, и не использую ухищрений ?
lexa 1 - 10.06.2004 14:42 | а номер документ у тебя текстовый или числовой
wind_wail 2 - 10.06.2004 14:46 | Строковый.
Valery 3 - 10.06.2004 14:48 | Код сделай текстовым
wind_wail 5 - 10.06.2004 14:51 | разрядность 10
Rom 6 - 10.06.2004 14:57 | В первом документе в номере пропиши нули (нумератор д/б текстовым). Все остальные номера пойдут с нулями...
lexa 7 - 10.06.2004 14:59 | попробуй в процедуре ВводНового() УстановитьНовыйНомер()
wind_wail 8 - 10.06.2004 15:26 | (7) сделал: Процедура ВводНового() УстановитьНовыйНомер("0000000000"); КонецПроцедуры Теперь каждому документу присваивается один номер. (6) не нравится мне такой подход, вводить то должен пользователь... но наверно придется смириться с этим.
Rom 9 - 10.06.2004 15:28 | (8) Сделай проверку - первый это документ в базе или нет. Если первый - рисуй нули, если нет - не рисуй.
wind_wail 10 - 10.06.2004 15:42 | (9) Идея хорошая, а как определить первый он или нет ? Ато перебор будет много временного ресурса жрать, причем в большинстве случаев зря.
Rom 11 - 10.06.2004 15:44 | ВыбратьДокумены(,) - Возвращает 0 или 1
lexa 12 - 10.06.2004 15:58 | (8)Процедура ВводНового() УстановитьНовыйНомер(""); КонецПроцедуры


Непосредственное удаление в 77 | База знаний | mista.ru

Непосредственное удаление в 77

Никола 09.06.2004 15:39 | У меня 65 тысяч не удаленных объектов в базе. Написал маленькую обработку по непосредственному удалению документов и справочников. Когда провел тестирование базы, документы опять востановились :(( Причем тем числом, которым проводил тестирование. Я наверное в тупике :((( Доки штатными методами 77 удалить невозможно, очень много ссылок. Как быть, может кто подскажет.
AlexP 1 - 09.06.2004 15:50 | Как по твоему - Для чего делается контроль при удалении отмеченных объектов? Если ты в своей обработке удалил все 65 тысяч объектов без такого контроля, а потом сделал проверку базы (с восстановлением отсутствующего объекта, если на него есть ссылка из другого объекта), то они у тебя естесссно восстановились. Не изгаляйся, сделай штатным методом.
Никола 2 - 09.06.2004 15:55 | так я два месяца буду удалять
Gavrila 3 - 09.06.2004 15:57 | поставь при тестировании очищать ссылки на несуществующие объекты :)


Метод УстановитьОтбор() в журнале. Как его использовать? | База знаний | mista.ru

Метод УстановитьОтбор() в журнале. Как его использовать?

Таня 04.06.2004 18:02 | не получается В документе есть реквизит (переключатель) создала объект Графа отбора ВидОперации и назначила ему этот реквизит, тип графы - "число" в модуле формы журнала пишу: ПриОткрытии() Если ТипЗначенияСтр(Форма.Параметр) = "число" Тогда УстановитьОтбор("ВидДоговора", Форма.Параметр); Почему не срабатывает? по идее мне надо при выборе из журнала видеть только те договора у которые реквизит = 1.
Таня 1 - 04.06.2004 18:02 | а, да, забыла добавить, что сообщает: УстановитьОтбор("ВидДоговора", Форма.Параметр); {Журнал.ЦенныеБумаги.Форма.ФормаСписка.Модуль(3)}: Неверное имя реквизита!
mszsuz 5 - 04.06.2004 18:20 | Пример с отбором в журнале одновременно по тре реквизитам можно посмотреть здесь: http://www.sinor.ru/~my1c/knowhow/jur_otb.html
lexa 8 - 04.06.2004 18:37 | (4) про свойство реквизита отбор - это я поторопился ( как всегда) - оно есть только у общих реквизитов документов а графу отбора надо добавить в ЖурналыДокументов - ГрафыОтбора
Alexxx 9 - 08.06.2004 22:13 | У меня такая проблема. Нужно из всех документов в журнале выбрать только два вида (например, Приходные накладные и Приемные акты). Процедура УстановитьОтбор("ВидДокумента") способна отобрать только один вид. Помогите, плииииз.
mszsuz 10 - 08.06.2004 22:21 | (9) "Дополнительный" журнал пробовал?
Alexxx 11 - 08.06.2004 22:27 | Нужно сделать это программно (нажатием на кнопку)
mszsuz 12 - 08.06.2004 22:39 | Дык по кнопке как раз и можно открыть этот "доп." журнал. ... Если не нравится доп.журнал, тогда сценарий обычный - заводи доп.реквизиты в доках и графу отбора по ним или общий реквизит с отбором, и прописывай туда общее значение для этих двух видов документов.
Alexxx 13 - 08.06.2004 23:13 | Журнал уже существует (обычный), где находятся 5 видов доков... А над вторым вариантом я уже подумывал. Буду внедрять.


Отбор документов по общему реквизиту и виду документа одновременно | База знаний | mista.ru

Отбор документов по общему реквизиту и виду документа одновременно

keyt 08.06.2004 12:21 | Неужели не существует в 7.7 простого способа сделать отбор по значению одного общего реквизита и одновременно чтобы были выбраны документы только одного вида? Не считая способа с созданием дубля общего реквизита в документе?
Gavrila 9 - 08.06.2004 12:37 | (0) Есть: 1. "Тип журнала" должен быть "Общий"; 2. Добавить графы журнала и в свойствах указать значения только по одному виду документа; ЗЫ: В типовой ТиС 7.7 для Украины это есть: Журнал "Договора"
lexa 10 - 08.06.2004 12:38 | (7) нет в ответе (2) , а в журнале (общем) отбор только по одному реквизиту, поищи по форуму были описаны разные технологии, но сводились примерно к твоему способу


Так возможны ли две табличные части.??? | База знаний | mista.ru

Так возможны ли две табличные части.???

BykovAG 02.06.2004 13:39 | Возможны ли две табличные части в докуметне? Суть в следующем. Необходима форма документа с двумя табличными частями В первой номенклатура, а во воторой ее спецификация, т.е. из чего состоит. Причем с возможностью добавления строк как в первую так и во вторую часть. И переходя по строкам первой табличной части чтобы менялась соответствеено и вторая. На чем всеже лучше и проще организовать вторую табличную часть??? У кого есть опыт поделитесь. На 8-ке конечно можно. Но там разберешься пока...
KALEX 1 - 02.06.2004 13:41 | ТЗ поможет. и кнопочки "Удалить", "Добавить". и автообновление формы
gr13 2 - 02.06.2004 13:41 | господи, посмотри по форуму, тут уже выясняли этот вопрос несколько раз.
gr13 3 - 02.06.2004 13:42 | (0) извини telepat.dll сломался, так в какой версии 1с ты хочешь 2 табличные части? если в 7.7, то (1)
Композитор 5 - 02.06.2004 13:53 | (0) В семерке - многострочная часть документа и ТЗ на форме.
BykovAG 6 - 02.06.2004 13:53 | О как вы быстро накидали... да конфа своя. Все что есть в форуме я видел. Но там нет связи между этими табличными частями а мне надо чтобы они были связаны...
Композитор 8 - 02.06.2004 13:54 | (6) Напишите функцию ПриСменеТекущейСтроки() и "повесьте" ее на форму.
lexa 9 - 02.06.2004 13:54 | создай подчиненный справочник и по кнопке открывай его
427 10 - 02.06.2004 13:59 | Номенклатура + спецификация... Производство ? Сделай через подчиненные справочники... или совмести табличные части в одном доке с разделением при показе.... Элементарно ведь делается...
BykovAG 11 - 02.06.2004 14:05 | (10) Объясни бестолковому :)) Как совместить две табличные части с разделением при показе???
BykovAG 12 - 02.06.2004 14:13 | С подчиненными справочникам не удобно в том плане что прийдется каждый раз добавлять спецификацию в ручную. А нужно ее выбирать. Поэтому справочники не д.б. подчиненными. Остается только через таблицы значений с хранением спецификации в служебном документе.
SiMazx 14 - 02.06.2004 14:33 | Не проще ли дать человеку Дикого Зайца? http://www.mista.ru/articles1c/hare/article.74.html
romix 17 - 02.06.2004 20:50 | (0) Я в таких случаях использую присоединенный \"дочерний\" документ. В многострочной части - реквизит, у которого тип скажем \"Документ.Спецификация\". Повесь на форму кнопарь Спецификация. Юзер нажмет - ему должна открыться спецификация по данной строке.
427 18 - 02.06.2004 21:24 | Не надо плодить лишних сущностей.... Их и так достаточно... В случае (0) можно сделать все в одном доке в табличной части...
romix 19 - 03.06.2004 19:54 | (18) А если надо несколько значений (заранее неизвестно какое число) прикрепить к одной строке? Например, в счете есть строка Материалы, а в прикрепленной к строке счета спецификации - какие именно материалы. Список значений не катит, т.к. длина строки до 100. Да и нехорошо это - в блоб-полях куски базы держать...
Asmody 20 - 03.06.2004 20:02 | идеологически правильнее делать как в (17), но иногда возникают моменты, когда надо сделать быстро, тогда и вариант с большой ТЗ завернутой в текст подойдет
Asmody 22 - 03.06.2004 21:30 | (21) не люблю я такие разговоры. на поверку, чаще всего и приходится разгребать. за неторопливыми. которые сначала наобещают, потом лабуду слепят неторопясь, а потом... ну не важно.
romix 23 - 04.06.2004 00:39 | (22) :-) да так даже и не быстрее... Обработка дочернего документа - строк 5 (создание, если его еще нет, и открытие формы). А с таблицей - строк кода значительно больше.
wt 24 - 04.06.2004 11:21 | http://1c.hippo.ru/clubmemb.html Там в поиске набрать "BMA" без кавык. Смотреть "Пример документа с двумя таблицами". Очень красивое решение. Спасибо BMA.


cvvПроведение документов НЕ используя СТАНДАРТНЫЕ средства 1С | База знаний | mista.ru

cvvПроведение документов НЕ используя СТАНДАРТНЫЕ средства 1С

be-may
02.06.2004 09:29 		Здравствуйте. Первый раз на вашем форуме.
В настоящее время назрело решение уйти от стандартного проведения документов в 1С.
Имеется сетевая 1С SQL версии (7.7.). В базе работает около 100 пользователей (около 30 постоянно создают или модифицируют существующие документы). В связи с этим в базе периодически случаются практически мертвые транзакции.
Необходимо переписать проведение документов на чистый SQL.
Может кто ни будь сталкивался с подобной проблемой и может описать алгоритм такого проведения?
SiMazx
2 - 02.06.2004 09:38 		Что значит перевести проведение в чистый SQL? Напрямую в SQL-таблицы планируешь писать?
VladZagorsky
3 - 02.06.2004 09:44 		2be-may: А ты представляешь сколько в 1С связанных таблиц?????

P.S. А не подумать ли тебе о "восьмерке"?
be-may
4 - 02.06.2004 09:46 		(1) - Не все так плохо. Половина отчетов уже переписаны на SQL.

(2) - Да. Напрямую. Хочу попробовать.По сути проведение, что это? Запись в журнал(ы), проведение по регистрам, бух. итоги.. Что еще? Индексирование?
be-may
5 - 02.06.2004 09:48 		(3) У нас 7.7. полностью переписана. От базовой остались "рожки да ножки".
SnarkHunter
6 - 02.06.2004 09:56 		(5)Делали... Но только подготовку к проведению (формирование списка движений) на чистом SQL, само проведение - штатными методами 1С...
sss
7 - 02.06.2004 10:11 		если делать запросы на изменение и получение данных напрямую к базе, зачем 1С вообще? - стандартные объекты не используются, а формы лучше в VB или Delphi рисовать
BorisG
9 - 02.06.2004 10:27 		Не... вопрос не здравый ;-))
SiMazx
10 - 02.06.2004 10:31 		(8) md он и в Африке md... Вместо dd в SQL - dds...
(7) ню-ню...
be-may
11 - 02.06.2004 10:33 		(7) - Зачем изобретать велосипед?
В 1С все уже есть (формы документов). Плюс не нужно обучать пользователей.
Т.е. по сути 1С использовать как внешний интерфейс доступа к SQL базе.
А по существу! Кто-нибудь действительно пробовал заниматься подобным?
Кто-нибудь разбирался с механизмами, запускающимися при проведении документов?
Затраты на разработку окупаются за счет увеличения производительности...
SnarkHunter
12 - 02.06.2004 10:35 		Увеличение производительности будет заметно только на тысячах движений по документу...
DimG
13 - 02.06.2004 10:38 		у меня есть мдшник конфы где сделано нечто подобное, писал не я. Просто стырил в одном месте в целях образования. Пишите на мыло. Пришлю. Только, возможно, не сегодня, и не завтра т.к. в коммандировку еду.
sss
14 - 02.06.2004 10:38 		Основа конечного приложения - плоская таблица. Пусть независимая от СУБД,
пусть с метаданными и методами, но плоская и тупая.
Например, 1С-программист ничего не знает о реляционной модели. Он оперирует
действительно объектами, максимально приближенными к предметной области
(учет и анализ). Например - иерархический справочник (дерево). Да еще с
поддержкой истории изменения атрибутов. Или - многомерный накопительный
регистр. Накапливает ресурсы в разрезе аналитик. Или документ - допустимы
вложенные таблицы (документы). Понятно, почему создание простого склада на
1C - это день работы. Реляционная схема хранения создается автоматически,
пусть неоптимально, тормознуто (есть над чем работать), но суть в том, что
реляционная модель чрезвычайна бедна для отображения реальных понятий учета
и анализа.

переходя на прямой доступ к данным вы отказываетесь от стандартных механизмов системы(неважно какой: 1С, Аттейна Аксапты). Ссылочной целостности в этих системах не предусмотрено (точнее на уровне приложения). Следовательно ее надо реализовывать самому.
Вопрос чем это отличается от связки Oracle + Forms или Interbase + Delphi?
SnarkHunter
15 - 02.06.2004 10:45 		(14)Извлечение данных ничем не нарушает ссылочную целостность, значительно повышая, тем не менее, производительность...
sss
16 - 02.06.2004 10:53 		"Извлечение данных ничем не нарушает ссылочную целостность, значительно повышая, тем не менее, производительность... "
да, но большинство проблем то при проведении, т.е. при ЗАПИСИ
be-may
17 - 02.06.2004 10:57 		(14) Не буду спорить.
Речь несколько не о том.
Задача не стоит 'с нуля'. Есть готовая работающая база. Существует проблема в транзакциях в этой базе. При обработке проведения выполняется куча проверок. Из некоторых документов при проведении формируются другие. Все это перенести из 1С куда-то еще ..?! (Why? I do not know.. )
На SQL необходимо перенести только модификацию таблиц, т.к. это действительно выполняется быстрее (Не голословно. Проверено. Например, для некоторых отчетов производительность в 100-150 раз выше)
SnarkHunter
18 - 02.06.2004 10:57 		Связка "подготовка данных для проведения при помощи SQL" + "проведение штатными средствами 1С" прекрасно работает, существенно ослабляя остроту проблемы "ожидания транзакции"...
SnarkHunter
19 - 02.06.2004 10:58 		(17)Как связаны "модификация таблиц" и уменьшение времени формирования отчетов?
be-may
20 - 02.06.2004 11:23 		(18) - На практике?
(19) - Согласна. Ни как.
Подумалось, что по аналогии: "обращение к регистру через 'запрос' (стандартно)" - и - "обращение через SQL запрос"(через "1cpp.dll")
Z1
21 - 02.06.2004 12:06 		(20) Отчеты и расчет данных для проведения через sql запросы делай.
Само проведение лучше оставь 1с.
Почитай у Муму и toypaul
Опиши свою конфигурацию : операц система, sql, сеть, сервер есть ли терминал и.т.д.( чем подробней тем лучше )
Сейчас достаточно много хорошего железа за счет которого очень быстро и достаточно эффективно можно решить твои проблемы
SnarkHunter
22 - 02.06.2004 12:11 		(20)Естественно на практике...
Z1
23 - 02.06.2004 12:28 		(17)
Цитата "При обработке проведения выполняется куча проверок." - (ИМХО)
проверки лучше поставить ПриЗаписи, режим документа ПриЗаписиПерепроводить(1).
Цитата "Из некоторых документов при проведении формируются другие." - (ИМХО)
лучше моделировать тем или иным способом документ с несколькими многостроч.
частями чем при проведении одного документа проводить другие.
be-may
24 - 02.06.2004 13:28 		(23) - А при записи документа таблицы не блокируются? Тем более с последующим перепроведением. Насчет многострочной части. Такой возможности нет, т. к. это повлечет за собой очень большие изменения в конфигурации и работе фирмы.
(21) - Все основные отчеты переписаны на SQL. До расчета данных для проведения дело пока не дошло, но это хорошая идея. За неё спасибо. (Интересно , а отмена проведения? Это размышления по ходу...). Вообще дело не в конфигурации железа. ОС- Advanced Server, SQL - 8.0, Citrix, 100 Mb-ая и гигабитная сеть, есть рабочая база в основном для \'активных\' пользователей, копия по вчерашний день.
P.S. Кто такие Муму и toypaul? toypaul - http://1csql.udmnet.ru/???
SnarkHunter
25 - 02.06.2004 15:58 		(24)Да, toypaul - это http://1csql.udmnet.ru
Z1
26 - 02.06.2004 17:12 		(24) Citrix и sql на разных серверах или на одном?
Что такое SQL - 8.0 я не знаю.
При записи документы также блокируются.В любой момент времени только один домумент может записываться (проводиться ) и в этот момент клиент 1с ( приложение 1с) ведет себя ну очень некоректно плохо. Особенно это проявляется
в Citrix или терминале при большом количестве пользователей.
Спасает от этого моя multex_1c лежит на hippo. Будут вопросы по ней пишите.
Отмена проведения много времени не занимает - бывает правда в "плохих"
конфигурациях такое наворотят приотменепроведения - но это очень редкий случай.
Поверь конфигурация железа сервера , настройка ОС, сеть очень много
значат особенно для работы 1c в cязки с SQL.
romix
27 - 02.06.2004 20:43 		(0) 1С, как вы понимаете, при проведении документа делает
ни что иное, как модифицирует SQL таблицы. Что изменится от того, что вы станете делать ТО ЖЕ САМОЕ напрямую? Ну может вдвое выростет производительность за счет отказа от ODBC - но вашу проблему надо решать более кардинально, а не пытаться "оптимизировать пузырьковую сортировку".

Zl абсолютно прав - нельзя из дока при проведении создавать другие доки и лучше не выполнять там никакие проверки. Все это тормозня, а другие юзера в это время ждут завершения транзакции. Все такие вещи надо делать в ПриЗаписи().
Asmody
28 - 02.06.2004 22:59 		(0) а БР не пробовали? (http://www.vtools.ru/fastreg.htm)
be-may
29 - 03.06.2004 10:20 		(26)Citrix и sql на одном сервере. Ms. SQL server 2000, версия SQL 8.00.
Цитата: \'Поверь конфигурация железа сервера , настройка ОС, сеть очень много
значат особенно для работы 1c в cязки с SQL\'. -> Все это проверено и перепроверено. Этим занимались сис. админы. Поверьте, вопрос бы не стоял так остро, если бы не были использованы другие способы(в плоть до покупки нового сервера). Под Citrix-ом работает ограниченное число пользователей(только те, кому \'ну очень\' надо (4-5 человек))

(27) \'..но вашу проблему надо решать более кардинально..\' А как бы её решили Вы?
Можно пообщаться вне форума (e-mail).

(28) Спасибо за ссылку. Заинтересовало. Встречный вопрос. А вы пробовали?
Asmody
30 - 03.06.2004 13:10 		(29) на работающих проектах - не приходилось. А так, поиграться... Интересные идеи там. На Т1С была как-то большая ветка по БР.
romix
31 - 03.06.2004 20:23 		(29) Я бы исключил любые длительные обработки в модуле проведения.
Это требование есть в Желто-Красных Книгах.
Их надо вынести из модуля проведения куда-нибудь в ПриЗаписи() например.
Это резко уменьшит торможение и взаимоблокировки в SQL базе.

Насчет резкого (в 100 раз) ускорения отчетов - вы наверное их делаете простым перебором по документам или справочникам. А потом - бац - делаете на компилирующем языке. Естественно, это дает резкий рост производительности труда.

Почту отправить не удалось - попробую дома...
SnarkHunter
32 - 03.06.2004 20:41 		Ну все по полочкам разложил... Выдержат ли...
SnarkHunter
34 - 04.06.2004 05:53 		(33)Про какого суслика ты все время талдычишь?

А советы твои в (31) я бы поостерегся применять... Ибо вынесение кода в, к примеру, процедуру ПриЗаписи() ведет к одной весьма неприятной ситуации, когда у "тупых 1С-ников" широко открываются глаза, рот и прочие отверстия... При этом они начинают кричать: "Помогите!!!" и спрашивать: "Это глюк 1С???"...

По поводу запросов... Называть T-SQL компилирующим языком... Ну ладно, если нравится, то продолжай его так называть... А ускорение (в 100 раз) достигается совсем по другой причине - за счет более эффективного построения запросов к СКЛ-серверу, потому как трансляция "запрос 1С" -> "запрос СКЛ" может служить примером того, как не нужно писАть запросы... Почему это так реализовано - это другая тема...

Так что рекламируй книжки Болдырева - у тебя это лучше получается...
romix
35 - 04.06.2004 20:01 		(34) См. поиск по слову "суслик" на этом форуме. :-) Если тема сусликов Вам уже не интересна (и снарк - это не суслик, а особое животное), то ну и ладно. Sorry, если мои слова читаются как наезд или некорректный прикол.

Это советы из ЖКК. Насчет того, что новички не смогут - ну не смогут, позовут кого-нибудь... Но по любому это действие должно быть выполнено, прежде чем обращаться к базе SQL напрямую (а также писать ассемблерные вставки).

Слово T-SQL в этой ветке я не нашел - запрос может быть выполнен и средствами стандартного ANSI SQL-92. Я имею в виду обработку полученного массива на клиентской стороне - торможение может быть еще и из-за этого (если, например, перебирают документы в цикле, чтобы получить отчет).

Насчет "1С не оптимизирован для запросов" - очень может быть. Правда, я не особо сталкивался с неисправимым торможением - в 1С почти всегда можно извернуться штатными средствами (например, регистрами без ресурсов - это почти полный аналог "плоских" SQL-таблиц), и сделать быстро за счет большего размера базы.

Ветку с книгами Болдырева http://forum.mista.ru/topic.php?id=4865 завел не я, а Волшебник. Человек даже нарушил Правила своего же Форума "Не публикуйте материалы, нарушающие авторские и имущественные права, а также ссылки на них". А вы говорите, книги плохие. :-)
SnarkHunter
37 - 05.06.2004 06:46 		(35)Советы из ЖКК говоришь... Похоже разработчики типовой ТиС 9.хх обкурились этих советов, в результате чего программное и интерактивное проведение документов стало различаться словно небо и земля....

По поводу слова T-SQL... T-SQL = Transact-SQL, реализация фирмой MS стандарта ANSI SQL-92...

"Не сталкивался с неисправимым торможением"... Смотря какие объемы баз у тебя были до сих пор и сколько пользователей с ними работало... Когда-то и я не сталкивался...


программное создание и заполнение документа... ? | База знаний | mista.ru

программное создание и заполнение документа... ?

Crystalizer
07.06.2004 15:20 		нужно программно из обработки создать и заполнить документ...

//создаю
расх_накл = СоздатьОбъект("Документ.Т_РасходнаяНакладная");
// что в шапку заполнять пока не знаю
//хочу начать заполнять табличную часть...
расх_накл.Новаястрока();
расх_накл.тмц = Запрос.значениеУпорядочивания(1);
и тут он:
Не выбран документ!
SnarkHunter
1 - 07.06.2004 15:22 		Ну правильно... Сам документ-то создай...
3V
3 - 07.06.2004 15:24 		//создаю
расх_накл = СоздатьОбъект("Документ.Т_РасходнаяНакладная");
расх_накл.Новый(); //!!!!!!!!!!!
// что в шапку заполнять пока не знаю
//хочу начать заполнять табличную часть...
расх_накл.Новаястрока();
расх_накл.тмц = Запрос.значениеУпорядочивания(1);


Как правильно подготовить данные для отчета по подчиненным документам? | База знаний | mista.ru

Как правильно подготовить данные для отчета по подчиненным документам?

{}
04.06.2004 15:09 		Вижу след- ие способы, но все с недостатками:
1) Через Запрос.
|ДокА = Документ.ДокА.ТекущийДокумент, Документ.ДокВ.ДокОснование;
|ДокВ = Документ.ДокВ.ТекущийДокумент;
|Группировка ДокА;
|Группировка ДокВ;
Позволяет гибко настраивать отбор по условиям.
Но если ДокВ сформирован не на основании ДокА, а самостоятельно, то он в выборку вообще не пападает. Можно изменить порядок группировки, но тогда часть ДокА не попадет в выборку.
.
2) Выполнить несколько запросов (сколько видов документов), выгрузить в тз.
Думаю будет отчет выполнятся очень медленно.
.
3)Раскрутить цепочку ВыбратьПодчиненныеДокументы(). Для быстроты можно создать графу отбора в журнале документов и воспользоваться методом ВыбратьПоЗначению().
В этом случае придется делать реквизит отбора элементом спр- ка, т.к. условия выборки для отчета очень кудрявые.
.
Кто как выводит подчиненные отчеты?
lexa
1 - 04.06.2004 15:13 		посмотри обработку "деревоДокументов"
427
2 - 04.06.2004 15:17 		При определенных условиях она врет... Например, когда есть более одного родителя ...
.
Увы, за Х лет ее не поправили ...
{}
3 - 04.06.2004 15:19 		Смотрел. Сделано через ВыбратьПодчиненныеДокументы.
Для отчета по одному корневому документу больше и не надо.
А если отчет по множеству корневых документов? Долго. Вот и хотел запросы использовать.
427
4 - 04.06.2004 16:03 		запрос - долго...
Сделай через графу отбора - полетит..
Только правильно сформируй.
{}
5 - 04.06.2004 16:09 		427, с графой отбора есть одно но.
Насколькоя я понял, что бы использовать индекс для поиска в ф- ии ВыбратьПоЗначению() необходимо указать конкретное значение отбора.
Например я хочу строить отчет по док- ам с отбором по реквизиту: Поле1 и Поле2.
При этом должна быть возможность задать условие только для Поле1 или для Поле2.
В этом случае я уже не смогу воспользоваться графой отбора, т.к. надо указать конкретную пару Поле1 + Поле2.
lexa
6 - 04.06.2004 16:12 		Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Док = СоздатьОбъект("Документ");
Док.ВыбратьДокументы();
ВремДок = 0;
Род=0;
Пока Док.ПолучитьДокумент() = 1 Цикл
ВремРод = Док.ТекущийДокумент();
Если глЕстьРеквизитШапки("ДокОснование", Док.Вид()) = 1 Тогда
ВремДок = Док.ТекущийДокумент();

Пока ПустоеЗначение(ВремДок.ДокОснование) = 0 Цикл
Род = ВремДок.ДокОснование;
ВремДок = Род;
Если глЕстьРеквизитШапки("ДокОснование", Род.Вид()) = 0 Тогда
Прервать;
КонецЕсли;
КонецЦикла;
КонецЕсли;
Таб.ВывестиСекцию("Доки");
КонецЦикла;
Таб.ТолькоПросмотр(1);
Таб.Показать("Таблица", "");
pit конечно раскритикует
{}
7 - 04.06.2004 16:41 		Кстати, пользуясь случаем:
Стоит ли создавать графу отбора для всего пары документов ?
lexa
8 - 04.06.2004 16:50 		(7) 427 сегодня добрый изря советовать не будет, кто тебе мешает добавить поле где будет хранится поле1 + поле2 и по немк сделать отбор, или при вводенаосновании или при заполнении Докоснование, добавив поле кореньоснования, записывать его сразу


починить последовательность | База знаний | mista.ru

починить последовательность

Leonid_UA 03.06.2004 11:58 | Как починить последовательность в 1С 7.7 , а то не работает отчет ВЗАИМОРАСЧЕТЫ ???
Gavrila 1 - 03.06.2004 12:02 | Восстановление последовательности (Мену операцыы-> проведение документов...:)
sorrel 2 - 04.06.2004 22:11 | а как сделать автоматизацию данного процесса, например ночью
SnarkHunter 3 - 04.06.2004 22:16 | Например, написать обработку...
Волшебник 4 - 04.06.2004 22:17 | (2) http://www.anvil.spb.ru/php/forum1/index.php?tp=vievm&thind=53&th=16


Кто делал дерево документов на 8.0? | База знаний | mista.ru

Кто делал дерево документов на 8.0?

Волшебник 03.06.2004 19:07 | Есть ли подобная вещь на 8.0, аналогичная универсальной обработке на 7.7? Если есть, где ее можно найти, кто что посоветует?
Волшебник 1 - 03.06.2004 19:12 | V8 :: Структура подчиненности документов [16.04.04] http://itland.ru/rep/index.php?id=127 V8 :: Структура подчиненности документов [16.04.04] http://itland.ru/rep/index.php?id=148 V8 :: "Дерево документов" для "Управление торговлей" 10.1 [14.02.04] http://itland.ru/rep/index.php?id=90


Сбилось поле автонумерации | База знаний | mista.ru

Сбилось поле автонумерации

vk 01.06.2004 17:41 | При открытии документа Приходный кассовый ордер поле документа НомерДок начинает нумерацию со 100, хотя документов там давно уже за тысячу.. посмотрел в журнале - а там пользователь сам назначал номер и например вместо 00000210 стоит 210 и таких много, а дала сбой программа только вчера.. непойму - куда копать....?
Marinka 2 - 02.06.2004 09:38 | (0) Насколько мне известно в таких случаях помогаетперенумерация с того момента, когда произошел сбой...
yaret 4 - 02.06.2004 09:53 | Надо обязательно чтобы были ведущие нули, при чем в номере должно стоять не меньше четырехзначного числа.


как увеличить количество строк в табличной части документа? | База знаний | mista.ru

как увеличить количество строк в табличной части документа?

Annushka 01.06.2004 14:58 | Там по умолчанию 1000 строк, а мне нужно больше
GrayT 1 - 01.06.2004 15:04 | Ты о чем. Я уж испугался: Для сч = 1 по 1001 Цикл НоваяСтрока(); КонецЦикла; Знаешь сколько у меня строк получилось? А зачем столько надо?
Press 7 - 01.06.2004 15:31 | 9999, остальные нулями ставит
Annuska 8 - 01.06.2004 15:32 | ладно,попробую еще раз. как думаете,10000 строк тоже без проблем будет?
Композитор 9 - 01.06.2004 15:35 | (7) Тип поля НомСтроки - Число, длина - 4.
GrayT 15 - 01.06.2004 15:47 | У меня мысль была такая сперва, но смутила 1000, а не 999. Да чего уж. Подскользнулись :)


Время документа, откуда 1С его берет? | База знаний | mista.ru

Время документа, откуда 1С его берет?

Сергей 26.03.2004 13:24 | Есть 1С:Предприятие вер.7.7 21 релиз. На 5 машинах все нормально (98, ХР, на одной машине с ХР творится черт знает что - при записи документа, время документа устанавливается на 2 часа меньше системного (проверено время в BIOS, ХР, на сервере, проверена зона +5GMT. Команда time выдает правильное время, net time синхронизирует по серверу. Все по барабану. Где еще копать, господа хорошие?
NastyFrog 6 - 26.03.2004 13:41 | (0)А ТекущееВремя() что выдает?
327 8 - 26.03.2004 13:54 | Не умеешь ставить ХР ... не берись ....
Сергей 9 - 26.03.2004 13:55 | Забыл уточнить, что версия сетевая, если вдруг кто не догадался, с административной установкой, DBF, сервер Windows 2003, на клиенте ХР Prof. Ну это если уж быть совсем точным. И самое главное - на аналогичных машинах с аналогичной виндой все ОК, глюк вылез только на этой машине.
Сергей 10 - 26.03.2004 13:58 | для 327 спешал: сколько вас говорливых, если бы столько же умных, а ХР я уже больше сотни машин поставил с разообразным железом и софтом, может уважаемый 327 подскажет что такого хитрого в ХР, что от ее установки время в 1С стало кривым?
Сергей 11 - 26.03.2004 14:44 | доп информация - на этой машине стоит ICQ Lite Rus, на аналогичной в которой нет проблем аська отсутствует
ZOV1 13 - 01.06.2004 12:23 | У меня аналогичная проблема. Время вдруг сместилось на 6 часов вперед. Судя по дисскусии она закончилась ничем. Может все таки кото-то подскажет, что это за болезнь и как ее лечить?
ZOV1 18 - 01.06.2004 13:24 | Господа! Перестаньте нести хрень! =========================== В ручную это правиться. Но почему вдруг точка актуальности перескакивает вперед. Пользователи божаться, что ничего не трогали. А проблема возникает.
igorluk 24 - 01.06.2004 14:24 | 2(Сергей) А разобраться не пробовал. умный мужик наверное, такие коменты кидаеш. меняй время поочереди на полчас например, отключи синхронизацию с сервером ну и тд и тп...


Сохранение документа из модуля документа после проводки в 7.7 | База знаний | mista.ru

Сохранение документа из модуля документа после проводки в 7.7

keyt 01.06.2004 10:25 | Возможно это или нет? НЕ могу найти как это можно сделать. Похоже, что при проведении открыта транзакция и нет доступа к контексту текущего документа.
keyt 2 - 01.06.2004 10:29 | После проводки документа нужно, в зависимости от результата проводки поменять реквизит документа, и, соответственно эти изменения сохранить. Может это, конечно, и по-другому надо делать, просто я неправильно задачу ставлю ...
mszsuz 3 - 01.06.2004 10:32 | Все измененные в модуле проведения реквизиты документа сохраняются автоматически.


Ввод на основании... шо оно такое? // ламерский вопрос | База знаний | mista.ru

Ввод на основании... шо оно такое? // ламерский вопрос

Crystalizer 26.05.2004 23:02 | дали мне перенести документы из стандартной-базовой конфигурации Бухгалтерия для Украины в готовую для одной конторы. Вроде всё основное сделал но шеф потыкал - опа! ввод на основании не катит. что это такое - "ввод на основании" и как его _приделать_ ? В чём там суть в смысле программирования?
SnarkHunter 1 - 26.05.2004 23:07 | Новый документ заполняется данными на основании данных другого документа...
It is me 2 - 26.05.2004 23:18 | То бишь пример - приходная и расходная накладные - вещи принципиально различные в плане учета, но имеющие много общего в плане реквизитов. И сегодня (реально) клиент мой захотел сразу после ввода приходной мочь вводить расходную с тем же товарным составом нажатием одной волшебной клавиши ВвестиНаОсновании. Реализуется это следующим образом: открываешь документ в Конфиг., нажимаешь Ввод на основании и ставишь галочки, что на основании чего будешь вводить. Затем пишешь процедуру ВводНаОсновании (в модуле формы), в которой, собственно и будешь заполнять новый док, например: Процедура ВводНаОсновании(Док) Контрагент=Док.Контрагент; Док.ВыбратьСтроки(); Пока Док.ПолучитьСтроку()=1 Цикл НоваяСтрока(); ТМЦ=Док.ТМЦ; Конеццикла; КонецПроцедуры
Crystalizer 4 - 27.05.2004 10:35 | а теперь практика %) В свойствах документа указал "вводить на основании" таких-то документов (списание тмц/...). Добавил в модуль процедуру наполовину готовую. открываю полный журнал... Там у записи о моем документе в выпадающем меню (по правой кнопке) заблокирован пункт "ввод на основании". Почему? Как исправить?
SnarkHunter 5 - 27.05.2004 10:41 | Так и должно быть... Этот пункт будет активен, если ты укажешь что на основании твоего документа могут быть введены какие-то другие...
Crystalizer 6 - 27.05.2004 10:45 | SnarkHunter: опа... :) А тогда основанием для каких документов может быть "оприходование излишков"?
Crystalizer 11 - 27.05.2004 12:49 | Процедура не обнаружена: ВводНаОсновании/InputCausedBy а она есть! уже и в модуль и в форму пихал...
v-soft 12 - 27.05.2004 12:53 | А ты в какой документ ее вставляешь?
Crystalizer 13 - 27.05.2004 12:57 | эээ... в этот - "оприходование излишков"
v-soft 14 - 27.05.2004 13:00 | А надо в тот, который заполняется на основании. Например"Поступление контрабанды".
Crystalizer 15 - 27.05.2004 13:25 | японский ты городовой! :) я думал что когда вводишь то воод происход в обратную сторону - в выбранный документ %)
Crystalizer 16 - 27.05.2004 13:46 | далее по тексту... :) при выполнении процедуры "ВводНаОсновании" (Хвала!) вызываются процедуры из формы типа "УстРеквизитыШапки();" и тд. На них можно сослаться как-то из модуля -> Форма.Процедура ?
SiMazx 17 - 27.05.2004 13:52 | Из модуля проведения? А зачем?
v-soft 18 - 27.05.2004 13:57 | Так ведь Проц "ВводНаОсн" находиться в модуле формы, просто вызываешь и все, только непонятно зачем? Ты же на основании вводишь, если надо работать с реквизитами интерактивно то просто не заполняй их. Или ты имеешь в виду форму документа основания?


Повторное проведение документа | База знаний | mista.ru

Повторное проведение документа

Тутанхамон 26.05.2004 17:21 | Необходимо при сохранении документа ДД создать, записать и провести подчиненный док. Я сделал в ПриЗаписи() строчку Записать(); //записываем текущий, чтобы на его основании создать подчиненный далее следует алгоритм создания/записи/проведения подчиненного. В ПриОткрытии() есть ПриЗаписиПерепроводить(1); Модуль проведения ДД стартует дважды - как я понимаю, один раз в ПриЗаписи() по строчке Записать() и второй раз по кнопке #Записать? Провести?... Как избавиться повторного запуска проведения? Если сделать ПриЗаписиПерепроводить(0), то при записи изменений и отказе от проведения ранее проведенного документа движения регистра не будут соответствовать значениям в ДД (напр., в ДД списывается 6 шт. Товара, а регистры двигаю 3 шт.)
Valery 1 - 26.05.2004 17:29 | Если он проводится В ПриЗаписи Зачем кнопка ЗаписатьПровести
Тутанхамон 2 - 26.05.2004 17:37 | Это -0- не касается никак. ДД должен проводиться и интерактивно и программно. Я могу на кнопку навесить другую процедуру, из которой запускать ПриЗаписи(), но проблема -0- при это остается.
SnarkHunter 4 - 26.05.2004 22:25 | Проводи подчиненный в модуле проведения документа-владельца...
Тутанхамон 5 - 27.05.2004 01:41 | -4- В модуле проведения нежелательно. Ведь я должен подчиненный сначала создать. А что будет при распроведении владельца? Надо и подчиненный потом аккуратно удалять, все нюансы учесть... Решение, подсказанное на Территории: В ПриЗаписи(): ПриЗаписиПерепроводить(0); Записать(); ПриЗаписиПерепроводить(1); Просто и изящно. У меня сначала взгляд остекленел... Я к этой проблеме сделал три подхода на протяжении двух дней. Почувствовал какое-то разочарование в себе, неверие в свои возможности. Тупым обозвался... Но после прочтения ветки, запущенной Волшебником ("Как долго вы изучали..."), меня попустило :). Оказывается, некоторые нынешние звезды и Т1С и Волшебного форума тоже туго начинали. Так что решил пока дать отсрочку своей самоотбраковке... Классная ветка.
SnarkHunter 6 - 27.05.2004 05:54 | При "распроведении владельца" можно использовать ОбработкаУдаленияПроведения... Куда еще изящней...


Как получить Представлениевида числового реквизита документа? | База знаний | mista.ru

Как получить Представлениевида числового реквизита документа?

Rider
2 - 24.05.2004 10:38 		В документе есть числовой реквизит. Как получить его пользовательское представление. Для агрегатных типов данных ПредставлениеВида(), а как это получить для числового или текстового реквизита.
SnarkHunter
3 - 24.05.2004 11:09 		Название реквизита? Слово "Число"? Его длину и точность? Что именно?
Rider
4 - 24.05.2004 11:14 		То что пишется в поле синоним или комментарий реквизита документа.
SnarkHunter
5 - 24.05.2004 11:20 		Метаданные.Документ(Ид_Дока_Строка).РеквизитШапки(Ид_Рекв_Строка).Синоним
Метаданные.Документ(Ид_Дока_Строка).РеквизитТабличнойЧасти(Ид_Рекв_Строка).Синоним
Метаданные.ОбщийРеквизитДокумента(Ид_Рекв_Строка).Синоним

Вместо идентификаторов могут использоваться номера...
Rider
6 - 24.05.2004 11:32 		Спасибо конечно, но это очень неудобно. Я хотел написать глобальную процедуру которая бы выводила название реквизита документа, который незаполнен, при проведении документа. а при таком подходе надо знать название документа, табличная это часть или шапка и как получить тотже идентификатор реквизита.
lexa
8 - 24.05.2004 11:54 		//******************************************************************************
// глВсеРеквизитыДокументаЗаполнены(Конт,СписокРеквизитов)
//
// Параметры:
// Конт - групповой контекст (контекст документа)
// СписокРеквизитов - строка, в которой через запятую перечислены идентификаторы
// реквизитов (шапки или общие реквизиты документа)
//
// Возвращаемое значение:
// 1 - если все реквизиты заполнены правильно.
// 0 - если какой либо обязательный реквизит не заполнен
//
// Описание:
// Функция вызывается из модулей проведения документов и предназначена для
// проверки полноты заполнения обязательных реквизитов.
//
Функция глВсеРеквизитыДокументаЗаполнены(Конт,СписокРеквизитов) Экспорт

Если Константа.РазрешитьПроводитьБудущейДатой = 0 Тогда
Если Конт.ДатаДок>РабочаяДата() Тогда
глНеПроводить(Конт,"Нельзя проводить документ будущей датой!");
Возврат (0);
КонецЕсли;
КонецЕсли;

Пока СтрДлина(СписокРеквизитов)>0 Цикл
ПозЗапятой = Найти (СписокРеквизитов,",");
Если ПозЗапятой = 0 Тогда
ИдентРеквизита = СписокРеквизитов;
СписокРеквизитов = "";
Иначе
ИдентРеквизита = Сред(СписокРеквизитов,1,ПозЗапятой-1);
СписокРеквизитов = Сред(СписокРеквизитов,ПозЗапятой+1);
КонецЕсли;
Если ПустоеЗначение(Конт.ПолучитьАтрибут(ИдентРеквизита))=1 Тогда
ВидДок = Конт.Вид();
Если Метаданные.Документ(ВидДок).РеквизитШапки(ИдентРеквизита).Выбран()=1 Тогда
Объект = Метаданные.Документ(ВидДок).РеквизитШапки(ИдентРеквизита);

ИначеЕсли Метаданные.ОбщийРеквизитДокумента(ИдентРеквизита).Выбран()=1 Тогда
Объект = Метаданные.ОбщийРеквизитДокумента(ИдентРеквизита);

ИначеЕсли Метаданные.Документ(ВидДок).РеквизитТабличнойЧасти(ИдентРеквизита).Выбран()=1 Тогда
Объект = Метаданные.Документ(ВидДок).РеквизитТабличнойЧасти(ИдентРеквизита);

Иначе
глНеПроводить(Конт,"ВсеРеквизитыДокументаЗаполнены(): Неверный реквизит:"+ИдентРеквизита);
Возврат (0);
КонецЕсли;
ПредставлениеРеквизита = ?(ПустоеЗначение(Объект.Синоним)=0,Объект.Синоним,Объект.Идентификатор);
глНеПроводить(Конт,"Не заполнен реквизит """+ПредставлениеРеквизита+"""");
Возврат (0);
КонецЕсли;
КонецЦикла;

Возврат (1);

КонецФункции // глВсеРеквизитыДокументаЗаполнены()
427
9 - 24.05.2004 12:06 		(6) а ты точно знаешь, что этот реквизит должен быть заполнен?... Логика то в документе лежит...

особенно мне нравится, ... когда ты сообщищь о незаполненности реквизита, которого нет на форме (а такие есть в типовых) ...

Вот юзер то потрахается.... а потом некоторые особо нервные могут и этих... на букву п... подвесить с нервов то....

Формальный опрос возможен и ответ дал Снарк ....


Название документа в торговле | База знаний | mista.ru

Название документа в торговле

inter
15.05.2004 14:28 		Кто подскажет что нужно сделать в обработке для того чтобы в созданном документе "реализация" появилось наименование и оно отражалось в журнале.
Gavrila
1 - 15.05.2004 15:01 		(0) Вопрос можно ?
1. В какой обработке ?
2. Документ "реализация" - э то вид документа так?, а что значит появилось наименование (где появилось?, на форме, в заголовке?)
3. "оно отражалось в журнале" - оно исходя из того что такое "появилось наименование" ?
inter
2 - 15.05.2004 15:15 		Пожалуйста... 1)В личной обработке по автовыделению к концу дня прихода в разрезе налогового учета на основе проводной реализации.
2) Да.При создании нового документа в форме есть идентификатор НазваниеДокумента, но его нет в основных ревизитах шапки и непонятно как его установить.
3) Документ формируется проводится а в общем журнале все графы заполнены , кроме графы документ.
Gavrila
3 - 15.05.2004 15:22 		(2) НазваниеДокумента - реквизит диалога и устанавливается(заполняется) в модуле формы документа (не помню в какой процедуре: делаешь поиск в модуле формы документа и смотришь как).
Открываешь форму списка журнала(журнал какой и в какой конфигурации?) и смотришь как заполняется эта самая графа. :)
staer
4 - 15.05.2004 15:28 		Может НазваниеДокумениа у тебя в Общих Реквизитах Документов.
Тогда в Модуле ФОРМЫ Например: НазваниеДокумента=Строка(Вид());
GrayT
5 - 15.05.2004 15:29 		глНазваниеДокументаВЖурнале(Док) в глобальнике
inter
6 - 15.05.2004 15:36 		В модуле формы он заполняется функцией ЗаголовокФормы, которая вызывается лишь при изменении самого заголовка, вернее в его закладке
Функция ЗаголовокФормы()

Перем Заголовок, Название;

Заголовок = глНазваниеДокументаВЖурнале(Контекст);
Название = Заголовок+ " №";

Если Выбран() = 1 Тогда
Если Проведен() = 1 Тогда
Заголовок = Заголовок + ". Проведен";
Иначе
Заголовок = Заголовок + ". Не проведен";
КонецЕсли;
Иначе
Заголовок = Заголовок + ". Новый";
КонецЕсли;
Форма.Заголовок(Заголовок);
Возврат Название;

КонецФункции //ЗаголовокФормы

А как его присвоить в обработке чтобы оно сохранилось
Док=СоздатьОбъект("Документ.Реализация");
Док.НазваниеДокумента= ?
Док.Новый();
глЗаполнитьШапку(Док, 0, "Продажа");
Док.ДатаДок=ДатаКон;
Док.АвтоВремяНачалоДня();
GrayT
7 - 15.05.2004 15:42 		А он тебе в обработке зачем? Это же реквизит ФОРМЫ.
Gavrila
8 - 15.05.2004 15:46 		(6) если у тебя нет названия документа на форме этого самого документа и в журнале, то скорее ошибка здесь (5)
inter
9 - 15.05.2004 15:51 		Мне необходимо чтобы при открытие обработкой созданного документа в название документа была стандартная надпись Реализация(купля-продажа)№...Сейчас выходит просто №. И в общем журнале в графе документ было тоже а не пустое множество.
Gavrila
10 - 15.05.2004 15:54 		(9) тогда тебе точно сюда: глНазваниеДокументаВЖурнале(Контекст);
смотри по отладчику :))
inter
11 - 15.05.2004 15:57 		Это не устраняет коллизию

Док.Новый();
глЗаполнитьШапку(Док, 0, "Продажа");
глНазваниеДокументаВЖурнале(Док);
Док.ДатаДок=ДатаКон;
Док.АвтоВремяНачалоДня();
Gavrila
12 - 15.05.2004 15:59 		(11) говорю русским языком, что при создании и последующем открытии его из обработки тебе не нужно указывать название дока !!!
Название документа появится в открытом документе и в журнале если ты исправишь гл. процедурку "глНазваниеДокументаВЖурнале(Контекст);" :))
inter
18 - 15.05.2004 16:42 		Всем огромное ПЛ..З . До меня кажется дошло. Надо было сделать так
Док.КодОперации=Перечисление.КодыОпераций.Продажа;
Док.ПредставлениеВида();
В самой обработке
или так
Док.КодОперации=Перечисление.КодыОпераций.Продажа;
глНазваниеДокументаВЖурнале(Док);

или так глНазваниеДокументаВЖурнале(Док); при этом изменяя гл.мод.


Подчиненные документы | База знаний | mista.ru

Подчиненные документы

Андрюха
23.05.2004 18:49 		Мне нужно заполнить подчиненный документ (т.е. на первом документе нажимаю на кнопку, выходит второй документ, где некоторые поля заполняются с первого документа). На форумах прочитал, что есть предопределенная процедура ВводНаОсновании(...), например:

Процедура ВводНаОсновании(Докум)
ДокОснование = Докум;
КонецПроцедуры

Вопрос: а как и где определяется переменная "Докум"?
skunk
1 - 23.05.2004 19:06 		ЖКК трудно полистать

Процедура ВводНаОсновании(<?>)
КонецПроцедуры
Procedure InputCausedBy(<?>)
EndProcedure
Синтаксис:
ВводНаОсновании(<ДокументОснование>)
Назначение:
Предопределенная процедура при интерактивном вводе нового документа на основании.
Параметры:
<ДокументОснование> - значение типа Документ.
Замечание:
Данная процедура может располагаться только в модуле формы документа.
Подробнее см. в документации, глава 'Системные предопределенные процедуры'
mszsuz
2 - 23.05.2004 19:31 		Документ-основание передается третьим параметром в ОткрытьФорму(), н-р:
ОткрытьФорму("Документ.ПлатежноеПоручение",,ТекущийДокумент())
(понятно, что в этом случае док.-основание должен быть уже записан)
или
автоматически передается при нажатии кнопки "Ввод на основании" в Журналах.
Андрюха
3 - 23.05.2004 20:07 		Я так и передаю через
ОткрытьФорму("Документ.ПлатежноеПоручение",,ТекущийДокумент()),
но в поле куда должна записываться информация из первого документа, ничё автоматически не заносится. Тип поля Документ и именно тот с которого я хочу получить данные.
Волшебник
5 - 23.05.2004 20:47 		Видимо документ-основание все-таки не записан.
Андрюха
6 - 23.05.2004 22:04 		Я в 1С только начинаю писать... И мне не совсем понятно, что значит "документ-основание не записан". Он где-то должен программно записаться перед вызовом ВводНаОсновании()?
SnarkHunter
7 - 23.05.2004 22:13 		Нет... Перед вызовом ОткрытьФорму...
Андрюха
8 - 23.05.2004 22:46 		Перез вызовом ОткрытьФорму у меня идет следующих код:

ДокТест = СоздатьОбъект("Документ");
ДокТест.ВыбратьПодчиненныеДокументы(,, ТекущийДокумент());
Если ДокТест.ПолучитьДокумент() = 1 Тогда
НовыйДок = ДокТест.ТекущийДокумент();
ОткрытьФорму(НовыйДок);
иначе
ОткрытьФорму("Документ.Новый", ТекущийДокумент());
КонецЕсли;

...но всё равно в поля подчиненного документа ничё не пишется...
SnarkHunter
9 - 23.05.2004 22:59 		Ты перед вызовом ОткрытьФорму() проверь записан ли текущий документ... Тебе об этом все уши прожужжали... Напиши:
Если Выбран()=1 Тогда
...
// Тут можешь свой кусок поместить
Иначе
Сообщить("Меня зовут Ручник Тормозович...");
КонецЕсли;
Волшебник
10 - 23.05.2004 23:05 		Если бы речь шла про восьмерку, я бы сказал, что в 8.0 есть процедура ОбработкаЗаполнения, которая должна располагаться в модуле объекта (справочника, документа). Не путайте с модулем формы.

Эта процедура срабатывает при вводе на основании.

Ввод на основании можно также вызвать программно методом Заполнить объекта типа СправочникОбъект и ДокументОбъект.
GrayT
11 - 23.05.2004 23:54 		+9 И еще одну запятую напиши. Впрочем об этом уже писали в 2, но в коде 8 ее нет


Групповая печать документов | База знаний | mista.ru

Групповая печать документов

Антон 21.05.2004 08:53 | Подскажите пожайлуста, как отправить на печать документы не просматривая их (конкретно приходники причем только первые страницы) может какая нибудь обработка для этого есть? заранее благодарен
Maka 1 - 21.05.2004 09:36 | Напечатать(<?>); Синтаксис: Напечатать(<Флаг>) Назначение: Напечатать таблицу без предварительного просмотра (печать без открытия окна редактирования). Параметры: <Флаг> - необязательный параметр. Режим запроса диалога печати: 1 - запрашивать диалог печати (по умолчанию), 0 - не запрашивать. Замечание: Метод может использоваться при работе с таблицей в режиме ввода данных.
GrayT 3 - 21.05.2004 11:21 | Не слышал про такую обработку. Тем более - только первые листы. А потому придеться писать самому. Выбираешь документы, формируешь таблицы и командой Напечатать выбрасываешь на принтер
SiMazx 4 - 21.05.2004 11:29 | Если пользовать печатную форму и алгоритм печати самого документа, тогда можно в процедуру документа ПриЗаписи (например) вставлять проверку на групповую обработку и запускать процедуру печати... А в вызывающей обработке докменты просто Док.Записать()... Более простой вариант в обработке бежать по документам, выдергивать данные, запихивать в печатную форму обработки(скопировать из документа) и печатать...
Антон 7 - 21.05.2004 11:42 | Обработку такую нашел, только она корявая немного, выкидывает данные в текстовый файл, потом просто его кинуть на печать, но это некрасиво. Сам написал почти по человечьи, вроде работает, только со страницами проблема осталась.


Восстановление удаленных строк в документе? | База знаний | mista.ru

Восстановление удаленных строк в документе?

valich 19.05.2004 13:27 | Опять я глупые вопросы задаю. Но, надеюсь на вашу снисходительность ;-) Тут пользователь нарисовался с "бедой". В документе "Заявка от покупателя" (ПУБ) удалила 35 строк из 36. Долго меня пытала как это можно восстановить, и наконец с матом принялась заводить вручную по "Выпуску". Я почему-то уверен, что в 1С такое (автоматическое) восстановление невозможно, но может я не прав? А?
SnarkHunter 1 - 19.05.2004 13:44 | Штатных средств в 1С для этого нет...
a7 2 - 19.05.2004 13:45 | В 1С такое штатными средствами конечно невозможно, но если в dbf-файле табличной части этого документа у удаленных записей снять dbf-пометки удаления, то все получится.
valich 3 - 19.05.2004 13:52 | (1) Спасибо, а то она побежала жаловаться внедренцам, что у "наших" ничего не получается... Теперь я хоть поувереннее себя чувствую ;-) (2) Жаль, в смысле у нас SQL...
Шольц 4 - 19.05.2004 13:53 | А почему нельзя из архивной копии (вчерашней) этот док выгрузить обработкой, а в сегоодняшнюю загрузить? Это, правда, возможно, только если правился док, созданный в день, который входит в архивную копию.
valich 5 - 19.05.2004 21:00 | (4) Шольц, а что ты имеешь в виду под "выгрузить". Можно поподробнее... Извини, я только-только учусь ;-) P.S.: Да, днем меня (в 14:00) отрубили на работе от инета, лимит исчерпал (хе-хе)...
Lazarus 6 - 20.05.2004 13:07 | Он имеет в виду, что нужно написать обработку, которая выгрузит из архивной копии, все реквизиты и табличную часть в файл, а потом загрузит из файла в рабочую программу. Говорят существуют универсальные выгрузки, если не найдешь, то пиши сам. ;-)
SiMazx 7 - 20.05.2004 13:14 | На hippo была обработка по восстановлению удаленных объектов... Но работает только для дбф.. Придется выгружать... Но при выгрузке она кажется ужимает таблицы.. не уверен... Поэтому лучше вариантом (4)... Проще будет...
SnarkHunter 8 - 20.05.2004 13:35 | Лучше всего вариант (0) - руками удалявшего... Тогда он перед удалением будет размышлять - а надо ли...
valich 9 - 20.05.2004 22:20 | (6) Штука то интересная, тем более что моей сегодняшней подготовки вроде должно хватить... (7) Да, конечно попробую сам, но и взглянуть на примеры тоже хорошо ;-) у меня где-то валялись архивы закачек с него... (8) Оно конечно верно, но тётку жалко... Хорошая тётка ;-) Да и 1С для нее еще в новинку...


Интервала видимости в журнале документов | База знаний | mista.ru

Интервала видимости в журнале документов

Таня 20.05.2004 14:41 | как установить программно? чтобы при открытьФорму устанавливался нужный интервал.
SnarkHunter 1 - 20.05.2004 14:44 | УстановитьИнтервал()


табличная часть документа 7.7 | База знаний | mista.ru

табличная часть документа 7.7

maks
18.05.2004 14:14 		Как програмно реализовать возможность заполнения табличной части документа.
Т.е. в табличной части есть реквизит "Номенклатура" Справочник.Номенклатура и есть DBF файл с полем "Номенклатура" необходимо заполнить из dbf файла табличную часть документа.
lexa
1 - 18.05.2004 14:37 		А откуда у тебя это файл? И что лежит в поле "номенклатура"?
maks
2 - 18.05.2004 14:57 		файл сделал fineriader ом сканирован документ и сохранен в формате dbf в поле номенклатура содержится название номенклатуры. Смысл всего этого: заполняется шапка документа (поступление МПЗ из упрощеннки 1.3) затем вызывается процедура для заполнения табличной части документа из dbf.
lexa
3 - 18.05.2004 15:23 		http://www.anvil.spb.ru/1c/lang/lang038.htm#3258
http://www.anvil.spb.ru/1c/lang/lang0102.htm#1612
http://www.anvil.spb.ru/1c/lang/lang0122.htm#1769
lexa
4 - 18.05.2004 15:30 		Но учти что наименование вещь неоднозначная. тем более после распознования часть товара может не найтись и что делать если товар новый. По хорошему надо из дбф в таблицу значений. Потом в эту таблицу добавить товар из номенклатуры если он найден с возможностью выбора товара. Кучу проверок по преобразованию строк в число и т.п. и т.д.
maks
5 - 18.05.2004 16:01 		распознаванию идет в режиме обучения fineriadera, если товар новый то он записывается в справочник номенклатуры как новый.
lexa
6 - 18.05.2004 16:21 		Честно говоря с дбф не заморачивался в ТиС сделал загрузку из екселла, могу как пример привести.
З.Ы.: Не боишься. что все справочники задвоятся
Valery
7 - 18.05.2004 16:52 		Алгоритм должен быть такой:
Сканируеш ДБФ
Находиш название из ДБФ в справочника Номенклатуры
Если есть, присваиваешь номенклатуре в таблице значение справочника
если нет добавляешь новый элемент в справочник, и присваивешь его талице
maks
8 - 18.05.2004 16:54 		6 - приводите пример.
просто столкнулся с такой проблемой впервые и показалось что из dbf вроде как легче.
вполне может произойти зодвоение, но можно поставить цикл на проверку время конечно возрастет, в данный момент важно время написания обработки а не время ее работы, когда не будут поджимать сроки то можно и доработать не спеша.
maks
9 - 18.05.2004 16:57 		7 - сканирую, нахожу, присваиваю результат 0. Вот процедура

Процедура КнопкаСканер()
Товар ="";
ЕдИзм =0;
Колич=0;
Цена=0;
СтоимостьБезНДС=0;
СтавкаНДС=0;
СуммаНДС=0;
СтоимостьВсего=0;
СтранаПроисхож="";
НомерГТД="";

СпрНом = СоздатьОбъект ("Справочник.Номенклатура"); // Справочник номенклатуры
Док = СоздатьОбъект ("Документ.ПоступлениеМПЗ");
Док = ТекущийДокумент();
Номенклатура = СпрНом.НайтиПоКоду(43);

//СпрНом.НайтиПоНаименованию ("");
ДБФ=СоздатьОбъект("XBase");
ИмяФайла="";
ИмяПути="";
ФС.ВыбратьФайл(0,ИмяФайла,ИмяПути,,"*.dbf|*.dbf");
ПутьДБ=ИмяПути+ИмяФайла;
ДБФ.ОткрытьФайл(ПутьДБ);
ДБФ.КодоваяСтраница(0);
Если ДБФ.Открыта()=1 Тогда
Предупреждение ("База открыта", 2);
ДБФ.Первая();
Пока 1=1 Цикл
Товар = СокрЛП(ДБФ.Column1);
ЕдИзм = СокрЛП(ДБФ.Column2);
Колич = СокрЛП(ДБФ.Column3);
Цена = СокрЛП(ДБФ.Column4);
СтоимостьБезНДС = СокрЛП(ДБФ.Column5);
СтавкаНДС = СокрЛП(ДБФ.Column6);
СуммаНДС = СокрЛП(ДБФ.Column7);
СтоимостьВсего = СокрЛП(ДБФ.Column8);
СтранаПроисхож = СокрЛП(ДБФ.Column9);
НомерГТД = СокрЛП(ДБФ.Column10);
// Номенклатура = "";
СпрНом.ВыбратьЭлементы();

Пока СпрНом.ПолучитьЭлемент() = 1 Цикл

//действия с очередным элементом
// Сообщить("Наименование " + СпрНом.Наименование);
Если (Товар = СпрНом.Наименование) Тогда
Товар = СпрНом.Наименование;
КонецЕсли;
КонецЦикла;

Если (Товар <> СпрНом.Наименование) Тогда
СпрНом.Новый();
СпрНом.ПолнНаименование = Товар;
СпрНом.Наименование = СпрНом.ПолнНаименование;
СпрНом.ЕдиницаИзмерения = ЕдИзм;
СпрНом.ТипНоменклатуры = "Товар";
СпрНом.ПлановаяСебестоимость = Цена;
СпрНом.Цена = (Цена + (Цена * 20)/100);
СпрНом.Валюта = "руб";
СпрНом.СтавкаНДС = СтавкаНДС;
СпрНом.СтавкаНП = "0";
СпрНом.СтранаПроисхождения = СтранаПроисхож;
СпрНом.Записать();
КонецЕсли;

НоваяСтрока();
Номенклатура = Товар;
//ПодборТовара(Товар);

СпрНом.НайтиПоНаименованию(Товар,0);
Если СпрНом.Выбран()>0 Тогда

Док.Номенклатура = СпрНом.НайтиПоНаименованию(Товар);
Номенклатура = СпрНом.ПолнНаименование;
НазначитьТип(Номенклатура,СпрНом);
ОткрытьПодбор(СпрНом,Товар);
Количество = Колич;
СтавкаНДС = СпрНом.СтавкаНДС;
АктивизироватьСтроку();
Иначе
Сообщить ("Не нашли" + Товар);
КонецЕсли;
//Док.НоваяСтрока();

//Пересчет("Номенклатура");

Если ДБФ.Следующая()=0 Тогда
Возврат;
КонецЕсли;
КонецЦикла;
КонецЕсли

КонецПроцедуры
lexa
10 - 18.05.2004 17:04 		а записать() и вместо перебора используй НаийтиПоНаименованию, тем более это функция
Valery
11 - 18.05.2004 17:04 		Я так думаю
Надо вместо Номенклатура = Товар;
Номенклатура=СпрНом.ТекущийЭлемент();
или после Записать()
добавить Товар=СпрНОм.ТекущийЭлемент(), а то у тебя при добавлении новой записи в справочник значение Товар не меняется.
maks
12 - 18.05.2004 17:13 		11 - Номенклатура=СпрНом.ТекущийЭлемент();
СпрНом.ТекущийЭлемент()- нормальное значение спозициолнированного справочника, т.е. текущий элемент = значению из справочника номенклатуры, но присвоения не происходит номенклатура = ""
Valery
13 - 18.05.2004 17:19 		(12) все так ,но у тебя в коде этого нет
Если Номенклатура- имеет тип строка тогда я не прав
Если номенклатура это справочник, то
у тебя в коде ты присваиваешь тип строка
lexa
14 - 18.05.2004 17:23 		Процедура КнопкаСканер()
Товар ="";
ЕдИзм =0;
Колич=0;
Цена=0;
СтоимостьБезНДС=0;
СтавкаНДС=0;
СуммаНДС=0;
СтоимостьВсего=0;
СтранаПроисхож="";
НомерГТД="";
ДБФ=СоздатьОбъект("XBase");
ИмяФайла="";
ИмяПути="";
ФС.ВыбратьФайл(0,ИмяФайла,ИмяПути,,"*.dbf|*.dbf");
ПутьДБ=ИмяПути+ИмяФайла;
ДБФ.ОткрытьФайл(ПутьДБ);
ДБФ.КодоваяСтраница(0);
Если ДБФ.Открыта()=1 Тогда
Предупреждение ("База открыта", 2);
КонецЕсли;
Если ДБФ.КоличествоЗаписей() = 0 Тогда
Возврат();
КонецЕсли;
ДБФ.Первая();
Флаг =1;
Пока Флаг = 1 Цикл
Товар = СокрЛП(ДБФ.Column1);
ЕдИзм = СокрЛП(ДБФ.Column2);
Колич = СокрЛП(ДБФ.Column3);
Цена = СокрЛП(ДБФ.Column4);
СтоимостьБезНДС = СокрЛП(ДБФ.Column5);
СтавкаНДС = СокрЛП(ДБФ.Column6);
СуммаНДС = СокрЛП(ДБФ.Column7);
СтоимостьВсего = СокрЛП(ДБФ.Column8);
СтранаПроисхож = СокрЛП(ДБФ.Column9);
НомерГТД = СокрЛП(ДБФ.Column10);
Если СпрНом.НайтиПоНаименованию(Товар,0) = 0 Тогда
СпрНом.Новый();
СпрНом.ПолнНаименование = Товар;
СпрНом.Наименование = СпрНом.ПолнНаименование;
СпрНом.ЕдиницаИзмерения = ЕдИзм;
СпрНом.ТипНоменклатуры = "Товар";
СпрНом.ПлановаяСебестоимость = Цена;
СпрНом.Цена = (Цена + (Цена * 20)/100);
СпрНом.Валюта = "руб";
СпрНом.СтавкаНДС = СтавкаНДС;
СпрНом.СтавкаНП = "0";
СпрНом.СтранаПроисхождения = СтранаПроисхож;
СпрНом.Записать();
КонецЕсли;
НоваяСтрока();
Док.Номенклатура = СпрНом.ТекущийЭлемент();
Количество = Колич;
СтавкаНДС = СпрНом.СтавкаНДС;
Записать();
Если ДБФ.Следующая()=0 Тогда
Флаг = 0;
КонецЕсли;
КонецЦикла;
КонецПроцедуры
lexa
15 - 18.05.2004 17:26 		нет усн под рукой проверь реквизиты документа и справочников - может они ссылаются на другие справочники или перечисления
maks
16 - 18.05.2004 17:51 		13- в коде нет но я подставил значение из 11 и проверил, а потом написал
kvm
17 - 19.05.2004 00:12 		(14) Количество в документе - это число.
Количество=Число(СокрЛП(Колич));
И раньше Колич=0, тогда присвоение Колич=СокрЛП(ДБФ.Column3) не сработает, надо Колич="";
ЕдИзм, ТпНоменклатуры, СтавкаНДС, Валюта - справочники, присвоение им текстового значения не прокатит.
maks
18 - 20.05.2004 08:46 		Почему не работает присвоение?
Док.Номенклатура = СпрНом.ТекущийЭлемент().Наименование;
Номенклатура = СпрНом.ТекущийЭлемент().Наименование;

Номенклатура и Док.Номенклатура реквизит табличной части документа
SnarkHunter
20 - 20.05.2004 08:51 		Потому что несоответствие типов... И ТекущийЭлемент() - это лишнее...
lexa
22 - 20.05.2004 10:44 		(18)Док.Номенклатура = СпрНом.ТекущийЭлемент();


Дыры в номерах документов | База знаний | mista.ru

Дыры в номерах документов

DenisF 17.05.2004 09:44 | Занимался ли кто проблемой "дыр" (>> 1) в номерах накладных? А именно - все номера в базе должны быть заняты! Как реализовать контроль дыр и автоприсвоение номера из "дырки", если она есть? Буду признателен за подсказку и любую другую информацию.
ander139 1 - 17.05.2004 10:29 | Ну, можно вести базу дыр. В смысле, когда документ удаляется, или документы создают сразу два человека и один не записывает, тогда сохранять номер в базу дырок. И при открытии документа писать номер первой дыры, а при записи удалять из базы...
427 2 - 17.05.2004 11:19 | Таким образом "черные доки" не затыкают......
BorisBiz 7 - 18.05.2004 08:38 | А чем перебор плох ? Только зачем затыкать дыры в накладных ? Это бзик, ИМХО. В кассовых документах, понятно - обязаны без дыр.
SnarkHunter 8 - 18.05.2004 09:23 | Да и в кассовых только в тех, что в кассовую книгу попадают...
Bell 9 - 18.05.2004 12:35 | (0) На hippo я выкладывал обработку для поиска "дыр". Реально использую для присвоения свободных номеров.
427 10 - 18.05.2004 12:52 | Плиз, реквизиты организации в студию.... Завтра придет Налоговоая проверка... По номерам она сразу увидит, куда копать... Затыкать номера не стоит... Просто не стоит делать дыр... А для этого нужно знание ...


Табличная часть документа | База знаний | mista.ru

Табличная часть документа

UltraViolet 17.05.2004 16:32 | Народ, скажите, плиз, как в табличную часть документа вставить столбец, который не является реквизитом. Например, формула = Изделие.Наименование.
SiMazx 2 - 17.05.2004 16:45 | Создаешь текстовую колонку - щелк по табличной части, меню вставить->текст, щелк по табличной части...
UltraViolet 4 - 18.05.2004 08:58 | А как программно изменять количество колонок в табличной части документа?
Valery 5 - 18.05.2004 09:02 | Количество не изменишь. Можно только скрывать и открывать
427 8 - 18.05.2004 09:11 | Почему? Нормально работает.... Наклепай колонок с запасом... с показывай нужные
427 10 - 18.05.2004 09:30 | А какая разница .... текст, справочник.... мальчик, девочка ... Кстати, этот прием довольно широко в типовых юзается ....
SiMazx 12 - 18.05.2004 11:43 | (11) Каким "таким" способом? Добавлением вручную текстовой колонки? Нельзя туда писать ничего кроме текста... Можно попробовать нафигачить реквизитов с типом неопределенный... И потом присваивть тип на лету и играть с видимостью....
lexa 13 - 18.05.2004 11:55 | Может вместо табличной части использовать таблицу значений, в которую при открытии выгркжать табличную часть документа, а при записи из таблицы значений в табличную часть документа
GrayT 14 - 18.05.2004 12:04 | +13 & 14. Есть ведь универсальные документы для движений по любому регистру. Они именно по такому принципу и работают


Передача параметра в модуль док-та | База знаний | mista.ru

Передача параметра в модуль док-та

Свечечка
14.05.2004 16:08 		В модуле формы
Процедура Кнопка()
Провести(Фрм);//Фрм - справочник Фирмы
КонецПроцедуры

В модуле док-та
Процедура ОбработкаПроведения(ФФФ)
Сообщить(ТипЗначения(ФФФ));
КонецПроцедуры

Сообщает "0" (ноль, значение неопр. типа).
Каковы особенности передачи параметра в модуль д-та?
alxkorvin
1 - 14.05.2004 16:10 		Провести(<?>,);
Синтаксис:
Провести(<Режим>,<Знач>)
Назначение:
Выполнить проведение документа.
Возвращает: 1 - если проведение документа выполнено, 0 - иначе.
Параметры:
<Режим> - необязательный параметр. Число: 0 - проводить документ без сдвига ТА; 1 - проводить непроведенный документ реальным временем (со сдвигом ТА); 2 - перепроводить проведенный документ реальным временем (со сдвигом ТА); 3 - проводить любой (непроведенный, проведенный) документ реальным временем (со сдвигом ТА). Значение по умолчанию - 0.
<Знач> - выражение произвольного типа, которое передается при запуске предопределенной процедуры ОбработкаПроведения (необязателен, по умолчанию - пусто).
Свечечка
2 - 14.05.2004 16:22 		В общем, все дело в запятой, т. е.
Провести(,Фрм);
Я правильно поняла?
Свечечка
3 - 14.05.2004 16:56 		Хорошо, а вот теперь хочу повесить на кнопку - #Провести(,Фрм)?Закрыть
Снова не фурычит. Где вообще документированы правила написания формул на кнопках?
AVP
4 - 14.05.2004 17:30 		На кнопке процедура _Провести()
В процедкре _Провести()(в модуле ФОРМЫ документа)
Провести(,Фрм);
Форма.Закрыть(0);
Свечечка
5 - 14.05.2004 17:41 		Я уже разобралась. Я сделала на кнопке:
Провести(,Фрм) #Закрыть
а обработку проведения вообще не трогала. Работает вроде чики-пики.


Проведение документов | База знаний | mista.ru

Проведение документов

AlexMan
12.05.2004 18:10 		Как можно (и можно ли вообще) узнать в модуле проведения документа что его проводит... т.е. создается внешний отчет_1 в котором пишем:

Док=СоздатьОбъект("Документ.Накладная");
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент()=1 Цикл
Док.Провести();
КонецЦикла;

создается внешний отчет_2 в котором пишем тоже самое что и в Отчет_1 так вот можноли в модуле проведения документа Накладная узнать проводит документ отчет_1 или отчет_2?
Gavrila
1 - 12.05.2004 18:22 		Провести(<?>,);
Синтаксис:
Провести(<Режим>,<Знач>)
Назначение:
Выполнить проведение документа.
Возвращает: 1 - если проведение документа выполнено, 0 - иначе.
Параметры:
<Режим> - необязательный параметр. Число: 0 - проводить документ без сдвига ТА; 1 - проводить непроведенный документ реальным временем (со сдвигом ТА); 2 - перепроводить проведенный документ реальным временем (со сдвигом ТА); 3 - проводить любой (непроведенный, проведенный) документ реальным временем (со сдвигом ТА). Значение по умолчанию - 0.
<Знач> - выражение произвольного типа, которое передается при запуске предопределенной процедуры ОбработкаПроведения (необязателен, по умолчанию - пусто).
Замечание:
Метод нельзя использовать в теле предопределенной процедуры ОбработкаПроведения.
Если этот метод применяется в Модуле формы документа непосредственно к документу локального контекста, то данный метод отрабатывает те же действия, как интерактивное нажатие пользователем кнопки с формулой ''#Провести''. В этом случае, если параметр <Режим> опущен, то документ проводится в режиме, соответствующем установкам системы меню Сервис-Параметры.

Так вот в этом самом <Знач> передаешь "отчет_1" или "отчет_2", а в обработке проведения смотришь кто, откуда и что делает :))
AlexMan
2 - 12.05.2004 18:29 		(1) Спасибо конечно но что делать если Отчет_1 и Отчет_2 писал не я и в методе Провести() ничего не писалb а паролей у меня нет , или например пароли есть и в методе провести ничего не написано но Отчет1 (Отчет2) править нельзя под страхом смертной казни ... как доподлинно узнать чем проводят?
Gavrila
3 - 12.05.2004 18:32 		(2) никак, если даже нельзя править Отчет1 (Отчет2)
Gavrila
5 - 12.05.2004 18:35 		+(3) Хотя если сделать еще одну обработку из которой и будут запускаться Отчет1 (Отчет2), то в ней можно перед запуском какого-либо отчета1(2) присваивать допустим глобальной переменной значение 1 или 2, ну и так далее :))
AlexMan
6 - 12.05.2004 18:40 		(5) так ведь Отчет1 и Отчет2 (конечно на самом деле было бы правельней их назвать обработка1 и обработка2 ну да ладно) являются не конечным множеством т.е. могут быть еще и другие обработки .... наверное пора закрывать тему , ответ получен в (3). еще раз спасибо.


Обработка дублирования значений т.части документа | База знаний | mista.ru

Обработка дублирования значений т.части документа

90-78
12.05.2004 19:16 		Как проще всего избежать дублирования значений в столбце
табличной части документа, при вводе их пользователем?
Gavrila
1 - 12.05.2004 19:23 		через таблицу значений
AlexMan
3 - 12.05.2004 19:37 		В формуле того столбца в котором хочеш избавится от повторов пишеш ПоискЭлементов()
в модуле формы пишеш что то типа:
Процедура ПоискЭлементов()
Таб=СоздатьОбъект("ТаблицаЗначений");
ВыгрузитьТабличнуюЧасть(Таб,"Продукция,Отпущено");
КолСтрок=Таб.КоличествоСтрок();
Таб.Свернуть("Продукция","Отпущено");
КолСтрок2=Таб.КоличествоСтрок();
Если КолСтрок2<КолСтрок Тогда
Предупреждение("Этот элемент справочника уже выбран");
Продукция="";
КонецЕсли;
КонецПроцедуры
90-78
4 - 12.05.2004 19:54 		3 -спасибо за Таб.Свернуть()!
Я тут такого накрутил (видимо продублировал её потроха)


Групповая печать документов | База знаний | mista.ru

Групповая печать документов

ФАКОэмульсификатор 11.05.2004 17:29 | Задача: вывод печатных форм каких-то заданных документов при условии, что в код документа не меняем (т.е. оформляем в виде отчета или обработки). Возможно у кого-нибудь есть подобные наработки.
Gavrila 1 - 11.05.2004 17:34 | Docprint.ert тебе поможет наверное :)
Gavrila 2 - 11.05.2004 17:34 | +(1) единственный недостаток в том что формы всех доков будут стандартные :(
ФАКОэмульсификатор 3 - 11.05.2004 17:36 | Смотрел, может в торопях не догнал, но он похоже выводит только реквизиты документов. Меня же интерисуют родные печатные формы документов:(
ФАКОэмульсификатор 4 - 11.05.2004 17:51 | Есть идея - организовать цикл по докам, в нем через контекст вызывать процедуру печати. Недостаток - у нас будет куча окон, для каждого надо жмакать цтрл+П и т.д. Жду Ваши идеи.
Таня 5 - 11.05.2004 17:53 | Использую команду Напечатать(?) и тогда не надо будет кучу окон щелкать
Gavrila 6 - 11.05.2004 17:59 | если понял не правильно - попраь: - обработка должна быть универсальной ? - менять модулм формы нельзя ?
ФАКОэмульсификатор 7 - 11.05.2004 18:18 | Да Gavrila ты прав, а Таня ошибается т.к. Напечатать(?) нужно вставлять в модуль дока.
Gavrila 9 - 11.05.2004 18:20 | Похожая тема уже была недавно... Но штатными средствами такое проделать вряд ли получиться (ИМХО). Хотя может я не совсем понял (4) "через контекст вызывать процедуру печати" - это как ?
ФАКОэмульсификатор 9 - 11.05.2004 18:20 | Бухам захотелось распечатать туеву хучу кассовых ордеров. Открывать каждый влом.
Fynjy 11 - 11.05.2004 18:35 | Ерт написать проблема? Печатная форма у тебя есть в доке...
Gavrila 12 - 11.05.2004 18:36 | (11) ну и как ты ее из дока достанешь?
Fynjy 13 - 11.05.2004 18:43 | (12)Ню по этапам. 1. В почти каждом доке есть процедурка выводящая печатную форму... 2. В почти каждом доке есть объект типа "таблица"... 3. Что мешает сделать все остальное?(Цикл по докам т. д.)...
Mohoshito 15 - 12.05.2004 09:47 | Создаешь внешний отчет, в него копируешь процедуру печати и таблицу из нужного тебе документа. Дорабатываешь их исходя из того, что печатать ты будешь не из контекста документа, а через ссылку на объект. В конце модуля ставишь, чтобы выводилось все сразу на печать, хочешь делай одним большим файлом, в котором на каждой странице будет новый документ, хочешь кучей документов, зато меньшего размера. Смотря на то, как принтер лучше пережевывает. Нудно и долго переделывать? Ничего не поделаешь, другого еще не придумали.
BorisBiz 16 - 12.05.2004 09:51 | Делаю такое постоянно (бухи часто только делают документы, а печатают за месяц скопом). Могу предложить два варианта: 1. С изменением модуля формы документа: обработка, цикл по нужным докам, открытие формы с реквизитом (например "автопечать"). В документе в ПриОткрытии() если Форма.Параметр="автопечать" - печатаем - в печати если Форма.Параметр="автопечать" Таб.Напечатать() , затем СтатусВозврата(0);Возврат 2. Без изменения: внешняя обрабтка, в которой должна быть печатная форма нужного докумета, процедура печати и т.д. - короче геморойнее это, имхо проще 1 сделать, а потом, если нужно, убрать.
Gavrila 17 - 12.05.2004 16:27 | (13) - (16) - это все замечательно, но как сделать тоже самое универсально, тобто для любого дока (любой конфигурации) у которого есть печатная форма и процедура "печать". В идеале хотелось бы получить следующее: Док = СоздатьОбъект("Документ"); Док.ВыбратьДокументы(Дата1, Дата2); Пока Док.ПолучитьДокумент() = 1 Цикл Док.Печать(); КонецЦикла; где "Печать()" - это процедура в модуле формы документа... Может кто ссылочкой на ВК поделится :))


Ошибка, при отборе документов | База знаний | mista.ru

Ошибка, при отборе документов

90-78 07.05.2004 14:22 | При вызове процедуры вида: Док.ВыбратьПоЗначению(,,"ИмяГрафыОтбора",Знач); выдаётся сообщение об ошибке: Объект - документ определённого вида! Что это может означать?
SnarkHunter 1 - 07.05.2004 14:37 | Это означает, что Док - объект-документ определенного вида... Используй: Док=СоздатьОбъект("Документ");
Valery 2 - 07.05.2004 14:38 | скорее всего создан док - это документ с конкретным видом попробуй создатьобъект("Документ") без указания вида.
90-78 3 - 07.05.2004 14:38 | Хорошо, конкретнее: Аргумент Знач, тоже имеет тип Документ.ХХХХХ. Какой из двух документов виноват?
SnarkHunter 4 - 07.05.2004 14:40 | Док


Как запретить удаление документа (или пометку на удаление) ? | База знаний | mista.ru

Как запретить удаление документа (или пометку на удаление) ?

UltraViolet
07.05.2004 13:35 		Можно ли как-то запретить ставить пометку на удаление документов?
427
1 - 07.05.2004 13:37 		Права

или

предопределенная процедура в глобальнике
Valery
2 - 07.05.2004 13:38 		Самое простое назначить пользователям права соответствующие
UltraViolet
3 - 07.05.2004 13:38 		предопределенная не катит... уже пробовала... а права очень хлопотно...
UltraViolet
4 - 07.05.2004 13:40 		дело в том, что начальство желает устанавливать дату, чтобы документы до этой даты нельзя было удалять
wolfy
5 - 07.05.2004 13:42 		имхо для случая описанного в (4) только предопределенная проц в глобальнике и подойдет
UltraViolet
6 - 07.05.2004 13:44 		во время выполнения процедуры ПриУдаленииДокумента пометка еще не установлена, так что и снять ее не получается
Valery
7 - 07.05.2004 13:46 		Незнаю какая конфигурация, но в последних есть константа Дата запрета редактирования. Может подойдет.
wolfy
10 - 07.05.2004 13:58 		вот пример простейший попробуй

Процедура ПриУдаленииДокумента(УдалДокумент)
//Если метим на удаление сменный отчнет то надо пометить и служебные документы

Если УдалДокумент.ДатаДок<'01.01.2004' Тогда
СтатусВозврата(0);
КонецЕсли;

КонецПроцедуры
wolfy
11 - 07.05.2004 14:00 		в (10)
то что в комментарии написано ни как к теме ветки не относиться, не обращайте на это внимания
427
13 - 07.05.2004 14:08 		(6) Ой люли.....

(с) Дока по 1С

ПриУдаленииДокумента
Предопределенная процедура при удалении документа и при отмене пометки на удаление.
Синтаксис:
ПриУдаленииДокумента(<УдалДокум>, <Режим>)
Параметры:
<УдалДокум> Значение удаляемого документа.
<Режим> Значение флага непосредственного удаления: 1 — непосредственное удаление; 0 — пометка на удаление.
Описание:
Вызов предопределенной процедуры ПриУдаленииДокумента производится системой 1С:Предприятие неявно при интерактивном удалении документа и в случае отмены пометки на удаление. В этом случае, условия вызова мож-но узнать методом ПометкаУдаления документа. Если в данной предопределенной процедуре установить статус возврата — 0 (например, если не истек срок хранения документа), то удаление документа не будет выполнено.
Данная предопределенная процедура может располагаться только в глобальном программном модуле.
Пример:
Процедура ПриУдаленииДокумента(Док, Реж)
Если НазваниеНабораПрав() = "Продавец" Тогда
Если (Док.Вид() = "РасходнаяНакл") И (Реж = 1) Тогда
Предупреждение("У вас нет права удалять накладную!", 2);
СтатусВозврата(0);
КонецЕсли;
КонецЕсли;
КонецПроцедуры
См. также: СтатусВозврата


Нумерация документов в 1с (Сложный случай) Срочно нужна помощь. | База знаний | mista.ru

Нумерация документов в 1с (Сложный случай) Срочно нужна помощь.

Alex_Nik
05.05.2004 13:29 		Поздравляю всех с майскими празниками. Желаю удачи, здоровья, благополучия и материального процветания.
Может быть кто-нибудь сталкивался с такой ситуацией?:
У нас счета-фактуры имеют символьный номер: 02 /ТО-9996. Всего под номер было определено 11 разрядов. Настал момент, когда номер должен был превысить 11 знаков, т.е. 02 /ТО-10000. Этот момент не наступил, так как выше я уже сказал: было отпущено 11 разрядов. Система запнулась, вместо 02 /ТО-10000 она пытается присваивать очередной номер 02 /ТО-1000, который уже существует.
Номера документов у нас присваиваются в глобальном номере командой ( УстановитьНовыйНомер(<Префикс>)). В документации написано,а также у Митичкина в электронном учебнике говорится что эта команда работает очень и очень корректно!!!
Что я сделал? Прежде всего увеличил разрядность до 15 знаков. Ясный перец что в свойствах документа стоит проверка на уникальность номера. Но откуда эта команда с диким упрямством вытаскивает именно номер 02 /ТО-1000. Соответственно, так как номер не уникальный, документ не записывается.
Тестирование и исправление базы данных - как мертвому припарка...
Вопрос: куда можно залезть, чтобы исправить эту ситуацию и чтобы нумерация по команде УстановитьНовыйНомер(<Префикс>), начиналась с 02 /ТО-10000. Да, можно конечно поменять префикс и с увеличенной разрядностью, например до 15 знаков нумерация будет начинаться с
03 /ТО-00000001, но бухгалтерия против. А счета-фактуры у нас формируются и в пакетном и в ручном режиме и в очень больших количествах.
Что делать?
С Уважением, Алексей.
GrayT
2 - 05.05.2004 14:11 		И в правду тяжелый случай. Отягощен желаниями бухгалтеров. Что делать? Попытаться договориться с бухгалтерией. Один из аргументов "будете править вручную". И это еще не все, надоть будет еще и всю старую нумерацию переделать (с увеличеним разрядности 000099999). Хотя может я и туплю.
3ton
3 - 05.05.2004 14:32 		Согласен с (2), думаю, что поможет перенумерация документов со сдвигом разрядности из 02 /ТО-9996 в 02 /ТО-09996 (или 02 /ТО-ххх9996, где х=0). Такое уже приходилось делать, (как факт перепроводить доки не надо, зависимость никоим образом не меняется), а чтобы сохранить соответствие номеров документов при выводе на печать сделать парсер номера, как например в СЧФ или РКО/ПКО
Dionisious
4 - 05.05.2004 14:36 		Отркываешь общий журнал. Фильтруешь его по виду документов. Сортируешь по номеру. И смотришь последний номер. Кстати он какой? Вот тут и отгатка загатки.
triton
5 - 05.05.2004 14:57 		Перемименовать все документы с добавлением одного разряда. На ближайшие лет цать хватит.
SnarkHunter
6 - 05.05.2004 15:03 		(4)Не все так просто... Кстати, научи по номеру общий журнал сортировать...
GrayT
7 - 05.05.2004 15:06 		(4)Научишь сортировать по номеру в журнале? ;)
(5)Можно и обработку написать


Дважды обрабатывается проведение документа??? | База знаний | mista.ru

Дважды обрабатывается проведение документа???

Острие Бревна 04.05.2004 01:48 | Вычислил, что дважды выполняется процедура ОбработкаПроведения(). Упростил до невозможного: Процедура ОбработкаПроведения() Сообщить("Привет"); КонецПроцедуры "Привет" пишет дважды!!! Я уже выпадаю в осадок. Что это может быть?
Dionisious 1 - 04.05.2004 10:01 | А формула у кнопки ОК какая? Возможно "#Провести Записать Закрыть". Тогда "Записать" надо убрать.


Как с наименьшей кровью суммировать числовой реквизит отдельных строк МЧ? | База знаний | mista.ru

Как с наименьшей кровью суммировать числовой реквизит отдельных строк МЧ?

Острие Бревна
03.05.2004 20:29 		В многостр. части дока есть реквизиты ТМЦ и Кво. В случае дублирования ТМЦ (наличия строк с одинаковыми ТМЦ) есть необходимость знать суммарное Кво данной ТМЦ по доку. Как это лучше организовать?
Острие Бревна
1 - 03.05.2004 20:33 		В смысле идеи-то есть, например, вести ТЗ с двумя колонками - ТМЦ и Кво, ввести доп. реквизит МЧ... Но хочу выслушать идеи со стороны.
427
2 - 03.05.2004 20:54 		ВыгрузитьТабличнуюЧасть (ТЗ)
тз.свернуть("Товар","Кол-во")

если кол-воСтрок() <> тз.Кол-воСтрок() тогда
Предупреждение ("Уберите нах... дубли..... не могу работать с ними")

И пусть оператор сам разбирается ..... чего он хочет

Но я бы еще добавил в документ кнопарь с функцией сортировки товара в ТЧ... Набрал как попало, отсортировал и все видно.... Удобно, когда товаров более 10 строк
Острие Бревна
3 - 03.05.2004 21:05 		То есть ты предлагаешь вести ТЗ. Вопрос не ставится о сворачивании табл. части. Пусть себе будут строки с одинаковыми ТМЦ. Нужно просто в любой момент знать их суммарное Кво по доку.
Я так понимаю - ТЗ с двумя колонками (ТМЦ и КвоПоДоку). А вот изменять как КвоПоДоку - перебор строк ТЗ/поиск нужной/изменение КвоПоДоку? И так после каждого изменения Кво в МЧ? А поизящней что-либо нельзя придумать? Вот чем например хуже ввод реквизита в МЧ.
427
4 - 03.05.2004 21:10 		Нет, ТЗ вести не надо... ВыгрузитьТабЧасть можно в любой момент...

Лучше убирать дубли... А то ежели расход - вобьют один товар дважды... с разным количеством (это терпимо) но по разной цене (ну ошибся оператор)... и пздц...

Пусть лучше убирает дубли и неоднозначность ....
Острие Бревна
5 - 03.05.2004 21:21 		Про ВыгрузитьТабличнуюЧасть не знал, спасибо. А насчет дублей - есть нюансы. Так получается, что необходимо, чтобы дубли были. Бывает, даже по разной цене и отпускается. Накладные накопительные за месяц и более.
Ой долько допер. ВыгрузитьТабличнуюЧасть наверное, тоже плохо. Ведь надо выгружать после каждого изменения реквизита Кво. Дело в том, что необходимо срванивать сумму Кол-ва по доку с реальным остатком. Есть реквизит Остаток
427
6 - 03.05.2004 21:28 		Изложи всю постановку задачи.... Пока каспер обновляется - отвечу ....
Острие Бревна
7 - 03.05.2004 21:38 		Накладные на протяжении некоторого периода формируются как обычно. Но клиент требует, чтобы по итогам этого периода была выписана одна накладная. Они сводятся в одну т. н. "сведенную". Само собой в ней часто возникают дублирующиеся строки. Но их имеет смысл для хранить в первоначальном виде, т. к. иногда требуется поднять историю (очередность) отгрузок. Ведется контроль наличия ТМЦ на складе. В случае нехватки требуется, чтобы конфа не проводила накладную. Вот для этого и нужно сравнивать остаток с суммарным отпускаемым в накладной количеством, причем по каждой ТМЦ отдельно.
Надеюсь объяснил внятно.
427
8 - 03.05.2004 21:43 		В твоем случае проще распечатать ОДНУ сводную накладную как отчет, не трогая ничего остального.... с указанием в ПЧ форме даты отгрузки и номера РН

Если клиент не согласен - в задницу клиента.... Вообще то это нарушение....
На один и тот же товар два расходных дока....

Ну и другие заморочки...
Так что не стоит биться - проще ему выдавать в виде отчета
Острие Бревна
9 - 03.05.2004 21:53 		Рациональное зерно в твоем предложении есть.
Клиент будет несогласен, причем он не один, а таких большинство. Задницы, даже самой большой в мире, на всех не хватит :) Товар - канцтовары и офисные принадлежности. Мы тем клиента и берем, что предлагаем такую форму работы. Прикинь, если каждую отгрузку оформлять как положено - например: "дайте две ручки и десяток карандашей, а авам вот доверенность..." Стоимость платежки в банке будет в процентном отношении к объемам закупок за месяц ощутимой...
Острие Бревна
10 - 03.05.2004 21:55 		В смысле стомимость банковского обслуживания по б/н платежам.
kvm
11 - 03.05.2004 22:38 		Сделай все-таки отчет. Сформировал запрос, а там делай что хочешь, хочешь, отсортируй по товару и дате, хочешь, по дате и товару. Вы свои внутренние накладные, наверное, все-таки делаете вовремя? Если нет, то все хуже, ведь клиентов-то много, а при вводе документов не учтешь, кто раньше. А так - контроль остатка при отгрузке, а клиенту одну накладную в конце месяца.
427
12 - 03.05.2004 22:39 		Здесь м.б. несколько нарушений...

Вы возите товар клиентам мелкими партиями. Весь вопрос, куда он это пускает... Хорошо, если товар для внутреннего использования...

Если же товар для дальнейшей продажи... Тут все серьезнее...
Должна быть расходная накладная от вас... в которой клиент распишется в получении, иначе он просто скажет - НЕ БРАЛ, НЕ ПРИВОЗИЛИ... и вы не причем.... На отсутствие подписей и суда нет....

Второе - экспедитор и кладовщик должны знать, что кому отгружается...

А вот если вы передали товар клиенту для дальнейшей продажи, и не дали ему РН - вот тогда ваш клиент должен смазать задницу вазелином....

У него товар на прилавке, документов поступления НЕТ.... САМЫЙ СТРАШНЫЙ ГРЕХ в торговле.... Продажа неотфактурованного товара.... Первая же проверка засадит по самые не хочу.... Сумма откупа в этом случае очень большая...

Если вы даете клиенту РН - какие его проблемы... Все хлопоты ваши ... Он расписался, принял товар.... Его затрат НОЛЬ....

А договор на поставку заключается следующим образом
в нем оговаривается, что мелкие поставки до ХХХХХ руб в течении месяца осуществляются по заявке клиента, Счет на оплату выставляется по итогам месяца и также выписывается СЧФ (если нужна).... Проплата через банк одна.... Документы все... Подписи все...

В качестве приложения к счету - отчет по РН с перечнем товара...
Все сыты, целы и довольны....

Доверенность можно оформить постоянную - на срок допустим 3-6 месяцев.... Чтобы по каждой РН не дергаться... Это лучше у юриста протрясти...
427
13 - 03.05.2004 22:40 		Аналогично возят всякие пирожные, котлеты, хлеб и прочую лабудень. РН каждый день, СЧФ и оплата - один-два раза в месяц....
Острие Бревна
14 - 03.05.2004 23:13 		По описанной мною схеме естественно, отпускается ТОЛЬКО товар для личного потребления клиентом. И они его, как правило, списывают сразу по оприходованию как малоценку. А если вдруг надумает продать - флаг в руки, мы то причем? Мало ли какой у него товар на прилавке лежит, на нем же не написано, что он от меня. Он станет "товаром от меня" ТОЛЬКО после оформления с моей стороны РН, которая, как я уже говорил, оформляется сводно. Еще нюанс - вся эта мудня происходит в Украине, а здесь действуют свои законы, в частности, только в некоторых случаях можно оформлять одну доверенность и то не больше чем на месяц. Поэтому в любом случае идем на нарушение, оформляя сведенную РН. Да еще и рискуем - фактически отгрузки "первичных" РН нелегитимны - клиент, конечно, расписывается в накопительной ведомости, но в принципе может меня послать куда подальше. Что уде несколько раз и случалось, правда по мелочам.
Острие Бревна
15 - 03.05.2004 23:19 		Сейчас прочитал предыдущий свой пост и обнаружил, что не сказал главного - оформлять доверенность раз в месяц можно, но для этого в каждой нашей РН должна стоять печать клиента. Наверное, так же и в России. Так что булки-котлеты возят, но наверняка в магазине клента ставят печать. А к нам от некоторых клиентов заходят разные уполномоченные лица по нескольку раз в день. На всех печатей не наделаешь. Вот почему наши первичные РН нелегитимны.
427
16 - 03.05.2004 23:20 		Украинская Веселуха ....

тут я пас....
А еще меня веселит ваше "Первое событие" .... и партионный учет в бухии как обязаловка ...

Хоть сам хохол.... но хохлов не понимаю ....
Острие Бревна
17 - 03.05.2004 23:27 		Первое событие скоро канет в Лету. Обещают...
Ладно, отошли от темы - я все еще не решил как лучше, т. е. эффективнее обсчитывать КвоПоДоку. Неужто придется при каждом изменении Кво в любой строчке пробегать либо ТЗ либо МЧ (а все-таки что лучше?), чтобы обсчитать КвоПоДоку?
kvm
18 - 03.05.2004 23:48 		ТЗ проще свернуть. Другие методы я придумать могу, но они сложнее.
ВыгрузитьТабличнуюЧасть(ТЗ);
ТЗ.Свернуть("Товар","Количество");
Чего проще?
Острие Бревна
19 - 04.05.2004 00:06 		Да проще и вправду нет, но это придется делать после каждого изменения количества товара в МЧ. Я не знаю что, но что-то мне в этом не нравится. Куры с меня не будут смеяться? :)
kvm
20 - 04.05.2004 00:15 		А ты делай проверку при записи или проведении. В принципе такая обработочка работает влет. Насчет кур, я не знаю, тебе все равно виднее, но работать это будет. Только про много покупателей (11) остается проблема, нерешаемая простыми средствами. Если документы клиенту, который брал товар раньше, когда он был, вводить после другого, кому по программе не хватило, то не хватит первому. Лучше бить накладные вовремя, а документ печатать из отчета.


В продолжение темы о безалаберности пользователей... | База знаний | mista.ru

В продолжение темы о безалаберности пользователей...

DElo
01.05.2004 23:38 		Может ли журнал регистрации "врать"?
Столько проблем было из-за больничных за апрель, проведённых в периоде расчёта з/пл "Март", приходилось откат назад делать, всё пересчитывать, поехали ручные корректировки...
Клянётся и божится, что назад не откатывалась, и доки сделала вчера. Позавчера я сама сменила период расчёта з/пл на апрель, смотрю в журнал регистрации - новые доки введены действительно вчера, но отката назад не было. Кому верить??? Документ без отката не редактировается и не удаляется...
kadr
1 - 02.05.2004 07:50 		Логи надо ставить! Тогда с точностью до секунды можешь сказать какой пользователь когда и что правил.
427
2 - 02.05.2004 08:03 		Документ прекрасно редактируется и удаляется без отката.... если это проделать обработкой.... при этом протокол чист, как стеклышко....

Ежели хочешь иметь логи - прописывай их сама в обработках ... мастерах ... и т.д.
DElo
3 - 03.05.2004 01:01 		Как без отката отредактировать? Я, например, не знаю, а пользователи - и подавно. Буду очень пизнательна, если скажешь мне, как отредактировать в ЗиК документ, у которого период проведения - предыдущий период.
skunk
4 - 03.05.2004 05:27 		к примеру...
Doc = CreateObject("Документ.КакойНадо");
Doc.FindDocument(НужныйДокумент);
// делаем что надо с доком
// типа
// Doc.Сотр = НужныйСотрудник;
Doc.Write();
Doc.MakeActions()


сообщить(Докум.ТекущийДокумент()) проблема | База знаний | mista.ru

сообщить(Докум.ТекущийДокумент()) проблема

Железяка 28.10.2004 16:13 | Объясните почему сообщить(Докум.ТекущийДокумент()) для разных видов документов возвращает с датай или без? Как настроить одинаково? Пример: Путевка 123 Поступление ТМЦ 123 (01.01.04)
Diter 2 - 28.10.2004 16:16 | У тех документов. у которых не выводится дата установлена периодичность нумерации "по всем данного вида".э Поставь периодичность "год" и всё будет ОК. Как то раз день целый просидел, пока методом тыка не нашёл этот косяк


Реквизит табличной части в отдельном поле ввода | База знаний | mista.ru

Реквизит табличной части в отдельном поле ввода

m1ke 15.10.2004 15:52 | Создаю новый документ. В табличной части 2 столбца - в первом выбираются кадровые документы,во втором к каждому документу пишется длинное примечание, писать это примечание в самой таблице в одну строку не совсем удобно, поэтому хочу ниже табличной части поместить поле ввода многострочного текста "Примечание". Вопрос в следующем, можно ли привязать это "Примечание" к строкам таблицы, чтобы при выборе строки, ниже,в поле ввода текста отображалось примечание именно для этой строки? И вообще можно ли поместить в таблицу неогранниченный по знакам текст?
GrayT 1 - 15.10.2004 15:59 | ТЗ поместишь неограниченную строку, а вот в таб. часть документа едва ли. А привязать. Кинь реквизит на форму в формуле пропиши процедурку, которая перепишет из реквизита на форме в таб документа. Ну и при смене строки в документе (для красоты)


Доступность формы документа. | База знаний | mista.ru

Доступность формы документа.

СОМС 30.09.2004 23:11 | Здравствуйте. Подскажите, пожалуйста, как сделать следующее. Юзер заходит в документ, нажимает кнопку (например, Заполнить), после этого табличная часть документа должна быть ему недоступна.
bsg 1 - 01.10.2004 00:21 | Форма.Реквизит.Доступность(0)
СОМС 2 - 01.10.2004 15:42 | Это понятно. Не ясно, что за реквизит табличная часть.
bsg 3 - 01.10.2004 15:45 | (2) +(1) Здесь Реквизит - идентификатор реквизита табличной части.
SnarkHunter 4 - 01.10.2004 15:46 | (2)Это не будет работать... Разруливай через предопределенные процедуры...


Почему для рекв. таб. части док. неопред. вида не действует НазначитьТип() | База знаний | mista.ru

Почему для рекв. таб. части док. неопред. вида не действует НазначитьТип()

Chameleon
13.09.2004 13:06 		Или почему если в таб. части док. имеется рекв, вида справочник неопред. вида, я не могу воспользоватся командой ВидыДляВыбора(); если реквизит не является рекв. табл. части,а рекв. шапки, то все работает нормально, и вообще не действует ни НазначитьТип(), не УстановитьТип(), не Вид()....
Реал. ситуация: Есть реквизит табл. части "ТМЦ", (справочник неопр. вида), мне нужно что-бы один раз пользователь выбирал этот тмц из Спр. Номенклатура, а другой раз скажем из Спр.Инвестиции, но что-бы при этот не светились все те справочники которые имеются в конфе. ВидыДляВыбора() не помогает.. :(
wolk
1 - 13.09.2004 13:08 		Ты это делаешь внутри цикла Пока ПолучитьСтроку() = 1?
Рупор абсурда
2 - 13.09.2004 13:08 		Потому, что у него уже есть тип ...
См. НазначитьВид()
wolk
12 - 13.09.2004 14:12 		(11) - попробую объяснить ещё раз. Внутри цикла ПолучитьСтроку() пишешь сначала то, что в (2) и сразу после этого то, что в (10).
SnarkHunter
19 - 13.09.2004 14:24 		Процедура ПриНачалеВыбораЗначения(ИдентЭлемДиалога,ФлагСтандОбр)
Если ИдентЭлемДиалога="Товар" Тогда
// При выборе товара сначала предлагается указать вид справочника, из
// которого требуется выбрать МПЗ, затем открывается форма выбранного справочника.
Значение="";
Меню=СоздатьОбъект("СписокЗначений");
Меню.ДобавитьЗначение("Номенклатура", Метаданные.Справочник("Номенклатура").Представление());
Меню.ДобавитьЗначение("Материалы", Метаданные.Справочник("Материалы").Представление());
Если Меню.ВыбратьЗначение(Значение,,,, 2)=1 Тогда
НазначитьВид(Товар, Значение);
Иначе
ФлагСтандОбр=0;
КонецЕсли;
КонецПроцедуры // ПриНачалеВыбораЗначения()
Фокусник
38 - 13.09.2004 21:08 		В сторону.
Chameleon (видимо) не понимает, что в каждой строке реквизит может иметь свой тип. Потому и нужно сначала ПолучитьСтроку(), а потом уже НазначитьТип(). Как ему это объяснить ? :)


Можно ли что-то обработать в Журнале Документов | База знаний | mista.ru

Можно ли что-то обработать в Журнале Документов

Ars 12.07.2004 12:19 | Ситуация: есть некий журнал документов, мне необходимо, чтобы при удалении из него документа у меня удалились документы, имеющие отношение к этому из другого журнала. Каких-то событий, типа ПриУдалении() я не нашел. Что делать, как возможно реализовать подоюный механизм?
laeg 1 - 12.07.2004 12:24 | А можно пояснить ? Как вы удаляете документ из журнала ? В конфигураторе что ли ?
427 2 - 12.07.2004 12:28 | см ПредОпределенные процедуры глобальника но помни - это только ИНТЕРАКТИВНО отслеживается. А если хочешь отслеживать как правильно - см предопределенную процедуру в модуле дока
Ars 3 - 12.07.2004 12:29 | Нет, пользователь удаляет документ из рабочей программы (из журнала), нужно это обработать.
Ars 4 - 12.07.2004 12:32 | >427 Так какую процедуру-то в модуле дока? Там же нет ничего такого?
laeg 4 - 12.07.2004 12:32 | Тоды тебе в Глобальник, Синтаксис: ПриУдаленииДокумента(<УдалДокум>,<Режим>) Назначение: Предопределенная процедура при интерактивном удалении документа. Параметры: <УдалДокум> - удаляемый документ; <Режим> - режим удаления: 1 - непосредственное удаление, 0 - пометка на удаление. Замечание: Данная процедура может располагаться только в глобальном программном модуле. Подробнее см. в документации, глава 'Системные предопределенные процедуры'
Ars 6 - 12.07.2004 12:35 | > laeg Вот как раз изменение глобальника крайне не приветствуется. Нельзя ли без него как-нибудь обойтись?
laeg 7 - 12.07.2004 12:45 | Можно ... но больно уж гиморно это ... Через глобальнник лучше, прописать там две строчки и пометить что ты их написал это не приветствуется ? Тогда не приветствуется любые изменения в конфигурации ...
427 8 - 12.07.2004 12:46 | (4) в модуле документа - всего 2 предопределенные... Посомтри и подумай.... Если удаляется (метится на удаление) проведенный док - тогда отловишь все... Если удаляется непроведенный док - тогда кое чего можно не поймать.... но если еще юзать и предопределенные глобальника -...... Надеюсь, документы просто помечаются на удаление?
Ars 9 - 12.07.2004 12:54 | Все, понял, все спасибо.


Структура подчиненности обработка? | База знаний | mista.ru

Структура подчиненности обработка?

ursaloff
20.09.2004 17:50 		Есть ли на восьмерке универсальная обработка которая показывает дерево подчиненности документа?
Волшебник
2 - 20.09.2004 17:54 		http://itland.ru/rep/index.php?id=148
Волшебник
6 - 20.09.2004 19:04 		В модуле формы документа:
Процедура ПриОткрытии()
ЗаполнитьКнопкуДействия(ЭлементыФормы.ДействияФормы.Кнопки.Подменю,ЭтотОбъект);
КонецПроцедуры
------------------------
Процедура ДействияФормыДействиеДерево(Кнопка)

Если Кнопка <> Неопределено Тогда // найти новое значение вида операции
ПостроитьДерево(Ссылка);
КонецЕсли;

КонецПроцедуры
------------------------

В общем модуле:

Процедура ЗаполнитьКнопкуДействия(ЭлементМеню,Объект) Экспорт
//Пункт меню дерево
Элемент = ЭлементМеню.Кнопки.Добавить("РазделительДерево", ТипКнопкиКоманднойПанели.Разделитель,,);
Элемент = ЭлементМеню.Кнопки.Добавить("Дерево", ТипКнопкиКоманднойПанели.Действие,
"Дерево", Новый Действие("ДействияФормыДействиеДерево"));
Элемент.Картинка = БиблиотекаКартинок.Дерево;
КонецПроцедуры
--------------------------------
#ЕСЛИ КЛИЕНТ ТОГДА
Процедура ПостроитьДерево(Ссылка) Экспорт

Если ЗначениеНеЗаполнено(Ссылка) Тогда
Возврат;
КонецЕсли;

Форма = Отчеты.Дерево.Создать().ПолучитьФорму();
Форма.СсылкаНаОбъект = Ссылка;
Форма.Заголовок = Ссылка;
Форма.Открыть();

КонецПроцедуры
#КОНЕЦЕСЛИ


Расшифровка в печатной форме отчета, помогите разобраться ... | База знаний | mista.ru

Расшифровка в печатной форме отчета, помогите разобраться ...

LAV 27.07.2004 14:57 | Можно ли реализовать следующие: после того как отчет по планированию закупок в ТиС сформированн, по двойному нажатию мыши в поле с количеством товара для оформления заказа, открывалась форма документа "Заказ поставщику", это возможно?
NS 15 - 27.07.2004 17:05 | (14) Как это? ОбработкаЯчейкиТаблицы() Не надо приоткрытии() править....
ander139 16 - 27.07.2004 17:37 | (15) В типовой, вроде, нету заполнения табличной части нового документа у заказов
NS 17 - 27.07.2004 17:41 | (16) Нет конечно... Нужно прописать заполнение в отчете - в процедуре обработакаЯчейкиТаблицы()
Crew 19 - 27.07.2004 18:02 | (NS) А как получить значение других ячеек? При помощи Значение("адрес")?
NS 22 - 27.07.2004 18:10 | (19) При помощи метода Таб.Область()...


Товарный отчет с фильтрацией по складу | База знаний | mista.ru

Товарный отчет с фильтрацией по складу

mkos
26.06.2004 11:45 		Добрый день.
Необходимо в типовой торговле в отчете "Товарный отчет" (включен в состав конф.)
добавить на форму реквизит "Склад" для фильтрации документов в
которых есть данный реквизит по этому рекизиту.
В результате добавления к запросу текста:
СтрД="";
Для ин=1 По Метаданные.Документ() Цикл

Если глЕстьРеквизитШапки("Склад",Метаданные.Документ(ин).Идентификатор) = 0 Тогда
Продолжить;
КонецЕсли;

Если ПустаяСтрока(СтрД)=0 Тогда
СтрД=СтрД+","+РазделительСтрок;
КонецЕсли;
СтрД=СтрД+"Регистр.ПартииНаличие.ТекущийДокумент."+Метаданные.Документ(ин).Идентификатор+".Склад";
КонецЦикла;
СтрД=СтрД+";";
ТекстЗапроса = ТекстЗапроса+РазделительСтрок+"Склад = "+СтрД+РазделительСтрок+"Условие (Склад в ВыбСклад);";

Начальный и конечный остатки (в печатной форме "Остаток на...") равны нулю. Есть возможность
получить данные показатели путем перебора всех докуметов делающих движения в "Партии наличие"
с самого начала. Однако это,я думаю, никого не устоит (работать будет медленно).
Есть ли вариан рашения данного вопроса?
Aiuan
1 - 26.06.2004 12:09 		я делал через патрииНаличие... и в общем таких уж больших тормозов не наболюдалось.... хатя у меня все работают на терминалах сервера... так шта...
mkos
2 - 26.06.2004 12:21 		Дело в том, что документов в базе за 3 года,
хотя у меня тоже терминальный сервер. Однако другого решения не вижу.
NS
3 - 26.06.2004 12:57 		(0) Тебе ж сальдо (остатки) не нужны?
Только приход/расход?
Намного проще делается...
makip
4 - 26.06.2004 13:10 		Ясное дело:
запрос ко всем документам(в цикле... Регистр.ПартииНаличие.ТекущийДокумент.<ВидДокумента>)
с функциями приход(СуммаБезНДС) и расход(СуммаБезНДС) и получение нужного
начОст как итгогвого приход-расход, а конОст как начОст+ПриходЗаПериод-РасходЗаПериод (период пользователь выбирает на форме). Как-то еще проще делается?


Может есть готовое решение? | База знаний | mista.ru

Может есть готовое решение?

koshechka
19.06.2004 11:37 		Проблема вот в чем - море складов, на складах лежат товары, каждый товар имеет свою классификацию, которая привязана к субсчету. Не могу создать отчет - вторую неделю мучаюсь - отбор по классификации - общее количество всех этих товаров (принадлежащих классификации) и разворот только по тем складам, где они есть. Решила проблему только до уровня разворота по всем складам. Складов около 200. Пустые совсем не нужны. Помогите ПЛЗ. Заранее благодарна.
427
1 - 19.06.2004 12:33 		вообще то "классификацию, которая привязана к субсчету" - это КРУТО....
Сколько же у вас субсчетов то?

//=======================================================================
if Номенклатура.Selected() <> 1
then
DoMessageBox ("НаФиг пошли... Не выбран товар с классификацией");
return;
endIf;

БИ = CreateObject("BookkeepingTotals");
БИ.UseSubconto(SubcontoKinds.Номенклатура, , 1);
БИ.UseSubconto(SubcontoKinds.МестаХранения, , 1);
СубСчетикУчетика = Номенклатура.СубСчетУчета;

БИ.DoQuery( , ДатаОстатков , СубСчетикУчетика, , , 1, , "К");
//==============================================================

if БИ.SelectSubconto(1) =1 then
while БИ.GetSubconto(1) = 1 do
ОстатокНаВсехСкладах = 0;
Товар = БИ.Subconto(1);
ОстатокНаКонец = БИ.СКД ("К")-БИ.СКК ("К");
Message ("-------- " +Товар + "------ Его валяется на всех складах -- " + ОстатокНаКонец);

if БИ.SelectSubconto(2) =1 then
while БИ.GetSubconto(2) = 1 do
Склад = БИ.Subconto(2);
ОстатокНаСкладе = БИ.СКД ("К")-БИ.СКК ("К");
Message ("----" +Товар + "--на складе -- " + Склад+ " лежит "+ ОстатокНаСкладе);
endDo;
endIf;
endDo;

else
Message ("Весь товар на субсчете "+СубсчетикУчетика+" либо украден, либо его съели мыши");

EndIf;
koshechka
2 - 19.06.2004 13:10 		субсчетов порядка 25, просто нек. классификации привязаны к одному и тому же субсчету.
SnarkHunter
3 - 19.06.2004 13:25 		(2)Субконто не признаете как класс?
BorisG
4 - 19.06.2004 13:33 		(3) Вероятно с шестерки перевели... и оставили ;-)
koshechka
5 - 19.06.2004 13:53 		Выходной отчет должен выглядеть
________________________________________________________
| ТМЦ | Колво общее | Колво |колво |колво |
| | |на складе 1|на складе2|на складе 9|
--------------------------------------------------------
|винт | 200 | 150 | 30 | 20 |
и т. д.
а у меня получается
________________________________________________________________________
| ТМЦ | Колво | Колво |колво |колво |колво |колво |
| | общее |на складе 1|на складе2|на складе 3|на складе4|на складе9|
-------------------------------------------------------------------------
|винт | 200 | 150 | 30 | | | 20 |

а складов очень много, так вот хотелось бы избавится от пустых, тем паче что из 200 складов реально сейчас используется около 80, отчет нужен до зарезу,
спасибо за скорый ответ
koshechka
6 - 19.06.2004 13:54 		классификация не есть субконто
427
7 - 19.06.2004 14:09 		Снарк - это отчет с группировкой по реквизиту субконто...

мне нравится .... даже если колонка шириной 1 см - то отчет будет 85-90 см шириной... Во портянка.....

из указанного в 2 легко делается нужная тебе форма...

Или очень хочется поиметь на халяву? Тогда - вперед на Хиппо....
koshechka
8 - 19.06.2004 14:13 		Господа эксперты! Подскажите где есть ошибка????

Процедура ОстаткиТоваров()
БИ=СоздатьОбъект("БухгалтерскиеИтоги");
БИ.ИспользоватьСубконто(ВидыСубконто.ТМЦ,ВыбТовары,1,1 );

Если ВыбСклад.Выбран()=1 Тогда
БИ.ИспользоватьСубконто(ВидыСубконто.Сотрудники,ВыбСклад,2,1);
Иначе
БИ.ИспользоватьСубконто(ВидыСубконто.Сотрудники,,1,1);
КонецЕсли;
БИ.Опции(1,1);
БИ.ВыполнитьЗапрос(ДатаОтчета,ДатаОтчета,"43,10.01,10.02,10.03,",,,1,,"КС");

БИР=СоздатьОбъект("БухгалтерскиеИтоги");
БИР.ИспользоватьСубконто(ВидыСубконто.ТМЦ,ВыбТовары,1,1 );
Если ВыбСклад.Выбран()=1 Тогда
БИР.ИспользоватьСубконто(ВидыСубконто.Сотрудники,ВыбСклад,2,1);
Иначе
БИР.ИспользоватьСубконто(ВидыСубконто.Сотрудники,,1,1);
КонецЕсли;

Если ВыбТовары.РазмерСписка()=0 Тогда
Заг="По всем товарам. ";
Иначе
Заг="По товарам из списка: "+ВыбТовары.ВСтрокуСРазделителями()+". ";
КонецЕсли;

Если ВыбСклад.Выбран()=0 Тогда
Заг1="По всем складам";
Иначе
Заг1 = "По складу " + ВыбСклад.Наименование;
КонецЕсли;
Если ВыбКласс.Выбран()=0 Тогда
Заг2="Без выбора классификации";
Иначе
Заг2="Классификатор: "+ВыбКласс.Наименование;
КонецЕсли;
ЧислоСтрок=0;
// Создание Таблицы для выходного отчета
Таб=СоздатьОбъект("Таблица");
СписокСкладов=СоздатьОбъект("СписокЗначений");
ОстСкладов=СоздатьОбъект("СписокЗначений");
РезСкладов=СоздатьОбъект("СписокЗначений");
КЛ=СоздатьОбъект("СписокЗначений");
Всего=БИ.СКД("К");
Таб.ВывестиСекцию("Отчет|НаимТовара");
Если ВыбСклад.Выбран()=0 Тогда
БИ.ВыбратьСубконто(2);
Пока БИ.ПолучитьСубконто(2)=1 Цикл
Если (ВыбКласс.Выбран()=1) И (БИ.Субконто(1).Классификация<>ВыбКласс) Тогда
Продолжить;
Иначе // Возврат;
КонецЕсли;
Если БИ.СКД("К")<>0 Тогда
Склад=БИ.Субконто(2).Наименование;
Ост=БИ.СКД("К");
Рез=0;
Таб.ПрисоединитьСекцию("Отчет|Склад");
СписокСкладов.ДобавитьЗначение(БИ.Субконто(2));
ОстСкладов.ДобавитьЗначение(Ост);
РезСкладов.ДобавитьЗначение(Рез);
КонецЕсли;
КонецЦикла;
КонецЕсли;
БИ.ВыбратьСубконто(1);
Пока БИ.ПолучитьСубконто(1) = 1 Цикл
Если (ВыбКласс.Выбран()=1) И (БИ.Субконто(1).Классификация<>ВыбКласс) Тогда
Продолжить;
Иначе // Возврат;
КонецЕсли;

Если БИ.СКД("К")>0 Тогда
Товар=БИ.Субконто(1);
НаимТовара="";
//Если Товар.Родитель.Выбран()=1 Тогда
// НаимТовара=СокрЛП(Товар.Родитель.Артикул)+" ";
//КонецЕсли;
НаимТовара=НаимТовара+Товар.Наименование;
ПечЕд=Товар.ЕдИзм;
ПечКол=Формат(БИ.СКД("К"),"Ч010.3");
ПечРез="";

Если БИ.Субконто(1).ЭтоГруппа()=1 Тогда
Таб.ВывестиСекцию("Группа|НаимТовара");
Иначе
Таб.ВывестиСекцию("Товар|НаимТовара");
КонецЕсли;
Если ВыбСклад.Выбран()=0 тогда
Если (ВыбКласс.Выбран()=1) И (БИ.Субконто(1).Классификация<>ВыбКласс) Тогда
Продолжить;
Иначе // Возврат;
КонецЕсли;
Для а=1 по СписокСкладов.РазмерСписка() Цикл
ПечКол="";
Если БИ.ПолучитьСубконто(2,,СписокСкладов.ПолучитьЗначение(а)) = 1 Тогда
Если БИ.СКД("К")>0 Тогда
ПечКол=Формат(БИ.СКД("К"),"Ч010.3");
КонецЕсли;
КонецЕсли;
ПечРез="";
Если БИ.Субконто(1).ЭтоГруппа()=1 Тогда
Таб.ПрисоединитьСекцию("Группа|Склад");
Иначе
Таб.ПрисоединитьСекцию("Товар|Склад");
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЕсли;
КонецЦикла;
ПечКол=Формат(Всего,"Ч010.3");
Таб.ВывестиСекцию("Итог|НаимТовара");
Для а=1 по СписокСкладов.РазмерСписка() Цикл
Если (ВыбКласс.Выбран()=1) Тогда
//Продолжить;
ПечКол=Формат(ОстСкладов.ПолучитьЗначение(а),"Ч010.3");
Таб.ПрисоединитьСекцию("Итог|Склад");
Иначе // Возврат;
КонецЕсли;
КонецЦикла;
//Вызов выходного отчета в окно просмотра и редактирования.
koshechka
10 - 19.06.2004 14:17 		А из указанного в п.2 СОВСЕМ НЕ ДЕЛАЕТСЯ НУЖНАЯ ФОРМА!!!!
Я ТОЛЬКО ЧТО ПРОВЕРИЛА
ДЕЛО НЕ В ПОЛУЧЕНИИ ОСТАТКОВ! ПЛИИИИЗ! ДЕЛО В ТОМ ЧТОБЫ НЕ ВЫВОДИЛИСЬ НА ПЕЧАТЬ ПУСТЫЕ!!!!
427
12 - 19.06.2004 14:46 		Не ори... Оглохну....

Какие сроки? Завтра - воскресенье.....

Если ВыбСклад.Выбран()=1 Тогда
БИ.ИспользоватьСубконто(ВидыСубконто.Сотрудники,ВыбСклад,2,1);
Иначе
БИ.ИспользоватьСубконто(ВидыСубконто.Сотрудники,,1,1);
КонецЕсли;

Это чего? Конфа переделана? Субконто 10 и 43 - сотрудники? Круто... ну ладно, хрен с ними...

БИ.Опции(1,1); не нужно... ты указываешь список субсчетов.... Кстати, какие нахрен субсчета, если нужен отчет по реквизиту субконто.... А если нужно одним вопросам по всем классификаторам - тогда алгоритм другой...

БИ.ВыполнитьЗапрос(ДатаОтчета,ДатаОтчета,"43,10.01,10.02,10.03,",,,1,,"КС");
здесь ошибка.... Стоят обе даты... будет возращены остатки на начало дня и на конец... Если в этот день на начало было 10, ушло десять, на конец 0 - запрос ВОЗВРАТИТ эту строку..... а она тебе не нужна....

Также нельзя по реализованному алгоритмы просто выбросить склад...
если ты хочешь получить табличку вида

Товар Склад1 Склад2 Склад3
тов1 10 15 ----
тов2 --- 5 15
тов3 --- --- ---

то пока ты не просмотришь ВСЕ товары - ты не знаешь, какие склады есть в таблице, а каких быть не должно

Так что берешь (2), результат запроса выгружаешь в ТЗ, разносишь склады по колонкам, сортируешь по Товару, Складу, Классификатору, выбрасываешь полностью пустые колонки (вообще говоря, их не должно быть после запроса в (2) и этот пункт - лишнее) и выводишь .....

Да, кстати, с какого бодуна 43 и 10 счета имеют субконто ТМЦ? В типовой бух это материалы на 10 и номенклатура на 43.... Или это тоже переделано?
koshechka
13 - 19.06.2004 14:54 		счета 10 и 43 я указала просто так, чтобы не писать <выбКласс.СчетУчета>
Сотрудники - это склады, они и хранят ТМЦ, за дату спасиб, а то что завтра воскресень ничего не меняет, в понедельник бухи уже будут этот отчет юзать, а если нет, то тада.....................
427
14 - 19.06.2004 14:59 		Уточнение
"Кстати, какие нахрен субсчета, если нужен отчет по реквизиту субконто..."

Вроде я понял так - один классификатор - один субсчет....
Если не так - тогда конструкцию типа
Если (ВыбКласс.Выбран()=1) И (БИ.Субконто(1).Классификация<>ВыбКласс) Тогда
Продолжить;
надо вставить в (2).....
427
15 - 19.06.2004 15:00 		без ТЗ ты ничего в данном случае не сделаешь - в частности, не удастся удалить колонки, ибо при просмотре БИ количество складов известно только в конце.....
koshechka
16 - 19.06.2004 15:52 		ес! один классификатор - один субсчет. у меня что то в голове засело, если субконто(1) отобрать по классификатору, то потом глянуть их остатки (БИ.СКД) общие, а после этого раскидать по каким складам эти остатки наблюдаются то ТЗ вообще не нужна, или тута есть жесткое условие, или по всем, или вообще тока общие? Написала от отчаяния, потому что уже совсем запуталась и очевидных вещей не наблюдаю
koshechka
17 - 19.06.2004 18:41 		уффффффф! написала ТЗ, правда при этом чуть не сожгла квартиру (забыла что на плите кое что вариться), ну да ладно! все заработало. огромное спасибо 427
427
18 - 19.06.2004 20:52 		а теперь возьми ломик и молоток.... и на кухню - оббивать кастрюлю....
koshechka
23 - 21.06.2004 01:47 		все равно не то, таблица получается кривая - завтра будет море недовольства, сегодня уже звонили :-(((
кароче, мне так и не удалось запихать в печатную форму все что хотели и как хотели. или красиво и с пустыми, или как надо и криво
Z1
24 - 21.06.2004 08:05 		Разделяем исходную задачу на несколько далее решаем каждую
в итоге имеем решение всей задачи.
1.Создаем таблицу значений с колонками
Товар, КолвоСклад_Код_1го_Склада,
КолвоСклад_Код_2го_Склада
КолвоСклад_Код_n_го_Склада

2. Заполняем эту таблицу значений.
эта задача у тебя тоже решена вроде.

3. Анализируем таблицу значений.
Цикл по колонкам - если в столбце одни нули то удаляем
колонку.
Можно после проверить по строкам ( только проверку делай с последней по 1-ю строку ) если в строке одни нули то удаляем строку.

4. И последнее написать Красивый вывод получившийся Таблицы значений.
427
25 - 21.06.2004 08:35 		Тз --> колонки - все заполняется в цикле просмотра БИ… классификатор пишется для общего алгоритма – можно будет работать при неуказанном классификаторе….. т.е. полные остатки по всем классификаторам с сортировкой по складу классификатору материалу

колонки

Склад
Материал
Классификатор
Остаток

Бух итоги --> по условию в ТЗ
=======================================
Выясняем колво складов в запросе
ТЗ --> тз1…
Тз1.свернуть (\"склад\", \"Остаток\") – это список складиков
Тз1.сортировка (Склад)
=======================================
Для Ш=1 по тз1.колво строков делать
Тз.новаяКолонка (\"Скл\"+число(Ш), \"Число\",……….)
Конец

Тз.новаяКолонка (\"ИтогоПоВсемСкладам\", \"Число\",……….)
Тз.новаяКолонка (\"ДляСОртироки\", \"Строка\", \"НужнойДлины\",……….)

НужнойДлины - Сумма длин (названияСклада + названия классификатора + названия материала + еще немного для сл целей...)

Для Индекс …. По тз.количество строков ………
Тз.получитьПоНомеру(Индекс)

Определяем – куда (в какую колонку совать остаток)
Инд = \"\";
Тз1.найтиЗначение(тз.Склад,Инд,\"Склад\"); нашли нужную колонку
Тз.установитьЗначение(индекс,\"Скл\"+Инд, тз.Остаток)

Тз.ДляСортировки = тз.Склад.Наименование + \" \"+
Тз.Классификатор+\" \"+
тз.Материал.ПолноеНаименование()
или
тз.материал.наименование (см как надо сортировать)
конецЦикла

тз.Сортировка(ДляСортировки)

здесь можно сделать ТЗ.выбратьСтроку – чтобы посмотреть что получилось, дальше будет ясно, как печатать…. В ТЗ уже весь требуемый сортированный отчет….

Только вот смотреть тебе явно будет неудобно…. Эти казлы в 1С сделали окошко выбора строки ТЗ маленьким….. Я это обхожу, правя 1crcrus.dll - Dialogs - 1511 (для СЗ 1116)
теперь по выбратьСтроку() у меня открывается окно шириной почти во весь экран, очень удобно….. И мне положить в этом моменте на © 1с… Зато удобно…

==========================================
колонку ИтогоПоВсемСкладам заполнишь сама …. Можно при печати…. Можно сворачиванием ТЗ

Итоги по классификатору (Сводный остаток материала по классификатору, если материалов с одним классификатором несколько) – заполнишь сама… если эти итоги нужны….. вообще часто требуют….
427
26 - 21.06.2004 08:47 		(24) ты не умеешь готовить ТЗ-шных кошек ......

Чем хороша ТЗ - не надо анализировать... надо просто грамотно заполнить и свернуть....

В моем вариант нет анализа заполнения ТЗ
В моем варианте нет предопределнных колонок по складам - колво складов неопределенное (в твоем - жестко заданное)

т.е. ты удаляешь пустые колонки - я добавляю попавшие в запрос хотя бы по одному товару...

Единственный недостаток - в зависимости от классификатора отчет может быть разной ширины .... это есть
koshechka
27 - 21.06.2004 11:48 		не умею, согласна, до сег. дня не пользовалась такой возможностью. бухи меня убивают, медленно, но верно, дали срок до завтра, может чего и получится. тока текучки стока, что до завтра не успею, это уже понятно
спасибки тебе "427"
427
28 - 21.06.2004 14:52 		фигню спорол... Пропустил кусок

Перед
тз.Сортировка(ДляСортировки)
нужно вставить след кусок - пропустил

СтрСортировки= ""
для И=...... тз1.колвоСтрок
СтрСортироки = СтрСортировки +"Скл"+число(И);
если И <> тз1.колвоСтрок тогда СтрСортироки = СтрСортировки + ",";
конеццикла
тз.свернуть ("Склад,Материал,Классификатор,Остаток",СтрСортировки);
koshechka
29 - 21.06.2004 15:29 		cспасибки огромное, часика через два воспользуюся и посотрю что выйдет но вааще то хочу засесть за "Конфигурирование и...т.д. в 1С", а то голова совсем пустая, аж стыдно прям
koshechka
30 - 21.06.2004 21:42 		Не, не вышло у меня ничего.
Есть другая идея, она у меня в доке одном реализована суперски.
Тока как туда загнать ту номенклатуру, которая подпадает под классификатор?
Процедура Сформировать()
ТЗ=СоздатьОбъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("Номенклатура");
Заг2="Классификация: "+ВыбКласс;
Субк=СоздатьОбъект("Справочник.ТМЦ");
Субк.ВыбратьЭлементыПоРекВизиту("Классификация",выбКласс); -------это пральна?
СЗ = СоздатьОбъект("СписокЗначений");
СЗ.Выгрузить(субк);
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
Таб.ПараметрыСтраницы(1, ,,20,,5,,,,1);
Таб.ВывестиСекцию("Заголовок");
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.ТМЦ, СЗ, 1);
Ит.ИспользоватьСубконто(ВидыСубконто.Сотрудники,,1);
Ит.ВыполнитьЗапрос(, ДатаОтчета, ВыбКласс.СчетУчета,,, 1,, "СК");
Сформировать_Колонки(Ит, Таб, "Шапка");
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);

Ит.ВыбратьСубконто(1,1);
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку() = 1 Цикл
Ит.ПолучитьСубконто(1,ТЗ.Номенклатура);
Сформировать_Колонки(Ит, Таб, "Субконто2");
КонецЦикла;
Сформировать_Колонки(Ит, Таб, "Подвал");
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать","");
КонецПроцедуры
Очень коротенько, зато все что надо, кроме выбранных субк.
koshechka
31 - 21.06.2004 21:44 		А в доке просто табл. значения загружаются
СЗ = СоздатьОбъект("СписокЗначений");
ВыгрузитьТабличнуюЧасть(СЗ,"Номенклатура");
427
32 - 21.06.2004 23:07 		Процедура ОстаткиТоваров()
БИ=СоздатьОбъект("БухгалтерскиеИтоги");
БИ.UseSubconto(SubcontoKinds.ТМЦ,ВыбТовары,1,1 );

if ВыбСклад.Selected()=1
then БИ.UseSubconto(SubcontoKinds.Сотрудники,ВыбСклад,2,1);
else БИ.UseSubconto(SubcontoKinds.Сотрудники,,1,1);
endIf;

БИ.DoQuery(, ДатаОтчета,"43,10.01,10.02,10.03,",,,1,,"К");

// Создание ТЗ

тз = CreateObject("ValueTable");
тз.NewColumn( "Материал","Reference.Материалы",,,"СправМ",,,);
тз.NewColumn( "Склад","Reference.МестаХранения или Сотрудники ?",, , "Справ" , , , );
тз.NewColumn( "Количество","Число" ,15 , 3, " " , , , );
тз.NewColumn( "Классификация","Не знаю какой тип ?" , , , "Классификатор " );

// заполнение тз

if БИ.SelectSubconto(1) =1 then
while БИ.GetSubconto(1) = 1 do
if БИ.SelectSubconto(2) =1 then
while БИ.GetSubconto(2) = 1 do
if ВыбКласс.Выбран()=1 then
if БИ.Субконто(1).Классификация<>ВыбКласс then
Continue;
endIf;
endIf;
тз.NewLine();
тз.Склад = БИ.Subconto(2);
тз.Количество = БИ.СКД ("К")-БИ.СКК ("К");
тз.Материал = Би.Subconto (1);
тз.Классификация= Би.Материал.Классификация;
endDo;
endIf;
endDo;

// далее трясем тз................

if тз.LinesCnt() =0 then
DoMessageBox ("Ничего не найдено");
return;
endIf;

Склады = CreateObject("ValueTable");
тз.Unload(Склады);
Склады.GroupBy("Склад","Количество"); // это список складиков
Склады.Sort("Склад"); // отсортировали для приличия

// навесим колонки в ТЗ
for Индекс = 1 to Склады.LinesCnt() do
тз.NewColumn( "Скл"+string(Индекс),"Число" , 14 , 3, "Скл" );
endDo;

Тз.NewColumn( "ДляСортировки","Строка" , 500 , , "ДляСортировки" );

//-------------------------------------------------------
// разносим остатки по нужным колонкам

for Индекс = 1 to тз.LinesCnt() do
тз.GetLineByNumber(Индекс);
стр = "";
кол = "";
Склады.FindValue(тз.Склад,стр,кол); // нашли номер строки - склад

// загоняем остаток в нужную колонку
тз.SetValue ( Индекс,"Скл"+string(стр),тз.Количество) ;

// индекс сортировки - Склад, классификая, наименование
тз.ДляСортировки = тз.Склад.Description + " "+
Тз.Классификация + " "+
тз.Материал.Description;
endDo;

//-------------------------------------------------------
// сворачиваем тз для объединения инфы по Материалу из нескольких
// строк в одну строку....
// Количество по складам суммируется в нужных колонках - мы уже разнесли его
// в колонке Количество - будет сумма по материалу на всех склада

// составляем перечень колонок, по которым будет суммирование
// сами названия колонок сформированы как
// СклХ - где Х - номер склада в списке

СтрСортировки= ""
for Индекс = 1 to Склады.LinesCnt() do
СтрСортировки = СтрСортировки +"Скл"+string(Индекс);
если Индекс <> Склады.LinesCnt() then
// пришили запятую, если это не последний склад в списке
СтрСортировки = СтрСортировки + ",";
endIf;
endDo;

// свернем ТЗ для получения нужного вида
тз.GroupBy("Материал,Классификация","Количество,"+СтрСортировки);

// отсортировали по критерию - типа
// Склад
// Классификация
// Название материала

тз.Sort("ДляСортировки");

вот по сути и все - данные ТЗ имеют вид

Классификация Материал Колво Скл1 Скл2 ....... СклН

ХХХ1 Мат1 10 0 0 ....... 10
ХХХ1 Мат2 15 0 15 ....... 0
ХХХ2 Мат3 20 0 20 ....... 0

Ну а уж красиво напечатать - без проблем
склады выводятся через ПрисоединитьСекцию ....
столько раз, сколько строк в таблице значений Склады...
koshechka
34 - 25.06.2004 01:10 		А вообще все оказалось гораздо проще:

//==================================================
//*******************************************
Процедура Сформировать_Колонки(Ит, Таб, Стр)
Таб.ВывестиСекцию(Стр+"|Начало");
Ит.ВыбратьПериоды(1, 1);
Таб.ПрисоединитьСекцию(Стр+"|Конец");
КонецПроцедуры
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, СписокТМЦ;
//Перем Документ;
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
//Ит.ИспользоватьРазделительУчета(ВыбРазделительУчета);

Если ВыбСубконто1.Выбран() = 1 Тогда

//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(ВыбТМЦ)
|ТМЦ = Справочник.ТМЦ.ТекущийЭлемент;
|Классификация = Справочник.ТМЦ.Классификация;
|Группировка ТМЦ;
|Группировка Классификация;
|Условие(Классификация в ВыбСубконто1);
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
Если Запрос.Выгрузить(СписокТМЦ,,0) = 0 Тогда Предупреждение("Фигня"); КонецЕсли;
СТ= СоздатьОбъект("СписокЗначений");
СписокТМЦ.Выгрузить(СТ,,,"ТМЦ");
Ит.ИспользоватьСубконто(ВидыСубконто.ТМЦ, СТ, 1);
Иначе
Ит.ИспользоватьСубконто(ВыбСубконто1.СчетУчета.ВидСубконто(1));
КонецЕсли;

Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");

Если ВыбСубконто2.Выбран() = 1 Тогда
Ит.ИспользоватьСубконто(ВидыСубконто.Сотрудники, ВыбСубконто2, 2);
Иначе
Ит.ИспользоватьСубконто(ВидыСубконто.Сотрудники);
КонецЕсли;
Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, ВыбСубконто1.СчетУчета,,, 3, "Операция", "К");
Таб.ВывестиСекцию("Заголовок");

СЗДебет = СоздатьОбъект("СписокЗначений");
СЗКредит = СоздатьОбъект("СписокЗначений");
СЗСотры = СоздатьОбъект("СписокЗначений");
ТЗ = СоздатьОбъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("ККод","Строка");
ТЗ.НоваяКолонка("ТМЦ","Строка"); //Справочник.ТМЦ
ТЗ.НоваяКолонка("ЕдИзм","Строка");
ТЗ.НоваяКолонка("Начало","Число");
ТЗ.НоваяКолонка("Конец","Число");
ТЗ.НоваяКолонка("Дебет","Число");
ТЗ.НоваяКолонка("Кредит","Число");
Если ВыбСубконто2.Выбран() = 0 Тогда
Ит.ВыбратьСубконто(2,1);
Пока Ит.ПолучитьСубконто(2) =1 Цикл
Если Ит.СКД(3)<>0 Тогда
СЗСотры.ДобавитьЗначение(Ит.Субконто(2), Ит.Субконто(2).Наименование);
ТЗ.НоваяКолонка("С_"+СЗСотры.РазмерСписка(),"Число");
КонецЕсли;
КонецЦикла;
КонецЕсли;

Ит.ВыбратьСубконто(1);
Пока Ит.ПолучитьСубконто(1) = 1 Цикл
ТЗ.НоваяСтрока();
ТЗ.ККод = Ит.Субконто(1).Код;
ТЗ.ТМЦ = Ит.ПредставлениеСубконто(1,); //Субконто(1);
ТЗ.ЕдИзм = Ит.Субконто(1).ЕдИзм.Наименование;
ТЗ.Начало = Ит.СНД(3);
ТЗ.Дебет = Ит.ДО(3);
ТЗ.Кредит = Ит.КО(3);
ТЗ.Конец = Ит.СКД(3);
Если ВыбСубконто2.Выбран() = 0 Тогда
Ит.ВыбратьСубконто(2,1);
Пока Ит.ПолучитьСубконто(2)= 1 Цикл
ТекПоз = СЗСотры.НайтиЗначение(Ит.Субконто(2));
ТЗ.УстановитьЗначение(ТЗ.НомерСтроки,"С_"+Строка(ТекПоз),Ит.СКД(3));
КонецЦикла;
КонецЕсли;
КонецЦикла;
Таб.ВывестиСекцию("Шапка|Начало");
Документ = "";
Таб.ПрисоединитьСекцию("Шапка|Конец");
Если ВыбСубконто2.Выбран() = 0 Тогда
Для идн = 1 По СЗСотры.РазмерСписка() Цикл
СЗСотры.ПолучитьЗначение(идн, Документ);
Таб.ПрисоединитьСекцию("Шапка|Оборот");
КонецЦикла;
КонецЕсли;
КС = 0;
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку() = 1 Цикл
КС = КС+1;
Состояние("Обрабатывается "+ТЗ.НомерСтроки + " из "+ТЗ.КоличествоСтрок());
Таб.ВывестиСекцию("Субконто1|Начало");
Таб.ПрисоединитьСекцию("Субконто1|Конец");
Если ВыбСубконто2.Выбран() = 0 Тогда
Для идн = 1 По СЗСотры.РазмерСписка() Цикл
Оборот = 0;
Оборот = ТЗ.ПолучитьЗначение(ТЗ.НомерСтроки,"С_"+Строка(идн));
Таб.ПрисоединитьСекцию("Субконто1|Оборот");
КонецЦикла;
КонецЕсли;
КонецЦикла;

Таб.ВывестиСекцию("Итого|Начало");
Таб.ПрисоединитьСекцию("Итого|Конец");
Если ВыбСубконто2.Выбран() = 0 Тогда
Для идн = 1 По СЗСотры.РазмерСписка() Цикл
Таб.ПрисоединитьСекцию("Итого|Оборот");
КонецЦикла;
КонецЕсли;
Таб. ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(0);
Таб.Опции(1,1,1,0);
Таб.Показать("Сформировать","");
Сигнал();
Сигнал();
Сигнал();
Сигнал();
КонецПроцедуры
Процедура ПриОткрытии()
ВыбНачПериода = НачалоПериодаБИ();
ВыбКонПериода = РабочаяДата();
КонецПроцедуры

//===============================================================

надо было просто мне мозгами пошевелить
бухи от меня в диком восторге, все плохое позабыто и терь у нас мир и согласие
:-)))
все одно - спасибки тебе
koshechka
35 - 25.06.2004 01:17 		получилось можно по классиф. можно по складу, мож. по тому и тому, просто супер! а на счет халяв - я тя умоляю - не пользуюсь
сама люблю поработать :-)
Z1
36 - 25.06.2004 09:01 		(34,35) Молодец. Твое решение один в один ложиться на (24)- метод разделяй и
властвуй. Разделяем одну сложную задачу на несколько независимых мелких более простых.Далее решаем каджую задачу по отдельности и имеем решение исходной задачи.
Совет на будущее. В таблицах значения хранить не представления товаров не
коды товаров а сами элементы справочника т.е
ТЗ.НоваяКолонка("ТМЦ","Справочник.ТМЦ"); //Справочник.ТМЦ
ТЗ.НоваяКолонка("ЕдИзм","Справочник.Единицы");
Если хранить в виде строк то в будущем можешь налететь на большие грабли
(при поиске в таблице значений и/или при свертке таблицы значений)

Интересно а почему в базу знаний не заносят?
427
37 - 25.06.2004 09:37 		(36) хороший совет... хранить ссылки... В любой момент можно додернуть из элемента нужную инфу.. Кстати, если Единица хранится в карточке материала/товара - тогда ее хранить не надо - а просто получать в момент печати.

Только и в этом случае можно налететь... Причем не совсем явно... Например, в сортировках...

Но это реже все таки.


Формирование отчётов | База знаний | mista.ru

Формирование отчётов

NataS 25.06.2004 14:23 | При повторном формировании уже открытого отчёта суммы в колонках удваиваются. Где может стоять обнуление?
AlexMan 2 - 25.06.2004 14:25 | У меня было что то подобное потом оказалось что таблицу значений надо было очищать в конце работы отчета.
Warlock 3 - 25.06.2004 14:26 | (0,1)Если суммы удваиваются, то и обнуления тоже, наверно, нет :)))
NataS 5 - 25.06.2004 14:36 | Тогда как оно (обнуление) выглядит? (Разбираюсь в готовом отчёте.)
lexa 12 - 25.06.2004 15:11 | Таб.Очистить();


Преобразование таблицы в текст | База знаний | mista.ru

Преобразование таблицы в текст

Руслан 23.06.2004 08:44 | Ну я думаю из сабжа всё понятно, а кому не понятно; то как преобразовать таблицу в 1C - в текст, с последующей записью в текстовый файл??? Никто не видел готовой обработки?
Тупой Мля 1 - 23.06.2004 08:53 | Я Тупой Мля и мне непонятно из сабжа что ты называешь "таблицей в 1С". Я могу представить себе три сущности, подходящих под это "определение". А теперь - внимание - вопрос: "Что конкретно ты имела в виду"?
insert 7 - 23.06.2004 10:37 | (0) Где-то когда-то видел, но не помню. Причем в обе стороны - txt в ТЗ, ТЗ в txt. главное - регулярность в строках текста. ЗЫ чем по инету шариться искать, потом под себя затачивать, написать нафик под конкретную задачу и то быстрее...


1C 8.0 - Помогите с ТабличнымДокументом | База знаний | mista.ru

1C 8.0 - Помогите с ТабличнымДокументом

Gor 23.06.2004 00:12 | Есть макет (дебиторская кредиторская задолженность), который заполняется некоторыми значениями из баланса (с этим все нормально - выкрутился). Теперь вопрос: В ячейке значение = 1800000,09 мне нужно это отобразить в тысячах, т.е. текст = 1800 - КАК ЭТО СДЕЛАТЬ? Пробывал так: перебирал все ячейки, СодержитЗначение ставил ложь, изменял текст на нужный - НО терялось значение...
ChAlex 1 - 23.06.2004 00:18 | Имя параметра в макете следует сделать отличным от имен переменных запроса или формы и далее присваивать значение параметру. Только значение должно быть СТРОКОВЫМ! (иначе пустая ячейка - считаю, что это глюк, хотя .... может... весьма скрытый смысл, который нам - прстым смертным не доступен ?)
Gor 2 - 23.06.2004 00:23 | Значения я успешно заполняю. Но вот текст должен отображаться совсем другой - вот в чем проблема... Причем пользователь если введет значение в ячейку равное 1000000 - то после нажатия ентер он должен увидеть 1000. В семерке понятно как делать, а тут... нет
ezh 3 - 23.06.2004 11:21 | 1. Ячейка должна "Содержать значение". Тип значения: Число. 2. Установи для ячейки формат: ЧС=3 (сдвиг на 3 позиции).


Печать на указанный принтер | База знаний | mista.ru

Печать на указанный принтер

Кирилй 22.06.2004 14:40 | Нужно пользователю запретить выбирать принтер (заблокировать вывод диалогового окна "печать"). Принтер, на котором будет идти печать я задаю программно.
Valery 2 - 22.06.2004 14:54 | Вытаскиваешь пиктограмму "печать активного документа используя текущие установки принтера", тогда запрос появлятся не будет, но из меню Файл Печать не уберешь. Всеравно вариант.
Кирилй 3 - 22.06.2004 14:59 | (2)всё равно у пользователя останется лазейка для выбора принтера?
Композитор 4 - 22.06.2004 15:02 | (3) Пуск-Настройка-Принтеры... И так для каждого рабочего места.
SnarkHunter 5 - 22.06.2004 15:04 | (3)Отправляй на принтер без просмотра...
Кирилй 6 - 22.06.2004 15:06 | Нужно принудительно печатать часть документов на матричном принтере, остальные через лазарник (ну бзик у директора :) ). Ясно, что не один пользовател не захочет печатать на матричном, конечно если рядом не стоит директор, поэтому нужно заставить программно.


Работа с таблицей в режиме ввода данных | База знаний | mista.ru

Работа с таблицей в режиме ввода данных

Искатель 21.06.2004 11:42 | Решаю аттестационные задачи, но аттестационная задача №4 поставила меня в тупик :"- Табличная форма для заполнения плановых бюджетных цифр по выбранному отделу" Если у кого есть пример работы с таблицей(а если пример решения аттестационной задачи №4 то ваще будет класно) в режиме ввода данных, то поделитесь пожалуйста.
Волшебник 2 - 21.06.2004 12:29 | http://www.mista.ru/kurs1c/8.htm


Напечатать текст "вверх ногами" | База знаний | mista.ru

Напечатать текст "вверх ногами"

afk 20.06.2004 21:14 | - каким способом это возможно?
mszsuz 1 - 20.06.2004 21:24 | Excel или ВК
mszsuz 2 - 20.06.2004 21:26 | ... или картинка
Волшебник 3 - 20.06.2004 21:52 | В версии 8.0 см. свойство, определяющее наклон текста в градусах.
427 5 - 20.06.2004 22:17 | а в версии 6 и без ВК можно было.....
Asmody 6 - 20.06.2004 22:19 | (0) вопрос еще где напечатать?
Z1 7 - 21.06.2004 07:45 | (0) ActiveText (3) Так не годиться потому что слово будет написано при этом справо налево
FAM 8 - 21.06.2004 08:16 | Найди или нарисуй шрифт
Z1 10 - 21.06.2004 08:39 | (9) Скорее всего это нужно для ценника чтобы цена ( и внутр код для весов) были видны с двух сторон. Поэтому если делать как (3 или 8) надо дополнительно еще и переворачивать исходную строку текста. (есть наклон текста, а есть наклон всей строки) ИМХО 7 самый оптимальный вариант как по скорости работы так и по времени написания программы.
Волшебник 11 - 21.06.2004 10:11 | Можно печатать строку по одной букве, каждую из которых поворачивать на 180 градусов.
afk 12 - 21.06.2004 10:21 | Спасибо! Особенно за наводку на ActiveText! (9) нужно именно так, как написано: "вверх ногами". Напишите на бумажке слово, переверните лист на 180 гр. - это и будет "вверх ногами". (10) Совершенно верно! Еще раз большое спасибо!


Как запретить печать выходной формы отчета | База знаний | mista.ru

Как запретить печать выходной формы отчета

graf 20.06.2004 10:17 | После построения отчета, необходимо заретить печать, результирующей таблицы. Как это можно зделать?
Warlock 5 - 20.06.2004 11:23 | (0,3)Если Таб - это результирующая таблица, то перед методом Показать(): Таб.ОбластьПечати(0,0,0,0); Таб.Защита(1); Сообщить("Попробуй распечатай!");//Эта строка необязательна :)
427 7 - 20.06.2004 11:44 | (5) я не буду говорить, как вся эта хрень обходится..... (0) вместо формирования таблицы загоняй все в ТЗ, которая лежит на форме отчета... И да будет тебе счастье ....
Warlock 10 - 20.06.2004 11:52 | (7)А эта хрень обходится? Подскажи как!(В целях защиты!)
SnarkHunter 11 - 20.06.2004 11:53 | (10)Меню Таблица - Убрать область печати... Дальше можно печатать сколько влезет...


Печать справочника "контрагенты" | База знаний | mista.ru

Печать справочника "контрагенты"

Alena 18.06.2004 13:38 | Как распечатать справочник "Контрагенты", чтобы были поля: наименование и почтовый адрес. У меня "Торговря и склад".ред.9.2
Волшебник 1 - 18.06.2004 13:40 | Варианты: 1. Воспользоваться конструктором отчетов. 2. Написать свой отчет "с нуля" 3. Взять универсальный отчет и настроить его 4. Взять один из стандартных отчетов и удалить лишние колонки в сформированной печатной форме.
Alena 3 - 18.06.2004 13:46 | Устраевает вариант №3. А где взять универсальный отчет?
Волшебник 4 - 18.06.2004 13:47 | 1c.hippo.ru на ИТС - ПечатьСправочника (кажется)
Arhitektor 5 - 18.06.2004 13:47 | на диске ИТС
SnarkHunter 7 - 18.06.2004 13:50 | Называется refprint.ert


Как в таблице программно скрыть/показать часть столбцов? | База знаний | mista.ru

Как в таблице программно скрыть/показать часть столбцов?

kаdr 18.06.2004 06:42 | Если делаю так Таблица.Область("R2C29:R16C32").Видимость(1); то говорит, что "Поле агрегатного объекта не обнаружено (Видимость)"
maloy 1 - 18.06.2004 07:29 | Нет такого метода у области талицы. Никогда нужды не возникало. Зачем тебе это надо? Попробуй Таблица.Область("R2C29:R16C32").ШиринаСтолбца(0);
kаdr 2 - 18.06.2004 07:31 | Я формирую табель отработанного времени по дням. Так вот если в месяце 30 дней, то 31 день в табеле отображать не надо. Я запретил ввод данных в эти столбцы, но, видимо, еще добавочно сделаю так как ты посоветывал. Спасибо
SnarkHunter 3 - 18.06.2004 07:37 | А если 28?
kаdr 5 - 18.06.2004 08:02 | (3) Без проблем - хоть двадцать два! (4) Это таблица для ввода данных. Вверху форма - на ней выбирается человек и еще кое-какие параметры. Снизу табличная часть - вводятся данные по дням (в часах) по участкам, на которых работал рабочий в этот день
maloy 7 - 18.06.2004 10:30 | (6) Не знаю, никогда так не изголялся. (5) И куда это всё потом сохраняется? в текстовый файл? Или не нужно потом воспроизводить результат? Таблица для ввода данных в данном случае не лучший выбор. Она динамически не строится и вид её не зависит от начальных данных (типа, от месяца). Я бы вставил ТаблицуЗначений в форму и нарезал её на столько дней на сколько нужно. А ещё лучше использовать обычную таблицу вместе с диалогом. Тогда можно динамически её перерисовывать как захочешь. И дни выводить не одной длинной колбасой, а располагать в несколько "слоёв". Значения будут вводиться не прямо в ячейки, а в отдельные диалоги для ввода числа. 1С-ники просто ввели 31 реквизит в документ (по количеству дней), но у тебя, похоже, не документ.


Можно ли в таблице закрепить области? | База знаний | mista.ru

Можно ли в таблице закрепить области?

kаdr 16.06.2004 10:19 | ...как в MS Excel. То есть как сделать так, чтобы при прокрутки таблицы заголовки таблицы не перемещались. Если можно, то как? Спасибо
kаdr 3 - 16.06.2004 10:48 | Прочитал... Нашел... Вид-->Зафиксировать
SnarkHunter 4 - 16.06.2004 10:57 | (3)Если программно, то метод Опции()...
kаdr 5 - 17.06.2004 06:00 | (2) Как в (3) в режиме конфигуратора работает, а в режиме работы с базой не работает. Циатата из ЖКК: Фиксация сторок и столбцов таблицы не переносится в готовый табличный документ. В этом случае необходимо использовать метод встроенного языка Опции(). Сделал так: Процедура ПриОткрытии() Табл = СоздатьОбъект("Таблица"); Табл.ИсходнаяТаблица("Таблица"); Табл.Опции(,,1,1,,,); КонецПроцедуры Не работает... Где я не прав?
SnarkHunter 8 - 17.06.2004 06:32 | При открытии формы еще не существует...
Press 9 - 17.06.2004 17:48 | Процедура ПриОткрытии() Таблица.Опции(,,1,1,,,); КонецПроцедуры


Таблица в режиме ввода данных. HELP!!! | База знаний | mista.ru

Таблица в режиме ввода данных. HELP!!!

Nick_ 15.06.2004 12:25 | Есть таблица в режиме ввода данных. Она формируется динамически след образом: Для с=1 по Тз.КоличествоСтрок() Цикл ТекОбласть=Таблица.Область("R"+Строка(с)+"C1"); ТекОбласть.Значение=ТЗ.ДоговорЗайма.Процент; ТекОбласть.Редактирование(1); КонецЦикла; Вопрос: почему не работает метод Редактирование() ???!!! (нужно сделать, чтобы в ТекОбласть можно было заносить новые значения) Что я не так делаю???
wind_wail 1 - 15.06.2004 12:52 | Гы... у меня такая же хрень была. Времени не было разбираться и я сделал ввод нового значения в предопределнной процедуре ПриВыбореЯчекиТаблицы вызывая ВвестиЧисло(). Конечено это не красиво, но нужно было сделать все быстро.
barada 8 - 16.06.2004 06:58 | Совсем динамически такую таблицу сделать нельзя, можно лишь условно динамической. То бишь в режиме конфигуратора определяешь в таблице, ну скажем в 300 строках в нужной тебе области тип значения "неопределенный", а уже после того как известно кол-во строк в исходной таблице проходишь циклом и устнавливаешь (УстановитьТип или НазначитьТип (см. док.)) у нужной области "ТипЗначения" (но не забывай предельное кол-во строк 300). Если заведомо формирующаяся таблица неособо большая, то такой метод вполне подходит + можно сделать, такую хрень и не для одной колонки, а полностью для строки. Если не совсем понятно, могу выслать пример тока скажи куда.


Как получить текст расшифровки в таблице отчета. | База знаний | mista.ru

Как получить текст расшифровки в таблице отчета.

sheale
16.06.2004 16:40 		Как получить текст расшифровки в таблице отчета. Т.е. тот текст, который написан в свойствах ячейки в поле расшифровка?
sheale
2 - 16.06.2004 17:07 		По этому тексту можно обращаться именно к нужной ячейки, отсеивая ненужные (в столбце или строке).
sheale
4 - 16.06.2004 17:14 		Для н=4 по Таб.ВысотаТаблицы() цикл
// тут я проверяю на пустую строку (выкрутился), но в этом столбце может быть не пустое значение расштфровки.
Если ПустаяСтрока(Таб.Область("R"+н+"C9").Расшифровка())=1 Тогда -- здесь
Колич = Число(Таб.Область("R"+н+"C9").Текст);
Тз.НоваяСтрока();
Тз.Количество = Колич;
Тз.Номенклатура = Таб.Область("R"+н+"C4").Расшифровка();
Тз.ПоСчету = Таб.Область("R"+н+"C6").Расшифровка();
з.ПоЗаявке = Тз.ПоСчету.ДокОснование;
Тз.ЗаявкаБМ = Таб.Область("R"+н+"C8").Расшифровка();
КонецЕсли;
КонецЦикла;
Рупор абсурда
6 - 16.06.2004 17:24 		Проверяй ЗНАЧЕНИЕ рсшифровки на пустое ЗНАЧЕНИЕ, а не на пустую строку ...
Рупор абсурда
10 - 16.06.2004 17:30 		(7) Нуууу, к примеру, если ты в функцию ПустаяСтрока() подставишь элемент справочника с наименованием "" и представлением в виде наименования, она вернёт 1 ...
LOSS
12 - 16.06.2004 17:34 		ПустаяСтрока
Проверить строку на наличие значащих символов.

Синтаксис:

ПустаяСтрока(<Строка>)

Англоязычный синоним:

IsBlankString

Параметры:

<Строка>
Строковое выражение.

Возвращаемое значение:

Числовое значение. 1 — пустая строка или только пробелы. 0 — не пустая строка.

Описание:

Функция ПустаяСтрока проверяет переданный параметр <Строка> на наличие значащих символов (любых кроме пробелов) и возвращает число 1, если строка пустая или содержит только пробелы, 0 , если строка не пустая.

Пример:

Если ПустаяСтрока(Буфер) = 1 Тогда

// если Буфер содержит только пробелы, то его удаляем

Буфер = "";

КонецЕсли;

А вот значение

ПустоеЗначение
Проверить значение любого типа.

Синтаксис:

ПустоеЗначение(<3начение>)

Англоязычный синоним:

Empty Value

Параметры:

<3начение> Выражение любого типа данных, значение которого проверяется на «пустое».

Возвращаемое значение:

Функция возвращает числовое значение: 1 — значение пустое; 0 — значение не пустое.

Описание:

Функция ПустоеЗначение определяет, является ли пустым переданное в параметре значение. При этом применяется следующее правило:

- значение неопределенного типа — всегда пустое;

- значение типа «строка» проверяется как в методе ПустаяСтрока;

- значение типа «число» проверяется на равенство нулю;

- значение типа «дата» проверяется на пустое значение;

- значения следующих типов: «справочник», «перечисление», «документ», «счет», «вид субконто», «план счетов», «календарь» проверяются как в методах Выбран для соответствующего типа объекта.

Пример:

Если ПустоеЗначение(Код) = 1 Тогда

Предупреждение("Задайте непустое значение Кода !!!");

КонецЕсли;
romix
19 - 17.06.2004 14:01 		(15) Есть такая функция - Расшифровка()
Может она вернет этот текст - если хочешь, попробуй...
А вообще, чтобы однозначно идентифицировать ячейку, я всегда использую такой трюк:

п=СоздатьОбъект("СписокЗначений");
п.ДобавитьЗначение("Какой-то идентификатор");
п.ДобавитьЗначение(док);
Расшифровка=п;

Ну и извлекаю из расшифровки тоже список значений, и из него беру, что мне надо
(ПолучитьЗначение()


Сортировать по алфавиту отчет Реестр Документов | База знаний | mista.ru

Сортировать по алфавиту отчет Реестр Документов

busy1 17.06.2004 14:18 | Как отсортировать отчет Реестр документов по конкретной колонки отчета? (Колонка выводит Текст) 1C Бух.
Gavrila 1 - 17.06.2004 14:54 | загружай сперва все в таблицу значений, сортируй, и выводи на печать уже из таблицы значений. Либо сохрани в xls и там сортируй :)


Шапка на каждой новой странице отчета | База знаний | mista.ru

Шапка на каждой новой странице отчета

Freelancer
17.06.2004 14:12 		Где надо установить параметр чтобы выводилась шапка на каждой новой странице отчета?
It is me
1 - 17.06.2004 14:25 		ПовторятьПриПечатиСтроки(<?>,);
Синтаксис:
ПовторятьПриПечатиСтроки(<НачСтрока>,<КонСтрока>)
Назначение:
Задать строки результирующей таблицы, повторяющиеся при печати в начале каждой страницы.
Параметры:
<НачСтрока> - номер первой строки повторения.
<КонСтрока> - номер последней строки повторения.
Замечание:
Метод может использоваться при работе с таблицей в режиме ввода данных.
lexa
7 - 17.06.2004 14:39 		http://www.mista.ru/articles1c/hare/article.51.html
busy1
9 - 17.06.2004 14:40 		Да вообще то это стандартная фигня. Посмотри как это сделано в других отчетах
к примеру в Отчет реестр документов. Там в модуле форме прям есть кусок
процедуры ("Сформировать") с комментарием "вывод шапки на каждой страницы")
busy1
11 - 17.06.2004 14:44 		Вот так это выглядит точно :
// выводим шапку на каждой странице
НачПовт = Таб.ВысотаСекции("Кнопки") + Таб.ВысотаСекции("Шапка");
КонПовт = НачПовт + Таб.ВысотаСекции("ШапкаТаблицы");
Таб.ПовторятьПриПечатиСтроки(НачПовт + 1, КонПовт);


Как добраться до печатных форм.... | База знаний | mista.ru

Как добраться до печатных форм....

Aiuan 17.06.2004 13:24 | например стандартные печатные формы (ТОРГ12)
NastyFrog 3 - 17.06.2004 13:32 | Общие таблицы + \ExtForms\PrnForms\... ptorg12.ert torg12.ert
Aiuan 5 - 17.06.2004 13:53 | возвращаясь к этому вопросу.... как добавить/удалить/изменить элемент меню, где выбираются формы отчета... например поменять ему ассоциированный файл..
Aiuan 6 - 17.06.2004 13:54 | кароче как до менюшки выбора печатных форм добраться?
SnarkHunter 7 - 17.06.2004 14:03 | В сервисе регистрацию печатных форм смотри... Ленивые все...


ИТОГ по колонке | База знаний | mista.ru

ИТОГ по колонке

Freelancer 17.06.2004 10:57 | Можно ли выводить итог по колонке для отчета вводя команду только в самой ячейке отчета? или надо обязательно прописывать в модуле?
427 2 - 17.06.2004 11:23 | Можно.... в некоторых случаях....
Волшебник 3 - 17.06.2004 11:29 | (2)+ Если выводится табличная часть документа, то можно воспользоваться функцией Итог("ИмяКолонки")
Outlander 4 - 17.06.2004 11:35 | +3 если у колонки включен "Итог по колонке". (2) еще в каких-то?


Как отобразить в отчете часть ячейки полужирным шрифтом? (ЗиК 7.7) | База знаний | mista.ru

Как отобразить в отчете часть ячейки полужирным шрифтом? (ЗиК 7.7)

3V 1 - 16.06.2004 15:05 | на сколько помню стандартными средствами никак... :(
olgert 2 - 16.06.2004 15:10 | Сорри, не дописала, Проблема в следующем: У нас на предприятиии используется произвольная форма приказа на отпуск (на фирменном бланке). Одним прказом можно отправить в отпуск хоть 100 человек (и такое бывает). Бухалтер по зарплате жалуется на нечитабельность документа и просит выделить жирным шрифтом Фамилии и даты начала и окончания отпуска. Вот, собственно и вопрос: можно ли в одной ячейке выделить жирным шрифтом избранные слова. Убеждения в том, что им это не надо уже не помогают.
AlexMan 4 - 16.06.2004 15:16 | Шрифт один на всю ячейку т.е. можно выделить например Фамилия+Имя+Отчество а просто Фамилия нельзя.
90-78_2 5 - 16.06.2004 15:20 | Поищи в Сети расширения (OLE-контейнеры). Может, что подходящее найдешь.
Z1 8 - 16.06.2004 17:22 | (0) Использовать стандартный объект таблицы 1с - Текст ( таблица --> вставитьрисунок --> текст ) или ActiveText - тогда можно даже динамически менять любую характиристику щрифта в том числе нормальный-полужирный.
Z1 12 - 17.06.2004 09:04 | (11) Только что попробовал - можно вставить объект OLE MS Word - и все получилось в объекте MS Word можешь менять все что захочешь. Шрифт размер цвет.
olgert 13 - 17.06.2004 10:04 | (12) Да, попробовала, действительно меняет и цвет и шрифт, но это текстовое поле и значения(6) там не вычисляются :-(
Z1 14 - 17.06.2004 10:09 | (13)Это OLE объект. Указатель на него у тебя есть, а далее документация MS все можно найти и раскопать. весь MSDN лежит в ONLINE на microsoft.


Как значения несколких разных отчетов собрать в своем отделно сделанном? | База знаний | mista.ru

Как значения несколких разных отчетов собрать в своем отделно сделанном?

Оля 16.06.2004 13:00 | Мне нужно сделать свой отчет, который бы отражал значения других отчетов и обработок. Примерный алгоритм подскажите!!!
AlexP 3 - 16.06.2004 13:16 | 1.Сформировать отчеты, из которых нужны данные. 2.Выгрузить их во внешние файлы. 3.Написать свой отчет, который из внешних файлов выберет нужные тебе данные и поместит в твой отчет. 4.Посмотреть, что получилось. 5.Удалить все, что сделала. 6.НАПИСАТЬ НОРМАЛЬНЫЙ ОТЧЕТ, выбирающий из БД нужные тебе данные.
Оля 5 - 16.06.2004 13:33 | Нельзя! Нужны данные которые формируют только отчеты! А я не хочу весь алгоритм формирования цифирок писать в своем отчете, хочу только итоги выдернуть.
Владимир 9 - 16.06.2004 15:56 | Проше всего, тогда будет, сформировать все "отдельные" отчеты и перетащить куда-нибудь в Excel. Если "только итоги выдернуть" тогда эти самые отчеты все равно формировать надо.....
romix 10 - 16.06.2004 16:53 | Я так понимаю, что Оля хочет пойти по пути декомпозиции своего отчета - вынести часть расчетов во внешние модули. Своего рода, Unix way. :-) В случае 1С проще всего заставить дочерний отчет формировать ТаблицуЗначений, и передавать ее основному отчету, например, через временный файл.
sheale 12 - 16.06.2004 16:58 | (10)Данные можно передать и через Форма.Параметр.тз Только тз должна быть на форме. И из временного отчета открыть главный.
spock 13 - 16.06.2004 17:06 | ДописАть в отчетах возможность выгрузки данных, например, в дбф. Каждый отчет - свой файл. Потом собрать эти данные. Можно использовать mxl, текст. И даже ексель - отчет на лист. Потом сводно. Вах, фантазия моя гранична :)


Режим ввода данных | База знаний | mista.ru

Режим ввода данных

Nataly 16.06.2004 10:38 | Подскажите,как обратиться к именованой области, чтобы использовать ее значение в формуле другой ячейки.
Рупор абсурда 1 - 16.06.2004 11:26 | Таблица.Область("ИмяОбласти") ... или совсем просто: Таблица.ИмяОбласти ...
Valery 2 - 16.06.2004 11:29 | Таблица.Область("ИмяОбласти").Значение
Valery 4 - 16.06.2004 11:47 | Таблица.Область("ИмяОбласти") это просто ссылка на область
Nataly 6 - 16.06.2004 12:57 | А кто подскажет про процедуру пересчет(), которая задается в верхнем углу таблицы и выполняется при изменении какой-либо из ячеек? Это для того, чтобы не пользоваться формулами, а в ячейку выводить сразу значение.
Nataly 8 - 16.06.2004 13:01 | (7)Наверное, не совсем. Нужно красиво вычислить это значение, при помощи формул. Т.к. часть данных вводится в таблицу, а другие рассчитываются на основе этого.
Valery 9 - 16.06.2004 13:03 | (5) Дошло. формула в ячейке таблицы. ОК (7) Процедура в верхнем углу. Это кнопка что-ли?
Nataly 10 - 16.06.2004 13:06 | Нет не кнопка, в свойствах ячейки в поле формула пересчет(), а в теле модуля описание этого. Мне сказали, что так умные люди теперь делают, чтобы не писать формулы во всех вычисляемых ячейках. А с формулами в ячейках у меня получается.
wolfy 11 - 16.06.2004 13:14 | (10) в свойствах ячейки ставиш галочку Защита. в поле формула пишешь Пересчет(). пересчет описываешь в модуле. Пересчет будет выполняться каждый раз при вводе значения в любую ячейку. В процедуре Пересчет узнать адрес ячейки , которую редактировали можно так Адрес=Таблица.АктивнаяОбласть(); НомерСтолбца=Число(Прав(Адрес,СтрДлина(Адрес)-Найти(Адрес,"C"))); НомерСтроки =Число(Сред(Адрес,2,Найти(Адрес,"C")-2)); введенное значение получить так ВведенноеЗначение=Таблица.Область(Адрес).Значение;


Расшифровка | База знаний | mista.ru

Расшифровка

Незнайка 16.06.2004 10:35 | Подскажите пожалуйста. У меня в отчете находятся элементы справочника, как мне узнать по какому именно кликнули, чтобы сформировать отчет по этому элементу?
Valery 1 - 16.06.2004 11:26 | В макете отчета, в ячейке, где выводятся элементы справочника, в свойстве поле Расшифровка указываешь н-р: #Расшифровка (Это список значений, который заполняется в модуле н-р Элемент справочника), затем это значение передается в обработку ОбработкаЯчейкиТаблицы(). В ней ты это значение принимаешь и запущаешь свой отчет. примерно так
Рупор абсурда 2 - 16.06.2004 11:28 | Никак ... Если, конечно, не внести предварительно его в поле "Расшифровка" ...


ОбработкаЯчейкиТаблицы() с закрытой формой | База знаний | mista.ru

ОбработкаЯчейкиТаблицы() с закрытой формой

ander139 09.06.2004 16:41 | Вот формируется таблица отчета с кнопочками-ячейками (в смысле, расшифровка у них есть). Обрабатываются они процедуркой ОбработкаЯчейкиТаблицы(). Но если закрыть саму форму отчета, то функция перестает работать. Можно ли как-нить сделать, чтобы работало, даже когда форму закрываешь?
Gavrila 1 - 09.06.2004 16:47 | Если данная процедура описана в модуле формы, то вызывается она, иначе система запускает одноименную процедуру из глобального модуля.
ander139 2 - 09.06.2004 16:52 | (1) Ну, то есть, если я форму закрываю, то вызваться она может только из глобального. И если её нет в глобальном, значит ничего и не будет делаться. Проблема в том, что не имею я допуска к глобальному модулю :)
romix 5 - 09.06.2004 17:01 | (0) Меню Действия-Свойства формы. Там укажи Использовать таблицу - Пустую - Снизу. Назови таблицу "Таблица". Сделай форму узкой (придай ей небольшую высоту, чтобы внизу влезла таблица). Убери в тексте Таблица=СоздатьОбъект("Таблица"); (т.к. объект с именем Таблица уже создан). Тогда внизу формы отчета выползет таблица. При закрытии отчета закроется и таблица. Достаточно прикольный режим, и убирает глюк как в (0). Свойства таблицы (например, невидимость сетки) надо указывать в ПриОткрытии(). Еще можно попробовать в глобальном модуле прописать обработку ячейки, хотя я никогда так не делаю, а всегда вешаю таблицу на форму.
Gavrila 6 - 09.06.2004 17:02 | (4) То о чем спрашиваешь. Не важно закрылась форма или нет, кнопки(ячейки) "Обновить", "Настройка". Но ОбработкаЯчейкиТаблицы вызывается из гл. и там же обрабатывается. Скажи подробней, что именно нужно :)
ander139 8 - 09.06.2004 17:10 | (6) Да, Обновить и Настройка из глобального модуля вызываются, это верно. Но я хочу вставить в таблицу ещё кнопочек и хочу, чтобы они работали при закрытой форме, формирующей эту таблицу. Однако, проблема в том, что я не могу исправлять глобальный модуль.
lexa 9 - 09.06.2004 19:03 | (8) ты из основной формы вместо вывод в таблицу запускай обратку с формой (5), а вкачестве параметров передай всю нужную инфу
lexa 10 - 09.06.2004 19:04 | 9+ не обратку, а обработку


1C:8.0 | База знаний | mista.ru

1C:8.0

mic23 08.06.2004 17:17 | кто может объяснить на примере как передавать параметры в построитель отчетов например: |РегистрБухгалтерии.Основной.ОстаткиИОбороты ( | {&Организация}) А как теперь установить значение параметра Организация реквизитом справочника Организация, выбираем в форме?
Волшебник 4 - 08.06.2004 17:47 | (0) см. свойство Параметры
Волшебник 7 - 08.06.2004 18:09 | Это не метод, а свойство. Обращайся к нему без скобок.


Разделитель стараницы и Co | База знаний | mista.ru

Разделитель стараницы и Co

ФАКОэмульсификатор 07.06.2004 16:17 | Привет всем. Следующая проблема: при печати накладных вывожу их, если позволяет кол-во строк, на один лист, но второй экземпляр вставляется сразу после первого. Иногда, при малом кол-ве строк, накладные получаются высотой по пару сантиметров. Как разместить второй экземпляр строго с половины листа?
AlexP 1 - 07.06.2004 16:30 | В параметрах страницы есть опции "Количество экземпляров на странице" и возможные значения "1", "2" и "авто" и "Количество копий". Если поставить "Количество экземпляров на странице" - "2", и "Количество копий" - "2", то на странице будет две копии документа. Если поставить "авто", то программа сама будет определять, поместится ли вторая копия на эту страницу, и если непоместится, то напечатает ее на втором листе.
ФАКОэмульсификатор 2 - 07.06.2004 16:43 | поставил АВТО все равно второй экземпляр выводится сразу под первым, похоже надо в модуле формы поставить между экземплярами разрыв страницы. Я прав?
ФАКОэмульсификатор 3 - 07.06.2004 17:00 | и еще вопрос, можно ли программно получить доступ к указанным (1) настройкам?
AlexP 4 - 07.06.2004 17:07 | Поставь "2 экземпляра на страницу" и посмотри что получится. Плохо если документ большой, на первом листе будет печатать две первых половинки экземпляра, на втором - две вторых половинки экземпляра.
AlexP 5 - 07.06.2004 17:09 | Можно. Форма - Модуль Формы: Таб.ЭкземпляровНаСтранице(2); Таб.КоличествоЭкземпляров(2);


Рассчет высоты таблицы при печати... | База знаний | mista.ru

Рассчет высоты таблицы при печати...

iceTiger 04.06.2004 15:05 | Приветствую знатоков! Вопрос таков: При печати документов с табличной частью (например Расх. накл.) возникают ситуации когда на последней напечатанной странице выводится полностью или частично только секция "Дно", т.е. накладная занимает допустим 1-у страницу, а на второй выводятся только "Директор_________ Бухгалтер___________ /МП/". Бухи кричат, что в таком случае на второй странице должна выводится последняя строка табличной части. Но еще итересней то, что наименование товара может быти очень длинным, т.е. высота строки документа непредсказуема. Если кто-то сталкивался с подобным напишите, или ссылочку. Заренее благодарен.
lexa 2 - 04.06.2004 15:16 | http://www.mista.ru/articles1c/hare/article.51.html
Рупор абсурда 4 - 04.06.2004 18:19 | http://avb1c.narod.ru/?=a24


Рисунок на заднем фоне печатной формы. | База знаний | mista.ru

Рисунок на заднем фоне печатной формы.

VAZ 03.06.2004 18:54 | Вопрос можно ли так сделать?
427 1 - 03.06.2004 19:04 | Можно... Юзай дрова принтера - они делают для любого приложения ....
Рупор абсурда 5 - 03.06.2004 19:17 | Можно положить картинку на таблицу, а всё что нужно сверху её изобразить с помощью текстовых боксиков ... Можно заюзать ВК, называется ЭктивБМП, кажись ..., автор сюда иногда приходит под ником Z1 ..., а найти её можно на хиппе ...
Gavrila 6 - 03.06.2004 19:37 | "activebmp" - кому надо пишите скину, откуда скачал не помню


таблица в режиме ввода данных - как записать ссылку на элемент справочника | База знаний | mista.ru

таблица в режиме ввода данных - как записать ссылку на элемент справочника

gls
03.06.2004 17:31 		В таблицу в режиме ввода данных забивается информация по контрагентам. Ячейка таблицы защищена. Ввод и запись информации осуществляется через проц. ПриВыбореЯчейкиТаблицы:
Клиент = "";
ОткрытьПодбор("Справочник.Контрагенты", , Клиент, 0);
...
в проц. ОбработкаПодбора(Эл) пишу:
Обл = Таблица.Область(СтрокаТаблицы, КолонкаТаблицы);
Обл.НазначитьТип("Справочник.Контрагенты",,);
Обл.Значение = Эл;
Обл.Текст = Эл;
сообщить(ТипЗначенияСтр(Обл.Значение)) - выдает "Строка". В чем дело? Вроде должен быть только что назначенный тип - "Справочник.Контрагенты"?


В отчетах "9'999'999.99" вместо суммы... | База знаний | mista.ru

В отчетах "9'999'999.99" вместо суммы...

Bzzzzz 02.06.2004 10:01 | ТиС 933. В отчетах(например, в ОтчетПоПроектам) для итоговых значений выводятся вместо сумм выражения вида "9'999'999.99". Для вывода используется конструкция ПечПоступило = Формат(тз.Поступило, "Ч012.2.'"). В результате число 21 828 687.05 "не убирается" в этот формат, хотя благополучно лежит в этой самой тз (колонка тз объявлена как Число 15.2). Нафига 1С так сделали? В этом скрыт глубокий смысл? Как это побороть - править все отчеты?
VladZagorsky 2 - 02.06.2004 10:03 | Да. Править отчеты. К вопросу "а нафига?" это ты не по адресу...
Lori 6 - 02.06.2004 13:02 | (0)Попробуй расширить колонку.
SnarkHunter 7 - 02.06.2004 13:11 | (6)Когда колонка Уже - эффект другой...
Bzzzzz 9 - 02.06.2004 20:32 | (8) Это кому адресовано интересно? Ну-ка впиши число формата 15.2 в Формат(Сумма, "Ч012.2.'") и посмотри, что будет. Зачем 1с допускает размерность суммы в тз 15.2, если выводится всё в 12.2 да еще с разделителями ??? ЗЫ. Я бы послал тебя, да вроде как добрею ;-))


Как автоматически подгонать высоту ячейки в соответствии с кол-вом текста? | База знаний | mista.ru

Как автоматически подгонать высоту ячейки в соответствии с кол-вом текста?

MC 01.06.2004 21:16 | Как сделать, чтобы в таблице при выводе отчета автоматически подгонялась высота ячейки в соответствии с кол-вом текста в ней?
Волшебник 1 - 01.06.2004 21:19 | Свойства ячейки - Текст Переносить.
Рупор абсурда 2 - 01.06.2004 21:22 | (1)+ Высота строки - авто Вертикальное объединение - на фиг


Как задать область таблицы в режиме ввода, чтобы м.б. исп-ть .Рамка(,,,,) ? | База знаний | mista.ru

Как задать область таблицы в режиме ввода, чтобы м.б. исп-ть .Рамка(,,,,) ?

Таня 01.06.2004 11:15 | почему в редакции 3.0 такая конструкция: Таблица.Область("R"+Н+"С2:R"+Н+"С10").Рамка(3,3,3,3); выполняется и рамка нормально рисуется, а в 4.5 говорит, что Значение не представляет агрегатрный объект (Рамка). Если надо могу полный код привести.
Таня 1 - 01.06.2004 11:22 | Ок, вопрос снимается, написала Таблица.Область(Н,2,Н,10).Рамка(3,3,3,3);


Как узнать сколько строк в отчете? | База знаний | mista.ru

Как узнать сколько строк в отчете?

evgen 31.05.2004 13:14 | добрый день всем. хэлп.. подскажите как узнать сколько реально строк на странице выводиться в отчете???? например, в секции 1 строка, но в этой одной строке может быть несколько, т.е. высота строки может меняться.
Рупор абсурда 1 - 31.05.2004 13:20 | Штатно только геморрно ...
lexa 3 - 31.05.2004 13:24 | не совсем то, но может поможет http://www.mista.ru/articles1c/hare/article.51.html
Рупор абсурда 4 - 31.05.2004 13:26 | http://avb1c.narod.ru/?=a24


Как работать с гиперссылкой в 8.0 ? | База знаний | mista.ru

Как работать с гиперссылкой в 8.0 ?

ChAlex 25.05.2004 16:35 | Можно ли организовать переход по гиперссылке в табличном документе (аналогично Exel-а). В форме есть заполненный табличный документ с поименованными областями и картинки. В свойствах картинки установлен признак гиперссылки. По щелчку на картинке нужно перейти к поименованной ячейке в табличном документе. Вроде все понятно как обрабатывать, вот только не понятно каким образом можно обновит форму, чтобы искомая ячейка стала активной (или отображалась)?
Волшебник 1 - 25.05.2004 17:33 | Табличный документ должен выводиться в ПолеТабличногоДокумента на форме. У этого элемента управления должен быть назначен обработчик события Выбор. При щелчке на рисунке сработает эта процедура, в которой нужно присвоить значение свойству ТекущаяОбласть объекта ТабличныйДокумент (или ПолеТабличногоДокумента).
ChAlex 2 - 26.05.2004 11:06 | Я так и делаю. ------------------ Процедура Выбор(Элемент, Область, СтандартнаяОбработка) Элемент.ТекущаяОбласть=Элемент.Области.Найти(СокрЛП(Область.Расшифровка)); СтандартнаяОбработка=Ложь; КонецПроцедуры ------------------ Но, ТекущаяОбласть находится за пределами отображаемой страницы и остается невидимой на экране (скроллинг экрана не производится).
Vozhd 5 - 27.05.2004 12:49 | (0) А если табличный документ заменить HTML документом?
ChAlex 6 - 27.05.2004 19:26 | Если не должна скроллиться, то зачем тогда она вообще нужна ? Чем она тогда отличается от Расшифровки ? Только одним кликом вместо двух... ?
Волшебник 7 - 27.05.2004 20:17 | (6) Еще видом курсора: при наведении мышки на гиперссылку курсор меняется на "пальчик".


Поменять програмно шрифт | База знаний | mista.ru

Поменять програмно шрифт

Елена
26.05.2004 14:10 		Подскажите пожалуйста как поменять программно шрифт в таблице 1С.Нужно накладную распечатать разными шрифтами.
SnarkHunter
1 - 26.05.2004 14:13 		У области таблицы есть метод Шрифт()...
lexa
2 - 26.05.2004 14:15 		Таб = СоздатьОбъект("Таблица");

Таб.Открыть("tabl_l.mxl");

ВыбОбласть = Таб.Область("R8C4");

ВыбОбласть.Шрифт("Arial, 204");


Таблица в режиме ввода данных | База знаний | mista.ru

Таблица в режиме ввода данных

lexa
24.05.2004 15:59 		Как из таблицы в режиме ввода данных вызвать поцедуру?
wind_wail
1 - 24.05.2004 16:27 		Для этого есть предопределенные процедуры. Ее пишишь и она вызывается при двойном щелчке, в качестве параметров ей передается адрес ячейки на которой был произведен клик :) К сожалению у меня все дома, сейчас конкретно мало что многу подсказать.
Напиши мне на мыло. Вечерком отвечу, может пришлю что-нибудь полезно.
wind_wail@mosk.ru
lexa
2 - 24.05.2004 18:06 		//******************************************************************************
Процедура ПеренестиВДокумент()
КолСтрок = 0;
КолКолонок = 6;
СчСтрок = 3;
СчКолонок = 0;
ДвепустыхСтрокиПодряд = 0;
КолНепустыхВСтроке = 0;
ВыбОбласть = Шабл.Область("R1C2");
ВыбОбласть.Доступность(0);
ВремТабл = СоздатьОбъект("ТаблицаЗначений");
ВремТабл.НоваяКолонка("N");
ВремТабл.НоваяКолонка("Обозначение");
ВремТабл.НоваяКолонка("Размеры");
ВремТабл.НоваяКолонка("Исполнение");
ВремТабл.НоваяКолонка("ЗаказнойНомер");
ВремТабл.НоваяКолонка("Количество");
Пока ДвепустыхСтрокиПодряд = 0 Цикл
КолНепустыхВСтроке = 0;
ВремТабл.НоваяСтрока();
Для СчКолонок = 1 По КолКолонок Цикл
ВыбОбласть = Шабл.Область("R"+СчСтрок+"C"+СчКолонок);

// Если ВыбОбласть.Текст = "" Тогда
Если ПустоеЗначение(ВыбОбласть.Текст) = 0 Тогда

КолНепустыхВСтроке = КолНепустыхВСтроке + 1;

КонецЕсли;
ВремТабл.УстановитьЗначение(ВремТабл.НомерСтроки,СчКолонок,СокрЛП(ВыбОбласть.Текст));
КонецЦикла;
Если КолНепустыхВСтроке = 0 Тогда
ДвепустыхСтрокиПодряд = ДвепустыхСтрокиПодряд +1 ;
ВремТабл.УдалитьСтроку();
Иначе
ДвепустыхСтрокиПодряд = 0;

КонецЕсли;
СчСтрок =СчСтрок +1;
КонецЦикла;
ВремТабл.ВыбратьСтроки();
Пока ВремТабл.ПолучитьСтроку() = 1 Цикл
НоваяСтрока();
N = ВремТабл.N;
Обозначение = ВремТабл.Обозначение;
Размеры = ВремТабл.Размеры;
Исполнение = ВремТабл.Исполнение;
ЗаказнойНомер = ВремТабл.НоваяКолонка("ЗаказнойНомер");
Количество = Число(ВремТабл.Количество);
КонецЦикла;

КонецПроцедуры
//******************************************************************************
Процедура ОбработкаЯчейкиТаблицы()
Если Шабл.АктивнаяОбласть = "R1C3:R1C3" Тогда
ПеренестиВДокумент();
КонецЕсли;
КонецПроцедуры
//******************************************************************************
При двойном клике ничего не происходит
Макс
3 - 24.05.2004 18:14 		Читай синтаксис-помощник на будущее иногда. Вот тебе просто копия от туда:
"ОбработкаЯчейкиТаблицы()"
Внимание!
Данная предопределенная процедура НЕ вызывается при выборе ячейки таблицы в режиме ввода данных. Для этого случая вызывается предопределенная процедура ПриВыбореЯчейкиТаблицы.
lexa
4 - 25.05.2004 10:14 		(3) процедура ПриВыбореЯчейкиТаблицы - пробовал эффект тот же
Valery
5 - 25.05.2004 10:33 		Параметры в процедуре Процедура ОбработкаЯчейкиТаблицы()где
lexa
6 - 25.05.2004 10:45 		Спасибо всем буду делать а-ля "мудрые" разработчики типовых: напишу специальную обработку и буду ее вызывать модально и з формы документа


Как построить отчет по регистру сведений v.8? | База знаний | mista.ru

Как построить отчет по регистру сведений v.8?

Perepechin 22.05.2004 18:56 | Кто-нибудь разрабатывал отчеты по регистру сведений в 1С v.8? Это сильно отличается от отчетов УТ по регистрам накоплений? (регистры оборотов и остатков). В УТ отчетов по регистрам сведений не нешел. Может не там искал?
Perepechin 3 - 22.05.2004 19:05 | Сделать один раз макет по аналогии с макетом для регистра накоплений, в котором описать всю небесную механику ==> получать отчет по любому регистру сведений (естественно, предварительно подключив макет). Например, в регистре сведений хранятся цены конкурентов и нужно построить отчет, где в строках будут конкуренты и товары (иерархия), а в колонках будут даты, на которые будет указана цена. Или в другой комбинации ... Комбинация настройки строк и колонок должна быть произвольной (из доступного перечня, разумеется).
Тю 4 - 22.05.2004 19:06 | Кончоль отчетов там твое счастье
Непонятливый 5 - 22.05.2004 19:06 | Во-первых, что нужно конкретно сделать? Во-вторых, не путайте теплое с мягким - регистры сведений и накоплений это две ощутимые разницы.
Asmody 7 - 22.05.2004 19:07 | (3) ну это в УТ уже есть. "Консоль запросов" называется. Так, Стас?
Asmody 12 - 22.05.2004 19:10 | (10) учите язык запросов v8 и объект "Построитель отчетов" и будет Вам счастье
Perepechin 17 - 22.05.2004 19:14 | Ну это же понятно, что по одному макету отчет по валютам и ценам не получится. Интересует пример реализации. Вот по регистрам накоплений все ясно (в УТ есть пример), а вот с регистром сведений немного труднее.
Asmody 18 - 22.05.2004 19:16 | (14) и все бросились 8ку запускать :) Отчеты - Универсальные - Консоль отчетов. правда, УТ 8.10.1.4
Непонятливый 19 - 22.05.2004 19:17 | Ну сделай, как велел Великий Митичкин - присобачь запрос к построителю отчетов. А в запросе можно поиздеваться над выборкой из регистра...
Perepechin 24 - 22.05.2004 19:29 | Консоль обнаружена в УТ 8.10.1.6! Ура! Всем спасибо!


Можно ли запустить отчет 1С из Windows | База знаний | mista.ru

Можно ли запустить отчет 1С из Windows

Lazarus
19.05.2004 07:13 		Можно ли через командную строку запустить отчет в 1С?
c:\PF\1cv77\bin\1cv7.exe enterprise /n name /p password имя.отчета
или в 1С не предусмотрен такой режим запуска?
Я слышал что ERTLoader делает подобное, но у меня он открывает отчет, только если запущена 1С.
psk21office
1 - 19.05.2004 10:22 		В принципе верно, но ты забыл указать базу (c:\PF\1cv77\bin\1cv7.exe enterprise /n name /p password /d pathtobase имя.отчета ), а без этого отчет работать не будет. Отчет формируется на основании данных базы, которая должна быть запущена, иначе отчет с пустого места - в простонародии фиг тебе.
klom
2 - 19.05.2004 15:28 		Как запустить ERT-файл из Проводника?
впервые опубликовано: май 2002 на сайте Hare.ru

Этот вопрос относится поднимается на форумах по V7 с завидной регулярностью. Для чего может понадобится такая фича – это пусть каждый решает сам, я же просто опишу как это сделать технически.

Прежде всего: курочить глобальный модуль не нужно, вообще никаких изменений в конфигурации не понадобится. Для решения задачи мы возьмём не V7, а встроенный в Windows сервер сценариев (Windows Script Host, WSH).

Пишем сценария, вот такой:

set wshShell = wScript.createObject("wScript.shell")
wshShell.run """C:\V7\bin\1cv7s.exe"" enterprise /d""C:\MyBase\"" /nПупкин /p123"
wScript.sleep 120000 'подождем пока загрузится (2 минуты)
wshShell.appActivate "1С:Предприятие"
wshShell.sendKeys "^(o)"
wshShell.sendKeys wScript.arguments.unnamed.item(0)
wshShell.sendKeys "~"

И сохраним его с именем, к примеру, RunErt.vbs. Теперь берём командную строку и пишем в ней: RunErt.vbs C:\ERT\MyERT.ert

Жмем Enter, и через 2 минуты, оно ка-а-ак прыгнет ;-)

Естественно, ключи запуска 1cv7 нужно подставить ваши, да и задержку времени, возможно, придется подобрать экспериментально.

Если же нужно запустить ERT в уже загруженной сессии 1С:Предприятия, тогда сценарий будет еще короче:

set wshShell = wScript.createObject("wScript.shell")
wshShell.appActivate "1С:Предприятие"
wshShell.sendKeys "^(o)"
wshShell.sendKeys wScript.arguments.unnamed.item(0)
wshShell.sendKeys "~"

При желании можно даже проассоциировать ert-файлы с RunErt.vbs, тогда по двойному клику из Проводника они будут открываться на исполнение внутри V7.

Может возникнуть проблема: если запущено несколько экзепляров Предприятия, то неизвестно, в каком именно будет открыт наш внешний отчёт.

Заранее согласен со всеми критиками: это не самый красивый, не самый надежный, не самый правильный… да и наверняка не единственный способ проблемы. Но всё же он работает.
Fynjy
4 - 20.05.2004 11:44 		(2) Ню, ню. Сам то пробовал?


Вывод отчета | База знаний | mista.ru

Вывод отчета

Magnus
19.05.2004 13:36 		Проблема такая - есть запрос:
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|Обрабатывать НеПомеченныеНаУдаление;
|Без Итогов;
|Поставщик = Документ.ПриходМолока.Поставщик.Наименование;
|Машина = Документ.ПриходМолока.Машина;
|Вес = Документ.ПриходМолока.Вес;
|Функция ВесСумма = Сумма(Вес);
|Группировка Машина;
|Группировка Поставщик;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
тЗнач=СоздатьОбъект("ТаблицаЗначений");
Запрос.Выгрузить(тЗнач,0,1);
На основе него надо сделать отчет со следующимим столбцами: Машина(№), Количество, Поставщики.
Поставщики должны отображаться в виде списка. Как бы это сделать?
GrayT
1 - 19.05.2004 13:46 		Ну и какие проблемы?
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Таб.ВывестиСекцию("Заголовок");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка() = 1 Цикл
Таб.ВывестиСекцию("............");
КонецЦикла;
Таб.ТолькоПросмотр(1);
Таб.Показать("Так это сделать", "");

А зачем в ТЗ выгружать?
И Документ.ПриходМолока.Поставщик.Наименование - можно без наименования
Magnus
2 - 19.05.2004 13:49 		(1) Видимо, я не до конца объяснил проблему. Этот отчет ежедневный. Просто в течение дня одна машина бывает у нескольких поставщиков и их надо вывести в виде списка, вес естествено суммируется.
GrayT
3 - 19.05.2004 13:56 		Так у тебя две группировки - два цикла по первой и второй группировке. И убери "Без итогов"
Magnus
4 - 19.05.2004 14:01 		Имеется в виду список в одной ячейке. Без итогов убрал.


Создание регламентированных отчетов | База знаний | mista.ru

Создание регламентированных отчетов

Олег 19.05.2004 06:52 | Народ! Как в 1С создать отчет, подобный регламентированному. То есть где диалог с таблицей на одной странице... Заранее Всем благодарен.
Valery 1 - 19.05.2004 08:26 | Когда создаешь экранную форму выбери в Действия.Свойства Формы и установи или "Пустую" или "для ввода данных". В регламентных использован 2 ой вариант


Рейтинг продаж и закупок | База знаний | mista.ru

Рейтинг продаж и закупок

el_dia 13.05.2004 17:13 | Помогите найти или сделать обработку чтобы можно было увидеть рейтинг продаж и закупок продукции за определенный период. Заранее благодарен.
el_dia 2 - 13.05.2004 17:24 | Извиняюсь вылетело из головы. АБТ 3.5.1 ПРОФ Авто Комлексная конфигурация.
Gavrila 3 - 13.05.2004 17:36 | (2) В отчете "Обороты" чего имно не хватает ?
el_dia 4 - 13.05.2004 18:25 | Диаграммы неполноценно строятся и при сливе в EXCEL всего товара горизонтальных ячеек просто нехватает.
Gavrila 5 - 13.05.2004 18:37 | (4) может тогда проще попробовать изменить диаграмму в отчете, а не искать (делать) что-то новое?


Еще раз о таблицах в режиме ввода данных... | База знаний | mista.ru

Еще раз о таблицах в режиме ввода данных...

Львенок
13.05.2004 09:57 		Есть таблица в режиме ввода данных. Мне хочется чтобы при изменении данных в любой из нескольких ячеек, находящихся в одном столбце, другая ячейка пересчитывалась по их значениям. Конечно, можно написать в каждой из этих ячеек формулу и вызывать в ней процедуру пересчета, но когда ячеек много, писать в каждой вызов одной и той же процедуры... некрасиво... Есть предопределенная процедура ПриВыбореЯчейкиТаблицы() - думал она мне поможет... Адрес ячейки передается, можно быстро вычислить, принадлежит ли она той области при изменении которой мы хотим пересчитать результат... Но она вызывается почему-то только для тех ячеек, у котороых стоит "защита", а для редактируемых, как раз и не вызывается... Т.е. все в точности да наоборот от того, что мне нужно.
Есть какой-то более элегантный способ пересчитывать динамически одну ячейку по содержимому других, чем использование в каждой из них прямого вызова процедуры пересчета внутри поля "Формула"? Уж думаю, а не написать ли локальную обработку ожидания... а все опять от незнания правильных путей решения... ;)
___
Искренне Ваш, Львенок.
Таня
2 - 13.05.2004 11:06 		есть способ. в первую ячейку таблицы ставь формулу Расчет() в поле Расшифровка и делай процедуру Расчет()
подробнее смотри в регламентированных отчетах, например в отчетах по НДС например.
Таня
3 - 13.05.2004 11:11 		Извиняюсь не процедуру,а функцию
и еще можно посмотреть отчеты по ЕСН, там тоже есть такое


Есть примеры работы с таблицей в режиме ввода? | База знаний | mista.ru

Есть примеры работы с таблицей в режиме ввода?

Львенок 12.05.2004 16:17 | Очень хочется небольшой и прозрачный кусочек кода в качестве примера работы с таблицей в режиме ввода данных. Просто никогда не требовалось работать с ней подобным образом, а следовательно опыта нет. Хочется избежать типичных ошибок, изобретения велосипеда, и использования сложных методов там, где можно использовать простые. Есть что-нибудь тривиальное, где в таблице значения некоторых полей заполняются, другие рассчитываются, третие недоступны? ___ Искренне Ваш, Львенок.
Таня 1 - 12.05.2004 17:06 | у меня есть примеры, решенная задача по бухгалтерии - отчет инвентаризация материалов с вводом фактических остатков, только я послать смогу только из дома, а еще можно посмотреть регламентированные отчеты.
Valery 2 - 12.05.2004 17:07 | Может в качестве примера регламентные отчеты посмотреть.


Область печати для таблицы. | База знаний | mista.ru

Область печати для таблицы.

jetcom 12.05.2004 19:28 | Возможно ли в таблице задать область, которая будет выводиться на печать? Если "да", то каким образом? Т.е. мне необходимо иметь, к примеру, расчетную колонку по проценту прибыли по каждому наименованию, но нельзя ее выводить на печать...
Gavrila 3 - 12.05.2004 20:45 | ОбластьПечати(<?>,,,); Синтаксис: ОбластьПечати(<Верх>,<Лево>,<Низ>,<Право>) Назначение: Устанавливает из языка область печати табличного документа. Параметры: <Верх> - номер верхней печатаемой строки; <Лево> - номер крайнего левого печатаемого столбца; <Низ> - номер нижней печатаемой строки; <Право> - номер крайнего правого печатаемого столбца. Замечание: Метод может использоваться при работе с таблицей в режиме ввода данных. а вдруг чем то поможет? (неуверенно)


Таблица в режиме ввода данных | База знаний | mista.ru

Таблица в режиме ввода данных

Press 07.05.2004 12:36 | Вот, сижу, разбираюсь. Не могу понять почему нельзя непосредственно присваивать значение ячейки таблицы по стандартному идентификатору - RnCn. Значение присваивается только если поменять название ячейки. Процедура Сформировать() R1C1 = 100;//облом //Переименовываю R1C1 в к1 - присваивает. КонецПроцедуры Приходится делать так: R1C1 = Таблица.Область("R1C1"); R1C1.Значение = 100; Нельзя ли попроще?
Gavrila 1 - 07.05.2004 12:38 | Нет
Рупор абсурда 2 - 07.05.2004 13:08 | Таблица.Область("R1C1").Значение = 100;
Press 3 - 07.05.2004 13:10 | Почему если переименовываешь - то все как надо?
Рупор абсурда 5 - 07.05.2004 13:19 | (4) >>Я хочу непосредственно присваивать значение. А в (2), по-твоему, посредственное присвоение?
Press 6 - 07.05.2004 13:25 | (2)Не работает. Пробывал уже до этого. Непосредственно - R1C1 = 100;
Рупор абсурда 8 - 07.05.2004 13:30 | (6) Фигню какую-то упорно гонишь ... Перечитай, к примеру, (6) ... и подумай хоть чуть-чуть ...
Gavrila 9 - 07.05.2004 13:36 | (6) "Непосредственно - R1C1 = 100;" - см. (1), с извинениями за назойливость
Press 11 - 07.05.2004 13:50 | Извиняюсь, (2) работает. Попробую еще раз "прогнать фигню". Писать вот такую конструкцию: Таблица.Область("R1C1").Значение = Таблица.Область("R1C11").Значение + Таблица.Область("R1C2").Значение - Таблица.Область("R1C8").Значение* *Таблица.Область("R1C5").Значение +... - не прикольно. Стоит переименовать получается вот так: R1C1а = R1C11а+R1C2а+R1C8а+R1C15а+... Ячеек больше 200 каждую переименовывать вручную - долго. Может можно автоматом это сделать?


отчёты в фоновом режиме | База знаний | mista.ru

отчёты в фоновом режиме

Shadal 01.07.2004 11:11 | Интересно можно ли как-нибудь выполнять отчёты в 1с и одновременно продолжать работать с документами, понятно что под одним и тем же пользователем.Или кроме как использовать аналог робота ничего нельзя придумать?(Типа посылаем сигнал на формирование отчёта, у робота в режиме ожидания перехватывается запрос на отчёт. Робот выполняет отчёт и посылает результат заказчику)
Guk 1 - 01.07.2004 11:18 | (0) Тут mszsuz и avb прикольную идейку подкинули. Глянь, может пригодится http://www.sinor.ru/~my1c/knowhow/prikolis.html
mszsuz 5 - 01.07.2004 11:30 | Более наглядный пример по формированию отчета в фоновом режиме можно посмотреть в обработке "Пример обхода справочника в фоновом режиме" http://1c.hippo.ru/cgi-bin/rlist.cgi?r=1c77&s=1&q_page=20&searchstr=mszsuz&order=up_date%20DESC


html Макет в v8 | База знаний | mista.ru

html Макет в v8

Колапс
16.08.2004 18:39 		необходимо сделать макет документа, в формате html .
однако насколько мною было замечено- есть некоторые трудности с параметрами и шаблонами. как использовать параметры и шаблоны при создании макета html? ...
Волшебник
3 - 16.08.2004 20:46 		Дело в том, что работа с HTML-макетом организована совсем по другому принципу, чем с объектом "ТабличныйДокумент".

Допустим у нас есть обработка, у которой есть HTML-макет с именем "HTMLМакет". В модуле формы обработке в процедуре КнопкаВыполнитьНажатие мы пишем:

//Следующая конструкция возвращает объект ОболочкаHTMLДокумента
Макет = ПолучитьМакет("HTMLМакет");

//Эта конструкция возвращает HTML-код макета:
ИсходникHTML = Макет.ПолучитьТекст();

//А эта конструкция получает COMОбъект,
//через который можно манипулировать HTML-макетом:
Document = Макет.Получить();

Свойства объекта Document похожи на свойства элемента управления ПолеHTMLДокумента, т.е. их можно посмотреть в штатной палитре свойств 8.0.

Но общий список свойств, методов и событий соответствует объектной модели DOM (Document Object Model), поддерживаемой IE.

Чтобы присвоить значение, например, ячейке таблицы или полю ввода, нужно обратиться к нему, как это принято в DOM, например:

Document.formname.element.property = value;
Document.getElementById(elemId).style.display = "none";

Более подробно про работу с DOM можно посмотреть в Dreamweaver Reference
или на соответствующих сайтах.

Общее представление о Document Object Model
http://rtfm.vn.ua/prog/js/domintro/
или зеркало http://www.zeiss.net.ru/docs/design/dom/index.htm

Internet Explorer 5.0 и Document Object Model
http://www.compress.ru/Article.asp?id=2069


Оперативные итоги | База знаний | mista.ru

Оперативные итоги

Alex_ 03.07.2004 20:17 | Вопрос такой не открыв период к примеру июль, я не смогу провести документ в этом периоде (опер.) когда я открываю период выходит сообщение о том что если Вы хотите то можете провести доки и выбираются виды доков которые необходимо провести (группа - проведенные и группа - непроведенные ???). Я к примеру выбираю все доки и проведенные и непроведенные. И выбираю ОК. Но я не могу понять 1) Что должно проводиться и что должно произойти. 2) Ничего не проводится и вроде не происходит. ??? Заранее огромное спасибо за просвешение
Warlock 1 - 03.07.2004 20:31 | Перепроведение доков - это перепроведение доков, и его надо делать, если тебе это надо. А непроведенные и проведенные - это соответственно что делать: проводить непроведенные или перепроводить проведенные. Вот так. Хочешь смысл - создай в неоткрытом периоде документы(провести ты их не сможешь), а теперь открывай период и отметь "галочкой" те документы в списке "непроведенные" - и они проведутся! Могу еще смысла придумать :)
Alex_ 2 - 03.07.2004 22:10 | Ну впринцыпе понятно. Огромное спасибо. Но если есть желание к примеру провести документ - то почему сразу не открыть период. и еще один вопросик там есть поле для отбора проведенных доков. Что бы их перепровести. Но как они могут появиться в неоткрытом периоде если они там не проводятся???
Warlock 3 - 03.07.2004 22:26 | (2)Измени ТА на год назад, например. Так у тебя появятся проведенные документы в неоткрытом периоде...


Глюк объекта "Регистры" ? | База знаний | mista.ru

Глюк объекта "Регистры" ?

ChAlex
30.06.2004 12:28 		Обнаружил некорректную работу (а может скрытый смысл...?) при работе объекта "Регистры". В конфе при проведении есть два регистра - "Остатки готовой продукции" и "Спецификация материалов". В "Спецификации материалов" хранятся материалы, списанные на готовую продукцию, которые должны быть списание с таможенного контроля при леализации. Остатки готовой продукции хранятся в разрезе актов сдачи готовой продукции в последнем ресурсе регистра. При прведении документа выполняется следующий код:
Р=СоздатьОбъект("Регистры");
РегГП=Р.ОстаткиГП;
РегМт=Р.Материалы;
РегГП.ВременныйРасчет(1);
РегМт.ВременныйРасчет(1);
Р.РассчитатьРегистрыНа(ТекущийДокумент());
....
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
РегГП.УстановитьФильтр(...,) // Установка фильтра по всем измерениям, кроме последнего - акта приходования готовой продукции
// Далее по стеку списываем готовую продукцию
РегГП.ВыбратьИтоги();
Пока РегГП.ПолучитьИтог()=1 Цикл
....

РегМт.УстановитьФильтр(....) // Установка фильтра по продкукции и складу
РегМт.ВыбратьИтоги();
Пока РегМт.ПолучитьИтог()=1 Цикл
....
КонецЦикоа;
КонецЦикоа;
КонецЦикла;

Так вот в цикл по готовой продукции проходит только один документ (т.е. первый вход в цикл) и далее идет выход из цикла. Заменил объявление регистров на РегГП=СоздатьОбъект("Регистр.ОстаткиГП") и РегМт=СоздатьОбъект("Регистр.Материалы") и РассчитатьРегистрыНа(...) и все заработало.


Как вывести список названий всех имеющихся регистров конфы? | База знаний | mista.ru

Как вывести список названий всех имеющихся регистров конфы?

Apollo 11
22.06.2004 16:19 		Как вывести список названий всех имеющихся регистров конфы? Если кому не трудно ответьте ...
Композитор
2 - 22.06.2004 16:23 		//*******************************************
Процедура Сформировать()

Для К = 1 По Метаданные.Регистр() Цикл
Сообщить(Метаданные.Регистр(К).Идентификатор);
КонецЦикла;

КонецПроцедуры
Волшебник
4 - 22.06.2004 16:27 		Для версии 8.0:

Для Каждого Рег Из Метаданные.РегистрыСведений Цикл
Сообщить("Регистр сведений " + Рег.Имя);
КонецЦикла;

Для Каждого Рег Из Метаданные.РегистрыНакопления Цикл
Сообщить("Регистр накопления " + Рег.Имя);
КонецЦикла;

Для Каждого Рег Из Метаданные.РегистрыБухгалтерии Цикл
Сообщить("Регистр бухгалтерии " + Рег.Имя);
КонецЦикла;

Для Каждого Рег Из Метаданные.РегистрыРасчета Цикл
Сообщить("Регистр расчета " + Рег.Имя);
КонецЦикла;


V8: Планы видов характеристик | База знаний | mista.ru

V8: Планы видов характеристик

ValeriTim 15.06.2004 15:56 | Люди добрые, ктонибудь мне может внятно объяснить что это и счем его едят. Посыласть смотреь документацию не надо - у меня ее нет.
¶ 1 - 15.06.2004 17:45 | Вид характеристики - это свойство, присущее некоторому объекту предметной области: например, цвет, объем, радиоактивность, хрупкость и т.п., которое может принимать некоторое допустимое множество значений - характеристик. ПВХ - это список объектов, называемых "видами характеристик", с каждым из которых связан набор типов допустимых значений характеристики: например, цвет - справочник названий цветов или же числовое значение(RGB), радиоактивность - перечисление "высокая, средняя, низкая" или же числовое значение, и т.п.


Как получить вид движения | База знаний | mista.ru

Как получить вид движения

Term2 15.06.2004 10:57 | Выбираю движения регистра: Док = СоздатьОбъект("Документ"); Рег = СоздатьОбъект("Регистр.ДвиженияПродукции"); д = Док.ВыбратьДокументы("06.04.04","06.04.04"); Пока Док.ПолучитьДокумент()=1 Цикл Рег.ВыбратьДвиженияДокумента(Док); Пока Рег.ПолучитьДвижение()=1 Цикл здесь всякие команды КонецЦикла; КонецЦикла; А как получить вид движения? Приход это или расход. (для регистра остатков)
Medved 1 - 15.06.2004 11:03 | 2(1) Мдя... У тя ж 77 - почему не посмотреть Рег.Приход и Рег.Расход?
AlexP 2 - 15.06.2004 11:07 | +(1) Если Рег.Приход=1 Тогда //Здесь всякие твои команды КонецЕсли;// Это приход Если Рег.Расход=1 //Это расход //Здесь всякие твои команды КонецЕсли;


РассчитатьРегистрыНа! Ну ёлы-палы! | База знаний | mista.ru

РассчитатьРегистрыНа! Ну ёлы-палы!

Crystalizer
09.06.2004 17:54 		есть такой текст:

Ре = СоздатьОбъект("Регистр.ПартииТоваров");
Ре.ВременныйРасчет(1);
Ре.РассчитатьРегистрыНа(ДатаДок); /// !!! тут выдаёт ошибку Поле агрегатного объекта не обнаружено (РассчитатьРегистрыНа) ПОЧЕМУ????
Ре.ВыбратьДвиженияСОстатками(датадок, "Себестоимость");
.......
spock
1 - 09.06.2004 18:03 		ВремРегистры = СоздатьОбъект("Регистры");
Рег = ВремРегистры.ПартииТоваров;
Рег.ВременныйРасчет();
ВремРегистры.РассчитатьРегистрыНа(ДатаДок);
alxkorvin
2 - 09.06.2004 18:09 		(0) Потому что у объекта "Регистр.ПартииТоваров" нет процедуры РасчитатьРегистрыНа
At
5 - 09.06.2004 18:17 		потому что синтаксис языка 1С такой
нету для объектов, созданных функцией СоздатьОбъект(Регистр.ХХХ) метода РассчитатьРегистрыНа()
Crystalizer
6 - 09.06.2004 18:25 		(5) т.е. расчет всегда идёт по всем регистрам?
и если я хочу быстрый расчет то это никак?
At
7 - 09.06.2004 18:27 		Ре = СоздатьОбъект("Регистр.ПартииТоваров");
Ре.ВременныйРасчет(1);
РассчитатьРегистрыНа(ДатаДок);
Gavrila
8 - 09.06.2004 18:28 		(6) не по всем, а по тем которые участвуют во временном расчете (Рег.ВременныйРасчет();)
alxkorvin
9 - 09.06.2004 18:29 		РассчитатьРегистрыНа(<?>,);
Синтаксис:
РассчитатьРегистрыНа(<ГраницаРасчета>,<ГрафаОтбора>)
Назначение:
Рассчитать все регистры с установленным флагом временного расчета на начало события.

ВременныйРасчет(<?>)
Синтаксис:
ВременныйРасчет(<Флаг>)
Назначение:
Установить флаг участия регистра во временном расчете.
Crystalizer
10 - 09.06.2004 18:31 		(7,8) ну так конечно лучше :)

а чем СВодный остаток отличается от остатка?
At
11 - 09.06.2004 18:35 		Метод СводныйОстаток возвращает сводный остаток ресурса <ИмяРесурса> по регистру. Данный метод работает аналогично методу Остаток, однако здесь могут быть заданы не все значения измерений, а только несколько, но обязательно в правильной последовательности, соответствующей структуре измерений данного регистра, как она задана в конфигураторе. Измерения могут задаваться с пропусками (неуказанное значение — просто запятая), фиксируются только указанные измерения.
Gavrila
12 - 09.06.2004 18:36 		(10)
Сводный остаток:
Измерения могут задаваться с пропусками (неуказанное значение - просто запятая), фиксируются только указанные измерения. Метод используется только для регистров остатков.
At
13 - 09.06.2004 18:39 		Для регистра с измерениями «Товар», «Склад», «МОЛ» запись

Рег.СводныйОстаток(Тов1, , "ОстатокТовара");

означает, что ресурс «ОстатокТовара» будет получен только по одному товару (Тов1), но по всем складам и всем МОЛам.
Crystalizer
14 - 09.06.2004 18:46 		(11) понял

но вот результаты вычислений (кстати всё равно долго считает блин, ну хрен с ним):
Из регистра стоимость: 4170930.93
и так по всем товарам!!! :(((

текст такой:

Ре = СоздатьОбъект("Регистр.ПартииТоваров");
Ре.ВременныйРасчет(1);
РассчитатьРегистрыНа(ДатаДок);

Ре.ВыбратьДвиженияСОстатками(датадок, "Стоимость");
себрег = Ре.СводныйОстаток (Товар,,,,,,, "Стоимость");
Сообщить("Из регистра стоимость: "+ себрег );

товар = тот самый товар... но блин... почему же такое значение?
At
20 - 09.06.2004 19:01 		надо использовать что-нить одно...
1.либо делать цикл по "Товар" и получать для каждого сводный остаток..
2.либо использовать <ВыбратьДвиженияСОстатками> и опять цикл, но уже использовать <СводныйОстаток> не получится

и то, и другое одновременно - не очень...
Gavrila
25 - 09.06.2004 19:08 		(22) если не ошибаюсь, то по партиям одна и таже операция выполняется два разы(по фирме, и без фирмы), потому ставь фильтр по фирме :)
romix
27 - 09.06.2004 21:42 		(0) Короче бери образец из типовой конфы (ТиС кажется).
Поиск по слову РасчитатьРегистрыНа (или По).
Мне кто-то это дело посоветовал, и я быстро въехал.


Ре... Ре... Регистр ! Ы ! | База знаний | mista.ru

Ре... Ре... Регистр ! Ы !

Crystalizer 09.06.2004 16:09 | увидел я что есть в регистре "ПартииТоваров" ресурс "стоимость" и "продСтоимость". И обрадовался. Да. Но потом заметил что получить эту информацию по двум измерениям не получается. Все же дьявольские измерения есть таковы: Фирма, Товар, Статус, МестоХранения, Поставщик, Поставка, ПрихДокумент. Я пытался это делать так: Ре = СоздатьОбъект("Регистр.ПартииТоваров"); Ре.ВременныйРасчет(1); себрег = Ре.Остаток (Товар, "Стоимость"); // 1й случай продсебрег = Ре.Остаток (Товар, Склад, "ПродСтоимость");// 2й случай 1С меня вразумило: "Недостаточное число параметров передано при вызове функции/процедуры объекта". Вопрос: чтобы получить значение ресурса "Стоимость" нужно указать ВСЕ измерения или можно обойтись по меньшим количеством? Если можно указывать не все - то каким это способом воплощается в реальность? // про запрос уже догадываюсь, но как-то заморочено уж получица
romix 2 - 09.06.2004 16:14 | см. СводныйОстаток()
alxkorvin 3 - 09.06.2004 16:14 | Пропускать значения можно. Но при этом нужно все таки указывать запятые по количеству измерений всего.
Valery 4 - 09.06.2004 16:16 | Если используешь Остаток,то все.СводныйОстаток не все
Valery 7 - 09.06.2004 16:36 | Последовательность измерений долна быть как в конфигураторе
Crystalizer 8 - 09.06.2004 16:40 | (7) это понятно выяснил что нужно установить ясно расчёт на дату документа (дефолт = на точку актуальности )


Переодический реквизит в справочнике V8 | База знаний | mista.ru

Переодический реквизит в справочнике V8

Denn 08.06.2004 16:39 | Как сделать реквизит справочника переодическим в V8. Понятно, что нужно сделать переодический регистр сведений, но как его связать с реквизитом справочника???
Волшебник 1 - 08.06.2004 16:42 | ПерИодических реквизитов справочников в v8 нет.
Rom 2 - 08.06.2004 16:43 | Каждый раз считывать и перезаписывать при необходимости
Denn 3 - 08.06.2004 16:46 | Понятно, что считывать и записывать, но неужели это лучше и функциональнее чем было до этого в V7, поставил галочку и поехали! Как считывать и как записывать? Читаю книжку вижу фигу:(((
Rom 4 - 08.06.2004 16:48 | Смотри методы работы с периодическими регистрами сведений (Как пример, глянь справочник "Валюты" в УТ)


Ведения учета ресурсов принципиально не выводимых в ноль | База знаний | mista.ru

Ведения учета ресурсов принципиально не выводимых в ноль

Искатель 04.06.2004 17:07 | Вопрос в следующем надо организовать в 1с некую подсистему "покупательского спроса". То есть когда покупатель спрашивает но по каким то причинам не хочет покупать. Делать естественно будем в компоненте оперативный учет, и как по тех- заданию то движение выполняется только в сторону прихода, но в 1с насколько я знаю говорят что вести учет на регистрах принципиально не выводимых в ноль нельзя. Что вы думаете по этому поводу?
DimG 1 - 04.06.2004 17:41 | Используй оборотный регистр.
mszsuz 2 - 04.06.2004 18:30 | ... или субконто с признаком "Только обороты"


Работа с регистрами остатков - где найти подробное описание | База знаний | mista.ru

Работа с регистрами остатков - где найти подробное описание

keyt 04.06.2004 10:20 | Не могу понять, как правильно работать с регистрами остатков, почитала всё что есть в инете по этому. Не могу найти ответ на такой вопрос - какое значение заносится в ресурсы регистров перед их движением (с помощью ДвижениеПриходВыполнить, ДвижениеРасходВыполнить) - абсолютное значение остатка или относительное изменение. Допуститм у меня было 10 единиц чего-нибудь в ресурсе (задано с помощью ДвижениеПриходВыполнить при значении регистра=10), затем произошло изменение этого чего-нибудь на 2 единицы - уменьшилось. Нужно делать ресурс = 2 ед ДвижениеРасходВыполнить либо ресурс = 8 ед ДвижениеРасходВыполнить Была уверена, что первый вариант правильный, но теперь сомневаюсь. Прошу прощения если эсли такой вопрос уже был. Если можно, киньте ссылку, где это объясняется.
mszsuz 1 - 04.06.2004 10:37 | Первый вариант правильный. А что вызвало сомнения?
Gavrila 2 - 04.06.2004 10:41 | (0)-> http://www.mista.ru/tutor_1c/regs.htm
keyt 3 - 04.06.2004 10:43 | Вызвало сомнения неправильное значение остатка в регистре, хотя по коду вроде всё правильно. Значит, надо ошибку искать у себя. Хотя ... Может я остатки неправильно вычисляю (с помощью функции Остаток())


Задваиваются значения по оборотному регистру | База знаний | mista.ru

Задваиваются значения по оборотному регистру

Sasha
02.06.2004 22:25 		Какой-то глюк:
Оборотный регистр. Движения документов по регистру какие нужно.
А отчет выдает значения в два раза больше.
В чем дело - не понимаю.
Помогите, плиз, если кто сталкивался с подобной проблемой...
Sasha
2 - 02.06.2004 23:14 		Не вопрос: вот текст запроса:
|Период с ВыбНачПериода по ВыбКонПериода;
|Контрагент = Регистр.СКП.Поставщик;
|Контракт = Регистр.СКП.Контракт;
|Сумма = Регистр.СКП.Сумма;
...
|КодОперации = Регистр.СКП.КодОперации;
|Функция ПлатежиСумма = Сумма(Сумма) Когда (КодОперации=глКО.Продажа);
|Функция Начислено = Сумма(Сумма) Когда (КодОперации=глКО.Начислено);
|Группировка Контракт;
|Условие (Контрагент в ВыбКонтрагент);

Вот ПлатежиСумма и Начислено задваиваются!
romix
4 - 03.06.2004 20:25 		Короче у тебя видимо надо поставить галку "удалять движения при перепроведении" в документе (в конфигураторе). А от она и задваивает, и затраивает ...
Валентин
7 - 03.06.2004 21:10 		Если ведется управленческий и финансовый учет, то необходимо добавить условие на проверку принадлежности учету (в ТиС 8.7 это соответсвенно для упро - 0, для фин - 1) Примерно так : Условие (фирма=глПустаяФирма), где глПустаФимра=ПолучитьПустоеЗначение("Справочник.Фирмы") (это в 8.7). Если другая редакция - разделитель ищи сам


Отчет по Торговле | База знаний | mista.ru

Отчет по Торговле

Zerg
03.06.2004 11:18 		Есть отчет, нужно изменить запрос так чтобы попадал документ "СписаниеЛома", к-рый двигает регистр "ОстаткиЛома": измерения "Фирма", "Клиент", "Склад" и "вид_драг_металла"... ресурс "Вес"

ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|Фирма = Регистр.ОстаткиТоваров.Фирма;
|Товар = Регистр.ОстаткиТоваров.Товар;
|Склад = Регистр.ОстаткиТоваров.Склад;
|ОстатокТовара = Регистр.ОстаткиТоваров.ОстатокТовара;
|ВесТовара = Регистр.ОстаткиТоваров.ВесРес;
|ФлагУчета = Регистр.ОстаткиТоваров.ФлагУчета;
|"//}}ЗАПРОС

ТекстЗапроса = ТекстЗапроса+"
|Скл_Кл = Регистр.ОстаткиТоваров.ТекущийДокумент.ПриходнаяНакладная.Клиент,
|Регистр.ОстаткиТоваров.ТекущийДокумент.АктПередачиЛома.Склад,
|Регистр.ОстаткиТоваров.ТекущийДокумент.Списание.Склад,
|Регистр.ОстаткиТоваров.ТекущийДокумент.РасходнаяНакладная.Клиент;
|"//}}ЗАПРОС

ТекстЗапроса = ТекстЗапроса+"
|Функция ПриходОст = Приход(ОстатокТовара);
|Функция ПриходВес = Приход(ВесТовара);
|Функция РасходОст = Расход(ОстатокТовара);
|Функция РасходВес = Расход(ВесТовара);
|Функция КонОст = КонОст(ОстатокТовара);
|Функция КонВес = КонОст(ВесТовара);
|Функция НачОст = НачОст(ОстатокТовара);
|Функция НачВес = НачОст(ВесТовара);
|Группировка Скл_Кл без групп;
|"//}}ЗАПРОС

ТекстЗапроса = ТекстЗапроса+"
|Условие(Товар=Выб_Вид_лом.лом);
|Условие(Склад=ВыбСклад);
|Условие(Фирма=глПустаяФирма);
|"//}}ЗАПРОС


Регистры в 1С:Предприятии 7.7 | База знаний | mista.ru

Регистры в 1С:Предприятии 7.7

Дима 02.06.2004 16:33 | Подскажите как использовать регистры? Как их создавать и т.д.
wind_wail 1 - 02.06.2004 16:36 | Почитай учебник на mista.ru, почитай "описание внутреннего языка 1С" (в 2х частях) (пиши на wind_wail@mosk.ru, если нужно поделюсь), на крайний случай можно поглядеть как это делается в стандартных конфигах.
lexa 4 - 02.06.2004 17:26 | http://firststeps.narod.ru/1c/i4.html
HanProg 5 - 02.06.2004 17:37 | В учебнику в стандартном действительно непонятно описано но на www.mista.ru все подробно описано главное помнить что ты работаешь с базой данных имеющей много измерений и посмотреть можно все что угодно в любом срезе это очень удобно и класно лучше работать при помощи запросов с регистром а вообще это в 8.0 стало основой.
romix 6 - 02.06.2004 19:57 | Попробуй создать регистр Остатки (с измерениями Товар и ресурсом Количество). И попробуй создать документ ПриходнаяНакладная и РасходнаяНакладная. Установи флажок Оперативный учет в документах. Модуль проведения в приходной накладной: Процедура ОбработкаПроведения() ВыбратьСтроки(); Пока ПолучитьСтроку()=1 Цикл Регистр.Остатки.Товар=Товар; Регистр.Остатки.Количество=Количество; Регистр.Остатки.ДвижениеПриходВыполнить(); КонецЦикла; КонецПроцедуры В расходной то же самое, но либо Регистр.Остатки.Количество=-Количество; либо Регистр.Остатки.ДвижениеРасходВыполнить(); После проведения документа посмотри в меню Действия - Движения документа, что там изменилось. Чтобы получить итоги по регистру (сколько и каких товаров сейчас на складе), создай отчет, помести на него таблицу значений с именем тз, и напиши Процедура Сформировать() рег=СоздатьОбъект("Регистр.Остатки"); рег.ВыгрузитьИтоги(тз); КонецПроцедуры


ТА и оборотный регистр | База знаний | mista.ru

ТА и оборотный регистр

Petro 28.05.2004 14:13 | Появилась необходимость использовать регистр (оборотный), но так как работа ведется круглые сутки и крайне сложно регулярно запускаться в монопольном режиме хочу открыть период сразу до конца года. Насколько я понимаю, ТА важна при регистре остатков, а при регистре оборотов вроде как и неважно где она стоит (лишь бы не раньше сегодняшней даты). Или я не прав, тогда чем мне это может грозить ? Будут ли тормоза при перепроведении документов задним числом ?
Xelon 1 - 28.05.2004 14:31 | А что в конфигурации отсутствуют регистры остатков? При конфигурации только с оборотными регистрами такую операцию с ТА сделать можно. Тормозов быть не должно.
Petro 2 - 28.05.2004 14:40 | (1) Регистров нет вообще - это самописная конфа на бухе. Для анализа конкретной информации решил, что регистр будет удобнее. Я вооб-ще то не силен в оперативном учете, но предположил, что если нужны только обороты, без остатков, то лучше вместо какого-нибудь забалансового счета сделать регистр, подскажите я не заблуждаюсь ?
Xelon 3 - 28.05.2004 14:49 | (2) Не заблуждаетесь. На регистрах будет работать быстрее и удобнее.


Подскажите где можно почитать о регистрах 8 версии | База знаний | mista.ru

Подскажите где можно почитать о регистрах 8 версии

bel_igor
20.05.2004 12:59 		Подскажите где можно почитать о регистрах 8 версии.
Wareznic
1 - 20.05.2004 13:39 		Автор энтого сайта издал брошюрку - "Разработка в среде 1С Пр 8.0"
Там есть , но мало.
bel_igor
8 - 20.05.2004 14:20 		Например: имеется какойто ресурс который постоянно инкрементируется +1 и нигде не сбрасывается, правомерно ли его формировать как регистр накопления.
bel_igor
10 - 20.05.2004 14:40 		Просто много вопросов типа, что лучше использовать регистр сведений или подчиненый справочник, а может вообще табличную часть справочника. Использовать регистр накопления или в справочнике инкрементировать реквезит (например кол-во заказов), но тогда нельзя посмотреть итог на дату.
А 1с говорит:
o Нельзя на регистрах накопления остатков вести учет ресурсов, принципиально не выво-димых в ноль! Плохо, когда ресурсы регистра остатков (один или все) изменяются документами только «в одну сторону» (только в «+» или только в «-»), т.е. не обеспечивается выведения ос-татков ресурсов в «0». Нарушение этого требования приводит к неоправданному «распуханию» таблиц хранения итогов регистров;
o Нельзя допускать рассогласование по набору измерений при выполнении положительных и отрицательных движений для регистра остатков. Плохо, когда ресурсы регистра остатков (один или все) изменяются документами и в «+» и в «-»), но движения с противоположным зна-ком для одного того же объекта учета выполняются с разными наборами значений измерений, что также не обеспечивает выведения остатков ресурсов в «0».
bel_igor
11 - 20.05.2004 14:41 		А вот еще:
o Единственной достоверной информацией в системе учета следует считать информацию регистров. Информация из документов может рассматриваться лишь как вспомогательная и не может быть абсолютно достоверной при условии наличия документа, аналогичного ручной операции 7.7
Непонятливый
13 - 20.05.2004 15:46 		А чего про них читать-то? Сало как сало...

Всего 4 типа:
1)Регистры сведений;
2)Регистры накопления;
3)Регистры бухгалтерии;
4)Регистры расчетов.
...


1Cv8: Неоперативное проведение | База знаний | mista.ru

1Cv8: Неоперативное проведение

ganesha 13.05.2004 15:18 | Можно ли при неоперативном проведении обращаться к текущим остаткам регистров? ИМХО: никто не запрещает. Другое дело, что текущие остатки отличаются от остатков на дату проведения... Так ли это?
Львенок 1 - 13.05.2004 16:08 | Ну вот поэтому и не стоит к ним обращаться. Т.ч. скорее всего ответ "нет". Хотя (0) справедливо.
¶ 3 - 13.05.2004 16:44 | (0) Обращаться можно. Остатки будут неправильными. Значит - можно, но не нужно.


Использование регистров в запросе | База знаний | mista.ru

Использование регистров в запросе

-morgan-
07.05.2004 16:26 		оброго времени суток всем.
Вобщем проблема в следующем, пишу такой код:

ДатаК=РабочаяДата();
Запрос=СоздатьОбъект("Запрос");
ТекстЗапроса=
"//{{ЗАПРОС(ОстаткиТоваров)
|Период с '01.01.1990' по ДатаК;
|Продукт=Регистр.ПродОст.Продукция;
|Цена=Регистр.ПродОст.Цена;
|Колво=Регистр.ПродОст.Количество;
|Вес=Регистр.ПродОст.Вес;
|Группировка Продукт;
|Группировка Цена;
|"//}}ЗАПРОС
;
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
Сообщить("1");
Пока Запрос.Группировка("Продукт") = 1 Цикл
Сообщить("2");
Пока Запрос.Группировка("Продукт") = 1 Цикл
Сообщить("3");
КонецЦикла;
КонецЦикла;
Сообщить("4");

на выходе хочу получиь 1,2,3,4, а получаю только 1,4, то есть в цикли я не вхожу совсем.
В том что регистр не пуст я уверен.
Подскажите plz. в чем проблема?
SiMazx
3 - 07.05.2004 18:11 		В запросе по регистру должны быть функции. В результирующию выборку включаются только позиции с ненулевыми значениями функций.
Макс
5 - 07.05.2004 18:27 		Допустим регистр остатков. Ресурсы Количество, Вес. Тогда

ДатаК=РабочаяДата();
Запрос=СоздатьОбъект("Запрос");
ТекстЗапроса=
"//{{ЗАПРОС(ОстаткиТоваров)
|Период с '01.01.1990' по ДатаК;
|Продукт=Регистр.ПродОст.Продукция;
|Цена=Регистр.ПродОст.Цена;
|Колво=Регистр.ПродОст.Количество;
|Вес=Регистр.ПродОст.Вес;
|Функция КолвоНачОст=НачОст(КолВо);
|Функция КолвоПриход=Приход(КолВо);
|Функция КолвоРасход=Расход(КолВо);
|Функция КолвоКонОст=КонОст(КолВо);
|Функция ВесНачОст=НачОст(Вес);
|Функция ВесПриход=Приход(Вес);
|Функция ВесРасход=Расход(Вес);
|Функция ВесКонОст=КонОст(Вес);
|Группировка Продукт;
|Группировка Цена;
|"//}}ЗАПРОС
;
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
Сообщить("1");
Пока Запрос.Группировка("Продукт") = 1 Цикл
Сообщить("2");
Пока Запрос.Группировка("Продукт") = 1 Цикл
Сообщить("3");
КонецЦикла;
КонецЦикла;
Сообщить("4");


Как при проведении прописать движения рег., имея переменную с его именем? | База знаний | mista.ru

Как при проведении прописать движения рег., имея переменную с его именем?

Den
14.11.2004 16:01 		Сабж таков. Делаю технологическое перепроведение с заменой элементов справочника. Перед проведением считываю все движения всех регистров нужного документа в ТЗ, выставляю глобальный флаг и перепровожу документ. Но при этом возникает проблема. Обычно в модуле проведения пишется что-то вроде
Конт.Регистр.ОстаткиТовара.ДвижениеПриходВыполнить()
или
Конт.Регистр.Взаиморасчеты.ДвижениеРасходВыполнить()

Все это здорово, но... Имена регистров у меня в ТЗ, движения регистров у переменных, созданных функцией СоздатьОбъект не прописываются и вообще все это делается только в модуле документа. Как быть? Каким образом, имея в переменной имя регистра, прописать движения? Неужели придется шлепать кошмарную конструкцию
Если ИмяРегистра = "Касса" Тогда
ИначеЕсли ИмяРегистра = "Взаиморасчеты" Тогда
...
Это же ужас! Никакой универсальности! Подскажите, как этого можно избежать?
Бивень
10 - 15.11.2004 13:05 		(9) Смешной ты клоун :))
Рег=Регистр.ПолучитьАтрибут(ИмяРегистра);
...
Рег.ДвижениеРасходВыполнить();
Den
23 - 15.11.2004 13:37 		Прикольно получилось
// ********************
//
Процедура ОбработкаПроведения()

//Здесь следует написать алгоритм проведения документа
Рег = Регистр.ПолучитьАтрибут("Новый1");
Рег.Новый1 = Новый1;
Рег.Количество = 1;
Рег.ДвижениеПриходВыполнить();
КонецПроцедуры

Спасибо, Бивень!


Как привязать строку таб части документа к движению регистров этого же док | База знаний | mista.ru

Как привязать строку таб части документа к движению регистров этого же док

Denisr
30.06.2004 07:04 		Ситуация следующая, Документ должен перебрасывать материалы с 10сч на 41сч. Ведется партионный учет. Поэтому сначала документ выбирает регистры по партиям и списывает материалы. Далее выбираем движения регистров этого же документа и определяем общюю сумму списания для каждого из материалов.
Выглятит это так
Док1 = ТекущийДокумент();
Партии = СоздатьОбъект("Регистр.Партии");
Партии.ВыбратьДвиженияДокумента(Док1);
Пока Партии.ПолучитьДвижение() = 1 Цикл
МПЗ2 = Партии.МПЗ;
ВидМПЗ2 = Партии.ВидМПЗ;
СчетУчетаМПЗ = глПолучитьСчетУчетаМПЗ(МПЗ2);
НомерЖурнала = глПолучитьНомерЖурнала(МПЗ2);
СуммаСписания1 = Партии.Сумма;
БазовоеКоличество1 = Партии.Количество;
проблема в том что дальше нужно получить строку документа с наименованием товара(а это новый цикл) а сумму и количество взять из данного цикла

Если вопрос глупый, просьба не высказываться по этому поводу. Все когда-то с чего-то начинали.
SnarkHunter
1 - 30.06.2004 07:53 		Перед проведением по регистру Партии используй метод ПривязыватьСтроку().
Тогда в твоем цикле сможешь использовать конструкцию Док1.ПолучитьСтрокуПоНомеру(Партии.НомерСтроки())...


Как то не получается с вычислением ОБ("","")!!!! | База знаний | mista.ru

Как то не получается с вычислением ОБ("","")!!!!

прочерк
11.05.2004 13:44 		Всё перепробовала,но при вычислении оборотов между счетами никак не берётся то значение,которое именно для этого конртагента и именно такого договора.
Пожалуйста,если кто знаком с этим подскажите как мне получить такое?
Заранее всем ответившим спасибо!
GrayT
3 - 11.05.2004 14:34 		Показала бы как пыталась, так быстрее получится.
А так ИспользоватьСубконто() и запросом
прочерк
4 - 11.05.2004 14:41 		Ок.
Вот примерно так я пишу:
БухИт = СоздатьОбъект("БухгалтерскиеИтоги");
БухИт.ПериодМНГ(ДатаКон);
БухИт.ИспользоватьСубконто(ВидыСубконто.Контрагенты,Расчеты.Контрагент,2);
БухИт.ИспользоватьСубконто(ВидыСубконто.Договоры,Расчеты.Договор,2);
БухИт.ВключатьСубсчета(1,1);
Об = БухИт.ОБ("62.2","62.01");
и далее заношу значение Об в таблицу значений.

Но,значение "Об" берётся общее за данный год. А мне необходимо конкретную цифру по такому контрагенту - Расчеты.Контрагент,и по данному договору - Расчеты.Договор.
прочерк
5 - 11.05.2004 14:49 		а мне пишется:Слишком много параметров передано привызове функции/процедуры объекта
SiMazx
9 - 11.05.2004 15:05 		БухИт.ИспользоватьСубконто(ВидыСубконто.Контрагенты,Расчеты.Контрагент,2);
БухИт.ИспользоватьСубконто(ВидыСубконто.Договоры,Расчеты.Договор,2);
БухИт.ВыполнитьЗапрос(НачПер,КонПер,"62.2,62.02",,,2);
AVP
12 - 11.05.2004 15:36 		БухИт.ИспользоватьСубконто(ВидыСубконто.Контрагенты,Расчеты.Контрагент,2);
БухИт.ИспользоватьСубконто(ВидыСубконто.Договоры,Расчеты.Договор,2);
БухИт.ВыполнитьЗапрос(НачПер,КонПер,"62.2,62.02",,,2);
БухИт.Выбратьсчета();
Если БухИт.ПолучитьСчет(,СчетПоКоду("62.2")=1
БухИт.ВыбратьКорсчета();
Если БухИт.ПолучитьКорСчет(,СчетПоКоду("62.02")=1
ТвойОборот=БухИт.ДО()
...
GrayT
13 - 11.05.2004 15:47 		(12)Зачем так сложно
БухИт.ИспользоватьСубконто(ВидыСубконто.Контрагенты,Расчеты.Контрагент,2);
БухИт.ИспользоватьСубконто(ВидыСубконто.Договоры,Расчеты.Договор,2);
БухИт.ВыполнитьЗапрос(НачПер,КонПер,"62.2,62.02",,,2);
Сообщить(БухИт.ДО); //Вернет ДО между счетами
(10)БО - нет для запроса. И еще
"Ты мальчик или девочка?" (с) :))
Press
16 - 11.05.2004 16:04 		Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,Расчеты.Контрагент,2);
Ит.ИспользоватьСубконто(ВидыСубконто.Договоры,Расчеты.Договор,2);
Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "62.2","62.1",, 2,,);
Если Ит.ПолучитьСчет(,"62.2") = 1 Тогда
Если Ит.ПолучитьКорСчет(,"62.1") = 1 Тогда
ТвойОборот = Ит.КорДо();
КонецЕсли;
КонецЕсли;
427
19 - 12.05.2004 06:23 		Мдя.... Советчики....

(0) в БИ есть режим временных итогов и режим запроса... Разберись с ними...


Бухгалтерские запросы в 1С 8.0 | База знаний | mista.ru

Бухгалтерские запросы в 1С 8.0

Gor 07.06.2004 00:22 | Было бы интересно узнать, как народ в восьмерке достает (оптимально) развернутое сальдо по субсчетам и субконто. Т.е хотелось бы провести анологию с функциями СНДР, СНДРС и т.д.
Волшебник 1 - 07.06.2004 00:27 | Запросами. А точнее обращением к виртуальным таблицам регистра бухгалтерии. Например 1. Выбрать * Из РегистрБухгалтерии.Основной.Остатки 2. Выбрать * Из РегистрБухгалтерии.Основной.Обороты 3. Выбрать * Из РегистрБухгалтерии.Основной.ОстаткиИОбороты
Gor 2 - 07.06.2004 00:43 | А можно одним запросом вытянуть обороты между счетами с итогами по счетам-родителям (т.е. если были обороты между 361 и 311, 362 и 312 и т.д. видеть обороты между 36 и 31, 36 и 311, 361 и 31)? Не хочеться делать запрос на каждую пару счатов, один из которых или оба родители.
Волшебник 3 - 07.06.2004 00:44 | Для этого нужно указать в запросе, что подсчитываются итоги ПО ИЕРАРХИИ. Запрос делается к виртуальной таблице Обороты.


Выбор плана счетов. v7.7 | База знаний | mista.ru

Выбор плана счетов. v7.7

Василий 2 - 26.07.2004 14:09 | Запускаем базу в режиме 1с:Предприятие. Открываем планы счетов: Операции - План счетов. Вижу перед собой открытый "Основной план" и закладку "Бюджетный план". Имена планам счетов присвоил сам ("Основной план" и "Бюджетный план"). Как отлавить момент выбора закладки плана счетов ? Пробовал процедурой ПриВыбореЗакладки(), но результат ноль. з.ы. Прошу прощения за сумбур в первом вопросе.
Волшебник 5 - 26.07.2004 18:57 | Наверное, никак. В форме списка планов счетов закладки генерируются системой автоматически. Достучаться до них программно не получилось. При вызове метода Форма.ИспользоватьЗакладки(1) пишет "Закладки уже задействованы". Метод Форма.ИспользоватьЗакладки(0) игнорируется. p.s. Переходи на 8.0.
Press 9 - 27.07.2004 09:42 | Попробовал на 21 релизе вроде работает. Перем ПрошлПлан; //_____________________________________________________________________________ Функция Тест() ПланСчетов = ТекущийСчет().ПланСчетов().ПорядковыйНомер(); Если ПланСчетов=0 Тогда Возврат \"\"; КонецЕсли; Если ПланСчетов<>ПрошлПлан Тогда Сообщить(ПланыСчетов.ЗначениеПоНомеру(ПланСчетов)); // Вот здесь то //событие и поймали... КонецЕсли; ПрошлПлан = ПланСчетов; Возврат \"\"; КонецФункции //Тест .............................................. ПрошлПлан=1; На форме, естественно, текст с формулой тест().
dkuznecov 14 - 27.07.2004 16:02 | Помещаем на форму функцию (текст с формулой Управление()) В модуле пишем: Функция Управление() Если ИспользоватьПланСчетов()="Основной" Тогда Форма.БлаБлаБла.Видимость(0); КонецЕсли; Возврат 0; КонецФункции
cup of tea 15 - 27.07.2004 16:03 | Может я чего-то не понимаю, но по-моему задача совершенно тривиальная. Планы Счетов - Формы списка - редактировать ->> в основной форме плана счетов на форму списка нужно разместить текстовую метку с формулой. ИспользоватьПланСчетов() в формуле возвратит значение интерактивно выбранного плана счетов, и в зависимости от выбранного плана можно сделать видимыми те или иные колонки.
cup of tea 17 - 27.07.2004 16:07 | (14) только не ИспользоватьПланСчетов()="Основной" , а ИспользоватьПланСчетов()=ПланыСчетов.Основной однако... :-)


БухИтого - установка периода | База знаний | mista.ru

БухИтого - установка периода

RommBoss 25.06.2004 19:18 | Мне надо поставить период отчёта Месяц текущий по месяц+1 Правильно ли это будет? БИ.ПериодД(МесяцОтчета,МесяцОтчета+1);
Press 1 - 25.06.2004 20:27 | Используй - ДобавитьМесяц(Дата>,<ЧислоМесяцев>)...


Ошибка при проведении документа | База знаний | mista.ru

Ошибка при проведении документа

Максим 25.06.2004 10:20 | Почему при проведении документа “Закрытие месяца” в стандартной конфигурации “Бухгалтерия” (7.70.456) может возникать следующая ошибка: Операция.ЗаписатьПроводки(); {Документ.ЗакрытиеМесяца.Модуль Документа(6046)}: Выбранный счет является группой!(проводка 12, счет 44) ??? В конфигураторе ничего не менялось. Ошибка появилась после того, как внесли изменения задним числом в документ.
Gavrila 1 - 25.06.2004 10:24 | потому как у счета 44 мабуть е субсчета :)
Максим 2 - 25.06.2004 14:48 | Это понятно, а что дальше ? Документы перестали проводиться за ВСЕ периоды, кроме самого первого. Я считаю ошибка не в том, что где то проходит счет 44 а не 44.1.1 Делал отчет по проводкам.
Волшебник 3 - 25.06.2004 14:50 | "Я считаю ошибка не в том, что где то проходит счет 44 а не 44.1.1" В данном вопросе я бы поверил системе, а не отчету.


Оборотно-сальдовая по счету... | База знаний | mista.ru

Оборотно-сальдовая по счету...

Crystalizer 22.06.2004 10:59 | кароче оказалось что надо было разложить дебет и кредит на в ОСВ, а в ОСВ по 281 счету и убрать лишнее (см. топик за пятницу) :)))) так вот... там в таблице есть "Итого" и "Итого развернутое". Объясните пжлст - зачем развёрнутое и неразвёрнутое? как я смотрю по отчетам развернутое всегда равно неразвернутому. или оно может быть неравно и это и должно проверяться?
It is me 4 - 22.06.2004 12:55 | Развернутое не будет равно неразвернутому только в случае наличия по счету как положительных остатков так и отрицательных, то бишь если по одним товарам у тебя в минусе 100, по другим в плюсе 200, то свернутое сальдо будет 100, развернутое дебетовое 200, развернутое кредитовое 100.


Субконто: "разворачивать" и "отбирать" | База знаний | mista.ru

Субконто: "разворачивать" и "отбирать"

Crystalizer 15.06.2004 11:05 | что такое отбирать понятно, а что значит Р А З В О Р А Ч И В А Т Ь ?
Crystalizer 1 - 15.06.2004 11:06 | это я про бухитоги: "ИспользоватьСубконто"
Vozhd 2 - 15.06.2004 11:19 | (0) RTFM - ВыбратьСубконто()
Crystalizer 4 - 15.06.2004 12:15 | Ёж: я думал что это как раз "отбирать"...
ezh 5 - 15.06.2004 12:54 | отбирать - это показывать ТОЛЬКО выбранное значение.


Не работает фильтр в бухгалтерских итогах | База знаний | mista.ru

Не работает фильтр в бухгалтерских итогах

ken_gd
09.06.2004 13:04 		Не подскажите почему, когда я в командах
Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Контрагент,2);
Ит.ИспользоватьСубконто(ВидыСубконто.Договоры, Договор,2);
указываю Тип фильтра – 2 – отобрать по данному субконто команда Сообщить (см.ниже) выдает Нулевое СКД, СКК. (На самом деле сальдо не равно 0)
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьРазделительУчета(ВыбЮрЛицо);
Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Контрагент,2);
Ит.ИспользоватьСубконто(ВидыСубконто.Договоры, Договор,2);
Ит.ВключатьСубсчета(0, 0);
Ит.ВыполнитьЗапрос("31.12.2002", НачДата-1, СписокВыбранныхСчетов, ,,3, "Проводка",);
НачДата1=НачДата-1;
Сообщить("НачДата"+НачДата1);
Сообщить("Ит.СКД()"+Ит.СКД());
Пробовала убрать Тип фильтра=2. Выдается сообщение Microsoft ODBC SQL Server Driver/ Connection is busy with results for another hsmt. Невосстановимая ошибка. Программа выполнила недопустимую ошибку и будет закрыта. Что значит это сообщение? И как быть в данной ситуации? Мне надо развернуть для списка счетов по проводкам по определенному контрагенту по определенному договору.
Z1
1 - 09.06.2004 13:22 		(0) Очень странное сообщение sql
Надо делать через список значений.
Дата вводиться не в двойный а в одинарных кавычках т.е надо так '31.12.2002'
Список1= СоздатьОбъект("СписокЗначений");
Список1.ДобавитьЗНачение(Контрагент, "");
Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Список1,2);


Разделитель учета в бухгалтерии | База знаний | mista.ru

Разделитель учета в бухгалтерии

vdi
31.05.2004 09:29 		Уважаемые колеги.
Привожу фрагмент из статьи "Применение "1С:Предприятия 7.7" для организации управленческого учета", размещенной по адресу http://www.buh.ru/document.jsp?ID=326#breakIIrISCINDDIIIDD326DI0.
_________________________
Рассмотрим два способа (идеи) настройки типовой конфигурации "Бухгалтерский учет", которые уже были апробированы на ряде предприятий.

Первый способ - это использование "разделителя учета" в качестве разделителя операций по видам учета, а не только по юридическим лицам, как он обычно используется. Можно использовать в качестве разделителя учета "Фирмы" (как это реализовано, например, в конфигурациях "Торговля+Склад" или "Комплексная конфигурация") или "Виды учета" - управленческий, бухгалтерский. Таким образом, план счетов и аналитические разрезы будут едиными для управленческого учета и учета в целях налогообложения, однако, мы сможем реализовать возможность учета фактов хозяйственной деятельности так, как этого требуют управленцы. В некоторых случаях, правда, одновременно разделить и виды учета, и юридические лица будет не просто (скорее сложно к восприятию, т.к. одна "фирма" будет восприниматься с точки зрения двух учетов). Способ прост на уровне идеи, но в реализации потребует кропотливого конфигурирования.
_________________________

1) В конфигурации "Бухгалтерский учет" у объекта "ПланыСчетов" имеется предопределенный реквизит - "разделитель учета". Варианты значений его следующие: "Не назначен", "СодержаниеПроводки", "НомерЖурнала", "ПервичныйДокумент" и "РаделительУчета". Все. Никаких "Видов учета" из названной статьи здесь нет. Видимо, эти "Виды учета" предполагается создать самостоятельно. Но каким образом? Как я понимаю у нас нет возможности ввести еще одно значение для разделителя учета, например "Виды учета". Тогда о чем идет речь в статье, что-то я не понимаю. Объясните пожалуйста.

2) Одно из значений реквизита "разделитель учета" - "РазделительУчета". С чем кушать такое значение?

3) Правильно ли я понимаю, что выбрав одно из значений разделителя учета, необходимо в документах предусмотреть соответствующий реквизит со всеми вытеакющими.

С уважением, vdi.
SnarkHunter
1 - 31.05.2004 09:32 		Добавление значений для разделителя учета в ПС = добавление реквизитов в Проводке... Отсюда все вытекает...
DimG
2 - 31.05.2004 10:14 		нажми f1 в конфигураторе, когда открыт план счетов, там же все написано. Эх...
427
6 - 31.05.2004 14:02 		Пора мне очки покупать ....

"Как я понимаю у нас нет возможности ввести еще одно значение для разделителя учета, например "Виды учета"."

Разделитель Учета - справочник... Например, виды учета, или фирмы (белая/черная) или иная аналитика... Но полностью проблемы Ч/Б учета разделитель не решает...

"Одно из значений реквизита "разделитель учета" - "РазделительУчета". С чем кушать такое значение?" ... Питаться им можно как справочником

"Правильно ли я понимаю, что выбрав одно из значений разделителя учета, необходимо в документах предусмотреть соответствующий реквизит со всеми вытеакющими" -- правильно. Надо вытащить реквизит на форму и дать возможность его изменять... юзеру... Посмотри комплексную и использование разделителя по фирмам (справочник Фирмы)..
vdi
7 - 01.06.2004 07:27 		Всем спасибо. Помогли. Остался один вопрос. В описаниии говорится, да и 6-й ласково промяукал, что разделителем учета желательно пользоваться, как справочником.

А что мешает мне воспользоваться им, как перечислением. На самом деле программа не мешает. Но тогда справочник - это просто пример использования или могут трудности, если как-то по-другому испоьзовать разделитель.
SnarkHunter
8 - 01.06.2004 07:37 		ИМХО немного не так акценты расставлены...

Я бы сказал не "разделителем учета желательно пользоваться, как справочником", а "в качестве разделителя учета желательно использовать справочник..."

Перечисление в 1С, впрочем, есть частный случай справочника...
427
9 - 01.06.2004 07:58 		Ну почему... Можно и перечисление... например, разделитель учета - перечисление Пол...

Но справочник - более гибкое решение ...

К тому же Ч/Б учет кроме разделителя требует еще многого... что разделитель учета не позволяет сделать

Ну хотя бы на примере...

Человек поехал в командировку. Для закупки материалов для конкретного вида продукции...
В бухгалтерском учете - это затраты всего предприятия...
В управленческом учете - затраты нужно отнести на конкретный вид продукции
В ч/б учете .... по своему

разделитель учета позволяет четко разделить затраты по критерию... но не позволяет сделать более одного критерия распределения... один для одного вида учета, другой для другого...

Это позволяет сделать второй план счетов....
Но геморойно... Пахать не перепахать ...

Либо 2 базы - управленческая со своим распределением, бухгалтерская со своим распределением... Одни и теже документы (единая первичка!) порождают разные движения...

Ч/Б - за счет выборочного переноса ...

P.S. я промолчал про самую главную тонкость переноса... Судя по постановке (0) - слишком прямолинейно поставлена задача... И такая организация ч/б учета сразу видна в отчетности... т.е. не надо быть знатоком, чтобы увидеть ведется ли в фирме ч/б учет...


Отрицательная сумма в колонке ТЗ. | База знаний | mista.ru

Отрицательная сумма в колонке ТЗ.

sov
07.06.2004 13:14 		Мужики, помогите!
В форме надо ввести конкретную Расходную накладную из списка реализованного в виде ТЗ. В форме находится кнопка, при нажатии на которую выполняется следующая процедура:
Процедура Основание()
ТабЗн=СоздатьОбъект("ТаблицаЗначений");
ТабЗн.НоваяКолонка("Док","Документ.РасходнаяНакладная",,,"РасхНакл",18);
ТабЗн.НоваяКолонка("Нум","Число",8,0,"Номер",9);
ТабЗн.НоваяКолонка("Дат","Дата",10,0,"Дата",10);
ТабЗн.НоваяКолонка("Сум","Число",14,2,"Сумма",14);
ТабЗн.ВидимостьКолонки("1",0);
БухИтоги=СоздатьОбъект("БухгалтерскиеИтоги");
БухИтоги.ИспользоватьПланСчетов(ПланыСчетов.Учебный);
БухИтоги.ИспользоватьРазделительУчета(Константа.ОснФирма);
БухИтоги.ИспользоватьСубконто(ВидыСубконто.Контрагент,Покупатель,2);
БухИтоги.ИспользоватьСубконто(ВидыСубконто.РасходнаяНакладная,,1);
БухИтоги.ВыполнитьЗапрос(,ДатаДок,"62");
БухИтоги.ВыбратьСубконто(1);
Пока БухИтоги.ПолучитьСубконто(1)=1 Цикл
БухИтоги.ВыбратьСубконто(2);
Пока БухИтоги.ПолучитьСубконто(2)=1 Цикл
ТДок=БухИтоги.Субконто(2);
КреС=БухИтоги.СКК(1);
ТабЗн.НоваяСтрока();
ТабЗн.Док=ТДок;
ТабЗн.Нум=ТДок.НомерДок;
ТабЗн.Дат=ТДок.ДатаДок;
ТабЗн.Сум=КреС;
КонецЦикла;
КонецЦикла;
ТабЗн.Сортировать("1+");
Стр=0;
Рез=ТабЗн.ВыбратьСтроку(Стр,"Выберите расходную накладную");
Если Рез=1 Тогда
Основание=ТабЗн.ПолучитьЗначение(Стр,"Док");
КонецЕсли;
КонецПроцедуры

Мне непонятно, почему в колонке ТЗ "Сумма" значение суммы получается отрицательным. Хотя в случае Приходной накладной , где реализована та же самая прцедура(только счёт 60-й), сумма положительная. Смотрел проводку данных накладных в журнале операций, везде суммы положительные.
Michael99
1 - 07.06.2004 13:24 		В оборотно-сальдовой красненькие цифры видел ?
Так как "ПланыСчетов.Учебный" сказать что-либо конкретно трудно.
Вероятно закрыл аванс которого небыло, вот и вылезло красное сальдо.
sov
5 - 07.06.2004 13:37 		В данной учебной базе ситуация простейшая. Купил детали, собрал из них новую деталь, продал. Когда купил детали, оплатил покупку через приходную накладную. Продажу оформил через расходную накладную. Деньги от покупателя оформил через приходный ордер. При его оформлении нужно ввести документ (конкретную расходную накладную). Далее всё как в вопросе(0).
427
9 - 07.06.2004 13:50 		(4) фигня... полная

такое (в (0)) происходит из-за наличия у счетов признака А (активный) П (пассивный) АП (активно-пассивный). Почитай про эти признаки...

Есть еще смысл счета...

на примере кассы (счет 50) он активный. т.е. на нем хранится сумма находящихся в кассе денег... Пусть это 100 рупий... Если ты выдашь 80 рупий - останется 20... Далее если расходным ордером (без проверки остатка) выдать еще 30 рупий на руки - в кассе будет минус 10 рупий... Естественно, в жизни такого быть не может..

т.к. счет 50 активный - у него нет кредитового остатка. Фича в том, что в 1С в этом случае возвращается дебетовый остаток НО С МИНУСОМ....

Вообще прочитай про счета нормальную книжку.....


продолжаем получать себестоимость... | База знаний | mista.ru

продолжаем получать себестоимость...

Crystalizer 07.06.2004 12:25 | накидал такой текст. он не катит. скажите где может быть лажа? ит=создатьобъект("БухгалтерскиеИтоги"); ит.ВключатьСубсчета(1); ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, Склад); ит.ИспользоватьСубконто(ВидыСубконто.ТМЦ, Товар); ит.ВыполнитьЗапрос(, ДатаДок, "28.1",,,,,1); // Если ит.ПолучитьСубконто(1) = 1 Тогда Сообщить("1... "); Если ит.ПолучитьСубконто(2) = 1 Тогда Сообщить("--------------------------- "+Ит.СКД("28.1",1,,Склад,Товар,)); КонецЕсли; КонецЕсли; ========================== "1..." не выводит
Gavrila 1 - 07.06.2004 12:32 | Ит.ВыбратьСубконто(1); Перед Ит.получитьсубконто(1)
Gavrila 5 - 07.06.2004 12:40 | (3) да, только здесь Сообщить("--------------------------- "+Ит.СКД("28.1",1,,Склад,Товар,)); я написал так: Сообщить("--------------------------- "+Ит.СКД(СчетПоКоду("28.1"))); и работает :)


Подскажите начинающему, как определить оборот по счету по определенным субк | База знаний | mista.ru

Подскажите начинающему, как определить оборот по счету по определенным субк

leonid11111
30.04.2004 10:51 		Пробовал определять как разницу между функциями СККРС и СНКРС, но че то не получается одновременно по двум субконто. Может есть другой вариант.
Сергей
1 - 30.04.2004 11:13 		ИспользоватьСубконто()
SiMazx
3 - 30.04.2004 11:47 		Перед тем как выполнить запрос по БИ, делаешь нужное количество раз ИспользоватьСубконто с указанием конкретных значений субконто...
Потом после запроса - ВыбратьСубконто, пока получитьСубконто...
AVP
4 - 30.04.2004 11:48 		Ит.ИспользоватьСубконто("Материалы");
Ит.ВключатьСубсчета(-1,-1);
Если Ит.ВыполнитьЗапрос(НачДата, КонДата, "10") = 0 Тогда
Возврат;
КонецЕсли;
Ит.ВыбратьСубконто(1);
Пока Ит.ПолучитьСубконто(1) = 1 Цикл
// Ит.ДО() - это дебетовый оборот
// Ит.КО() - это кредитовый оборот

КонецЦикла;


Как называется функция метаданных для проверки принадлежности к бухучету | База знаний | mista.ru

Как называется функция метаданных для проверки принадлежности к бухучету

FAR 03.06.2004 12:25 | Задача - вывести все непроведенные документы. Причем в конфе есть много видов документов, не принадлежащих к бухучету. Напомните имя функции документа- элемента метаданных , плиз. Где вообще есть описание функций и атрибутов метаданных? Заранее спасибо, FAR
Рупор абсурда 1 - 03.06.2004 12:32 | Документ(Вид).БухгалтерскийУчет
Vantala 2 - 03.06.2004 12:35 | Метаданные.Документ(х).БухгалтерскийУчет Метаданные.Документ(ВидДока).БухгалтерскийУчет Назначение: Определение, принадлежит ли док бухучету (имеет ли доступ к плану счетов) Возвращаемое значение Число - 1 - Да, принадлежит У меня файл для синтакс-помощника не помню где брал, он на многих сайтах есть хочешь скинь мыло - я пришлю


1C SQL 77. Тормозит стандартный запрос по счету по ГРУППЕ субконто | База знаний | mista.ru

1C SQL 77. Тормозит стандартный запрос по счету по ГРУППЕ субконто

Prostoi 26.05.2004 11:28 | Данные: иерархический спр-ик ТМЦ в виде субконто на 201 счете. Порядка 20тыс записей, ну и сколько-то проводок. Сервер: 540МБ ОЗУ, два процессора Pentium 350 МГц // ит.ИспользоватьСубконто("ТМЦ",ГруппаТМЦ,1,0) ит.выполнитьЗапрос(НачМесяца,Конмесяца,СчетТМЦ) Во-первых такой запрос на 100 % и надолго (2-5мин) загружает процессор. Во-вторых зависают все подключенные пользователи. То есть , мне кажется, что SQL так подвисает когда формирует запрос. Причем если делать запрос не по группе , а по всему спр-ку, то тормозов нет, да и запрос выполняется быстрее. Что можете посоветовать ?
SnarkHunter 1 - 26.05.2004 11:36 | Прямой запрос...
427 2 - 26.05.2004 11:55 | Да... такой запрос на сиквеле напрочь ложит сервер... Но у меня на ДБФ такой запрос летает.... Попробуй заменить ВыбраннуюГруппу ТМЦ на список значений, куда загрузи ТМЦ из выбранной группы... и в запрос запихивай СЗ....
Z1 3 - 26.05.2004 12:52 | Вместо ит.ИспользоватьСубконто("ТМЦ",ГруппаТМЦ,1,0) Надо Список1.ДобавитьЗначение(ГруппаТМЦ,""); ит.ИспользоватьСубконто("ТМЦ",Список1,2,0) Надо фильтры ставить - исключи обороты и.т.д - оставляй только то что нужно. Ну и железо для sql базы то что ты описал это не сервер.
Prostoi 4 - 26.05.2004 12:58 | Я посмотрел в профайлере, какой запрос генерит сиквел....одуреть. Может в 1С можно какой-то индекс для групп сделать ? А лучший вариант, по-моему, делать запрос по всему спр-ку, а потом выбирать нужную группу.


Проблема с корреспондирующими счетами | База знаний | mista.ru

Проблема с корреспондирующими счетами

Willhelm
18.05.2004 17:07 		Народ помогите разобраться со следующей ситуацией. Нужно получить выборку по контрагентам и договорам по счету 76.4 с остатками на начало и конец периода, а также обороты корреспондирующих счетов по каждой из позиций

//****************
Процедура Сформировать()
ТД=СоздатьОбъект("Таблица");
ТД.ИсходнаяТаблица("Дебеторы");
ТК=СоздатьОбъект("Таблица");
ТК.ИсходнаяТаблица("Кредиторы");

Ит=СоздатьОбъект("БухгалтерскиеИтоги");
Итг=СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты);
Ит.ИспользоватьСубконто(ВидыСубконто.Договора);
Ит.ВключатьСубсчета(1,1);
Ит.ВыполнитьЗапрос(Дата1,Дата2,"76.4","51.1;52.1;52.2;62.1;66.1;69.1;70;79.1;79.2;79.10;90.1;91.1");

ТД.ВывестиСекцию("Шапка");
Ит.ВыбратьСубконто(1);
Пока Ит.ПолучитьСубконто(1)=1 Цикл
Контрагент=Ит.Субконто(1);
ТД.ВывестиСекцию("Контрагент");
Ит.ВыбратьСубконто(2);
Пока Ит.ПолучитьСубконто(2)=1 Цикл
Договор=Ит.Субконто(2);
ДатаДоговора=Ит.Операция.ДатаОперации;
СНД=Ит.СНД();
СНК=Ит.СНК();
СКД=Ит.СКД();
СКК=Ит.СКК();
КО76_4=Ит.КО();
Ит.ВыбратьСчета(0,1);
Пока Ит.ПолучитьСчет()=1 Цикл
Ит.ВыбратьКорСчета(1,2);
Пока Ит.ПолучитьКорСчет()=1 Цикл
Если Ит.КорСчет=СчетПоКоду("51.1") Тогда
КО51_1=Ит.КорКО();
ИначеЕсли Ит.КорСчет=СчетПоКоду("52.1") Тогда
КО52_1=Ит.КорКО();
ИначеЕсли Ит.КорСчет=СчетПоКоду("52.2") Тогда
КО52_2=Ит.КорКО();
ИначеЕсли Ит.КорСчет=СчетПоКоду("62.1") Тогда
КО62_1=Ит.КорКО();
ИначеЕсли Ит.КорСчет=СчетПоКоду("66.1") Тогда
КО66_1=Ит.КорКО();
ИначеЕсли Ит.КорСчет=СчетПоКоду("69.1") Тогда
КО69=Ит.КорКО();
ИначеЕсли Ит.КорСчет=СчетПоКоду("70") Тогда
КО70=Ит.КорКО();
ИначеЕсли Ит.КорСчет=СчетПоКоду("79.1") Тогда
КО79_1=Ит.КорКО();
ИначеЕсли Ит.КорСчет=СчетПоКоду("79.2") Тогда
КО79_2=Ит.КорКО();
ИначеЕсли Ит.КорСчет=СчетПоКоду("79.10") Тогда
КО79_10=Ит.КорКО();
ИначеЕсли Ит.КорСчет=СчетПоКоду("90.1") Тогда
КО90_1=Ит.КорКО();
ИначеЕсли Ит.КорСчет=СчетПоКоду("91.1") Тогда
КО91_1=Ит.КорКО();
КонецЕсли;
КонецЦикла;
КонецЦикла;

ТД.ВывестиСекцию("Строка");

КонецЦикла;
КонецЦикла;
ТД.Показать("Расчеты с дебеторами",,1);
КонецПроцедуры
Valery
1 - 18.05.2004 17:11 		Я так понял обароты не считает?
Willhelm
2 - 18.05.2004 17:54 		Да.
->Вот в этом месте см. по тексту
Ит.ВыбратьКорСчета(1,2);
Пока Ит.ПолучитьКорСчет()=1 Цикл
->
получается пустая выборка кор.счетов, а по журналу ордеру - они есть
Мой отчет это по сути журнал-ордер с детализацией по контрагентам и договорам
Willhelm
3 - 18.05.2004 19:09 		Так как есть мнения из-за чего корреспондирующие счета не выгребаются?
gerasan
4 - 18.05.2004 19:14 		Попробуй в параметрах метода ВыполнитьЗапрос (тип итогов по моему) указать необходимость расчета оборотов между счетами, так как по умолчанию рассчитываются остатки и обороты только по счетам, указанным в третьем параметре.
Lark
6 - 18.05.2004 19:55 		Шестым параметром в бухЗапросе нужно поставить "3"
Valery
10 - 19.05.2004 15:28 		В строке Запроса попробуй поставить Тип итогов 2 или 3


глюк при пересчете бухгалтерских итогов 7.7 | База знаний | mista.ru

глюк при пересчете бухгалтерских итогов 7.7

gerasan
18.05.2004 19:10 		Может быть кто-нибудь сталкивался с такой проблемой.
При пересчете бухгалтерских итогов (как через конфигуратор, так и через предприятие) 1С не то чтобы зависает, а уходит в глубокий расчет, занимая все доступные ресурсы процессора.
При этом индексный файл таблицы итогов (1SBKTTL.CDX) растет не останавливаясь.
Пробовал убивать файлы с итогами - не помогает.
Чистил таблицу 1SENTRY.DBF - добился интересных результатов:
1. Сначала пометил на удаление все проводки до 1 апреля 2004 года;
2. Запустил пересчет итогов - итоги рассчитались;
3. Отменил пометку на удаление у проводок с 1 марта по 31 марта 2004;
4. Запустил пересчет итогов - итоги рассчитались с некоторым подтормаживанием, но размер файла 1SBKTTL.CDX получился на порядок больше, чем размер файла 1SBKTTL.DBF, хотя обычно наоборот;
5. Удалил файлы 1SBKTTL.DBF, 1SBKTTL.CDX, 1SACCSEL.DBF, 1SACCSEL.CDX;
6. Запустил пересчет итогов - расчет остановился на 01.04.04.

Что делать???
Принимаются любые догадки, предположения и т.п.

Заранее спасибо.
427
1 - 18.05.2004 21:52 		Чтото не в порядке с назначенными отборами в проводках....

Итоги рассчитались с некоторым подтормаживанием..... все правильно.... Возможно, начали активно работать...

"расчет остановился на 01.04.04" все правильно.... Точка среза.... перенос итогов... И где то в первом квартале косяки....
gerasan
2 - 19.05.2004 13:19 		Спасибо всем ответившим - проблема найдена.
Возникает из-за того, что добавлен вид субконто типа строка(25).

При добавлении такого вида субконто (даже если он не используется) после пересчета итогов структура индексного файла итогов усложняется. Видимо поэтому 1С "зацикливается" при его создании.
Интересно, что в SQL-версии индекс создается нормально, но работа с бухгалтерскими итогами (особенно получение остатков на момент документа) становится медленнее в несколько раз.
427
3 - 19.05.2004 14:06 		"вид субконто типа строка(25)"

Облажались аднако... Строка 22 будет...недостача 3 символов....


Проводки по рег-ам бухгалтерии в 8.0 | База знаний | mista.ru

Проводки по рег-ам бухгалтерии в 8.0

Valentin_Azheronok
18.05.2004 14:21 		имеем регистр бухгалтерии без корреспонденций, конструктором формирую движения , проводить не желает, находит ошибку. Релиз 6.3

Для Каждого ТекСтрокаТовары Из Товары Цикл
// регистр Основной Приход
Движение = Движения.Основной.Добавить();
Движение.ВидДвижения = ВидДвиженияБухгалтерии.Дебет;
Движение.Счет = ПланыСчетов.Основной.Товары_на_складах;
Движение.Период = Дата;
Движение.Регистратор = Ссылка;
Движение.Количество = ТекСтрокаТовары.Количество;
Движение.Сумма = ТекСтрокаТовары.Сумма;
Движение.Субконто[ПланыВидовХарактеристик.ВидыСубконто.Номенклатура] = ТекСтрокаТовары.Товар;
Движение.Субконто[ПланыВидовХарактеристик.ВидыСубконто.МестоХранения] = МестоХранения;
Движение.Субконто[ПланыВидовХарактеристик.ВидыСубконто.ПартияТовара] = Ссылка;
КонецЦикла;
// регистр Основной Приход
Движение = Движения.Основной.Добавить();
Движение.ВидДвижения = ВидДвиженияБухгалтерии.Дебет;
Движение.Счет = ПланыСчетов.Основной.НДС_уплаченный;
Движение.Период = Дата;
Движение.Регистратор = Ссылка;
Движение.Сумма=Товары.Итог("НДС");
Движение.Субконто[ПланыВидовХарактеристик.ВидыСубконто.Контрагент] = Контрагент;

// регистр Основной Расход
Движение = Движения.Основной.Добавить();
Движение.ВидДвижения = ВидДвиженияБухгалтерии.Кредит;
Движение.Счет = ПланыСчетов.Основной.Расчеты_с_пост_в_рублях;
Движение.Период = Дата;
Движение.Регистратор = Ссылка;
Движение.Сумма=Товары.Итог("Всего");
Движение.Субконто[ПланыВидовХарактеристик.ВидыСубконто.Контрагент] = Контрагент;
Движение.Субконто[ПланыВидовХарактеристик.ВидыСубконто.Договор] = Договор;

// записываем движения регистров
Движения.Основной.Записать();
Valentin_Azheronok
1 - 18.05.2004 14:24 		Ошибка при вызове метода контекста (записать). Запись не верна, Нарушен баланс.

Но ведь регистр без подд. корреспонденции. где же логика?
Непонятливый
3 - 18.05.2004 19:03 		Про логику - согласен на 200%.
Ошибка такая запросто может лезть на проводке балансовый-забалансовый счет при корреспонденции включенной (сам видел), но вот без поддержки не копался...

Возникает вопрос - а как проводка выглядит на бумаге?
Дт(Товары на складах) - Сумма по строкам
Дт(НДС) - Сумма НДС
Кт(Расчеты_с_пост_в_рублях) - Итог всего...

Тупой вопрос - Дт=Кт?
427
4 - 18.05.2004 19:33 		А словосочетание "Нарушен баланс. " уже ни о чем не говорит ......
¶
5 - 18.05.2004 21:32 		(0) См. свойство Балансовый у ресурсов и измерений. Стоит флажок?
Valentin_Azheronok
6 - 18.05.2004 23:24 		Всем спасибо, уже разобрался, теперь все работает. Немного перемудрил с измерениями и ресурсами, благо УПП достал, есть куда подглядеть.


Бухия. Бухгалтерские Итоги. Обращение к результатам запроса. | База знаний | mista.ru

Бухия. Бухгалтерские Итоги. Обращение к результатам запроса.

Janna 17.05.2004 16:17 | Есть выборка проводок. Как определить номер строки в документе, по которому сделана проводка?
SiMazx 1 - 17.05.2004 16:51 | ПривязыватьСтроку смотри в синтакс-помощнике...
AVP 2 - 17.05.2004 17:05 | ПривязыватьСтроку() в модуле проведения есть? Если да, то может БухИт.Операция.НомерСтрокиДокумента()?
427 3 - 17.05.2004 18:12 | Можно и без привязывать строку..... но хлопотно .... P.S. ПривязыватьСтроку в типовых, по моему, не используется нигде.......
Janna 4 - 18.05.2004 13:13 | Посмотрела ПривязыватьСтроку(),в описании написано, что метод используется при движении регистров,но я не использую регистры. А БИ.Операция.НомерСтрокиДокумента() дает 0.
SnarkHunter 5 - 18.05.2004 13:25 | ПривязыватьСтроку(<?>); Синтаксис: ПривязыватьСтроку(<НомерСтроки>) Назначение: Записывать номер строки документа в движениях документа. Параметры: <НомерСтроки> - номер строки Документа. Замечание: Метод устанавливает номер строки для всех последующих движений регистров, при записи значений периодических реквизитов справочников с привязкой к документу, а также при записи БУХГАЛТЕРСКИХ ПРОВОДОК (Caps Lock мой). Метод доступен только в Модуле документа в предопределенной процедуре ОбработкаПроведения.


Не получается у меня ИспользоватьСубконто() :( | База знаний | mista.ru

Не получается у меня ИспользоватьСубконто() :(

Таня
17.05.2004 17:52 		Для Б = 1 По Счет.КоличествоСубконто() Цикл
ИТ.ИспользоватьСубконто(Счет.ВидСубконто(Б));
ИТ.ВыполнитьЗапрос(,Дата1,Счет);
ИТ.ВыбратьСубконто();
Пока ИТ.ПолучитьСубконто()=1 Цикл
Субконто = ИТ.ПредставлениеСубконто();
ОстатокСубконто= ИТ.СКД();
Таб.ПрисоединитьСекцию("Н");
КонецЦикла;
КонецЦикла;

Для счета 50.1 не показывает, что есть у него остаток по субконто Дв.денежных средств - говорит ИТ.ВыбратьСубконто() = 0
хотя есть проводка Дт 50.1/Прочие поступления Кт 00 500 рублей
mszsuz
1 - 17.05.2004 18:03 		У ВидаСубконто.ДвиженияДенежныхСредств на данном счете установлен признак "Только обороты".
Таня
2 - 17.05.2004 18:05 		И как теперь быть?
мне надо чтобы отчет показывал остатки в разрезе субконто
Michael99
3 - 17.05.2004 18:15 		(0) Задумайся над смыслом отчета в этом разрезе.
Что например должен показывать остаток по субконто "Поступления от покупателей" ?
Таня
4 - 17.05.2004 18:21 		Голова не работает, что должен показывать остаток?
Michael99
5 - 17.05.2004 18:22 		Включай голову .
Бред полный он будет показывать.
Смысл имеют только обороты , потому и субконто оборотное.
Таня
6 - 17.05.2004 18:32 		То есть, если в задании сказано, выполнить оценку остатков по счету 50.1 на Дата1 в выбранную валюту, то по этому субконто ничего не надо выводить?
Michael99
7 - 17.05.2004 18:36 		Я не знаю что там за задание и куда что нужно выводить,
но остатков по этому субконто нет и получить их нельзя.


Работа с корсчетами в бухгалтерских итогах | База знаний | mista.ru

Работа с корсчетами в бухгалтерских итогах

ken_gd
14.05.2004 10:10 		Помогите!
Задача: "Необходимо развернуть бухгалтерские итоги по корсчетам"
Пишу:
БИ = СоздатьОбъект("БухгалтерскиеИтоги");
БИ.ИспользоватьРазделительУчета(ВыбЮрЛицо);
БИ.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Контрагент);
БИ.ИспользоватьСубконто(ВидыСубконто.Договоры, Договор);
БИ.ВключатьСубсчета(0, 0);
БИ.ВыполнитьЗапрос(НачДата, КонДата, СписокВыбранныхСчетов,,,3,,);

СальдоНач = БИ.СНД() - БИ.СНК();
СальдоКон = БИ.СКД() - БИ.СКК();

БИ.ВыбратьСчета();
Пока БИ.ПолучитьСчет()=1 Цикл
Сообщить("Счет:"+БИ.Счет.Код+" КорСчет:"+БИ.КорСчет.Код+" Субконто:"+БИ.Субконто()+ " СНД: "+БИ.СНД()+" СНК: "+БИ.СНК()+" СКД: "+БИ.СКД()+" СКК: "+БИ.СКК()+" ДО: "+БИ.ДО()+" КО: "+БИ.КО());
БИ.ВыбратьКорСчета();
Пока БИ.ПолучитьКорСчет()=1 Цикл
Сообщить("Счет:"+БИ.Счет.Код+" КорСчет:"+БИ.КорСчет.Код+" Субконто:"+БИ.Субконто()+ " СНД: "+БИ.СНД()+" СНК: "+БИ.СНК()+" СКД: "+БИ.СКД()+" СКК: "+БИ.СКК()+" ДО: "+БИ.ДО()+" КО: "+БИ.КО());
КонецЦикла;
КонецЦикла;

Выдается результат:
Счет:62 КорСчет: Субконто:Омега ООО СНД: 0 СНК: 1896.29 СКД: 0 СКК: 8169.23 ДО: 1919.86 КО: 8192.8
Счет:62 КорСчет:52 Субконто:Омега ООО СНД: 0 СНК: 1896.29 СКД: 0 СКК: 8169.23 ДО: 1919.86 КО: 8192.8
Счет:62 КорСчет:91 Субконто:Омега ООО СНД: 0 СНК: 1896.29 СКД: 0 СКК: 8169.23 ДО: 1919.86 КО: 8192.8

Т.е. как будто при подсчете сумм по корсчетам фильтр по корсчету не включается.

Что я делаю не так?
Gavrila
3 - 14.05.2004 12:33 		Вот:
1.
КорДО(<?>)
Синтаксис:
КорДО(<ТипСуммы>)
Назначение:
Возвращает дебетовый оборот между корреспонденциями.
Параметры:
<ТипСуммы> - Необязательный параметр. Число или строка - тип возвращаемой суммы. Может принимать одно из следующих значений: 1 (''C'') - сумма; 2 (''В'') - валютная сумма; 3 (''К'') - количество. Если параметр не указан, метод возвращает сумму.
2.
КорКО(<?>)
Синтаксис:
КорКО(<ТипСуммы>)
Назначение:
Возвращает кредитовый оборот между корреспонденциями.
Параметры:
<ТипСуммы> - Необязательный параметр. Число или строка - тип возвращаемой суммы. Может принимать одно из следующих значений: 1 (''C'') - сумма; 2 (''В'') - валютная сумма; 3 (''К'') - количество. Если параметр не указан, метод возвращает сумму.
ken_gd
4 - 14.05.2004 13:44 		Кроме оборотов между счетами меня еще интересует и сальдо на начало периода и сальдо на конец периода
Gavrila
6 - 14.05.2004 16:56 		(4) остатки получаешь так же как и получал, а обороты между корр счетами ->(3)
Ken_gd
7 - 17.05.2004 15:16 		Дело в том, что я пишу обработку акта сверки по контрагентам. Бухгалтерия попросила убрать корсчет "91.2" из всех сумм оборотов за период, а также из сальдо на начало и сальдо на конец периода. Из оборотов я уже корсчет убрал, а вот из сальдо на начало не получается.


Как получить субконто при переборе по Идентификатору? | База знаний | mista.ru

Как получить субконто при переборе по Идентификатору?

Denis Nsk
17.05.2004 08:52 		Подскажите пожалуйста почему не получается получить субконто по Идентификатору субконто "ВидыРасчетов"? По номеру не устраивает т.к. не универсально, предется отслеживать в плане счетов номер субконто на всех счетах

Опер=СоздатьОбъект("Операция");
Опер.ВыбратьОперацииСПроводками(Дата1,Дата2,"68.08",,,);

Пока Опер.ПолучитьПровоку()=1 Цикл
Субконт=Опер.Дебет.Субконто(3); //данная строка работает
Субконт=Опер.Дебет.Субконто("ВидыРасчетов"); //данная строка выдает "" строку.
КонецЦикла;

Спасибо.
427
1 - 17.05.2004 09:10 		Пиво надо приходить пить ....

Пока Опер.ПолучитьПрово(!)ку()=1 Цикл
Счетик = Опер.Debit.Account;
if Счетик.Selected() <> 1 then
Message ("ну и хрен с ним");
Continue;
endIf;
for Индекс = 1 to Счетик.SubcontoCount() do
Субконт=Опер.Дебет.Субконто(Индекс);
if EmptyValue(Субконт) = 1 then
Message ("Какой то идиот сделал проводку с пустым субконто");
Continue;
endIf;
if Субконт.Kind() = "ВидыРасчетов" then
Message ("Бляха- с мухой.... Попался ВидРасчетов");
endIf;
endDo;
КонецЦикла;
AVP
2 - 17.05.2004 09:39 		Субконт=Опер.Дебет.Субконто(ВидыСубконто.ВидыРасчетов)


Остатки по зарплате | База знаний | mista.ru

Остатки по зарплате

костя
14.05.2004 18:21 		И снова о наболевшем. Так и не услышал ответа на вопрос

1С 7.7 стандартная кон-фа. Расчетно-сальдовая ведомость по з/п подгружается из внешнего файла (mxl). Добавил в оборотку столбец \"Сальдо на начало\" в котором по идее должна отображаться информация о состоянии взаиморасчетов организации с сотрудником (ему должны - он должен), а вот с кодом в модуле формы никак не выходит - в столбце нули и хоть тресни.
код таков
Нач.СоздатьОбъект("БухИтоги")
Нач.Использовать Субконто(ВидыСубконто.Сотрудники,Сотрудник,2);
Нач.Использовать Субконто(ВидыСубконто.Периоды,ПериодДок,2);
Нач.ВыполнитьЗапрос(НачМесяца(ДатаПериода),ДатаДок,СчетПоКоду("661"),,2);
Остаток=Нач.СНД()

В таблице (в Конфигураторе)в колонке Сальдо на начало в ячейку ставлю <Остаток #18.2,>
staer
2 - 14.05.2004 18:56 		Если бы знал, то ответил бы. А так просто ббросилось в глаза. В ячейке
<Остаток#N18.2>, Даст эта N,что-то или не даст, не знаю
Gavrila
6 - 14.05.2004 20:09 		(5) Здсь у тебя Нач.ВыполнитьЗапрос(НачМесяца(ДатаПериода),ДатаДок,СчетПоКоду("661"),,2); 5-й параметр должен быть ВАЛЮТА, а ты передаешь 2 - шо цэ такэ?
если тип итогов, то он является 6-м параметром... попробуй это
Нач.ВыполнитьЗапрос(НачМесяца(ДатаПериода),ДатаДок,СчетПоКоду("661"));
читай ЖКК:
ВыполнитьЗапрос(<?>,,,,,,,)
Синтаксис:
ВыполнитьЗапрос(<НачалоПериода>,<КонецПериода>,<Счет>,<КоррСчет>,<Валюта>,<ТипИтогов>,<Периодичность>,<ТипСуммы>)
Назначение:
Выполнить отбор и расчет итогов по параметрам.
Возвращает число 1 - запрос выполнен; 0 - запрос не выполнен.
Параметры:
<НачалоПериода> - дата, документ или позиция начала периода запроса.
<КонецПериода> - дата, документ или позиция конца периода запроса.
<Счет> - необязательный параметр. Счета, для которых будут отбираться итоги в запросе. Задается значением типа ''Счет'' или объектом типа ''СписокЗначений'', содержащим значения типа ''Счет'', либо строкой содержащей список кодов счетов, разделенных символом '','' или '';''. Если параметр не указан, отбор будет выполняться по всем счетам.
<КоррСчет> - необязательный параметр. Значение типа ''Счет'' - корреспондирующий счет, в корреспонденции с которым будут отбираться итоги счета, указанного в параметре <Счет>. Задается значением типа ''Счет'' или объектом типа ''СписокЗначений'', содержащим значения типа ''Счет'', либо строкой содержащей список кодов счетов, разделенных символом '','' или '';''. Если параметр не указан, будут отбираться итоги в корреспонденции со всеми счетами.
<Валюта> - зачение типа ''Справочник.Валюты''. Если параметр не указан итоги выдаются без учета валюты.
<ТипИтогов> - число - тип отбираемых итогов. Может принимать следующие значения: 1 - остатки и обороты по счету в целом; 2 - обороты между счетами; 3 - первое и второе вместе. По умолчанию: 1.
<Периодичность> - число или символьная строка (см. документацию).Позволяет получить дополнительный разрез итогов по периодам. По умолчанию периодичность не задана.
<ТипСуммы> - число или строка - тип рассчитываемых итогов. Может принимать следующие значения (в скобках указаны строковые синонимы):
1 (''C'', ''S'') рассчитывать суммы;
2 (''В'', ''C'') рассчитывать валютные суммы;
4 (''К'', ''A'') рассчитывать количество.
Если требуется одновременно рассчитывать разные суммы, значение параметра получается путем сложения допустимых значений, например: 5 (1+4) - рассчитывать суммы и количество.
При указании параметра строкой в ней указываються все символы, которые обозначают типы сумм, которые нужно рассчитывать. По умолчанию рассчитываются все типы сумм.
Замечание:
Подробнее см. в документации в гл. ''Работа с бухгалтерскими итогами''
:)
костя
8 - 14.05.2004 20:23 		(6)
попробовал - показывает ту же сумму, что и начислено, а задолженость за прошлый месяц не показывает
?
Gavrila
9 - 14.05.2004 20:35 		(8)Есть значит Дат1 и Дата2 в запросе, значит:
начальный остаток - СН-ы там всякие, покажет остаток на начало Дата1;
конечный остаток - СК-ы там всякие, покажет остаток на конец Дата2;
а дальше по логике запроса и хранения данных :))
костя
10 - 14.05.2004 20:50 		(9)но если я правильно понимаю, то в у меня верно
Нач.ВыполнитьЗапрос(НачМесяца(ДатаПериода),ДатаДок,СчетПоКоду("661"));

запрашивается дата остаков (начало месяца)на которую необходимо отобразить эти самые остатки?
или чего-то в нем поменять с датами исходя из того, что ты написал?
Gavrila
11 - 14.05.2004 20:56 		(10) если ты написал это Остаток=Нач.СНД() , то наверное неправильно, т.к. насколько помню в укр бухии (?) сч.661 - это пассивный счет, значит остаток должен быть по кредиту: Остаток=Нач.СНК(), я правильно тебя понял ?
костя
12 - 14.05.2004 21:01 		(10)да уж так и пишу - Остаток=Нач.СНК(), а он начисленную з/п показывает
Gavrila
13 - 14.05.2004 21:06 		(12) проверь по сч.661 (по оборотке по счету исходной) остаток на дату "НачМесяца(ДатаПериода)"
костя
14 - 14.05.2004 21:16 		проверял - оборотка показывает кредитовый остаток на начало месяца
костя
21 - 15.05.2004 18:05 		перепробовал разные варианты - либо нули отображаются, либо начисленная з/п
427
22 - 15.05.2004 18:40 		Достал ты уже....

Я тя явно украинский план счетов... Я его не знаю....

Опиши - какой счет 661 (активный, пассивный) какие субконто
Какими проводками (дебет, кредит) начисляется ЗП.... и выплачивается...

тогда напишу бухзапрос...
костя
24 - 15.05.2004 19:01 		счет 661 активно-пассивный, исп. два субконто - сотрудники и периоды (месяц начисл з/п)
по кредиту отображается начисленная з/п, по дебету - выплаченная з/п

начисления - Дт 23(92,91)(производство, админперсонал) Кт 661
выплата - Дт 661 Кт 301 (каса)
костя
29 - 15.05.2004 20:02 		1С Бухгалтерия 7.7 (АКС.Бухгалтерия) релиз от 14,02,04 (без номера)
427
30 - 15.05.2004 20:38 		Я не знаю, что такое ПЕРИОД .... И какое у него представление
Допустим, это справочник, с реквизитами - НачДата и КонДата
в этом предположении написан пример

Если же Период - это просто ДАТА, то тогда запрос строится по другому
тогда надо знать, какими датами делаются начисления....

так что уточни, какой тип субконто Период

тз = CreateObject("ValueTable");
тз.NewColumn( "Сотрудники","Reference.Сотрудники" , , , "Сотрудники" , , , );
тз.NewColumn( "Период","Reference.Периоды" , , , "" , , , );
тз.NewColumn( "СуммаНаНачало" ,"Число" ,15 , 2, "ОстатокНаНачалоСумма" , , , );
тз.NewColumn( "СуммаНаКонец" ,"Число" ,15 , 2, "ОстатокНаКонецСумма" , , , );
тз.NewColumn( "СуммаПриход" ,"Число" ,15 , 2, "ПриходСумма" , , , );
тз.NewColumn( "СуммаРасход" ,"Число" ,15 , 2, "РасходСумма" , , , );

//===================================================================
Би = CreateObject("BookkeepingTotals");

if Сотрудники.Selected() = 1
then Би.UseSubconto(SubcontoKinds.Сотрудники, Сотрудники, 2);
else Би.UseSubconto(SubcontoKinds.Сотрудники, , 1);
endIf;
if Период.Selected() <> 1 then
DoMessageBox ("Не выбран период");
return;
иначе Би.UseSubconto(SubcontoKinds.Периоды, Период, 2);
endIf;

//==============================================
// пример запроса фактически за один период
// если надо, к примеру, за квартал - небольшая доработка нужна
// если за один период - цикл по второму субконто не нужен
// приведен только для общего случая - когда несколько периодов

Би.DoQuery(Период.НачДата , Период.КонДата , AccountByCode("661"), , , 3, , "СК");
//==============================================================
if Би.SelectSubconto(1) =1 then // выбрать Сотрудники
while Би.GetSubconto(1) = 1 do // получить Сотрудники
//==============================================
// итоги по Сотрудник
//==============================================
тз.NewLine();
тз.Сотрудники = Би.Subconto(1); // итоги по Сотрудники
//---- суммы -----------------------------------------
// Сумма на начало -
// если 0 - нет долгов
// меньше 0 - долг за предприятием
// больше 0 - сотру повезло.... ему переплатили .... т.е. долг за сотром
//-------------------------------------------------------
// аналогично конец периода

// итоги по первому субконто - сумма за все периоды

//-------------------------------------------------------
// именно в этой точке надо смотреть остатки на начало
// текущего периода.... Как можно заметить, здесь
// ЕЩЕ НЕ АНАЛИЗИРУЕТСЯ субконто ПЕРИОД

тз.СуммаНаНачало = Би.СНД ("С")-Би.СНК ("С");
тз.СуммаНаКонец = Би.СКД ("С")-Би.СКК ("С");
тз.ПриходСумма = Би.ДО ("С"); // выплаты
тз.РасходСумма = Би.КО ("С"); // начисления

if Би.SelectSubconto(2) =1 then // выбрать
while Би.GetSubconto(2) = 1 do // получить
// по сотру с разбиением на периоды
тз.NewLine();
тз.Сотрудники = Би.Subconto(1);
тз.СрокиУплаты = Би.Subconto(2);

//---- суммы ---------------------------------
// в данной точке СуммаНаНачало ВСЕГДА (!!!!) равна
// НУЛЮ !!! И анализировать ее могут только идиоты
//
// Сумма на конец отражает состояние ЗП на конец
// периода
//-----------------------------------------------
тз.СуммаНаНачало = Би.СНД ("С")-Би.СНК ("С");
тз.СуммаНаКонец = Би.СКД ("С")-Би.СКК ("С");
тз.ПриходСумма = Би.ДО ("С");
тз.РасходСумма = Би.КО ("С");

endDo; // перебор по СрокиУплаты
endIf;
endDo; // перебор по Сотрудники
EndIf;
//==============================================================

if тз.LinesCnt() <> 0 then
//-----------------------------------------
for Индекс = 1 to тз.LinesCnt() do // цикл по ТЗ тз
тз.GetLineByNumber(Индекс);
if тз.Период.Selected() <> 1 then
//---------------------------------------------------
// расскажем об итогах
//---------------------------------------------------
Message ("-----------------------------");
Message ("Сотр ----"+тз.Сотрудник);

if тз.СуммаНаНачало > 0 then
Message ("Долг за сотром --- "+тз.СуммаНаНачало);
elsIf тз.СуммаНаНачало < 0 then
Message ("Долг за конторой --- "+Строка(0-тз.СуммаНаНачало));
else
Message ("Этот идиот получил все и не имеет долгов");
endIf;

Message ("Начислено "+тз.РасходСумма);
Message ("Выплачено "+тз.ПриходСумма);

if тз.СуммаНаКонец > 0 then
Message ("Долг за сотром после выплаты --- "+тз.СуммаНаНачало);
elsIf тз.СуммаНаКонец < 0 then
Message ("Долг за конторой после выплаты --- "+Строка(0-тз.СуммаНаНачало));
else
Message ("Этот идиот получил все и не имеет долгов после выплаты");
endIf;

else
// период выбран - данные по начислениям/выплатам за выбранный период
//
.................

endIf;
endDo;
//-----------------------------------------
endIf;
костя
31 - 15.05.2004 20:53 		(427) ты совершенно прав - Периоды - это справочник с реквизитами ДатаНач ДатаКон
427
33 - 15.05.2004 21:11 		В коде, который написан в (0) - две ошибки

Одна техническая.... в параметре ...
Вторая - идеологическая... по причине непонимания работы запросов и БИ в частности

Исправление любой одной из них не позволит получить требуемый результат

P.S. насчет справочника - ну это и предполагалось... В общем то практически единственный вариант...

В советах Гаврилы (примерного сына) ... нет указаний на техническую ошибку ... про идеологическую он вообще не допер ...
Gavrila
35 - 16.05.2004 13:29 		(33) были указания на техн. ошибку, были... (6), хотя может ты про другое - тогда поясни :)
а идеологические ошибки "допирать" - это еще и опыт работы с бухией нужен, которого нет к сожалению :)
427
36 - 16.05.2004 13:54 		Пардон... насчет 2 (кстати, 1 надоть) - было замечание...

А опыт работы с бухией тут ни при чем... Нет понимания идеологии работы не самой бухии... А работы БИ... А это две большие разницы.... как говорят в Одессе...

Подумай, почему "в данной точке СуммаНаНачало ВСЕГДА (!!!!) равна НУЛЮ !!!"


Информация о сотруднике в документе | База знаний | mista.ru

Информация о сотруднике в документе

костя 14.05.2004 13:44 | код таков Нач.СоздатьОбъект("БухИтоги") Нач.Использовать Субконто(ВидыСубконто.Сотрудники,Сотрудник,2); Нач.Использовать Субконто(ВидыСубконто.Периоды,ПериодДок,2); Нач.ВыполнитьЗапрос(НачМесяца(ДатаПериода),ДатаДок,СчетПоКоду("661"),,2); Остаток=Нач.СНД() В таблице в колонке Сальдо на начало в ячейку ставлю <Остаток #18.2,>
427 1 - 14.05.2004 13:50 | Нач.ВыполнитьЗапрос(НачМесяца(ДатаПериода),ДатаДок,СчетПоКоду("661"),,1); и что такое ПериодДок.... Как период может быть задан в субконто?


Субконто | База знаний | mista.ru

Субконто

Agibuba 13.05.2004 08:46 | Возникла следующая проблема. В субконто3 в плане счетов задана цена товара. Цена товара берется из подчиненнего справочника. При организации проводки заношу в данное субконто цену из справочника, провожу документ, после этого просматриваю проводки, а цена не отображается. Открываешь операции и вручную выбираешь из справочника цену, после этого она видна везде. Но руками это ... :(((( Перепробовал различные способы выбора цены, даже заставлял пользователя выбирать цену из справочника при проведении документа - ничего не помогает. Помогите! Для связи можно использовать 978107@mail.ru Буду очень признателен!!!!!!!!
427 1 - 13.05.2004 08:56 | Круто.... Субконто - цена....
Волшебник 2 - 13.05.2004 23:56 | "заношу в данное субконто цену из справочника" значит не заносишь. проверь соответствие типов данных


как в карточке счета выстроить значение по номенклатурному номеру | База знаний | mista.ru

как в карточке счета выстроить значение по номенклатурному номеру

zorro2011
13.05.2004 15:57 		как в карточке счета выстроить значение по номенклатурному номеру
Gavrila
1 - 13.05.2004 16:00 		ВыбратьСубконто(<?>,,,,,,)
Синтаксис:
ВыбратьСубконто(<Индекс>,<ФлагВсе>,<ФлагДК>,<Номер>,<РазвСальдо>,<Сортировка>,<ОбратныйПорядок>)
Назначение:
Открывает выборку по субконто.
Возвращает 1 - если действие выполнено и в выборке есть хотя бы одно субконто; 0 - если действие не выполнено или в выборке нет ни одного субконто.
Параметры:
<Индекс> - число: порядковый номер вызова метода ''ИспользоватьСубконто''.
<ФлагВсе> - число: 0 - отбирать те субконто, которые имели итоги на этом уровне обхода итогов запроса; 1 - включить в выборку все субконто, которые имели итоги в данном запросе; -1, -2 : включить в выборку субконто, которые имели итоги в группировке n-го вышестоящего уровня. По умолчанию - 0.
<ФлагДК> - число: 1 - включать в выборку счета только с дебетовыми оборотами; 2 - включать в выборку счета только с кредито-выми оборотами. 0 - включать в выборку счета вне зависимости от дебетовых/кредитовых оборотов. По умолчанию 0.
<Номер> - число - номер выборки. Если параметр не указан, выборке присваивается номер 0.
<РазвСальдо> - признак необходимости рассчитывать развернутое сальдо по субконто. Используется только если в запросе участвуют субконто. 1 - рассчитывать развернутое сальдо. 0 - не рассчитыть развернутое сальдо; По умолчанию 0.
<Сортировка> - cтрока - идентификатор реквизита субконто (если субконто - справочник или документ или счет), который будет использован для упорядочивания обхода субконто методом ''ПолучитьСубконто''. Если значение пустое - используется стандартное представление.
<ОбратныйПорядок> число: 0 - выборка в прямом порядке, 1 - выборка в обратном порядке; необязательный параметр. По умолчанию 0.


Журнал проводок и журнал операций | База знаний | mista.ru

Журнал проводок и журнал операций

нач 13.05.2004 10:39 | Бух попросила чтоб в журнале проводок не было видно проводок по кредиту определенного счета, чтоб не мозолили глаза, т.к этот счет забалансовый. И так же в журнале операций. Можно ли это как-о сделать и как если не трудно объясните. Бухия 7.7.019
Valery 3 - 13.05.2004 10:57 | Скрыть документы в журнале можно или изменением интервала времени, или отбором других механизмов не знаю, поэтому только так


ВыполнитьЗапрос() по валютам | База знаний | mista.ru

ВыполнитьЗапрос() по валютам

нач
07.05.2004 11:43 		Как можно ВыполнитьЗапрос(ДатаНач,ДатаКон,Счет,,Валюта) сразу по нескольким валютам, а не по одной, которую указываешь???
SnarkHunter
1 - 07.05.2004 11:48 		Изменить условие в запросе с "=" на "в"...
нач
2 - 07.05.2004 11:52 		Не понял :-( Есть например такое:
Бии=СоздатьОбъект("БухгалтерскиеИтоги");
Бии.ИспользоватьСубконто(ВидыСубконто.Контрагенты);
Бии.ВыполнитьЗапрос(ДатаНачала,ДатаКонца,"999.2",,Валюта);
Бии.ВыбратьСубконто(1);
Что сделать чтоб выполнялся запрос не поодной валюте а по нескольким? Валюта это элемент справочника Валюты
Gavrila
3 - 07.05.2004 11:53 		Попробуй список передать... (наверное)
нач
4 - 07.05.2004 12:03 		список не передается, пробовал :-(
Можно конечно добавить цмкл обхода всех элементов валют в справочнике и передавать их в ВыполнитьЗапрос(), но это очень не оптимально
SnarkHunter
5 - 07.05.2004 12:04 		(2)Ну так с этого и надо было начинать... Ты про БИ промолчал, я тебе ответил про ОУ...
Gavrila
7 - 07.05.2004 12:12 		1)
ВыбратьВалюты(<?>,,,,)
Синтаксис:
ВыбратьВалюты(<ФлагВсе>,<ФлагДК>,<Номер>,<РазвСальдо>,<Сортировка>)
Назначение:
Открывает выборку валют.
Возвращает 1 - если действие выполнено и в выборке есть хотя бы одна валюта; 0 - если действие не выполнено или в выборке нет ни одной валюты.
Параметры:
<ФлагВсе> - число: 0 - отбирать те счета, которые имели итоги на этом уровне обхода итогов запроса; 1 - включить в выборку все счета, которые имели итоги в данном запросе; -1, -2 : включить в выборку счета, которые имели итоги в группировке n-го вышестоящего уровня. По умолчанию - 0.
<ФлагДК> - число: 1 - включать в выборку счета только с дебетовыми оборотами; 2 - включать в выборку счета только с кредито-выми оборотами. 0 - включать в выборку счета вне зависимости от дебетовых/кредитовых оборотов. По умолчанию 0.
<Номер> - число - номер выборки. Если параметр не указан, выборке присваивается номер 0.
<РазвСальдо> - признак необходимости рассчитывать развернутое сальдо по субконто. Используется только если в запросе участвуют субконто. 1 - рассчитывать развернутое сальдо. 0 - не рассчитыть развернутое сальдо; По умолчанию 0.
<Сортировка> - строка - идентификатор реквизита справочника валют, который будет использован для упорядочивания обхода валют методом ''ПолучитьВалюту''. Если значение пустое - используется представление справочника.
2)
ПолучитьВалюту(<?>,)
Синтаксис:
ПолучитьВалюту(<Номер>,<Валюта>)
Назначение:
Получить из выборки следующую валюту. Выборка должна быть предварительно открыта при помощи метода ''ВыбратьВалюты''.
Возвращает 1 - следующая валюта выбрана успешно; 0 - следующий валюта не выбрана (отсутствует).
Параметры:
<Номер> - число - номер выборки. Необязательный параметр.
<Валюта> - значение валюты, на которое нужно спозиционироваться.
Попробуй ето :) может и получиться


Номер журнала в 1с | База знаний | mista.ru

Номер журнала в 1с

Искатель 05.05.2004 15:21 | В бухгалтерии многие проводки делаются через функцию глобального модуля, ГлПров(), так вот там есть параметр НомерЖурнала, я посмотрел как он используется документами при проводках, но не понял откуда берутся "номера журнала". Что такое номер журнала? И более конкретный вопрос как узнать номер журнала?
SnarkHunter 1 - 05.05.2004 15:25 | Это реквизит проводки...
Искатель 2 - 05.05.2004 15:35 | ТО что это реквезит это хорошо. Но как мне узнать номер определенного журнала, я наверно то то не понимаю подскажите пожалуйста.
3ton 3 - 05.05.2004 15:37 | (+2) который, в разных случаях отображает, [содержит] дополнительную информацию о содержании проводки, точнее о ее принадлежности к учету. (например: как в старой доброй журнально-ордерной системе). Ну а как сейчас это применительно, это право предоставляется уSеру, а эска, дабы не захламлять номерами этих журналов проводки в операциях, прости их игнорит. P.S.:Типично используется в шаблонах операций и ручных проводках.
Искатель 4 - 05.05.2004 15:44 | Не, ну подождите я смотрю почти каждый длкумент предает при проводки какой то номер(в основном строка, например документ банковская выписка "БК"). Где можно увидеть что "БК", есть номер журнала "Банковская выписка"?
SnarkHunter 5 - 05.05.2004 15:47 | (4)Нигде... Цитата: "Кроме того, в состав данных проводок включен реквизит "НомерЖурнала". Он используется для ввода в каждой проводке некоторого двухзначного номера. Номер может содержать цифры и буквы. Номер журнала в основном используется для отбора проводок по этому признаку. Отбор проводок может производиться в журнале проводок и в отчете по проводкам. Данный реквизит проводки может заполняться пользователем произвольно. Рекомендуется выработать некоторый принцип, по которому проводки будут разделяться по номерам журналов и в дальнейшем его придерживаться. Целесообразно использовать небольшое количество номеров журналов."


PROBLEM План счетов ПЕРЕСЧЕТ БУХ ИТОГОВ | База знаний | mista.ru

PROBLEM План счетов ПЕРЕСЧЕТ БУХ ИТОГОВ

piton 03.11.2004 06:14 | Взяли разделили счет 60.1 на два субсчета 60.1.1 и 60.1.3 Работали, пока не обнаружили что после полного пересчета бух итогов Итоги по 60 счету увеличиваются в 2 раза, причем к карточке стоят нормальные суммы а ОСВ увеличенные, попробовали избавиться от этих субсчетов, все равно проблема осталась.
egor1 1 - 03.11.2004 06:34 | Когда счет делится на субсчета, обычно будет создан субсчет типа ХХХ.Х.0 и на него сбросятся все обороты до деления. Дальше все будет требовать проведения по субчетам. Судя по номерам .1 и .3 субсчетам меняли нумерацию. ИМХО, если это проделали не один раз, без пересчета итогов, могла возникунуть такая ситуация. Что показывает ОСВ по субсчетам? На каком именно субсчете появляются лишние суммы?


За данный период бухгалтерские итоги не рассчитаны! | База знаний | mista.ru

За данный период бухгалтерские итоги не рассчитаны!

БухИтоги 22.10.2004 20:31 | Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода,,,,1,,"СК"); Сообщает, что "За данный период бухгалтерские итоги не рассчитаны!" Как можно проверить, расчитаны ли итоги ДО выполнения запроса?
SnarkHunter 1 - 22.10.2004 20:34 | КонецРассчитанногоПериодаБИ()


Знатокам и/или столкнувшимся: Два пл.счетов - два учета - управленч. и бух. | База знаний | mista.ru

Знатокам и/или столкнувшимся: Два пл.счетов - два учета - управленч. и бух.

apis
15.10.2004 11:41 		Вопрос знатокам и/или просто уже столкнувшимся с сей фичей:
Кто что может сказать про использование в бухле (или комплексной) двух планов счетов - один для бух. отчетности, другой - сугубо для управленки. Т.е. если создаю в конфе второй план счетов и для доков прописываю по нему проводки ручками (управленческие отчеты, также пишутся дополнительно и, разумеется, явно настроены на второй план счетов). Задача возникла из-за того, что управленцы желают принципиально иные проводки, нежели стандартные (причина этого вне обсуждений).
Итак, возможно ли это (стандартными бух. отчеты и квартальные балансовые формы настроены на "родной" план счетов, а самописные
отчеты - на управленческий) и если да - какие здесь могут быть особенности и подводные камни? Подозреваю, что мой вопрос может быть
не вполне корректно сформулирован, но тем не менее... Надеюсь на снисхождение и помощь...
apis
11 - 15.10.2004 12:15 		ANik
3 - 15.10.2004 - 10:45 Простейшее решение:
1. Ставишь УРБД.
Периферийная - только получатель.
Те справочники, которые отвечают за формирование проводок, в обмене не участвуют.
В периферейной перенастраиваешь проводки.
2. Ставишь МОД.
3. Через КД.
В любом случае имеешь:
1. Возможность обновления
2. Не будет падения быстродействия.

fisher
9 - 15.10.2004 - 11:00 2(0) ИМХО, самый правильный подход, если реальный учет серьёзно отличается от бух. (или черного больше белого). В этом случае для фин. анализа деятельности предприятия и фин. планирования можно использовать стандартные подходы. Бухгалтерам и экономистам на порядок проще осуществлять учет, контроль и анализ реальной деятельности предприятия. Значительную часть управленческой информации можно будет получить стандартными бух. отчетами. Только там, где для управленческого учета аналитики хватать не будет, всё равно прийдется использовать регистры а по плану счетов формировать сводные проводки.
ЗЫ. Подводных камней всё равно будет много, но овчинка стоит выделки (плюсов больше). ИМХО.
Только в типовой комплексной слишком тяжеловато получится... А в перспективе - так вообще... Аппетит приходит во время еды и управленческий учет имеет тенденцию к бесконечному усложнению ;)

Anomaly
11 - 15.10.2004 - 11:16 (10) ну есть всякие "мелкие пакости" - например, придется прописывать наименование плана счетов в конструкциях СчетПоКоду() и в бухитогах (причем не строкой, как описано в ЖКК, а именно СчетПоКоду("001",ПланыСчетов.Новый))...но это все мелочи, просто к этому нужно привыкнуть.

fisher
12 - 15.10.2004 - 11:19 2(10) В основном, организационного характера.
Ну, навскидку... Прийдется принять принципиальное решение - использовать или нет документы по совместному учету. Возможно, такое решение прийдется принимать по видам документов. Если периоды закрытия (сдачи отчетности) по управленческому учету и бух. совпадать не будут и активно практикуются изменения задним числом, то возможно проще будет вообще отказаться от документов по совместному учету (при этом, ессно, увеличивается документооборот и усложняется контроль). Если аналитика упр. учета местами принципиально отличается от бух., то в документах совм. учёта нужно предусмотреть обе. Обе должен заполнять и нести за это ответственность один чел. Если организационно это проблематично, то просматривать, проставлять и допроводить документы дложен другой чел, что тоже проблематично...

Раскольников
14 - 15.10.2004 - 11:29 Кстати, в комлексной механизм (0) сделать проще всего. 70% документов генерят проводки через схему - ну и добавим еще одну, тогда только глПриПроведении переписать надо..

panda
16 - 15.10.2004 - 11:50 Ну я делал два ПС в комплексной. Изменения минимальны, ибо стандартный механизм проводок отлично работает и с двумя планами счетов. Единственное что напрягает - в каждом документе, где выбирается произвольный счет нужно добавить реквизиты для выбора еше и управленческого счета. Обновление конфы занимает ок. получаса (452->453).

panda
17 - 15.10.2004 - 12:00 14 - Да и одной схемы достаточно. Все что нужно изменить: в спр.ПроводкиХозОпераций сделать реквизиты СчетД(К) неопределенного вида, добавить в таблицу формы строки с реквизитами СчетУП в тех документах, где он будет выбираться как кор.счет, ну и добавить соотв. реквизит с субконтами в документы (РКО, ПКО, выписки и др.). Если требуется нестандартное поведение проводок можно еще подправить глПолучитьТаблицуПроводок, если надо считать амортизацию то глРасчетАмортизацииОС (НМА) ибо там счета задаются явно.


Пиктограмма в журнале расчета | База знаний | mista.ru

Пиктограмма в журнале расчета

clg 29.06.2004 12:33 | Можно ли штатными средствами 1С (и если да, то как) для реквизита журнала расчета в его форме выводить пиктограмму?(Для многострочной части формы можно указать картинку, но вот назначить колонку для вывода что-то не удается)
Warlock 1 - 29.06.2004 20:20 | Для многострочной части формы _нужно_ указать картинку, где будут все пиктограммы(в ряд). Далее в колонке реквизита ставится "галочка" "выводить пиктограммы". Имеет смысл только для реквизитов, принимающих значения 0,1,2,3... Если надо вывести пиктограммы для других типов реквизитов, то вместо них(колонок с реквизитами) создаются расчетные колонки, результатами которых должны быть 0,1,2,3..., а затем "выводить пиктограммы" и вперед!


в торговле праздничные дни | База знаний | mista.ru

в торговле праздничные дни

tank 15.06.2004 19:25 | как работать с календарями есть где-нибудь инф.?
iceTiger 1 - 15.06.2004 20:16 | В коробке.
Волшебник 2 - 15.06.2004 21:50 | http://www.mista.ru/tutor_1c/zarplata_calendar.htm


1cv8.конфигурирование: перерасчеты | База знаний | mista.ru

1cv8.конфигурирование: перерасчеты

mckol 03.06.2004 13:30 | очень прошу оказать содействие в нелёгком пути понимания принципов работы с регистром расчета при конфигурировании на восьмёрке. вопрос следующий, о перерасчетах. после некоторых движений по регистру расчета, у меня формируется таблица перерасчета, то есть таблица с указаниями на те записи, которые необходимо пересчитать. как логически следует - пересчитывать необходимо только записи, попавшие в эту таблицу, но механизмов идентификации, получений, и перерасчета конкретно этих записей я не понял. в перерасчетах содержиться ссылка на документ, вообще-то можно было бы перепровести этот документ, но в общем случае, он может делать большое число движений и лишь малую часть из них нужно пересчитывать... так же видел реализацию, когда пересчитываются записи, отобранные по какому-то измерению. в моём случае - это опять же излишне. и требуется пересчитать только те записи, которые находяться в таблице перерасчетов. надеюсь вопрос понятен. заранее спасибо.
мскол 3 - 03.06.2004 17:55 | вопрос вот в чем: как пересчитать только те записи, которые содержаться в перерасчете? инфы, содержайшийся в таблице перерасчета, на мой первый взгляд, недостаточно для однозначной идентификации записи: там содержиться только ссылка на регистратор. про перепроведение всего документа уже было сказано. то есть, каким механизмом их отобрать и по какому признаку?... если всё же вопрос не ясен до конца -то каким образом вообще работать с перерасчететом,в смысле пересчитывания записей регистра расчета?..
Vozhd 4 - 03.06.2004 18:07 | (3) нужно проектировать структуру данных так, что бы по таблице расчетов такой, какая она есть, можно было найти все требующие перерасчета записи. К сожалению, пока еще платформу не научили думать за разработчика конфигураций...
Vozhd 5 - 03.06.2004 18:09 | (3) в дополнение к (4), у таблиц перерасчетов есть измерения, которые могут вполне приемлимо идентифицировать данные, требующие перерасчет.


Налоговые вычеты | База знаний | mista.ru

Налоговые вычеты

Magnus
03.06.2004 14:55 		Пишу отчет о налоговых вычетах с сотрудников после расчета ЗП. Откуда их тащить (документов, справочников)?
Magnus
2 - 03.06.2004 14:58 		(1) Вычеты в отчет
Valery
3 - 03.06.2004 15:04 		если речь идет о стандартных вычетах, то параметры дожны быть в справочнике сотрудников. А суммы ни где не храняться. Думаю,что их надо расчитывать заново
mszsuz
4 - 03.06.2004 15:06 		В ЗиК Справочник "ВычетыСотрудниковПоНДФЛ" подчиненный справочнику "Сотрудники"
Magnus
5 - 03.06.2004 15:31 		пытаюсь вывести налоговые вычеты через запрос, но что-то вычеты не выводятся, не пойму в чем грабли. Код:
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|Обрабатывать НеПомеченныеНаУдаление;
|ДатаРождения = Справочник.Сотрудники.ДатаРождения;
|Наименование = Справочник.Сотрудники.Наименование;
|ВычетыСотрудниковПоНДФЛ = Справочник.ВычетыСотрудниковПоНДФЛ.ТекущийЭлемент;
|Группировка Наименование;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка(1) = 1 Цикл
// Заполнение полей Наименование
Таб.ВывестиСекцию("Наименование");
КонецЦикла;
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры
SnarkHunter
6 - 03.06.2004 15:45 		|Период с ВыбНачПериода по ВыбКонПериода;
|Обрабатывать НеПомеченныеНаУдаление;
|Сотрудник = Справочник.ВычетыСотрудниковПоНДФЛ.Владелец;
|ВычетыСотрудниковПоНДФЛ = Справочник.ВычетыСотрудниковПоНДФЛ.ТекущийЭлемент;
|Группировка Сотрудник Упорядочить По Сотрудник.Наименование;
Magnus
7 - 03.06.2004 15:56 		(6) Точно, забыл что вычеты-это подчиненный справочник, спасиба
Magnus
8 - 03.06.2004 16:15 		А мне еще нада дату рождения вывести, добавил строчку с датой рождения из справочника сотрудники, но выодится пустая строка, не пойму в чем дело.
SnarkHunter
9 - 03.06.2004 16:16 		Запрос.Сотрудник.ДатаРождения


8.0, Расчет зарплаты, подход к выполнению перерасчетов. | База знаний | mista.ru

8.0, Расчет зарплаты, подход к выполнению перерасчетов.

Непонятливый
26.05.2004 19:22 		Сабж.
Интересуют варианты практической реализации.
Просто перебрать строки из виртуальной таблицы перерасчетов и перепровести засветившиеся там документы?
В общем, как правильно?
BorisG
1 - 26.05.2004 19:33 		В какой конфигурации восьмерки расчет зартплаты?
Если ЗиК, так она пока демо... Если УПП, то бетта.
Хотя как раз в последней и реализовала методология перерасчетов от 1С "сторнирование + новый исправленный документ"
Непонятливый
2 - 26.05.2004 19:43 		Соррри!
В _НИКАКОЙ_ конфигурации.
Очень интересует самостоятельное написание данного процесса.

Все, что касается вытеснений, получения дополнений и создание сторно-документов освоено и прямо-таки понятно.
Проблемы вызывают записи, попадающие в перерасчет через механизм ведущих видов расчета.
Как обычно люди поступают в таком случае?
Или не надеяться на простой /понятный ответ и копать демку ЗП? Но там нет ни куя, а на УПП только счет на оплату пришел - не успею в скором времени... :(((
BorisG
3 - 26.05.2004 20:00 		Ну... тогда ОЙ! ;-))
На самом деле это очень непростой вопрос, и полностью, включая некоторые спорные юридические моменты он не реализован, и скорее не будет реализован и в конфигурациях 1С.
Честно говоря, тут его обсуждать, пока нет финальной конфы от 1С нет большого желания. Некоторые спорные моменты перерасчетов по табелям я обозначал в конференции 1С.
Волшебник
4 - 26.05.2004 21:51 		(0) Перебрать строки таблицы перерасчетов (и не виртуальной, а вполне реальной) и пересчитать данные по нужным значениям измерений. Как вы их будете пересчитывать - решаете сами. Правильнее всего реализовать расчет в процедурах общего модуле и при перерасчете вызывать именно их, а не перепроводить документы.
Непонятливый
5 - 27.05.2004 05:07 		Ага. Все-таки реальная табличка-то...

Все дело в чем. По той информации, что собралась у меня - на основании статистики колупания 8-ки, все выглядит так:

1) Настройки вида расчета определяют его взаимодействие с другими видами расчетов.
С базовых можем собрать базу (используя метод);
при попадании в один и тот же период с вытесняющими получаем дополнение+сторно (используя метод);
при изменении (=> перепроведении => срабатывании ловушки (?) на изменение данных в регистре перерасчетов) документов для ведущих видов расчетов получаем таблицу перерасчета (используя запрос или более тупой и общий метод).
Получается, что логика ведущих как-то выбивается из общего строя.

2)Собственно, момент расчета.
Базовые - тут и говорить не о чем;
Расчет сторно вытесняющих довольно легко пустить через процедуру общего модуля, тут как-то тоже легко и просто...
А вот как быть с перерасчетами по ведущим?
Возникает ряд вопросов:
- Что нужно сделать, чтобы запись исчезла из таблицы перерасчета? (ессно, исключая удаление :) )
- Правильно ли я понял, что перерасчет целиком дело рук и головы программиста, и единственная помощь от платформы - это таблица перерасчета?

(3) А там много чего интересного.
Например, настроить иерархию вытеснений как можно? Через несколько планов&регистров?
Непонятливый
6 - 27.05.2004 07:21 		(4),(5)

C утреннего ручника снялся - по аналогии с демо-конфигурации написал свою обработку перерасчетов. Работает, но пока непонятно, как.
Т.о. вопрос про "что нужно сделать, чтобы..." снят. :)))

А вот вопрос о сервисе платформы приобретает еще небольшой подвопрос:
- В случае, если перерасчитать нужно прошлый (aka закрытый) период, это исключительно собственными лапами делать нужно? В смысле, плясать со сторно&добавлением новых корректных строк в регистр расчета?


Вопрос про ЗиК. Как установить определенный порядок вычисления расчетов. | База знаний | mista.ru

Вопрос про ЗиК. Как установить определенный порядок вычисления расчетов.

stud 15.05.2004 17:10 | У меня имеется несколько моих видов расчетов. На нескольких из них имеются начисления. Нужно чтобы эти расчеты выполнялись в определенном мной порядке. Как установить порядок расчета?
DElo 1 - 15.05.2004 17:15 | Если эти расчёты делаются отдельно документом "Ввод расчёта сотруднику" - то всё будет зависить от порядка создания и проведения этих документов.
bazvan 2 - 15.05.2004 17:18 | +1 От порядка создания расчетов так как у них приоритет одинаковый (в пофигураторе) то они обрабатываются в глМодуле
stud 3 - 15.05.2004 17:18 | В смысле по дате создания или как?
stud 4 - 15.05.2004 17:27 | Т.е. у одного нужно установить приорите больше чем у другого? Там везде стоят 15. У меня будут 15, 16, 17. Или как?
bazvan 5 - 15.05.2004 17:29 | Ну типо того


Календари | База знаний | mista.ru

Календари

Vini
11.05.2004 06:44 		Добрый день !!
Вот такая проблема никак не могу разобратся с календарями!!!
создаю календарь
включаю автозаполнение и вот хочу чтобы в в окне сообщений он мне
сообшил все выходные и праздникик если вас не затруднитть подскажите код буду очень признателен!!
Зарание благодарен!
List
1 - 11.05.2004 15:05 		Для этого необходимо просмотреть календарь и найти дни, в которых Значение установлено в 0.00 и все.
Выходные = СоздатьОбъект("Календарь.КалендарьСдачиОтчетности");
Выходные.ВыбратьДаты(ДатаНачала,ДатаОкончания);
Пока Выходные.СледующаяДата() = 1 Цикл
ВсеПраздники = Выходные.Дата;
ЗначениеДаты = Выходные.Значение;
Если ЗначениеДаты = 0.00 Тогда
Таб.ВывестиСекцию("Строка");
КонецЕсли;
КонецЦикла;


Скорость работы журнала расчетов | База знаний | mista.ru

Скорость работы журнала расчетов

Сергей 08.05.2004 11:53 | Вопрос следующий. У меня база абонентов в справочнике содержит порядка 18000 элементов. При выполнении простого расчета для всех (хотябы просто вид расчета поставить 5 руб начисления) уходит порядка 5-10 мин на расчет можно ли как то ускорить этот процесс к примеру транзакцией.
BorisG 1 - 08.05.2004 12:47 | Можно... в зависимости от того, что умеешь делать, и какая стоит цель. Один из вариантов... 1С++


Какое различие между документом-основанием и документом-родителем записи | База знаний | mista.ru

Какое различие между документом-основанием и документом-родителем записи

seon 05.10.2004 15:41 | v7. Какое различие между документом-основанием и документом-родителем записи журнала расчетов?
Волшебник 1 - 05.10.2004 15:55 | Документ-родитель - кто ввел эту запись, например, док. "ВводЕжемесячныхУдержаний" Документ-основании - на основании кого, например, док. "ИсполнительныйЛист" или "Ссуда".


V8 Что означает базовый период в регистре расчета? | База знаний | mista.ru

V8 Что означает базовый период в регистре расчета?

44 18.08.2004 13:03 | Что означает базовый период в регистре расчета?
Michael99 1 - 18.08.2004 13:18 | Посмотри : http://itland.ru/forum/index.php?showtopic=3575&hl=базовый+период
44 2 - 18.08.2004 15:50 | Базовый период - это период, за который система анализирует изменения в базовых видах расчета по отношению к текущей записи, при формировании таблицы перерасчета.


В каком файлике хранятся настроки шаблонов для 7.7 ? | База знаний | mista.ru

В каком файлике хранятся настроки шаблонов для 7.7 ?

gray 10.09.2004 13:47 | subj
F427 1 - 10.09.2004 13:49 | *.st


Графовое представление MD | База знаний | mista.ru

Графовое представление MD

Rodion 21.06.2004 06:03 | Доброго времени суток, видел в инете отчет под 1С v8 который выгружает структура метаданных в граф, с последующей загрузкой в просматривалку. Т.е. это такой инструмент для анализа структур конфигураций. Может знаете где взять такую вешь, понадобилось, а найти немогу :(
mszsuz 1 - 21.06.2004 06:21 | http://mista.ru/dot/index.htm


А можно создать программно новый объект метаданных? | База знаний | mista.ru

А можно создать программно новый объект метаданных?

Таня 03.06.2004 17:58 | например, добавить в Перечисление новый элемент?
gls 1 - 03.06.2004 17:59 | в 7.7 - нет.
Волшебник 2 - 03.06.2004 18:02 | в 8.0 тоже нет
gls 4 - 03.06.2004 18:03 | только через конфигуратор.
Gavrila 6 - 03.06.2004 18:22 | попробуй ActiveMD
Волшебник 8 - 03.06.2004 19:06 | (0) Можно еще ПРОГРАММНО распаковать md через GComp, добавить туда объекты (программно) и собрать md обратно. Только это надо делать извне md, например, из другой конфигурации или из программы на другом языке.
Рупор абсурда 9 - 03.06.2004 19:07 | (6) Попробуй Джага-джага ... Успех будет точно таким же ...


Копирование документов (модуль,формы) | База знаний | mista.ru

Копирование документов (модуль,формы)

Luda 28.05.2004 11:04 | В демо-версии отредактировала документ(модуль,экр.и печ.формы). Подскажите,пожалуйста, как его корректно перенести в рабочую версию целиком,а не отдельно модуль и формы. Пробовала поменять идентификатор(чтобы не было двух одинаковых док-в при копировании),т.к. старый док.не удаляется - есть ссылки.
SnarkHunter 1 - 28.05.2004 11:13 | Режим объединения...
kadr 2 - 28.05.2004 11:26 | Я не совсем понял: ты редактировала в режиме конфигуратора (модуль,экр.и печ.формы) или в режиме работы с базой (тогда при чем тут модуль и т.д.?)?
Luda 3 - 28.05.2004 13:27 | (1) Спасибо.С режимом объединения пока не разобралась. Перенесла отдельно модуль и формы. (2) А разве модуль можно отредактировать не в Конфигураторе?
427 4 - 28.05.2004 13:33 | Модули можно редактировать ... В блокноте, в ворде в мдЭдиторе и переносить можно... не пользуясь объединением и замещением ....
Luda 5 - 28.05.2004 13:41 | (4)Да, модуль и печатную форму объекта перенести без объединения просто. А вот с экранной формой (многостраничная часть) у меня не получилось.


А никто не думал? Может быть, Орефков, или ФЕЗ ? | База знаний | mista.ru

А никто не думал? Может быть, Орефков, или ФЕЗ ?

vS 19.10.2004 16:23 | а что это мы, братья славяне, для обновления ВЕСЬ МД таскаем? может быть можно таскать только то, что изменилось/мы решили изменить? только не предлагайте ГКомп, это довольно массивно, и требует большого обвеса, я про минимальный софт... ФАРом я там думаю можно.. может есть чтото более визуальное применительно к 1С?
Diter 1 - 19.10.2004 16:25 | (0) Может ActiveMD подойдёт?
Diter 5 - 19.10.2004 16:42 | (4) С помощью этой ВК можно работать по полной программе (добавлять, изменять, удалять) со всеми модулями всех объектов МД, справочниками, документами, перечислениями. Проблемно (или невозможно) работать с формами. Ограниченно можно работать с журналами. Вообще самый простой способ работы с изменением МД я применяю такой. Есть два одинаковых МД. В первойм я например добавляю или изменяю документ. Становлюсь на него в конфигураторе и нажимаю Ctrl+Ins. После этого открываю буфер обмена и сохраняю содержимое в файл (один документ порядка 200 Kb). Беру этот файл и еду к клиенту. Там повторяю операцию с точность до наоборот.
fez 13 - 19.10.2004 18:00 | Минимальным набором софта для тебя - будет как раз gcomp. Больше ничего не надо. 1. Разбираешь конфу в папку. 2. Правишь то, что хочешь исправить. 3. Разбираешь еще раз в ту же папку с ключом -v. 4. Внимательно смотришь - что тебе скажет gcomp. А скажет он тебе список измененных файлов. Список можно перенаправить в файл на всякий случай. 5. Берешь эти файлы с собой на дискетке к клиенту. 6. По приезду к клиенту - разбираешь его конфу gcomp'ом. 7. В развернутую папку подкладываешь файлики с дискетки. 8. Компилишь конфу обратно. 9. Загружаешь ее как измененную. Когда надоест делать ручками - напишешь скрипт. Для программиста это не должно составить затруднений.


Как программно узнать параметры справочника | База знаний | mista.ru

Как программно узнать параметры справочника

jbond 13.10.2004 12:42 | Как программно узнать: 1)Признак контроля уникальности кодов справочника 2) Кол-во уровней справочника
Рупор абсурда 2 - 13.10.2004 12:47 | 1) В попытке создать и записать элемент с неуникальным кодом, проанализировать сообщение об ошибке ... 2) В попытке последовательно записывать элемент на более глубокий уровень, на ошибке получишь максимальный уровень ... (1) Объект МЕТАДАННЫЕ это для ламеров и лентяев ...
Волшебник 3 - 13.10.2004 12:47 | См. также: Описание объекта Метаданные http://www.mista.ru/download1c/metadata_als.zip Автор pit


Будни: Как определить, что ссылка на справочник или документ? | База знаний | mista.ru

Будни: Как определить, что ссылка на справочник или документ?

Волшебник
20.09.2004 22:48 		Вопрос с Т1С:

Есть функция глЧтото(Парам), в качестве параметра в оную может передаваться либо Метаданные.Справочники.ХХХ, либо же Метаданные.Документы.ХХХ. Собственно, вопрос: как в функции глЧтото
узнать Парам - это справочник, или объект?

-------------
Ответ:

Дяпти:
ЭтоСправочник = Справочники.ТипВсеСсылки().СодержитТип(ТипЗнч(МояНепонятноКакаяСсылка));

аналогично:

ЭтоДокумент = Документы.ТипВсеСсылки().СодержитТип(ТипЗнч(МояНепонятноКакаяСсылка));

Та ветка:
http://www.kuban.ru/forum_new/forum9/files/200703.html

-----------------------------
В типовых еще используется функция ПринадлежностьКлассуМетаданных

Функция ПринадлежностьКлассуМетаданных(Класс, Объект) Экспорт
Для Каждого МДОбъект Из Метаданные[Класс] Цикл
Если МДОбъект = Объект Тогда
Возврат Истина;
КонецЕсли;
КонецЦикла;
Возврат Ложь;
КонецФункции
--------

Но что-то она мне не нравится. Топорно как-то...


Где в 1С хранятся процедуры обработки быстрых клавиш? | База знаний | mista.ru

Где в 1С хранятся процедуры обработки быстрых клавиш?

ken_gd 13.07.2004 11:22 | Где в 1С хранятся процедуры обработки быстрых клавиш? Хочу переписать стандарную процедуру копирования документов в 1С.
ken_gd 3 - 13.07.2004 12:09 | Пользователи иногда вместо копирования в документах, думая что копируют (много работы, пользователи невнимательные), просто открывают сам документ и изменяют в нем данные (а документы уже проведены через кассу).Хочу запретить копирование, оставить только ввод на основании.
Волшебник 4 - 13.07.2004 12:24 | Предопределенная процедура в модуле формы документа/справочника: ВводНового(<ПризнКопирования>,<ОбъектКопирования>) <ПризнКопирования> - признак того, что объект введен копированием. Число: 1 - объект введен копированием, 0 - просто новый объект. Процедура ВводНового(ПризнКопирования,ОбъектКопирования) Если ПризнКопирования = 1 Тогда СтатусВозврата(0); КонецЕсли; КонецПроцедуры


Как программно определить длину реквизита, задаваемую в конфигураторе? | База знаний | mista.ru

Как программно определить длину реквизита, задаваемую в конфигураторе?

GeV 13.08.2004 14:49 | Ситуация следующая: Создан СписокЗначений, элементами которого являются все справочники конфигурации. Из этого списка выбирается конкретный справочник для дальнейшей обработки. Как програмно узнать длину кода элемента этого справочника? Речь идет не о конкретном элементе справочника и длине его кода, а о длине кода, которая задается в диалоговом окне справочника в конфигураторе.
Guk 2 - 13.08.2004 14:54 | Метаданные.Справочник(х).ДлинаКода
SnarkHunter 11 - 13.08.2004 15:18 | (9)Попроси als у 427 - он автор... Или по ссылке http://www.sinor.ru/%7Efilez/meta.zip
mszsuz 13 - 13.08.2004 15:23 | "Справочный файл "Синтакс-помощника" по метаданным" (редакция от декабря 2002 г.) от Моисеенко П.П. aka pit aka 427 http://www.sinor.ru/~my1c


Как сделать 1С-ке генератор случайных чисел ? | База знаний | mista.ru

Как сделать 1С-ке генератор случайных чисел ?

cat
12.08.2004 07:32 		Привет всем!
Подскажите пож-та... можно ли сделать в 1С-ке генератор случайных чисел или есть ли такая команда как "randomize timer"
Petro
2 - 12.08.2004 08:11 		Пользуюсь вот этим. Чье-то. Спасибо ему(ей).

Перем глСлучайноеЧисло Экспорт;

Функция глРанд(От=0,До=1,Шаг=0,Парам=0) Экспорт
Если Парам<>0 Тогда
глСлучайноеЧисло=Парам;
КонецЕсли;
Если Число(глСлучайноеЧисло)=0 Тогда
глСлучайноеЧисло=Число(СтрЗаменить(""+ТекущееВремя(),":",""));
глСлучайноеЧисло=(16807*глСлучайноеЧисло)%2147483647;
КонецЕсли;
глСлучайноеЧисло=(16807*глСлучайноеЧисло)%2147483647;
глСлучайноеЧисло=макс(глСлучайноеЧисло,-глСлучайноеЧисло);
СлЕд=глСлучайноеЧисло/2147483647;
СлВыб=СлЕд*(До-От)+От;
Если Шаг>0 Тогда
СлВыб=От+Окр((СлВыб-От)/Шаг)*Шаг;
КонецЕсли;
Возврат(СлВыб);
КонецФункции
Эмблема форума
4 - 12.08.2004 08:15 		http://www.sinor.ru/%7Emy1c/knowhow/rand.html
NS
13 - 12.08.2004 14:06 		(11)Да уж.... веточка... Никто так и не привел алгоритм, как пять чисел расположить в случайном порядке....
randSeed=ranseed%100000000001;
randSeed=randSeed*1103515245+12345;
и проблемы со скоростью снимаются...
NS
18 - 12.08.2004 14:37 		(17) randSeed=randseed%100000000001;
а так? ;-)
по поводу (12)
Премешать N чисел:
Для а=1 по N цикл
массив[а]=а;
Конеццикла;
Для а=1 по N-1 цикл
Сл=Случ(а,N);// Целое случайное число в интервале [а..N]
К=массив[а];
массив[а]=массив[Сл];
массив[Сл]=К;
КонецЦикла;
cat
21 - 12.08.2004 14:47 		всё хорошо....
Sc = CreateObject("MSScriptControl.ScriptControl");
Sc.language = "VBscript";
sc.executeStatement("randomize");
оноВотТутаБудет=Sc.eval("rnd");
но как тут сделать чтобы числа выбирались произвольно от 1 до 100?
cat
24 - 12.08.2004 15:29 		Ранд=_GetPerformanceCounter()%(100+1);
похоже это лучшеее
romix
31 - 12.08.2004 20:35 		Библиотека мат. функций, где есть генератор сл. чисел:
http://1c.proclub.ru/modules/mydownloads/personal.php?cid=92&lid=2688

Или поиск по ключевому слову "математические".

(30) Не понял. Где там можно ошибиться? Рандомизатор - это стандартная сишная функция, которая есть во всех языках (кроме 1С).


Смысл метода ВключитьПроводки() | База знаний | mista.ru

Смысл метода ВключитьПроводки()

Слеш 04.08.2004 12:09 | Объясните пожалуйста (доступно) зачем нужен этот метод. Если мы хотим чтобы проводки не влияли на бухитоги - проще IMHO сделать документ непроведенным, хочем назад - провели. По моему этот метод потенциальный источник проблем, вроде как и проводки есть у документа, а в оборотке ноль. Ведь нигде (в журнале или где-нибудь еще) не видно, что у дока проводки отключены.
Camino 1 - 04.08.2004 12:11 | Видно в журнале проводок вполне отчетливо.
SnarkHunter 3 - 04.08.2004 12:12 | Работает быстрее чем удаление движений...
Слеш 4 - 04.08.2004 12:15 | (1) да, дейсвительно, в журнале проводок меняются иконки у строк (3) в смысле, если нам нужно на время убрать движения документов за какой-то период, гораздо шустрее получится отключить/включить проводки. Я прав?
SnarkHunter 5 - 04.08.2004 12:18 | (4)Ах-ха... Ибо записи физически остаются в таблице... Для СКЛ, по крайней мере...
Dert 6 - 04.08.2004 12:19 | Вот еще на ум пришло. Например нам понанобилось, чтобы проводки на некоторое время не влияли на бухитоги, а при перепровдении например они могут поменятся. Иногда такое тоже может быть


ФИО в родительном падеже как? | База знаний | mista.ru

ФИО в родительном падеже как?

Lem 16.07.2004 20:18 | Собственно вот и весь вопрос. :)
Asmody 7 - 18.07.2004 01:34 | (6) а если точнее, то теперь тут: http://1c.proclub.ru/modules/mydownloads/personal.php?cid=5&lid=1545
Матрейя 8 - 18.07.2004 13:06 | Самый корректный вариант - это дополнительный реквизит, который по умолчанию автозаполняется, так как многие Ф.И.О не склоняются или склоняются нестандартно.
Asmody 16 - 18.07.2004 14:18 | ИМХО, я бы использовал (7) для получения ФИО в нужном падеже, но дал бы пользователю возможность его отредактировать прямо там, где оно понадобилось (в документе и т.п.) в 90% случаев (а может и больше) (7) дает нормальный результат, остальное можно и руками поправить
Warlock 17 - 18.07.2004 14:20 | (16)А как тебе вариант при создании элемента справочника применить (7), а затем заполнить соответствующие (дополнительные) реквизиты. И при формировании печатных форм - все ОК...
Asmody 18 - 18.07.2004 14:26 | (17) ну или так... хотя так больше места надо.
Lem 20 - 18.07.2004 14:57 | А как все это сделать Я скопиров из текстового файла фунцию падеж сделал 3 реквизита фамилие имя отчество и напротив их еще такие же но в родительном падеже. Так вот как сделать так чтобы в ревизитах при вводе например фамилии напротив в реквизите фамилие род.падеж делалась подстановка.
Asmody 21 - 18.07.2004 15:07 | в свойствох исходных реквизитах напиши функцию, которая будет заполнять реквизиты в род.падеже


Масивы в 1С | База знаний | mista.ru

Масивы в 1С

Valik
13.07.2004 17:58 		Ребята скажите я чето не пойму есть в 1С моногомерные массивы?
И если есть то как они обявляетються?

перем а[100,100]; - такое не катит :(
Crew
1 - 13.07.2004 18:06 		Есть. Называются таблицы значений ;)
427
2 - 13.07.2004 18:34 		есть... надо только подумать....
(1) можно и не таблицу значений....
Crew
5 - 13.07.2004 21:13 		(2)
Можно. Но, имхо, ТЗ проще.
Волшебник
6 - 13.07.2004 21:16 		В ячейке таблицы значений может содержаться другая таблица значений или список значений. И наоборот.

В версии 8.0 еще появились Структура, Соответствие и ДеревоЗначений.

В общем полный простор для алгоритмов любой сложности. :)
Valik
14 - 14.07.2004 11:23 		Ладно. Конкретный вопрос.
Есть код

тЗнач = СоздатьОбъект("ТаблицаЗначений");

тЗнач.НоваяКолонка("код","Число");
тЗнач.НоваяКолонка("Организация","Строка");
тЗнач.НоваяКолонка("Адрес","Строка")

тЗнач.НоваяСтрока();

тЗнач.код = 12;
тЗнач.Организация = "АВТ";
тЗнач.Адрес = "Киев";

вак = тЗнач.ПолучитьЗначение(0,3);

Сообщить(вак);

На него Error
вак = тЗнач.ПолучитьЗначение(0,1);
{Отчет.отСправочние.Форма.Модуль(84)}: Номер за пределами значения!

Почему? Начинаю с 0 строки и получю 1 значение.
Пояснте как со строки таблицы значений заберать например в первой строке значение первой ячейки?
skunk
16 - 14.07.2004 11:29 		номер строки = 1
Valik
48 - 17.07.2004 16:25 		Какойто бред.
Есть 2 таблицы значений. Я их сравниваю по одному уникальному полю и если они совпадают, то удаляю совпадающие поля из обоих.

тЗнач.ПолучитьСтрокуПоНомеру(1);
Пока тЗнач.ПолучитьСтроку() = 1 цикл
рЗнач.ПолучитьСтрокуПоНомеру(1);
сообщить (рЗнач.КоличествоСтрок());

Пока рЗнач.ПолучитьСтроку() = 1 цикл

Если рЗнач.Организация = тЗнач.Организация Тогда
рЗнач.УдалитьСтроку();
тЗнач.УдалитьСтроку();
КонецЕсли;

конецЦикла
конецЦикла;

Вот такой код дает очень странные результаты :)
Подскажите как нармальные люди бы написали.
NS
52 - 17.07.2004 17:11 		//Выше небольшие синтаксические ошибки
//Это проверенный и отлаженный вариант...
//Но не самый быстрый...
//Удаление строк, конечно лучше делать через доп. колонку...
//*******************************************
Процедура Сформировать()
рЗнач=Создатьобъект("ТаблицаЗначений");
тЗнач=СоздатьОбъект("ТаблицаЗначений");
рЗнач.НоваяКолонка("Организация","Строка",6,0);
тЗнач.НоваяКолонка("Организация","Строка",6,0);
рЗнач.НоваяКолонка("Сумма","Число",10,2);
тЗнач.НоваяКолонка("Сумма","Число",10,2);
рЗнач.НоваяСтрока();
рЗнач.Организация="Москва";
рЗнач.Сумма=152;
рЗнач.НоваяСтрока();
рЗнач.Организация="Судак";
рЗнач.Сумма=140;
рЗнач.НоваяСтрока();
рЗнач.Организация="Тверь";
рЗнач.Сумма=196;

тЗнач.НоваяСтрока();
тЗнач.Организация="Судак";
тЗнач.Сумма=134;
тЗнач.НоваяСтрока();
тЗнач.Организация="Киев";
тЗнач.Сумма=183;
//Тестовое заполнение
//Теперь сам модуль...
рТемп=Создатьобъект("ТаблицаЗначений");
тТемп=СоздатьОбъект("ТаблицаЗначений");
рЗнач.Выгрузить(рТемп,,,"Организация");
тЗнач.выгрузить(тТемп,,,"Организация");
рТемп.свернуть("Организация","");
тТемп.Свернуть("Организация","");
рТемп.НоваяКолонка("Количество","Число",2,0);
тТемп.НоваяКолонка("Количество","Число",2,0);
рТемп.Заполнить(1,,,"Количество");
тТемп.Заполнить(1,,,"Количество");
КолР=рТемп.КоличествоСтрок();
КолТ=тТемп.КоличествоСтрок();
тТемп.КоличествоСтрок(КолР+КолТ);
тТемп.Заполнить(рТемп,КолТ+1,КолТ+КолР);
рТемп.Очистить();
тТемп.Свернуть("Организация","Количество");
тТемп.Сортировать("Количество+");
стр="";
Если ТТемп.НайтиЗначение(2,стр,"Количество")>0 Тогда
тТемп.Выгрузить(тТемп,стр,тТемп.КоличествоСтрок(),"Организация");
Иначе
тТемп.УдалитьСтроки();
КонецЕсли;
тТемп.ВыбратьСтроку(); // Для отладки
СЗ=СоздатьОбъект("СписокЗначений");
тТемп.Выгрузить(СЗ);
// Модуль неоптимальный, но если будет медленно - то напишу другой...
КолР=рЗнач.КоличествоСтрок();
Для а=1 по колР цикл
номстр=КолР-а+1;
Если СЗ.НайтиЗначение(рЗнач.ПолучитьЗначение(номстр,"Организация"))>0 Тогда
рЗнач.УдалитьСтроку(номстр);
КонецЕсли;
КонецЦикла;
КолТ=тЗнач.КоличествоСтрок();
Для а=1 по колТ цикл
номстр=КолТ-а+1;
Если СЗ.НайтиЗначение(тЗнач.ПолучитьЗначение(номстр,"Организация"))>0 Тогда
тЗнач.УдалитьСтроку(номстр);
КонецЕсли;
КонецЦикла;
рЗнач.ВыбратьСтроку(); //Для отладки
тЗнач.ВыбратьСтроку(); //Для отладки
КонецПроцедуры
Valik
53 - 17.07.2004 17:43 		Спасибо, дружище.
Блин, я немного не правильно сказал в описании задачи.
Есть две таблицы значений. Первая Полная, вторая Сокращенная. Так вот мне нужно выбрать все значения из Полной таблицы которые отсутствуют в Сокращенной. Колонка "Организация" не уникальная в обоих таблицах, она может повторяться несколько раз.

Тоесть задача как бы вычесть из Полной таблицы Сокращенную.
Сорри что не дал правельноую постановку проблемы :(
NS
55 - 17.07.2004 17:50 		СЗ=СоздатьОбъект("СписокЗначений");
тЗнач.Выгрузить(СЗ,,,"Организация");
КолР=рЗнач.КоличествоСтрок();
Для а=1 по колР цикл
номстр=КолР-а+1;
Если СЗ.НайтиЗначение(рЗнач.ПолучитьЗначение(номстр,"Организация"))>0 Тогда
рЗнач.УдалитьСтроку(номстр);
КонецЕсли;
КонецЦикла;
Удаляет из рЗнач всё, что есть в тЗнач....
Valik
56 - 17.07.2004 17:53 		Вот они. тЗнач - полная. рЗнач -Сокращенная.
Вычитать надо по полю "Организация".

тЗнач = СоздатьОбъект("ТаблицаЗначений");

тЗнач.НоваяКолонка("ид","Число");
тЗнач.НоваяКолонка("ЕДРПОУ","Число");
тЗнач.НоваяКолонка("Организация","Справочник");
тЗнач.НоваяКолонка("Книга","Справочник");
тЗнач.НоваяКолонка("Колво","Число");
тЗнач.НоваяКолонка("Область","Строка");

рЗнач = СоздатьОбъект("ТаблицаЗначений");

рЗнач.НоваяКолонка("ид","Число");
рЗнач.НоваяКолонка("ЕДРПОУ","Число");
рЗнач.НоваяКолонка("Организация","Справочник");
рЗнач.НоваяКолонка("Книга","Справочник");
рЗнач.НоваяКолонка("Колво","Число");
рЗнач.НоваяКолонка("Область","Строка");
NS
57 - 17.07.2004 17:56 		СЗ=СоздатьОбъект("СписокЗначений");
рЗнач.Выгрузить(СЗ,,,"Организация");
КолТ=тЗнач.КоличествоСтрок();
Для а=1 по колТ цикл
номстр=КолТ-а+1;
Если СЗ.НайтиЗначение(тЗнач.ПолучитьЗначение(номстр,"Организация"))>0 Тогда
тЗнач.УдалитьСтроку(номстр);
КонецЕсли;
КонецЦикла;
Удаляет из тЗнач всё, что есть в рЗнач....


выбор и печать из перечислений | База знаний | mista.ru

выбор и печать из перечислений

Lem 16.07.2004 13:36 | Если поставить в документ реквизит например должностные инструкции (перечисление) как сделать так чтобы при выборе долж. инструкции при печати выскакивала своя должностная инструкция. например выбрали - водитель - выводиться секция водитель, а если выбрать диспетчер то выводилась секция диспетчер
Волшебник 1 - 16.07.2004 13:38 | Самый простой вариант: Если...Тогда ИначеЕсли...Тогда ИначеЕсли...Тогда КонецЕсли;
laeg 3 - 16.07.2004 13:51 | Можно попробовать так таб.ВывестиСекцию(СокрЛП(МоеПеречисление.Вид()));
laeg 7 - 16.07.2004 14:16 | Бес меня попутал :о))) Идентификатор()
Волшебник 8 - 16.07.2004 14:50 | Что-то я не понимаю... А так разве не подходит? Если ПроверяемоеЗначение = Перечисление.ИмяПеречисления.Значение Тогда ....


есть ли программный аналог операции/поиск ссылок на объекты? | База знаний | mista.ru

есть ли программный аналог операции/поиск ссылок на объекты?

Crystalizer 29.06.2004 10:39 | или это всё же делается в цикле вручную?
SnarkHunter 1 - 29.06.2004 10:41 | НайтиСсылки СП трудно открыть?


Управление размером шрифта при печати ценников | База знаний | mista.ru

Управление размером шрифта при печати ценников

Scarabey 26.04.2004 09:46 | Вопрос на засыпку для профессионалов: Печатное наименование товара может достигать более 100 символов, поэтому не убирается в стандартном ценнике Торговли. Задача: по условию превышения 100 символов уменьшить шрифт в области наименования выводимого ценника. А для небольших названий оставить стандартный размер шрифта. Пробовал: Таб.наименование.РазмерШрифта(10); где Таб - таблица вывода, а наименование - соответствующая именованная область. Ноль эмоций, ругня: " Поле агрегатного объекта не обнаружено (наименование)"
Поп Гапон 1 - 26.04.2004 09:56 | Используй Таб.Область("наименование")
Scarabey 2 - 26.04.2004 10:01 | попробовал, теперь так: Значение не представляет агрегатный объект (РазмерШрифта)
Scarabey 3 - 26.04.2004 10:54 | хелп, плиз, что здесь не так?: Таб.Область("наименование").РазмерШрифта(100/СтрДлина(ПечНаименованиеТМЦ)*14);
SnarkHunter 4 - 26.04.2004 11:08 | Здесь "не так" - "наименование"...
Поп Гапон 5 - 26.04.2004 11:13 | (3) А ты Отладчиком пользоваться умеешь? Shift-F9, например в отладчике есть такая комбинация.
Scarabey 6 - 26.04.2004 11:14 | SnarkHunter'у: так как тогда к этой области обратиться? я её поименовал - "наименование"...
lexa 7 - 26.04.2004 11:14 | может сделать проще: сделать две секции с разным рамером шрифта и выводить их в зависимости от длины наименования
SnarkHunter 8 - 26.04.2004 11:18 | (6)Обратись через координаты... Почитай синтакс-помощник, если ЖКК нет...
Scarabey 9 - 26.04.2004 11:41 | Обратился так: Таб.Область("R2C1:R2C4").РазмерШрифта(100/СтрДлина(ПечНаименованиеТМЦ)*14); Результат: В начале страницы выводятся 2 пустые строки, первая с высотой 11.25 пункта, вторая - 18.75 Далее - без изменений
SnarkHunter 10 - 26.04.2004 11:50 | Ну а текст кто будет выводить? Пушкин?
Scarabey 11 - 26.04.2004 11:56 | далее - собственно стандартный вывод секции ценника (с текстом). В результате ячейки по адресу подготовлены для вывода текста правильного размера, но на вывод ценника это не влияет.
lexa 12 - 26.04.2004 12:32 | попробуй все таки две секции, и еще, если надо напечатать несколько ценников на одном листе, то придется выводить номенклатуру с разной длиной наименования в разные таблицы
skunk 13 - 26.04.2004 12:38 | а если два вида ценников... да еще несколько размеров шрифтов... этож сколько секций... ууууу
lexa 14 - 26.04.2004 12:56 | (13) вообще-то в стандартной печати ценников у ценника только один вид и довольно часто печатают на одном листе сразу несколько ценников, и если они разного вида и с разными шрифтами. то как это все будет выглядеть
lexa 15 - 26.04.2004 12:58 | to skunk я конечно не специалист, а если вначале вывести секцию, а потом задать размер шрифта
SnarkHunter 16 - 26.04.2004 13:03 | (15)Вообще-то так и делают...
skunk 17 - 26.04.2004 13:55 | (14)не всегда стандарт прет... большинство испльзуют два вида ценников... говорят есть больше, но я не видал
Valery 18 - 26.04.2004 14:43 | Может подойти так: Размер ценника не меняется,поэтому чтобы разместить надпись необходимо менять размер шрифта, но если надпись бальшая размер будет очень маленьким, тогда что на этом ценнике увидишь. Поэтому я обычно задаю в таблице высоту строки с названием "Авто", тогда размер ценника несколько изменится, но зато название влезет. Остается только найти оптимальное соотношение. Приходится где-то скорректировать название. Так я думаю.
Scarabey 19 - 26.04.2004 14:49 | to Valery: переменная высота строки с наименованием приведёт к тому, что заданное количество ценников на странице может и не поместиться, что, в свою очередь, вызовет глюки в процедуре вывода на печать - и всё расползётся на фих...
Valery 20 - 26.04.2004 15:21 | Все так, но влюбом случае надо чем-то жертвовать. Я в свое время решил так. Оставил запас на странице. Ситуацию разъяснил. Все согласились. Хотя некоторым название необходимо только для торговых инспекций. Им без разницы шрифт лишь бы были указаны все необходимые реквизиты и ценник не заслонял товар.


Как получить значение из обработки? | База знаний | mista.ru

Как получить значение из обработки?

kаdr 25.06.2004 07:21 | Из модуля формы документа из процедуры ПриОткрытии вызывают обработку ОткрытьФорму("Обработка.Новый1",ТЗ), где ТЗ - таблица значений, а в обработке находится таблица в режиме ввода данных. При закрытии формы обработки значения таблицы выгружаются в таблицу значений. Где можно прочитать содержимое таблицы значений в модуле формы документа? Потому, что если я пишу ТЗ.ВыбратьСтроки() сразу после команды ОткрытьФорму, то выдается ошибка Поле агрегатного объекта не обнаружено (ВыбратьСтроки)
Tyпoй Mля 2 - 25.06.2004 08:00 | При закрытии, после выгрузки в ТЗ, напиши Форма.Параметр = ТЗ.
Tyпoй Mля 3 - 25.06.2004 08:02 | Мдя. И еще - писать ТЗ.ВыбратьСтроки() СРАЗУ после функции ОткрытьФорму не имеет никакого смысла.
mszsuz 4 - 25.06.2004 08:58 | // В документе: Функция глВзятьКонтекст(Конт) Возврат Конт; КонецФункции //глВзятьКонтекст Процедура ПриПовторномОткрытии() Если ТипЗначенияСтр(Форма.Параметр)="ТаблицаЗначений" Тогда Форма.Параметр.ВыбратьСтроку(); КонецЕсли; КонецПроцедуры //ПриПовторномОткрытии Процедура ПриОткрытии() Конт=глВзятьКонтекст(Контекст); ОткрытьФорму("Обработка.Новый1",Конт); КонецПроцедуры // В Обработке: Процедура ПриЗакрытии() Если ТипЗначения(Форма.Параметр)=100 Тогда Если Вопрос("Перенести в документ?","Да+Нет")="Да" Тогда Конт=Форма.Параметр; Если Конт.Выбран()=0 Тогда ОткрытьФорму("Документ."+Конт.Вид(),ТЗ); Иначе ОткрытьФорму(Конт.ТекущийДокумент(),ТЗ); КонецЕсли; КонецЕсли; КонецЕсли; КонецПроцедуры //ПриЗакрытии


Как разобрать Имя, Фамилию, Отчество на отдельные состовляющие | База знаний | mista.ru

Как разобрать Имя, Фамилию, Отчество на отдельные состовляющие

bam
24.06.2004 12:55 		Как получить отдельно имя фамилию и отчество, в справочнике сотрудников - то они все в одном свойстве: наименование
Миха
1 - 24.06.2004 13:00 		разобрать строку на 3 составляющие, учитывая пробелы
Волшебник
2 - 24.06.2004 13:05 		см. функцию РаздФИО
в конфигурации Мини-зарплата
http://www.mista.ru/tutor_1c/files/mini_zarplata.zip

или в типовых конфигурациях
Волшебник
8 - 24.06.2004 13:12 		Вот теория выделения фамилии, имени и отчества из ФИО:
http://www.aot.ru/docs/graphan.html
Волшебник
9 - 24.06.2004 13:15 		1-й вариант:

ФИО=СокрЛП(ФИО);
Пока СтрНайти(ФИО, " ")<>0 Цикл
ФИО=СтрЗаменить(ФИО, " ", " ");
КонецЦикла;
ФИО=СтрЗаменить(ФИО, " ", РазделительСтрок);
Фамилия=СтрПолучитьСтроку(ФИО, 1);
Имя=СтрПолучитьСтроку(ФИО, 2);
Отчество=СтрПолучитьСтроку(ФИО, 3);

-------------------------------------------
2-й вариант:

Фамилия = "";
Имя = "";
Отчество ="";

ФИО=СокрЛП(ФИО);
ОбщДлина=СтрДлина(ФИО);

//поделим на фамилию, имя и очество
// позиция первого пробела
ПервПроб = Hайти(ФИО," ");
Если ПервПроб=0 Тогда
Фамилия = СокрЛ(ФИО);
Иначе
Фамилия = Лев(ФИО,ПервПроб);
ИО = Сред(ФИО,ПервПроб+1);
ИО = СокрЛП(ИО);
// позиция второго пробела
ВтПроб = Hайти(ИО," ");
Если ВтПроб = 0 Тогда
Имя = СокрЛП(ИО);
Иначе
Имя = СокрЛ(Лев(ИО,ВтПроб-1));
Отчество =СокрЛ((Сред(ИО,ВтПроб+1)));
КонецЕсли;
КонецЕсли;


ПустоеЗначение() | База знаний | mista.ru

ПустоеЗначение()

ViCon 23.06.2004 09:58 | В описании 1С 8 версии сообщают что этой функции больше нет, а что вместо нее, кто знает? И чем собствено она не устраивала?
Волшебник 1 - 23.06.2004 10:27 | Теперь есть функция ЗначениеНеЗаполнено(), написанная на встроенном языке. Увидеть ее можно в общем модуле типовых конфигураций.
Gavrila 2 - 23.06.2004 10:40 | интересно аж, а чем собственно аргументировано "убийство" столь полезной функции?
Волшебник 3 - 23.06.2004 10:48 | Видимо потому, что она легко реализуется средствами встроенного языка. Для устранения избыточности и достижения высшей гармонии платформы.


Может у когонить уже есть готовая функция склонения | База знаний | mista.ru

Может у когонить уже есть готовая функция склонения

_student 18.06.2004 18:54 | подкиньте если не жалко
It is me 2 - 18.06.2004 18:59 | Если ты мне "на пальцах" расскажешь некривой алгоритм работы такой функции, напишу бесплатно. Самый некривой способ это создать словарь и в него заносить все эти склонения...
Asmody 3 - 19.06.2004 17:08 | смотреть сюда http://1c.hippo.ru/cgi-bin/predownl.cgi?id=1545


Математика в 1С | База знаний | mista.ru

Математика в 1С

pepler 11.06.2004 15:43 | Как в 1С возвести число в степень 0.5 или вычислить квадратный корень ?
mszsuz 1 - 11.06.2004 15:59 | http://www.sinor.ru/~my1c/knowhow.html#MATH
SnarkHunter 3 - 11.06.2004 17:22 | Разложение в ряд Тейлора рулит... Сходимость там хорошая...


Стиль работы с типом Булево на платформе v8 | База знаний | mista.ru

Стиль работы с типом Булево на платформе v8

Волшебник
09.06.2004 11:48 		В связи с тем, что в версии 8.0 появился тип Булево со значениями Истина и Ложь, то стали возможными некоторые интересные конструкции.

Например, есть простой фрагмент:

Если Флаг Тогда
ЭлементыФормы.Поле1.Доступность = Истина;
Иначе
ЭлементыФормы.Поле1.Доступность = Ложь;
КонецЕсли;

...тогда его можно заменить на более короткую конструкцию:

ЭлементыФормы.Поле1.Доступность = Флаг;

...а если флаг с обратным смыслом, то:

ЭлементыФормы.Поле1.Доступность = НЕ ОбратныйФлаг;

===================================

Более сложный пример. Вместо Флаг используется логическое выражение (дающее результат типа Булево)

Например, следующую длинную конструкцию...

Если Поле2 = Поле3 Тогда
ЭлементыФормы.Поле1.Доступность = Истина;
Иначе
ЭлементыФормы.Поле1.Доступность = Ложь;
КонецЕсли;

...можно заменить на более короткую конструкцию (как в 7.7):

ЭлементыФормы.Поле1.Доступность = ?(Поле2 = Поле3,Истина,Ложь);

...или еще на более короткую (невозможную в 7.7)

ЭлементыФормы.Поле1.Доступность = (Поле2 = Поле3);

Последняя конструкция выглядит элегантно, но сложна для понимания (или просто непривычна). Как на ваш взгляд? Как вы относитесь к такому стилю программирования в восьмерке?
427
1 - 09.06.2004 11:58 		ЭлементыФормы.Поле1.Доступность = (Поле2 = Поле3);

такая запись используется в Паскале. Известна уж ХХХ лет и достаточно прозрачна.

из типовых !!!! как ответ Чемберлену

Например, есть простой фрагмент:
глобальник
Истина = 1;
Ложь = 0;

ЭлементыФормы.Поле1.Доступность(Флаг)
Практически все флажки так и сделаны
Флаг = Истина или Ложь

P.S. - введение типа данных Булево в 8 достаточно удобно. Хотя и не принципиально.
Волшебник
2 - 09.06.2004 12:01 		(1) Можно еще завести глобальные переменные
Да = Истина;
Нет = Ложь;

Некоторые фрагменты станут более понятными.
Но к сожалению экспортируемые переменные модуля приложения в восьмерке не видны в общих модулях.
Vozhd
3 - 09.06.2004 12:12 		(2) Определи в глобальнике структуру КонтекстВолшебника, забей в нее все свои переменные, и передавай ее во все общие модули
Волшебник
4 - 09.06.2004 12:26 		"и передавай ее во все общие модули"
в каждую процедуру и функцию общего модуля?? Как некрасиво!
Vozhd
5 - 09.06.2004 12:42 		(4) А что поделаешь, если сервер 1С построен на stateless объектах MTS. Вот и приходится не совсем красиво крутиться...
Z1
6 - 09.06.2004 12:48 		(0) "ЭлементыФормы.Поле1.Доступность = (Поле2 = Поле3); "
В языке С ( как и в паскале)разные лексемы языка для операции присваивания и операция сравнения на равенство. И то возникали неправильнbе написания кода и
интерпретация кода.
В 1сv8 еще хуже одна лексема = еще более запутывает понимание кода.
И что будет если скобки пропустить ?
(ИМХО) Т.е. код должен быть проще и понятнее даже в ущерб эффективности.
Поиск такой ошибки сколько может занять времени.
Опять же тип булево могут быть очень тонкие ошибки ( нет строгой типизации) при преобразованиях из за позднего связывания и преобразований типов
Variant, int, Булево.
Vozhd
7 - 09.06.2004 12:55 		(6) Это проблема большинства скриптовых языков - за скорость разработки приходится платить жутко тонкими и хитрыми ошибками...


Особенность преобразования числа к типу "Строка" в 1Cv8 | База знаний | mista.ru

Особенность преобразования числа к типу "Строка" в 1Cv8

Rom 09.06.2004 09:49 | При преобразовании чисел начиная с 1000 в строку получаем следующее: "1 000" (т.е. разделение триад пробелами)
427 1 - 09.06.2004 09:51 | Об этом сказано в доке - учет форматов даты и времени из системы. Во многих случаях неудобно
¶ 3 - 09.06.2004 10:29 | Убери разделитель групп и поставь Группировка=0 (Администрирование - Региональные установки ИБ).
Волшебник 4 - 09.06.2004 10:39 | См. статью на ИТС
mszsuz 7 - 09.06.2004 11:22 | http://v8.1c.ru/predpriyatie/typical_problems.htm#10


форматирование чисел типа #N019.4 | База знаний | mista.ru

форматирование чисел типа #N019.4

Crystalizer 08.06.2004 10:22 | в таблицах можно форматировать так #N019.4 в самой программе не принимает такое. работает ли это как-то в программе. про "окр" знаю
SnarkHunter 1 - 08.06.2004 10:27 | Read This F...ing Manual, please... Формат() читай, да?


Как лучше найти ссылки на элемент справочника в документе? | База знаний | mista.ru

Как лучше найти ссылки на элемент справочника в документе?

lexa 02.06.2004 19:24 | Сделал двумя способами через запрос и через НайтиСсылки(). но медленно?
427 2 - 02.06.2004 21:24 | Смотря что надо найти... Можно и быстро, но надо знать структуру данных в конфе... И где какой реквизит используется в движении... Тогда по движению с детализацией до дока - ищется быстро (номенклатура в доках, например)
SnarkHunter 3 - 02.06.2004 22:41 | Сделай прямым запросом...
Warlock 4 - 03.06.2004 01:26 | (3) Вообще-то lexa написал, что он делал запросом! Может и не (?) \"прямой\"?! Но я думаю, что запрос должен выполняться быстро, оперативно, чтобы не заставлять пользователя ждать, а при нормальном объеме данных как ни крути, а понадобится время!
SnarkHunter 5 - 03.06.2004 06:03 | (4)Вообще-то запрос запросу рознь... Раз lexa пишет, что медленно, то это, скорее всего, честный запрос 1С, так называемый "черный"... Мне тут по роду деятельности не так давно пришлось такую же вещь делать - поиск ссылок на элементы справочника номенклатура... Элементов порядка 15000 штук, результирующая таблица ссылок получилась чуть больше миллиона записей... Так вот, метод НайтиСсылки() работал минут сорок, после чего я его просто прибил, ибо надоело ждать... "Прямой" запрос к СКЛ-серверу отработал ту же задачу за время чуть меньшее 3 минут + еще пару минут понадобилось, чтобы выгрузить результат запроса во внешний файл, потому как оперативки не хватало...
lexa 6 - 03.06.2004 10:38 | (5) у меня дбф (2) а что такое движение? (0)+ проблема еще и в том, что нужно найти и не проведенные документы
Valery 7 - 03.06.2004 10:48 | SnarkHunter предлагает поиск непосредственно в dbf. Вообще тема хорошая, но надо всю структуру изучить.
lexa 8 - 03.06.2004 11:09 | (7) если я правильно понял то нет -""Прямой" запрос к СКЛ-серверу отработал" хотя конечно, если использовать ключи, то "прямой" запрос к дбф будет быстрее, но не факт
SnarkHunter 9 - 03.06.2004 11:32 | (7)Нет, не в дбф (8)Далеко не факт


Как передать список выражений в функцию Мин() или Мак() | База знаний | mista.ru

Как передать список выражений в функцию Мин() или Мак()

Дмитрий 01.06.2004 08:17 | Доброго времени суток Помогите разобраться с такой проблемой. Есть таблица значений, из которой выбирается несколько значений удовлетворяющих определенному условию... Полученные значения нужно передать в функцию Мин(). Как это можно сделать?
Волшебник 1 - 01.06.2004 08:19 | например, через функцию Шаблон. А еще можно написать свою функцию Мин
Волшебник 3 - 01.06.2004 08:22 | Вот здесь кое-что написано: http://www.sinor.ru/~my1c/knowhow/shablon.html
Дмитрий 4 - 01.06.2004 08:51 | Шаблон конечно хорош при фиксированом количестве переменных... Только этих переменных уж очень много получается, и их число всегда разное... Может быть еще другие способы?
Волшебник 5 - 01.06.2004 08:52 | Можно в процессе выборке сразу находить минимум/максимум. Еще можно отсортировать по убыванию/возрастанию и выбрать первый.


Как прервать выполнение обработки в 8.0 | База знаний | mista.ru

Как прервать выполнение обработки в 8.0

ChAlex 20.05.2004 17:27 | Как в 1С 8.0 прервать запущенную обработку (например отчет), не дожидаясь ее окончания. В 1С 7.х выйти можно было по Esc. В 8-ке это не работает.
427 1 - 20.05.2004 17:45 | контрол бреак
Волшебник 2 - 20.05.2004 22:24 | Нужно, чтобы в цикле вызывалась процедура ОбработкаПрерыванияПользователя()
ChAlex 3 - 25.05.2004 16:26 | С программным кодом нормально. А можно ли прервать выполнение запроса уже после начала выполнения? Все-таки иногда сложные запросы тоже долго формируются.


Процедура вызывается как функция... Кто поможет? | База знаний | mista.ru

Процедура вызывается как функция... Кто поможет?

Багира 24.05.2004 16:19 | Процедура _Вычислить(Выражение) Экспорт Шаблон("["+Выражение+"()]"); КонецПроцедуры Процедура П() _Вычислить("Проба"); КонецПроцедуры Не вызвыается процедура Проба(), говорит Проба<<?>>() Процедура вызывается как функция (Проба)
SnarkHunter 3 - 24.05.2004 16:47 | Сделай Пробу функцией...
Багира 4 - 24.05.2004 16:50 | Есть на форме кнопка с формулой П(), она запускает проц-ру П(), которая запускает проц-ру Гл. модуля _Вычислить(). В качестве параметра передается строка "Проба". В Гл. модуле формируется строка "Проба()" при мощи функции Шаблон, и после этого происходит ругательство. Я не могу въехать в фразу "Процедура вызывается как функция".
Багира 8 - 24.05.2004 17:56 | Ладно, конкретизирую задачу. Для передачи в модуль проведения документа Таблицы значений, созданной в процессе редактирования документа в пр-ре ПриЗаписи() используем Провести(,ТЗ). На кнопку ОК вешаем (#Записать Закрыть). Интерактивная запись/проведение работает исключительно. При групповом проведении (из обработки) ТЗ создается программно, для передачи ее в модуль проведения необходимо обратиться к ПриЗаписи(). По совету более опытных товарищей :) принято решение вызывать ее через шаблон в Глобальном модуле. В мод. формы: Процедура П() _Вычислить("ПриЗаписи"); КонецПроцедуры В гл. мод.: Процедура _Вычислить(Выражение) Экспорт Шаблон("["+Выражение+"()]"); КонецПроцедуры Ругается как сказано выше. Я вот думаю, может вообще задействовать в обработке Форма.ПриЗаписи() ? Почему опытные товарищи рекомендовали именно такой путь?
SnarkHunter 9 - 25.05.2004 06:09 | Потому что опытные товарищи пользуются ВК Formex...


О функции "Формат(<Параметр>,<Форматная строка>) | База знаний | mista.ru

О функции "Формат(<Параметр>,<Форматная строка>)

lis 12.05.2004 11:20 | Формат(ДатаДок,"Д(0)ДДММММГГГГ"),в этой функции возможно написание месяца с маленькой буквы? или Формат(Сумма,"ЧП") возможно ли здесь написание числа с маленькой буквы?
427 1 - 12.05.2004 11:28 | Да.... смотри файл прописи
lis 2 - 12.05.2004 12:04 | ок, в случае с датой это работает, а в случае с числом Формат(Сумма,"ЧП") не работает
Krio 3 - 12.05.2004 13:09 | а как насчет функций ВРЕГ(), НРЕГ() ?


Есть ли в 1С-ине конструкция подобная case ... switch | База знаний | mista.ru

Есть ли в 1С-ине конструкция подобная case ... switch

-morgan- 11.05.2004 18:07 | Соббственно сабж.
Fynjy 1 - 11.05.2004 18:54 | Нет. Хотя похоже можно реализовать через "Если Тогда КонецЕсли".


Вызов процедуры с помощью контекста | База знаний | mista.ru

Вызов процедуры с помощью контекста

Вася 07.05.2004 16:16 | Поможите люди! Можно вызывать процедуру примерно вот так: док = СоздатьОбъект("Документ.ХХХ"); док.Процедура(); а если нет то как можно через "док"
Gavrila 2 - 07.05.2004 16:29 | ОткрытьФорму(док, "Какая-то там процедура", -1); В самом документе в модуле формы в процедуре при открытии проверяешь Форма.Параметр, запускаешь свою процедуру и пишешь СтатусВозврата(0); :)
Вася 3 - 07.05.2004 16:38 | А так чтобы не трогать модуль документа. Нельзя?
Gavrila 4 - 07.05.2004 16:40 | попробуй "экспорт" указать процедуре в документе, может и получиться, хотя никогда не пробовал, а вообще лучше ты эту процедуру перенеси в глобальник если она не только в документе используется.
SiMazx 5 - 07.05.2004 16:41 | Низя... А почему не хочешь потрогать модуль документа? Это так прикольно! Незабываемые вчепятления!
SiMazx 6 - 07.05.2004 16:42 | Экспорт только для глобальниковских процедуров... А глобальник потрогать не боишься?
Вася 7 - 07.05.2004 16:45 | Просто хотелось написать универсальную обработку которая работала бы не зависино от конфы. Ну если нельзя то ладно. Спасибо!
427 10 - 07.05.2004 17:46 | Можно.... ВК от Альфа... Но это нештатные средства
Skorp 11 - 07.05.2004 20:43 | Есть штатный изврат вызывать внутри конструкции Шаблон(). Не помню точно при каких условиях, но иногда работает как-будто код расположен в модуле формы.


Вопрос по синтаксису языка 1с | База знаний | mista.ru

Вопрос по синтаксису языка 1с

Danila 03.05.2004 10:18 | Подскажите пожалуйста, что означает знак вопроса перед скобками? ЦенаНДС = ?(КолТовара=0,0,ТЗИтоги.СуммаРуб/КолТовара); Заранее благодарю
Если 1 - 03.05.2004 10:21 | Если
leon3 2 - 03.05.2004 10:22 | Я че это разве не условный оператор? ?(Условие, Действие_Если_Условие_Истинно, Действие_Если_Условие_Ложно)


Как автоматически обойти 30 однотипных реквизитов в табличной части ? | База знаний | mista.ru

Как автоматически обойти 30 однотипных реквизитов в табличной части ?

Allan Stark 30.11.2004 12:44 | Создаю табель (зарплата). Там есть такое понятие, как разграфка по дням, причем значением в ячейке может быть либо кол-во часов (число), либо Б (болел) либо О (отпуск). Реализовал через перечисление (несколько вариантов часов) + Л + О. создал процедуру, которая автоматически просматривает ячейку и в зависимости от значения перечисления накручивает соотв. счетчик для итогов. Встает вопрос: как красиво обойти все 30 реквизитов, без выстраивания длиннющей последовательности вызовов этой процедуры типа Преобр(Д1) Преобр(Д2) Преобр(Д3) .... Преобр(Д31) Заранее благодарен.
Guk 6 - 30.11.2004 12:52 | Для к=1 по 31 Цикл ТекРеквЗнач=ПолучитьАтрибут("Д"+к);


Можно ли программно поменять номер операции? | База знаний | mista.ru

Можно ли программно поменять номер операции?

vS 05.11.2004 05:13 | т.е. я создаю программно операцию, только ее номер меня не совсем устраивает, есть ли чтото типа НомерДок? Чтото найти не могу...
SnarkHunter 6 - 05.11.2004 06:58 | Опер.Документ.НомерДок


Интерпретатор 1С ??? | База знаний | mista.ru

Интерпретатор 1С ???

apples 26.10.2004 08:48 | В руководстве 1С (7.7) "Описание встроенного языка" во 2 томе на стр. 833-834 есть такое вот интересное предложение: " ... В данном варианте фаза вывода данных в Таблицу работает быстреепервого варианта (выигрыш ~ 20%), т.к. в програмном модуле выражения вычисляются существенно быстрее, чем выражения, помещенные в ячейках Таблицы (програмный модуль при загрузке компилируется, а выражения в ячейках таблицы интерпретируются каждый раз при выводе секций). ...". Так вот вопрос: Можно ли создать такую Таблицу, которая бы могла интерпретировать выражение и вычислять значение выражения, которое вручную или программно во заносим в определенную ячейку. (короче говоря можно ли заставить работать 1С интерпретатор во время работы программы)?
Злобный Фей 12 - 26.10.2004 09:29 | (9) Не понятно, чем в данном случае не устраивает системная функция Шаблон. Из синтаксис-помошника: Шаблон(<?>) Синтаксис: Шаблон(<Строка_шаблон>) Назначение: Возвращает строку, полученную по шаблону заменой встроенных выражений на значения и форматированием. Параметры: <Строка_шаблон> - строка, содержащая шаблон формирования.
Злобный Фей 13 - 26.10.2004 09:31 | Насколько я помню, в ней можно использовать все доступные в локальном контексте переменные, атрибуты и объекты.


Программный доступ к интерфейсу | База знаний | mista.ru

Программный доступ к интерфейсу

Lyolik 10.10.2004 12:55 | Подскажите, пожалуйста, как можно средствами встоенного языка доступится к интерфесу? (Надо сделать седующее: Если систему запускает Пользователь с интерфейсом №1 Тогда сделать то-то. Как определить интерфейс данного пользователя?)
Warlock 1 - 10.10.2004 13:05 | НазваниеИнтерфейса()


А где в 1С квадратные корни, степени и прочая подобная лабуда? | База знаний | mista.ru

А где в 1С квадратные корни, степени и прочая подобная лабуда?

Женька
15.10.2004 12:30 		Неужели в таком мощном вычислительном средстве нет средств для извлечения корней, возведения в степень?
Crew
2 - 15.10.2004 12:35 		http://www.sinor.ru/~my1c/knowhow.html
Последний Будда
17 - 15.10.2004 13:12 		1с - позволяет расширять функционал при помощи ВК. Какие проблемы подключить dll? Мне лично понравилась ai-Match
Warlock
19 - 16.10.2004 01:09 		http://www.sinor.ru/~my1c/knowhow/addmath.html

Квадратный корень, Экспонента, Степенная функция, Синус, Косинус, Тангенс

// Hижe пpивeдeн Полный тeкcт мoдyля, coдepжaщeгo фyнкции
// КвaдpaтныйКopeнь(),
// ЭкcПонeнтa(),
// CтeпeннaяФyнкция(),
// Cинyc(), Кocинyc() и Taнгeнc().

// Toчнocть c кoтopoй вычиcляютcя Значeния функций
// КвaдpaтныйКopeнь(), ЭкcПонeнтa(), CтeпeннaяФункция()
Перем ДocтaтoчнaяToчнocть;
// Кoличecтвo Значaщиx знaкoв Поcлe зaпятoй для peзультaтoв,
// вoзвpaщaeмыx функциями
// КвaдpaтныйКopeнь(), ЭкcПонeнтa(), CтeпeннaяФункция()
Перем КoличecтвoЗнaкoв;
// Максимaльнoe кoличecтвo итepaций, кoтopoe выПолняeтcя в функцияx
// КвaдpaтныйКopeнь(), ЭкcПонeнтa(), CтeпeннaяФункция()
Перем КoличecтвoИтepaций;
// Чиcлo "пи"
Перем ЧиcлoПИ;
Функция КвaдpaтныйКopeнь(Apгумeнт) Далее
Функция ЭкcПонeнтa(Apгумeнт) Далее
Функция CтeпeннaяФункция(Apгумeнт1,Apгумeнт2) Далее
Функция Cинуc(Знач Apгумeнт, TипApгумeнтa = 0) Далее
Функция Кocинуc(Знач Apгумeнт, TипApгумeнтa = 0) Далее
Функция Taнгeнc(Знач Apгумeнт, TипApгумeнтa = 0) Далее

//******************************************************************
// КвaдpaтныйКopeнь(Apгумeнт)
//
// Пapaмeтpы:
// Apгумeнт - нeoтpицaтeльнoe чиcлo
//
// Boзвpaщaeмoe Значeниe:
// Квaдpaтный кopeнь Apгумeнтa
//
// Oпиcaниe
// ПpeднaЗначeнa для иcчиcлeния квaдpaтнoгo кopня чиcлa c
// пpимeнeниeм итepaциoннoгo мeтoдa Hьютoнa
// Итepaции выПолняютcя дo дocтижeния тoчнocти, зaдaннoй
// внeшнeй (публичнoй) Перемeннoй ДocтaтoчнaяToчнocть
//
Функция КвaдpaтныйКopeнь(Apгумeнт)
// Oгpaничимcя oблacтью oпpeдeлeния функции
Если Apгумeнт<0 Тогда
// cooбщeниe oб oшибкe
Сообщить("...","!");
Возврат ПолучитьПустоеЗначение();
// Oтceчeм нoль
ИначеЕсли Apгумeнт=0 Тогда
Возврат 0;
КонецЕсли;
// Bыбepeм пepвoe пpиближeниe
ПpeдыдущaяИтepaция = Apгумeнт/2;
Для Cч=1 По КoличecтвoИтepaций Цикл
Значeниe = 0.5*(ПpeдыдущaяИтepaция+
Apгумeнт/ПpeдыдущaяИтepaция);
Если Значeниe<ПpeдыдущaяИтepaция Тогда
Paзницa = ПpeдыдущaяИтepaция-Значeниe;
Иначе
Paзницa = Значeниe-ПpeдыдущaяИтepaция;
КонецЕсли;
Если Paзницa<ДocтaтoчнaяToчнocть Тогда
Прервать;
КонецЕсли;
ПpeдыдущaяИтepaция=Значeниe;
КонецЦикла;
Значeниe = Окр(Значeниe,Макс(КoличecтвoЗнaкoв-Лог10(Значeниe),0));
Возврат Значeниe;
КонецФункции // кoнeц функции КвaдpaтныйКopeнь
//******************************************************************
// ЭкcПонeнтa(Apгумeнт)
//
// Пapaмeтpы:
// Apгумeнт - чиcлo
//
// Boзвpaщaeмoe Значeниe:
// Чилo e в cтeпeни Apгумeнт
//
// Oпиcaниe
// ПpeднaЗначeнa для иcчиcлeния экcПонeнты c пpимeнeниeм
// pядa Maклopeнa (чacтный cлучaй pядa Tэйлopa)
// Итepaции выПолняютcя дo дocтижeния тoчнocти, зaдaннoй
// внeшнeй (публичнoй) Перемeннoй ДocтaтoчнaяToчнocть
//
//
Функция ЭкcПонeнтa(Apгумeнт)
Значeниe = 1;
ПpeдыдущийЧлeн = 1;
Для Cч=1 По КoличecтвoИтepaций Цикл
OчepeднoйЧлeн = ПpeдыдущийЧлeн*Apгумeнт/Cч;
Значeниe = Значeниe+OчepeднoйЧлeн;
Toчнocть = OчepeднoйЧлeн/Значeниe;
Если (Toчнocть<ДocтaтoчнaяToчнocть) И (OчepeднoйЧлeн<0.1) Тогда
Прервать;
КонецЕсли;
ПpeдыдущийЧлeн=OчepeднoйЧлeн;
КонецЦикла;
Значeниe = Окр(Значeниe,Макс(КoличecтвoЗнaкoв-Лог10(Значeниe),0));
Возврат Значeниe;
КонецФункции // кoнeц функции ЭкcПонeнтa
//******************************************************************
// CтeпeннaяФункция(Apгумeнт1, Apгумeнт2)
//
// Пapaмeтpы:
// Apгумeнт1 - чиcлo, кoтopoe вoзвoдитcя в cтeпeнь Apгумeнт2
// Apгумeнт2 - чиcлo
//
// Boзвpaщaeмoe Значeниe:
// Чиcлo Apгумeнт1 в cтeпeни Apгумeнт2
// Oпиcaниe
// ПpeднaЗначeнa для иcчиcлeния cтeпeннoй функции c пpимeнeниeм
// pядa Maклopeнa (чacтный cлучaй pядa Tэйлopa)
// Итepaции выПолняютcя дo дocтижeния тoчнocти, зaдaннoй
// внeшнeй (публичнoй) Перемeннoй ДocтaтoчнaяToчнocть
//
//
Функция CтeпeннaяФункция(Apгумeнт1,Apгумeнт2)
// Пpoвepим бaзу cтeпeннoй функции
Если Apгумeнт1<0 Тогда
// cooбщeниe oб oшибкe
Сообщить("...","!");
// Oтceчeм нoль
ИначеЕсли Apгумeнт1=0 Тогда
Возврат 0;
КонецЕсли;
Значeниe = 1;
ПpeдыдущийЧлeн = 1;
Для Cч=1 По КoличecтвoИтepaций Цикл
OчepeднoйЧлeн = ПpeдыдущийЧлeн*Apгумeнт2*Лог(Apгумeнт1)/Cч;
Значeниe = Значeниe+OчepeднoйЧлeн;
Toчнocть = OчepeднoйЧлeн/Значeниe;
Если Toчнocть<0 Тогда
Toчнocть = -Toчнocть;
КонецЕсли;
Если (Toчнocть<ДocтaтoчнaяToчнocть) И (OчepeднoйЧлeн<0.1) Тогда
Прервать;
КонецЕсли;
ПpeдыдущийЧлeн=OчepeднoйЧлeн;
КонецЦикла;
Значeниe = Окр(Значeниe,Макс(КoличecтвoЗнaкoв-Лог10(Значeниe),0));
Возврат Значeниe;
КонецФункции // кoнeц функции CтeпeннaяФункция
//******************************************************************
// CлужTaнгeнc(Apгумeнт)
//
// Пapaмeтpы:
// Apгумeнт - чиcлo, Значeниe углa в paдиaнax
//
// Boзвpaщaeмoe Значeниe:
// Taнгeнc зaдaннoгo углa
//
// Oпиcaниe
// ПpeднaЗначeнa для иcчиcлeния тaнгeнca зaдaннoгo в paдиaнax углa
// в oблacти Значeний oт 0 дo ПИ/8
// ИcПользуeтcя функциями Cинуc(), Кocинуc() и Taнгeнc()
// Иcчиcлeниe пpoизвoдитcя c иcПользoвaниeм цeпнoй дpoби
//
//
Функция CлужTaнгeнc(Apгумeнт)
КвApгум = Apгумeнт*Apгумeнт;
Значeниe = Apгумeнт/(1-КвApгум/(3-КвApгум/(5-КвApгум/(7-КвApгум/(9-КвApгум/(11-КвApгум/(13-КвApгум/(15-КвApгум))))))));
Возврат Значeниe;
КонецФункции // кoнeц функции CлужTaнгeнc
//******************************************************************
// Cинуc(Apгумeнт, TипApгумeнтa = 0)
//
// Пapaмeтpы:
// Apгумeнт - чиcлo, Значeниe углa
// TипApгумeнтa - чиcлo, тип пapaмeтpa Apгумeнт
// 0 - Значeниe углa Apгумeнт зaдaнo в paдиaнax
// 1 - Значeниe углa Apгумeнт зaдaнo в гpaдуcax
// Значeниe По умoлчaнию - 0
//
// Boзвpaщaeмoe Значeниe:
// Cинуc зaдaннoгo углa
//
// Oпиcaниe
// ПpeднaЗначeнa для иcчиcлeния cинуca углa, зaдaннoгo в
// paдиaнax или гpaдуcax
// Oблacть oпpeдeлeния функции нe oгpaничeнa
//
//
Функция Cинуc(Знач Apгумeнт, TипApгумeнтa = 0)
Если TипApгумeнтa=1 Тогда
Apгумeнт = (Apгумeнт/180)*ЧиcлoПИ;
КонецЕсли;
ЗнaкPeзультaтa=1;
// Пpивeдeм к oблacти 0 - 2ПИ
Если Apгумeнт<0 Тогда
Apгумeнт=-Apгумeнт;
ЗнaкPeзультaтa=-1*ЗнaкPeзультaтa;
КонецЕсли;
Apгумeнт = Apгумeнт-Цел(Apгумeнт/(2*ЧиcлoПИ))*2*ЧиcлoПИ;
// тeпepь пpивeдeм к oблacти 0 - ПИ
Если Apгумeнт>ЧиcлoПИ Тогда
Apгумeнт = Apгумeнт-ЧиcлoПИ;
ЗнaкPeзультaтa=-1*ЗнaкPeзультaтa;
КонецЕсли;
// тeпepь пpивeдeм к oблacти 0 - ПИ/2
Если Apгумeнт>ЧиcлoПИ/2 Тогда
Apгумeнт=ЧиcлoПИ-Apгумeнт;
КонецЕсли;
// тeпepь пpивeдeм к oблacти 0 - ПИ/4
Если Apгумeнт>ЧиcлoПИ/4 Тогда
Значeниe = ЗнaкPeзультaтa*Кocинуc(ЧиcлoПИ/2-Apгумeнт);
Иначе
TaнгeнcПолoвины = CлужTaнгeнc(Apгумeнт/2);
Значeниe = ЗнaкPeзультaтa*2*TaнгeнcПолoвины/
(1+TaнгeнcПолoвины*TaнгeнcПолoвины);
КонецЕсли;
Возврат Значeниe;
КонецФункции // кoнeц функции Cинуc
//*****************************************************************
// Кocинуc(Apгумeнт, TипApгумeнтa = 0)
//
// Пapaмeтpы:
// Apгумeнт - чиcлo, Значeниe углa
// TипApгумeнтa - чиcлo, тип пapaмeтpa Apгумeнт
// 0 - Значeниe углa Apгумeнт зaдaнo в paдиaнax
// 1 - Значeниe углa Apгумeнт зaдaнo в гpaдуcax
// Значeниe По умoлчaнию - 0
//
// Boзвpaщaeмoe Значeниe:
// Кocинуc зaдaннoгo углa
//
// Oпиcaниe
// ПpeднaЗначeнa для иcчиcлeния кocинуca углa, зaдaннoгo в
// paдиaнax или гpaдуcax
// Oблacть oпpeдeлeния функции нe oгpaничeнa
//
//
Функция Кocинуc(Знач Apгумeнт, TипApгумeнтa = 0)
Если TипApгумeнтa=1 Тогда
Apгумeнт = (Apгумeнт/180)*ЧиcлoПИ;
КонецЕсли;
// Пpивeдeм к oблacти 0 - 2ПИ
Если Apгумeнт<0 Тогда
Apгумeнт=-Apгумeнт;
КонецЕсли;
Apгумeнт = Apгумeнт-Цел(Apгумeнт/(2*ЧиcлoПИ))*2*ЧиcлoПИ;
// Если Попaли в oблacть 0 - ПИ/4 - cчитaeм чecтнo
Если Apгумeнт<ЧиcлoПИ/4 Тогда
TaнгeнcПолoвины = CлужTaнгeнc(Apгумeнт/2);
Значeниe = (1-TaнгeнcПолoвины*TaнгeнcПолoвины)/
(1+TaнгeнcПолoвины*TaнгeнcПолoвины);
Иначе
Значeниe = Cинуc(Apгумeнт+ЧиcлoПИ/2);
КонецЕсли;
Возврат Значeниe;
КонецФункции // кoнeц функции Кocинуc
//******************************************************************
// Taнгeнc(Apгумeнт, TипApгумeнтa = 0)
//
// Пapaмeтpы:
// Apгумeнт - чиcлo, Значeниe углa
// TипApгумeнтa - чиcлo, тип пapaмeтpa Apгумeнт
// 0 - Значeниe углa Apгумeнт зaдaнo в paдиaнax
// 1 - Значeниe углa Apгумeнт зaдaнo в гpaдуcax
// Значeниe По умoлчaнию - 0
//
// Boзвpaщaeмoe Значeниe:
// Taнгeнc зaдaннoгo углa
//
// Oпиcaниe
// ПpeднaЗначeнa для иcчиcлeния тaнгeнca углa, зaдaннoгo в
// paдиaнax или гpaдуcax
// B тoм cлучae, Если для Значeния Apгумeнт функция нe
// oпpeдeлeнa (нaпpимep, пи/2 paдиaн)
// вoзвpaщaeтcя пуcтoe Значeниe c cooбщeниeм oб oшибкe
//
//
Функция Taнгeнc(Знач Apгумeнт, TипApгумeнтa = 0)
Если TипApгумeнтa=1 Тогда
Apгумeнт = (Apгумeнт/180)*ЧиcлoПИ;
КонецЕсли;
ЗнaкPeзультaтa=1;
// Пpивeдeм к oблacти 0 - ПИ
Если Apгумeнт<0 Тогда
Apгумeнт=-Apгумeнт;
ЗнaкPeзультaтa=-1*ЗнaкPeзультaтa;
КонецЕсли;
Apгумeнт = Apгумeнт-Цел(Apгумeнт/(ЧиcлoПИ))*ЧиcлoПИ;
// Пpивeдeм к oблacти 0 - ПИ/2
Если Apгумeнт>ЧиcлoПИ/2 Тогда
Apгумeнт=ЧиcлoПИ-Apгумeнт;
ЗнaкPeзультaтa=-1*ЗнaкPeзультaтa;
КонецЕсли;
// Если Попaли в oблacть ПИ/8
Если Apгумeнт<ЧиcлoПИ/8 Тогда
Значeниe = ЗнaкPeзультaтa*CлужTaнгeнc(Apгумeнт);
Иначе
// oбoйдeм дeлeниe нa нoль
Попытка
Значeниe = ЗнaкPeзультaтa*Cинуc(Apгумeнт)/
Кocинуc(Apгумeнт);
Исключение
// cooбщeниe oб oшибкe
Сообщить("...","!");
Значeниe = ПолучитьПустоеЗначение();
КонецПопытки
КонецЕсли;
Возврат Значeниe;
КонецФункции // кoнeц функции Taнгeнc
// Toчнocть c кoтopoй вычиcляютcя Значeния функций
// КвaдpaтныйКopeнь(), ЭкcПонeнтa(), CтeпeннaяФункция()
ДocтaтoчнaяToчнocть = 0.00000000001;
КoличecтвoИтepaций = 1000;
// Кoличecтвo Значaщиx знaкoв Поcлe зaпятoй для peзультaтoв пpи
// зaдaннoй тoчнocти
КoличecтвoЗнaкoв = -Лог10(ДocтaтoчнaяToчнocть)-1;
// Чиcлo "пи"
ЧиcлoПИ = 3.1415926535897932384626433832795;


Как скопировать строку в буфер обмена Windows? | База знаний | mista.ru

Как скопировать строку в буфер обмена Windows?

AlexanderAA 28.10.2004 09:50 | 1С Предприятие 8.0.8.7 Как средствами встроенного языка скопировать строку или текст в буфер обмена?
Jabbers 1 - 28.10.2004 09:51 | WSH ... неа? Средствами языка еще незнаю :0/
Rovan 5 - 28.10.2004 10:06 | http://www.dinform.ru/kuban/htmls/public_htmls/9-50903.html
krz2004 6 - 28.10.2004 10:39 | http://itland.ru/rep/ имееться обработка по реализации буфера обмена в 8ерке
Все ОК 7 - 28.10.2004 10:40 | Вставить из буфера можно http://itland.ru/forum/index.php?showtopic=4821 Наверное можно и скопировать спроси там может скажут
AlexanderAA 9 - 28.10.2004 12:54 | (7) - а это наиболее подходящий вариант. только вот с таким куском кода: МойТекст = "Это мой текст!"; Окно.ClipboardData.SetData("Text", МойТекст);


Переход от объекта "Отбор" к объекту "Структура" | База знаний | mista.ru

Переход от объекта "Отбор" к объекту "Структура"

Волшебник
23.10.2004 19:14 		Thrash

форма.
динамический список (ргСведений, спр - неважно).
панель инструментов.
юзер делает какой-либо отбор (абсолютно произвольный, стандартными средствами).
жмет на пимпу - и мне надо получить то, что у него в данный момент в списке.
логичное , казалось бы:

CODE
тзЧтототам = РегистрыСведений.Чтототам.СрезПоследних(ТекущаяДата(), ЭлементыФормы.РегистрСведенийСписок.Значение.Отбор);

по понятным причинам не прокатывает (ну дурь, отбор - это отбор, а не структура, если 2 вида - надо дать возможность использовать оба варианта) - ибо ЭлементыФормы.РегистрСведенийСписок.Значение.Отбор это объект "Отбор", а в команде в параметре должна быть Структура.
то есть это отпадает и нужен запрос с условием.

собственно вопрос - есть ли какой-либо изящный способ это сделать, кроме как потрошить отбор, вытаскивая оттуда типы, пути к данным, виды сравнения, данные для сравнения громоздя условие в запрос?

---------------------------------
отвечаю сам себе, делюсь своим решением - вдруг кому-то пригодиться.

во вложении функция, ей передается динамический список
CODE
глЗапросПоОтборуДС(ЭлементыФормы.РегистрСведенийСписок)

возвращает она ТЗ состояния регистра "как в списке" .
в качестве источника для условий используется отбор, для регистров сведений выполняется проверка устанвки значения среза - первых, последних, не использовать.

в качестве домашнего задания - там еще надо упорядочить, как в списке, и обработать галочку Иерархического просмотра в списках ПВХ, спр., планов счетов - сделаете самостоятельно

если обнаружите ошибки - пишите.

-------------------------------------------
Функция глЗапросПоОтборуДС(СписокД) Экспорт
ВидД = СтрЗаменить(Строка(СписокД.Значение), "Список", "");

Если Лев(ВидД, 15) = "РегистрСведений" Тогда
Если СписокД.ВыбиратьСрез = ИспользованиеСреза.Первые Тогда
ВидД = ВидД + ".СрезПервых";
ИначеЕсли СписокД.ВыбиратьСрез = ИспользованиеСреза.Последние Тогда
ВидД = ВидД + ".СрезПоследних";
КонецЕсли;
КонецЕсли;

ЗапросД = Новый Запрос;
ТекстЗапроса = "Выбрать
| *
|Из
| " + ВидД;
_где = "
|ГДЕ
| ";
_и = "
| И
| ";

Попытка //бывает, что Отбор недоступен (например при первом вызове и
ОтборД = СписокД.Значение.Отбор; //из проц. ПередОткрытием()
Исключение
ОтборД = Неопределено;
КонецПопытки;

БылоГде = Ложь;
Если ОтборД <> Неопределено Тогда
Для ИндексОтбора = 0 По ОтборД.Количество() - 1 Цикл
Если ОтборД[ИндексОтбора].Использование Тогда
Если не БылоГде Тогда
ТекстЗапроса = ТекстЗапроса + _где;
БылоГде = Истина;
Иначе
ТекстЗапроса = ТекстЗапроса + _и;
КонецЕсли;
Вариант = 0;
Если ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.Больше Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " > ";
Вариант = 1;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.БольшеИлиРавно Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " >= ";
Вариант = 1;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.ВИерархии Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " В иерархии ";
Вариант = 4;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.ВСписке Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " В ";
Вариант = 4;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.ВСпискеПоИерархии Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " В иерархии ";
Вариант = 4;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.Интервал Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " > &" + ОтборД[ИндексОтбора].ПутьКДанным + "1" + _и;
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " < &" + ОтборД[ИндексОтбора].ПутьКДанным + "2";
Вариант = 2;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.ИнтервалВключаяГраницы Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " >= &" + ОтборД[ИндексОтбора].ПутьКДанным + "1" + _и;
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " <= &" + ОтборД[ИндексОтбора].ПутьКДанным + "2";
Вариант = 2;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.ИнтервалВключаяНачало Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " >= &" + ОтборД[ИндексОтбора].ПутьКДанным + "1" + _и;
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " < &" + ОтборД[ИндексОтбора].ПутьКДанным + "2";
Вариант = 2;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.ИнтервалВключаяОкончание Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " > &" + ОтборД[ИндексОтбора].ПутьКДанным + "1" + _и;
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " <= &" + ОтборД[ИндексОтбора].ПутьКДанным + "2";
Вариант = 2;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.Меньше Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " < ";
Вариант = 1;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.МеньшеИлиРавно Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " <= ";
Вариант = 1;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.НеВИерархии Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " Не В иерархии ";
Вариант = 4;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.НеВСписке Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " Не В ";
Вариант = 4;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.НеВСпискеПоИерархии Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " Не В иерархии ";
Вариант = 4;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.НеРавно Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " <> ";
Вариант = 1;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.Равно Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " = ";
Вариант = 1;
ИначеЕсли ОтборД[ИндексОтбора].ВидСравнения = ВидСравнения.Содержит Тогда
ТекстЗапроса = ТекстЗапроса + ОтборД[ИндексОтбора].ПутьКДанным + " Подобно ";
Вариант = 3;
Иначе
Сообщить("ошибка!");
КонецЕсли;

Если Вариант = 1 Тогда
ТекстЗапроса = ТекстЗапроса + "&" + ОтборД[ИндексОтбора].ПутьКДанным;
ЗапросД.УстановитьПараметр("" + ОтборД[ИндексОтбора].ПутьКДанным, ОтборД[ИндексОтбора].Значение);
ИначеЕсли Вариант = 2 Тогда
ЗапросД.УстановитьПараметр("" + ОтборД[ИндексОтбора].ПутьКДанным + "1", ОтборД[ИндексОтбора].ЗначениеС);
ЗапросД.УстановитьПараметр("" + ОтборД[ИндексОтбора].ПутьКДанным + "2", ОтборД[ИндексОтбора].ЗначениеПо);
ИначеЕсли Вариант = 3 Тогда
ТекстЗапроса = ТекстЗапроса + "&" + ОтборД[ИндексОтбора].ПутьКДанным;
ЗапросД.УстановитьПараметр("" + ОтборД[ИндексОтбора].ПутьКДанным, "%" + ОтборД[ИндексОтбора].Значение + "%");
ИначеЕсли Вариант = 4 Тогда
ТекстЗапроса = ТекстЗапроса + "(&" + ОтборД[ИндексОтбора].ПутьКДанным + ")";
ЗапросД.УстановитьПараметр("" + ОтборД[ИндексОтбора].ПутьКДанным, ОтборД[ИндексОтбора].Значение);
КонецЕсли;

КонецЕсли;
КонецЦикла;
КонецЕсли;

Сообщить("" + ТекстЗапроса);
ЗапросД.Текст = ТекстЗапроса;

тзТ = ЗапросД.Выполнить().Выгрузить();
Возврат тзТ;
КонецФункции // ()
-------------------------

Источник:
http://itland.ru/forum/index.php?showtopic=4977


v8: аналог СтатусВозврата(0) из 7.7 в 8.0 | База знаний | mista.ru

v8: аналог СтатусВозврата(0) из 7.7 в 8.0

Gavrila
22.10.2004 16:29 		Необходимо при вводе на основании документа по определенному условию отменить операцию. В семерке все просто СтатусВозврата(0), а как это сделать в восьмерке?
----
заранее благодарен.
OctoberHammer
1 - 22.10.2004 16:31 		Не помню точно, но вроде СтандартнаяОбработка=Ложь..
1Спец
2 - 22.10.2004 16:32 		Отказ = Истина
Gavrila
7 - 22.10.2004 16:37 		(1), (2) ни отказ ни СтандартнаяОбработка не получилось

(3)Предопределенная процедура ОбработкаЗаполнения(<Основание>) в модуле документа, вызывается при вводе на основании другого документа и "отказ"а здесь нет к сожалению :(
alxkorvin
10 - 22.10.2004 16:45 		(0) ОбработкаЗаполнения вызывается уже для созданного документа и прервать создание нельзя. Соответственно проверки нужно делать при создании документа, а не при обработке заполнения.
Harley
11 - 22.10.2004 16:46 		В общем модуле обьявляется глобальная переменная "НаОсновани"
если на основании ввести нельзя присвоить ей значение ложь

данная переменная будет доступна в процедуре формы "ПриОткрытии"
на основании ее значения можно сделать отказ
Gavrila
12 - 22.10.2004 16:47 		окей я все понял, нет так нет...
Есть документ "Заказ покупателя";
Есть документ "Производство";
Необходимо при вводе документа "Производство" на основании документа "Заказ покупателя" проверять установленный вид операции установленный в заказе (тип - перечисление), если не тот что нужон нужно "обматерить" юзера и отменить ввод на основании.
------------
зы: Пришлось проверку добавить в процедуру "ПередОткрытием" модуля формы документа "Производство".
Всем спасибо.
Harley
13 - 22.10.2004 16:49 		ОбработкаЗаполнения вызывается еще до процедуры ПередОткрытием
поэтом прервать открытие можно
Евгений
14 - 22.10.2004 16:51 		(8) - просто не показывай созданный документ юзверю. Тогда он не сможет его сохранить.
Вриант №2 не пользоваться стандартой процедурой "ОбработкаЗаполения", а написать свою.
Harley
16 - 22.10.2004 17:00 		// Модуль объекта
Перем НеОткрыватьФорму Экспорт;

Если Выборка.Количество = NULL Тогда
НеОткрыватьФорму = Истина;
Иначе
НеОткрыватьФорму = Ложь;
КонецЕсли;
// Модуль объекта

//Модуль формы документа
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
Если ЭтотОбъект.НеОткрыватьФорму <> Неопределено И ЭтотОбъект.НеОткрыватьФорму = Истина Тогда
Отказ = Истина;
КонецЕсли;
//Модуль формы документа


Выборка и значения реквизитов табличной части | База знаний | mista.ru

Выборка и значения реквизитов табличной части

ValA
07.10.2004 13:58 		Народ, как в выборке документов добраться до значения реквизитов табличной части? Чего-то я запутался, через что это делать надо.
Волшебник
1 - 07.10.2004 14:00 		ВыборкаДокументов = Документы.ИмяДок.Выбрать();
Пока ВыборкаДокументов.Следующий() Цикл
тч = ВыборкаДокументов.ИмяТЧ;
Для каждого СтрокаТЧ Из тч Цикл
Сообщить(СтрокаТЧ.ИмяРекв);
КонецЦикла;
КонецЦикла;
ValA
3 - 07.10.2004 14:07 		А пример если табличных частей несколько?
Волшебник
4 - 07.10.2004 14:09 		ВыборкаДокументов = Документы.ИмяДок.Выбрать();
Пока ВыборкаДокументов.Следующий() Цикл
тч = ВыборкаДокументов.ИмяТЧ;
Для каждого СтрокаТЧ Из тч Цикл
Сообщить(СтрокаТЧ.ИмяРекв);
КонецЦикла;

тч2 = ВыборкаДокументов.ИмяТЧ2;
Для каждого СтрокаТЧ2 Из тч2 Цикл
Сообщить(СтрокаТЧ2.ИмяРекв);
КонецЦикла;

КонецЦикла;
ValA
5 - 07.10.2004 14:11 		А чтобы в цикле перебрать тч, если их кол-во заранее неизвестно
Волшебник
6 - 07.10.2004 14:16 		(5)

ВыборкаДокументов = Документы.ИмяДок.Выбрать();
Пока ВыборкаДокументов.Следующий() Цикл

Для Каждого МдТч ИЗ ВыборкаДокументов.Ссылка.Метаданные().ТабличныеЧасти Цикл
Для каждого ТЧ Из ВыборкаДокументов[МдТч.Имя] Цикл

Для Каждого СтрокаТЧ ИЗ ТЧ Цикл

Для Каждого МдРекв ИЗ МдТч.Реквизиты Цикл

Сообщить(СтрокаТЧ[МдРекв.Имя]);

циклы закрыть по вкусу

p.s. фрагмент не проверял


Помогите с 1С версии 6.0. | База знаний | mista.ru

Помогите с 1С версии 6.0.

Forgotten god 13.05.2004 08:53 | Перенес базу на новый комп, раньше 80486 стоял и Win 3/11 теперь P-2-350 и Win 98 но 1С ver/ 6.0. не хочет понимать что дата стоит 2004 год а не 1904. Где это можно поправить?
427 1 - 13.05.2004 09:02 | Если это последние релизы движка, понимающие 2000 год, надо установить год начала рабочего столетия (как то так называется)..... Поищи в каталоге файлик Реадме - там д.б. описано ....
Forgotten god 2 - 13.05.2004 10:28 | А если не последний, и какой был последний? Платежки там старые!!!
OffRoader 3 - 14.05.2004 16:30 | В файле 1SBW.CNF в секции Values вставить: [Values] YearOfCentury=60 На 40 лет хватит :)
Дык 4 - 14.05.2004 22:25 | Если ничего не путаю, то были релизы 1C60 под WIN 311 и WIN95. Последний под WIN95 "локальный" релиз я видел 36, а сетевой 24. Эти релизы понимают 2000 год.
BorisG 5 - 14.05.2004 23:15 | (4) Не путаешь. Только вот программы, не поддерживающие 2000 год были до апрела 1998 года ;-) "... программы семейства "1С:Бухгалтерия" 6.0 для Windows 3.xx и Windows 95 (выпущенные с апреля 1998г.), ... стандартно обрабатывают информацию на стыке 1999 и 2000 годов..." http://www.1c.ru/news/info.asp?id=357


Отображения интервала между датами в виде "1 год 4 месяца 25 дней" | База знаний | mista.ru

Отображения интервала между датами в виде "1 год 4 месяца 25 дней"

Olegandr
04.08.2004 15:16 		Как получить строку "расстояния" между двумя датами (01.01.2000 и 25.04.2001) в виде, например, "1-лет 4-месяц 25-день"
alxkorvin
3 - 04.08.2004 19:20 		Взято из ЗиК

//******************************************************************************
// глРазобратьРазностьДат(Дата1,Дата2,Лет,Месяцев,Дней)
//
// Параметры:
// Дата1 - первая дата (более поздняя, часто текущая, стаж определяется по состоянию на эту дату)
// Дата2 - вторая дата (ранняя дата, с нее начинается "течение" стажа)
// Лет - в этот параметр будет записано кол-во лет между двумя датами (Дата1-Дата2)
// Месяцев - в этот параметр будет записано кол-во месяцев между двумя датами (Дата1-Дата2)
// Дней - в этот параметр будет записано кол-во дней между двумя датами (Дата1-Дата2)
//
// Описание:
// Процедура разбирает две даты и возвращает в параметрах кол-во лет, месяцев и дней
// между двумя датами (Дата1-Дата2)
//
Процедура глРазобратьРазностьДат(Знач Дата1,Знач Дата2,Лет=0,Месяцев=0,Дней=0) Экспорт

Лет = 0; Месяцев = 0; Дней = 0;
Если Дата1>Дата2 Тогда

ВременнаяДата = Дата1;
Если ДатаЧисло(ВременнаяДата)<ДатаЧисло(Дата2) Тогда
Дней = ВременнаяДата-ДобавитьМесяц(ВременнаяДата,-1);
ВременнаяДата = ДобавитьМесяц(ВременнаяДата,-1);
КонецЕсли;
Если ДатаМесяц(ВременнаяДата)<ДатаМесяц(Дата2) Тогда
ВременнаяДата = ДобавитьМесяц(ВременнаяДата,-12);
Месяцев = 12;
КонецЕсли;
Лет = Макс( ДатаГод (ВременнаяДата)-ДатаГод (Дата2),0);
Месяцев = Макс(Месяцев +ДатаМесяц(ВременнаяДата)-ДатаМесяц(Дата2),0);
Дней = Макс(Дней +ДатаЧисло(ВременнаяДата)-ДатаЧисло(Дата2),0);

// скорректируем отображаемое значение, если "вмешалось" разное количество дней в месяцах
Если Дата2 <> (ДобавитьМесяц(Дата1,-Лет*12-Месяцев)-Дней) Тогда
Дней = Дней + (КонМесяца(Дата2)-НачМесяца(Дата2)) - (КонМесяца(ДобавитьМесяц(Дата1,-1))-НачМесяца(ДобавитьМесяц(Дата1,-1)));
КонецЕсли;
КонецЕсли;

КонецПроцедуры // глРазобратьРазностьДат


Получить ВремяДок на форме. | База знаний | mista.ru

Получить ВремяДок на форме.

ТорМОЗИЛЛА 23.07.2004 09:42 | Как получить на форме ДОКУМЕНТА его время, когда он был проведен?
NS 1 - 23.07.2004 09:46 | На форме? Может в модуле формы? ПолучитьВремя(<?>,,) Синтаксис: ПолучитьВремя(<Часы>,<Минуты>,<Секунды>) Назначение: Прочитать время документа. Возвращает время документа в переданные для этого переменные <Часы>, <Минуты>, <Секунды>. Возвращает: Строковое значение времени записи документа в виде 'ЧЧ.ММ.СС'. Параметры: <Часы> - переменная для приема часа записи документа; <Минуты> - переменная для приема минут записи документа; <Секунды> - переменная для приема секунд записи документа. Замечание: Метод можно использовать только для объектов, созданных функцией СоздатьОбъект.
NS 14 - 23.07.2004 10:05 | Кидаешь "Текст" на форму, убираешь заголовок, На второй закладке ("Дополнительно") в поле формула - пишешь: ?(Выбран()=1,ПолучитьВремя(),ТекущееВремя());
ТорМОЗИЛЛА 16 - 23.07.2004 10:11 | NS - ссенкс, это мне дало получение на форме времени СОЗДАНИЯ (сори, я может не правильный термин употребил) документа. А как быть с временем последнего ПЕРЕПРОВЕДЕНИЯ дока?
NS 18 - 23.07.2004 10:16 | (16) Добавляешь реквизит ШАпки документа (или общий реквизит если нужно для всех документов) (строка - длина - 8) В процедуре вводнового() ВремяПослПроведения=""; ...... В модуле документа - Процедура ОбработкаПроведения() ......... Если СтатусВозврата()=1 Тогда ВремяПослПроведения=ТекущееВремя(); КонецЕсли; Конецпроцедуры


Установить время документу | База знаний | mista.ru

Установить время документу

Кирил
17.06.2004 14:10 		Можно ли при записи нового документа установить "своё" время?
It is me
2 - 17.06.2004 14:17 		АвтоВремяОтключить();
Синтаксис:
АвтоВремяОтключить()
Назначение:
Отключить режим автоматической установки времени для новых документов, при этом новые документы заносятся с временем, устанавливаемым при помощи метода УстановитьВремя.
Замечание:
Для новых документов в модуле формы доступно использование методов установки признака автоформирования времени документа и собственно установки времени. Если эти методы использованы, то диалог запроса времени не вызывается и игнорируются пользовательские установки в параметрах системы.
Кирил
3 - 17.06.2004 14:55 		УстановитьВремя(,,) Метод можно использовать только для объектов, созданных функцией СоздатьОбъект.
lexa
9 - 17.06.2004 15:32 		УстановитьВремя(<Часы>, <Минуты>, <Секунды>)
Кирил
10 - 17.06.2004 15:36 		Повторю. УстановитьВремя(,,) Метод можно использовать только для объектов, созданных функцией СоздатьОбъект. Мне нужно записать время в модуле формы!!!
Это, наверное, невозможно :(.
It is me
12 - 17.06.2004 15:58 		АвтоВремяОтключить();
Если выбран()=0 Тогда
УстановитьВремя(18,1,1);
КонецЕсли;

Проверял только что, все прекрасно работает
It is me
15 - 17.06.2004 18:19 		Ты условие Если Выбран()=0 Тогда видишь или нет? Работать будет только для новых документов, при перезаписи старых ошибка будет
//
Процедура ПриЗаписи()
АвтоВремяОтключить();
Если выбран()=0 Тогда
УстановитьВремя(18,1,1);
КонецЕсли;
КонецПроцедуры


Точка актуальности (вопрос) | База знаний | mista.ru

Точка актуальности (вопрос)

Danila 09.06.2004 09:14 | Подскажите как получить дату точки актуальности, а то у меня отчет не работает если с утра бухгалтеры документы не проводили... :-)
тип топ 1 - 09.06.2004 09:18 | получитьдатуТА()


Как убрать время документа??? | База знаний | mista.ru

Как убрать время документа???

andrey_z 07.06.2004 09:19 | Как убрать время проведения документа? Блин док нормально проводится, а другой док, все время выдает время проведения? Используются регистры остатков
SiMazx 1 - 07.06.2004 09:24 | АвтоВремяОтключить() и т.п.
AlexP 2 - 07.06.2004 09:25 | А не будешь ли ты потом иметь большой гемор с последовательностью документов, и как результат - с остатками товаров?
SiMazx 3 - 07.06.2004 09:46 | Будет. С большой долей вероятности. ;)
maloy 5 - 07.06.2004 09:59 | По умолчанию эта фича настраивается в параметрах: "Оперативный учет" - "Новые документы записывать..." и "Новые документы проводить...", но в модуле формы может вызываться: ПроводитьПослеТА(0,1);//И тогда всё зависит от этого


ПустоеЗначение() типа дата | База знаний | mista.ru

ПустоеЗначение() типа дата

Valery 03.06.2004 09:17 | Ситуация такая Проверяю пустую переменную типа Дата на пустое значение. возвращает 0. ДБ.endDate = ' . . ' ТипЗначенияСтр(ДБ.endDate) = "Дата" ПустоеЗначение(дата(ДБ.endDate)) = 0 Не пойму почему 0. В чем фокус.
SnarkHunter 1 - 03.06.2004 09:28 | ДБ.endDate = ПолучитьПустоеЗначение("Дата")
Bzzzzz 2 - 03.06.2004 09:28 | Я тоже. Следующий код сработал нормально: _Дата=' . . '; Сообщить(ТипЗначенияСтр(_Дата)); = "Дата" Сообщить(ТипЗначенияСтр(Дата(_Дата))); = "Дата" Сообщить(ПустоеЗначение(дата(_Дата))); = 1
Valery 3 - 03.06.2004 09:36 | Мне кажется, что глюк вызван тем, что ДБ.endDate - это значение из DBF. Может у кого еще есть мнения.
lexa 4 - 03.06.2004 10:26 | а почему функция Дата() должна возвращать пустое значение ?
lexa 7 - 03.06.2004 10:36 | ко всем, в (0) "Проверяю пустую переменную типа Дата на пустое значение. возвращает 0" и тут же проверяет не переменную а функциию от этой переменной
Bzzzzz 8 - 03.06.2004 10:37 | (7) Так он же преобразует значение к типу "Дата". Вл\друг там фигня какая-нибудь
Рупор абсурда 12 - 03.06.2004 10:43 | ДБ.Записать() не хватает, если, конечно, это ИксБэйс
Valery 13 - 03.06.2004 10:43 | ПустоеЗначение(дата(ДБ.endDate)) = 0 На функцию дата не обращайте внимания, это я в отладчике тыкал. должно быть так ПустоеЗначение(ДБ.endDate) = 0
Valery 15 - 03.06.2004 10:52 | (12) это xbase. просто проверяю значение поля типа дата. Дбф из проги на foxe. Уже сколько раз делал все одно. Подозреваю что это с дбф связано
lexa 16 - 03.06.2004 10:55 | (15) если отладчик показывает что пустое значение в ДБ.endDate = ' . . ' , то используй это в качестве условия
Valery 17 - 03.06.2004 11:03 | (16)Обойти эту ситуацию можно. кстати почемуто ДБ.endDate <> ' . . ' помогает только Строка(ДБ.endDate) = " . . "
Bzzzzz 18 - 03.06.2004 11:11 | Или так: ПустоеЗначение(Дата(Строка(ДБФ.D)));


Как сложить время? Например 12:26 + 05:06 = 17:32 | База знаний | mista.ru

Как сложить время? Например 12:26 + 05:06 = 17:32

Lucky
26.05.2004 13:22 		Собственно а можно ли?
Когда складываю ТекущееВремя()+число то получаю=ВремяЧисло
Например 12:26 + 05:06 = 12,260506

Подскажите пожайлуста.
Arhitektor
2 - 26.05.2004 14:05 		Не очень красиво, но надеюсь понятно...

//*******************************************
Функция Выполнить()
Перем Час, Ми, Сек;

ТекущееВремя(Час,Ми,Сек); //возвращает три переменные типа строка
Час = число(Час);
Ми = число(Ми);
Сек = число(Сек);
Сек = Сек + 125;
Ми = Ми+123;
Час = Час + 122;

Если Сек/60 > 0 Тогда
Сек = Сек%60;
Ми = Ми + 1;
КонецЕсли;

Если Ми/60 > 0 Тогда
Ми = Ми%60;
Час = Час + 1;
КонецЕсли;

Если Час/24 > 0 Тогда
Час = Час%24;
КонецЕсли;

Стр = "";

Если Час < 10 Тогда
Стр = "0" + Строка(Час);
Иначе
Стр = Строка(Час);
КонецЕсли;

Стр = Стр + ":";

Если Ми < 10 Тогда
Стр = Стр + "0" + Строка(Ми);
Иначе
Стр = Стр + Строка(Ми);
КонецЕсли;

Стр = Стр + ":";

Если Сек < 10 Тогда
Стр = Стр + "0" + Строка(Сек);
Иначе
Стр = Стр + Строка(Сек);
КонецЕсли;

Возврат Стр;
КонецФункции
Arhitektor
3 - 26.05.2004 14:07 		опс-с-с ошибочка
вместо
Сек = Сек%60;
Ми = Ми + 1;
надо писать
Сек = Сек%60;
Ми = Ми + цел(Сек/60);

аналогично для Ми и Час

сорри
Рупор абсурда
12 - 26.05.2004 15:03 		12:26 + 05:06 = 17:32

Функция Время(чч,мм,сс,Время=0)
Если Время=0 Тогда Возврат сс+мм*60+чч*3600 КонецЕсли;
чч=Цел(Время/3600);
мм=Цел((Время%3600)/60);
сс=(Время%3600)%60;
Возврат Время;
КонецФункции

А=Время(12,26,0);
Б=Время(5,6,0);
чч=0; мм=0;
Время(чч,мм,0,А+Б);
Сообщить(""+чч+":"+мм);
Рупор абсурда
15 - 26.05.2004 15:17 		Эх! Придерусь сам ...
(12) А последнюю строчечку лучше заменить на:
Сообщить(?(чч<10,"0","")+чч+?(мм<10,":0",":")+мм);


8.0 Дата&время. Пусть рассудит Волшебник | База знаний | mista.ru

8.0 Дата&время. Пусть рассудит Волшебник

Непонятливый 29.05.2004 20:05 | Итак, какие есть хытрые даты+время (ну, или -время)? Озадачился. Ведь есть: РабочаяДата - только дата ТекущаяДата() - дата и время ПолучитьОперативнуюОтметкуВремени() - таки да. Для проведения документов - самый гастроном, НО! В п.меню Сервис место есть. Где рабочая дата задается. Вид результатов вышеупомянутых функций до смены рабочей даты: 29.05.2004 0:00:00 29.05.2004 23:01:36 29.05.2004 23:01:36 и после: 30.05.2004 0:00:00 29.05.2004 23:01:51 29.05.2004 23:01:51 Не правда ли, возникает вопрос - куда податься бедному крестьянину, если он хочет манипулировать рабочей датой? А в особенности, как добывать момент текущий для контроля остатков, если меняется рабочая дата???
romix 3 - 29.05.2004 23:50 | Рабочая дата влияет только на дату вновь создаваемых документов. Чтобы изменить дату уже созданных документов, надо 1) создать объект с типом нужного документа 2) спозиционироваться на документ (ВыбратьПоНомеру, кажется) 3) Изменить дату и / или время 4) записать и провести Ну или вручную менять дату и время(из конт. меню).


Операции с датами | База знаний | mista.ru

Операции с датами

Kudryashka
28.05.2004 11:28 		Задача такая: есть ДатаНач и ДатаКон. нужно вычесть из ДатыКон ДатуНач и посчитать точное количество лет, месяцев, дней из подучившегося числа... нужно учесть високосные года, к-во дней в разных месяцах и т.д... короче нужно посчитать стаж с точностью до дня. помогите новичку... :(
kadr
1 - 28.05.2004 11:33 		// глРазобратьРазностьДат(Дата1,Дата2,Лет,Месяцев,Дней)
//
// Параметры:
// Дата1 - первая дата (более поздняя, часто текущая, стаж определяется по состоянию на эту дату)
// Дата2 - вторая дата (ранняя дата, с нее начинается "течение" стажа)
// Лет - в этот параметр будет записано кол-во лет между двумя датами (Дата1-Дата2)
// Месяцев - в этот параметр будет записано кол-во месяцев между двумя датами (Дата1-Дата2)
// Дней - в этот параметр будет записано кол-во дней между двумя датами (Дата1-Дата2)
//
// Описание:
// Процедура разбирает две даты и возвращает в параметрах кол-во лет, месяцев и дней
// между двумя датами (Дата1-Дата2)
//
// алгоритм Пенсионного фонда
//Мк = ДатаМесяц(Дата1);
//Гк = ДатаГод(Дата1);
//Если ДатаЧисло(Дата1) - ДатаЧисло(Дата2) < 0 Тогда
// Дней = ДатаЧисло(Дата1) - ДатаЧисло(Дата2) + 30;
// Мк = Мк - 1;
//Иначе
// Дней = ДатаЧисло(Дата1) - ДатаЧисло(Дата2);
//КонецЕсли;
//Если Мк - ДатаМесяц(Дата2) < 0 Тогда
// Месяцев = Мк - ДатаМесяц(Дата2) + 12;
// Гк = Гк - 1;
//Иначе
// Месяцев = Мк - ДатаМесяц(Дата2);
//КонецЕсли;
//Лет = Гк-ДатаГод(Дата2);
//Дней = Дней + 1;
//Если Дней >= 30 Тогда
// Дней = 0;
// Месяцев = Месяцев + 1;
//КонецЕсли;
//Если Месяцев = 12 Тогда
// Месяцев = 0;
// Лет = Лет + 1
//КонецЕсли;
Процедура глРазобратьРазностьДат(Знач Дата1,Знач Дата2,Лет=0,Месяцев=0,Дней=0) Экспорт

Лет = 0; Месяцев = 0; Дней = 0;
Если Дата1>Дата2 Тогда

ВременнаяДата = Дата1;
Если ДатаЧисло(ВременнаяДата)<ДатаЧисло(Дата2) Тогда
Дней = ВременнаяДата-ДобавитьМесяц(ВременнаяДата,-1);
ВременнаяДата = ДобавитьМесяц(ВременнаяДата,-1);
КонецЕсли;
Если ДатаМесяц(ВременнаяДата)<ДатаМесяц(Дата2) Тогда
ВременнаяДата = ДобавитьМесяц(ВременнаяДата,-12);
Месяцев = 12;
КонецЕсли;
Лет = Макс( ДатаГод (ВременнаяДата)-ДатаГод (Дата2),0);
Месяцев = Макс(Месяцев +ДатаМесяц(ВременнаяДата)-ДатаМесяц(Дата2),0);
Дней = Макс(Дней +ДатаЧисло(ВременнаяДата)-ДатаЧисло(Дата2),0);

// скорректируем отображаемое значение, если "вмешалось" разное количество дней в месяцах
Если Дата2 <> (ДобавитьМесяц(Дата1,-Лет*12-Месяцев)-Дней) Тогда
Дней = Дней + (КонМесяца(Дата2)-НачМесяца(Дата2)) - (КонМесяца(ДобавитьМесяц(Дата1,-1))-НачМесяца(ДобавитьМесяц(Дата1,-1)));
КонецЕсли;
КонецЕсли;

КонецПроцедуры // глРазобратьРазностьДат

З.Ы. Специально для BorisG: (с) 1С
_student
2 - 28.05.2004 11:34 		Посмотри глобальном модуле. Там полно всяких подобных расчетов.


Дата записи документа | База знаний | mista.ru

Дата записи документа

Press 26.05.2004 14:42 | Можно ее как нибудь вытащить, акромя mlg.
Arhitektor 1 - 26.05.2004 14:53 | Док.ПолучитьВремя()


Международное время, а как? | База знаний | mista.ru

Международное время, а как?

Lucky 20.05.2004 14:48 | Добрый день, Работаем с Иностранными клиентами разбросанными по всему миру, конфигурация самописанная. Не подскажите как сделать так чтобы Показывалось время со смещением относительно нашего. Может кто уже делал? СurrentTime() это понятно но как организовать смещение? Плиз подскажите.
SnarkHunter 11 - 20.05.2004 16:34 | 1. В справочник Контрагенты добывляешь числовой реквизит Смещение и заполняешь для каждого контрагента. 2. На форме элемента справочника создаешь текстовое поле с идентификатором, скажем, ТекВремя. 3. В модуле формы вставляешь функцию, скажем, ПоказатьТекВремя(): Процедура ПоказатьТекВремя() Форма.ТекВремя.Заголовок(ТекущееВремя()+Смещение); КонецПроцедуры 4. В процедуру ПриОткрытии добавляешь строчку: Форма.ОбработкаОжидания("ПоказатьТекВремя",1);


Как подсчитать количество месяцев между произвольными датами | База знаний | mista.ru

Как подсчитать количество месяцев между произвольными датами

Майк
3 - 18.05.2004 18:28 		Подрихтуй под свои надобности:

Процедура глРазобратьРазностьДат(Знач Дата1,Знач Дата2,Лет=0,Месяцев=0,Дней=0) Экспорт

Лет = 0; Месяцев = 0; Дней = 0;
Если Дата1>Дата2 Тогда

ВременнаяДата = Дата1;
Если ДатаЧисло(ВременнаяДата)<ДатаЧисло(Дата2) Тогда
Дней = ВременнаяДата-ДобавитьМесяц(ВременнаяДата,-1);
ВременнаяДата = ДобавитьМесяц(ВременнаяДата,-1);
КонецЕсли;
Если ДатаМесяц(ВременнаяДата)<ДатаМесяц(Дата2) Тогда
ВременнаяДата = ДобавитьМесяц(ВременнаяДата,-12);
Месяцев = 12;
КонецЕсли;
Лет = Макс( ДатаГод (ВременнаяДата)-ДатаГод (Дата2),0);
Месяцев = Макс(Месяцев +ДатаМесяц(ВременнаяДата)-ДатаМесяц(Дата2),0);
Дней = Макс(Дней +ДатаЧисло(ВременнаяДата)-ДатаЧисло(Дата2),0);

// скорректируем отображаемое значение, если "вмешалось" разное количество дней в месяцах
Если Дата2 <> (ДобавитьМесяц(Дата1,-Лет*12-Месяцев)-Дней) Тогда
Дней = Дней + (КонМесяца(Дата2)-НачМесяца(Дата2)) - (КонМесяца(ДобавитьМесяц(Дата1,-1))-НачМесяца(ДобавитьМесяц(Дата1,-1)));
КонецЕсли;
КонецЕсли;

КонецПроцедуры // глРазобратьРазностьДат
Таня
4 - 18.05.2004 18:28 		ДатаМесяц надо наверное использовать
и вычитать потом
SiMazx
6 - 18.05.2004 18:42 		(4) ДатаМесяц правильно, но учти, что даты могут быть в разных годах...
Тогда месяцу поздней даты прибавить 12 и тогда вычитать...


Как избавиться от "Сменилась текущая дата..." | База знаний | mista.ru

Как избавиться от "Сменилась текущая дата..."

Олег 13.05.2004 10:26 | У нас на сервере стоит 1С (репликация). При смене даты (в 0.00) выскакивает сообщение "Сменилась текущая дата. Изменить рабочую дату?" Как сделать, что быэто окошко не появлялось?
mszsuz 1 - 13.05.2004 10:31 | Сервис - Параметры - Изменять автоматически или второй параметр в РабочаяДата()


Скачет время проведения. | База знаний | mista.ru

Скачет время проведения.

lili 14.05.2004 10:59 | При проведении документов время идет сначала в хронологическом порядке(например, до 15.00), а потом перескакивает на 20.00. В чем причина?
Gavrila 1 - 14.05.2004 11:08 | документы как проводятся? может "обеденный" перерыв с 15.00 до 20.00, тобто проводили люди документы до 15.00 потом перестали, а в 20.00 проводят и указывают при проведении "изменить время" ?
Valery 2 - 14.05.2004 11:36 | Может на какой-то машине время неверное.
lili 3 - 14.05.2004 13:05 | (2)время проверяла, с этим все нормально. (1) обеденного перерыва нет, а документы проводятся всегда текущим временем.
Gavrila 4 - 14.05.2004 13:14 | (3) время меняется при перепроведении сохраненного документа? или при записи и проведении новых документов?
lili 5 - 14.05.2004 13:18 | если просто сохранить документ, то время ставится текущее, а если провести то все едет. Соотвественно и с новыми документами, т.к. сразу проводятся, то тоже самое со временем.
Gavrila 6 - 14.05.2004 13:21 | (5) ищи тогда в алгоритме проведения
Valery 7 - 14.05.2004 13:51 | Нужно глянуть а параметрах настройки проведения документов. где тут собака зарыта. Я бы еще глянул такой момент: при проведении не каком компе происходит такой скачек.


очень простой вопрос ламера: что надо прописать в формуле поля ввода | База знаний | mista.ru

очень простой вопрос ламера: что надо прописать в формуле поля ввода

pansy 14.05.2004 09:17 | чтобы оно заполнялось датой, отстоящей от даты документа на 5 рабочих дней? Спасибо!
pansy 2 - 14.05.2004 09:20 | ну хотя бы календарных:)
SnarkHunter 3 - 14.05.2004 09:22 | ДатаДок+5...
SnarkHunter 5 - 14.05.2004 09:27 | Значит не там прописываешь... Прописывать надо в формуле поля ДатаДок: ИД_Нужного_Реквизита = ДатаДок+5
pansy 6 - 14.05.2004 09:29 | в формуле поля ДатаДок пишу СрокО=ДатаДок+5;
pansy 7 - 14.05.2004 09:30 | Срок оплаты должен иметь тип "Дата"?
pansy 11 - 14.05.2004 09:41 | Процедура ДатаО() СрокО=Дата(ДатаДок+5); КонецПроцедуры Получилось вот так, но в документе работает только тогда, когда щелкнешь по полю ввода СрокО
pansy 12 - 14.05.2004 09:42 | можно сделать так, чтобы поле заполнялось сразу же??
pansy 14 - 14.05.2004 09:53 | при создании документа
SnarkHunter 15 - 14.05.2004 09:54 | В процедуре ВводНового() напиши СрокО=ДатаДок+5
SiMazx 16 - 14.05.2004 09:57 | Ну и вставь свою процедуру в ВводНового...


Работа с датой | База знаний | mista.ru

Работа с датой

Platon 13.05.2004 07:04 | Добрый день!. Что-то возился я с датой в своём отчёте, перечитал пол ЖКК но никак понять немогу как получить дату месяц назад. Например у меня так: Процедура ПриОткрытии() ВыбДата1=НачМесяца(РабочаяДата()); ВыбДата2=КонМесяца(РабочаяДата()); КонецПроцедуры Процедура возвращает текущий месяц. Я,что-то никак немогу добится, чтобы получить предыдущий месяц.
SnarkHunter 3 - 13.05.2004 07:27 | Для того, чтобы получить дату, отстоящую от твоей даты на один месяц, воспользуйся функцией ДобавитьМесяц().
427 9 - 13.05.2004 07:41 | Типа добавка может быть и отрицательной.... (5) .........
Platon 10 - 13.05.2004 09:08 | Опа!!! сработала! Процедура ПриОткрытии() ВыбДата1=ДобавитьМесяц(НачМесяца(РабочаяДата()),-1); ВыбДата2=ДобавитьМесяц(КонМесяца(РабочаяДата()),-1); КонецПроцедуры Всем привет.


Считать возраст | База знаний | mista.ru

Считать возраст

gleb
01.05.2004 15:07 		В ЗиК создаем отчет, где хотели бы видеть возраст сотрудников. Однако в отчете можно вставить только год рождения. Как получить возраст?
427
1 - 01.05.2004 15:14 		Мляяяяя.....

ТекущаяДата()-датаРождения....
Волшебник
2 - 01.05.2004 15:19 		(1) не так все просто как кажется, если нужно получить возраст в виде:
лет, месяцев и дней
427
3 - 01.05.2004 15:33 		Описывать использование функций
РазностьЛет
РазностьМесяцев
РазностьДней

считаю излишним ....
DElo
4 - 01.05.2004 23:23 		(0) Если нужно в днях, месяцах и годах, то такая же функция прописана в расчёте стажа работы сотрудника на предприятии. Стаж "толкается" от даты приказа о приёме на работу до текущей даты. Сделай всё идентично.
kadr
5 - 02.05.2004 08:11 		//******************************************************************************
// глРазобратьРазностьДат(Дата1,Дата2,Лет,Месяцев,Дней)
//
// Параметры:
// Дата1 - первая дата (более поздняя, часто текущая, стаж определяется по состоянию на эту дату)
// Дата2 - вторая дата (ранняя дата, с нее начинается "течение" стажа)
// Лет - в этот параметр будет записано кол-во лет между двумя датами (Дата1-Дата2)
// Месяцев - в этот параметр будет записано кол-во месяцев между двумя датами (Дата1-Дата2)
// Дней - в этот параметр будет записано кол-во дней между двумя датами (Дата1-Дата2)
//
// Описание:
// Процедура разбирает две даты и возвращает в параметрах кол-во лет, месяцев и дней
// между двумя датами (Дата1-Дата2)
//
// алгоритм Пенсионного фонда
//Мк = ДатаМесяц(Дата1);
//Гк = ДатаГод(Дата1);
//Если ДатаЧисло(Дата1) - ДатаЧисло(Дата2) < 0 Тогда
// Дней = ДатаЧисло(Дата1) - ДатаЧисло(Дата2) + 30;
// Мк = Мк - 1;
//Иначе
// Дней = ДатаЧисло(Дата1) - ДатаЧисло(Дата2);
//КонецЕсли;
//Если Мк - ДатаМесяц(Дата2) < 0 Тогда
// Месяцев = Мк - ДатаМесяц(Дата2) + 12;
// Гк = Гк - 1;
//Иначе
// Месяцев = Мк - ДатаМесяц(Дата2);
//КонецЕсли;
//Лет = Гк-ДатаГод(Дата2);
//Дней = Дней + 1;
//Если Дней >= 30 Тогда
// Дней = 0;
// Месяцев = Месяцев + 1;
//КонецЕсли;
//Если Месяцев = 12 Тогда
// Месяцев = 0;
// Лет = Лет + 1
//КонецЕсли;
Процедура глРазобратьРазностьДат(Знач Дата1,Знач Дата2,Лет=0,Месяцев=0,Дней=0) Экспорт

Лет = 0; Месяцев = 0; Дней = 0;
Если Дата1>Дата2 Тогда

ВременнаяДата = Дата1;
Если ДатаЧисло(ВременнаяДата)<ДатаЧисло(Дата2) Тогда
Дней = ВременнаяДата-ДобавитьМесяц(ВременнаяДата,-1);
ВременнаяДата = ДобавитьМесяц(ВременнаяДата,-1);
КонецЕсли;
Если ДатаМесяц(ВременнаяДата)<ДатаМесяц(Дата2) Тогда
ВременнаяДата = ДобавитьМесяц(ВременнаяДата,-12);
Месяцев = 12;
КонецЕсли;
Лет = Макс( ДатаГод (ВременнаяДата)-ДатаГод (Дата2),0);
Месяцев = Макс(Месяцев +ДатаМесяц(ВременнаяДата)-ДатаМесяц(Дата2),0);
Дней = Макс(Дней +ДатаЧисло(ВременнаяДата)-ДатаЧисло(Дата2),0);

// скорректируем отображаемое значение, если "вмешалось" разное количество дней в месяцах
Если Дата2 <> (ДобавитьМесяц(Дата1,-Лет*12-Месяцев)-Дней) Тогда
Дней = Дней + (КонМесяца(Дата2)-НачМесяца(Дата2)) - (КонМесяца(ДобавитьМесяц(Дата1,-1))-НачМесяца(ДобавитьМесяц(Дата1,-1)));
КонецЕсли;
КонецЕсли;

КонецПроцедуры // глРазобратьРазностьДат
kadr
7 - 03.05.2004 07:08 		(6) Кто тебе сказал, что за свою?
Надо, так получайте (с) 1С ЗиК 244
Еще вопросы будут?


Обращение к строке документа через регистр (НомерСтроки) | База знаний | mista.ru

Обращение к строке документа через регистр (НомерСтроки)

sheale
19.08.2004 19:04 		Я хочу через номер строки обратиться к реквизиту табличной части документа.
Цена = Док.цена
Вот запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(ЗапросПоНомерамСтрокДокумента)
|ТекущийДокумент = Регистр.ЗаявкаНаПеревозкуП.ТекущийДокумент;
|НомерСтроки = Регистр.ЗаявкаНаПеревозкуП.НомерСтроки;
|Количество = Регистр.ЗаявкаНаПеревозкуП.Количество;
|Функция КоличествоКонОст = КонОст(Количество);
|Группировка ТекущийДокумент ;
|Группировка НомерСтроки;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

Пока Запрос.Группировка(1) = 1 Цикл
Таб.ВывестиСекцию("ТекущийДокумент");
Пока Запрос.Группировка(2) = 1 Цикл
Таб.ВывестиСекцию("НомерСтроки");
Док = Запрос.ТекущийДокумент;
Цена = Док.Цена; // цена находится в табличной части
Сообщить(" Цена = "+цена);
КонецЦикла;
КонецЦикла;
Запрос не перебирает строки табличной части документа.
При записи в регистр я использую Регистр.ЗаявкаНаПеревозкуП.ПривязыватьСтроку(НомерСтроки);
Что здесь не правильно?
Рупор абсурда
1 - 19.08.2004 19:23 		См. про предопределённую группировку СтрокаДокумента ...
Michael99
3 - 19.08.2004 19:54 		1. После такой конструкции :
Док = Запрос.ТекущийДокумент;
Цена = Док.Цена; // цена находится в табличной части
ты получил Док но позиционирования не произошло
можно конечно сделать
Док.ПолучитьСтрокуПоНомеру(Запрос.НомерСтроки)
это для первого варианта
но лучше вытащить цену в запрос и исп группировку СтрокаДокумента

а что делает функция :Функция НомерСтрокиСумма = Сумма(НомерСтроки);
sheale
4 - 19.08.2004 22:50 		Получилось только так
\"//{{ЗАПРОС(ЗапросПоНомерамСтрокДокумента)
|Период с (НачГода(ТекущаяДата())) по (ТекущаяДата());
|ТекущийДокумент = Регистр.ЗаявкаНаПеревозкуП.ТекущийДокумент;
|НомерСтроки = Регистр.ЗаявкаНаПеревозкуП.НомерСтроки;
|Количество = Регистр.ЗаявкаНаПеревозкуП.Количество;
|Цена = Регистр.ЗаявкаНаПеревозкуП.ЗаявкаНаПеревозку.Цена;
|Функция КоличествоПриход = Приход(Количество);
|Функция КоличествоКонОст = КонОст(Количество);
|Группировка ТекущийДокумент;
|Группировка НомерСтроки;
//|Условие (Запрос.КоличествоКонОст > 0);
|\"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

Пока Запрос.Группировка(1) = 1 Цикл
Пока Запрос.Группировка(2) = 1 Цикл
Док = Запрос.ТекущийДокумент;
Док.ПолучитьСтрокуПоНомеру(Запрос.НомерСтроки);
Цена = Док.Цена; // цена находится в табличной части
Сообщить(\" Цена = \"+цена);
Сообщить(\"КоличествоКонОст =\"+Запрос.КоличествоКонОст);
Таб.ВывестиСекцию(\"НомерСтроки\");
КонецЦикла;
КонецЦикла;

Оказывается нужна функция приход. Но с остатками не получается. Нельзя получить остаток по строке документа. А, жаль…


V8 Запрос, аналог Получить в 7.7 | База знаний | mista.ru

V8 Запрос, аналог Получить в 7.7

blin
13.07.2004 22:45 		Есть запрос с итогами. Нужно спозиционироваться в нем на конкретное значение группировки. В 7.7 метод Получить у запроса. Есть ли такая же возможность в V8?
Asmody
1 - 13.07.2004 23:04 		ВыбИзРезЗап=Запрос.Выполнить().Выбрать();
ВыбИзрезЗап.НайтиСледующий(...);
см. НайтиСледующий() в СП


Пока Запрос.Группировка() = 1 Цикл | База знаний | mista.ru

Пока Запрос.Группировка() = 1 Цикл

Crystalizer 17.06.2004 15:41 | Объясните в чём грабли так работает: Пока Запрос.Группировка() = 1 Цикл а так не работает: Пока Запрос.Группировка(1) = 1 Цикл результат тот же что 1 что 2 группировки...
Bzzzzz 3 - 17.06.2004 16:10 | а БЕЗ ИТОГОВ в тексте запроса есть?
Crystalizer 4 - 17.06.2004 16:57 | Bzzzzz: ДА... и шо теперь никак не сделаешь 2 группировки?
Bzzzzz 5 - 17.06.2004 17:01 | (4) Если Используется Без итогов, то выборка осуществляется с помощью одного цикла обхода - Запрос.Группировка(). Прочти подробнее в ЖКК.


Проблема с запросом с подчиненным справочником | База знаний | mista.ru

Проблема с запросом с подчиненным справочником

Alex Lazareff
09.06.2004 03:26 		Поможите!

Проблема такая в запросе хочу пройтись по справочнику "Номенклатор", но только по тем позициям, к которым в ПОДЧИНЕННОМ (к номенкларору) справочнике прикручено значение "ВыбМарка". В данном случае запрос отбирает ВЕСЬ номенклатор и указанную "марку"

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Поля)
|Обрабатывать НеПомеченныеНаУдаление;
|Без итогов;
|ТекущийЭлемент = Справочник.Номенклатор.ТекущийЭлемент, Справочник.Вен.Владелец;
|Марка = Справочник.Вен.Марка.Значение;
|Группировка ТекущийЭлемент без групп;
|Группировка Марка;
|Условие (Марка = ВыбМарка);
|"//}}ЗАПРОС

Подскажите, что не так?
VladZagorsky
1 - 09.06.2004 04:21 		Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Поля)
|Обрабатывать НеПомеченныеНаУдаление;
|Без итогов;
|Ном = Справочник.Вен.Владелец;
|Марка = Справочник.Вен.Марка.Значение;
|Группировка Ном без групп;
|Группировка Марка;
|Условие (Марка = ВыбМарка);
|"//}}ЗАПРОС


Ислючение родителя в запросе | База знаний | mista.ru

Ислючение родителя в запросе

BorisBiz 04.06.2004 11:14 | Как сделать ислючение родителя в запросе. (ограничить можно через 'в', а ислючить как ?) Условие вида 'Условие (НЕ (Элемент в выбРодитель))' не работает. Может кто-нибудь сталкивался с подобной задачкой ? PS можно конечно сделать Условие (Элемент.Родитель<>выбРодитель), но заранее не известна глубина справочника :(
SnarkHunter 1 - 04.06.2004 11:17 | "Без Групп" тебе поможет...
lexa 2 - 04.06.2004 11:18 | Элемент.ПринадлежитГруппе(ВыбРодитель) = 0
BorisBiz 3 - 04.06.2004 11:25 | (2) Видимо то что нужно. Спасибо !
Рупор абсурда 4 - 04.06.2004 11:27 | А почему ты решил, что 'Условие (НЕ (Элемент в выбРодитель))' не работает?
SnarkHunter 5 - 04.06.2004 11:27 | Так тебе элементы определенной группы исключать надо или самого родителя?


Условие в запросе к двум справочникам | База знаний | mista.ru

Условие в запросе к двум справочникам

NastyFrog
26.05.2004 17:30 		Профи, подскажите, плз. Одним запросом из двух справочников можно данных набрать? Типа:
"//{{ЗАПРОС(Сформировать)
|Конт=Справочник.Контрагенты.ТекущийЭлемент;
|Дог=Справочник.Договоры.ТекущийЭлемент;
|Группировка Конт без групп;
|Условие (Дог.Владелец=Конт);
|"//}}ЗАПРОС
;
Выдается предупреждение "значение не представляет агрегатный объект (Владелец):2"
Где я с условием кривлю?
lexa
3 - 26.05.2004 17:37 		"//{{ЗАПРОС(Сформировать)
|Конт=Справочник.Договоры.Владелец;
|Дог=Справочник.Договоры.ТекущийЭлемент;
|Группировка Конт без групп;
|"//}}ЗАПРОС
;
lexa
8 - 26.05.2004 17:47 		(4) а условие не нужно, Владелец - ссылка из подчиненного справочника на справочник - владелец
если нужно отфильтровать по конкретному контрагенту, тогда да


Обход подчиненного справочника (вопрос №3) | База знаний | mista.ru

Обход подчиненного справочника (вопрос №3)

Danila
26.05.2004 18:06 		Ниже приведен код, в котором выполняется запрос. В результате которого я получаю значения элементов справочника номенклатура (переменная запроса Наим). Далее хочется получить цену элемента справочника номенклатура путем перебора подчиненного справочника "Цены" установив в качестве владельца значение Запрос.Наим, т.е. элемент справочника номенклатура. Но перебора подчиненного справочника Цены не происходит. Подскажите в чем проблема. Код:
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Запрос)
|Период с (НачМесяца(ТекущаяДата()));
|Наим = Регистр.ОстаткиТМЦ.Номенклатура.Наименование;
|Группировка Наим;
|"//}}ЗАПРОС
;

Пока (Запрос.Группировка("Наим") = 1) Цикл

ВыбДата = ТекущаяДата();
СпрЦены = СоздатьОбъект("Справочник.Цены");
СпрЦены.ИспользоватьВладельца(Запрос.Наим);
СпрЦены.ВыбратьЭлементы();
Пока (СпрЦены.ПолучитьЭлемент() = 1) Цикл
Сообщить(СпрЦены.Валюта);
Сообщить(СпрЦены.Процент);
Сообщить(СпрЦены.ТипЦен);
Цена=СпрЦены.Цена.Получить(ВыбДата);
Сообщить(Цена);
КонецЦикла;

КонецЦикла;

Заранее благодарю!
lexa
1 - 26.05.2004 18:07 		не |Наим = Регистр.ОстаткиТМЦ.Номенклатура.Наименование;
а |Наим = Регистр.ОстаткиТМЦ.Номенклатура;
Press
3 - 26.05.2004 18:08 		В Запрос.Наим - у тебя наименование элемента, а для такого дела нужен сам элемент.
Макс
9 - 26.05.2004 18:13 		(6)Первое - ты выбираешь именно наименование, т.е. текст.
А второе - выбираешь элементы справочника, который подставляешь в ИспользоватьВладельца

PS: На будущее - пробуй делать все в отладчике - ведь не зря придумали эту шнягу.
lexa
10 - 26.05.2004 18:14 		Наим = Регистр.ОстаткиТМЦ.Номенклатура.Наименование; - это наименование (реквизит справочника номенклатра)
а
Наим = Регистр.ОстаткиТМЦ.Номенклатура; - ссылка на элемент спраочника номенклатура ( на который ссылается справочник цен)


Тут вижу тут не вижу ИЛИ Запрос и все, все, все | База знаний | mista.ru

Тут вижу тут не вижу ИЛИ Запрос и все, все, все

Львенок
19.05.2004 12:57 		Есть ряд впросов... Вот коротенький код отчетика

Процедура Сформировать()
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"
|Фирма = Регистр.ПартииНаличие.Фирма;
|Номенклатура = Регистр.ПартииНаличие.Номенклатура;
|Партия = Регистр.ПартииНаличие.Партия;
|Док = Регистр.ПартииНаличие.ТекущийДокумент;
|КоличествоП = Регистр.ПартииНаличие.Количество;
|СуммаУпр = Регистр.ПартииНаличие.СуммаУпр;
|Функция КоличествоПКонОст = КонОст(КоличествоП);
|Функция СуммаУпрКонОст = КонОст(СуммаУпр);
|Функция Ра=Расход(КоличествоП);
|Функция К=Счётчик();
|Группировка Номенклатура без групп;
|Группировка Партия;
|Группировка Документ;
|Условие(Номенклатура в ВыбНоменклатура);
|";
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда Сообщить ("Жопа");Возврат;КонецЕсли;

Запрос.Выгрузить("ТестТабл",0,1);// !!!!!!!!!*1
Пока Запрос.Группировка(1) = 1 Цикл
Сообщить ("А: "+Запрос.Номенклатура);
Пока Запрос.Группировка(2) = 1 Цикл
Сообщить ("Б: "+Запрос.Партия);
Пока Запрос.Группировка(3) = 1 Цикл
Сообщить ("В: "+Запрос.Документ);// !!!!!!!!*2
КонецЦикла;
КонецЦикла;
КонецЦикла;
КонецПроцедуры

ТестТабл - ТаблицаЗначений лежащая на форме, ВыбНоменклатура - справочник номенклатура, лежит там же.

Так вот я не понимаю, то ли я идиот, толи ... все равно я идит... Но результат работы кода - поримерно таков:

1) ТестТабл - остается девственно пустой(!) - каким образом интересно?
2) Группировки обходятся - все кроме третьей - треться вечно пустая, т.е. строк типа "В: Документ-Такой-То" не бывает.
3) Резальтат не меняется, если группироку Документ заменить на группироку Док

Мне не ясно почему ТаблицаЗначений получается пустой, если группировки при этом обходятся (хотя и не все)? И мне не ясно почему группировка по документу не работает упорно. Я туплю? (ТиС 7.70.930, 1С:Предпр SQL 7.70.021)
___
Искренне Ваш, Львенок.
SnarkHunter
1 - 19.05.2004 13:04 		Кавычки у ТестТабл - лишние...
SnarkHunter
2 - 19.05.2004 13:06 		А по поводу третьей группировки... Остатков на документ нету - только движения...
Львенок
3 - 19.05.2004 13:07 		Вопрос, снимается, я нашел все глюки. Они дейтсивтельно мои и я действительно туплю. Таблицу заключил в кавычки, а запрос без периода. Если это исправить, все работает как ожидается.
___
Искренне Ваш, Львенок.


Два регистра остатка в одной строке | База знаний | mista.ru

Два регистра остатка в одной строке

staer
12.05.2004 10:21 		Жизнь заставила создать два регистра остатка.Стоит задача их сравнить.
И вывести в одну таблицу.В них одинаковые товары, но разное количество,цены, приходы,...
Нужно: товар.кол1.кол2.прих1.прих2.расх1.расх2.
У меня:товар.кол1.0.прих1.0.расх1.0.
0.Кол2.0.Прих2.0.расх2.0.товар(для контроля)
А нужно все в одной строке.Я делаю так:
Процедура Контроль()
Перем Запрос, ТекстЗапроса, Таб;
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Контроль)
|Период с НачДата по КонДата;
|ОстТов = Регистр.ОстаткиТоваров.Товар;
|ОстРош = Регистр.ОстаткиТоваровРошен.Товар;
|КолРош =Регистр.ОстаткиТоваровРошен.Количество;
|КолТов =Регистр.ОстаткиТоваров.Количество;
|Функция КолТовНач=НачОст(КолТов);
|Функция КолРошНач=НачОст(КолРош);
|Функция КолТовКон=КонОст(КолТов);
|Функция КолРошКон=КонОст(КолРош);
|Функция ПрихТов=Приход(КолТов);
|Функция ПрихРош=Приход(КолРош);
|Функция РасхТов=Расход(КолТов);
|Функция РасхРош=Расход(КолРош);
//|Условие (ОстТов.Поставщик=Константа.Рошен);
|Группировка ОстРош;
|Группировка ОстТов;
|"//}}ЗАПРОС
;

Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Контроль");
Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);

Пока Запрос.Группировка(1) = 1 Цикл
Пока Запрос.Группировка(2) = 1 Цикл
Если Запрос.ОстТов.Поставщик=Константа.Рошен Тогда
Наз=Запрос.ОстТов.Наименование;
КолТовНачТ=Запрос.КолТовНач;
//КолРошНачТ=Запрос.КолРошНач;
КолТовКонТ=Запрос.КолТовКон;
//КолРошКонТ=Запрос.КолРошКон;
ПрихТовТ=Запрос.ПрихТов;
//ПрихРошТ=Запрос.ПрихРош;
РасхТовТ=Запрос.РасхТов;
//РасхРошТ=Запрос.РасхРош;
ТабЗн.НоваяСтрока();
Таб.ВывестиСекцию("Товар");
КонецЕсли;
КонецЦикла;

Наз=Запрос.ОстРош.Наименование;
//КолТовНачТ=Запрос.КолТовНач;
КолРошНачТ=Запрос.КолРошНач;
//КолТовКонТ=Запрос.КолТовКон;
КолРошКонТ=Запрос.КолРошКон;
//ПрихТовТ=Запрос.ПрихТов;
ПрихРошТ=Запрос.ПрихРош;
//РасхТовТ=Запрос.РасхТов;
РасхРошТ=Запрос.РасхРош;
Таб.ВывестиСекцию("Товар");
КонецЦикла;
Таб.ТолькоПросмотр(1);
Таб.Показать("Контроль", "");
КонецПроцедуры
Рупор абсурда
1 - 12.05.2004 10:26 		Товар = Регистр.ОстаткиТоваров.Товар,Регистр.ОстаткиТоваровРошен.Товар;
lexa
2 - 12.05.2004 10:44 		и соответсвенно убрать одну группировку
Процедура Контроль()
Перем Запрос, ТекстЗапроса, Таб;
Запрос = СоздатьОбъект(\"Запрос\");
ТекстЗапроса =
\"//{{ЗАПРОС(Контроль)
|Период с НачДата по КонДата;
|Тов = Регистр.ОстаткиТоваров.Товар, Регистр.ОстаткиТоваровРошен.Товар;
|КолРош =Регистр.ОстаткиТоваровРошен.Количество;
|КолТов =Регистр.ОстаткиТоваров.Количество;
|Функция КолТовНач=НачОст(КолТов);
|Функция КолРошНач=НачОст(КолРош);
|Функция КолТовКон=КонОст(КолТов);
|Функция КолРошКон=КонОст(КолРош);
|Функция ПрихТов=Приход(КолТов);
|Функция ПрихРош=Приход(КолРош);
|Функция РасхТов=Расход(КолТов);
|Функция РасхРош=Расход(КолРош);
//|Условие (ОстТов.Поставщик=Константа.Рошен);
|Группировка Тов;
|\"//}}ЗАПРОС
;

Таб = СоздатьОбъект(\"Таблица\");
Таб.ИсходнаяТаблица(\"Контроль\");
Заполнение полей \"Заголовок\"
Таб.ВывестиСекцию(\"Заголовок\");
Состояние(\"Заполнение выходной таблицы...\");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);

Пока Запрос.Группировка(1) = 1 Цикл

Если Запрос.ОстТов.Поставщик=Константа.Рошен Тогда
Наз=Запрос.Тов.Наименование;
КолТовНачТ=Запрос.КолТовНач;
КолРошНачТ=Запрос.КолРошНач;
КолТовКонТ=Запрос.КолТовКон;
КолРошКонТ=Запрос.КолРошКон;
ПрихТовТ=Запрос.ПрихТов;
ПрихРошТ=Запрос.ПрихРош;
РасхТовТ=Запрос.РасхТов;
РасхРошТ=Запрос.РасхРош;
ТабЗн.НоваяСтрока();
Таб.ВывестиСекцию(\"Товар\");
КонецЕсли;
КонецЦикла;

Таб.ТолькоПросмотр(1);
Таб.Показать(\"Контроль\", \"\");
КонецПроцедуры
Но, если у тебя в обоих регистрах есть еще измерения то их тоже надо связать


Сортировка документов в отчете по дням | База знаний | mista.ru

Сортировка документов в отчете по дням

staer
10.05.2004 13:35 		Подскажите плиз идею.Её нету у меня!!!
ТЗ.Один день одна строка.Разные док. у каждого свой столбец.В нем выводится СуммаДокум.Три столбца.Три Разных Докум.Нужно:
День.ИтогКолСумДок1.ИтогКолСумДок2.ИтогКолСумДок3
У меня:
День.НазванДок.СумДок1.00000
День.НазванДок.0000000.СумДок2.
Не могу придумать алгоритм.Сами док. не интересуют(наз),нужна ИтогСумДокум.Сейчас у меня все получается кроме строк.Делаю через запрос по докум. И каждый док. выводится в отдельной строке.
Композитор
1 - 10.05.2004 14:09 		Перем Запрос;

//*******************************************
Процедура Сформировать()
Запрос = СоздатьОбъект("Запрос");
ДатаНач = НачГода(РабочаяДата());
ДатаКон = ПолучитьДатуТА();
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ДатаНач по ДатаКон;
|ДатаДок = Документ.Реализация.ДатаДок,Документ.ПоступлениеТМЦ.ДатаДок,Документ.СчетФактураВыданный.ДатаДок;
|Сумма1 = Документ.Реализация.Сумма;
|Сумма2 = Документ.ПоступлениеТМЦ.Сумма;
|Сумма3 = Документ.СчетФактураВыданный.Сумма;
|Функция Сум1 = Сумма(Сумма1);
|Функция Сум2 = Сумма(Сумма2);
|Функция Сум3 = Сумма(Сумма3);
|Группировка ДатаДок;";

Запрос.Выполнить(ТекстЗапроса);
Пока Запрос.Группировка(1) = 1 Цикл
ТЗ.НоваяСтрока();
ТЗ.Дата = Запрос.ДатаДок;
ТЗ.СуммаДок1 = Запрос.Сум1;
ТЗ.СуммаДок2 = Запрос.Сум2;
ТЗ.СуммаДок3 = Запрос.Сум3;
КонецЦикла;
КонецПроцедуры

Процедура ПриОткрытии()
ТЗ.НоваяКолонка("Дата");
ТЗ.НоваяКолонка("СуммаДок1");
ТЗ.НоваяКолонка("СуммаДок2");
ТЗ.НоваяКолонка("СуммаДок3");
КонецПроцедуры
staer
2 - 10.05.2004 17:18 		Огромное Спасибо. Все Работает. Встречный Вопрос.
Как можно Обратиться к документу по которому идет запрос.
GrayT
3 - 10.05.2004 20:28 		(1)Зачем так сложно?
тз = СоздатьОбъект(\"ТаблицаЗначений\");
Запрос.Выгрузить(ТЗ);
Ни цикла, ни формирования ТЗ
(2)Ты ж говорил, что сами документы не интересуют :)

\"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|ОбрабатыватьДокументы все;
|ТекДок = Документ.Реализация.ТекущийДокумент, Документ.ПоступлениеТМЦ.ТекущийДокумент, Документ.СчетФактураВыданный.ТекущийДокумент;
|ДатаДок = Документ.Реализация.ДатаДок, Документ.ПоступлениеТМЦ.ДатаДок, Документ.СчетФактураВыданный.ДатаДок;
|СумДок = Документ.Реализация.Сумма, Документ.ПоступлениеТМЦ.Сумма, Документ.СчетФактураВыданный.Сумма;
|Функция Сум1 = Сумма(СумДок) когда(ТекДок.Вид()=\"\"Реализация\"\");
|Функция Сум2 = Сумма(СумДок) когда(ТекДок.Вид()=\"\"ПоступлениеТМЦ\"\");
|Функция Сум3 = Сумма(СумДок) когда(ТекДок.Вид()=\"\"СчетФактураВыданный\"\");
|Группировка ДатаДок;
|Группировка ТекДок;
|\"


Простецкий запрос по справочнику | База знаний | mista.ru

Простецкий запрос по справочнику

AlexMan
07.05.2004 18:24 		Парни , такая задача (у юзеров фантазия разыгралась): Есть справочник Номенклатура , у элемента справочника есть реквизит "Серия"-тип значения "Справочник.Серии" так вот им в отчете "необходимо" чтобы шло так : Группа,Серия,Элемент....
можно ли это организовать в запросе?
SiMazx
3 - 07.05.2004 18:34 		А сам пробовал чо-нить делать? Или тебе все разжевать?
Логичнее когда ты чего-то делаешь, что-то не получается и ты просишь совета...
А тут...
Ну если я тебе скажу, что у тебя в запросе будет три группировки, тебе сильно легче станет?
AlexMan
5 - 07.05.2004 18:58 		Вот ответ на мой вопрос , спасибо SiMazz за подсказку в (3)
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Родитель = Справочник.Номенклатура.Родитель;
|ТекущийЭлемент = Справочник.Номенклатура.ТекущийЭлемент;
|ВидНоменклатуры = Справочник.Номенклатура.ВидНоменклатуры;
|Группировка Родитель;
|Группировка ВидНоменклатуры;
|Группировка ТекущийЭлемент без групп;
|"//}}ЗАПРОС


Упорядочивание в запросе | База знаний | mista.ru

Упорядочивание в запросе

Вася 07.05.2004 14:29 | Есть текст запроса ... Группировка ДеньДок упорядочить по ДеньДок; ... Как упорядочить по убыванию так не идет "Группировка ДеньДок упорядочить по ДеньДок-;"
SnarkHunter 1 - 07.05.2004 14:36 | При обходе используй ВТОРОЙ параметр метода Группировка()
Lew 4 - 07.05.2004 14:41 | попробуй Пока Запрос.Группировка(<Группировка>,-1)=1 Цикл


V8 условие в запросе | База знаний | mista.ru

V8 условие в запросе

Palex 06.05.2004 12:36 | "|ГДЕ ОстаткиТМЦОстатки.Склад В (&Склад) И |ОстаткиТМЦОстатки.Номенклатура В ИЕРАРХИИ (&Номенклатура) " Склад - не иерархический справочник, а Номенклатура иерархический. Как сделать, чтобы при пустом значении параметра "Склад" выбирались все склады? Для "Номенклатура" получается.
GrayT 1 - 06.05.2004 12:54 | А какая фих разница. Для не иерархического справочника тоже должно работать? А зачем скобки у параметров?
Palex 2 - 06.05.2004 14:08 | Если сделать справочник иерархическим и изменить как \\\\\\\"ГДЕ ОстаткиТМЦОстатки.Склад В ИЕРАРХИИ (&Склад) \\\\\\\" тогда при пустом Склад все выводиться. Я так понимаю, что для того , чтобы использовать в параметрах пустые значения для вывода все значений нужно делать справочник иерархическим. Верно или как-то по другому можно?
GrayT 3 - 06.05.2004 21:12 | Млин, и вправду. Попытался просто сделать выборку из справочника с пустым условием ВыбСклад - пусто :( Я еще не понял смысла всего этого, но я "вывернулся" так: |ГДЕ | (СкладыКомпании.Ссылка В (&ВыбСклад)) или (&ВыбСклад = &ПС)\"; Запрос.УстановитьПараметр(\"ВыбСклад\", ВыбСклад); Запрос.УстановитьПараметр(\"ПС\", Справочники.СкладыКомпании.ПустаяСсылка());


Периодические реквизиты в запросах | База знаний | mista.ru

Периодические реквизиты в запросах

Татьяна 05.05.2004 04:12 | Не получается взять значение периодического реквизита в запросе на дату документа, берется значение на конечную дату запроса. Существует ли способ?
kvm 3 - 05.05.2004 21:47 | Ты запрос нарисуй. Вообще, там автоматом периодическое значение берется на ту дату/документ, который сейчас обрабатывается, так что глюк в тексте запроса.
GrayT 4 - 05.05.2004 23:03 | (3)Неправда - на конечную дату
GrayT 5 - 05.05.2004 23:22 | (0)Может поможет? http://194.135.22.174/forum/topic.php?id=1984


Две таблицы значений - поиск одинаковых значений реквизитов | База знаний | mista.ru

Две таблицы значений - поиск одинаковых значений реквизитов

Шольц 12.05.2004 19:03 | Существуют две таблицы значений Т1 и Т2. В них колонки №1 совпадают по типам значений а в некоторых случаях и по самим значениям. Необходимо найти номер строки в Т2 со значением в 1-й колонке, совпадающим со значением 1-й колонки Т1 для каждой строки Т1. Вроде объяснил доступно :) Делаю Перем НомСтр; Для ц=1 По Т1.КоличествоСтрок() Цикл Т2.НайтиЗначение(Т1.ПолучитьЗначение(ц,1),НомСтр,1); Сообщить(НомСтр); КонецЦикла; Сообщает всегда "1". Битый час бьюсь, не могу вкурить где ошибка. Может кто свежим взглядом заметит.
AlexMan 1 - 12.05.2004 19:12 | НомСтр=""; перед Т2.НайтиЗначение...
Шольц 2 - 12.05.2004 19:20 | Пошло. Спасибо. Я правда поставил ноль вместо "". Но еще, если не сложно, объясни. Я так понимаю, что переменная уже определена (Перем НомСтр), потом в цикле регулярно меняется ее значение... Зачем ее еще каждый раз обнулять?
Gavrila 3 - 12.05.2004 19:22 | но лучше: НомСтр=0; перед Т2.НайтиЗначение... :))
AlexMan 4 - 12.05.2004 19:35 | (2) Почитай описалово к методу НайтиЗначение() там все написано.
Шольц 5 - 12.05.2004 19:50 | Я понял. После первого прохода в цикле НомСтр принимет значение, скажем N и при последующем прохождении НайтиЗначение() ищет только в N-й строке. Я правильно понял?
Рупор абсурда 8 - 12.05.2004 20:10 | Ещё лучше: НомСтр=''; перед Т2.НайтиЗначение... :))
427 49 - 15.05.2004 21:12 | Просто остроумное использование метода свернуть и ..... оператора "если" Все делается за один проход ТЗ.....


НайтиЗначение() в ТЗ по двум колонкам. Возможно ли? | База знаний | mista.ru

НайтиЗначение() в ТЗ по двум колонкам. Возможно ли?

User63
03.08.2004 12:18 		Допустим, у меня есть таблица значений с колонками номенклатура и партия. Можно ли методом НайтиЗначение() получить строку по этим двум параметрам, например,предварительно создав дополнительную колонку и какаим нибудь образом скопировав туда значения этих двух вышеуказанных колонок?
Спасибо.
Warlock
2 - 03.08.2004 12:19 		(0)Перебором строк...
Рупор абсурда
4 - 03.08.2004 12:21 		Можно и без доп. колонки ...
User63
6 - 03.08.2004 12:25 		Перебор строк не устраивает...
Хотелось бы через НайтиЗначение(). Вот только не знаю как в одну колонку два реквита вставить.
ТЗ.ДопКолонка =Стр(Номенклатура.Код)+Стр(Партия.Код)
Такой вариант у меня пройдет? Или есть более наработанные способы?
Рупор абсурда
13 - 03.08.2004 12:33 		Функция ПоискПоДвумКолонкам(ТЗ,Значение1,Значение2,Колонка1,Колонка2)
Перем ТЗ_;
Если ПустоеЗначение(Значение1)=1 Тогда Возврат("Глюк :)") КонецЕсли;
ТЗ.Выгрузить(ТЗ_);
Пока 1=1 Цикл
Ном=0;
ТЗ_.НайтиЗначение(Значение1,Ном,Колонка1);
Если Ном=0 Тогда Возврат(0) КонецЕсли;
Если ТЗ_.ПолучитьЗначение(Ном,Колонка2)=Значение2 Тогда Возврат(Ном) КонецЕсли;
ТЗ_.УстановитьЗначение(Ном,Колонка1,ПолучитьПустоеЗначение());
КонецЦикла;
Возврат 0;
КонецФункции
IAm
24 - 03.08.2004 12:48 		Функция ПоискПоДвумКолонкам(ТЗ,Значение1,Значение2,Колонка1,Колонка2)
Перем ТЗ_;
ТЗ.Выгрузить(ТЗ_);
ИндексПоиска = 0;
Пока 1=1 Цикл
Если ИндексПоиска <> 1 Тогда
Поз1=0;
ТЗ_.НайтиЗначение(Значение1,Поз1,Колонка1);
КонецЕсли;
Если ИндексПоиска <> 2 Тогда
Поз2 =0;
ТЗ_.НайтиЗначение(Значение2,Поз2,Колонка2);
КонецЕсли;
Если (Поз1=0) ИЛИ (Поз2=0) Тогда
Возврат(0)
ИначеЕсли Поз1 = Поз2 Тогда
Возврат Поз1;
ИначеЕсли Поз1 > Поз2 Тогда
ТЗ.Заполнить("", 1, Поз1 - 1, Колонка2);
ИндексПоиска = 1;
Иначе
ТЗ.Заполнить("", 1, Поз2 - 1, Колонка1);
ИндексПоиска = 2;
КонецЕсли;
КонецЦикла;
КонецФункции
NS
85 - 04.08.2004 00:47 		Avb, ну указывал же я метод...
Поиск скорей всего многократный...
Методов нормальных два - хранить остсортированными по первому параметру в двух направлениях, и бинарный поиск, и сводный реквизит...
Остальное - порезанное (83)
Рупор абсурда
88 - 04.08.2004 00:57 		(85) Один хрен, большая часть времени у тебя уйдёт на подготовку к поиску ...
А если тз предварительно никак не подготовлена для поиска ...
Изменять порядок строк в ней нельзя ...
И, допустим, найти нужно всего один раз ...

Ты пойми, я ж не навязываю никакого решения ..., просто предложил, как один из вариантов ...
IAm
91 - 04.08.2004 00:59 		1) Сортировка. Не катит если нужно вернуть номер строки.
2) Бинарный поиск. Что это?
3) Отдельный реквизит. Ёжику понятно, только если поиск выполняется один раз для таблицы, то создавать его в несколько раз дольше.
NS
93 - 04.08.2004 01:02 		(88) Колонка - номер строки.
Сортировка? Долго? Сколько секунд сортируется ТЗ на миллион?
По индексу? Меньше десяти секунд...
А поиск явно неоднократный.
Рупор абсурда
95 - 04.08.2004 01:05 		(91) А бинарный поиск тоже предполагает предварительную сортировку ...
NS
96 - 04.08.2004 01:06 		(95) Я и говорб - сортировка в обе стороны и бинар.
NS
140 - 04.08.2004 02:50 		А я из-за этого дерьма проснулся...
Если ТЗ совсем неотсортирована...
Сложность алгоритма -
Добавление любой колонки (номер строки, сводный реквизит) - эн логарифмов эн.
Пробег - Эн.
Лучшее решение..
ТЗ.ВыбратьСтроки();
пока тЗ.ПолучитьСтроку()=1 цикл
если ТЗ.Номенклатура=номенклатура тогда
если ТЗ.Партия=партия Тогда
сообщить(ТЗ.Номерстроки);
прервать;
конецесли;
конецесли;
КонецЦикла;
правильное решение - (2)
Z1
143 - 04.08.2004 09:50 		(Рупор абсурда) Мой вариант поисковой функции
Идея 1 симметрия алгоритма по колонке1 и колонке2
Идея 2 улучшения том что если нашли сразу то и не надо выгружать ТаблицуЗначений

// Возвращает номер строки где значения совпадают
Функция ПоискОдиночныйПоДвумКолонкам(ТЗ,Значение1,Значение2,Колонка1,Колонка2)
Перем ТЗ_;
Если ПустоеЗначение(Значение1)=1 Тогда Возврат("Глюк1 :)") КонецЕсли;
Если ПустоеЗначение(Значение2)=1 Тогда Возврат("Глюк2 :)") КонецЕсли;
Ном1=0;
ТЗ.НайтиЗначение(Значение1,Ном1,Колонка1);
Если Ном1=0 Тогда Возврат(0) КонецЕсли;
Ном2=0;
ТЗ.НайтиЗначение(Значение2,Ном2,Колонка2);
Если Ном2=0 Тогда Возврат(0) КонецЕсли;
Если Ном1 = Ном2 Тогда
Возврат(Ном1);
ИначеЕсли Ном1 > Ном2 Тогда
Зн2 = ТЗ.ПолучитьЗначение(Ном1,Колонка2);
Если Зн2 = Значение2 Тогда
Возврат(Ном1);
КонецЕсли;
Ном3 = Ном1 + 1;
Иначе
Зн1 = ТЗ.ПолучитьЗначение(Ном2,Колонка1);
Если Зн1 = Значение1 Тогда
Возврат(Ном2);
КонецЕсли;
Ном3 = Ном2 + 1;
КонецЕсли;
Дельта = Ном3;
СписокКолонок = Колонка1 + "," + Колонка2;
ТЗ.Выгрузить(ТЗ_,Ном3, ,СписокКолонок );
Если ТЗ_.КоличествоСтрок() <= 0 Тогда Возврат(0) КонецЕсли;
Пока 1=1 Цикл
Ном1=0;
ТЗ_.НайтиЗначение(Значение1,Ном1,Колонка1);
Если Ном1=0 Тогда Возврат(0) КонецЕсли;
Ном2=0;
ТЗ_.НайтиЗначение(Значение2,Ном2,Колонка2);
Если Ном2=0 Тогда Возврат(0) КонецЕсли;
Если Ном1 = Ном2 Тогда
Возврат(Дельта + Ном1);
ИначеЕсли Ном1 > Ном2 Тогда
Зн2 = ТЗ_.ПолучитьЗначение(Ном1,Колонка2);
Если Зн2 = Значение2 Тогда
Возврат(Дельта + Ном1);
КонецЕсли;
Ном3 = Ном1 + 1;
Иначе
Зн1 = ТЗ_.ПолучитьЗначение(Ном2,Колонка1);
Если Зн1 = Значение1 Тогда
Возврат(Дельта + Ном2);
КонецЕсли;
Ном3 = Ном2 + 1;
КонецЕсли;
Дельта = Дельта + Ном3;
ТЗ_.Выгрузить(ТЗ_,Ном3, , );
Если ТЗ_.КоличествоСтрок() <= 0 Тогда Возврат(0) КонецЕсли;
КонецЦикла;
КонецФункции
Громобой
157 - 04.08.2004 10:43 		(154) "Для множественного поиска ничего красивше индекса нету" - согласен. Но для одиночного ничего элегантнее твоего (5) нет. (24) - не элегантно, т.к. при большой ТЗ будит ЗНАЧИТЕЛЬНО тормознее, потому что основное время займет ТЗ.Выгрузить(ТЗ_).
IAm
159 - 04.08.2004 10:47 		157 Если нужно получить номер строки, то решение в 5 не покатит.
ТЗ.Выгрузить(ТЗ_); можно заменить на ТЗ.Выгрузить(ТЗ_,,,"Колонка1,Колонка2");
Время экономит.
NS
179 - 04.08.2004 15:34 		Для разового поиска - всяко бытрее простой перебор...
Так как добавление любой колонки с заполнением - эн логарифмов эн....
в методе (5) - не узнать номер строки...
И раз уж отсортировал - то лучше бинарный поиск (логарифм вместо эн)
NS
180 - 04.08.2004 15:35 		Для разового поиска - всяко бытрее простой перебор...
Так как добавление любой колонки с заполнением - эн логарифмов эн....
в методе (5) - не узнать номер строки...
И раз уж отсортировал - то лучше бинарный поиск (логарифм вместо эн)
Z1
188 - 04.08.2004 16:11 		(180) Для разового поиска перебор это просто N.
Все дело в реалиции этого перебора.
Одно дело перебор через интерпретатор 1с и
другое дело тот же самый перебор через метод НайтиЗначение в ТЗ, реализованный
на языке Си++.
NS
189 - 04.08.2004 16:21 		Кто спорит - смотрим (140) и предыдущий диалог...
Есть ТЗ, неотсортированная, нужно найти любую строку, с данной партией, и товаром - и сообщить НОМЕР СТРОКИ в изначальной таблице...
Мной предложен способ - если кто-то считает, что можно разовый поиск сделать быстрее - предлагайте свой вариант.
стр=0;
ТЗ.ВыбратьСтроки();
пока тЗ.ПолучитьСтроку()=1 цикл
если ТЗ.Номенклатура=номенклатура тогда
если ТЗ.Партия=партия Тогда
стр=ТЗ.Номерстроки;
прервать;
конецесли;
конецесли;
КонецЦикла;
если стр=0 тогда
сообщить("не нашли");
Иначе
сообщить(стр);
КонецЕсли;
можно подготовить тестовый пример - ТЗ на 10000 строк, в первой и второй колонке случайное целое число из диапазона 1..100
NS
226 - 04.08.2004 20:53 		А вот и тест - параметры, как договаривались - первый 10000, второй 100...
Можно попробовать - первый 100000, второй 300...

перем случ;
Процедура Рандомизе()
случ=_GetPerformanceCounter();
КонецПроцедуры
Функция Рандом(Интервал)
Случ=случ%1000000000000001;
Случ=Случ*1103515245+12345;
Возврат ((Случ/65536)%32768)%Интервал+1;
КонецФункции
Процедура Сформировать()
перем ТЗ,ТЗ_,КолстрокВТЗ,Разных;
ввестичисло(колСтрокВТЗ,"Введите кол. строк в ТЗ",10,0);
ввестичисло(Разных,"Введите количество разных значений",10,0);
ТЗ=создатьОбъект("ТаблицаЗначений");
ТЗ.Новаяколонка("Кол1","Число",10,0);
ТЗ.НоваяКолонка("Кол2","Число",10,0);
Рандомизе();
Для а=1 по КолСтрокВТЗ цикл
Если а%100=0 Тогда
состояние(а);
КонецЕсли;
ТЗ.НоваяСтрока();
ТЗ.Кол1=Рандом(Разных);
ТЗ.Кол2=Рандом(Разных);
КонецЦикла;
Ищем1=Рандом(Разных);
Ищем2=Рандом(Разных);
начвремя=_GetperformanceCounter();
стр=0;
ТЗ.ВыбратьСтроки();
пока тЗ.ПолучитьСтроку()=1 цикл
если ТЗ.Кол1=Ищем1 тогда
если ТЗ.кол2=Ищем2 Тогда
стр=ТЗ.Номерстроки;
прервать;
конецесли;
конецесли;
КонецЦикла;
если стр=0 тогда
сообщить("не нашли");
Иначе
сообщить(стр);
КонецЕсли;
конвремя=_GetperformanceCounter();
сообщить("Простым перебором "+(конВремя-НачВремя)+" мс.");
// способ 2;
начвремя=_GetperformanceCounter();
стр=0;
_ТЗ=создатьобъект("ТаблицаЗначений");
ТЗ.Выгрузить(_ТЗ,,,"Кол1");
Пока _ТЗ.НайтиЗначение(Ищем1,Стр,"Кол1")>0 Цикл
если ТЗ.ПолучитьЗначение(стр,"Кол2")=Ищем2 Тогда
прервать;
Иначе
_ТЗ.УстановитьЗначение(Стр,"Кол1",0);
стр=0;
КонецЕсли;
КонецЦикла;
_ТЗ.Очистить();
если стр=0 тогда
сообщить("не нашли");
Иначе
сообщить(стр);
КонецЕсли;
конвремя=_GetperformanceCounter();
сообщить("Метод 2: "+(конВремя-НачВремя)+" мс.");

// метод IAm
начвремя=_GetperformanceCounter();
_ТЗ=создатьобъект("ТаблицаЗначений");
ТЗ.Выгрузить(_ТЗ);
ИндексПоиска = 0;
Пока 1=1 Цикл
Если ИндексПоиска <> 1 Тогда
Поз1=0;
_ТЗ.НайтиЗначение(Ищем1,Поз1,"Кол1");
КонецЕсли;
Если ИндексПоиска <> 2 Тогда
Поз2 =0;
_ТЗ.НайтиЗначение(Ищем2,Поз2,"Кол2");
КонецЕсли;
Если (Поз1=0) ИЛИ (Поз2=0) Тогда
прервать;
ИначеЕсли Поз1 = Поз2 Тогда
прервать;
ИначеЕсли Поз1 > Поз2 Тогда
_ТЗ.Заполнить("", 1, Поз1 - 1, "Кол2");
ИндексПоиска = 1;
Иначе
_ТЗ.Заполнить("", 1, Поз2 - 1, "Кол1");
ИндексПоиска = 2;
КонецЕсли;
КонецЦикла;
_ТЗ.Очистить();
если (Поз1=0)или(поз2=0) тогда
сообщить("не нашли");
Иначе
сообщить(стр);
КонецЕсли;
конвремя=_GetperformanceCounter();
сообщить("Метод IAm: "+(конВремя-НачВремя)+" мс.");
// Если что не так - подправте модуль.
КонецПроцедуры
NS
227 - 04.08.2004 21:08 		Кого интересуют результаты теста - перебор, как я и говорил - быстрее,
и чем больше строк в ТЗ, тем перебор сильнее выигрывает...
NS
234 - 04.08.2004 22:07 		перем случ;
Функция ПоискОдиночныйПоДвумКолонкам(ТЗ,Значение1,Значение2,Колонка1,Колонка2)
Перем ТЗ_;
//Если ПустоеЗначение(Значение1)=1 Тогда Возврат("Глюк1 :)") КонецЕсли;
//Если ПустоеЗначение(Значение2)=1 Тогда Возврат("Глюк2 :)") КонецЕсли;
Ном1=0;
ТЗ.НайтиЗначение(Значение1,Ном1,Колонка1);
Если Ном1=0 Тогда Возврат(0) КонецЕсли;
Ном2=0;
ТЗ.НайтиЗначение(Значение2,Ном2,Колонка2);
Если Ном2=0 Тогда Возврат(0) КонецЕсли;
Если Ном1 = Ном2 Тогда
Возврат(Ном1);
ИначеЕсли Ном1 > Ном2 Тогда
Зн2 = ТЗ.ПолучитьЗначение(Ном1,Колонка2);
Если Зн2 = Значение2 Тогда
Возврат(Ном1);
КонецЕсли;
Ном3 = Ном1 + 1;
Иначе
Зн1 = ТЗ.ПолучитьЗначение(Ном2,Колонка1);
Если Зн1 = Значение1 Тогда
Возврат(Ном2);
КонецЕсли;
Ном3 = Ном2 + 1;
КонецЕсли;
Дельта = Ном3;
СписокКолонок = Колонка1 + "," + Колонка2;
ТЗ.Выгрузить(ТЗ_,Ном3, ,СписокКолонок );
Если ТЗ_.КоличествоСтрок() <= 0 Тогда Возврат(0) КонецЕсли;
Пока 1=1 Цикл
Ном1=0;
ТЗ_.НайтиЗначение(Значение1,Ном1,Колонка1);
Если Ном1=0 Тогда Возврат(0) КонецЕсли;
Ном2=0;
ТЗ_.НайтиЗначение(Значение2,Ном2,Колонка2);
Если Ном2=0 Тогда Возврат(0) КонецЕсли;
Если Ном1 = Ном2 Тогда
Возврат(Дельта + Ном1);
ИначеЕсли Ном1 > Ном2 Тогда
Зн2 = ТЗ_.ПолучитьЗначение(Ном1,Колонка2);
Если Зн2 = Значение2 Тогда
Возврат(Дельта + Ном1);
КонецЕсли;
Ном3 = Ном1 + 1;
Иначе
Зн1 = ТЗ_.ПолучитьЗначение(Ном2,Колонка1);
Если Зн1 = Значение1 Тогда
Возврат(Дельта + Ном2);
КонецЕсли;
Ном3 = Ном2 + 1;
КонецЕсли;
Дельта = Дельта + Ном3;
ТЗ_.Выгрузить(ТЗ_,Ном3, , );
Если ТЗ_.КоличествоСтрок() <= 0 Тогда Возврат(0) КонецЕсли;
КонецЦикла;
КонецФункции

Процедура Рандомизе()
случ=_GetPerformanceCounter();
КонецПроцедуры
Функция Рандом(Интервал)
Случ=случ%1000000000000001;
Случ=Случ*1103515245+12345;
Возврат ((Случ/65536)%32768)%Интервал+1;
КонецФункции
Процедура Сформировать()
перем ТЗ,ТЗ_,КолстрокВТЗ,Разных;
ввестичисло(колСтрокВТЗ,"Введите кол. строк в ТЗ",10,0);
ввестичисло(Разных,"Введите количество разных значений",10,0);
ТЗ=создатьОбъект("ТаблицаЗначений");
ТЗ.Новаяколонка("Кол1","Число",10,0);
ТЗ.НоваяКолонка("Кол2","Число",10,0);
Рандомизе();
Для а=1 по КолСтрокВТЗ цикл
Если а%100=0 Тогда
состояние(а);
КонецЕсли;
ТЗ.НоваяСтрока();
ТЗ.Кол1=Рандом(Разных);
ТЗ.Кол2=Рандом(Разных);
КонецЦикла;
Тз.ВыбратьСтроку();
Ищем1=Рандом(Разных);
Ищем2=Рандом(Разных);
сообщить("Ищем: "+Ищем1+" "+Ищем2);
начвремя=_GetperformanceCounter();
стр=0;
ТЗ.ВыбратьСтроки();
пока тЗ.ПолучитьСтроку()=1 цикл
если ТЗ.Кол1=Ищем1 тогда
если ТЗ.кол2=Ищем2 Тогда
стр=ТЗ.Номерстроки;
прервать;
конецесли;
конецесли;
КонецЦикла;
если стр=0 тогда
сообщить("не нашли");
Иначе
сообщить(стр);
КонецЕсли;
конвремя=_GetperformanceCounter();
сообщить("Простым перебором "+(конВремя-НачВремя)+" мс.");
// способ 2;
начвремя=_GetperformanceCounter();
стр=0;
_ТЗ=создатьобъект("ТаблицаЗначений");
ТЗ.Выгрузить(_ТЗ,,,"Кол1");
Пока _ТЗ.НайтиЗначение(Ищем1,Стр,"Кол1")>0 Цикл
если ТЗ.ПолучитьЗначение(стр,"Кол2")=Ищем2 Тогда
прервать;
Иначе
_ТЗ.УстановитьЗначение(Стр,"Кол1",0);
стр=0;
КонецЕсли;
КонецЦикла;
_ТЗ.Очистить();
если стр=0 тогда
сообщить("не нашли");
Иначе
сообщить(стр);
КонецЕсли;
конвремя=_GetperformanceCounter();
сообщить("Метод 2: "+(конВремя-НачВремя)+" мс.");

// метод IAm
начвремя=_GetperformanceCounter();
_ТЗ=создатьобъект("ТаблицаЗначений");
ТЗ.Выгрузить(_ТЗ);
ИндексПоиска = 0;
Пока 1=1 Цикл
Если ИндексПоиска <> 1 Тогда
Поз1=0;
_ТЗ.НайтиЗначение(Ищем1,Поз1,"Кол1");
КонецЕсли;
Если ИндексПоиска <> 2 Тогда
Поз2 =0;
_ТЗ.НайтиЗначение(Ищем2,Поз2,"Кол2");
КонецЕсли;
Если (Поз1=0) ИЛИ (Поз2=0) Тогда
прервать;
ИначеЕсли Поз1 = Поз2 Тогда
прервать;
ИначеЕсли Поз1 > Поз2 Тогда
_ТЗ.Заполнить("", 1, Поз1 - 1, "Кол2");
ИндексПоиска = 1;
Иначе
_ТЗ.Заполнить("", 1, Поз2 - 1, "Кол1");
ИндексПоиска = 2;
КонецЕсли;
КонецЦикла;
_ТЗ.Очистить();
если (Поз1=0)или(поз2=0) тогда
сообщить("не нашли");
Иначе
сообщить(стр);
КонецЕсли;
конвремя=_GetperformanceCounter();
сообщить("Метод IAm: "+(конВремя-НачВремя)+" мс.");
//Метод Z1
начвремя=_GetperformanceCounter();
Зн1 = ПоискОдиночныйПоДвумКолонкам(ТЗ,Ищем1,Ищем2,"Кол1","Кол2");
конвремя=_GetperformanceCounter();
Сообщить("Зн1 = " + Зн1);
сообщить("Метод Z1 (143) "+(конВремя-НачВремя)+" мс.");
Сообщить(" ");

// Если что не так - подправте модуль.
КонецПроцедуры
...
Добавил метод Z1, и проверку генератора (ТЗ выводит)
NS
236 - 04.08.2004 22:16 		Все тесты - 10000,100
Мало того, что метод Z1 тормозит жутко - еще и результат неправильный ;-)
(и есно генератор в (230) неправильно работает - ТЗ кривая)

Ищем: 13 8
4477
Простым перебором 781 мс.
4477
Метод 2: 1517 мс.
4477
Метод IAm: 4002 мс.
Зн1 = 4505
Метод Z1 (143) 72650 мс.

Ищем: 20 1
не нашли
Простым перебором 1596 мс.
не нашли
Метод 2: 2417 мс.
не нашли
Метод IAm: 17113 мс.
Зн1 = 0
Метод Z1 (143) 112295 мс.

Ищем: 84 76
795
Простым перебором 142 мс.
795
Метод 2: 904 мс.
795
Метод IAm: 1645 мс.
Зн1 = 800
Метод Z1 (143) 10821 мс.

Ищем: 52 98
7540
Простым перебором 1008 мс.
7540
Метод 2: 1606 мс.
7540
Метод IAm: 11298 мс.
Зн1 = 7596
Метод Z1 (143) 95587 мс.
NS
241 - 04.08.2004 22:24 		перем случ;

Процедура Рандомизе()
случ=_GetPerformanceCounter();
КонецПроцедуры
Функция Рандом(Интервал)
Случ=случ%1000000000000001;
Случ=Случ*1103515245+12345;
Возврат ((Случ/65536)%32768)%Интервал+1;
КонецФункции
Процедура Сформировать()
перем ТЗ,ТЗ_,КолстрокВТЗ,Разных;
ввестичисло(колСтрокВТЗ,"Введите кол. строк в ТЗ",10,0);
ввестичисло(Разных,"Введите количество разных значений",10,0);
ТЗ=создатьОбъект("ТаблицаЗначений");
ТЗ.Новаяколонка("Кол1","Число",10,0);
ТЗ.НоваяКолонка("Кол2","Число",10,0);
Рандомизе();
Для а=1 по КолСтрокВТЗ цикл
Если а%100=0 Тогда
состояние(а);
КонецЕсли;
ТЗ.НоваяСтрока();
ТЗ.Кол1=Рандом(Разных);
ТЗ.Кол2=Рандом(Разных);
КонецЦикла;
Тз.ВыбратьСтроку();
Ищем1=Рандом(Разных);
Ищем2=Рандом(Разных);
сообщить("Ищем: "+Ищем1+" "+Ищем2);
начвремя=_GetperformanceCounter();
стр=0;
ТЗ.ВыбратьСтроки();
пока тЗ.ПолучитьСтроку()=1 цикл
если ТЗ.Кол1=Ищем1 тогда
если ТЗ.кол2=Ищем2 Тогда
стр=ТЗ.Номерстроки;
прервать;
конецесли;
конецесли;
КонецЦикла;
если стр=0 тогда
сообщить("не нашли");
Иначе
сообщить(стр);
КонецЕсли;
конвремя=_GetperformanceCounter();
сообщить("Простым перебором "+(конВремя-НачВремя)+" мс.");
// способ 2;
начвремя=_GetperformanceCounter();
стр=0;
_ТЗ=создатьобъект("ТаблицаЗначений");
ТЗ.Выгрузить(_ТЗ,,,"Кол1");
Пока _ТЗ.НайтиЗначение(Ищем1,Стр,"Кол1")>0 Цикл
если ТЗ.ПолучитьЗначение(стр,"Кол2")=Ищем2 Тогда
прервать;
Иначе
_ТЗ.УстановитьЗначение(Стр,"Кол1",0);
стр=0;
КонецЕсли;
КонецЦикла;
если стр=0 тогда
сообщить("не нашли");
Иначе
сообщить(стр);
КонецЕсли;
конвремя=_GetperformanceCounter();
сообщить("Метод 2: "+(конВремя-НачВремя)+" мс.");
_ТЗ.Очистить();
// Если что не так - подправте модуль.
КонецПроцедуры

////////////

Ищем: 87 84
не нашли
Простым перебором 1171 мс.
не нашли
Метод 2: 1695 мс.
Ищем: 23 98
5995
Простым перебором 1030 мс.
5995
Метод 2: 1803 мс.
Ищем: 15 73
не нашли
Простым перебором 1170 мс.
не нашли
Метод 2: 1813 мс.
NS
243 - 04.08.2004 22:29 		100000,300

Ищем: 45 219
50263
Простым перебором 7538 мс.
50263
Метод 2: 25402 мс.
Рупор абсурда
244 - 04.08.2004 22:31 		Вывод:
Не фиг бояться перебора и называть его тупым! ...
Рупор абсурда
249 - 05.08.2004 12:13 		Вот вам ещё вариант ..., в среднем работает быстрее перебора ..., даже самого тупого перебора ...

// способ Рупора;
начвремя=_GetperformanceCounter();
СЗ=СоздатьОбъект("СписокЗначений");
стр=0;
Пока ТЗ.НайтиЗначение(Ищем1,Стр,"Кол1")>0 Цикл
если ТЗ.ПолучитьЗначение(стр,"Кол2")=Ищем2 Тогда
прервать;
Иначе
СЗ.ДобавитьЗначение(ТЗ.ПолучитьЗначение(стр,"Кол1"));
ТЗ.УстановитьЗначение(Стр,"Кол1",0);
стр=0;
КонецЕсли;
КонецЦикла;
если стр=0 тогда
сообщить("не нашли");
Иначе
сообщить(стр);
Для стр=1 По СЗ.РазмерСписка() Цикл
ТЗ.УстановитьЗначение(СЗ.ПолучитьЗначение(стр),"Кол1",Ищем1);
КонецЦикла;
КонецЕсли;
конвремя=_GetperformanceCounter();
сообщить("Метод Рупора: "+(конВремя-НачВремя)+" мс.");
Рупор абсурда
251 - 05.08.2004 12:19 		(250) Перебор иногда оказывается быстрее в случае когда "не нашли" ...
... Но редко ... :))


Как увеличить окно выборки ТЗ? | База знаний | mista.ru

Как увеличить окно выборки ТЗ?

koshechka
22.07.2004 00:43 		Процедура ТЗ.ВыбратьСтроку() например открывает такусенькое маленькое недоразумение, в котором ничего толком не видно. Как можно сделать окно нормального размера?
427
4 - 22.07.2004 09:01 		Без меня как без .....лей...

Садишься на машину с разрешением 800*600
Берешь любой редактор ресурсов...
Посылаешь копирайты в путешествие
Влазишь в 1SrcRus.dll
Правишь
Dialogs -
1511 для выбора из ТЗ
1116 для выбора из СЗ

после этого по выбратьСтроку() открывается окно нормальной величины

1056 – регистрационное окно.... удобно для программиста, когда список баз большой.... Только в нем не проколитесь - внизу экрана лежит строка пути, в некоторых редакторах она не подсвечена... Засунете под грид с базами - неудобно будет

1145 – настройка порядка обхода.... Только для программиста...
1157 настройка журнала .... Только для программиста

В String Table 68
в ресурсе 1076 надпись "1С-Предприятие" заменяем на "1С-" - удобно, если юзеры работают с большим количеством программ одновременно. Видно название конфы...

Конечно, это не совсем законные методы... Но сама фирма 1С как сделала окошки фиксированного размера... размером с глазок в двери... так и заставляет всю страну Trax 0.33 литра..... Кстати, ни одного байта кода при этом не правится... Только ресурсы..

Почему это не поправит сама фирма 1С? Столько лет...

ТОЛЬКО НЕ ПЕРЕСТАРАЙТЕСЬ С РАЗМЕРАМИ ОКОН...


как задать процедуру обработки при нажитии на колонке таблицы | База знаний | mista.ru

как задать процедуру обработки при нажитии на колонке таблицы

Crystalizer 21.07.2004 14:41 | значений на форме, если колонки в ней создавались программно? цель: сортировка по разным колонкам
Diter 2 - 21.07.2004 14:45 | Я устанавливаю процедуру для всей ТЗ в формуле с параметрами (ТекущаяСтрока,ТекущаяКолонка) и в процедуре уже отлавливаю, какая колонка является текущей, то и делаю с ней. Например ОбработатьТаблицу(ТабДок.ТекущаяСтрока(),ТабДок.ТекущаяКолонка()) Да, добавляю ещё имя таблицы, если их много на форме, чтобы для каждой не писать отдельную процедуру
Crystalizer 3 - 21.07.2004 14:56 | Valery: угу Diter: да так срабатывает но только при клике на уже заполненное строчке. а как сделать чтобы и при клике на заголовке колонки?
Композитор 4 - 21.07.2004 15:29 | (3)А какая разница? Если у Вас в колонке однотипные данные, то при клике на любую ячейку проверяйте номер колонки, которой принадлежит ячейка, и обрабатывайте в цикле все ячейки активной колонки.
Crystalizer 5 - 21.07.2004 15:34 | Композитор: стереотипней для юзера кликать на заголовке колонки для сортировки и на ячейке со значением для редактирования...
Композитор 6 - 21.07.2004 15:38 | (5) Верно. Я делаю кнопку "Сортировать" с процедурой "Сортировать". //******************************************* Процедура Сортировать(Табл) Кол = Строка(Табл.ТекущаяКолонка()); Табл.Сортировать("-"+Кол); Конецпроцедуры //
Diter 7 - 21.07.2004 15:56 | Кликая на названии колонки (неважно как созданной программно или явно) - никак. Либо делай кнопку, либо кликать надо на строчке (пускай даже рустой)


Как объединить 2 таблицы значений в одну? | База знаний | mista.ru

Как объединить 2 таблицы значений в одну?

Василий
14.07.2004 14:31 		Хочу слить 2 таблицы значений в одну.
Струтура колонок одинаковая.
Есть ли какая-нибудь процедура которая дописывает в Таблицу1
все строки из Таблицы2 или нужно перебирать все ячейки в цикле?
Warlock
12 - 17.07.2004 01:08 		(11)Извиняюсь. Действительно неправильно фурычит... Я для теста плохо заполнил ТЗшки и не увидел ошибки. Там не хватает "+1". Вот рабочий вариант без доп. переменных:

ТЗ1.КоличествоСтрок(ТЗ1.КоличествоСтрок()+ТЗ2.КоличествоСтрок());
ТЗ1.Заполнить(ТЗ2,ТЗ1.КоличествоСтрок()-ТЗ2.КоличествоСтрок()+1,ТЗ1.КоличествоСтрок());


копирование таблицы значений... | База знаний | mista.ru

копирование таблицы значений...

Crystalizer 15.06.2004 15:36 | делаю так: тзн_групп = тзн; тзн_групп.Свернуть("Менеджер", "ДолгКомпл, ДолгЖилКом"); тзн.ВыбратьСтроку(); тзн_групп.ВыбратьСтроку(); в итоге "тзн" тоже самая что и "тзн_групп". получаеца "тзн_групп" = ссылка на "тзн"...?! а как же сделать копию? //кроме поштучного копирования по циклам
SnarkHunter 1 - 15.06.2004 15:39 | тзн.Выгрузить(тзн_групп);
3V 5 - 15.06.2004 16:15 | (1) вообще-то более правильно будет, тзн_групп.Загрузить(тзн); имхо
3V 6 - 15.06.2004 16:16 | (+5) Загрузить(<?>); Load(<?>); Синтаксис: Загрузить(<ТаблицаЗначений>) Назначение: Скопировать структуру и значения таблицы значений. Прежняя структура колонок таблицы значений при этом очищается. Параметры: <ТаблицаЗначений> - значение типа ''Таблица значений''. Структура и значения для загрузки.


Чем можно заменить динамические массивы? | База знаний | mista.ru

Чем можно заменить динамические массивы?

connect_ 18.05.2004 14:46 | В отчете задается произвольный диапазон дат. Это может быть месяц или несколько лет. Информацию за каждый месяц необходимо сохранить в нескольких массивах. Раньше отчет был строго за год, от начала и до конца. Бухша попросила сделать произвольный диапазон. Есть ли в 1С динамические массивы, или чем их можно заменить? Заранее спасибо.
Композитор 1 - 18.05.2004 14:48 | ТаблицаЗначений
GrayT 2 - 18.05.2004 16:09 | Не уверен что тут нужны динамические массивы или их аналоги. Возможно нужна просто группировка по периодам
Inside 3 - 18.05.2004 16:42 | А чем список значений не динамический?
Fynjy 5 - 18.05.2004 18:01 | Возьми жкк почитай ... Как вариант можно работать через черный запрос ... Но мне ТЗ ближе ...
GrayT 6 - 19.05.2004 00:37 | (3)Тем что имеет всего три предопределенных поля


Сортировка в таблице значений | База знаний | mista.ru

Сортировка в таблице значений

Tani 15.06.2004 11:51 | ТЗ-таблица значений, колонки Клиент, счет - символьные Сумма - число ТЗ.Сортировать("Клиент+,Счет+"); ТЗ.Свернуть("Клиент,счет","Сумма"); после этого вывожу на печать клиенты получаются не попорядку. Что не правильно делую?
SiMazx 1 - 15.06.2004 11:52 | Сверни, потом сортируй...


Поиск по таблице значений | База знаний | mista.ru

Поиск по таблице значений

lexa
08.06.2004 18:56 		Есть копия базы, в основную базу вкачали номенклатуру, соответственно часть кодов у номенклатуры съехала и добавилась новая номенклатура, нужно удалить все то, что вкачали. В копию базы добавил новый реквизит справочника Ид, туда записал внутренний индентификатор. Подключился к копии через оле. Создал таблицу значений, куда записал из копии все внутр. индентификаторы. Вычисляю внутр. индентификатор элемента справочник и ищу его в ТЗ. Если не находит, то ставлю пометку на удаление. Назодит только одно значение в ТЗ. Смотрел в екселе должно быть больше.
перем БазаОле;
Функция Ид(Объект)
Перем Стр;
СЗ=СоздатьОбъект("СписокЗначений");
СЗ.ДобавитьЗначение("",Объект);
СЗ.ПолучитьЗначение(1,Стр);

Возврат СокрЛП(Строка(Стр));
КонецФункции
//*******************************************
Процедура Сформировать()
ТМЦOLE = БазаОле.CreateObject("Справочник.Номенклатура"); // "СоздатьОбъект" в OLE не работает!
// ТМЦОле = БазаОле.CreateObject("Справочник.Номенклатура"); // "СоздатьОбъект" в OLE не работает!
ТМЦ = СоздатьОбъект("Справочник.Номенклатура");
ТЗОЛЕ = СоздатьОбъект("ТаблицаЗначений");
ТЗОЛЕ.НоваяКолонка("Ид");
ТЗОЛЕ.НоваяКолонка("Код");
// ТМЦOLE.ПорядокКодов();
ТМЦOLE.ВыбратьЭлементы();
Кол= 0;
Стр = 0;
ВремКод ="";
Табл = СоздатьОбъект("Таблица");
Пока ТМЦOLE.ПолучитьЭлемент() = 1 Цикл
ВремКод = ТМЦOLE.Код;
// ТМЦОле.НайтиПоКоду(ВремКод,0);
ТЗОЛЕ.НоваяСтрока();
ТЗОЛЕ.Ид = СокрЛП(ТМЦOLE.Ид);
ТЗОЛЕ.Код = ТМЦOLE.Код;
// Табл.ВывестиСекцию("тек1");
Сообщить(ТЗОЛЕ.НомерСтроки);
КонецЦикла;
ТМЦ.ВыбратьЭлементы();
Пока ТМЦ.ПолучитьЭлемент() = 1 Цикл
Если ТЗОЛЕ.НайтиЗначение(Ид(ТМЦ.ТекущийЭлемент()),Стр,1) = 1 Тогда
ТЗОЛЕ.ПолучитьСтрокуПоНомеру(Стр);
Табл.ВывестиСекцию("тек");
Иначе
Табл.ВывестиСекцию("тек1");
ТМЦ.Удалить(0);
КонецЕсли;
// ТЗОЛЕ.ПолучитьСтрокуПоНомеру(1);
КонецЦикла;
Табл.Показать("Печать прайс-листа","");
КонецПроцедуры
Процедура ПриОткрытии()
БазаОле=СоздатьОбъект("V77.Application");
КаталогБазыОЛе = "D:\1c\КопияDB";
ПользовательОле = "Администратор";
ПарольОле = "";
МонопольныйРежимOLE = " /m"; // для немонопольного запуска указать пустую строку!
ЗапускБезЗаставки = 1; // для появления заставки (например, чтобы наблюдать
// процесс запуска базы OLE визуально) поставьте здесь "0"
РезультатПодключения = БазаОле.Initialize ( БазаОле.RMTrade , "/d" +
СокрЛП(КаталогБазыОле) + " /n" + СокрЛП(ПользовательОле)+
" /p" + СокрЛП(ПарольОле) ,
?(ЗапускБезЗаставки = 1,"NO_SPLASH_SHOW",""));
Если РезультатПодключения = 0 Тогда
Предупреждение("Не удалось подключится к указанной базе - проверьте вводные!");
КонецЕсли;
КонецПроцедуры
lexa
2 - 08.06.2004 19:12 		ТЗОЛЕ.НайтиЗначение(Ид(ТМЦ.ТекущийЭлемент()),Стр,1) находит одно значение и все, в екселе сравнивал ТЗ и справочник, должно находить больше
SnarkHunter
3 - 08.06.2004 19:14 		Ты в курсе, что ИД объекта уникален по своей природе? С какой стати больше?
lexa
6 - 08.06.2004 19:33 		Сам себя задурил сделал проще
перем БазаОле;
Функция Ид(Объект)
Перем Стр;
СЗ=СоздатьОбъект("СписокЗначений");
СЗ.ДобавитьЗначение("",Объект);
СЗ.ПолучитьЗначение(1,Стр);

Возврат СокрЛП(Строка(Стр));
КонецФункции
//*******************************************
Процедура Сформировать()
ТМЦOLE = БазаОле.CreateObject("Справочник.Номенклатура"); // "СоздатьОбъект" в OLE не работает!
ТМЦ = СоздатьОбъект("Справочник.Номенклатура");
СПОЛЕ = СоздатьОбъект("СписокЗначений");

ТМЦOLE.ВыбратьЭлементы();
Кол= 0;
Стр = 0;
ВремКод ="";
Табл = СоздатьОбъект("Таблица");
Пока ТМЦOLE.ПолучитьЭлемент() = 1 Цикл
СПОЛЕ.ДобавитьЗначение( СокрЛП(ТМЦOLE.Ид),);
КонецЦикла;
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Товар = Справочник.Номенклатура.ТекущийЭлемент;
|Группировка Товар;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

Пока Запрос.Группировка(1) = 1 Цикл
Если СПОЛЕ.НайтиЗначение(Ид(Запрос.Товар)) = 0 Тогда
ТМЦ.Удалить(0);
КонецЕсли;
КонецЦикла;
КонецПроцедуры
Процедура ПриОткрытии()
БазаОле=СоздатьОбъект("V77.Application");
КаталогБазыОЛе = "D:\1c\КопияDB";
ПользовательОле = "Администратор";
ПарольОле = "19620225";
МонопольныйРежимOLE = " /m"; // для немонопольного запуска указать пустую строку!
ЗапускБезЗаставки = 1; // для появления заставки (например, чтобы наблюдать
// процесс запуска базы OLE визуально) поставьте здесь "0"
РезультатПодключения = БазаОле.Initialize ( БазаОле.RMTrade , "/d" +
СокрЛП(КаталогБазыОле) + " /n" + СокрЛП(ПользовательОле)+
" /p" + СокрЛП(ПарольОле) ,
?(ЗапускБезЗаставки = 1,"NO_SPLASH_SHOW",""));
Если РезультатПодключения = 0 Тогда
Предупреждение("Не удалось подключится к указанной базе - проверьте вводные!");
КонецЕсли;
КонецПроцедуры
Все работает
lexa
8 - 08.06.2004 19:38 		(5) на момент копирования ИД должны совпадать
lexa
10 - 08.06.2004 19:49 		(9) да согласен я с тобой, сам толко что убедился, если в обеих базах что то создать то ИД совпадают у разныз объектов, так что буду через журнал ковырять
SnarkHunter
11 - 08.06.2004 19:58 		Не... чего-то ты недопонимаешь... Если у тебя имеются две идентичные базы - основная и копия, а затем копию не трогают, а в основную добавляют некоторое количество объектов, то ИД объектов копии являются подмножеством ИД объектов основной базы... Именно подмножеством, не пересечением... Так что вычислить объекты, которые были добавлены - элементарно просто...


Максимум | База знаний | mista.ru

Максимум

povar
04.06.2004 07:48 		ТаблицаЗначений, колонка тип = число
Как определить максимальное ??
SnarkHunter
2 - 04.06.2004 08:03 		Есть...
ТЗ.Сортировать("Цена-");
НоваяЦена=ТЗ.ПолучитьЗначение(1,"Цена");


метод Свернуть() в ТЗ | База знаний | mista.ru

метод Свернуть() в ТЗ

VNL 01.06.2004 16:01 | Можно ли методом Свернуть() суммировать одну колонку ТЗ, а по другой колонке получать числовые значения построчно?
alxkorvin 1 - 01.06.2004 16:03 | да
lexa 24 - 01.06.2004 16:54 | Свернуть Свернуть таблицу значений но соответствующим значениям колонок. Синтаксис: Свернуть(<ГруппКолонки>, <СуммКолонки>) Англоязычный синоним: GroupBy Параметры: <ГруппКолонки> Группировочные колонки (номера или идентификаторы колонок через запятую), по которым группировать данные. <СуммКолонки> Суммируемые колонки (номера или идентификаторы колонок через запятую), по которым суммировать данные. Описание: Метод Свернуть позволяет свернуть таблицу значений по соответствующим значениям колонок, т. е. заменяет на одну строку все дублирующие (по значениям группировочных колонок) строки, суммируя значения но суммируемым колонкам. Пример: Табл.Свернуть("1,2,3,4", "5,6,7");
VNL 27 - 01.06.2004 17:17 | нужно свернуть колонку по товару, суммировать по количеству, а по цене оставить как есть..
lexa 28 - 01.06.2004 17:19 | ТЗ.Свернуть("НомерКолонкиТовар,НомерКолонкиЦена","НомерКолонкиКоличество") НомерКолонки - цифра


Обнуление ячейки Таблицы значений | База знаний | mista.ru

Обнуление ячейки Таблицы значений

Platon
01.06.2004 11:58 		Кто подскажет можно-ли обнулить ячейку ТЗ.?
Ситуация такая.
Две колонки имеют одинаковое значение но надо, чтобы это значение показывалось только в одной из колонок в зависимости от значения третьей колонки.
Так не обнуляется
ТЗ.Сум=ДокНакл.Всего;
ТЗ.СумПр=ДокНакл.Всего;
Если (ДокНакл.Наименование)="Заготов.складск.расх. 4 %" Тогда
ТЗ.Сум=0;
Иначе
ТЗ.СумПр=0;
КонецЕсли;
После этого все числа только в колонке ТЗ.Сум а в другой 0.
lexa
2 - 01.06.2004 12:02 		а ДокНакл.Наименование это разве колонка ТЗ
Композитор
3 - 01.06.2004 12:06 		ТЗ.Сум = 0;
ТЗ.СумПР = 0;
Если ДокНакл.Наименование = "что-то" Тогда
ТЗ.Сум = ДокНакл.СуммаВсего;
Иначе
ТЗ.СумПР = ДокНакл.СуммаВсего;
КонецЕсли;
Platon
4 - 01.06.2004 12:14 		(3)Забавно сейчас всё наоборот получилось.
ТЗ.Сум=0;
ТЗ.СумПр=0;
if ТЗ.Мат="Заготов.складск.расх. 4 %" then
ТЗ.Сум=ДокНакл.Всего;
Иначе
ТЗ.СумПр=ДокНакл.Всего;
endif;
427
6 - 01.06.2004 12:18 		А еще при создании колонки можно указать формат вывода в этой колонке...
Бывает так, что в некоторых релизах в синтаксис помошнике об этом иногда написано.... Наверное, пора поменять релиз... или руки ...

Также бывает полезно вместо конструкции
Если (ДокНакл.Наименование)="Заготов.складск.расх. 4 %" Тогда

использовать конструкцию
if Find(ДокНакл.Description,"Заготов.складск.расх. 4 %") > 0 then

вот только какой нибудь юзер поправит наименование ... и придет страшный зверь писец... Надо заранее припасти вазелин... чтобы кусался не больно ....
Композитор
7 - 01.06.2004 12:18 		(4) Не выполняется условие. Проверьте тип значения ТЗ.Мат, правильность написания "Заготов..."
lexa
8 - 01.06.2004 12:22 		(6) так могут как раз подстроку "Заготов.складск.расх. 4 %" изменить
Platon
10 - 01.06.2004 12:29 		(7)Я тип значения не указывал. Отладчик находит места где это условие выполняется
Platon
11 - 01.06.2004 12:32 		(8)Эта строка элемент справочника у которого кстати даже кода нет
GrayT
12 - 01.06.2004 12:36 		То что кода нет не беда. Элемент справочника - это объект


Необходимость задания типа для колонки таблицы значений | База знаний | mista.ru

Необходимость задания типа для колонки таблицы значений

valich 29.05.2004 21:01 | Вот столкнулся тут, 5 часов потратил, пока понял... Может кому пригодиться... В таблице значений было несколько колонок объявленных примерно так: ИтоговаяТаблица.НоваяКолонка("КолвоПриход"); ИтоговаяТаблица.НоваяКолонка("СумПриход"); Т. е. без указания типа и размера переменных. Далее, отбирались разные документы и по ним заполнялась эта таблица значений. Но с каждого документа заполнялась только часть колонок, те что требовались. Остальные (незаполненные) колонки строкИ просто не получали значений. Что привело к проблемам при попытке свернуть таблицу значений. Колонки в которых в первой строке не было значений выдавали при сворачивании нулевой результат. Проблема решается двумя способами. Либо все суммируемые колонки объявляются при создании с явным указанием типов. Либо, второй вариант, заполнять все колонки, а там где значений не имеется передавать "0". P.S.: Написал так, на всякий случай. Просто для меня это было неочевидным...
427 5 - 29.05.2004 21:24 | Свинство, описанное в (0), творится не только в ТЗ.... Кстати, сортировка в ТЗ интересно будет работать на нетипизированных колонках... На самом деле похожим поведением обладают все системы с неявным приведением типов ... просто 1С наиболее яркий представитель таких систем, в которой многое не додумано ... Кстати, типизация колонки ускоряет работу некоторых методов в ТЗ....
valich 6 - 29.05.2004 21:44 | (5) А сортировочка-то работает... PHP тоже система с неявным приведением типов, а такого я там не наблюдал, хотя опыта в нем больше чем в 1С... P.S.: Кстати, при моем разбирательстве злую шутку сыграла именно моя "паскальная зависимость"... По привычке, все что можно объявить, объявляю. Потом долго искал "стрелочника"... И еще на час флейм устроили с моей коллегой, она тоже 1С изучает (FoxPro'шница). Хорошо, когда есть с кем поделиться ;-)


Работа с таблицей значений | База знаний | mista.ru

Работа с таблицей значений

Новичок
29.05.2004 11:58 		Не могу разобраться с таблицей значений.
Как можно отловить интерактивный выбор(по двойному клику) элемента в таблице значений на форме документа, если эта таблица значений является просто элементом диалога?
Волшебник
1 - 29.05.2004 12:00 		Пропиши ей формулу в свойствах.
В процедуре проверь текущую строку и колонку.
Композитор
3 - 29.05.2004 12:38 		Простой пример
Процедура м_глПриДвойномКликеМышки(Табл) Экспорт
Перем ТекПоз;
Перем ТекКол;
Перем Значение;
Перем Список;
ТекПоз = Табл.ТекущаяСтрока();
Если ТекПоз = 0 Тогда
Возврат;
КонецЕсли;
ТекКол = Табл.ТекущаяКолонка();
Если ТекКол="Пометка" Тогда
Пом = Табл.ПолучитьЗначение(ТекПоз,"Пометка");
Пом = ?(Пом = 1,2,1);
Табл.УстановитьЗначение(ТекПоз,"Пометка",Пом);
ИначеЕсли ТекКол = "Период" Тогда
КолКол = Табл.КоличествоКолонок();
ПрДн = 0;
ПрДК = 0;
Для Индекс = 1 по КолКол Цикл
Если (Табл.ПолучитьПараметрыКолонки(Индекс) = "ДатаНачала") Тогда
ПрДН = 1;
КонецЕсли;
Если (Табл.ПолучитьПараметрыКолонки(Индекс) = "ДатаКонца") Тогда
ПрДК = 1;
КонецЕсли;
КонецЦикла;
Если (ПрДН = 1)И(ПрДК = 1) Тогда
ДатаНачала= Табл.ПолучитьЗначение(ТекПоз, "ДатаНачала");
ДатаКонца= Табл.ПолучитьЗначение(ТекПоз, "ДатаКонца");
ВвестиПериод(ДатаНачала,ДатаКонца);
Табл.УстановитьЗначение(ТекПоз, "ДатаНачала",ДатаНачала);
Табл.УстановитьЗначение(ТекПоз, "ДатаКонца", ДатаКонца);
КонецЕсли;
Иначе
Объект = Табл.ПолучитьЗначение(ТекПоз, ТекКол);
ТипЗнач = ТипЗначенияСтр(Объект);
Если ТипЗнач = "Строка" Тогда
Если ВвестиСтроку(Объект,"Введите значение",256) = 1 Тогда
Табл.УстановитьЗначение(ТекПоз, ТекКол, СокрЛп(Объект));
КонецЕсли;
ИначеЕсли ТипЗнач = "Число" Тогда
Если ВвестиЧисло(Объект,"Введите значение",15,2) = 1 Тогда
Табл.УстановитьЗначение(ТекПоз, ТекКол, Объект);
КонецЕсли;
ИначеЕсли ТипЗнач = "Дата" Тогда
Если ВвестиДату(Объект,"Введите значение") = 1 Тогда
Табл.УстановитьЗначение(ТекПоз, ТекКол, Объект);
КонецЕсли;
ИначеЕсли ТипЗнач = "Перечисление" Тогда
Если ВвестиПеречисление(Объект,"Введите значение") = 1 Тогда
Табл.УстановитьЗначение(ТекПоз, ТекКол, Объект);
КонецЕсли;
ИначеЕсли ТипЗнач = "ТаблицаЗначений" Тогда
ОткрытьФорму("Обработка.М_РедактироватьТЗ",Объект);
ИначеЕсли ТипЗнач = "ТаблицаЗначений" Тогда
ОткрытьФорму("Обработка.М_РедактироватьСЗ",Объект);
ИначеЕсли ТипЗнач = "Справочник" Тогда
ОткрытьФормуМодально(Объект);
ИначеЕсли ТипЗнач = "Документ" Тогда
ОткрытьФормуМодально(Объект);
Иначе
Если ВвестиЗначение(Объект,"Введите значение",ТипЗнач) = 1 Тогда
Табл.УстановитьЗначение(ТекПоз, ТекКол, Объект);
КонецЕсли;
КонецЕсли;
КонецЕсли;

КонецПроцедуры


1с. Идентификатор Таблицы Значений полученной из Списка Значений. | База знаний | mista.ru

1с. Идентификатор Таблицы Значений полученной из Списка Значений.

PilotBrian 13.05.2004 08:20 | Был СЗ (Список Значений), создал ТЗ (Таблица Значений) и выгрузил туда СЗ: Список. Выгрузить(ТЗ); У меня после выгрузки в ТЗ появилась новая колонка. Как мне к ней обратиться? Мне нужно каждое значение. Я могу перелистать все значения: ТВ.ВыбратьСтроки(); Пока ТЗ.ПолучитьСтроку()=1 Цикл //А вот как теперь полученное значение проверить на что либо? КонецЦикла;
SnarkHunter 1 - 13.05.2004 08:26 | ТЗ.ПолучитьЗначение()
mszsuz 2 - 13.05.2004 08:31 | ТЗ._1
PilotBrian 3 - 13.05.2004 08:33 | (1) Ага, понятно. Номер строки делаем в цикле а Колонка цифрой. Спасибки :)


визуальная ТЗ, не работает | База знаний | mista.ru

визуальная ТЗ, не работает

Алексей 07.05.2004 13:40 | есть форма списка справочника ТМЦ, у него существует элемент типа ТЗ. Заполнение ТЗ происходит очень красиво, но курсор по ТЗ не хочет двигаться, вернее двигается только в пределах одной строки по колонкам, а по строкам ни как? Второй день ни с места
Gavrila 1 - 07.05.2004 13:42 | а ТЗ.ТекущаяСтрока(n) где-нибудь в модуле формы не используется случайно, или что-то похожее?
Алексей 4 - 07.05.2004 13:53 | Да, если при заполнении ТЗ, не укажу другую, тогда в той какой укажу
GrayT 7 - 07.05.2004 15:28 | Скорее всего идет постоянное перезаполнение ТЗ. Отладчиком встань на процедуру заполнения


Какой самый быстрый метод удаление строк в ТЗ | База знаний | mista.ru

Какой самый быстрый метод удаление строк в ТЗ

NS
04.10.2004 22:55 		Был конкурс...
http://1c.proclub.ru/modules/mydownloads/personal.php?cid=5&lid=1419
И заглох...
вроде-бы всё решено... самый быстрый метод использует массивы, что не очень хорошо, его можно переделать без использования массивов....
И тут оказалось - что процентов на 10-20 ускорить - легко...
NS
9 - 04.10.2004 23:33 		ИначеЕсли Вариант="NefedovSergey /NS/" Тогда // Nefedov_Sergei@mail.ru
ВсегоСтрок=Тз.КоличествоСтрок(ТЗ.КоличествоСтрок()+2); // добавим строки вспомогательные...
Тз.УстановитьЗначение(ВсегоСтрок+1,"К",максЗнач); //Пропишем туда неудаляемое и удаляемое значения...
Тз.УстановитьЗначение(ВсегоСтрок+2,"К",0);
ТЗ.ВыбратьСтроки(); // найдем первую оставляемую строку
Пока (ТЗ.ПолучитьСтроку()=1)и(УсловиеВыполняется(ТЗ.К)=0) Цикл
КонецЦикла;
НачалоПервогоБлока=Тз.НомерСтроки;
Если НачалоПервогоБлока>ВсегоСтрок Тогда
ТЗ.УдалитьСтроки(); // Значит возвращаемую пустую ТЗ
Иначе // найдем первую удаляемую строку
Пока (ТЗ.ПолучитьСтроку()=1)и(УсловиеВыполняется(ТЗ.К)=1) Цикл
КонецЦикла;
КонецПервогоБлока=ТЗ.НомерСтроки;
Если КонецПервогоБлока>ВсегоСтрок Тогда //До самого конца дошли
ТЗ.УдалитьСтроку(ВсегоСтрок+2);
ТЗ.УдалитьСтроку(ВсегоСтрок+1);
Если началоПервогоБлока>1 тогда
ТЗ.Выгрузить(ТЗ_СЛУЖ,НачалоПервогоБлока);
ТЗ=ТЗ_СЛУЖ;
КонецЕсли;
Иначе // найдем начало следующего блока
ТЗ_Служ=создатьобъект("ТаблицаЗначений");
ТЗ1=создатьобъект("ТаблицаЗначений");
Пока (ТЗ.ПолучитьСтроку()=1)и(УсловиеВыполняется(ТЗ.К)=0) Цикл
КонецЦикла;
НачалоОчередногоБлока=ТЗ.НомерСтроки;
Если НачалоОчередногоБлока>ВсегоСтрок Тогда //В таблице один блок
Если началопервогоблока>1 тогда
ТЗ.Выгрузить(ТЗ_СЛУЖ,НачалоПервогоБлока,КонецПервогоБлока-1);
Иначе
ТЗ.Выгрузить(ТЗ_СЛУЖ,1,1);
ТЗ_СЛУЖ.Количествострок(КонецПервогоБлока-1);
ТЗ_СЛУЖ.Заполнить(ТЗ);
КонецЕсли;
ТЗ=ТЗ_СЛУЖ;
Иначе //Метод количествоСтрок() на уменьшение не использую - он часто работает неверно.
ТЗ.УдалитьСтроку(ВсегоСтрок+2);
ТЗ.УдалитьСтроку(ВсегоСтрок+1);
ТЗ.НоваяКолонка("_Уд");
ТЗ.Заполнить(1,НачалоПервогоБлока,КонецПервогоБлока-1,"_Уд");
ТЗ._Уд=1;
колстр=конецпервогоблока-началопервогоблока+1;
Пока ТЗ.Получитьстроку()=1 Цикл
Если УсловиеВыполняется(ТЗ.К)=1 Тогда
ТЗ._Уд=1;
колстр=колстр+1;
КонецЕсли;
КонецЦикла;
ТЗ.Сортировать("-_Уд");
ТЗ.УдалитьКолонку("_Уд");
ТЗ.Выгрузить(ТЗ_СЛУЖ,1,1);
ТЗ_СЛУЖ.КоличествоСтрок(колстр);
ТЗ_СЛУЖ.Заполнить(ТЗ);
ТЗ=ТЗ_Служ;
КонецЕсли;
КонецЕсли;
КонецЕсли;
строкКода=57;
Иначе
Предупреждение("Неизвестный вариант: "+Вариант,3);
КонецЕсли;


Создание локального меню по нажатию на кнопку | База знаний | mista.ru

Создание локального меню по нажатию на кнопку

List
17.05.2004 13:37 		Как создать локальное меню, как это делает фирма «1С» в своих типовых конфигурациях, например, когда нажимаешь на кнопку «Действия» в конфигурации ЗиК, то появляется меню в котором можно выбирать необходимые действия.
Композитор
1 - 17.05.2004 13:59 		Простой пример
//*****************************************************************************
Процедура ПоКнопкеЗаполнить()
Перем Ф;
Если ТаблНоменклатура.КоличествоСтрок() <> 0 Тогда
Если Вопрос("Перед заполнением табличная часть будет очищена!", "Да+Нет", 60) <> "Да" Тогда
Возврат;
КонецЕсли;
КонецЕсли;
ТаблНоменклатура.УдалитьСтроки();
СпособЗаполнения = СоздатьОбъект("СписокЗначений");
СпособЗаполнения.ДобавитьЗначение("По заявкам");
СпособЗаполнения.ДобавитьЗначение("Из справочника все");
СпособЗаполнения.ДобавитьЗначение("Из справочника ненулевые продажи");
Если СпособЗаполнения.ВыбратьЗначение(Ф, , , 60, 1) = 1 Тогда
Если Ф = "По заявкам" Тогда
ЗаполнениеПоЗаявкам();
ИначеЕсли Ф = "Из справочника все" Тогда
ЗаполнениеИзСправочникаВсе();
ИначеЕсли Ф = "Из справочника ненулевые продажи" Тогда
ЗаполнениеПоФильтру();
КонецЕсли;
КонецЕсли;
КонецПроцедуры //ПоКнопкеЗаполнить()


Как получить текущее значение выпадающего списка??? | База знаний | mista.ru

Как получить текущее значение выпадающего списка???

VaS 26.07.2004 11:24 | В общем при любом действии юзера на форме, вызывается функция из глобального модуля. В неё передаётся параметром её контекст и имеется список реквизитов формы, который при вызове функции, обходится циклом и получаются текущие значения реквизитов формы. ЗначениеИзСтрокиВнутр(Шаблон("[ЗначениеВСтрокуВнутр("+ТекРеквизит+")]")) // Взято из FAQ Вот блин везде работает, а с выпадающим списком не хочет (может и с др. структурными элементами... не знаю, не пробовал). Получаеся сам список без намёков на текущую строку и т.п. Помогите победить...
VaS 4 - 26.07.2004 12:46 | Конт.Форма.ПолучитьАтрибут(ТекРеквизит).???? Что дальше? ТекущаяСтрока()???
Diter 5 - 26.07.2004 12:53 | Если ТекРеквизит.Вид="СписокЗначений" Тогда Конт.Форма.ПолучитьАтрибут(ТекРеквизит.ПолучитьЗначение(ТекРеквизит.ТекущаяСтрока())). Иначе Конт.Форма.ПолучитьАтрибут(ТекРеквизит).
SiMazx 6 - 26.07.2004 12:57 | ТекРеквизит.Вид()
VaS 8 - 26.07.2004 13:00 | Сорри, я кажется говорил, что ТекРеквизит берётся из списка реквизитов. Так что ТипЗначенияСтр(ТекРеквизит)="Строка" ...всегда
OctoberHammer 9 - 26.07.2004 13:03 | Если это форма првязанная к объекту метаданных, тогда так: Метаданные.Справочник(Вид()).Реквизит(ТекРеквизит).Тип
Diter 10 - 26.07.2004 13:04 | Так занеси его в этот список так : СписокРеквизитов.ДобавитьЗначение(Реквизит.Вид(),Реквизит) Потом будешь получать и раскладывать на вид реквизита и наименование реквизита.
VaS 11 - 26.07.2004 13:12 | Ну, для начала, (9) это не справочник, а отчёт. (10) Вид реквизита получить легко... ТипЗначенияСтр(ЗначениеИзСтрокиВнутр(Шаблон("[ЗначениеВСтрокуВнутр("+ТекРеквизит+")]"))) Мне бы значение его получить, вернее значение из текущей строки списка.
Diter 15 - 26.07.2004 13:29 | ТипЗначения=ТипЗначенияСтр(ЗначениеИзСтрокиВнутр(Шаблон("[ЗначениеВСтрокуВнутр("+ТекРеквизит+")]"))) или как там ешё короче получаешь ТипЗначения как строку вида "ТаблицаЗначений" или "СписокЗначений" или "Число" и т.д. Если ТипЗначения="СписокЗначений" Тогда Конт.Форма.ПолучитьАтрибут(ТекРеквизит.ПолучитьЗначение(ТекРеквизит.ТекущаяСтрока())). Иначе Конт.Форма.ПолучитьАтрибут(ТекРеквизит).
VaS 16 - 26.07.2004 13:35 | ТекРеквизит - СТРОКА, а у строки кажется нет метода "ПолучитьЗначение()" и т.п.
Diter 17 - 26.07.2004 13:39 | Повторю ещё раз для тех кто на бронепоезде : Когда ты проверяешь ТИПЗНАЧЕНИЯ и оно раво "СПИОКЗНАЧЕНИЙ" то пользуешься Конт.Форма.ПолучитьАтрибут(ТекРеквизит.ПолучитьЗначение(ТекРеквизит.ТекущаяСтрока())). ВО ВСЕХ ОСТАЛЬНЫХ СЛУЧАЯХ Конт.Форма.ПолучитьАтрибут(ТекРеквизит). Если это не понятно - вызывай нормального программиста.
Diter 18 - 26.07.2004 13:43 | А чтобы у тебя ТЕКУЩИЙРЕКВИЗИТ был вида "СПИСОКЗНАЧЕНИЙ" а не "строка" создавай список как я тебе сказал в (10) Да кстати вопрос - а на кой тебе этот самый список реквизитов? Пробежать все реквизиты документа можно и без промежутночного списка реквизитов. Или ты его создаёшь отдельно и вносишьтуда только те реквизиты, которые нужно обрабатывать? Так тем более делай как в (10)
VaS 19 - 26.07.2004 13:53 | С перона, мимо проносящимся, отвечаю... Из списка заначений, содержащего строки с идентификаторами реквизитов формы. В цикле они последовательно выбираются и... Если ТипЗначенияСтр(ЗначениеИзСтрокиВнутр(Шаблон("[ЗначениеВСтрокуВнутр("+ТекРеквизит+")]")))="СписокЗначений" Тогда // Это уже тот, который на форме //Здесь мне надо получить значение текущей строки или её номер имея контекст формы и строку с идентификатором реквизита Конт.Форма.ПолучитьАтрибут(ТекРеквизит) даёт ссылку на реквизит, как на объект метаданных. Т.е. я могу оперировать только со свойствами этого реквизита, но не с его значением. Либо могу получить весь список (из реквизита), без намёка на то, какая строка является текукщей... Все эти действия выполняются в глобальном модуле. И у строки нет метода "ПолучитьЗначение()" и ему подобных.
GrayT 21 - 26.07.2004 14:08 | Извращенцы :)) Путаете божий дар с яишницей :) Две обработки. У первой на форме "МойСЗ" и кнопка открывающая вторую обработку 1 - модуль //_____________________________________________________________________________ Процедура ОткрытьОбработку() сз = СоздатьОбъект("СписокЗначений"); сз.ДобавитьЗначение(Контекст, "Контекст"); сз.ДобавитьЗначение("МойСЗ", "МойСЗ"); ОткрытьФорму("Обработка.Новый1", сз); КонецПроцедуры //ОткрытьОбработку Для сч = 1 по 10 Цикл МойСЗ.ДобавитьЗначение("Строка"+сч) КонецЦикла; 2 - модуль Процедура ПриОткрытии() Конт = Форма.Параметр.Получить("Контекст"); Рекв = Форма.Параметр.Получить("МойСЗ"); Сообщить(ЗначениеИзСтрокиВнутр(Шаблон("[ЗначениеВСтрокуВнутр(Конт."+Рекв+".ТекущаяСтрока())]"))) ; КонецПроцедуры //ПриОткрытии А извращенцы потому что проще передать не идентификаторы реквизитов, а сами реквизиты
Diter 22 - 26.07.2004 14:10 | (19) "Конт.Форма.ПолучитьАтрибут(ТекРеквизит) даёт ссылку на реквизит, как на объект метаданных. Т.е. я могу оперировать только со свойствами этого реквизита, но не с его значением. Либо могу получить весь список (из реквизита), без намёка на то, какая строка является текукщей... Все эти действия выполняются в глобальном модуле. И у строки нет метода "ПолучитьЗначение()" и ему подобных" У тебя же есть контекст формы. Ну так и запроси из него текущую строку списка и заодно текущее занчение списка. Ты скажи - вместо того, чтобы здесь по пять раз рассказывать - ты пробовал или нет настучать этот код? Чего пишет в отладчике?


как программно выбрать элемент спискаЗначений типа "Выпадающий список" ? | База знаний | mista.ru

как программно выбрать элемент спискаЗначений типа "Выпадающий список" ?

Crystalizer 21.06.2004 15:31 | а то шото как-то не выбирается...
Рупор абсурда 1 - 21.06.2004 15:33 | Список.ПолучитьЗначение(Список.ТекущаяСтрока())


Список значений в таблице значений | База знаний | mista.ru

Список значений в таблице значений

ander139
21.05.2004 10:09 		Есть таблица значений. В каждой строке такой таблицы я делаю одну ячейку, содержащую список значений. Потом считываю эти списки, а они все такие же, как и последний введенный.
Может быть кто-нибудь встречался с похожей ситуёвиной?
SnarkHunter
3 - 21.05.2004 10:25 		Ты их не присваиванием, а через выгрузить()...
mike
8 - 21.05.2004 13:15 		правильно работает такой вариант :

ТЗ.НоваяСтрока();
спис = СоздатьОбъект("СписокЗначений");
// заполняем список
.....
ТЗ.спис = спис;
mike
11 - 21.05.2004 13:27 		пробовал и списки и таблицы значений туда засовывал , все прекрасно работает.
Bzzzzz
13 - 21.05.2004 13:31 		(12) Я так же помещал Таблицы.
Причем можно обращаться тз.Табл.ВывестиСекцию(..)
lexa
15 - 21.05.2004 13:42 		(13) со списком присваивание точно не пройдет, я так сделал, а потом долго удивлялся, прада я просто переменную использовал. Но SnarkHunter прав - при присваивании создается ссылка на список.
lexa
16 - 21.05.2004 13:44 		ТЗ.НоваяСтрока();
спис = СоздатьОбъект("СписокЗначений");
// заполняем список
.....
спис.Выгрузить(ТЗ.спис) ;
Bzzzzz
17 - 21.05.2004 13:48 		тз=СоздатьОбъект("ТаблицаЗначений");
тз.НоваяКолонка("сз");

Для Ном=1 По 5 Цикл
сз=СоздатьОбъект("СписокЗначений");
сз.ДобавитьЗначение(""+Ном+" = 1");
сз.ДобавитьЗначение(""+Ном+" = 2");
тз.НоваяСтрока();
тз.сз=сз;
КонецЦикла;

тз.ВыбратьСтроки();
Пока тз.ПолучитьСтроку() = 1 Цикл
Для Ном=1 По тз.сз.РазмерСписка() Цикл
Сообщить(тз.сз.ПолучитьЗначение(Ном));
КонецЦикла;
КонецЦикла;
lexa
18 - 21.05.2004 13:52 		ТЗ.НоваяСтрока();
спис = СоздатьОбъект("СписокЗначений");
// заполняем список
.....
ТЗ.спис = СоздатьОбъект("СписокЗначений");
спис.Выгрузить(ТЗ.спис) ;
SnarkHunter
19 - 21.05.2004 13:52 		И что?
Ты сделай в ТЗ хотя бы 2 строки, в которых разные списки...
Bzzzzz
21 - 21.05.2004 13:57 		(20) не понял тебя?
в ТЗ 5 строк, в каждой свой СЗ, со своими значениями
Bzzzzz
22 - 21.05.2004 14:03 		Результат работы кода (17)
1 = 1
1 = 2
2 = 1
2 = 2
3 = 1
3 = 2
4 = 1
4 = 2
5 = 1
5 = 2
SnarkHunter
23 - 21.05.2004 14:04 		Недоглядел... Строк действительно 5, вот только значения в Сз одинаковые для всех строк... Попробуй сделать разные...
lexa
28 - 21.05.2004 14:26 		(25) Да все правильно
тз=СоздатьОбъект("ТаблицаЗначений");
тз.НоваяКолонка("сз");

Для Ном=1 По 5 Цикл
сз=СоздатьОбъект("СписокЗначений");
сз.ДобавитьЗначение(""+Ном+" = 1");
сз.ДобавитьЗначение(""+Ном+" = 2");
тз.НоваяСтрока();
тз.сз=сз;
КонецЦикла;

тз.ВыбратьСтроки();
Пока тз.ПолучитьСтроку() = 1 Цикл
Для Ном=1 По тз.сз.РазмерСписка() Цикл
Сообщ =Строка(тз.НомерСтроки) + " " +Строка(Ном)+ " " + тз.сз.ПолучитьЗначение(Ном);
Сообщить(Сообщ);
КонецЦикла;
КонецЦикла;
Получил
1 1 1 = 1
1 2 1 = 2
2 1 2 = 1
2 2 2 = 2
3 1 3 = 1
3 2 3 = 2
4 1 4 = 1
4 2 4 = 2
5 1 5 = 1
5 2 5 = 2
SnarkHunter
29 - 21.05.2004 14:27 		У тебя в КАЖДОЙ строке ТЗ ОДИН И ТОТ ЖЕ список...
Bzzzzz
33 - 21.05.2004 14:38 		(32) Сделай так и посмотри значения в списках :-))
тз.ВыбратьСтроки();
Пока тз.ПолучитьСтроку() = 1 Цикл
Зн="";
тз.сз.ВыбратьЗначение(Зн);
//Для Ном=1 По тз.сз.РазмерСписка() Цикл
// Сообщить(тз.сз.ПолучитьЗначение(Ном));
//КонецЦикла;
КонецЦикла;
Bzzzzz
34 - 21.05.2004 14:41 		Для Ном=1 По 5 Цикл
сз=СоздатьОбъект("СписокЗначений");
сз.ДобавитьЗначение(""+Ном+" = 1");
сз.ДобавитьЗначение(""+Ном+" = 2");
Если Ном%2=0 Тогда
сз.ДобавитьЗначение(""+Ном+" = 3");
КонецЕсли;
тз.НоваяСтрока();
тз.сз=сз;
КонецЦикла;
вот тебе разный размер списков :-))
lexa
35 - 21.05.2004 14:41 		(29) Для каждой строки ТЗ Bzzzzz создает каждый раз новый список значений.
сз=СоздатьОбъект("СписокЗначений"); - находится внутри цикла заполнения ТЗ.
ChAlex
39 - 25.05.2004 16:56 		Я делаю так (и ни каких проблем нет)!
Т=СоздатьОбъект("ТаблицаЗначений");
Т.НоваяКолонка("Спис");
Для А=1 По ... Цикл
Т.НоваяСтрока();
Т.Спис=СоздатьОбъект("СписокЗначений");
Для К=1 По ... Цикл
Т.Спис.Добавить(НекоеЗначение);
КонецЦикла;
КонецЦикла;
spock
41 - 25.05.2004 20:37 		Религиозно неверно делать присваивание СпискаЗначений или ТаблицыЗначений. Правильно делать Выгрузить().
А для прикола сделайте коррективы в примере (34):
Для Ном=1 По 5 Цикл
сз = СоздатьОбъект("СписокЗначений");
сз.ДобавитьЗначение(""+Ном+" = 1");
сз.ДобавитьЗначение(""+Ном+" = 2");
Если Ном%2=0 Тогда
сз.ДобавитьЗначение(""+Ном+" = 3");
КонецЕсли;
тз.НоваяСтрока();
тз.сз=сз;
сз = ""; << ====
КонецЦикла;
NiGMa
53 - 27.05.2004 09:42 		Я такую ситуацию обхожу проще:
тз.Список = ЗначениеВСтрокуВнутр(сз);

Ну и соотв. назад:

сз = ЗначениеИзСтрокиВнутр(тз.Список);
SnarkHunter
54 - 27.05.2004 09:43 		Это вовсе не проще...


У меняВ Расшифровке обычная переменная - передается, а список значений нет? | База знаний | mista.ru

У меняВ Расшифровке обычная переменная - передается, а список значений нет?

MC 01.05.2004 00:29 | В процедуре Сформировать при выводе ячеек таблицы вставляю код: Список.Установить("Контрагент",Контрагент); Список.Установить("Договор",Договор); Сообщить(Список.Получить("Договор")); Сообщить(Список.Получить("Контрагент")); Все пар-ры сообщаются верно. В процедуре ОработкаЯчейкиТаблицы пишу: Процедура ОбработкаЯчейкиТаблицы(Зн,Фл) Фл=0; Если ТипЗначенияСтр(Зн)="СписокЗначений" Тогда Дог=Зн.Получить("Договор"); Сообщить("Вот: "+Строка(Дог)); КонецЕсли; КонецПроцедуры Выводится "Вот" и пустая строка, а если передавать обычную переменую - то все ок. Гляньте, где я накосячил
GrayT 1 - 01.05.2004 09:25 | На первй взгляд все нормально. Список значений у тебя передался, да вот со значением Договор что то не так. Проверь Сообщить(ТипЗначенияСтр(Дог)) Возможно где-нить латинские буквы затесались


Интерфейс группировки строк документа | База знаний | mista.ru

Интерфейс группировки строк документа

Perepechin 04.06.2004 20:53 | Нужно в строках документа дать возможность группировки строк, например, сгруппировать товары: - в строках по группам; в колонках - по дням, неделям, месяцам ("плюсики" слева от строк по аналогии с отчетами). На пересечении группировок необходимо выводить соответствуующие числовые значения по группе. Например, такой интерфейс удобно применять в системах планирования и бюджетирования. Аналогичный пример - группировка строк и колонок в Excel (очень удобно!). Есть идеи, как это лучше сделать?
Perepechin 2 - 04.06.2004 20:56 | 8-ка, конечно
Волшебник 3 - 04.06.2004 21:01 | Тогда можно табличное поле связать с деревом значений. Еще можно не мучать табличное поле, а сделать нормальный табличный документ.
Perepechin 5 - 04.06.2004 21:04 | А в УТ где-нибудь документ с таким интерфейсом живет? Кто знает, дайте ссылку по меню, плз.
¶ 6 - 04.06.2004 21:07 | (3) Если в гриде, то с группировкой колонок гемор будет. Нужно ведь, чтобы интерфейсный элемент +/- был жестко связан с колонкой и перемещался вместе с ней.
Perepechin 7 - 04.06.2004 21:13 | Вот реальная задача - делаю документ "План продаж" (свой вариант, не так, как в УТ). В строках нужно отобразить: группы (иерархия), товары. Нужна возможность сворачивать и разворачивать строки. В колонках нужно отобразить дни планирования (например, за январь месяц). Итого получается 31 колонка. Нужна возможность сворачивать колонки по неделям, по декадам. Ввод в документ должен быть табличным (полная аналогия с Excel). Можно +/- заменить на какое-либо действие, вызываемое по кнопке, это не принципиально. Главное поулчить группировку и итоговые значения на пересечениях.
¶ 8 - 04.06.2004 21:16 | (7) А почему нельзя просто положить ЭУ "Табличный документ" на форму и работать с ним?
Волшебник 9 - 04.06.2004 21:17 | (7)+ "Поле табличного документа".
¶ 10 - 04.06.2004 21:56 | Попробовал сейчас: положил на форму ActiveX MS Office Spreadsheet. Получается - Excel в форме 1С. Управляется программно вполне хорошо. Так что выход есть накрайняк, можно запрограммировать поведение элемента - листа Excel.
Волшебник 11 - 04.06.2004 22:37 | (10) Я тоже его пробовал, хорошо работает. Можно даже перейти ActiveX в полноценный Excel, поработать там, а потом через буфер обмена перекинуть обратно.
¶ 12 - 04.06.2004 22:49 | (11) Да, но похоже, этот элемент с группировками... того... не работает... Это же не полноценный Worksheet. Так что совет свой отзываю.


раздвинуть ячейку таблицы | База знаний | mista.ru

раздвинуть ячейку таблицы

makhnov 09.09.2004 11:40 | как сделать, чтобы, если текст не умещается в ячейке она бы раздвигалась вниз (ну всмысле увеличивалась высота строки)?
SnarkHunter 1 - 09.09.2004 11:41 | Высоту строки поставь АВТО и контроль - переносить
Мдя 5 - 09.09.2004 12:18 | (1,3) А у меня высота строки - "Авто", контроль - "Переносить" ..., а строки не раздвигаются ... Почему?
Мдя 8 - 09.09.2004 12:35 | (7)+ Ааааа ... Всё! Понял! ... Объединённая по вертикали ячейка не раздвигается ... SnarkHunter, спасибо!


Полосы прокрутки в форме | База знаний | mista.ru

Полосы прокрутки в форме

SKrin 28.08.2004 12:05 | Создал форму документа при разрешении экрана 1024*768 - все помещалось впритык Поставил конфу клиенту, а у него разрешение 800*600 - и поэтому многие важные элементы формы не помещаются. Вопрос: ГДЕ ПОЛОСЫ ПРОКРУТКИ? Есть ли они вообще при таких ситуациях. Может я где-то галочку не поставил? Подскажите плз.
SKrin 16 - 28.08.2004 12:53 | После долгих и тщательных поисков на других форумах я всетаки нашел ответ http://1c.realnet.ru/kuban/137218.html


Как программно открыть форму ввода нового элемента справочника? | База знаний | mista.ru

Как программно открыть форму ввода нового элемента справочника?

Александр 05.08.2004 12:58 | Помогите, не могу сам дойти :( Как программно открыть форму ввода нового элемента справочника? Хотелось бы подобное вводу нового документа: Пример из здешнего описания- ОткрытьФорму("Документ.ПриемНаРаботу",Конт); //новый документ А вот как сделать так, что бы вводился новый элемент справочника, а не открывалась форма списка справочника?
lexa 18 - 05.08.2004 13:53 | (13) спасибо ОткрытьФорму("Элемент.НужныйТебеСправочник");


Как в Форме Списка подчиненного справочника получить ссылку на владельца... | База знаний | mista.ru

Как в Форме Списка подчиненного справочника получить ссылку на владельца...

Alexis 20.07.2004 19:00 | ... если подчиненный пуст ?
GrayT 7 - 20.07.2004 20:33 | ИспользоватьВладельца();


контекст, переменная... | База знаний | mista.ru

контекст, переменная...

Crystalizer
21.07.2004 17:52 		нужно чтобы в форме подчинённого справочника читалась переменная формы вызываюшего справочника. переменная объявлена в тексте, в диалоге её нет.
не получается :(

в форме справочника есть "глобальная" переменная "действие".

делаю такой вызов:

действие = 1; // 1= добавить
ОткрытьФормуМодально("Элемент.ТМЦЦиС", Контекст,,, ТекущийЭлемент());

в вызываемой форме

читаю:
конт = Форма.Параметр;
если конт.действие = 1 Тогда
....

и вот тут выдает:
если конт.действие = 1 Тогда
{Справочник.ТМЦЦиС.Форма.Модуль(13)}: Поле агрегатного объекта не обнаружено (действие)

КАк правильно это сделать?
It is me
1 - 21.07.2004 18:12 		Правильно
1) или объявить "действие" глобальной переменной и обращаться если действие = 1 Тогда
2) Вместо ОткрытьФормуМодально("Элемент.ТМЦЦиС", Контекст,,, ТекущийЭлемент());
ОткрытьФормуМодально("Элемент.ТМЦЦиС", действие,,, ТекущийЭлемент());
и обращаться Форма.Параметр
3) Или Списочек = СоздатьОбъект("СписокЗначений");
Списочек.ДобавитьЗначение(Действие);
Списочек.ДобавитьЗначение(Контекст);
ОткрытьФормуМодально("Элемент.ТМЦЦиС", Списочек,,, ТекущийЭлемент());
и там уже разбирать список значений на составляющие...
wolk
2 - 21.07.2004 18:13 		Если эта переменная глобальная, то надо писать просто "если действие = 1 Тогда" и всё будет работать.


Параметры формы | База знаний | mista.ru

Параметры формы

hook 16.07.2004 12:12 | Подскажите пож-та каким образом можно передать параметры из вызываемой формы в вызывающую после закрытия вызываемой. Т.е. из первой формы вызываю вторую форму. Как из второй формы вернуть что-то в первую.
laeg 1 - 16.07.2004 12:15 | Через контекст формы ОткрытьФорму(<?>,,) Синтаксис: ОткрытьФорму(<Документ>,<КонтекстФормы>,<РежимПросмотра>) Назначение: Открывает визуальную форму существующего документа или элемента/группы справочника. Возвращает: 1 - если действие выполнено, 0 - иначе. Параметры: <Документ> - выражение со значением типа 'документ'; <КонтекстФормы> - имя переменной, куда можно задать значение любого типа для передачи в открываемую форму. Данное значение будет доступно в открытой форме как атрибут Форма.Параметр. После исполнения данного метода система вернет в данную переменную контекст открытой формы (необязателен);
hook 2 - 16.07.2004 12:30 | а как из элемента диалога первой формы (например текст) прочитать возвращаемый <КонтекстФормы>? СЗ = Форма.Параметр не получается
hook 4 - 16.07.2004 12:40 | СЗ - список значений
Рупор абсурда 5 - 16.07.2004 12:42 | (4) Тогда не СЗ = Форма.Параметр , а Форма.Параметр.Выгрузить(СЗ) ...
laeg 6 - 16.07.2004 12:49 | Можно проще Форма.Параметр.ПолучитьЗначение() .... и т.д. оперировать так же как и со список значений, только предварительно проверить тип параметра


Показать несколько фото | База знаний | mista.ru

Показать несколько фото

Вик
09.07.2004 18:14 		Имею обработку "ПоказатьФотоТовара",
на форме элемент Фото типа картинка,
Для показа отрабатывает команда
Фото.Загрузить(КаталогФотографий+СокрЛП(ФайлФото));
Хочу показать Фото товара1, затем перейти к товару2 и показать его фото (Смотреть сразу на 2 фотографии)
Но не могу - вижу все время только товар1 в одном окне (Вызов формы не модальный)
Может ли кто предложить, как показать обе картинки для сравнения?
Asmody
1 - 09.07.2004 18:19 		как обработка выбирается?
Вик
6 - 09.07.2004 18:36 		Параметр.ДобавитьЗначение(Фотография,"ТекЭлемент);
ОткрытьФорму("Обработка.ПоказатьФото",Параметр);
Asmody
7 - 09.07.2004 18:44 		(6) так пробовал:
ОткрытьФорму("Обработка.ПоказатьФото#",Параметр);
Вик
9 - 09.07.2004 19:22 		Большое спасибо, помогло.
Не пояснишь ли смысл этой решетки в контексте?
427
10 - 09.07.2004 20:14 		# - открыть новую форму, а не перезаполнять имеющуюся...


Внешний отчет, как закрыть форму при нажатии кнопки печать | База знаний | mista.ru

Внешний отчет, как закрыть форму при нажатии кнопки печать

Druid_A
02.07.2004 14:46 		Печатаю ценники через внешние обработки, подскажите, как сделать чтобы при нажатии кнопки печать, форма из которой произведено нажатие автоматом закрылась, процедура работала как надо.
Для того чтобы после печати заново вызывать процедуру, а не попадать в старую форму
Crystalizer
1 - 02.07.2004 14:54 		можешь написать в конце процедуры что то типа "Закрыть();" или "Закрыть;"
не помню точно
такое есть во многих стандартных
посмотри хелп по "закрыть" если не получится
SnarkHunter
2 - 02.07.2004 14:56 		Форма.Закрыть(0)
Druid_A
3 - 02.07.2004 15:21 		Спасибо! Помогло!!!
___________________
Тогда встречный вопрос! Как перетащить список наминклатуры из приходной накладной во внешний отчет?
всякую ересь туда переносит, но не то что надо! Может есть где готовое решение?
gr13
5 - 02.07.2004 15:37 		много способов есть... например перебором строк...
или ВыгрузитьТабличнуюЧасть... книга 1 стр. 280 ЖКК...
Warlock
7 - 02.07.2004 20:56 		Если ДокПриходнаяНакладная - это нужный документ, то
ДокПриходнаяНакладная.ВыбратьСтроки();
Пока ДокПриходнаяНакладная.ПолучитьСтроку() = 1 Цикл
//Обработка для ДокПриходнаяНакладная.Номенклатура
КонецЦикла;


Не работает ПЕРЕКЛЮЧАТЕЛЬ на закладке ДИАЛОГ в форме ДОКУМЕНТ. | База знаний | mista.ru

Не работает ПЕРЕКЛЮЧАТЕЛЬ на закладке ДИАЛОГ в форме ДОКУМЕНТ.

Дык 28.06.2004 16:11 | 1с77 Предприятие 12 релиз. Бухгалтерия ред3… Платежное поручение. Есть переключатель срочности платежа «Обычный» или «Срочный». Потребовалось добавить еще одну позицию «SWIFT». Думал застрелюсь. Не могу выбрать нужный тип срочности. То две кнопки светятся, то одна не «гаснет», а в печатной форме всегда стоит галочка на «Обычный». Поиск информации в «Описание встроенного языка» в ЖКК в предметном указателе «Переключатель», «Диалог», «Форма» результатов не дали. Может быть я не там искал. Решение: Оказывается, необходимо, что бы порядок обхода переключателей в группе был СТРОГО ОПРЕДЕЛЁННЫМ, т.е., например: Имя группы 5, ПервыйПереключатель 6, ВторойПереключатель 7, ТретийПереключатель и т.д. Кстати, может кто подскажет, где же в предметном указателе надо искать описание переключателя.
Волшебник 1 - 28.06.2004 16:24 | Все написано здесь: http://www.mista.ru/tutor_1c/configurator.htm#formeditor


ОткрытьФорму(,Конт) не могу достучатся до контекста открытой формы.... | База знаний | mista.ru

ОткрытьФорму(,Конт) не могу достучатся до контекста открытой формы....

AlexMan 21.06.2004 15:31 | Код работает: ОткрытьФорму("Отчет.УчетМПЗ",Конт); Конт.Активизировать("КнопкаБольшеУсловие2"); (действительно активизирует Кнопку) Код не работает: ОткрытьФорму("Отчет.УчетМПЗ",Конт); Сообщить(Конт.КнопкаБольшеУсловие2.Видимость()); выдает ошибу: Значение не представляет агрегатный объект (КнопкаБольшеУсловие2) почему в одном случае комп понимает КнопкаБольшеУсловие2 а в другом нет?
Рупор абсурда 1 - 21.06.2004 15:32 | Сообщить(Конт.ФОРМА.КнопкаБольшеУсловие2.Видимость());


как добавить воможность выбора группы из справочника при создании отчета | База знаний | mista.ru

как добавить воможность выбора группы из справочника при создании отчета

Aiuan 16.06.2004 10:26 | как добавить воможность выбора группы из справочника при создании отчета
mszsuz 1 - 16.06.2004 10:31 | Форма.ТвойРеквизит.ВыборГруппы(1);


Использование формулы в реквизите диалога для ввода | База знаний | mista.ru

Использование формулы в реквизите диалога для ввода

Sweet
10.06.2004 07:47 		Есть задача: после ввода пользователем строки символов и нажатия Enter осуществить проверку строки на эталон и в случае совпадения выполнить метод ОткрытьФорму() и закрыть форму, иначе метод Активизировать("СтрокаВвода"), чтобы вернуть фокус на строку ввода.
Для решения используется внешний отчет на диалог которого "кладется" реквизит диалога для ввода строки. В формуле данного реквизита прописывается вызов функции.
Но использование методов ОткрытьФорму() и Активизировать() недопустимо в формулах.
Проблему с методом ОткрытьФорму() удалось решить путем размещения его в процедуре ПриЗакрытии с передачей соответствующего параметра через переменную модуля.
Осталось решить, как вернуть фокус в строку, точнее сделать ее содержимое "выделенным", чтобы при наборе символов существующий текст исчез.
Использование метода ВвестиСтроку (и подобных) неприемлимо, т.к. строка предназначена для ввода пароля.
Использование дополнительной кнопки типа "Найти" неприемлимо, т.к. заставляет пользователя дважды жать Enter.
Буду благодарен за любое решение данной задачи, средствами 1С, ВК, или собственное видение.
SnarkHunter
1 - 10.06.2004 07:58 		Активизировать() можно использовать в формулах... Через гланды, но можно...
Sweet
2 - 10.06.2004 10:56 		Если можно поподробней, пожалуйста.
Пишу в формуле реквизита диалога Активизировать("СтрокаВвода") в ответ: В данной формуле не может быть вызвана эта процедура(функция).
SnarkHunter
3 - 10.06.2004 11:07 		http://www.sinor.ru/~my1c/knowhow/getskod.html


V8: Составной тип данных | База знаний | mista.ru

V8: Составной тип данных

Алексей 08.06.2004 21:18 | Имеем: Справочник \"Материалы\", Справочник \"Номенклатура\", Документ \"ПеремещениеТМЦ\". У документа имеется реквизит шапки \"ВидПеремещения\" имеющий тип \"ПеречислениеСсылка.ВидыПеремещений\" (перемещение номенклатуры или Материалов) У документа имеется табличная часть у которой есть реквизит \"ТМЦ\" имеющий составной тип данных (либо Справочник.Материалы либо Справочник.Номенклатура) Вопрос: Как программно сделать так, чтобы в зависимости от значения реквизита \"ВидПеремещения\" в реквизите \"ТМЦ\" происходил выбор либо из справочника материалов либо из справочника номенклатуры? (В 7-ке это можно было сделать с помощью \"НазначитьВид()\", но в 8-е как я понял такого нет в принципе)
Волшебник 1 - 08.06.2004 21:20 | Лучше бы у тебя был один справочник "Номенклатура", а в нем группа "Материалы".
¶ 2 - 08.06.2004 21:37 | (+1) Или сделай "Перемещение" не перечислением, а планом видов характеристик. Тогда тип характеристики (ТМЦ) можно будет приводить к типу, связанному с видом характеристики (Материалы либо Номенклатура). См. в УТ, там есть образцы.
ezh 3 - 09.06.2004 01:44 | На колонку табличной части надо накладывать ОграничениеТипа + при добавлении новой строки (и при смене реквизита ВидПеремещения) надо приводить значение к нужному типу. Вот тут это все подробно расписано: http://itland.ru/forum/index.php?showtopic=2577 За разъяснениями (если понадобятся) сюда: http://itland.ru/forum/index.php?showforum=5


Как проверить наличие кнопки на форме | База знаний | mista.ru

Как проверить наличие кнопки на форме

Serg73 09.06.2004 10:16 | Подскажите, пожалуйста, как проверить наличие кнопки на форме? Есть какое-то количество документов у кажого своя форма, и свои кнопки. Мне нужно запретить определенную кнопку, если она есть в форме этого документа. Процедура должна быть глобальная. Заранее благодарю. Serg
Gavrila 1 - 09.06.2004 10:24 | в глобальнике, Конт - контекст документа: Функция глЕстьКнопкаНаФорме(Конт) Попытка Конт.Форма.НужнаяКнопка.Доступность(); Возврат 1; Исключение Возврат 0; КонецПопытки; КонецФункции
Rom 2 - 09.06.2004 10:26 | (0) В 8-ке можно перебрать коллекцию элементов формы.
SnarkHunter 4 - 09.06.2004 10:28 | (1)Не взлетит... Ибо у тебя не параметризован идентификатор элемента диалога...
Gavrila 5 - 09.06.2004 10:29 | +(1)Функция глЕстьКнопкаНаФорме(Конт) Экспорт :)
mszsuz 10 - 09.06.2004 11:04 | (8) А почему бы не довести до универсальной? ... глЕстьКнопкаНаФорме(Конт,ИдентификаторКнопки) Экспорт ... Конт.Форма.ПолучитьАтрибут(ИдентификаторКнопки).Доступность();


Обработка событий в 8-ке | База знаний | mista.ru

Обработка событий в 8-ке

SergeF 08.06.2004 08:54 | Возможно ли интерфейсному объекту на форме назначить обработчик события находящийся в другом (общем) модуле?
¶ 2 - 08.06.2004 09:08 | Нельзя. Процедура обработчика должна находиться в модуле формы.
ezh 5 - 08.06.2004 16:09 | че тут знать? обработчики элементов форм могут находиться только в модуле этих форм. об этом явно написано в документации. зы: хотя есть небольшое ислючение, точнее фича, но о ней щас не будем.
Rom 6 - 08.06.2004 16:35 | Обработчик события находится в модуле формы, а вот сама процедура или функция может находится в разх местах. Процедура КнопкаВыполнитьНажатие(Элемент) ВыболнитьДействие(); КонецПроцедуры


В данной формуле не может быть вызвана эта процедура(функция) | База знаний | mista.ru

В данной формуле не может быть вызвана эта процедура(функция)

OctoberHammer
07.06.2004 20:09 		Процедура ИзмВремяС()
Часов = Лев(ВремяС,2);
Минуты = Прав(ВремяС,2);
Если (Число(Часов)>23) или (Число(Часов)<0) или (Число(Минуты)<0) или (Число(Минуты)>59) Тогда
глАктивизировать(Контекст,"ВремяС");
КонецЕсли;
КонецПроцедуры
==========\
Процедура глАктивизировать(Конт, ИмяРеквизита) Экспорт
Конт.Активизировать(ИмяРеквизита);
КонецПроцедуры
{Глобальный модуль(38)}: В данной формуле не может быть вызвана эта процедура(функция)
==========================
Как побороть? Если смысл не понятен, скажите, или задайте наводящие вопросы, я намкну
Волшебник
1 - 07.06.2004 20:20 		Вот способ обхода этого ограничения платформы:

// глобальный модуль
Процедура глАктивизироватьПоле(Конт, Поле) Экспорт
Сп=СоздатьОбъект("СписокЗначений");
Сп.Установить("Контекст", Конт);
Сп.Установить("Поле", Поле);
ОткрытьФормуМодально("Обработка.АктивизироватьПоле", Сп);
КонецПроцедуры

// модуль формы Обработка.АктивизироватьПоле
Процедура ПриОткрытии()
Сп=Форма.Параметр;
Если НРег(ТипЗначенияСтр(Сп))<>"списокзначений" Тогда
Сообщить("'Активизировать поле': неверный вызов","!");
СтатусВозврата(0);
Возврат;
КонецЕсли;

Конт=Сп.Получить("Контекст");
Поле=Сп.Получить("Поле");
Конт.Активизировать(Поле, 1);
СтатусВозврата(0);
КонецПроцедуры

Соответственно - вызов в коде:
глАктивизироватьПоле(Контекст, "Артикул");


Ручное редактирование табличного поля. | База знаний | mista.ru

Ручное редактирование табличного поля.

димон 07.06.2004 10:43 | Нужна помощь по 1с v8. В форме обработки есть табличное поле. Колонки в табличном поле формируются динамически, а потом в это поле загружаются данные из Excel. В реквизитах формы есть таблица значений, с которой связано табличное поле. Все загружается нормально, но почему-то не возможно редактирвание загруженных значений. Причем copy/paste работает, а все остальное нет. В чем может быть дело?
димон 2 - 07.06.2004 14:14 | Проблема решилась после определения типа колонки.


форма документа открыта для изменения | База знаний | mista.ru

форма документа открыта для изменения

Anton_n 07.06.2004 12:30 | как проверить, что форма документа открыта для изменения
SnarkHunter 3 - 07.06.2004 12:46 | Синтакс-Помощник лень открыть? ТолькоПросмотр()
Anton_n 4 - 07.06.2004 13:12 | Я имел ввиду следующее: Если ФормаОткрытаДляИзменения тогда делать то... Если ФормаОткрытаДляВводаНового тогда делать другое... Как узнать в каком режиме открыта форма?
SnarkHunter 5 - 07.06.2004 13:15 | Выбран()=0 - новый, не записанный...


Кнопки в поле ввода (V8) | База знаний | mista.ru

Кнопки в поле ввода (V8)

AVCh_ 04.06.2004 11:28 | Может это и тупой вопрос, но почему если просто включить флаг у поля ввода "кнопка открытия", она не срабатывает. В типовой конфигурации также сделано, и все работает. Как ее работать-то заставить, ведь не надо для этого процедуру писать?
OctoberHammer 1 - 04.06.2004 13:05 | зависит от типа значения. Если там у поля ввода тип - строка, то что должно происходить при нажатии на кнопку открытие? Нужно писать процедуру
AVCh_ 2 - 04.06.2004 13:34 | Да в том-то и дело, что там справочник
¶ 3 - 04.06.2004 14:19 | У тебя, наверное, редактирование "в списке"? Поставь "в диалоге".


Переключатели в форме | База знаний | mista.ru

Переключатели в форме

Таня 04.06.2004 14:50 | Как сделать два набора переключателей? ввела два реквизита - переключателя говорит что нельзя записать в недоступную для записи переменную
Таня 2 - 04.06.2004 15:20 | я уже поняла, неправильно назвала реквизит диалога


Добавление новой колонки в таблицу формы списка (справочник) - КАК ? | База знаний | mista.ru

Добавление новой колонки в таблицу формы списка (справочник) - КАК ?

Crystalizer 04.06.2004 12:56 | блин... простите... помогите не могу добавить новую колонку в таблицу. колонка должна быть не полем из справочника, а просто динамически заполняемой колонкой.
SnarkHunter 1 - 04.06.2004 12:57 | Текстовое поле перетащи на таблицу...
Gavrila 2 - 04.06.2004 12:58 | (0) меню "Вставить"-"Текст" и мышкой по "таблице формы"
VladZagorsky 3 - 04.06.2004 12:59 | В форме-диалог: Вставить - Текст (на таблицу). Если нужно заполнять пропиши функцию (Свойства текста- дополнительно - Формула).
Crystalizer 5 - 04.06.2004 13:06 | опа... а можно ли его сделать числовым???
VladZagorsky 6 - 04.06.2004 13:08 | В это колонку ты можешь вывести все, что захочешь (в пределах разумного). :)
Gavrila 9 - 04.06.2004 13:11 | (8) текстовое поле нельзя сделать числовым, но вывести число в нем можно :)


Закрытие окна диалога | База знаний | mista.ru

Закрытие окна диалога

fil514 04.06.2004 11:33 | Товарищи, как закрыть окно диалога справочника без сохранения?????
SnarkHunter 1 - 04.06.2004 11:34 | Когда спрашивает "Записать?" отвечай - "Нет"...
fil514 2 - 04.06.2004 11:36 | Не смешно, я хочу, чтоб не спрашивало...
kаdr 3 - 04.06.2004 11:40 | Не используй предопределенные процедуры, например #Закрыть, а используй Закрыть(0)
Gavrila 6 - 04.06.2004 11:55 | (5) Процедурка такая на встроеном языке :) Форма.Закрыть(<?>); Синтаксис: Форма.Закрыть(<ЗапрСохр>) Назначение: Закрыть форму. Параметры: <ЗапрСохр> - необязательный параметр. Число: 0 - закрыть форму без вопросов; 1 - если документ, счет, элемент справочника изменен, то будет запрос о сохранении изменений. Значение по умолчанию - 1. Замечание: Действие данного метода не прерывает выполнения текущей процедуры программы, т.е. процедура доработает до конца. Данный метод лишь устанавливает признак, который отрабатывает после окончания выполнения процедуры. Доступ к методу возможен только в контексте Модуля формы через атрибут Форма
kаdr 7 - 04.06.2004 12:04 | Открываешь свойства кнопки "ОК" и вместо #Записать Закрыть пишешь : Закрыть(0) #Закрыть


Как открыть форму элемента по гиперссылке (v8) | База знаний | mista.ru

Как открыть форму элемента по гиперссылке (v8)

AVCh_ 04.06.2004 10:14 | Если делать через ПулучитьФорму открывается форма для нового элемента, о чем написано в документации. А как сделать чтобы открылся определенный существующий элемент?
Волшебник 2 - 04.06.2004 10:26 | СуществующийЭлемент.ПолучитьОбъект().ПолучитьФорму().Открыть();


Как вставить реквизит документа в форму не в виде поля ввода | База знаний | mista.ru

Как вставить реквизит документа в форму не в виде поля ввода

Barbatsutsa 03.06.2004 14:29 | Мне необходимо реквизит документа (тип числовой) добавить в форму в виде переключателя, а при вставке реквизитов поле "Вставлять", где забито "Поле ввода", недоступно. Как быть, подскажите!
Таня 1 - 03.06.2004 14:33 | а длина реквизита равна 1?
Barbatsutsa 3 - 03.06.2004 14:41 | Да, равна 1. А что дальше то сделать?
mszsuz 4 - 03.06.2004 14:44 | Галочкой реквизит пометил? Реквизит случаем не в табл.часть закинул?
Barbatsutsa 5 - 03.06.2004 14:48 | Оказывается, галочкой не пометила! Ну спасибо!


Недоступность новой колонки в табличной части документа | База знаний | mista.ru

Недоступность новой колонки в табличной части документа

Олег 03.06.2004 09:18 | Проблема такая : вставляю новую в табличную часть документа. Колонка не является реквизитом, поэтому вставляю как текст... Но в свойствах колонки стоит не отключаемый флаг "недоступно". Чего делать-то... Как с этой колонкой работать... Мне к ней нужно обращаться по идентификатору...
dtprST 7 - 03.06.2004 09:29 | Такую колонку можно примерно сравнить по аналогии с "вычисляемой колонкой" (в Fox-о DOS-овые времена точно был такой термин :) ); чтобы в этой колонке выводилась информация - надо в Формулу ее выражение прописать, а чтобы попытку "вбить" в эту колонку отлавливать - только через предопеределенные, думаю понятнее всего на примере существующих ТЧ посмотреть - та же колонка "Партия" в расходных документах в ТиС Более подробно можно рассмотреть и в рассылке - subscribe.ru/catalog/economics.book.likbez1c Преимущество рассылки - уверенность в том, что никогда не пропустишь информацию :) Ну и опять же, траффика с почтой меньше 8-))


Как поменять размер формы программно в 1Cv77? | База знаний | mista.ru

Как поменять размер формы программно в 1Cv77?

nikn
02.06.2004 12:13 		нужно кусочек снизу отрезать и показывать по кнопке ..
как это сделать ?

про слои знаю... но нужно убирать\показывать нижний кусок формы...
GrayT
2 - 02.06.2004 12:28 		Штатно ни как. А не штатно - не люблю я эти примочки - от того и готовить их неумею
Рупор абсурда
3 - 02.06.2004 12:59 		procedure bottomSize(n=1)
if n=0 then return endif;
wShell.sendKeys("%");
wShell.sendKeys("{left}{down 3}~{down}");
wShell.sendKeys("{"+?(n>0,"down "+n,"up "+(-n))+"}~");
endProcedure

или ФормЭкс возьми
Рупор абсурда
4 - 02.06.2004 12:59 		(3)+ wShell=createObject("wScript.shell");
SnarkHunter
6 - 02.06.2004 13:16 		www.rsdn.ru - Статьи / COM/DCOM/COM+ / Автоматизация / Windows Scripting
GrayT
7 - 02.06.2004 13:38 		http://www.winhowto.ru/reg_s1.shtml - про WHS
http://consult.legion.ru/alf/formex.shtml - про FormEx


Вычисление в таблице | База знаний | mista.ru

Вычисление в таблице

Александр 18.03.2004 11:09 | Уважаемые господа! Подскажите, пожалуйста, как сделать чтобы в 1С:Предприятие 7.7 релиз 20 Бухгалтерский учет, редакция 4.4, при выписывании счета (счета-фактуры, акта оказания услуг), можно было бы вводить цифры в графу "ВСЕГО", с вычислением в графах "Цена", "Сумма", "НДС", как это было в редакции 4.0
unior 1 - 18.03.2004 11:19 | 1.Убери галочку ЗапретитьРедактирование на колонке Всего. 2. в процедуру Пересчёт() добавь строки: ИначеЕсли Форма.ТекущаяКолонка() = "Всего" Тогда НП = Окр(Всего*СтавкаНП/(100+СтавкаНП),2,1); НДС = Окр((Всего-НП)*СтавкаНДС/(100+СтавкаНДС),2,1); Сумма = Всего - НП - НДС; Цена = Окр(Сумма/?(Количество=0,1,Количество),2,1);
Александр 2 - 19.03.2004 10:29 | Увы, ничего не получается. При попытке заполнить счет выдается следующее сообщение: НП = Окр(Всего*СтавкаНП<<?>>/(100+СтавкаНП),2,1); {Документ.Счет.Форма.Модуль(217)}: Переменная не определена (СтавкаНП) НДС = Окр((Всего-НП)*СтавкаНДС<<?>>/(100+СтавкаНДС),2,1); {Документ.Счет.Форма.Модуль(218)}: Переменная не определена (СтавкаНДС)
unior 3 - 19.03.2004 13:33 | После строки: Если Товар.Выбран() = 1 Тогда добавь: СтавкаНДС = Товар.СтавкаНДС.Получить(ДатаДок).Ставка; СтавкаНП = Товар.СтавкаНП.Получить(ДатаДок).Ставка;


Общие формы в 8.0 | База знаний | mista.ru

Общие формы в 8.0

Valentin_Azheronok 29.05.2004 22:26 | Подскажите как открыть общую форму, как к ней обратиться то?
Волшебник 1 - 29.05.2004 22:37 | ПолучитьОбщуюФорму(<ИмяФормы>).Открыть();


Скрытие строки символами ****** | База знаний | mista.ru

Скрытие строки символами ******

Миха 28.05.2004 15:00 | Кто подскажет, можно как-нибудь средствами 1С скрыть вводимые символы в реквизите диалога другими символами, например - ****?
SnarkHunter 1 - 28.05.2004 15:02 | Галка "Для ввода пароля"...


Можно ли предотвратить изменение флага модифицированности документа в 7.7? | База знаний | mista.ru

Можно ли предотвратить изменение флага модифицированности документа в 7.7?

keyt 27.05.2004 12:22 | Например, если пользователь убирает-снимает галку формы, то документ сейчас же становится модифицированным, хотя значение этой галки нигде в документе не сохрняется - это некий временный признак. Можно ли это как-нибудь побороть?
SnarkHunter 3 - 27.05.2004 12:29 | http://www.sinor.ru/~my1c/knowhow/clrmodif.html


Контекстное меню над табл. в форме вн. отчета? | База знаний | mista.ru

Контекстное меню над табл. в форме вн. отчета?

Mazay 25.05.2004 19:36 | V77. Можно ли по правой кн.мыши над ТЗ, на форме, заполучить контекстное меню? Что-то похожее на конт.меню в таблице отчета. Может кто знает, подскажите плз!
Рупор абсурда 1 - 25.05.2004 19:40 | Нет
Asmody 5 - 25.05.2004 22:50 | (0) ВК тебе поможет. Прямая дорога на hippo.


Выбор строк таблицы при помощи флажков - возможно ли это? | База знаний | mista.ru

Выбор строк таблицы при помощи флажков - возможно ли это?

keyt 25.05.2004 10:24 | Можно ли как-нибудь для версии 7.7 сделать в форме документа в таблице значений колонку для выбора строк этой таблицы - что-то вроде флажка или галки. И чтобы пользователь мог просто кликом на строке поставить-убрать эту галку. Заранее спасибо.
Волшебник 1 - 25.05.2004 10:29 | Только двойным кликом. Реализуется с помощью картинок.
keyt 2 - 25.05.2004 10:38 | Тогда можно ещё уточнить: будет ли это работать также и для ТаблицыЗначений, а не только для табличной части документа? По-моему, всё-таки, для таблицы значений это сделать нельзя, поскольку для неё не определено никакких предопределённых функций типа ПриНачалеРедактировнияСтроки. Или я не права?
Волшебник 3 - 25.05.2004 10:42 | При двойном щелчке на таблице значений в форме 7.7 срабатывает ее формула, т.е. можно вызвать процедуру, которая по текущей строке и колонке таблицы значений определит, куда именно щелкнул пользователь.


Расширить во весь экран | База знаний | mista.ru

Расширить во весь экран

нач 24.05.2004 11:19 | Где можно настроить чтоб все документы, журналы, отчеты и т.д открывались во весь экран, чоб не приходилось постоянно нажимать расширить окно???
kadr 1 - 24.05.2004 11:23 | Один раз расширив любой документ и т.п. все остальное будет открываться всегда расширенным
SnarkHunter 2 - 24.05.2004 11:28 | Есть способы... Из легальных - использование ВК... Про нелегальные вроде как нельзя говорить...
shura 3 - 24.05.2004 11:34 | Ищи FormEx


Как поместить на форму документа поле для ввода комментария? | База знаний | mista.ru

Как поместить на форму документа поле для ввода комментария?

kadr 20.05.2004 11:17 | Господа! Помещаю на форму "Реквизит диалога". Задаю ему идентификатор "Комментарий". Говорит, что идентификатор задан неправильно.
SiMazx 3 - 20.05.2004 11:21 | Прав (1). Общий реквизит документов... Девяностодевятипудово...
SiMazx 5 - 20.05.2004 11:23 | (2) Значит надо вставлять через механизм вставки реквизитов документа, а не через добавление поля ввода и присваивания ему идентификатора общего реквизита...
kadr 24 - 21.05.2004 11:24 | (18) Рапортую большими буквами: ФОРМА ДОКУМЕНТА Она когда сама первый раз создала форму - поместила все реквизиты (номер документа, дата и, в т.ч., комментарий). Потом я случайно поле "Комментарий" удалил... А теперь его надо вернуть
At 28 - 21.05.2004 11:35 | 1.панель "Элементы диалога", кнопка "Реквизиты".. обычно распологается в низу.. крайняя правая кнопка или 2.меню "Вставить", пункт меню " Реквизиты.." в открывшимся окне ставишь галочку около реквизита "комментарий" и жмешь кнопку "Вставить"


Как изменить активность формы? | База знаний | mista.ru

Как изменить активность формы?

Таня 20.05.2004 15:37 | из процедуры ПриОткрытии() вызываю (ОткрытьФорму()) форму журнала (ДляПодбора), при этом окно исходной формы скрывать не надо, а журнал открывается на заднем плане, как вывести его на передний план?
SnarkHunter 1 - 20.05.2004 15:40 | Исходная форма открыта видимо модально?
Таня 2 - 20.05.2004 15:52 | не знаю, это внешняя обработка, открываю я ее через Файл - Открыть
GrayT 3 - 21.05.2004 00:54 | Может у тебя где "Активизировать" затесалось после ОткрытьФорму?


Управление закладками | База знаний | mista.ru

Управление закладками

Sfinx
20.05.2004 20:15 		Как программно управлять закладками на форме?

По щелчку на закладку мы обрабатываем событие и делаем видимым определенный слой.
А если просто из программы сделать видимым этот слой, то закладка не "перещёлкивается", что собственно, логично, но при последующем переходе по закладкам несколько сбивает...

Или я слишком много хочу?
(Вообще, надо сказать, работа с закладками через ж.... в 1С. Мне много больше реализация в том же Delphi нравится.)
427
7 - 20.05.2004 21:50 		Имхо - использование закладок, особенно в таком документе, как РасходнаяНакладная, значительно увеличивает количество ошибок при вводе документа...

А СЧФ с тремя закладками - это вАще полная Ж....
Sfinx
8 - 20.05.2004 21:53 		(7) у меня другая задача.
Нужно в табличной части хранить 3 "разных" вида элементов с разными параметрами.
В одну таблицу их бить не гоже. Зело наглядность теряется. Хочу бить из в три разных ТЗ, а при сохранении заполнять табличную часть из трех ТЗ.
При отрытии соответственно сортировать по трем разным ТЗ...
Вот тут и нужно на разных закладках их разложить. Иначе не влезают ;)
SnarkHunter
9 - 20.05.2004 21:56 		Например так:
Для к=1 По Форма.Закладки.РазмерСписка() Цикл
Форма.Закладки.ТекущаяСтрока(к);
ПриВыбореЗакладки(к,Форма.Закладки.ПолучитьЗначение(к));

// Задержка...
Для л=1 По 100000 Цикл
КонецЦикла;
КонецЦикла;
Sfinx
10 - 20.05.2004 22:11 		Черт побери...
Форма.Закладки.ТекущаяСтрока(к);
Вот до этого я не додумался.
Форма.Закладки - это же список значений... Век живи - век учись ;)


Как плоучить "старые" значения реквизитов документа в форме? Вопрос по 8 | База знаний | mista.ru

Как плоучить "старые" значения реквизитов документа в форме? Вопрос по 8

SVASVA 19.05.2004 16:39 | Во время редактирования документа в форме необходимо получить значения реквизитов документа, которые были до начала редактирования документа в форме. Каким образом это можео сделать? Только сохранив эти значения перед началом редактирования документа? Как получить ссылку на документ в таблице, соответствующий редактируемому? С уважением, Владимир.
¶ 1 - 19.05.2004 20:30 | А если так: в обработчике события формы ПриОткрытии создать объект-копию методом Скопировать() документ-объекта, попользоваться значениями из нее, а потом копию - в песок?
427 2 - 19.05.2004 20:44 | Обычно в любых языках при всасывании данных в форму инфа на диске лежит в прежнем состоянии... а на форме она м.б. изменена.... И фиксится она в момент ЗАПИСИ из формы дока... Когда нажмут кнопоёмбочку Записать ... или сработает системное событие ЗАПИСЬ.... Правда, некоторые извращенцы программируют АвтоЗапись .... при смене фокуса на форме... но это уже изврат... Обычно решение о записи измененной инфы принимает юсер... Если в нужном месте через созданный программно объект повторно взять инфу с диска - ее можно сравнить с имеющейся на форме... (0) дерзайте, таварищ....
SVASVA 3 - 20.05.2004 10:07 | Вчара разбирался с этим вопросм и обнаружил, что полям формы соотвестсвует объект ДокументОбъект. Этот объект содержит актуальные для формы значения реквизитов. Кроме того, этот объект содержит реквизит Ссылка, которая ссылается на редактируемый документ, т.е. ДокументСсылка. Причем это объект хранит "старые" значения реквизитов документа, которые будут заменены на новые после подтверждения изменений. В связи с этим вопрос, правильна ли моя гипотеза о том, что ДокументОбъект хранит редактируемые в форме значения реквизитов, а полученный по ссылке ДокументСсылка - "старые" значения реквизитов документа. Насколько корректно использовать для восстановления значений реквизитов, отображенных в форме, значения реквизитов из полученного по ссылке ДокументаСсылки? С уважением, Владимир.
¶ 4 - 20.05.2004 11:05 | Ты спрашиваешь: "Насколько корректно использовать для восстановления значений реквизитов, отображенных в форме, значения реквизитов из полученного по ссылке ДокументаСсылки?" - Корректно до момента записи документа в базу (применения метода Записать()), после этого значения, возвращаемые ДокументомСсылкой, будут совпадать со значениями реквизитов формы и ДокументаОбъекта, связанного с формой, а старые значения будут утеряны. Это тебе и сказал 427 в (2). Если тебе надо хранить значения "от момента открытия формы", то сделай, как я написал в (1).


Как достать элемент диалога из модуля проведения документа | База знаний | mista.ru

Как достать элемент диалога из модуля проведения документа

Ivan1c 19.05.2004 13:13 | В модуле проведения документа. В предопределенной процедуре обработка проведения как обратится и выбрать значение из элемента диалога если он не добавлен в список реквизитов шапки документа.
NastyFrog 2 - 19.05.2004 13:17 | Форма.Элемент
427 4 - 19.05.2004 14:07 | Можно... Лично я знаю 4 методики Методика 1 - спросить у юзера.... Про остальные не расскажу....
GrayT 8 - 19.05.2004 15:23 | (4)Если форма закрылась, то реквизиты диалога пропали. И как их достать? Или я не понял вопроса в (0) (7)Индентификатор чего?
GrayT 9 - 19.05.2004 15:26 | А вот если форма не закрылась, то тут можно поизвращаться! :)
Valery 10 - 19.05.2004 15:34 | У элемента диалога есть идентификатор, вот его можно передать в модуль документа
BorisBiz 11 - 19.05.2004 15:45 | В (0), ИМХО мало того что бессмысленно, так еще и ошибочно - при повторном проведении документа другие условия, соответвенно другой результат. Хотя возможно для всяких извращений различным извращенцам может и нужно... :)
GrayT 12 - 19.05.2004 15:46 | Модуль формы Процедура ККК() Провести(,Контекст); КонецПроцедуры //ККК Модуль документа Процедура ОбработкаПроведения(Парам) Парам.ЧР = 5; КонецПроцедуры На форме реквизит диалога ЧР - Числовой.
427 13 - 19.05.2004 16:09 | (10) Можно даже засунуть этот идентификатор в параметры... или в задницу ... и будет совершенно одинаково ... Если форма дока не открыта - реквизитов диалога НЕТ.... Перепроведение документов как делать буш?


Картинки на кнопках формы | База знаний | mista.ru

Картинки на кнопках формы

LOSS 15.05.2004 08:47 | Как изменить хором все картинки во всех формах, предположим одну и туже картинку на кнопе Закрыть, на какую нить другугю. Мож где в библиотеке ссылку поменять? Киньте ссылку или ответ
GrayT 5 - 15.05.2004 13:24 | to LOSS: Опять же MdBrowser помог. Выцепил две картинки из МД переименовал их друг в друга, загрузил обратно. Ух ты - на кнопочках картинки изминились :)) Делал на пустой базе. Сделай копию на всякий случай
LOSS 11 - 15.05.2004 15:45 | (10) DocFileBrouser?? если так, то как узнать какой номер у какой картинки MDBrowser правит только текст


Как передать параметры в форму списка справочника при открытии из документа | База знаний | mista.ru

Как передать параметры в форму списка справочника при открытии из документа

Андрейка Полонянкин 14.05.2004 05:25 | Если через ОткрытьПодбор("Справочник.ТМЦ", "Выбор", КонтекстФормы), то параметры передаются через переменную КонтекстФормы. А как передать параметры, если юзер просто вводит новую строчку? Тогда ведь тоже вызывается справочник, но это делается автоматом, а не программно.
unior 1 - 14.05.2004 05:52 | А тебе что надо - то? Через контекст ты и получаешь что хочешь - отбор или ещё что-то.... В любом случае в модуле формы списка придётся обрабатывать контектс - хочешь создавай свою форму списка, или иправляй имеющуюся.
mszsuz 2 - 14.05.2004 08:50 | Дату документа наверно хочешь получить? Тогда сюда: http://www.sinor.ru/~my1c/knowhow/dateinspr.html Если надо именно передать параметры, тогда в Документе заведи процедуру ПриНачалеВыбораЗначения(ИЭД,ФСО) и в ней: СписокПараметров=СоздатьОбъект("СписокЗначений"); ... ОткрытьФорму("Справочник.ТМЦ",СписокПараметров);
Андрейка Полонянкин 3 - 14.05.2004 13:53 | Пользователи не хотят пользоваться кнопкой \"Подбор\". Привыкли просто вставлять новую строчку в документ Инсертом. Хотят чтобы при подборе показывались товары по складу и подотчетнику. По кнопке я вызываю ОткрытьПодбор() и передаю параметры. Проблем нет. А когда пользователь нажимает кнопку Инсерт, то в новой строчке форма вызывается сама. И параметры я передать не успеваю. ПриНачалеВыбораЗначения(ИЭД,ФСО), как я понял не предопределенная процедура. Тогда в какой ситуации ее вызывать? Если же использовать ПриНачалеРедактированияСтроки(), то вызывается два окна, одно, которое вызываю я, с переданными параметрами, и второе, которое вызывается при вводе новой строки документа, куда я параметры не умею передавать.
iceTiger 5 - 14.05.2004 14:11 | ПриНачалеВыбораЗначения(Элем,СтандартОбр) - предопределенная процедура! элем - строка с идентификатором элемента ("товар", "партия"...) СтандартОбр - флажок, если в теле данной процедуры поставить СтандартОбр=0 тогда будет открываться только форма открытая тобой. Прим.: // =============================== Процедура ПриНачалеВыбораЗначения(Элем,СтандартОбр) Если Элем="Контракт" тогда Стандарт=0; Спс=СоздатьОбъект("СписокЗначений"); Спс.ДобавитьЗначение("У_ПриказНаОтгрузку","Док"); Спс.ДобавитьЗначение(Получатель,"Клиент"); ОткрытьПодбор("Журнал.У_Контракты","ФормаСписка",Спс,0); СтандартОбр = 0; КонецЕсли; КонецПроцедуры
Frol 6 - 14.05.2004 15:01 | А как, насчет предопределённой процы "ПриВводеСтроки", разве не в неё проваливаемся, когда нажимается кнопочка "Insert".....
Андрейка Полонянкин 7 - 14.05.2004 15:43 | SiMazx, посмотрел в синтаксис-помошнике, предопределенные по документу. После запустил контекстный поиск и увидел, что это предопределенная процедура для модуля формы. А что такое ЖКК? iceTiger, сделал как Вы написали, получилось именно то, что нужно. Огромнейшее Вам спасибо, и от меня и от радостных пользователей. Frol, проваливаемся, и тогда запускайтся и наш выбор и системный, т.е. две формы. А запретить системный можно как раз флажком, про который говорит iceTiger. Еще раз спасибо всем за участие!


Форма документа | База знаний | mista.ru

Форма документа

lexa 14.05.2004 12:17 | Можно ли добавить поле (колонку) в многовтрочную часть. Если да, то как?
ally 3 - 14.05.2004 12:22 | Меню-> Текст, Поместить курсор на ТЗ (многострочную часть), и щелкнуть лев. кнопкой мышки
ally 7 - 14.05.2004 12:33 | ну а если нужно вставить реквизит в ТЧ Меню-> Вставить-> Реквизиты
SnarkHunter 9 - 14.05.2004 12:42 | Текст тоже можно через иконку...


Открыть документ из документа | База знаний | mista.ru

Открыть документ из документа

гол 13.05.2004 15:36 | Как открыть один документ из другого проинициализировав некоторые поля? Пробовал ОткрытьФорму() для нового документа.
Frol 1 - 13.05.2004 15:42 | проясни, что значит "проинициализировав некоторые поля"?
гол 2 - 13.05.2004 15:43 | Присвоив им начальные значения
Frol 6 - 13.05.2004 16:09 | Gavrila, прикалывается над тобой... :) Те нада сначала создать его, типа : Док = СоздатьОбъект("Документ._____"); Док.Новый(); //потом "инициализируешь" нужные реквизиты //типа: Док.НомерДок = Переменная; // и т.д. и т.п. //потом Док.Записать() Док.НайтиПоНомеру(Переменная,РабочаяДата); //Этим ты спозиционируешься на нем //а потом мож открывать методом ОткрытьФорму()
Львенок 10 - 13.05.2004 16:18 | (6) Точно, а потом пользователь взял и передумал записывать документ... и отказался от записии... А документ все равно уже записан, да еще с запоненными вами несколькими полями, и пустыми прочими... Красота... ___ Искренне Ваш, Львенок.
Львенок 12 - 13.05.2004 16:27 | А на самом деле нужно создать СписокЗначений, заполить его значениями полей, потом открыть форму нового документа ОткрытьФорму(<ОписательОбъекта>,<НашСписокЗначений>,<ДокументОснование>), а в открываемом документе доработать процедуру ПриОткрытии, чтобы она проверяла Форма.Параметр, если у него ПустоеЗначение(...)=1 (или можно даже тип проверить, если он не список значений), то ничего не делаем, а если списокзначений, то достаем из него значения и инициализируем ими поля. Этот медот сложнее, но гораздо более корректен. ___ Искренне Ваш, Львенок.


Как вставить формулу в элемент диалога Поле со списком | База знаний | mista.ru

Как вставить формулу в элемент диалога Поле со списком

Таня
12.05.2004 15:47 		Я вставила формулу и соответственно в модуле формы документа есть процедура, то при выборе значения (позиции) в списке, должна меняться видимость одного из полей формы. Почему, когда я выбираю второе значение, то выполняется процедура, но при этом список показывает первое значение. Что делать?
Gavrila
1 - 12.05.2004 16:04 		ищи в модуле .ТекущаяСтрока()
Таня
2 - 12.05.2004 16:06 		Есть у меня ТекущаяСтрока()
Щас кусок напишу:

Процедура ВыборОтгрузки();
Если Константа.КомиссионнаяТорговля = Перечисление.Булево.Нет Тогда
Иначе
Если СписокВидовОтгрузки.ТекущаяСтрока() = 1 Тогда
Форма.ДоходыРасходы.Видимость(1);
Форма.ЗагДох.Видимость(1);
ИначеЕсли СписокВидовОтгрузки.ТекущаяСтрока() = 2 Тогда
Форма.ДоходыРасходы.Видимость(0);
Форма.ЗагДох.Видимость(0);
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Таня
3 - 12.05.2004 16:10 		В принципе задача такая: надо чтобы если основным видом деятельности является комиссионная торговля (переключается константой), то надо в отгрузке выручку на 91 счет, поэтому, если комиссионка = да, тогда в списке значений видов отгрузки должно быть 91 и 45, иначе 90 и 45
когда отладчиком смотрю, то если выбираю 45 СписокВидовОтгрузки.ТекущаяСтрока() показывает =2, а в самом списке показывает все время 91, хотя видимость поля ДоходыРасходы меняется как надо.
Gavrila
4 - 12.05.2004 16:35 		А список правильно заполнен?:) может там одинаковые значения?:)
Таня
5 - 12.05.2004 16:37 		Нет, значения разные
в конце модуля :
Если Константа.КомиссионнаяТорговля = Перечисление.Булево.Да Тогда
СписокВидовОтгрузки.ДобавитьЗначение(1, "Продажа (счет 91)");
Форма.ДоходыРасходы.Видимость(1);
Форма.ЗагДох.Видимость(1);
Иначе
СписокВидовОтгрузки.ДобавитьЗначение(1, "Продажа (счет 90)");
Форма.ДоходыРасходы.Видимость(0);
Форма.ЗагДох.Видимость(0);
КонецЕсли;
СписокВидовОтгрузки.ДобавитьЗначение(2, "Отгрузка (счет 45)");
Таня
6 - 12.05.2004 16:40 		Когда отладчиком смотрю, то успеваю заметить, что до перехода в отладчик в поле отражается 45 счет (то что выбираю), а когда из отладчика обратно в бухгалтерию возвращаюсь, то уже 91 написано
Gavrila
8 - 12.05.2004 17:01 		в чем проблемс то был ?
Таня
9 - 12.05.2004 17:03 		а процедура, вставленная в поле со списком ничего не хочет выполнять, она только смогла присвоить значение переменной и передать управление на функцию, тогда я то что хотела в функцию вписала.


Как сделать редактируемое поле в ТЧ документа? | База знаний | mista.ru

Как сделать редактируемое поле в ТЧ документа?

Barmaley 12.05.2004 06:35 | Для ускорения работы со справочником "Товары" в документах в табличную часть хочу добавить поле ввода кода, чтобы потом заполнить поле "Товар". Т.е. если код найден, то форма справочника не открывается и наоборот Пример ТЧ: N Код Товар Кол-во Цена Сумма 1 10511 Самый крутой товар 5 2,40 12,00 Но не хочется добавлять в базу реквизит "Код", а только в форму док-та Возможно ли это????
427 2 - 12.05.2004 06:53 | (1) Привет... Отметился... (0) можно, но не нужно... Лучше при вводе открывать нужный справочник и программно активизировать нужную колонку (код, наименование, артикул)... Тогда при наборе оператор сразу видит - попал он или ошибся.... Получается быстрей ....


Процедура ПриОткрытии() и функции для расчета текстов на форме. | База знаний | mista.ru

Процедура ПриОткрытии() и функции для расчета текстов на форме.

Мак 11.05.2004 13:17 | Есть текст на форме. Значение рассчитывается функцией Функция Нал_ВФВС() Перем Стр; ТЗ_РН.НайтиЗначение(ТМЦ,Стр,1); Возврат ТЗ_РН.ПолучитьЗначение(Стр,2); КонецЕсли; Сообщить(Стр); КонецФункции ТЗ_РН - ТаблицаЗначений, формируется в процедуре ПриОткрытии(), причем формируется корректно - текст, что на форме показывает правильное значение, но при этом в окошке сообщений ругается, что номер за пределами значений. В чем тут подвох? У меня ощущение, что данная функция рассчитывается до процедуры ПриОткрытии()
SnarkHunter 1 - 11.05.2004 13:23 | Перед НайтиЗначение вставь Стр=0;
Мак 2 - 11.05.2004 13:27 | ПОставил. Ничего не меняет. Да я так понимаю, и не должнго менять. СТр - переменная, куда НайтиЗначение() помещает номер строки с "ТМЦ".
Vozhd 3 - 11.05.2004 13:29 | (0) А кто будет проверять возвращаемое значение функции НайтиЗначение()?
Gavrila 4 - 11.05.2004 13:29 | (0)"У меня ощущение, что данная функция рассчитывается до процедуры ПриОткрытии()" - у тебя абсолютно правильное ощущение, заполняй ТЗ в модуле формы... :)
SnarkHunter 5 - 11.05.2004 13:31 | Логично... А если поиск неудачен функция что возвращать будет?
427 6 - 11.05.2004 13:32 | (1) Очки то протри.... ТЗ_РН.... это что у него за фигня?
Gavrila 7 - 11.05.2004 13:34 | (5) ага проверка нужна, согласен :)
SnarkHunter 8 - 11.05.2004 13:36 | (4)Ни фига... Функция в тексте на форме... При отрабатывании ПриОткрытии формы еще нет, соответственно нет и текста, в формуле которого вычисляется функция...
Gavrila 10 - 11.05.2004 13:41 | (8) абсолютно прав: сам проверил... все таки проверка :)
Gavrila 12 - 11.05.2004 13:49 | (11) пиши так: Функция Нал_ВФВС() Перем Стр; Стр = 0; Если ТЗ_РН.НайтиЗначение(ТМЦ,Стр,1) = 0 Тогда Возврат ""; Иначе Возврат ТЗ_РН.ПолучитьЗначение(Стр,2); КонецЕсли; Сообщить(Стр); КонецФункции
SnarkHunter 13 - 11.05.2004 13:51 | (11)И при этом сообщит, "что номер за пределами значений"...
Мак 14 - 11.05.2004 13:52 | Хорошо. А все же почему одновременно я вижу и правильное значение, и сообщение об ошибке?
Gavrila 15 - 11.05.2004 13:54 | (14) не прав: почти одновременно :), а дальше по отладчику :))


Отлов изменений размера окна пользорвателем | База знаний | mista.ru

Отлов изменений размера окна пользорвателем

fishca 08.05.2004 18:06 | Отлов изменений размера окна пользорвателем, как осуществить в восьмерке?
GrayT 1 - 08.05.2004 23:59 | А это вообще возможно? Я покопался-покопался, да плюнул :( Короче Up
BorisG 2 - 09.05.2004 09:23 | Можно... но писать самому будет нужно. MSDN поможет. Только оно Вам надо?
GrayT 3 - 09.05.2004 09:56 | Мне - не то что бы очень, так спортивный интерес. Была такая мысль, что как-нить через ВнешнееСобытие. Видимо придется надо будет посылать новое сообщение. Спасибо.
¶ 4 - 09.05.2004 14:12 | (2) Ты, надеюсь, в курсе, что в 8.0 - своя, "сампописная" оконная система?
BorisG 5 - 09.05.2004 14:45 | (4) В курсе. И что с того? Событие WM_WINDOWPOSCHANGING нельзя отловить? Хотя если честно, не пробовали, за ненадобностью.


При удалении строки табличной части хочу матюк | База знаний | mista.ru

При удалении строки табличной части хочу матюк

ФАКОэмульсификатор
2 - 07.05.2004 17:45 		Сам нашел ответ. Кому надо смотрите ниже. Какие-то вы сегодня сонные, БЛИН.

ПриУдаленииСтроки
Предопределенная процедура при удалении строки многострочной части документа.
Синтаксис:
ПриУдаленииСтроки()
Англоязычный синоним:
OnDeleteLine
Описание:
Вызов предопределенной процедуры ПриУдаленииСтроки производится в системе 1С:Предприятие при инте-рактивном удалении строки многострочной части документа. Если в данной предопределенной процедуре установить статус возврата — 0 (например, если данному пользователю нельзя изменять документ), удаление строки документа не будет выполнено.
Данная предопределенная процедура может располагаться только в Модулях формы документов (см. «Виды про-граммных модулей»).
Пример:
Процедура ПриУдаленииСтроки()
Если НазваниеНабораПрав() = "Продавец" Тогда
Предупреждение("У вас нет права удалять строки!", 2);
СтатусВозврата(0);
КонецЕсли;
КонецПроцедуры


Как открыть документ (интерактивно) в режиме просмотра | База знаний | mista.ru

Как открыть документ (интерактивно) в режиме просмотра

Силикат 06.05.2004 22:02 | Как из журнала документов интерактивно открыть док в режиме просмотра?
427 1 - 06.05.2004 22:18 | Мдя..... А набрать в модуле ОткрытьФОрму и нажать Стрл-Ф1 на этом операторе уже не канает? Надо переться на форум? ..ля.... Ну сАвсем народ .....й пошел ....
Силикат 2 - 06.05.2004 22:32 | А если по Энтеру требуется открытия в режиме редактирования, а по какой-либо другой комбинации - в реж. просмотра?
GrayT 3 - 06.05.2004 23:12 | Ты синтакс-помощника все же почитай :) Там параметр в форму можно передать, вот ПриОткрытии и определишь как открывать
427 4 - 06.05.2004 23:16 | А еще есть "горячие" клавиши... которые можно делать самому
Силикат 5 - 06.05.2004 23:20 | И что я напишу в ПриОткрытии()? Если НажатаКлавишаЭнтер Тогда ОткрытьФорму(Док,0); ИначеЕсли НажатыКлавишыКонтролЭнтер Тогда ОткрытьФорму(Док,1); КонецЕсли; ? :)))
GrayT 7 - 06.05.2004 23:29 | УЖ если очень жмет С СтрлЕнтером поиграться - КнопкаПоУмолчанию тебе поможет. А так почти все верно: В документе Процедура ПриОткрытии() Если Форма.Параметр=1 Тогда Форма.толькоПРосмотр(1) ......
427 10 - 07.05.2004 06:25 | (9) Однако тебя тоже нужно послать ... в ЖКК.... в ОткрытьФорму .... для открытия существующего дока есть еще третий параметр .... И да увидит его зрячий... и не будет компостировать себе мозги... P.S. - никаких изменений в самом доке не требуется....


запретить выбор одной из радиокнопок? | База знаний | mista.ru

запретить выбор одной из радиокнопок?

1c-dummy 06.05.2004 08:39 | Приходится писать несложную конфигурацию почти с нуля. Так вот, есть поле на форме справочника (и для элемента и для группы) есть радиокнопки: "как в группе", "есть" и "нет", у первой кнопки идентификатор Фл4и6 и признак "первый в группе", у других - ничего не указано. Естественно, есть и поле Для4и6: при открытии Для4и6 = сред(" -+",Фл4и6,1), при закрытии Фл4и6 = найти(Для4и6,"+-")+1 . Как запретить выбор кнопки 1 для уровня 1? Или, в общем случае, как запретить выбор одной из радиокнопок?
GrayT 1 - 06.05.2004 08:44 | Напиши обработку в Свойства-Дополнительно-формула
SnarkHunter 2 - 06.05.2004 09:28 | (0)Задай идентификаторы у всех радиокнопок и используй Доступность()
3ton 3 - 06.05.2004 12:04 | Не знаю как у всех, но у меня когда через доступность блокируешь радиобокс с признаком "Первый в группе", значение, при попытке его изменить интерактивно сбрасывается автоматом на установленное по умолчанию (старое при открытии) 1С (18) 2k (sp4) значение первого радиобокса - переменная (не реквизит справочника) каждый бокс имеет идентификаторы... Фича или баг...? кто знает?


Как получить список колонок многострочной части формы списка справочника? | База знаний | mista.ru

Как получить список колонок многострочной части формы списка справочника?

Leyla
27.10.2004 12:34 		Здравствуйте!
Нужно получить список колонок многострочной части формы списка справочника. Как это можно сделать?
Виталий из Ростова
74 - 27.10.2004 17:42 		Перем Скрипт;
Перем СписКолонок;

Процедура СканироватьКолонки()
Форма.ОбработкаОжидания(,);
Если СписКолонок.НайтиЗначение(Форма.ТекущаяКолонка())=0 Тогда
СписКолонок.Добавитьзначение(Форма.Текущаяколонка());
СписКолонок.Пометка(СписКолонок.РазмерСписка(),1);
Скрипт.SendKeys("{RIGHT}");
СканироватьКолонки();
Иначе
Возврат;
КонецЕсли;
КонецПроцедуры

Процедура УстановитьВидимость()
Для П=1 По СписКолонок.РазмерСписка() Цикл
Пом=СписКолонок.Пометка(П);
Зн=СписКолонок.Получитьзначение(П);
Атр=Форма.ПолучитьАтрибут(Зн);
Атр.Видимость(Пом);
КонецЦикла;
КонецПроцедуры

Процедура УправлениеВидимостью()
Если СписКолонок.ОтметитьЗначения(,,,)=1 Тогда
УстановитьВидимость();
КонецЕсли;
КонецПроцедуры

Процедура ПриОткрытии()
Форма.ОбработкаОжидания("СканироватьКолонки",1);
КонецПроцедуры

СписКолонок=СоздатьОбъект("Списокзначений");
Скрипт=СоздатьОбъект("WScript.Shell");
Виталий Августейший
75 - 27.10.2004 17:43 		Процедура управлениеВидимостью() - формула кнопки.
Можно было сделать и без WScript...


Помогите заставить работать переключатель в документе | База знаний | mista.ru

Помогите заставить работать переключатель в документе

SemT 14.10.2004 16:40 | Столкнулся с глупой проблемкой. Делал впервые переключатель из двух пунктов. Делал на основе примеров. Программную функцию они свою выполняют. Вот только почему-то когда я делаю документ я могу выбрать оба сразу, а нужно только один. Подскажите где копать.
Rovan 3 - 14.10.2004 16:44 | Проверь свойство "Первый в группе" и порядок обхода в диалоге - должны стоять друг за другом, идентификатор должен быть только у 1-го.


Горячие клавиши и 1С - недружат? | База знаний | mista.ru

Горячие клавиши и 1С - недружат?

Lyolik 09.10.2004 13:08 | Может кто сталкивался с такой проблемой: на форме документа есть кнопочка, в её свойствах на закладке команда назначаем горячую клавишу (например Ctrl+F10). При работе с документом нажимает заветное сочитание, но увы ничего не происходит :-( В чем дело?
F427 5 - 09.10.2004 13:22 | Ну не знаю как в 8, а в 7 сей глюк наличествует и не исправлен за все время существования платформы, хотя всплыл он практически сразу... P.S. напиши на линию консультаций. Просто интересно как и куда тебя пошлют... После стольких лет задавания этого вопроса... P.S. Глюк обходится через ...опу...
F427 7 - 09.10.2004 13:46 | Глюк описан в (0) ... Начиная с некоторого места в порядке обхода, горячая клавиша теряется... Место потери - неопределенное, при некотором количестве реквизитов на форме (для каждого дока свое, ХЗ от чего зависит).... В качестве примера посмотри типовую бухию, клавишу Ф8 в ПКО и РКО, до 460 (или 459?) редакции... Не работает... Способ обхода - как всегда, через .опу... Просто переставить клавишу поближе к началу в порядке обхода....
Фольшепник 8 - 09.10.2004 13:50 | Там есть такая фигня. Кнопка по горячим клавишам до поры до времени работает, причем может быть и невидимой. Потом, если втулить на форму еще одну кнопку, она будет "выше" твоей. Тупой и эффективный выход - вырежь свою в буфер и вставь, только потом идентификатор (если есть) подправь на старый. Будет работать до тех пор, пока не сотворишь новую кнопку на форме.


Про журналы подчиненых документов... | База знаний | mista.ru

Про журналы подчиненых документов...

At 11.10.2004 18:14 | Можно ли сделать красивую форму для журнала подчиненых документов?
Лошадка в пальто 1 - 11.10.2004 18:17 | Да
At 8 - 11.10.2004 18:31 | мне просто хотелось добавить в журнал подчиннёных еще одну графу, которая имеет смысл только для одного из видов документа.. а насколько я понял журнал подчиненных используется один для всех документов?
Warlock 9 - 11.10.2004 23:27 | (8)Ты прав, "журнал подчиненных используется один для всех документов". Создаешь общий журнал и отмечаешь флажок "Использовать как журнал подчиненных документов" и настраиваешь форму так, как тебе нравится.


Как в табличную часть формы списка справочника добавить колонку | База знаний | mista.ru

Как в табличную часть формы списка справочника добавить колонку

Мишка на сеРвере 08.10.2004 09:06 | Подскажите тупому как в табличную часть формы списка справочника добавить колонку с идентификатором, не являющимся индентификатором элемента справочника?
F427 3 - 08.10.2004 09:12 | Вставить реквизит... Вставить текстовый реквизит... Вставить текстовый реквизит в табличную часть...
SnarkHunter 11 - 08.10.2004 09:26 | Меню Вставка - Текст, курсор мыши на ТЧ справочника, клик...


Checkbox'ы в табличной части документа | База знаний | mista.ru

Checkbox'ы в табличной части документа

Абрикос
04.10.2004 16:22 		Добрый день!

Хочу сделать так чтобы можно было помечать строку документа чекбоксом.
Вывожу пиктограмму в простом текстовом поле (не реквизит). Надо, чтобы при двойном клике на эту пиктограмму - она менялась. Но при вводе строки пиктограмма меняется, потому что функция повешенная на колонку с пиктограммой почему-то вызывается для всех полей табличной части.
Вот код:

// ====================================================================
Функция ФлагОтветственного()
Если ("ОтвЛиИсп" = СокрЛП(Форма.ТекущаяКолонка())) Тогда
Если (1 = ОтветственныйЛиИсполнитель) Тогда
ОтветственныйЛиИсполнитель = 0;
Возврат(1);
КонецЕсли;
Если (0 = ОтветственныйЛиИсполнитель) Тогда
ОтветственныйЛиИсполнитель = 1;
Возврат(2);
КонецЕсли;
Иначе
Если (1 = ОтветственныйЛиИсполнитель) Тогда
Возврат(1);
КонецЕсли;
Если (0 = ОтветственныйЛиИсполнитель) Тогда
Возврат(2);
КонецЕсли;
КонецЕсли;
КонецФункции

Чего не так? Я же проверяю текущую колонку, а все равно чекбокс меняется при перемещении по строке (при вводе данных)

"ОтветственныйЛиИсполнитель" - Реквизит ТЧ
"ОтвЛиИсп" - Поле с пиктограммой
mszsuz
3 - 04.10.2004 23:29 		Попробуй так:
//_____________________________________________________________________________

Функция Флаг() // вызывается из формулы текстовой колонки

Возврат Флаг+1;

КонецФункции
//_____________________________________________________________________________

Процедура ПриНачалеРедактированияСтроки()

Если Форма.ТекущаяКолонка() = "ПиктограмаФлаг" Тогда
Флаг = 1 - Флаг;
СтатусВозврата(0);
КонецЕсли;

КонецПроцедуры


Как в форме списка справочника владельца отобразить элементы подчиненного? | База знаний | mista.ru

Как в форме списка справочника владельца отобразить элементы подчиненного?

vsa666 12.11.2004 11:10 | Не получается! Нарисовал в форме списка справочника Контрагенты еще одно ТабличноеПоле1 тип СправочникСписок.Договора, указал на нем связь по справочнику владельцу Контрагенты - не работает. Помогите!
Волшебник 5 - 12.11.2004 11:16 | (2) А нужно так: ЭлементыФормы.СпрКонтрагентыСписок.ТекущиеДанные
vsa666 7 - 12.11.2004 11:59 | Нашел на закладке "События": Связь по владельцу: СправочникСписок.ПриАктивизацииСтроки Все работает. Спасибо!


Открытие подч. справ. в табличной части на основе род. справ. в шапке | База знаний | mista.ru

Открытие подч. справ. в табличной части на основе род. справ. в шапке

Абрикос 15.10.2004 10:20 | Добрый день. Есть два справочника: "Размерные сетки" и, подчиненный ему "Размеры". В шапке документа - реквизит - Справочник.РазмерныеСетки. В табличной части - реквизит - Справочник.Размеры. Как сделать, чтобы при выборе РазмернойСетки в шапке документа, при вводе строк в табличной части открывался подчиненный справочник Размеры?
Шапокляк 1 - 15.10.2004 10:26 | В таблице в свойствах колонки заполни "Связан с"


Будни: Организация подбора на 8.0 | База знаний | mista.ru

Будни: Организация подбора на 8.0

Волшебник
22.09.2004 00:02 		Начинающие программисты на 8.0 иногда затрудняются организовать подбор в 8.0. Подбирать можно все, что угодно: товары, контрагентов, сотрудников. Это типичная задача для автоматизированной системы, поэтому нельзя обойти это вниманием.

Но даже если вы многое знаете, прочитайте этот выпуск - есть некоторые тонкости.

-------------
Организация подбора на 8.0

1. Простой подбор

В форме размещаем кнопку "Подбор". Это может быть кнопка панели инструментов или отдельно стоящая кнопка.

В обработчике события Нажатие для кнопки пишем:

Процедура кпТоварыПодбор(Кнопка)

ФормаПодбора = Справочники.Номенклатура.ПолучитьФормуВыбора(,ЭтаФорма);
ФормаПодбора.ЗакрыватьПриВыборе = Ложь;
ФормаПодбора.Открыть();

КонецПроцедуры

При этом происходят довольно интересные вещи:

1. В первой строке получаем форму выбора. Это особая форма, которая может не совпадать с формой списка (а может совпадать). Форму выбора можно создать самому, или она будет сгенерирована системой автоматически, или форма списка может работать в режиме выбора.

Если вы получили не форму подбора, а обычную форму (методом ПолучитьФорму или ПолучитьФормуСписка), то по умолчанию у нее не установлено свойство РежимВыбора. Нужно или установить это свойство в Истина, или оповещать о выборе элемента самостоятельно (см. метод формы ОповеститьОВыборе).

а) Первым параметром можно передать имя формы или объект описания метаданных типа формы. Если у объекта несколько форм выбора, то здесь можно указать, какую форму нужно использовать.

б) Вторым параметр указывается владелец формы - форма или элемент управления, из которого производится вызов формы выбора. После совершения выбора именно владельцу формы будет послано оповещение о выборе, которое инициирует событие "ОбработкаВыбора" (у формы или элемента формы).

в) Третьим параметром можно указать ключ уникальности для поиска среди уже открытых форм. Если форма с таким ключом уникальности будет найдена, то будет возвращена именно она. Это удобно, если не нужно открывать новых форм выбора.

2. Вторая строка устанавливает режим, при котором после выбора значения форма не будет закрываться, т.е. это и и есть основная функция подбора. При множественном выборе это свойство имеет смысл установить в Истина, но об этом ниже. Здесь же можно присвоить и другие свойства открываемой формы, например, расположение на экране, задать значения реквизитов формы или экспортных переменных модуля формы.

3. Третья строка открывает форму выбора. После первой строки форма еще не была открыта, но ее модуль уже был скомпилирован и инициализирован.

В свойствах формы должен быть назначен обработчик события "ОбработкаВыбора".

Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)

Если ТипЗнч(ЗначениеВыбора) = Тип("СправочникСсылка.Номенклатура") Тогда

Строка = Товары.Найти(ЗначениеВыбора,"Номенклатура");
Если Строка = Неопределено Тогда
Строка = Товары.Добавить();
Строка.Товар = Товар;
Строка.Количество = 1;
Иначе
Если Вопрос("Такой товар уже есть (" + СокрЛП(Товар) + ")! Увеличить кол-во?", РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Да Тогда
Строка.Количество = Строка.Количество + 1;
КонецЕсли;
КонецЕсли;

КонецПроцедуры

---------------------------------
2. Множественный выбор

При таком выборе пользователь может выделить сразу несколько элементов (например, с помощью клавиши Ctrl) и после нажатия кнопки "Выбрать" система вернет массив выбранных элементов, а не один элемент, как в первом случае.

Процедура кпТоварыПодбор(Кнопка)

ФормаПодбора = Справочники.Номенклатура.ПолучитьФормуВыбора(,ЭтаФорма);
ФормаПодбора.МножественныйВыбор = Истина;
ФормаПодбора.ЗакрыватьПриВыборе = Ложь;
ФормаПодбора.Открыть();

КонецПроцедуры

Тогда обработчик события ОбработкаВыбора можно написать так:

Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)

МассивВыбранныхЭлементов = Новый Массив;

Если ТипЗнч(ЗначениеВыбора) = Тип("СправочникСсылка.Номенклатура") Тогда
МассивВыбранныхЭлементов.Добавить(ЗначениеВыбора);

ИначеЕсли ТипЗнч(ЗначениеВыбора) = Тип("Массив") Тогда
МассивВыбранныхЭлементов = ЗначениеВыбора;
КонецЕсли;

Для каждого Элемент Из МассивВыбранныхЭлементов Цикл
//действия с очередным элементом
КонецЦикла;

КонецПроцедуры

-------
Вот, собственно, и все. Подбор - легкая вещь, если понимаешь, что происходит.


Автоматическое тестирование функционала конфигураций 1С | База знаний | mista.ru

Автоматическое тестирование функционала конфигураций 1С

fez
14.07.2004 15:24 		Брать тут: http://1c.alterplast.ru/functest/index.html
.
Зачем нужна эта дура: вкратце
Наши ожидания от функционала любой программы (в том числе и конфигурации 1С) можно записывать в виде, понятном для компьютера. И затем использовать эти записи для автоматической проверки сохранения программой ожидаемого функционала.
Полезно для контроля над ошибками при внесении в программу изменений.
Так же может применятся, как способ написания ТЗ.


Скрипты | База знаний | mista.ru

Скрипты

Аврора 15.06.2004 09:37 | Как прописать скрипт в обработку CDExpVar? Дополнительный код формирую,а дальше?
SiMazx 2 - 15.06.2004 10:15 | Ручками... Открываешь CDExpVar.ert в пофигураторе и вставляешь в процедурку (она там последняя и в ней комментарий есть типа "Сюды пихать дополнительный код")
Аврора 3 - 16.06.2004 17:02 | спасиба Симазкс:)...а это обязательно делать в конфигураторе?...есть еще файл CDExpVar с расширением txt, а нельзя скопировать прямо в него?
SiMazx 5 - 16.06.2004 18:13 | (3) Если у тебя в CDExpVar.ert будет директива ЗагрузитьИЗФайла, тогда можно... Собственно для этого тхт туда и кладут...


Запуск внешней обработки для 7.7 из Windows с параметрами | База знаний | mista.ru

Запуск внешней обработки для 7.7 из Windows с параметрами

sheale 08.06.2004 12:31 | У меня есть скрипт: -------------------------------------------------------------- set wshShell = wScript.createObject("wScript.shell") wshShell.run """\\server\1Cv77.ADM\BIN\1cv7s.exe"" enterprise /d""D:\testdb\TS\DB\"" /nroot /ptralfamado" wScript.sleep 10000 'подождем пока загрузится (2 минуты) wshShell.appActivate "1С:Предприятие" wshShell.sendKeys "^(o)" wshShell.sendKeys "c:\my.ert" wshShell.sendKeys "~" -------------------------------------------------------------- Я хочу передать в открываемый отчет к-либо параметр, что бы считать его как Форма.Параметр
Валентин 3 - 08.06.2004 13:14 | Создай хмл файл куда загони нужные параметры. А из обработки читай их. Прокатывает. Но почему-то тормозит. Поэтому теперь пишу жестко прошитые параметры в ночные обработки
SnarkHunter 4 - 08.06.2004 13:22 | Ну файл можно и текстовый использовать для передачи параметров...
sheale 5 - 08.06.2004 13:25 | Мне нужно отличать, запущен отчет из windows или пользователем из меню.
SnarkHunter 6 - 08.06.2004 13:32 | Ну так при в процедуре ПриНачалеРаботыСистемы() проверяй ИмяПользователя()="root"...


Сравнение прайсов | База знаний | mista.ru

Сравнение прайсов

S_O_N_I_C 16.05.2004 19:36 | Ищу конфигурацию/обработку для сравнения прайсов и составления заказов Интересная тема, не знаю с какой стороны подойти. Если есть наработки скинте, премно-ого благодарен.
Gavrila 1 - 16.05.2004 19:38 | Сводный прайс-лист поставщиков (конкурентов). Обработка предназначена для генерации сводного прайс-листа поставщиков. В качестве исходных данных используются прайс-листы поставщиков в формате Microsoft Excel. Исходные прайс-листы не требуют предварительной подготовки. Обработка использует Microsoft Excel, как OLE объект для переброски данных. Для работы требуются небольшие изменения структуры метаданных. Прежде чем запускать обработку ознакомьтесь с файлом readme.1st. http://avb1c.narod.ru может это ? :)


Нужна внешняя обработка | База знаний | mista.ru

Нужна внешняя обработка

Aleksey 12.05.2004 19:44 | Всем Доброе время суток. Подскажите существует ли в природе обработка "Анализ продаж" по заявкам покупателей или нет. В комплексной стоит Анализ продаж на основе уже фактического отпуска товара, а мы работаем под заказ, и она нам совсем не подходит. Если есть у кого то скиньте , буду признателен. Спасибо
Aleksey 2 - 12.05.2004 21:31 | Нет, чтоб примерно видеть рентабельность продаж товара который ещё не опускался покупателю. Затяжка отпуска иногда бывает до 3 месяцев
Gavrila 3 - 12.05.2004 21:43 | Есть значит в укр. типовой торговле и комплексной отчетик "ОценкаПрибыльностиТоваров" позволяет видеть прибыль по оплате и по отгрузке товаров... в принципе должно такое же быть и российской, чем имно он не подходит?
Aleksey 4 - 12.05.2004 22:11 | В рус.такого отчёта нет.
It is me 5 - 12.05.2004 23:35 | To Gavrila: ABBYY и 1С, как говорят в Одессе - две большие разницы, так что судя по отзывам на форумах, каждую ночь перед отходом ко сну благославляй ABBYY...


Обработка .epf | База знаний | mista.ru

Обработка .epf

jetcom 12.05.2004 19:02 | Подскажите, плииз! Как подключается обработка с таким расширением???
¶ 1 - 12.05.2004 19:04 | Если в 7.7, то никак.
jetcom 2 - 12.05.2004 19:09 | Это к 8.0 ??? Тогда пнятненько!


Распечатка документов | База знаний | mista.ru

Распечатка документов

Sveta 06.05.2004 12:26 | Можно ли из внешней обработки распечатать документ. Например счет - фактуру выданный или ТОРГ 12
Sveta 7 - 06.05.2004 12:52 | Отчет ККМ. В процедуре ПриЗакрытии() вызывается обработка. В ней создаются документы Реализация, Счет - фактура выданный, и поступление ТМЦ, надо напечатать товарную накладную и счет - фактуру. Печатные формы копировать лень и процедуры печати перегонять тоже. Можно как - нибудь проще?
GrayT 8 - 06.05.2004 13:04 | О, это дело. Свет и вправду много :) Открой форму созданного документа параметром передай список значений сз.Установить("Команда", "ПечатьНаПринтер") сз.Установить("КолЭкз", .....) Это для реализации, ну а для счетов фактур сама посмотришь ПриОткрытии()


Как из внешней обработки открыть существующий документ? | База знаний | mista.ru

Как из внешней обработки открыть существующий документ?

Олег 03.05.2004 19:10 | Написал обработку. Создаю в ней документ, записываю его Документ.Записать(). Теперь хочу, чтобы он открылся, пишу Открыть(Документ), но ничего не происходит. Хелп плис!!!!
skunk 6 - 04.05.2004 10:16 | http://www.forum.mista.ru/topic.php?id=2384


Работа с FormEx | База знаний | mista.ru

Работа с FormEx

Wow__cooL
04.04.2004 23:29 		Пишу в модуле:
ФормаРасш = СоздатьОбъект("РасширениеФормы");
ФормаРасш.УстановитьФорму(Док.ТекущийДокумент());
Форм=ФормаРасш.ПОлучитьФорму();

Мне нужен доступ к атрибутам документа ДОк.ТекущийДокумент(), а именно к его многострочной части, к колонке Товар. Как до него добраться?
Wow__cooL
1 - 04.04.2004 23:30 		Причем сейчас он у меня привязывает к объекту не форму Док.ТекущийДОкумент(), а форму, с которой я сейчас работаю (форму обработки)
unior
2 - 05.04.2004 05:48 		Скорее всего нельзя обратиться к форме документа таким способом. FormEx наверное работает с активной открытой форомой (у тебя это форма обработки) и всё...

P|S а почему штатными средствами не хочешь обратиться к многострочной части? Или "Товар" у тебя не реквизит?
Mel
3 - 18.06.2004 11:10 		Скажите плиз. у меня вілетает 1С при работе с FormEx, как быть?
romix
4 - 18.06.2004 11:14 		(3) Попробуй первый раз запуститься под правами Админа, чтобы dll-ка зарегистрировалась.
(0) А что надо сделать с колонкой Товар? Цвет поменять?
Gavrila
5 - 18.06.2004 11:30 		(4) права админа ни причем


Вопрос по ActiveMD | База знаний | mista.ru

Вопрос по ActiveMD

Diter 16.07.2004 14:45 | Создовать с помощью этой компоненты реквизиты документов я научился, а вот как добавить в журнал новые графы и установить их значение - не пойму. Помогите!!! Ну очень надо.
Diter 18 - 19.07.2004 09:05 | И всётаки попробуем ещё раз закинуть вопрос. Итак, Для тех, кому лень лезть в начало беседы. Как добавить в журнал новые графы и установить их значение с помощью этой ВК- не пойму. Помогите!!! Ну очень надо
Diter 19 - 19.07.2004 09:10 | (17) Посмотрел - это несколько не то, что надо. Попробую более полно раскрыть ситуацию. Пишу свой МОД. Пользователь заполняет правила обмена в соответствующих справочниках. В т.ч. и выбирает документы, которые буду гоняться через модуль. Программа проверяет эти документы на присутствие реквизита (назовём его "признак"), в который записывается текущее состояние документа (готов, выгружен, загружен и т.п.). Если этого реквизита нет - программа копирует мд-шник, добавляет реквизит в документ и предлагает пользователю объединение текущей конфы и исправленной копии внести изменения. Так вот, получается с реквизитом всё ОК, а вот графы в журнал приходится пока вносить вручную, а такую операцию доверять юзеру не хотелось бы. Сам не всегда могу добраться до клиента (на то он и МОД - дальние расстояния). Вот и возник такой вопрос. А может кто ещё чего присоветует из этой области? Буду очень благодарен.
fez 27 - 19.07.2004 10:10 | (26) Разбираешь MD на запчасти. Смотришь в полученную структуру. Находишь в ней описание структуры документа. Смотришь в него. Думаешь. Потом добавляешь в документ реквизит сначала ручками из конфигуратора. Сохраняешь конфу, разбираешь gcomp'ом снова, но в другой каталог. Полученные каталоги сравниваешь с помощью kdiff3. Смотришь на разницу. Думаешь. По результатам думания пишешь скрипт, который будет совершать аналогичную работу автоматически. Скрипт пишешь на любом языке, который умеет работать с текстовыми файлами.
Zubr 53 - 19.07.2004 12:05 | Diter, в ActiveMD не реализовано то, о чем ты спрашиваешь.
Diter 56 - 19.07.2004 14:34 | Вопрос к fez Скачал ВК. пытаюсь её регистрить - ругается "не обнаружена точка входа". Чего делать?
fez 57 - 19.07.2004 14:36 | (56) "Скачал ВК." gcomp - это не внешняя компонента. Это консольное приложение. "Чего делать?" Запустить консоль (например FAR), пойти в каталог с gcomp.exe, запустить без параметров, прочитать то, что он напишет.
Diter 58 - 19.07.2004 15:37 | Так Федя. Значит разложил мд, внёс изменения разложил во второй каталог, сравнил. Нашёл отличия. Отличия в принципе только в двух файлах. Чего не нашёл - где прописаны значения новых граф и как мне взять код поля или реквизита новых граф. Да, ещё вопрос что это за программка для сравнения и где её можно взять. Ну и на последок - теперь что. Предположим я разберусь где, чего. Принцип работы какой ? Разобрали-внесли изменения-собрали? или как?
fez 59 - 19.07.2004 15:51 | (58) "Да, ещё вопрос что это за программка для сравнения и где её можно взять" http://sourceforge.net/projects/kdiff3/ "Принцип работы какой ? Разобрали-внесли изменения-собрали?" Да. "Чего не нашёл - где прописаны значения новых граф" Создай графу и сравни с помощью kdiff3. "как мне взять код поля или реквизита новых граф" Не понял вопроса. Внутренний идентификатор реквизита документа? Смотри в файлик Структура.mdp
Diter 60 - 19.07.2004 15:59 | (59) Не это я нашёл. Вопрос задан некорректно. Это код при работе через конфигуратор задаётся автоматом. При создании вручную, на этапе "внесли изменения" мне прийдётся его ставить вручную. Где и как мне его взять?
fez 61 - 19.07.2004 16:02 | (60) А. В (58) ты говорил про изменения в двух файлах. Один файл - это Структура.mdp того документа, в который ты добавил реквизит, а второй файл, это, очевидно, ИдентификаторыКонфигурации.mdp. Та циферка, которая в нем поменялась - это идентификатор, который будет следующим.
Diter 62 - 19.07.2004 16:30 | (61)Нет первый файл - это структура журнала, а второй - форми списка этого журнала, никаких файлов со списком ID-номеров системы 1С я не нашёл.
fez 64 - 19.07.2004 16:39 | "ИдентификаторыКонфигурации.mdp" в корне того каталога, в который распаковалась конфигурация.
Diter 65 - 19.07.2004 16:41 | Там строка {"MainDataContDef","3012","10009","7120"} Первая цифра - код для поля (вычеслил методом научного тыка) А остальные?
fez 66 - 19.07.2004 16:42 | Остальные оставляешь как есть.
Diter 67 - 19.07.2004 16:59 | Кстати прога эта kdiff3 не хочет работать. Ругается на недопустимую инструкцию. У меня ХР стоит. мож в этом дело? Да повторюсь "не нашёл - где прописаны значения новых граф" т.е. где прописано, что графа "Признак" это реквизит шапки документа с именем "Признак"?
fez 68 - 19.07.2004 17:03 | На циферки смотри. ГрафыОтбораДокументов.mdp: {"1019","Контрагент","Отбор по контрагенту","Контрагент","1","B","46", {"Refers", {"413"}, {"437"}, ... Вот 413, 437 и так далее - это идентификаторы тех реквизитов, которые входят в данную графу отбора.
Diter 70 - 19.07.2004 17:30 | (68) Эти строки из графы отбора, а графы, которые я добавляю не являются графами отбора для журналов. Так что это не то, о чём я спрашивал. А зачем вообще пользоваться этой прогой? Ведь все полученные файлы по сути своей текстовые. Так переименовать их и сравнить содержимое допустим TotalCommander-ом? Или я чего то не понимаю?
Diter 72 - 19.07.2004 17:54 | Операция самая простая. В документе (предположим счёт) программно создаётся реквизит (назовём его "Признак"). Мне необходимо добавить этот реквизит для отображения в журнал счетов. Я в конфигураторе захожу в этот журнал. Добавляю новую графу (называю "Признак1") и устанавливаю, что данные в графе "Признак1" будут браться из реквизита "Признак" шапки документа "счёт". Вот это значение (т.е. ссылку на конкретный реквизит шапки документа) я и не нашёл.
fez 73 - 19.07.2004 17:58 | А, ну это еще проще. ЖурналыДокументов\АвансовыеОтчеты\Структура.mdp {"5448","АвансовыеОтчеты","Журнал учета авансовых отчетов","Авансовые отчеты","-1","0","5451","5451","0", {"15372","","","", {"Refers"} }, {"JournalFld", {"5449","ФИО","ФИО","", {"Refers", {"6646"} } 6646 - это и есть идентификатор реквизита в документе.


Что такое проект "Rainbow" | База знаний | mista.ru

Что такое проект "Rainbow"

busy1 26.06.2004 15:32 | Расскажите пожалуйста подробнее, наверняка штука интересная
Тот 1 - 26.06.2004 17:00 | В переводе с английского - "Радуга".
АЛьФ 7 - 28.06.2004 14:08 | rainbow.hare.ru


Нужен DocFile Browser для Far | База знаний | mista.ru

Нужен DocFile Browser для Far

SiMazx 18.06.2004 10:10 | Срочно нужен сабж!!! В поиске ссылки битые или у меня руки кривые - не суть важно. Кто может помочь - sinmax(гав)mail.ru
SnarkHunter 2 - 18.06.2004 10:14 | http://plugring.farmanager.com/downld/files/fdb102.zip


Внешняя компонента для работы с файлами | База знаний | mista.ru

Внешняя компонента для работы с файлами

Dormancy 03.06.2004 14:28 | Подскажите, пожалуйста, существует ли готовая внешняя компонента для работы с файлами? В v7plus.dll есть методы для работы со строками текстового файла, а мне нужно читать/записывать байты.
mszsuz 1 - 03.06.2004 14:42 | http://www.sinor.ru/~my1c/knowhow/chr0.html


Как подключить внешнюю компоненту в 1С? | База знаний | mista.ru

Как подключить внешнюю компоненту в 1С?

Oksa
03.06.2004 11:51 		Как подключить внешнюю компоненту в 1С? конкретно пытаюсь подключить FormEx. объяснения типа как в хелпе "Компонента подключается в соответствии с "Технологией создания внешних компонент". Т.е. для ее загрузки необходимо вызвать функцию ЗагрузитьВнешнююКомпоненту("FormEx.dll")" не понимаю :) поподробнее пожалуйста подскажите. и как потом этой компонентой пользовать тоже не понятно
Michael99
3 - 03.06.2004 11:56 		// Загрузка Formex
Попытка
//создаем объект "Сервис". если компонента не установлена методом подмены dll, то сработает исключение
Сервис = СоздатьОбъект("Сервис");
Исключение
//пытаемся загрузить компоненту в формате штатной ВК
Если ЗагрузитьВнешнююКомпоненту("FormEx.dll") = 0 Тогда
Предупреждение("Неудачная попытка загрузить FormEx.dll");
СтатусВозврата(0);
Возврат;
КонецЕсли;
КонецПопытки;
Oksa
5 - 03.06.2004 12:28 		хех, вот я тупая.... :) оказывается у меня уже все давно работает, а я ищу чего-то сама не знаю чего :) надо ж просто процедурки новые использовать и все будет видно :)) сегодня туплю, дождь наверное достал


Помогите с внешней компоненетой!!! | База знаний | mista.ru

Помогите с внешней компоненетой!!!

Hd 31.05.2004 13:49 | Какого фига после использования в ВК AppDispatch.EvalExpr() 1Ска остается в фоновом режиме. Т.е Done вообще не вызывается, до него дело и недоходит. Все объекты обнулил. Пробовал на Delphi и VB?
Рупор абсурда 4 - 31.05.2004 13:59 | Для использования интерфейса AppDispatсh необходимо у него вызвать метод AddRef, который увеличивает счетчик ссылок на объект интерфейса. Сублимированный опыт работы с внешними компонентами в 1С:Предприятии (collected from Kuban.ru by Soaron (C) 2001)
DimG 6 - 31.05.2004 15:08 | (5)яндексом пользоваться умеем? http://www.yandex.ru/yandsearch?rpt=rad&text=collected+from+Kuban.ru+by+Soaron+%28C%29+2001 - первая ссылка.


RainBow : как получить ID поля даты документа? | База знаний | mista.ru

RainBow : как получить ID поля даты документа?

Василий 23.04.2004 14:54 | Хочу сделить прямой SQL-запрос с использованием Rainbow. не могу получить ID поля даты документа :( Пробую так : ЗагрузитьВнешнююКомпоненту("Rainbow.dll"); Мета=создатьОбъект("MetaDataWork"); ИДДат="sp"+Мета.ИДРеквизитаШапки("ОказаниеУслугПациенту","ДатаДок") а оно выдает ошибку. Кто работал с этой штукой? подскажите плз!!!
SnarkHunter 1 - 23.04.2004 14:56 | ДатаДок - это не реквизит шапки...
Василий 4 - 23.04.2004 15:09 | ну.. не только для справочников. Вот так же : ИДП="sp"+Мета.ИДРеквизитаШапки("ОказаниеУслугПациенту","Фамилия") ; работает без проблем... здесь SP - это наименование поля в таблице DHхх
SnarkHunter 5 - 23.04.2004 15:12 | Согласен, протупил... Для справочников, конечно же SC...
SnarkHunter 6 - 23.04.2004 15:12 | А дата документа хранится в журнале...
Василий 7 - 23.04.2004 15:13 | Понимаешь, тут если через ЕМ в SQL базу ручками влезть, видно что требуется поле SP138 таблицы DH27, но как это функциями Rainbow вытащить?
Василий 8 - 23.04.2004 15:20 | опс.. теперь я протупил... т.е. надо дёргать _1CJOURN ? насколько я понимаю... там хранятся записи о всех документах системы?
SnarkHunter 9 - 23.04.2004 15:22 | Так точно...
Василий 10 - 23.04.2004 15:27 | Тогда такой вопрос. Зачем дублируется информация в полях IDDOC и DATE_TIME_IDDOC?
SnarkHunter 11 - 23.04.2004 15:28 | По этим полям индексы имеются...
Валентин 12 - 29.05.2004 21:59 | И попутно вопрос, каким образом сохранено время в поле DATE_TIME_IDDOC? Подскажите кто знает
Валентин 14 - 29.05.2004 22:07 | Да. И если можно то поподробнее про время в 1С вообще. Можно и про получение периодических реквезитов sql-запросом (мой запрос сравнивающий дату и идентификатор документа медленно шевелиться)
Волшебник 15 - 29.05.2004 22:10 | См. также: http://1csql.udmnet.ru/toysql/index.shtml
SnarkHunter 16 - 29.05.2004 22:16 | Поле DATE_TIME_IDDOC - 23 символа: 1. Дата - 8 символов - ГГГГММДД 2. Время - 6 символов - кол-во секунд с начала суток * 10000 (по основанию 36) 3. ИД дока - 9 символов
Валентин 17 - 29.05.2004 22:19 | Спасибо за формат. А про запрос к периодическим реквизитам? Может какие идеи есть? Я слизал запрос указываемый 1С при работе с периодическими реквизитами, но как-то очень уж медленно все получается ...
Валентин 19 - 29.05.2004 22:31 | Есть периодический реквизит (его ид- 38, имя - ЦенаПриобретения) Есть репистр партии товаров и соответственно журнал документов (речь идет про ТиС) select top 1 h.sp1131 as goodsId, h.idDoc as currentDoc, s.value from ra1130 h, _1SConst s, _1SJournal t where s.objid=h.sp1131 and h.iddoc=t.iddoc and s.date<=convert(datetime,subdtring(DATE_TIME_IDDOC,1,4)+'-'+substring(DATE_TIME_IDDOC,5,2)+'-'+substring(DATE_TIME_IDDOC,7,2) and s.iddoc<=t.iddoc order by h.date но вот это все очень медленно. Хотелось бы побыстрее
Валентин 20 - 29.05.2004 22:38 | В смысле order by s.date (ночь все таки и субота опять же... спать хочу)
SnarkHunter 21 - 29.05.2004 22:49 | Слушай... По-моему ты сам себя перехитрил... В таблице _1sJourn есть ведь поле DATE...
Валентин 22 - 29.05.2004 22:58 | Поле date усть в константах (_1SConst) в _1SJourn если специльно не вводить лбщий реквизит шапки МояДатаДок нет упоминния о дате. Сейчас посмотрел представление времени. Бред. Или просто ночь. Но добавил проверку на время и рычаги увеличелись на 31% согласно профайлера. Да кстати. У меня попутно вопрос. Почему часть идентификаторов в 36-ричной, а часть в 10-ричной системе? И зачем нужен этот зверь - 36-ричная система?
SnarkHunter 23 - 29.05.2004 23:21 | (22)Согласен, прогнал... Глянул DD вместо DDS... :-) По поводу систему счисления - считай, что так сложилось исторически... Запросы, которые создает 1С при обращении к серверу нужно использовать в качестве пособия как НЕ нужно писАть запросы ИМХО... Основные тормоза в твоем запросе дает convert скорее всего...


Не удается загрузить внешнюю компоненту | База знаний | mista.ru

Не удается загрузить внешнюю компоненту

Сергей 17.05.2004 15:55 | Не удается загрузить внешнюю компоненту AzimuthAX.dll. Пишет "отсутствует CLSID". В чем может быть проблема?
GrayT 1 - 18.05.2004 01:06 | Может ее надо зарегистрить regsvr32 AzimuthAX.dll?
Волшебник 2 - 18.05.2004 01:08 | еще для регистрации нужны права локального админа, чтобы был доступ к реестру


1C и буфер обмена | База знаний | mista.ru

1C и буфер обмена

Vitaliy 29.04.2004 16:39 | Надо картинку из буфера средствами 1С писать в файл, а в базу имя этого файла. Как попроще извернуться? Типа, юзверь принтскринит экран и сохраняет его в 1С (минихелпдескдляособоленивых)
Gavrila 1 - 29.04.2004 18:02 | Внешние компоненты ищи! :)
¶ 2 - 29.04.2004 20:04 | Ради потехи сваял такую dll-ку. Работает, пишет в формате bmp. Если надо - свети мыло, вышлю.


Как получить список работающих пользователей? | База знаний | mista.ru

Как получить список работающих пользователей?

Символ
14.10.2004 14:49 		Как в 7.7 для SQL получить список работающих в данный момент пользователей (тех, что в мониторе пользователей)?
Как все запущено
9 - 14.10.2004 16:20 		(7) Понял. Расписываю известную всем истину, которая по непонятным причинам неизвестна магу и волшебнику 1С-а.
Список активных пользователей содержится в файле syslog\links.tmp. Для определения активности записи используется залочивание (LockFile) одного байта в этом файле со смещением 2000001+ номер записи.
белый и пушистый MMF
12 - 14.10.2004 19:29 		(11) Рискую быть заплеваным за очевидные недостатки нижеприведенного модуля (но "работает - не трожь). Возможно, пригодится кому-нибудь.

метод ВК, возвращающий таблицу значений с информацией о подключениях
Function TAddInObject.GetLinks(): OleVariant;
var
Obj1C: OleVariant;
LinksWork: TLinksWork;
i: integer;
begin
Obj1C:= OleVariant(pCon).AppDispatch;
IDispatch(obj1C)._AddRef;
Result:=Obj1C.CreateObject('ТаблицаЗначений');
Result.NewColumn('Имя', 'Строка');
Result.NewColumn('Режим', 'Строка');
Result.NewColumn('Компьютер', 'Строка');
Result.NewColumn('ВремяВхода', 'Строка');
try
LinksWork:=TLinksWork.Create;
if LinksWork.CheckLinks(Obj1C.IBDir+'\Syslog\Links.tmp') then
for i:=0 to LinksWork.Count-1 do
begin
Result.NewLine;
Result.Имя:= LinksWork.Links[i]^.usrName;
Result.Режим:= LinksWork.Links[i]^.usrMode;
Result.Компьютер:= LinksWork.Links[i]^.usrComp;
Result.ВремяВхода:= LinksWork.Links[i]^.usrTime;
end;
finally
if Assigned(LinksWork) then LinksWork.Free;
End;
end;

вспомогательный модуль

unit LinksWork;

interface
uses Windows, SysUtils, Classes;

type
//элемент - подключение пользователя
TLinkInfo = record
usrName: string;
usrMode: char;
usrTime: string;
usrComp: string;
end;
PLinkInfo=^TLinkInfo;

TLinksList=Class(TList)
end;

TLinksWork=class
protected
function Get(Index: Integer): PLinkInfo;
private
FFileName: string;
FFileHandle: THandle;
FMapHandle: THandle;
FFileOpened: Boolean;
FLinks: TLinksList;
FDataSize: Integer;
PData: PByte;
function GetFileIsOpened: Boolean;
function GetLinksCnt: integer;
Function OpenFile(): boolean;
Procedure CloseFile();
function CreateFileMap: Boolean;
Function TestRecordAlive(RecNum: integer): boolean;
public
Constructor Create;
Destructor Destroy; override;
procedure Clear;
property Count: Integer read GetLinksCnt;
property FileIsOpened: Boolean read GetFileIsOpened;
property Links[Index: Integer]: PLinkInfo read Get; default;
function CheckLinks(FileName: string): boolean;
end;

implementation

{ TLinksWork }

//*****************************************************************************
//определим, является ли запись живой, для этого
//попытаемся залочить байт по адресу 2000001+ номер записи
//*****************************************************************************
function TLinksWork.TestRecordAlive(RecNum: integer): boolean;
var LockAddr: integer;
begin
if not (FFileOpened) then
begin
Result := False;
Exit;
end;
LockAddr:=$1E8481 + RecNum - 1;
Result := True;
if not (LockFile(FFileHandle, LockAddr, 0, 1, 0)) then Exit;
Result := False;
UnLockFile(FFileHandle, LockAddr, 0, 1, 0);
end;

function TLinksWork.CheckLinks(FileName: string): boolean;
var
usrName, usrTime, usrComp: string;
Cur, UsrMode: char;
PTempData: Pchar;
RecNum, DataSize: integer;
Item: PLinkInfo;
strWin: string[8];

procedure AppendChar(c: Char);
var i: byte;
begin
for i := 1 to 7 do strWin[i] := strWin[i + 1];
strWin[8] := c;
end;
procedure StepOut();
begin
inc(PTempData);
Dec(DataSize);
end;
function GetSubstr():string ;
begin
Result:='';
repeat
StepOut;
Result := Result + PTempData^;
until (PTempData^ = '"') or (DataSize = 0);
end;

begin
FFileName:=FileName;
Result:=false;
Clear;
if FFileOpened then CloseFile;
if Not(OpenFile) then Exit;
if not (CreateFileMap()) then Exit;

PTempData := PChar(PData);
strWin := '12345678';
RecNum := 0;
DataSize:=FDataSize;
while DataSize > 0 do
begin
cur := PTempData^;
//ищем строку "Name","
AppendChar(Cur);
if StrWin = '"Name","' then
begin
UsrName:='';
usrMode := '?';
usrTime := '';
usrComp := '';
usrName:=GetSubstr;
usrName := Copy(UsrName, 1, Length(usrName) - 1); //удалили правую кавычку
Inc(RecNum);
//ищем режим запуска
//' mode","'
strWin := '12345678';
while DataSize > 0 do
begin
//ищем строку ' mode","'
cur := PTempData^;
AppendChar(Cur);
if StrWin = ' mode","' then
begin
//считываем букву режима
AppendChar(Cur);
StepOut;
Cur := PTempData^;
case Cur of
'E': UsrMode := 'П';
'C': UsrMode := 'К';
'M': UsrMode := 'М';
'D': UsrMode := 'О';
end;
Break;
end;
StepOut;
end;

//определяем время входа
//&Time","
strWin := '12345678';
while DataSize > 0 do
begin
//ищем строку '&Time","'
cur := PTempData^;
AppendChar(Cur);
if StrWin = '&Time","' then
begin
UsrTime:=GetSubstr();
break;
end;
StepOut;
end;

strWin := '12345678';
while DataSize > 0 do
begin
//ищем строку 'rName","'
cur := PTempData^;
AppendChar(Cur);
if StrWin = 'rName","' then
begin
UsrComp := GetSubstr;
break;
end;
StepOut;
end;

//добавляем считанную информацию
if TestRecordAlive(RecNum) then
begin
UsrComp := Copy(UsrComp, 1, Length(usrComp) - 1);
UsrTime := Copy(UsrTime, 1, Length(usrTime) - 1);
New(Item);
Item^.usrName:=UsrName;
Item^.usrMode:=UsrMode;
Item^.usrTime:=UsrTime;
Item^.usrComp:=UsrComp;
FLinks.Add(Item);
end;
strWin := '12345678';
end;
StepOut;
end;
CloseFile;
Result:=True;
end;

procedure TLinksWork.Clear;
begin
FLinks.Clear;
end;

procedure TLinksWork.CloseFile;
begin
if FFileOpened then
begin
CloseHandle(FFileHandle);
CloseHandle(FMapHandle);
UnmapViewOfFile(PData);
FFileOpened:=false;
end;
PData:=Nil;
FFileHandle:=0;
FMapHandle:=0;
end;

function TLinksWork.CreateFileMap: Boolean;
begin
result := False;
FDataSize := GetFileSize(FFileHandle, nil);
FMapHandle := CreateFileMapping(FFileHandle, nil, PAGE_READWRITE, 0, FDataSize,
nil);
if FMapHandle = 0 then Exit;
PData := MapViewOfFile(FMapHandle, FILE_MAP_ALL_ACCESS, 0, 0, FDataSize);
if PData = nil then Exit;
Result := True;
end;

destructor TLinksWork.Destroy;
begin
Clear;
CloseFile;
if Assigned(FLinks) then FreeAndNil(FLinks);
inherited;
end;

function TLinksWork.Get(Index: Integer): PLinkInfo;
begin
Result:=Nil;
if Index>FLinks.Count then
begin
raise Exception.Create('Неверный индекс подключения');
Exit;
end;
Result:=PLinkInfo(FLinks[Index]);
end;

function TLinksWork.GetFileIsOpened: Boolean;
begin
Result:=FFileOpened;
end;

function TLinksWork.GetLinksCnt: integer;
begin
Result:=FLinks.Count;
end;

function TLinksWork.OpenFile(): boolean;
begin
if Not(FileExists(FFileName)) then
begin
FFileOpened:=False;
Result:=False;
Exit;
end;
FFileHandle:=FileOpen(FFileName, fmOpenReadWrite or fmShareDenyNone);
result := FFileHandle >0;
FFileOpened:=Result;
end;

constructor TLinksWork.Create;
begin
inherited;
FLinks:=TLinksList.Create;
FFileOpened:=False;
end;
белый и пушистый MMF
14 - 14.10.2004 20:44 		(13) можно взять здесь: http://1c.proclub.ru/modules/mydownloads/personal.php?cid=5&lid=3171


FormEx и раскраска кнопки | База знаний | mista.ru

FormEx и раскраска кнопки

G-Re 24.09.2004 16:20 | Уважаемые коллеги! Почему-то так и не смог в кнопке написать что-то (Заголовок()) другим цветом. Совсем уж торможу. Спасибо.
АЛьФ 1 - 24.09.2004 16:39 | 2(0) Это потому что в FormEx такого функционала нет.


v7plus.dll | База знаний | mista.ru

v7plus.dll

Bekas
25.05.2004 22:21 		Скажите, а кроме v7plus.als есть какие-нибудь методические материалы?
bazvan
2 - 25.05.2004 22:24 		На ИТС какая то шняга была. С примерчиками всякими
Asmody
9 - 25.05.2004 23:25 		Чем не устраивает
Получить(URL, Приемник, ТипПриемника)

Помещает содержимое указанного ресурса в файл или указанную переменную, в
зависимости отуказанного типа приемника.
Волшебник
10 - 25.05.2004 23:32 		Вот про HTTP:
http://chin.dataltd.ru/index2.php?id=1c_http
http://money.karagandy.com/update.shtml

Вот про XML:
http://chin.dataltd.ru/index2.php?id=1c_xml

Вот про e-mail:
http://forum.mista.ru/topic.php?id=904 (нашел через Яндекс :)
http://www.perlscript.ru/v77_20.shtml
Bekas
11 - 25.05.2004 23:33 		устраивает. я не знаю, в каком виде скрипт должен отдать информацию и как ее обработать.
Предполагаю что-то типа такого:
URL="http://www.mysite.com?action=add&clientid=Клиент.Код&sum=100";
Получить(URL, MyVar, "String");
и обработать MyVar как строку?
Волшебник
12 - 25.05.2004 23:37 		Работа с HTTP с помощью v7plus.dll:

======================================================
Иногда возникает потребность в получении (импортировании) тех или иных данных из Интернета либо с веб-сайта компании, содержащихся в html-страничках, с последующей обработкой в импортирующей программе. Такими данными могут быть сведения о номеклатуре, товарные запасы, цены на товары, курсы валют, сведения о погоде в конце концов. В роли импортирующей программы может выступать 1С.

В качестве примера, рассмотрим задачу для получения курса валюты на заданную дату с сайта Центраьного Банка Российской Федерации. Превое, что нам нужно, это собственно узнать точный URL к страничке с необходимыми сведениями. Немного походив по сайту, такую страничку находим по адресу http://www.cbr.ru/currency_base/D_print.asp?date_req=datakursa. Собственно это не страничка, а скрипт, формирующий отчет о котировках валюты на заданную дату, передаваемую в datakursa.

В качестве инструмента для работы с HTTP-протоколом будем использовать стандартную бибилиотеку v7plus.dll, поставляемую самой 1С и содержащую необходимый нам класс V7HttpReader. Данный класс, позволяет получить страничку с заданного адреса в виде "текста", который мы можем проанализировать на наличие нужной нам информации.

Код, реализующий данный метод, довольно прост:

Попытка
Соединение= СоздатьОбъект("AddIn.V7HttpReader");
// используем запрос к версии для печати. Ответ меньше получается.
Соединение.Получить("http://www.cbr.ru/currency_base/D_print.asp?date_req="+Стр,Результат,2);
Соедиенение= 0;
Если ПустоеЗначение(Результат) = 1 Тогда
Предупреждение("Не получен ответ от интернет-ресурса www.cbr.ru");
Возврат;
КонецЕсли;

Поз= Найти(Результат,"Доллар США </td>");
ЕслиПоз= 0 Тогда
Предупреждение("В ответе интернет-ресурса не найден курс доллара!"+РазделительСтрок+
"Попробуйте использовать просмотр по всем валютам.");
Возврат;
КонецЕсли;

// просто вырезаем курс из html-файла
Если Найти(Результат,"не зарегистрированы") > 0 Тогда
Сообщить("На данную дату курсы валют не зарегистрированы","!!");
КонецЕсли;

Результат= Прав(Результат,СтрДлина(Результат)-Поз-36);
Поз= Найти(Результат, "<");
Результат= Лев(Результат,Поз-1);
Курс=Результат;

Исключение
Предупреждение("Ошибка при создании объекта доступа к интернет-ресурсу");
Возврат;
КонецПопытки;

В переменной Стр передается дата курса. Необходимые нам данные о курсе доллара содержатся между последовательностью символов "Доллар США </td>" и "<", кои собственно и "отлавливаем" с помощью оператора Найти(). "Очищенный" результат заносим в переменную Курс. Естественно, чтобы определить точное местоположение нужных данных, желательно иметь хоть какое-то представление о HTML-форматировании.
==========================================================
Источник: http://chin.dataltd.ru/index2.php?id=1c_http
Волшебник
13 - 25.05.2004 23:38 		Работа с XML с помощью v7plus.dll (создание XML-файла):

======================================================
XML , как известно, один из языков разметки. Подробно о нем можно прочитать в книге и в Инете. С его помощью легко реализовать древовидную структуру хранения данных , а также задать жесткие правила построения дерева, что уменьшит ошибки, связанные с доступом к данным.

Применительно к 1С с его помощью можно реализовать множество задач, в частности по документообороту внутри компании и с внешними корреспондентами, всевозможные переносы справочников и документов между конфигурациями, обмен данными с другими приложениями, поддерживающими формат XML.

XML-документ вкратце можно представить следующим образом. Верхним в иерархии является корневой элемент. Все остальные элементы (кроме сведений о формате файла) являются вложенными по отношению к нему (подчиненными), назовем их ветви. Каждый элемент, в т.ч. и корневой поименован. Каждый элемент имеет атрибуты, может содержать данные, а также может иметь множество других вложенных в него элементов.

В качестве примера разберем задачу по переносу приходно-кассовых ордеров и банковских выписок, формируемых оперативнм отделом с помощью ТиС в бухгалтерию. Код Вы можете посмотреть в ert-обработке. Данный пример показывает простые приемы работы со структурой XML-документа.

Примечание: Конфигурации ТиС и Бухгалтерии - переделанные на основе типовых, поэтому какие-то поля и реквизиты данных могут отличаться от Ваших.

Необходимо было обеспечить перенос сведений о поступлении денежных средств, формируемых оперативным отделом. Для этого предполагается выгружать из ТиС приходно кассовые ордера, выписки, а также справочники Контрагентов, Договоров и сведения о документах-основаниях. Справочник Номеклатуры выгрузке не подлежит, т.к. по учетной политике компании в бухгалтерии достаточно сведений о товародвижении только в разрезе 10-ти и 20-ти процентных ставках НДС на товар.

Код с пояснениями:

//Сначала проинициализируем компоненту v7plus, предоставляющую объекты для работы с XML:

Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "v7plus.dll") <> 1 Тогда
Если ЗагрузитьВнешнююКомпоненту(КаталогПрограммы() + "v7plus.dll") <> 1 Тогда
Предупреждение("Компонента v7plus.dll не найдена!");
КонецЕсли;
КонецЕсли;

Анализатор = СоздатьОбъект("AddIn.XMLParser");

//Теперь начнем строить дерево документа. Заодно занесем служебную информацию о файле выгрузки в атрибуты корневого элемента

Корень=Анализатор.СоздатьДокумент();
Данные =Корень.СоздатьПодчиненныйЭлемент("Данные");
Данные.УстановитьАтрибут("ИБ",КаталогИБ());
Данные.УстановитьАтрибут("Дата",Строка(РабочаяДата()));
Данные.УстановитьАтрибут("Оператор",ИмяПользователя());

Примечание: Пусть Вас не смущает, что открыв XML-документ, Вы увидите, что визуально корневым элементом будет элемент Данные. Просто в процессе разбирательства с работой с XML я задал такие имена переменным и стал использовать их в последующих разработках. Просто мне так привычнее.

//И создади две основные ветви Справочники и Документы

Справочники=Данные.СоздатьПодчиненныйЭлемент("Справочники");
Документы=Данные.СоздатьПодчиненныйЭлемент("Документы");
// в общей ветке Справочники создадим ветку для справочника Контрагентов
Клиенты=Справочники.СоздатьПодчиненныйЭлемент("Клиенты");

//А вот так заполняются элементы для справочников. Каждый реквизит справочника выносится в отдельный элемент дерева. Т.к. в данном задании выбрана схема синхронизации справочника Контрагентов по ИНН, то в значение элемента записываем ИНН, а для наглядности в атрибут элемента заносим наименование клиента

К=СписокКлиентов.ПолучитьЗначение(х);
Состояние("Выгружаются сведения по: " +К.Наименование);
Клиент=Клиенты.СоздатьПодчиненныйЭлемент("Клиент");
Клиент.УстановитьАтрибут("Наименование",К.Наименование);
Клиент.Значение=К.ИНН;
// выгружаем все нужные реквизиты контрагента
ПН=Клиент.СоздатьПодчиненныйЭлемент("ПолнНаименование");
ПН.Значение=К.ПолнНаименование;
ВК=Клиент.СоздатьПодчиненныйЭлемент("ВидКонтрагента");
ВК.Значение=К.ВидКонтрагента.Идентификатор();
// и так далее по всем необходимым реквизитам, аналогично заполняется информация о документах в соответствии с разработанной схемой обмена с бухгалтерией.

// Завершающие шаги и сохранение файла
ИмяФайла= СтрЗаменить(Строка(ДатаВыгрузки)+Строка(ДатаВыгрузки1),".","") + ".xml";
ПапкаФайла= "C:\1C\Change\Sweet\";
Корень.Записать(ПапкаФайла+ИмяФайла);

Полученный файл Вы можете посмотреть в Интернет Эксплорере или в любом другом просмотрщике xml-документов.

===========================================================

Источник: http://chin.dataltd.ru/index2.php?id=1c_xml1
Волшебник
14 - 25.05.2004 23:40 		Работа с XML с помощью v7plus.dll (создание XML-файла):

===========================================================
В первой части статьи были рассмотрены простейшие приемы работы по созданию XML-документа. В этой части будут описаны способы получения данных.

Основным моментом, на который я хотел бы обратить Ваше внимание, является следующее правило: сперва с помощью методов .ВыбратьУзел() или .ВыбратьУзлы() производится выборка узла/элемента, а затем с помощью методов соответственно .ПолучитьПодчиненныйПоНомеру() и .ПолучитьУзел() обеспечивается непосредственный доступ к узлам/элементам документа. Впрочем, здесь можно провести аналогию работы со справочниками и документами в 1С: сначала делаем выборку с помощью .ВыбратьЭлементы() или .ВыбратьДокументы(), а затем получаем сами объекты .ПолучитьЭлемент() или ПолучитьДокумент().

Оба приема используются в данном примере.

Код с пояснениями:

Инициализацию компоненты опустим. Для чтения она ничем не отличается.

//создадим объект для доступа к xml-файлу, загрузим в него файл и получим ссылку на корневой элемент xml-документа. Напомню, что у нас он назван "Данные"
ФайлДанных=Анализатор.СоздатьДокумент();
ФайлДанных.Загрузить(ФайлЭксп);
ВсеУзлы=ФайлДанных.ВыбратьУзлы("Данные");

// получаем доступ к корневому узлу/элементу и читаем его атрибуты
Данные=ВсеУзлы.ПолучитьУзел(0);
Сообщить("Идет загрузка данных из базы: " +Данные.ПолучитьАтрибут("ИБ"));
Сообщить("Выгрузка производилась: " +Данные.ПолучитьАтрибут("Дата"));
Сообщить("Выгрузку произвел/произвела: " +Данные.ПолучитьАтрибут("Оператор"));

Примечание: на данном этапе через переменную Данные мы имеем доступ к корневому узлу/элементу всего документа.

// следующими операторами мы получаем доступ к двум основным ветвям: ветки Справочники и ветке Клиенты
Справочники=Данные.ВыбратьУзел("Справочники");
Документы=Данные.ВыбратьУзел("Документы");

// "спускаемся" по иерархии глубже и получаем доступ к элементу Клиенты, Выписки и Приходники
Клиенты=Справочники.ВыбратьУзел("Клиенты");
Выписки=Документы.ВыбратьУзел("Выписки");
Приходники=Документы.ВыбратьУзел("Приходники");

//если очень интересно сколько прийдется загружать Контрагентов, то можно воспользоваться следующей конструкцией
Сообщить("Количество клиентов: " + Строка(Клиенты.КоличествоПодчиненных()));

// организация перебора всех элементов узла Клиенты
Длях= 1 ПоКлиенты.КоличествоПодчиненных() Цикл
Клиент=Клиенты.ПолучитьПодчиненныйПоНомеру(х);
ИНН=Клиент.Значение;
ЕслиПустоеЗначение(ИНН) = 1 Тогда
Сообщить("Ошибка. В файле выгрузки не задан ИНН клиента " +Клиент.ПолучитьАтрибут("Наименование"),"!!");
Продолжить;
КонецЕсли;
КонецЦикла;

Как видите ничего сложного в работе с XML нет. Чтобы не запутаться перед началом работы по созданию той или иной схемы обмена желательно нарисовать/составить четкую структуру переносимых данных, определить какие данные и характеристики будут выгружаться и что к чему относится. Как раз для этого и предназначены "Схемы данных", но о них мы поговорим в слудующих статьях.

===========================================================
Источник: http://chin.dataltd.ru/index2.php?id=1c_xml2
Asmody
15 - 25.05.2004 23:41 		(11)
ТипПриемника=1 - Значение переменной Приемник интерпретируется как путь к файлу, в который следует записать содержимое ответа сервера.
ТипПриемника=2 - ответ сервера запоминается в переменной Приемник в виде строки.
ТипПриемника=3 - переменная Приемник должна иметь тип объекта OLE-Automation, имплементирующего интерфейс IStream. Cодержимое ответа будет передано этому интерфейсу, способ обработки этих данных будет зависеть от реализации OLE-объек та.


Отправка файла | База знаний | mista.ru

Отправка файла

WiND 22.06.2004 13:37 | Каким образом корректно отправить файл средствами 1С на веб сервер? Я пробую через методы v7plus.dll, но, ничего не получается
Gruz 1 - 22.06.2004 13:45 | Я сейчас отправляю файлы 2-мя способами: 1. Можно использоавть V7plus.dll и выгружать через HTTP 2. Можно использовать FTP.exe и метод КомандаСистемы() Что конкретно не получилось с V7plus? Опиши поподробнее ...
колодина 2 - 22.06.2004 13:46 | а можно внешнюю компоненту, на хиппе есть очень неплохие, сама использую однй из них.


Положить прайс zip на сайт с помошью v7plus | База знаний | mista.ru

Положить прайс zip на сайт с помошью v7plus

Gruz
28.06.2004 19:14 		Пишу нечто вроде ...
HTTP.ОтправитьДляОбработки(АдресСайта+"/getzip.php", ПутьПрайса, 1, Ответ, 2);

Вопрос в том, как в PHP достать это прайс ???
shura
4 - 29.06.2004 04:33 		Загрузка методом POST
PHP способен принимать загрузку файлов из любого RFC-1867-соответствующего браузера (в том числе - Netscape Navigator 3 и новее, Microsoft Internet Explorer 3 с патчем от Microsoft или новее без патча). Это даёт возможность загружать текстовые и бинарные файлы. С помощью функций РНР для аутентификации и манипуляций с файлами вы получаете полный контроль над тем, кому разрешено загружать файлы, и над тем, что делать с файлом после его загрузки.

Заметьте, что PHP поддерживает также загрузку методом PUT, который используется в Netscape Composer и в Amaya-клиентах W3C. См. также "Поддержка метода PUT".

Экран загрузки файлов может быть создан с помощью специальной формы примерно так:Пример 19-1. Форма для загрузки файлов
<form enctype="multipart/form-data" action="_URL_" method="post">
<input type="hidden" name="MAX_FILE_SIZE" value="1000">
Send this file: <input name="userfile" type="file">
<input type="submit" value="Send File">
</form>

_URL_ должен указывать на PHP-файл. Скрытое поле MAX_FILE_SIZE обязано предшествовать полю ввода файла/file input field, и его значение это максимальный размер принимаемого файла. Значение в байтах.

Предупреждение!
MAX_FILE_SIZE является для браузера лишь уведомляющим. Легко обойти этот максимум. Поэтому не рассчитывайте, что браузер будет повиноваться вашим желаниям! Однако PHP-установки maximum-size обмануть нельзя.

Переменные, определяемые для загруженных файлов, зависят от версии PHP и конфигурации. Следующие переменные будут определены в скрипте назначения после успешного завершения загрузки. Если track_vars включена, инициализируется массив $HTTP_POST_FILES/$_FILES. Наконец, соответствующие переменные могут быть инициализированы как глобалы, если register_globals включена. Однако использовать глобалы больше не рекомендуется.

Примечание: track_vars всегда включена, начиная с версии PHP 4.0.3. Начиная с версии PHP 4.1.0, можно использовать $_FILES вместо $HTTP_POST_FILES.
$_FILES всегда является глобальной, поэтому global не должно использоваться для $_FILES в области видимости функции.

$HTTP_POST_FILES/$_FILES предоставлены для вмещения информации загруженных файлов.

Далее идёт содержимое $_FILES. Обратите внимание, что здесь предполагается использование имени 'userfile' для загружаемого файла, как в примере скрипта ранее:

$_FILES['userfile']['name']
Оригинальное имя файла на клиентской машине.

$_FILES['userfile']['type']
mime-тип файла, если браузер предоставил эту информацию. Пример: "image/gif".

$_FILES['userfile']['size']
Размер загруженного файла в байтах.

$_FILES['userfile']['tmp_name']
Временное имя файла, под которым загруженный файл был сохранён на сервере.

Примечание: в PHP версии до 4.1.0 она называлась $HTTP_POST_VARS и не была автоглобальной переменной. PHP 3 не поддерживает $HTTP_POST_FILES.

Если register_globals включена в php.ini, то будут доступны нижеследующие переменные. Обратите внимание, что имена этих переменных предполагают использование имя файла для загрузки 'userfile', как в примере предыдущего скрипта:

$userfile - Временное имя файла, под которым загруженный файл был сохранён на сервере.

$userfile_name - Оригинальное имя или путь к файлу на системе отправителя.

$userfile_size - Размер загруженного файла в байтах.

$userfile_type - mime-тип файла, если браузер предоставил эту информацию. Пример: "image/gif".

Заметьте, что часть "$userfile" этих переменных это имя, которое записано в поле <input> type="file" в форме загрузки. В предыдущем примере формы мы назвали её "userfile".

Примечание: register_globals = On не рекомендуется по соображениям производительности и обеспечения безопасности.

Файлы будут по умолчанию сохраняться во временной директории по умолчанию на сервере, если только не задано другое место директивой upload_tmp_dir в php.ini. Директория по умолчанию сервера может быть изменена через установку переменной окружения TMPDIR в среде, в которой работает PHP. Установка её с использованием putenv() из РНР-скрипта не будет работать. Эта переменная окружения может также использоваться для того, чтобы гарантировать, что другие операции также работают с загруженными файлами. Пример 19-2. Проверка загрузки файлов
Следующие примеры предназначены для версий PHP 4 выше 4.0.2. См. о функциях is_uploaded_file() и move_uploaded_file().

<?php
// В PHP ранее 4.1.0 должна использоваться $HTTP_POST_FILES вместо $_FILES.
if (is_uploaded_file($_FILES['userfile']['tmp_name'])) {
copy($_FILES['userfile']['tmp_name'], "/place/to/put/uploaded/file");
} else {
echo "Possible file upload attack. Filename: " . $_FILES['userfile']['name'];
}
/* ...или... */
move_uploaded_file($_FILES['userfile']['tmp_name'], "/place/to/put/uploaded/file");
?>

PHP-скрипт, который получает загружаемый файл, должен реализовывать логику, необходимую для определения того, что нужно сделать с загруженным файлом. Вы можете, например, использовать переменную $_FILES['userfile']['size'] для исключения файлов, которые слишком малы или велики. Вы можете использовать переменную $_FILES['userfile']['type'] для исключения файлов, которые не отвечают критериям определённого типа. При любой логике вы должны либо удалять, либо перемещать такие файлы из временной директории.

Файл будет удалён из временной директории по окончании запроса, если он (файл) не перемещён или не переименован.


прием Экселевского документа по почте из 1С... | База знаний | mista.ru

прием Экселевского документа по почте из 1С...

Aiuan 25.07.2004 20:37 | прием Экселевского документа по почте из 1С... как грамотнее осуществить?
Волшебник 1 - 25.07.2004 21:02 | Через v7plus.dll или OLE
Матрейя 2 - 25.07.2004 21:12 | 1. Автоматическое сканирование спецящика почтовой программой, автоматическое сохранение файлов в спецкаталог, автоматическое сканирование каталога из 1с. 2. Rom-Mail - самая мощная почтовая ВК для 1с (http://rom1c.narod.ru). ВК "Навигатор" - самая удобная ВК для открытия любых файлов в 1с. Автор: Токарев Антон (Употевший) hddragon@mail.ru


Отправка почты | База знаний | mista.ru

Отправка почты

Rider 11.06.2004 10:48 | Использую V7Plus.dll для отправки почты. Но выскакивает вопрос с подтверждением того что нужно оправить почту. Как можно убрать этот запрос?
Rom 1 - 11.06.2004 11:05 | Покрути настройки MS Outlook - м/б поможет.
lexa 3 - 11.06.2004 11:37 | параметры - безопасность
vf_01 6 - 11.06.2004 18:25 | Rider-у напиши пожалуйта мне на yunus@rambler.ru есть пару вопросов.
Рупор абсурда 7 - 11.06.2004 19:08 | http://rom1c.narod.ru/rom_mail.html И не забудь отправить в корзину эту глючную V7Plus ...


WEB-компонента | База знаний | mista.ru

WEB-компонента

tonic 07.06.2004 17:32 | Всем привет. Решил я тут на днях попробывать что есть web-компонента к 1С. Сделал все как написано в инструкции: настроил IIS, отконфигурил DCOM. Запускаю 1С:Предприятие с ключом /W. Пишу в адресной строке Браузера 127.0.0.1/имя каталога. В ответ мне IIS выплевывает что: Язык сценариев 'V7Script' не обнаружен на сервере:((( Большая прозъба объесните мне как правильно настроить этоту WEB-Компоненту. Спасибо.
tonic 4 - 08.06.2004 11:02 | 3- Да я сам стормознул, забыл DLL в системе зарегистрировать:))


работа 1с в сети Интернет? | База знаний | mista.ru

работа 1с в сети Интернет?

нач 26.05.2004 13:28 | Плиз, объясните пожайлуста как можно сделать такое: в одном здании магазин с выделенкой, в другом здании бухгалтерия с выделенкой, хотят одновременно работать с базой, с УРБД работать не хотят. С помощью чего и как можно это сделать??? Бух 7.7
lexa 1 - 26.05.2004 13:30 | http://www.mista.ru/articles1c/terminal.htm
gr13 2 - 26.05.2004 14:24 | http://www.forum.mista.ru/topic.php?id=3950 http://www.forum.mista.ru/topic.php?id=2115 посмотри здесь
BorisG 3 - 26.05.2004 15:14 | (2) Где в приведенных ветках ответ на поставленный в (0) вопрос? Все, что ему нужно, это поднять VPN, и запустить терминал.
romix 4 - 26.05.2004 15:19 | А за траффик платить они не хотят? Чем им УРБД не катит - ярлык на рабочем столе, и автообмен произойдет по двойному клику. Кстати, в УРБД можно выгрузку части данных (например, проводок из бухии в магазин - они там не нужны) не делать, проставив соотв. флажки в конфигураторе.
lexa 5 - 26.05.2004 15:23 | (4) я вот только не пойму причем магазин и бух 7.7, префиксы на ИБ поставил и не каких проблем с задвоением документов и справочников, опять же свежий архив, а (3) - надо толковых спецов искать


Как можно на фтпэшник закинуть файл из среды 1С? | База знаний | mista.ru

Как можно на фтпэшник закинуть файл из среды 1С?

rty 21.05.2004 23:58 | Помогите: Как можно на фтпэшник закинуть файл из среды 1С?
Волшебник 1 - 22.05.2004 00:49 | КомандаСистемы("ftp.exe <ключи>");
Волшебник 3 - 22.05.2004 12:26 | (2) Ну это было несложно. Есть еще внешняя компонента для 1С, которая также позволяет работать с FTP.
Волшебник 5 - 22.05.2004 21:14 | http://www.mista.ru/articles1c/hare/article.26.html
Волшебник 6 - 22.05.2004 21:25 | (4) Иди сюда http://1c.hippo.ru/addin.html и сделай поиск по "ftp"
Волшебник 9 - 22.05.2004 22:02 | Отправил на почту. В письме ест описание и пример. -------------- FTP – это практически единственная внешняя компонента для V7, которая реализует работу с протоколом FTP. Что умеет FTP? Соединиться с FTP-сервером (если нужно, то и через proxy) Авторизоваться на FTP-сервере Менять текущую директорию на FTP-сервере Загружать и выгружать файлы (в текстовом или двоичном режиме, по выбору) Создавать и удалять каталоги на FTP-сервере Переименовывать файлы и каталоги на FTP-сервере Досточно ли этих функций для полноценной работы с FTP? В общем случае, этого хватит. Конечно, очень бы хотелось иметь функцию получения списка файлов текущего каталога FTP-сервера (т.е. поддержку команды list). Но и без неё жить можно: обычно пользователь точно знает, какие файлы ему необходимо выкачать с сервера. Резюме: уникальный и крайне полезный инструмент.


1С Предприятие 7.7 , нужно из 1С по кнопке открывать страничку в Интернете. | База знаний | mista.ru

1С Предприятие 7.7 , нужно из 1С по кнопке открывать страничку в Интернете.

Frol 12.05.2004 11:40 | Как этот лучше сделать, может кто уже сталкивался? Через компоненту V7...(не помню точное название) вроде мудрёно слишком. Может есть способ проще?
Композитор 1 - 12.05.2004 11:54 | ЗапуститьПриложение(АдресСайта)


Как V7HttpReader передаёт запрос http серверу | База знаний | mista.ru

Как V7HttpReader передаёт запрос http серверу

bel_igor 04.05.2004 16:10 | Процедура ОтпрДлОбработки_Нажатие() стр_запр = "?name=FFF&foo=foo"; стр_отв=""; Попытка HTTPСоединение.ОтправитьДляОбработки("http://localhost/one.php", стр_запр, 2, стр_отв, 2); Сообщить("стр_отв = "+стр_отв); Исключение Сообщить("Исключение"+HTTPСоединение.СтрокаСостоянияОтвета) ; КонецПопытки КонецПроцедуры В стр_отв пусто хотя серверу дано while (list($key, $value) = each($_REQUEST)) { echo "$key: $value<br>"; }
bel_igor 1 - 04.05.2004 16:12 | Как на сервере получить стр_запр (строку запроса)?
bel_igor 2 - 04.05.2004 16:59 | Если сделать вот так "http://localhost/one.php"+стр_запр HTTPСоединение.ОтправитьДляОбработки("http://localhost/one.php"+стр_запр , стр_запр, 2, стр_отв, 2); то на сервере в $_REQUEST все появляется, так что же имела 1С когда в справке к V7Plus писала: 2 - переменная Источник должна иметь тип строки, к запросу будет присоединено ее содержимое КАК она присоединяется к запросу


Работа с компонентой УРБД в 1С 7.7 (пошаговая инструкция+скрипт) | База знаний | mista.ru

Работа с компонентой УРБД в 1С 7.7 (пошаговая инструкция+скрипт)

romix
07.08.2004 21:02 		Компоненту УРБД (Управление распределенными базами данных) применяют, когда необходимо обмениваться информацией между двумя идентичными информационными базами (далее – ИБ) по узкому каналу связи (например, модем, электронная почта). Ниже приведена пошаговая инструкция и практические советы по настройке УРБД в 1С:Предприятие 7.7. Пример приведен для двух ИБ, хотя настроить его на большее количество баз по аналогии с двумя базами не представляет большого труда.
1) За работу компоненты УРБД отвечает библиотека DistrDB.dll в папке BIN программы 1С:Предприятие. Эта компонента приобретается и устанавливается отдельно.
2) Для примера автообмена мы создадим две информационные базы, разместив их в папках с именами c:\1c_base1 и c:\1c_base2. Создайте эти папки, а в каждой из них – вложенные папки с именами CP и PC (латинскими буквами)
3) В папке c:\1c_base1 разместите уже готовую конфигурацию (скажем, «Торговля и Склад»). Но тренироваться лучше на самой простой информационной базе (содержащей, к примеру, всего один справочник с несколькими записями). Нам важно убедиться, что данные действительно мигрируют из одной ИБ в другую в результате автообмена УРБД, а это можно показать как на сложном, так и на самом простом тестовом примере.
4) Закройте все окна в Конфигураторе и активизируйте пункт меню «Администрирование – Распределенная ИБ – Управление». Этот пункт меню доступен, если в папке BIN программы 1С:Предприятие имеется компонента DistrDB.dll. Если библиотека имеет неправильную версию или повреждена, просто переустановите 1С:Предприятие поверх текущей установки – библиотека DistrDB.dll будет замещена ее правильной версией.
5) В открывшемся окне нажмите кнопку «Центральная ИБ». В окне запроса укажите код новой информационной базы (укажите цифру 1) и ее описание (например, «Центральная ИБ»).
6) Появившееся предупреждение о необратимости изменений загасите нажатием «ОК» (ниже описан недокументированный способ, как при необходимости вернуть базу в ее первоначальное состояние).
7) Нажмите кнопку «Новая периф. ИБ». В окне запроса укажите для нее код 2 и описание – «Периферийная ИБ».
8) Выделите однократным щелчком периферийную базу и нажмите кнопку «Настр. автообмена». В открывшемся окне установкой переключателя поменяйте «Ручной» режим автообмена на «Автоматический» и нажмите кнопку «ОК».
9) Нажмите кнопку «Выгрузить данные». Запомните (в буфер обмена) имя файла с выгрузкой «c:\1c_base1\CP\20.zip» - он нам еще пригодится. Нажмите ОК. По окончании выгрузки 1С напишет «Выгрузка успешно завершена».
10) Закройте Конфигуратор и войдите (также в режиме Конфигуратора) в папку (пока еще пустую), где должна лежать вторая ИБ (в нашем примере – c:\1c_base2). Укажите, что база должна быть в формате DBF/CDX и нажмите «ОК».
11) Зайдите в пункт меню Администрирование – Распределенная ИБ – Управление. В ответ на вопрос «Информационная база не обнаружена. Выполнить загрузку данных?» нажмите «Да» и укажите имя файла выгрузки (в нашем примере, «c:\1c_base1\CP\20.zip») и нажмите кнопку «ОК». По окончании загрузки 1С напишет «Загрузка успешно завершена». Мы успешно создали Периферийную ИБ, выгрузив данные из Центральной ИБ.
12) Измените что-нибудь (например, добавьте новый элемент справочника) в одной из информационных баз. Наша цель – добиться, чтобы изменения в одной (любой) ИБ попали в другую ИБ через автообмен. Используйте пункт меню «Администрирование» – «Распределенная ИБ» – «Автообмен» попеременно в каждой из баз. Вновь появляющиеся файлы выгрузок с расширением ZIP в папках CP и PC надо перемещать (копировать) между информационными базами по принципу CP->CP, PC->PC (в реальных «полевых» условиях обычно это делают при помощи электронной почты).
Советы и рецепты
1) Чтобы превратить распределенную базу в обычную, удалите файлы 1SDBSET.DBF, 1SDWNLDS.DBF, 1SUPDTS.DBF и соответствующие им файлы *.CDX, а также 1SSYSTEM.DBF. В принципе, достаточно удалить 1SSYSTEM.DBF. После этого необходимо восстановить точку актуальности, запустив программу в монопольном режиме. Этот трюк недокументирован (угадайте, почему), но, тем не менее, он работает.
2) Вы можете изменять конфигурацию 1С, но только в Центральной ИБ. Это очень удобно – изменения в периферийных ИБ «накатываются» автоматически.
3) Если у вас пропала (например, в результате ошибки почты) одна или несколько выгрузок – не огорчайтесь, т.к. УРБД умеет отслеживать такие ситуации, и повторять отправку потерянных данных при следующем сеансе автообмена.
4) Штатная возможность отправки почты в 1С реализована через интерфейс MAPI, когда взаимодействие происходит с почтовым клиентом (таким, как Outlook). Мой совет – не тратьте зря времени - с MAPI и разного рода Оутлюками на практике постоянно возникают заморочки, требующие «быстрой езды» разработчика между филиалами. Использовать прямое модемное соединение или FTP я не советую по этой же причине. Посылать почту лучше внешними компонентами, такими как rom-mail.dll или DialMail.dll.
5) Программу, которая умеет автоматически выполнять автообмен и пересылать файлы выгрузки по электронной почте, вы можете взять здесь: http://x-romix.narod.ru/urbd.rar. Если вы правильно настроите несколько констант (почтовые адреса, пароли, явки и т.д.), пользователю остается лишь дважды кликнуть на ярлык, чтобы запустить Автообмен.
Программа реализована как конфигурация 1С:Предприятие. Ее настройки надо выполнять в константах.
Если вы умеете настраивать почтовый клиент (например, Outlook Express), то смысл большинства из этих настроек для вас достаточно очевиден.
Константу «Аутентификация при отправке» следует выставлять в 1 для некоторых почтовых серверов, которые отказываются посылать неавторизованную почту.
Константа «Закрывать Internet соединение» позволяет завершить текущее открытое модемное соединение («положить трубку») по завершению сеанса автообмена.
Константа «Подстрока заголовка» позволяет указать подстроку, которая должна быть в заголовке входящего письма, чтобы оно было принято. Эта настройка нужна на случай, если вы захотите отлаживаться на своем собственном почтовом адресе, но не хотели бы, чтобы адресованные вам письма были приняты в сеансе автообмена. Если вы создали отдельные почтовые адреса (я рекомендую этот вариант), то просто очистите эту константу.
6) Если нужно автоматически выполнять дозвон до провайдера, используйте программу E-Type Dialer. Она умеет запускать внешние приложения при успешном соединении. Другой вариант – использовать внешнюю компоненту DialMail, которая имеет средства работы с модемом (совет – префикс «p» латинское перед номером дает импульсный набор, 9W перед номером – звонок через «девятку» и ожидание гудка в линии т.д.).
7) Синхронизация происходит по кодам справочников и номерам документов. При совпадающих кодах или номерах приоритет отдается изменениям, выполненным в Центральной ИБ. Обратите внимание, что в типовых конфигурациях 1С применяются префиксы информационной базы (см. эту настройку в Константах), чтобы коды элементов справочников и номера документов, созданных в разных базах, никогда не совпадали.
Матрейя
1 - 07.08.2004 21:53 		+(0). Если изменили MD, то невозможно принять (штатно) выгрузку с переферийных, которая была сделана до изменения конфигурации.
Алина
3 - 08.08.2004 07:55 		1. Будет ли УРБД правильно работать с большими справочниками, где данные в основном хранятся в периодических реквизитах? Периодические реквизиты не привязаны к документам.
1.1 В таком случае элементы передаются полностью?
2. Если документ не изменяется, но меняется журнал расчета (программно правятся записи на этот документ)?
3. Вообще, если изменяется конфигурация документа, то документ помечается для передачи? Если так, то изменения в периферийной базе будут потеряны.
4. Если ли потенциальные проблемы с 1С (при условии, что конфигурация правильно написана)?
Serg_bl
4 - 08.08.2004 10:46 		Работа УРБД проста и надежна, как танк. Однако надо учитывать, что без дополнительных изменений в конфе в случае перепроведения доков все эти доки передадутся в другие базы (с разными последствиями: от долгой загрузки до потери некоторых данных из-за коллизий) и нельзя передавать доки выборочно. Интересно, насколько МОД в этом плане лучше/хуже?
Матрейя
5 - 08.08.2004 13:14 		4. МОД еще надежнее. Полностью (и легко) настраиваемая система. К тому же МОД - просто код на 1с-ном языке, можно обойтись без ВК и инсталятора.
Crew
9 - 08.09.2004 11:18 		(3)
1 и 1.1
Из описания УРИБ:
"Значение на определенную дату периодического реквизита справочника или счета, а также значение периодической константы не является «ведущим» объектом: ими могут быть только константа, элемент справочника, счет, вместе со всей историей изменения периодических реквизитов. Поэтому, при условно одновременном изменении периодической константы, элемента справочника, счета, по окончании процесса корректировки распределенной И Б принятым окажется только одно изменение, даже если корректировка периодического значения производилась для разных дат."

3. Если имеется ввиду изменения в конфигураторе, то при этом не передаются сами документы, а только изменения конфигурации.

4. Нет ;) при соблюдении условия


Запуск 1С в пекетном режиме через планировщик | База знаний | mista.ru

Запуск 1С в пекетном режиме через планировщик

vcv
04.06.2004 10:57 		Есть два батничка на одном сервере с запуском 1С в пакетном режиме. Один для ночной проверки/загрузки/выгрузки в монопольном режиме, другой, для ежечасной загрузки/выгрузки УРБД. Оба, если просто запустить из, например, ФАРА или проводника, успешно отрабатывают. Если-же запускать через планировщий (стандартный Windows2000Server), с первым батником все нормально, а из второго 1С не запускается, возвращая errorlevel 128.
Что это может быть?
Где-нибудь можно раздобыть информацию о 1Сных errorlevel?
Ключ и сетевой менеджер стоят на этом-же сервере.
lexa
1 - 04.06.2004 10:59 		приведи батник и файл параметров, у меня автообмен запускается каждые полчаса без проблем
vcv
2 - 04.06.2004 13:01 		[General]
Output=C:\backups\AutoExchange.~mlg
Quit=1
CheckAndRepair=0
UnloadData=0
SaveData=0
AutoExchange=1
[AutoExchange]
SharedMode=Yes
ReceiveFrom=
ReadFrom=*
WriteTo=*
SendTo=

Батничек приводить не буду, там много лишнего, только глаза будет путать, но и просто такая строчка в планировщике не пускается:
"C:\Program Files\1Cv77\BIN\1cv7.exe" config /D"C:\Baza.1C\МПК 2004\" /NАдминистратор /@C:\backups\AutoExchange.prm

Ту же строчку запуска скармливаю "Пуск / Выполнить" - все идеально.
Killgur
3 - 04.06.2004 13:26 		В задании обязательно укажи пользователя от чьего имени будет запускаться задание и введи его пароль (задать пароль)
lexa
4 - 04.06.2004 13:36 		переименовал бы ты МПК 2004 в МПК_2004 и убрал бы кавычки и
Output=C:\backups\AutoExchange.~mlg сделай попроще например
Output=C:\backups\AutoEx.mlg
я как то в Output неправильно путь прописал так конфигуратор вообще зависал
попробуй
cd "C:\Program Files\1Cv77\BIN\"
start 1cv7.exe" config /DC:\Baza.1C\МПК_2004\ /NАдминистратор /@C:\backups\AutoExchange.prm
vcv
5 - 07.06.2004 08:17 		Не помогает. Самое что интересное, рядом второй батник, который запускается ночью для проверки базы и загрузки/выгрузки в монопольном режиме. Так он запускается. И от *.prm файла это не зависит, пробовал подменять. Какой-то глюк с неустоячивым запуском.
Тот батник, из которого 1С-ка не запускается так и висит на регулярном запуске каждый час и по логам где-то раз в день, он таки умудряется запуститься.
427
6 - 07.06.2004 08:25 		запусти первый раз батник руками... И ответь на все сообщения - которые вываливаются... Типа там всяких подсказок ежедневных...

Она не висит - просто ждет ответа...
lexa
7 - 07.06.2004 10:29 		(2) попробуй упростить батничек до (4) и (3) прав на задание надо прописать пароль пользователя . Вообще если ОС 2000/ХР, то не .bat, а .cmd. И приведи все-таки батничек. Я сам долгл геморроился с батником: надо было обмен через дискету сделать, а уриб на ЦБ не дает это сделать. Пришломь, проверять наличе файлов, переписывать с дискеты на винт, а после обмена с винта на дискету
vcv
8 - 07.06.2004 13:43 		To 427: "Висит на регулярном запуске" не в смысле 1С запускается и висит, а в смысле запуск указан в шедулере. Сама 1С пытается запуститься и мгновенно завершается с кодом возврата (errorlevel) 128.

To lexa:
Упрощение батничка эффекта не дает. Пароль на задание есть. Как же без него на корпоративном серваке?
А батничек.... Ну ты сам попросил.... :-) :-)

Сначала первый, который запускается раз в день ночью и нормально отрабатывает:

@echo off
setlocal ENABLEEXTENSIONS ENABLEDELAYEDEXPANSION
set TS=%date:~9,4%%date:~6,2%%date:~3,2%
set RAR=rar.exe a -m5 -av- -idp -k -mdG -y -dh
set ONEC="C:\Program Files\1Cv77\BIN\1cv7.exe" config /M

echo.>>%~dpn0.log
echo ------------------------------------------------------------------------------->>%~dpn0.log
echo %TS% %TIME% Обслуживание ИБ 1С>>%~dpn0.log

rem ***
rem *** Архивирование информационных баз
rem ***
pushd C:\Baza.1C
for /F "tokens=*" %%i in ('dir /b /s *.md ^| findstr /V "NEW_STRU"') do (
if not exist "%~dp0%%~pi" mkdir "%~dp0%%~pi"
echo %TS% Архивирование ИБ %%~dpi>>%~dpn0.log
pushd "%%~dpi"
%RAR% -ilog"%~dp0%%~pi%TS%.log" "%~dp0%%~pi%TS%.tmp" @%~dpn0.lst
if exist "%~dp0%%~pi%TS%.log" (
echo %TS% : Протокол ошибок в файле %~dp0%%~pi%TS%.log>>%~dpn0.log
)
popd
pushd "%~dp0%%~pi"
if exist %TS%.tmp (
for /F %%i in ('%~dp0cksum.exe %TS%.tmp') do set sum1=%%i
for /F %%i in ('dir /OD /B *.rar 2^>nul') do set oldname=%%i
for /F %%i in ('%~dp0cksum.exe !oldname!') do set sum2=%%i
if "!sum1!"=="!sum2!" (
echo %TS% : Изменений в ИБ не обнаружено, архив не сохранен>>%~dpn0.log
del %TS%.tmp
)
)
if exist %TS%.tmp move %TS%.tmp %TS%.rar
popd
)
popd

rem ***
rem *** Тестирование и автообмен ИБ
rem ***
echo %TS% Тестирование и автообмен ИБ C:\1C\МПК2004\>>%~dpn0.log
del "%BASE%\Exchange\CP\" /Y 2>nul
del "%BASE%\Exchange\PC\" /Y 2>nul
if exist C:\Home\Exchange\U~2C.ZIP move /Y C:\Home\Exchange\U~2C.ZIP "%BASE%\Exchange\CP"
%ONEC% /D"C:\Baza.1C\МПК 2004\" /NАдминистратор /@%~dpn0.prm
if exist %~dpn0.~mlg (
type %~dpn0.~mlg>>%~dpn0.mlg
%~dp0recode.exe -wd %~dpn0.~mlg
findstr "Err" %~dpn0.~mlg>>%~dpn0.log
del %~dpn0.~mlg
)
move /Y "%BASE%\Exchange\PC\U~?D.ZIP" C:\Home\Exchange >nul

endlocal

и пакетный файл к нему:

[General]
Output=C:\backups\maintenance.~mlg
Quit=1
CheckAndRepair=1
UnloadData=0
SaveData=0
AutoExchange=1

[CheckAndRepair]
Repair=0
PhysicalIntegrity=1
Reindex=1
LogicalIntegrity=1
RecalcSecondaries=1
RecalcTotals=1
Pack=0

[AutoExchange]
SharedMode=No
ReceiveFrom=
ReadFrom=*
WriteTo=*
SendTo=

Второй батничек, который не работает, гораздо проще, он только выгружает данные, забираются они по FTP с другого сервера

@echo off
setlocal ENABLEEXTENSIONS ENABLEDELAYEDEXPANSION

pushd %~dp0
set ONEC="C:\Program Files\1Cv77\BIN\1cv7.exe" config
set BASE=C:\Baza.1C\МПК 2004
set TS=%date:~9,4%%date:~6,2%%date:~3,2% %time:~0,5%
echo %TS% Автообмен ИБ %BASE%>>%~dpn0.log
del "%BASE%\Exchange\CP\" /Y 2>nul
del "%BASE%\Exchange\PC\" /Y 2>nul
if exist C:\Home\Exchange\U~2C.ZIP move /Y C:\Home\Exchange\U~2C.ZIP "%BASE%\Exchange\CP"

rem %ONEC% /D"%BASE%\" /NАдминистратор /@%~dpn0.prm
cd "C:\Program Files\1Cv77\BIN\"
%ONEC% /D"C:\Baza.1C\МПК 2004\" /NАдминистратор /@%~dpn0.prm
if not %errorlevel%==0 echo %TS% Запуск 1С не удался >>%~dpn0.log

del "%BASE%\Exchange\CP\" /Y 2>nul
if exist %~dpn0.~mlg (
type %~dpn0.~mlg>>%~dpn0.mlg
%~dp0recode.exe -wd %~dpn0.~mlg >nul
findstr "Err" %~dpn0.~mlg>>%~dpn0.log
del %~dpn0.~mlg
)
move /Y "%BASE%\Exchange\PC\U~2D.ZIP" C:\Home\Exchange 2>nul
popd
endlocal

и пакетный файл к нему:

[General]
Output=C:\backups\AutoExchange.~mlg
Quit=1
CheckAndRepair=0
UnloadData=0
SaveData=0
AutoExchange=1

[AutoExchange]
SharedMode=Yes
ReceiveFrom=
ReadFrom=*
WriteTo=*
SendTo=

Кстати, если кому-то мои батнички приглянутся - берите на здоровье. :-) :-)
lexa
9 - 07.06.2004 13:47 		cd "C:\Program Files\1Cv77\BIN\"
start /wait %ONEC% /D"C:\Baza.1C\МПК 2004\" /NАдминистратор /@%~dpn0.prm
Akim
11 - 07.06.2004 15:08 		У меня была подобная проблема с пакетным режимом . Победил тем что исключил кирилицу в паролях и именах юзеров (ну не любит 1С русских ^:)) ). И все пути в формат 8.3. Попробуй.
Akim
12 - 07.06.2004 15:09 		ЗЫЖ И каталоги тоже по английски. :-)
lexa
13 - 07.06.2004 15:11 		Да, батники у тебя навороченные, даже завидно
У меня все просто:
@echo off
cd "g:\Program Files\1Cv77\BIN\"
start /min 1cv7.exe CONFIG /DD:\1C\db /NAutoExchange /P132 /@D:\1C\CMD\Autoexchange.txt
а Autoexchange.txt :
[General]
Output=d:\1C\CMD\Log.txt
Quit=Y
AutoExchange=Y
[AutoExchange]
SharedMode=Y
ReceiveFrom=*
ReadFrom=*
WriteTo=*
SendTo=*
все работает без геморроя (через e-mail)
lexa
14 - 07.06.2004 15:20 		ты перезаписываешь файлы автообмена и не дожидаясь завершения перезаписи запускаешь конфигуратор, а потом недожидаясь завершения его работы опять перезаписываешь файлы, я тут заморачивался с автообменом через дискету и делал примерно так:
xcopy /wait a:\db21.zip c:\cmd\*
cd "g:\Program Files\1Cv77\BIN\"
start /wait 1cv7.exe CONFIG /DD:\1C\db /NAutoExchange /P132 /@D:\1C\CMD\Autoexchange.txt
xcopy c:\cmd\db20.zip a:\*
vcv
15 - 07.06.2004 15:21 		Вопрос кажется решен. Как только юзера ушли домой батник сразу заработал. По предварительным экспериментам, что бы все заработало, надо для пользователя, от которого пускается 1С в пакетном режиме задать свой личный каталог. С пустым каталогом не прокатывает. Точно проверю завтра, когда юзера опять на базу насядут. Непонятно только кочему это важно при запуске из шедула и безразлично при запуске батника вручную.


Помогите с обменом инфой между 1С и Супермаг | База знаний | mista.ru

Помогите с обменом инфой между 1С и Супермаг

fixer 25.03.2004 16:31 | Подскажите существует ли возможность выгрузить данные из 1С Торговля и загрузить их в Супермаг 2000.
Рупор абсурда 8 - 26.03.2004 13:12 | В 1С формируются файлы ДБФ - файлы переноса из 1С в Супермаг ... В Супермаге есть свой загрузчик, с помощью которого оно всё загрузится ... Там же есть и разгрузчик, который выгрузит тебе всё нужное тоже в ДБФки ... А загрузить всё это в 1С можно из самой 1С ... Инфу по структуре ДБФ ищи в супермаговских книжках ...
Львенок 11 - 26.03.2004 15:33 | (9) Не пробовал(а) читать инструкцию идущую к СуперМагу? Толстенная такая книженция в пару сотен страниц. Там довольно подробно расписаны абсолютно все аспекты. Кстати пофиг в чем хранит информацию сам Супермаг 2000 и чем она отличается от аналогичной же в Супермаг УКМ, в любом случае программа должа поставляться с неким конвертором (как он называется в документации) - модулем встроенным в Супермаг и преобразующим текстовый и/или dbf формат во внутреннее представление программы и обратно. Загрузка и Выгрузка данных происходит не во внутреннем формате Супермага, а в формате который поддерживается вашим конвертором (см. инструкцию). ___ Искренне Ваш, Львенок.
Mr.Bars 25 - 30.03.2004 10:36 | Не знаю чем fixer тебе понравился Супермаг 2000, На самом деле, ИХМО, на 1С все решается гороздо проще и функциональнее важно научиться вытаскивать оперетивную сводку из SMUKM30 (именно под нее заточен Супермаг) Загрузка-выгрузка 1с-УКМ уже давно реализована Проблема осталась одна - получать информацию в On-line режиме
fixer 27 - 30.03.2004 11:41 | Супермаг 2000 хорош тем, что с помощью него удобно централизовано управлять магазинами из офиса. А проблема состоит в том, что у нас в одном из магазинов стоит 1С, а мне необходимо данные перекидывать в Супермаг... хочу найти способ отличный от ручного режима...
fixer 28 - 30.03.2004 14:22 | Не подскажите? Возможно или нет вообще осуществить такую цепочку: 1С - Супермаг УКМ - СМ2000.
fixer 33 - 01.04.2004 09:31 | up Я хочу перекинуть накладные и кассовые документы из 1С Торговля в СМ2000. Проблема в том, что при загрузке в СМ2000 используется свой формат данных - физические пакеты с расширением sfp.
SiMazx 36 - 05.04.2004 14:51 | (35) Ты эт... Не шуми... Тебе ж говорят можно... Твоя задача - найти конвертор из дбф в твой супермаг... Остальное - дело техники, тут подскажем что и как... Вот если ты стопроцентно уверен, что такого конвертера нет, тогда все, баста карапузики...
fixer 37 - 05.04.2004 15:11 | Дело в том, что конвертора в формат СМ2000 как такого нет, но есть второй путь... выгрузка из Супермаг-УКМ... Вопрос такого плана - есть ли возможность загрузить информацию в Супермаг-УКМ из 1С торговля (накладные и кассовые документы меня больше всего интересуют), а затем их перекинуть в СМ2000.
SiMazx 38 - 05.04.2004 15:16 | Ладно, подытожу: из 1С данные можно выгрузить в дбф/тхт практически в любом заданном формате... Если у тебя есть инструмент который съест дбф/тхт и засунет в Супермаг/СуперМаг УКМ, тогда твоя задача решена, если нет такого инструмента, то финиталякомедия...


1c и MySQL | База знаний | mista.ru

1c и MySQL

Sorrel
16.06.2004 22:32 		Кто нить подскажите как залить в сиквельную базу например справочник номенклатуры с остатками а потом слить обратно в 1с
THawk
4 - 18.06.2004 22:00 		Я делал через OLE Automation и передавал данные по обычной схеме.
hanprog
5 - 19.06.2004 11:45 		Можно писать на 1С через OLE например,
а можно через Access 1С хранит данные если это dbf
ыерсия в dbf файлах и перекинуть их куда угодно можно и внешне
Матрейя
11 - 27.06.2004 15:43 		(0) Через ADO
Соединение=СоздатьОбъект("ADODB.Connection");
Соединение.Open("СтрокаСоединения") и т.д.
Орк
12 - 27.06.2004 16:36 		То (0)
А справочник с остатками - это как?
Или здесь не об 1С?
Матрейя
13 - 27.06.2004 17:18 		12. Select Номенклатура, КонОс=КонОст(Количество) from Регистр.ОстаткиТМЦ и т.д., только вместо 1с-ных названия - ставишьреальные названия таблиц, полей.
Орк
14 - 27.06.2004 19:45 		13. Спасибо. Смотрел. Думал. Нифига не понял.
Вроде как фрагмент запроса?
Если запрос 1с-ный почему рекомендуется вместо 1с-ных названий реальные?
Если внешний - почему встроенная функция КонОст?
Неужели контора по стандартизации SQL из 1С функциии ворует?

Теперь немножко по сути.
В (0) на мой взгляд предполагается получить какие-то данные из
DBF-базы 1С в скульную опять же 1С (возможно я ошибаюсь).
Каким образом не проведя ни один документ изменить остатки
то-ли в регистрах, то-ли на бух счетах я не представляю.

Если же внешняя база не 1С-ная то в обратной заливке я опять же
глубоко сомневаюсь.

То (0).
Вообще способов обмена между 1С и другими программами несколько
корректными считаются (с точки зрения самой 1С) Ole и XBase.
Матрейя
15 - 27.06.2004 20:01 		14. 1c++, ToySQL - доступно обращение к объектам в формате 1с + функции КонОст и т.д. Если чистый SQL-запрос, то необходимо выполнить Sum () по движениям+значение остатка на начало. Что касается вопроса в (0), то я понял, что нужно вылить в какую-то внешнюю таблицу, а потом считать данные этой таблицы (скорректированные другой (не 1с) программой) и сделать корректирующие доки в 1с на основании сравнения.


УРБД в 1С Предприятие 8. | База знаний | mista.ru

УРБД в 1С Предприятие 8.

Игорь 03.12.2003 09:50 | Имеется ли УРБД для версии 8. Если нет, каким образом будед решатся обмен между ИБ? И будет ли это решение реализованно по подобию 7.7?
Puh 2 - 03.12.2003 15:45 | Функциональность внешней компоненты v7plus.dll включена в платформу в виде объектов «Почта», «СистемнаяИнформация», «ИнтернетСоединение», «FTPСоединение и т.д. Есть средства для работы с XML-документами, а также для последовательного чтения и записи больших текстовых файлов. Это включено в отличия 8-ки. А отдельно УРБД никгде не упоминается. :(
Gira 4 - 27.04.2004 15:03 | А МОД имеется для 8 версии?
OctoberHammer 5 - 27.04.2004 15:35 | В в8 реализован объект "Планы Обмена". Это не УРБД. Это скорее похоже на конвертацию данных... Не знаю, на МОД... от УРБД отличается тем, что при передаче иземенений не передаются изменения в конфигурации
BorisG 6 - 27.04.2004 16:13 | Да... странно задавать вопросы в ветке... которой 4 месяца. За это время много воды утекло... Хотя об этом уже писали... Новое в версии 8.0.5 Универсальный механизм обмена данными предназначен как для создания территориально распределенных систем на основе 1С:Предприятия 8.0, так и для организации обмена данными с другими информационными системами. http://v8.1c.ru/overview/release_5/dataexchange/dataexchange.htm Не УРБД, как это было в семерке, ну уже кое-что... УРБД будет позднее... и все равно не так, как в семерке...
lift 8 - 01.07.2004 12:19 | Версия 8.0.7 включен механизм распределенных инф. систем.Судя по демо версии "Обмен данными" интересная и полезная чтучка.
¶ 9 - 01.07.2004 12:42 | (8) Угу. http://www.1c.ru/news/info.asp?id=3073
SiMazx 10 - 01.07.2004 13:19 | http://v8.1c.ru/overview/release_7/


УРБД, перенос документов только с определенным реквизитом | База знаний | mista.ru

УРБД, перенос документов только с определенным реквизитом

InDesign 07.07.2004 10:27 | Подскажите, plz, как сделать перенос документов в периферийную базу документов, имеющих определенное значение одного реквизита. Возможно ли это?
lexa 4 - 07.07.2004 12:11 | Попробуй МОД
pauls 5 - 07.07.2004 14:11 | Можно еще сделать через УРИБ через "буферные документы"...
pauls 8 - 07.07.2004 15:52 | Вещь достаточно простая. необходимо в периф. базе (ПБ) создать определенное кол-во "заготовок"(т.е. не проведенных, с пустыми рекизитами и таб. частью) документов вида, который собираешься таскать между базами. Их поведение в УРИБ "место созд. и центр". Перегоняешь их в центр. базу (ЦБ). А в ЦБ при формировании дока такого же типа заполняешь два реквизита формы. Один реквизит текущая база, второй получатель. Если они различны, при записи перехватывать текущий документ и переписывать его в "заготовку", которая пришла из нужной ПБ(код ИБ в которой создан данный документ можно получить). По правилам УРИБа этот документ уйдет обратно в ПБ. Перегружаем бывшие "болванки" в ПБ, а при заходе в ПБ формируем новую порцию "заготовок", они уйдут в ЦБ при следующем обмене. Вот такой круговорот.
lexa 9 - 07.07.2004 16:24 | (8) мощно задвинул, внушает а количество заготовок?
pauls 11 - 07.07.2004 17:07 | Можно посчитать скока "болванок" осталось в ПБ после загрузки и настрогать новых, отталкиваясь от числа документов, допустим надо поддерживать "болванки" между обменами в кол-ве 100 шт. отсюда и плясать...
lexa 12 - 07.07.2004 17:10 | а если их поудаляют?
pauls 13 - 07.07.2004 17:15 | Ну удалить можно все, что угодно :). А "болванки" надо писать на даты за пределами константы редактирования (например с 01.01.1990 - 31.12.1990). Кто полезет в такой период. И искать болванки будет проще (ВыбратьДокументы(Дата1, Дата2))...
lexa 14 - 07.07.2004 17:35 | (13) здорово в ПриНачалеРаботыСистемы дописать, чтобы генерила новые болванки до нужного количества
pauls 15 - 07.07.2004 17:37 | (14) Молодец. Тебе конфета :)


DBF файл | База знаний | mista.ru

DBF файл

Mike_L
22.07.2004 14:55 		А вот кто подскажет соответствие обозначений при задании поля с его реальным значением. Огласите весь список, пожалуйста!
???
Файл.ДобавитьПоле("NAME","S",50,0);
???

???
Файл.ДобавитьПоле("PRICE","N",10,2);
???

А еще какие есть?
SnarkHunter
8 - 22.07.2004 15:21 		Цитата из ЖКК:

1 или"N" — число;
2 или "S" — строка;
3 или "D" — дата;
4 или "L" — логическое;
5 или "F" — то же, что и 1, т. е. число;
6 или "М" — memo (не поддерживается).


импорт из txt в 1С | База знаний | mista.ru

импорт из txt в 1С

Brejnev 14.07.2004 09:28 | Здравствуйте! Меня зовут Мусахмет. У меня к Вам большая просьба. В 2000 году я написал программку на Access. Сейчас возникла необходимость сделать тоже самое в 1С. Вторую неделю копаюсь в инете, не могу найти примеров импорта данных из txt в 1с, импорта как в Access, Excel с разбивкой по столбцам. Если есть пример. Помогите, пожалуйста. С уважением, Мусахмет
Warlock 1 - 14.07.2004 09:33 | Объект "Текст". С помощью этого объекта можно загрузить текст из файла, разюить по строкам. А далее смотри "Встроенный язык/Системные/Строковые".
CzujMao 5 - 14.07.2004 09:48 | Примеров и не найдёшь, всё настолько элементарно... лСписок=СоздатьОбъект("СписокЗначений"); лТекст=СоздатьОбъект("Текст"); лТекст.Открыть(лИмяФайла); лСтрокВсего=Текст.КоличествоСтрок(); Для лСтрока=1 По СтрокВсего Цикл лСписок.УдалитьВсе(); лСписок.ИзСтрокиСРазделителями(лТекст.ПолучитьСтроку(лСтрока)); Для лНомер=1 По лСписок.РазмерСписка() Цикла МояПеременная=лСписок.ПолучитьЗначение(лНомер); и используешь как тебе надо Пример правильного формата текста можешь получить использовав ВСтрокуСРазделителями()


Срочно нужно Описание УРБД | База знаний | mista.ru

Срочно нужно Описание УРБД

AlSh 29.06.2004 19:13 | ЛЮДИ!!! Срочно нужно описание УРБД по 7.7
Warlock 3 - 29.06.2004 20:28 | На сайте http://www.1c.ru/ есть немного: http://www.1c.ru/rus/products/1c/predpr/urbd.htm и еще здесь http://argat.h11.ru/URBDStructure.html а вообще надо начинать отсюда: http://www.mista.ru/articles1c/urbd.htm


перенос доков из нераспределнки в УРИБ | База знаний | mista.ru

перенос доков из нераспределнки в УРИБ

LOSS 26.06.2004 09:33 | в филиале База велась локально. Потом головной прикупил УРИБ. Настройки те же остались. Перенёс обработкой доки с старой в новую базу которую центр прислала. Выгрузил у себя в периферийной для центра. Отправил. Жду результата. Вопрос: какие сюрпризы воможно с переносом доков (ессно и справочники тоже) таким образом.
Матрейя 1 - 26.06.2004 16:43 | УРИБ - надежная штука. Я поставил распределенку на несколько магазинов+оптовый склад (это одна конфигурация), юзеры сами все переносят - проблем при интенсивном обмене (раз в день) за несколько месяцев не было. Если правильно выставлены префиксы кодов справочников, доков,соблюдается последовательность загрузок-выгрузок - то проблем не будет.
LOSS 2 - 26.06.2004 17:32 | Не по другому. Я не про текущую работу. 1.Была база с набитыми доками в филиале (нераспределенка) 2. Даллее втыкают УРИБ в центр офисе, высылают нам файл загрузки в перефирийную базу 3. В периф. база воткнули её 4. Шоб бух не перебивал доки за полгода, я с бывшей нераспределенки перекачал доки и справ. обработкой, настройка осталась та же, токма УРИБ появился 5. Вопрос: выгрузили в центральную базу. Какие могут нестыковки быть у центра из-за переноса доков из бывшей базы?
Матрейя 3 - 26.06.2004 17:37 | 2. Если одинаковые номера доков, одинаковые коды справочников. Других нестыковок быть не должно.
Матрейя 4 - 26.06.2004 17:39 | Опять-таки, если один и то же справочник велся и в центре и в текущей переферийной базе, то после выгрузки - справочники объединяться. То есть если было кофе и там и там, то станет 2 кофе.


Пополнение базы | База знаний | mista.ru

Пополнение базы

Parabol 25.06.2004 11:58 | Ситуация такова: Есть два удаленных компа (никакой сети) как можно синхронизировать информацию в базах? И можно ли вообще вести базы параллельно? (зарплата+кадры) заранее спасибо
AlexMan 1 - 25.06.2004 11:59 | Можно УРБД поставить и с дискеткой кататся раз в неделю к примеру.
Parabol 3 - 25.06.2004 12:43 | //Можно УРБД поставить и с дискеткой кататся раз в неделю к примеру. // такой вариант начальству и нужен что такое УРБД? поподробнее пожалуйста
lexa 4 - 25.06.2004 12:46 | http://www.mista.ru/articles1c/urbd.htm
AlexMan 5 - 25.06.2004 13:13 | такой вариант начальству и нужен - Для ЗиК раз в неделю это даже часто лучше раз в 2-3 недели ...
Parabol 6 - 25.06.2004 13:49 | А где такую компоненту взять? И условия использования. Да и их, наверное, много разных? какую лучше?
lexa 7 - 25.06.2004 13:53 | (6) УРБД она одна, купи у франчей, и не забудь про префиксы ИБ
Parabol 8 - 25.06.2004 14:23 | Нда...почитал статью. По-моему слишкой много проблем возникает. Есть у кого-нибудь практический опыт использования? всем спасибо за советы
lexa 9 - 25.06.2004 15:26 | опыт есть проблемы возникают если один и тот же объект изменяют на разных ИБ в период между обменом данных, если использовать префиксы ИБ, то нумерация документов на каждой ИБ будет своя и кодировка у справочников тоже ( без префиксов будет нарушаться уникальность кодов и номеров) можешь попробовать МОД но он сложнее посмотри в сервисе-доплнительные возможности наверняка есть выгрузка из ЗиК в ЗиК если поиграться с настройками то можно и через XML, но проблем будет еще больше


При попытке сделать автообмен 1С закрывается | База знаний | mista.ru

При попытке сделать автообмен 1С закрывается

Tatav 23.06.2004 18:39 | Под 1С v77 стоит несколько распределенных баз и одна из них при попытке сделать через меню штатными средствами автообмен , тут же закрывается . Остальные базы выполняют автообмен нормально . Тестирование и испоавление делал , загрузку - выгрузку тоже. В чем может быть проблема ? ОС Win2000
lexa 11 - 23.06.2004 19:14 | приведи настройки автообмена
Tatav 12 - 23.06.2004 19:18 | каталог выгрузки C:\DB\ННовгородОУ\out каталог загрузки C:\DB\ННовгородОУ\in Режим автоматический Самое интересное что она закрывается не аварийно т.е при открытии не просит переиндексации
romix 14 - 24.06.2004 02:45 | Короче видимо пути к файлам кривые - русские - либо перепутаны русские и латинские буквы. Еще вариант - пользователь не может писать или читать эти папки - попробуй написать в консоли dir C:\DB\ННовгородОУ\out\*.* а также создать там вручную какие-нибудь файлы в Блокноте, например. А может, компонента DistrDB или сама 1С накернилась - попробуй на пустой базе на том же компе проверить запуск автообмена.
boy 15 - 24.06.2004 15:55 | У меня другая проблема... на перифирии при загрузке вылетает 1С Подскажите в чем дело база DBF
lexa 16 - 24.06.2004 18:47 | (15) загружаешь как?
boy 17 - 25.06.2004 12:25 | как обычно, через настройки на обмен, каталог тот, но почему-то постоянно просит переиндексацию, хотя *.CDX удалены и снова восстановлены
lexa 18 - 25.06.2004 12:35 | т.е. из конфигуратора, а тестирование и исправление делал? если конфа типовая попробуй подменить мд если не поможет то сделай новую пб
boy 19 - 25.06.2004 12:59 | я наверно что-то не так делаю...тестирование проводилось, все гладко, только до пересчета итогов, дальше не дождался. менял ПБ бесполезно, то же самое, хотя до этого работала. Что значить подменить мд?
lexa 20 - 25.06.2004 13:04 | а ПБ как менял? если конфу не менял, возьми мд из ЦБ и запиши его в ПБ
boy 21 - 25.06.2004 13:21 | объясняю как делал 1.удалил стпрую периферию в ЦБ 2.создал с тем же именем 3.выгрузил данные из ЦБ 4.создал новую базу и загрузил данные ЦБ вроде бы все
lexa 22 - 25.06.2004 13:31 | Если ЦБ при загрузке не виснет, тогда попробуй создать ПБ на той же машине, где находится ЦБ. Сделай обмен данными. Если все в порядке, то проблема с удаленной машиной. И в студию техинфо (какая 1С, какая конфа, какая ОС)
boy 23 - 25.06.2004 13:47 | ПБ создавалась на той же машине, где находится ЦБ. Был сделан обмен данными там же,было все в порядке. А что может быть с машиной? Подскажите можно ли из ЦБ сделать периферию не загружая данные(очень долгий процесс!). Что это-"студия техинфо"
lexa 24 - 25.06.2004 13:56 | (23) на одной машине все работает, а на другой нет - значит проблема в другой машине какие винды стоят на другой машине по поводу выгрузки - обычно все происходит достаточно быстро
boy 25 - 25.06.2004 14:01 | ПБ-WIN98 ЦБ-Server2000 выгрузка быстро, загрузка-жуть...даже на Server2000 жду ответа на мой второй вопрос:"Подскажите можно ли из ЦБ сделать периферию не загружая данные"
lexa 26 - 25.06.2004 14:13 | (25) штатными средствами нет а машины какие? проверь путь у переменной среды TEMP (сделай его попроще) у меня загрузку клинило при автообмене, а из конфигуратора без проблем отруби антивирус
Tatav 27 - 25.06.2004 14:14 | я сегодня только до базы добрался , у меня эта проблема прошла после запуска тестирования и исправления на переферийной базе в филиале , ЦБ при автообмене перестала закрываться
boy 28 - 25.06.2004 14:24 | а нештатными как? Очень хочу научиться, если есть возможность наставте на путь... думаю мне это пригодится
lexa 29 - 25.06.2004 14:30 | (28) изучай УРБД не знаю сколько у тебя весит файл начальной выгрузки? если до 4 метров, то проблема в настройках
boy 30 - 25.06.2004 14:54 | у меня нет литературы, может ссылки дадите файл около 4, в каких настройках
lexa 31 - 25.06.2004 15:05 | http://www.anvil.spb.ru/1c/rec/recom012.htm индентификатор базы, путь и имя файла выгрузки, значение переменной среды TEMP


А я всё - по выгрузке из Т+С в бух... | База знаний | mista.ru

А я всё - по выгрузке из Т+С в бух...

DElo
14.05.2004 17:43 		Задача №2: выгружать проводки не пономенклатурно, а с единым субконто: ТОВАР. Мотивирует клиент тем, что не хотит засорять свою бух. номенклатурой, хотит только видеть единый элемент. Как, например, при выгрузке из ЗиК образуется субконто "по всем сотрудникам". В пользовательском режиме я это реализовать не могу, да и элементов должно быть столько, сколько типов номенклатуры и ставок НДС.
Насколько сложно и долго это реализовывать?
427
2 - 14.05.2004 18:26 		Но перед заменой скажи клиенту, что нужна переделка типовой бухии…. И серьезная

P.S. – о проблемах, вызванных желанием клиента, советую подумать на досуге….
Можно проимитировать ручками такую замену, сделав приход, расход товара ….. и закрытие месяца ….

P.S. о правильности и соблюдении учетной политики он может успешно забыть….

Также об обновлениях…
DElo
3 - 14.05.2004 20:26 		(2)И бухию поднастраивать? А нафига?
Что изменится в бухии, если вместо "Вентилятор такой-то..." пойдёт просто ТОВАР с указанием кол-ва и суммы?
И почему учётная политика перестанет соблюдаться?
427
4 - 14.05.2004 21:37 		А подумать?

Пригони 3 товара ручными операциями в чистой бухии (чтобы четко видно было)
НДС для простоты выбросим... Но косяк по нему будет еще какой!

Товар1 1 шт по 100 рублей д41.1 к60.1
Товар2 5 шт по 120 рублей д41.1 к60.1
Товар3 8 шт по 200 рублей д41.1 к60.1

Спиши себестоимость
Товар1 1 шт по 100 рублей д41.1 к60.1
Товар2 2 литра по 120 рублей д41.1 к60.1
Товар3 2 коробки по 200 рублей д41.1 к60.1

Закрой месяц - посмотри суммы... запиши

теперь замени ТоварХ на просто Товар в операциях... в приходе и расходе...
закрой месяц.... посмотри суммы....

Средняя развалится... причем это будет видно явно....

В этом случае надо отключать количественный учет... А то будет гибрид ежа и ужа ... Квадратные литры...

А отключать количественный учет - задница... Надо переделывать все документы, работающие с 41.1.... Там алгоритмы построены на количестве...

Нет количества - нет расчета средней.... Просто списываем суммы... О какой учетной политике идет речь.... после этого...

Впрочем, чего я буду доказывать... Мне это не надо...

Желание клиента понятно... Я в своей обработке переноса тоже сворачиваю.... но по группам аналогичных товаров.... с однотипными характеристиками и примерно одинаковой ценой.. Тогда детализация резко уменьшается.... и не столь велика погрешность... ее не видно... И править в этом случае нужно только РН - там дубли будут....

наприме
DElo
5 - 14.05.2004 21:47 		Спасибо, открыл глаза.
Просто товар - штучка, и ед. измерения у всего - штуки, правда, учёт идёт по партиям и по ГТД.
Ну а всё же, как трудоёмок процесс написания этих обработок в Бухии и Торговле?
Скажи, плиз, я с тобой не собиралась спорить и доказывать свою правоту, хочу просто услышать от программиста, писавшего эти обработки, очень это долго и муторно или нет.


Можно ли править переферийную конфигурацию? | База знаний | mista.ru

Можно ли править переферийную конфигурацию?

Lazarus 23.06.2004 13:53 | Иногда возникает необходимость подправить конфигурацию под местные нужды, а головная контора не может оперативно отреагировать на наши нужды, в следствии чего и вопрос, есть ли возможность подправить конфигуратор так, чтобы процесс автообмена не нарушался и для головной конторы все было бы так, как буд-то никаких изменений небыло? Формат всех данных остается неизменен, нужно лишь немного подправить код. Удалив файлы 1sdbset.dbf, 1sdwnlds.dbf и 1supdts.dbf, я превращаю распределнную базу в обычную, затем могу делать с конфигуратором что хочу, но вот не уверен что вернув эти файлы обратно, я восстановлю распределенную БД. Или все же все буде нормально?
Lazarus 3 - 23.06.2004 17:11 | Править хочу встроенные отчеты и некоторые функции глобального модуля дабы иметь более полную информацию в журнале регистраций действий пользователя. Про "периферию" согласен... долго соображал как правильно и все равно ошибся ;-(
Asmodeus 4 - 23.06.2004 17:17 | Наверное, если в центральной базе поддержут механизм загрузки внешних модулей, то проблем с отчетами точно не будет...
Gavrila 5 - 23.06.2004 17:21 | +(4) с глобальником тоже будет все оки
Asmodeus 6 - 23.06.2004 17:25 | (5) А это не будет несколько громоздко? К тому же, смотря что править в глобальнике... Если это исправление повлечет, в момент исполнения, срабатывание флажка изменения объекта метаданных (который, возможно, не должен был бы изменяться в оригинальной конфе), то, наверное, процесс автообмена нарушится, ИМХО...


Отгрузка ЗиК->Бух. Как правильно? | База знаний | mista.ru

Отгрузка ЗиК->Бух. Как правильно?

romix 21.06.2004 17:36 | У меня есть некоторые проблемы с отгрузкой проводок в subj. (в частности, не проставляется субконто 20 счета, приходится ставить его вручную). Я хочу "сбросить" все настройки обмена в их первоначальное состояние, чтобы все стало правильно. Как это сделать? Заранее спасибо за хелп.
Майк 5 - 22.06.2004 08:28 | Вообще ситуация описана не слишком определенно. Скорее всего (телепатически): на 20 счете в Бух введена аналитика, которая отсутствует в типовой конфигурации. При этом в ЗиК такая аналитика может тоже присутствовать и с виду все может быть ОК. Но в правилах вполне вероятно справочник (перечисление) с этой аналитикой отсутствует, поэтому при выгрузке субконто остается пустым. Или, может быть, что конфигурация обновлена, а правила обмена старые. Короче подробностев маловато для точной диагностики. Надо бы точно понять, какая аналитика на 20-м счете в Бух, в ЗиК и имеется ли соответствующее правило в XML файле правил.
romix 6 - 22.06.2004 14:34 | (5) Спасибо, похоже я допер, видимо в бух. поправили значение в справочнике для первого субконто 20 счета (вид продукции по умолчанию), и 1С его не цепляет... Ошибку бы прога написала, что ли... Наверное, не первый год люди на этом ... того...


Синхронизация и перенос между двумя конфигурациями данных. | База знаний | mista.ru

Синхронизация и перенос между двумя конфигурациями данных.

офииу 18.06.2004 18:54 | Нужно синхронизировать два справочника, один одноуровневый, другой многоуровневый. Причем из одноуровненвого в многоуровненвый. Пробовал с помошью xml. Не хватает знаний. Может че подскажете. Также будут интересны и другие способы... И если можно, то киньте немного информации по поводу переноса данных такого рода. Как лучше? *.xml или *.txt или че др.
THawk 1 - 18.06.2004 19:00 | Пробовали из диска ИТС: RefImport.ert или tranref.ert? они проще
офииу 2 - 18.06.2004 19:08 | Доступ к диску пока закрыт. Синхронизация непосредственно в форме акшн на кнопку. Посоветуйте что-нибудь по реальнее...
офииу 3 - 18.06.2004 19:18 | Есть старый *.xml файл. Он работает, но когда идет перенос из одноуровневого справочника в многоуровненвый, то значения которые уже есть в подуровнях находятся и подставляются, а которых нет, то создаются новые в первом уровне, а надо, чтобы они автоматически подкидывались в подуровень с названием 7. Дело еще вот в чем. Когда я делаю свой *.xml файл в Конвертации, то перенос данных не работает. Когда я беру за основу старый *.xml файл и подставляю ручками строки по смыслу, то такой измененный старый файл работает. И вот вроде бы добился таким способом всего, но вот эта проблема все еще не решена. Новые значения добавляются в первый уровень.
THawk 4 - 18.06.2004 19:19 | Что означет доступ к диску закрыт? У меня есть эти обработки, если надо. tranref.ert это работает через текстовый файл выгрузки и последующей загрузки. На самом деле синхронизаторов столько сколько умелых программистов.
SnarkHunter 5 - 19.06.2004 12:19 | У новых элементов родителя надо прописывать соответствующего...
romix 6 - 19.06.2004 22:27 | Попробуй мою компоненту (упрощенный доступ к XML) http://1c.hippo.ru/cgi-bin/rlist.cgi?r=1c77&t=na&code=2&s=1&searchstr=FastXML&order=1 Приведен пример запуска из 1С.
Michael99 9 - 21.06.2004 18:41 | Чего подробнее то? Находишь в своей обработке место где создается новый элемент справочника. (Ключевое слово Новый()) B присваиваешь атрибуту Родитель нужное тебе значение.


Как объединить 13-ть организаций в одно информационное пространство? | База знаний | mista.ru

Как объединить 13-ть организаций в одно информационное пространство?

HexSys
08.06.2004 14:53 		Ситуация такая. Есть холдинг, управляющая компания + 12 организаций в подчинении. Все организации являются юридическими лицами.

В управляющей компании хотят видеть всю картину в целом.
Каждая организация ведет свой баланс.

Конфы у всех разные: ЗиК у всех, есть ТиС, есть несколько ПУБ, и почти у всех есть Бухия.

Фот такая задачка... уже башка пухнет :(
Волшебник
1 - 08.06.2004 14:57 		Как насчет МОД?
HexSys
2 - 08.06.2004 15:00 		Где про него можно прочитать? (МОД-это Менеджер обмена данными?)
clg
3 - 08.06.2004 15:04 		http://www.pb.ru/manager/po.shtml
HexSys
10 - 08.06.2004 16:05 		Если не трудно, брось на hexsys@land.ru , заранее спасибо.

У меня впринципе ситуация забавная, я могу сказать давайте - "Вы все ребята будете работать в Коплексной конфигурации", например... И будете делать то-то и то-то. Так и будет... Или давайте купим ERP систему. (все организации в одной сети). Но хотелось бы конечно остаться с 1С... А вот какие должны быть у всех конфы и как их завязать, Фот ето вопрос... :(
Rom
12 - 08.06.2004 16:31 		В подобной ситуации два варианта:
1. Пытаться всеми правдами и неправдами объединить в единое информационное пространство разнородные конфигурации и формы учета...
2. Разработать на базе типовой конфигурации (ТиС, а лучше УП) единую для всех составных частей холдинга управленческую конфигурацию с возможностью ведению многофирменного учета и получения консолидированной отчетности и организовать информационный обмена (УРБД для 7.7 или планы обмена для 8.0)
HexSys
13 - 08.06.2004 16:39 		(12) 1. - Как? в этом и есть вопрос...

2.- Разрабатывать? на ето надо очень много времени, а ХоЗявам надо всегда Все и сразу. Тут еще прикол в разнородности деятельности каждой компании...
1 - Торговая и обеспечение сырьем, 3 - чистое производство 3- чисто оказание услуг... и т.п.
+еще уровень пользователей... :(
Rom
14 - 08.06.2004 16:58 		Поэтому, сперва необходимо разработать методику внутрикорпоративного управленческого учета, а затем уже написать управленческую конфигурацию. При этом, каждая фирма может вести свой учет как хочет, но в управленческой базе строго по стандарту.
HexSys
15 - 08.06.2004 17:04 		(14) Если каждая ведет как хочет... то как потом синхронизировать и сливать данные в управленческую?!? Или все документы бить 2 раза?...

Возмем например Номенклатуру - Каждый у себя назовет как хочет, а где потом правду искать - одно и тоже или нет?
Rom
16 - 08.06.2004 17:08 		Если номенклатура, контрагенты прочие справочники необходимы как аналитические разрезы в консолидированной отчетности, то нужно либо синхронизировать, либо "бить 2 раза". Обычно, достаточно "Группа номенклатуры 1", "Класс контрагентов А" итд.
HexSys
37 - 09.06.2004 15:47 		Есть например идеая такая...
Базы 1С не связывать. Поставить систему электронного документооборота.
Пользователь 1 в Базе 1, формирует заявку, выгружет в Excel и отправлает Пользоавателю 2, Тот смотрит и ручками заносит в Базу 2. и т.д.
Что думаете по этому поводу?
Rom
40 - 09.06.2004 15:53 		Зачем ручками, когда лможно загрузить из файла Excel, а лучше из xml
HexSys
42 - 09.06.2004 16:01 		(39) Именно ручками... Снимаем работу с программистов - перекладываем на пользователей, почему нет? Что поделаешь если они нехотят вникать и учится...
romix
43 - 09.06.2004 16:08 		Я тоже думал, а не лучше ли XML, но потом решил, что в 1С уже есть УРБД, которая позволяет загружать данные и туда, и сюда. Да еще и позволяет автоматически апдейтить конфу в периферийных базах, если программист меняет ее в центральной базе.
Rom
44 - 09.06.2004 16:15 		(42) Если ручками, то зачем тогда вообще автоматизация?
(43) УРБД - сложная в обслуживании и негибкая в программировании штука (к планам обмена v8 не относится). Для нормальной работы требует наличия во всех узлах обмена квалифицированного спеца. Не советую
romix
45 - 09.06.2004 16:18 		(44) Я сделал на рабочий стол ярлык Автообмен. Тетушка включает модем, нажимает ярлык, а все остальное делается само. Если кому надо заслать образец настройки, то могу...
romix
46 - 09.06.2004 16:22 		(+45) А что там негибкого в программировании то? Ставите галки, что выгружать, а что-нет, вот и все программирование...
lexa
47 - 09.06.2004 16:35 		(44) Если есть компьютер в узле, то неплохо иметь хоть какого-нибудь спеца, который хотя бы знает, что кнопка резет не является кнопкой эникей. А для автообмена спец не нужен. У меня шедулер виндовый сам все делает. А оператор смотрит чтобы конфигуратор не завис, если ошибка при приеме или отсылке почты. Проблема мне кажется в другом. Если нет опыта в решении таких задач, то браться за их решение нельзя. Пит прав. Rom прав в другом : вначале надо понять что нужно. Иначе через месяц или позднее на HexSys повесят всех собак. На счет сторонних программистов HexSys не прав. Они все равно уйдут, а рагребать после них и поддерживать кто будет. У 1С есть большой плюс - исходники останутся.
Rom
48 - 09.06.2004 16:57 		(47) УРБД плох тем, что обмену поджежат все объекты конфигурации (с признаком миграции). В случаее 13-ти фирм переферийные базы будут расти в размерах в геометрической прогресии. А если нужно обмениваться документами только по конкретной фирме или конкретному контрагенту, что тогда? Односторонний обмен здесь тоже не поможет.
HexSys
49 - 09.06.2004 17:09 		Вариант еще такой... Делаем общий классификатор кодов, пользователи на местах прежде чем завести Элемент любого справочника узнают там номер, и заводят в своей базе. Цель одна и таже номенклатура (материал, контрагент и т.п.) будет с одним кодом у всех.
Дальше пишем свою конфу с набором правил для переправки документов которыми нужно обмениваться... Пишем постепенно, своими силами...

Звучит совсем маразматично или нет?
Z1
50 - 09.06.2004 17:13 		Да не о том вы говорите.
Как учитывать взаиморасчеты между внутренеми фирмами.
Разные юр фирмы - между ними взаиморасчеты а хозяин то один.
Вот в чем вопрос ( а не как что-то куда-то перенести)
Rom
52 - 09.06.2004 17:16 		(49) Тоже самое говорилось в (12) п. 2. Единый клссификатор номенклатуры - это обязательный и единственно правильный подход в твоей ситуации. Классификатор можно загружать в каждую ИБ с помощью обработки.
HexSys
53 - 09.06.2004 17:18 		+(50) Есть на этот счет придовая мысль... Разделить документооборот на два потока... 1. Все что идет ввиде денег и 2-ой что пойдет взаимозачетом...
Rom
54 - 09.06.2004 17:18 		(50, 51) Взаиморасчеты учитываются легко, если предусмотрен многофирменный учет и присутствует консолидированная отчетность (по холдингу в целом). Все это есть в ТиС.
HexSys
55 - 09.06.2004 17:22 		(52) ...угу полный классификатор в каждой базе?
1. А как быть с тем что у одних это Продукция, а уругих это-же сидит в полуфабрикатах.
2. В производстве есть справочник Материалы, а в ТиС - материалы седят в номеклатуре...
Z1
55 - 09.06.2004 17:22 		(54) Ты уверен ?
Где в ТС векселя ( причем векселя интерпретируют как деньги иногда как товар),
сложные взаиморасчеты и возвраты. Бартерные сделки.
Rom
57 - 09.06.2004 17:24 		(55) В функционал обработки добавить возможность выборочной загрузки классификатора.
HexSys
58 - 09.06.2004 17:24 		(54) Согласен, может быть... Как привязать сюда еще и Производство?
Rom
59 - 09.06.2004 17:26 		(55)он же (56) Я грил о возможностях ТиС в целом. Учет специфичных документов и операций - это вопрос адаптации под определенного заказчика. Неужели холдинг из 13-ти фирм будет работать в типовой конфе?
Rom
60 - 09.06.2004 17:30 		(58) Обычно холдинг интересует исключительно управленческая информация: стоимость активов, обороты, продажи, остатки, долги, использование бюджета и т.п. Специфика учета производственной деятельности должна волновать производственную фирму, но не холдинг.
romix
61 - 09.06.2004 17:36 		(48) Да, действительно... Ну можно хотя бы справочники синхронизировать.
Или забить на рост базы (ну не геометрический он, а такой же, как в центральной ИБ). Кому сейчас интересен рост базы? Винта что ли не хватит? Все равно отгрузки - несколько килобайт в день. Ну будет не 1 Кб, а 13. Или не 5 Кб, а 60. Или не 10, а 130... Все равно это очень мало.

(49) Не маразматично, если есть префиксы кодов/номеров доков у каждой базы.
Кстати, в этом очень поможет Pit'овский (427 - это вроде бы он и есть) als по метаданным.

(51) Кто попал, тот и поможет. :-)
romix
62 - 09.06.2004 17:40 		А связывать несколько разных конф (Зарплату, Производство...) можно, имея их все на Центральном компе, и выполняя в конце месяца из них отгрузку в Бухию (типовая отгрузка через XML).
427
63 - 09.06.2004 18:03 		Размазать, чтоли, кого нибуть по столу....

Ну ладно

(0) В управляющей компании хотят видеть всю картину в целом. Каждая организация ведет свой баланс. Конфы у всех разные: ЗиК у всех, есть ТиС, есть несколько ПУБ, и почти у всех есть Бухия.

romix (35) Общая для всех конфа + УРБД. Кстати, УРБД позволяет передавать (например, в периферийные базы) не все данные.

(0) и (35) через УРБД стыковать не получится. Слишком разнородные данные надо собирать. Учет всех особенностей учета каждой фирмы в одной конфе - МД явно зашкалит за нормальные размеры.
Хотя при желании - флаг в руки.... Но в связи с частыми изменениями трахаться будут все 14 баз....

==============================
HexSys (37) Есть например идеая такая... Базы 1С не связывать. Поставить систему электронного документооборота. Пользователь 1 в Базе 1, формирует заявку, выгружет в Excel и отправлает Пользоавателю 2, Тот смотрит и ручками заносит в Базу 2. и т.д. Что думаете по этому поводу?

За такое программиста просто выгоняют... Задача программиста - уменьшить объем рутины ...

УРБД этой проблемы не решит...
МОД - решит.

Итог - никто даже не высказал мысли о возможности такого объединения, правилах такого объединения и принципах консолидации информации....

Начали обсуждать какие то технические детали... Причем ненужные и вообще говоря, к целям (0) никакого отношения не имеющие...

Хотя нет. Была одна идея... Непродуманная... Но зрелое зерно в ней было.

P.S. (0) запомни - первое правило любого форума - никто никому ничем не обязан..
427
65 - 09.06.2004 20:04 		(64) много надеешься... Я просто показал, что здесь обсуждается....
и в топике затронуты только 5% проблем переноса....

Например, проблема выбрасывания внутрихолдинговых передвижений (а фирмы- это отдельные юр лица со всеми вытекающими, специально не буду говорить для ... ламеров - какими последствиями). И учет потерь этих перемещений..

Как говорится... трах-cь сами ... дальше.....
romix
66 - 09.06.2004 20:36 		(63) Вы не поняли. Я предлагаю синхронизировать через УРБД отдельно ТиС, отдельно ЗиК, отдельно ПуБ. А сливать все воедино уже на центральной ИБ,
сливать все в Бух. стандартными средствами ТиС, ЗиК и ПУБ. Тогда объем программирования станет = 0, и при обновлениях объем, извиняюсь, секса тоже будет =0.
427
67 - 09.06.2004 21:30 		(66) Ну так кое кто тоже считал, что в СССР секса нет ...

Стандартными средствами это не решается.... точнее - считается с потерей части смысла этой инфы, после чего ценность ЦБ равна нулю....

А если и сделаешь стандартными - получишь дебет лампочки, кредит потолка.... А точнее спроси у грамотных экономистов.... После такого переноса...
romix
68 - 09.06.2004 21:36 		(67) Синхронизацию справочников еще никто не отменял. Вы правильно поставили проблему. Жалко, что в 1С нет внешних справочников (по аналогии с внешними отчетами). Так что (0) придется придумать схему синхронизации (справочники синхронизировать проще, чем базы целиком). А может быть МОД дает такую возможность (я просто не в курсе)?
BorisG
69 - 09.06.2004 21:41 		(68) Справочники (и не только) синхронизируются прежде всего организацией документооборота, при отсутствии онного внешние - слабое спасение... Впрочем я об этом уже писАл. ;-)
(67) Ека тебя сегодня понесло ;-) Ты тут, Maniac на itland'е двинул... День чтоль сегодня такой ;-))
romix
70 - 09.06.2004 21:47 		(69) Это как? Юзера за кодами что ли должны следить?
Хотя можно, наверное, создать пустую конфу, в которой есть справочники (общие для всех) и документы для создания, изм и удал. элементов. Вся ручная правка справочников д.б. везде запрещена. Ну и отгрузка через XML во все конфы изменений справочников. Я это так себе представляю по-хорошему.
427
71 - 09.06.2004 23:38 		Привет, Борь... Я седня дважды оторвался... Один раз здесь, второй на рыбалке...
Позвонили вечером - рак попер, пришлось взять раколовки, сесть на велик, в магазин, купить пару минтуев на наживку и на рыбалку....

Почти 2 ведра нахапал... Да крупный.... Все наелись до отвала... Вон кошка даже свернуться не может - брюхо мешает. Еще с полведра по ванне скачут - на завтрак пойдут.

(68) А похер синхронизацию справочников... Кстати, внешние сделать недолго. У меня используется другой принцип синхронизации, чем в стандартных ХМЛ переносах - не используется ни код, ни наименование, доп реквизитов синхронизации тоже нет... Юзер может править ВСЁ - код, наименование, все реквизиты - дубликаты не плодятся.... Можно сливать или делить справочники... Удивляюсь, как до этого в 1С не доперли....

Да МОД многое делает. Идею я спер в МОДе, признаюсь, но глубоко модернизировал ее..

"Вся ручная правка справочников д.б. везде запрещена. Ну и отгрузка через XML во все конфы изменений справочников. Я это так себе представляю по-хорошему."

Ну в принципе идея ничего... Но гемороя .... вагон с тележкой.... Ну его нахрен.... Пусть HexSys с ней трахается. Можно ему подарить.
{}
72 - 10.06.2004 09:09 		pit, а ведь МОД использует доп. реквизит синхронизации (поле IDD). Как сделал то синхронизацию ?
"не используется ни код, ни наименование, доп реквизитов синхронизации тоже нет... Юзер может править ВСЁ - код, наименование, все реквизиты - дубликаты не плодятся.... "
Расскажи , все равно уже с некоторыми поделился идеей -).
DocenT
73 - 10.06.2004 09:32 		Как всегда 427 не забыл упомянуть свою никчемную субъективную точку зрения. Что значит "а похер синхронизацию"? Например, в торговых сетях с распределенными филиалами и единым центром синхронизация играет не последнюю роль.
У нас в организации уже давно используется МОД и больших нареканий к нему нет.
Отличное средство. Гибкая система настроек. Обмен по различным каналам связи.
Rom
74 - 10.06.2004 09:35 		Забудьде УРБД, МОД и т.п. и переходите на 1Cv8 - там вопросы интеграции распределенных ИБ решаются гораздо проще на основе планов обмена!
Bell
82 - 10.06.2004 17:23 		(0) С точки зрения бухгалтерии Холдинга.
1. Решить организационные моменты (стандарт на конф.бухгалтерия, сроки закрытия месяца).
2. Программа ежемесячной выгрузки "Оборотов" в "Холдинг" (без излишней детализации).

Трудоемкость минимальна....
HexSys
83 - 10.06.2004 18:03 		(82) Согласен на 100%. Но для управляющей компании холдинга как раз данная иформация представляет мин. интерес, с точки зрения финансового планирования всей группы.
luk
87 - 11.06.2004 10:55 		Привет всем!
Почитал я тут вашу дискуссию и решил "всунуть" свои 5-ть коп.

Не пойму - зачем нужна выгрузка/загрузка доков? И тотальная синхронизация.
Я думаю, что прежде всего нужно определить характер информации, необходимой центральному руководсву. И исходя из этого создать (даже на 1С) прогу, к-я будет анализировать/хранить/выдавать и т.д. эту иформацию. А данные в нею можно получать из периферийных компаний, через формирование в их же базах так званых итоговых отчетов в разрезе необходимых данных (здесь конечно потребуется синхронизация - но не всего же подряд!).
Вот в принцыпе в кратце - то, что я думаю по этому поводу...
Valery
88 - 11.06.2004 11:40 		(87)Тоже придерживаюсь такого мнения. Зачем всю информацию качать, можно просто сводную информацию передать. установить единый формат передачи.
HexSys
89 - 11.06.2004 12:03 		(86) Про структуру...
1-Кампания занимается чисто продажей нашей продукции + поставками материалов.
4-Компании производственных... 2-полуфабрикаты, 2-готовыую продукцию
7-компаний оказывают услуги производственного и общего характера (внутри холдинга и нетолько)
lexa
91 - 11.06.2004 12:15 		(87) тогда можно еще проще: в подразделениях раз в месяц делают очеты в экселе, пересылают в центральный офис, а тм сидит человек, который из 13 делае один сводный (работы на день)
Бред.
Нет коррктной постановки задачи ( есть как есть и надо все это объединить, а как должно быть не знаю - "классический" бухгалтерский подход)
Как минимум можно предложить - создать копии баз подразделений в центральном офисе и синхронизировать их посредством УРИБ или МОД, а потом уже объединять это в одну базу уже в центральном офисе
Ирина
102 - 16.06.2004 09:22 		Мы эту проблему решили давно.
Существуют 12 департаментов. Во главе стоит офис. В офисе создаются справочники и кодировка например по материалам осуществляется в 1с(за основу мы взяли старый советский справочник в эл. виде, перекодировали во всех департаментах все ма-лы чтобы кодировка была единая это порядка 30000 наименований). затем пересылаем по почте все справочники и изменения в конфигурации.А обратно загружаем данные. ПРичем списание мат-лов ведется по FiFo, и поэтому существует понятие партии. Так как существует единый номер ТМЗ, хотя и имеются разные цены, поэтому и появляетя понятие партии.
tenant
106 - 16.06.2004 15:38 		Когда руководство говорит, что хочет видеть все, на самом деле его/их интересуют
лишь некоторые цифры. Как правило, довольно общие, сводные там таблички задолженности, поставки, оплат.
Вот это и надо им дать. В каждую контору - по толковому оператору+распределенка.
Все. Операторы ручками вбивают, что нужно. А уже потом можно думать про импорт данных из их систем. В распределенку. А про слияние в одну конфу вообще говорить не нужно. Вернее, надо говорить, раздувая щеки, ты делаешь именно так необходимое ох@енное объединение всех и вся.
HexSys
107 - 16.06.2004 16:52 		(105) Я тебе потом отвечу более детально...
Скорее всего будем внедрать 8-ку.
На сегоднишний день... Будут "частично" связанные конфигурации (на базе 7.7) и в основном бумажный документооборот.


Выгрузка данных из "1С-Бух" | База знаний | mista.ru

Выгрузка данных из "1С-Бух"

Марина 11.06.2004 14:03 | С помощью какой обработки можно выгрузить из 1С-бухгалтерии все документы, справочники и тд.? Эти данные после выгрузки нужно будет загрузить в программу "Корпоративные финансы" которая стоит на платформе 1С-Бухгалтерии.
Valery 1 - 11.06.2004 14:27 | лучше всего думаю воспользоваться конфигурацией Конвертация. При помощи ее настраивается правила обмена, а затем пользуешся стандартной обработкой. Универсальная выгрузка/загрузка
iceTiger 2 - 11.06.2004 15:08 | конф. Конвертация ? Подробнее ПЛС. Или ссылочку...
Valery 3 - 11.06.2004 15:09 | на любом ИТС
Filippych 5 - 11.06.2004 15:28 | 2(0) Ищи на ИТС обработку Tranref.ert
SiMazx 6 - 11.06.2004 15:34 | (5) Эт только для справочников... И то не всегда все хорошо...


УРБД. Как программно получить дату последнего успешного обмена? | База знаний | mista.ru

УРБД. Как программно получить дату последнего успешного обмена?

Bayr 14.06.2004 19:28 | Хотелось бы так, что бы журнал не ковырять. Хотя на самом деле думаю, что она нигде, кроме как в журнале, и не хранится. А может я не прав???
Z1 1 - 14.06.2004 19:39 | Да прав. На hippo поищи мою обработку по разбору журнала. Называется " Быстрый поиск подстрок в mlg-журнальном файле" Там есть все что нужно


УРБД. Корректировка старых документов и перерасчет базы "с разных концов" | База знаний | mista.ru

УРБД. Корректировка старых документов и перерасчет базы "с разных концов"

Bayr 14.06.2004 12:14 | Существует следующая проблема. В распределенной базе есть необходимость корректировать документы на разных периферийных базах. А после корректировки, естественно, хочется перепровести базу, дыбы отчеты отражали эти корректировки. Но после этого крректировки "другого конца" пропадают. Кто как решает эти траблы??? Или я что-то неправильно настроил?
SnarkHunter 1 - 14.06.2004 12:53 | Перед тем как перепроводить нужно из ПБ даннаые получить и загрузить...
Bayr 2 - 14.06.2004 13:16 | Это правило для ЦБ. Это понятно. А что делать на ПБ. Ситуация - ПБ1 решила, что приняла товар по накладной от 1.06.04 некорректно. И откорректировала цену товара. А для того, что бы увидеть "правильный" отчет по рентабельности продаж за период с 1.06 по 14.06 провела перерасчет базы. При этом были перепроведены все документы в "их базе"(ПБ1). А в этот момент ПБ2 исправила 5 документов за 11.06 и 10 документов за 12.06 (ошибки операторов и проч.). Обмен с ЦБ производися в последовательности ПБ1 затем ПБ2. В итоге исправления от ПБ2 "не приживутся" и будут потеряны. Хорошо когда это замечают сразу и поднимают крик. А если очнуться через 2 недели??
Z1 3 - 14.06.2004 13:19 | Перепроведение делай только в Цб. Еще лучше перепроведение делай один раз в неделю.
Bayr 4 - 14.06.2004 13:35 | Т.е. запретить перепроведние на ПБ. Но тогда некорректны итоги. До сей поры я делал следующее. Правки на ПБ разрешал только в текущем дне. Обмен шел 1 раз в день (ночью), поэтому на ПБ были только "свои" документы за сегодня. А все исправлнения вносил на ЦБ по письменным заявкам от ПБ. Сейчас очень возрос объем этих корректировок. Хочу часть преложить на плечи ПБ. Скажем, корректировки "глубиной" до недели - на ПБ, более глубокие - на ЦБ. Но если ПБ не видит сразу же итогов своих корректировок - она их не будет вносить, а точно так же скинет заявку на ЦБ.
SnarkHunter 5 - 14.06.2004 13:52 | Интересно как документы ПБ2 оказываются в базе ПБ1? У тебя миграция для документов настроена как "Все информационные базы"?
Z1 6 - 14.06.2004 14:06 | (4) перепроводить в ПБ разрешить. Перепроведение для восстановления последовательности только в ЦБ
Bayr 7 - 14.06.2004 14:08 | Да, все информационные базы. ПБ1 - склад и касса, ПБ2 - бухгалтерия (безнальные оплаты )(как пример) - все хотят видеть все документы
Bayr 8 - 14.06.2004 14:13 | (6) Если не перепровести все документы, в которых используются итоги откорректированного документа, то итоги - некорректны. Любой перепроведенный документ считаеся исправленным (т.е не допустит корректировки "с другого конца"). Вот тут и возникают "пропажи корректировок"
SnarkHunter 9 - 14.06.2004 14:16 | Ну тут либо "шашечки", либо ехать...
Z1 10 - 14.06.2004 14:21 | (4) Как вариант Пусть заявки на исправления шлют на конкретный почтовый ящик. Ночью робот вытаскивает письма из этого ящика и все корректо перепроводит. Если все успешно прошло письмо удаляется. Только перед запуском убедись что подгрузка с обоих филиалов прошла успешно иначе тоже возможны трудноуловимые ошибки(неточности) (8) Что-то с трудом понимаю как можно так написать чтобы было (8). Избавляйся от таких алгоритмов расчетов итогов т.к. все равно вряд ли сможешь запретить изменения задним числом.
Bayr 11 - 14.06.2004 14:26 | (9) Вот и я прихожу к такому же мнению - что механизм УРБД имеет недостатки (ограничения лучше сказать). Но четко сформулировать эту проблему пока не могу - а соответвенно не могу и лекарство найти...
Bayr 12 - 14.06.2004 14:33 | (10) Вот пример: Приходный документ формирует партию товара и , соответственно, ее себестоимость. Любой расходный документ использует эту себестоимость при проведении по регистрам. Исправив в приходе цену, мы исправим себестоимость партии. И что-бы отчеты были правильными, надо перепровести все расходные документы. Был бы рад избавиться от такого алгоритма, но ничего другого придумать не смог. А корректировок действительно стало очень много, и чувствую, они меня доконают...
427 13 - 14.06.2004 14:53 | (12) можно не перепроводить, а изменить остаток (сумму) документом.... Например, пришло 100 по 10 = 1000 продали 40 * 10 = 400 Пришли бумаги на стоимость перевозки удорожание 200 руб делаем документом удорожание по товару на 200 руб по этой же партии и тут же списываем 200 / 100 * 40 = 80 руб - эта та часть удорожания, которая уже продана... Ничего перепроводить не надо.... В базе остался след изменений ... Все довольны ... После документа исправления доки списания будут автоматом брать измененную себестоимость...
Bayr 14 - 14.06.2004 15:23 | (427)(хороший у тебя ник ;))) Если бы речь шла только о "законных" исправлениях..., которые можно ввести отдельным документом. Я потратил очень много времени для ввода таких доков как возврат (поставщику, от покупателя) - до этого правили отгрузку. Но, к сожалению, есть такая специфика бизнеса - правка цены отгрузки. И с этим нечего не поделать. Обкатываю пока мысль, что бы исправления цены в приходном доке делались отдельным документом, но пока не реализовал...
Z1 15 - 14.06.2004 15:30 | (14) Что отражают в расход. накладных и его движениях цена себестоимости? Заведи реквизит себестоимости в справочнике партия. И если меняется цена отгрузки задним числом то надо ведь переделывать документы отданные клиенту ( или это дочка и с .тим нет проблем) ?
Bayr 16 - 14.06.2004 15:53 | (15) Чаще всего именно клиент инициирует изменение цены отгрузки, поэтому приходится переделывать и "бумагу" А цена приходных документов конечно же не отражается в расходных доках(в реквизитах)... Но используется при проведении их - списание со склада происходит по себестоимости. Насчет себестоимости в справочнике - была такая мысль... уже не помню, почему отказался от этого. Может придется вернуться. Но если вариант хранения стоимости в регистре остатков является, скажем так, привычным, то хранение себестоимости в справочнике - надо все осмыслить. Думаю, там появяться другие подводные камни...


Конвертация данных | База знаний | mista.ru

Конвертация данных

Zombi 05.06.2004 21:04 | Как в конфигурации "Конвертация данных" между 2 конфигурациями где в одной ставка НДС - перечисление, а в другой справочник, написать правило соответствия? Может кто-нибудь знает ссылку на какой-нибудь практический учебник по этой конфигурации?
787 3 - 07.06.2004 08:45 | Устанавливаете с диска ИТС конфигурацию Конвертация данных, ищете конвертацию торговля 9.х в бухгалтерию 4.х и смотрите, как перечисления СтавкиНДС конвертируются в элементы справочника Ставки НДС.
Valery 4 - 07.06.2004 08:53 | В конвертере есть конвертация Торговля 9.2- УСН там как раз такая ситуация.
SiMazx 5 - 07.06.2004 08:59 | Ой, ну шо вы накинулись, да? http://www.mista.ru/articles1c/hare/article.62.html


Проблема с УРБД для 1С: Зарплата | База знаний | mista.ru

Проблема с УРБД для 1С: Зарплата

SvetK 09.06.2004 15:30 | Конфигурация - переработанная типовая (работа внедренческой фирмы). Созданы Центральная и несколько периферийных баз. Правило миграции - все информационные базы, автоматическая регистрация изменений. Первая загрузка из периферийных в ЦБ происходит более менее гладко. Уже вторая загрузка из периф. в ЦБ очень проблемна: слетают некоторые долгосрочные начисления и удержания (вообще нет записей в ЖР), почти все записи-сторно и записи-перерасчеты. Никаких специальных правил по миграции в модулях конфигурации не прописано. У кого есть опыт - отзовитесь!
Rom 1 - 09.06.2004 15:44 | Для начала вписывай префиксы ИБ в номера документов и коды справочников и запрети их редактирование в смежных ИБ.
romix 2 - 09.06.2004 15:46 | (0) Указаны ли во всех базах префиксы ИБ? Периферийные базы "изготовляли" методом "загрузить" в пустую базу? Тогда откуда там сторно? Тестили ли на одном компе все базы?
SvetK 3 - 09.06.2004 16:12 | Префиксы, конечно, заданы - для документов и почти всех справочников (кроме некоторых подчиненных Сотрудники). Создавали базу по инструкции 1С УРБД. Сторно и перерасчеты связаны с тем, что на момент создания распределенной базы, в ней уже были расчеты по всем сотрудникам за 1,5 года.
Rom 4 - 09.06.2004 16:18 | Мнение. Откажитесь от ЗиК+УРБД - только проблем больше наживете!
romix 5 - 09.06.2004 16:29 | (3) Вы тестите в пределах одного компа? (т.е. все базы на одном компе?) Что стоит на закладке Свойства-Миграция для глючащих элементов метаданных? Какой релиз 1С?
lexa 7 - 09.06.2004 16:46 | http://www.mista.ru/articles1c/urbd.htm http://argat.h11.ru/URBDStructure.html
SvetK 12 - 10.06.2004 08:49 | Базы тестировали и не один раз, на одном компе. Глючащими являются не элементы метаданных (документы и справочники перегружаются без проблем), а созданные документами записи ЖР, которые свойств миграции не имеют. Хотелось бы, конечно, чтобы откликнулся администратор, занимающийся именно УРБД для 1С:Зарплата (7.7).


Запуск (!)1С:Предприятия(!) в пакетном режиме и выполнение там обработок | База знаний | mista.ru

Запуск (!)1С:Предприятия(!) в пакетном режиме и выполнение там обработок

Botan 07.06.2004 13:25 | У меня такая задача: 1. При автообмене (непосредственно перед самой выгрузкой из ЦИБ) мне необходимо на центральной базе выполнять обработку, которая делит документы по базам. Ее надо запускать в немонопольно запущенном enterprise. Хотелось бы, чтобы это происходило без моего участия по расписанию. 2. Плюс ко всему после загрузки-выгрузки в периферийных ИБ надо пускать монопольно enterprise и делать там обработку отмены проведения смигрировавших документов. Эту обработку тоже было бы здорово делать без моего участия по расписанию. ВОЗМОЖНО ЛИ ЭТО РЕАЛИЗОВАТЬ?
lexa 3 - 07.06.2004 13:42 | создай фиктивного пользователя, в глобалном модуле в процедуре ПриНачалеРаботыСистемы() добавь проверку на этого пользователя и запускай обработку. У romixа есть интересная разработка для запуска автообмена, если ее модернизировать то можешь сделать через нее.
Botan 5 - 07.06.2004 14:04 | автообмен через конфигуратор в пакетном режиме у меня просто сначала делается обработка в ЦИБ, которая делит документы по периферийным базам (определяя для каждой из них только их документы) потом делается выгрузка по этим периферийным базам потом в периферийных делается загрузка-выгрузка потом обработка отмены проведения смигрировавших документов потом загрузка выгрузок в ЦИБ из периферийных
lexa 7 - 07.06.2004 14:25 | http://www.forum.mista.ru/topic.php?id=5094
Botan 8 - 07.06.2004 15:25 | Но дело в том, что запуск обработок у меня осуществляется исключительно в немонопольном enterprise (!!!)
lexa 9 - 07.06.2004 16:02 | создай пользователя в глобадьном в глобалном модуле в процедуре ПриНачалеРаботыСистемы() где нибудь в конце (например перед "КонецПроцедуры" Если глПользователь = Пользователь ОткрытьФорму("Обработка.ТвояОбработка"); КонецЕсли В модуле формы обработки добавь ЗавершитьРаботуСистемы(0) в cmd или bat cd <путь к 1сv7.exe> start /wait 1cv7.exe enterprise /<путь к базе>/NПользователь /PПароль start 1cv7.exe CONFIG /<путь к базе>/NАвтообмен /PПароль /@<путь к файлу параметров>


Проблема с открытие больших MXL-файлов в Excel | База знаний | mista.ru

Проблема с открытие больших MXL-файлов в Excel

Vser1 13.05.2004 11:36 | Давненько не подкидывал головоломных вопросов... Формирую в ЗиК Отчет о доходах физических лиц, сам отчетик формируется без проблем (база примерно 2000 сотров), и не могу ничего с ним сделать, на печать из 1С не прет (стоит SQL 19 релиз), задумывается намертво, сохраняю его в MXL-файл (размер 78 мертов с кепкой) и та же ерунда, Eхcel зависает на открытии, зато жрет ресурсы процессора и памяти. Что сделать, как расшевелить сию беду?
Bzzzzz 1 - 13.05.2004 11:41 | Раздели mxl-файл на части и распечатай их из 1С отдельно.
Vser1 2 - 13.05.2004 11:51 | А как разделить такой файлик на части? Он выводится из 1С целиком, а делить при сохранение вроде нет возможности.
Gavrila 3 - 13.05.2004 11:56 | (2) "Файл"->"Новый"->"Таблица" - в новую таблицу пытаешься скопировать какунить часть исходной таблицы, а потом сохраняешь либо печатаешь отдельно
Vser1 5 - 13.05.2004 12:17 | Попытался 25 тыс строк вырезать одинэссиса задумалась, похоже намертво... Подскажите разумное число, чтоб не использовать метод научного тыка?
Gavrila 6 - 13.05.2004 12:30 | (5) альтернативные форматы TXT и HTML не подходят ?
Vser1 7 - 13.05.2004 12:37 | Нет не катят :((( потом возможно печатать придется, придется так издеваться... Отчет о вырезке 10000 строк вырезалось 10 минут......... ооооочень долго, если и раньше у меня о эссине было не лучшее мнение то теперь оно упало совсем в ноль :(((
Gavrila 9 - 13.05.2004 12:59 | (7) Вот кстати где-то нашел, может и поможет чем (неуверен, но на всякий случай) Для того, чтобы открыть файл *.mxl в Excel Необходимо внести в реестр следующую информацию: REGEDIT4 [HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Excel\Converters] "Moxel"="1С:Предприятие (*.mxl),...\\bin\\mxl2xl.dll, *.mxl" где: <...> это пусть к каталогу 1С-Предприятия <10.0> это номер версии Экселя - XP. Для 2000 это будет 9.0, 97 - 8.0, 95 - 7.0
Vser1 10 - 14.05.2004 02:21 | (8) Для разового случая дорого. Если сильно приспичит найду на халяву :))) (9) Спасибо за подсказку, а то на одной машине Excel, не знает об этой возможности, теперь разъясню ему об этом. Отчет о разрезании и открытии: 5000 строк вырезается терпимо, 3-4 минуты, Excel не открывает.... 2500 строк УРЯЯЯЯ!!!! Все поехало.... Тока мой исходный файл придется делить на 28 частей :(((((((((((
427 11 - 14.05.2004 06:34 | Делите, товарисч, все по кускам .... Кстати, 2500 - это только в твоем конкретном случае... В другом может быть и 1000 строк всего... А в третьем и 10000
Shadal 12 - 14.05.2004 09:20 | А при формировании отчёта при выводе строк в модуле если прописать чтоб после вывода 2500 строк создавалось новое окошко(новая таблица) и туда выводилось.. Можно кстати на экран не выводить а сразу на печать эти таблички.(Экономия времени).Короче так формируется отчёт, создаётся таблица , выводятся в неё строки, затем после вывода 2500 строки таблица посылается на печать, очищается и в неё выводятся строки дальше и т.д. до конца формирования отчёта....
Mohoshito 13 - 14.05.2004 10:04 | А разве печать по одной странице не поможет делу? Сам не пробовал, но теоретически должно вроде?
Vser1 14 - 14.05.2004 10:11 | (12-13) Это все изменения в коде, мне б без этого простое и доступное решение.
Mohoshito 15 - 14.05.2004 10:16 | Не, ну (13) это меню файл\печать\ и там ставишь номер страницы. Гемор конечно, но зато просто. :) Или несколько страниц.
Vser1 17 - 14.05.2004 11:49 | (15) Пытались :((( С таким файлом не катит (читай начало), виснет намертво сама эссина. (16)Это время нуна на поиск обработки и т.д..... а его не было, нужно было срочно, проверяющей понадобилось. Разбил ручками и на этом все успокоились.
krok 18 - 14.05.2004 16:48 | В этом случае я делаю так: Сохраняю отчет в .txt В экселе открываю этот .txt и преобразую в таблицу... Затем пара кликов мышкой для форматирования столбцов и все... Отчет в Экселе...


Закачка данных в бух.7.7 из УТ 8.0 | База знаний | mista.ru

Закачка данных в бух.7.7 из УТ 8.0

Monstrik 20.05.2004 12:11 | Кто-нить заливал данные в 77 из УТ ? Выгрузка данных из УТ идет замечательно. При попытке загрузить в 7.7 без паузы после нажатия ОК выдается ошибка "ТипТега = гФайл.Спуститься(); {Обработка.ЗагрузкаДанных.Форма.Модуль(3273)}: : Ошибка исполнения метода" Это чего она ругается ? :)
Estet 1 - 20.05.2004 13:52 | Скорее всего проблема с правами доступа к этому файлу переменая не может с ним связаться гФайл.СвязатьСФайлом(ФормИмяФайлаДанных);
Estet 5 - 21.05.2004 09:10 | Поробуй в свойствах Безопасности - Дополнительно сделать себя текущим владельцем
Monstrik 7 - 07.06.2004 08:42 | Проблема решилась поднятием версии 8.0 УТ до 1.8, а 7.7 Бух до 459


помогите в составлении скриптов | База знаний | mista.ru

помогите в составлении скриптов

COLORFISH 07.06.2004 00:45 | я совершенно новичёк в 1С.. по роду своей работы вынужден ей(им) заниматься и при обмене данными между удалёнными базами приходится запускать каждую базу например- переферийную в режиме конфигуратор и делать автообмен и потом закрывать её... я понимаю что это мелочи, но если имеешь дело только с одной базой, если их штук 20 то на это уходит около часа ежедневно... я чувствую, что есть решение этой проблеммы в составлении какого то набора символов в бат файле и он всё зделает сам, пусть за тот же самый час, но я не буду сидеть как идиот и кликать одни и те же кнопки вместо того чтобы занятся чем нибуть другим... заранее пасиб
Волшебник 1 - 07.06.2004 00:50 | Читайте тут: http://www.forum.mista.ru/topic.php?kb=1&id=4064
Волшебник 3 - 07.06.2004 01:24 | Автообмен (УРИБ) в системе 1с "Как сделать автообмен 1с между серверами, соединенными tcp/ip - сеткой с медленным и ненадежным соединением, например через коммутируемый канал (идеи и примеры)." http://mshapkin.narod.ru/adm1c/autoex.rar (12К) Читайте readme.txt внутри.


Из 1С:Бухгалтерия в 1C:Предприниматель | База знаний | mista.ru

Из 1С:Бухгалтерия в 1C:Предприниматель

Человек 02.06.2004 23:43 | Помогите, если сможете, пожалуйста. Требуется данные (справочники, документы) из конфигурации 1С:Бухгалтерия 7.7 (456 релиз) перенести в конфигурацию 1С:Предприниматель 1.25 (или выше). Данные уже внесены за 2003 г. и уже ничего не исправишь. Требуется получить книгу учета доходов и расходов предпринимателя. Могу написать сам, но времени очень мало, практически нет.
Влад 1 - 03.06.2004 11:12 | а что если воспользоваться обработками с ИТС, например tranref.ert или чем-нибудь подобным?
ally 2 - 03.06.2004 16:00 | tranref.ert перенесет не все, и многое придется руками добавлять, о переносе доков можешь забыть (есть вариант, конечно, но очень не простой).
Valery 3 - 03.06.2004 16:05 | Имею только выгрузку из торговли 9
Человек 4 - 03.06.2004 22:25 | Спасибо, выгрузка из торговли 9 не нужна. А какой вариант имеешь в виду ты, ally? Или придется все-таки кропотливо переносить через текстовый файл. Уйдет куча времени.
Влад 5 - 04.06.2004 04:39 | (2) я и не утверждаю, что, например tranref.ert, перенесет абсолютно корректно все реквизиты справочников, но если нет времени на собственные разработки, то наверное проще воспользоваться этой обработкой (для справочников), хотя самый оптимальный вариант, конечно же, - это самому написать подобную обработку.
Влад 6 - 04.06.2004 04:46 | http://www.forum.mista.ru/topic.php?id=4600
Человек 7 - 04.06.2004 21:17 | Все ясно, за ссылку спасибо. Время поджимает, придется все-таки руками шевелить. Что-такое hippo (хиппо), которую упоминали в той теме?
Волшебник 8 - 04.06.2004 21:28 | (7) 1c.hippo.ru


нужна обработка переноса справочника номенклатура | База знаний | mista.ru

нужна обработка переноса справочника номенклатура

Вася 04.06.2004 17:08 | Помогите люди. Есть у кого нибудь обработка переноса справочника номенклатура из ТиС в Бух
lexa 1 - 04.06.2004 17:48 | сервис-дополнительные возможности
hanprog 2 - 04.06.2004 18:04 | помойму на mista.ru втдел обработку по копированию справочников из одной конфы в другую в вообще все уже есть стандартное или если есть желание то лучши напиши сам лучшая тренировка
lexa 3 - 04.06.2004 18:09 | (2) для тренировки да, а для дела "Выгрузка из торговли", позоляет не только номенклатуру, а любые справочники и доки с филтрами
mszsuz 4 - 04.06.2004 18:23 | на ИТС и не только, есть обработка TranRef.ert ...


Не получается из ТиС выгрузить счета в бух. | База знаний | mista.ru

Не получается из ТиС выгрузить счета в бух.

romix 02.06.2004 20:11 | Это вообще позволяет стандартная выгрузка через XML? А уже на основании бухша сформирует счета-ф, накладные etc.
427 1 - 02.06.2004 21:27 | И правильно, что не получается... Будут расхождения (на копейки) из-за разных алгоритмов расчета и округлений .... но они недопустимы .... Надо выгружать накладные с уже рассчитанными суммами ....
VladZagorsky 2 - 03.06.2004 06:59 | Правильно ли я понял: ты хочешь выгрузить счета, чтобы потом на их основании сделать документы? А в чем смысл-то? Исходя из опыта общения с бухгалтерами знаю, что счета они в бухгалтерии не проводят. Т.е. счета в большинстве случаев нужно только лишь для того, чтобы зарезервировать товар (т.е. для отдела продаж, но не для бухгалтерии). Если тебе нужно передать информацию по счет-фактурам (накладные) - передавай счет-фактуры (накладные). Так и буху будет меньше работы и ошибок меньше. --------------------------------------------- Программист нужен для того, чтобы оператор (бухгалтер, аналитический отдел и т.п.) не занимались "обезьянней" работой.
romix 3 - 03.06.2004 20:07 | (427) Вы правы, это плохо. Поэтому я хочу, чтобы в ТиС создавали только счета, а разные фактуры делал и печатал только бух, уже в своей базе. (2) Тоже вариант. То есть, бух сможет на основании фактур делать накладные? По моему с этим при отгрузке у меня была подстава... фактуры есть, а накладных -нет...
427 4 - 03.06.2004 20:30 | Как то все через Ж.... "чтобы в ТиС создавали только счета, а разные фактуры делал и печатал только бух, уже в своей базе" С дуба рухнул?.... Клиент ждет ... и матерится - время то идет... Лучше просто переносить из ТиС в бух накладные и СЧФ в конце периода... Именно документы (с нумерацией и цифирью копейка в копейку)... Ну армянские комсомольцы.... сами выроем канал.... сами успешно будеть ...ся в него Обычно про такое я цитирую знакомого боцмана "ХХХ вашу жесть" - сказал боцман и грязно выругался ....
romix 5 - 03.06.2004 20:35 | (4) Так не переносятся же из ТиС в бух. накладные. Или я что-то не так делаю?


Синхронизация баз 1С | База знаний | mista.ru

Синхронизация баз 1С

ФАКОэмульсификатор 03.06.2004 10:43 | Привет всем. Возникла задача синхронизации двух баз, обе на УРИБе. В одной ведется бухия предприятия, вторая работает в торговых точках. Сделано для того, чтобы в торговые точки не попадала вся бухия. Никогда ранее не занимался синхронизацией но сразу вижу следующие проблемы: - риск дважды загрузить одни и те же данные - проблема повторной загрузки измененных документов Прошу помочь советом или ссылкой на ресурс, где расмотрены проблемы и методы синхронизации.
lexa 2 - 03.06.2004 11:01 | http://www.mista.ru/articles1c/urbd.htm если поставишь префиксы ИБ, то более менее все будет нормально возможна следующая колизия - если один и тот же объект правят одновремеено ( в перерыве между обменом) в разных ИБ УРИБ отслеживает все изменения и пересылает их, а потом ждет подтверждение, что эти изменения приняты, если подтверждения нет, то посылает их повторно вместе с новыми
ФАКОэмульсификатор 3 - 03.06.2004 11:58 | Спасибо за ссылку, но наверно я немного не точно описал задачу. Есть 2 отдельных независимых (пока) базы. Каждая - распределенная. В одной ведется бухгалтерия (ее части размещены в разных офисах компании). Во второй ведется учет продажи товаров в магазинах (соответственно, она распределенка, ее части в разных магазинах) Необходимо наладить перенос доков из торговли в бухгалтерию.
Vantala 4 - 03.06.2004 13:00 | IMHO не поможет здесь УРИБ если конфигурации разные Для переноса доков можна установить МОД компании ПиБи там все можно произвольно настроить.
lexa 5 - 03.06.2004 13:15 | либо стандартная выгрузка из торговли в бух Сервис-Дополнительные возможности


КД. Перенос подчиненных | База знаний | mista.ru

КД. Перенос подчиненных

Bzzzzz 02.06.2004 16:48 | Перенос Номенклатуры из ПУБ 283 в ТиС 933. Реквизит "ЕдиницаИзмерения" -> "БазоваяЕдиница" "ЕдиницаИзмерения" = справочник "ЕдиницыИзмерений" (Классификатор единиц) "БазоваяЕдиница" = справочник "Единицы". Подчинен "Номенклатуре", т.е. нужен Владелец! Как его установить, как передать из ПУБ? Может делал такой перенос или может подскажите похожие типовые правила переноса.
Bzzzzz 5 - 02.06.2004 17:12 | И еще вопрос: Допустим я переношу не весь справочник Номенклатуры, а конкретные элементы (их можно подобрать в обработке выгрузки данных). Как сделать, чтобы при этом из подчиненных справочников выгрузились элементы, подчиненные выбранным?
SiMazx 6 - 02.06.2004 17:18 | (5) Если правила оформишь как надо - они сами перенесутся... Посмотри, там есть объяснение... http://www.mista.ru/articles1c/hare/article.62.html
Bzzzzz 8 - 02.06.2004 17:26 | (6)Угу. Это я уже прочитал. Но... Номенклатуру я переношу "Выборка", а для подчиненного справочника если поставить "Выборка" он же будет весь перетаскиваться, даже если я подбором отберу конкретные значения Номенклатуры. Разве нет?
HanProg 9 - 02.06.2004 17:30 | Подчиненый справочник это обычный справочник у него только в Реквизите Владелец установлена ссылка на справочник владельца так что выгрузкить можно справочник а при загрузки использовать оператор ИспользоватьВладельца выгрузку можно самому написать иногда это быстрее чем заставить работать стандартныю
Bzzzzz 10 - 02.06.2004 17:33 | (9) Да я уже сделал перенос, но мне интересно теперь реализовать это через КД.
Рупор абсурда 11 - 02.06.2004 17:44 | (10) На оба вопроса ответ - нельзя


Нужно перегрузить данные из Торговли в Бухгалтерию | База знаний | mista.ru

Нужно перегрузить данные из Торговли в Бухгалтерию

Фантомас 02.06.2004 07:01 | В Бухгалтерию (7.70.456) введен разделитель учета (перебросил из Торговли справочник Фирмы со всеми вытекающими).Нужно из Торговли (7.70.933)выгрузить данные и загрузить их в Бухгалтерию в виде операций.Существует типовая обработка ,позволяющая выгружать проводки по выбранному в диалоге юридическому лицу,но при загрузке этих данных в Бухгалтерию фирма в проводках естественно не проставляется.Для этого нужно подкорректировать типовой файл правил обмена данными в формате XML ,используя конфигурацию "Конвертация данных".Проштудировал инфу об этой Конфе на ИТС,но этого мало-уж очень скудно там все описано.А клиент уже начинает нервничать.Может быть я полный лузер,но сам с этой гребанной конвертацией разобраться не могу.ПРОШУ О ПОМОЩИ!!!!!!!!!!!!!!!!!
SiMazx 4 - 02.06.2004 09:32 | (0) Имеющийся файл правил Конвертацией не поправишь... Нету там таких возможностей... А сам в КД быстро не разберешься... По крайней мере до такого уровня, чтобы самому все исправить... Поэтому обращайся к спецам...
SiMazx 5 - 02.06.2004 09:34 | (0)Хотя как вариант... В КД есть правила переноса между типовыми конфигурациями... Если в них поковыряться... Пробуй!
427 7 - 02.06.2004 11:05 | Отчеты типовые в составе конфы - не надо... Там все есть... Доки - надо


Как перейти с Бухучета 4.5 на УСН 1.3 ? | База знаний | mista.ru

Как перейти с Бухучета 4.5 на УСН 1.3 ?

waits 01.06.2004 14:35 | Подскажите, каким образом перенести бухгалтерские остатки между разными конфигурациями. Исходная: Бухучет 7.70.457, Оперучет, Расчет. Переносится в чистую: Упрощенная система налогообложения 7.70.136 Может кто ответит?
ally 1 - 01.06.2004 14:42 | Между ними есть обмен
waits 2 - 01.06.2004 15:06 | Может подробнее для новичка! Там есть обмен, но только не с УСН :-( Заранее спасибо ally!
ally 3 - 01.06.2004 16:00 | у тебя в каталоге базы в ExtForms лежит файл Cv45_Usn.txt


Планы обмена в 1Сv8 - личный опыт | База знаний | mista.ru

Планы обмена в 1Сv8 - личный опыт

Rom 01.06.2004 19:10 | Функционал плнаов обмена в связке со средствами работы с xml позволяют быстро и достаточно просто переносить данные из одной конфигурации в другую, при условии, что установлен режим авторегистрации измений объектов. Однако на практике требуется требуется переносить не все измененные объекты, а лишь некоторые из них. Например, приходные/расходные накладные, отобранные по реквизиту "Организация" (речь идет о УТ). В такой
Rom 1 - 01.06.2004 19:17 | сорри... При такой схеме другим звеньям распределенной ИБ незачем передавать все номенклатуру и всех контрагентов определенной Организации. Для решения подобной задачи был использован рекурсивный вызов процедуры, регистрирующий изменения всех подчиненных реквизитов документа, независимо от уровня их вложенности.
OctoberHammer 4 - 01.06.2004 19:49 | Вообще-то именно этот личный опыт реализован в демо-конфе на ИТСе - по крайней мере идея выодится буквально следующим шагом после того, как ты видишь галку "главный" в узле и видишь когд, где эта галка анализируется - нужно ли загружать изменения или нет. А так - молодец.


1С и подготвка данных для OLAP | База знаний | mista.ru

1С и подготвка данных для OLAP

Валентин 01.06.2004 12:31 | Как обеспечить выгрузку данных в OLAP? Какие структуры/форматы и алгоритмы кто использует? Может у кого есть обработка формирования DTS пакета по конфигурации? Коммерческие предложения и Adelite:ETL не предлагать (нет денег)
Валек 1 - 01.06.2004 12:54 | своими силами каждую ночь 1с ч/з адо выгружает в хранилище которое в дбф формате, счас строется новое хранилище в скл
Валек 2 - 01.06.2004 12:55 | своими силами каждую ночь 1с ч/з адо выгружает в хранилище которое в дбф формате, счас строется новое хранилище в скл форум по Olap технологиям http://sql.ru/forum/actualtopics.aspx?bid=26
Валентин 3 - 01.06.2004 13:18 | Про форум знаю. Вещт полезная. Что бы не изобретать велосипед (в данном случае самокат) - поделись обработкой выгрузки (если это конечно это возможно)
Валек 4 - 01.06.2004 14:45 | можно было бы выслать, но нет в этом смысла т.к. это не обработка, а отчет одна из функций которого выгрузка данных в хранилище, но там разобраться очень сложно т.к. я при написании не документировал, и счас порой сам трачу некоторое время на то чтобы вспомнить что к чему и после того ввести изменения да и к тому-же конфа не типовая
Валентин 5 - 01.06.2004 15:14 | Да и нет уже необходимости. Все увязвается очень легко с 1С если использовать _idtostr. Нет необходимости экспортировать справочники. а готовность помочь - спасибо.
Валек 6 - 01.06.2004 16:34 | все конечно зависит от того какая задача по анализу стоит перед вами, мож справочники не нужны, а только лишь документы. поэтому удачи. давно я небыл на этом форуме а подергивание поля сообщений все также неприятно


Знатокам VBA | База знаний | mista.ru

Знатокам VBA

maloy 01.06.2004 03:01 | Есть отчет, который читает данные из прайсов (файлы EXCEL) поставщиков и выводит сравнительную таблицу цен. При смене прайса или при закрытии отчета нужно, соответственно, закрыть эти файлы. Тут и загвоздка: если на компьютере установлен Office XP, то даже если вызываешь метод Close() с параметром "0", ExAp.Workbooks(Книга).Close(0); то всё равно появляется запрос о необходимости пересчитать формулы для файлов созданных в более ранних версиях. Можно это как-нибудь объехать? А то пользователям приходится нажимать пару-тройку лишних кнопок.
List 1 - 01.06.2004 05:40 | В VBA есть функция, которая отключает данную проблему, только давно этим не занимался. Зайди на сайт www.firststep.ru там где-то есть описание данных функций.
List 2 - 01.06.2004 05:52 | Прошу прощения за ошибку правильно будет так - http://www.firststeps.ru/
* 4 - 01.06.2004 09:03 | http://www.sinor.ru/~my1c/knowhow/tip2exel.html


Загрузка прайса в Ехселе в справочник | База знаний | mista.ru

Загрузка прайса в Ехселе в справочник

Ерж
26.05.2004 22:54 		Помогите загрузить Прайс.xls с 5000 наименованиями в справочник Номенклатура. Что за процедура и в каком модуле её располагают. Я только 3 месяца изучаю 1С, пытаюсь написать конфигу "Оперативный учет" для аптеки. Если можно подробнее объясните начинающему
It is me
1 - 26.05.2004 23:09 		Перем Excel, ТекСтрока, Разделитель, СпрМетаданные, спРеквизиты, Столбцов, Дубль, Справочник;

// ===============================
Процедура ПриОткрытии()
ДатаДок = НачМесяца(РабочаяДата())-1;

Для Инд = 1 По Метаданные.Справочник() Цикл
Если Метаданные.Справочник(Инд).Владелец.Выбран() = 0 Тогда
спСправочники.ДобавитьЗначение(Метаданные.Справочник(Инд).Идентификатор,Метаданные.Справочник(Инд).Синоним);
КонецЕсли;
КонецЦикла;
КонецПроцедуры

// ===========================
Функция ПроверкаЗаписьРеквизитов()
Для Стлб = 3 По Столбцов Цикл
Если ((Строка(Excel.Cells(1, Стлб).Value) = "Наименование") или (Строка(Excel.Cells(1, Стлб).Value) = "Код")) Тогда
// зарезервированные
Продолжить;
ИначеЕсли (СпрМетаданные.Реквизит(Строка(Excel.Cells(1, Стлб).Value)).Выбран() = 0) Тогда
// нет такого реквизита в справочнике
глКомментарий("Справочник не может быть загружен! В файле присутствуют реквизиты, которых нет в данном справочнике. Колонка "+Стлб+".", 0,,"!");
Возврат 0;
КонецЕсли;
КонецЦикла;

спРеквизиты = СоздатьОбъект("СписокЗначений");
Для Стлб = 3 По Столбцов Цикл
спРеквизиты.ДобавитьЗначение(СокрЛП(Строка(Excel.Cells(1, Стлб).Value)));
КонецЦикла;
Возврат 1;
КонецФункции

// ===============================
Процедура ОпределитьРодителя()
Справочник.ИспользоватьРодителя(0);
КодС = Сокрлп(Excel.Cells(ТекСтрока, 2).Value);
Если Дубль = 1 Тогда
Возврат;
КонецЕсли;

Поз = СтрДлина(КодС);
Пока Поз > 1 Цикл
Если Сред(КодС, Поз, 1) = Разделитель Тогда
КодРодителя = Лев(КодС, Поз-1);
Род = СоздатьОбъект("Справочник."+Справочник.Вид());
Если Род.НайтиПоРеквизиту("СтарыйПолныйКод", КодРодителя, 1) = 1 Тогда
Попытка
Справочник.ИспользоватьРодителя(Род.ТекущийЭлемент());
Исключение
глКомментарий("Родителем для записи должна быть запись, у которой установлен тип группа (Г)! Строка "+ТекСтрока,1,,"!");
КонецПопытки;
КонецЕсли;
Возврат;
КонецЕсли;
Поз = Поз -1;
КонецЦикла;
КонецПроцедуры

// ===========================
Функция Обработать(ВидЗаписи)
Справочник.ИспользоватьДату(ДатаДок);
ОпределитьРодителя();
Если Дубль = 1 Тогда
КодС = Строка(Excel.Cells(ТекСтрока, 2).Value);
Справочник.НайтиПоРеквизиту("СтарыйПолныйКод", КодС, 1);
ИначеЕсли ВидЗаписи = "Элемент" Тогда
Справочник.Новый();
Иначе
Справочник.НоваяГруппа();
КонецЕсли;

Справочник.СтарыйПолныйКод = Строка(Excel.Cells(ТекСтрока, 2).Value);

Для Инд = 1 По спРеквизиты.РазмерСписка() Цикл
Если Сокрлп(Excel.Cells(ТекСтрока, (Инд+2)).Value) = "" Тогда
// в ячейке ничего нет
Продолжить;
КонецЕсли;
Реквизит = спРеквизиты.ПолучитьЗначение(Инд);
Если Строка(Excel.Cells(1, (Инд+2)).Value) = "Наименование" Тогда
// заполним наименование
Справочник.УстановитьАтрибут(Реквизит,Строка(Excel.Cells(ТекСтрока, Инд+2).Value));
ИначеЕсли Строка(Excel.Cells(1, (Инд+2)).Value) = "Код" Тогда
// заполним код
Если (СпрМетаданные.Автонумерация = 0) и (Сокрлп(Excel.Cells(ТекСтрока, (Инд+2)).Value) = "") Тогда
глКомментарий("В строке "+ТекСтрока+" не указан код элемента справочника!", 0,,"!");
Возврат 0;
Иначе
Если СпрМетаданные.ТипКода = "Текстовый" Тогда
Справочник.Код = Строка(Excel.Cells(ТекСтрока, (Инд+2)).Value);
ИначеЕсли СпрМетаданные.ТипКода = "Числовой" Тогда
Справочник.Код = Число(Excel.Cells(ТекСтрока, (Инд+2)).Value);
КонецЕсли;
КонецЕсли;
Иначе
// произвольный реквизит
Если (СпрМетаданные.Реквизит(Реквизит).Использование = "ДляЭлемента") и (ВидЗаписи = "Группа")
или (СпрМетаданные.Реквизит(Реквизит).Использование = "ДляГруппы") и (ВидЗаписи = "Элемент") Тогда
Продолжить;
КонецЕсли;

// проверим тип реквизита
Если СпрМетаданные.Реквизит(Реквизит).Тип = "Строка" Тогда
Справочник.УстановитьАтрибут(Реквизит,Строка(Excel.Cells(ТекСтрока, Инд+2).Value));
ИначеЕсли СпрМетаданные.Реквизит(Реквизит).Тип = "Число" Тогда
Справочник.УстановитьАтрибут(Реквизит,Число(Excel.Cells(ТекСтрока, Инд+2).Value));
ИначеЕсли СпрМетаданные.Реквизит(Реквизит).Тип = "Дата" Тогда
Справочник.УстановитьАтрибут(Реквизит,Дата(Excel.Cells(ТекСтрока, Инд+2).Value));
ИначеЕсли СпрМетаданные.Реквизит(Реквизит).Тип = "Счет" Тогда
Сч = СчетПоКоду(Сокрлп(Excel.Cells(ТекСтрока, Инд+2).Value));
Если Сч.Выбран() =1 Тогда
Справочник.УстановитьАтрибут(Реквизит, Сч);
Иначе
глКомментарий("В строке "+ТекСтрока+" колонке "+(Инд+2)+" указан счет, которого нет в конфигурации",1,,"!");
КонецЕсли;
ИначеЕсли СпрМетаданные.Реквизит(Реквизит).Тип = "Перечисление" Тогда
//Если Метаданные.Перечисление(СпрМетаданные.Реквизит(Реквизит).Вид).Выбран() <> 0 Тогда
// // есть такое
Пере = Перечисление.ПолучитьАтрибут(СпрМетаданные.Реквизит(Реквизит).Вид);
Значение = Пере.ЗначениеПоИдентификатору(СокрЛП(Строка(Excel.Cells(ТекСтрока, (Инд+2)).Value)));
Если ПустоеЗначение(Значение) = 1 Тогда
глКомментарий("В строке "+ ТекСтрока + " колонке "+(Инд+2)+" указано значение перечисления, которого нет в конфигурации",1,,"!");
Иначе
Справочник.УстановитьАтрибут(Реквизит,Значение);
КонецЕсли;
//Иначе
// глКомментарий("В строке "+ ТекСтрока + " колонке "+(Инд+2)+" указано перечисление, которого нет в конфигурации",1,,"!");
//КонецЕсли;
ИначеЕсли СпрМетаданные.Реквизит(Реквизит).Тип = "Справочник" Тогда
ВидСправочника = СпрМетаданные.Реквизит(Реквизит).Вид;
Если ВидСправочника <> "" Тогда
//ПрефиксСп = СпрМетаданные.Реквизит(Строка(Excel.Cells(1, (Инд+2)).Value)).Вид;
Сп = СоздатьОбъект("Справочник."+ВидСправочника);
КодСп = Число(Excel.Cells(ТекСтрока, (Инд+2)).Value);
Если Метаданные.Справочник(ВидСправочника).ТипКода = "Текстовый" Тогда
КодСп = Строка(Excel.Cells(ТекСтрока, (Инд+2)).Value);
КонецЕсли;
Если Сп.НайтиПоКоду(КодСп) <> 0 Тогда
Справочник.УстановитьАтрибут(Реквизит, Сп.ТекущийЭлемент());
Иначе
глКомментарий("В строке "+ ТекСтрока+" колонке "+(Инд+2)+" ссылка на несуществующий элемент.", 1,,"!");
КонецЕсли;
Иначе
// должен быть указан и вид справочника, и код элемента через разделитель
Темпл = Строка(Excel.Cells(ТекСтрока, (Инд+2)).Value);
ВидСправочника = Лев(Темпл, (Найти(Темпл,Разделитель)-1));
Если Метаданные.Справочник(ВидСправочника).Выбран() <> 0 Тогда
Сп = СоздатьОбъект("Справочник."+ВидСправочника);
КодСп = Число(Прав(Темпл, (СтрДлина(Темпл)-Найти(Темпл,Разделитель))));
Если Метаданные.Справочник(ВидСправочника).ТипКода = "Текстовый" Тогда
КодСп = Строка(Прав(Темпл, (СтрДлина(Темпл)-Найти(Темпл,Разделитель))));
КонецЕсли;
Если Сп.НайтиПоКоду(КодСп) <> 0 Тогда
Справочник.УстановитьАтрибут(Реквизит, Сп.ТекущийЭлемент());
Иначе
глКомментарий("В строке "+ ТекСтрока+" колонке "+(Инд+2)+" ссылка на несуществующий элемент.", 1,,"!");
КонецЕсли;
Иначе
глКомментарий("В строке "+ ТекСтрока+" колонке "+(Инд+2)+" указан справочник, которого нет в конфигурации.", 1,,"!");
КонецЕсли;
КонецЕсли;
ИначеЕсли СпрМетаданные.Реквизит(Реквизит).Тип = "Документ" Тогда
ВидДокумента = СпрМетаданные.Реквизит(Строка(Excel.Cells(1, (Инд+2)).Value)).Вид;
Если ВидДокумента <> "" Тогда
// документ определенного вида
ПрефиксДо = СпрМетаданные.Реквизит(Строка(Excel.Cells(1, (Инд+2)).Value)).Вид;
Док = СоздатьОбъект("Документ."+ПрефиксДо);
Темпл = Строка(Excel.Cells(ТекСтрока, (Инд+2)).Value);
ДатаДо = Лев(Темпл, (Найти(Темпл,Разделитель)-1));
НомерДо = Прав(Темпл, (СтрДлина(Темпл)-Найти(Темпл,Разделитель)));
Если Док.НайтиПоНомеру(НомерДо, ДатаДо,) <> 0 Тогда
Справочник.УстановитьАтрибут(Реквизит, Док.ТекущийДокумент());
Иначе
глКомментарий("В строке "+ ТекСтрока+" колонке "+(Инд+2)+" ссылка на несуществующий документ.", 1,,"!");
КонецЕсли;
Иначе
// документ неопределенного виды, должен быть указан и вид
Темпл = Строка(Excel.Cells(ТекСтрока, (Инд+2)).Value);
ПрефиксДо = Лев(Темпл, (Найти(Темпл,Разделитель)-1));
Темпл = Сред(Темпл, (Найти(Темпл,Разделитель)+1));
ДатаДо = Дата(Лев(Темпл, (Найти(Темпл,Разделитель)-1)));
НомерДо = Прав(Темпл,(СтрДлина(Темпл)-Найти(Темпл,Разделитель)));
Если Метаданные.Документ(ПрефиксДо).Выбран() <> 0 Тогда
// есть такой вид документа
До = СоздатьОбъект("Документ."+ПрефиксДо);
Если До.НайтиПоНомеру(НомерДо, ДатаДо,) <> 0 Тогда
Справочник.УстановитьАтрибут(Реквизит, До.ТекущийДокумент());
Иначе
глКомментарий("В строке "+ ТекСтрока+" колонке "+(Инд+2)+" ссылка на несуществующий документ.", 1,,"!");
КонецЕсли;
Иначе
глКомментарий("В строке "+ ТекСтрока+" колонке "+(Инд+2)+" некорректно заполнено значение.", 1,,"!");
КонецЕсли;
КонецЕсли;
КонецЕсли;

КонецЕсли;
КонецЦикла;
Попытка
Справочник.Записать();
Исключение
глКомментарий("Строка "+ ТекСтрока+" не может быть корректно записана.
|Проверьте ее заполнение. Колонка "+(Инд+2), 1,"!");
КонецПопытки;
Возврат 1;
КонецФункции

// ===============================
Функция ОбработатьСтроку()
// обработка
Состояние("Обрабатывается строка " + ТекСтрока);

ТипПоля = Excel.Cells(ТекСтрока, 1).Value;
СтарыйКод = Строка(Excel.Cells(ТекСтрока, 2).Value);

Уровней = СтрЧислоВхождений(СтарыйКод, Разделитель);
Если ((Уровней + 1) > СпрМетаданные.КоличествоУровней) Тогда
глКомментарий("Количество уровней в заполняемом справочнике меньше,
|чем указано в "+ТекСтрока + " строке загружаемого файла.
|Увеличьте количество уровней в заполняемом справочнике.", 0,,"!");
Возврат 0;
КонецЕсли;

Спр = СоздатьОбъект("Справочник."+спСправочники.ПолучитьЗначение(спСправочники.ТекущаяСтрока()));
Дубль = Спр.НайтиПоРеквизиту("СтарыйПолныйКод", СтарыйКод, 1);
Если (Дубль = 1) и (Обновлять = 0) Тогда
// есть такой элемент, но обновлять не нужно
Возврат 1;
Иначе
Если ВРЕГ(Лев(Строка(ТипПоля), 1)) = "Г" Тогда
Возврат Обработать("Группа");
ИначеЕсли ВРЕГ(Лев(Строка(ТипПоля), 1)) = "Э" Тогда
Возврат Обработать("Элемент");
КонецЕсли;
КонецЕсли;
Возврат 1;
КонецФункции

// ===============================
Процедура Выполнить()
Если спСправочники.ТекущаяСтрока() = 0 Тогда
Предупреждение("Выберите справочник!");
Возврат;
КонецЕсли;

СпрМетаданные = Метаданные.Справочник(спСправочники.ПолучитьЗначение(спСправочники.ТекущаяСтрока()));
Справочник = СоздатьОбъект("Справочник."+спСправочники.ПолучитьЗначение(спСправочники.ТекущаяСтрока()));

Попытка
Excel = СоздатьОбъект("Excel.Application");
Исключение
глКомментарий("Похоже, Excel на компьютере не установлен. Необходимо выполнить установку/переустановку Excel.",0,,"!");
Возврат;
КонецПопытки;

Excel.Workbooks.Open(Сокрлп(ИмяФайла));
Книга = Excel.ActiveWorkbook;

Строк = Excel.Cells.CurrentRegion.Rows.Count;
Столбцов = Excel.Cells.CurrentRegion.Columns.Count;

// проверим наличие зарезервированных колонок
Если (Строка(Excel.Cells(1, 1).Value) <> "ТипПоля")
или (Строка(Excel.Cells(1, 2).Value) <> "СтарыйПолныйКод") Тогда
глКомментарий("Неверный формат файла! 1-я и 2-я колонки - зарезервированы.", 0,,"!");
Возврат;
КонецЕсли;
// проверим наличие реквизита СтарыйПолныйКод
Если СпрМетаданные.Реквизит("СтарыйПолныйКод").Выбран() = 0 Тогда
глКомментарий("Справочник не может быть загружен! У данного справочника должен присутствовать реквизит СтарыйПолныйКод.", 0,,"!");
Возврат;
КонецЕсли;
// проверим наличие "Сортировки" по этому реквизиту
Если СпрМетаданные.Реквизит("СтарыйПолныйКод").Сортировка = 0 Тогда
глКомментарий("Справочник не может быть загружен! У данного справочника у реквизита СтарыйПолныйКод должна быть отмечена 'Сортировка'.
|(Конфигуратор - конфигурация - свойства реквизита СтарыйПолныйКод - закладка 'Дополнительные').", 0,,"!");
Возврат;
КонецЕсли;

Если ПроверкаЗаписьРеквизитов() = 0 Тогда
Возврат;
КонецЕсли;

НачатьТранзакцию();
Для ТекСтрока = 1 По Строк Цикл
Если ОбработатьСтроку()= 0 Тогда
ОтменитьТранзакцию();
Возврат;
КонецЕсли;
КонецЦикла;
ЗафиксироватьТранзакцию();

Предупреждение("Справочник загружен!");

Excel.Workbooks.Close();
Excel = 0;
ОткрытьФорму("Справочник."+спСправочники.ПолучитьЗначение(спСправочники.ТекущаяСтрока()));
КонецПроцедуры

// ===============================
Процедура ВыбратьФайл()
сФайл = "";
сКатал = "";
Если ФС.ВыбратьФайл(0,сФайл,сКатал,"Выберите файл импорта","Таблицы Excel (*.xls)|*.xls") = 1 Тогда
ИмяФайла = сКатал+сФайл;
КонецЕсли;
КонецПроцедуры

Разделитель = ":";

//Первая строка в Эксель должна содержать наименования реквизитов справочника. Располагать процедуру можешь где захочешь, данный пример взят из встроенной обработки типовой конфигурации, работать прямо так не будет, нужны реквизиты формы, которые (вместе с обработкой) могу выслать только на мыло или поищи на 1c.hippo.ru
afk
2 - 26.05.2004 23:24 		Еще можно посмотреть в Торговле обработку ИмпортСправочников.


Импорт данных из Паруса | База знаний | mista.ru

Импорт данных из Паруса

ms.x 19.05.2004 08:58 | А можно ли импортировать справочник основные средства из программы Парус в 1С
Валентин 4 - 29.05.2004 21:27 | Эта проблема в моем случае решалась выгрузкой всего в XML и последующими XSLT-скриптами приводим к нужному виду в 1С. Хотя если есть желание поизвращаться - фоксу в руки и можно лить напрямую в 1с (юзая ОЛЕ (правда сам не пробовал, но теоретически должно получиться)) Вот только верно все это для Парус 7.хх ,для 4.хх и прочей гадости не пробовал. Вот только клиенты после такого перехода остались недовольны (в бюджетной части парус все же сильнее, да и зарплата получше будет)
BorisG 6 - 29.05.2004 23:43 | (4) Какой XML для 4.0? Там ручками... что в общем то и не сложно... Относительно того, кто сильнее... Не стал бы я так утверждать, что в бюджетной части Парус сильнее... Увы, но бюджетное решение у них даже на сайте не заявлено. То же касается и Зарплаты. Разве что некоторые отрасли, которые 1с не любит. ;( Да еще кадровый модуль... но с развитием УП ситуация должна поправиться и в этом вопросе. Это все касается семерки... про 4.х вообще молчу... она проигрывает 1С по всем статьям. Единственный, но существенный минус у одинэсников (не 1С) - это очень слабая подготовка спецов по бюджету... хотя в регионах и парусники не блещут.
Валентин 7 - 30.05.2004 23:43 | В принципе для 4.хх есть выгрузка в XML формате (в доп функциях лежит, нужна для коныертирования данных при апгрейде с 4.хх на 7.хх) Насчет сильнее или нет понимаю что вопрос спорный но внедрение зарплаты проще идет на Парусе (если нет извращений по типу нескольких источников финансирования на одну выплату зависящую от месяца (тут согласен красивого решения нет)). Насчет тогочто 4.хх проигрывает по всем статьям... В досовском варианте парус - не более чем 1С, толко вместо встроенного языка - foxpro. А реализация 107 инструкции получше чем в 1С (типовых конфигурациях, которые не менялись) Сам отработал на Парус более 2 лет и сказать что там все плохо - язык не поворачивается, тем более что от типовой ЗиК 1С были очень неприятные ощущения Насчет плохого знания бюджета в региональных подразделениях Паруса - очень смелое, но по моему не верное заявление.
BorisG 8 - 31.05.2004 00:35 | (7) Видишь ли... я как раз с бюджетом работаю не 2 года, а поболее ;-)) так что есть с чем сравнивать. Как раз ЗиК Парусу и не проигрывает... и именно в отношении ИФ. Слабое место ЗиК 1С это педагоги и ЦБ, но... есть партнерские решения... и как раз в этих областях я и съел собаку. Относительно реализации 107н в конфигурациях 1С... видно давно смотрел. ;-)) Сейчас 1С практически по всем статьям по функционалу у 4.х Паруса и выигрывает... Впрочем... это обсуждение не выглядит конструктивным... способ у кого длиннее не самый лучший ;-) Во всяком случае Парус практически без сопротивления сдал перед новым годом крупного клиента. А вот последнюю цитату передернул... "не блещут" и "плохо знают" согласись, вещи разные...


Перенос справочников | База знаний | mista.ru

Перенос справочников

Alexandr_byr 28.05.2004 14:34 | Привет всем! Проблемка вот в чем сделал обработки для переноса номенклатуры из одной базы в другую. Экспортирует только карточки товара без групп (Так задумано). Самое интересное начинается при импорте то, что медленно это ладно, а вот как создавать карточки товара в выбранной группе, т.е. КАК указать родителя для создаваемых элементов?
SnarkHunter 1 - 28.05.2004 14:36 | Атрибут Родитель...
lexa 2 - 28.05.2004 14:39 | если конфы одинаковые, обычно в сервисе в доп возможносятчх есть выгрузка
Alexandr_byr 3 - 28.05.2004 15:09 | конфигурации разные причем принимающая написана под заказ. Как именно указать атрибут Родитель
lexa 6 - 28.05.2004 15:51 | Номенкл.Родитель
Alexandr_byr 7 - 28.05.2004 15:55 | Возможен ли многоуровневый перенос справочников и как это можно реализовать
lexa 8 - 28.05.2004 15:56 | На диске ИТС есть Конвертация данных через XML
Alexandr_byr 9 - 28.05.2004 16:02 | я уже через dbf завернул как на один уровень подчинения сделать я знаю а вот как на 2 и более уровней
SiMazx 10 - 28.05.2004 16:04 | В данные переноса включи поле КодРодителя... Если элемент корня, значит поле будет пустым...
SiMazx 11 - 28.05.2004 16:05 | Для элемента любого уровня вложенности в нем будет код группы в которую он входит...
Alexandr_byr 12 - 28.05.2004 16:11 | а как когда на подчиненом уровне помимо карточек есть ещё и группы и как выхватить код родителя в товара
lexa 13 - 28.05.2004 16:14 | попробуй ПолныйКод
Press 14 - 28.05.2004 16:18 | Попробуй Universam.ert
lexa 15 - 28.05.2004 16:22 | http://1c.hippo.ru/un77.html
Alexandr_byr 17 - 28.05.2004 16:38 | Я бы забил но заказ есть заказ. А на счет универсальных обработок я уже даже побовать не хочу это не панацея всёравно прийдется под конкретную конфигурацию подгонять
lexa 19 - 28.05.2004 16:41 | Тогда добавь поле Номенкл.Родитель.Код при выгрузке отсортируй по нему, а при загрузке ИспользоватьРодителя(Номенкл.НайтиПоКоду(Номенкл.Родитель.Код )
ChAlex 21 - 29.05.2004 10:29 | Лучше добавить поле Номенкл.Родитель.ПолныйКод() и отсортировать по нему. Родитель.НайтиПоКоду(<Поле>,2); Номенкл.ИспользоватьРодителя(Родитель); Номенкл.Новый() и далее... Вообщем то проблемы только с синхронизацией кодов!
mike 22 - 29.05.2004 11:34 | 1 вариант : сортировать родителей надо по уровню, прапра, пра-, дедушки , отцы , дети и т д 2 вариант : в первом цикле грузишь всех без привязки, во втором цикле ищешь родителя и привязываешь его к элементу. Хорошо если коды уникальны во всем справочнике.


Access -> 1C ... готовые решения? | База знаний | mista.ru

Access -> 1C ... готовые решения?

Crystalizer 28.05.2004 16:37 | есть база на эксессе + программа. я вот думаю, если представится необходимость загнать её в 1С... как это нормально сделать? Там база товаров с категорями. Категории не вложенные (1 уровень). Поля обычные типа имя, количество, цена, ед.измерения... Есть ли какие готовые решения для этого?
lexa 1 - 28.05.2004 16:44 | если с OLE и 1С не знаком то проще через ODBC, или http://www.sinor.ru/%7Emy1c/knowhow.html#ACCESS http://www.mista.ru/articles1c/ole.htm
mike 8 - 29.05.2004 11:16 | я делал такую цепочку Access->Excel->текстовый файл с разделителями . А дальше для меня было дело техники . Может не совсем красиво, но быстро.


Помогите! Расстояние между магазинами 7км ,а работать в 1с надо | База знаний | mista.ru

Помогите! Расстояние между магазинами 7км ,а работать в 1с надо

Appon 26.05.2004 13:24 | Ситуация такова. Между сервером и клиентом 7 км.Возможно ли их подключить между собой и желательно через dualup.Если да объясните по подробнее
lexa 1 - 26.05.2004 13:29 | http://www.mista.ru/articles1c/urbd.htm
gr13 3 - 26.05.2004 14:02 | http://www.forum.mista.ru/topic.php?id=3950 http://www.forum.mista.ru/topic.php?id=2115
lexa 4 - 26.05.2004 14:09 | ну еще http://www.mista.ru/articles1c/terminal.htm, если диалап, то лучше УРБД, иначе запаришься базу индексировать при разрыве соединения. С урбд несложно разобраться за день (случ чего помогу), а сервер терминалов настраивать непросто и безопасность соединения обеспечивать тяжело, придется спецов искать. опять же телефон постоянно занят и в случае отсутствия связи у тебя все будет работать ( в крайнем случае через дискеты), автообмен настроил и живи спокойно, и всегда есть достаточно свежий архив (2 ИБ синхронизируются между собой) с точностью до последнего обмена, минусов правда тоже хватает
miha_root 5 - 27.05.2004 22:10 | для модема предпочтительней citrix - как более экономичный по трафику. нормальным админом такое поднимается с "нуля" за день, максимум за два. впрочем, УРБД тоже работает и с точки зрения денег (лицензии) более экономичное решение.


Организация учета | База знаний | mista.ru

Организация учета

ФАКОэмульсификатор 27.05.2004 12:42 | Есть предприятие, у которого 3 офиса и десяток АЗС. В офисах стоит 1С 7.7 на базе распределенной базы. На каждой АЗС есть магазин, где продают сопутствующие товары. В одном магазине уже используется 1С (та же распределенка, что и в офисах). Стал вопрос продолжать автоматизацию АЗС, но получается развитие существующей схемы приводит к тому, что на заправки попадает вся бухия предприятия!!! Можно настроить правила миграции, но все равно на заправки попадает лишння инфа, например, кассовые ордера других АЗС. Есть идея создать отдельную распределенку только для АЗС, но выплывают проблемы синхронизации с основной бухией. Как быть?
v-soft 1 - 27.05.2004 12:50 | Написать свою обработку по переносу данных и никаких проблем.
alegrig 2 - 27.05.2004 13:47 | На этом сайте лежит учебник по распределенке, там указывается, что базы миграции можно перечислять через запятую, сам не пробовал, почитай, попробуй.
lexa 4 - 27.05.2004 14:00 | стандартного решения нет можно попробовать МОД, но мне франч сказал, что 1С его не любит и вроде бы в 21 релизе сделано все чтобы мод не работал. Можно конечно добавить справочник ИБ, где будет привязка к конкретному подразделению. А потом чистить таблицу изменений. Как вариант: добавь в справочник пользователей и документы реквизит "подразделения" и создай свой журнал документов с отбором по этому реквизиту. Запрети создавать документы для других подразделений.
shura 6 - 27.05.2004 14:30 | (4) Небыло еще не одной проблемы с МОД ни на 20, ни на 21 релизе. Штука хорошая.
Valery 7 - 27.05.2004 14:49 | Если у всех одна конфигурация,то проще иметь свою процедуру переноса документов. одна процедура на все филиалы. А если использовать XML то и писать ничего не надо. только настройка выгрузки, при одинаковых конфигурациях это займет ну пару часов


Обработка ERT 1С, Exel и команда OpenText. | База знаний | mista.ru

Обработка ERT 1С, Exel и команда OpenText.

Елена 27.05.2004 11:13 | Из обработки ERT 1С требуется программно с помощью Exel открыть текстовый файл с разделителями. Так, чтобы само окно Exel на экране не показывалось. Пытаюсь открыть командой OpenText(ИмяФайла). Проблема: файл окрывается, но на столбцы не делится. Как указать, какой символ является разделителем столбцов в данном файле?
Елена 2 - 27.05.2004 11:34 | Присылают кучу разных текстовых файлов из разных программ (расходные накладные). Есть текстовый файлы с разделителями-табуляцией, с разделителями-запятыми, и т.д. Форматы файлов разные, общее - то, что записи в этих файлах идут построчно. Требуется всю эту разношерстицу загрузить в 1С. Поскольку вручную все эти файлы в Exel открываются, то мысль-и воспользоваться этим. Если есть другие варианты с такими текстовыми файлами - подскажите, плиз.
427 3 - 27.05.2004 11:43 | Алт-Ф11 в эекселе... И читай... А также использование автонаписания программ ... то бишь макросов ... помогает
Евгений 4 - 27.05.2004 12:07 | (3) все и сказал. Запускаешь в Excel'е макрорекодер и открываешь свой файл с разделителями используя Excel'овский мастер. По результатам работы макрорекодер составит тебе строку с указанием всех необходимых параметров. Ее и подставляешь в свою обработку. Это по вопросу. Но я бы так делать не рекомендовал. Если тебе присылают текстовые файлы, то лучше их читать средствами 1С. Будет раза в 4 быстрее (проверено практикой). Я даже то, что мне сейчас поставщики присылают в формате XLS, перевожу (при помощи Excel'я) в текст и гружу средствами 1С.
Елена 5 - 27.05.2004 12:21 | Евгений, если пользоваться средствами 1С (ИзСтрокиСРазделителями и ВСтрокуСРазделителями), работает только с разделителями-запятыми. А как быть с другими символами? Или речь идет о других средствах?
Евгений 6 - 27.05.2004 13:06 | Написана функция - аналог ИзСтрокиСРазделителями. На входе - исходная строка и разделитель. Функция в строке ищет разделитель, загоняет все, что слева от него, в новый элемент массива значений, отрезает от строки все, что найдено слева и разделитель. Снова ищет разделитель... Цикл продолжается до тех пор, пока в строке не кончатся разделители. В результате на выходе имеем массив значений из колонок строки. Примерно так.


Подстановка данных из справочника при импорте | База знаний | mista.ru

Подстановка данных из справочника при импорте

Игорь 26.05.2004 17:43 | 1. 1с версия 7.70.021 конфигурация 7.70.135 2. При импорте данных из клиента данных происходит следующее: загружается ИНН. по ИНН находится организация. Эти данные загружаются в банковскую выписку. Хотелось бы чтобы программа подставляла для данной организации тип договора. (те для справочник.контрагенты нужно плучить соответсвующий ему справочник.договор и подставить в суконто2).
lexa 1 - 26.05.2004 17:51 | 135 - это наверное УСН посмотри обработку загрузки и проверь наличие договоров у контрагентов кстати, а если у контрагента несколько договоров? у тебя наверное последняя версия telepat.dll есть (шутка)
Игорь 3 - 26.05.2004 18:28 | Спасибо. Я нашел где она заполняется, но там есть некая процедура выглядящая следующим образом : глЗаполнитьСтрокуВыпискиПоПлатежномуДокументу(Объект, Документ, Приход + Расход) Как я понимаю, ее изменить нельзя, значит после того как она выполнилась перед сохранением документа и нужно подставлять соответсвующие данные?.
lexa 4 - 26.05.2004 18:30 | смотри глобальный модуль


перекодировка из DOS -> UTF-8 | База знаний | mista.ru

перекодировка из DOS -> UTF-8

lift 26.05.2004 17:50 | Как перекодировать текстовые поля файла DBF(DOS)в UTF-8 при импорте в 1С 8.0
Волшебник 1 - 26.05.2004 18:05 | У объекта XBase есть свойство Кодировка, которое принимает значения: ANSI (Windows) и OEM (DOS).


Как создать обработку по выгрузке данных из Exel в 1С 7.7 | База знаний | mista.ru

Как создать обработку по выгрузке данных из Exel в 1С 7.7

stalker_kz 25.05.2004 06:53 | Может кто подскажет или сталкивался с учебниками в инете по создании обрабодки подргузки данных из Exel в 1С. Знаю что это возможно, но нигде не могу найти хоть одно подробное описаниее или руководство как создавать такие обработки. Если кто сталкивался скиньте ссылку. Заранее благодарен.
romix 2 - 25.05.2004 14:47 | //******************************************* Процедура Сформировать() xl=СоздатьОбъект("Excel.Application"); row=1; //номер строки col=1; //номер колонки для row=1 по 1000 цикл Значение=""+xl.Cells(row,col).Value; Сообщить("Значение="+Значение); Если Значение="" Тогда Прервать; КонецЕсли; конеццикла; КонецПроцедуры Обратная выгрузка в Excel возможна похожим способом xl.Cells(row,col).Value="Привет!" Управление цветом, рамками и прочее - рекомендую сохранять Таблицу (функция Сохранить(ИмяТаблицы,"XLS"), или ищи в Яндексе по ключевым словам (Cells, Value, КонецПроцедуры....), или попробуй поюзать Запись Макроса в Excel. Он дает код на языке Бейсик, который примерно соответствует коду 1С (за некоторыми отличиями).
lexa 3 - 25.05.2004 15:01 | лучше Значение=""+xl.Cells(row,col).Text; если в ячейке ошибка (например деление на 0) - висяк обеспечен
stalker_kz 5 - 26.05.2004 06:18 | Спасибо... вашим примерам, по ключевым словам из примеров удалось найти учебники в сети по данному вопросу.


Чем лучше всего переносить данные в разных конф. 1С? | База знаний | mista.ru

Чем лучше всего переносить данные в разных конф. 1С?

TT 22.05.2004 18:35 | Подскажите, чем лучше всего переносить данные и справочники если конфигурации разные?
Asmody 1 - 22.05.2004 18:38 | Конвертация данных
TT 3 - 22.05.2004 18:42 | Из 1С Предприятия 7.7 Бухгалтерский учет Форт-2000 в 1С Предприятие 7.7 Торговля+Склад+Бухгалтерия+Кадры+Зарплата!
Asmody 9 - 22.05.2004 18:53 | еще на hippo в поиске введи "перенос данных" и радуйся
Asmody 14 - 22.05.2004 18:57 | (10) есть такая конфигурация у 1С "Конвертация данных" на ИТС лежит. С ее помощью реализован перенос данных в типовых. Это первый вариант. На хиппо вагон обработк для переноса данных. Сдается мне каждый второй 1сник это дело пишет... Можно выбрать что тебе больше подходит и пользоваться.
Влад 28 - 24.05.2004 04:33 | Если конфиги разные, то я, например, выгружаю документы в ТаблицуЗначений (само собой в ТЗ содержаться все реквизиты, которые нужны, в базовых типах данных), затем СохранитьВФайл(), в другой конфе: ЗагрузитьИзФайла(), получаем наглядную табличку и потом, циклом по строкам создаем новые документы и элементы справочников (если они отсутствуют). Правда есть один недостаток - элементы справочников создаются на первом уровне. Для того чтобы этого избежать лучше предварительно перенсти справочники, соблюдая иерархию элементов (если делать это во время создания документов, то обработка может работать очень долго). Вот и все.
427 29 - 24.05.2004 07:18 | (28) Идеологически все верно... Есть только несколько проблем - как определить, что элемент справочника переносить не нужно, что в целевой конфе есть такой элемент, но с другим кодом/наименованием (проблема синхронизации).... А если реквизит в элементе справочника ссылается на другой справочник, а тот ссылается еще дальше.... перенос периодики? Как определить, что уже есть такой документ.... но проклятые юзеры в нем просто номер поменяли.... Как автоматом делать изменения в данных, если документы в разных конфах имеют разную структуру... P.S. через ТЗ неудобно... Лучше делать через текстовый файл где строки - сохраненные списки списков значений .... P.S. Отвечать не надо... - у меня такая обработка работает... такая... полуавтоматическая ... Это я так, к проблемам ....
Влад 30 - 24.05.2004 08:12 | я совсем не претендую на универсальность этого варианта переноса, а наоборот, даже настаиваю на том, что что-то нужно подделывать в каждом конкретном случае, подкаждую ситуацию, я не сторонник универсальных обработок. а вот на счет того, что через ТЗ неудобно - полностью не согласен - каждое значение в своей строке и графе, добраться до него - раз плюнуть, - быстро и удобно.
wind_wail 32 - 24.05.2004 17:59 | (28) Здорово. Только есть пара вопросов. 1. Как быть с периодическими реквизитами? можно программно забить их историю? 2. Можешь прислать пример такой конфигурации, или сказать ссылочку где можно подобные примерчики надыбать? Заранее спасибо.
Влад 33 - 25.05.2004 05:22 | 1.программно историю забить конечно же можно (методы Получить() Установить()) 2.в качестве примера могу выслать свою обработку по переносу документов (уже выслал)


Финансовое планирование | База знаний | mista.ru

Финансовое планирование

alkv 23.05.2004 12:08 | Помогите разобраться с операндом "не равно". Выгружаю данныеиз Торговли по Регистру "Касса". Если в "Отборе итогов" ставлю операнд "не равно", то не выгружается "ни одного значения". Пример: Есть три кассы: Касса1, Касса2 и Касса3. По всем есть движения. Нужно выбрать в Фин.план. движения по всем, кроме Кассы1. Если пишу: Измерение "Касса" равно Касса2 Измерение "Касса" равно Касса3 то выборка идет, а если пишу: Измерение "Касса" не равно Касса1 то не выгружает ни одного значения Почему так происходит, может кто знает. С уважением ALKV.
alkv 4 - 23.05.2004 16:36 | Я не знаю итоги или движения, но дело в принципе: если операнд "Равно", то обороты(или показатели - результат одинаковый) при выгрузке имеют значения отличные от нуля, а если "Не равно", то при выгрузке говорит, что нет ни одного значения.
SnarkHunter 6 - 23.05.2004 22:33 | Дождался я таки этой фразы... Поверь, умение решить проблему и умение быть телепатом - вещи несколько разные... Доктор тебя по телефону обследовать не будет, не так ли? По идее такой ситуации не должно быть... Смотри в отладчике какой запрос транслируется на основании заданных тобой условий в первом и во втором случае... В частности, условия запроса пишутся в процедуре ТекстУсловийФильтра() в обработке ФП_ВыгрузкаДанных...


Справочник контрагенты | База знаний | mista.ru

Справочник контрагенты

Evgen® 19.05.2004 06:16 | Помогите советом. После автообмена в спраочнике контрагенты из групп вылетели все контрагенты в корневик .... а всего их порядка 10.000 Подскажите как их вернуть на свои места ? (В архивной копии все нормально, все стоят в своих группах) Можно ли экспортировать из архивной копии конкретный документ, если можно, то обьесните как? П.С: Заранее благодарен!
Волшебник 1 - 19.05.2004 08:44 | При обмене нужно было заполнять поле Родитель.
Evgen® 2 - 19.05.2004 10:10 | Обмен с переферийной базой. Всегда все проходило нормально, а в тот раз слетело! В резервных копия за период "до" все нормально все сидут в своих группах, за период после все контрагенты в корневике. Соотетсвенно отчеты по группам не проходят!!! Операторы негодуют, а мне что сказать ??? Сбой в программе обращайтесь к разработчикам ?? :)) Подскажите как старый справочник вернуть ?


Вопрос по УРИБ | База знаний | mista.ru

Вопрос по УРИБ

Tani
17.05.2004 13:41 		Такая ситуация: на перифирии кассир вводит документы задним числом. Дата запрета редактирования документов в центральной базе поставлена, но кассир меняеет ее.
Как можно запретить ввод и изменение документов задним числом или на определенную дату?
SnarkHunter
1 - 17.05.2004 14:13 		Убрать права у кассира на изменение константы...
Tani
2 - 17.05.2004 14:51 		А если изначально не было пользователей, как их (пользователей) туда выгрузить?
lexa
3 - 17.05.2004 17:35 		Создай: В конфигураторе - "Администрирование"-"Пользователи"
Tani
4 - 18.05.2004 08:05 		Как можно проверить в какой базе(центральной или на периферии) открыт документ?
SnarkHunter
5 - 18.05.2004 08:07 		Открыт или создан? Или изменен?
SnarkHunter
6 - 18.05.2004 08:17 		...или тебе все равно?
Tani
7 - 18.05.2004 08:18 		интерисуют состояния "открыт" и "изменен", хотя скорее всего просто определить в какой базе я сейчас нахожусь периферийной или центральной
SnarkHunter
8 - 18.05.2004 08:21 		ТекущаяИБКод()
Tani
9 - 18.05.2004 08:25 		Убрать права на изменение констаны я не могу, т.к. девушка которая работает в периферийной базе неного знает администрирование 1С и как поменять права она найдет. Вот хочу программно запретить редактирование константы
GuineaPig
10 - 18.05.2004 12:00 		(9)
Если ((НазваниеНабораПрав()<>"Кассир")) Тогда
Если (ТекущаяИБКод()<>ИБСозданияОбъекта(Конт.ТекущийДокумент()))И((НазваниеНабораПрав()<>"Бухгалтерия"))Тогда
Вопрос("Нельзя изменять документ,созданный на другой площадке.");
Сообщить("Объект создан в "+ИБСозданияОбъекта(Конт.ТекущийДокумент()));
Возврат 0;
КонецЕсли;
КонецЕсли;


Импорт справочников из Excel | База знаний | mista.ru

Импорт справочников из Excel

jetcom
11.05.2004 23:03 		Как импортировать из Excel вмесе с Наименованием элемента Номенклатуры соответствующий ему Штрих-код? Есть какие-нибудь наработки?
Влад
1 - 12.05.2004 04:44 		Процедура Сформировать()
СпрНоменклатура=СоздатьОбъект("Справочник.Номенклатура");
ExcelApp=СоздатьОбъект("Excel.Application");
Книга=ExcelApp.Workbooks.Open(СокрЛП(XLSфайл));
Лист=Книга.Sheets(1);
Для ш=1 по ПоследняяСтрока Цикл//последняя строка задается в диалоге
Попытка
КонтрольноеЗначение=СокрЛП(Лист.Cells(ш,3).Value);
Если ПустоеЗначение(КонтрольноеЗначение)=0 Тогда
СпрНоменклатура.Новый();
СпрНоменклатура.Название=Лист.Cells(ш,2).Value;
СпрНоменклатура.ЦенаПродажи=КонтрольноеЗначение;
СпрНоменклатура.ЦенаПокупки=Лист.Cells(ш,4).Value;
СпрНоменклатура.Записать();
КонецЕсли;
Состояние(""+ш+" записано");
Исключение
Сообщить("Ошибка в строке "+ш);
КонецПопытки;
КонецЦикла;
ExcelApp.Workbooks.Close();
ExcelApp.Quit();
КонецПроцедуры

//примерно так, я думаю
Frol
3 - 12.05.2004 12:03 		А Штрих-код как..., тоже через value, чтоли?
jetcom
4 - 12.05.2004 13:20 		И непонятненько, кстати, как будет осуществляться проверка его (штрих-кода) на уникальность???
jetcom
5 - 12.05.2004 20:38 		Подсказали люди добрые воспользоваться стандартной transref.ert
Мож кто намылит? Оч буду благодарен!!!
Frol
6 - 13.05.2004 14:20 		Она на всех ИТС-ах имеется, если сильно нада...
Ну , если не на всех, тон на последних 3-х точно.
jetcom
9 - 15.05.2004 14:44 		(8)Спасибо! RefImport.ert - Это то, что нужно! Только импортирует все, кроме штрих-кода... Или я неправильно выставляю настройки... Может кто работал с ней?
Подскажите, плиииз!!!


Новая база с заполненным справочником товаров | База знаний | mista.ru

Новая база с заполненным справочником товаров

staer 14.05.2004 14:10 | Есть база.Нужно создать новую чистую базу, но включить в нее заполненый справочник товаров. Как ее сделать???
ally 1 - 14.05.2004 14:15 | обработкой переноса
iceTiger 3 - 14.05.2004 14:23 | Копируешь МДшник в новый каталог, Конфигуратором создаешь базу, ищешь в файле 1cv77.DD название и файл *.dbf нужного справочника, и копируешь его в новую базу. И все дела.. !)
Gavrila 4 - 14.05.2004 14:25 | +(3) а заодно и всех подчиненных, и используемых справочников: единицы, цены и т.д.
Bzzzzz 5 - 14.05.2004 14:26 | (3) А еще подчиненные справочники, справочники, элементы которых являются реквизитами первого ...
lexa 7 - 14.05.2004 14:27 | ага и не забудь про единицы измерения, ГТД, страны лучше уж стандартной обработкой выгрузки из конфы в конфу ("серви"-"Доплнительные возможности"), а потом универсальеой загрузкой данных (там же), можно и цены подтянуть
iceTiger 8 - 14.05.2004 14:36 | Такие обработки тянут все что как-то связанно с ТМЦ (партии и др. мусор)... (7) :) человеку вроде как хотелось новую базу?
Bzzzzz 9 - 14.05.2004 14:44 | (8) Там можно выбрать что тянуть,а что нет
staer 12 - 14.05.2004 15:09 | Что значит (3) "Конфигуратором создаешь базу?"
Valery 13 - 14.05.2004 15:17 | Я делаю так: Копирую базу, Удаляю все dbf кроме Sc*- это справочника 1Cv7*.dbf это системные в системных нужно удалить только 1cv7jornal.dbf журнал документов. затем запускаешь тестирование и исправление. Это лучше чем (3) Т.к. остаются все связки между подчиненными базами. в (3) их не будет.
lexa 14 - 14.05.2004 15:22 | Если есть дистрибутив конфы запусти его еще раз только укажи другую папку
iceTiger 15 - 14.05.2004 15:23 | Пустой каталог, где лежит МД, добавляешь в список баз при запуске 1С, заходишь в режиме конф., открываешь дерево конфигурации, делаешь какие-нибуть изменения, что бы заставить конфигуратор сохраняться (например поставить пробел в названии конфигурации). После сохранения у тебя в новой папке полная структура .DBF
iceTiger 16 - 14.05.2004 15:27 | +(15) Ну и всех остальных файлов. А при открытии предприятия, в крутых конфиг. есть обработка первого запуска, которая заполнит спр. по умолчанию (налоги, е.и., баз ТМЦ...)
iceTiger 17 - 14.05.2004 15:39 | http://www.mista.ru/download1c/copy_spr.zip
staer 18 - 14.05.2004 18:30 | Начал Делать по способу (13), 3 часа уже тестируется и проверяется, есть и приятный момент, Почитал книгу, попил чай , сыграл 3 партии в тенис, опять почитал книгу, выпил чай....
Gavrila 19 - 14.05.2004 20:19 | (15) лучше в этом же каталоге оставить и ДД, тогда просто запускаешь базу в монопольном режиме и радуешься жизни :)) и результат тот же, но проще :))
Gavrila 20 - 14.05.2004 20:20 | (18) а размер базы, спр. ТМЦ не уточнишь ?, если база большая, то .... чая напьешся на 10 лет вперед :))
427 21 - 14.05.2004 21:38 | Долго наблюдаю.... Фигней народ мается.... Новая база делается за 10 минут... С полными справочниками от старой....
It is me 22 - 14.05.2004 23:51 | Два самых актуальных вопроса: как то, что делается за 10 минут, сделать за 5 и как то, что не делается вообще, сделать хоть как нибудь...
staer 23 - 15.05.2004 12:53 | Все бросил и сделал как советовал iceTiger. Таки да сделал, ну не за 10, за 20 минут. У меня оказывается в глобальном модуле идет проверка на вход в 1С.Сравнение входящего со справочником сотрудники.Поэтому пришлось скопировать еще и спр.Сотрудники.Не хотелось портить код. Зато при удалении папки userdef в предприятие не зайдешь, правдв в конфигуратор зайдешь.


Использование УРБД | База знаний | mista.ru

Использование УРБД

Serg_bl 06.05.2004 11:26 | ТиС9.2 + УРБД. Есть центральная база со складом А и торговая точка (ТТ)со складом Б. Чтобы в торговой точке видели только свой товар, он перемещается с помощью доков "ПеремещениеТМЦ" (для этого миграция стоит "Все инф.базы"). Проблема 1)в ТТ попадают в том числе и не их доки перемещения, 2)Док "ПеремещениеТМЦ" списывает товар со склада А, а в ТТ на этом складе ничего нет. Кто-нибудь подобные проблемы решал???
lexa 2 - 14.05.2004 11:40 | Я в похожем случае сделал так: Склад А оставил сам посебе, а для ТТ сделал отдельную ИБ, т.е. из ИБ А выгружаю доки и справочники в ЦБ ТТ, а измениния посредством УРБД автоматически попадают в ПБ ТТ, потом из ЦБ ТТ выгружаю доки в ИБ А. Геморрой конечно, но желание заказчика. чтобы в ТТ была инфа только по ней. К сожалению УРБД не позволяет штатными средствами отфильтовывать изменения. Скорей всего тебе нужен МОД.


УРБД, Запуск в пакетном режиме | База знаний | mista.ru

УРБД, Запуск в пакетном режиме

lexa 06.05.2004 11:44 | WinMe запускается bat-файл: @echo off cd "C:\Program Files\1Cv77\BIN\" start /min 1cv7.exe CONFIG /DD:\1C\db /NAutoExchange /Ppasw /@c:\1C\CMD\Autoexchange.txt Autoexchange.txt: [General] Output=d:\1C\CMD\Log.txt Quit=Y AutoExchange=Y [AutoExchange] SharedMode=Y ReadFrom=* WriteTo=* В настройках автообмена путь к файлам загрузки и выгрузки - a:\CMD При большом файле загрузке конфигуратор зависает Если запускать вручную конфигуратор под тем же пользователем и выполнить автообмен то все выполняется влет
lexa 1 - 12.05.2004 11:03 | Проблема была в Output=d:\1C\CMD\Log.txt - криво был прописан путь (русские буквы вместо латинских), но на это конфигуратор не ругался, а тормозил
SnarkHunter 2 - 12.05.2004 11:05 | Тормозил не конфигуратор, а тот, кто писАл... Конфигуратор же честно пытался найти указанный путь...


про .dbf | База знаний | mista.ru

про .dbf

jul 07.05.2004 12:46 | Ситуация такая: Необходимо открыть dbf-файлы в 1С в виде справочника(например). Информация хранилась в Access97. А сейчас есть желание перейти на 1С, но вот набирать информацию за последние 2 года скорее всего не реально (наименования товаров, серийные номера). Возможно ли это. Подскажите. И если да, то как. Напрямую явно не получается. Возникает проблема с кодировкой и записи блокируются.
Press 3 - 07.05.2004 13:05 | Надо написать в 1С обработку которая открывает dbf файл пробегает по записям и заполняет реквизиты справочника.
Ivanmih 4 - 07.05.2004 18:44 | Идея такова: из Access выгружаешь в Excel. Или из ДБФ загружаешь через объект XBase
Сергей 5 - 11.05.2004 14:35 | Создай OLE-объект Access в 1с, и пользуясь всеми методами Access делай с базой что хочешь, только помни о совместимости типов данных. Примеры кода 1С поищи в инете "Access, 1С".
GrayT 6 - 11.05.2004 14:44 | Если надо просто перенести данные, то не проще ли экспортить прямо из акцесса в дбф а дальше (3)


В 1С есть механизм выгрузки в формат 3.0, а механизм загрузки... | База знаний | mista.ru

В 1С есть механизм выгрузки в формат 3.0, а механизм загрузки...

RuslanF 06.05.2004 10:55 | В 1С есть механизм выгрузки в формат 3.0, а механизм загрузки отсутствует. Конечно, он есть в налоговой инспекции. А можно ли его получить не выклянчивая у знакомого инспектора? Может у кого есть?
427 3 - 06.05.2004 11:32 | Сколько раз повторять - нет механизма загрузки.... Есть механизм ВГРУЗКИ.... он поставляется фирмой ... Но только особям, особо близким к телу.... P.S. у меня его нет .... механизма то бишь.... а не тела ....
RuslanF 4 - 06.05.2004 11:48 | Поясняю: в Регламентированных отчетах есть функция выгрузки отчетов (деклараций)для налоговой инспекции в формате 3.0. Как сказал товарыч 427, есть механизм ВГРУЗКИ, вот он мне и нужен.
HanProg 7 - 06.05.2004 16:41 | Выгрузку, загрузку документов при желание можно сделать самому, там нет ничего страшного только надо учитывать что этот механизм может за собой по ссылкам пол базы утащить ;-)


Конвертация из формата отчетности (версия 3.0) в формат Excel | База знаний | mista.ru

Конвертация из формата отчетности (версия 3.0) в формат Excel

RuslanF 05.05.2004 15:49 | Есть необходимость конвертации файла с отчетами формата версии 3.0 в формат Excel. Если кто знает как, подскажите, пожалуйста.
kvm 1 - 05.05.2004 22:09 | Тебе надо из тектового формата (3.0) в Ексел? А форму можно просто сохранить и открыть.


Как настоить обмен данными 1С Предприятие 7.7 - Клиент-банк Сбербанк ? | База знаний | mista.ru

Как настоить обмен данными 1С Предприятие 7.7 - Клиент-банк Сбербанк ?

BorisG 1 - 05.05.2004 13:11 | Если версия под Windows, инструкцию к программе. Если под DOS, тоже... только в этом случае загрузку ручками сам...
ally 2 - 05.05.2004 13:13 | Не надо ручками. На хипо есть обработка хорошая, я недавно ее под себя переделывала для дос-клиент банка-Сбербанка
rick 5 - 05.05.2004 13:22 | инструкция к клиент-банку (та которая есть у меня) не содержит информации о настройках
kvm 7 - 05.05.2004 22:04 | Позвони в Сбербанк, они тебе все скажут. В коплекте поставки Клиент-Банка должны быть все нужные файлы. Иногда их не дают, забывают и т.д. Тогда их надо взять


XBASE | База знаний | mista.ru

XBASE

LOSS
04.05.2004 20:12 		Есть код но не работает
Как добавлять следующую запись в существующей базе

ДБФ.КоличествоЗаписей();
R=0;
Пока ДБФ.Последняя()=1
Цикл
R=R+1;
ДБФ.Добавить();
ДБФ.УстановитьЗначениеПоля("SYS_ID",0);
ДБФ.УстановитьЗначениеПоля("SYS_CREF",0);
ДБФ.УстановитьЗначениеПоля("SYS_HASATT",0);
ДБФ.УстановитьЗначениеПоля("PLT_ACC",Номер1);
ДБФ.УстановитьЗначениеПоля("BANK_POL_1",Получатель.МФОБанкаРасч);
ДБФ.УстановитьЗначениеПоля("BANK_POL_2",Получатель.АдресБанкаРасч);
ДБФ.УстановитьЗначениеПоля("BANK_POL_3",Получатель.РННБанкаРасч);
ДБФ.УстановитьЗначениеПоля("BANK_POL_4",Получатель.БанкРасч);
ДБФ.УстановитьЗначениеПоля("KNP_KOD",КодПлатежа);
ДБФ.УстановитьЗначениеПоля("KNP_KOMME2",НаимПл);
ДБФ.УстановитьЗначениеПоля("KBK_KOD",КодБюджета);
ДБФ.УстановитьЗначениеПоля("KBK_NAME",НаимБюдж);
ДБФ.Автосохранение(1);
КонецЦикла;
КонецПроцедуры
kvm
1 - 04.05.2004 21:46 		Структуру ДБФ проверил?
Попробуй прямое присвоение
ДБФ.SYS_ID=0;
Может, что не так с открытием ДБФ?
Naumov
2 - 04.05.2004 21:59 		Честно говоря не понял логики, но если открывается Пустая dbf-ка, то вероятно
ДБФ.Последняя() возвращает 0 и цикл не выполняется.
И вообще странное это условие для цикла.
LOSS
3 - 04.05.2004 22:14 		Прошу разобрать два случая. Когда база существует и добавляем дальше строки и второе когда пустая начиная с первой строки и т.д. вставляем строки. Рябяты в долгу не буду
LOSS
4 - 04.05.2004 22:16 		База открывается ОК. Вот дальше....именно добавить строки и т.д.
Naumov
5 - 04.05.2004 22:17 		Если база существует, то получается вечный цикл
или нет.
kvm
6 - 04.05.2004 22:20 		Получаем вечный цикл, если база не пустая. Если пустая, то цикл выполнен не будет, Последняя()=0
kvm
7 - 04.05.2004 22:23 		Напиши весь код. Последняя() выполняется по разному.
Метод Последняя предназначен для перехода на последнюю запись. Если не установлен текущий индекс, объект позиционируется на последнюю запись в базе данных, если установлен — на запись, имеющую самое старшее значение выражения текущего индекса (если индекс создавался с установленным флагом «Убывание», то наоборот).
LOSS
8 - 04.05.2004 22:34 		//Честно у вас гуру хочу совета. Сам не догнал. Короче если безцикла то ежу понятно что все ОК

Процедура ВТемирБанк()
REG=0; //номер записи обнуляется
ДБФ=СоздатьОбъект("XBase");
ДБФ.КодоваяСтраница(1);
ДБФ.ДобавитьПоле("SYS_ID",2,32,0);
ДБФ.ДобавитьПоле("SYS_CREF",2,32,0);
ДБФ.ДобавитьПоле("SYS_HASATT",2,1,0);
ДБФ.ДобавитьПоле("PLT_ACC",2,9,0);
ДБФ.ДобавитьПоле("BANK_POL_1",2,9,0);
ДБФ.ДобавитьПоле("BANK_POL_2",2,50,0);
ДБФ.ДобавитьПоле("BANK_POL_3",2,25,0);
ДБФ.ДобавитьПоле("BANK_POL_4",2,100,0);
ДБФ.СоздатьФайл("c:\temp\plat.dbf",);

НаимПл="1";
НаимБюдж="1";
БСчет=СоздатьОбъект("Справочник.БанковскиеСчета");
БСчет.НайтиЭлемент(Константа.ОснБанковскийСчет);
Номер1=БСчет.Номер;
БИК=БСчет.МФОБанкаРасч;
Город=Бсчет.АдресБанкаРасч;
НаимБанк=БСчет.БанкРасч;
РНН=БСчет.РННБанкаРасч;

ДБФ.КоличествоЗаписей();
R=0;
Пока ДБФ.Предыдущая()=1
Цикл
R=R+1;
ДБФ.Добавить();
ДБФ.УстановитьЗначениеПоля("SYS_ID",0);
ДБФ.УстановитьЗначениеПоля("SYS_CREF",0);
ДБФ.УстановитьЗначениеПоля("SYS_HASATT",0);
ДБФ.УстановитьЗначениеПоля("PLT_ACC",Номер1);
ДБФ.УстановитьЗначениеПоля("BANK_POL_1",Получатель.МФОБанкаРасч);
ДБФ.УстановитьЗначениеПоля("BANK_POL_2",Получатель.АдресБанкаРасч);
ДБФ.УстановитьЗначениеПоля("BANK_POL_3",Получатель.РННБанкаРасч);
ДБФ.УстановитьЗначениеПоля("BANK_POL_4",Получатель.БанкРасч);
ДБФ.Автосохранение(1);
КонецЦикла;
КонецПроцедуры
kvm
9 - 04.05.2004 22:40 		Добавь перед циклом ДБВ.Открыта() и посмотри, что он выдает. По-моему, надо ДБФ.ОТкрыть("c:\temp\plat.dbf")
kvm
10 - 04.05.2004 22:42 		И помтавь в присвоении полям с типом 2 строки, типа "0".
Naumov
11 - 04.05.2004 22:43 		ДБФ.КоличествоЗаписей(); эта строка совсем не имеет смысла
А цикл все равно не правильный. Чего хочешь сделать?
Получатель это кто?
LOSS
12 - 04.05.2004 22:53 		2kvm разберем сначала то что если нет цикла то код работает. Вопрос как сделать цикл валидным
2Naumov код выгружает платежку из 1С в банкклиент. Прога Банк клиент (у ней функция импорт ДБФ) проглатывает когда нет цикла Все ОК раскидывает по полям. То есть только одну запись.
Рябяты нужно добавление записи, когда наапример одну платежку выгрузил, потом в эту же базу вторую, а потом например все разом БанкКлиент проглотил. А так все ок
LOSS
13 - 04.05.2004 22:56 		Только Цикл с добавлением след строки. Как например в Таблице печ формы добавляется строка
GrayT
14 - 04.05.2004 22:59 		Если честно лениво разбираться. Может поможет. Ночь длинная ...
http://www.mista.ru/tutor_1c/dbf.htm#write
LOSS
15 - 04.05.2004 23:12 		(14) посмеяться перед сном тоже полезно. нет там этого. я не поле добавляю
GrayT
16 - 04.05.2004 23:21 		Со смеху не помри, плз
.......Файл.Добавить();
.......Файл.NAME = СпрТовары.Наименование;
.......Файл.УстановитьЗначениеПоля("PRICE",СпрТовары.Цена) //так тоже можно;
.......Файл.Записать();
Это поля или записи?
GrayT
17 - 04.05.2004 23:24 		Млин. В твоих циклах. Ты в цикл вообще заходишь? Отладчиком смотрел?
LOSS
18 - 04.05.2004 23:46 		.....Файл.Добавить();
//эт запись ну ты опытней вот и все. Попробую
А что с партией товаров вдругой ветке
GrayT
19 - 04.05.2004 23:59 		Угу, опытней. Так что с циклом?
"Хорошо смется тот, кто..." ну дальше сам :)
SnarkHunter
20 - 05.05.2004 06:23 		Если ты платежки из 1С во внешний дбф выгружаешь, то за каким цикл по этой дбф-ке? Цикл в этом случае должен быть по выборке документов...
LOSS
21 - 05.05.2004 06:57 		2GrayT значит ты шутил. ОК наработе попробую.
2SnarkHunter верно по докам. Втом случае если набраны и сохранены в журнале опер. А если набрал платежку и сразу выгрузил, набрал платежку и сразу выгрузил, набрал платежку и сразу выгрузил......., тогда наверное GrayT прав .....Файл.Добавить(); буду пробовать. Есть еще умные советы?
SnarkHunter
22 - 05.05.2004 07:03 		(21)Даже в твоем случае цикл совершенно не нужен...
kadr
23 - 05.05.2004 07:25 		А я бы предложил сделать так:
ДБФ = СоздатьОбъект("Xbase");
ДБФ.ОткрытьФайл(".....");
ДБФ.Первая();
Пока ДБФ.ВКонце() = 0 Цикл
.....тело цикла....
ДБФ.Следующая();
КонецЦикла;
SnarkHunter
24 - 05.05.2004 07:35 		(23)Это правильно, но применимо для чтения из внешней дбфки... Для записи это просто не нужно...
kadr
25 - 05.05.2004 07:36 		(24) А надо было записывать? Сорри, внимания не обратил...
kvm
26 - 05.05.2004 21:52 		"НАбрал платежку и сразу выгрузил". Не понял зачем цикл? Набрал платежку и
ДБФ.ОТкрытьФайл();
ДБФ.Добавить();
---
ДБФ.Записать();
ДБФ.ЗакрытьФайл();

Закончил выгрузку-очистил файл.


Конвертация 7 в 6? | База знаний | mista.ru

Конвертация 7 в 6?

Вадим 09.04.2004 18:09 | Господа, помогите юзеру. Нужно перенести проводки из 7-ки в 6-ку, есть какя-нибудь софтина, или это невозможно?
Все ОК 1 - 09.04.2004 18:40 | В старых конфигурациях (старый план счетов)была выгрузка проводок она выгружала в формате в формате 6.0 - обычный текстовый файл.Там ещё параметр был с субконто или без. Можешь сам с ним разобраться: выгружаешь проводки из какого-нибудь журнала и смотришь разделители. Можно посмотреть в старых конфигурациях если не ошибаюсь, то в Торговле ред. 5 было.
Vital 3 - 05.05.2004 16:29 | Помогите, кто может? Как базу данных из 1С_6 в 1С_7, релиз 19, превратить? Устанавливаю 1с_7, потом Sable. Запускаю конфигуратор. Выбираю конвектировать и указываю путь в конвектор. Конвектор запускается, а дальше куча ошибок и 1с вываливается.
Nasty 5 - 05.05.2004 17:02 | (3) Значит, не судьба. Распечатывайте оборотку, вносите остатки ручками и пользуйтесь стандартной 1С:Бухгалтерией 4.5.
427 6 - 05.05.2004 21:22 | Можно конвертить 6 --> 7... Эта возможность описана на ИТС (давно ею пользовался).... Можно конвертить 7 --> 6.... В 6 есть возможность загрузки аналитики и проводок (кстати, есть и выгрузка)... Нужно просто смолотить обработку и выгружать проводки в нужном формате.... Геморрно.... Всетаки в 6 только одно субконто на счете ....


При переносе текста из отчетов 1с в ворд появляются кракозябры | База знаний | mista.ru

При переносе текста из отчетов 1с в ворд появляются кракозябры

beginning 02.05.2004 18:32 | Как можно перенести текст из отчетов в ворд, чтобы текст был нормальный.
kvm 1 - 02.05.2004 18:36 | Перенеси в Excel. Есть примочка, которая позволяет в нем открыть 1с-овский сохраненный в mxl отчет, причем совершенно корректно. А из Excel-а в Word уже как нефиг делать.
427 3 - 02.05.2004 19:54 | Перед копированием в буфер включи РУССКУЮ раскладку.... И будет тебе счастье
ramstar 10 - 04.05.2004 05:19 | если че таблицы mxl можно сохронять в xls а потом drag & drop его в Word


ДБФ XBAse | База знаний | mista.ru

ДБФ XBAse

LOSS
02.05.2004 14:44 		ДБФ.КоличествоЗаписей();
R=0;
Пока ДБФ.Предыдущая()=1 Цикл
R=R+1;
ДБФ.Добавить();
ДБФ.УстановитьЗначениеПоля("SYS_ID",0);
ДБФ.УстановитьЗначениеПоля("SYS_CREF",0);
КонецЦикла
GrayT
2 - 02.05.2004 14:59 		Правильно - не плодить в ветки....
Если нужно просто добавить запись зачем цикл - просто и Добавить.


Префикс номера документа | База знаний | mista.ru

Префикс номера документа

525Alex 21.10.2004 10:31 | Есть самописная конфа. Очень простой склад. В нем нет Префикса для УРБД. Клиент хочет поставить УРБД. Немогу нигде найти как формируется новый номер документа и как туда вставить префикс для УРБД. Посоветуйте.
Sabron 10 - 22.10.2004 05:14 | IMXO Оптимальнее так: Процедура ПриРаботеСистемы() Если ПустоеЗначение(Константа.ПрефиксИБ)=0 Тогда ПрефиксАвтонумерации("Документ.*",Константа.ПрефиксИБ); ПрефиксАвтонумерации("Справочник.*",Константа.ПрефиксИБ); КонецЕсли; КонецПроцедуры
Оборотень 11 - 22.10.2004 10:00 | Есть немного другой способ в глобальнике Процедура ПриНачалеРаботыСистемы() Если ТекущаяИБЦентральная()=0 Тогда СтрПреф=ТекущаяИБКод()+"-"; ПрефиксАвтонумерации("Документ.*",СтрПреф); ПрефиксАвтонумерации("Справочник.*",СтрПреф); КонецЕсли КонецПроцедуры Вот тоже способ и не нужно за константами следить :)


Выгрузка "пустых " значений. | База знаний | mista.ru

Выгрузка "пустых " значений.

roVer 11.10.2004 10:51 | Не выгружаются "пустые" (тип реквизита - справочник) и нулевые (тип реквизита - число) значения. (ТиС 9.2) Можно где-то в правилах поправить или нужно что-то еще?
F427 1 - 11.10.2004 11:35 | обозначай их скобками.. вот так <...> - и все будет нормально


Выгрузка данных из Паруса 4.4 | База знаний | mista.ru

Выгрузка данных из Паруса 4.4

Серж 09.10.2004 17:07 | Клиенту надо загрузить данные из Паруса 4.4 в 1С Бухгалтерию. Смотрел более поздние версии Паруса, там база хранится в dbf файлах, в версии 4.4 тоже самое или нет?. Плюс есть, судя по всему, выгрузка их базы в каталог (куча sdf файлов). Есть ли конвертация sdf в dbf? В затруднении я с какой стороны подойти к этому вопросу, помогите советом.
NS 3 - 09.10.2004 17:22 | http://www.parus.ru/index.php?page=100&mode=thread&sub=3738
Valery 7 - 09.10.2004 18:38 | Я даже пользовалься таким вариантом. База хранилась в нестандартном формате, тогда я распечатал отчеты, отсканировал далее эксель-> дбф. Как оказалось вариант очень неплохой, даже если базы в дбф.
Серж 8 - 10.10.2004 13:31 | С отчетами это интересно, в крайнем случае можно попробовать :). NS спасибо за ссылочку. sdf без проблем в excel прочитался. Осталось опредилиться с полями, а там уже дело техники.
Охламон 9 - 10.10.2004 14:50 | Серж, в Парусе есть файлик STRUC440.BUM - там описана вся структура баз. Когда переводил свою контору, оч. помогло. Единственное с чем из неприятностей столкнешься - это memo поля, но это все обходиться, просто правь поля в базе на текстовые и вперед...


настройка УРБД | База знаний | mista.ru

настройка УРБД

koluchiy 08.10.2004 17:44 | Подскажите где можна пощитать инфу по установке, настройке и использованию УРБД.
Волшебник 1 - 08.10.2004 17:45 | http://www.mista.ru/articles1c/urbd.htm
Crew 4 - 08.10.2004 17:52 | http://www.sinor.ru/~my1c/knowhow.html
Иешуа 6 - 08.10.2004 18:20 | http://argat.h11.ru/URBDStructure.html http://faq1c.gorbunov.ru/faq1c/distr.htm http://warenic.narod.ru/doc2.html/


Cтандарт 1C-XML -файла | База знаний | mista.ru

Cтандарт 1C-XML -файла

Kopyl 26.07.2004 19:05 | Существуют ли Cтандарт 1C-XML -файла (кроме "кособокого" коммерс-ИксЕмЕль) Или каждый создает то на че горазд?
Валентин 1 - 26.07.2004 20:24 | Каждый под себя точит. По крайней мере выгоднее иметь 10 поставщиков с 10 плсдиченными списками чем геморой с 5 обновляемыми каталогами номенклатурв
Kopyl 5 - 27.07.2004 10:24 | Содрать то содрали , да до ума не довели Тогда такой вопрос: Как лучше переносить реквизиты справочника в XML отдельными тегами ------------------- - <Товар Наименование="Апельсины 2511"> 2 <ПолнНаименование>Апельсины 2511</ПолнНаименование> <БазЕдиница /> <ПрихВалюта>USD</ПрихВалюта> <ПрихКурс>5.4</ПрихКурс> <ПрихВалЦена>0.65</ПрихВалЦена> <ПрихЦена>3.51</ПрихЦена> <СтоимДоставки>0</СтоимДоставки> <СтоимРастамож>0</СтоимРастамож> <GUID>6EF07DA3-64EB-4C9F-A81A-01061997FF54</GUID> </Товар> ------------------ т.е через -СоздатьПодчиненныйЭлемент или чере -УстановитьАтрибут- для Элемента ? или
Валентин 6 - 27.07.2004 10:56 | А тут уже вопрос удобства. Не более чем. Элементраным XSLT преобразованием приводишь атрибуты к тэгам и наоборот. Но у себя при переносе, описывая схему справочника 1. реквизитов описывают подчиненные элементы 2. служебную инфу в атрибуты Потом после схемы - сами данные. Удобно как мне кажется
Kopyl 7 - 27.07.2004 11:02 | (6) 1. реквизитов описывают подчиненные элементы 2. служебную инфу в атрибуты А можно пример, а то на словах как-то не совсем "доходчиво"
Валентин 8 - 27.07.2004 11:15 | Народ!!! Порадуйтесь за меня - отпуск на неделю!!! ТОлко что выбил. По памяти: <Справочник база="sc33" Починен="" ТипКода="Число" ДлиннаКода="5" Группы="Да"> Номенклатура <Реквизит поле ="sp52" вид="Справочник" тип="ЕдиницыИзмерения" Периодический="Нет"> ЕдИзмерения <\Реквизит > <Реквизит поле ="sp55" вид="Число" Длинна="10.2" Периодический="Да"> Цена <\Реквизит > <Данные> <Элемент ЭтоГруппа="Нет"> <Код>1<\Код> <Наименование> Апельсин <Наименование> <Реквизит> 1 <\Реквизит> <Реквизит> <Дата наДату="2004-01-01" отДокумента=0> 100.00 <\Дата > <Дата наДату=ref_Doc_100 отДокумента=1> 120.00 <\Дата > <\Реквизит> <\Элемент> <\Данные> <\Справочник> Примерно так. Если что - аська 198390822
Kopyl 9 - 27.07.2004 13:20 | А вот по этому поводу у кого какое мнение? http://www.iso.ru/dxml/regulation.html
Валентин 11 - 04.10.2004 19:16 | Нет. В принципе интересовался XML только для себя, т.к. пока нет необходимости внедрять такое на предприятии. Про XSLT можно прочитать практически на любом сайте посвященом XML. Да и кривоват "стандартный" /1Совский/ формат для обмена информацией поставщик-покупатель. Лучше свое разработать. С учетом специфики общения с поставщиком.
PVasili 12 - 05.10.2004 11:40 | Валентин: Вроде как есть описание http://www.1c.ru/rus/products/1c/predpr/xml-schs.htm или http://www.1c.ru/rus/products/1c/predpr/xml.htm. IMHO удобно и понятно, что там кривоватого? Можно взять только часть только На itLand http://itland.ru/forum/index.php?showtopic=3674&hl=xslt тоже нет вариантов :-( Просто за день и без без пол литра с XSLT не разберешься, вот и интересны любые наработки.


Разграничение прав в УРБД. Как??? | База знаний | mista.ru

Разграничение прав в УРБД. Как???

Иешуа 07.10.2004 15:29 | Ситуация значится такая: есть "Головная фирма" и удаленные филиалы (расположены в других городах). На одном из филиалов есть очень умный и активный бух, который по своему усмотрению правит справочники, константы, операци. Как следствие при обмене эти изменения попадают в центральную базу, а оттуда расползаются по всем базам, что совсем не нравится остальным бухам и они очень больно бьют разработчика (а ему это ну совсем не нравится!). Так вот подскажите, как разграничить права доступа (хотя бы к справочникам) по месту создания. Т.е. где элемент создали, там его и правят, а к чужим доступа не имеют, а в идеале и их не видят. Всем заранее Спасибо!
insurance 1 - 07.10.2004 15:50 | Переписать модули справочников. Используя событие ПриЗаписи и методы CurrentIBCode и BirthIBOfObject. А лучше всего в филиалах вообще запретить редактировать справочники используя те же методы.
12345 2 - 07.10.2004 16:06 | (1) + надо учитывать, что последний метод возвращает пустое значение в случае, если элемент был создан ДО того, как база стала распределенной!
Иешуа 3 - 07.10.2004 16:22 | Вообще запретить нельзя, у филиалов своя номенклатура, контрагенты и прочее... А ПриЗаписи к чему привязаться? как отследить откуда записывают? по коду базы?
Lex2004 4 - 07.10.2004 16:35 | сделай единую базу контаргентов и номенклатуры и запрети редактирование в филиалах в чем вопрос то...
insurance 5 - 07.10.2004 17:35 | (3) я же сказал какие методы надо использовать. Сравнивать код текущей ИБ с местом создания объекта и если они не равны, то не давать записывать. + можно сделать навороты - типа филиалы могут записывать контрагентов только в их папку (специально для них созданную для каждого филиала). (4) В филиалах обычно заводят своих контрагентов (местные налоговые, свои поставщики, покупатели) - не будут же их заводить всех в центре?


Объединение двух переферийных баз в одну | База знаний | mista.ru

Объединение двух переферийных баз в одну

Timur
23.09.2004 20:02 		Задача-Существуют две переферийные базы в разных городах - переходим на спд и соответственно надобность в УРБД отпадает --вопрос-----
Возможноли объединить эти две базы в одну(возможно)
Но есть одна как мне кажется проблема
Две переферийные базы - это два магазина -- и соответственно нужны будут отчеты по двум разным магазинам -- по отдельности
Т е пользователи одного магазина по СПД в терминальном режиме будут вводить документы -- и надо чтоб программа как-то отличала -- что эти пользователи -- одного магазина -- а те другого

Существует ли какоето решение
Волшебник
1 - 23.09.2004 20:46 		Объединить и отвязаться от УРБД возможно.
Существует много решений введения подобной аналитики.
Волшебник
4 - 23.09.2004 22:06 		При использовании компоненты "Управление РБД", создав центральную и периферийные базы, вы сталкиваетесь с проблемой невозможности вернуть все назад. Причины "крутить кино назад" могут быть разные.
Вариант 1. У меня однажды слетела центральная база. Манипулировать пришлось с периферийной. Чтобы получить возможность править конфигурацию я убил файлы 1sdbset.dbf, 1sdwnlds.dbf, 1supdts.dbf и соответствующие им индексные файлы. Это дало мне возможность залезть в конфигуратор, сделать необходимые доработки и обозвать эту базу центральной. Далее я создал периферийную и сделал выгрузку данных. При этом данные из слетевшей центральной ИБ, которые не выгружались в периферийную, безвозвратно пропадают.

Вариант 2. Более свежий. Это я прочитал в конференции профессионалов. Нужно найти файл 1ssystem.dbf. Он находится в каталоге информационной базы. Чтобы информационная база отвязалась от компоненты УРБД, достаточно очистить два поля: DBSIGN и DBSETUUID. 1sdbset.dbf, 1sdwnlds.dbf, 1supdts.dbf и соответствующие им индексные файлы можно удалить - они больше не понадобятся.

Вариант 3. А вообще-то, просто-напросто убиваете файл 1ssystem.dbf. При следующей загрузке система сама его восстановит Файлы 1sdbset.dbf, 1sdwnlds.dbf, 1supdts.dbf и соответствующие им индексные файлы все же можно удалить. Но, говорят, при этом могут быть проблемы с ТА (?).

--------------------------------------------------------------------------------

!!!Очень важно предварительно загрузить в центральную базу все данные из периферийных! После отвязки от РБД, это будет невозможно сделать


УРБД и XML | База знаний | mista.ru

УРБД и XML

AndreiL 02.07.2004 10:09 | Подскажите пожалуйста в чём разница между УРБД и XML или это одно и то же
Crew 2 - 02.07.2004 10:20 | УРБД - уже написаные правила обмена между одинаковыми конфигурациями. XML - сделай сам. Конечно можно найти готовые решения, но то что они подойдут к конкретному случаю шанс невелик. Да конфигурации могут быть разными.
AndreiL 4 - 02.07.2004 10:22 | А кто пишет правила обмена для УРБД и как писать для XML?
lexa 5 - 02.07.2004 10:23 | УРБД сам синхронизирует информацию и конфигурацию между ИБ а при использовании переноса данных через XML - это твоя забота
AndreiL 6 - 02.07.2004 10:25 | Как использовать УРБД если между двумя филиалами есть связь только через модем?
Crew 7 - 02.07.2004 10:26 | Дополню: в УРБД сам можешь настроить права миграции для объектов, т.е. из переферийной в центральную переносить, а наоборот нет.
lexa 8 - 02.07.2004 10:27 | (6) через мыло - стандартная опция
AndreiL 9 - 02.07.2004 10:27 | С какой периодичность происходит обмен данными?
Crew 10 - 02.07.2004 10:28 | (6) А как пользоваться вилкой или ложкой ;) Давай мыло сброшу описание по УРБД там и прочитаешь или зайди в google.ru и набери УРИБ или УРБД
AndreiL 12 - 02.07.2004 10:30 | Мыло - jordanmj23@yandex.ru Кстати в чём разница между УРИБ и УРБД
lexa 13 - 02.07.2004 10:32 | (12) это одно и тоже
lexa 14 - 02.07.2004 10:33 | http://www.mista.ru/articles1c/urbd.htm http://www.sinor.ru/~my1c/knowhow.html#URIB http://www.anvil.spb.ru/1c/rec/recom012.htm
AndreiL 15 - 02.07.2004 10:35 | УРБД позволяет обмен данными организовывать в разные стороны по разному Филиал экспортирует одну информацию а офис другую?
lexa 16 - 02.07.2004 10:41 | (15)Все зависит от того какой способ обмена ты выберешь, ли бо ходит вся информация либо в одну сторону. ты можешь некоторые объекты исключить из обмена. Посмотри ссылки и проверь почту
Crew 18 - 02.07.2004 10:43 | Вообщем да. Пример: Основное предприятие №1 и дочернее №2 консолидированая отчетность. Нужно из №2 в №1 передовать все изменения, а из №1 в №2 только изменения конфигурации и служубной информации. УРИБ с эти легко справляется
AndreiL 19 - 02.07.2004 10:45 | Как считаешь а программно можно организовать такой обмен данными. Филиал с помощьб моей проги вносит изменения в свою БД и в то же время посылает сообщение в офис. В офисе сообщение принимается и все данные вносятся и в здешнюю БД. Твоё мнение?
Crew 21 - 02.07.2004 10:50 | (19) :) "Возможно все и все возможно" Вариантов соединения двух БД (не только 1с) очень много. Какой из них ты выберешь это только твое решение. Проанилируй полученую информацию и выбирай. У 1с возможности очееееень широкие. ;) Особенно если использовать внешние компоненты.
AndreiL 22 - 02.07.2004 10:50 | А кто-то так делает или это всё чушь? И такой вопрос в 1С 7.7 меню Обмен данными это и есть УРБД или нет
Crew 23 - 02.07.2004 10:52 | (19) например есть еще МОД www.pb.ru
lexa 25 - 02.07.2004 10:54 | (22) имеет смысл если разные конфы ( но синхронизация данных и задвоение объектов, замучаешься баги искать) Обмен данными это и не есть УРБД посмотри (14)
AndreiL 26 - 02.07.2004 10:56 | В двух словах что такое МОД и насколько он эффективен?
lexa 27 - 02.07.2004 11:00 | МОД боле эффективен чем УРБД, но и сложнее в использовании Попробуй урбд, если не подойдет поюзай мод, или пиши сам
AndreiL 28 - 02.07.2004 11:03 | Ещё раз хотел спросить меню Обмен данными в 1С Предприятие это и есть УРБД или нет
Crew 29 - 02.07.2004 11:03 | (26) Все зависит только от придатка к компьютеру, т.е. человека. МОД и УРИБ два решения практически однотипной задачи, но если конфы одинаковые, то бери УРИБ, а если разные то МОД.
lexa 30 - 02.07.2004 11:06 | (28) Обмен данными это не есть УРБД УРБД это в конфигураторе Администрирование-Распределеные ИБ Ты ссылки смотрел? Или это просто развод?
Stra 41 - 02.07.2004 11:47 | Бери УРБД и не забивай голову. Нормальная вещь, нормально работает. Обмен мылом, автообмен, носителями на худой конец. Частота обмена - любая (как настроишь).


УРБД на v8 за четыре шага. | База знаний | mista.ru

УРБД на v8 за четыре шага.

Asmody
10.08.2004 19:10 		Волшебник попросил меня опубликовать это здесь. Ну вот:
--------------------------------------------------------
сразу замечу, что все ниже следующее относится к релизу платформы 8.0.7.36 и выше.

Шаг 1. Создание плана обмена.
Создаем в конфигурации план обмена. Называем его, например "РаспределеннаяБаза". Обязательно в свойствах плана обмена ставим галку "Распределенная база".
На закладке "Прочее" по кнопке "Состав" определяем, какие объекты будут включаться в обмен. По умолчанию можно включить все объекты ("Действия"-"Включить все"). Важным моментом является параметр "Авторегистрация". В общем случае ее нужно разрешить для всех объектов. Замечание: при добавлении новых объектов в конфигурацию, они не включаются в план обмена. Т.е. после добавления объекта его необходимо добавить в состав плана обмена.
Если Вы хотите, чтобы некоторые объекты не участвовали в обмене, просто исключаете их из состава плана обмена. Но тогда контроль ссылочной целостности остается целиком на Вашей совести. (Если, к примеру, некий документ не включен в план обмена, а регистр, по которому он делает движения включен, то в базе-приемнике вполне реально получить движения по регистру без документа-регистратора, что согласитесь, не есть хорошо)
В принципе, этих действий достаточно, чтобы РБД заработала в "ручном" режиме. Для этого запускаем Предприятие, открываем наш план обмена через меню "Операции". В плане обмена всегда присутствует узел "с точкой". Это описание текущего узла. Его нужно открыть и заполнить. В нашем случае будут доступны поля "Код" и "Наименование". Присвоим нашему узлу код "AA" и назовем "Центральная".
Добавим в план обмена один узел. Присвоим ему код "ВВ" и назовем "Периферийная".
Теперь мы можем создать образ периферийной базы. Делается это нажатием кнопки "Создать начальный образ". В списке узлов должна быть выбрана периферийная база. Образ базы создается в виде готовой ИБ в каталоге или на сервере 1С:Предприятия. (в отличие от 7.7, где образ ИБ создавался как файл выгрузки). Далее созданную базу можно перенести в нужное место просто скопировав файлик 1CV8.1CD (для файлового варианта), либо через Конфигуратор через выгрузку-загрузку данных.
Если Вы откроете план обмена в периферийной ИБ, то Вы увидите, что узлом "с точкой", т.е. текущим узлом стал узел "Периферийная", а иконка у узла "Центральная" стала красного цвета, т.е. узел "Центральная" является главным узлом по отношению к текущему.
Обмен в "ручном" режиме можно производить при помощи кнопок "Записать изменения" и "Прочитать изменения". В первом случае будет предложено выбрать файл, куда изменения будут записаны, во втором - файл, откуда изменения будут считаны. Обмен ведется в формате xml. Изменения записываются для выбранного узла.
Далее мы займемся автоматизацией процесса обмена.
(продолжение следует)
Asmody
1 - 10.08.2004 19:11 		Шаг 2. Итак мы создали план обмена, создали периферийную ИБ и даже научились переносить данные между базами. Теперь наша задача научить базы обмениваться по электронной почте.
Добавляем в план обмена два реквизита: ЭлектронныйАдрес типа строка и ВыполнятьОбмен типа булево. В реквизите ЭлектронныйАдрес будем хранить email узла, т.е. тот адрес, на который будем посылать сообщения обмена. Реквизит ВыполнятьОбмен нужен чтобы быстро отключить автоматическую посылку-отправку сообщений.
Для работы с эл.почтой сделаем универсальной, т.е. сделаем возможным использование как MAPI (отправка-получение через MS Outlook), так и прямое обращение к SMTP/POP3 серверам.
Добавим несколько констант:
ИспользоватьОбменПоSMTP - Булево
АдресСервераSMTPОбмена - Строка(50)
ПортСервераSMTPОбмена - Число(4,0)
ПользовательСервераSMTPОбмена - Строка(10)
ПарольПользователяSMTPОбмена - Строка(10)
АдресСервераPOP3Обмена - Строка(50)
ПортСервераPOP3Обмена - Число(4,0)
ПользовательСервераPOP3Обмена - Строка(10)
ПарольПользователяPOP3Обмена - Строка(10)
ВремяОжиданияСервера - Число(3,0)
ВыводитьСообщенияОбмена - Булево

где-нибудь в общей форме обеспечиваем редактирование значений этих констант.

Добавим общий модуль, назовем его рбРаспределеннаяБаза
в нем пишем:

Процедура рбОтправитьСообщенияОбмена() Экспорт
ИспользоватьSMTP=Константы.ИспользоватьОбменПоSMTP.Получить();

Если ИспользоватьSMTP Тогда
ПочтовыйПрофиль=Новый ИнтернетПочтовыйПрофиль;
ПочтовыйПрофиль.АдресСервераSMTP=Константы.АдресСервераSMTPОбмена.Получить();
ПочтовыйПрофиль.ПортSMTP=Константы.ПортСервераSMTPОбмена.Получить();
ПочтовыйПрофиль.ПользовательSMTP=Константы.ПользовательСервераSMTPОбмена.Получить();
ПочтовыйПрофиль.ПарольSMTP=Константы.ПарольПользователяSMTPОбмена.Получить();
ПочтовыйПрофиль.ВремяОжидания=Константы.ВремяОжиданияСервера.Получить();

Почта=Новый ИнтернетПочта();
Попытка
Почта.Подключиться(ПочтовыйПрофиль);
Исключение
Сообщить("ОБМЕН: Ошибка при подключении к почтовому профилю! Обмен не выполнен! "+ОписаниеОшибки(),СтатусСообщения.ОченьВажное);
Возврат;
КонецПопытки;
Иначе
Почта=Новый Почта();
Попытка
Почта.Подключиться();
Исключение
Сообщить("ОБМЕН: Ошибка при подключении к почтовому профилю пользователя! Обмен не выполнен! "+ОписаниеОшибки(),СтатусСообщения.ОченьВажное);
Возврат;
КонецПопытки;
КонецЕсли;

ВыборкаУзлов=ПланыОбмена.РаспределеннаяБаза.Выбрать();
Пока ВыборкаУзлов.Следующий() Цикл
Если Не ВыборкаУзлов.ВыполнятьОбмен Тогда
Продолжить;
КонецЕсли;
Если ВыборкаУзлов.Ссылка <> ПланыОбмена.РаспределеннаяБаза.ЭтотУзел() Тогда
ЭлектронныйАдрес=СокрЛП(ВыборкаУзлов.ЭлектронныйАдрес);
Если ЭлектронныйАдрес="" Тогда
Продолжить;
КонецЕсли;
Узел=ВыборкаУзлов.Ссылка;
ЗаписьXML=Новый ЗаписьXML();
ИмяФайлаСообщения=КаталогВременныхФайлов()+"Message_"+СокрЛП(ПланыОбмена.РаспределеннаяБаза.ЭтотУзел().Код)+"_"+СокрЛП(Узел.Код)+".xml";
ЗаписьXML.ОткрытьФайл(ИмяФайлаСообщения);
ЗаписьСообщения=ПланыОбмена.СоздатьЗаписьСообщения();
ЗаписьСообщения.НачатьЗапись(ЗаписьXML,Узел);
ПланыОбмена.ЗаписатьИзменения(ЗаписьСообщения);
ЗаписьСообщения.ЗакончитьЗапись();
ЗаписьXML.Закрыть();

Если ИспользоватьSMTP Тогда
ПочтовоеСообщение=Новый ИнтернетПочтовоеСообщение;
Иначе
ПочтовоеСообщение=Новый ПочтовоеСообщение;
КонецЕсли;
Файл=Новый Файл(ИмяФайлаСообщения);
ПочтовоеСообщение.Тема="1С:Обмен "+СокрЛП(ПланыОбмена.РаспределеннаяБаза.ЭтотУзел().Код)+"_"+СокрЛП(Узел.Код);
Если ИспользоватьSMTP Тогда
ПочтовоеСообщение.Вложения.Добавить(ИмяФайлаСообщения, Файл.Имя);
Иначе
ПочтовоеСообщение.Вложения.Добавить(ИмяФайлаСообщения);
КонецЕсли;
ПочтовоеСообщение.Получатели.Добавить(ЭлектронныйАдрес);

Если ИспользоватьSMTP Тогда
Почта.Послать(ПочтовоеСообщение);
Иначе
Почта.Послать(ПочтовоеСообщение, Ложь);
КонецЕсли;
Если Константы.ВыводитьСообщенияОбмена.Получить() Тогда
Сообщить("ОБМЕН: Сообщение обмена для узла "+Узел.Наименование+" отправлено!",СтатусСообщения.Информация);
КонецЕсли;
УдалитьФайлы(ИмяФайлаСообщения);
КонецЕсли;
КонецЦикла;

Почта.Отключиться();

КонецПроцедуры

комментарий к процедуре: сначала создаем объект Почта, который в зависимости от настроек будет типа ИнтернетПочта если используется прямое обращение к серверам, либо Почта если используется MAPI. Для объекта типа ИнтернетПочта создаем и заполняем почтовый профиль. Далее выбираем все узлы из плана обмена, за исключением текущего, у которых установлен реквизит ВыполнятьОбмен. С помощью объектов ЗаписьXML и ЗаписьСообщения выполняем запись изменений для выбранного узла в xml-файл. Затем создаем новое письмо, прикрепляем к нему полученный xml-файл и отправляем по адресу, указанному в реквизите ЭлектронныйАдрес узла.
Рекомендую в интерфейс добавить дополнительную панель, на одну из кнопок которой повесить вызов этой процедуры. Теперь осталось запустить Предприятие, настроить электронный адрес периферийной ИБ, поставить галку "Выполнять обмен", нажать на кнопку процедуры на панели и бежать получать почту для указанного эл. адреса. Должно придти письмо с темой "1С:Обмен AA_BB" и вложеным файлом "Message_AA_BB.xml".
Итак, половина дела сделана: мы научили 8ку отправлять сообщения обмена РБД по электронной почте.
Asmody
2 - 10.08.2004 19:11 		Шаг 3. Теперь займемся обратной процедурой: получение обновлений по электронной почте и запись их в ИБ.
в параметры сеанса добавим реквизит ИдетОбменРаспределеннойБазы типа Булево. Ниже я объясню его назначение.

Добавим в модуль рбРаспределеннаяБаза такую процедуру:

Процедура рбПолучитьСообщенияОбмена() Экспорт
ИспользоватьSMTP=Константы.ИспользоватьОбменПоSMTP.Получить();

Если ИспользоватьSMTP Тогда
ПочтовыйПрофиль=Новый ИнтернетПочтовыйПрофиль;
ПочтовыйПрофиль.АдресСервераPOP3=Константы.АдресСервераPOP3Обмена.Получить();
ПочтовыйПрофиль.ПортPOP3=Константы.ПортСервераPOP3Обмена.Получить();
ПочтовыйПрофиль.Пользователь=Константы.ПользовательСервераPOP3Обмена.Получить();
ПочтовыйПрофиль.Пароль=Константы.ПарольПользователяPOP3Обмена.Получить();
ПочтовыйПрофиль.ВремяОжидания=Константы.ВремяОжиданияСервера.Получить();

Почта=Новый ИнтернетПочта();
Попытка
Почта.Подключиться(ПочтовыйПрофиль);
Исключение
Сообщить("ОБМЕН: Ошибка при подключении к почтовому профилю! Обмен не выполнен!",СтатусСообщения.ОченьВажное);
Возврат;
КонецПопытки;
Иначе
Почта=Новый Почта();
Попытка
Почта.Подключиться();
Исключение
Сообщить("ОБМЕН: Ошибка при подключении к почтовому профилю пользователя! Обмен не выполнен!",СтатусСообщения.ОченьВажное);
Возврат;
КонецПопытки;
КонецЕсли;

МассивСообщений=Новый Массив;
Если ИспользоватьSMTP Тогда
ВсеСообщения=Почта.Выбрать(Ложь);
Иначе
ВсеСообщения=Почта.Выбрать(Ложь, Ложь);
КонецЕсли;
Для Каждого Сообщение из ВсеСообщения Цикл

Если Лев(Сообщение.Тема, 8)<>"1С:Обмен" Тогда
Продолжить;
КонецЕсли;
Попытка
МассивСообщений.Добавить(Сообщение);
Вложение=Сообщение.Вложения[0];
ИмяФайлаСообщения=КаталогВременныхФайлов()+Вложение.Name;
ДанныеОбмена=Вложение.Данные;
ДанныеОбмена.Записать(ИмяФайлаСообщения);

ЧтениеXML=Новый ЧтениеXML();
ЧтениеXML.ОткрытьФайл(ИмяФайлаСообщения);
ЧтениеСообщения=ПланыОбмена.СоздатьЧтениеСообщения();
ЧтениеСообщения.НачатьЧтение(ЧтениеXML);
ПараметрыСеанса.ИдетОбменРаспределеннойБазы=Истина;
ПланыОбмена.ПрочитатьИзменения(ЧтениеСообщения);
ЧтениеСообщения.ЗакончитьЧтение();
ЧтениеXML.Закрыть();
Если Константы.ВыводитьСообщенияОбмена.Получить() Тогда
Сообщить("ОБМЕН: Данные обмена приняты",СтатусСообщения.Информация);
КонецЕсли;
Исключение
Сообщить("ОБМЕН: Ошибка при получении данных обмена: "+ОписаниеОшибки(),СтатусСообщения.ОченьВажное);
КонецПопытки;
ПараметрыСеанса.ИдетОбменРаспределеннойБазы=Ложь;

Попытка
УдалитьФайлы(ИмяФайлаСообщения);
Исключение
КонецПопытки;

КонецЦикла;

Если ИспользоватьSMTP Тогда
Почта.УдалитьСообщения(МассивСообщений);
КонецЕсли;
Почта.Отключиться();

КонецПроцедуры

коментарий к процедуре: так же, как в процедуре рбОтправитьСообщенияОбмена(), сначала создаем объект Почта. Отбираем среди всех писем те, которые имеют тему "1С:Обмен". (Маленькое, но важное замечание: считаем, что все полученные письма с темой "1С:Обмен" прдназначены именно для текущего узла. Т.е. что у разныз узлов в плане обмена РАЗНЫЕ электронные адреса.) Вложение письма сохраняем на диске. Аккуратную проверку вложения оставим пока "за кадром." С помощью объектов ЧтениеXML и ЧтениеСообщения читаем данные обновления из сохраненного файла. Перед записью обновлений в ИБ устанавливаем параметр сеанса ИдетОбменРаспределеннойБазы в Истина. Затем читаем изменения в ИБ: ПланыОбмена.ПрочитатьИзменения(ЧтениеСообщения). Попутно сохраняем сообщения в массиве, чтобы потом их все сразу удалить. После того, как чтение данных обмена закончено, возвращаем параметру сеанса ИдетОбменРаспределеннойБазы значение Ложь.
Теперь про то, для чего нужен параметр сеанса ИдетОбменРаспределеннойБазы. Дело в том, что при чтении данных методом ПланыОбмена.ПрочитатьИзменения() происходит вызов процедур-обработчиков события ПередЗаписью() изменяемых/добавляемых объектов. И если при записи какого-либо объекта в процедуре обработчике параметр Отказ будет установлен в значение Истина, то при выполнении ПланыОбмена.ПрочитатьИзменения() возникнет исключение, и, соответственно, обмен выполнен не будет. Значение параметра сеанса ИдетОбменРаспределеннойБазы может быть проанализированно в процедурах-обработчиках, дабы избежать подобной ситуации.
Теперь в интерфейсе на нашей панели добавляем еще одну кнопку, на которую вешаем вызов этой процедуры. Запускаем Предприятие и наслаждемся.
Почти все сделано, осталось малость: заставить наши процедуры выполняться в автоматическом режиме.
(продолжение следует)
Asmody
3 - 10.08.2004 19:11 		Шаг 4.
Итак, мы почти вплотную приблизились к цели нашего повествования.
Остался всего один шаг: запустить выполнение процедур обмена в автоматическом режиме.
Приступим.

Добавим константу ИнтервалАвтообменаРаспределеннойБазы типа Число(5,0).
В настройки пользователя добавим параметр ВыполнятьОбменРаспределенныхБаз. Для УТ это делается так:
В план видов характеристик "НастройкиПользователей" добавим предопределенную характеристику ВыполнятьОбменРаспределенныхБаз типа Булево.
В форме элемента справочника "Пользователи" настраиваем изменение этого параметра (как это сделать можно посмотреть в модуле формы, по аналогии с остальными параметрами).
В модуль рбРаспределеннаяБаза добавляем процедуру:

Процедура рбВыполнитьОбмен(прПользователь) Экспорт
Если нпПолучитьЗначениеПоУмолчанию(прПользователь, "ВыполнятьОбменРаспределенныхБаз") Тогда
рбПолучитьСообщенияОбмена();
рбОтправитьСообщенияОбмена();
КонецЕсли;
КонецПроцедуры

в модуль приложения:

Процедура ПроверитьПодключениеАвтообмена() Экспорт
Если нпПолучитьЗначениеПоУмолчанию(глТекущийПользователь,"ВыполнятьОбменРаспределенныхБаз")
и Константы.ИнтервалАвтообменаРаспределеннойБазы.Получить() > 0 Тогда
ПодключитьОбработчикОжидания("ВыполнитьАвтообмен",Константы.ИнтервалАвтообменаРаспределеннойБазы.Получить());
Иначе
ОтключитьОбработчикОжидания("ВыполнитьАвтообмен");
КонецЕсли;
КонецПроцедуры

Процедура ВыполнитьАвтообмен() Экспорт
рбВыполнитьОбмен(глТекущийПользователь);

ОтключитьОбработчикОжидания("ВыполнитьАвтообмен");
Если нпПолучитьЗначениеПоУмолчанию(глТекущийПользователь,"ВыполнятьОбменРаспределенныхБаз")
и Константы.ИнтервалАвтообменаРаспределеннойБазы.Получить() > 0 Тогда
ПодключитьОбработчикОжидания("ВыполнитьАвтообмен",Константы.ИнтервалАвтообменаРаспределеннойБазы.Получить());
КонецЕсли;
КонецПроцедуры

Процедура ОтключитьАвтообмен() Экспорт
ОтключитьОбработчикОжидания("ВыполнитьАвтообмен");
КонецПроцедуры

в процедуру ПриНачалеРаботыСистемы() модуля приложения добавим такие строки:
(после подключения торгового оборудования)
...
ПараметрыСеанса.ИдетОбменРаспределеннойБазы=Ложь;
ПроверитьПодключениеАвтообмена();
...

Добавим на нашу панель еще пару кнопок для управления процессом: на одну вешаем процедуру ПроверитьПодключениеАвтообмена(), на другую - ОтключитьАвтообмен()
Запускаем предприятие, настраиваем свойства пользователя и интервал автообмена и все!
Теперь при заходе в базу под этим-самым-настроенным пользователем будет запускаться обработчик ожидания ВыполнитьАвтообмен(). Естественно, в периферийной базе тоже нужно настроить пользователя для обмена.
Asmody
4 - 10.08.2004 19:12 		Еще одно маленькое, но важное замечание:
Во всей, созданной нами прелести, присутствует одна неприятность: изменение конфигурации. При получении периферийной базой сообщения, в котором будут содержаться изменения конфигурации, оно будет принято, но возникнет исключительная ситуация. При этом измененная конфигурация будет загружена. Для обновления конфигурации БД необходимо выгнать всех пользователей, зайти в конфигуратор и выполнить обновление конфигурации БД (перед этим неплохо сделать выгрузку данных). К сожалению, это неизбежное зло. Можно немного облегчить себе жизнь, написав коротенький bat-файл примерно такого содержания:

1cv8.exe CONFIG /F<путь к ИБ> /N<Пользователь> /P<Пароль> /UpdateIBCfg
Asmody
5 - 10.08.2004 19:12 		И еще одно замечание:
К сожалению, xml-файлы не отличаются компактностью, но, к счастью, прекрасно сжимаются. Можно в процедуры отправки и получения сообщений добавить упаковку-распаковку файлов. Делать это можно либо внешним архиватором, либо используя ВК, например Wheel.AddIn (http://1c.proclub.ru/modules/mydownloads/personal.php?cid=81&lid=2714). Реализацию сего оставляю вам для самостоятельного упражнения.


опять...Есть ли обработки которые из 7.7 переносят данные в V8 ? | База знаний | mista.ru

опять...Есть ли обработки которые из 7.7 переносят данные в V8 ?

Maniac
23.09.2004 19:25 		Полный тест проблемы
http://itland.ru/forum/index.php?showtopic=2330
И
http://www.kuban.ru/forum_new/forum9/files/200259.html
Maniac
6 - 23.09.2004 20:51 		А что так пренебрежительно ?
Мож я неправ, сейчас поищу.
Полазил, ничего по сабжу не нашел. Одни вопросы без ответов.
Самая близка тема
http://www.forum.mista.ru/topic.php?id=8596&area=exchange
ито безрезультатная. Это База знаний ?
Michael99
20 - 23.09.2004 21:17 		(0)Вот ссылка на одну из обработок :
http://itland.ru/rep/index.php?id=134
Maniac
25 - 23.09.2004 21:21 		(20) видел, в ней ошибка валится. Мне уже прислали несколько с открытым кодом. Написать через ОЛЕ не вопрос. Но это не решение задачи. Боюсь что решить её можно только написанием выгрузки из 7.7 под правила конвертации 2.0 и обработку для загрузки в 8.0.
Волшебник
26 - 23.09.2004 21:22 		(22) Вообще-то это должны были сделать в 1С, но не сделали.. Может пока ты напишешь, они тоже напишут, вот будет обидно...
Guk
27 - 23.09.2004 21:26 		(26) Обидно будет смотреть на то что напишу я, и то что что напишут в 1С, т.к. я это напишу для своего предприятия, а они это сделают тиражной обработкой...
Maniac
28 - 23.09.2004 21:28 		Задачи такого обмена с помощью КД 2.0:
1) перенос данных из 7.7 любой конфигурации в любую конфигурацию под 8.0.
Как этот обмен будет работать (типы, виды и прочее) полностью ложится на готовую уже в этом плане конфигурацию "Конвертация данных 2.0". именно она корректно сосатвляет правила, и спомощью гибкой достаточно настройки там можно многое сделать.
2) задача использования такого обмена в постоянном режиме между центром и удаленными филиалами. А конкретно имеется филиал, в котором два юзера. Целесообразности ставить туда 8.0 нет (с ихней задачей учета). плюс ко всему файловый вариант (о котором идет много разговоров) говорит сам за себя.

Так вот я считаю что этот обмен самый наилучший вариант. Разовые выгрузки и самописные не катят. Конфигурации под 8.0 будут круто менятся также как и семерочные. Чтобы постоянно сидетть лопатить обмены, по моему просчету нужно будет тратить треть времени работы. нужен универсальный инструмент, каковым является КД 2.0
Моя претензия по сабжу. 1С написала КД 2.0, сделал настройку правил между 7.7 и 8.0 (в ней имеются специальные для этого опции). Но не сделала самого главного, от чего и возник сабж и куча веток на этом форуме, как впрочем и на других у массы народа.
Guk
30 - 23.09.2004 21:33 		(28) Открою тебе тайну...
Данные из 7.7 ав 8.0 переносить бесполезно...
Это даже клинический случай, скорее всего...
Maniac
31 - 23.09.2004 21:36 		(30) ты думаешь ? А я думаю по другому.
Переносил же, даже с той же конвертацией базы в восьмерку а затем обменом с КД 2.0.
У тебя бухи остатки вручную вбивать будут и справочники ?
А если обмен между 7.7 и 8.0 постоянный будет хотя бы!! справочники тоже вручную щелкать. По-моему там все полезно.
Maniac
32 - 23.09.2004 21:37 		(30) обсонования ? про клинический случай может каждый сказать, кого тема не касалась напрямую в работе. А вот доводы ? хотелось бы услышать доводы...
Guk
33 - 23.09.2004 21:41 		(32) Спорить бесполезно.
Мне данные из 3-х программ тащить надо.
1С 7.7, Галактика, Самописка на Oracle.
Из 7.7 на УПП ложится бред. Логика другая...
Maniac
34 - 23.09.2004 21:41 		как например работать с клиентами ? высылать им прайсы, каталоги номенклатуры с ценами (если допустим они работают с нашей номенклатурой), обмениватся коммерческими предложениями ? Вот например в типовых семерки это все есть.
Как работать если клиенты на разных версиях сидят ? Сидеть лопатить специфические обработки ? Да помоему это 20 век..сейчас другие технологии. Вокруг все звиздят про новые возможности 8.0, 1С++, а голимый обмен нужно вручную делать ? Причем каждому, под своё ?
Maniac
35 - 23.09.2004 21:45 		(33) не ну понятно что галимотья может получится без вопросов. Структура то тоже не гибкая может быть.
Например я конфу под семеркой уже приблизил к восьмерочным требованиям (идентификаторы, структуру где надо подправил). Если сейчас мою конфу в КД 2.0 с УПП или УТ правила настраивать, там больше половины совместимо.
Ая планирую использовать в будущем именно схему конфигурация 8.0 и конфигурация 7.7 (которая будет соответствовать по структуре на сколько это возможно с 8.0). остальное скриптами и правилами по КД.
Maniac
36 - 23.09.2004 21:51 		Я в (35) про логику имел ввиду. Мне кое-что понравилось всетаки в УТ. Чего нет ни в одних типовых 7.7 и других прогах которые я видел.
Я в семерке безболезненно реализовал эту логику (то что на мой взгляд было полезным). И планирую что следующая работа будет небесполезна.
Но пока стоит стопорняк. Я не берусб за восьмерку, пока не будет принят проект на переход. Переход возможет только если клиенты "покатаются" (аля выставик же проходят по новым моделям машин, можно покататся запросто). тоесть хотят чтобы я загрухил в типовую восьмерки данные и они там попробуют на том что им близко и понятно (номенклатура, контрагенты, принципы работы их заказов, остатков). Люди работают, сидеть тыкатся просто так им не хочется.


1C и С++ | База знаний | mista.ru

1C и С++

CYuri 11.06.2004 09:20 | Люди поможите! Как из С++ создать новый документ, загрузить в него данные и записать. В частности проблема состоит только в том что русские буквы не компилируются в С++.
romix 47 - 05.07.2004 11:07 | ответ на (0) на самом деле очень простой: Doc.SetAttrib(ИмяАтрибута,Значение);
SnarkHunter 48 - 05.07.2004 12:27 | У него же "русские буквы не компилируются"...
romix 49 - 05.07.2004 12:31 | (48) И правильно делают... SetAttrib позволяет установить русскоязычные атрибуты, т.к. они в кавычках. Doc.SetAttrib("Комментарий","Ж-ж-ж-ж-ж-ж");


Как закрыть файл Excel без запроса на сохранения из 1С? | База знаний | mista.ru

Как закрыть файл Excel без запроса на сохранения из 1С?

kadr
24.08.2004 09:37 		Файл открыт программно из 1С.
Если сделать так
Excel.Workbooks.Close(), то появляется вопрос о сохранении.
В документации по VBA говорится сделать так
Workbooks("BOOK1.XLS").Close SaveChanges:=False
Но как "засунуть" этот параметр "SaveChanges:=False" в конструкцию языка 1С?
kadr
3 - 24.08.2004 10:12 		Вот как надо было:
Excel.DisplayAlerts = 0;
Excel.Workbooks.Close();
Excel.DisplayAlerts = 1;


Агенты в 1С | База знаний | mista.ru

Агенты в 1С

Maxver123 18.05.2004 19:05 | Помогите Пожалуйста. Прикрутил к конфиг. Волшебника какие у него свойства имеется в виду что-бы можно было сделать как в 1С предупреждение, и другие интересные вещи Заранее признателен
Michael99 2 - 18.05.2004 20:09 | Посмотри на http://avb1c.narod.ru/msagent1.html
427 3 - 18.05.2004 21:52 | У каждого агента свой набор методов и движений.... в общем случае....
GrayT 4 - 19.05.2004 00:28 | (2)Это одна ссылка из нескольких. (1) и 3 Думаю вопрос должен был звучать примерно так: Каждый из агентов умеет что то свое. Как узнать что умеет каждый конкретный агент. В свое время я прикручивал агента с голосовым движком. Фразу "А не попить ли нам пивка" пришлось снять. Часто в тему попадал :) Но ограниченность возможностей напрягала. Я знаю, что агент "Волшебник" умеет много движений, но как их вызвать не знаю. Как узнать?
BorisBiz 5 - 19.05.2004 08:48 | Движения агента http://winchanger.narod.ru/system.html а вот тут http://characters.narod.ru агентов тьма :)


Как закрыть приложение открытое через OLE | База знаний | mista.ru

Как закрыть приложение открытое через OLE

tiko 30.08.2004 16:08 | Здравствуйте! Делаю загрузку из Exel, все ок. Но вот в памяти остается процесс Exel и повторно не дает открыть этот файл. Пробовал ExcelApp=СоздатьОбъект("Excel.Application"); ... ExcelApp = 0; не убивает процесс Как правильно после загрузки в 1С грохнуть процесс?
Den 2 - 30.08.2004 16:10 | (+1) ExcelApp.Quit()


нужно из другой базы сделать выборку документов | База знаний | mista.ru

нужно из другой базы сделать выборку документов

Oksa 21.05.2004 12:59 | при инициализации базы требует вручную каждый раз ввода пароля пользователя. можно как-нибудь программно прописать этот пароль, чтоб не вводить его ручками? запаривает Если ИБПр.Initialize(ИБПр.RMTrade, "/d"+КаталогИБПриемника+ " /m /n"+ИмяПользователя(), "No_splash_show")
SiMazx 2 - 21.05.2004 13:07 | /nИмя /pПароль


Проигрывание WAV ? | База знаний | mista.ru

Проигрывание WAV ?

Crystalizer 02.06.2004 13:38 | Может такое 1С 7.7 без эктив-иксов дополнительных?
GrayT 1 - 02.06.2004 13:54 | Через ЗапуститьПриложение, но красота зависит от приложения по умолчанию
GrayT 6 - 02.06.2004 15:56 | (4)Так я и сказал - все зависит от приложения по умолчанию. Я в свое время сам с этим мучался - так написал что-то на дельфе - играет и закрывается. А на ИТС было описание как ВК делать и там в качестве примера было как проигрыватель сделать - опять же не ActivX ;)
¶ 8 - 02.06.2004 21:53 | А типа так? http://www.delphimaster.ru/cgi-bin/faq.pl?look=1&id=988622528&n=22


Зависает процесс 1С ОЛЕ только при работе более 20 мин.... | База знаний | mista.ru

Зависает процесс 1С ОЛЕ только при работе более 20 мин....

Kreont 03.08.2004 10:46 | Есть обработка которая делает обмен документов между базами за период. И проявляется такой вот глюк: 1.Если к примеру задать перекидку документом за неделю то процес ОЛЕ почти не подвисает.(2% что зависнет ;-) 2. Если задать за месяц - 100% зависнет. 3. При етом задача исполняется до конца, зависание происходит при самом завершении.(Даже чуточку после него , тоесть база 1С вызывающая процес 1С ОЛЕ не зависает, и дальше работает, но сам процесс ОЛЕ висит в памяти). Подскажите как лечить. (А то не могу даную задачу поставить на ночь, утром висит и ночью переиндексация не проходит)
427 1 - 03.08.2004 10:54 | есть такая фишка... проверь - может ОЛЕ база сообщение выкидывает - тогда 100% зависнет...
palpal 3 - 03.08.2004 11:03 | есть такая мулька, и связана с объемом выкачки, например у меня виснет когла по OLE выгребаю около 12 000 документов не зависимо от периода или чегото другого, как бороться не знаю. Приходится работать по кускам - мелкими набегами по 5 - 7 тыс доков.
Valery 5 - 03.08.2004 11:31 | Может попробовать удалить процесс по окончании задачи, присвоив OLE объекту 0.
Kreont 6 - 03.08.2004 12:02 | (5) Такое в коде присуствует (+ присвоение всем переменным = 0, + принудительное зевершение работы). Проблемка в том что виснет не обработка, она то как раз исполяется до конца и коректно завершается, а виснет именно сотворенный процесс ОЛЕ.


Как вызвать процедуру из глобального модуля из Delphi | База знаний | mista.ru

Как вызвать процедуру из глобального модуля из Delphi

AndreiL 31.07.2004 14:49 | Как вызвать процедуру из глобального модуля из Delphi 1С используется как Ole Server
IAm 10 - 31.07.2004 15:43 | Ole1C.ExecuteBatch(ИмяПроцедуры);


Перенос документов из Excel в 1С | База знаний | mista.ru

Перенос документов из Excel в 1С

Sash 09.07.2004 00:11 | Подскажите, может кто знает, есть ли какие-нибудь стандартные обработки для переноса документов из Excel в 1С, просто програмка вроде Шлюз Excel->1C 1.0 это хорошо, но как тогда автоматизировать вызов этой програмки с нужными параметрами... Примеры переноса доков(конкретных)с благодарностью приму на мыло. СПАСИБО!
Petrovich 6 - 22.07.2004 05:55 | http://1c.klim.org/pafiledb/pafiledb.php?action=file&id=73


При печати через шаблон в Word, как задать путь к файлу с картинкой ? | База знаний | mista.ru

При печати через шаблон в Word, как задать путь к файлу с картинкой ?

Gary
28.07.2004 11:09 		Суть проблемы: есть файл Word-овский, с шаблоном документа, из 1С заполняю через OLE-объект поля необходимой информацией, но есть и картинки (фото) в каталоге. Можно ли их каким образом "передать" в Word ?
Композитор
1 - 28.07.2004 11:24 		Передавайте путь доступа к картинке.
Gary
2 - 28.07.2004 11:36 		Если бы я знал какой именно объект в ворде применить, да его методы... Подскажи, если знаешь ?
Композитор
3 - 28.07.2004 11:41 		Selection.InlineShapes.AddPicture FileName:= _
"C:\Documents and Settings\Мои документы\Мои рисунки\Образец.jpg", _
LinkToFile:=False, SaveWithDocument:=True

Код, который я взял из макроса, вставляющего картинку. Путь до картинки наверняка хранится в справочнике. Например, имя файла картинки номенклатуры логично иметь или в справочнике Номенклатура или в подчиненном справочнике Картинки.
Gary
4 - 28.07.2004 11:49 		Ага, направление понял ... Только я хотел именно связывать картинку с файлом.
Получается у меня в документе уже есть две картинки, они каким объектом там зовутся, как "вытащить"-то их для изменения свойств ? Названия у них как я понял "Рисунок1" и "Рисунок2", а объект Shapes ?
Композитор
5 - 28.07.2004 11:51 		Процедура ОткрытьДокументWORD(ИмяДок)
Word=CreateObject("Word.Application");
Word.Visible=1;
Word.Documents.Open(ИмяДок);
Word.Selection.InlineShapes.AddPicture("C:\Documents and Settings\Шкляев\Мои документы\Мои рисунки\Образец.jpg");
КонецПроцедуры
Gary
6 - 28.07.2004 11:58 		(5) Я ж говорю, это немного не то... Он просто добавляет картинку, а у меня уже есть внутри картинки, мне их менять надо ! Пробую поковырять Shapes
romix
11 - 28.07.2004 15:44 		Короче надо сохранять файл не с внедренными, а с внешними картинками.
Где-то в свойствах документа есть переключение. У меня всегда получался файл с внешними картинками, когда я переводил страницу из HTML в Word (делал Сохранить как).


Не могу получить значение поля, являющегося перечисленем | База знаний | mista.ru

Не могу получить значение поля, являющегося перечисленем

RomanXXX
07.07.2004 09:18 		Не могу получить значение поля, являющегося перечисленем. Например Справочник.Сотрудники.ХарактерРаботы = Перечисление.ХарактерРаботы.ТрудовойДоговор, При выгрузке справочника Сотрудники из бухгалтерии в Зарплату с помощью OLE не могу получить значение Справочник.Сотрудники.ХарактерРаботы - выгружаемый объект.
Gavrila
1 - 07.07.2004 09:37 		(0) Если не можешь получить в базе ОЛЕ, то вот:
БазаОЛЕ.EvalExpr("Перечисление.ПолучитьАтрибут(""" + ВидПеречисления + """)").ЗначениеПоИдентификатору(ИдентификаторПеречисления);
где ВидПеречисления - строка с названием вида перечисления, а ИдентификаторПеречисления - строка с идентификатором значения перечисления
Gavrila
15 - 07.07.2004 12:19 		(14) Вот пример для справочника "Контрагенты", где реквизит "ВидКонтрагента" - тип Перечисление.ВидыКонтрагентов. Все работает
//*******************************************
Процедура Сформировать()
// Получаем доступ к OLE объекту V7
БазаОле = СоздатьОбъект("V77.Application");
КаталогБазыОЛе = "D:\1cv77\МояБаза\";
ПользовательОле = "";
ПарольОле = "";

МонопольныйРежимOLE = " /m";
// для немонопольного запуска указать пустую строку!

ЗапускБезЗаставки = 1;
// для появления заставки поставьте "0"

РезультатПодключения =
БазаОле.Initialize(БазаОле.RMTrade , "/d" + """" +
Сокрлп(КаталогБазыОле) + """ /n" +
Сокрлп(ПользовательОле)+ " /p" +
Сокрлп(ПарольОле) + МонопольныйРежимOLE ,
?(ЗапускБезЗаставки = 1,"NO_SPLASH_SHOW",""));

Если РезультатПодключения = 0 Тогда
Предупреждение("Ошибка подключения.");
КонецЕсли;

СпрОле = БазаОле.EvalExpr("СоздатьОбъект(""Справочник.Контрагенты"")");
СпрОле.ВыбратьЭлементы();
Пока СпрОле.ПолучитьЭлемент() = 1 Цикл
Сообщить("К:" + СокрЛП(СпрОле.Код) + ", Н:" + СокрЛП(СпрОле.Наименование) + ", Вид:" + СокрЛП(СпрОле.ВидКонтрагента.Идентификатор()));
КонецЦикла;

КонецПроцедуры
RomanXXX
16 - 07.07.2004 12:38 		Я конечно благодарен тебе за твою помощь, спасибо, но результат остается прежний, может твой способ не работает потому что Сотрудник.ХарактерРаботы периодический?
Спр.ХарактерРаботы.Идентификатор()=неизвестный объект Идентификатор()
Спр.ХарактерРаботы = "OLE"
Gavrila
17 - 07.07.2004 12:42 		(16) естесственно
Попробуй так
Если Сотрудник.ХарактерРаботы.Получить(Необходимая_Дата).Идентификатор() = БазаОЛЕ.EvalExpr("Перечисление.ХарактерРаботы.ТрудовыеОтношения.Идентификатор()") Тогда
// Принадлежит ...
КонецЕсли;


Работа с Office через OLE | База знаний | mista.ru

Работа с Office через OLE

Руслан 30.06.2004 09:08 | Никто случаем не знает где достать полные описания, по объектам (методам, свойствам объектов), при работе с Excel и Word, через OLE, в инете есть лишь обрывки (куски кода). А полного описания найти нигде не могу :(
Gavrila 1 - 30.06.2004 09:10 | посмотри в хелпе визуала басика :)
¶ 2 - 30.06.2004 10:11 | Поищи файлы vbawd*.chm, vbaxl*.chm Чё-то с утра прямо обвал вопросов по Оффису!
romix 3 - 30.06.2004 10:51 | Обычно советуют использовать Запись макросов, она записывает то, что ты делаешь (например, в Excel) в формате свойств и методов. Т.е. это самый простой способ узнавать такие вещи. Константы переводить в числа (в 1С катят именно числа) можно при помощи функции MsgBox (выводит окно сообщения). Булевы константы: 0=False, -1 (минус 1)=True.


Word из 1С | База знаний | mista.ru

Word из 1С

maksik 23.06.2004 22:27 | Коллеги если кто нибудь создавал таблицы в Worde из 1С подскажите как это сделать
Warlock 2 - 23.06.2004 22:51 | (0)Связываешься с Вордом через OLE, а далее используешь Tables() с его свойствами и методами... Конкретнее можешь прочитать в файлике vbaxl??.chm, который должен быть в папке Microsoft Office\Office??\1049 ?? зависит от версии офиса...
¶ 3 - 23.06.2004 22:59 | (2) vbawd*.chm


Не получается заполнить таблицу Word-овского шаблона :-( | База знаний | mista.ru

Не получается заполнить таблицу Word-овского шаблона :-(

Crystalizer 3 - 11.06.2004 12:14 | off: где есть примеры работы 1С с вордом?
ezh 4 - 11.06.2004 12:27 | http://itland.ru/forum/index.php?showtopic=2854&hl=word


Как через Ole-Automation связаться с базой Oracle 9.2. Очень надо!!! | База знаний | mista.ru

Как через Ole-Automation связаться с базой Oracle 9.2. Очень надо!!!

Александр 08.06.2004 14:10 | Как через Ole-Automation связаться с базой Oracle 9.2. Очень надо!!!
* 1 - 08.06.2004 15:30 | http://www.orafaq.com/faqoo4o.htm


OLE: Вызов Word с конкретным именем файла, по образцу Excel (как в учебнике | База знаний | mista.ru

OLE: Вызов Word с конкретным именем файла, по образцу Excel (как в учебнике

Vitaliy
07.06.2004 14:02 		Есть файл NNN.doc, имя файла в поле.

Как его коретно вызвать из 1с, чтобы открался в Ворде? зараннее спасип.
mszsuz
1 - 07.06.2004 14:06 		Word = СоздатьОбъект("Word.Application");
MyFile = Word.Documents.Open(СокрЛП(Файл));
Asmody
2 - 07.06.2004 14:09 		Word.Visible=-1;


OLE | База знаний | mista.ru

OLE

Oksa 03.06.2004 12:46 | для акта взаимозачета мне нужно вытащить документы из базы прошлого года, ОЛЕ дает работать с реквизитами документов без проблем, но мне ж надо подтянуть документ в рабочую базу как объект, типа ТЗ.Документ=Док.ТекущийДокумент() - как в рабочей базе, а потом когда надо для расчетов оперировать строками этого документа. это ж чекнуться можно, если все табличные части документов загонять в ТЗ с названиями услуг и векселями (как хотят бухи) с суммами без НДС, НДС и т.д. и не хочу засорять базу ненужными документами за прошлый год. подскажите чего-нибудь, пожалуйста
Asmody 1 - 03.06.2004 13:01 | объекты по ОЛЕ не передаются. можно попробовать поиграться с ЗначениеВСтроку() и ЗначениеВСтрокуВнутр().
Gavrila 2 - 03.06.2004 13:03 | Можно попробовать так: ТЗ.Документ = БазаОЛЕ77.Док.ТекущийДокумент(); посмотри здесь -> http://zone1c.narod.ru/docs/other/ole1c.htm :)
Oksa 3 - 03.06.2004 13:06 | не понимает ОЛЕ ТекущийЭлемент()... это только для текущей базы


VB vs 1C или как скрестить ежика с гиеной | База знаний | mista.ru

VB vs 1C или как скрестить ежика с гиеной

ФАКОэмульсификатор 26.05.2004 12:28 | Привет всем. Подбросьте плиз линки на ресурсы по работе с 1С из VB. Заранее благодарен.
Волшебник 3 - 26.05.2004 13:18 | 8.0 позволяет обращаться к себе через COM-соединений COM-объект V8.ComConnector
romix 5 - 26.05.2004 14:54 | А оно надо? Скрещивать ежиков лучше имхо через XML или другие файлы обмена.
gleb64 6 - 26.05.2004 15:42 | Если использовать SQL версию, то можно создавать свои Stored Procedure и т.д. и через них методами VB (ADO) работать с таблицами 1С.


OLE-OLE-OLE | База знаний | mista.ru

OLE-OLE-OLE

Миха 25.05.2004 12:10 | Возникла проблема при переносе по технлогии ОЛЕ реквизита типа строка неограниченной длины. Никак не могу заполучить значение загружаемого реквизита, кто-нить подскажет как бороться?
Волшебник 1 - 25.05.2004 12:38 | Может быть здесь есть ответ: http://mista.ru/articles1c/ole.htm
Миха 4 - 25.05.2004 14:37 | ..... V7=СоздатьОбъект("v77.Application"); ..... ДокОЛЕ = V7.CreateObject("Документ." + Назв); ЗначОле = ДокОЛЕ.ПолучитьАтрибут(Рекв.Идентификатор); //собстно та сама строка неогр. длины ...... никак не могу к ней подступиться и получить значение, 1Ска возвращает значение OLE - якобы агрегатный тип...
Valery 5 - 25.05.2004 14:46 | Попробуй так ДокОЛЕ.evalExpr("ПолучитьАтрибут(Рекв.Идентификатор)")


OLE | База знаний | mista.ru

OLE

Mazay
24.05.2004 18:11 		//V77 = СоздатьОбъект("V77.Application");
//V77.Initialize(V77.RMTrade, Стр, "NO_SPLASH_SHOW");
//СпрН = V77.CreateObject("Справочник.Номенклатура");
Только что все работало :(
Теперь матерится - Неудачная попытка создания объекта (Справочник.Номенклатура): 0
Макс
1 - 24.05.2004 18:16 		Такого просто так не бывает.
PS:Значит в той базе нет такого справочника...
Волшебник
2 - 24.05.2004 21:52 		Может быть имя справочника набрано не верно. Например, в буквы затесалась английская.
kvm
3 - 25.05.2004 01:27 		Поставь проверку открытия базы. На всякий случай.
Valery
5 - 25.05.2004 12:55 		Возможно предыдущее завершение было аварийным и требуется монопольный режим


1C+Excel | База знаний | mista.ru

1C+Excel

AlexMan 11.05.2004 18:57 | Имеем некоторый отчет в 1С в котором в одной колонке пишем в свойствах ячейки (в конфигураторе) : Тип-Текст в самом поле пишем чтото вроде : "=R11C11+R12C12" затем после формирования отчета в 1С (в режиме предприятия) сохраняем его как файл Excel , открываем получившийся файл и что же значение колонки НЕ ВЫЧИСЛЕНО!!! и не вычисляется до тех пор пока не "встанеш" на одну из ячеек затем в строку формул и там нажмеш Enter и так с каждой ячейкой колонки как можно сделать чтобы значения в Excel после сохранения из 1С считались автоматически?
AlexMan 1 - 11.05.2004 21:48 | Наверное я криво задаю вопрос... или он никого не заинтерисовал , попробую заинтерисовать описываю жизненную ситуацию: прайс сохраняется в Excel , по эл. почте отсылается клиенту клиент помимо количества товара которое хочет взять указывает свою скидку (в процентах) - по этому надо расчитать уже на месте (т.е. в Excel) новую сумму , вот это как раз и не выходит...
здысь 2 - 11.05.2004 22:07 | Помоему F9 или Schift+F9, это перерасчет листа. А еще в этой-же книге скопировать полностью лист, мне помогало.
AlexMan 3 - 12.05.2004 13:18 | F9 и Shift+F9 мне не помогало а вот копировать не пробовал (попробую дома завтра напишу результат).
Ssem 4 - 12.05.2004 15:00 | попробуй в настройках Excel установить в ярлыке Calculation (в русском варианте наверное Калькуляция) Automatic. Замечал не раз, что Excel сам переводит режим Automativ в Manual. (Почему??? не отслеживал.) Тогда действительно нужно давить F9 или Shift+F9...
AlexMan 6 - 12.05.2004 15:38 | (4) -(5) в настройках Excel стоит "автоматически" все равно не расчитывает ...
AlexMan 7 - 13.05.2004 13:32 | (2) копирование листа не помогает (куда только не копировал) нажимал "Пересчет листа" в Сервис/Параметры/Вычисления не считает эту колонку хоть ты тресни.... блин чего делать то?
Frol 8 - 13.05.2004 13:58 | Я думаю, проблема в формате той строки "=R11C11+R12C12",наверняка в Excel-е строка, содержащая формулу для вычисления имеет совсем не строковый формат. При вводе такой строки Excel (после нажатия злополучной клавиши Enter) переводит её в свой формат ( типа формат формул...). Тебе лучше всего делать по другому... Создай шаблон листа Excel с формулами для расчёта, в который будешь выгружать нужные данные из 1С с помощью обработки. Или по другому... интереснее, но и сложнее. Поройся в VBA в Excel-е, наверняка там есть методы у ячейки, которые задают такой формат. Тобишь, с помощью обработки создавай сам файл Excel. Надеюсь, ты знаешь, как можно выгрузить что-нибудь используя OLE. Успехов!
AlexMan 9 - 13.05.2004 19:42 | (8) Как выгружать что то через Оле я знаю (честно говоря я не вижу принцыпиальных отличий между способами 1 и 2 и там и там надо использовать Оле). Только через Оле работать медленно будет (прайс не детский 3000 строк) да и геморойно это слишком надо будет ячейки Excel програмно "рвать", "соединять" с цветами гемороится и т.д.. Вобщем не тот вариант учитывая что весь прайс в 1С распрекрастно формируется и юзерам не составляет труда самим его в Excel сохранить талько с этой колонкой беда . может лучше в Excel чевонибудь дописать чтобы эту колонку в свой формат переводил?
GrayT 10 - 13.05.2004 20:56 | (8)Прав похоже. Я попробовал макрос ActiveCell.FormulaR1C1 = ActiveCell.Value - расчитал текущу ячейку
427 11 - 13.05.2004 23:10 | (10) да... Он прав.... (0) надо... (все через ОЛЕ) отключить автовычисления (будет быстрее заполняться через ОЛЕ, т.к. не будет перевычислений) заполнить какие надо ячейки включить автовычисления дать команду перерасчета на всякий случай формрулы пишутся только в формате R1C1 в свойство FormulaR1C1..... все будет нормально... Прайс в 3000 строк - абсолютно детский.... 14000-15000 - уже более менее нормальный... (косметика, парфюмерия, бытовая химия) например губная помада 8 серий по 24 цвета (9*24) уже 216 строк.... каждый цвет в прайсе отдельно, потому что есть ходовые и неходовые цвета... В моем прайсе клиент просто вбивает количество - сразу видит сумму по строке товара и всего по заказу... Затем пинает прайс-заказ обратно и на фирме он просто всасывается в Счет или РасхНакл с проверкой остатков.... Что есть - сразу на отгрузку.... только там нужно использовать еще кучу всяких методов... чтобы защититься от дурости покупателя и подделки прайс-заказа...
AlexMan 12 - 14.05.2004 15:03 | (10)-(11) блин через Оле как я уже писал муторно слишком, а код ActiveCell.FormulaR1C1 = ActiveCell.Value (из 10) где писать надо не в Excel случайно?
Frol 13 - 14.05.2004 15:12 | (12) всё через ОЛЕ, т.е. в 1С-ке... типа Excel.cells(K,S).FormulaR1C1= Excel.cells(K,S).Value и т.д. где, Excel - это объект листа.
Estet 15 - 14.05.2004 17:59 | Здравствуй, Александр:) Если формулы расположены в одном столбце, через Меню: [Данные] -> [Текст по столбцам...] можно автоматом преобразовать весь столбец(предварительно выделив его целиком)
AlexMan 16 - 14.05.2004 18:41 | Привет Игорек я тебе кстате тоже писал ответ про Штатную обработку проведения. Дома попробую. Зарание благодарен.
427 17 - 14.05.2004 19:00 | В эекселе есть автоматическое написание программ... Изучи его и ..... будь счастлив - эксель все будет делать сам ....


Нужна обработка по переносу документов по ОЛЕ из одной базы в другую | База знаний | mista.ru

Нужна обработка по переносу документов по ОЛЕ из одной базы в другую

Макс 17.05.2004 14:04 | Нужна обработка по переносу документов по ОЛЕ из одной базы в другую СРОЧНО
Макс 2 - 17.05.2004 14:48 | Зачем изобретать велосипед, если он уже есть...
Valentin_Azheronok 4 - 17.05.2004 20:57 | Hippo.ru и поиск, а вообще сегодня ghv на первой странице по 7.7


Как под SQL в версии 1С 7 запускать хранимые процедуры? | База знаний | mista.ru

Как под SQL в версии 1С 7 запускать хранимые процедуры?

valex 17.05.2004 07:13 | Мне необходимо запустить хранимую процедуру из БД, которая находиться на MS SQL Server 2000
Волшебник 1 - 17.05.2004 08:33 | может быть через ODBC?
aleks_ru 2 - 17.05.2004 11:12 | exec "Имя сохраненки" Best Regards Александр


ввод документов в 1С | База знаний | mista.ru

ввод документов в 1С

Maks 07.05.2004 09:48 | Здрастуйте! Возможно ли реализовать в комплексной или торговле и складе возможность ввода первичных документов (в частности поступление товара) через сканер обычный планшетный? То есть сканируем документ (накладную) и он должен попасть в журнал документов т.е. пройти весть документооборот как если бы мы ввели его вручную. Как вариант можно использовать документ после fineriadera. Возможно ли это вообще и если возможно то хотя бы наметки как это можно реализовать.
SiMazx 3 - 07.05.2004 12:18 | Finereaderom - в Excel, оттуда через OLE...
GrayT 7 - 07.05.2004 15:24 | Ну как закачать в эксель, ты кажись понял - fineRider твой друг :). А дальше либо по форумы поищи, тут уже много об этом говорилось, либо http://www.sinor.ru/~my1c/knowhow/exel_ole.html
Skorp 8 - 07.05.2004 20:40 | 2(0) StrMatch писалась специально для этого


OLE Automation и 1С | База знаний | mista.ru

OLE Automation и 1С

meO 12.05.2004 11:07 | Использование 1СV7.7 как OLE сервер
meO 2 - 12.05.2004 11:10 | Помогите кто чем может.. Как на С++ получить доступ к конфигурации 1С
romix 3 - 12.05.2004 11:56 | Через XML по-моему лучше обмениваться... Можно больше опасных ошибок выявить до их появления.


связь AutoCAD с 1С с помощью VBA | База знаний | mista.ru

связь AutoCAD с 1С с помощью VBA

Berlin 09.05.2004 23:31 | Подскажите, возможно ли написание проги для редактирования объектов 1С с помощью VBA (из AutoCAD). Или,например, перегонять данные в Excel или Access, а затем в 1С. Может у кого-нибудь есть такой опыт?
GrayT 1 - 09.05.2004 23:53 | АвтоКАД стал потдерживать ВБА? 1С является сервером ОЛЕ, так что из всего что это умеет - по идее можно. Но, имхо, геморойно. А что за данные из автокада в 1С гнать надоть?
Berlin 2 - 09.05.2004 23:57 | текстовые данные. Точнее нужно с помощью VBA в 1С создать таблицы и в них занести определенный текст. Это возможно?
427 3 - 09.05.2004 23:57 | Открой 1С через ОЛЕ и дрючь ее... Только шибко неторопливо это будет...
GrayT 4 - 10.05.2004 00:01 | Ну текст, так текст. Возможно. Возможно и конвертер написать, на основе XML. По задаче смотри


Вызов внешнего приложения из 1С | База знаний | mista.ru

Вызов внешнего приложения из 1С

Вик
02.05.2004 11:42 		Добрый день!
Не подскажет ли кто, есть ли возможность выдать команду вызова внешнего приложения из 1С. Ну, например, по принципу команды RUN из фокса, что нибудь типа дос-команды, или START...
GrayT
1 - 02.05.2004 11:53 		ЗапуститьПриложение(<?>);
skunk
2 - 02.05.2004 12:13 		можно и system(<?>)
Вик
4 - 02.05.2004 13:18 		Кстати, а можно ли сделать так, чтобы это приложение осталось на переднем плане?
А то оно тут же прячется за окном 1С
427
5 - 02.05.2004 16:00 		Поиграйся с обоими вызовами ....
Вик
6 - 02.05.2004 23:40 		Поигрался. ЗапустиьПриложение(?) работает прекрасно!!! только прячет вызванное окно под 1С. Спокойно могу передать просто имя файла достаточно произвольного типа, и эта штука откроет файл хоть вордом, хоть экселем, хоть почтовой программой, и т.д. С System этого не получается...
skunk
8 - 02.05.2004 23:42 		как раз этим и различаються
Вик
9 - 02.05.2004 23:43 		А как же заставить держать открытый файл перед глазами?
skunk
10 - 02.05.2004 23:45 		тогда имей олю
Вик
11 - 02.05.2004 23:50 		Т.е. анализ типа файла, создание объекта соответствующего типа, активизация, передача команды на вывод окна на передний план...?
а может есть возможность спрятать свое окно на задний план?
Вик
13 - 03.05.2004 00:07 		Ну на ВФП я писал примерно так -
TmpSheet=CreateObject('Excel.Sheet')
on error do myerror with ;
ERROR(),MESSAGE(),MESSAGE(1),PROGRAM(),LINENO()
if __ij>0
=__resume([Не могу вызвать EXCEL])
exit
endif
wait wind [Ждите, готовлю прайс-лист] nowait
xlObj=TmpSheet.Application
xlObj.WINDOWSTATE=-4140 && minimized
xlObj.VISIBLE=.T.
xlObj.ScreenUpdating=.F.
xlObj.DisplayAlerts=.F.
xlObj.IgnoreRemoteRequests = .t.
Ну и т.д., в конце
XlObj.EnableEvents=.T.
XlObj.ScreenUpdating=.T.
XlObj.DisplayAlerts=.T.
XlObj.WINDOWSTATE=-4137 && maximized
xlObj.IgnoreRemoteRequests = .f.

А здесь, что-то подобное?
skunk
14 - 03.05.2004 05:21 		сорри уснул... первомай... у мамы, денюха ну и все такое...

в ЖКК есть пример с екселем... тут на форуме не один раз приводилось...

к примеру
http://www.forum.mista.ru/topic.php?id=283#msg4
GrayT
15 - 03.05.2004 09:40 		Или тут
http://www.forum.mista.ru/topic.php?id=3955
Вик
16 - 03.05.2004 09:58 		Большое спасибо, это то, что нужно, но не все.
Если ТипФ="XLS" Тогда
Док=СоздатьОбъект("Excel.Application");
Док.Workbooks.Open(ИмяФ);
Док.Visible = 1;
ИначеЕсли ТипФ="DOC" Тогда
Док=СоздатьОбъект("Word.Application");
Док.Documents.Open(ИмяФ);
Док.Visible = 1;
ИначеЕсли ТипФ="EML" Тогда
Док=СоздатьОбъект("???.Application");
Док.???.Open(ИмяФ);
Док.Visible = 1;
ИначеЕсли ТипФ="HTM" Тогда
Док=СоздатьОбъект("???.Application");
Док.???.Open(ИмяФ);
Док.Visible = 1;
КонецЕсли
???


1с7: Как делается перебор строк в файле Excel? | База знаний | mista.ru

1с7: Как делается перебор строк в файле Excel?

Tren
10.11.2004 11:09 		Нужно открыть файл EXcel, просмотреть все его страницы,
все строки, и все ячейки для поиска некоторого значения.
Пустяковый вопрос: как сделать цикл по строкам и ячейкам?
По листам просто - от 1 до Excel.WorkSheets.Count,
а как в Excelе задается количество непустых строк на каждом листе и
количество непустых ячеек в каждой строке?
Лист.Count не проходит, говорит "Поле агрегатного объекта не обнаружено".

Excel = СоздатьОбъект("Excel.Application");
РабочаяКнига=Excel.WorkBooks;
РабочаяКнига.Open(ИмяФайла);

Для НомерЛиста = 1 По Excel.WorkSheets.Count Цикл
Лист=Excel.WorkSheets(НомерЛиста);

// цикл по строкам
Для НомерСтроки = 1 По Лист.Count Цикл
// цикл по колонкам
Для НомерКолонки = 1 ??????? Цикл
Значение=Лист.Cells(НомерСтроки, НомерКолонки).Value;
Сообщить("Значение= " +Значение);
КонецЦикла;
КонецЦикла;
КонецЦикла;
kadr
1 - 10.11.2004 11:19 		Попробуй метод Selection, т.е что-нибудь вроде Selection.End(xlToRight).Select
Но это сработает при условии, что данные у тебя размещены непрерывно
bsg
5 - 10.11.2004 11:55 		//Последняя строка на листе
Лист.Cells.SpecialCells(xlLastCell).Row
alvandael
8 - 10.11.2004 12:07 		(5) Надо так:
ActiveSheet.Cells.SpecialCells(xlCellTypeLastCell).Activate
NastyFrog
11 - 10.11.2004 12:18 		Const xlCellTypeLastCell = 11
NastyFrog
12 - 10.11.2004 12:20 		Можно Лист.Cells.SpecialCells(11).Address разобрать, получишь и колонку и строку
Nite
14 - 10.11.2004 22:14 		Для НомерСтроки = 1 По Лист.Count Цикл // это вообще цикл по всем листам рабочей книги

А номер строки и номер колонки можно попробовать получить с помощью функции где используется activerange или workrange. Уже не помню как точно называется. Суть этого метода в том, что он возвращает только рабочий range, т.е. всю область где есть(набиты) какие-либо данные. Можно самому написать функции в экселе и потом вызывать их из 1С. У меня где-то была похожая обработка.

Про xlLastCell. См. версию VBA. До 97 офиса нет такой.
А вообще есть позитивная обработка для 7-ки :) Которая загрузит Тебе даныые из экселя :)

Всего наилучшего


1С и Visual Basic 6.0 | База знаний | mista.ru

1С и Visual Basic 6.0

Прохожий
19.10.2004 11:49 		Кто-нибудь может помочь в этом направлении?
Сумел подключиться к базе, могу работать со справочниками. Но возникла проблема с некоторыми методами. Например, не могу присвоить переменной значение конкретного элемента справочника (не его реквизита, а именно самого элемента как объекта). Возможно ли это в VB6?
Прохожий
2 - 19.10.2004 12:26 		Dim v7 As Object
Dim Goods As Object

Set v7 = CreateObject("V77s.Application")
result = v7.Initialize(v7.RMTrade, "/DD:\1C\Bases\PS_Clean\", "")
Set Goods = v7.EvalExpr("CreateObject(""Справочник.Номенклатура"")")

Goods.ВыбратьЭлементы
i = 1
Do While Goods.ПолучитьЭлемент = 1
If Goods.ПринадлежитГруппе(Goods.НайтиПоНаименованию("Перец")) = 1 Then
grdGoods.TextMatrix(i, 1) = Goods.Наименование
i = i + 1
End If
Loop

End Sub
///

Выражение Goods.ПринадлежитГруппе(Goods.НайтиПоНаименованию("Перец")) он и не понимает, что не так?
NastyFrog
4 - 19.10.2004 12:57 		Попробуй
If Goods.Родитель.Наименование="Перец" Then
Прохожий
5 - 19.10.2004 13:00 		Да есть такая группа. VB не понимает такие методы как:
Goods.НайтиПоНаименованию()
Goods.НайтиПоКоду()

В данном коде я пытаюсь выгрузить в таблицу только те элементы справочника, которые принадлежат определленой группе. Может это можно сделать как-то по другому? Да и вообще как мне позиционироваться на каком либо элементе справочника (либо документе), кроме как с помощью методов Выбрать и Получить?
Прохожий
6 - 19.10.2004 13:04 		Такой вариант работает. Большое спасибо за помощь. Но, все таки, как можно еще позиционироваться на нужном элементе (либо документе) и работать уже с ним?
NastyFrog
7 - 19.10.2004 13:06 		VB всё понимает
Попробуй
If Goods.найтиПоНаименованию("Перец", 0) = 1 Then
MsgBox Goods.Наименование
End If
НайтиПоНаименованию возвращает 1 или 0 - это не группы, а числа - им не может принадлежать элемент справочника
NastyFrog
8 - 19.10.2004 13:12 		Если ты спозиционируешся во время перебора выборки на элементе мимо порядка выборки, ты выборку похренишь.
If Goods.НайтиПоНаименованию("Перец")=1 Then
myGroupe=Goods.текущийЭлемент
End if
Goods.ВыбратьЭлементы
i = 1
Do While Goods.ПолучитьЭлемент = 1
If Goods.ПринадлежитГруппе(myGroupe) = 1 Then
grdGoods.TextMatrix(i, 1) = Goods.Наименование
i = i + 1
End If
Loop
Прохожий
10 - 19.10.2004 13:20 		Твой пример кода не работает:
myGroupe=Goods.текущийЭлемент не понимает. Понимает -
Dim mygpoupe As Object
Set myGroupe=Goods.текущийЭлемент
Но тогда If Goods.ПринадлежитГруппе(myGroupe) = 1 Then не понимает
NastyFrog
11 - 19.10.2004 13:38 		Sub test()
Dim v7 As Object
Dim Goods As Object
Dim myGroupe As Object
Set v7 = CreateObject("V77s.Application")
Result = v7.Initialize(v7.RMTrade, "/DD:\1C\Bases\PS_Clean\", "")
Set Goods = v7.EvalExpr("CreateObject(""Справочник.Номенклатура"")")

If Goods.НайтиПоНаименованию("Перец", 0) = 1 Then
Set myGroupe = Goods.текущийЭлемент
MsgBox myGroupe.наименование
End If
Goods.ВыбратьЭлементы
i = 1
Do While Goods.ПолучитьЭлемент = 1
If Goods.ПринадлежитГруппе(myGroupe) = 1 Then
'grdGoods.TextMatrix(i, 1) = Goods.наименование
MsgBox Goods.наименование
i = i + 1
End If
Loop

End Sub


DBF: есть ли способ работать с полями MEMO? | База знаний | mista.ru

DBF: есть ли способ работать с полями MEMO?

romix
12.10.2004 21:27 		Есть файлы из другой программы, их надо зацепить в 1С.
Но 1С не умеет работать с полями MEMO.
Есть ли способ это обойти?
bsg
1 - 12.10.2004 21:31 		Делал экспорт из БД на ФоксПРо. Там были мемо-поля. Я обращался к фоксу через ОЛЕ и считывал эти поля.
Охламон
2 - 12.10.2004 22:38 		Мой вариант: берешь bdbfs - досовская версия свободная, и меняешь структуру полей в базе на текстовые, длинной этак 200... ну или на сколько тебе нудно, что б данные влезли, сохраняешь, получаешь файл побольше, но читаемый. Естественно, способ не динамический, но для импорта вполне сносный.
romix
3 - 13.10.2004 17:40 		Есть еще вариант - через ADO:

//*******************************************
Процедура Сформировать()

//РАБОТА С ФАЙЛАМИ DBF ЧЕРЕЗ ADO

Path="c:\"; //Путь к папке с файлами DBF

//Стираем файл, если он уже существует
Если фс.СуществуетФайл("c:\persons.dbf")=1 Тогда
фс.УдалитьФайл("c:\persons.dbf");
КонецЕсли;

//******* ПРИМЕР ЗАПИСИ DBF *******//

//Открываем соединение
DBConn = CreateObject("ADODB.Connection");
DBConn.Open("Provider=Microsoft.Jet.OLEDB.4.0;" +
"Data Source=" + Path + ";" +
"Extended Properties=""DBASE IV;"";");

//Создаем новый DBF и задаем его колонки
DBConn.Execute("Create Table Persons (Name char(50), City char(50), Phone char(20), Zip decimal(5))");

//Пишем строки в наш DBF
DBConn.Execute("Insert into Persons Values('Иванов И.И.', 'Москва','123-45-67','14589')");
DBConn.Execute("Insert into Persons Values('Поляков С.Л.', 'Москва','333-44-55','38215')");
DBConn.Execute("Insert into Persons Values('Сидоров С.С.', 'Москва','222-33-44','54323')");

//******* ПРИМЕР ЧТЕНИЯ DBF *******//

//Делаем выборку
Persons = DBConn.Execute("Select * from [Persons#DBF]");

Пока Persons.EOF=0 Цикл //Цикл по записям DBF

Имя= Persons.Fields("Name").value;
Город= Persons.Fields("City").value;
Телефон=Persons.Fields("Phone").value;
Zip= Persons.Fields("Zip").value;

Сообщить("Имя="+Имя+" Город="+Город+" Телефон="+Телефон+" Zip="+Zip);

Persons.MoveNext(); //Переходим к след. записи DBF
КонецЦикла;

DBConn.Close(); //Закрываем соединение

КонецПроцедуры


Траблы с вызовом Excel | База знаний | mista.ru

Траблы с вызовом Excel

Diman
23.09.2004 17:45 		Приветствую всех!
Такая вот фигня... При обращении к Excelю из V8 через COM хоть убей не работают методы Range, Select :(( Стою на одной ячейке, сдвинуться не можу... Для записи в ячейку работает только FormulaR1C1Local, все остальное говорит - СТРАШНАЯ ОШИБКА!
В чем дело? Может кто напарывался?
Заранее благодарен,
Диман
Diman
3 - 23.09.2004 17:57 		XLApp = ПолучитьCOMОбъект(,"Excel.Application");
XLApp.Activecell.FormulaR1C1Local = "23";
XLApp.Range("A1").Select();

{Форма.Форма(11)}: Ошибка при вызове метода контекста (Select): Неизвестная ошибка
XLApp.Range("A1").Select();

вот, все-то навсего...
Zoom
8 - 24.09.2004 12:57 		xl = Новый COMОбъект("Excel.Application");
Книга=xl.Application.Workbooks.Open(ИмяФайла);
ТекЛист=Книга.WorkSheets(1);
ТекЛист.Cells(1,1).Value = "23";

Вот так оно работает.


Использование .ocx в 1С,или подключение ШтрихТерминала PiccoLink | База знаний | mista.ru

Использование .ocx в 1С,или подключение ШтрихТерминала PiccoLink

Alex_1c_Franch 10.05.2004 18:05 | Можно ли вставить ActiveX object в 1С, в частности драйвер от штрихкод терминала PiccoLine. в VB проблем нет,а в 1С ,если через СоздатьОбъект(\"\") то применяя любой метод ответ - \"неизвестная ошибка!\" .ocx имеет диологовую форму и как ее всавить в 1С - для меня загадка. Пожалуйста помогите если сможете,вопрос жизни или плохой жизни. Заранее благодарен!
SkyP 1 - 27.05.2004 14:13 | Возможна работа с ОСХ только как с внешней ДЛЛ (кое она по сути и является), но только если есть у нее возможность внешнего вызова. Сначала нужно зарегистрировать эту библиотеку: regsvr32 bla-bla-bla.ocx Система должна сказать "....... registered successfully." или что-то в районе этого. А потом можно создавать экземпляр объекта через СоздатьОбъект();
Z1 2 - 27.05.2004 15:03 | (0) Напиши внешнее приложение на VB. Вызывай это приложение с ожиданием окончания приложения. Передача параметров через файл.


Вопрос по весам (торговое оборудование) | База знаний | mista.ru

Вопрос по весам (торговое оборудование)

GrayT 12.03.2004 00:09 | Есть задумка реализовать такую работу: На весы кладем товар, на компе нажимаем кнопочку и получаем новую строку документа, с уже заполненым весом. Кто-нить делал/видел нечто подобное. Что-то сколько я не искал, у меня сложилось ощущение что с весами работают только в сторону весов :(
BorisG 1 - 12.03.2004 00:15 | Это давно решено... Работа с весовыми товарами является еще одним направлением автоматизации учета в розничной и оптовой торговле. Имея в наличие электронные весы, имеющие интерфейс с компьютером, мы получаем возможность передать вес товара в кассовый аппарат или непосредственно в программу для обработки. http://www.retail.ru/encycl/vesi.asp
AlexMan 2 - 12.03.2004 00:18 | Напрасно такое мнение сложилось ... Я работал с весами фирмы Тензо-М так вот должен доложить работа с ними сплошное удовольствие они (фирма Тензо-М) продают тебе весы (твоей организации) и за 100 $ еще и драйвер с помощью которого и осуществляется связь с весами . Далее все как в сказке : Драйвер даже устанавливать не надо 1 раз запустил *.ехе и все драйвер у тебя уже стоит Весы имеют 4 свойства и вроде 4 метода (типа СчитатьВес() или УспокоилисьВесы() вроде того) и все это пишется в коде 1С после Весы=СоздатьОбъект("НеПомнюКакой"); простенько и со вкусом..... мне очень понравилось
Львенок 3 - 12.03.2004 00:25 | А на самом деле это делается все не так. Берутся весы CAS (LP-15), на них выгружается весовой товар (пишется ручками обработка на 1С), а затем на них вешается все что нужно, а они печатают липкие эктикетки с ценой, весом и главное со штрих-кодом. Эти этикетки лепятся на пакетик со взвешеным товаром, а пакетики раскладываются на полки магазина. Покупатель берет пакетики вместе с прочими продуктами, и столь же единообразно они все сканируются сканером на кассе (возможно даже без доработок в 1С), причем правильно. Вот так это все работает у меня не первый год. ___ Искренне Ваш, Львенок.
AlexMan 7 - 12.03.2004 12:38 | +(2) чють не забыл 100$ за драйвер и если у тебя будет 50 весов тогда все равно 100$ круттттттто


Кто-нибудь подключал к 1С сканеры штрих-кодов? | База знаний | mista.ru

Кто-нибудь подключал к 1С сканеры штрих-кодов?

Den 10.04.2004 16:22 | Подскажите, плиз, общие принципы работы 1С со сканером штрих-кода. Каким образом они взаимодействуют и что это за процедура ОбработкаВнешнегоСобытия?
Inside 1 - 10.04.2004 16:36 | Какой сканер. Разрыв KB или RS-232?
Den 2 - 10.04.2004 16:39 | В принципе, не вижу разницы, потому что понятия не имею чем чреват каждый способ. На Metrologic.ru прочитал, что вообще есть сканеры с USB интерфейсом, а какой лучше - не представляю.
Inside 3 - 10.04.2004 16:40 | для 232 ВК ловит в указанном в настройках порту ШК и засылает в ОбработкаВнешнегоСобытия в качестве параметра Данные, что в параметре Источник - нада читать в доке по ВК. ОбработкаВнешнегоСобытия - процедура куда приходит вызов ExternalEvent из ВК.
Композитор 4 - 10.04.2004 16:41 | Порядок подключения сканера описан в ЖКК. В справочнике "Единицы" (комплексная конфигурация) есть реквизит штрих-код. При создании нового элемента справочника "Номенклатура" штрих-код формируется. Открываете (создаете новый) документ "Реализация". Сканируете штрих-код. В накладной появляется новая строка с соответствующей штрих-коду номенклатурной позицией. Если номенклатурная позиция в накладной уже имеется, увеличивается значение реквизита "Количество".
Inside 5 - 10.04.2004 16:41 | (2) Карроче открою тебе тайну. USB работает либо в режиме эмуляции клавы, либо эмулирует COM-порт. Для второго случая нада ставить дополнительные дрова.
Den 6 - 10.04.2004 16:42 | Thank`s. Уже понятнее. А ВК может сгенерить ШК и напечатать его или сварганить картинку, которую можно будет обработать?
Inside 7 - 10.04.2004 16:43 | (2) а разница в том, какую ВК использовать. кое-кто не поддерживает разрыв клавы.
Inside 8 - 10.04.2004 16:45 | ВК(внешняя компонента) для обслуживанию сканера ШК ничего такого и не должна делать. Для печати ШК есть barcode.oсх, но про неё уже столько всего понаписано, что лучче поиши где-нить.
Inside 11 - 10.04.2004 16:49 | А конфа-то какая? Есть обработка НастройкаТорговогоОборудования? Если есть, то там галка про сканер ШК существует. Далее всё а Сервис-Параметрах настраивается.
Inside 12 - 10.04.2004 16:51 | А barcode.oсх в поставке ТиС есть по-моему. А ссылки нету... Только сам barcode. Это просто Active-X control, на Таблицу его кидаешь и фсё...
Львенок 14 - 10.04.2004 19:56 | (7) Что значит "кое-кто не поддерживает разрыв клавы"? Сканеры подключающиеся в разрыв вообще не требуют никаких драйверов и ВК. Работают ВСЕГДА. Ввод штрихкода с них ничем с точки зрения компа не отличается от того, что вы с клавиатуры сами набрали его ручками и нажали энтер. Все драйвера для этого как минимум прошиты в БИОСЕ. Поэтому, если не хочется геморроя, то надо брать как раз сканер который подключается в разрыв клавиатуры - работает прекрасно, без дров, даже под терминалом, позволяет вводить штрих код в любую форму 1С и производить поиск по ШК. Единственное - для оператора он немного менее удобен в том плане, что требует лишнего клика на тот элемент диалога, куда надо ввести данные перед тем, как их ввести (что отчасти решается грамотным порядком обхода). ___ Искренне ваш, Львенок.
skunk 19 - 10.04.2004 20:56 | да и вообще прежде чем юзать сканер, надо подумать о его реальном использовании... не вовсех магазинах он облегчает работу оператора...
Львенок 26 - 12.04.2004 14:05 | (25) Вы меня поймать чтоли пытаетесь на чем-то? Какой-то недалекостью попахивает. Одно предложение другому не противоречит. Если не хочется программисту ничего делать, он берет клавиатурный. Весь геморрой при этом возлагается на оператора(ов). Если программист не против капельку поковыряться (особенно при работе в терминальном режиме), следует брать комовский. Правда операторы все равно спасибо не скажут, ибо обычно не знают от чего избавлены. Во всех магазинах для открытия которых изначально приглашали меня, стоят комовские. В тех магазинах, куда я пришел уже после открытия иногда встречались и клавиатурные, приходилось либо ничего не делать, либо немножко ковырять конфу, чтобы было поудобнее работать. Вы довольны? P.S.: Кстати, я люблю сложные пути. Они дают опыт (иногда - как надо делать, иногда, как не надо делать). ___ Искренне Ваш, Львенок.
Den 27 - 12.04.2004 19:01 | (26) Кстати, работать придется именно в терминальном режиме. Что значит "немного поковыряться" в отношении комовских?
Львенок 28 - 12.04.2004 20:59 | (27) У меня получалось настроить работу COM'овских сканеров физически подключенных к машине клиента (а не к серверу) только в Win2000 server + Citrix MF. Заставить работать мэппинг клиентских портов, как надо, под родными MS'овскими терминалами в Win 2000 и Win 2003 мне не удавалось. Может быть дело не в терминалах, как таковых, а в не вполне правильной работе с витуальными com-портами атолл'овского драйвера сканера, а может быть и в моих ручках. Но с родными терминалами я долго очень бился и не победил (на форумах тоже внятного ничего не сказали), а пот citrix'ом все почти само заработало (нужно было только клиентский порт по net use'у подцепить). Как-то так. ___ Искренне Ваш, Львенок.
Kosyak 29 - 27.05.2004 14:36 | У меня такая проблема: Хочу подключить сканер ШК с разрывом клавы. Захожу через "Настройку торгового оборудования", ставлю нужную галочку и пытаюсь настроить сканер через кнопку "О". А там есть такая байда - внешняя компонента = "scanopos.dll". Так вот, нажимаю "Подключить", выводиться сообщение об ошибке: "Ошибка создания объекта из компоненты c:\...\...\scanopos.dll (отсутствует CLSID)" Что за CLISD и как с ним бороться? Мои настройки для справки: 1С:Предприятие 7.7 конфигурация Торговля+Склад (7.70.006) В обработке Настройка торгового оборудования : модель сканера по умолманию "Стандартный сканер" (реально ZEBEX) в настроках сканера: обработка обслуживания - встроенная внешняя компонента - scanopos.dll программный идентификатор - Scanner Помогите, плиз, чем сможете! Заранее благодарен!
lexa 30 - 27.05.2004 15:39 | если винды 2000 или ХР то у тебя должны быть права локального админа
shura 31 - 27.05.2004 15:42 | (29) А клавиатурный сканер, ИМХО, никаких dll-лок не требует. Просто становишся в поле вводи и жмакаешь кнопку на сканере. Или я не прав?
Kosyak 32 - 29.05.2004 09:00 | Я пробовал и без всякой DLL-ки и нифига, выдает ошибку, что типа не может подключить внешнюю компоненту. shura, а про какое поле ты говоришь? Я понимаю, что отсканенные штрих-коды он сразу посылает в виде цифр на комп и причем прямо туда где стоит курсор (напр. в Блокноте или в 1С). Но он то должен по штрих-коду сразу выдавать название товара или что-то в этом роде. А для этого его должна "увидеть" 1С-ка, чего она делать (из-за ошибок указанных выше) не хочет.


Вопрос по Феликс-РФ | База знаний | mista.ru

Вопрос по Феликс-РФ

Макс 19.06.2004 14:54 | На чеке печатается 158600*30=4758000, хотя на самом деле это 1586.00*30=47580.00 И еще, можно ли наименование печатать не в одну строку, а в две-три?
Gavrila 1 - 19.06.2004 15:28 | Если Не (Феликс-РФ = ЭККА) Тогда Возврат "Дальше можно не читать"; КонецЕсли; С этим не работал, но попадались ЭККА ПО которых имело определенные требования по формату передачи данных, в частности колво и цены необходимо было передавать умноженными на 100, в твоем случае все похоже наоборот, а инфа драйверу передается неправильная. Вывод: смотри описание, руководство тощо..., а дльше ручками.... :) А по поводу наименования - та же хрень смотри в описании дров ЭККА, если позволяет, значит можно сделать, если нет - значит нет :)
Я 2 - 20.06.2004 15:28 | Насчет нескольких строк наименования, у тебя должны быть Атолловские дриверы не ниже 5.4, там у метода регистрация() есть входное свойство TextWrap, это сво-во устанавливаешь 1 или 2 и имеешь сколько угодно строк текста, а насчет положения точки смотри в таблицах.


Подключение сканера штрих-кодов в терминале | База знаний | mista.ru

Подключение сканера штрих-кодов в терминале

Windsurf 05.06.2004 16:06 | Люди добрые, почитав форум, я так понял, что в принципе эта проблема решаема? Сама проблема у меня в следующем: сервак Win2003, на нем SQL, сервер терминалов. На клиентах XP. Клиенты ходят в 1С через терминал (клиент терминалов встроенный в XP Professional), в настройках клиента есть подключение COM-портов. Настроил все на сервере и на клиенте. Если подключить какой-нибудь модем к клиенту, то на сервере он видится нормально и с ним работает. Если на клиенте подключаю сканер штрих-кодов (USB, MetroLogic, с эмулем COM-порта), то на сервере порт вроде бы и создается и видится, но при попытке доступа к сканеру из 1С, порт не возможно захватить. :(( В, общем вопрос - как заставить работать сканер штрих-кодов под терминалом?
Волшебник 1 - 07.06.2004 20:49 | Нечто похожее уже спрашивал Тимур: http://forum.mista.ru/topic.php?id=889 Вот что тогда ответил Борис: "В терминале можно назначить локальный порт клиента терминальной сессии."
Волшебник 2 - 07.06.2004 20:54 | См. также: "Проблема переназначения клиентских com-портов в Windows 2003" http://forum.mista.ru/topic.php?id=463


а как сделать чтоб при сканировании сканером штрих кода определялся товар | База знаний | mista.ru

а как сделать чтоб при сканировании сканером штрих кода определялся товар

lexa 2 - 01.06.2004 16:09 | в модуле формы справочника номенклатуры или документа должна быть процедура ОбработкаВнешнегоСобытия()
Рупор абсурда 3 - 01.06.2004 16:11 | (2) Необязательно!


Дисконтные карты | База знаний | mista.ru

Дисконтные карты

Batman 25.05.2004 17:30 | интересует взаимодействие с 1с. Кто-нить занимался подобным?
Batman 3 - 26.05.2004 20:14 | Руководство поставило задачу, подключить к 1с кард-ридер, скидка различная, будет считывается с дисконтных карт. (2) ))))))))
cardy 7 - 28.05.2004 13:40 | В свое время писал руками для 1С Рарус-Автозапчасти. В чем сложности то? Создаешь дополнительный справочник - "Дисконтные карты", и если нужно- справочник "Скидки по дисконтным картам". И пишешь обработку для работы с этим делом. Если ридер подключается в разрез клавиатуры то все элементарно (у нас так и было).
Волшебник 8 - 29.05.2004 11:41 | См. также тему "Подскажите, кто что знает о ридерах дисконтных карт" http://www.forum.mista.ru/topic.php?id=2146


Citrix XP как увеличить количество com-портов (более сом9)? | База знаний | mista.ru

Citrix XP как увеличить количество com-портов (более сом9)?

DmitriL
25.05.2004 14:57 		При подключении весов, сканеров командой net use com10 \\client\com2: выдается: Системная ошибка 67. До com10 (т.е com1-com9) команда завершалась успешно. Кто хоть что-нибудь знает о таком, убедительная просьба откликнуться.

ubiley@ishim.ru
DmitriL
2 - 25.05.2004 15:07 		Более пяти пользователей работают под терминалами со сканерами и весами.
DmitriL
6 - 25.05.2004 15:20 		В цитрикс терминале на каждого пользователя есть до 9 портов, НО если подключить под одним и тем же портом разных пользователей, у одного из них блокируется устройство, т.е. порты должны быть уникальными.
fellow
8 - 25.05.2004 18:15 		Попробуйте использовать "\\.\com10"
DmitriL
9 - 25.05.2004 19:05 		не совсем понятно как это использовать "\\.\com10". На клиенте у нас физические порты com1,com2, и т.д. до com6 максимум (при установке платы дополительных com портов), которые затем перенаправляются на серверные виртуальные, с которыми работает 1Ска под терминалами.
Неужели никто не знает как увеличить число виртуальных com портов более 9ти на терминальном сервере с цитриксом?????
SnarkHunter
11 - 25.05.2004 20:11 		Ломало меня курить ман, но коли фраза была произнесена, то пришлось найти цитату: "To map a client COM port: ... 3. At the prompt, type net use comx: \\client\comz: where x is the number of the COM port on the server (port 1 through 9 are available for mapping)..." Переведешь сам?
DmitriL
13 - 26.05.2004 09:05 		Есть способ в Citrix 1.8

This is by design. However (from Hotfix ME182T003 Readme for MetaFrame 1.8 for Windows Terminal Server), The number of COM ports created by Cdmsvc.exe was raised to 9 by changes in MetaFrame 1.8, Service Pack 1, and this value was hard coded. This change caused an existing customer configuration to fail because their modem redirection software would not work with a COM port higher than 9. This hotfix can be applied only to a Windows Terminal Server with MetaFrame 1.8 and Service Pack 2 installed. This fix is included in SP3 for MetaFrame. The default remains 9 but it can be modified by defining/creating the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CdmService\Parameters

Then Add "DefaultComPorts" as a REG_DWORD value in the range of 0 to 99.

When this value is set, you must manually remove the already defined COM port keys from the following registry key:

HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\SERIALCOMM

Reboot the system once these changes are made.

Пробовали в Citrix XP - не помогло.
На форуме www.sql.ru/forum один товарищ решил проблему, но поделиться не хочет.
alxkorvin
14 - 26.05.2004 16:40 		(6) Нечего пользовать Citrix.
В Win2003 проблема решена.


Виснет компьютер при работе с ККМ 100Ф | База знаний | mista.ru

Виснет компьютер при работе с ККМ 100Ф

ONI 12.05.2004 10:16 | Проблема с ККМ 100Ф: виснет компьютер в момент, когда пробивается чек на кассе. Причем виснет не всегда, один и тот же документ может "пройти" сразу, а может с третьей попытки. Причем такая же касса подключена в филиале фирмы, где она успешно работает, причём драйвера в филиалах одинаковые, конфигурации ТиС тоже. Кто-нибудь сталкивался с такой проблемой? Может дело в прошивке ККМ?
ONI 1 - 13.05.2004 10:20 | Проблема вроде бы решилась - вопрос был в драйверах ключа защиты для утилиты "чековый онлайн" - установили новые с сайта производителя (http://www.guardant.ru/) и в BIOS изменили настройки LPT - порта.


Подключение GEG POS-Мастер 100Ф | База знаний | mista.ru

Подключение GEG POS-Мастер 100Ф

Frol 25.10.2004 08:02 | Привет всем! Не могу найти инструкцию, как подключить GEG POS-Мастер 100ф к 1С:Торговля. Может есть у кого ссылочка на ресурсик с такой инфой. Помогите пожалуйста.
Evgeny 5 - 25.10.2004 10:10 | А он у тебя идет с кассовой программой?
Frol 6 - 25.10.2004 10:14 | скорее всего да... это моим клиентам надо подключить. А если без кассовой программы то можно?
Evgeny 7 - 25.10.2004 11:30 | нет нельзя Вообщем если ты используешь POS терминалы то для их управления используется кассовая программа, в твоем случае Мастер Касс(FrontOffice), которая и будет обмениваться информацией с 1С ТИС (BackOffice) Если ты хочешь непосредственно к 1С привязатться, то нужно использовать фискальные регистраторы.Напимер Штрих ФР К совеетую, классные кассы


OffLine, OnLine | База знаний | mista.ru

OffLine, OnLine

Link 05.10.2004 06:54 | Объясните пожалуста разницу этих режимов работы кассы подключенной к 1с. Что нужно для подключения кассы?
F427 1 - 05.10.2004 06:58 | сходи в нормальную контору, которая обслуживает кассы - там проконсультируйся... Вообще то там много понятий ... Какой режим тебе подходит лучше - выбери с ними... Некоторые режимы запрещены... Для некоторых нужен специфический софт... Для начала почитай о работе с кассой на ИТС...
Фокусник 4 - 05.10.2004 08:41 | OffLine касса - выгрузка данных разово (например в конце смены)
gr13 5 - 05.10.2004 08:54 | (4) тему говорит товарищь... OffLine режим это режим, при котором касса у которой нет прямой связи с сервером. Т.е. работает в автономе. OnnLine режим это режим, когда изменения поступают в реальном режиме времени. И имеется постоянная связь с кассами, терминалами, АРМ, и др.
YamMike 7 - 05.10.2004 09:07 | (6) и ОН и ОФФ могут работать со сканером, компом и т.д. Только для ОФФ не требуется постоянное соединение, ОФФ касса во время работы может быть отвязана от сети... А ваще вариантов многою...


Штрих-код весового товара | База знаний | mista.ru

Штрих-код весового товара

Кортес 22.09.2004 12:05 | Мне с таким не доводилось сталкиваться. Разъясните, пожалуйста. Есть товар штучный. Ему соответствует штрих-код. Этот штрих-код записан в справочнике "Номенклатура", соответственно, по этому коду и происходит сопоставление. А вот как быть с весовым товаром? Электронные весы посчитали вес товара, сформировали штрих-код, этикетку наклеили на упаковку. А какой штрих-код в данном случае должен быть в базе в справочнике "Номенклатура"?
bets 1 - 22.09.2004 12:09 | У меня был 5-ти значный (код товара в справочнике)
Кортес 2 - 22.09.2004 12:26 | То есть, часть кода? А по какому признаку он формируется?
Дуч 3 - 22.09.2004 12:31 | Два символа префикс весового товара пять символов код товара пять символов вес товара последний символ контрольная сумма
bets 4 - 22.09.2004 12:34 | Вот так: - перефик весового товара ("23", у меня вроде был "21") - 12345 - код товара, - вес в граммах - конрольная сумма http://cashdrive.com.ua/bar_scale.htm


Показывать только существующие позиции.... как? | База знаний | mista.ru

Показывать только существующие позиции.... как?

forex
17.05.2004 16:26 		1с:21 cfg Т+С 934

Как сделать чтобы при подборе номенклатуры в справочнике показывались только товары остаток которых больше 0 (по кнопке).

С групповой обработкой номенклатуры, не удобно (количество элементов справочника > 10000) - приходится долго ждать.

Что можно сделать в данной ситуации? Заранее спасибо...

если возможно поконкретней...
iceTiger
1 - 17.05.2004 17:21 		Есть проц. "ИспользоватьСписокЭлементов(СписокЗначений)"
СписокЗначений - список показуемых элементов.

В принципе как альтернатива, чтобы не считать остатки:
Можно ввести новый реквизит спр. ТМЦ - "ЕстьНаСкладе" (1/0) и соответственно ставить/снимать при движениях.
Но если бухи балуются проведением задним числом данный вариант кривоват...
forex
2 - 17.05.2004 17:40 		С новым реквизитом явно не потянет....
ИспользоватьСписокЭлементов(СписокЗначений) - но ведь СписокЗначений тоже надо как-то получить.....

А можно сделать так?
сделать запрос по номенклатуре, где родитель=выбранный каталог, и чтобы запрос сразу же считал остатки
а потом, обработать запрос и по остатку менять флаг включения в прайс
ну и установитьотбор(...)

только вот как правильно сделать запрос?
iceTiger
3 - 17.05.2004 18:00 		Если использовать запрос тогда уж просто включать в спЗначений ТМЦ с ненулевыми остатками, но это будет та гр. обработка о которой ты говорил...
А по поводу "установитьотбор(...)" еще медленней :(. Придется перезаписывать каждый найденный элемент.
427
4 - 17.05.2004 18:12 		(2) по второй части - это было реализовано в ТиС 8.7х .... Обзывалось "кеширование остатков"
forex
5 - 17.05.2004 21:11 		iceTiger: Придется перезаписывать каждый найденный элемент
перезаписывать каждый элемент только текущего каталога, а не всей номенклатуры... вроде как долго не должно быть (обычно не более 100 позиций в каталоге)....

ИспользоватьСписокЭлементов, я таким еще не пользовался... (не так давно пишу под 1с). Если есть какой примерчик, буду очень благодарен...
forex
6 - 17.05.2004 21:13 		427: это было реализовано в ТиС 8.7х .... Обзывалось "кеширование остатков"
посмотрел - не нашел :( может не там искал...

Как раз и делается переход с 8.7 на 9.2
forex
8 - 18.05.2004 00:14 		427: Плохо смотрел
Дело ведь уже не в этом... в 934 видимо этого нет
SnarkHunter
9 - 18.05.2004 06:05 		Нельзя утверждать, что при многопользовательской работе эти остатки будут актуальны...
forex
10 - 18.05.2004 10:26 		2 SnarkHunter: а почему нельзя? все прекрасно работает же в подборе номенклатуры, ну а если товар уже будет списан со склада (пока действует фильтр), не так страшно...
SnarkHunter
11 - 18.05.2004 10:32 		Я же не сказал, что этим нельзя пользоваться, правда?..
iceTiger
13 - 18.05.2004 13:30 		Пример из ЖКК:

Процедура УстановитьФильтр(ВыбПризнак)
Список.СоздатьОбъект("СписокЗначений");
Буфер = СоздатьОбъект("Справочник.Главн");
// отбираем только те элементы, которые могут отображаться в текущем списке
Буфер.ИспользоватьРодителя(ИспользоватьРодителя());
Буфер.ВключатьПодчиненные(0);
Буфер.ВыбратьЭлементы();
Пока Буфер.ПолучитьЭлемент() = 1 Цикл
// отбираем только те элементы, которые удовлетворяют заданному признаку
Если (Буфер.Признак = ВыбПризнак) Тогда
Список.ДобавитьЗначение(Буфер.ТекущийЭлемент());
КонецЕсли;
КонецЦикла;
ИспользоватьСписокЭлементов(Список);
КонецПроцедуры
forex
14 - 18.05.2004 14:07 		2 iceTiger: это процедура собственного написания?
попробую, спасибо

Сделал скрытие отсут. товаров через запрос и обработкой номенклатуры, но запрос выполняется не очень быстро :( сек 5 (справочник 10000 позиций), может я что не так сделал?

родитель=ТекущийЭлемент().Родитель;
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Номенклатура = Справочник.Номенклатура.ТекущийЭлемент;
|Группировка Номенклатура Без Групп Без Упорядочивания;
|Условие (Номенклатура.Родитель=родитель);";

Запрос = СоздатьОбъект("Запрос");
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

ТМЦ = СоздатьОбъект("Справочник.Номенклатура");

Пока Запрос.Группировка("Номенклатура") = 1 Цикл
Если ТМЦ.НайтиЭлемент(Запрос.Номенклатура) = 0 Тогда
Сообщить("Не найден """ + СокрЛП(Запрос.Номенклатура) + """! Действие не выполнено!","!");
Продолжить;
КонецЕсли;
ост=число(ОстатокТоваранаскладе(Запрос.Номенклатура));
Если ост>0 Тогда
ТМЦ.НеНулевойОстаток = 1;
Иначе
ТМЦ.НеНулевойОстаток = 0;
КонецЕсли;
ТМЦ.Записать();
КонецЦикла;
УстановитьОтбор("НеНулевойОстаток", 1);


Передача параметра в открываемую форму | База знаний | mista.ru

Передача параметра в открываемую форму

sheale 25.08.2004 17:13 | Я заполняю документ через отчет. Я использую процедуру ПриПовторномОткрытии() Далее получаю таблицу значений через Форма.Параметр. Есть еще один отчет, который тоже передает таблицу значений. Мне нужно определить – какой отчет передал какую Тз. Как мне их различить?
Guk 1 - 25.08.2004 17:18 | (0) Передавай вместо ТЗ, спиок значений. Первый элемент списка - название отчета, второй - ТЗ...
mszsuz 2 - 25.08.2004 17:18 | Закинь таблицу в СписокЗначений. В Список же добавь флаг различия. И передавай этот СЗ параметром.


Учет товара по серийным номерам | База знаний | mista.ru

Учет товара по серийным номерам

Evgeny 09.09.2004 03:54 | Подскажите как лучше организовать учет товаров по серийным номерам в ТиС или Комлексной конфиг.
Морозов Александр 1 - 09.09.2004 04:56 | Добавить подчиненный справочник...
Морозов Александр 3 - 09.09.2004 05:33 | Не только в документы, но и регистр бы.
SKrin 4 - 09.09.2004 08:11 | (1) Зае..шся потом с этим справочником, ИМХО лучше тока по регистрам дополнительный реквизит внести-но придется в глобалнике Доооолго ковырятся-ну от этого некуда не денешся
Мулька 6 - 09.09.2004 08:17 | Партионный учет ведешь ? Если да - то привязывай номера серий к партиям. Иначе - начинай вести


1c-сметы | База знаний | mista.ru

1c-сметы

Ириска 06.05.2004 15:39 | Кто подскажет (покажет) как сделать учет строительных смет (составление) без использования оперативного учета? Нужно контролировать остатки и обороты.
3ton 1 - 06.05.2004 17:18 | В принципе если отбросить все внутренние возможности агрегатных объектов (регистр, операции, журналы и т.д.), тогда остается только работа с таблицами aka справочники (правда методы и свойства их, как реальных таблиц ох как ограничены). Отсюда вывод: любую конфу можно нарисовать просто на справочниках. Следстия реализации конфы: 1. "А-ххх" какая скорость работы законченого продукта (см. "") 2. Появится, полюбому, избыточность данных -> увеличение размеров базы 3. Ограниченность обработки и организации данных. (без использования внешних компонент и т.п.) i. ... Вывод: Непонятно почему тогда сразу не писать такую прогу на любой другой системе (программирования) с возможностью обработки БД, где это и пошустрее, и более заточеннее работать будет?
427 2 - 06.05.2004 22:13 | Не понял.... "как сделать учет строительных смет" ???? Учет работ по составлению смет? Учет готовых смет (в архиве) ? Собственно составление смет? Если учет в архиве (библиотеке) - да похрен на чем делать... 4 справочника + 3 счета на бухии или 4 справочника + 3 регистра на опер учете и там и там штук 5 доков Если же составление смет ... то я бы поостерегся браться... Там проблема не в написании программы, а в нормативной базе... Которая охрененного размера и самое противное - обновляется в непонятных размерах раз квартал.... Самому набивать - застрелиться... А готовая да еще с обновлениями стоит нехилых денег...


Объединение двух Глобальных модулей | База знаний | mista.ru

Объединение двух Глобальных модулей

Marshall 02.09.2004 13:02 | Подскажите пожалуйста какой-нибудь хороший инструментик для того, что бы объединить код двух больших (более 10 000 строк) глобальных модулей, а то стандартный режим объединения 1С слишком неудобен.
Den 6 - 02.09.2004 14:59 | http://www.documenta.spb.ru/textutil.html утилита AraxisMerge 6.0
Camino 8 - 02.09.2004 15:45 | +(6) Рекомендую. Сам пользуюсь уже год. Пожалуй лучшая диффалка.
Marshall 9 - 02.09.2004 17:09 | 2 (6) не удается скачать.., но мне порекомендовали kdiff3 (http://kdiff3.sourceforge.net/) - отличная вещь, очень удобно.
artbear 10 - 02.09.2004 22:05 | (0) Еще есть скрипт для GComp для разложения глобального модуля (если не путаю, ExtractProc.py на Питоне). В этом случае все процедуры и функции выносятся в отдельные файлы, где их можно править и сравнивать. В таком случае можно сравнивать 2 глобальника, в которых не совпадает порядок большинства функций. Поищи на итланде в разделе GComp или скачай последний GComp (этот скрипт идет в поставке) ЗЫ Очень удобная штука, самому не раз помогло при объединении с типовой своей рабочей базы ЗЗЫ Последняя версия раскладывает любой модуль, не только глобальный
Gary 11 - 03.09.2004 09:20 | А я использую Visual MD Editor от Soaron-а (tnx!) и прогу WinMerge для сравнения и слияния текстовых файликов, вполне просто и достойно ...


каждой конфигурации свой " ...\ExtForms" из конфигуратора | База знаний | mista.ru

каждой конфигурации свой " ...\ExtForms" из конфигуратора

Nomis 25.08.2004 11:02 | Ситуация такова, что приходится работать с несколькими конфигурациями живыми (рабочими то-бишь), несколькими копиями этих "живых", да еще пара-тройка с примерами какими-нибудь... Так вот, когда пытаешься открыть в конфигураторе внешний отчет, то открывается ...\ExtForms\ конфигурации, с которой работал последний раз... Все бы ничего, но... замучился, короче, бегать по каталогам. Так вот, можно ли, каким либо образом назначить каждой конфигурации (в режиме конфигуратора) "свой" "...\ExtForms\" ? Чтобы открывался тот, "...\ExtForms\ ", который нужно. Если можно, то где? Реестр?
Crew 6 - 26.08.2004 11:54 | HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32\LastVisitedMRU HKEY_USERS\S-1-5-21-1454471165-920026266-1343024091-1003\Software\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32\LastVisitedMRU Ключ "а" Не ленись !!! И слушай пита.


Как заполнять перечисления | База знаний | mista.ru

Как заполнять перечисления

namor 19.08.2004 18:22 | Сделал в Конфигураторе перечисления. Как заполнять их в предприятии? В меню перечисления не размещаются.
Йошкар-Олинка 1 - 19.08.2004 18:28 | никак, они заполняются фиксированным списком только через конфигуратор


Запуск внещних приложений из 1с (встроенный язык - вопрос) | База знаний | mista.ru

Запуск внещних приложений из 1с (встроенный язык - вопрос)

Danila 17.06.2004 17:41 | Подскажите есть ли возможность у встроенного языка такая, чтоб в какой либо обработке можно было запускать внешнее приложение (внешний исполняемый файл).
Press 5 - 17.06.2004 17:51 | ЗапуститьПриложение(<?>); Синтаксис: ЗапуститьПриложение(<СтрокаКоманды>) Назначение: Выполняет запуск любого приложения. В отличие от функции 'КомандаСистемы' запуск приложения выполняется непосредственно, минуя командный интерпретатор. Процедура, кроме того, может открыть файл с помощью ассоциированного для данного вида файлов приложения. (При условии, что таковое установлено на данном компьютере). Параметры: <СтрокаКоманды> - командная строка запуска приложения или имя файла, чтобы открыть его с помощью ассоциированного для данного вида файлов приложения. Последовательность поиска программы (если не задан путь): текущий системный каталог; каталог Windows; системный каталог Windows; все каталоги, указанные в переменной PATH. PS. Где взял не скажу!
romix 7 - 18.06.2004 12:30 | ЗапуститьПриложение() делает это в потоке. Но иногда (или даже чаще всего) надо приостанавливать работу 1С, пока не закончится работа запущенной программы. ////_______________________________________________________________________ Функция ЗапуститьПриложениеМодально(cmdLine) WshShell = CreateObject("WScript.Shell"); Возврат WshShell.Run(cmdLine, 1, -1); КонецФункции


Как вести учет по серийному номеру в торговле 9.2 | База знаний | mista.ru

Как вести учет по серийному номеру в торговле 9.2

Ilia
02.08.2004 12:37 		Есть стандартная 1с конфигурация торговля+склад 9.2. Необходимо вести учет товара по серийным номерам, по партии поступления. Т.е. товар пришел на склад, забили серийник, при продаже опять же выбираем товар из номенклатуры и можем выбрать партию (от кого пришел, когда) и серийный номер товара. Главное, чтобы товар с этим серийником списывался со склада при продаже и записывался при поступлении.
В стандартной версии есть понятие "основное свойство". С помощью него можно организовать это дело. При продаже в розницу, однако, не дает выбрать ни партию, ни серийный номер, ругается и постоянно дает автоподбор. Да еще до кучи в партии не пишет поставщика, приходный документ, договор и т.д. Т.е. выбрать желаемый товар не получается. Плюс ко всему, конкретный товар со склада не списывается, т.е. следующий раз опять можно выбрать такую же партию автоподбором.

Вопросы: 1. Правильно ли я пытаюсь стандартными средствами вести учет по серийникам или как-то можно иначе?
2. Почему программа не дает выбрать партию, а всегда хочет делать автободбор? Как перебороть и выбирать руками?
3. Или все же стоит дописать конфигурацию, чтобы было отдельное слежение за серийными номерами? Зачем тогда "основное свойство"?
427
1 - 02.08.2004 13:03 		нормального посерийного учета в типовой ТиС нет...

Примитивно руками можно наизгаляться (по крайней мере 2 способа есть точно, или 4-счиать лень), но это неудобно (следовательно, много ошибок).

Так что надо дописывать...
sam_sam
2 - 02.08.2004 13:19 		создаешь регистр серийные номера.
создаешь справочник серийные номера подчиненный номенклатуре.
И вперед, придется дописывать, но не много.


Количество страниц ... | База знаний | mista.ru

Количество страниц ...

YF 29.07.2004 13:39 | Хочу написать в колонтитуле таблицы: "Страница 1 из N", где N, как догадываетесь кол-во страниц печатной формы - как его узнать? Может глупый вопрос, но я честно не знаю, не разу не сталкивался с этим ...
Рупор абсурда 4 - 29.07.2004 14:59 | (3) Как я уже сказал, если только для красоты, то лучше забить ..., игра не стоит свеч ... А, ващще, есть два весьма точных способа ... Первый, несколько трудоёмкий, описан здесь: http://absur.da.ru/por/ (см. в самом конце странички) Второй с использованием вк ..., этой: http://consult.legion.ru/alf/formex.shtml


Два одинаковых контрагента или две карточки товара. Как объединить? | База знаний | mista.ru

Два одинаковых контрагента или две карточки товара. Как объединить?

Den
20.07.2004 12:39 		Юзеры не понимают, что вредно для здоровья заводить одного и того же контрагента несколько раз, думают, так проще - шлепнул Ins и готово, а потом удивляются - почему взаиморасчеты не сходятся? Есть ли какой-нибудь способ объединить несколько записей справочника в одну, то есть по всей ИБ заменить ссылки где только можно?
Простая замена в документах и перепроведение не катят, документов может быть очень много.
Как-то была у меня самописка на Делфи - там я такую штуку встроил в ядро, очень была популярная вещь.
Diter
1 - 20.07.2004 12:44 		А нафига на делфях? Пиши обработку, которая перелопатит все документы и подменит одного контрегнта другим. Перепроводи их и спокой удаляй лишнего. Для ускорения поиска, чтобы не лопатить лишние документы - воспользуйся НайтиСсылки() и всё.
laeg
4 - 20.07.2004 12:46 		1.Помечаешь на удаление дубляж
2.Штатная обработка Универсальная замена значений (REPVAL)
3.Запускаешь, меняешь помеченный на удаление - > на нормальный, так все время делаю, глюков и сбоев нету.
laeg
5 - 20.07.2004 12:47 		В Догонку: Можешь ни чего не перепроводить, только вот Итоги потом прейдется заново расчитать ....
Diter
6 - 20.07.2004 12:53 		Это как не перепроводить? Ты чего? Если это Торговля - то кто отменил регистр взаиморасчётов, если бухгалтерия - надо перепривязать субконто. Как это не перепроводить?
Какая бы небыла конфа самописаная всё равно работает на одной из трёх компонент. И принципы работы одинаковые для самописной и типовой конф.
А что это за особенности конфы, что нельзя перепроводить документы?
SnarkHunter
7 - 20.07.2004 12:59 		В бухгалтерии перепроводить не обязательно...
laeg
8 - 20.07.2004 13:00 		(6)
Для бухгалтерии можно ни чего не перепроводить, она меняет и Аналитику в субконто :о))), только итоги пересчитать
SnarkHunter
9 - 20.07.2004 13:04 		И итоги пересчитывать не надо...
Diter
10 - 20.07.2004 13:12 		Бр-бр. Как такое возможно? Просто сохраняешь док и всё? И перепроводить не надо? Это что-то новенькое.Такого я за всё время работы с 1С не слышал. На кой ляд тогда в бухгалтерии есть обработка "перепроведение док-ов"? Насколькл я понимаю, речь идёт о программной замене? Но тогда система заругается при записи документа типа "нельзя записывать проведённый документ"? Или я всётаки чего-то не понимаю. КАК в оборотку попадёт новое субконто? точнее как в БИ попадёт новое субконто без перепроведения. Ведь операция создаётся и записывается именно в момент проведения документа?
laeg
11 - 20.07.2004 13:25 		(10)
Вы не вкурсе что можно менять любую операцию ? В том числе и привязанную к доку ? Причем не перепроводя документы ?
ХМ ......
Diter
12 - 20.07.2004 13:30 		Это я в курсе. Т.е. ты предлагаешь найти документ, программно получить его операцию и изменить контрагента в ней, затем записать операцию? Так? Ну а теперь скажи, чем это отличается от обычного проведения? Только тем, что при этом нужно перебирать все проводки операции, выискивая нужную (ту в которой субконто-контрагент). Можно конечно через бухитоги лопатить. Но как узнать, по каким счетам делать запрос. Как идёт расчёт с контрагентом через аванся или напрямую? Лопатить все аозможные счета? А не займёт ли это столько же время? Да и код получиться строк на 100. Не прощели написать пять строк и перепровести документы?
Diter
14 - 20.07.2004 13:50 		А где такая обработочка есть?
fez
15 - 20.07.2004 13:52 		(14) На ИТС
fez
18 - 20.07.2004 14:01 		НайтиСсылки(<?>,);
FindReferences(<?>,);
Синтаксис:
НайтиСсылки(<Объекты>,<Ссылки>)
Назначение:
Находит ссылки на объекты, переданные в списке значений.
Параметры:
<Объекты> - конкретное значение искомого объекта или значение типа ''СписокЗначений'', в котором данной процедуре передаются объекты, по которым надо найти ссылки.
<Ссылки> - идентификатор объекта типа ''ТаблицаЗначений'', в который данная процедура помещает найденные ссылки на объекты. Таблица значений состоит из 3 колонок: 1. объект на который ссылаются; 2. объект, который содержит ссылку; 3. комментарий к ссылке.
Den
19 - 20.07.2004 14:03 		(18) Это все понятно. Но как в регистрах заменить ссылки без того, чтобы перепроводить документы??? А также в журналах расчетов? А в итогах по регистрам?
Den
20 - 20.07.2004 14:05 		(+18) Ведь напрямую в регистр не залезешь
fez
21 - 20.07.2004 14:07 		А почему нельзя перепроводить документы?

А вообще, есть такая штука - "технологическое перепроведение". Подробное описание есть на том же ИТС.
Вкратце все выглядит так: отключаем удаление движений при перепроведении, переписываем модули проведения так, чтобы все, что делалось при проведении - замена значений в уже существующих движениях, перепроводим, откатываем изменения в конфе назад.
fez
31 - 20.07.2004 14:43 		Документы надо перепроводить по-любому. С помощью технологии, обрисованной в (21) можно сократить время перепроведения (например из-за того, что не приходится заного пересчитывать списание партий или взаиморасчетов).
Ну и хороший сервер в сочетании с dbf'ной базой тоже здорово помогает в вопросе ускорения.
laeg
33 - 20.07.2004 14:57 		(29)
Стандартная операции привязанные к Доку не меняет в целях безопасности ...
Трудно вставить пару строк в модуль ?

На счет регистров на ХИППО (правда он сейчас умер, надеюсь что временно) была обработка по регистрам ...
Diter
34 - 20.07.2004 15:04 		(33) А объясни зачем? Всё равно тебе прийдётся изменив операцию записывать её. Да чуть быстрее будет работать из-за указанного в (31) и всё. Зато никакого контроля по остаткам и прочей контрольной информации. Проще и надёжнее ли будет такая замена с перепроведением документов. А работать напрямую с регистрами - можно но так стрёмно, что дулать это нужно только в самом крайнем случае. Наворотишь, а истории изменений там нет. Потом до пенсии будешщь искать где ошибка, пока не сделаешь перепроведение и восстановление последовательности.
wt
35 - 20.07.2004 17:44 		(laeg) в обработке REPLVAL меняется один элемент справочника, дока и тп, на другой. (Den)у же надо менять реквизит по всем ссылкам на другой, т.е. другое. Может ты другую обработку имеешь ввиду?
Валентин
37 - 20.07.2004 19:54 		Если база на SQL. Выяснешь ид элемента справочника который меняем, ид на который меняем. Во всех таблицах (связанные таблицы выясняешь сам по конфигурации, особенно смотришь на те таблицы где есть реквизиты неопределенного вида),кроме ответственных за регистры просто меняем одно на другое.
Для регистров - в таблица ra* - update, в rg* - перерасчет
После этого смело удаляешь ненужное тебе.
Однажды делал такое, конфа была переписано по самое не могу, но вот повторять как-то не хочется.
Den
38 - 20.07.2004 22:27 		(37) Вот!!! Наконец-то!!! Первый человек, который понял и сформулировал именно то, что мне и надо! Но... База DBF (ну нет у меня клиентов на SQL, хотя надо бы некоторых перевести), кроме ra* и rg* существует еще таблица ссылок, журналы расчетов и прочая лабуда (константы, проводки, операции... 8-))) . Не знаю, SQL не ковырял, но в DBF это такой кошмар!
Ладно, как IWD или DW7 превратить в нормальное число или наоборот вытащить его из ЗначениеВСтрокуВнутр я понял (недок. функции _IdToStr & _StrToID), даже понял, как это все найти в sc* dh* dt* ;-) но вот в таблице 1SCRDOC есть хитрое поле PARENTVAL данные в котором имеют примерно такой вид (точками указываю пробелы):
B1..33...4X
B1..33...4T
O1..L3...5A
U
U
B1..33.....Q
и т. д.
Что это такое, с чем его едят и вообще, как пробелы распределяются. Блин, сформулировать не могу, мозги уже кипят, от жары наверное.
Вот. Самое интересное, что я сначала своей башкой дошел, что 1С хранит ИД в 36-тиричном виде, даже функции написал (на 1С) преобразования туда-обратно, и только потом обнаружил, что зря старался, они уже есть. Тогда мне стало интересно - вроде в справочниках и документах под ИД отвели девять символов - это ж охеренное число получается, если ZZZZZZZZZ преобразовать в нормально десятеричное число - Делфи, по крайней мере, это число просто не всасывает (правда, не пробовал в тип Extended, но как целочисленное - у него такого размера нет :). Даже Ёксель подглючивал, когда я пытался что-то сделать. Ну, думаю, Борины программеры совсем крутые, раз 1С может сообразить с такими числами. Начал ручками в справочнике подводить к следующему. Вручную установил ИД в ZZ, создал новый элемент, посмотрел, все нормально, следующий ИД стал 100,
затем переправил его в ZZZ, создал новый, все нормально, следующий = 1000, и так далее. После того, как ручками переправил на ZZZZZZ, то есть 6 разрядов - возник глюк. Я уже не помню, как 1С отреагировала, врать не буду, только больше чем 6 разрядов в 36-тиричном виде она не всасывает. Вот возникает вопрос - а нафига 9 знаков?
Den
40 - 20.07.2004 22:38 		Но это вопрос скорее риторический, теперь возникает следующий - что за формат у этого PARENTVAL?
B1..33..QWE
B1..33...WE
B1..33....1
Если максимальное ИД - это 6 разрядов, под первую группу (B1.) например отводится 3 знака, под вторую(.33) например 3 знака, то почему под третью(..QWE) всего 5? А вообще длина поля 23 символа.

Так. сейчас обнаружил еще один вариант
E1.1JU...1JV
Что-то я вообще ничего не понимаю.

Если кто-то что-то тоже не понимает - напоминаю:
Есть у меня мысля - пробежаться по всем таблицам, просканировать в каждой записи каждое поле (метод, конечно, ненаучный, но железобетонный, для начала пойдет) и заменить, например B3T из справочника Контрагенты на 1O5 из того же справочника.

Господа!!! Я практически до всего допер, но вот что это за поле!?!?!
Хэлп, а то улям хазер
или утрям нафиг тех юзеров, которые плодят одинаковые по смыслу, но разные по ИД карточки...
Warlock
51 - 20.07.2004 23:44 		(49)А я хочу все равно вернуться к техническому перепроведению:
Буду разъяснять относительно оперучета(для бухучета даже проще):
1. Глобально ставим флажок "ТехническоеПерепроведение"
2. Перед проведением документа собираем все его движения(В ТЗ, например).
3. Воспроизводим движения 2. в зависимости от флажка 1. (не обращая внимания на оригинальный модуль перепроведения)

Достоинства:
1. Все можно написать встроенным языком 1С
2. Можно перепроводить не в монопольном режиме.

Ну как? (Вот вспомнил - а программное перепроведение влияет на последовательности?)
SnarkHunter
57 - 21.07.2004 06:05 		Скорее "good fuck"...

По поводу (38) и (40)...

Из девяти символов ИД первые 6 отводятся под собственно ИД объекта в базе, последние 3 - под ИД базы (используются при установленной компоненте УРИБ)

В таблице 1SCRDOC хранятся различные отборы документов. Например:
- Ссылки между документами, при этом
MDID — 0
PARENTVAL — значение "родительского" документа в формате неопределенного
значения, начинается с O1
CHILD_DATE_TIME_IDDOC — дата, время, ИД подчиненного документа
CHILDID — IDDOC подчиненного документа
- дополнительные журналы
MDID — ID метаданных дополнительного журнала
PARENTVAL = 'U '
CHILD_DATE_TIME_IDDOC — дата, время, ИД документа в журнале
CHILDID — IDDOC документа
- графы отбора
MDID — ID метаданных графы отбора
PARENTVAL — значение графы отбора в формате неопределенного значения
CHILD_DATE_TIME_IDDOC — дата, время, ИД документа попадающего в графу отбора
CHILDID — IDDOC документа

(Информация по таблице 1SCRDOC взята из руководства к библиотеке ToySQL)
427
60 - 21.07.2004 06:59 		koshechka 46 - 20.07.04 - 23:26
"в подборе обычно (у меня это точно есть) нет вохможности копировать. В доках расходная ТТН и ТТН на отпуск товара/материала, нет возможности создавать новые субконто товары/материалы."

А у меня похрен... ПУСТЬ КОПИРУЮТ... Пусть ЗАВОДЯТ НОВЫЕ....
Документ НЕ ПРОВЕДЕТСЯ... ибо новой хрени нет на складе... и проверка пошлет расход в пешее путешествие...

А чтобы не выпендривались - распечатать печатную форму можно только из журнала по клавише Печать... И ТОЛЬКО У ПРОВЕДЕННОГО документа. т.е. не провелся - нет печатной формы... Все свободны....

(51) программное проведение очень даже влияет...
427
107 - 22.07.2004 08:59 		У меня документооборот поменьше.... Но есть накладные по 400-600 позиций... И тут сказывается опыт в построении структуры справочника... Стартовое направление даю я при внедрении, но часто в таких фирмах ЕСТЬ опытный манагер на закупке... Практический опыт которого ЛУЧШЕ моего - и он вносит исправления. Если эти исправления улучшают ситуацию - они просто живут... Если нет - тогда начинаются трения закупок и продаж - приходится разруливать...

Сейчас это делать просто - есть еще штрих-код товара... Не забывайте...

И НЕ НАДО без нужды ломать десятилетиями складывающийся документооборот. Он уже оптимизирован и позволяет при правильном использовании делать ВЗАИМОКОНТРОЛЬ... тогда возможность ошибок и краж сводится к минимуму... И ошибки исправляются достаточно быстро....

Основные принципы на самом деле достаточно просты...
Пришел товар.

1. Нет документов. Это особый случай... Разруливается обычно по принятым в компании правилам (с учетом требований бух учета, иначе вы не сможете предъявить претензий через суд).

2. Есть документы. Сначала кладовщик примет товар и проверит его КОЛИЧЕСТВО и КАЧЕСТВО (за плохой после приема будут драть кладовщика). Если кладовщик принимает чохом все без пересчета - он дятел... И через пару месяцев такой работы - будет платить из своего кармана... Поэтому грамотные НИКОГДА так не делают...
После пересчета и проверки товар приходуется отделом закупок. Если отдел закупок ошибся при вводе
- указали 100 вместо 10 - при выписке очередной РН будет скандальчик, крайний - отдел закупок (после сравнения за что расписался кладовщик и что ввел отдел закупок). Выписка люлей пару раз - и ошибки исчезают...
- указали 10 вместо 100 - товар завис (в программе его нет). Очередная инвентаризация это обнаружила (причем часто проводят частичную инвентаризацию по группе товаров)... крайний - отдел закупок (после сравнения за что расписался кладовщик и что ввел отдел закупок). Выписка люлей пару раз - и ошибки исчезают...

Отдел продаж имеет право просмотра приходов без их корректировки... И право продавать только товар, который есть в программе... Ибо иначе начнется сабж...

(90) не надо делать слишком жесткий контроль с запретами. Будет сложно работать... Но контроль с предупреждением - НАДО... Будет меньше ошибок...

А запрет продавать в минуса - так это штатная возможность любой конфы (бух, ТиС... регилируется в константах или в справочнике Фирмы или Пользователи) - везде по разному - но есть обязательно. Вот когда разрешают продавать в минуса - весь бардак и начинается...
427
108 - 22.07.2004 09:00 		и еще - применение современных средств (штрих кодов, считывателей) позволяет упростить работу и убрать много ошибок...

Но в маленьких фирмах часто на этом экономят....
427
109 - 22.07.2004 09:06 		выписка люлей обычно производится в виде денежного вычета по договору мат ответственности .... или лишение премии

и плохие работники либо платят либо нормально работают... либо исчезают...

А хорошим в нормальных фирмах платят хорошую ЗП... Гораздо дешевле платить нормальную ЗП на ключевых местах, чем терять на претензиях - суммы не сравнимы... Те владельцы, которые это понимают - имеют нормальный бизнес


Как отследить смену рабочей даты? | База знаний | mista.ru

Как отследить смену рабочей даты?

tank 19.07.2004 17:48 | Как отследить смену рабочей даты? Есть график платежей контрагентам, необходимо напомнить оператору что сегодня нужно оплатить какому нибудь контрагенту. (необходимо чтобы работало не только при входе в систему)
Warlock 1 - 19.07.2004 17:53 | ОбработкаОжидания()


алгоритм проверки связности ортграфа | База знаний | mista.ru

алгоритм проверки связности ортграфа

Asmody
18.07.2004 15:18 		помнит кто? вот понадобилось, но подзабыл чего-то
Asmody
13 - 18.07.2004 16:11 		ха! сам нашел. яндекс форева >;))

Алгоритм выполнения :
1. Ищем все достижимые вершины (в данном случае все вершины достижимые из А)
и запоминаем их.
2. Транспонируем исходный граф.
3. Снова ищем все достижимые вершины (снова из А), таким образом получаем все
вершины из которых достижима вершина (А).Запоминаем их.
4. Запоминаем все вершины исходного графа
5. Сравниваем вершины из 1. с вершинами из 3. а также с вершинами из 4. Если
списки совпадают то граф связный.

(http://green.iis.nsk.su/~sop/2003/old-sop/lisp/lisp/sketch/16/16.html)
NS
14 - 18.07.2004 16:11 		(8) Уболтал - делаю без матрицы смежности...
Привожу к виду (вершина-вершина) (все связи) - на ТЗ...
Asmody
16 - 18.07.2004 16:23 		(15) спасибо, конечно, за заботу. я только алгоритм просил. кодить я сам умею >;))

кстати, для алгоритма как раз оптимальным будет вариант представления графа списком вершин в ТЗ. транспонировать не надо >;))
еще раз спасибо за идею.
NS
17 - 18.07.2004 16:25 		(16) Вот тут ты здорово ошибаешься...
Если у тебя в списке - только нижестоящие вершины - то ничего не получится...
Как ты вверх будешь подниматься?
Транспонируем?
Сколько времени у тебя уйдет на транспонирование с твоим представлением?
NS
18 - 18.07.2004 16:27 		Алгоритм - кстати - дерьмо..
Есть намного лучше...
Без транспонирования - для этого достаточно сделать граф ненаправленным...
Asmody
19 - 18.07.2004 16:32 		(17) в (16) ошибочка - именно списком дуг в ТЗ. алгоритм для неориентированного графа я тоже нашел. надо подумать, существенно-ли в контексте задачи то, что граф ориентированный... при проверке связности скорее всего нет. пошел думать. где тут мой кофе? >;))
NS
20 - 18.07.2004 16:37 		(19) Для ориентированнонго - тебе либо подниматься вверх, либо транспонировать, что ресурсоемко...
Но ты изначально можешь представить граф в неориентированном виде (в списке - и выше, и нижестоящие вершины....)
Тогда реализовывать просто... тем более на 1с (темповая СЗ)
Asmody
22 - 18.07.2004 16:49 		(20) скорее всего ты прав. короче, сделаю так: сделаю список дуг на ТЗ с колонками "Начало,Конец", а при проверке связности буду иметь ввиду, что у меня существует как дуга типа "начало->конец", так и дуга "конец->начало"
Asmody
24 - 18.07.2004 16:53 		(21) напишу. в графе будет 5-10 вершин в среднем. чуть больше дуг. собственно, чего я - это описание последовательности тех.процессов на производстве. проверка нужна, чтобы была уверенность в том, что из начала последовательности достижим конец.
NS
25 - 18.07.2004 16:57 		Плюс - по неореинтированному графу - это чистый алгоритм закраски...
Используется, например -
http://1c.proclub.ru/modules/mydownloads/personal.php?cid=5&lid=2373
Asmody
29 - 18.07.2004 17:07 		сеанс одновременного программирования? >;))
ну давай. чтобы абстрагироваться от задачи сделаем так:
пустая конфа, справочник "Вершины" без реквизитов, справочник "Дуги": реквизиты "Начало" и "Конец" типа "Справочник.Вершины".
NS
32 - 18.07.2004 17:29 		//*******************************************
Процедура Сформировать()
спр=создатьобъект("Справочник.Вершины");
// Считаем, что в этом справочнике нет групп
спр1=СоздатьОбъект("Справочник.Дуги");
спис=создатьобъект("СписокЗначений");
спр.ВыбратьЭлементы(0);
спр.ПолучитьЭлемент(1);
спис.ДобавитьЗначение(спр.ТекущийЭлемент());
а=1;
КолвоЭлементов=1;
пока (а<=КолвоЭлементов) цикл
Эл=Спис.ПолучитьЗначение(а);
спр1.ВыбратьЭлементыПоРеквизиту("Начало",Эл,0,0);
пока спр1.ПолучитьЭлемент(1)=1 цикл
Эл1=спр1.Конец;
Если спис.НайтиЗначение(Эл1)=0 Тогда
КолвоЭлементов=КолвоЭлементов+1;
спис.ДобавитьЗначение(Эл1);
КонецЕсли;
КонецЦикла;
спр1.ВыбратьЭлементыПоРеквизиту("Конец",Эл,0,0);
пока спр1.ПолучитьЭлемент(1)=1 цикл
Эл1=спр1.Начало;
Если спис.НайтиЗначение(Эл1)=0 Тогда
КолвоЭлементов=КолвоЭлементов+1;
спис.ДобавитьЗначение(Эл1);
КонецЕсли;
КонецЦикла;
а=а+1;
КонецЦикла;
КолвоВСписке=спис.РазмерСписка();
Запрос=создатьОбъект("Запрос");
ТекстЗапроса="Верш=Справочник.Вершины.ТекущийЭлемент;
|Функция сч=счётчик();";
Запрос.Выполнить(ТекстЗапроса);
КолвоВСправочнике=Запрос.СЧ;
Если КолвоВСправочнике>КолвоВСписке Тогда
сообщить("Беда");
Иначе
сообщить("ОК");
КонецЕсли;
КонецПроцедуры
NS
33 - 18.07.2004 18:07 		Хм... Если только по вершинам которые в связях - весь справочник не использовать...
Пять минут - допью... немного осталось...
NS
34 - 18.07.2004 18:14 		//*******************************************
Процедура Сформировать()
спр=создатьобъект("Справочник.Вершины");
// Считаем, что в этом справочнике нет групп
спр1=СоздатьОбъект("Справочник.Дуги");
спис=создатьобъект("СписокЗначений");
ТЗ=создатьобъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("Вершина");
спр.ВыбратьЭлементы(0);
спр.ПолучитьЭлемент(1);
спис.ДобавитьЗначение(спр.ТекущийЭлемент());
а=1;
КолвоЭлементов=1;
пока (а<=КолвоЭлементов) цикл
Эл=Спис.ПолучитьЗначение(а);
спр1.ВыбратьЭлементыПоРеквизиту("Начало",Эл,0,0);
пока спр1.ПолучитьЭлемент(1)=1 цикл
Эл1=спр1.Конец;
Если спис.НайтиЗначение(Эл1)=0 Тогда
КолвоЭлементов=КолвоЭлементов+1;
спис.ДобавитьЗначение(Эл1);
КонецЕсли;
КонецЦикла;
спр1.ВыбратьЭлементыПоРеквизиту("Конец",Эл,0,0);
пока спр1.ПолучитьЭлемент(1)=1 цикл
Эл1=спр1.Начало;
Если спис.НайтиЗначение(Эл1)=0 Тогда
КолвоЭлементов=КолвоЭлементов+1;
спис.ДобавитьЗначение(Эл1);
КонецЕсли;
КонецЦикла;
а=а+1;
КонецЦикла;
КолвоВСписке=спис.РазмерСписка();
Спр1.ВыбратьЭлементы(0);
Пока спр1.ПолучитьЭлемент(1)=1 цикл
Тз.НоваяСтрока();
ТЗ.Вершина=спр1.Начало;
Тз.НоваяСтрока();
ТЗ.Вершина=спр1.Конец;
КонецЦикла;
ТЗ.Свернуть("Вершина","");
Если ТЗ.КоличествосТрок()>КолвоВСписке Тогда
Сообщить("Аааа...");
Иначе
Сообщить("Круто...");
КонецЕсли;
КонецПроцедуры
Asmody
35 - 18.07.2004 18:39 		прикольно. мне тут пришлось на обед отвлечься...
вот мое:
Процедура Сформировать()
ТабВершин=СоздатьОбъект("ТаблицаЗначений");
ТабВершин.НоваяКолонка("Вершина");
СпрВ=СоздатьОбъект("Справочник.Вершины");
СпрВ.ВыбратьЭлементы();
Пока СпрВ.ПолучитьЭлемент()=1 Цикл
Если СпрВ.ПометкаУдаления()=1 Тогда Продолжить; КонецЕсли;
ТабВершин.НоваяСтрока();
ТабВершин.Вершина=СпрВ.ТекущийЭлемент();
КонецЦикла;

ТабДуг=СоздатьОбъект("ТаблицаЗначений");
ТабДуг.НоваяКолонка("Начало");
ТабДуг.НоваяКолонка("Конец");
СпрД=СоздатьОбъект("Справочник.Дуги");
СпрД.ВыбратьЭлементы();
Пока СпрД.ПолучитьЭлемент()=1 Цикл
Если СпрД.ПометкаУдаления()=1 Тогда Продолжить; КонецЕсли;
ТабДуг.НоваяСтрока();
ТабДуг.Начало=СпрД.Начало;
ТабДуг.Конец=СпрД.Конец;
КонецЦикла;

СпсВершин=СоздатьОбъект("СписокЗначений");
СпсВершин.ДобавитьЗначение(ТабВершин.ПолучитьЗначение(1,"Вершина"));
ВсегоВершин=ТабВершин.КоличествоСтрок();
ии=1;
Пока ии<=СпсВершин.РазмерСписка() Цикл
ТекВершина=СпсВершин.ПолучитьЗначение(ии);
ТабДуг.ВыбратьСтроки();
Пока ТабДуг.ПолучитьСтроку()=1 Цикл
Если ТабДуг.Начало=ТекВершина Тогда
Если СпсВершин.НайтиЗначение(ТабДуг.Конец)=0 Тогда
СпсВершин.ДобавитьЗначение(ТабДуг.Конец);
КонецЕсли;
ИначеЕсли ТабДуг.Конец=ТекВершина Тогда
Если СпсВершин.НайтиЗначение(ТабДуг.Начало)=0 Тогда
СпсВершин.ДобавитьЗначение(ТабДуг.Начало);
КонецЕсли;
КонецЕсли;
КонецЦикла;
ии=ии+1;
КонецЦикла;

Сообщить(""+СпсВершин.РазмерСписка()+" "+ВсегоВершин);
Если СпсВершин.РазмерСписка()=ВсегоВершин Тогда
Сообщить("Граф связный");
Иначе
Сообщить("Граф несвязный");
КонецЕсли;
КонецПроцедуры
NS
36 - 18.07.2004 18:44 		Хм... скорость замерь...
Если без помеченных - просто условие добавить...
Asmody
41 - 18.07.2004 19:02 		(36) скорость замерил. если выкинуть формирование таблиц (они все равно будут), то получается примерно одинаково...


Уникальность ИНН Контрагента | База знаний | mista.ru

Уникальность ИНН Контрагента

koshechka 13.07.2004 18:14 | Как настроить проверку ИНН в справочнике Контрагентов? Чтобы вообще невозможно было записать, если с таким ИНН Котрагент уже существует. У меня получилось только так: Если ПустоеЗначение(ИНН)=1 Тогда Предупреждение("ВВЕДИТЕ УНН КОНТРАГЕНТА!!!"); ИначеЕсли ПустоеЗначение(ИНН)=0 Тогда Если Выбран() = 0 Тогда СПР=СоздатьОбъект("Справочник.Контрагенты"); СПР.ВыбратьЭлементы(); Пока СПР.ПолучитьЭлемент(1)=1 Цикл Если СПР.ЭтоГруппа()=1 Тогда Продолжить; ИначеЕсли СПР.ЭтоГруппа()=0 Тогда Если СПР.ИНН=ИНН тогда Предупреждение("Нельзя записать Контрагента с таким УНН!"+РазделительСтрок+ "Контрагент уже существует! Проверьте список Контрагентов!"); КонецЕсли; КонецЕсли; КонецЦикла;КонецЕсли; КонецЕсли; У кого эта проблема решена, отзовитесь!
NS 24 - 14.07.2004 11:18 | (17) Прикольно.... Попробуй, как в школе... Пройтись построчно... Процедура ПриЗаписи() Ошибка=0; Если пустоеЗначение(ИНН)=1 Тогда Ошибка=1; Иначеесли выбран()=0 Тогда СПР=СоздатьОбъект("Справочник.Контрагенты"); Если спр.выбратьЭлементыПоРеквизиту("ИНН",ИНН)>0 Тогда ошибка=1; КонецЕсли; спр=""; Иначе СПР=СоздатьОбъект("Справочник.Контрагенты"); спр.выбратьЭлементыПоРеквизиту("ИНН",ИНН); пока спр.получитьЭлемент()=1 цикл Если спр.текущийЭлемент()<>ТекущийЭлемент() Тогда Ошибка=1; прервать; КонецЕсли; конеццикла; спр=""; Конецесли; Если ошибка=1 тогда статусвозврата(1); возврат; КонецЕсли; ....... КонецПроцедуры
koshechka 25 - 14.07.2004 11:37 | Процедура ПриЗаписи() Если Выбран()=0 Тогда Если ПустоеЗначение(ИНН)=1 Тогда Предупреждение("ВВЕДИТЕ УНН КОНТРАГЕНТА!!!"); СтатусВозврата(0); ИначеЕсли ПустоеЗначение(ИНН)=0 Тогда Если Выбран() = 0 Тогда СПР=СоздатьОбъект("Справочник.Контрагенты"); СПР.ВыбратьЭлементы(); Пока СПР.ПолучитьЭлемент(1)=1 Цикл Если СПР.ЭтоГруппа()=1 Тогда Продолжить; ИначеЕсли СПР.ЭтоГруппа()=0 Тогда Если СПР.ИНН=ИНН тогда Сигнал(); Предупреждение("Нельзя записать Контрагента с таким УНН!"+РазделительСтрок+ "Контрагент уже существует! Проверьте список Контрагентов!"); КонецЕсли; КонецЕсли; КонецЦикла;КонецЕсли; КонецЕсли; Если Вопрос("Вы записываете дубль! Выйти без сохранения?","Да+Нет")="Да" Тогда Форма.Закрыть(); КонецЕсли; КонецЕсли; КонецПроцедуры ВСЕ РАВНО ЗАПИСЫВАЕТ!!!! УУУУУУУУУУУУУУУ! :-(((
SiMazx 26 - 14.07.2004 11:40 | Блин... Да не Форма.Закрыть, а СтатусВозврата(0);Возврат;!!!!!!!
NS 27 - 14.07.2004 11:44 | Да уж... в (24) ес-но статусвозврата(0); Вот что значит невыспаться... И сортировку по ИНН - поставить надо...
NS 47 - 14.07.2004 12:17 | Кстати - еще не плохо-бы... Процедура призаписи() ИНН=сокрлп(ИНН); ...... Побежал я к клиенту - потом посмотрю - чем эпопея закончилась...


номер страницы | База знаний | mista.ru

номер страницы

boy 14.07.2004 08:40 | Подскажите как прописать номера страниц в выходной форме(отчете) Что то вроде встроенного в колонтитуле нумерации
Valery 1 - 14.07.2004 08:48 | В колонтитуле и установи #P
laeg 3 - 14.07.2004 09:28 | Так тебе и говорят как в программе ... 1.Конфигуратор 2.Открыть Отчет 3.Таблицу отчета 4. Меню -> Таблица -> Колонтитул -> Верхний (нижний) 5.Ставишь "Галочку выводить с" -> указываешь номер страницы с которой нужно выводить 6.В поле "Страница #P" И все ...


Как подготовить демо версию | База знаний | mista.ru

Как подготовить демо версию

Delirium 25.06.2004 21:26 | Не нашел такой темы в форуме и решил создать новую. Господа, кто нибудь сталкивался с такой ситуацией: Предлагаю конфигурацию. Фирма, в которую предлагаю конфигу, ссылаясь на сильную загруженность и невозможность посмотреть ее "из моих рук" просит демоверсию программы. Так вот, как все же можно сделать демку, ну скажем, ограниченную временем или кол-вом запусков, но полнофункциональную?
Матрейя 1 - 25.06.2004 22:00 | 1. Поставить демо-комплекс защиты Альфа. 2. Использовать какие-нибудь ВК, имеющие ограниченный срок действия, ToySql к примеру. 3. Написать в нескольких местах код, который убивает MD.
Delirium 2 - 25.06.2004 22:26 | Интересно, как можно убить MD из 1С??? К тому же Фирма находится в другом городе и конфиг я должен передать на CD с курьером. А вот про Альфу и ToySQL, щас узнаю по подробнее...
Матрейя 3 - 25.06.2004 22:30 | Очень просто. Создаешь скрипт, который при перезагрузке компьютера удалит MD. По возможности повыноси все во внешние обработки-отчеты и их также коцай.
Delirium 4 - 26.06.2004 11:25 | В снесении смысла нет, т.к. все равно на CD останется.
Delirium 5 - 26.06.2004 12:30 | Все. Отдал так: Конфига под паролем. Добавил скрытые глюки, не сильно влияющие на работу, убрал несколько отчетов. Не заплатят, пошлю все нах...
alxkorvin 6 - 27.06.2004 00:18 | Пароль снимут, глюки уберут, отчеты добавят. Плакали твои денежки. Еще и конфигурацию в свободный доступ выложат, что бы значит все могли пользоваться :)


Работа с графической информацией в 1С | База знаний | mista.ru

Работа с графической информацией в 1С

zov 29.12.2003 12:17 | У фирмы много времени и сил уходит на копирование сертификатов для отправки их вместе с ТТН и товаром. Слышал, что уже разработана компонента позволяющая сканировать документы, хранить их ( в графической БД? или в нутри 1С?) и печатать вместе с накладными. Может кто сталкивался с этим? Или сам писал? Поделитесь. А то мы сами не местные. Да и хата сгорела. Одолжите на билет. Сто миллионов пятьсот миллиардов. ПЖАЛУЮСТА-аа-а!
egor 1 - 29.12.2003 12:58 | если сертификат один, вставь его в отдельную таблицу и при выводе ТТН выводи и сам сертификат
zov 2 - 29.12.2003 13:23 | Хорошо. Но его надо отсканировать. И ... Компактно хранить. Графика всет-ки ... ========================================= Иногда мне кажется, что ответы похожи на анегдот о системном программисте. Древний анегдот...
skunk 3 - 29.12.2003 13:30 | Сканишь 300х300 черно-белым 256 gray scale, сохраняешь. В справочнике создаешь реквизит путь до сертификата. Далее все дело техники считываешь его из файла бросаешь на форму печатешь, смотришь и т.д.
zov 4 - 29.12.2003 17:10 | Получается, что сколько Товаров в Номенклатуре ( около 5000) столько и файлов на диске умножить на прериодичность поступления свежих товаров .... И получаем не подъемные величины. Я поэтому и спрашиваю. Кто уже решал эту задачу. Грамотно рещал. А дать на любой вопрос - любой ответ. Это очень просто. Сэр!?
zov 5 - 29.12.2003 17:12 | И процесс должен быть понятен тупой девочке печатающей ТТН. И тупой бабушке с толстой попой оприходующей товар на складе и которая, собственно, и должна сканить ... А главное хранение графики ...
skunk 6 - 29.12.2003 17:22 | Угу, понятно! Только ты учти, что 1С работает только растровым рисунком. Так что немереных объемов тебе ни как не избежать. Можно конечно изгальнуться написать внешнию компоненту. Хватит тямы дерзай. А процесс понятности ты и будешь реализовывать. И не кто другой. ИХМО
zov 7 - 29.12.2003 19:08 | ЧТО КАСАЕТСЯ 1С-Э. ТО ТУТ ВСЕ ПОНЯТНО. ТАКИЕ ВЕЩИ НЕ ДЕЛАЮТСЯ ВНУТРИ ПРОБЛЕМНО-ОРИЕНТИРОВАННЫХ ЯЗЫКОВ. ЭТО ВНЕШНИЕ ВЕЩИ. КОТОРЫЕ ГРАМОТНО ВЫЗЫВАЮТСЯ. КОРРЕКТНО ВСТРАИВАЮТСЯ. И ПОМОГАЮТ ЖИТЬ. ВОТ Я И СПРАШИВАЮ У ВСЕГО ВООБЩЕСТВА. МОЖЕТ КТО УЖЕ ДЕЛАЛ ТАКОЕ.
skunk 8 - 31.12.2003 08:59 | Глянул тут твои сабжы и все понял, хе програмер ты еще тот. Готовое решение оно есть. К примеру у меня на 8000 наименований товара на серваке храниться куча всякой имфы от внешнего вида до сертификатов. ТЕБЕ ПРЯМ ЗДЕСЬ ВЕСЬ СЫР ПЕРЕБИТЬ ИЛИ КАК.
zov 9 - 12.01.2004 13:36 | Skunk'у от ZOV. Совершенно секретно. Уважаемый Сэр! Прошу простить за долгое молчание. Каникулы, понимаешли. Ну да ладно. Что касается сыра, то его весь перебивать не надо. Это лишнее. Страна не оценит такого героизма. Да и не к чему это. А вот рассказать, человеку следуещее - какая используется Графическая база данных ( если она есть), какой используется интерфейс, и немного о технологии обработки и т.д., было бы не плохо - Человеку. Да я думаю, что и для остальных это было бы интересно. Уж больно мне хочется оценить, что лучше - держать старушку который за тарелку супа которая ведет архив вручную или добавить компоненту и перевести это на современный уровень. Ведь не факт, что это даст материальный эффект. Вот собственно и все соображения по поводу СЫРА. И ТОГо программиста.
Черт 10 - 12.01.2004 14:16 | Поделюсь своим опытом(может он и неправильный, но я решил его так) В базе я храню только имена файлов с картинками, а сами картинки в отдельной папке (имя файла соответствует уникальному номеру, у меня это заводской номер штампа),ну а дальше при составлении документа воовдится этот номер и соответственно подгружается нужный рисунок
zov 11 - 12.01.2004 15:12 | Спасибо! Но это я уже видел. И знаю с чем иногжа приходится сталкиваться. Ну типа, комп сбойнул или девочка что-то намудрила. Но отрицательный опыт уже есть. я поэтому и спрашивал - Применял ли кто нибудь именно базу данных (желательно ориентированную на хранение графики). А почему именно БД да потому что кроме собственно хранения БД предполагает набор процедур для обслуживания и механизмы дополнительного сжатия, а так же поддержание различных графических форматов. Как мне видится. Может я и не прав. Пусть старшие товорищи меня поправят.
skunk 12 - 14.01.2004 05:54 | К сожалению избавиться от изжоги тебе не удастаться в любом случае, где бы ты не хранил картинки, в БД или каждую в отдельном файле. Ставишь дельфина и смотришь примеры. Там есть примерчики как хранить картинки в dbf, по аннологии делаешь в чем тебе надо. Есть пример создания COM серваната. На оснве его лупешь свой COM объект. После чего все это скрещиваешь. И смотришь как к нему обращаться из одинСи. Примеров море 1С и Ексель, в частности. Ну вроде все, общее направление дал, дальше думай сам. PS все примеры смотрелись в пятом дельфине, других дельфинов не видал, просто на фих нужно было, ну думаю что все можно смотреть и в других.
zov 13 - 19.01.2004 10:20 | Спасибо. моцна утискаю.
ViL 14 - 26.06.2004 13:11 | Так все же кто то решил этот вопрос? Картинки пускай храняться где угодно, а в базе только путь до них. ВОт пришел товар, с ним сертификат(ы), определенным образом формируется имя файла для картинки сертификата. Так вот, ставим кнопочку "получить со сканера". Так вот как теперь заставить 1С вызвать окно TWAIN от нашего сканера, получить готовую каритнку, и сохранить ещё с именем которое у нас сформировано? Можно конечно сканировать и вручную задавать имя (которое состоит из 12 цифр), но хотчеться сделать это более понятно.
NS 15 - 26.06.2004 14:10 | "Угу, понятно! Только ты учти, что 1С работает только растровым рисунком." неправда ваша... учите мат. часть.
Матрейя 16 - 26.06.2004 20:05 | На 1c.hippo.ru была Вк,которая позволяла сканировать из 1с, там же была и другая ВК, котрая позволяла хранить файлы внутри 1с. Названия ВК не помню, но в разделе Addin их легко найти.
BorisG 17 - 26.06.2004 20:51 | Самое интересное, что это решено в самй фирме 1С ;-) Как картинка хранятся в базе регистрационные анкеты пользователей ;-)
Z1 18 - 27.06.2004 09:34 | (0) на hippo мое "Хранение двоичных файлов в таблицах 1с v77"
Asmody 19 - 27.06.2004 11:44 | 2(0) на v8 переходи >;))
Орк 20 - 27.06.2004 14:55 | Ну не встроли разработчики поддержку TWAIN, поддержку векторной графики, алгоритм расчета траэктории подлета к луне в свою программу. Ай-я-я-я-й им за это. ;) Для таких задач в природе миллион своих разработок. Например VFP в состоянии в своих таблицах хранить чего угодно (поле с типом General). А поддержка файлов DBF проработана 1с-ом достаточно. Насчет 11 (в случае комп сбойнул ...). Если накроется часть файлов - воостановить нужно будет часть. Если же накроется база с файлами - кранты всем картинкам.


запрет продажи при рентабельности ниже Х% | База знаний | mista.ru

запрет продажи при рентабельности ниже Х%

Михаил 21.06.2004 16:47 | Вопрос 2. Необходимо запретить (или предупредить о том, что это так) пользователю проведение док-тов при рентабельности продажи по позиции менее Х%. Х изменяется в зависимости от прав пользователя от 0, 2, 5 далее с шагом 5 до 40%. Ваши мысли, дамы и господа?
Михаил 2 - 21.06.2004 16:56 | Ну, как сказать... Проблема наверное в моих кривых руках и не совсем под то заточенных мозгах. Поставили задачу, я до этого 1С-конфигуратор не видел даж , ну, не нужно было, а тут вот понадобилось, прошу подсказать пути решения, чтоб хоть знать в каком направлении копать.
Michael99 3 - 21.06.2004 17:05 | Для начала скажи на какой конфигурации работаешь. И готов ли ты поддерживать обновления этой конфигурации после своих переделок.
Композитор 4 - 21.06.2004 17:11 | Задачка несложная. Только не стоит привязываться к текущей рентабельности продажи. Правильнее (я так думаю и делаю у себя) грамотно распорядиться типами цен и скидками. Соотнести конкретного клиента и тип цены (уровень скидки). Вовремя делать переоценку. Все это можно делать без ковыряния в конфигураторе.
Михаил 5 - 21.06.2004 17:27 | 2 Michael99: 7.7 DBF сетевая, да, обновления хотелось бы поддерживать, т.е. если что-то изменится в делопроизводстве (ну, там форма счета или еще что) то проще получить все изменения от 1С, чем переделывать это самому. 2 Композитор: Задача стоит именно в привязке к текущей рентабельности, так как менеджер сам формирует цену по договоренности с клиентом, некоторые даже могут продавать ниже себестоимости, но только те, кто пользуется безграничным доверием руководства. А оперировать скидками не всегда удобно. 2 ALL: Замечательно бы было, если бы помимо рентабельности продажи позиции можно было бы анализировать рентабельность заказа в целом, т.е.: предупреждение - по такой-топозиции цена не удовлетворяет условию рентабельность не ниже Х%, но пускает работать дальше, если по всему заказу рентабельность выше Х%, только тогда документ можно проводить.
Композитор 7 - 21.06.2004 18:02 | (5) Послал по почте обработку. Не совсем то, что нужно Вам, но на мысли натолкнет.
Michael99 10 - 22.06.2004 11:46 | (0) Я боюсь, что реализация всего этого выльется в большой геморой при многопользовательской работе. Т.е если менеджеры продают один и тот же товар. В ТиС себестоимость определяется в момент проведения документа. В момент проведения (если не стоит ручной выбор партии) определяется какая партия(ии) будут списыватся. Т.е предварительный анализ сделать конечно можно , но не факт что он будет таким же как при проведении. Но в любом случае тебе надо лезьт в модуль документа и править процедуру Проведения, что как сам понимаешь отразится на обновлениях. Я бы как и (4) рекомендовал ограничится косметическими изменениями с предоставлениям разным группам менеджеров различных скидок. Наценка как правило известна и в пределах нее можно поиграть. По поводу торговли ниже себестоимости. Если это каким то боком попадет в бух отчетность , нарветесь на санкции.


Учёт товаров по серийным номерам. | База знаний | mista.ru

Учёт товаров по серийным номерам.

asdd FX 21.06.2004 12:30 | Добрый день. Начальник заставил переделать конфигурация под v8 таким образом чтобы учёт товаров вёлся по серийный номерам... тоесть в документах, атких как приход товаров, перемещение товаров, продажа товаров, везде главное значение имело поле сериный номер.. может кто то уже сталкивался с подобными задачами? так вот у меня будет просьба - посоветуйте как реализвать данную задачу.. в принцыпе я довольно неплохо знаком с 1cv8 (язык и т д) но вот алгоритм как сделать точто надо мне не понятен.. вобшем кто что может подскажите. заранее спасибо =)
Valery 1 - 21.06.2004 13:48 | Примерно так. Создаешь подчиненный сравочнику Номенклатура, справочник Серий. Во все документы вносишь дополнительное поле Серии(в табличную часть). В регистры учета товара тоже самое. Правишь модули документов с учетом изменений.


Подскажите как мне организовать поиск данных? | База знаний | mista.ru

Подскажите как мне организовать поиск данных?

MadGhost 20.06.2004 00:19 | скажем есть документ, там форма. есть список определеный: выглядит так. форма наименование <поле ввода> таблица Наименование Реквизиты т.е. надо по наименованию (т.е. шаблон скажем с *-дочками) вывести список всех кто подходит под определение скажем Дев* и все что с ним связано. вывести надо в таблицу. все в одном документе. как сделать?
Орк 2 - 20.06.2004 15:56 | 1.А не кажется ли Вам уважаемый, что поиск записи в базе и отбор нескольких записей по какому-либо условию несколько разные понятия и соответственно действия ? 2. Термин [вывести список всех] несколько расплывчат и порождает у читателя несколько вопросов в догонку : - все это кто? (документы, реквизиты, девченки, передачи ТВ...)? - и что с этим может быть связано? Не хотите получить глупый ответ - не задавайте глупых вопросов
MadGhost 3 - 20.06.2004 21:52 | не дело не в глупых вопросах. и не в том что выбирать. например я со склада хочу получить всё пиво Балтика что есть, скажем там может быть 3,7,9 и другие. надо задать типа "*Балтика*" чтобы нашлось все пиво. со склада, со справочника. вот.... т.е. есть форма. мда, щас посмотрел, организовать это не реально. значит выводим это в отчетах. как выполняются запросы вида "*балтика*" ????
SnarkHunter 4 - 20.06.2004 22:08 | Select ID From SC156 Where Lower(Descr) Like '%балтика%'
Asmody 6 - 20.06.2004 22:23 | 2SnarkHunter: а почему сразу SC156? а чем SC84 или SC4089 не подходит?
SnarkHunter 7 - 20.06.2004 22:31 | (6)Ок... СпрНоменклатура = "SC" + РадугаМД.ИДСправочника("Номенклатура"); ТекстЗапроса = " |Select ID | From " + СпрНоменклатура + " | Where Lower(Descr) Like '%балтика%'";
Asmody 8 - 20.06.2004 22:37 | (7) давай докопаюсь, а? (настроение такое) а почему "Номенклатура"? >;)) и почему ты уверен, что в (0) про 7.7 речь? >;))
SnarkHunter 11 - 20.06.2004 22:50 | (8)Воспринимай это как пример...


Накопительный счетчик - обработка статистики | База знаний | mista.ru

Накопительный счетчик - обработка статистики

Sovushka
15.06.2004 17:16 		Начальство поставило задачу перевести базу с акцесса в 1с (единообразие .... - отчеты им в 1с смотреть удобнее)
в базе хранятся записи от накопительных счечиках на оборудовании (счетчики похожи на электрические которые КВТ дома меряют)
Условия - записи отсортированы в порядке дата, время и несколько записей типа число)
Вопросы
1. как это все хранить - переодический справочник не подходит - записей на одно число может быть несколько.
2. Создать отчеты по этим данным
3. люди это набирают ручками - но приходят еще из подразделений с файлами за несколько дней - импорт можно из этих фалйов по определенным правилам сделать (форму файла можно разработать самому :) - разрешили)
4. Автоматическое создание из отчетов проводок в другой бухгалтерии (её я точно править не буду - она стандартная и вроде даже работает:)
5 Вобще стоит ли за это братся или проще переписать на акцессе базу и послать начальство и работу с 1,2,3 и 4 вопросом?

ЗЫ Я чайник в 1С, подставка - RTFM и иже с ними
mszsuz
1 - 15.06.2004 17:23 		Под эту задачу подходят оборотные субконто или регистр оборотов.
Vvv2
2 - 15.06.2004 19:59 		Задача простейшая.
Хранить можно в реквизитах документов. Кои можно не проводить и сл.
не относить ни к какому виду (оперативные, бух, расчет).
Построить отчет по документам тоже не проблема
(для ленивых см. конструктор отчетов в пофигураторе).
Насчет автоматического формирования проводок несколько сложнее.
Проще всего пользовать ОЛЮ.
Сложность в том, что нужно какимто образом иметь общий с бухией алгоритм
формирования суммы проводки
427
4 - 15.06.2004 22:06 		проектировщики из вас хреновые....

Задача то непростая.... Ладно, .....
Сначала о (2)
\"Хранить можно в реквизитах документов. Кои можно не проводить и сл.
не относить ни к какому виду (оперативные, бух, расчет).\"

хватит.... можно увольнять как полного идиота... использовать доки, когда есть регистры/счета

\"Насчет автоматического формирования проводок несколько сложнее.\" -- как раз это не вызывает никаких проблем...

теперь (1) - использование оборотного регистра/счета - ну, в принципе потянет.. Но есть технические сложности...
Идут показания приборов.... 100, 200, 300, ... и т.д. Для оборотного регистра нужно вносить разность показаний последнее минус предпоследнее.... Все вроде бы ничего, но есть заморочка - а если делается ввод задним числом - что делать? Оборот то введен...

Немного о том, чего никто не увидел....

Из (0) - имеем записи вида
Прибор дата время показание..... Показание НАКОПИТЕЛЬНЫЕ.... Следовательно, весь оборот есть последнее показание минус первое показание...
Оборот за заданный период есть показание на конец минус показание на начало периода....

итак,
Первое - что будем делать и хранить при вводе информации задним числом?

Второе - приборы имеют такую регламентную штуку, как ремонт и поверка, т.е. показания счетчика после поверки произвольные... Как ее учитывать?

Третье - приборы имею такую вещь, как переворот в ноль... т.е. 5 разрядный прибор (тот же спидомЭтр) .... 99997 99998 99999 .... а дальше НОЛЬ, уважаемые... Как вы будете учитывать переворот?

Четвертое - анализ разности показаний (оборотов) с учетом времени - это важная информация.... позволяющая выявить зависимость УРОВНЯ РАСХОДА от дня месяца, недели, дня недели, часа .... и т.д. Это сказано в (0) - хранится ДАТА и ВРЕМЯ.
И эта информация важна (т.е. должны храниться все показания) для получения нужных отчетов...

Ну ладно... хватит для начала...

P.S. это еще не все... Если делать полную постановку, есть еще несколько критических пунктов...
mszsuz
5 - 15.06.2004 22:39 		Последовательности нам помогут ...
Пусть max=999.
Типа алгоритма:
1) 00:00:00 = 100 (самое первое показание, вводим начальный остаток на все количество = 100. 100 в регистр. Последовательность здесь.)
...
2) 00:10:00 = 123 (Создаем док с этим временем. Последовательность не нарушена. Берем показание с ГП (Пишем в регистр разницу: 123-100=23)
3) 00:05:00 = 111 (Сбили последовательность. Обратным порядком находим предыдущий, берем из него показания. Перепроводим далее по Последовательности, пересчитывая разницу)
...
02:00:01 = 5 (Переворот. Разница отрицательная. Считаем: Разница=max-Предыдущее+Текущее=999-123+5. Опять пишем разницу.)
yaret
7 - 16.06.2004 00:19 		Действительно вопрос сложный. Особенно если начинать его изучать с нуля. Я пришел к выводу, что, используя 1С.Бух, показания счетчиков необходимо заносить как субконто, используя дополнительный счет, специально предназначенный для этих целей. Контроль за вводом можно осуществлять проверкой вводимых данных - если вводимые данные меньше предыдущих - предупреждать сообщением и не проводить такой документ, поэтому для ввода задним числом придется вернуться в последний проведенный документ и там уменьшать показания счетчика и менять дату документа (но это пока как вариант). Контроль за обнулением вести с помощью учета разрядности счетчика и дополнительной операцией оператора по изменению показаний, например, добавить на форму флажек "обнуление".
ЗЫ Это мое личное умозаключение, к которому я пришел, изучая вопрос о доработке типовой 1С.бухгалтерии для госсектора отдела энергосбыта электроснабжающей организации.
427
8 - 16.06.2004 07:30 		(7) - решение через Ж.... ... искать, уменьшать....
К тому же ты хранишь только обороты - у тебя частный случай, просто расход без анализа по времени....

(5,6) ну до чего любят некоторые .... трахаться с перепроведением....
Ведь эту задачу решали тысячи людей ... и без последовательности...
Valery
9 - 16.06.2004 08:39 		427.
Без документов никак не обойдешся, т. к. запись в регистры без них не внесешь.
По поводу счетчиков. В базе всерано хранятся только приращения, какое показание счетчика будет реально, для базы по барабану.
Я так думаю.
Sovushka
10 - 16.06.2004 10:28 		Как вывод
1. Хранить документы по каждому счечику, с признапками группы (ну например в отдельном журнале)
в документе писать преведущее значение и текущее
2. документы проводить хитрым образом как расчет оборотов по показаниям счетчика (для быстрого формирования отчетов) (при проведении и проверять переполнение, а также завести флаг о регламентных работах(т.е. например замене)
3. При проведении документа задним числом все документы с датами после введеной (включая введенную дату)и относящуюся к данному автомату перепроводить и перепроверять на изменение последующих начальных значений (за исключением тех документов которые имеют флаг регламентных работ)
4. для проведения отчетов типа расходов за период - хранить в документах дату и время преведущих значений счетчиков и дату и время введения счетчиков
5. имеет ли смысл хранить обороты в данном случае на счетах - может собирать сразу из документов и план счетов не использовать?
6. по поводу создания документов в другой бухгалтерии
нужно создавать документы двух типов (они там стандартные - ну для начала буду тестировать на приходных и расходных ордерах :), т.е. нужно создать новый документ, заполнить его и записать :). Но в тоже время нухно проводить по группам.
7. хорошо мы храним все данные в документах. что хранить в документах если они разбиты на группы? счетчики могут перемещатся между группами - т.е. надо хранить в документе еще и группу?
8. Если счетчики вводятся все для группы - как формировать документы - разбивать каждый на кучу мелких однотипных - а потом на дату деать сборку ?
9. И на последок вопрос по Excel - импорт сделать возможно в 1с ?
mszsuz
11 - 16.06.2004 10:36 		"3. При проведении документа задним числом все документы с датами после введеной ..." -
Нет, не все, только следующий. Остальные не изменятся.
По поводу (9): http://www.sinor.ru/~my1c/knowhow.html#EXCEL


скрыть элементы справочника | База знаний | mista.ru

скрыть элементы справочника

ollleup 16.06.2004 07:32 | в одной базе ведёться несколько фирм. соответсвенно имеется несколько складов. как сделать так, чтобы при выборе определённой фирмы отображались только её склады, а остальные были невидимы?
ollleup 2 - 16.06.2004 07:48 | стандартная торговля. релиз последний. при создании любого документа(ну почти любого) мы должны выбрать фирму и к ней соответственно склад. вопрос: как сделать так, чтобы у определённой фирмы отображались только определённые склады(при выборе склада)? т.е. как скрыть ненужные?
SnarkHunter 4 - 16.06.2004 07:57 | Связать справочники надо... Либо через реквизит в справочнике Склад и последующий фильтр, но это если на складе всегда товары одной фирмы, что необязательно... Либо через подчиненный справочник СкладыФирмы, если на складе могут храниться товары нескольких фирм...


Организовать в журнале отбор по графе только для одного вида документа | База знаний | mista.ru

Организовать в журнале отбор по графе только для одного вида документа

Оксана 15.06.2004 10:57 | Задача заключается в том, чтобы организовать графу отбора только для одного вида документов. Отбор по значениям может производиться только в «Общем» журнале, т. е. в котором установлен признак «Все документы». Для того, чтобы создать видимость, что журнал не «Общий», а «Обычный» и в нем собраны документы одного вида, делаю предопределенную процедуру ПриОткрытии: устанавливаю отбор по виду документа и назначаю возможные отборы опять же по виду документа и по графе отбора. // =============================== Процедура ПриОткрытии() УстановитьОтбор(ВидДокумента); ВидыОтбора(ВидДокумента,ОтборПоГрафе); Конец процедуры Все красиво до того момента пока пользователь, интерактивно формируя отборы, нажимает кнопку «Отключить отбор», и тут все документы лезут в этот журнал. Подскажите, как отследить нажатие на кнопку «Отключить отбор».
mszsuz 1 - 15.06.2004 11:06 | в ПриУстановкеОтбора() в журнале СтатусВозврата(0); не помогает?
Оксана 2 - 15.06.2004 11:14 | Тогда будет невозможно установить отбор по графе. Нужно отслеживать, что это именно "Отключить отбор"
Warlock 4 - 15.06.2004 12:07 | А если так: Процедура ПриУстановкеОтбора(ИмяРеквизОтбора,Значение) Если ПустоеЗначение(Значение) = 1 Тогда СтатусВозврата(0); КонецЕсли; КонецПроцедуры


Как установить первоначальное значение "Поля выбора" в 1С 8.0? | База знаний | mista.ru

Как установить первоначальное значение "Поля выбора" в 1С 8.0?

ChAlex
11.06.2004 00:07 		Кто знает, как установить начальное значение "Поля выюора" в 8.0 при открытии формы. При открытии формы формирую список выбираемых значений поля "СписокСотрудников" типа строка, далее пытаюсь инициализировать начальное значение ЭлементыФормы.СписокСотрудников.Значение="Иванов" а при открытии формы значение - пустая строка. В отладчике тип свойства "Значение" остается "Неопределено". При интерактивном изменении оно меняется на тип "строка" и соответсвенно присваивается значение.
Asmody
1 - 11.06.2004 00:44 		Эх, спит Волшебник! Самому придется отдуваться.
Вот так попробуй:

Процедура ПриОткрытии()
ЭлементыФормы.СписокСотрудников.СписокВыбора.Добавить("1");
ЭлементыФормы.СписокСотрудников.СписокВыбора.Добавить("2");
ЭлементыФормы.СписокСотрудников.СписокВыбора.Добавить("3");
ЭлементыФормы.СписокСотрудников.СписокВыбора.Добавить("4");
СписокСотрудников="1";
КонецПроцедуры
ChAlex
2 - 11.06.2004 01:21 		Так и делал. Не работает!!! Спасибо , но уже разобрался сам.

Надо так:

ЭлементыФормы.СписокСотрудников.СписокВыбора.Добавить("1");
ЭлементыФормы.СписокСотрудников.СписокВыбора.Добавить("2");
ЭлементыФормы.СписокСотрудников.СписокВыбора.Добавить("3");
ЭлементыФормы.СписокСотрудников.СписокВыбора.Добавить("4");
Отправитель="1";
// Отправитель - имя перемонной, установленной в свойстве "Данные" поля выбора.

Вобщем завернуто круто ... (и даже с документацией сразу не доезжаешь)
Asmody
3 - 11.06.2004 11:48 		(2) если точнее, Отправитель у тебя (и СписокСотрудников к меня) - это реквизит формы, который установлен в свойстве "Данные"
ezh
4 - 11.06.2004 11:52 		http://itland.ru/forum/index.php?showtopic=2884


Программное изменение заголовка окна 1С 7.7 | База знаний | mista.ru

Программное изменение заголовка окна 1С 7.7

sheale 04.06.2004 13:59 | У меня стоит УРБД. Есть несколько баз. Они одинаковые по конфигурации, но имеют разное назначение. Что бы пользователь не путался, с какой базой работает, я хочу изменять заголовок окна в зависимости от значения константы базы. Можно ли сделать такое, или как-либо облегчить пользователю идентификацию базы
lexa 2 - 04.06.2004 14:31 | В глобальном модуле в процедуру ПриНачалеРаботыСистемы() вставляешь строчку ЗаголовокСистемы(Константа.Заголовок);
sheale 4 - 04.06.2004 15:16 | Спасибо. Все получилось. А, у меня действительно ТиС. ЗаголовокСистемы(СокрЛП(Константа.Заголовок)+". Пользователь: "+ИмяПользователя()+". Права: "+НазваниеНабораПрав() );


Контекстный поиск во внешних файлах | База знаний | mista.ru

Контекстный поиск во внешних файлах

Вик 04.06.2004 08:31 | Кто нибудь пробовал по набору слов из 1С искать документы в папке - *.doc, *.rtf, *.xls, *.eml ? Если возможно подскажите, пожалуйста, как это можно сделать.
VladZagorsky 1 - 04.06.2004 09:04 | Стандартными средставми 1С - нельзя, однозначно !
Вик 2 - 04.06.2004 09:15 | Ну эт, понятно. Но наверно можно доступ к тексту на уровне макросов в ворде через олю, хотя гемор... С другой стороны искать контекстно в самих виндах ручками можно, но как сделать это программно? Может еще что есть?
Вик 4 - 04.06.2004 09:20 | Есть мини-конфа для кадрового агентства, там папка с резюме...
mszsuz 5 - 04.06.2004 10:47 | find "Нужное_Слово" [путь_к_файлам_можно_с_маской]>result.txt и разбирай полученный текстовый файл ...
Вик 6 - 04.06.2004 11:40 | Спасибо, попробовал, если ищем латинницу, находим, если кирилицу в *.DOC - файлах - то не находим, но кроме этого работает супер-медленно, я ждал минут 10 на примерно 1000 файлов резюме Нет ли еще чего?
Вик 7 - 04.06.2004 11:42 | Кстати, при поиске руками с помощью ФАРа и указании "по всем таблицам символов" нашел 78 файлов за 20 секунд
SnarkHunter 8 - 04.06.2004 11:43 | (6)Ты думаешь, что поиск в произвольном неструктурированном тексте будет работать быстрее?
Вик 9 - 04.06.2004 11:51 | Быстрее чего - find, или FAR? Фар ищет с приемлемой скоростью, и потом я не ставлю вопрос так. Меня интересуют 4 типа файлов, расположенных в указанной папке. Если есть возможность обратиться к виндовым механизмам поиска - было бы прекрасно, только как? Если есть другое решение, тоже хорошо, ?какое


Выснить разрешение экрана на пользовательской машине | База знаний | mista.ru

Выснить разрешение экрана на пользовательской машине

Валентин
31.05.2004 23:48 		Где-то видел на коныеренции, но поиск что-то не находит.
Там как-то через VBS извращались.
Помогите пожалуйста...
unior
2 - 01.06.2004 06:15 		// Как определить экранное разрешение
// ------------------------------------------
// Copyright (C) MAV 2002
// ------------------------------------------
// Автор: Андрей Михайлов
// E-Mail/MSN : m4v@mail.ru
// ICQ : 137167406
// URL : http://zone1c.narod.ru

//_____________________________________________________________________________
//
// Через WMI
//_____________________________________________________________________________

Процедура Через_WMI()
Locator = СоздатьОбъект("WbemScripting.SWbemLocator");
Service = Locator.ConnectServer();
Service.Security_.ImpersonationLevel=3;

Video = Service.Get("Win32_VideoController.DeviceID='VideoController1'");
Стр = "" + Video.CurrentHorizontalResolution + "x" + Video.CurrentVerticalResolution;

Предупреждение(Стр, 5);
КонецПроцедуры //Через_WMI

//_____________________________________________________________________________
//
// Через IE
//_____________________________________________________________________________

Процедура Через_IE()
oIE = СоздатьОбъект("InternetExplorer.Application");
oIE.navigate("about:blank");
Пока oIE.readyState<4 Цикл
КонецЦикла;

oScreen = oIE.document.parentWindow.screen;
Стр = ""+oScreen.width+"x"+oScreen.height;

Предупреждение(Стр, 5);
КонецПроцедуры //Через_IE
//_____________________________________________________________________________
mszsuz
4 - 01.06.2004 09:11 		http://www.sinor.ru/~my1c/knowhow/get_res.html


Как завершить сеанс 1с (закрыть программу) | База знаний | mista.ru

Как завершить сеанс 1с (закрыть программу)

a_aladdin 26.05.2004 09:18 | Всем привет - возникла такая необходимость... Нужно, собственно, следующее - с утра запустить командный файл, кототорый сначала удалит индексы, потом запустит 1с монопольно, потом ПриНачалеРаботеСистемы(),а вот как именно закрыть монопольный сеанс не знаю Может кто че получше предложит?
SnarkHunter 1 - 26.05.2004 09:30 | Сделай специального юзера для такой операции, ПриНачалеРаботыСистемы() анализируй имя и говори СтатусВозврата(0); Возврат
Druid 3 - 26.05.2004 09:56 | Есть такой платировщик - nncron (www.nncron.ru). Он тебе поможет. Вообще-то он много чего умеет
Druid 5 - 26.05.2004 10:05 | А он не только запускать умеет, но и эмулировать действия пользователей (например, нажатие кнопок). Фактически это мощный скриптер.


Сортировка по алфавиту | База знаний | mista.ru

Сортировка по алфавиту

оля 21.05.2004 02:57 | Как сделать сортировку по алфавиту в отчете (в него выгружаются выборочные данные из справочника)
unior 1 - 21.05.2004 05:39 | Загоняй перед выводом данные в ТЗ, затем сортируй и выводи.
427 2 - 21.05.2004 07:27 | Только юниоры делают лишние действия.... При выборке данных из справочника перебором или запросом по умолчанию система отдает элементы в том порядке, какое написано в ОсновноеПредставление .... У большинства справочников в типовой стоит ПорядокНаименований.... Это и есть сортировка по алфавиту.... Порядком выдачи элементов можно управлять (ПорядокКодов, ПорядокНаименований)... Группы могут ломать сортировку по списку - тогда нужна выгрузка в ТЗ, и хитрая сортировка - чтобы в отчете вопроизвести дерево справочника в том виде, как оно существет в справочнике


Как проверить наличие объекта (реквизита) ? | База знаний | mista.ru

Как проверить наличие объекта (реквизита) ?

Zernov 19.05.2004 20:45 | Можно ли проверить сабж у объекта метаданных. Вроде знаю, что можно, но каким методом?
Bzzzzz 1 - 19.05.2004 20:49 | может так: Документ("ИмяДок").Реквизит("ИмяРеквизита").Выбран()
Bzzzzz 2 - 19.05.2004 21:02 | Во: Метаданные.Документ("Доверенность").РеквизитШапки("Контрагент").Выбран()
427 3 - 19.05.2004 22:18 | (2) ответ неполный.... Есть еще 2 категории, где этот реквизит м.б. (0) какой из семи способов тебя устроит?....
Волшебник 4 - 19.05.2004 22:25 | Для версии 8.0: проверка существования реквизита документа (реквизита шапки): Если Метаданные.Документы[ВидДокумента].Реквизиты.Найти(ИмяРеквизита) <> Неопределено Тогда проверка существования реквизита табличной части ТабЧасть = Метаданные.Документы[ВидДокумента].ТабличныеЧасти.Найти(ИмяТабЧасти); Если ТабЧасть <> Неопределено И ТабЧасть.Реквизиты.Найти(ИмяРеквизита) <> Неопределено Тогда а общих реквизитов документов в 8.0 не бывает


Работа с XBase | База знаний | mista.ru

Работа с XBase

Lark 18.05.2004 19:46 | Ответьте кто-нибудь! Можно ли увеличить количество знаков имени поля? у меня всего длина получается 10 знаков.
GrayT 1 - 19.05.2004 00:31 | 10 знаков это вроде стандарт для DBF. Во всяком случае DBU умеет только 10.


Пиктограммы | База знаний | mista.ru

Пиктограммы

REM 15.05.2004 09:51 | Как перенести пиктограммы из ТИС в БУХ???
GrayT 1 - 15.05.2004 13:13 | Библиотеку картинок? Я плагином к фару папку Picture перекопировал в МД :) Думаю там старые картинки упали - проверять не охота. А так по одной - не мудрувствуя лукаво.


просмотр и печать jpg из 1С | База знаний | mista.ru

просмотр и печать jpg из 1С

Dim 15.05.2004 23:30 | Не подскажете что лучше использовать для работы с jpg в 1С ?
Василек 1 - 16.05.2004 00:41 | Для работы с JPG из 1С лучше всего использовать 1С. :)))


Как скрыть окно сообщений програмно? | База знаний | mista.ru

Как скрыть окно сообщений програмно?

Gavrila 15.05.2004 19:25 | Есть ли какая-либо возможность програмно закрывать окно сообщений с заданной периодичностью?
Волшебник 1 - 15.05.2004 19:29 | только вместе с самой программой 1С:Предприятие :) ПрекратитьРаботуСистемы
Gavrila 4 - 15.05.2004 19:55 | (3) Ctrl+Shift+Z да есть такое, просто вот эти самые клиенты хотят все таки видеть все выдаваемые при проведении документов сообщения,предупреждения и т.д. и т.п., но что бы оно само потом закрывалось. Руки у них корявые такую комбинацию на клаве нажимать... :) Ладно, пустое это, буду учить :))
Волшебник 5 - 15.05.2004 20:03 | Открывай спецобработку, выводи туда все сообщения и закрывай ее. Или поставь 1С:Предприятие 8.0 :)
BorisBiz 7 - 15.05.2004 20:26 | см вот здесь http://avb1c.narod.ru/ Тем более, что здесь http://forum.mista.ru/topic.php?id=4342 уже отвечали :)
427 9 - 15.05.2004 20:52 | Методика перехвата сообщений давно реализована в российских типовых...


Где описание внешнего формата для файла выгружаемого по ЗначениеВФайл? | База знаний | mista.ru

Где описание внешнего формата для файла выгружаемого по ЗначениеВФайл?

Реанимация 14.05.2004 17:26 | Надо произвести экспорт из 1С в третью прогу, где найти описание внешнего формата файла создаваемого с помощью функции ЗначениеВФайл, при выгрузке СпискаЗначений?
Реанимация 2 - 14.05.2004 17:47 | Ну тогда, может изходя из богатого опыта и знаний кто объяснит! Вот пример этого самого выгруженного файла (вернее его начало и первое выгруженное значение) {"VL",{{{"S","0","0","0","0","0","ОАО ""Пшеница"""},"ОфициальноеНаименование"},..}} Идентификатор где, значение, тип данных тут вроде всё понятно, а вот что означает "VL" и зачем столько нулей "0" - понимается с трудом!
Bzzzzz 3 - 14.05.2004 17:52 | (1) Хорошо сказано :-) VL = Value List
Реанимация 4 - 14.05.2004 18:00 | to Bzzzzz - спасибо большое, остались нули. Я вообще с 1С неочень, может это шаблон для каких то многоразмерных типов данных, отличных от обычных массивов. Есть такие в 1С.
Bzzzzz 5 - 14.05.2004 18:04 | (4) S = Строка видимо, а про нули не знаю. Мож Пит перестанет стебаться и откроет нам тайну :*)
427 6 - 14.05.2004 18:09 | Спроси у яндекса по строке "ЗначениеВСтрокуВнутр"


Как запустить выполнение Процедуры в определенное время? | База знаний | mista.ru

Как запустить выполнение Процедуры в определенное время?

Львенок
1 - 13.05.2004 11:40 		Проверить в обработке ожидания текущее время.
___
Искренне Ваш, Львенок.
gr13
2 - 13.05.2004 11:51 		ОбработкаОжидания во втором параметре стоит время в секундах, а не проверка, хотя может что нить недокументированного?
Львенок
3 - 13.05.2004 13:07 		//-------ГлобальныйМодуль начало
Перем глСделано;

//-------ГлобальныйМодуль серидина, где все процедуры
Процедура глСделатьТогдаТо()
Ч=0;М=0;С=0;
ТекущееВремя(Ч,М,С);
Время=Ч+М*60+С*3600;
Если (Время>=Константа.ВремяХ) И (Время<=Константа.ВремяХ+300) И (Сделано=0) Тогда
Сделано=1;
глСделатоТоТо();//Здесь делаем то, что нужно сделать
КонецЕсли;
КонецПроцедуры

//-------ГлобальныйМодуль самый конец, после всех процедур
ОбработкаОжидания("глСделатьТогдаТо()",5);
глСделано=0;//Еще ничего не сделано

Есть константа ВремяХ, которая задает то значение времени (в секундах прошедших с начала суток) в которое надо что-то сделать. Процедура глСделатьТогдаТо() выполняется каждые пять секунд и проверяет не настало ли ВремяХ, если время уже настало то делает то, что нужно. Если в течении пяти минут после наступления времени "Х" 1С будет сильно занята (формировать какой-то сложный отчет), то "Что-то" может и не выполнится. Если в течении пяти минут после наступления времени "Х" пользователь выйдет из 1С и снова зайдет в нее "Что-то" может выполниться более одного раза.
Примерно так.
___
Искренне Ваш, Львенок.
Львенок
4 - 13.05.2004 13:08 		Ошибочка: "Если (Время>=Константа.ВремяХ) И (Время<=Константа.ВремяХ+300) И (Сделано=0) Тогда
Сделано=1; "
Заменить Сделано на глСделано;
___
Искренне ваш, Львенок.
Gavrila
5 - 13.05.2004 13:25 		если (0) то только ВК
gr13
7 - 13.05.2004 13:33 		(5) почему, я так понимаю, что данная процедура в глобальном, будет работать со всеми пользователями?
Frol
8 - 13.05.2004 13:35 		Можно сделать проще.
В предопределенной процедуре "ПриНачалеРаботыСистемы" необходимо просто вычислить, сколько секунд осталось до нужного времени и поместить в какуюнибудь глобальную переменную, например глКолСекунд. А потом вызвать
ОбработкаОжидания("глНужнаяПроцедура",глКолСекунд); // глНужнаяПроцедура - процедера в которой и запустите всё что хотите.
Естесственно, переменную глКолСекунд нужно определить.
Gavrila
9 - 13.05.2004 13:39 		(7) "ОбработкаОжидания запускает данную процедуру с заданным интервалом, а как не с интервалом, а на заданное время?" - вот на этот вопрос и ответ (5) :))
gr13
10 - 13.05.2004 13:41 		(9) Естессно, а в процедуре стоит контроль на время работы ее(процедуры)


Обработка клавы | База знаний | mista.ru

Обработка клавы

Maximus 06.05.2004 15:34 | Помню что была уже такая тема,но может быть у кого появились реальные идеи.Меня интересует обработка с помощью стандартных средств,а не дополнитеьных компонент.
mszsuz 1 - 06.05.2004 15:38 | http://1c.hippo.ru/cgi-bin/predownl.cgi?id=2673
SnarkHunter 3 - 06.05.2004 15:41 | (1)Обработка клавиш Del, Ins и т.п. не прокатывает...
Maximus 6 - 06.05.2004 16:02 | В принципе мне вообще-то нужны тока стрелки.При нажатии оной выполняется конкретное действие.mszsuz,в кратце как работает можно пояснить.плиз)
mszsuz 12 - 07.05.2004 10:10 | (11) Пож-ста: http://1c.hippo.ru/cgi-bin/predownl.cgi?id=2344


Транслит в 1С | База знаний | mista.ru

Транслит в 1С

Kudryashka
06.05.2004 12:32 		я не сталкивалась, может кто подскажет кто сталкивался? вот в справочнике занесена фамилия сотрудника например Иванова Маша. а при выводе отчета нужно две графы где в одной пишется Иванова Маша, а во второй Ivanova Masha. Возможно ли это? и как?
Valery
1 - 06.05.2004 12:44 		В 1с такое используется часто. например справочник Номенклатуры или контрагентов
Там есть два поля : Наименование и Наименование для печати.Можно так же сделать по аналогии.Добавить еще одно поле. Одно с русским наименованием, другое с английским.
Kudryashka
2 - 06.05.2004 12:47 		нет, два поля не пойдет. не буду же они вводить вручную все фамилии еще и не транслите.. это же моя задача как сделать чтобы так выводилось.
Композитор
4 - 06.05.2004 12:54 		Функция Исправить(Имя)
Рез = СокрЛП(Имя);
Рез = СтрЗаменить(Рез,"а","a");
Рез = СтрЗаменить(Рез,"б","b");
Рез = СтрЗаменить(Рез,"в","v");
Рез = СтрЗаменить(Рез,"г","g");
Рез = СтрЗаменить(Рез,"д","d");
Рез = СтрЗаменить(Рез,"е","e");
Рез = СтрЗаменить(Рез,"ё","e");
Рез = СтрЗаменить(Рез,"ж","zh");
Рез = СтрЗаменить(Рез,"з","z");
Рез = СтрЗаменить(Рез,"и","i");
Рез = СтрЗаменить(Рез,"к","k");
Рез = СтрЗаменить(Рез,"л","l");
Рез = СтрЗаменить(Рез,"м","m");
Рез = СтрЗаменить(Рез,"н","n");
Рез = СтрЗаменить(Рез,"о","o");
Рез = СтрЗаменить(Рез,"п","p");
Рез = СтрЗаменить(Рез,"р","r");
Рез = СтрЗаменить(Рез,"с","s");
Рез = СтрЗаменить(Рез,"т","t");
Рез = СтрЗаменить(Рез,"у","u");
Рез = СтрЗаменить(Рез,"ф","f");
Рез = СтрЗаменить(Рез,"х","h");
Рез = СтрЗаменить(Рез,"ч","ch");
Рез = СтрЗаменить(Рез,"ш","sh");
Рез = СтрЗаменить(Рез,"щ","sch");
Рез = СтрЗаменить(Рез,"ъ","");
Рез = СтрЗаменить(Рез,"ь","");
Рез = СтрЗаменить(Рез,"э","e");
Рез = СтрЗаменить(Рез,"ю","yu");
Рез = СтрЗаменить(Рез,"й","i");
Рез = СтрЗаменить(Рез,"ц","c");
Рез = СтрЗаменить(Рез,"я","ya");
Рез = СтрЗаменить(Рез,"ы","i");
Рез = СтрЗаменить(Рез,"А","A");
Рез = СтрЗаменить(Рез,"Б","B");
Рез = СтрЗаменить(Рез,"В","V");
Рез = СтрЗаменить(Рез,"Г","G");
Рез = СтрЗаменить(Рез,"Д","D");
Рез = СтрЗаменить(Рез,"Е","E");
Рез = СтрЗаменить(Рез,"Ё","E");
Рез = СтрЗаменить(Рез,"Ж","ZH");
Рез = СтрЗаменить(Рез,"З","Z");
Рез = СтрЗаменить(Рез,"И","I");
Рез = СтрЗаменить(Рез,"К","K");
Рез = СтрЗаменить(Рез,"Л","L");
Рез = СтрЗаменить(Рез,"М","M");
Рез = СтрЗаменить(Рез,"Н","N");
Рез = СтрЗаменить(Рез,"О","O");
Рез = СтрЗаменить(Рез,"П","P");
Рез = СтрЗаменить(Рез,"Р","R");
Рез = СтрЗаменить(Рез,"С","S");
Рез = СтрЗаменить(Рез,"Т","T");
Рез = СтрЗаменить(Рез,"У","U");
Рез = СтрЗаменить(Рез,"Ф","F");
Рез = СтрЗаменить(Рез,"Х","H");
Рез = СтрЗаменить(Рез,"Ч","CH");
Рез = СтрЗаменить(Рез,"Ш","SH");
Рез = СтрЗаменить(Рез,"Щ","SCH");
Рез = СтрЗаменить(Рез,"Ъ","");
Рез = СтрЗаменить(Рез,"Ь","");
Рез = СтрЗаменить(Рез,"Ы","I");
Рез = СтрЗаменить(Рез,"Ц","C");
Рез = СтрЗаменить(Рез,"Э","E");
Рез = СтрЗаменить(Рез,"Ю","YU");
Рез = СтрЗаменить(Рез,"Я","YA");
Рез = СтрЗаменить(Рез,"Й","I");
Возврат(Рез);
КонецФункции

Можно красивее сделать...
Kudryashka
8 - 06.05.2004 13:06 		(7) вариант неплохой, просто я думала что есть и другие пути, не перебирая каждую букву. просто я о них не знаю или недодумалась. значит нету.. нет, такие пути я знаю, но там проблемы с двойными буквами.. а вот чтобы и буквы не перебирая и проблем с двойными не было.. наверное слишком многого хочу :))
Kudryashka
10 - 06.05.2004 13:19 		примерно такое:

Функция Транслит(Стр)
Рус = "абв.."
Лат = "abv.."
КоличБукв = СтрДлина(Рус);
Для А = 1 по КоличБукв цикл
Русск = Сред(Рус,А,1);
Латин = Сред(Лат,А,1);
Стр = СтрЗаменить(Стр,Русск,Латин)
КонецЦикла;
Возврат Стр
КонецФункции

но это только для простых букв
GrayT
11 - 06.05.2004 13:20 		Полный изврат :)))))
Функция Транслит(Стр)
СтрРус="АБВГД...Ю...";
стрЕнг="ABVGD...YU...";
КолСим="11111...2...";
Дл = СтрДлина(СтрРус);
Для сч = 1 по Дл Цикл
Стр = СтрЗаменить(Стр, Сред(СтрРус,сч,1), Сред(СтрЕнг,сч, Число(Сред(КолСим,сч,1))));
КонецЦикла;
Возврат Стр
КонецФункции //Транслит


Однотипная партия товаров. Идентифик код | База знаний | mista.ru

Однотипная партия товаров. Идентифик код

LOSS 04.05.2004 22:44 | Где можно глянуть пример поступления партии Товара одного вида например принтера ХП 1010, далее если продан принтер то остаток не просто количество. А с каждым индивидуальным номером каждому принтеру. И приход также сделать
kvm 1 - 04.05.2004 22:55 | Есть такая штука - партия товара. Добавь еще одну такую штуку, заполняемую в приходной накладной. Дальше вся работа - как с партиями. Что-то похожее было в Рарус:Мебельное производство.
LOSS 2 - 04.05.2004 22:58 | Партионный учет? Я верно понял
GrayT 3 - 04.05.2004 23:01 | Имхо, не все так просто. Тут нечто подобное Львенок поднимал...
GrayT 4 - 04.05.2004 23:04 | http://194.135.22.174/forum/topic.php?id=1561 Кажеться это из этой же темы
427 5 - 04.05.2004 23:05 | Учет серийных номеров.... Это не просто партионный учет... Это вырожденный случай партионного учета ... Партия состоит из одной единицы.... . Таким образом, приход принтеров ХП 1010 в количестве 10 штук создаст 10 партий по 1 шт... Способов реализации масса ... Можно даже в типовой ТиС извратиться сосем немного... чтобы такой учет приделать ...
LOSS 6 - 04.05.2004 23:06 | Окромя Рарус Мебель, где еще можно у меня такого нет. Может кинешь. А насколько это трагично? Поможите чем сможите и мыло дам soldieras@mail.ru


Как убрать меню СЕРВИС из 1C | База знаний | mista.ru

Как убрать меню СЕРВИС из 1C

_Demon_ 03.05.2004 20:57 | Как убрать меню СЕРВИС из 1C?
GrayT 5 - 04.05.2004 00:28 | Читайте правила - пользуйтесь поиском ( чтой то я мало выпил - злой какой то) http://194.135.22.174/forum/topic.php?id=3483
ramstar 6 - 04.05.2004 05:14 | Есть такая штука инетрфейсы вот там и поудаляй всечто тебе надо если по умолчанию стоит интрефейс бухгалтер отредактируй оный
skunk 7 - 04.05.2004 05:45 | редактором ресурсов...
ramstar 8 - 04.05.2004 06:17 | ты что то против Restoratora или reshackera имешь ?


Поиск элементов по реквизиту | База знаний | mista.ru

Поиск элементов по реквизиту

Константин
07.11.2004 23:10 		Всех приветствую!
Помогите, пожалуйста. Ниже приведена обработка по поиску элементов справочника
номенклатуры по заданному реквизиту, а точнее по артикулу. Данная обработка
ищет точное соответствие заданного и искомого реквизита. Подскажите, какие изменения
необходимо внести в текст модуля, если мне необходимо произвести поиск по первым набранным символам,
а не по точному соответствию.

Процедура Сформировать()
Запрос = СоздатьОбъект("Запрос");
РеквизитПоиска="Артикул";
ТекстЗапроса ="
|ТекущийЭлемент = Справочник.Номенклатура.ТекущийЭлемент;" +
РеквизитПоиска + " = Справочник.Номенклатура." + РеквизитПоиска + ";
|Группировка ТекущийЭлемент Без Упорядочивания Без Групп;
|Условие(Найти(ВРег(" + РеквизитПоиска + "),ВРег(ПодСтрокаПоиска))>0);
|Без итогов;";
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
сообщить("Запрос не выполнен");
Возврат;
КонецЕсли;
Пока Запрос.Группировка() = 1 Цикл
ТекЭлемент = Запрос.ТекущийЭлемент;
рез= ТекЭлемент.Наименование;
сообщить(рез);
КонецЦикла;
КонецПроцедуры
Константин
5 - 08.11.2004 20:46 		Всем спасибо! Надо заменить строчку на |Условие(Найти(ВРег(СокрЛП(" +РеквизитПоиска + ")), Врег(СокрЛП(ПодСтрокаПоиска))) > 0);


Нумерация страниц в отчете 1с | База знаний | mista.ru

Нумерация страниц в отчете 1с

Dronchik 28.10.2004 20:15 | Подскажите, плиз, как сделать нумерацию страниц в отчете? Заранее благодарен.
vS 9 - 29.10.2004 18:20 | Гон, это когда трава уже созрела Перем НомСтр; Функция ПоказатьНомер() НомСтр = НомСтр+1; Возврат НомСтр; КонецФункции НомСтр = 0; В ячейке шапки, выводимой на каждой странице пишешь ПоказатьНомер() В ячейке последнего подвала пишешь НомСтр все?
vS 10 - 29.10.2004 18:22 | +9 чтобы вывести именно ПОСЛЕДНИЙ колонтитул, секция ПоследнийКолонтитул выводится после фразы КонецЦикла; перебора данных отчета... ЗЫ секцию создать не забудьте... ЗЫ ЗЫ кто тотм седня рулит, может в базу знаний?


Создание из 1С файла excel со структурой | База знаний | mista.ru

Создание из 1С файла excel со структурой

Эльфи 01.11.2004 16:34 | Добрый день. Возникла такая проблемка. Прайс из 1С необходимо выгрузить в Excel со структурой.... (возможность сворачивать группы - возможность Excel)
OFF 6 - 02.11.2004 09:47 | (5) Как два байта переслать :), качай, разбирай http://small.h12.ru/excel.zip Обработка демонстрирует простейший пример вывода из 1С:Предприятия в MS Excel. Обеспечение наличия у рабочей книги единственного листа, установка размера, жирности и цвета шрифта, ширины колонок, установка рамок и заливки ячеек. Выравнивание текста ячеек, группировка строк, установка числового формата ячеек, закрепление области. Работает в любой конфигурации 1С:Предприятия.


Как узнать какая высота выведенной строки? | База знаний | mista.ru

Как узнать какая высота выведенной строки?

Высота
15.10.2004 14:51 		по поиску не нашел :-(
Таб.Область(Таб.ВысотаТаблицы()).ВысотаСтроки();

Если высота таблицы задано автомат то выводит =0;
если не то выводит высоту.
Как узнать высоту тсроки если установленно высота строки "автомат" .
SnarkHunter
3 - 15.10.2004 15:01 		(0)http://avb1c.narod.ru/
Последняя статья...
Crew
10 - 15.10.2004 17:53 		(8)+
Автор АЛьФ:
ВысотаСтрокиТаблицы(<?>,,)
HeightTableString(<?>,,)
Синтаксис:
ВысотаСтрокиТаблицы(<Таблица>,<НомерСтроки>,<ТипВозврата>)
Замечание:
Метод работает только для таблиц, которые уже выведены на экран методом Показать().
Назначение:
Возвращает высоту строки объекта "Таблица" в заданных единицах
Параметры:
<Таблица> - объект "Таблица";
<НомерСтроки> - номер строки, высоту которой необходимо вычислить.
<ТипВозврата> - тип возвращаемого значения. Может принимать следующие значения:
1 - возвращается значение в миллиметрах, 2 - возвращается значение в экранных пикселах,
3 - возвращается значение во внутренних юнитах 1С.
Пример:
Сервис = СоздатьОбъект("Сервис");
Таб.Показать("Тест");
Сервис.ПрятатьТаблицу(Таб,1);
Для инд = 1 по Таб.ВысотаТаблицы() Цикл
Сообщить(""+инд+" :: "
+Сервис.ВысотаСтрокиТаблицы(Таб, инд, 1)+"мм. :: "
+Сервис.ВысотаСтрокиТаблицы(Таб, инд, 2)+" :: "
+Сервис.ВысотаСтрокиТаблицы(Таб, инд, 3));
КонецЦикла;
Сервис.ПрятатьТаблицу(Таб,0);

http://www.consult.legion.ru/alf/formex.shtml


Нумерация для нескольких видов документов | База знаний | mista.ru

Нумерация для нескольких видов документов

Слеш 08.10.2004 11:12 | Наткнулся в ЖКК на такую вешчь: Уникальность номеров и правила их автоматического присвоения могут быть определены едиными для нескольких видов документов. Например, может быть установлена сквозная нумерация для прих. и расх. накладных. Как это делается? Существует ли реальная потребность в таком механизме (где-то есть соответствующее законодательство)?
GrayT 1 - 08.10.2004 11:18 | Дык нумератор однако. У меня два вида документов для оприходывания готовой продукции, а номер у них один. Да и кадровые приказы идут по порядку
OFP 3 - 08.10.2004 11:21 | Для такого случая назначают единый нумератор, это объект такой в дереве метаданных, там же где документы. Он как раз для этих дел придуман.


Присвоение значения сгенерированному реквизиту формы | База знаний | mista.ru

Присвоение значения сгенерированному реквизиту формы

G-Re 28.09.2004 12:06 | Уважаемый коллеги! Как присвоить значение генерируемому реквизиту формы, например, такому Форма.ПолучитьАтрибут("Реквизит"+ц) Спасибо.
АЛьФ 1 - 28.09.2004 12:08 | http://1c.proclub.ru/modules/newbb/viewtopic.php?topic_id=266120&forum=2
F427 2 - 28.09.2004 12:23 | Форма.УстановитьАтрибут("КолВоПосылокНах",СчЁтчик)


Как загрузить или получить доступ к данным из таблиц Paradox в 1С 7.7 | База знаний | mista.ru

Как загрузить или получить доступ к данным из таблиц Paradox в 1С 7.7

SKrin
22.09.2004 11:38 		Есть программка, в которой все данные хранятся в DB таблицах.
Хочу сделать отчеты в 1С по этим данным.
Вопрос: как мне получить доступ к этим данным (DB, Paradox) и какие для этого есть методы и функции? Есть ли какие нибудь ресурсы в инете?
На http://www.sinor.ru/~my1c/knowhow/accs_ado.html есть только для Акцесса, можно их как нибудь сопоставить с Paradox?
SnarkHunter
6 - 22.09.2004 12:12 		(3)Использование промежуточных прокладок не нравится... Можно и без этого обойтись... Например:

//====================================================
Процедура ЗагрузитьВСКЛ(ИзФайла)
ВременныйПуть = ""+КаталогИБ()+"Trans\Shops\"; //

ФС.КопироватьФайл(КатСПочтой+ИзФайла+".DB",ВременныйПуть+ИзФайла+".DB",0);
ФС.КопироватьФайл(КатСПочтой+ИзФайла+".PX",ВременныйПуть+ИзФайла+".PX",0); // вторичные индексы
//

//====================================================
// Выгружаем данные во временную таблицу загружаем в SQL
//====================================================
Состояние("Получение данных из магазина '"+ИзФайла+"'...");
//-- Переносим клиентов TransBuh..KL
ТекстЗапроса ="Set NoCount On
|INSERT TransBuh..KL
|SELECT Z.Klient, Z.Inn_Klient, Z.Vid_kl
|FROM
| (SELECT Klient, ISNULL(Inn_Klient,'') as Inn_Klient, Vid_kl
| FROM
| OPENDATASOURCE('Microsoft.Jet.OLEDB.4.0','Data Source="+ВременныйПуть+";
| Jet OLEDB:Database Password=""jIGGAe"";Extended Properties=""Paradox 5.x""')..."+ИзФайла+"
| GROUP BY Klient, Inn_Klient, Vid_kl) Z
|LEFT JOIN TransBuh..KL
|ON (Z.Klient = TransBuh..KL.Klient) and
| (Z.Inn_Klient = TransBuh..KL.Inn_Klient)
|WHERE TransBuh..KL.ID_Klient IS NULL
|";
//-- Переносим кредитные документы TransBuh..DOC_KR
ТекстЗапроса = ТекстЗапроса +"
|INSERT TransBuh..DOC_KR
|SELECT SS.ID_KR_DOC, SS.Kr_doc, SS.Firma, SS.ID_Klient, SS.Mag
|FROM
| (SELECT Z.ID_KR_DOC, Z.Kr_doc, Z.Firma, TransBuh..KL.ID_Klient, Mag
| FROM
| (SELECT ID_KR_DOC, Kr_doc, Firma, Klient, ISNULL(Inn_Klient,'') as Inn_Klient, '"+Сред(ИзФайла,3)+"' as Mag
| FROM
| OPENDATASOURCE('Microsoft.Jet.OLEDB.4.0','Data Source="+ВременныйПуть+";
| Jet OLEDB:Database Password=""jIGGAe"";Extended Properties=""Paradox 5.x""')..."+ИзФайла+"
| GROUP BY ID_KR_DOC, Kr_doc, Firma, Klient, Inn_Klient) Z
| LEFT JOIN TransBuh..KL
| ON (TransBuh..KL.Klient = Z.Klient) and
| (TransBuh..KL.Inn_Klient = Z.Inn_Klient) ) SS
|LEFT JOIN TransBuh..DOC_KR
|ON (SS.ID_Kr_doc = TransBuh..DOC_KR.ID_Kr_doc) and
| (SS.Mag = TransBuh..DOC_KR.Mag)
|WHERE TransBuh..DOC_KR.ID_Kr_doc IS NULL
|";
// Если оплаты
Если (Лев(ИзФайла,1)="f") ИЛИ (Лев(ИзФайла,1)="F") Тогда
//-- Переносим оплаты TransBuh..OPL
ТекстЗапроса = ТекстЗапроса +"
|INSERT TransBuh..OPL
|SELECT Z.Firma, Z.Mag, Z.Vid_opl , Z.Data_opl, Z.Summa, Z.Np, Z.ID_Kr_doc, Z.ID_Klient
|FROM
| (SELECT f_Kalin.Firma, '"+Сред(ИзФайла,3)+"' as Mag, ISNULL(f_Kalin.Vid_opl,'') as Vid_opl ,
| f_Kalin.Data_opl, f_Kalin.Summa, f_Kalin.Np, TransBuh..KL.ID_Klient, TransBuh..DOC_KR.ID_Kr_doc
| FROM
| OPENDATASOURCE('Microsoft.Jet.OLEDB.4.0','Data Source="+ВременныйПуть+";
| Jet OLEDB:Database Password=""jIGGAe"";Extended Properties=""Paradox 5.x""')..."+ИзФайла+" f_Kalin
| LEFT JOIN TransBuh..KL
| ON (TransBuh..KL.Klient = f_Kalin.Klient) and
| (TransBuh..KL.Inn_Klient = ISNULL(f_Kalin.Inn_Klient,''))
| LEFT JOIN TransBuh..DOC_KR
| ON (TransBuh..DOC_KR.ID_Kr_doc = f_Kalin.ID_Kr_doc) and (TransBuh..DOC_KR.Mag = '"+Сред(ИзФайла,3)+"')) Z
|LEFT JOIN TransBuh..OPL
|ON (Z.Firma = TransBuh..OPL.Firma) and
| (Z.Mag = TransBuh..OPL.Mag) and
| (Z.Vid_opl = TransBuh..OPL.Vid_opl) and
| (Z.Data_opl = TransBuh..OPL.Data_opl) and
| (Z.Summa = TransBuh..OPL.Summa) and
| (Z.ID_Klient = TransBuh..OPL.ID_Klient) and
| (Z.ID_Kr_doc = TransBuh..OPL.ID_Kr_doc)
|WHERE TransBuh..OPL.Mag IS NULL
|";
Иначе // Если отгрузки
//-- Переносим товары TransBuh..TOV
ТекстЗапроса = ТекстЗапроса +"
|INSERT TransBuh..TOV
|SELECT Z.Tovar, Z.Artikl, Z.B_u
|FROM
| (SELECT Tovar, ISNULL(Artikl,'') as Artikl, B_u
| FROM
| OPENDATASOURCE('Microsoft.Jet.OLEDB.4.0','Data Source="+ВременныйПуть+";
| Jet OLEDB:Database Password=""jIGGAe"";Extended Properties=""Paradox 5.x""')..."+ИзФайла+"
| GROUP BY Tovar, Artikl, B_u) Z
|LEFT JOIN TransBuh..TOV
|ON (Z.Tovar = TransBuh..TOV.Tovar) and
| (Z.Artikl = TransBuh..TOV.Artikl)
|WHERE TransBuh..TOV.ID_Tovar IS NULL
|";
//-- Переносим шапки документов отгрузки OTGR_SH
Если (Лев(ИзФайла,1)="r") ИЛИ (Лев(ИзФайла,1)="R") Тогда
КакОтгружали="rozn";
Иначе
КакОтгружали="opt";
КонецЕсли;
// | (vib.Firma = TransBuh..OTGR_SH.Firma) and
ТекстЗапроса = ТекстЗапроса +"
|DELETE TransBuh..OTGR_SH
|FROM TransBuh..OTGR_SH
| LEFT Join
| (SELECT DISTINCT ID_DOC, Firma, '"+Сред(ИзФайла,3)+"' as Mag
| FROM OPENDATASOURCE('Microsoft.Jet.OLEDB.4.0','Data Source="+ВременныйПуть+";
| Jet OLEDB:Database Password=""jIGGAe"";Extended Properties=""Paradox 5.x""')..."+ИзФайла+" ) vib
| ON (vib.ID_DOC = TransBuh..OTGR_SH.ID_DOC) and (vib.Mag = TransBuh..OTGR_SH.Mag)
| WHERE vib.ID_DOC IS NOT NULL
|
|DELETE TransBuh..OTGR_TBL
|FROM TransBuh..OTGR_TBL
| LEFT Join
| (SELECT DISTINCT ID_DOC, '"+Сред(ИзФайла,3)+"' as Mag
| FROM OPENDATASOURCE('Microsoft.Jet.OLEDB.4.0','Data Source="+ВременныйПуть+";
| Jet OLEDB:Database Password=""jIGGAe"";Extended Properties=""Paradox 5.x""')..."+ИзФайла+" ) vib
| ON (vib.ID_DOC = TransBuh..OTGR_TBL.ID_DOC) and (vib.Mag = TransBuh..OTGR_TBL.Mag)
| WHERE vib.ID_DOC IS NOT NULL
|
|INSERT TransBuh..OTGR_SH
| SELECT Z.Firma, Z.Mag, Z.ID_Klient, Z.Num_doc , Z.Data, Z.opl, Z.ID_Kr_doc, Z.Nal, Z.Otgr_vid, Z.ID_Doc
| FROM
| (SELECT DISTINCT r_Kalin.Firma, '"+Сред(ИзФайла,3)+"' as Mag, TransBuh..KL.ID_Klient, r_Kalin.Num_doc ,
| r_Kalin.Data, r_Kalin.opl, TransBuh..DOC_KR.ID_Kr_doc, r_Kalin.Nal,
| (CASE WHEN r_Kalin.Np=0 Then '"+КакОтгружали+"' ELSE 'Kred' END) as Otgr_vid, r_Kalin.ID_Doc
| FROM OPENDATASOURCE('Microsoft.Jet.OLEDB.4.0','Data Source="+ВременныйПуть+";
| Jet OLEDB:Database Password=""jIGGAe"";Extended Properties=""Paradox 5.x""')..."+ИзФайла+" r_Kalin
| LEFT JOIN TransBuh..KL ON (TransBuh..KL.Klient = r_Kalin.Klient) and (TransBuh..KL.Inn_Klient = ISNULL(r_Kalin.Inn_Klient,''))
| LEFT JOIN TransBuh..DOC_KR ON (TransBuh..DOC_KR.ID_Kr_doc = r_Kalin.ID_Kr_doc)) Z
| LEFT JOIN TransBuh..OTGR_SH ON (Z.Firma = TransBuh..OTGR_SH.Firma) and
| (Z.Mag = TransBuh..OTGR_SH.Mag) and
| (Z.ID_Doc = TransBuh..OTGR_SH.ID_Doc)
| WHERE TransBuh..OTGR_SH.ID_Doc IS NULL
|";
//-- Переносим таблицы документов отгрузки TransBuh..OTGR_TBL
ТекстЗапроса = ТекстЗапроса +"
|INSERT TransBuh..OTGR_TBL
|SELECT Z.ID_Doc, Z.ID_Tovar, Z.Kol_vo, Z.Summa, Z.Country, Z.Gtd, Z.Np, Z.LINENO_, Z.Mag
|FROM
| (SELECT r_Kalin.ID_Doc, TransBuh..TOV.ID_Tovar, r_Kalin.Kol_vo, r_Kalin.Summa , ISNULL(r_Kalin.Country,'') as Country , ISNULL(r_Kalin.Gtd,'') as Gtd, r_Kalin.Np, r_Kalin.LINENO_, '"+Сред(ИзФайла,3)+"' as Mag
| FROM
| OPENDATASOURCE('Microsoft.Jet.OLEDB.4.0','Data Source="+ВременныйПуть+";
| Jet OLEDB:Database Password=""jIGGAe"";Extended Properties=""Paradox 5.x""')..."+ИзФайла+" r_Kalin
| LEFT JOIN TransBuh..TOV
| ON (TransBuh..TOV.Tovar = r_Kalin.Tovar) and
| (TransBuh..TOV.Artikl = r_Kalin.Artikl)) Z
|LEFT JOIN TransBuh..OTGR_TBL
|ON (Z.LINENO_ = TransBuh..OTGR_TBL.LINENO_) and
| (Z.Mag = TransBuh..OTGR_TBL.Mag) and
| (Z.ID_Doc = TransBuh..OTGR_TBL.ID_Doc)
|WHERE TransBuh..OTGR_TBL.ID_Doc IS NULL
|";
КонецЕсли;

//Текст=СоздатьОбъект("ТЕКСТ");
//Текст.ДобавитьСтроку(ТекстЗапроса);
//Текст.Показать();

Если ОбъектП.ЗапросК1С(ТекстЗапроса,,,0)<>1 Тогда
Предупреждение("Запрос не выполнен."+РазделительСтрок+"Данные из "+ИзФайла+" не загруженны!");
КонецЕсли;

Состояние("");

//====================================================
ФС.УдалитьФайл(ВременныйПуть+ИзФайла+".DB");
ФС.УдалитьФайл(ВременныйПуть+ИзФайла+".PX");
ФС.УдалитьФайл(КатСПочтой+ИзФайла+".DB");
ФС.УдалитьФайл(КатСПочтой+ИзФайла+".PX");
КонецПроцедуры // ЗагрузитьВСКЛ
SnarkHunter
9 - 22.09.2004 12:22 		По поводу ОбъектП:

Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "neta.dll") <> 1 Тогда
Если ЗагрузитьВнешнююКомпоненту(КаталогПрограммы() + "neta.dll") <> 1 Тогда
Предупреждение("Компонента neta.dll не найдена!");
СтатусВозврата(0);
Возврат;
КонецЕсли;
КонецЕсли;

ОбъектП=СоздатьОбъект("AddIn.NPeriodik");

По поводу технологии: например, ВК 1С++
SKrin
10 - 22.09.2004 12:55 		(9) А где мне найти neta.dll
SnarkHunter
13 - 22.09.2004 15:23 		(10)Нигде. Это коммерческая компонента. Компоненты NetaInet.dll, NetaMenu.dll и NetaTable.dll этого же автора можно найти на proclub.ru
SKrin
14 - 22.09.2004 15:26 		(13) А есть другие не коммерческие решения данной задачи кроме (1)
SnarkHunter
15 - 22.09.2004 15:45 		1С++


Непонятная перекодировка(Украина) | База знаний | mista.ru

Непонятная перекодировка(Украина)

G-Re 14.09.2004 12:23 | Уважаемые коллеги! При формировании текстовых полей в ДБФ-файле из данных 1С вне зависимости от параметра КодоваяСтраница()украинская буква "i" почему-то перекодируется в "_". остальные "нерусские буквы" вроде без проблем. В чем может быть дело? Спасибо.
Diter 1 - 14.09.2004 12:28 | Проблема именно в этой букве. Мне пришлось при записи в dbf менять её на другой символ, а при чтении менять обратно.
Мулька 2 - 14.09.2004 12:29 | аналогично - меняй на аглицкие и не парься


Как правильно прочитать XML? | База знаний | mista.ru

Как правильно прочитать XML?

Gst33 05.10.2004 16:43 | Имеется, к примеру, следующих текст XML. Как грамотно его прочитать средствами 1cv8 (прошу написать пример кода)? Спасибо! <Данные ИБ="Trade" ДатаВыгрузки="05.10.04" Пользователь="Администратор"> <Шапка ВидДокумента="РасходнаяНакладная" Дата="2004-10-05" Номер="T-00007" ТипЦен="ТипыРасхЦен" Валюта="USD" Курс="29" Продавец="Основная фирма" Покупатель="Транспорт" Договор="" /> <ТабЧасть> <Строка Код="К4" Количество="10" Единица="шт." Цена="100" Сумма="1000" /> <Строка Код="К3" Количество="20" Единица="шт." Цена="120" Сумма="2400" /> </ТабЧасть> </Данные>
Множество 1 - 05.10.2004 17:08 | ХМЛ = Новый ЧтениеXML(); ХМЛ.ОткрытьФайл("C:\shop\www.shop.ru\1c\outbox\orders.xml"); Пока ХМЛ.Прочитать() Цикл Если ХМЛ.Имя = "Данные" И Строка(ХМЛ.ТипУзла) = "Начало элемента" Тогда Для Атрибут = 1 по ХМЛ.КоличествоАтрибутов() цикл Если Атрибут = 1 тогда ИБ = ХМЛ.ПолучитьАтрибут(Атрибут); ИначеЕсли Атрибут = 2 тогда ДатаВыгрузки = ХМЛ.ПолучитьАтрибут(Атрибут); . . . . ке кц ке Если ХМл.Имя = "Шапка" тогда Для Атрибут = 1 по ХМЛ.КоличествоАтрибутов() цикл Если Атрибут = 1 тогда ВидДокумента = ХМЛ.ПолучитьАтрибут(Атрибут); ИначеЕсли Атрибут = 3 тогда Номер = ХМЛ.ПолучитьАтрибут(Атрибут); . . . . ке ТаблицаЗначений."ДобавитьНовуюСтроку"; ТаблицаЗначений.Номер = Номер; кц ке . . . . . кц


Книга продаж | База знаний | mista.ru

Книга продаж

povar 16.06.2004 14:48 | Каким образом можно формировать книгу продаж, только в том случае если по товару прошла оплата (выписка, платежка) и отгрузка (накладная),а не сразу после отгрузки ?
Marinka 4 - 16.06.2004 17:00 | (0) Возможность автоматического формирования книги продаж/покупок возможна только для тех пользователей, кто работает по оплате (в этом случае делается только 1 документ 1 раз в месяц), для тех же кто работает по отгрузке необходимо на каждый документ реализации вводить документ "Запись книги продаж".
povar 5 - 17.06.2004 05:59 | (4) В том то и дело, что с одними клиентами работаем "по оплате" с другими " по отгрузке". Т.е. есть 2 варианта: 1. Сначала оплатили (аванс) - потом отгрузили 2. Отгрузили (накладная) - оплатили
SnarkHunter 11 - 17.06.2004 06:48 | Метод определения выручки у вас в организации какой?
povar 12 - 17.06.2004 06:52 | Выручка - по отгрузке НДС - по оплате
Marinka 18 - 17.06.2004 09:24 | 1. В каждом договоре у каждого контрагента ставишь галочку "Автоматически формировать книгу покупок/продаж". 2. Делаешь 3 документа: Оплата, Отгрузка, С-ф (порядок следования роли не играет). 3. Раз в месяц открываешь документ "Формирование записей книги покупок (продаж)", нажимаешь кнопку "Заполнить". Все отгрузки, по которым прошли оплаты и есть с-ф попадут в этот документ, а, следовательно, в нужную книгу. Если отгрузка не попала в этот документ, значит на нее нет оплаты или с-ф, а, значит, ты не имеешь права включить её в книгу продаж/покупок. Ещё вопросы есть?
povar 27 - 17.06.2004 14:31 | (18)А если оплата прошла частично и С-Ф выписана на эту часть, а отгружено на всю сумму, потом они доплатили. как в этом случае поступить ?
Marinka 28 - 17.06.2004 15:44 | с-ф на аванс была?... её надо закрыть записью книги покупок, отгрузить товар и выставить нормальную с-ф на всю сумму.
Sasha 33 - 17.06.2004 18:22 | 1. В договорах клиентов проставить галочку \\\"Использовать документы договора для автоматического формирования книги покупок и книги продаж\\\". Автоматизация все-таки! 2. Вводим аванс (ПКО или банковскую выписку) 3. На основании банковской выписки вводим счет-фактуру. Должна стоять галочка \\\"Счет-фактура на аванс\\\". Этот счет-фактура попадает в книгу продаж. 4. Оформляем отгрузку товаров (выполнение работ, оказание услуг :) Вводим счет-фактуру на основании этой реализации. 5. В конце месяца заводим два документа \\\"Формирование книги покупок\\\" и \\\"Формирование книги продаж\\\". В документ \\\"Формирование книги продаж\\\" попадет счет-фактура, выписанная на основании реализации. В документ \\\"Формирование книги покупок\\\" - сторно счета-фактуры, выписанной на аванс. В результате в книге продаж будет 2 записи: одна на аванс, другая на реализацию, в книге покупок - 1 запись: зачет аванса.


Остатки ОС к НУ | База знаний | mista.ru

Остатки ОС к НУ

vdi 04.06.2004 12:12 | Бухучет, 458. Раньше мне всегда казалось, что амортизация ОС в целях НУ рассчитывается по данным на закладке "Налоговый учет". Однако расчетный опыт показывает, что используется значение реквизата "Первоначальная стоимость" с закладки "Бухгалтерский учет"! Более того, для расчета амортизации в целях НУ, кажется, программа вообще игнорирует реквизит "Первоначальная стоимость" на закладке "Налоговый учет". Буду очень благодарен за разгадку этой тайны.
bazvan 1 - 04.06.2004 12:39 | Амортизация в целях НУ считается как Сальдо конечное дебетовое разделенное на срок полезного использования (при линейном методе и коэффициенте = 1
Sev 2 - 04.06.2004 12:44 | Ни с той ни с другой закладки, а со стоимости, отраженной на дебете счета Н05.01 "Первоначальная стоимость ОС".
VK 3 - 04.06.2004 13:39 | Согласен с Sev. Но туда она попадает когда вводишь ОС в эксплуатацию и берется она с налоговой закладки.
vdi 4 - 05.06.2004 08:17 | Все это так, но! Уточню вопрос. В орг. 1 декабря 2001 ОС принято к БУ. Спустя годы. 1) В БУ введены остатки на 31 марта 2004 г. В БУ: ПерСт=341666,67, Аморт=69956,19, СрокИсп=132 мес. Ежемесячная амортизация 341666,67/132=2588.38 руб. 2) ГлавБух утверждает, что согласно какого-то документа в целях НУ с 1 января 2002 срок испольования установлен равным 84 мес. Первоначальная прежняя - 341666,67 руб. Ежемесячная амортизация в целях НУ должна составить 341666,67/84=4067.46 руб. 3) "Обработкой формир. нач. ост." можно принять ОС либо по остаточной стоимости, либо по балансовой. Если принять по остаточной, то получим неправильную сумму ежемесячной амортизации. Правильной она получиться, если принять по балансовой стоимости. Но, этого вроде бы, делать нельзя. Все старые ОС должны приниматься по остаточной стоимости. Вот и не пойму, как разрешить эту дилемму. Спасибо всем, кто пытается помочь мне.


Бух. и ЗиК для бюджетников | База знаний | mista.ru

Бух. и ЗиК для бюджетников

Helenoc 14.08.2004 14:27 | есть потенциальный клиент-бюджетник, на него также вышел "Парус". как доказать клиенту, что 1с лучше? и лучше ли? поделитесь мнениями, ПЛИЗ.
bazvan 1 - 14.08.2004 14:30 | Выучить 107 инструкцию и рассказать.
BorisG 6 - 14.08.2004 14:42 | 0. Видишь ли... в бюджете наиболее важное - это поддержка. И вовсе не 1С, а учета в самой организации. По сути - консалтинг. Так что... если 107н не знаешь... никаких преимуществ перед Парусом у тебя нет. Увы. Посему... Учи 107н, а остальное в 1С есть. Одна из лучших конфигураций и великолепные разработчики.
Helenoc 9 - 14.08.2004 14:55 | ясно, что главное поддержка. но предположим, что 107-ю знаем и мы парусовцы. я же спрашиваю о программе. ведь Парус первоначально ориентировался на бюджет, а 1с - хозрасчет. Вы хотите сказать, что у типовых бюджетных конфигураций сейчас все просто изумительно и дело только в знании 107-й?? кто-нибудь может рассказать о реальных косяках 1с для бюджета (бога ради не сочтите меня врагом 1С :)).
BorisG 11 - 14.08.2004 15:08 | (9) "Парус первоначально ориентировался на бюджет, а 1с - хозрасчет" Неправда. Бюджетная конфигурация 1С - обна из самых сильных. И разработчики самые добросовестные среди разработчиков типовых конфигураций. Дальше уже надо вникать в отраслевую специфику. Где-то чуть больше охвачено Парусом, где-то 1С. Есть еще один минус Паруса. Это стоимость сопровождения. Она примерно равна 30% стоимости лицензий в год... Но... У меня в среднем выходит до 80 - 90% оплаченного времени - это вовсе не непосредственно сопровождение программ, а консультации по ведению учета, разбор спорных ситуаций и т.п. PS: Кстати, отрасль какая?
Helenoc 12 - 14.08.2004 15:09 | (10)районное управление финансами
NF 14 - 14.08.2004 15:14 | (13)Только что прочитал что лучше. Лучше ЗиК.
Helenoc 16 - 14.08.2004 15:16 | (14)а где прочитал? поделись, пожалуйста.
BorisG 17 - 14.08.2004 15:16 | (12) Так для них вообще ничего сложного нет. Так что все зависит вовсе не от конфигураций, а от "полноты налитого стакана" ;-) Кроме бюджетной бухгалтерии, есть у 1С отдельные конфигурации "Бухгалтерия для распорядителей бюджетных средств", "Финансовое планирование для распорядителей бюджетных средств" и "Свод отчетов". В зависимости от функций, которые предполагается автоматизировать.
Helenoc 19 - 14.08.2004 15:20 | кстати, про "Свод" - его нужно ставить и получателям и распорядителю, или можно только распорядителю (а получатели будут отчеты сливать из бухии)?
NF 20 - 14.08.2004 15:23 | (16) http://kamin.kaluga.ru/cgi/yabb/Printpage.pl?board=zpl20&num=327
NF 43 - 14.08.2004 19:32 | (42) Помоги пожалуйста.. Вчера купили ЗиКу. Во вторник надо идти отстраивать в бюджетной организации. Два источника финансирования. Вопросы состоят в том как: - Правильно оформить сотрудника - Каое выбрать ФКР(или где можно взять расшифровку) - Можно ли разделить НДФЛ по ИФ - Можно ли разделить ЕСН по ИФ т.е. в отчетах раздельно шли. И если что-нибудь еще сделать надо или какие подводные камни есть, скажите пожалуйста. Буду очень признателен..
ViktorG 44 - 15.08.2004 10:05 | (6) Уж не раз вижу Ваш лестный отзыв о бюжетной 1С. Честно говоря странно. Я когда увидел ее (мельком, правда) впечатление: кто-то как курица лапой... формы нарисованы тяп-ляп, флажки разбросаны даже не в шахматном порядке, кассовая книга печатается: нужно итоги на каждом листе, а там \"лист\" будет тянуться пока день не кончится и т.д. и т.п. Может быть это старый релиз был... последние я не видел. НО, ТАК НЕ ДЕЛАЕТСЯ нормальная конфига, ИМХО.
BorisG 45 - 15.08.2004 10:12 | (44) Ну и... И почему ты не Нуралиев? ;-) Во-первых, это не только моя оценка... Несмотря на всю сложность оганизации учета, на семинарах эта конфигурация постоянно получает высшие оценки партнеров. О заслугах Ксении Сергеевой вообще помолчу... PS: Вообще-то чтобы так пИсать, нужно самому что-то сделать стоящее.


Зачем нужен "лимит" в кассе, и нужен ли вообще в 1С:Бухгалтерии | База знаний | mista.ru

Зачем нужен "лимит" в кассе, и нужен ли вообще в 1С:Бухгалтерии

Demiurg 10.08.2004 10:11 | Подскажите пожалуйста, мне бухгалтера задала вопрос о том, что она работала в другой программе (т.е. не 1С:ХХХ), и там был некий "лимит". Поясните пожалуйста смысл и его необходимость (наличие в 1С конфигурациях)!
ИВМ35 1 - 10.08.2004 10:21 | лимит - допустимый максимум остатка в кассе, для предприятия определяется на год банком. Цель - уменьшение наличности в обращении. Основной способ расчетов - не через кассу, а ч. банк, безналично. Допускается его превышать в течение 3-х дней в период выплаты з/пл Бухша должна знать об этом.. а отслеживать в 1С.. - напиши обработку. Спец., по-моему, нет
ИВМ35 2 - 10.08.2004 10:23 | кстати, банк проверяет кассовую книгу, и при превышении этой суммы может штрафовать предприятие.. Размер штрафа - не помню, да можно узнать эти штуки в банке.. справку о лимите - проси посмотреть у бухши..
BorisG 4 - 10.08.2004 10:40 | Лимит по кассе установлен пп. 2.6 и 2.7 Положения о правилах организации наличного денежного обращения на территории Российской Федерации, утвержденного письмом Банка России от 05.01.98 N 14-П. Вот только документ то зачем? Неужели буху трудно контролировать остаток на конец дня? Он во вкладном листе кассовой книги отражается. Наказание - ст. 15.1 КоАП РФ, на должностных лиц - от 40 до 50 МРОТ, на ЮЛ - от 400 до 500 МРОТ.
ИВМ35 6 - 10.08.2004 10:46 | 4. документ, если предприятие хочет установить свой лимит, выше утвержденного письмом. Иначе - конечно, не нужен..
ИВМ35 7 - 10.08.2004 10:51 | 3. доработка не очень большая - в доке "КассоваяКнига" вставить операторы сравнения остатка с лимитом и "Сообщить"..
ИВМ35 8 - 10.08.2004 10:52 | +7 подскажи бухше, что есть "Анализ счета по датам" - удобная штука, пропустить перед кассовой


Перемещание материалов в 1С:Бухгалтерия | База знаний | mista.ru

Перемещание материалов в 1С:Бухгалтерия

Maikl 08.07.2004 10:50 | При перемещение материала со склада на склад количество перемещается, а сумма нет. Что нужно сделать, чтобы перемещалась и сумма.
3V 1 - 08.07.2004 10:58 | поставить признак суммового учета на 10-х субсчетах, но это не выход, внутренне перемещение ведеться только по количественному учету, в противном случае тебе придется еще реализовывать партионный учет
GrayT 2 - 08.07.2004 11:03 | +1 И перелопатить всю конфигурацию - учет материалов идет по средней по всему предприятию
3V 4 - 08.07.2004 11:08 | у тебя потом проблемы будут со списанием у подотчетников, когда к ним приходит, то средняя одна, а когда списываете, то средняя другая, в итоге получается, что виснут суммы на десятке при нулевом количестве... бухам енто явно не понравиться....


НОВЫЙ ПЛАН СЧЕТОВ | База знаний | mista.ru

НОВЫЙ ПЛАН СЧЕТОВ

Ирина 23.06.2004 22:31 | Предприятие уже полгода работает по старому плану счетов. Хотят перейти на новый (в Беларуси новый план счетов введен в действие с 01.01.2004). Мое предложение было - в чистой базе с новым планом счетов внести остатки по счетам и работать дальше, но бухгалтеры хотят видеть все свои обороты по счетам с начала года. Может быть кто-нибудь подскажет решение - каким образом это лучше сделать. (Еще один момент - практически все проводки вносятся вручную, документы проводок не формируют).
Bell 3 - 25.06.2004 15:13 | () Но остатки на НАЧАЛО ГОДА! А Перенос движений со сменой счетов и т.д. начиная с начала года.
Дык 4 - 27.06.2004 01:17 | Я скачал с hippo.ru обработку переноса справочников moveanal.ert и остатков inoutost.ert. Остатки выгружаются в текстовый файл. Изменил счет на нужный в каждой строке. Загрузил в новую базу. Готово. Есть более крутые обработки, но с ними дольше разбираться, особенно если что-то не идет. Есть на сайте и обработки и для переноса документов, типа import77.ert. В общем посмотри - интересный сайт и хорошие ребята.


Ввести разделитель учета в типовую бухгалтерию. | База знаний | mista.ru

Ввести разделитель учета в типовую бухгалтерию.

Akim 07.06.2004 15:02 | Поделитесь пожалуйста опытом\соображением по сабжу. Я так думаю: 1) добавляем реквизит проводки "Разделитель учета"; 2) в свойствах плана счетов указываем "ИСпользовать разделитель учета" и ссылаемся на реквизит проводки из первого пункта; 3) в отчетах, как я понял, уже есть разделители учета; В документы добавляем реквизит табличной части того же типа что и этот разделитель учета; 4) для каждой стоки "Операция.НоваяПроводка()" в програмных модулях добавляем строку(строки) для Дт\Кт "Операция.РазделительУчета =<Реквизит Табличной Части> " И теперь вопрос: Что еще нада сделать? У кого есть такой опыт - поделитесь пожалуйста.
Asmody 1 - 07.06.2004 15:05 | Документы "ЗакрытиеМесяца", "НачислениеАмортизации" и т.п. переделать придется
427 2 - 07.06.2004 15:06 | поищи на синоре или в инете. Гдето было описание.. Довольно полно описал ....
bazvan 3 - 07.06.2004 15:07 | + Константы + Справочнк ОС, Подразделений, Налоги, Сотрудники Чуть рихтануть все отчеты


Автоматическое формирование книги покупок | База знаний | mista.ru

Автоматическое формирование книги покупок

MiCo 24.06.2004 07:01 | Проблема: В документе "Формирование книги покупок" в поле "Документ выписки" попадает документ "Поступление товаров ...", а хотелось бы, чтобы туда попадал документ "Выписка ...". Вопрос: что необходимо сделать, чтобы в документе "Формирование книги покупок" в поле "Документ выписки" попадал документ "Выписка"? Т.е. каким образом изменить учетную политику (порядок формирования документов)? Текущее положение дел: 1.Метод определения выручки - по отгрузке. 2.Для каждого договора стоит галочка "Использовать документы по договору для автоматического формирования книги продаж и покупок" 3.Документы вводятся в следующем порядке: 3.1. Вводится выписка. 3.2. Далее вводится посупление товаров. 3.3. На основе поступления товаров вводится отгрузка 3.4. На основе отгрузки вводится счет-фактура. P.S. Буду признателен на любые замечания
Valery 1 - 24.06.2004 08:49 | Книга покупок всегда формируется только по оплате. Если в документ "Формирование книги покупок" попадает документ "поступление товара" значит он был оплачен в предыдущем периоде.
MiCo 2 - 24.06.2004 10:02 | (1) Спасибо за замечание. Понятно, что в книгу покупок попадают только оплаченные документы. Но проблема в отображении информации: в поле "Документ выписки" виден документ "Поступление товаров ...", а хотелось бы видель документ "Выписка ...", по которому видно приход денег.
Valery 5 - 25.06.2004 08:51 | Что изменится если в поле "Документ выписки" будет документ "Поступление товаров ...", а не выписка?
MiCo 6 - 28.06.2004 04:58 | Бухи хотят, чтобы при просмотре книги покупок можно было посмотреть документ, по которому прошла оплата за товар. Если в поле "Документ выписки" будет документ "Поступление товаров ...", то такого простого просмотра не получается
smdv1000 7 - 28.06.2004 15:29 | как ты собираешься это делать. если выписка заполняется не на основании, а в табличной части ссылки только на платёжки?
besenka 8 - 28.06.2004 15:40 | если бухи хотят, чтоб была Выписка именно, то пускай ручками вводят... автозаполнение (насколько я в этом разобралась и разбираюсь щас) происходит так: сделали выписку - но прихода пока нет. сделали приход - соотв-но в качестве док-та оплаты воспринимается приходная накладная уже, а не выписка! если сначала - приход, а потом сделать выписку (ессно в пределах одного месяца все делается), то тогда в кач-ве док-та оплаты будет уже выписка.
besenka 9 - 28.06.2004 15:44 | прастите..если в пределах одного месяца-то порядок - выписка-приход значение не имеет. в (1) верно подсказали... :))


настройка отчета | База знаний | mista.ru

настройка отчета

EAV 18.06.2004 09:51 | Как активизировать в Бухгалтерии 7.7 кнопку Раскрыть(F6), в Отчеты - Регламентированные - Бухгалтерская отчетность - Отчет о прибылях и убытках (форма №2)?
busy1 1 - 18.06.2004 09:57 | Есди кнопка есть, но она не активизированная, то посмотри Пользователи, возможно у твоего пользователя не достаточно прав доступа. 1 ) Залезь в справочник пользователей, там глянь. 2 ) Залезб в конфигуратор в модуле формы найди эту кнопку и посмотри доступность должна быть 1
Marinka 2 - 18.06.2004 14:25 | Если не ошибаюсь - будет активна, если есть показатели по таким видам как: выручка и себестоимость, операционные доходы, внерелизационные доходы, а так же должен быть заполнен справочник Отчеты->Настройка раскрытия отчетности по перечисленным видам.


Как обновить в Бухгалтерии ставки РеФинансирования ч.з Инет? | База знаний | mista.ru

Как обновить в Бухгалтерии ставки РеФинансирования ч.з Инет?

Оля 17.06.2004 15:40 | Как загрузить Бухгалтерию новые ставки РеФинансирования? Наверное как-то просто, типа как курсы валют, просто че-то не вижу где!Помогите!!
Michael99 1 - 17.06.2004 15:50 | Загрузить врядли , а получить можно через интернет поддержеку Раздел Обновление-Получение и просмотр дополнительной информации -Раздел "Справочная информация"


Новое субконто | База знаний | mista.ru

Новое субконто

guglina 11.06.2004 15:44 | Есть ли обработка для автоматического заполнения нового Субконто2 (Налоги и Отчисления) счета ОС ? Подбросьте идею ее написания. Бух7.7 (Украина).
iceTiger 1 - 11.06.2004 16:15 | На данную формулировку вопроса можно ответить только одно: "Нет!". Конкретней... (Документ, релиз бух, и зачем тебе вообще это нужно?)
Guglina 3 - 14.06.2004 14:58 | В V7/70/253 (бух, Украина) в документе "НачислениеИзноса" для расчета по налоговому методу используются счета ОС с двумя субконто: НеоборотныеАктивы и НалогиОтчисления. В имеющейся конфигурации субконто только одно. Как довнести данные в счета ОС?
Outlander 4 - 14.06.2004 15:29 | А вы что делаете? Обновили конфигурацию на новую или переносите новый док в старую? ЗЫ. Институт Титана. Оччень интересно.
Outlander 5 - 14.06.2004 15:37 | Наверное, обновление конфы. Тогда достаточно перепровести док-ты, проверив установку в них (док-тах) второго субконто.


конец месяца. кто его делает? | База знаний | mista.ru

конец месяца. кто его делает?

Crystalizer 10.06.2004 17:39 | в конце месяца, то бишь как я понимаю - "подотчетного периода" выполняется списание средств с одних счетов на другие... хорошо..... а какая именно обработка/процедура это делает и каков принцип её вызова?
sam_sam 1 - 10.06.2004 17:40 | документ закрытие месяца, если речь идет про бухгалтерию
Vozhd 2 - 10.06.2004 17:43 | (0) "а какая именно обработка/процедура?" - та, которыю написали. "каков принцип её вызова?" - отработали мы месяц, и друг захотели узнать как мы отработали этот месяц. Были какие-то доходы, какие-то расходы, вот и начинаем их сводить вместе. После сведения у нас либо прибыль, либо убыток. Вот это сведение и называют закрфтием месяца...
Crystalizer 4 - 10.06.2004 17:47 | (3) = ответ на (1) Вождь: Где эТа процедура находится? в Каждом документе? и Каждый докумеНт будет вызЫваться?
Crystalizer 6 - 10.06.2004 18:04 | Бухгалтерия+Торговля+Склад+Зарплата+Кадры для Украины (7.70.008) разработка ABBY Ukraine 2001
Gavrila 7 - 10.06.2004 18:13 | (6) тогда финансовые результаты
Crystalizer 8 - 10.06.2004 18:24 | агаа... есть такое этот документ вызываетя вручную? в глоб.мод. не нашёл его вызовов...
Gavrila 9 - 10.06.2004 18:43 | (8) Да группа "Документы/Регламентированные документы"


Приглашаю обсудить технологию ввода остатков ОС в НУ. | База знаний | mista.ru

Приглашаю обсудить технологию ввода остатков ОС в НУ.

vdi
06.06.2004 11:14 		Основные средства в БУ и в НУ

В соответствии с НК РФ, 25 Глава, ст. 322, п. 1 «По основным средствам, введенным в эксплуатацию до вступления в силу настоящей главы, полезный срок их использования устанавливается налогоплательщиком самостоятельно по состоянию на 1 января 2002 года…».

Там же: «Вне зависимости от выбранного налогоплательщиком метода начисления амортизации по имуществу, введенному в эксплуатацию до вступления в силу настоящей главы, начисление амортизации производится исходя из остаточной стоимости указанного имущества».

Попытаемся разобраться, к чему это приводит при регистрации ОС в программе бухучета. Предположим, что объект ОС введен в эксплуатацию 31 декабря 2001 года. Его первоначальная стоимость равна 120000 руб., срок полезного использования 120 месяцев. Ежемесячная сумма амортизации при линейном методе начисления составит 1000 руб.

Остатки этого объекта вводятся в программу на 31 декабря 2004 года. К этому времени общая сумма начисленной амортизации составит 24000 руб. В бухгалтерском учете отражаем этот факт следующими записями.

Дебет 01.1 Кредит 00 – 120000 руб.
Дебет 00 Кредит 02.1 – 24000 руб.

Здесь все просто и никаких вопросов не возникает. Вопрос в налоговом учете. Организация решила на 1 января 2002 г. в целях налогового учета установить другой срок использования, а именно – 60 месяцев. Ежемесячная сумма амортизации при линейном методе начисления составит уже 2000 руб. Следовательно, к моменту ввода остатков сумма начисленной в целях НУ амортизации составит 48000 руб.

С помощью обработки «Формирование и контроль начальных остатков по налоговому учету» примем наш объект ОС к налоговому учету по остаточной стоимости. В карточке реквизитов ОС, на закладке «Налоговый учет» первоначальную стоимость укажем равной 120000, а срок полезного использования - 60 месяцев. В результате обработка сформирует следующую проводку.

Дебет Н05.01– 96000 руб.

Обращаем внимание на то, что к налоговому учету объект ОС принят по первоначальной стоимости в БУ, а не в НУ. Это приводит к неправильному начислению амортизации в целях налогового учета.

Дебет 26 Кредит 02.1 – 1000 руб. Здесь все верно!
Дебет Н07.04.1 Кредит Н05.02 – 1600 руб. Здесь все НЕ верно!

Значение 1600 руб. – это результат деления 96000 руб. на 60 мес. То есть обработка вместо того, чтобы рассчитать остаточную стоимость объекта ОС в целях НУ, использует остаточную стоимость в целях БУ. Правильный результат можно получить, если отказаться от использования обработки и принять ОС к НУ вручную, а именно.

Дебет Н05.01– 120000 руб.
Кредит Н05.02– 48000 руб.

В этом случае получим правильный результат.

Дебет 26 Кредит 02.1 – 1000 руб.
Дебет Н07.04.1 Кредит Н05.02 – 2000 руб.

Программа рассчитала остаточную стоимость в НУ (72000 руб), рассчитала остаточный срок использования в НУ (36 мес.) и начислила правильную сумму амортизацию.

Выводы. В правильности этих выводов меня укрепило сообщение на http://forum.klerk.ru/showthread.php?t=27814.

1) Обработка формирования и контроля начальных остатков в налоговом учете не позволяет корректно принять к НУ ОС средства, у которых разная остаточная стоимость.
2) В программе не предусмотрено блокировки действий обработки, если остатки в НУ введены вручную. Она все равно сформирует проводку в дебет счета Н05.01 на сумму 96000 руб. В результате стоимость ОС в НУ станет 216000 руб., а ежемесячное начисление 3600 руб.!!!
3) Последнее означает, что, если в организации несколько сотен единиц объектов ОС и среди них есть хотя бы один объект, подобный описанному, то все остатки в НУ придется вводить вручную.

P.S. Уважаемые коллеги. Я могу ошибаться, тем более будут ценны Ваши замечания, соображения и дополнения.
doomerr
13 - 06.06.2004 23:03 		Я могу ошибаться, но обработка «Формирование и контроль начальных остатков по налоговому учету», смотрит остатки по БУ и делает такие же по НУ, поэтому данная обработка не подходит в данном случае. Одни мои клиенты вышли из положения таким образом: Они данные объекты ОС стали вести по НУ с самого момента их поступления, у них сроки были не большие, объектов много, и им показалось так проще. Может все это и глупость, заранее прошу прощения.
kvm
14 - 07.06.2004 01:26 		Для ОС до 2001 года в обработке нужно указать "Принимать по остаточной стоимости". Тогда будет сделана проводка
Д Н05.01 Остаточная стоимость.
Если надо вводить с учетом начисленной амортизации с 01.01.2002, тогда руками, но учитывая, что сумма по НУ на это число = остаточной стоимости по БУ.


Расчет себестоимости продукции в бухгалтерии? | База знаний | mista.ru

Расчет себестоимости продукции в бухгалтерии?

Killgur 01.06.2004 14:42 | Ломаю типовую бухгалтерию 456. Меняю план счетов. В 20 счете субконто ВидНоменклатуры заменил на Номенклатура. Пишу документ для списания материалов в производство по нормам. Знаю что предется менять документ Закрытие месяца. Интересует именно бухгалтерия. Производство не предлагать. Какие подводные камни могут быть в таком подходе?
427 1 - 01.06.2004 17:08 | Ты просто обрезал себе маневр.... И нажил проблемы с обновлениями ....
427 5 - 02.06.2004 09:29 | Не всегда и не везде надо учитывать строго по номенклатуре... Иногда полезно свернуть.. если для каждой номенклатуры создать свой вид - будет то же самое, что ты и сделал, поломав типовую... Но если так надо - надо просто вставить автоматическое создание нового ВидаНоменклатуры при записи нового элемента Номенклатуры.... Без изменений типовой ... Вообще то есть дятлы, которые еще и на 9х счетах хотят сделать такое же....
GrayT 6 - 02.06.2004 10:45 | (0) А зачем тебе это вообще надо? Хочешь посчитать себестоимость по конкретной номенклатуре. Тогда надо еще и про зарплату не забыть и закрытие месяца поломать серьезно придется. А что там с налоговым учетом получиться? ЗЫ: Понравилась мысль с автосозданием Вида от Номенклатуры
Vozhd 7 - 02.06.2004 11:39 | (5) А потом такие дятлы не имеют никаких проблем с расчетом налогов, со сменой ставок, с анализом прибылей и доходов, потому что эти данные есть в базе... А умные, в лучшем случае, все данные переколбашивают вручную, пытаясь посчитать вдруг понадобившуюся цифирку...
427 10 - 03.06.2004 09:34 | Применяя автосоздание, как раз и можно получить себестоимость по конкретным видам... причем вообще не трогая типовую ....


Ввод ОС в эксплуатацию | База знаний | mista.ru

Ввод ОС в эксплуатацию

Kisss 31.05.2004 17:05 | Господа, подскажите можно ли в одном доке "Ввод в эксплуатацию" указать объекты, поступившие от разных поставщиков, но являющие составляющими одного объекта ОС? Т.е. есть 2 дока "Поступление ОС", в каждом по 2 позиции. Хотелось бы создать 1 "ВВод в эксплуатацию", в котором будет 4 позиции. Заранее, спасибо:)
Marinka 1 - 01.06.2004 14:33 | Ввод в эксплуатацию работает только для 1 объекта внеоборотного актива, если в документе \"Поступление ОС\" был выбран один и тот же актив (что на мой взгляд - маразм), то можно, а если нет - то нельзя.


Невозможно провести запись в книге продаж | База знаний | mista.ru

Невозможно провести запись в книге продаж

PANAtlant 01.06.2004 14:50 | На основании товарной накладной на отгрузку готовой продукции выдана с/ф. На основании этой с/ф делаем запись в книгу продаж и... Сумма НДС превышает сальдо по кредиту 76.Н.1. Документ не проведён. Почему такое происходит?
SiMazx 1 - 01.06.2004 14:53 | Значит по этой с/ф уже делали ЗКП на какую-то сумму... Или обработкой сливали часть... Или с/ф неправильно проведена... Т.е. сразу на 68...
PANAtlant 3 - 01.06.2004 15:00 | Что интересно в книге продаж запись появилась, а документ ЗаписьВКнигуПродаж не проведён и нет галочки на документе, естественно.
PANAtlant 4 - 01.06.2004 15:03 | (2)Типовая, Бухгалтерия, 456, РЕЛИЗ 7.70.021
SiMazx 5 - 01.06.2004 15:08 | Сделай оборотку по 76.н.1 и посмотри какие были движения по твоей с/ф...
SiMazx 6 - 01.06.2004 15:10 | Либо их вообще не было - значит с/ф сделана сразу на 68, либо часть суммы уже ушла на 68 - значит были другие ЗКП...
PANAtlant 7 - 01.06.2004 15:19 | В оборотке за весь период только эта же сумма, что и в с/ф и Документе ЗКП, в подчинённых документах к с/ф - только отгрузка и ЗКП
PANAtlant 8 - 01.06.2004 15:44 | У контрагента в договоре стоял "крыжик" использовать документы по договору для авт. формир. ЗКП. После "крыж" убрали. Это объясняет, видимо, сделанную запись в КП. А теперь, сделать ЗКП - повторить ещё раз запись, так? Т.е. попытка удвоить. С "крыжами" непонятно, если в договоре он стоит, то при выписке с/ф на аванс, PRG формируется автоматически. Если же с/ф выдана на основании отгрузки продукции, то PRG не проводится, хотя "крыж" включён.


Ошибка при переходе с редакции 4.4 на 4.5. 1С:Предприятие7.7 | База знаний | mista.ru

Ошибка при переходе с редакции 4.4 на 4.5. 1С:Предприятие7.7

waits 26.05.2004 07:30 | При переходе с редакции конфигурации 4.4 на 4.5 происходит ошибка. Делаю все строго по инструкции, но на стадии сохранения объединенной конфигурации выскакивает ошибка: "Оперативный учет не может быть отключен. Существуют проведенные документы! Поступление товаров - 111882002 :00000000001" Проверка и исправление ИБ ничего не изменили. В чем ошибка? Как исправить?
shura 7 - 26.05.2004 09:16 | В документе "Поступление товара" стоит (поставили) галочка "Оперативный учет", а при обновлении этот документ накрывается. И галочка перестает существовать. Это-ж "Бухгалтерский учет"? Другой редакции 4.5. 1С:Предприятие7.7 я не знаю.
shura 10 - 26.05.2004 09:21 | (8) Если-бы компонента отсутствовала, то он-бы писал что-то типа "не обнаружен ключ защиты..." в момент запуска в режиме "предприятие" если оперделял, что есть регистры. (0) Однозначно какой-то шибко умный программист к стандартной бухии прилепил оперучет.
shura 11 - 26.05.2004 09:24 | (9) Во первых, объясни что на что ты обновляешь. Ни "редакции 4.4", ни "редакции 4.5 1С:Предприятие7.7" я не знаю. Во вторых: Открываешь конфигуратор и смотришь: есть-ли "Регистры". Если есть, то скорее всего кто-то эту конфу дорабатывал. В третих: Если объектов "Регистр" нету то скорее всего по ошибке на каком-то документе установили галочку "Оперативный учет"
SnarkHunter 19 - 26.05.2004 09:33 | Значит конфа, которую обновляешь - правленая... Кто-то прикрутил к документам движения по регистрам, которых нет в обновлении... Если эти движения нужны, то в обновлении выставляй галки ОУ для этих доков, потом обновляйся...
waits 20 - 26.05.2004 09:48 | В конфе присутствует объект Регистр, но он не открывается, и свойства на данный объект отсутствуют В документах "Поступление товаров" действительно стоит галочка на Оперативном учете Как быть дальше? Ее убрать и будет мне счастье? :-)


На сайте Бух.1С открыт раздел, посвященный регламентированной отчетности | База знаний | mista.ru

На сайте Бух.1С открыт раздел, посвященный регламентированной отчетности

BorisG
01.06.2004 14:48 		На сайте Бух.1С открыт специализированный раздел, в котором планируется помещать материалы по регламентированной отчетности, в том числе - по представлению отчетности в электронном виде.

http://www.buh.ru/documents.jsp?ParentID=571


Увеличение разрядности цены и количества до 5 после запятой | База знаний | mista.ru

Увеличение разрядности цены и количества до 5 после запятой

PANAtlant 01.06.2004 09:42 | По просьбе Бухии увеличил разрядность цены и количества до 5. Не приведёт ли это к неприятностям, которых я ещё не знаю? Разрядность сумм оставил как есть. Конфигурация типовая, 456, Бухгалтерия.
Stan from Piter 3 - 01.06.2004 09:49 | Ну, во первых, если в типовой стоит 15,2 это означает 12 знаков и два после запятой. Если поставить тупо 15,5, то целая чпсть уменьшиться на 3 знака. Ну, а во вторых, не везде есть точное округление до двух знаков (программное), что сообретственно приводит к возникновению хвостов, особенно по НДС.
PANAtlant 4 - 01.06.2004 09:52 | Учёт драгметала, например, в кг, учёт отходов и прочее. Так в 100 шт изделия - 0,17 милиграмм и т.д. Впрочем в количестве мало и 6 знаков после запятой.
GrayT 5 - 01.06.2004 09:53 | Если нет округления 5 после запятой поможет? А 5 в количестве, так для этого есть тонны, килограммы, декалитры, мимлиграммы.... ну думаю ясно.


НДФЛ и ЕСН при обновлении неправильно рассчитываются | База знаний | mista.ru

НДФЛ и ЕСН при обновлении неправильно рассчитываются

Darych 01.06.2004 12:09 | На днях обновил локалку до сетевой и релиз сразу 457 поставил . При обнолении 1С пересчитала итоги и теперь за первый квартал начиная с февраля неправильно рассчитывается НДФЛ и ЕСН. Причем ЕСН увеличен в 2 раза, а НДФЛ рассчитан как 0,13(з/п начисл минус вычеты+з/пл начисл) в апреле все ок ???
SnarkHunter 1 - 01.06.2004 12:13 | Ставь сразу 459...


списание тмц. Какие проводки должны выполняться? (для Украины) | База знаний | mista.ru

списание тмц. Какие проводки должны выполняться? (для Украины)

Crystalizer 28.05.2004 10:55 | и будет ли оно выполняться если списывается 0 единиц (для теста)?
Outlander 1 - 28.05.2004 11:08 | Проводки будут, если сумма <> 0. Даже при нулевом количестве.
Outlander 2 - 28.05.2004 11:11 | Какие проводки - а это смотря куда списывам. Например Сырье в производство Дт23 - Кт201.
Crystalizer 3 - 28.05.2004 11:58 | гм в главном модуле Если СокрЛП(СчетД)="" Тогда Если СчетК.Количественный=1 Тогда Конт.Операция.Количество = Кво; КонецЕсли; ИначеЕсли СокрЛП(СчетК)="" Тогда Если СчетД.Количественный=1 Тогда Конт.Операция.Количество = Кво; КонецЕсли; Иначе // выбраны оба счета Если (СчетД.Количественный=1) или (СчетК.Количественный=1) Тогда Конт.Операция.Количество = Кво; КонецЕсли; КонецЕсли; т.е. с любым количеством проводки должны выполняться но это контора ничего не производит, т.е. сырья нет... какие в таком случае проводки должны быть?
Outlander 4 - 28.05.2004 12:12 | Списать на затратные счета, часто это 92. Или 91, 93, 94. . Что за фирма которая "ничего не производит"? Может хоть услуги оказывает?
Crystalizer 5 - 28.05.2004 12:30 | кажеца просто "перепродает"
Uutlander 6 - 28.05.2004 12:36 | Понятно. Просто торговля. Тогда можно использовать любой из указанных девяностых. На выбор ГБ. Иногда еще используют 704-й кажется. Надо вспомнить.
Outlander 7 - 28.05.2004 13:00 | Нет, 704 здесь ни при чем.


Сортировка в кассовой книге | База знаний | mista.ru

Сортировка в кассовой книге

Slayyyer 14.05.2004 09:15 | Нужно, чтобы в отчете "КассоваяКнига" Строки сортировались не по дате, а по номеру касс.орд. Мож кто делал такое, подскажите, я пока еще тока учусь и продолаюсь с этим очень долго, буду очень благодарен
427 1 - 14.05.2004 09:24 | Дятел ты..... тебя потом подставят.... и вольют клизму на полведра скипидара .... с патефонными иголками ... И ЗАСТАВЯТ ПЛАТИТЬ за нарушение правил ведения кассовых операций КАССОВАЯ КНИГА СОГЛАСНО ПРАВИЛАМ ВЕДЕТСЯ ПО ДАТАМ! С итогами по датам.... ОДИН ДЕНЬ --- СТРОГО ОДИН ЛИСТ !!! И НОМЕРА Приходных и расходных ордеров ДОЛЖНЫ ИДТИ ПОДРЯД.... ЭТО - проблема кассира... А то кассир накосячил - теперь тебя хотят заставить исправлять, а в случае проверки свалить на тебя ответственность.... Знай - кассовая книга документ строгой отчетности, листы пронумерованы и книга прошнурована и опечатана. при любой проверке она проверяется в первую очередь.... И очень тщательно.. Ибо это наличные деньги...
VladZagorsky 5 - 28.05.2004 07:34 | 427: как ты, наверно, знаешь, есть "белый" учет и "черный"... В "черном" - хоть по диагонале распечатывай (В 1С правда нет такой возможности, а жаль...) Нет бы помочь человеку... Slayyyer: попробуй такой вариант: 1. документы "пихаешь" в таблицу значений. 2. Сортируешь документы по номеру. 3. Выводишь. Текст примера не вывожу умышленно - попробуй сам. :)


Вопрос по релизу 7.70.454 | База знаний | mista.ru

Вопрос по релизу 7.70.454

nick
19.05.2004 12:06 		В релизе Бух 7.70.454 от 08.01.2004 в части зарплаты
валовый доход сотрудника начисляется только за текущий месяц,
а не с начала года. В чем причина ?
Заранее благодарю.
Marinka
2 - 19.05.2004 16:58 		Документ "Закрытие месяца" (за месяц который идет перед начислением з/пл) с галочкой "Начисление налогов с ФОТ" не сделан.
vdi
3 - 19.05.2004 20:40 		Если начисление в текущем месяце, например, апрель, не более 400 руб, то НДФЛ принимается равным нулю. Что не правильно.

На сколько я понял, в бух 457 и более ранних расчет доходов, вычетов и налогов ведется не нарастающим итогом, а помесячно. Это не всегда приводит к правильным результатам. Не претендую на абсолютную правильность анализа программного кода. Но выявляется следующее. Например, в модуле документа "Начисление зарплаты" самый 1-й оператор, где встречается переменная "ВаловойДоход_СНачалаГода" это строка:

ВаловойДоход_СНачалаГода = ?(ДатаГод(глДатаПриема(Сотрудник))=ДатаГод(ДатаДок), Сотрудник.ВаловойДоход_СНачалаГода, 0);

Переменая "Сотрудник.ВаловойДоход_СНачалаГода" вроде, как нигде ранее не определена. В результате выполнения оператора

Если ТипВычета = Перечисление.ТипыВычетов.Обычный Тогда
Вычеты = Вычеты + 400*?((ВаловыйДоход+ВаловойДоход_СНачалаГода - ТаблицаВидовНачисленийОблПо13.Итог("Сумма"))<=ПределВычетов,1,0);

получаем, что "Вычеты = 400", так как "ВаловойДоход_СНачалаГода=0". Это приводит к тому, что переменная "НеОблагается" становится равной 400.
Marinka
4 - 20.05.2004 16:01 		(3) Не знаю как там в коде написано, но если принять человека на работу, например, в январе (дать ему вычет 400 руб.), но не начислять з/пл, а в феврале начислить з/пл, то вычетов предоставиться 800руб., а следовательно, сделано наростающим итогом. (проэксперементированно на 458)
BorisG
5 - 20.05.2004 16:59 		(3) Ну ну... и откуда такие "выводы"?
НДФЛ во всех релизах 1С считается нарастающим итогом с начала года. Это религия.
vdi
6 - 21.05.2004 08:02 		(4)Marinka благодарю Вас за ответ. К сожалению, ваш пример оказывается частным случаем, приводящим к правильному результату. Если интересно поэкспериментируйте с таким примером.

С 1 января принят на работу сотрудник с окладом 1500 руб и вычетом в 400 руб.

1) В январе начисляем 1500, к выплате 1357, O'Key.
Закрываем месяц январь и в начале февраля выплата 1357руб.

2) В начале феврале увольнем сотрудника и начисляем 300, к выплате 300, Это уже совсем НЕ O'Key.

На лице переплата сотрудником НДФЛ на сумму в 13 руб.
Marinka
7 - 21.05.2004 10:28 		А на каких основаниях уволеному сотруднику что-то начисляется?... Мое мнение: трудовые отношения не установлены, а если они не установлены, то в бухгалтерии вообще все начисление \"кривое\", так что не удивительно... (если перед тем как делать начисление в феврале установить трудовые отношения с сотрудником на день начисления и указать, что вычетов не предоставляем, то НДФЛ программа насчитает 39 руб, что есть 13% от 300 руб., а если вычеты есть, то какой НДФЛ с 300 руб? там вычеты перекроют начисления...)
vdi
8 - 21.05.2004 19:16 		(7) Так не пойдет! Мы не имеем права лишать сотрудника льготы. Даже,если он проработал лишь один день, например, 1 февраля. А потому общая сумма НДФЛ должна на дату увольнения должна быть равной
[(1500+300)- (400+400)]*0.13=130 руб.

Документы увольнения и начисления можно поменять местами. В любом случае программа начислит НДФЛ равный 143 руб. Такой результат возможен в том случае, когда игнорируется алгоритм нарастающих итогов, а расчет ведется помесячно. Несмотря на проповедуемую законодательством религию, см. (5).
BorisG
9 - 21.05.2004 19:44 		(8) Чего мутить народ? Может лучше внимательно почитать закон?
Методически тут 1С, как всегда права ;-), ибо налоговый агент не может без заявления сотра из других (не его доходов) источников эти 13 руб. ему выплатить... (см. ст. 231 п.1).
.
Посему твой пример из (0)... к выплате 300, плюс 13 руб. по заявлению сотра, итого 313 руб.
vdi
10 - 21.05.2004 21:14 		(9) Что ты такой подозрительный? Нет заговорщиков. Если тебя сильно коробит чья-то неосведомленность, то зачем отвечать. Лично я легко обойдусь без твоих снисходительных "ответов". А, если отвечаешь, то будь корректен. Умников, отягченных собственным величием не любят.

Из того, что ты написал информативным является лишь фраза

"налоговый агент не может без заявления сотра из других (не его доходов) источников эти 13 руб. ему выплатить... (см. ст. 231 п.1).".

Остальное мусор, пардон помехи.
BorisG
11 - 21.05.2004 21:51 		(10) Будь так добр, оставить за мной право отвечать так, как считаю нужным, впрочем не нарушая правила конференции.
.
Если уж говорить о мусоре... то с твоей стороны мусор - вся ветка... ибо перед тем как писАть "...Несмотря на проповедуемую законодательством религию, см. (5)." стоило бы этот самый закон, и почитать... а также более внимательно посмотреть на "творение" методистов 1С ;-)
Marinka
12 - 24.05.2004 09:55 		То ли я туплю... то ли...
Откуда это: "[(1500+300)- (400+400)]*0.13=130 руб" Мы же ему за февраль только 300 начисляем... а тут вообще цифры какие-то непонятные...
За январь мы ему все начислили и все удержали... никто никому не должен... за февраль у него вычеты перекрыли доходы, а значит нет НДФЛ. Или ты хочешь с тех 100 руб (вычет-доход), отдать 13 руб?
vdi
13 - 25.05.2004 07:55 		(12) Про это сказано в п.3 ст.226 НК РФ: "Исчисление суммы налога производится налоговыми агентами нарастающим итогом с начала НАЛОГОВОГО периода по итогам каждого месяца ...".

В отношении п. 1 ст. 231 НК РФ, которую милостиво подсказал BorisG, все правильно, спасибо Ему. Более того. Прогрмма ЗиК в отличие от Бух подсчитает эти злосчастные 13 руб. Но окрашивает их в красный цвет, да и минус впереди ставит. Видимо, это оначает, что, если уволенный работник потребует возврата переплаты, то ему можно будет произвести перерасчет. В бух это придется делать вручную.
Marinka
14 - 25.05.2004 09:50 		Погоди... а я тут на днях читала Коментарий к главе 23 НК РФ \"Налог на доходы физ.лиц\", так вот... там сказано, что если ежемесячный доход меньше суммы вычетов, то налоговая база принимается ранвой 0 и соответственно начисление и удержание НДФЛ не производиться...
... или это не касается увольнения?... что-то я совсем запуталась :о(
Marinka
15 - 25.05.2004 09:52 		аа...это, наверное, если доход сначала года меньше вычетов... но... кажеться дошло :)))
nick
16 - 25.05.2004 13:20 		Господа ! А может, обратиться к модулю проводки докумэнта Начисление зарплаты ?
Там, где СчДФЛ... :) Меняю на БухИтоги.Ко(Сч70)... и валовый доход попер.
Кстати, у бухов интересуюсь забалансовыми счетами, а они не микитят в этом :)
Ну, да ладно.
vdi
17 - 26.05.2004 07:40 		(16) Правильно, что не микитят! Ведь все эти счета типа ДФЛ, ЗПР, PGR и т.п. отсутствуют в утвержденном Плане счетов. Разработчики 1с вводит их в План счетов для обслуживания конфигурации. Но вот где и как они используются особенно не распространяется. Вот и пррходитсярешать шарады.


Обмен опытом: Погашение стоимости остатков спецодежды. | База знаний | mista.ru

Обмен опытом: Погашение стоимости остатков спецодежды.

vdi
23.05.2004 10:02 		Если ввести остатки спецодежды, находящееся в эксплуатации, ограничившись проводками Дт 10.11.1 Кт 00, то документ "Начисление амортизации и погашение стоимости" не будет погашать стоимость этой спецодежды. Найдено три варианта решения этой задачи.

Вариант 1.
а) Вводим остатки спецодежды на складе Дт 10.10 Кт 00.
б) Запускаем обработку «Формирование и контроль начальных остатков по налоговому учету» по разделу Н02.1.
в) На дату ввода остатка проводим документ «Передача спецодежды и спецоснастки в производство».

Вариант 2.
Вводим остатки спецодежды в эксплуатации.
Дт 10.11.1 Кт 00
Дт МЦ.02
Дт Н07.04.1
Кт Н02.01

Вариант 3.
По варианту 2 создать типовую операцию.

Вариант 1 на мой взгляд наилучший.
Вариант 2 не нравится. Он нигде не описан, может быть я плохо искал. Для бухгалтеров он тоже малоприемлим. Ибо информации о забалансовых 1с-х счетах минимум и что с ними делать не ясно. Кроме того этот вариант требует при большой номенклатуре очень много ручной работы по вводу проводок с забалансовыми счетами.
Вариант 3. Был бы достаточно хорош, если бы в программе существовала готовая типовая операция.

Уважаемые колеги поделитесь своими соображеними и опытом.
Marinka
1 - 24.05.2004 09:30 		Да... 1С как-то обещала включить типовые операции в программку... да что-то так их и невидать:(
vdi, я своим клиентам советую всегда первый вариант... что по спецодежде, что по ОС... путаницы потом меньше :)
vdi
2 - 25.05.2004 08:03 		Marinka спасибо за поддержку. Это дает большую уверенность в своих силах.

Если к вводу остатков относиться безпредметно, то кажется это плевое дело. Но в последнее время я все больше склоняюсь к тому, что это совсем непростое дело. И рекомендации типа "вводим остатки там, где они есть" верны по сути, но в методическом плане практически ничего не дают.


Бухия: черный учет | База знаний | mista.ru

Бухия: черный учет

romix 13.05.2004 00:21 | Белой и черной бывает не только магия... Или сторона Луны... Короче, вопрос, прокатит ли типовая бухия, чтобы вести теневой учет, или там нужны переделки? Я встречал инфу, но не могу ее ни вспомнить, ни найти :-) Как это делают обычно?
Василек 1 - 13.05.2004 00:36 | Нужно создать каталог на секретном диске и создать там базу... будет кульно...
romix 2 - 13.05.2004 00:46 | (1) И забыть к нему пароль :-) Мозг можно запрограммировать, чтобы при приходе налоговой проверки он начисто забывал пароль. :-)
Дудка ахинеи 3 - 13.05.2004 06:06 | (0)Как валиант: 1 база черный учет, 1 база белый учет, выгрузка из черной в белую ч/з OLE того что необходимо.
Haron 8 - 14.05.2004 10:05 | Просто! В одной базе - два плана счетов. И несколько пользователей, которые видят только белое.
vdi 9 - 14.05.2004 10:36 | Мое мнение, может быть и ... правильное! Если обнаружено, что какая-то контора утаивает налоги, то основанием для возбуждения уголовного дела являются ненадлежащим образом оформленные первичные документы. Информация в рабочей базе может служить, как мне кажется, лишь поводом для возбуждения. Программа является средством регистрации операций. А вот для каких целей вы это делаете и каким образом решаете вы. Вы же несете и ответственность. Вообще-то в цивилизованнм мире различают два учета: бухгалтерский и управленческий. А налоги надо все-таки платить!
romix 10 - 24.05.2004 12:22 | Короче сделал через УРБД. Две базы - между ними односторонний автообмен (черная - только приемник). Хотя, наверное, действительно получается пособничество (ст. 33 п. 5 УК РФ). Сорри что поздно поднимаю ветку - поиск вот у Волшебника нормально заработал, и я нашел, что спрашивал... :-)
lexa 11 - 24.05.2004 12:37 | (10) зря насчет пособничества, то что есть некая база данных для управленческого учета - это не преступление. Ты же не создаешь нелегальную финансовую схему от ухода от налогов, не берешь черный нал, не подделываешь документы, не делаешь нарушений в БУ и НУ. Вот если УРБД нелицензионная или 1С, тогда да. Если черный учет ведется в MS Excell, то что Билл Гейтс - пособник финансовых преступлений?


Связать с/фактуры с оплатой за продукцию | База знаний | mista.ru

Связать с/фактуры с оплатой за продукцию

PANAtlant 20.05.2004 10:54 | Как увязать счета-фактуры выданные, с оплатой. Необходимо вести учёт по каким с/ф прошла оплата, по каким остался долг. Варианты: 1) Получен аванс. Выписан с/ф на аванс, через время отгрузили продукцию, выписали с/ф на отгрузку. Сумма аванса меньше отгрузки. 2) То же (1), но сумма аванса равна сумме отгрузки. 3) Аванс больше суммы отгрузки. Во всех случаях число оплат и счетов-фактур различно и кол-во их большое (производство большое). Оплата разных видов и наличными и на расчётный счёт и векселями. Ещё Бухия требует чтоб на с/факт. на аванс были записи в книгу покупок. А в книгу идут суммы с минусом. 1С:Предприятие 7.7. (сет. версия), Бухучёт, тип. конфигурация. уч. политика – по оплате. Релиз 7.70.021, конф.456. DBF.
pan_Atlant 2 - 21.05.2004 08:13 | Получаем оплату от Контрагента в размере 100 000 руб 20 марта. Ранее было 5-6 отгрузок на суммы 20 000 - 300 000 рублей. Сейчас разносят оплату вручную, какой-то счёт-фактуру закрывают полностью, часть остаётся незакрытой, также надо вести книгу продаж, частично оплаченные счета записываем в книгу продаж на суммы остатка оплаты. Добавил в форму с/ф по 3 поля: даты оплаты, суммы оплаты, документа оплаты. В журнале отображаю с/ф с суммами оплаты и остатка. Но, повторюсь, документов много, вручную выбирать нужные с/ф - сложно, по кр. мере для Бухии, да и оплат может быть для данной с/ф больше 3. Как быть? Что посоветуют знающие люди?
SnarkHunter 4 - 21.05.2004 09:26 | Закрывай по фифо и не грейся...
psk21office 5 - 21.05.2004 09:50 | У меня примерно тоже самое. Нужно отследить оплачено поступление материалов или нет. Мое решение: - введен дополнитеный счет ОПЛ (контрагент, договор, поступление); - в выписке и приходном ордере добавлена разноска по поступлениям (если указано поступление, то засчитывать только по данному поступлению; если без указания поступления, то засчитывать последовательно по документам у которых есть долг);
PANAtlant 6 - 21.05.2004 09:52 | Сам придумал или это где-то в ПБУ имеется? И есть ли это в 1С или имеются настройки в типовой? Только по векселям указаны с/ф, остальные на откуп Бухии.
Valery 7 - 21.05.2004 10:23 | В бух происходит это так: На авнс получается с-ф на всю сумму, по документу выделяется НДС на сч 19 Когда происходит продажа, то формируется документ запись книги продаж, где формируется проводка 68-19. В 19 счете есть субконто С-ф. По нему можно отследить оплату. Такой вариант пройдет?
PANAtlant 8 - 21.05.2004 11:27 | Так понимаю, пришла оплата, в списке - с/ф выданные на отгрузку по данному контрагенту, можно не отражать уже проплаченные и сверху вниз выбирай и проводи оплату. Мечта. Как реализовать? И стоит ли городить огород?
Valery 9 - 21.05.2004 13:52 | Так городить ничего не надо уже все рализовано.


Неправильно указывается документ в оборотно-сальдовой ведомости | База знаний | mista.ru

Неправильно указывается документ в оборотно-сальдовой ведомости

MiCo 21.05.2004 07:26 | В документе ВЫПИСКА для контрагента задается договор (субконто 2), по которому происходили платежи. Делается отчет "Оборотно-сальдовая ведомость по счету" со следующими параметрами: Вид субконто 1 = Контрагенты Вид субконто 2 = Договора В результате в отчете указывается не тот договор, который был указан в выписке, а служебный ("Служебный договор") Каким образом порешать данную проблему?
427 1 - 21.05.2004 07:35 | Никак... Это особенность алгоритмов... И не надо с ней бороться... Если к примеру, уплаченная сумма превышает отгрузку по договору, остаток вешается на аванс без указания договора... ("Служебный договор")... Ибо куда отнести автоматически - неизвестно... При очередной отгрузке аванс гасится переносом суммы на договор отгрузки.. А если хочется потрахаться самому с переделкой доков - вперед и с песней... Но не забудь про трах бухов... которые будут вынуждены руками разбивать суммы ... и отслеживать их закрытие... Кстати, пусть попробуют без переделок забивать - все должно отходить...


Разница в доходах НУ и БУ | База знаний | mista.ru

Разница в доходах НУ и БУ

gr13 20.05.2004 09:07 | Организация оказывает услуги за первый квартал сформировали анализ налогового учета", раздел "доходы", в полной уверенности, что НУ=БУ. Но данные НУ правильные, а данные по БУ меньше на 150 т.р. Если делаем анализ счета в программе на счетах БУ, выходим на правильные суммы. Что может являться причиной этого? Так и от меня, бухия стоит 7.7
SnarkHunter 1 - 20.05.2004 10:00 | Ищи непопавшие суммы и анализируй... У меня был случай, когда в НУ не попадали суммы с невыбранным субконто...
gr13 2 - 20.05.2004 11:49 | Если бы НУ формировался бы не правильно, то нашли бы, но неправильно формируется БУ, не идет с действительными анализами счетов
SnarkHunter 4 - 21.05.2004 09:39 | Ну плин... Разверни доходы по БУ в анализе налогового учета, сделай анализ счетов в самом БУ и сравнивай...


Переход на новый НДС 18% | База знаний | mista.ru

Переход на новый НДС 18%

Evgen® 19.05.2004 07:18 | Подскажите как настроить конфигурацию на новый НДС 18% Замена константы НДС не даёт нужного результата !
Evgen® 5 - 19.05.2004 10:18 | Я в конторе меньше недели ... так, что не судите меня строго, на носу защита диплома!! До меня программист поменял, но как я понял не так как надо !! В итоге журнал покупок и журнал продаж выдают ерунду .... и каждый месяц надо по 2 дня тратить чтобы все перещитать в ручную!
bazvan 10 - 19.05.2004 16:58 | (8) Если конфа не паханная то переведи на 284 релиз и успакойся. Если переделанная вешайси или готовь бабло
427 12 - 21.05.2004 07:14 | А ты проверил? Работает? Книги формирует? Формирует правильно? 18% отдельной колонкой выделяется? Или наХХХХ посылается? Итоги по колонкам правильно считаются?


ИНН предпринимателя | База знаний | mista.ru

ИНН предпринимателя

ИНН 18.05.2004 12:42 | Как настроить в 1С, чтобы ввести в платежное поручение 12 значный номер предпринимателя ?
Bzzzzz 1 - 18.05.2004 12:50 | Изменить вид предпринимателя на физ.лицо


Бух: суммовой учет по складам | База знаний | mista.ru

Бух: суммовой учет по складам

Serg_bl 18.05.2004 12:31 | Проблема: хочет бухгалтерия видеть суммовые остатки на складах в Бух 7.7, а 1С говорит, что в таком случае при списании по-средней будет количественно-суммовой дисбаланс. Что можно придумать?
Valery 1 - 18.05.2004 12:48 | Уже плохо помню но примерно так В плане счетов в субконто места хранения устаносить суммовой учет Далее во всех документах где идет списание товара или материала надо поправить рассчет БИ по складам.


проблема переноса книги расходов и доходов на бухгалтерию | База знаний | mista.ru

проблема переноса книги расходов и доходов на бухгалтерию

Doc83 15.05.2004 11:33 | есть такой милый отчетик в упрощенке, ну и да того он в душу запал, что надо его в бухгалтерию перенести. А он, пес его бери, берет все из налоговых счетов протевоестесвенным для меня образом. Метод учета - по доходам, в общем нужен дельный совет. Заранее всем спасибо.
BorisG 1 - 15.05.2004 12:04 | Купить Упрощенку-6 или -15 от Камина.
427 2 - 15.05.2004 12:26 | Найти грамотного исполнителя и заказать этот отчет ему ...
Doc83 3 - 16.05.2004 13:37 | почти решил вопрос с технической точки, по 50,51 счету вот только как выделить доход/расход из прихода/ухода ден. средств?
kvm 4 - 17.05.2004 01:06 | По виду движения денежных средств. Только тогда его надо четко вести.


Запуталась в комиссии | База знаний | mista.ru

Запуталась в комиссии

Таня 13.05.2004 17:45 | Дт 62 Кт 76 - выручка от реализации комиссионного товара (240,000 р) (сумму минус вознаграждение должны отдать хозяину товара - комитенту) Дт 76 Кт 90 - начислен доход от реализации - (комиссионное вознаграждение) - 24,000 р Как быть с НДС? Дт 90 Кт 68 - 3,661 р кому выписывать счет-фактуру?
427 1 - 13.05.2004 18:58 | С полученных денег ты оставляешь себе ком вознаграждение и платишь с него НДС... Остальные деньги не твои... и оставшийся НДС не твой.... Но нужно уточнить по тексту договора на оказание услуг по комиссии... Счет-фактуру выписывает владелец товара.... По договору СЧФ можете выписать и вы от имени владельца... Вообще то все эти вещи тебе должны сказать директор или ГавГавБух.... ибо договор на комиссию находится у них .... А именно в нем м.б. прописана туева [exf нюансов... Причем весьма существенных.... И вполне законных....
vdi 3 - 14.05.2004 08:57 | Право на получение вознаграждения возникает после оформление документа "Оказание услуг". При заполнении учтите три важных момента. 1) Сумма услуги должна равняться сумме выручки от реализации!!! 2) Реквизиту «Тип услуги» установите значение «Оказание посредн. услуг в торговле». 3) Если ваша организация участвует в расчетах с комитентом, то и активизируйте реквизит «Удержать комисс. вознаграждение». На причитающееся вознаграждение выписываем на основании документа «Оказание услуг» "Счет фактура выданный". Получите проводку Дт90.3Кт 68.2. Услугу Вы оказали комитенту, поэтому и СФ выписывается на комитента. Если вопрос актуален, могу выслать на мыло более подробный алгоритм.
427 4 - 14.05.2004 09:18 | "1) Сумма услуги должна равняться сумме выручки от реализации!!!" Хрена вам, таварисч... Полную тележку.... Сумма услуги вычисляется ПО ДОГОВОРУ КОМИССИИ... А чего там высокие договаривающиеся стороны наворотили... только им известно.... Если ты видел только один договор... то это ничего не значит.... P.S. у меня сейчас клиент... так у него вариантов комиссии - до горы... я насчитал уже 6 основных типов договоров... Самый прикольный - когда расчеты осуществляются помимо конторы, оказывающей комиссионные услуги... В типовой бухии комиссия отражена очень слабо и может использоваться без переделки только максимум в 10% случаев ....


Отчет по ОС | База знаний | mista.ru

Отчет по ОС

Slayyyer 11.05.2004 18:17 | нужно сделать так, чтобы ОС с нулевой балансовой стоимостью отображались в отчете, я уже голову поломал... Подскажите пожалуйста
vdi 1 - 11.05.2004 23:21 | Уточните вопрос. В Бух458 специализированный "Отчет по основным средства" прекрасно отображает ОС с нулевой остаточной стоимостью. Естественно, если они не списаны со счета 01.
Slayyyer 2 - 12.05.2004 07:43 | К сожалению у меня версия 453, если не трудно, то скиньте пожалуйста листинг отчета
DElo 5 - 12.05.2004 12:35 | а как насчёт обновиться? в 453-м глюков дофига
vdi 8 - 12.05.2004 13:55 | (0) Для пущей убедительности я послал тебе просто сформированную форму очтета. Присоединяюсь к мнению большинства - обновляйся.
Slayyyer 13 - 13.05.2004 08:18 | Что-то я врублю, поставил обновление, но ничего не изменилось, ОС с нулевой балансовой стоимостью как не появлялись, так их и нет Поидее должно быть что-то похожее Если (БИ.Счет=Сч01_1) и ((БИ.СНД("К")<>0) или (БИ.СНД("С")=0)) Тогда продолжить; КонецЕсли


Как распечатать баланс с пустыми строками? | База знаний | mista.ru

Как распечатать баланс с пустыми строками?

Nikolay13 12.05.2004 12:20 | Если в балансе заполнены не все строки, то на печать выводятся только заполненные, а налоговая требует чтобы был напечатан весь бланк баланса. Типовая конфигурация. Релиз 457.Варианты отчета: Печатать сразу, Показать бланк, Напечатать пустой бланк.
SnarkHunter 1 - 12.05.2004 12:21 | Налоговая не права...
Sector04 2 - 12.05.2004 12:53 | Ссылаясь на бзики моих и др. "чудо" работников, Nikolay13, тебя понимаю. Если так хочешь, то делай так - файл - печать. Тогда у тебя принтер баланс "плюнет" такой, какой ты видишь, т.е. и пустые строки и заполненные.
BorisG 3 - 12.05.2004 13:10 | Да............... Для Ваших бухов видно Указания о порядке составления и представления бухгалтерской отчетности, утв. приказом Минфина РФ от 22 июля 2003 г. N 67н документом к руководству не является... Заметьте, больше полгода документу...
DElo 4 - 12.05.2004 13:17 | Да не для бухов, Боря, а для налоговиков. К нам на ЛК тоже задолбали звонить с этим вопросом. А мы что? Главное - на норм. док сослаться, а дальше... клиент всегда прав
BorisG 5 - 12.05.2004 13:34 | (4) Этот приказ и на них распространется. И знаешь, выполняют... И, кстати, больше уважают. Но... это отдельная история... на тему "Как мы общаемся с налоговой..." Ну а если хочется перед ними прогнуться, покупайте Каминовскую настройку, там все настраивается. PS: Кстати, 1С просила сообщать на Хотлайн или непосредственно в отдел разработки отчетности (если знаете их адрес) города и номера налоговых, где не выполнятся приказы Минфина и МНС, или теперь это одно и тоже ;-) PSS: Так какой номер налоговой, где эту дурь требуют?
Nikolay13 6 - 12.05.2004 13:37 | Файл -> Печать - не работает. Иначе бы вопросов бы не было никаких. При входе в форму заполнения баланса меню печати недоступно, все зашифровано. Отчет кстати в конфигураторе также изменить нельзя, все зашифровано.Может кто знает как его открыть для изменения.
DElo 8 - 12.05.2004 13:47 | 33, последний раз требовал (ну это то, что я слышала). Причём НИЧЕГО не принимают, если нет в проге "Баланс" сохранённой отчётности в эл. виде, хотя, Боря, тоже права не имеют, писали об ентом неоднократно.
BorisG 12 - 12.05.2004 14:00 | (8) Ну относительно электронной, это другое дело... У них план... приучить большинство сдавать в электронной... довести процент... а потом протащить приказ. Но... У меня свой бух квартальную сдавала, не прочиталась одна дискета, пытались ее послать, но... не получилось... приняли, правда пришлось ей дойти до зам. начальника налоговой.
427 13 - 12.05.2004 14:07 | "Причём НИЧЕГО не принимают" А послать их на три буквы (на Бам, к примеру) и ПОСЛАТЬ ПОЧТОЙ ломает? Пусть сами разбираются....
BorisG 14 - 12.05.2004 14:12 | (13) Верно... налоговый кодекс никто не отменял ;-)
Nikolay13 15 - 12.05.2004 14:26 | Вообще-то я вопрос чисто технический задавал, а с законами пусть юристы разбираются. Так неужели нет ни одного спеца по 1С, что может прояснить эту ситуацию, а то что и как сдавать я и сам знаю.
AVP 18 - 12.05.2004 15:27 | (0) Да печатает все через Файл-Печать.. Щелкни для начала мышкой на таблице...


Списание себестоимости товара | База знаний | mista.ru

Списание себестоимости товара

Tani 12.05.2004 13:12 | При поступлении товара формируется проводка Д41.1 К61.1 сумма 173.39, кол-во 2 шт. При отгрузке накладная1 Д90.2.1 К41.1 сумма 86.70 кол-во 1 шт, накладная2 Д90.2.1 К41.1 сумма 86.70 кол-во 1 шт. На счете 41.1 остается отрицательное дебетовое сальдо. Что делать с этим сольдо, или как его избежать?
427 1 - 12.05.2004 13:46 | Все нормально.... Это ошибка криворуких прогов, делавших типовую.... Пиши на линию консультаций ... Пусть исправляют.... P.S. Заодно узнаешь, как работает хваленая линия.... и как посылают
BorisG 4 - 12.05.2004 14:11 | (3) На линию консультаций надо не звонить, а писАть ;-))) Берешь типовую демо базу, воспроизводишь ошибку, описываешь, как это получилось, отправляешь и... наслаждаешься... ;-))
Tani 7 - 12.05.2004 14:49 | Приходит Счет фактура со следующими суммами Сумма без НДС = 173.39 НДС 18% сверху = 31.21 количество 2 шт. В колонке цена автоматически ставиться цена 86.70.
SnarkHunter 8 - 12.05.2004 14:52 | Вот тут собака и порылась... Когда третья цифра после запятой есть 5...
Marinka 9 - 12.05.2004 14:57 | (7) ну... делаем первую отгрузку 1 шт - Д90.2.1. К41.1 = 86,70, делаем вторую отгрузку 1 шт - Д90.2.1. К41.1 = 86,69 и никаких минусов нету... или я что-то не так делаю?


1c-амортизация | База знаний | mista.ru

1c-амортизация

nic 04.05.2004 11:53 | народ ввел основные средства, а расчет амортизации не производится, что неправильно?
Dionisious 1 - 04.05.2004 11:58 | В каком смысле не проводится? Если ошибку выдает то какую? Если не выдает, проводится, а амортизация = 0, тогда дело скорее всего в периодических реквизитах.
nic 2 - 04.05.2004 12:07 | просто при запуске расчета рассчитывает полько три единицы, а остальное игнорит
Dionisious 3 - 04.05.2004 12:16 | Точно периодические реквизиты справочника "Основные средства". В этом справочнике, в списке, есть кнопка внизу справа что то типа "дата периодических реквизитов". Нажимаешь, устанавливаешь дату на один день раньше чем начало периода за который расчитываешь амортизацию. Затем открываешь каждыэ элемент справочника и смотришь правильность заполнения всех реквизитов. Основные реквизиты: начислять амортизацию, подлежит амортизации, счет отнесения затрат на амортизацию, срок полезного использования.


Отчётность | База знаний | mista.ru

Отчётность

Троя 01.05.2004 08:13 | Из каких справочников в 1С:Бухгалтерия берутся данные при формировании регламент. бух. отчётности в лице бух. баланса (форма №1) и отчёта о прибылях и убытках (форма №2)?
GrayT 1 - 01.05.2004 09:10 | Из Бух. итогов. Только это не справочник
kvm 3 - 01.05.2004 16:25 | Заполни баланс кнопочкой заполнить и нажми F5 или кнопку "Расшифровать", он тебе скажет откуда что взял.


ФИО сотрудника перестала появляться в списках по кнопке ЗАПОЛНИТЬ | База знаний | mista.ru

ФИО сотрудника перестала появляться в списках по кнопке ЗАПОЛНИТЬ

СОН 09.11.2004 10:57 | Помогите, пожалуйста. Сотрудник работал внешним совместителем. Потом уволили и нас след. день оформили штатным сотрудником. После этого его ФИО перестала появляться в списках по кнопке ЗАПОЛНИТЬ. Может быть надо было для штатного открыть новую позицию в справочноке Сотрудников, а я воспользовалась прежней?
Marinka 2 - 09.11.2004 11:00 | Код ошибки : 00022031 Дата публикации : 12.08.2004 16:22:57 Дата последнего изменения: 12.08.2004 16:22:57 ----------------------------------------------------------------- Источник информации : ООО "Бизнес Софт" Описание: Сотрудники, уволенные ранее текущего месяца, не попадают в список при автозаполнении документов с флагом "прочие физлица".


ОСВ по 41.1---пустые строки---Что бы это значило? | База знаний | mista.ru

ОСВ по 41.1---пустые строки---Что бы это значило?

ЕА 04.11.2004 11:39 | Формирую ОСВ по 41.1 и (первый раз такое вижу!) Номенклатура есть а вся остальная строка пустая и таких строк очень много - это что-то с базой ... или.. Кто знает- откликнитесь!!!!!
427 3 - 04.11.2004 12:03 | косяк платформы + косяк ОСВ обсуждалось с год назад...
427 4 - 04.11.2004 12:04 | + по 10 такая же хрень бывает... причина - ошибка платформы при отсутствии суммового учета по второму субконто - неверно обрабатывается в ряде случаев...


Обновление бухгалтерии 461 релиз | База знаний | mista.ru

Обновление бухгалтерии 461 релиз

Akv
02.11.2004 10:06 		Добрый день всем.
При обновлении бухгалтерии (типовой) до 461 релиза
в обработке ОбновлениеИБ где - то при "обработке индивидуальных карточек сотрудников" выходит ошибка. Кто встречался и знает как помочь - напишите.
Я закомментарил это место в коде, в итоге все обновилось, но у первого сотрудника в списке (помеченного на удаление) новая карточка по ЕСН не формируется (ошибка).
Iren_O
7 - 02.11.2004 11:06 		Источник информации : Орлов В.В. (ВВ-Софт, Саратов)

Описание:
После обновления конфигурации на релиз 7.70.461 при запуске
программы в режиме "1С:Предприятие" может появиться сообщение об
ошибке:
"Обработка.ОбновлениеИБ.Форма.Модуль(6430)}: Значение не
представляет агрегатный объект (Получить)".

При этом, программа запускается, но не выполняется обновление
информационной базы, необходимое для корректной работы релиза
7.70.461.

Способ исправления:
1. В глобальном модуле после строки 10012 вставить строки:

Если ПустоеЗначение(Карточка) = 1 Тогда
Продолжить;
КонецЕсли;

2. В модуле обработки ОбновлениеИБ после строки 6399 вставить строки:

Если ПустоеЗначение(СписокСохранения) = 1 Тогда
Продолжить;
КонецЕсли;

Способ обхода:
- Из архивной копии восстановить информационную базу с предыдущим
релизом конфигурации;
- Запустить программу в режиме "1С:Предприятие";
- Для всех сотрудников, для которых сформированы налоговые
карточки за 2004 год (1-НДФЛ), сформировать и сохранить
индивидуальные карточки за 2004 год;
- Обновить релиз конфигурации на релиз 7.70.461.

Причина возникновения
Ошибка проявляется, если на момент обновления конфигурации, в
информационной базе сформированы налоговые карточки сотрудников
за 2004 год (1-НДФЛ), но не сформированы индивидуальные карточки
этих же сотрудников за 2004 год.

Планируется исправить в релизе: 7.70.462
BorisG
8 - 02.11.2004 11:17 		Если обновляете сами, просто обратитесь к партнерам или на Хотлайн. 1С выпустила обработку ICARDS.ERT, исправляющую данную ситуацию.


Хелп по бухгалтерии!!!!!!!! | База знаний | mista.ru

Хелп по бухгалтерии!!!!!!!!

tron 29.10.2004 07:46 | Привет люди! Начал изучать 7.7 (причём, как программинг так и собственно, саму бухгалтерию), проблема в том, что ни как не пойму, что такое дебет и кредит??? Может кто нить плиз поможет(опишет, как то образно, "нарисует", или ещё как нибудь).
Мишка на сеРвере 1 - 29.10.2004 07:50 | гыы... дык сначала надобы теорию бухучета выучить :) лан... счет делится на две ветки: первая - поступления на счет (чаще всего дебет), вторая - списание со счета (чаще всего кредит). Разница между дебетом и кредитом называется сальдо. теперь по поводу видов счета... бывают активные, пассивные, и активно-пассивные счета (прям как у геев :) ), так вот. на активных счетах поступления - это дебет, на пассивных наоборот - кредит.
Волшебник 3 - 29.10.2004 08:11 | ликбез по бухучету для компьютОрщиков http://www.erpg.ru/theory/buh4it/index.htm


Выскакивает код ошибки 10. Как исправить? | База знаний | mista.ru

Выскакивает код ошибки 10. Как исправить?

Gamma
13.10.2004 06:10 		Пришел программист и чего-то наворотил, теперь выскакивает ошибка с кодом 10. Подскажите как от нее избавиться?
Морозов Александр
4 - 13.10.2004 06:21 		10 Ошибка закрытия файла
20 Ошибка создания файла
30 Ошибка определения длины файла
40 Ошибка установки длины файла
50 Ошибка при попытке заблокировать файл
60 Ошибка при открытии файла
70 Ошибка чтения файла
80 Ошибка удаления файла
90 Ошибка переименования файла
100 Ошибка позиционирования в файле
110 Ошибка снятия блокировки с файла
120 Ошибка записи в файл
200 Файл не является базой данных DBF-формата
210 Неопознанное имя поля
220 Неопознанный тип поля
230 Запись слишком длинная
300 Индексный файл не содержит информации о записи
310 Нарушение структуры индексного файла
330 Указанное имя индекса недоступно
340 Ошибка уникальности индекса
400 Ожидается запятая или скобка
410 Выражение не завершено
422 IFF() требует параметров одинаковой длины
425 У STR() и SUBSTR() 2-й и 3-й параметры - константы
430 Неверное число параметров
440 Слишком сложное выражение
450 Пропущена правая скобка
460 Неверный тип подвыражения
470 Неопознанная функция
480 Неопознанный оператор
500 Выражение не завершено символом двойной кавычки
920 Недостаточно памяти


OFF: проблема с округлением | База знаний | mista.ru

OFF: проблема с округлением

makhnov 08.10.2004 09:26 | вот например... товар стоит 127,97 НДС 23,03 итого 151 р потом товар 254,24 НДС 45,76 итого 300 р. товар стоит 451 р НДС 68,79 вроде все правильно.. а если считать (151+300) * 18 / 118 НДС получится 68,80 и так может набежать довольно много копеек. это конечно копейки, но всетаки как правильно платить налог. я предложил не обращать на это внимание, может зря?
SnarkHunter 1 - 08.10.2004 09:27 | Правильно - от общей суммы...
Таня 3 - 08.10.2004 10:06 | я эту проблему решала увеличением точности после запятой до 4-х знаков у НДС.
Шапокляк 7 - 08.10.2004 10:43 | К сожалению, нет у меня сейчас возможности доступа к справочной системе. Попробуй для начала те законы, на которые ссылка в шапке счета-фактуры в печатной форме. на 1С-овском форуме для партнеров много на эту тему было тоже. Гарант на ИТС-е есть, смотрите. То, что тут говорится, что НДС должен до копейки стыковаться с общей суммой по всем позициям - ахинея просто. Если позиций две, предположим, на одинаковую сумму, а НДС, если его рассчитывать от общей суммы, нечетный получается, что, по полкопейки добавлять в каждую строку? И хотелось бы мне посмотреть на бухгалтера покупателя, когда он это увидит! В общем так, короче, нет такого требования, хотите верьте, хотите проверяйте. Проблема надуманная - в этом документе конейка туда, в другом сюда. А платят с точностью до рубля (а кое-кто и до тысячи).


Какая есть команда в 1с чтобы сделать присвоение по сравнению? | База знаний | mista.ru

Какая есть команда в 1с чтобы сделать присвоение по сравнению?

Андрей 07.10.2004 05:35 | Какая есть команда в 1с чтобы сделать присвоение по сравнению, чтобы сделать вида (поле1, поле2, значение1, значение2), т.е. если поле 1=поле2, то присваивается знач1, если нет, то знач2?...вроде все просто, но никак найти немогу...подскажите...
SnarkHunter 1 - 07.10.2004 05:40 | Х = ?(Поле1 = Поле2, Значение1, Значение2);
Андрей 2 - 07.10.2004 06:12 | а как подцепить для такого случая +СокрЛП(СчетФактура)+...чтобы не высвечивала пустое значение если пусто в поле счетфактуры?..что то у меня не получается...
Морозов Александр 4 - 07.10.2004 06:17 | Строка="Для данного документа " +?(Текст(СокрЛП(СчетФактура))="","нет счет фактуры",Строка=СокрЛП(СчетФактура));


А кто в бехгалтерии реализовал партионный учет с на 41 +учет наценок на 44? | База знаний | mista.ru

А кто в бехгалтерии реализовал партионный учет с на 41 +учет наценок на 44?

Nikulin
20.09.2004 17:10 		А кто в бехгалтерии реализовал партионный учет с на 41 + учет наценок на 44 по правилам ПБУ, или как в торговле?
Собственно, есть ли что нибудь готовое, дабы не изобретать извечный двухколесный монстр?
Хряк
1 - 20.09.2004 17:38 		Не моё!
Как сделать FIFO/LIFO в бухгалтерии

Поскольку такой вопрос задается достаточно регулярно, а фирма "1С" не решается
внести такую возможность в типовые конфигурации (4.2х), я решил опубликовать
свое решение данной проблемы. Надеюсь, что это кому-нибудь поможет....

Можете высказать благодарности и пожелания на
alex_2k@mailru.com
или
alex_2k@mail.ru

Просьба не писать о возможных неполадках и багах. Это всего-лишь пример (хотя и рабочий)

------
Александр (АКА "ПростоТАК")

Итак,
1. Заводим перечисление "МетодыСписания" - fifo/lifo/ПоСредней
2. Заводим константу "МетодСписания"- тип "МетодыСписания"
3. Создаем новое субконто "Партия" - тип "Документ"
4. На счете 41.1 (для примера) заводим 3-ее субконто "Партия" - тип "Партия"
5. В модуль документа поступления на наш счет (41.1) добавляем строчки (например)

Операция.Дебет.Партия =ТекущийДокумент();

6. Добавляем следующий кусок кода в модуль документа списания (например, "расходная накладная")

....
7. Прикручиваем в нужном месте вызов процедуры списания по партиям (это самое сложное ...)

8. Ну и все, собственно....

// кусок модуля
Процедура ПроводкиСписания(КолвоСпис,СуммаСпис,Партия)
Операция.НоваяПроводка();

Операция.СодержаниеПроводки = "Отгружено со склада";
Операция.НомерЖурнала = "ТВ";
Операция.Кредит.Счет = СчетПоКоду("41.1");
Операция.Кредит.Номенклатура = Товар;
Операция.Кредит.МестаХранения = МестоХранения;
Операция.Кредит.Партия = Партия;
Операция.Количество = КолвоСпис;
Операция.Сумма = СуммаСпис;

Операция.Дебет.Счет = СчетПоКоду("90.2.1");;
Операция.Дебет.ВидыНоменклатуры = Товар.ВидНоменклатуры;

КонецПроцедуры

//_____________________________________________________________________________
Процедура СписаниеПартий()
Фл=0;
Если Константа.МетодСписания=Перечисление.МетодыСписания.FIFO Тогда
Фл=0;
ИначеЕсли Константа.МетодСписания=Перечисление.МетодыСписания.LIFO Тогда
Фл=1;
КонецЕсли;

ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
ОсталосьСписать=Количество;
ИтогСуммаСписания=0;
Ит = СоздатьОбъект ("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура,Товар, 2);
Ит.ИспользоватьСубконто(ВидыСубконто.Партия);
Ит.ВыполнитьЗапрос(,ТекущийДокумент(),"41.1",,1);//,"Операция");
Ит.ВыбратьСубконто(1);
Ит.ПолучитьСубконто(1);
ОбщийОстаток=Ит.СКД(3);
Если ОсталосьСписать>ОбщийОстаток Тогда
Сообщить("Недостаточно товара на складе, остаток="+ОбщийОстаток);
СтатусВозврата(0) ;
Возврат;
КонецЕсли;
Ит.ВыбратьСубконто(2,,,,1,,Фл);
Пока Ит.ПолучитьСубконто(2) = 1 Цикл
Остаток=Ит.СКД(3);
ОстатокСумма=Ит.СКД(1);
Списываем=Мин(Остаток,ОсталосьСписать);
СуммаСписания = ОстатокСумма/Остаток*Списываем;
// СуммаСписания=Окр(Цена*Списываем,2);
ОсталосьСписать=ОсталосьСписать-Списываем;
Если ОсталосьСписать<=0 Тогда
// все списали, подгоним последнюю цифру
// СуммаСписания=Сумма-ИтогСуммаСписания;
ИтогСуммаСписания=ИтогСуммаСписания+Окр(СуммаСписания,2);
ПроводкиСписания(Списываем,СуммаСписания,Ит.Субконто(2));
Сообщить("Последнее по "+Ит.ПредставлениеСубконто(2)+" = "+Остаток+", списываем "+Списываем+" осталось "+ОсталосьСписать+" сумма "+СуммаСписания+" итого "+ИтогСуммаСписания);
Прервать;
Иначе
ПроводкиСписания(Списываем,СуммаСписания,Ит.Субконто(2));
Сообщить("Остаток по "+Ит.ПредставлениеСубконто(2)+" = "+Остаток+", списываем "+Списываем+" осталось "+ОсталосьСписать+" сумма "+СуммаСписания);
ИтогСуммаСписания=ИтогСуммаСписания+Окр(СуммаСписания,2);
КонецЕсли;
КонецЦикла;
КонецЦикла;
Операция.Записать();

КонецПроцедуры //СписаниеПартий()
F427
2 - 20.09.2004 18:52 		Полное повторение торговли.
Работать будет 100%

Трах с перепроведением при работе заним числом
lemon
3 - 20.09.2004 19:13 		(1) зачем создавать бухитоги в цикле?
должна позволять списывать больше в случае, когда одинаковый товар в более, чем одной строке... проверь...
psk21office
4 - 20.09.2004 19:21 		(1) Кусок кода:
Процедура СписаниеПартий()
Фл=0;
Если Константа.МетодСписания=Перечисление.МетодыСписания.FIFO Тогда
Фл=0;
ИначеЕсли Константа.МетодСписания=Перечисление.МетодыСписания.LIFO Тогда
Фл=1;
КонецЕсли;

ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
[....]
Ит = СоздатьОбъект ("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура,Товар, 2);
Ит.ИспользоватьСубконто(ВидыСубконто.Партия);
Ит.ВыполнитьЗапрос(,ТекущийДокумент(),"41.1",,1);//,"Операция");
[....]
КонецЦикла
КонецПроцедуры

СЛЕДУЮЩИМ ОБРАЗОМ

Процедура СписаниеПартий()
Фл=0;
Если Константа.МетодСписания=Перечисление.МетодыСписания.FIFO Тогда
Фл=0;
ИначеЕсли Константа.МетодСписания=Перечисление.МетодыСписания.LIFO Тогда
Фл=1;
КонецЕсли;

Ит = СоздатьОбъект ("БухгалтерскиеИтоги");
Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура,Товар, 2);
Ит.ИспользоватьСубконто(ВидыСубконто.Партия);
Ит.ВыполнитьЗапрос(,ТекущийДокумент(),"41.1",,1);//,"Операция");

ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
[....]
КонецЦикла
КонецПроцедуры

При таком построении получаешь ускорение в разы.
(на аттестации за это снижают оценку на 2 балла).
psk21office
5 - 20.09.2004 19:22 		Сорри, строку:
Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура,Товар, 2);

надо читать так:
Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура);
F427
18 - 21.09.2004 09:24 		а каким боком 44 и наценка связаны? а 42 кудыть дели?

Разберись с учетом розницы в типовой бухии 4.60...
Там сделано достаточно хорошо, но есть пара НО
- в рознице требуется вести количественный учет. Этого торгаши не любят. Геморой. При большой номенклатуре действительно запарка.
В этом случае 41.2 в типовой ведется по себестоимости, а наценка считается в момент реализации. Против учета по себестоимости торгаши тоже орут - хотят по продажным ценам. Типа ответственность продавцов. Но по продажным - на самом деле гемор при возвратах и переоценках с НДСом будет нехилый...
Геморой типовой бухии исчезает, если в рознице стоят кассы со сканерами, из касс по концу смены можно выгрузить отчет о продажах, без проблем всосать его в бухию (или ТиС) и списать товар с точки с вычислением наценки... Учетная у тебя есть, товар, продажная стоимость и количество есть в отчете - все шоколадно...

P.S. - пройденный этап. так что на самом деле тебе требуется просто нормальное ведение розницы. А нормальное ведение требует нормальных средств учета в рознице - на данный момент это покупка соответствующего оборудования. Стоимость затрат там нехилая... разовая...

Если же розницу вести без количественного учета ... Ну тогда готовься к бардаку... В этом случае вообще все неконтролируемое...
Nikulin
21 - 21.09.2004 11:53 		И всеже.
Как мне в случае партионного учета определять сумму на 42 счет при поступлении или списании?
F427
22 - 21.09.2004 12:12 		документ перемещения двинет с 41.1 на 41.2 себестоимость и наценку с 42 на 41.2. Наценка - разность между себестоимостью и продажной ценой, которую ты укажешь в документе перемещения... Наценка вычислится в момент проведения..
После проведения по сумме наценки можно вычислить профит...

При изменении продажных цен нужно произвести переоценку 41.2 за счет изменения наценки...
Роешься в бух итогах и пытаешься вычислить ранее переданную наценку... Если переоценка делается по доку основанию - перемещению... то нет проблем...
Однако у тебя явно в рознице (41.2) будет товар из нескольких партий.... и ты так сделать не сможешь...

В этом случае - пусть роются руками в партиях и делают столько документов переоценки, сколько партий на 41.2 валяется.... Самый смак при этом, если док перемещения в розницу двинет несколько партий одного товара сразу...

Аналогично и при реализации товара...

Партии в этом случае дают только дополнительный геморой из-за лишнего разреза учета...

Но и без партий бухи трахнутся...

Так что самый дешевый способ избавиться от гемороя - вести 41.2 по себестоимости, а наценку определять в момент реализации по разности продажных цен и себестоимости... Что и реализовано в типовой бухии (кстати, в ТиС по моему, то же самое на регистрах сделано)...

P.S. а если у тебя еще и несколько точек будет - это при ведении 41.2 по продажным ценам вообще песня.... А при партионном учете - песня в квадрате....


Торговля, ЧерноБелая | База знаний | mista.ru

Торговля, ЧерноБелая

Rebel Yell 29.05.2004 08:46 | Мне нужно реализовать сабж в ТиС. По началу думал завести две фирмы в справочнике "фирмы" и от одной вести белое от другой черное.. но, если у меня отгрузка будет делиться на ч/б , то приход я хотел бы сделать общий, т.е. делаю поступление товара на склад, а потом могу отгружать этот товар как от одной так и от другой фирмы, такое было в 8.7! как это реализованно в 9.2? можно ли для этого както использовать справочник.АналитикаУправленческогоУчета?? или СобственныеЮридическиеЛица.?
vdi 2 - 29.05.2004 09:48 | (0) Что вы понимаете под черной бухгалтерией? Уход от налогов или управленческий учет?
BorisG 7 - 29.05.2004 10:51 | (5) Видишь ли, Денис, в открытой конференции не принято обсуждать особенности пушистого учета... Ибо это интимное дело директора, буха и... программиста, ЗНАЮЩЕГО, как сие организавать, чтобы и самому еще под статью не залететь... Однако его основы есть в вопросах на сертификации ;-)) (6) А разве эта область не повод для флейма? ;-))
vdi 8 - 29.05.2004 16:05 | (0) Некоторые варианты ведения управленческого учета можно посмотреть на диске ИТС. Например, "Методика обмена данными между информационными базами". Суть ее кратенько такова. 1) Заводишь две ИБ для ТиС. Одна скажем для управленческого учета, другая для финасового. 2) Предварительно все оперативные данные заносишь в ИБ-Упр. Те документы,которые обязательно должны отражаться финансовом учете, помечай значением реквизита "Проект", например "фин". 3) После того, как все данные для регистрации в финансовом учете будут готовы, запускаешь обработку "Выгрузка данных из редакции 9.2 в 9.2". С ее помощью выгружаешь данные из ИБ-Упр в ИБ-Фин. Привлекательность этой обработки в том, что она позволяет делать выборку по проектам. Надеюсь, что эффективные методы управленческого учета будут способствоать не только повышению прибыли твоей организации, но к наполнению бюджета РФ.
romix 12 - 29.05.2004 23:33 | Для черно-белого учета можно юзать УРБД. Черная база - "только приемник". Константы (названия фирм) надо настроить Миграция -> Место создания. А вообще уход от налогов - это вроде как статья. Статья также есть за пособничество (см. № статьи УК в гугле).
Rebel Yell 13 - 30.05.2004 04:46 | BorisG, я тебя знаю? А вот правильное решение, если кому интересно. (дали на 1с.forum) Объедини две фирмы одной упр.аналитикой, в настройках контроля остатков ТМЦ выставь "По упр аналитике". (или "по компании" - в зависимости от нужд учета)
BorisG 14 - 30.05.2004 12:22 | (13) Скорее знаешь ;-) Правильно тебе заказчик вопрос поставил... только вот ответ Вы должны выработать вместе... Относительно ответа в конференции 1С... не решает он твоей проблемы. Ибо многое зависит от взаимодействия с поставщиком, наличия/отсутствия розницы, подакцизных товаров... взаимодействия персонала фирмы... Относительно же пространного ответа vdi... еще и рекомендованного в базу знаний... он, не смотря на свой апломб, просто не понимает особенностей разноцветного учета в учете управленческом... Впрочем... это уже проходили... Почитай... http://www.forum.mista.ru/topic.php?id=1528
427 15 - 30.05.2004 14:15 | (13) После трех-четырех месяцев боевой работы ты сумеешь оценить "красоту" подсказанного тебе решения...


Как изменить настройку валюты "вести учет" в Торговля-Склад | База знаний | mista.ru

Как изменить настройку валюты "вести учет" в Торговля-Склад

Gamma 17.08.2004 09:05 | При начальной настройке конфигурации установили по умолчанию "вести учет" в USD, а надо в рублях, но при этом некоторый период уже поработали в программе и лишь потом обнаружили этот недочет. Что можно сделать чтоб изменить настройку без потери данных?
3V 4 - 17.08.2004 11:42 | есть еще вариант, возьми напиши пустую обработку, где значение валюты прописывается на рубли и будет счастье в жизни :) работы на пять мин :)
Чип 5 - 17.08.2004 12:04 | Распроводишь доки ВСЕ абсолютно, заходишь в глобальник, находишь строчки, что-то типа этого Если (ВРег(ИмяКонстанты) = "НОМЕРРЕЛИЗА") или (ВРег(ИмяКонстанты)="БАЗОВАЯВАЛЮТА")ИЛИ (ВРег(ИмяКонстанты)="ОСНОВНАЯВАЛЮТА") Тогда Предупреждение("Константа """+СокрЛП(ИмяКонстанты)+""" является служебной и |не может быть изменена вручную."); СтатусВозврата(0); Возврат; КонецЕсли; закоментируй строчку СтатусВозврата(0), сохраняйся, меняй твою валюту, прога скажет что менять нельзя, но поменяет, потом убираешь комментарий (от шаловливых юзеров) Проводишь все доки и смотришь что получилось. у меня получилось все Ок, только делай для начала на тестовой базе.


Как убрать окно Время документа при проведении документа? | База знаний | mista.ru

Как убрать окно Время документа при проведении документа?

ollleup 20.07.2004 09:32 | Как убрать окно "Время документа" при проведении документа(по умолчанию пусть остаётся текущее время...)
fez 1 - 20.07.2004 09:36 | АвтоВремяТекущее(); Синтаксис: АвтоВремяТекущее() Назначение: Установить режим записи времени на текущее время дня для новых документов. Замечание: Для новых документов в модуле формы доступно использование методов установки признака автоформирования времени документа и собственно установки времени. Если эти методы использованы, то диалог запроса времени не вызывается и игнорируются пользовательские установки в параметрах системы.
fez 3 - 20.07.2004 09:40 | Не. В процедуру ПриЗаписи().
ollleup 5 - 20.07.2004 09:42 | записал в ПриОткрытии() - работает...
fez 6 - 20.07.2004 09:48 | Главное - проверить, что не будет падать при открытии и перезаписи уже существующего документа. Стоит отдельно проверить для текущей даты, отдельно - для вчерашней.
Vantala 8 - 20.07.2004 11:09 | Модули править вовсе не обязательно. Окно "Время документа" можно убрать через Сервис - Параметры: на вкладке "Бухгалтерия" снять флажок "Запрашивать время при вводе документов и операций"
fez 9 - 20.07.2004 11:15 | (8) А если пользователей - 40 человек в трех зданиях?


Помогите с Запросом !!! | База знаний | mista.ru

Помогите с Запросом !!!

Tetr
20.07.2004 01:06 		Конфигурация [Торговля и склад]. Есть регистр [Партиии Товаров]. Допустим сегодня поступила [Приходная накладная № п01] на 10т трубы, завели. Затем [Расходная накладная № р01] на 7т трубы, завели. Затем выписываем [Расходную накладную № р02] на 3т трубы. Все 3 операции проделаны в течении одного дня. НАДО -> определить остаток трубы по регистру [Партиии Товаров] на момент выписки [Расходная накладная № р02], т.е. должна показать 3 тонны:

Док = ("СоздатьОбъект.РасходнаяНакладная");
Док.НайтиПоНомеру("р02");
ТекДок = Док.ТекущийДокумент();

ВремРег = ("Регистр");
Рег = ВремРег.ПартииТоваров;
ВремРег.ВременныйРасчет();
Рег.РассчитатьРегистрыНа(ТекДок);

ТекстЗапроса = "
|ПЕРИОД с ТекДок по ТекДок
.................
.................
.................

????????
Bekas
1 - 20.07.2004 01:11 		В описываемом случае не обязательно строить запрос. Можно легко воспользоваться Методом .Остаток() или .СводныйОстаток()
Матрейя
2 - 20.07.2004 01:14 		Достаточно временого расчета.
Рег=СоздатьОбъект("Регистры");
РегП=Рег.ПартииТоваров;
Граница=?(Выбран()=1,ПолучитьПозицию(),ДатаДок);
ГраницаТа=?(Выбран()=1,ПолучитьПозициюТа(),ПолучитьДатуТа());
Если Граница<ГраницаТа Тогда
РегП.ВременныйРасчет(1);
РегП.УстановитьЗначениеФильтра(.........);
Рег.РассчитатьРегистрыНа(Граница);
КонецЕсли;
Остаток=РегП.Остаток(.......,"Количество");


Перемещение ТМЦ | База знаний | mista.ru

Перемещение ТМЦ

lili 02.07.2004 11:48 | Скажите, пожалуйста, какие проводки должны формироваться в документе "Перемещение ТМЦ". ГБ утверждает что там должна быть проводка Дт 41.2 Кт 19.3 с суммой НДС. Но в этом документе такого не предусмотрено. Я предложила ей сторнировать его документом "Закрытие месяца", т.к. розница под ЕНВД, но понять не могу как этот документ работает. Какой выход есть из ситуации?
427 4 - 02.07.2004 12:04 | ГБ права.... при перемещении с 41.1 на 41.2 НДС должен быть перемещен с 19 на 41.2... Ну а точно - надо смотреть, как у вас поставлен учет в рознице.... ибо если по продажным - то д.б еще д41.2 к42
Valery 6 - 02.07.2004 12:46 | 427 прав. Розница НДС не облагается (вменека), поэтому книга покупок должна быть уменьшена на сумму товара перемещенного в розницу. К С-ф эта операция отношения не имеет.
mszsuz 18 - 03.07.2004 14:41 | (16) ОФФ: загляни на ХИППО, посмотри какую ОСВ туда сегодня принял. Конфетка.
mszsuz 20 - 03.07.2004 14:46 | http://1c.hippo.ru/cgi-bin/predownl.cgi?id=3597


Хочу упростить оформление договоров... | База знаний | mista.ru

Хочу упростить оформление договоров...

Gus 25.06.2004 14:44 | Вопрос. Хочу упростить оформление договоров. Суть дела: приходит заявка по факсу, я ее забиваю в 1С. Надо: возможность на основании этой заявки напечатать договор с приложениями: спецификация оборудования, акт передачи оборудования, акт возврата оного, акт выполненных работ. Я надеюсь эта простая задача уже приходила кому-то в голову и есть готовые (типовые) варианты реализации. Просьба подсказать ссылку(и). Заранее спасибо.
AlexMan 1 - 25.06.2004 14:47 | Договоры в Word надо забивать....
Gus 2 - 25.06.2004 14:53 | Ответ ваш понятен, и очень лаконичен. Мне же нужно решение на базе 1С. Если знаете вариант решения я вам буду признателен.
Композитор 3 - 25.06.2004 14:53 | (1) Не обязательно. (0) Пример: Быстрая продажа в комплексной.
AlexMan 4 - 25.06.2004 14:55 | (3) при чем здесь договора?
Gus 5 - 25.06.2004 14:55 | <b>Пример: Быстрая продажа в комплексной.</b> Есть ли возможность данного способа в Торговле 9.2?
AlexMan 6 - 25.06.2004 14:57 | +(4) в (0) идет речь о печатных формах а не о эл-ных.
AlexMan 7 - 25.06.2004 14:58 | (5) Быстрая продажа есть и в торговле.
Gus 8 - 25.06.2004 14:59 | Необходимость оформления договоров силами 1С происходит от лени. Не хочется заморачиваться с шаблонами в ворде и т.д. А на основе заявки получить полный пакет документов (перечисленных выше) это (как я понимаю возможности 1С) просто.
Bell 11 - 25.06.2004 15:04 | (0)я подобное делал. см. аналог "Рынок-Аренда", если доработать идеи, то все реализуемо. см. на hippо.
Композитор 16 - 25.06.2004 15:11 | (8) Не ограничивайтесь бумажными формами. Делайте полный пакет "Документов".
Gus 17 - 25.06.2004 15:15 | (16) Для этого мне надо делать Справочник Договора куда все эти договора и етк. и будут заноситься?! Для этого мои познания еще не доросли, а вот обработать уже сделаное я наверное смогу... сейчас ищу наиболее подходящую для меня наработку... с вариантом подогнать ее под себя...


Учет оплаты кредитов | База знаний | mista.ru

Учет оплаты кредитов

Segment 20.06.2004 22:45 | Hello All! Жизнь заставляет знакомится с 1С. Возможно, это есть и в стандартной конфигурации, но на глаза не попалось. вобщем встала такая задача: занесение информации по проплате кредита. Подскажите, как это можно реализовать. У меня есть в бумажном варианте таблица со сроками погашения кредита. Мне это нужно впихнуть в 1с с возможностью напротив каждой даты ставить пометку, что платеж совершен. Как это сделать - ума не приложу. При обычном программировании (например, delphi + interbase) 1-е , что приходит на ум, это создать таблицу, в которой будут поля (упрощенно): id | наименование_кредита | дата погашения | дата реал. оплаты | плательщик | примечание нечто подобное мне и надо в 1с с возможностью просмотров сколько оплачено, сколько нет, кто платитл/неплатил ну и т.д. Направьте, плз, в нужном направлении.
koshechka 1 - 21.06.2004 01:55 | создай справочник например <кредиты>, в котором будут вышеуказанные поля, с отображение только в списке, и прицепи к нему пару документов, например чтоб записывался элемент документом, и оплата кредита документом, при открытии справочника будет видно, когда произошла реал.оплата, можно даже прицепить поле сколько на дату реал.оплаты оплачено


Вопрос по запросу для отчета | База знаний | mista.ru

Вопрос по запросу для отчета

Freelancer
09.06.2004 16:15 		|Период с ВыбНачПериода по ВыбКонПериода;
|Менеджер = Справочник.Контрагенты.ОсновноеСвойство.ЗначениеСвойства.Наименование;
|Контрагент = Справочник.Контрагенты.Наименование;
|ДатаОтгрузки = Документ.Реализация.ДатаДок;
|Группировка Менеджер;
|Группировка Контрагент;
|Группировка ДатаОтгрузки;

Данные по менеджеру и контрагенту выводятся а вот данные по документу не выбираются (пусто). подскажите где я ошибся?
Gavrila
10 - 09.06.2004 16:29 		|Период с ВыбНачПериода по ВыбКонПериода;
|Менеджер = Документ.Реализация.Контрагент.ОсновноеСвойство.ЗначениеСвойства.Наименование;
|Контрагент = Документ.Реализация.Контрагент.Наименование;
|ДатаОтгрузки = Документ.Реализация.ДатаДок;
|Группировка Менеджер;
|Группировка Контрагент;
|Группировка ДатаОтгрузки;
Freelancer
13 - 09.06.2004 16:35 		и еще вопрос на будущее... а если мне понадобится присоединять столбцы с данными из других документов (не Реализации), то как поступать?
Bzzzzz
15 - 09.06.2004 16:38 		(13) Смотря какие данные.
Возможно проще сделать запрос по регистрам(что обычно и делается) или по некольким видам документам, выделив у доков общие "измерения" для группировки.
Gavrila
16 - 09.06.2004 16:39 		|Период с ВыбНачПериода по ВыбКонПериода;
|Менеджер = Документ.Реализация.Контрагент.ОсновноеСвойство.ЗначениеСвойства.Наименование, Документ.ДругойДокумент.Контрагент.ОсновноеСвойство.ЗначениеСвойства.Наименование;
|Контрагент = Документ.Реализация.Контрагент.Наименование, Документ.ДругойДокумент.Контрагент.Наименование;
|ДатаОтгрузки = Документ.Реализация.ДатаДок, Документ.ДругойДокумент.ДатаДок;
|Группировка Менеджер;
|Группировка Контрагент;
|Группировка ДатаОтгрузки;
Freelancer
22 - 09.06.2004 16:54 		а из запроса как обратится к периодическому элементу справочника? (курсу валюты)
Gavrila
23 - 09.06.2004 17:33 		(22)
//*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Валюты = Справочник.Валюты.ТекущийЭлемент;
|Курс = Справочник.Валюты.Курс;
|Кратность = Справочник.Валюты.Кратность;
|Группировка Валюты;
|Группировка Курс;
|Группировка Кратность;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка(1) = 1 Цикл
// Заполнение полей Валюты
Таб.ВывестиСекцию("Валюты");
Пока Запрос.Группировка(2) = 1 Цикл
// Заполнение полей Курс
Таб.ВывестиСекцию("Курс");
Пока Запрос.Группировка(3) = 1 Цикл
// Заполнение полей Кратность
Таб.ВывестиСекцию("Кратность");
КонецЦикла;
КонецЦикла;
КонецЦикла;
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры

Конструктор форева :)


Могут ли находится в близких отношениях Товар принятый и Книга продаж? | База знаний | mista.ru

Могут ли находится в близких отношениях Товар принятый и Книга продаж?

Mazay 09.06.2004 23:30 | Суть: должны ли попадать счет-фактуры выданные в книгу продаж, если в них отражается НДС от реализации "товара принятого на комиссию".
427 1 - 09.06.2004 23:40 | А это как составлен договор.... И через кого идет оплата... Там нюансов до горы... В любом случае комиссионное вознаграждение с НДС и он д.б. в книге...
vdi 2 - 10.06.2004 07:07 | ИТС: "Учет операций по договорам комиссии и купли-продажи". Были и другие материалы.


Документ "ОприходованиеТМЦ" - проведение по регистрам. | База знаний | mista.ru

Документ "ОприходованиеТМЦ" - проведение по регистрам.

Frol 07.06.2004 14:34 | Привет всем! Ситуация: При проведении документа "ОприходованиеТМЦ" нужно, чтобы товар приходовался в ту партию, из которой он был (ошибочно, при пересортице) реализован. Для чего это нужно - чтобы отслеживать реальный остаток товара от конкретного поставщика (клиент это делает с помощью отчета "Ведомость по партиям ТМЦ". Подскажите, кто знает, как лучше сделать?
Gavrila 1 - 07.06.2004 14:43 | Добавить в табличную часть партию
Frol 2 - 07.06.2004 15:09 | (1) вообщето там уже есть такой реквизит...и он заполняется новым значением (создается новая партия - без контрагента). Но это я уже переделал,у меня партия уже заполняется путем выбора из списанных партий. Но всё-равно, почемуто, документ не попадает в отче "Ведомость по партиям ТМЦ". Какие ещё могут быть 'подводные камни'?
Gavrila 3 - 07.06.2004 15:15 | (2) Партия может и заполняется, а проведение по какой партии выполняется?
Frol 4 - 07.06.2004 15:25 | (3) И проводится тоже, есстессьна по той-же партии, я проверил.
lexa 6 - 07.06.2004 16:16 | (5) посмотри документ ВводОстатковТМЦ, там вначале ищется партия, а потом если нет создается новая
Gavrila 7 - 07.06.2004 18:13 | (5) если по регистру правильно проводится значитца ищи в отчете :)


Ведомость по контрагентам в торговле 7.70.926 | База знаний | mista.ru

Ведомость по контрагентам в торговле 7.70.926

serj 07.06.2004 16:48 | Доброго всем времени суток! Проблема с торговлей. Опер вводит документ "Поступление ТМЦ (купля-продажа)" и проводит его, на контрагенте ессно виснет долг (отрицательный). После оплаты на основании этого документа бухи вводят "Строку выписки банка (расход)" и проводят. Шеф вызывает отчет "Ведомость по контрагентам" с детализацией по кредитным документам и документам движения, и наблюдает, что банковская выписка независимо от ее основания цепляется к другому, более раннему непроплаченному поступлению ТМЦ, подходящему по сумме. Как победить это безобразие?
lexa 1 - 07.06.2004 16:51 | долг считается на основании договора контрагента, если хочешь чтоб все было красиво, добавляй новый договор каждый раз или пиши свой расчет, отчет по контрагентам строится на основании соответствующих регистров, а проведение по регистрам происходит по договорам, а не по док. основаниям


Помогите с отчетом "Остатки ТМЦ" в 1С ТиС | База знаний | mista.ru

Помогите с отчетом "Остатки ТМЦ" в 1С ТиС

Forgotten god 01.06.2004 12:58 | Народ, я только учусь вот начальство решило озадачит в остатках ТМЦ хотят видет три цены Закупочную, Оптовую и Розничную, где что можно поправить или если есть такой отчет то где (единственное нужно с управлением аналитика).
Композитор 9 - 01.06.2004 13:38 | (4) 1. В отчете добавить три колонки с ценами. 2. В секцию, в которой фигурирует номенклатура в соответствующие колонки вставить переменные, которым необходимо присвоить значения соответствующих типов цен. 3. Перед выводом секции, в которой фигурирует номенклатура, взять из справочника цены нужных Вам типов и присвоить значения этих цен соответствующим переменным.
lexa 12 - 01.06.2004 15:59 | посмотри ПечатьПрайслиста, там есть отбор по остаткам , туда же можешь добавить количество


Клиент банка | База знаний | mista.ru

Клиент банка

uan 01.06.2004 06:29 | Существует ли обработка, позволяющая производить обмен данными между Торговля+Склад релиз 933 и Клиент сбербанка?
427 1 - 01.06.2004 06:52 | Да Но в разных городах и даже разных отделениях сбербанка может быть разный клиент...


Две позиции товара с разной ценой в РН? | База знаний | mista.ru

Две позиции товара с разной ценой в РН?

Inside 25.05.2004 13:42 | Есть продажа двух единиц товара. Одна со скидкой, а вторая нет. При внесении в РН ругается что мол уже присутствует в списке и нельзя добавить ещё один. А надо... Могу заремарить все эти предупреждения, но вот вопрос. Не нарушится ли что-нибудь в учёте?
kortun 1 - 25.05.2004 14:09 | У меня было такое же в ТиС, при проведение в регистры записывается только последня цена. Соответственно при отчете к примеру по продажам я видел что этот товар продался по этой накладной только по последней цене, при этом количество сложилось


Кто работал с торговлей??? | База знаний | mista.ru

Кто работал с торговлей???

Mario 06.05.2004 10:01 | Господа. Вопрос из зала. Каким образом строится работа со счетами в торговле ред 9.29 ?
Mario 2 - 06.05.2004 10:16 | Меня интересует 19 счет.
3ton 18 - 06.05.2004 14:03 | см: http://www.buh.ru/qaDescr.jsp?ID=221 http://www.buh.ru/document.jsp?ID=564 http://www.buh.ru/qaDescr.jsp?ID=196 и http://www.buh.ru/qaDescr.jsp?ID=235 (!!!)
3ton 19 - 06.05.2004 14:09 | кстати в догонку (18) выдержка из Гаранта: " Как следствие внесенных изменений в расчет НДС на предприятиях, занимающихся как оптовой торговлей, так и розничной, в 2000 г. упростился порядок передачи товаров из оптовой торговли в розничную и наоборот. Действительно, при передаче товаров, изначально закупленных для последующей реализации оптом, в розничную торговлю предприятию следовало восстановить в дебет счета 41 "Товары" сумму НДС, относящуюся к этим товарам, отнесенную при оприходовании в дебет счета 19 "НДС по приобретенным ценностям". Согласно письму Госналогслужбы РФ от 20 декабря 1995 г. N 05-4-09/41 "О налоге на добавленную стоимость" на эти суммы следовало кредитовать счет 68 "Расчеты с бюджетом" в корреспонденции со счетом 41, субсчет 41-2 "Товары в розничной торговле". Теперь передача товаров из оптовой торговли в розничную отразится лишь записями в аналитическом учете по счету 41. "
GrayT 20 - 06.05.2004 14:30 | (18) 1 - да можете добавить 2 - при чем тут инвентаризация? 3 - см 1 4 -ЕНВД склад Диск ИТС есть? Там есть справочник хоз опраций
GrayT 25 - 06.05.2004 14:57 | (24)И главное выжидал когда меня затопчут ;) (23)Вот и читаю "Покупка товаров для розничной торговли (учет товара по продажным ценам)". проводка №6 "Входной" НДС отнесен на расчеты с бюджетом 68/2,41 19/3 И если 19 прав, то это чтож и ИТСу верить нельзя, и где тогда проходить начальную школу по бух. учету?
3ton 26 - 06.05.2004 15:07 | Я думаю, что у (0) специфика торговой деятельности оптово-розничная, где розничная торговля не является основным видом деятельности. Поэтому и трактование формирования проводок двояко. (Хм... даже у 1С, т.к. основные заточки ТиС идут под оптовую спец., и еще по оплате (хотя даже и тут не везде, как надо)) :)
GrayT 27 - 19.05.2004 12:03 | (19)А вот выдержка из Консультанта+ "....Следовательно, при передаче товара для продажи в режиме розничной торговли, переведенной на уплату ЕНВД, организация, руководствуясь п.3 ст.170 НК РФ, должна восстановить к уплате в бюджет принятый к вычету НДС по переданному товару, что отражается в учете по кредиту счета 68 и дебету счета 19, субсчет 19-3-2. Восстановленная сумма НДС относится на увеличение стоимости товара записью по кредиту счета 19, субсчет 19-3-2, и дебету счета 41, субсчет 41-2...."
mike 28 - 19.05.2004 21:18 | Я решал подобную задачу при переносе из торговли в бухаглтерию :в торговле вообще за НДС не следили. а в бухгалтерии на основаниию типа складов происходило либо доначисление НДС либо списание его . Там было три типа складов : остатки на 41 были опт без НДС, опт с НДС и в розн ценах. Есть смысл написать свой отчет по перемещениям , при анализе документов перемещения анализировать тип склада поставщика и получателя и соответственно выводить в таблицу нужные проводки.
427 29 - 19.05.2004 22:18 | (28) полная фня... на 41.1 может быть только себестоимость без НДС (ПБУ надо чтить)... ибо при оприходовании НДС выделяется и складируется штабелями на 19 если же ты купил товар у ЧП (а у него НДС не выделяется) - тогда у тебя на 41.1 полная его себестоимость... и это означает, что НДС контора выплатит из своего кармана... на 41.2 (товары в рознице) валяется себестоимость ВМЕСТЕ с НДС... и при перемещении ты его отгрызаешь с 19.... Так что ОПТ с НДС - означает, что ГавБух - полный ч(м)удак.... Анализировать по типу склада - опасно... Запутаются... Мечта всех ГавБухов - ведение учета на 41.2 В ПРОДАЖНЫХ ценах в типовой отсутствует, ибо разработчики не смогли решить эту проблему... Но тем не менее это часто есть в жизни...
mike 30 - 20.05.2004 07:24 | (29) сам ты фигня ! Никто не путается ,ведется несколько видов учета одновременно : ЕНВД, общая система и учет по самообслуживанию, этой схемы не избежать. По общей системе у тебя всегда будет убыток если наценка меньше 40 %
427 31 - 20.05.2004 08:18 | Ню-Ню .... Нююююю ..... Многие оптовики работают на наценке 8-12% .... и вполне прибыльны... А 40% - это только там, где эта контора - монополист...
SnarkHunter 32 - 20.05.2004 08:24 | Скажу больше... Есть отрасли, где наценка на опте в 4% считается ОЧЕНЬ большой...
mike 33 - 20.05.2004 09:34 | (30) данная контора - предприятие из нескольких розничных магазинов. Другое дело , что они сами не могут оптимизировать свою работу, и из-за этого большие издержки.


Вопрос по 1с: Торговля и склад | База знаний | mista.ru

Вопрос по 1с: Торговля и склад

Fantom 17.05.2004 00:54 | Не могу провести Расходную розничную пишит "Для рабочего места *** не определен розничный склад"
Влад 1 - 17.05.2004 04:41 | Скорее всего в справочнике пользователей для текущего пользователя не установлен склад по умолчанию. А вообще, нужно просто взять строку сообщения и поискать поиском во всех текстах в конфигураторе и посмотреть какой модуль (модули) его могут выдавать. В Вашем случае можно сразу в модуле формы документа РасходнаяНакладная посмотреть, а может и в модуле самого документа. В общем воспользуйтесь поиском.
NiGMa 2 - 17.05.2004 08:22 | Я так понимаю, что речь про ТиС 8.х? Тогда дело совсем не в этом. Надо зайти в Настройку торгового оборудования и там настроить розничный склад, "обслуживаемый с данного рабочего места". А чтобы работали Отчеты кассовых смен - надо еще занести в справочник касс хотя бы одну кассу и отметить ее как неавтоматизированную.


Пользовательский вопрос по Торговле | База знаний | mista.ru

Пользовательский вопрос по Торговле

Danila 16.05.2004 12:45 | Подскажите пожалуйста как в Торговле зарезервировать на складе товар. Не могу найти. Заранее благодарю!
iceTiger 4 - 16.05.2004 15:16 | Счет выписать... :)
Danila 5 - 16.05.2004 22:08 | [2 iceTiger] Не совсем... Надо сделать заявку на склад...


1С Торговля+Склад Release R770934 | База знаний | mista.ru

1С Торговля+Склад Release R770934

Александр 12.05.2004 22:08 | Скажите plssssss!!! Почему в Т+С release R770934 отсутсвуют новые формы для счетов-фактур, книги покупок и книги продаж. И где их можно найти. PS: Срочно.
DElo 1 - 12.05.2004 22:14 | На диске ИТС апрель или май в универсальных отчётах и обработках


Как правильно в ТиС оформить возврат от подотчетника? | База знаний | mista.ru

Как правильно в ТиС оформить возврат от подотчетника?

Alni 11.05.2004 15:42 | ТиС 7.70 933 (1С предприятие 7.70 019). Подскажите как правильно оформить возврат денег от подотчетника? Если оформить только ПКО, то сумма в Ведомости по подотчетникам не идет с суммой по авансовому отчету, т.е. ПКО не отражается в Авансовом отчете. Как кто решает эту проблему?
vdi 1 - 11.05.2004 16:21 | Не забыли ли вы в ПКО реквизиту "Вид оплаты" присвоить значение "Возврат от подотчетника"?
Alni 2 - 11.05.2004 16:25 | Нет, не забыли, поставили "возврат от подотчетника"
vdi 3 - 11.05.2004 17:42 | Вероятно, так и должно быть. В конфигурации не предусмотрено отражение ПКО в авансовом отчете. Его табличная часть может содержать только три типа строк. 1) Строка аванс.отчета (закупка ТМЦ) - 2) Строка аванс.отчета (оплата поставщику) - 3) Строка аванс.отчета (прочее) - оформляется в том случае, если выданные сотруднику под отчет средства были израсходованы на наличную оплату ТМЦ, приобретенных у поставщика. Ведомость по подотчетным лицам учитывает возврат, ПКО.
Alni 4 - 12.05.2004 13:12 | И все-таки, если ПКО не попадает в авансовый отчет, то идет расхождение . По авансовому отчету подотчетник должен фирме, а по Ведомости фирма должна подотчетнику. Наверно можно сделать строку авансового отчета на сумму ПКО и не проставлять счет, чтобы не дублировалась проводка созданная ПКО. Может еще есть способы?


HELP! ТиС не правильно расчитывается сальдо | База знаний | mista.ru

HELP! ТиС не правильно расчитывается сальдо

Storm 11.05.2004 13:04 | Срочно, люди добрые помогите!!! Делаю отчет взаиморасчетов за январь и за февраль. Соответственно сальдо на конец месяца янвря должно быть равно сальду на начало месяца февраля по контрагенту. Но такого нет! Востанавливал последовательность не помогло. Что делать? Подскажите.
427 2 - 11.05.2004 13:16 | Интересно... В каком месте ТиС есть сальдА....
SnarkHunter 3 - 11.05.2004 13:19 | Ну это он так остатки по регистру на границы периода называет... ИМХО...
vdi 6 - 11.05.2004 13:44 | Конечно, релиз желательно обновить. Однако, прежде убедитесь в том, что за январь и февраль отчеты вы формируете либо по одному и тому же договору, либо по всем сразу.
Gavrila 7 - 11.05.2004 13:46 | +(6) либо тестирование базы с полным пересчетом итогов (на копии желательно) проведи: тоже иногда помогает :)
SnarkHunter 8 - 11.05.2004 13:59 | Млин... Это известная ошибка 18 релиза при работе с ОУ - неверный остаток на начало периода при запросе по регистру...


Новый СФ в ТиС? | База знаний | mista.ru

Новый СФ в ТиС?

vdi 07.05.2004 12:57 | Подскажите, почему в последних релизах ТиС отсутствует новый от 16 февраля СФ. Или я ослеп?
Valery 1 - 07.05.2004 13:20 | Новая СФ в последних релизах реализована внешней компонентой. Если данный файл присутствует в папке PrintForms, то при нажатии "Печать", появляется меню где будет присутствовать строка "СФ2004". В протиыном случае, необходимо найти этот файл и поместить в вышеуказанную папку.
vdi 2 - 07.05.2004 14:12 | Внешние печатные формы типа sf2004.ert(бухгалтерский вариант) в ТиС, в каталоге PrintForms, отсутствует. Где же их еще поискать?
SnarkHunter 3 - 07.05.2004 14:18 | "Внешней компонентой" - несколько преувеличено...


Поступление ТМЦ (импорт) | База знаний | mista.ru

Поступление ТМЦ (импорт)

zaa 07.05.2004 09:42 | есть у кого-н такая печатная форма в ТиС ? или то, что ее нет это принципиально???
SnarkHunter 2 - 07.05.2004 15:33 | Зачем документу поступления чего-либо печатная форма? Поставщик ее тебе должен предоставить...
ander139 3 - 07.05.2004 15:37 | (2) А если у всех поставщиков формы разные? Запаришься потом в поступлениях разираться
SnarkHunter 5 - 07.05.2004 15:40 | (3)И что? Ты хочешь заменить оригинал документа непонятно чем, но единообразным?
BorisG 6 - 07.05.2004 15:41 | (3) Нет, ты не прав. Первичный документ он и есть первичный. Разный... или одинаковый... все равно... Менять на свой его нельзя. Поимеют за подлог документов.
zaa 10 - 07.05.2004 15:55 | накладная от поставщика - конечно есть. Её в бухгалтерию. А надо документ кладовщику То есть: документ Поступление ТМЦ (купля-продажа) имеет печатную форму ПриходныйОрдер. На основании его кладовщик принимает товар на склад, а при Поступление ТМЦ (импорт) нифига! а должен быть такой же документ, причем со сквозной нумерацией
427 12 - 07.05.2004 16:45 | Мдя.... Дятлов становится все больше.... (10) Обычно сначала товар принимает кладовщик.... А потом вместе с ПрихДоком передает в бухию бумаги - если была недостача... Бухия вводит док в систему .... и печатает копию прих дока (в произвольной форме - для внутр учета) причем именно в произвольной форме.... которую кладовщик подшивает к своему отчету ... На этом доке желательно иметь отметку буха о том, когда приход введен в систему (просто дата, подпись)....
kvm 13 - 08.05.2004 00:15 | (12) И иногда сдает документы через... э-э... сколько-то. Вот и берут они их вначале в бухгалтерию. (10) Про сквозную нумерацию. Есть такая штука, Нумератор называется. Или делай как в Бухгалтерии кассовую книгу.


Помогите разобраться с формированием отчета по наличию остатков на складе | База знаний | mista.ru

Помогите разобраться с формированием отчета по наличию остатков на складе

Danila 03.05.2004 19:46 | Конфигурация Торговля и склад 9.2 Цель: Построить отчет о наличии (шт.) товаров на складе. С чего начать? К каким регистрам обращаться? Прошу сильно не критиковать. Я начинающий. Заранее благодарю!!!
Композитор 1 - 03.05.2004 19:56 | Начните с просмотра существующих отчетов. Многое из того, что Вы задумали написать, уже есть в типовых конфигурациях.


1Cv7.md без 1Cv7.DD | База знаний | mista.ru

1Cv7.md без 1Cv7.DD

jetcom 07.11.2004 00:33 | Возможно ли запустить новую конфигурацию, не имея 1Cv7.DD ? Есть только 1Cv7.md
SergoOd 1 - 07.11.2004 00:43 | Запустить конфигуратор, сделать незначительные изменения (по сути спровоцировать модифицированность) и записать. DD будет построен автоматически. Это самый "печной" способ, но сработает 100%.
Fеникс 7 - 07.11.2004 01:18 | 1) Создать пустую конф-ю 2) Загрузить в неё изменённую (нужный MD) 3) Enjoy
Дмитрий 9 - 07.11.2004 01:50 | быстрее всего в название задачи добавить и удалить пробел


Кнопки настройка и обновить для внешнего отчёта | База знаний | mista.ru

Кнопки настройка и обновить для внешнего отчёта

sk251 08.10.2004 11:07 | Конфигурация Торговля и Склад 7.7 типовая. Сохранил отчёт Анализ Продаж как внешний, нужно было внести небольшие изменения. Но если нажимаешь кнопки обновить или настройка, то открывается внутренний отчёт конфигурации. Как заставить его обращаться к внешнему файлу? Думал причина в этом Расшифровка.Установить("Отчет", "АнализПродаж"); но прописать путь к внешнему файлу не удалось. Подскажите?
Хряк 1 - 08.10.2004 12:07 | 1. Переименуй отчет, ех: АнализПродажВн 2. В модуле отчета: Расшифровка.Установить("Отчет", КаталогИБ()+"ExtForms\АнализПродажВн.ert");


ЗиК 246 - лицевой счёт Т-54 | База знаний | mista.ru

ЗиК 246 - лицевой счёт Т-54

DElo 14.05.2004 13:48 | Фирма "сворачивает архив". Госархив требует лицевые счета по сотрудникам. В ЗиК реализована типовая форма Т-54а, которая не имеет очень многих данных (а конкретно - там нет информации о начислениях). В результате лицевые счета Т-54 сделаны вручную на купленых бланках. Вопрос: почему это не реализовано, если это - обязательные требования при архивировании?
bazvan 2 - 14.05.2004 14:19 | Все очень просто Постановление Госкомстата РФ от 5 января 2004 г. N 1 "Об утверждении унифицированных форм первичной учетной документации по учету труда и его оплаты" Форма N Т-54а применяется при автоматизированной обработке учетных данных средствами вычислительной техники (свт) с использованием специальных программ и содержит условно-постоянные реквизиты, необходимые для расчета заработной платы. Экземпляр распечатки расчетного листка, содержащий данные о составных частях заработной платы, размерах и основаниях произведенных удержаний, об общей денежной сумме, подлежащей выплате, вкладывается (вклеивается) ежемесячно в лицевой счет работника на бумажном носителе. На оборотной стороне формы или вкладном листе дается расшифровка кодов (по системе кодирования, принятой в организации) различных видов выплат и удержаний.
DElo 8 - 14.05.2004 14:38 | (6) Погоди ты!!! нормативный документ от 1 января 2004года, а архив он сдаёт за прошлые периоды. Вобщем, я сама уже этот документ прочитала. Но клиент всегда прав, и любой каприз - за его деньги
bazvan 10 - 14.05.2004 14:42 | (8) Там есть и более старый и написано ТО ЖЕ самое А вот клиент всегда прав и каприз за его деньги:))) Почитай ветку алли про Дятлов


ЗиК. Как начислять премию от оклада? | База знаний | mista.ru

ЗиК. Как начислять премию от оклада?

yaret 23.05.2004 09:57 | ЗиК типовая. Надо начислять ежемесячную премию в процентах от полного оклада. В программе начисляется от оплаты по начисленному окладу, т.е. если сотрудник был в отпуске или на больничном, то ему ЗиК начисляет от оставшейся части оклада... Подскажите, пожалуйста, как можно это реализовать.
vdi 1 - 23.05.2004 10:10 | Я не знаю чем отличается с точки зрения закона ежемесячная премия от разовой. Если ничем, то воспользуйтесь документом "Ввод расчета списку сотрудников", выбрав "Премия разовая".
yaret 2 - 23.05.2004 12:46 | Разница в автоматизации процесса, где разовая премия вводится суммой, а месячная процентом и потом при начислении отпуска месячная премия включается в сумму месяца, а разовая выносится отдельной суммой за все месяцы.
BorisG 4 - 24.05.2004 10:27 | (1) Да... "Я не знаю чем отличается с точки зрения закона ежемесячная премия от разовой" Так а совет вводить разовую премию вместо регулярной тогда зачем давать? Или это не сор? Разовая премия тем и отличается от премии регулярной (квартальной, месячной и т.д.), что, как правило не предусмотрена системой оплаты труда, и соответственно не входит в расчет среднего. См. пост. правительства N213 от 11 апреля 2003 года.
BorisG 5 - 24.05.2004 10:34 | (0) Ты хоть полумал, о чем спросил? Какое есть основание для такой премии? Получается, сотр не работал, ПОЛУЧАЛ ПО СРЕДНЕМУ, а премию, да еще входящую в расчет среднего ему подавай? ;-)) PS: В каком же еще регионе местные "законодатели" такое для себя придумали? Ибо нормальный собственник до такого не додумается точно.
BorisG 7 - 24.05.2004 12:51 | (6) Если предприятие не бюджетное, то лучше почитай, что написано про систему оплаты труда. Так обычно не платят. ЗиК тут права. Если бюджетное, то цитату из нормативного документа в студию.
yaret 8 - 24.05.2004 14:51 | Предприятие не бюджетное. Такими я не занимаюсь, т.к. для этого есть такие как вы - франчи. Но муниципальное, поэтому прибыль стараются распределять так, чтобы на следующий год не оставалось запасов денежных средств. То, что ЗиК здесь абсолютно права - я ни сколько не сомневаюсь, уже много раз в этом убедился. В данном случае такой подход не противоречит закону, но отходит от рекомендуемых способов расчета премии - здесь премия назначается индивидульно каждому сотруднику по усмотрению директора и начислятся от оклада сотрудника. К сожалению, я пока мало изучил конфигурацию ЗиК, потому и возник такой вопрос, думал, что профи смогут подсказать, а получается дисскусия, которая мне мало интересна.


Компенсация отпуска | База знаний | mista.ru

Компенсация отпуска

povar 19.05.2004 09:42 | Типовая ЗиК Сотрудник взял копменсацию за неиспользованный отпуск, оформляю документ "Приказ по отпуску" в графе вид выбираю (компенсация).Естественно даты начала и конца отпуска не указываю. И так же естественно документ не проводится (т.к. нет дат). Как выйти из этой ситуации указывать даты начала и конца предпологаемого отпуска или еще как ??
Marinka 1 - 19.05.2004 10:34 | ЗиК 246. Если выбрать вид \"Компенсация отпуска\", то даты начала и конца отпуска и указывать-то негде... просто ставиться количество дней за которые выплачивается компенсация...


Можно ли ЗиК безболезнено обрезать, для уменьшения базы | База знаний | mista.ru

Можно ли ЗиК безболезнено обрезать, для уменьшения базы

egor 08.06.2004 12:59 | Сейчас в базе зарплата с 2001 г. Практически 2001-2002 год не используеться. Можно ли эти года обрезать и вынести например в другую базу, оставить только 2003-2004 г. И как это можно проделать?
BorisG 2 - 08.06.2004 13:07 | Обрезать то можно... но... раз задаешь вопрос, пригласи лучше спеца... ибо это вовсе неадекватная операция.
egor 5 - 08.06.2004 13:20 | Сейчас размер около 3 гиг. Но база комплексная Бухгалтерия, Оперативка, Расчет. Начальник поставил задачу урезать зарплату, типа нефиг тянуться. Вот и интересуюсь. (2) - естественно спеца никто приглашать не будет, зачем же я тогда нужен :-)
BorisG 6 - 08.06.2004 14:01 | (5) Самое тжелое поручил... проще урезать бухию и торговлю... Поищи по форуму... обсуждалось не раз...
Rom 11 - 09.06.2004 10:44 | Есть два подхода к этой проблеме: 1. Писать процедуру сворачивания данных. 2. Перенести остатки в свежую конфигурацию. Взвесь все "за" и "против" и прими решение: что быстрее, дешевле и проще. Если остановишься на втором варианте, советую отказаться от комплексной конфигурации.
427 15 - 10.06.2004 20:26 | В типовой бухии есть стандартная обработка свертки базы. Wrap.ert в каталоге ExtForms. Свртка регистров будет поиндивидуельнее. Обычно пишется вручную. Поищи на хиппо - там вроде были. ЗиК просто так не обрежешь. Там есть доки, могущие влиять на начисление ЗП несколько лет... так что аккуратнее... Кстати, документы бух учета хранятся по моему 5 лет, а по расчету ЗП - 75 лет... Так раньше было, сейчас не в курсе.... Не слежу.


Вопрос по расчету бригадных нарядов | База знаний | mista.ru

Вопрос по расчету бригадных нарядов

Darlok 12.08.2004 12:07 | В документации к типовой конфигурации 2.3, (у меня стоит 2.46), стр.134, написано что : "Установленный флажек 'Расчитывать только приработок', приведет к расчету наряда... когда на бригаду распеделяется только часть суммы наряда, оставшаяся после вычета заработка по тарифу всех работающих в бигаде" На деле же никак не получается заставить считать программу именно таким способом. Программа распределяет всю сумму наряда, и при расчете зарплаты, ещё прибавляется оплата по тарифу. Кто знает как правильно реализовать указанную возможность. Пожалуста поделитесь опытом. С уважением Бакиров Михаил.
Marinka 4 - 13.08.2004 09:53 | Вообщем это... ща опишу что она делает :)
Marinka 5 - 13.08.2004 10:04 | 2 сотрудника: 1: тариф 50, 2: тариф - 40. Вводим бригадный наряд на 10,000 по этим сотрудникам, ставим "галки" "Учитывать тариф" и "Расчитывать только приработок", отработано часов, например 1сотр: 10, 2 сотр: 20. Считаем: 1сотр: тариф*часы = 500, 2сотр: тариф на часы = 800. К распределению: 10,000-(500+800)=8700. Потом сумму к распределению делим на сумму тарифов и умножаем на тариф сотрудника (для 1сотр: (8700/(50+40))*50=4833,33 для 2сотр: (8700/(50+40))*40=3866,66) Итого начислено: Сумма к распределению+по тарифу (для 1сотр: 4833,33+500=5333,33 для 2сотр:3866,66+800=4666,66) Вот :)
Darlok 6 - 13.08.2004 12:48 | Что она должна делать я знаю, но вот почемуто у меня не делает .... операцию: "... Считаем: 1сотр: тариф*часы = 500, 2сотр: тариф на часы = 800. К распределению: 10,000-(500+800)=8700..." не выполнет, а рапределяет всю сумму, к остальным ньансам можно не приближаться, тут все правильно Может способ оплаты не тот, может что ещё не так делаю, но не считеат, вот я и хочу узать как, должно быть правитно?
Darlok 7 - 13.08.2004 12:52 | Часы отработанные тут-же в наряде ставятся ?
Marinka 9 - 13.08.2004 14:09 | (7) Да.. внаряде...
Darlok 11 - 16.08.2004 06:47 | Я ставил галочку \\\\\\\"Учитывать часы\\\\\\\", елси её ставить, то на расчет не влияет галочка \\\\\\\"Расчитывать только приработок\\\\\\\". А для моего расчета \\\\\\\"Учитывать часы\\\\\\\" обязательно.
Marinka 12 - 16.08.2004 09:59 | (11) Так ты мне на пальцах все объясни... вот как я в (5) а там уже дальше думать будем... может чем и помогу...
Darlok 13 - 16.08.2004 11:50 | (12) Ок. Попробую. Сотрудник 1=Иванов, Тариф=50, КТУ=1, отработанно часов = 10 Сотрудник 2=Петров, Тариф=40, КТУ=1, отработанно часов = 20 У обоих сотрудников система оплаты \"Повременно-премиальная по часовому тарифу\" Сумма наряда = 10,000 Ставим \"галки\": \"Учитывать КТУ\", \"Учитывать тариф\", \"Учитывать отработанные часы\", \"Распределять только приработок\". Итог расчета документа: Иванов = 3846,15 Петров = 6153,85 Делаем начисление заработной платы. Теперь делаем расчет заработной платы за текущий месяц. Открываем расчет и видим: Иванов: Бригадный наряд 3846,15 + Отдельно добавляет оплата по тарифу. Петров таже история
Marinka 14 - 16.08.2004 11:57 | (13) Ну... добавляет строку оплата по тарифу, но сумма там 0. И что? строка мешает?
Marinka 15 - 16.08.2004 11:59 | Ааа... sorry, повременно премиальная... чичаз посмотрим...
Ninon 17 - 16.08.2004 12:24 | Так, потому что у тебя поврем оплата, а ты ЕЩЁ делаешь сделку. Переведи сотра на сдельную оплату.
Marinka 18 - 16.08.2004 12:29 | (16) Угу... поставь просто прямая сдельная... и будет 0 :)
Darlok 19 - 16.08.2004 12:37 | Да так работает только, как теперь сделать чтобы считалась Районная и Северная надбавка, она их считает только сумма ноль получется
Marinka 21 - 16.08.2004 12:44 | Справочники->Расчет з/пл-> Виды расчетов, на закладке "начислениея" ищешь Сев. надбавка (если её нет - используй кнопку "помощник"->описать предопределенный вид расчета) и корректируешь её базу. Тоже самое с РК. P.S. Я скоро это уже с закрытыми глазами буду печатать....
Darlok 23 - 17.08.2004 06:33 | Возникли ещё некоторые сложности, например существуют виды оплаты которые, начисляются только на оплату по тарифу... Нельзя ли сделать так чтобы бригадный наряд выдавал Сумму к начислению, без оплаты по тарифу, т.е. в нашем примере (12): Иванов Вместо 3846.15 былобы 3816.15 - 10*50 (Оплата по тарифу) = 3346.15 (Приработок) Пертов Вместо 6153.85 былобы 6153.85 - 20*40 (Оплата по тарифу) = 5353.85 (Приработок)
Darlok 24 - 17.08.2004 07:46 | К примеру надбавка "Бригадиркие", вычисляется процентом от суммы, отлаты по тарифу, а сам, бригадир учавствует в бригадном наряде.
Андрей Оскольский 25 - 17.08.2004 08:47 | Я корректировал довольно сильно Бригадный наряд, чтобы для повременщиков расчитывать в нем оплату только приработка + можно было бы расчитывать там окладников (для них вычислял псевдо-тариф (оклад/календарные часы по графику))
Андрей Оскольский 26 - 17.08.2004 08:52 | А первоначальный вариант у меня вообще дикий был. Я завел в базе копию бригадного наряда и поиздевался над ним (по просьбе расчетчиков). Ввел туда помимо часов еще и период действия расчета в табличную часть. Типа: Иванов - с 3.08 по 9.08 - 40 часов. А потом еще проводил табель по Иванову. И вид расчета НовыйБригадныйНаряд вытеснял расчет по табелю с 3 по 9 августа. В результате люди получали и тариф и сдельную оплату. Но пришлось много чего править в конфигурации. ИМХО, вариант в (25) предпочтительнее.
Darlok 27 - 17.08.2004 10:26 | Да иправить конфигурацию, конечно не сложно, но у меня самое главное именно этого и не хотелось делать. Может кто-нибудь знает как решить указанную задачу, без изменения конфигурации?
Marinka 28 - 17.08.2004 10:36 | (27) Если я не ошибаюсь, то нельзя...


Как в общем организован многовалютный учет в 1С | База знаний | mista.ru

Как в общем организован многовалютный учет в 1С

Ivan1C 24.07.2004 10:53 | Будьте добры объясните: необходимо вести учет в нескольких валютах одновременно. Как это сделать? Меня интересует сам принцип, что, каждый документ должен пересчитывать сумму в выбранную валюту сам? И вообще где можно найти все принципы ведения валютного учета в 1С?
BorisG 1 - 24.07.2004 11:06 | Принципы ведения валютного учета есть на ИТС.
NS 11 - 24.07.2004 16:53 | (9) В 7.7 регистры недостаточно мощны для многовалютного учета? Для организации многовалютного учета в бухии... Достаточно прикрутить к ней один регистр....
BorisG 12 - 24.07.2004 16:59 | (11) Я разве утверждал обратное? Так именно прикрутить ;-)) самому... либо ждать... может 1С выпустит... Все зависит от полноты ... ... ;-))
BorisG 15 - 24.07.2004 17:16 | (13) Еще раз... для особо одаренных... ценообразование, пусть и в нескольких валютах и валютный УЧЕТ вещи СУЩЕСТВЕННО разные.
BorisG 19 - 24.07.2004 17:42 | (17) Мда... Валютный учет кроме цен (приходных, отпускных) еще содержит и особенности договоров, в которых отражены условия оплаты, порядок смены собственника, курсы оплаты, сроки оплаты, сроки оказания услуги и пр. и отсюда возникающие суммовые разницы, а также правила их отражения в бухучете. См. например, ПБУ 5/01 (на память, уточнять влом)
BorisG 22 - 24.07.2004 17:58 | (20) "Думал это для многовалютного учета товаров" Многовалютный учет в том числе подразумевает и многовалютный учет товаров. ;-)) Только вот он должен быть "правильный"... ;-)) Кстати, ПБУ 5/01 (не ошибся) так и называется "УЧЕТ МАТЕРИАЛЬНО - ПРОИЗВОДСТВЕННЫХ ЗАПАСОВ"


Обновление ЗиК | База знаний | mista.ru

Обновление ЗиК

Diletant 25.05.2004 02:03 | У нас установлена ЗиК 7.70.035 в которой расчет з/пл идет по концу года(т.е. когда определен финансовый результат) Формы отчетности и некоторые документы(в частности б/листы) у нас устаревшие т.к. своевременным обновлением никто не занимался... Что можно сделать на сегодняшний день, чтобы и обновить и оставить те наработки что реализованы в нашей конфигурации?
afk 1 - 25.05.2004 02:05 | перенести данные в конф. 2.46, затем внести изменения в алгоритмы расчета зп согласно вашим требованиям
Diletant 2 - 25.05.2004 02:15 | А при помощи чего перенести данные - ведь структуры справочников очень расходятся? Так же и документы очень отличаются. Получается что и внутренние наши отчеты все переписывать придется?
afk 3 - 25.05.2004 02:20 | Правила перехода описаны в файле conv23.txt. Конечно переписывать придется. . Либо, как вариант, забить на ЗиК 2 ред. и дорабатывать самим ред. 1 до состояния, соотв. законодательству
BorisG 6 - 25.05.2004 08:13 | (4) Ну там, наверное, не только больничные неверные... Налоги скорее тоже... На самом деле перенос не самая страшная штука. PS: Отрасль какая?
Diletant 7 - 25.05.2004 10:20 | Отрасль добывающая. Пока для меня страшен сам перенос, вернее очень трудоемок.
BorisG 8 - 25.05.2004 10:55 | (7) И сколько видов расчета, которые не укладываются в типовые ред 2 ЗиК? Их не должно быть много.
Diletant 10 - 25.05.2004 11:05 | +9 Конечно можно добавить в 246 документы, виды расчетов.Но как быть с приказами о приеме и перемещениях.Структуры справочников в 246 и в нашей совершенно разные. Изменены идентификаторы,хоть суть их осталась та же.
Diletant 13 - 25.05.2004 11:22 | +12 Чтобы было понятней: начале и конце года работают постоянные работники.Потом идет сезонный набор.В том числе и большое количество иностранцев.К концу года(октябрь,ноябрь,декабрь) их увольняют. Затем все по новой...
BorisG 14 - 25.05.2004 12:09 | Фигня это. Тогда не ломай голову и не пудри мозги. Переноси справочники сотров, вместе с приказами о приеме, обработок полно на Ниппо... или при помощи конфы Конвертация данных, чем лучше владеешь. А табели по новой ручками с начала года, их НЕ НАДО переносить... и все пересчитать. Только вот последнее, включая ввод табелей, надо заставить делать РАСЧЕТЧИКА. И ... о сколько нам открытий чудных ... (с) Пушкин
BorisG 16 - 25.05.2004 12:49 | Еще раз. Поскольку "грехов" в 035 из-за изменений законодательства с той поры больше, чем достаточно... все-таки лучше пересчитать... И заставить это делать расчетчика, каких бы это воплей ни стоило. Много "открытий" выплывет. Проходиди не один раз...


ЗиК, бюджет | База знаний | mista.ru

ЗиК, бюджет

PHelen 15.06.2004 09:48 | Сотра нужно принять с разными источниками фин-я, фирма 1С написала, что для этого нужно у них купить 1С,Аналит Источники Фин-я и поставить вместо ЗиК, но не хочется с этим связываться.До сих пор принимали по внебюджету как внутр.совм.,юрист возмутился, сказал, что это одна ставка,а как уж она делится по ист.фин. - ваши проблемы. вроде есть док.Бух.и налоговый учет, но у нас ещё куча разных доплат и каждая тоже м.б.неизвестно откуда. Как быть?
BorisG 1 - 15.06.2004 10:02 | А нука попоробнее. Кто в 1С тебе такое написал? ИФ есть в ЗиК.
Marinka 2 - 15.06.2004 10:13 | Согласна с BorisG. В бюджетной версии 1С:ЗиК есть разделение по источникам финансирования...
PHelen 8 - 15.06.2004 11:04 | Ну а работа с док.Бух.и налоговый учет - это стандартный ход и он везде будет отслежен ? Я имею ввиду своды и отчеты.
BorisG 9 - 15.06.2004 11:14 | (5) Не угадала. Я читал ту ветку. Это точно ответ НЕ 1С. (8) На разработчиков не надо выходить, в ЗиК это решается просто корректным вводом шаблонов проводок для разных ИФ, и все. Лучше франча для консультаций найди, специализирующегося на бюджете. Ну а насчет сводов и отчетов... задавай конкретные вопросы. А вот хотлайн сейчас бюджета боится ;-) сразу разработчикам, посему и такой ответ, и моя "заслуга" в этом есть ;-)))... скромно так ;-)
PHelen 10 - 15.06.2004 11:15 | Кроме того, есть мри обработки - тарификация, штатное расписание с фамилиями и ист.фин., я в них беру ИФ как реквизит у сотрудника или из док.нач.и уд., а что тогда будет основным ИФ ? если я в док.Бух.и налоговый учет введу две проводки ?
PHelen 11 - 15.06.2004 11:20 | Все шаблоны настроены и с доплатами проблем нет (хотя у нас есть еще лечебные ставки, ну это отдельная тема), но ведь нужно чтобы оклад был поделен. Получается, что в ПриказеОПриеме проводку вообще не нужно указывать ?
BorisG 12 - 15.06.2004 11:37 | (11) Ну... раз уж с педагогами и тарификацией разобралась... такая мелочь, как ИФ осталась ;-) Во-первых, для педагога это не совместительство (это как бы ответ на вопрос того форума). А во-вторых, указывать, или нет, зависит от того, есть ли основной источник. Если есть, можешь и указывать, а к конкретному начислению из другого ИФ - свой ШП. Все начисления у педагогов нелязя в приказе о приеме отразить по определению, ибо у них всегда есть такие штуки, "выбивающиеся" из общих ИФ, как, например, компенсация за литературу, у нее свой ФКР...
PHelen 13 - 15.06.2004 11:45 | Да, по каждому начислению указываем свой ШП, но что-то так я и не поняла с док.Бух.и налоговый учет, это стандартный ход для разделения оклада по ИФ(т.е. это будет учтено в своде по зрп и в своде проводок) или есть другая возможность ?
PHelen 16 - 16.06.2004 05:33 | Извините за назойливость, но ответа на свой вопрос я так и не получила "как стандартно принять сотр. на ставку и поделить эту ставку по ИФ, если 0,5ставки-бюджет, а ещё 0,5ставки-внебюджет ?" и эти 0,5 ставки я не могу дать ему ни доплатой, ни внутр.совм.Это д.б. именно оклад.Все ШП настроены.
BorisG 17 - 16.06.2004 11:00 | (16) Да вроде ответили... в том числе и на Т1С. ВО-первых, не надо путать ТК и бюджетный кодекс, ИФ не имеют отношения к ТК. Далее все зависит от структуры и штатного расписания Вашей конторы. Ну а с ЗиК... Еще раз, ничто не мешает принять сотрудника на 0,5 ставки бюджет и внутренним совместителем на внебюджет, и задать соответствующие ИФ ШП. Это самое простое, что можно сделать без проблем и изменения ЗиК.
PHelen 18 - 16.06.2004 11:27 | Это не вариант, хотя до сих пор делали именно так.Проблема возникла из-за того, что по закону преподаватель имеет право только на одно совм.,а мы его "съели" вневюджетной ставкой и хотя сотр может работать на 1,5 ставки, мы можем принять его таким методом только на ставку(или даже меньше) если эта ставка делится по ИФ. Док. Бух.учет начислений и уд. работает нормально и для оклада, но он работает месяц, а каждый месяц его вколачивать на 500 препод. еще то удовольствие, или может просто убрать из этого дока период ? Вот такая проблема.
BorisG 19 - 16.06.2004 11:59 | (18) Да нет там проблем, просто разберитесь с терминами... и особенностями учета. Во-первых, почитайте закон... что относится к совместительству у педагогов, а что не относится. ;-) Например, приложение к Положению об условиях работы по совместительству, утв. пост. Госкомтруда от 09.03.89 N81/604-К-3/6-84. И еще раз, не следует путать особенности учета в 1С, так чтобы не трогать типовую конфу, и ТК. То, что в базе проще оформить "внутренним совместителем", еше не факт, что это по Вашему выражению "съедает" ставку.
PHelen 20 - 16.06.2004 12:13 | Дело в том, что отдел кадров работает тоже в 1С, и плановый ведет штатное расписание и приказы по персоналу печатаются оттуда же. И если приняли сотра по внутр совм, то этот приказ подписывают все, в том числе и юрист, поэтому все д.б. в соответствии с ТК. А сотру все равно откуда его финансируют, но в этом случае он должен написать два трудовых договора, должно выйти два приказа по институту - а это нарушение, потому что его принимают на одну ставку.
NiGMa 21 - 16.06.2004 12:14 | Народу-то там много? На мой вкус, гораздо проще применить Камин:Расчет заработной платы 2.0. Все настраивается, и по источникам финансирования в том числе. Мы, правда, больше чем на 400 человек не пробовали - но по отзывам и не 1500 нормально работает.
BorisG 22 - 16.06.2004 12:45 | (21) Да нет, не проще. В их случае проще пригласить фирму, специализирующиюся на бюджете, чтобы они разрулили ситуацию с упрямыми кадровиками, и все. (20) Еще раз. Для педагога такое оформление НЕ ЯВЛЯЕТСЯ совместительством. Поэтому и проблем на самом деле с точки зрения закона нет. Если же Ваших кадровиков такое "оформление" в ЗиК, не реально, на предприятии, а именно отражение его в ЗиК не устраивает - дорабатывайте. Какие проблемы? Любой каприз за Ваши деньги (с) Только сильно сомневаюсь, что это реально надо делать только из-за "каприза".
PHelen 23 - 16.06.2004 12:47 | Народу у нас около 2000, мы - мед.университет и кроме ЗиК есть ещё и Бухгалтерия.Все это SQL,пользователей - 30,данные загружаем и выгружаем.Ну и конечно есть и наши внешние обработки и исправления в конфе и кое-что пришлось добавить. В общем все завязано и не хотелось бы все начать заново.
BorisG 24 - 16.06.2004 12:59 | (23) На 2000 сотров 30 пользователей... Ну ну... Сколько непосредственно с ЗиК работают? Потому скорее и проблемы ;-)))
PHelen 25 - 16.06.2004 13:06 | С Зик непосредственно 5 инспек.по кадрам, 2 программиста,2 плановика, 5 расчетчиков, 3 бухгалтера. Всего - 17, остальные в основном исп. для просмотра.
PHelen 26 - 16.06.2004 13:09 | И кстати, по-моему с педагогами Борис не прав.Не является совм-м пед.работа с почасовой оплатой труда. Это у нас тоже есть,но не об этом речь. Интересует именно оклад по разрядной сетке ЕТС.
BorisG 27 - 16.06.2004 13:10 | (25) Я так и думал ;-)) Сократите половину, в пять раз! уменьшатся проблемы. ;-)
PHelen 28 - 16.06.2004 13:17 | И даже эти имеют по 2-3 ставки (кроме прогр-в).Не забывайте, что мы бюджет.На каждого буха и кадровика есть нормы (кол-во людей,кот. он обслуживает).А вообще-то идея хорошая.
BorisG 29 - 16.06.2004 13:20 | (26) Читать то хотябы внимательно можете? Так и я о том же, не является, и это явно написано в приведенном мной Положении. А вот оклад по разрядной сетке... зависит от утвержденной структуры на предприятии. Но... похоже Вам это все не надо, ибо все втолковано. Честно говоря, не очень понятно, что в результате хочется получить? Еще раз... последний... Если хотите по капризу! Ваших кадровиков (другой серьезной причины нет) два ВР с разными ИФ, еще раз, дорабатываете ЗиК, это несложно, но врядли это стОит делать. Если хотите оставить этот участок типовой как есть, чтобы сократить трудоемкость обновления, вводите через внутреннего совместителя. Какие проблемы?


ЗиК... задолженность | База знаний | mista.ru

ЗиК... задолженность

VNL 17.06.2004 10:17 | подскажите, При вводе начальных данных в ЗиК необходимо ввести задолженность предприятия перед сотрудниками. Каким документом это делается - \"Накопленная задолженность\" или \"Ввод начального сальдо\"? Каково их отличие в данном случае?
ally 2 - 17.06.2004 10:30 | 1С:Предприятие 7.7 Конфигурация Зарплата и Кадры. Страница 97.
Aнтон 7 - 17.06.2004 14:53 | Начните работать без начального сальдо. В случае, если оно понадобится в отчётах, его можно будет самостоятельно дописать в нужную колонку.
VNL 8 - 17.06.2004 15:16 | (7) а как тогда выплачивать задолженность?
Marinka 9 - 17.06.2004 15:42 | (8) Ну как-то ведь вы раньше работали без программы... так же и задолженность выплачивайте... а программку лучше с нуля начните... без задолженности :)


проблемы с сетевой ZIK 7.7 | База знаний | mista.ru

проблемы с сетевой ZIK 7.7

luzer 09.06.2004 15:44 | При семене релиза на 21 ZIK 7.7, перестали заходить в базу сетевые рабочие станции, на сервере захожу без проблем (Win 2000 Serwer)использую CitricsMF. Подможите чем можите!
SSF 2 - 09.06.2004 15:50 | Поменялся драйвер защиты HASP.Снеси старый драйвер, перезагрузи ,поставь драйвер повторно.


ЗиК: отражение задолженности сотрудника перед предприятием | База знаний | mista.ru

ЗиК: отражение задолженности сотрудника перед предприятием

?&? 11.06.2004 11:39 | выдано больше, чем начислено. Где и как отражается разница?
Marinka 1 - 11.06.2004 15:07 | После смены периода и ввожа начисления з/пл за след. месяц появиться строка "Текущее начальное сальдо". если эту строку расчитать, то там как раз и будет разница м/у начисленным и выплаченым за прошлый месяц (в данном (0) случае - отруцательная). Еще в расчетном листке отразиться долг за работником.


ЗиК Прием сотрудников по срочному договору без изменения штатного расп-я | База знаний | mista.ru

ЗиК Прием сотрудников по срочному договору без изменения штатного расп-я

OLGERT 09.06.2004 13:42 | Проблема в следующем: На время декретного отпуска одного сотрудника нужно принять другого по срочному трудовому договору. Приказ о приеме не проводится (не хватает ставок в штатном расписании). Если принимать с нулевой ставкой - зарплата не начисляется. Что делать?
Marinka 1 - 09.06.2004 15:13 | Отключить контроль штатного расписания


Проводки в Зарплате 7.7 | База знаний | mista.ru

Проводки в Зарплате 7.7

AlexL 04.06.2004 14:12 | Кто-нибудь может внятно подрассказать, или где взять информацию как лепить проводки в 1С Зарплате и Кадрах 7.7 (релиз 245)?????
Marinka 2 - 04.06.2004 17:06 | Описание есть в книгах: Харитонов С.А. \"Настольная книга бухгалтера\" 1С:Предприятие \"Описание типовой конфигурации Зарплата+Кадры\"
vdi 3 - 05.06.2004 08:06 | Еще на ИТС раздел "Формирование проводок по заработной плате в конфигурации Зарплата+Кадры ред. 2.х и обмен данными с типовыми "бухгалтерскими" конфигурациями".
AlexL 4 - 07.06.2004 11:59 | Бухия редакции 4.2, план счетов не от поставки 1С, а свой хозрасчетный
Marinka 5 - 07.06.2004 14:15 | (4) И что?... Пиши правила по выгрузке, выгружай план счетов в ЗиК, настраивай проводки (литературу тебе сказали) и все...
Emvika 6 - 07.06.2004 23:29 | Ну если уж не по книгам, (мало кто их читает), то 1 - выгрузить план счетов из Бухии (Сервис-Обмен данными-Выгрузка данных в ЗиК), отмечаешь счета и субконто, участвующие в разноске начислений/удержаний, 2 - загрузить план счетов в ЗиК (Сервис-Обмен данными-Загрузка данных), ставишь в Сервис-Настройки Проводку по умолчанию, а в тех доках, где не такие проводки, как по умолчанию, рисуешь такие, какие надо. Соответсвенно и для видов расчетов рисуешь свои проводки (особенно важно для ЕСН сделать по образцу Демки). И пользуйтесь на здоровье - можно проводки грузить обратно в бухию.


ЗиК и этот районный коэффициент | База знаний | mista.ru

ЗиК и этот районный коэффициент

Антон 07.06.2004 20:25 | Тупость не порок, а болезнь. Установил в настройках Сервис>Настройки Районный коэффициент=1,15, и местность приравнял к северному региону. РК считается, но есть люди которые работают от нашего предприятия в других районах, где нет районного коэффициетна, а он считается. В справочнике>работники замаялся искать как можно его отменить. Искал в личной карте, СЗВ-К, и т.п. документах не нашел. ПОМОГИТЕ!!!!!!!!!!
Антон 2 - 07.06.2004 20:49 | У всех работников считается районный коэффициент, а у двух не надо как сделать. P/S Вроде нет ветвлений
Marinka 4 - 08.06.2004 09:55 | (0) Заведи новое подразделение (поставь в нем галочку "Обособленное" и укажи для этого подразделения РК = 0, или какой там тебе надо) и определи этих двух сотрудников в это подразделение и будет тебу счастье.


Проблема с уволенным сотрудником | База знаний | mista.ru

Проблема с уволенным сотрудником

Vitek 04.06.2004 15:43 | Проблема в Зарплате и Кадры 2.45. Сотрудник взял ссуду в октябре прошлого года. Должен был погасить с ноября по август. 1 июня он уволился и должен вернуть 14000 т.. Как взыскать с него эту сумму из зарплаты.
Vitek 2 - 04.06.2004 16:00 | Спасибо. Но нужен совет по программе. Каким документом или что где исправить
Oksa 3 - 04.06.2004 16:20 | и кто тебе мешает через помощник сделать новое удержание, а потом документ Ввод расчетов по сотруднику?
Marinka 4 - 04.06.2004 17:08 | (0) А из какой зарплаты, если он уволился?
DElo 5 - 04.06.2004 17:11 | (4) А разве нельзя в периоде последнего начисления ему з/пл. провести это удержание? Полагаю, что можно, тогда будет долг за сотр-ком
Oksa 6 - 04.06.2004 17:28 | ну ему же должны начислить последнюю зп с компенсацией или без, расчитаться, вот пусть сначала удержания сделают, а оставшую сумму выдадут
Vitek 7 - 04.06.2004 17:53 | Списать удержанием не вопрос. Просто должна закрытся ссуда и потом в Типовую конфигурацию эта сумма должна попасть как погашение ссуды.
Vitek 8 - 04.06.2004 17:58 | И ещё нам в одной конторе посоветовали просто взять и поставить в журнале расчёта зарплаты вместо суммы, которую он должен отдать за май, весь его долг. Вроде такой способ прокатывает, но беспокоет другое - не повлияет ли это на что-то ещё.
427 9 - 04.06.2004 18:03 | Повлияет... При сдаче в ПФР и ГНИ... Пусть думают бухи... Я то решение знаю...


Начало работы с ЗиК 2.36 | База знаний | mista.ru

Начало работы с ЗиК 2.36

Vik 07.06.2004 16:48 | С начала года уволенному человеку необходимо выплатить лишние удержания по НДФЛ в течение января, февраля. Они, соответственно должны уменьшить НДФЛ предприятия. Как это сделать? Заранее благодарен.
BorisG 2 - 07.06.2004 18:18 | Читай ст. 231 п.1 НК. Только по письменному заявлению сотра. А в ЗиК документ "Возврат НДФЛ"
BorisG 4 - 07.06.2004 18:22 | +2 Если сотру уже выдали на руки справку 2-НДФЛ, слудует ему выдать новую и письменно предупредить, что по итогам за год в МНС будет подана справка с учетом возврата НДФЛ. А лучше потребовать вернуть старую справку.


Как указать счет учета ЕСН в части ФСС? | База знаний | mista.ru

Как указать счет учета ЕСН в части ФСС?

Freelancer 07.06.2004 15:13 | Как указать счет учета ЕСН в части ФСС?
Marinka 1 - 07.06.2004 15:20 | Справочники -> Расчет з/пл -> Виды расчетов -> ЕСН и страховые взносы -> ФСС -> Бухгалтерский учет -> указываешь проводку.


как указать нерезидентов | База знаний | mista.ru

как указать нерезидентов

Freelancer 07.06.2004 13:35 | Конфигурация \"ЗиК\" 7.70.245 Где в программе указывается для сотрудника является ли он резедентом или нет?
Asmody 1 - 07.06.2004 14:07 | страну указать не Россию
Asmody 3 - 07.06.2004 14:32 | (2) "Страна ПМЖ" не катит?
Marinka 10 - 07.06.2004 14:46 | (7) Документики перепроведи все...


Зи К | База знаний | mista.ru

Зи К

meet
25.05.2004 09:43 		Штатный сотрудник уволен.В справочнике сотрудников стоит "Сотр уволен 15.04.2004". Теперь он выполняет работы по договору. Кадровик желает чтобы в справочнике сотрудников было как у всех договорников "Физическое лицо". Как это сделать?
kadr
1 - 25.05.2004 09:48 		Никак. Заведи новое физическое лицо с другим кодом
Nata-
2 - 25.05.2004 09:49 		В ЗиК есть Документы-Ввод начислений-Договор гражданско-правового характера.
Заполняем на этого сотрудника.
meet
3 - 25.05.2004 10:23 		2 Договор гр-прав хар-ра будет начисляться на уволенного сотра?
ss20
5 - 25.05.2004 14:44 		В журнале зарплаты будет оплата по договору подряда, НДФЛ, выплата зряплаты и т. д.
Marinka
6 - 25.05.2004 14:48 		Это понятно... но вопрос-то был не в том как начислить, а в том, что \"Кадровик желает чтобы в справочнике сотрудников было как у всех договорников \"Физическое лицо\". Как это сделать?\"
Nata-
7 - 25.05.2004 16:57 		Значит необходимо заново набирать этого сотрудника под другим номером, у нас так делают
meet
8 - 26.05.2004 03:45 		7 Вообще то это не правильно заводить еще один табельный номер.Он должен быть пожизненно одним для данного сотрудника на данном предприятии. Не возникнут ли проблемы с подачей данных в ПФР в случае двух табельных?
vdi
9 - 26.05.2004 07:58 		Договор подряда можно заключить с любым лицом. И, если это лицо отсутствует приказе о приеме на работу, то договор подряда присвоит ему статус физического лица.
Marinka
10 - 26.05.2004 11:11 		(9) Да ты чё... правда што ли?...
Чё же у меня-то тогда так не делает?... Есть сотрудник, январь, февраль он отработал и в конце февраля - уволился, в справочнике сотрудников статус - уволен с 20.02.04. В марте ввожу на него договор подряда. Смотрю статус в справочнике - пишет, что сотрудник уволен. Ниче никто никому не присвоил...
Marinka
11 - 26.05.2004 11:15 		(8) Полностью согласна.. у нас ПФР как только видит 2 карточки на одного сотрудника сразу же разворачивают все переделывать. Хотя... если бухгалтер хочет... и есть рядом программист, который ещё и думает и знает про эти "подводные камни", а не делает только то что хочет бухгалтер, то можно воспользоваться и так, как написано в (7), только перед сдачей сведений надо чтобы бухгалтер не забыл позвать программиста, который все "подправит".
vdi
12 - 27.05.2004 06:54 		(10) Правда, если договор подряда оформить на копию уволенного лица.

А вот насчет табельных номеров хотелось бы услышать мнение специалиста(ов) в области законодательства РФ. Я по своему недоразумению предполагаю следующее.Может быть и не прав я! Табельный номер должен сохраняться за уволенными сотрудниками, которые вновь принимаются в штат или, как внешние совместители. Эти приказы обусловлены ТК РФ.

Договор подряда (это уже ГК РФ) с уволенным сотрудником не делает его сотрудником в смысле ТК РФ. Более того, уважаемые колеги, обратите внимание на то, что договор подряда не имеет реквизита "табельный номер".
Майк
13 - 27.05.2004 08:27 		В ЗиК методологически предусмотрена возможность работы одно ФЛ на одном предприятии по нескольким основаниям, например, штатным и договорником или штатным и внутренним совместителем. Предусмотрена и возможность сначала штатной работы, увольнения, а потом работы по ДГПХ.

С точки зрения ТК это разные "единицы исчисления" и табельный номер у них должен быть разный. А вот с точки зрения НУ (НДФЛ, персонифицированный учет ПФ) - это одно и то же ФЛ.

Таким образом ЗиК ред. 2 различает понятия сотрудник и ФЛ.

Для того, чтобы в целях НУ доходы разных сотрудников, но одного и того же ФЛ собирались воедино в 1-НДФЛ, 2-НДФЛ, доках перс.учета ПФ справочник сотрудники имеет реквизит ОсновнойЭлемент (тип - ссылка на спр. Сотрудники). Именно при помощи этого реквизита контролируется сбор всех доходов ФЛ для целей НУ.

У штатного сотрудника ОсновнойЭлемент ссылается сам на себя. У всех остальных сотрудников того же ФЛ Основной элемент ссылается на того сотрудника по которому будут собираться доходы в целях НУ.

Отвечая конкретно на вопрос (0). В указанной ситуации мы имеем двух разных сотрудников (в смысле ТК), но одно физическое лицо (в смысле НУ). При заведении ДГПХ необходимо второму сотру с другим ТН т.е. договорнику указать в реквизите ОсновнойЭлемент ссылку на бывшего штатного сотрудника. В этом случае у договорника будет статус "ФЛ", но доходы в целях НУ и перс. учета будут собираться по данным обоих сотров.
Marinka
14 - 27.05.2004 10:13 		(12) "Правда, если договор подряда оформить на копию уволенного лица." - это как? В справочнику Сотрудники "встать" на сотрудника, нажать F9, и с точки зрения программы получить нового сотрудника?...
(13) "реквизите ОсновнойЭлемент" А я не нашла такого реквизита...:( можно поконкретнее где он находиться?
Argus
15 - 27.05.2004 10:27 		Помогите определиться... Фирма (1000 чел) считала зарплату в прог. "УПТЗ Парус" под DOS. Версия более не поддерживается. Нужно искать замену.
Вопрос: 1С ЗиК 7.7 потянет большую фирму со сложной зарплатой? Будет ли "Расчет зарплаты" в версии 8 пока не неизвестно, а решение нужно уже принимать и внедрять к новому году. Хотелось бы на платформе 1С, т.к. немного знаю язык и мог бы сам сопровождать программу.
Argus
19 - 28.05.2004 11:01 		Вопрос, как работать? В УПТЗ "Парус" тоже можно работать, но с "корявками". То 13-ю зарплату считает не всем, то люди теряются при переводе, то начисляет з/п не так и т.п. Постоянное напряжение и ожидание подвоха. Да, зарплата у нас сложная, тарифная сетка, разряды, табель - как в бюджете, потом куча совмещений и совместительств, доплаты, коэффициенты, почасовые, смены, ночные, хитрые премии, сверхурочные, и т.д и.т.п. Люди постоянно переходят из подразделения в подразделение, увольняются, потом возвращаются.
В описании говорится, что 1С - программа для малых и средних предприятий. Как она сработает на предприятии с тысячью сотрудников? У кого есть опыт внедрения 1С ЗиК в подобных предприятиях? Что посоветуете?
vdi
23 - 28.05.2004 21:53 		(13) Очень понравилось ваше объяснение. Но радость была недолгой.

В конфигураторе предусмотрено только ручное изменение реквизита "ОсновнойЭлемент". Однако попытки у ФЛ-подрядчика на закладке "Налоговый учет" с помощью кнопки "Изменить" сделать ссылку на уволенного сотрудника к успеху не приводит.

Если же ДГПХ оформить на копию уволенного сотрудника, то получается следующее.
1) В журнале расчетов и ФЛ и Уволенное лицо с точки зрения НДФЛ это одно и тоже лицо.
2) Однако отчеты 1-НДФЛ и 2-НДФЛ показывают, что это все-таки разные лица.
3) С точки зрения ЕСН они тоже разные лица.

Проблему вроде-бы решает оформление ДГПХ на уволенного сотрудника. Но это очень неудобно.

Если не трудно, пожалуйста, уточните свою методику оформления ДГПХ на уволенного.


ЗИК: Опять районные коэффициенты. | База знаний | mista.ru

ЗИК: Опять районные коэффициенты.

dusic 21.05.2004 06:18 | Есть районные коэффициенты местные и есть утвержденные правительством. Ставлю местный 1.3 и ставлю правительством 1.3 в итоге получаю что используется только местный в расчетах, а тот что РФ нет. Посмотрел в конфигурации где используется, так и есть этот РФ берется только во всяких больничных. А нам нужно что бы он начислялся. В чем я не прав? или кто не прав? Объясните или дайте ссылки на правовые акты... Спасибо
Marinka 1 - 21.05.2004 09:32 | "Ставлю местный 1.3 и ставлю правительством 1.3 в итоге получаю что используется только местный в расчетах, а тот что РФ нет" Так они же у тебя одинаковые... какая разница-то?... или просто принципиальный вопрос?... Читала где-то такое: /Согласно разъяснениям налоговых органов районный коэффициент, установленный местными органами власти, и превышающий предельный уровень районных коэффициентов, установленный законодательством Российской Федерации, не включается в состав расходов, уменьшающих налогооблагаемую базу по налогу на прибыль. / Не знаю правда как это реализованов ЗиК
TheEnd 2 - 21.05.2004 16:30 | Значит что то я не понимаю с этими коэфициентами? :) Мне нужно что бы было "районный коэфициент от РФ" 1.3 и "местный Дальневосточный" 1.3 В сумме получается 1.6 Смотрел по ведомости там так Оклад 5000р РК (РФ) -1500 РК(ДВ) - 1500. В итоге 8000р Что не так? Или дальневосточный нужно завестни "новым расчетом"?
Marinka 4 - 21.05.2004 17:07 | В ведомости 2 строки по Районному? Первый раз такое вижу... И вообще... что значит: \"В сумме получается 1.6\" их нельзя складывать... Согласно ст 316 ТК РФ размер РК устанавливается ФЗ, но месными влястями он может быть увеличен, для этого и сделано 2 константы. В том случае если РК увеличивают, то считается все по месному, н при этом разницу не включается в состав расходов, уменьшающих налогооблагаемую базу по налогу на прибыль. По-моему так.
Marinka 5 - 21.05.2004 17:09 | (2) Но даже если все так, как ты говоришь, то что получаем: Оклад 5000р РК (РФ) -1500 (30%) РК(ДВ) - 1500 (30%). В итоге 8000р. А тебе надо, чтобы РК был 1,6, т.е: 5000+5000*60%=8000. Что одно и тоже... Так что не так-то?


Табель в ЗиК. Зачем по дням ? | База знаний | mista.ru

Табель в ЗиК. Зачем по дням ?

BorisBiz
19.05.2004 15:23 		Зачем может пригодится заполнение табеля по дням (печать не нужна, т.к. заполняется по первичке) ? Может достаточно итого за месяц (дней, часов) заполнить ?
psk21office
8 - 21.05.2004 09:37 		Выдержка из описания:
\"Документ \"Табель отработанного времени\" предназначен для тех
сотрудников, отработанное время которых не поддается
регламентированию при помощи календарей отработанного времени
и рассчитывается вручную. Таким сотрудникам в обязательном
порядке должна быть указана одна из форм оплаты труда \"по табелю\".

Документ вызывается из пункта \"Начисление зарплаты\" меню \"Документы\".

В документе нужно за каждый календарный день ввести количество
отработанных часов, причем вечерние и ночные часы вводятся в
отдельных строках документа. Для включения введенных данных в
расчет документ нужно провести (нажав одноименную кнопку).

Во избежание разночтений при расчетах, данные об отработанном
времени на каждого сотрудника за какой-либо месяц можно ввести
только в одном документе. При проведении документа будет выдано
предупреждение о дублировании данных, и документ не будет проведен
(т.е. данные, включенные в документ, не будут учитываться при расчетах).

Кнопка \"Печать\" распечатывает введенные в документ данные в форме
стандартного \"Табеля учета использования рабочего времени\".

Для сотрудников, отработанное время которых учитывается при
помощи календарей отработанного времени, в этом документе
можно ввести сверхурочно отработанное время.\"

Табель можно заполнять как по дням, так и за месяц в целом.
В частности в табеле можешь вести учет сверхурочных.
Nata-
15 - 26.05.2004 10:07 		(0) Можно вводить данные за месяц в целом. Если в течении месяца у сотрудника менялась оплата труда, то обязательно надо вводить с разбивкой по дням, иначе з/п будет считаться по вновь введенному
Marinka
16 - 26.05.2004 11:41 		(15) Хм... и правда... напишет вот такую штуку: "У сотрудника <ФИО> в <месяц, год> г. изменялись расчетные данные (оклад или ставка или график работы)! Введите подробные данные об отработанном времени."


Зарплата и кадры - соцстрах | База знаний | mista.ru

Зарплата и кадры - соцстрах

MAAlekseev 25.05.2004 14:06 | Делаю выгрузку из 1с77 в ЗиК, включая счета 69.11 69.12 соцстрах. Загружаю в ЗиК. Начисляю зарплату, налоги с ФОТ, но проводок по соцстраху нет. Как сделать правильно, подскажите кто знает, работаю с ЗиК недавно.
M 1 - 25.05.2004 14:44 | Справочники->Бухучет з/пл->Доп. проводки на ФСС_НС укажи % от расчетной базы


Форма Т-2 | База знаний | mista.ru

Форма Т-2

Sector04 25.05.2004 15:44 | Ребята, может кто знает, тут мои зарплатчики, сказали, что якобы кто-то сказал, что появилась форма Т-2 от 2004 г. У нас ЗиК 245. Но форма там от 2001. Кто чё скажет?
SnarkHunter 1 - 25.05.2004 15:58 | Поставь ЗиК 246 и поимеешь счастье...


ЗиК: Денежное вознаграждение за квалификацию. | База знаний | mista.ru

ЗиК: Денежное вознаграждение за квалификацию.

vdi 25.05.2004 08:10 | В справочник "Виды расчетов" вводим предопределенный расчет "Денежное вознаграждение за квалификацию". Однако в документах типа "Ввод расчетов сотрудников" он не появляется. Уважаемые колеги. поделитесь пожалуйста своими соображениями.
Marinka 1 - 25.05.2004 15:49 | Если я не ошибаюсь, то этот вид начисления появляется только в документе \"Ввод расчета сотруднику\" в том случае, если сотрудник принят как Военнослужащий.


ЗиК. Как правильно использовать Удержание за неиспользованный отпуск? | База знаний | mista.ru

ЗиК. Как правильно использовать Удержание за неиспользованный отпуск?

Denis Nsk 24.05.2004 13:12 | Как правильно использовать Удержание за неиспользованный отпуск? Заводим Документы->Отпуск->Вид отпуска=Удержание за неотработанные дни отпуска. Ожидаем, что этот документ снимет часть оплаты отпуска оплаченного "Авансом" при увольнении сотрудника. Запись появляется в Расчетном листке/Своде в Удержаниях. И ни как не отражается на расчете НДФЛ. Вопрос: - Как сделать, что бы этот вид Отпуска появлялся в Начисленном с минусом (В режиме предприятия), - Как правильно завести документы если нужно что бы пересчитался НДФЛ?
BorisG 1 - 24.05.2004 13:56 | Да... спорный это вопрос. Если пересчитать налоги, надо быть готовым к спору с налоговой. Одно из мнений изложено, например, Михаилом Сорокиным: http://1c.klim.org/forum/viewtopic.php?t=257
Сомневающийся 2 - 24.05.2004 13:56 | А документ "Начисление заработной платы" заводил (или перепроводил) после того как ввел свой документ?
Denis Nsk 3 - 24.05.2004 14:29 | BorisG, спасибо ссылку почитал. Логика есть. Но здесь перемешивается Определения разных отраслей права Трудового и Налогового. Мы (не Царь Иоан Васильевич а нашь колхоз)) принимаем Вариант II. Т.к. считаем это перерасчетом для целей НК. Хотя с пересчетом НБ по НК дела обстоят еще хуже, на то должно быть письменное заявление работника на пересчет НДФЛ. Это распространенное мнение МНС. Сомневающийся Спасибо. Не перепроводил и думаю уже не надо. Так как в ссылке четко дана логика 1С. В соотвествии с которой Мы делали все правильно и результат то же правильный.


ЗиК. СуммаСреднегоЗароботкаОтпуска | База знаний | mista.ru

ЗиК. СуммаСреднегоЗароботкаОтпуска

Света 17.05.2004 12:32 | Подскажите пожалуйста, как сделать, чтобы "ПроизвольнаяДоплата" по которой есть расчеты, попадала в расчет среднего зароботка отпуска
kadr 1 - 17.05.2004 13:36 | Что такое произвольная доплата? Вид расчета? Если так, то надо включить этот вид расчета в базу вида расчета оплата по среднему
Света 2 - 17.05.2004 14:43 | Да это вид расчета. Я его включаю в группу "База расчетов оплата по среднему" и ничего???? Что же делать?
eug 4 - 17.05.2004 14:53 | В режиме "Предприятие": меню Справочники-Расчет зарплаты-Виды расчетов-закладка "Начисления"-"Оплата по среднему заработку"-кнопка "База".
Света 6 - 17.05.2004 18:16 | Очень жаль, но это не сработало.


Ещё не лучше: оклад военнослужащего в ЗиК... | База знаний | mista.ru

Ещё не лучше: оклад военнослужащего в ЗиК...

DElo 14.05.2004 20:34 | Зачисляем в списки части. В приказе стоит: должностной оклад, на закладке "Дополнительные" - Оклад по должности. В журнал расчёта при начислении з/пл. берётся должностной оклад, проверено. Кто может посмотреть конфигурацию и сказать - где участвует оклад по должности? И ещё: есть у военнослужащих оклад по званию, так я его указала для звания сотр-ка, а в журнале расчёта его нет( Причём,когда я смотрю движения документа "Приказ о зачислении в списки части", показать Записи журналов расчетов, то мне говорится: Нет записей по документу! ПОМОГИТЕ ПЛИЗ!!! Как начислить оклад по званию???? Выслуга лет от него идёт, однако... Очень надо, кровь из носа... В понедельник ехать и всё это реализовывать, а в книжках по ЗиК про это нет ничего(
DElo 4 - 14.05.2004 22:14 | Ладно... С начислением оклада по званию разобрались (спасибо bazvan - не совсем подсказал, но намекнул, а это уже +). Осталось - полдела, может, кто посмотрит-таки? Просто откроет конфигурацию и посмотрит: где может участвовать реквизит приказа о зачислении в списки части "оклад по должности"? Это на закладке приказа "Дополнительные". Заранее благодарна.
Gavrila 8 - 15.05.2004 16:17 | (7) смотрел на 245 - не нашел 246 :(( При проведении приказа это значение записывается в периодический реквизит справочника "Сотрудники" - "Оклад"; Не знаю правда чем это поможет :))


Шаблон проводки в ЗиК | База знаний | mista.ru

Шаблон проводки в ЗиК

димон 12.05.2004 17:48 | Подскажите как настроить шаблон проводки д20 - к70? Дело в том, что при переносе из бухгалтерии 4.58 не переносится субконто Подразделения (участвует в счете 20) и ВидыНачисленийВыплат (участвует в счете 70). При создании шаблона нет возможности заполнить третье субконто в сч20 и второе в сч70, при не заполненом субконто шаблон не создается. Я так понимаю, что субконто не переносятся, т.к. их нет в правилах переноса. Но что же в таком случае делать?
DElo 1 - 12.05.2004 22:45 | Про подразделения: Ты в подразделение определяешь на работу человека, стало быть подразделение, в котором он числится, машинально участвует 3-м субконто сч.20. Согласись, глупо писать "Токарный цех", допустим, для токаря, когда он числится на работе в токарном цеху. Про субконто 2 сч.70: Вид начисления/выплат нужен только в бух., чтобы определить вид лохода с кодом для НДФЛ и указать, какие налоги с этого дохода платятся. В ЗиК это заведомо прописано, и если проводки выгружать, то спокойно всё выгружается без субконто 2 сч.70.
Marinka 2 - 13.05.2004 09:30 | (0) ага... Delo права, а чтобы не возникало таких вопросов - обнови правила обмена... и все встанет на свои места :)
gr13 3 - 13.05.2004 09:33 | (0) а почему бы тебе в бухгалтерии не прописать данное субконто (не заполнить) и заного выгрузить, была подобная проблема, когда так сделал, то все заработало
DElo 5 - 13.05.2004 23:43 | (3)Marinka права на все 100% - смысла нет никакого. Таскать туда-сюда подразделения, когда их всё равно прописывать надо в ЗиК и заполнять по-обобому. А с видами расчётов (второе субконто 70) - вообще глупость, так как это нужно лишь для корректировки налогооблагаемой базы при начислении з/пл. в бух. В ЗиК уже всё скорректировано.


Зик. ВР который не обл только ФСС (4%) | База знаний | mista.ru

Зик. ВР который не обл только ФСС (4%)

ally 13.05.2004 12:04 | Есть такие?
Marinka 1 - 13.05.2004 12:13 | Так любой вид сними из базы ФСС и не будет облагаться...
ally 2 - 13.05.2004 12:34 | (1)Он снимается и с Накопительной и страховой и всего ЕСН при этом Мне клиент про п.3 статьи 238 НК лечит....а вот в виде расчета на закладке НУ в пункте "Тип дохода для ЕСН" пункта такого нЭту....
Евген 3 - 13.05.2004 12:40 | Договор подряда
ally 5 - 13.05.2004 13:41 | День у меня сегодня фиговый...надо сказать, бестолковый какой-то... Ст. 238 п3: В налоговую базу (в части суммы налога, подлежащей уплате в Фонд социального страхования Российской Федерации), помимо выплат, указанных в пунктах 1 и 2 настоящей статьи, не включаются также любые вознаграждения, выплачиваемые физическим лицам по договорам гражданско-правового характера, авторским и лицензионным договорам. Ну кто-нибудь, ткните меня носом, я туплю! Борис, как ты нужен, так тебя нет!
Mike_2104 6 - 13.05.2004 15:08 | Документы/Ввод начислений/Договор ГПХ


ЗиК: Забыли сотру начислить оплату по договору подряда | База знаний | mista.ru

ЗиК: Забыли сотру начислить оплату по договору подряда

Сказочник 05.05.2004 13:15 | теперь ДГПХ не вводит записи в журнал расчетов, т.к. документ "Начисление з/п " у данного сотра уже имеется.Перепроводить его не хочется, т.к. сотрудников много и расчет по ним придется делать заново.Можетъ, есть какие-то иные варианты?
LarsVVS 5 - 05.05.2004 16:25 | Не ругайся и не ругаем будешь... В документе "Нач. зарпл." видел поле "Способ"?


Смена системы оплаты не сначала месяца (ЗиК) | База знаний | mista.ru

Смена системы оплаты не сначала месяца (ЗиК)

kadr 26.04.2004 11:18 | Господа! Стоит ЗиК 244. Сотрудника переводят в середине месяца с одной должности на другую, причем у этих должностей отличаются системы оплаты труда (у первой - повременно-премиальная, а у второй - сдельно-премиальная). Программа говорит, что нельзя сменить систему оплаты труда не сначала месяца. Что делать?
Поп Гапон 1 - 26.04.2004 11:31 | Сделай не с середины месяца, подрихтуй сумму ручками. В кадровом приказе в примечании распиши подробности. Забодай расчетчика что так надо. Кадровику скорее всего будет пофиг, что вы там в 1С колбасите.
kadr 2 - 26.04.2004 12:02 | Так ведь он будет неправильно числится в штате. И те же расчетчики неправильно посчитают его (когда будут выбирать кого посчитать)
kadr 3 - 27.04.2004 07:31 | Может поделитесь как решали эту проблему те, кто с ней реально сталкивался
kalabukhov83 8 - 27.04.2004 21:20 | Не знаю как у вас на 244, а у меня на 245 все нормально меняется и считается.
meet 12 - 05.05.2004 03:48 | Можно ли поподробнее.Как у вас получилось поменять си-му оплаты не с начала месяца. Релиз у нас 246. У сотра в поле график работы стоит пусто т.е. по умолчанию основной график.Менять не дает. Пробовали и на 245 релизе - то же самое. Вопрос очень актуальный. Перемещения очень часто возникают. Помогите разобраться.
kadr 13 - 05.05.2004 07:18 | (12) Нельзя! Вообщем, пока программистам из 1С будет в лом написать нормальную конфигурацию, где просматривались бы все изменения за месяц (они щас просто делают что-то типа Получить(ДатаОкончания)), а не только конечное значение, париться с этим придется пользователям самим... Для BorisG: и не надо там на нормативные документы ссылаться - просто нормальную конфу написать программистов 1С ломает...
BorisG 14 - 05.05.2004 07:50 | (13) "пока программистам из 1С будет в лом написать нормальную конфигурацию" Ну ну... посмотри лучше сам, какие "советы" даешь... Иди на Парус, там нормальнее... bazvan'a на тебя нет, он бы грубее ответил.


Проблема с рассчетом НДФЛ. HELP! | База знаний | mista.ru

Проблема с рассчетом НДФЛ. HELP!

Александр 02.05.2004 20:00 | При рассчете НДФЛ всем вновь введенным в базу сотрудникам считается с учетом вычетов, а всем введенным месяц назад - без вычетов, хотя вычеты у всех введены. Подскажите где копать?
psk21office 2 - 03.05.2004 18:10 | Смотри период предоставления вычетов.
mos-ad 3 - 03.05.2004 21:51 | в какой-то из последних конфигураций бухгалтерии появилась данная фигня.... по-моему из-за добавления счета ДФЛ. нужно соблюсти последовательность действий: 1) начисление ЗП 2) закрытие месяца с галочкой по зарплате и так каждый месяц
kvm 4 - 03.05.2004 22:43 | Зарплата или Бухгалтерия? Зарплата сама отрезает при превышении 20000, смотри карточку НДФЛ-1, а в Бухгалтерии счет ДФЛ, но ты смотри все-таки историю, и ту-же карточку. Если не поможет, прогони в Отладчике, может какая-нибудь мелочь.


Как включить вычет на ребенка при рассчете НДФЛ? | База знаний | mista.ru

Как включить вычет на ребенка при рассчете НДФЛ?

Александр 30.04.2004 16:37 | При рассчете НДФЛ не учитываются вычеты, хотя они введены. Что нужно сделать? HELP!
SiMazx 1 - 30.04.2004 16:40 | Значит общий доход превысил лимит...
Александр 2 - 30.04.2004 16:43 | Не, общий доход 4000, лимит 20000. Не понимаю в чем дело, неделю назад вычеты считались, потом вдруг как отрезало.
Mazay 3 - 30.04.2004 18:03 | Может стоит посмотреть историю пер. реквизита тип вычета на сотрудника на момент расчета зарплаты ?
DElo 4 - 30.04.2004 23:19 | Это в ЗиК или в Бух? Исходя из конфигурации, можно найти причину. Если Бух, то гляньте обороты по сч. ДФЛ по этому сотруднику с начала года. Если там всё нормально - следите за историей периодических реквизитов. Если ЗиК - в журнале расчёта з/пл. оттрассируйте строчку "НДФЛ" по этому сотр-ку.
kadr 5 - 02.05.2004 08:13 | Если ЗиК, то введен документ начисление заработной платы?
Александр 6 - 02.05.2004 21:10 | Это в ЗиК. Пойду смотреть..


Неправильное начисление вечерних (ЗиК 244) | База знаний | mista.ru

Неправильное начисление вечерних (ЗиК 244)

kadr
02.05.2004 07:56 		Вообщем-то такая же ситуация и в ЗиК 245 (ну и наверняка в 246)
При вычислении вечерних (ночных, праздичных) программа делает так:

ТарифСотрудника = глПолучитьСуммуИзРеквизита(ТаблицаРеквизитов.Оклад,СледующаяДата)/глПолучитьСреднемесячноеКолвоЧасов(ГрафикРаботы,СледующаяДата);

то есть берет среднемесячное количество часов (делитель), а не столько, сколько отработано фактически. К тому же делимое тоже не равно фактически начисленному за отработанное время (например, если оклад сотрудника 4500, а он отработал 22 смены при норме в 21, то она все равно берет 4500).
То есть необходимо, что бы бралось фактически начисленное сотруднику и фактически отработанное время.
Если кто-то практически решал эту задачу просьба помогите.
BorisG
1 - 02.05.2004 09:43 		А ст. 153 и 154 ТК почитать...
kadr
2 - 02.05.2004 10:07 		Статья 153. Оплата труда в выходные и нерабочие праздничные дни
Работа в выходной и нерабочий праздничный день оплачивается не менее чем в двойном размере:
сдельщикам - не менее чем по двойным сдельным расценкам;
работникам, труд которых оплачивается по дневным и часовым ставкам, - в размере не менее двойной дневной или часовой ставки;
работникам, получающим месячный оклад, - в размере не менее одинарной дневной или часовой ставки сверх оклада, если работа в выходной и нерабочий праздничный день производилась в пределах месячной нормы рабочего времени, и в размере не менее двойной часовой или дневной ставки сверх оклада, если работа производилась сверх месячной нормы.
По желанию работника, работавшего в выходной или нерабочий праздничный день, ему может быть предоставлен другой день отдыха. В этом случае работа в нерабочий праздничный день оплачивается в одинарном размере, а день отдыха оплате не подлежит.
Оплата труда в выходные и нерабочие праздничные дни творческих работников организаций кинематографии, театров, театральных и концертных организаций, цирков и иных лиц, участвующих в создании и (или) исполнении произведений, профессиональных спортсменов в соответствии с перечнями профессий, установленными Правительством Российской Федерации с учетом мнения Российской трехсторонней комиссии по регулированию социально-трудовых отношений, может определяться на основании трудового договора, коллективного договора или локального нормативного акта организации.

Статья 154. Оплата труда в ночное время
Каждый час работы в ночное время оплачивается в повышенном размере по сравнению с работой в нормальных условиях, но не ниже размеров, установленных законами и иными нормативными правовыми актами.
Конкретные размеры повышения устанавливаются работодателем с учетом мнения представительного органа работников, коллективным договором, трудовым договором.

Где тут написано про расчет?
BorisG
3 - 02.05.2004 11:22 		(2) Видишь ли... те, кто считает, что методисты 1С не правы (твой заголовок: "Неправильное начисление..."), не пишут на форумах, как сделать...
А с этими методистами при желании и сражаются... только для сего нормативные документы знать надо... не хуже этих методистов...

Почитай комментарии к этим статьям... только я сильно сомневаюсь, что у тебя в колдоговоре или положении об оплате труда на предприятии записано то, о чем ты спрашиваешь... На что, собственно, тебе Геннадий и намекнул...
Так что можешь править, только не говори потом, что не предупреждали... когда расчетчик свалит проблему на тебя "У нас так программа считает...", когда поимеют по полной...

Обрати внимание, сие согласно ст. 137 ТК счетной ошибкой не является, и в случае переплаты удерживать будут с виновного ;-)
А в случае недоплаты работник и в суд подать может...


Разовая премия в расчете среднего заработка | База знаний | mista.ru

Разовая премия в расчете среднего заработка

Sector04 28.04.2004 17:15 | Плиз, кто знает, должна ли разовая премия учитываться при расчете среднего заработка. И как сделать, чтобы в ЗиК разовая премия не бралась в расчет среднего ? (ЗиК 243)
BorisG 1 - 28.04.2004 17:49 | А разве постановление Правительства РФ N213 от 11 апреля 2002 года отменили?
Mike_2104 2 - 28.04.2004 17:54 | (1)2003
Sector04 4 - 28.04.2004 18:05 | Вот статья из журнала - "Бухгалтер Татарстана"(расчетчик подогнал): ~премии к юбилейным датам, праздникам, торжественным событиям, за участие в мероприятиях, не связанных с должностными обязанностями (конкурсах и т.д.). как правило, не предусматриваются системами премирования и считаются разовыми. Поэтому они не учитываются при исчислении среднего заработка. На это что скажете?
Bell 5 - 28.04.2004 18:38 | В ЗиК эти премии не учитывались всегда!
Bell 6 - 28.04.2004 18:38 | удалите из группы расчет среднего...
BorisG 7 - 28.04.2004 19:06 | (5) Неужели? А если здорово подумать и документы почитать? (4) Посоветуйте почитать указанный в (1) документ, особенно внимательно пункт 2, и... собственное положение об оплате труда. PS: Кстати, вопрос в (0) и толкование в (4) - вещи существенно разные... И при определенных условиях и праздничная премия МОЖЕТ входить в расчет среднего.
Sector04 8 - 28.04.2004 19:33 | Чел работает с марта сего года. Предоставляется "дополнительный отпуск с сохранением среднего заработка дня" в мае на 20 дней. Оклад 2100 руб. В марте дали премию в размере оклада. Должна ли ЗиК при расчете среднего, брать эту премию?
BorisG 11 - 29.04.2004 09:10 | telepat.dll отдыхает... (10) Я привел тебе нормативный документ, определяющий порядок расчета среднего, есть еще ТК. Разве этого недостаточно? Остальное должно быть записано в трудовом контракте, коллективном договоре, в Вашем положении об оплате труда и... самом приказе о примии. Если в них все правильно написано, входит...
Sector04 12 - 29.04.2004 09:30 | BorisG, я не сомневаюсь, что ты прав. Но мне уже самому стало интересно, где и как это делается. Если тебе не трудно, то подскажи доходчиво (я не силен в ЗиК) как сделать, чтобы к примеру премия не поподала в среднее. Есть желание разобраться в ЗиК, что и откуда делается. Рассчетчиков вроде "послал" с их желаниями. Но суть этого самого заинтересовала.
Sector04 14 - 29.04.2004 12:58 | Чел работает с марта сего года. Предоставляется "дополнительный отпуск с сохранением среднего заработка дня" в мае на 20 дней. Оклад 2100 руб. В марте дали премию в честь праздника (день жилищника) в размере оклада. Должна ли ЗиК при расчете среднего, брать эту премию? Расчетчики утверждают, что не должна !!! Подскажите, плиз !!! И как это сделать?
Sector04 15 - 29.04.2004 14:19 | BorisG, а при каких условиях праздничная премия может входит в расчет среднего?
Marinka 16 - 29.04.2004 16:32 | Настырный... Справочник->Расчет зарплаты->Виды расчетов найти Оплата по среднему и откорректировать базу.
Sector04 17 - 29.04.2004 17:33 | Marinka, СПАСИБО СОЛНЦЕ. Но после расчета - смотрю в расчетках, 2 раза добавляется строка - премия разовая. В первом случае сумма с минусом, ниже нормальная. Т.е. итого начислено цифра верна. Но ведь у рабочих глаза вылезут, -почему и с минусом и с "плюсом".
Marinka 18 - 30.04.2004 09:37 | Где-нить есть документ Исправления... найди и удали :)
Sector04 19 - 30.04.2004 10:58 | Marinka, Спасибо, нашел исправление, "покоцал" его - и о чудо!!! СПАСИБОЧКИ.
ramstar 20 - 02.05.2004 08:39 | Создай но вид расчетов добавь виды начислений нужные и потом просто напросто при расчете зарплаты указывай какой период начисления премиальных и процент начисления и все будет тип топ если правильно виды начислений включишь в вид расчета так что пробуй


2-НДФЛ | База знаний | mista.ru

2-НДФЛ

Sector04 01.05.2004 14:19 | Почему в справке о доходах 2-НДФЛ общая сумма налога исчисленная не равна общей сумме налога удержанного. Подскажите чё делать? ЗиК 244. Заранее спасибо.
kvm 1 - 01.05.2004 16:22 | Проверь в журнале расчетов, все ли месяца был расчет "НДФЛ удержанный". Если зарплату платят месяцеи позже, то такая ситуация вполне возможна и правильна, начисление делается сейчас, а удержание при выплате зарплаты.


ЗиК. Сменная работа. | База знаний | mista.ru

ЗиК. Сменная работа.

KruS 04.11.2004 13:07 | Подскажите, пожалуйста, как правильно оформить сотрудника, который сначала работал 5 дней по 8 часов, а сейчас работает 2 дня через 2 по 12 часов. Я понимаю, что надо создать календарь для сменной работы, оформить кадровый приказ на изменение графика работы. Но потом при формировании расчетной ведомости его оплата по окладу меньше, чем его должностной оклад, указанный в сравочнике "Сотрудники". Пытался менять систему оплаты, но в расчетной ведомости его оплата по окладу все равно не соответствует должностному окладу.
Gary 1 - 04.11.2004 13:11 | Как только ты задаешь особый график (календарь) для сотрудника, то ЗиК именно оттуда дни/часы за полный месяц берет. Потому и видишь, что он по своему графику вроде все дни отработал, а оклад начисляет меньше (или больше) от ожидаемого.
KruS 2 - 04.11.2004 14:21 | Так ведь, если оклад у сотрудника 10 000 р., то какая разница как он работает - 5 дней по 8 часов или 2 дня через 2 по 12 часов. В месяц все равно должно быть примерно одинаковое кол-во часов/дней. Следовательно, одинаковая зарплата. Или я что-то не понимаю?
Gary 3 - 04.11.2004 14:37 | Угу, именно так ... Посмотри в созданном тобой календаре получается всего дней/часов, ЗиК будет считать это за "нормо-дни, нормо-часы" при расчете средневного/среднечасового заработка. В твоем же примере получается, что в первом случае отработка составила 40 часов, а в другом - 48.
Gary 4 - 04.11.2004 14:38 | ой, перепутал ... если наложить эти графики, то во втором случае будет 36 часов (три дня по 12)


Вопрос по Зарплата+Кадры 7.70.248 | База знаний | mista.ru

Вопрос по Зарплата+Кадры 7.70.248

Marinka 06.10.2004 17:00 | Сотрудник Веленеева Елена Викторовна. Начисляем Больничный лист с 10.01.04 по 15.01.04, общее заболевание, начислен по бюджету. В журнале расчета зарплаты получаем строку с суммой 837,20, НДФЛ по источнику Бюджет = 910,41. Делаем выплату з/пл по виду расчета больничный лист по бюджету, получаем сумму к выплате “–73,21”, т.е. расчет происходит таким образом: начислено – весь НДФЛ по данному источнику финансирования (в нашем случае – бюджет). Это нормальная ситуация или я что-то не то делаю?!
BorisG 8 - 07.10.2004 11:41 | (6) Внимательно прочитай эту статью. Неверный ответ хуже отсутствия ответа. (7) Marinka, на самом деле это ошибка типовой конфигурации, и НК тут совсем ни при чем. Проблема связана с невозможностью распределить НДФЛ по ИФ и по видам начислений при промежуточной выплате. Как раз в п.4 ст. 226 НК и говорится две вещи. Удержание производится при ФАКТИЧЕСКОЙ выплате, и удержание НЕ МОЖЕТ превышать 50% суммы выплаты. Переписка по этому вопросу у меня с 1С заняла больше полугода, и пока пришли к выводу, что исправить сию проблему они пока не могут. Возможно это будет исправено в следующей редакции конфигурации, а будет ли она на семерке... это вопрос, либо в конфигурации ЗиК на восьмерке, она скорее всего выйдет быстрее. Так что... пока ручками поправьте суммы пром. выплаты, и все.


сотрудница изменила фамилию | База знаний | mista.ru

сотрудница изменила фамилию

Broken Angel
13.09.2004 15:17 		сотрудница изменила фамилию , нужно подать документы в пенсионный фонд, на измение свидетельства ...
Какие документы подавать и где они находятся в ЗиК 246
BorisG
17 - 14.09.2004 20:06 		(16) Во-первых, требование сдачи форм в электронном виде определено в приказе 122п и этот приказ зарегистрирован в Минюсте. Так что... не прокатит.
Во-вторых, в этом же приказе софт НЕ ОПРЕДЕЛЕН, определен ТОЛЬКО ФОРМАТ.
Т.е. клиент может выбирать ЛЮБОЙ СОФТ, обеспечивающий вывод в указанном формате, в том числе и бесплатный.
Лично мне пока удавалось решить все конфликтные ситуации клиентов с ПФР по этому поводу. Достаточно было затребовать официальный отказ в приеме.
(8) Он есть, кроме правовых систем, на любом сайте ПФР, например...
http://www.opfr.ru/person/akt.html

Постановление Правления Пенсионного фонда Российской Федерации от 21.10.2002 г. № 122п “О формах документов индивидуального (персонифицированного) учета в системе государственного пенсионного страхования и инструкции по их заполнению (регистрация в Минюсте РФ от 19.12.2002 г., № 4051)
http://www.opfr.ru/person/post122p.htm

Инструкция по заполнению форм документов индивидуального (персонифицированного) учета в системе государственного пенсионного страхования.(Утверждена постановлением Правления ПФР от 21.10.02 № 122п) [Архив: 43-instr.zip]
http://www.opfr.ru/person/43-instr.zip

Формы документов индивидуального (персонифицированного) учета в системе государственного пенсионного страхования. (Утверждены постановлением Правления ПФР от 21.10.2002 г. № 122п).[Архив: 44-forms.zip]
http://www.opfr.ru/person/44-forms.zip
Naumov
18 - 14.09.2004 22:46 		Могу еще бесплатную прогру под названием IPFR порекомендовать.
http://www.opfr.komi.com/
BorisG
19 - 15.09.2004 00:00 		(18) Вообще-то ветка в форуме 1С ;-)
Посему нелишне напомнить, что выгрузка данных для ПФР есть и в программах 1С, в частности, в ЗиК, Бухии, Налогоплательщике.


Упр.торговли 8.0 Передача товара от одной организации в другую. | База знаний | mista.ru

Упр.торговли 8.0 Передача товара от одной организации в другую.

Monstrik 26.04.2004 16:57 | В типовой конфигурации реализован механизм передачи товара от одной организации на другу ? Например от отдела закупки на отдел продаж если это разные юр.лица .
Monstrik 2 - 26.04.2004 22:30 | Ты не понял вопроса. Я говорю не о контрагентах, а об организациях. Ими в восьмерке обзываются собственные фирмы. Я и спрашиваю о том, как эти организации могут друг с другом торговать.
Monstrik 3 - 12.05.2004 13:05 | никто не знает ? или вопрос не правильно поставлен ? или никто не пользует "1С:Предприятие 8.0 Управление торговлей" ? или пользует, но только с одним своим юр.лицом ? :) Повторю вопрос другими словами: Восьмерка поддерживает несколько организаций в рамках одной компании. Требуется передать (продать) товар от одной организации - другой, но так, что бы товар остался в компании (на складе). Какими документами такое движение можно оформить ? Если оформлять "Реализацией товара" с выбором контрагента с тем же юр.лицом, что и в принимающей организации, то происходит просто списание товара со склада ... канешна можно потом принять товар ... но это какое-то кривое решение.
lexa 5 - 12.05.2004 13:26 | Про 8 не знаю но в 7.7 была "Продажа собственной фирме", основанная на документе "Быстрая продажа". Формировался документ "Реализация" и документ "ПоступлениеТМЦ"
Monstrik 8 - 13.05.2004 10:02 | Ха ! Сам разобрался :) Значит так. Имеем: Организация1 с юр.лицом1 Организация2 с юр.лицом2 Контрагент1 с юр.лицом1 Контрагент2 с юр.лицом2 1.Принимаем товар от стороннего поставщика на Организацию1 2.Вешаем на этот приход всякие доп.расходы (например таможню) 3.Списываем товар (док."Реализация товара") Контрагенту2 ПО ЦЕНАМ СТОРОННЕГО ПОСТАВЩИКА !!! 4.Принимаем товар на Организацию2 по тем же ценам (для упрощения в конфигурации добавляем ввод на основании из "Реализации товара" в "Поступление товара". 5. В итоге получаем товар на Организации2 по себестоимости С УЧЕТОМ доп.расходов. Блин ... хоть бы написали где-нить об этом ... Местным знайкам (см.выше) --- не знаете - нефиг языком трепать. К сведению - в Управлении торговлей НЕТ ВООБЩЕ бухучета. В бухию 7.7 буду просто сливать доки.


Сменить родителя. | База знаний | mista.ru

Сменить родителя.

mricos 11.07.2004 21:47 | Господа, кто-нибудь может подсказать следующую вещь. Имеем УТ 10.1 , в ней справочник ГТД. Сделал его иерархическим без ограничения иерархии. Создал предопредленную группу "Введенные". В программе используется код: Если ТекСтрокаНоменклатура.ГТД.Родитель<>ГруппаГТД_Введенные Тогда ГТД_Для_Переноса=Справочники.ГТД.НайтиПоКоду(ТекСтрокаНоменклатура.ГТД.Код); ГТД_Для_Переноса.Родитель=ГруппаГТД_Введенные.Ссылка; ГТД_Для_Переноса.записать(); КонецЕсли; Все значения находятся, но при попытке присвоения значения родителю выдается сообщение: {Документ.ПриходГТД(19)}: Поле объекта недоступно для записи (Родитель) ГТД_Для_Переноса.Родитель=ГруппаГТД_Введенные.Ссылка; Чего делать?
Asmody 1 - 11.07.2004 23:33 | садись, 2! #1: НайтиПоКоду() - Возвращаемое значение: Тип: СправочникСсылка.<Имя справочника>. #2: А так не пойдет? (вернее, так надо!) ГТД_Для_Переноса=ТекСтрокаНоменклатура.ГТД.ПолучитьОбъект();


УТ 10.1 - регламентированный учет отсутствует? | База знаний | mista.ru

УТ 10.1 - регламентированный учет отсутствует?

Вик 01.06.2004 10:00 | Правильно ли я понял? В УТ никому нет никакого дела до регламентированной отчетности? Я не увидел там ничего, связанного с взаимоотношениями между юрлицами, входящими в компанию, никаких книг покупок и продаж, и выгрузка в бухгалтерию – это фиговый листок, чтобы сказать, что эта выгрузка вообще возможна. Иными словами, система обращена лицом на рынок, а проблемы взаимоотношений с «человеком с ружьем» - это личные проблемы бухгалтерии? Если товар приходуется на одно юрлицо компании, а продается через другое, то факт передачи и условия передачи нигде не фиксируются? Т.е. при выгрузке в бухгалтерию мы имеем в первом юрлице зависшие товары, а во втором продаем невесть откуда взявшиеся товары? Может быть в контрагентах завести свою компанию и выписывать документы продажи/покупки между собственными юрлицами? Но как эта чехарда отразится на всем учете? Очень хотелось бы, чтобы меня содержательно поправили…
Vozhd 1 - 01.06.2004 10:16 | (0) Золотые слова! А вообще не помню случая, чтобы 1С особо интересовал именно учет, продвижение конфигураций это да, красивые плакаты и много слов - да, а функционал всегда был как бы вторичен. Конечно какой-то функционал в конфигурациях есть, но например, у меня нет клиентов, которых бы этот функционал устроил хотя бы на половину...
Вик 2 - 01.06.2004 10:34 | Кстати сказать, структура компании как совокупности юрлиц есть не прихоть владельца, а необходимость наработать гибкие схемы торговли, позволяющие нормально общаться и с законом тоже. Если бы не это, ну и была бы компания "Иванов и К", и хватит для рынка.
Vozhd 3 - 01.06.2004 10:41 | (2) Совсем не обязательно. Если строить учет и управление по схеме дифференциации, например, разных видов деятельности (или брэндов), то разделение на несколько фирм (или юр лиц) может быть вполне оправдано не только исходя из хитростей наших законов.
Вик 4 - 01.06.2004 10:51 | Да, конечно, есть много серьезных причин дифференциации, но ни один главбух не проигнорирует того, что одна из его серьезнейших забот уже изначалу проигнорирована
Vozhd 5 - 01.06.2004 10:58 | (4) Если бы только главбух. Мне так и не удалось в УТ найти основных финансовых управленческих отчетов, как-то: прибыли-убытки, баланс, ДДС. Да и анализа многих аспектов деятельности (доходов, прибыли, затрат) провести практически невозможно.
427 6 - 01.06.2004 11:03 | А ТиС и УТ никогда не позиционировались как программы с регламентированной отчетностью... Так что наезд не принимается ... И грамотно вести взаимоотношения между своими юрлицами тоже весьма геморойно... Закону ведь нас рать, что один хозяин... Юрлица могут покупать-продавать друг другу, давать на реализацию.... Все должно оформляться договорами. Но ни в коем случае нельзя просто передавать...
Vozhd 7 - 01.06.2004 11:06 | (6) Замечательно, что ваши кладовщики всегда знают товар какого именно юрлица они отгружают
BorisG 8 - 01.06.2004 11:09 | (5) Да... "нет клиентов, которых бы этот функционал устроил хотя бы на половину..." А может вокруг внимательно посмотреть... И сказать... "А может я что неправильно делаю" ;-)) Ну и... зачем баланс в торговле? Для этого есть другие конфигурации... Каждому функционалу должно быть свое место...
DimG 10 - 01.06.2004 11:16 | (8) совершенно верно, просто у нас так заведено: бухгалтерия занимается и оперативным цчетом и бухгалтерским и складским и еще каким-то. Разницы между ними никто не видит, отсюда и вопросы такого рода. Ребята, не мешайте кислое с пресным, а...
427 11 - 01.06.2004 11:16 | (5) а с какого рожна ты там найдешь указанное в (5) ? Там ведь ТОЛЬКО ТОРГОВЫЕ операции... и вся жизнь предприятия НЕ ОТРАЖАЕТСЯ.... А для анализа нужно ВСЁ ! Все затраты ....
Вик 12 - 01.06.2004 11:20 | В (0) я и сказал, "А может я что неправильно делаю?" - подскажите, пожалуйста. Никто не спорит против использования других конфигураций, но данные в компьютере, а вот чей товар я продал от Фирмы1 - неведомо, в регистре партий, к примеру, это неизвестно. Компания раздифференцирована, это прекрасно, но внутри нее ?полный бардак? (пардон, коммунизм?). А у юрлиц компании разные бухгалтерии..., ну и т.д. И что делать, и как привести в чувство? Подскажите, пожалуйста...
Vozhd 13 - 01.06.2004 11:23 | (8) А в торговле не надо знать ни состояния активов, ни задолженностей, ни прибыли? (9) Что именно я не понимаю? И на что это похоже? (10) Почему людей занимающихся, например, торговлей, должно интересовать как там у вас или у 1С-а что-то заведено? Людям управлять надо, а для этого нужен учет, а не просто таблички со списком товаров. (11) Чтож у вас за торговля такая, если нет ни прибыли, нет изменения состояния активов, деньги лежат на месте и никуда не двигаются? Или это все для торговли не имеет никакого значения?
427 15 - 01.06.2004 11:43 | Насчет кусочной автоматизации от 1С - это тебе в фирму 1с надо обращаться... Да, в одной базе иметь все удобно... Но такая система будет стоить на порядок дороже... (не штуку баксов) Возможности системы должны это обеспечивать ... (7 не тянет явно) Такова маркетинговая политика 1С и тут ты ничего не изменишь - жри тот кактус, который тебе подали... Если хочешь есть вкусный банан - вырасти его сам ... Система называется УПРАВЛЕНИЕ ТОРГОВЛЕЙ ... в ней нет слова ФИНАНСЫ... вот дословно и делают... чтобы продать тебе платформу второй раз...
Вик 16 - 01.06.2004 12:03 | (15) 1С действительно проталкивает всем этот кактус и вся реклама на это. Но в форум (хоть ноги у него из 1С растут - как сразу народ эмоции в ветку плеснул) ходят и спецы от конечных клиентов. Может я просмотрел, но обсуждения вокруг платформы - "хорошая-плохая, лучше-хуже прошлой". А вот в плане практического приложения -"приложим и поглядим, что будет" - что-то не заметно. Интересно бы знать, как продается и каковы последствия внедрений? Насчет вырастить самому вкусный банан, это прекрасно, в комплексной 7.7 так и делаю, но там хоть почва есть, а здесь похоже только красивый плакат, насчет БУДЕТ ВАМ СЧАСТЬЕ!!! Только не надо говорить, что раз счастлив в своей 7.7, вот и живи там, а к нам не суйся. Что хорошо, то хорошо. Но отрезать то что нормально раньше пришито было тоже негоже.
Vozhd 17 - 01.06.2004 12:08 | (15) "торговля: Вид предпринимательской деятельности, связанный с куплей-продажей товаров и оказанием услуг покупателям." Государственный стандарт РФ ГОСТ Р 51303-99 "Торговля. Термины и определения" "По договору купли-продажи одна сторона (продавец) обязуется передать вещь (товар) в собственность другой стороне (покупателю), а покупатель обязуется принять этот товар и уплатить за него определенную денежную сумму (цену)." Статья 454 ГК РФ. Из вышеуказанного не могу себе представить ТОРГОВЛЮ без денежного (т.е. финансового) обращения. Таким образом управление торговлей просто обязано включать в себя управление финансами, так как, финансы неотъемлимая часть торговли. "
Вик 19 - 01.06.2004 12:21 | Кстати, (17), они сделали в этом направлении заявку - план-фактный анализ и наполнение рапорта руководителя как то перекликаются с финансами и планированием - для тех, кто раньше не дотягивался, чтобы сопрячь их. Но те же финансы и планирование могли отслеживать СТРУКТУРУ КОМПАНИИ! УТ просто стратегически отмахнулась от этой самой структуры, зарезав всякие механизмы ее поддержки Может быть я не прав и чего-то не вижу?
BorisG 20 - 01.06.2004 12:22 | (17) "Таким образом управление торговлей просто обязано включать в себя управление финансами" Каким образом и с какого бодуна? Это отдельная подситема... и она будет... за отдельные деньги ;-))
Vozhd 21 - 01.06.2004 12:26 | (20) За столько лет на 7.7 не сделали такую подсистему, а тут вдруг сделают? Сомневаюсь...
Вик 23 - 01.06.2004 12:35 | "Это отдельная подситема... и она будет... за отдельные деньги ;-))" Но сурово брови мы насупим... Видимо это реплика прямо от 1С... То, что будет, то будет. Сейчас-то что делать с тем что есть? Кушать и давиться? Плюнуть бяку? Или мы просто народ темный и не распробовали эту икру черную? Так поясните, может мы своего счастья не видим?
BorisG 25 - 01.06.2004 12:48 | (21) Не надо вешать кошек на одну конфу... Просто оглянитесь вокруг... ;-)) ... о сколько нам открытий чудных ... (с) Пушкин Почему не было? И были... и есть... продукты партнерских фирм... Например, Инталева, Раруса... Правда денег стоят ;-))
BorisG 26 - 01.06.2004 12:53 | (24) Если не нравится 1С, зачем Вы с ней работаете? Есть Парус..., есть еще совсем халявное счастье ;-)) любимица bazvan'а, ВС-бухгалтерия, Высший сорт ;-)))) вперед ;-)))
DimG 28 - 01.06.2004 12:56 | Провокационный вопрос. А кто нибудь знает, в чем разница между финансами и деньгами, в глобальном смысле, а не на уровне доморощенных управленцев, а?
Vozhd 29 - 01.06.2004 12:58 | (25) это не вешанье кошек. если вдруг кто-то решил, что управление торговлей может быть без управления финансами, так это просто человек в словах запутался и обозвал "управлением торговлей" достаточно простенький складской учет. Да добавили чуть-чуть планирования, но опять таки планирование только складских запасов, а не торговой деятельности вообще. Кстати, если есть партнерские продукты для финансового управления, то почему бы не назвать эти продукты? Мы же не бабки у подъезда, которые слышат звон, да не знают где он...
Вик 30 - 01.06.2004 12:59 | Ну да ладно, это уже похоже на базарную перепалку. Похоже ответ на свой вопрос я уже получил - чего нема, того нема. Суп отдельно, ... отдельно. Сколько в эту бухгалтерию не передавай проку не будет, потому как каждая бухгалтерия компании должна помирать в одиночку, и они сами должны промеж собой выяснять где чьи тряпочки, почем и т.д. и т.п. Вот только интересно все-таки, сколько смелых лопухов нырнули в это болото, и куда они выплыли?
Vozhd 31 - 01.06.2004 13:02 | (28) Финансы - совокупность всех денежных ресурсов, находящихся в распоряжении государства и хозяйствующих субъектов, а также система их формирования, распределения и использования. http://encycl.yandex.ru/cgi-bin/art.pl?art=glossary/1834/183_4316.HTM&encpage=glossary&mrkp=/yandbtm7%3Fq%3D-225269715%26p%3D0%26g%3D0%26d%3D4%26ag%3Denc_abc%26tg%3D1%26p0%3D0%26q0%3D405223104%26d0%3D0%26script%3D/yandpage%253F
BorisG 32 - 01.06.2004 13:07 | (29) А прайс 1С взлянуть религия не подволяет?
Вик 33 - 01.06.2004 13:09 | (26) Не нравиться - плюнь? Вопросы ведь задаются по существу, а в ответ "ты сам дурак, отойди и не мешай!" Странная манера, чесс-слово Сюда ведь ходят в основном те, кто занимается вот этим самым делом, а не для того, чтобы обругать, сабак повешать...
DimG 34 - 01.06.2004 13:10 | к (31)Оттуда же: Деньги - особый товар, выполняющий роль всеобщего эквивалента при обмене товаров, форма стоимости всех других товаров. Деньги выполняют функции: меры стоимости, средства обращения, средства образования сокровищ, средства платежа и мировых денег. Стало быть, денежное обращение и финансовое, все таки разные понятия, а система называется как? Управление торговлей. Откуда там взяться финансам.
BorisG 35 - 01.06.2004 13:13 | +32... улетело... клавишу зацепил... Я вообще-то считал, что вступая в дискуссии люди не просто языки чешут, а хотя бы ознакомятся с действующим положением вещей на рынке... У уж не говорю про партнерские (и не только) решения, которые в прайсе 1С или на ее сайте в разделе "Внедренные решения" ........... "Человек - это существо, которое охотнее всего рассуждает о том, в чем меньше всего разбирается" (с) Станислав Лем
Vozhd 36 - 01.06.2004 13:18 | (32) К сожалению, как и у самого 1С-а, так и нмогих партнеров, название продукта не всегда соответствует функциональному наполнению. А в таком случае, действительно остается только религиозный (или даже фанатичный) подход. Подскажи, в каких строках прайса искать те замечательные продукты, на которые ты так усиленно ссылаешься.


OFF Анализ торговли | База знаний | mista.ru

OFF Анализ торговли

Влад 31.05.2004 11:43 | Подскажите книжку по анализу торговой деятельности, ну и, само собой, где ее взять.
Asmody 1 - 31.05.2004 12:07 | А что ты понимаешь под "анализом"? Если применительно к 1С (по разделу форума), то можно почитать книжку Шуремова "Информационные технологии финансового планирования и экономического анализа". Она посвящена работе с конфигурацией "Финансовое планирование". Она (конфа) неплохо стыкуется с типовыми от 1С. Книжку можно купить у франчей.
BorisG 2 - 31.05.2004 12:44 | У Шуремова есть и другая книжка ;-), как раз применительно к восьмерке "Управление торговлей", она гораздо ближе к теме. ;-) Е.Л.Шуремов "Информационные технологии оптовой торговли" Купить можно там же.
Влад 3 - 31.05.2004 13:41 | (1) под анализом я понимаю анализ ;), т.е. мне нужна книжка, гда описаны все (или не все) возможные коэффициенты, показатели, методики, с помощью которых можно анализировать торговую деятельность, делать прогнозы и т.п., в общем не нужно описание какой-то конфигурации, мне просто нужна книжка по анализу, автор которой, может быть даже и не знает об 1С.
Sasha 5 - 31.05.2004 14:27 | Поддержу автора темы: Очень хочеться книжку, в которой написано все про анализ (анализ торговой деятельности, финансовый анализ). Для того, чтобы знать, что можно "вытащить" из базы данных. Такую информацию можно продавать клиентам. Вроде "А хотите, я вам вот такой отчет сделаю..."


скрипт автоматического входа в 1с 8.0 | База знаний | mista.ru

скрипт автоматического входа в 1с 8.0

Dasha
18.08.2004 16:40 		Можно ли написать скрипт в 1с 8.0, который будет производить вход в 1с под заданным пользователем и выгружать ИБ?
Asmody
1 - 18.08.2004 17:09 		1cv8.exe CONFIG {/F<Путь к ИБ> | /S<имя сервера>\<имя БД>} /U<Пользователь> /P<Пароль> /DumpIB
Asmody
3 - 18.08.2004 17:34 		До кучи:

Параметры командной строки. При запуске файла 1CV8.EXE в командной строке могут быть указаны следующие параметры:

Параметры командной строки выбора режима:

CONFIG
запуск системы 1С:Предприятие 8.0 в режиме «Конфигуратор»;

ENTERPRISE
запуск системы 1С:Предприятие 8.0 в режиме «1С:Предприятие»;

CREATEINFOBASE <connect string> [/AddInList [<имя ИБ>]]
создание файлов поставки и обновления

<connect string>
строка, задающая параметры информационной базы, каждый из которых представляет собой фрагмент вида
<Имя параметра=><Значение>,

где Имя параметра — имя параметра, а Значение — его значение.

Фрагменты отделяются друг от друга символами ';'.

Если значение содержит пробельные символы, то оно должно быть заключено в двойные кавычки (").

Для файлового варианта определен параметр:

File — каталог информационной базы;

Locale — язык (страна), которые будут использованы при создании информационной базы. Допустимые значения такие же как у параметра <Форматная строка> метода Формат. Параметр Locale задавать не обязательно. Если не задан, то будут использованы региональные установки текущей информационной базы.

Для клиент-серверного варианта определены параметры:

Srvr — имя сервера 1С:Предприятия;

Ref — имя информационной базы на сервере;

SQLSrvr — имя SQL сервера;

SQLDB — имя SQL базы данных;

SQLUID — имя пользователя SQL;

SQLPwd — пароль пользователя SQL. Если пароль для пользователя SQL не задан, то данный параметр можно не указывать

SQLYOffs - смещение дат, используемое для хранения дат в SQL Server. Может принимать значения 0 или 2000. Данный параметр задавать не обязательно. Если не задан принимается значение 0.

Locale - язык (страна), (аналогично файловому варианту).

Для всех вариантов определены параметры:

Usr — имя пользователя;

Pwd — пароль

/AddInList
параметр, показывающий, под каким именем добавлять базу в список, если не указан, база не будет добавлена в список. Если не указано имя, используется умолчание, аналогичное интерактивному созданию информационной базы.

Одновременное использование ключей не допускается.

Параметры командной строки для указания параметров запуска:

/@<имя файла>
параметры командной строки записаны в указанном файле

/F<Путь>
путь к информационной базе, если она хранится в файле (имя файла указывать не надо)

/S<Адрес>
адрес информационной базы, хранящейся на сервере 1С:Предприятия 8.0, складывается следующим образом:

<Имя компьютера, работающего сервером приложений>\ <Ссылочное имя информационной базы, известное в рамках сервера 1С:Предприятия 8.0>

/N<Имя>
имя пользователя. Должно быть указано так же, как в списке пользователей, создаваемом в Конфигураторе

/P<Пароль>
пароль пользователя, имя которого указано в параметре /N. Если у пользователя нет пароля, этот параметр можно опустить

/WA-
запрет применения Windows-аутентификации при старте Предприятия или Конфигуратора

/WA+
установка обязательного применения Windows-аутентификации при старте 1С:Предприятия или Конфигуратора. Если ключ /WA не указывается, то подразумевается, что используется параметр командной строки /WA+

/AU-
запрет вывода вопроса об обновлении текущей версии 1С:Предприятия с административной установки

/AU+
установка вывода вопроса об обновлении текущей версии 1С:Предприятия с административной установки. Если ключ /AU не указывается, то подразумевается, что используется параметр командной строки /AU+

/Out<Имя файла>
[-NoTruncate]
установка файла для вывода служебных сообщений. Если задан ключ –NoTruncate (через пробел), файл не очищается

/L<Каталог>
указывается каталог локализованных ресурсов интерфейса (например, «RU»)

/DisableStartupMessages
Подавляет стартовые сообщения: «Конфигурация базы данных не соответствует сохраненной конфигурации. Продолжить?»; «Возможностей Вашего компьютера недостаточно для редактирования справки по конфигурации. Для редактирования справки необходимо установить Microsoft Internet Explorer версии 6.0 или выше.»; «Возможностей Вашего компьютера недостаточно для редактирования html-документов, в том числе разделов справки. Для редактирования html-документов необходимо установить Microsoft Internet Explorer версии 6.0 или выше. В данном запуске редактирование html-документов будет недоступно.»

/C<Строка текста>
передача параметра в конфигурацию

Параметры командной строки пакетного режима конфигуратора:

/DumpIB<Имя файла>
выгрузка информационной базы в командном режиме

/RestoreIB<Имя файла>
загрузка информационной базы в командном режиме

/DumpCfg<имя cf файла>
сохранение конфигурации в файл

/LoadCfg<имя cf файла>
загрузка конфигурации из файла

/UpdateDBCfg
[-WarningsAsErrors]
обновление конфигурации базы данных. Если ключ WarningsAsErrors указан (через пробел), то все предупредительные сообщения будут трактоваться как ошибки

/DumpDBCfg<имя cf файла>
сохранение конфигурации базы данных в файл

/RollbackCfg
возврат к конфигурации базы данных

/CheckModules
выполнить синтаксический контроль

/UpdateCfg<имя cf | cfu файла>
обновление конфигурации, находящейся на поддержке

/IBCheckAndRepair [-ReIndex]
[-LogIntergrity] [-RecalcTotals]
[-IBCompression]
[-TestOnly | [-BadRefCreate |
-BadRefClear | -BadRefNone]
[-BadDataCreate |
-BadDataDelete] ]
выполнить тестирование и исправление информационной базы

ReIndex
реиндексация таблиц

LogIntergrity
проверка логической целостности

RecalcTotals
пересчет итогов

IBCompression
сжатие таблиц

TestOnly
только тестирование

при наличии ссылок на несуществующие объекты:

BadRefCreate
создавать объекты

BadRefClear
очищать объекты

BadRefNone
не изменять

при частичной потере объектов:

BadDataCreate
создавать объекты

BadDataDelete
удалять объекты

Одновременное использование ключей внутри подгруппы параметров не допускается.
Если команда прошла успешно, возвращает код возврата 0, в противном случае — 1 (101, если в данных имеются ошибки).
После выполнения закрывает систему 1С:Предприятие 8.0.

Параметры командной строки пакетного режима создания файлов поставки и обновления:

/CreateDistributionFiles
[-cffile<имя cf файла>]
[-cfufile <имя cfu файла>
[-f<имя cf файла>|-v<версия дистрибутива>]+]
Создание файлов поставки и обновления

-cffile<имя cf файла>
указание создать дистрибутив

-cfufile<имя cfu файла>
указание создать обновление

-f<имя cf файла>
дистрибутив, включаемый в обновление, задан именем

-v<версия дистрибутива>]
дистрибутив, включаемый в обновление, задан версией

Примечание: группа параметров -f<имя cf файла>|-v<версия дистрибутива> повторяется столько раз, сколько файлов дистрибутивов включается в обновление.

Параметры командной строки режима работы с хранилищем конфигурации:

/DepotF
каталог хранилища

/DepotN
имя пользователя хранилища

/DepotP
пароль пользователя хранилища

/DepotDumpCfg<имя cf файла> [-v<номер версии хранилища>]
сохранить конфигурацию из хранилища в файл (пакетный режим)

-v<номер версии хранилища>
v - номер версии, если номер версии не указан, или равен -1, будет сохранена последняя версия.

/DepotUpdateCfg [-v<номер версии хранилища>] [-revised]
Обновить конфигурацию хранилища из файла (пакетный режим)

-v<номер версии хранилища>
номер версии, если номер версии не указан, или равен -1, будет сохранена последняя версия, если конфигурация подключена к хранилищу, то параметр игнорируется

-revised
получать захваченные объекты, если потребуется. Если конфигурация не подключена к хранилищу, то параметр игнорируется.

Параметры командной строки пакетного режима регистрации 1С:Предприятия 8.0 в качестве Automation сервера:

/RegServer
регистрация приложения

/UnregServer
удаление регистрации приложения

После выполнения закрывает систему 1С:Предприятие 8.0.

Если значения параметров включают пробелы (например, путь или имя файла), значения должны быть заключены в кавычки.

Ниже приведен пример командной строки для запуска системы 1С:Предприятие 8.0:

С:\1CV8\BIN\1CV8.EXE ENTERPRISE /FDB

Приведенная командная строка означает, что система 1С:Предприятие 8.0 будет запущена в режиме «1С:Предприятие», а информационная база находится в подкаталоге «\DB» каталога «С:\1CV8\BIN».


Не могу изменить конфу ! | База знаний | mista.ru

Не могу изменить конфу !

Prost 11.10.2004 13:34 | Как стандартную конфу "Упр.торг" сделать доступной для изменений ?
Asmody 1 - 11.10.2004 13:41 | ай-яй-яй!!! какое горе. а с поддержки снять не пробовал?
Asmody 3 - 11.10.2004 13:54 | а за тебя ее 1С поставило. чтоб не мучался >;))
Волшебник 4 - 11.10.2004 13:55 | http://v8.1c.ru/predpriyatie/typical_problems_Common.htm#2


как отправить выгруженный в файл документ по почте? | База знаний | mista.ru

как отправить выгруженный в файл документ по почте?

Непоседа
10.11.2004 13:48 		Добрый день!
как правильно прописать процедуру отправки файла.. в 8-ке есть несколько объектов
ИнтернетПочтовоеСообщение. почтовоеСообщение, Почта, ИтеренетПочта...
чем они отличаются и что мне лучше использовать, в ситуации, когда надо после выгрузки документа в файл переслать его по почте в магазин?
Может можно где-нить на примере посмотреть?
1Спец
1 - 10.11.2004 13:52 		Письмо = Новый ПочтовоеСообщение;
Письмо.Тема = "Счет на оплату";
Письмо.Получатели.Добавить(Строка.Заказ.Контрагент.Мыло);
Письмо.Вложения.Добавить ("C:\shop\www.shop.ru\1c\Счета\Счет",ТипФайлаТабличногоДокумента.XLS);

Почта = Новый Почта;
Почта.Послать(Письмо);
Непоседа
2 - 10.11.2004 14:35 		{Документ.ПеремещениеТоваров.Форма.ФормаДокумента(1028)}: Ошибка при вызове метода контекста (Добавить): Недопустимое значение параметра (параметр номер "1")
Письмо.Вложения.Добавить(Имяфайла);
так ругается, когда пытается выполнить следующий код
Письмо = Новый ПочтовоеСообщение;
Письмо.Тема = "Файл выгрузки";
Письмо.Получатели.Добавить(СокрЛП(СкладПолучатель.АдресПочты));
ИмяФайла = ВыборФайла();//функция, которая возвращает путь+имя выбранного файла
Письмо.Вложения.Добавить(Имяфайла);
1Спец
3 - 10.11.2004 14:40 		Письмо.Вложения.Добавить(<Путь до файла>);

Например
Письмо.Вложения.Добавить("С:\файл.xls");
Непоседа
4 - 10.11.2004 14:58 		спасибо. я нашла свою ошибку... не доглядела - файл после записи неплохо было бы еще закрывать перед пересылкой :-((
теперь другое - говорит, что не установлен почтовый клиент по умолчанию... где его прописать надо?
1Спец
5 - 10.11.2004 15:01 		Вся почта уходит через АутГлюк или АутЭкспресс...
Также в Експлорере --> Серви --> Свойства обозревателя --> Программы
Волшебник
10 - 12.11.2004 10:37 		(9) У меня все работает через TheBAT!, что я делаю не так?


Обработки.ОбзорКонфигурации - специфика терминальной сессии? | База знаний | mista.ru

Обработки.ОбзорКонфигурации - специфика терминальной сессии?

008 15.10.2004 14:37 | На форме есть элемент ПолеДокумента, типа поле табличного документа. Без терминала все есть, все работает... а в терминальной сессии этого элемента формы нет! Ни в режиме предприятия, ни в пофигураторе его нет. Релиз платформы 8.0.8.7. ИБ не путаю (предупреждаю вопрос). Вопрос - это фича или глюк?
Gmix@Yandex.ru 3 - 18.10.2004 10:16 | Поставь IE6.0 на терминальный сервер и поле появиться!
008 4 - 25.10.2004 10:30 | Позволю себе поднять тему... Я не путаю обработки... тем более, что это не внешняя обработка (ОбзорКонфигурации). А по поводу 6-го эксплорера интересно... жаль сейчас не смогу терм.серв перегрузить. А завтра проверю.
008 5 - 25.10.2004 10:53 | Уже проверил... проблема в IE... Ёлы-палы... Drop, спасибо. Модератору - занесите в базу знаний, пожста.


Существует ли конфигурация для коммунальной энергетики? | База знаний | mista.ru

Существует ли конфигурация для коммунальной энергетики?

yaret 21.05.2004 10:29 | Пытался найти готовое решение для электросетей, но не нашел! Есть много для ЖКХ, есть для водоканала, но для городских электросетей нет! Почему? Ведь спрос на рынке есть (ИМХО конечно), а вот предложение от фирмы 1С и их франчей отсутствует.
Волшебник 1 - 21.05.2004 12:23 | См. также http://www.forum.mista.ru/topic.php?id=4338 А поводу спроса - напиши и будет предложение, будешь продавать, денег заработаешь.
yaret 2 - 21.05.2004 13:48 | (1) Эту ветку видел..... по ссылкам ходил.... ИТСы просмотрел, поиск в Интернете делал.... Ничего нет :-(( Придется самому делать - буду делать изменения в типовой бухгалтерии 7.7 Жаль! Хотел избавить себя от лишней работы, но видимо судьба.... хотя мож оно и к лучшему...


Амортизация ОС! Срок пол.действ. закончен, а амортизация начисляется! | База знаний | mista.ru

Амортизация ОС! Срок пол.действ. закончен, а амортизация начисляется!

Оля 18.06.2004 15:25 | Амортизация ОС! Срок пол.действ. закончен, а амортизация все равно начисляется!Такое ощущение, что это ошибка в стандартной конфигурации. Может условие(типа срок<0? то закончить) там не прописано. Можно ли мне его самой куда-нибудь вставить!(не знаю куда, нет отдельного докАмортизация) У кого-нибудь такое было? Если в конфиге все нормально, то что делать, вроде все перепробывала, система просто игнарирует все сроки!
Ira 2 - 18.06.2004 15:47 | Для этого есть регламентый док "Начисление амортизации". Амортизация начисляется не только до момента истечения срока полезного использования, но и до полного погашения стоимости. Посмотри Остатки по счетам 01.1 и 02.1. Если СКД по сч. 01 > СКК по сч. 02 по этому ОС, то амортизация будет начисляться, пока эти суммы не будут равны.


Вопрос по книге учета доходов и расходов в упращенке | База знаний | mista.ru

Вопрос по книге учета доходов и расходов в упращенке

Tani 09.06.2004 14:12 | За один квартал отчет выводит нормально, но если формировать отчет за полугодие ( 9 месяцев, год), то выводятся данные только за последний квартал. Вопрос: это так должно быть или это недоделки 1с?
Marinka 4 - 09.06.2004 15:09 | Там идет поквартальный отчет. Если надо сделать за год - делашь сначала за 1 квартал, потом за полугодие, потом за 9 мес, потом за год, при этом получишь 4 листа: 1 кв, 2 кв, 3 кв, 4 кв, что в сумме дает год. (а сделано все так, если я не ошибаюсь, потому что налог платиться поквартально)


Упрощенка, кто подскажет установки | База знаний | mista.ru

Упрощенка, кто подскажет установки

inter 01.06.2004 10:01 | Кто подскажет - каким образом (какие установки) надо сделать в упрощенке после прихода товара и оплаты за него сделать так чтобы эта опдата сразу попадала в расход (т.е. кассовый метод). И правильно ли это с точки бух.учета.
Marinka 1 - 01.06.2004 14:47 | Если я не ошибаюсь, то при проведение расходника-выписки на оплату она (оплата) и попадет в графу "Расход всего". Или ты имеещь ввиду графу "Расходы, учитываемые при УСН"?, так это произойдет только в том случае, когда ты реализуешь этот товар и тебе его оплатят... и никак иначе. Хотя... выход есть - ручные проводки.. только оно тебе надо? ещё сложнее все получиться... Хоть это и УСН, но не все там так просто....


Объединение конфигураций | База знаний | mista.ru

Объединение конфигураций

Term2 31.05.2004 03:54 | Начальство поставило такую задачу: объединить 2 конфиги Зарплпта+Кадры и Бухгалтерию в одну. Кто-нибудь такой фигней уже пробовал заниматься? Поделитесь опытом.
BorisG 2 - 31.05.2004 07:19 | +1 И их опыт объединения подробно изложен на ИТС...
BorisG 3 - 31.05.2004 07:21 | +2 Только почему-то у многих возникает обратный вопрос; "Как из комплексной вырезать Зарплату?" ;-))
vdi 4 - 31.05.2004 07:54 | ИТС №1, раздел "Обмен данными в формате XML", в в каталоге 1sITS\EXE\XML.
vdi 7 - 31.05.2004 10:23 | (0) Прежде чем применять эту обработку обязательно установи инсталятор Windows и XML Parser. На ИТС они в раделе 1sITS\EXE\XML\MsXMLPar. Проверь также, чтобы стояла последняя версия v7plus.dll. Учти, что структура объектов в "Бух" и в "Комплексной" разная. Поэтому какие-то объекты может быть и не удастся перенести. Или перенсти, но с возможной потерей некоторых реквизитов. Вообще-то здесь потребуется кропотливая работа по созданию схемы выгрузки данных. Я давно ничего никуда не переносил. Но перед написанием этого сообщения на всякий случай успешно перенес этой обработкой данные из "1с: Бухгалтерский учет" в "1с: Коплексная конфигурация". Удачи.
vdi 8 - 31.05.2004 10:28 | (0) Да, этой обработкой можно слить данные в комплексную, но не объединить бух и зарплату.


Решения по управленческому учету | База знаний | mista.ru

Решения по управленческому учету

Magnus 01.03.2004 14:00 | Люди добрые, подскажите какие есть решения по управленческому учету под 1С. На сайте 1С уже смотрел.
Dezart 2 - 26.05.2004 16:30 | 2 Magnus - посмотри на сайте www.auditoria.by (прога 1С:Экономист, кстати на базе МСФО) прямая ссылка: http://www.auditoria.by/index.php?p=econ удачи!


Вопрос по ПУБу | База знаний | mista.ru

Вопрос по ПУБу

Estet 25.05.2004 15:01 | В пустой базе отключаю контроль отрицательных остатков ТМЦ создаю 1-ый документ "Перемещение по складам" (перемещаю со Склада1 на Склад2 Товар в количестве 5 штук), при этом движение по регистру Места хранения: уход со склада1 5 штук, приход на склад2 5 штук. создаю 2-ой документ ""Перемещение по складам"" (перемещаю со Склада1 на Склад2 Товар(тот же самый) в количестве 8 штук), движение по регистру: уход со склада1 в количестве (-5)штук, уход со склада1 в количестве 13 штук, приход на склад2 13 штук. Делаю "Складской учет МПЗ" по Складу2 Итого на скдаде 18 штук Товара. Можно ли с этим как-нибудь бороться?
SnarkHunter 1 - 25.05.2004 15:12 | Контроль остатков включать не пробовал?
Estet 2 - 25.05.2004 15:18 | Если включить, то все нормально но пользователи в таком режиме хотят работать и получать правильные отчеты...


Комплексная. Продлема с проводками. | База знаний | mista.ru

Комплексная. Продлема с проводками.

vf_01 25.05.2004 11:37 | Справочник хозяйственных операция заполнен, Но при проведении накладной или расчетах зарплаты не формируются проводки. Может где то не проставил галочку? Или надо какие-то дополнительные действия выполнять?
psk21office 1 - 25.05.2004 13:57 | Попробуй: Меню "Торговля и бухгалтерия" - "Регламентные операции" - "Формирование проводок". Там выставляшь фирму и период. Должны сформироваться проводоки.


Форма счета-фактуры в комплексной | База знаний | mista.ru

Форма счета-фактуры в комплексной

Ученик ламера 19.05.2004 12:15 | Подскажите пожалуйста, с марта месяца изменилась форма счета-фактуры, в каком релизе комплексной конфигурации это дело учтено?
Композитор 1 - 19.05.2004 12:37 | У меня добавлены внешние обработки.
Ученик ламера 3 - 20.05.2004 12:21 | Хм... Так и не нашел. В релизе 453-м прилагаются печатные формы, и счет-фактура там тоже есть, вот только она не соответствует действительности почему-то... Консультанты клянутся, что эта форма была еще в 452-м релизе. Может кто-то все же сталкивался? Или вручную поменять проще?
lexa 4 - 20.05.2004 12:37 | Вручную проще, изменений минимум
User63 6 - 20.05.2004 15:05 | (3) Консультанты правы. В 452-м уже было. Надо этот отчет подключить через меню Подключение внешних печатных форм. И чтобы потом по кнопке Печать выводился именно этот отчет надо один раз выбрать его из списка (рядом с кнопочкой Печать).


ПО для ведения бухучета на производстве | База знаний | mista.ru

ПО для ведения бухучета на производстве

Kisss 20.05.2004 10:12 | Господа! Подскажите, пожалуйста, какое ПО лучше использовать бухгалтерии завода? Ведь на производстве учет материалов ведется не как в стандартной 1С:Бухгалтерии... Материалы (драг.металллы) "превращаются" в продукцию...
SiMazx 1 - 20.05.2004 10:18 | ПУБ: Производство-Услуги-Бухгалтерия...
Vser1 2 - 20.05.2004 10:41 | (0) Подобное производство, используется конфигурация от ИТРП под 7.7
Outlander 3 - 20.05.2004 10:42 | Так на большинстве производственных предприятий есть какое-то своеобразие. Не как в стандартной. И 1С подходит лучше большинства других прог для реализации этого своеобразия.


По поводу представления отчетов в ИМНС в электронном виде... | База знаний | mista.ru

По поводу представления отчетов в ИМНС в электронном виде...

User63 19.05.2004 15:35 | А есть у 1С программа по формированию регламентированных отчетов для ИМНС в электронном виде?
Valery 1 - 19.05.2004 16:12 | В регламентных отчетах она и есть


Есть ли готовое решение для КСК (Коммунальных хозяйств)? | База знаний | mista.ru

Есть ли готовое решение для КСК (Коммунальных хозяйств)?

Balance-1 15.05.2004 17:57 | Вот встала задача автоматизировать комм. услуг для коммунального хозяйства (КСК). Сам в принципе могу написать, но эта отладка... Хуже нет. Народ может у кто-нибудь из вас занимался уже чем-то подобным. Рассмотрю любые предложения. Спасибо.
Волшебник 1 - 15.05.2004 18:07 | Решения по ЖКХ, имеющие сертификат 1С:Совместимо: http://www.1c.ru/RUS/PRODUCTS/1C/predpr/compat/catalog/branch.jsp?id=6 Внедренные решения фирм-франчайзи http://www.1c.ru/rus/partners/solutions/solutions.jsp?type=6
NiGMa 3 - 17.05.2004 08:27 | У меня тут такое решение на фазе внедрения... Мы пользовались (продавали) конфигурацию от "Эффект-Информ", но она безграмотная до ужаса, поэтому сейчас пишу свою. К лету будет готова.
Balance-1 4 - 17.05.2004 17:24 | то NiGMA. Да я тоже начал писать... На базе типовой конфигурации для Казахстана 205... Ну чтоб там еще зарплату работникам подсчитать и Учет ОС и НМА готовый был.


Вопрос по организации Счет-Фактур в 1с | База знаний | mista.ru

Вопрос по организации Счет-Фактур в 1с

Игорь 17.05.2004 12:18 | Здравствуйте. Есть следующая проблемка: Имеется счет и по нему нужно сделать Счет-фактуру. Не могли бы Вы помочь это сделать?
ander139 2 - 17.05.2004 12:28 | Дык ты введи на основании счета накладную, а на основании неё счет-фактуру
Игорь 3 - 17.05.2004 12:55 | >>Дык ты введи на основании счета накладную, а на основании неё счет-фактуру А как это сделать сразу???.. то есть если я вбиваю счет, то как сделать чтобы после создания создавались бы также счет фактура и накладная на этом же основании?....
lexa 4 - 17.05.2004 13:26 | Если конфа "Торговля и склад", то "Документы" - "Быстрая продажа"


В ЗиК необходимо добавить 70 счету еще одно субконто | База знаний | mista.ru

В ЗиК необходимо добавить 70 счету еще одно субконто

stud 14.05.2004 13:14 | Когда перекачиваю из бухгалтерии в ЗиК то у 70 счета есть два субконто. Но при настройке проводок в ЗиК у 70 счета всеравно отображается только одно "Сотрудник". Можно ли добавть еще одно?
DElo 3 - 14.05.2004 13:27 | Уже писали об этом, что это НЕ НУЖНО!!! Так и втолкни ей. Ссылку на ветку привести?
lexa 4 - 14.05.2004 13:27 | У нас зимой один умный франч добавил в комплексную субконто, а при обновлении на новый релиз выскочила ошибка. Пока все обратно не вернул, обновить не удалось. Попробуй объяснить, что добавить то можно , но потом никаких обновлений
DElo 5 - 14.05.2004 13:30 | http://www.forum.mista.ru/topic.php?id=4217
lexa 12 - 14.05.2004 13:40 | (6) спасибо за внимание к моей скромной персоне, за франча конечно обидно. а насчет обновлений изменненой конфы то http://www.sinor.ru/~my1c/knowhow/mtd_upd.html
lexa 13 - 14.05.2004 13:43 | Смех то про умного франча еще в том, что добавил в комплексную субконто к 51 счету, чтобы работать с разными расчетными счетами (правда по просьбе бухгалтерии).
DElo 14 - 14.05.2004 13:44 | (10)Сделать можно только КАКом к верху!!! Она у тебя по-русски понимает, бухша твоя??? Пускай приведёт пример хотя бы одного отчёта, где это субконто используется, если проводки из ЗиК выгружать. Блин, вот был счёт КН - никто таких идиотских задач не ставил...


Разобрать комплексную на отдельные конфы. | База знаний | mista.ru

Разобрать комплексную на отдельные конфы.

Foma
14.05.2004 09:05 		Ситуация следующая:
есть комплексная (чуть доработанная).решили перейти на отделные компоненты. база ведется по нескольким предприятиям в течение 2 лет.
грабли при "распиливании" и последствия этих граблей.
lexa
4 - 14.05.2004 12:39 		А компоненты отдельно будут жить или будут обмениватся информацией?
Gavrila
5 - 14.05.2004 12:43 		(2) Баальшие такие грабли :))
- ошибки в глоб. модуле ?(постараться надо, но могут и появиться);
- ошибки в связках между доками (особно в тех которые относятся к двум(трем) участкам);
- алгоритмы проведения ВСЕХ доков надо перепроверить, а кое-где исправить;
- отчеты;
- формирование проводок по торг. и З/п операциям;
- логическая целлостность (связка) новых "распиленных" систем;
- доки за два года куда девать, либо формирование остатков отдельно по каждому участку учета;
:))
ally
6 - 14.05.2004 12:52 		Какое нафиг распиливание? Перенесли остатки, справочники, и вперед с нуля в отдельных конфигурациях. Обмен м/у ними сужествует.
Foma
7 - 14.05.2004 12:57 		(4) Отдельно.
в дополнение к теме ветки:
не нужны обработки, коды, ссылки на обработки. Желательно "услышать" общий механизм, с описанием граблей, кто уже делал подобное
lexa
8 - 14.05.2004 12:59 		(6) вообще не понятно зачем пилить:
если для уменьшения размера базы и повышения быстродействия, тогда навеное лучше доработать типовые;
если для упрощения интерфейса, тогда проще новых интерфейсов наделать
Foma
9 - 14.05.2004 13:00 		(6) касательно остатков и справочников. Для торговли и з/п понятно. Для бухии:
бухгалтер в конце года не увидит 1кв. Грабли? грабли. в конце года сказать ей открывать 2 базы или зниматься срочным переносом доков из одной в другую? косяк короче м.б.
ally
10 - 14.05.2004 13:05 		(9) Если год рвать, то здесь да, ты прав. При большом желании можно написать обработку переноса документов, но это дело весьма геморойное да и не факт что ты в дальнейшем не найдешь еще н-цать граблей... но я бы склонялась именно к такому варианту....
lexa
11 - 14.05.2004 13:15 		грабли будут при обмене информацией между компонентами:
от задвоения справочников и документов до измения остатков по разным периодам
Foma
12 - 14.05.2004 13:16 		может проще сделать так:
остатки по бухии наначало года с переносом справочников. Перенос всех доков с начала года из комплексной.
остатки по торговле на текущий момент + справочники.
з/п аналогично торговле
stud
13 - 14.05.2004 13:18 		Лучше забить заново все справочники а документы перенести через обработки. Я тут то же недавно переходил, задолбался с этой комплексной
Foma
14 - 14.05.2004 13:22 		(+12) +Все перетащить через Оле.


Вышла 1С-Логистика:Управление складом | База знаний | mista.ru

Вышла 1С-Логистика:Управление складом

BorisG
12.05.2004 21:56 		"1С:Предприятие 8.0. 1С-Логистика:Управление складом" - специализированное тиражное решение на платформе "1С:Предприятие 8.0" для автоматизации управления складским хозяйством предприятия. Продукт позволяет эффективно автоматизировать управление всеми технологическими процессами современного складского комплекса.

Функциональные возможности конфигурации

Задание топологии складского комплекса

Разделение на зоны, проходы, стеллажи, полки, ячейки.
Адресная идентификация мест хранения.
Приемка и контроль качества

Формирование Заявки на приемку товара на склад.
Приемка товара на склад в зону приемки (новых поставок или возвратов от клиентов).
Размещение товара в карантинной зоне или зоне брака.
Размещение товара в зоне основного хранения, с запретом отгрузки.
Переупаковка

Оперирование любыми типами и единицами хранения товара.
Разукомплектация, переупаковка, перефасовка товара.
Размещение на места хранения и грузопереработки, внутрискладские перемещения

Задание условий хранения товара (температурный режим, влажность, места размещения, и т.д.).
Задание правил размещения и рейтингов мест хранения для автоматического размещения товара (например в соответствии с ABC-классификацией товаров).
Ручное или автоматическое управление размещением товара внутри склада в соответствии с правилами приемки, хранения.
Контроль заполнения ячеек по объему.
Учет товара в разрезе паллет.
Ручное или автоматическое управление транспортировкой товара внутри склада в соответствии с правилами отбора, отгрузки.
Перемещение товара по указанным адресам.
Подбор товара и отгрузка

Формирование Заказа на отгрузку товара со склада.
Перемещение товара в зону отгрузки.
Возможность отгрузки товара непосредственно из зоны приемки.
Отгрузка товара со склада.
Инвентаризация и списание

Формирование заданий на инвентаризацию.
Проведение инвентаризации товара без остановки работы склада.
Блокирование инвентаризируемых ячеек для поступления и отгрузки товара.
Возможное перемещение товара в зону некондиционного товара для последующей утилизации.
Списание потерянных (утраченных) товаров.
Формирование аналитической отчетности:

Построение универсальных отчетов по движениям и остаткам товара на складе в любых разрезах

Дополнительные возможности

Возможность функционирование в единой информационной базе с "1С:Предприятием 8.0 Управление торговлей"
Возможность интеграции с любой информационной системой на уровне обмена файлами.
Возможность интеграции с торговым оборудованием (сканеры, терминалы сбора данных, принтеры этикеток и т.д.)
Аутентификация складских операций.
Управление правами доступа пользователей системы.

http://www.1c.ru/news/info.asp?id=2954
BorisG
3 - 12.05.2004 23:58 		(2) А разве имеет значение, КТО разрабатывал по заказу 1C?
Цитата из письма:
"Конфигурация является объектом исключительного права фирмы "1С"
BorisG
5 - 13.05.2004 00:28 		(4) А письмо прочитать?
Нет, дополнительная лицензия на продукт, так же, как и основная коробка ВКЛЮЧАЕТ и лицензию (и ключик, естественно) на платформу.
ally
6 - 13.05.2004 07:27 		Цена у нее надо сказать...хм...
Как понимать вот это: "Большая часть конфигурации открыта для чтения и внесения изменений, однако меньшая часть кода закрыта и защищена ключом аппаратной защиты. В случае необходимости модификации конфигурации и внесения изменений в закрытый с помощью средств аппаратно-программной защиты программный код, зарегистрированным пользователям следует направлять запрос на адрес разработчика - компании "АИСТ Ай Ти"."
Означает ли это что для того чтобы менять закрытую часть кода необходимо просить разрешения у "АИСТ Ай Ти", и как понимать "меньшая часть кода закрыта и защищена _ключом аппаратной защиты_".
Mike_2104
10 - 13.05.2004 10:23 		(5)"Нет, дополнительная лицензия на продукт, так же, как и основная коробка ВКЛЮЧАЕТ и лицензию (и ключик, естественно) на платформу. "

Дополнительная лицензия не включает лицензию (и ключ) на платформу, в отличие от основной коробки.
BorisG
11 - 13.05.2004 11:18 		(10) Миш, тогда это подробно нужно было объяснить в письме.
"Для расширения количества рабочих мест пользователи данного программного продукта могут приобрести необходимое количество дополнительных многопользовательских лицензий на конфигурацию и платформу, а также лицензию на использование сервера "1С:Предприятия 8.0"

Про сервер понятно однозначно, а вот про доп. лицензии вполне возможно двойное толкование.
Т.е. розничная цена на 1-5-10 мест будет соответственно 150-3520-6000 вечнозеленых.
И ключик Катран?


Куда деваются ГТД после выгрузки из Т+С в Бух? | База знаний | mista.ru

Куда деваются ГТД после выгрузки из Т+С в Бух?

DElo
12.05.2004 00:02 		Ситуация такая: Бухгалтерию имеем настроенную (есть особенности учёта услуг сторонних организаций), в Т+С ведём только поступление, перемещение и реализацию товара, а также расчёты с контрагентами сугубо для оперативного учёта (без формирования проводок). Банк/касса ведётся в Бух.
После проведения услуг сторонних организаций в Бух. и разноски банка/кассы за месяц в бух. формируем книгу покупок. Почему не отображаются Страна-производитель и ГТД??? В Т+С всё это отображается, у товара всё это заведено. Формировать книгу покупок/продаж в Т+С не можем, т.к. кое-какие операции проходят в бухгалтерии, и реализованы эти операции настройками.
У меня складывается впечатление, что ГТД не отображаются в книге покупок в Бух. потому как нет проводок по сч.ГТД (Т+С их не формирует). Если вести полностью учёт в Бух, всё было бы нормально, только вот метод списания себестоимости товаров нужен по партиям.
ВОПРОС: Как ГТД-шки перенести в Бух, если одно и то же наименование может до 10 раз в месяц проходить по разным ГТД? Торговля видит партии, а Бухия - нет.
Может, кто сталкивался? Буду признательна, если посоветуете как выйти из ситуации.
427
1 - 12.05.2004 06:42 		Да, как, друзья, вы не садитесь,
Вы всё в мартышки не годитесь ....

Перенос из ТиС (парт учет) в Бух (по среднему) в принципе может тащить и ГТД (я стандартного переноса не знаю)....

Но если посмотреть шире - два несовместимых механизма ... И чтобы был одинаковый результат....

Кстати, если в Тис сделать по средним ценам ... то учет ГТД накрывается медным тазиком ....
Мутант
2 - 12.05.2004 09:14 		//Буду признательна, если посоветуете как выйти из ситуации.
А зачем в ситуацию входить?
Я такую фишку встречал в одной конторе, но там в ТиСе вели кол-венно суммовой учёт, а в бухии только суммовой.
И НИКОГДА НИКАКИХ ГЕМОРРОЕВ !!!
DElo
3 - 12.05.2004 11:15 		Просто клиент принципиальный: надо, чтобы в книге покупок/продаж, которая в Бух формируется, отображались и ГТД, и страна происхождения.
ГТД выгружаются, а страны - нет. потому что в Т+С страна - реквизит отдельный, а в Бух - страна к ГТД привязана.
Как страны впихнуть???
427
4 - 12.05.2004 11:27 		А хрен их знает....

У меня свой перенос, стандартного не использую.... На уровне доков.... Все нормально едет...
427
8 - 12.05.2004 13:46 		Все делается в бухгалтерии... ВСЕ...

Ибо в каждой торговой организации есть еще и операции, которые по ТиС не протолкнешь... например, покупка расходных материалов для себя... или мебели для себя, и т.д.
DElo
9 - 12.05.2004 13:54 		(8)Ну как затолкать Страны-то в бухию??? Блин, ну надо позарез!!!
427
10 - 12.05.2004 19:10 		Обломайся.... Два совершенно разных механизма...

ТиС - страна и ГТД зашиты в справочник партии. И Страна и ГТД - это отдельные справочники....

СЧФ тащит ГТД из партии, которая списана документом Реализация

В Бух страна происхождения - строка в номенклатуре.... и кстати, есть в справочнике ГТД - опять таки как строка.
ГТД в СЧФ заносится руками - ибо НЕТ партионного учета....

Так что делай конвертацию справочников при переносе..

А если ваша контора не импортер (т.е. не она оформляла ГТД) - забей на ГТД вообще... Один хирен никто не импортеров не проверяет... На моей памяти не было...
DElo
11 - 12.05.2004 22:59 		Блин, ну пристал коиент: хочу, шоб было видно в БУХИИ и страну, и ГТД!!!
Хоть ты чё делай...
Да вродь мы тут помозговали и решили при выгрузке обработку приколотить, чтоб страны раскидывала по ГТД, а более - никак.


Автозаполняемая декларация по НДС | База знаний | mista.ru

Автозаполняемая декларация по НДС

DElo 08.05.2004 00:16 | ...Скажите, это возможно реализовать? Насколько мы поняли, делая отбор по проводкам - не выходит ни фига (базу брать неоткуда и разбиения по ставкам НДС с проводках нет, только в 90,3 - 68,2). А как делать по документам, если происходит выгрузка проводок из Т+С в Бух? Может, мы вообще зря бьёмся? Кто-нибудь пытался реализовать это?
Naumov 1 - 08.05.2004 00:19 | Камин реализовывал для старой декларации. Для новой используя план счетов типовой бух-ии декларацию можно заполнить лишь в некоторых частных случаях. (Мое мнение)
DElo 2 - 08.05.2004 00:29 | Для старой у нас есть, в новой же - куча различий (вычеты, например, постатейно разбились, аналитики у 19.3 нет по тому - услуга эта была или товар для перепродажи, а торговым фирмам это принципиально). Для частных случаев - это: только услуги и реализация, и вычеты, и авансы, всё по одной и той же ставке НДС, нет отложенных налогов... Так чтоли?
kvm 3 - 08.05.2004 00:30 | (1) Полностью согласен. Основные строки худо бедно можно, а с расшифровками труба. (0) Из ТиС в Бух выгружаются не только проводки, но еще и СФ, записи книги покупок/продаж.
DElo 4 - 08.05.2004 00:36 | Не делала я ещё выгрузку из Т+С в Бух, поэтому и представляю, что это как в ЗиК - всё проводками. Значит, сами доки выгрузить можно? Просто не пробовала. а проверить за праздники не на чем(
kvm 5 - 08.05.2004 00:48 | Можно. Услуги и товары разбиваются по субконто ВидНоменклатуры на 90 счете, в справочнике товаров он тоже есть, поэтому следи за синхронизацией справочников, тогда из документов сможешь достать. По поводу вычетов не понял. Авансы делаются другой проводкой, зачет их вообще другой документ. Как нет отложенных? А галочки везде как надо стоят?
DElo 6 - 08.05.2004 00:59 | (5)Ну как ты по оборотам 76.АВ-68.2 сделаешь разбивку по ставкам 10/110 и 18/118? Никак, только по документам "С/ф" или "Запись книги покупок/продаж". Вот есть у меня за месяц 5 выписанных с/ф на аванс. 2 - на 10/110 и 3 - на 18/118. В оборотах - только суммы НДС без аналитики по ставкам, базу считать - тоже замучаешься. А посмотришь декларацию - по ставкам разбивать надо, однако(
kvm 7 - 08.05.2004 01:04 | А чем тебе не нравятся СФ и Записи? Они из ТиС выгружабтся.


Принятие расходов в УСН | База знаний | mista.ru

Принятие расходов в УСН

Marinka
05.05.2004 10:00 		УСН 7.70.135
Вопрос таков:
1. Делаем документ "Поступление МПЗ". Он сделает проводки:
1 Д-т МХ.2
2 Д-т 41.2 К-т 60.2
3 Д-т НДС (см. проводки1.xml)
2. Дальше документ Авансовый отчет:
1 Д-т 60.2 К-т 71.2 (см. проводки2.xml)
3. Рассходный кассовый ордер:
1 Д-т 71.2 50.1
2 Д-т Н04
3 Д-т Н02.2 (см. проводки3.xml)
Почему проводка 3 (Д-т Н02.2) появляется на данном этапе? (хотя должна появляться при отгрузке материала). При этом при отгрузке она так же появляется в итоге у нас сумма расхода получается в 2 раза больше.
Marinka
1 - 05.05.2004 10:15 		Вопрос снимается. Ответ 1С-hotline:
Использование счета 60 в документе \"Авансовый отчет\" не предусмотрено
методологией типовой конфигурации (соответствующая оговорка есть во встроенном описании этого документа).
В описании Документа \"Авансовый отчет\" можно прочитать:
\"Если аванс использован на приобретение материально-производственных
запасов (МПЗ) - основных средств, нематериальных активов, материалов или на оплату услуг, то в качестве контрагента следует указать подотчетное лицо, а в качестве корреспондирующего счета счет оприходования МПЗ (например, 10). Указание счета 60 может привести к не корректному определению момента признания расходов для целей налогового учета. В реквизите \"Сумма\" следует указать сумму, выплаченную поставщику. \"

Правда возникает другой:
А как тогда реализовать схему: Поступление МПЗ -> Оплата через авансовый
отчет -> Возврат денего подотчетнику? Ведь поступление МПЗ мы уже отразили
документом \"Поступление МПЗ\", как нам теперь закрыть 60 счет, если не
авансовым отчетом?
kvm
3 - 05.05.2004 22:11 		Обнови версию, в 135 у меня такая схема отработала нормально.
kvm
4 - 05.05.2004 22:12 		Sorry. Схема была: РКО, Авансовый отчет, Приход, Списание.
vdi
5 - 06.05.2004 08:09 		Я, наверное, не очень врубился в тему и тем не менее. Описание авансового отчета я понимаю так: не рекомендуется использовать корреспонденцию д10к60. Но ничего ведь не говорится о корреспонденции д60.2к71.2.

РКО: Д71.2К50.1 – 12000 руб.
Поступление МПЗ: Д10.2К60.2 – 10000 руб.
Авансовый отчет (оплата поставщику): Д60.2К71.2 – 10000 руб.
ПКО: Д50.1К71.2 – 2000 руб.
Marinka
6 - 06.05.2004 09:10 		(5) При схеме РКО, Поступление, Авансовый отчет - работает, но стоит поменять местами т.е. сделать: Поступление, Авансовый отчет, РКО, и все... расходы удваиваються...

\"Описание авансового отчета я понимаю так: не рекомендуется использовать корреспонденцию д10к60\" а я наоборот поняла, что не рекомендуется использовать счет 60: \"Указание счета 60 может привести к не корректному определению момента признания расходов для целей налогового учета\", а рекомендуется счет 10 (и ему подобные) в качестве корреспондирующего счета счет оприходования МПЗ (например, 10).
vdi
8 - 07.05.2004 09:46 		(7) Если следовать схеме Поступление->Авнсовый отчет->РКО, то получим.

Поступление МПЗ: Д10.2К60.2 – 1180 руб.
Авансовый отчет: Д10.2К71.2 – 1180 руб.
РКО: Д71К50.1 - 1180 руб.

На лицо удвоение материалов и кредиторская задолженность. Можно все исправить ручными проводками, только зачем. Видимо, в 1с считают, что пользователи УСН не погут приобретать МПЗ по наличному расчету и без предоплаты.


С помощью какого документа можно ввести акт оказания услуг в комплексной? | База знаний | mista.ru

С помощью какого документа можно ввести акт оказания услуг в комплексной?

SAP 06.05.2004 13:20 | С помощью какого документа можно ввести оказание услуг в комплексной конфигурации?
GrayT 1 - 06.05.2004 13:25 | А реализация с номенклатурой услуга не подойдет?
unconnected 3 - 06.05.2004 14:15 | ага, а при выборе печатной формы можно и "акт об оказании услуг" выбрать


Комиссия в комплексной 4.5 (отчет комиссионера и возврат) | База знаний | mista.ru

Комиссия в комплексной 4.5 (отчет комиссионера и возврат)

NastyFrog 05.05.2004 17:00 | Отдаем на комиссию одному контрагенту один и тот же товар (по 2 шт.), но по разным ценам. Он отчитывается - продал 1 шт. по рублю и одну по два. В регистр ПартииОтданные пишется две шт. по рублю. Или возврат - 1 шт. по рублю и 1шт. по 2, остается у комиссионера 2 шт. по рублю - сталкивался кто? Как победить? Настройками или конфу править? Списание FIFO.
Naumov 1 - 05.05.2004 22:37 | Ничего править не нужно. По чем передавали на реализацию по том и списывается. На долг-то вешается вся сумма реализации. Это ж разные вещи
proreha 2 - 06.05.2004 03:11 | править нужно и давно....д.б. аналогично рознице - дополнительный учет по продажным ценам.....иначе порой такая фигня получаеться.....именно в случаях передачи одного и того же товара по разным ценам....


Формирование проводок в Комплексной конфигурации | База знаний | mista.ru

Формирование проводок в Комплексной конфигурации

Антон 05.05.2004 04:55 | Подскажите пожайлуста, заполняю проводки через сервис/формирование проводок, а они после этотого при проведении документов (например поступление товара) не формируются. Что я неправильно делаю?
3V 1 - 05.05.2004 08:26 | (0) первый вопрос: где в комплексной в сервисе есть формирование проводок? . в комплексной, если мне память не изменяет, есть два режима формирования проводок: 1. непосредственно при проведении документов 2. документом "формирование проводок" . если в настройках стоит второй вариант, то при проведении документов, проводки в самих документах все равно не будут формироваться.
КККК 2 - 05.05.2004 11:01 | (0) в спр. фирм или юр. лиц ли смотри историю реквизита "Формировать проводки" (как-то так называется). Надо поставить "по документам"
Rider 3 - 05.05.2004 11:45 | Кто-нибудь может объяснить зачем в Комплексной для Украины проводки по торговым документам формируются по информации из регистров при проведении БухТорг, а не сразу при проведении документов. Зачем придумали это извращение?


Налоги: Ошибка с Резидентом ??? | База знаний | mista.ru

Налоги: Ошибка с Резидентом ???

rick 03.05.2004 12:15 | Условия проблемы следующие: есть комплексная конфигурация 1с в 7.7., в ней организован кадровый учет. ПРОБЛЕМА: если при внесении физического лица не указывать страну проживания, то налог при рассчете з.п. считается нормально - 13%, со всеми вычетами - на себя и на детей (у кого они указаны). Если указать "россия" то исчисленный налог становится 30% и вычеты не делаются. В чем ошибка ? Пробовал в модуле расчета НДФЛ поставить "Резидент=1;" независимо от страны ПМЖ - не помогает. :/ Еще странно - через раз открывается форма Т-2.
Dionisious 1 - 03.05.2004 12:20 | А в справочнике стран у России код какой? Должен быть 643.
rick 3 - 03.05.2004 12:37 | Вообще интересно на что изменение поля "Страна ПМЖ" влияет кроме как на присвоение физ.лицу этого кода? Ведь когда это поле пустое - то все считаеся как положено, а модуле рассчета НДФЛ как раз проверка: Резидент=?(((СтранаПМЖ.Выбран()=0) или (СтранаПМЖ.Код="643")),1,0); я ставил вместо нее втупую: Резидент=1; и не помогает.
kadr 4 - 03.05.2004 13:01 | У-у-у-у батенька, если форма через раз открывается... да вам батенька сносить все к е*** матери надо и ставить заново :))) Кстати, какая версия конфы?
rick 6 - 03.05.2004 14:47 | Версия конфы 4.5 (компл.). При выгрузке данных в 4.4 с расчетом налогов тож самое происходит.
rick 7 - 03.05.2004 15:41 | Очистка "Страна ПМЖ" (Shift-F4) в справочнике "Физ. лица" решает проблему, но отелось бы детально разобраться в механизме этого глюка. Если сталкивались то скажите кто как лечил?
kvm 8 - 03.05.2004 23:02 | Да очень просто. В модулях последних версий всех конфигураций стоит проверка на ЗАПОЛНЕННОСТЬ поля страна. Если оно заполнено, то считается что это - НЕ НАШИ. Упростили, твою...
kvm 9 - 03.05.2004 23:06 | А решается так: Пишешь обработку, а в ней Если Врег(СПр.Страна)="РОССИЯ" Тогда //или ВРЕГ(Страна.Наименование), ну понятно.. Спр.Страна=ПолучитьПустоеЗначение(); //Что внутри скобок тоже ясно? Спр.Записать(); КонецЕсли; Очистил всю Россию...


Чем базовая конфигурация отличается от типовой? | База знаний | mista.ru

Чем базовая конфигурация отличается от типовой?

Юзер 24.10.2004 18:10 | Смотрю, на диске ИТС можно устанавливать базы и типовые, и базовые...а в чём их различие?
Marinka 1 - 24.10.2004 18:11 | базовая может быть только типовой... а вот типовая может не быть базовой...
GrayT 3 - 24.10.2004 18:18 | Базовые версии идут с базовыми движками, там кажись даже конфигуратора нет. Править базовые версии нельзя - они работать не будут
427 4 - 24.10.2004 18:48 | (3) Править базовые можно... И даже восстанавливать базовость можно. Руками. При наличии мозгов... Но это будет 1. незаконно... 2. при накате очередного обновления все смоет...
Дотошный 6 - 24.10.2004 19:58 | Базовая версия не предусматривает изменений с помощью конфигуратора. Матерится, однако :) Все обновления - через франча. (Ну, это когда все по правилам...) Ещё одно отличие: у базовой версии нет ключа защиты (железяки этой). При установке спрашивает волшебные слова из ЖКК. Если изменить конфигурацию или хотя бы открыть ее в конфигураторе и сохранить даже без изменений - всё: движок базовый откажется с ней работать. (Но это лечится).
GrayT 7 - 24.10.2004 21:20 | (4)Можно и не только ручками, можно рассказать чем ехе-шник отличается. Но думаю для Юзер понял о чем речь в целом, а остальное ....
Marinka 8 - 25.10.2004 10:18 | (6) У ЗиК базовой нет ключа?!
Дотошный 9 - 25.10.2004 21:02 | (8) Я бухгалтерию имел в виду. Про ЗиК информацией не владею.
Ша 10 - 26.10.2004 08:10 | Вы что...какие ключи??? Ключ идёт ведь к платформе, а не к конфигурациям! А зачем тогда используется базовая конфигурация?
427 11 - 26.10.2004 08:52 | (10) Дешевка за 70 баксов без возможности конфигурирования... поэтому ключа и нетути... "Аппаратный ключ защиты "СтарФорсе" - рулит...
Marinka 12 - 26.10.2004 09:06 | (10) Как зачем? если тебя стандарт устраивает, то зачем платить больше?
890 13 - 26.10.2004 09:08 | То есть типовая стоит дороже?
Marinka 14 - 26.10.2004 09:16 | не типовая а не базовая стоит дороже... я же те грю, что типовая может быть как базовой, так и не базовой... так вот типовая базовая стоит меньше типовой не базовой... ЗЫ: а "не базовая" раздельно пишеться?
427 15 - 26.10.2004 09:23 | в 7 продается платформа... Конфа - якобы бесплатно... Обновление одинаковое. Но в одном есть признак "базовое", в другом - нет... Из "базового" обновления - обычное делается элементарно. Открываешь с использованием обычной платформы, сохраняешь с игнорированием вопроса о потере невинности - и радуешься... (дальше матофильтр не пускает)... Сама 1С распространяет "базовые" обновления (читай редми). Уменьшает трафик в два раза...


Проблема при работе 1c+Sql+Terminal Server | База знаний | mista.ru

Проблема при работе 1c+Sql+Terminal Server

SergVE 08.06.2004 14:17 | Помогите решить проблему. При работе 1С предприятие на терминальном сервере возникает следующая ошибка: «Доступ возможен только из одного каталога ИБ». 1. Никакой системы при возникновении ошибки не замечено, возникает случайно. 2. Заблокированных файлов в каталоге ИБ нет. 3. Зависших процессов на Microsoft SQL нет. 4. Зависших сессий на Терминальном сервере нет. 5. Такая ошибка возникает только при запуске в терминальной сессии на терминальном сервере и при этом 1С можно запустить на рабочей станции по сети без ошибок. Конфигурация 1C: 1С 7.7 для Sql Build 21 Серверы: Windows 2000 server sp4 SQL: MsSql 2000 Sp3 Связка: Sql<-->Terminal<-->Пользователи
oleg1117 3 - 08.06.2004 16:04 | У меня абсолютно такая же проблема. Решение пока не найдено. Доступ к SQL базе с двух W2K + Citrix MF 1.8. Возникает это только на одном из терминальных серверов. Причем если попытаться из - под терминальной сессии скопировать файл метаданных, система не дает этого сделать. Сообщение об ошибках может варьироваться "Доступ возможен ...", "Файл 1cv7.md ... " и т.п. После отключения ВСЕХ пользователей с "кривого" терминального сервера вход через него становится снова возможным. Если кто подскажет как с этим бороться буду признателен. To (1): У всех пользователей прописаны каталоги, и естественно, речь не о попытке второго входа того же пользователя в один каталог.
alxkorvin 5 - 08.06.2004 16:57 | К базе у разных пользователей прописаны разные пути. Например расшарена папка и часть пользователей обращается с использованием сетевого пути, а часть с использованием локального.
oleg1117 7 - 09.06.2004 09:36 | To: SergVE Детально сравнил параметры терминальных серверов, обнаружил различия. Установил на "кривом" так же как на нормально работающем. Пуск / Настройка / Панель управления / Администрирование / Настройка служб теримналов Подключения / ICA - tcp (или RDP) / Свойства Закладка Параметры клиента "Подключение" Использовать параметры подключения пользователя - Нет (Было Да) Подключение дисков клиента при входе - Да Подключение принтеров клиента при входе - Да По умолчанию выбрать основной принтер клиента - Да (Было Нет) "Отключить следующие возможности:" (все флаги сняты) Пока жду, что получится. Какие в Вас настройки?
romix 10 - 09.06.2004 15:57 | Эта проблема возможна из-за того, что папки Temp не являются различными для разных пользователей терминального сервера. Напишите в консоли MS-DOS echo %temp% и нажмите Enter. Что пишет эта команда? Если короткий путь типа c:\temp, то надо выставить его в правильное значение в Свойствах системы (правый клик на Мой компьютер ...). Правильное значение взять из виндов, в которых эту переменную не изменяли.
romix 11 - 09.06.2004 16:02 | (+10) А изменять могли, чтобы поставить MS-SQL (на имени Администратор установщик MS-SQL молча падает; правильное решение - создать юзера с коротким латинским именем типа AdminSQL и устанавливать под ним, неправильное - изменить переменную окружения Temp и потом не вернуть как было).
nice 12 - 09.06.2004 22:06 | У меня такая же беда, просто если внимательно посмотреть, то сессия "плохого" пользователя не закрыта, хотя я закрывал на его машине терминал ручками... Можно удалить "плохую" сесию и всё должно быть Ок


Сообщение unable to log you on because of an account restriction | База знаний | mista.ru

Сообщение unable to log you on because of an account restriction

uno2003 19.06.2004 12:43 | Делал все так как написано в статье. http://www.mista.ru/articles1c/terminal.htm но при входе с клиентв (win98) вываливается следющее сообщение (см. сабж). никак не пойму в чем дело!!! :(
SnarkHunter 3 - 19.06.2004 13:21 | Вход невозможен по причине ограниченных прав...
uno2003 6 - 19.06.2004 13:45 | Ну тогда где их добавить и как Да забыл сказать получается войти только как guest и то с правами administrator'а, а при подключении любого другого созданного пользователя вы валивается такое (см. сабж) сообщение при входе на терминал сервер
BorisG 9 - 19.06.2004 14:14 | (8) В свое время специально попросил своего сотра проверить... И ты знаешь, там все правильно. По крайней мере в части прав. И еще, проверяли с настоящим ключиком... Посему... читай еще раз ;-)
Черт 10 - 19.06.2004 14:40 | Политики настрой
uno2003 11 - 20.06.2004 14:16 | (9) Первый раз в жизни все делал по инструкции!!! Единственное чего не нашел так это в свойствах дисков закладки security (10) Какие политики безопасности ткните пальцем.
Haspdie 12 - 23.06.2004 17:44 | 2 uno2003 : Посмотри пункт №43 http://www.myjavaserver.com/~gorbunov/faq1c/term.htm


Структура users.usr | База знаний | mista.ru

Структура users.usr

Stich 08.09.2004 09:50 | Никто не знает, как 1С хранит пользователей в users.usr? Интересует или структура файла, или способ добавления пользователей, минуя штатные средства 1С.
skunk 1 - 08.09.2004 10:01 | http://1c.realnet.ru/kuban/140641.html http://ytugteam.fatal.ru/hacking/1c_buh.htm


1С + Терминал 2003 | База знаний | mista.ru

1С + Терминал 2003

_vadim 28.06.2004 13:58 | Сервер Win2003 + текрминал-сервер. Захожу в 1С через терминал, потом выхожу, а терминал не закрывается. Если нажать на кнопку "отмена", в окошке выбора базы, то терминал закрывается сразу. Посоветуйте, как настроить, чтобы окно терминала закрывалось сразу же после выхода из 1С.
Черт 1 - 28.06.2004 14:09 | Администрирование>настройка служб терминалов, там все есть
Черт 2 - 28.06.2004 14:11 | + можно также при подключении удаленного доступа запускать 1С сразу, тогда при выходе из 1С терминальная сессия будет закрываться http://www.mista.ru/articles1c/terminal.htm


1c: Терминал сервер или файл сервер | База знаний | mista.ru

1c: Терминал сервер или файл сервер

Danila
13.04.2004 22:52 		Уважаемые системные администраторы! Посоветуйте! Как лучьше насторить 1С, через терминал сервер или файл сервер, что будет быстрее и стабильнее работать? Количество пользователей минимум 10 максимум 25, конфигурация Торговля. Какие требования к серверу?
SnarkHunter
1 - 13.04.2004 23:12 		Терминал...
It is me
2 - 13.04.2004 23:18 		Терминал, ОЗУ из расчета 50-100 Мб на юзера, 2ГГц проц и там по мелочи, может SCSI дадут, может двухголовый пень выпросишь...
427
3 - 14.04.2004 07:25 		При наличии сети 100 самое дешевое решение на 10-20 пользователей -
файл-сервер под стареньким Новелем не выше 4 (характеристики сервера пень не более 800мгц-1ггц, память - 3*128 мб, диски - любые ИДЕ...)
Ограничения
1 - на раб станциях желательно иметь память не менее 96 мб... лучше 128... В случае терминала это требование отпадает

2 - если юзеры хранят рабочие каталоги на серванте - надо на раб станции ставить и настраивать клиента от Новеля... Если на рабочих станциях - тогда можно пользоваться штатным виндовым ....

Также в случае использования новеловского серванта можно юзать программное дисковое зеркало на ИДЕ дисках.... что также уменьшает стоимость....

Решение - терминал стоит гораздо дороже по деньгам... Однако если раб станции совсем дохлые - тогда их можно не апгрейтить.... и в целом сэкономить....

Но будут косяки терминала.... слет принтеров.... и т.д.

P.S. - у клиента имеется 4 серванта.. новель 4, вин2000 (довольно средний, общая файло-помойка), вин2000 с терминалом и чтото линуксовое для инета... Админ достаточно грамотный... После экспериментов с терминалом вернули все взад на новель.... Всего машин ... а ХЕЗ... но более 50.... в 1С работает свыше 20 в пике, в среднем - 14-18.... 8 активных - операторы на выписке... ТиС 8.х и последняя бухия... На майские будем менять новеловский сервант ... а то старый работает без перезагрузок уже более 2 лет ... (упс - киловаттник)... Да и древний он ... там по моему пень 400 вертится.... а рабочие станции уже и по 2 ГГЦ есть... Но тормозов нет...

P.S. - свыше 30 юзеров на новеле не ставил.... но 20 - полет нормальный....
P.S. - ставить лучше все таки то, что лучше знаешь .... себе меньше хлопот....
don
4 - 20.04.2004 16:14 		Полностью противоположного мнения чем 427.
Самое дешевое решение на 10-20 пользователей - терминалы!
И не надо петь военных песен, что "будут косяки терминала". Уже более 2,5 лет работает Вынь 2000 сервак на 20 пользователей без перестановки.
И экономия какая - все компы старые без винтов Р100-150. А для сетевой загрузки использую Intel PXE и dosrdp. И ни какие принтеры не слетают.
И что дешевле 20 компов по 150-200 баксов + сервак на $1500-2000 или 20 компов по
500-800 баксов.
alxkorvin
5 - 20.04.2004 17:43 		Терминал вообще самое дешевое решение вне зависимости от количества пользователей.

Косяки терминалов и слет принтеров могут возникать только в результате неправильной настройки.
romix
10 - 26.07.2004 18:00 		(0) Безусловно терминал. Например, ЗиК (1С:Зарплата и Кадры) под терминалом начинает работать в несколько раз быстрее.
Sniffer
12 - 26.07.2004 18:19 		(0) на самом деле надо еще провести анализ сети: скорость, коммутаторы или хабы используешь, объем трафика
romix
13 - 27.07.2004 00:59 		(12) В любом случае терминал будет работать лучше, т.к. работа с локальными файлами всегда происходит быстрее, чем по сети. Конечно, выгода по траффику начнется с файлов какого-то определенного размера - так что если база пол-мега, то может быть файловый вариант и "лучше", и подобный "анализ" оправдан.
Skorp
14 - 27.07.2004 01:59 		Если ТиС, то только терминал. Это из личного опыта. При 4-8Гб базе и 5-10 пользователях никакой новел не спасет.


Как отключить отображение окна загрузки 1С? | База знаний | mista.ru

Как отключить отображение окна загрузки 1С?

UltraViolet 16.06.2004 11:11 | Народ, кто нибудь знает как отключить отображение картинки загрузки 1С?
Черт 1 - 16.06.2004 11:13 | п.10 http://www.mista.ru/articles1c/terminal.htm


Подскажите, как поставить пароль на конфигуратор? | База знаний | mista.ru

Подскажите, как поставить пароль на конфигуратор?

Heckfy 16.07.2004 11:33 | Нужно в режиме Конфигуратора поставить пароль на просмотр и изменение конфигурации. Подскажите, как это сделать.
Guk 1 - 16.07.2004 11:35 | (0)Задача-Свойства-Закладка Задача-Кнопка Сменить пароль...


Очистка баз | База знаний | mista.ru

Очистка баз

Александр 22.06.2004 13:11 | Проблема. 1С работает уже три года. Как убрать все данные до определенной даты (почистить базы) Александр.
gr13 1 - 22.06.2004 13:24 | торговля? написать внешнюю процедурку, которая удалит все документы до определенной даты
Gruz 2 - 22.06.2004 13:54 | Это нужно делать аккуратно, потому что вместе с документами могут удалятся и все их движения. (Это могут быть и взаиморасчеты и остатки и т.п.) В люблм случае сначала сделай бэкап.
Valery 3 - 22.06.2004 14:00 | Прежде чем удалить документы необходимо ввести на нужную дату остатки.
ChAlex 5 - 22.06.2004 14:11 | По моему, в какой-то типовой конфигурации есть процедура "СверткаИБ" и с ней связанных два документа "ДвиженияРегистра" и "СверкаИБ".
Valery 7 - 22.06.2004 14:22 | Лучше эту процедуру делать на начало года. Т.Е. вводишь остатки на начало в чистую базу, а старую в архив.
Stra 13 - 23.06.2004 11:47 | Процесс свертки базы довольно серьезный и трудоемкий вопрос. Сначала важно определится насколько конфигурация далека от типовой, если очень близка, то можно воспользоваться стандартной обработкой "завершение периода" (но ОБЯЗАТЕЛЬНО проаерить её работу на резервной копии, кстати это долгий процесс), если далека, то руками (внешней обработкой), но не забывая перенести остатки, взаиморасчеты, партии товаров, в общем все то, что сделает стандартная обработка. Ну и потом, конечно, полученные данные проверить. Это все, конечно, к торговле относиться, в бухгалтерии проще.
Valery 14 - 23.06.2004 13:03 | Я делал отдельный документ в котором собирал все остатки по всем регистрам одной базы и приход в другую чистую. Конфигурации были одинаковые, поэтому большой сложности не было. Использовал OLE.
_student 15 - 23.06.2004 13:51 | Ребята, проблема очень актуальная. Может статья какаянить есть по этому поводу. Если нету, то может ктонить напишет ее.
romix 21 - 24.06.2004 02:49 | Можно попробовать получить остатки по всем регистрам на определенную дату. И восстанавливать их на эту дату при помощи баа-льшого документа, который, например, читает их из табличного файла или нескольких файлов. Но проводиться он будет долго. Так что можно несколько документов - каждый восстанавливает свой регистр. После этого можно удалить или сделать непроведенными или лишить Ресурсов (не проводить по Ресурсам регистров) более ранние документы.
NS 22 - 24.06.2004 02:53 | (21) Всё совсем не так.... Самые долгие две операции - это удаление документов до даты свертки - и сдвиг ТА вперед.
romix 23 - 28.06.2004 20:53 | (22) Попробуйте - УстановитьТАна() у меня выполняется достаточно долго. В ситуации (0), когда надо архивнуть/корректно восстановить остатки на определенную дату.
ChAlex 24 - 28.06.2004 23:56 | Вообще-то я делаю свертки баз таким образом: На дату свертки формирую остатки по всем счетам и всем регистрам(n-м количеством документов "ДвижениеРегистра" по 5000 записей и n-м количеством "Операций" - по каждому счету), затем отменяю проведение документов до даты свертки, затем проверяем ссылки на документы до даты свертки и удаляю документы, на которые нет ссылок (можно просто пометить все документы до даты свертки на удаление, а непосредственное удаление првести интерактивно). Вообщем-то довольно универсальная процедура, если не используется зарплата и кадры.Поскольку свертка кадровых документов и расчета зарплаты требует индивидуального алгоритма. Если кого интересует, могу выслать на мыло.
ChAlex 26 - 29.06.2004 12:34 | Так он не индивидуальный, а универсальный ( в предположении, что удаляемые документы не нужны).Ограничения использования возникают в зарплате, если удалишь "Приказ о приеме на работу", то удалишь и сотрудника и т.д.. Сложность определения документов, которые можно удалить, а которые нелязя. А в остальном - все хорошо прекрасная маркиза... Поэтому индивидуальный алгоритм свертки ЗиК не предлагаю!


Ошибка сохранения базы | База знаний | mista.ru

Ошибка сохранения базы

vva 29.06.2004 12:53 | Пытаюсь сохранить базу стандартная бухгалтерия 4.5. Через конфигуратор Администрирование->Сохранить данные... Появляется "Ошибка при открытии списка сохраняемых файлов". Уже не раз такое встречал. Делал и обновление и тестирование базы ничего не помогло. Что делать?
Gavrila 1 - 29.06.2004 12:54 | наверное NT? да еще доступ на папочку BIN - только для чтения? - полный доступ давай
Gavrila 2 - 29.06.2004 12:55 | +(1) или хотя бы для файла 1CV7FILE.LST
vva 3 - 29.06.2004 13:01 | Папка BIN в которой платформа лежит и файл 1CV7FILE.LST там же? Так другие то базы сохраняются.
cup of tea 4 - 29.06.2004 13:06 | Скопируй файл 1CV7FILE.LST в рабочую базу из BIN - и все будет замечательно. Иначе - работая в 1С в одной базе (даже не в режиме сохранения данных), нельзя сохранить данные в другой базе.


Нарушена структура таблицы данных - как спасти базу???? Хелп! | База знаний | mista.ru

Нарушена структура таблицы данных - как спасти базу???? Хелп!

RommBoss 28.06.2004 20:03 | После того как я чуть-чуть изменённую конфигурацию (в 3 формулы в документе добавил по одному слагаемому) база стала выдавать ошибку "-210" и Нарушена структура таблицы данных, ЧТО ДЕЛАТЬ ПОМОГИТЕ СПАСТИ БАЗУ (резерва не создано)
RommBoss 1 - 28.06.2004 20:07 | 1 ошибка) Error #:-210 Unrecognized Field Name SP44164 2 ошибка) Нарушена структура данных таблицы SC37671 В конфигураторе тестирование и исправлени ИБ не помогает пишет "Непоправимая ошибка данных" Что делать - может кто посоветует???
427 2 - 28.06.2004 20:16 | уж сколько раз твердили миру..... СДЕЛАЙ КОПИЮ хотя бы битой .... чтоб разваливать дальше спокойно 210... по моему, чего то с неопознанным полем в ДБФ.... скорее всего ненормально записался ДД... В КОПИИ !!!!!!!!! посмотри, на какой файл ругается и что в этой ДБФ ке лежит какая конфа, редакция, релиз Дальше надо думать по месту...
Тупой Мля 3 - 28.06.2004 20:16 | Дык... измененные мдшники копировать в каталог базы не нуно...
ChAlex 4 - 28.06.2004 20:17 | Если не было изменения структур баз (т.е. не создавались дополнительные поля или, документы и т.п.) то это результат несоответсявтя файла 1CV7.dd текущей информационной базе. Т.е. файл переписан откуда либо, а не производилось обновление конфигурации через конфигуратор. Поэтому нужно либо найти родной файл 1CV7.dd либо править его структуру в соответствии со структурами текущей конфигурации. Можно попробовать вообще удалить его ,ПРЕДВАРИТЕЛЬНО СОХРАНИВ ПОЛНЫЙ АРХИВ БАЗЫ.
RommBoss 5 - 28.06.2004 20:26 | Убрал DD, стал писать - невосстановимая ошибка базы данных код -10, ошибка открытия словаря Базы Данных
RommBoss 6 - 28.06.2004 20:27 | а если взять DD от другой базы с такой-же конфигурацией может помочь?
RommBoss 7 - 28.06.2004 20:29 | не помогло
427 8 - 28.06.2004 20:31 | Фигня... Легкий триппер.... Справочник НазначенияИспользования в бухии 4.5 Используется в материалах для учета СпецОдежцы и спецоснастки Какой размер у этого файла? если не более 600 байт - просто перепиши его из демо конфы Если будет верещать В КОПИИ - удали файл с расширением ДД в конфигураторе - открой дерево метаданных, в самой верхней строке - правой клавишей - СВОЙСТВА, добавь пробел в название затем - сохранить конфу.... На вопрос "Сперли ДД.... Создать новый?" ответ ДА.. Реакцию сюда .....
RommBoss 9 - 28.06.2004 20:40 | Error #:-210 Unrecognized Field Name SP43270
RommBoss 10 - 28.06.2004 20:40 | конфу не сохранил
RommBoss 11 - 28.06.2004 20:42 | файл был 610 байт - это нормально?
romix 12 - 28.06.2004 20:48 | Жалко что 1С не сохраняет копии по ходу дела. Хотя, в папке new_stru она держит все файлы, которые изменила при предыдущем изменении БД. Чтобы откатиться, надо просто скопировать их в основной каталог базы. (10) Ты че, не понял, тебе сказали, сделай архив :-)
427 13 - 28.06.2004 22:15 | нда..... а копию Буратино делать будет? Если побит только один ДБФ - тогда просто убить этот файл в каталоге, затем запуститься и полная проверка через тестирование... Если бухи не вели учет спецодежды и оснастки - без последствий.... Затем через объединение взять этот справочник из дистрибутива или демы.... Если же побито много файлов - ну тогда я не Кашперовский, через телевизор не лечу.... А вообще просто еще одна жертва .... отсутствия копии.... Вазелин сходи купи в ночной аптеке - завтра понадобится.... И запомни на будущее - любая работа с базой - только после пары копий.....
Алекс 14 - 29.06.2004 08:55 | Открываешь файл .dd любым просмотрщиком с возможностью редактирования. Ищешь по поиску строку SC37671 . Должна найтись структура битого справочника. Ищешь в этой структуре поле SP44164 и удаляешь эту строку. (не просто название "SP44164 ", а именно строку). Сохраняешь .dd. , все должно заработать.
Valery 15 - 29.06.2004 09:52 | См New_ stru там резервная копия предыдущая.


Непонятная ошибка при отборе операций по значению добавленного реквизита | База знаний | mista.ru

Непонятная ошибка при отборе операций по значению добавленного реквизита

Udjin 25.06.2004 18:17 | 1С Предприятие 7.7 MS SQL версия. Создан дополнительный реквизит для операции -> <Флаг> Он особым образом заполняется. Мне необходимо отобрать операции у которых этот <Флаг>= "C". Естественно, перебирать все существующие операции в цикле и сравнивать не хочется, поэтому написан такой вот код: Опер=СоздатьОбъект("Операция"); Опер.ВыбратьПоЗначению "31.12.03", "01.02.04","Флаг","С"); Пока Опер.ПолучитьПроводку() = 1 Цикл Сообщить("Сумма " + Опер.Сумма+' '+Опер.ДатаОперации); КонецЦикла; при выполнении которого возникает ошибка: SQL State:42000 Native: 308 Message: [Microsoft][ODBC SQL Server Driver] Index 'VIA10049' on table '_1SOPER' (specified in the FROM clause) does not exist SQL State:42000 Native: 8180 Message: [Microsoft][ODBC SQL Server Driver] Statement(s) could not be prepared с последующей "Невосстановимой ошибкой базы данных" и вылетом... Что может быть за проблема, может кто подскажет?
427 1 - 25.06.2004 18:34 | индекс по реквизиту сделан?
Udjin 2 - 25.06.2004 19:07 | 427: Индекса VIA10049 для таблицы '_1SOPER' на сервере нет. Но ведь его 1С-ка сама должна была создать...
Warlock 3 - 25.06.2004 19:45 | А на реквизите стоит "галочка" "Отбор"?
Udjin 4 - 28.06.2004 16:09 | Warlock_WW: Спасибо. Да, после проставления галочки индекс появился и 1С-ка ругаться перестала. Но отбор все равно не производится... :(
Gavrila 5 - 28.06.2004 16:15 | (4)реквизит "Флаг" - тип "Строка", длина 1 ?
Udjin 6 - 28.06.2004 16:18 | (5) да
Gavrila 7 - 28.06.2004 16:23 | (6) попробуй так: Опер.ВыбратьПоЗначению(Дата('31.12.03'), Дата('01.02.04'), "Флаг", "С");
Udjin 8 - 28.06.2004 16:32 | (7) тут не с датами видимо проблема, потому как вот такая строка : Опер.ВыбратьПоЗначению ("31.12.03", "01.02.04", "Счет", СчетПоКоду("50")); отрабатывает без проблем


Загрузка БД 1С+SQL | База знаний | mista.ru

Загрузка БД 1С+SQL

usr 26.06.2004 11:41 | Какова должна быть последовательность действий по восстановлению на рабочей станции, вызгруженной БД ? Ситуация такова: исходная БД использует SQL. Выгрузка происходит ночью в пакетном режиме. Утром zip-файл перекачиваю на рабочую станцию. Есть необходимость поработать с копией БД отдельно от сервера, автономно, чтобы не изменять рабочую БД. На рабочей станции стоит сетевая версия 1С. При загрузке в конфигураторе выбираю тип SQL. Выдаётся диалоговая панель такая, как в пункте “Администрирование / Параметры базы данных SQL ”, где предлагается ввести имя пользователя, пароль и тд. Если указываю параметры рабочей БД, то начинается процесс соединения. Здесь я насильно прекращаю работу по загрузке из опасения за сохранность рабочей версии БД.
koshechka 1 - 26.06.2004 22:46 | А зачем указывать SQL ? укажи CDX и DBF файлы, и никакой загрузки не будет и рабочая база не затронется, а с копией ты будешь работать сколь тебе угодно


Терминал | База знаний | mista.ru

Терминал

KIRILOS_№1 25.06.2004 17:17 | Ктонить работает в терминале в 1с?? Как впечатления?
Матрейя 12 - 25.06.2004 22:08 | Впечатления от терминала хороши при условии: 1. На каждого активного пользователя не менее 60mb оперативной памяти. 2. Для количесва активных пользователей более 10 стоит подумать о двухпроцессорной конфигурации. 3. Лучше если используется еще и SQL сервер, но на отдельной машине. Терминал+SQL на одном сервере (даже мощном) - это извращение. 4. Отказаться по возможности от использования длинных транзакций. 5. Оперативная память сервера для обслуживания базы 1с типа ТиС на десять пользователей должна быть не менее 1 gb, процессор на уровне P4-3000
Warlock 13 - 25.06.2004 22:15 | (12)Короче, чем больше и мощнее, тем лучше и быстрее. А много и мощно - хорошо и быстро:)))
Матрейя 14 - 25.06.2004 22:23 | 13. Я предпочитаю SQL+прямые запросы, без терминала. :)


Не могу запусить 1С 8 из командной строки | База знаний | mista.ru

Не могу запусить 1С 8 из командной строки

DVS 25.06.2004 14:56 | Что-то недогоняю в чем проблема. В настройках пользователя пишу аутентификация средствами Виндов, от проверки пароля средствами 1С отказываемся командная строка имеет вид: запускаем через cmd файл для того чтобы подставить имя пользователя 1cv8.exe enterprise /SSBASE1\Demo /N%USERNAME% /WA+ SBASE1 - комп на котором стоит сервер 1С Demo - имя базы на сервере 1С при таком запуске возникает диалог 1С для выбора имени пользователя и пароля, но пароль из Виндов не подходит. Причем если запускать через диалог "Запуск 1С:Предприятия" все нормально загружается, пароль не спрашиват т.е. правильно аутентифицирует средствами Виндов
BorisG 1 - 25.06.2004 20:54 | Ключи /N и /WA взамоислючают друг друга. Либо /WA, либо /N и /P Посему... оставь только 1cv8.exe enterprise /SSBASE1\Demo И будет счастье... ибо /WA+ по умолчанию ;-)


Как перевести базу из сетевой в SQL 2000? | База знаний | mista.ru

Как перевести базу из сетевой в SQL 2000?

Олег 25.06.2004 19:21 | Как перевести базу из сетевой в SQL 2000?
Warlock 1 - 25.06.2004 19:22 | Выгрузка данных из сетевой 1C и загрузка в 1С SQL.
Warlock 3 - 25.06.2004 19:28 | 1.Делаешь в сетевой: "Администрирование/Выгрузка данных" 2.Делаешь в SQL-ной: "Администрирование/Загрузка данных" и указываешь на тот zip, что получил в п.1 3.Все Ссылка: ЖКК


Скрипт автоматичекого входа в 1С | База знаний | mista.ru

Скрипт автоматичекого входа в 1С

Danila 24.06.2004 08:51 | Можно ли написать такой скрипт, запуская который происходит вход в 1с сразу под заданным пользователем. Если да то как. Где можно посмотреть параметры запуска 1cv77.exe (т.е. опции командной строки, может там можно указать пользователя и пароль...)
aleks_ru 1 - 24.06.2004 09:08 | параметры запуска /D - каталог базы данных /N - Имя пользователя /P - Пароль пользователя /M - Монопольно
ander139 2 - 24.06.2004 09:11 | http://www.mista.ru/articles1c/tips.htm


Вопрос по перемещению списка баз | База знаний | mista.ru

Вопрос по перемещению списка баз

Danila 23.06.2004 08:52 | Создал нового пользователя в Вин2к Про, хочется список баз со старого пользователя перенести новому. Ломает список из 20 баз перепрописывать, может есть файл конфигурации... Подскажите, где этот файл лежит... Спасибо!
Тупой Мля 1 - 23.06.2004 08:54 | В реестре.
Vser1 2 - 23.06.2004 09:44 | http://www.forum.mista.ru/topic.php?id=1518 http://www.forum.mista.ru/topic.php?id=3417


Ошибка открытия базы данных | База знаний | mista.ru

Ошибка открытия базы данных

NINA 21.06.2004 22:00 | Может быть, кто-нибудь сталкивался с такой ситуацией? 1с не открывается, выдается сообщение "Ошибка открытия базы данных", а далее идут имена файлов типа ~mdNNNN.tmp, путь которых с:\windos\... Главное, что ни через "конфигуратор", ни через "предприятие", 1с не открывается? Может быть, кто-нибудь знает, как такую базу открыть?
Волшебник 1 - 21.06.2004 22:03 | что-то такое уже было.... попробуй сделать 1. переиндексацию 2. тестирование и исправление 3. удалить mlg-файл 4. переместить базу в короткий каталог 5. переустановить платформу
427 4 - 21.06.2004 23:09 | Битый МД (3) никак. Лечить надо руками без конфигуратора .....
427 5 - 21.06.2004 23:20 | (1) путь с:\windos\... указывает на темповик в каталоге виндов... в виде ~mdNNNN.tmp.... так что все 5 советов - мимо денег... P.S. покорячиться придется немало... если вообще удастся восстановить....
romix 6 - 22.06.2004 00:30 | Возможно, зашли в Windows не под тем пользователем. Попробуйте зайти под администратором. Также попробуйте запустить сканирование диска (возможно, вырубалось питание). Но сначала надо всю базу скопировать в безопасное место (сделать архивную копию, если до того как "все пропало" ее не делали).


Вопрос по автоматизации в 1С (если такое возможно) | База знаний | mista.ru

Вопрос по автоматизации в 1С (если такое возможно)

Danila 21.06.2004 10:52 | Здравствуйте! Есть необходимость делать некоторые обраюотки раз в час или раз в день, можно ли написать какой-нибудь скрипт который по расписанию ночью запускал 1С, логинися под определенным юзером и запускал нужную обработку. Если такое или подобное возможно, то подскажите что читать... Спасибо!
Волшебник 1 - 21.06.2004 10:54 | Ступай в поиск по форуму. Было неоднократно. Поищи по рубрике Администрирование. Посмотри по WSH - Windows Script Hosting. Можно завести юзера "Сервер", который не будет выключаться. Он будет запущен на сервере и по Обработке ожидания делать свое "черное дело".
SnarkHunter 2 - 21.06.2004 10:56 | Виндовым шедулером и запускай...


Порядок сортировки базы данных отличается. | База знаний | mista.ru

Порядок сортировки базы данных отличается.

lam 16.06.2004 06:44 | Проблема такая:в сети несколько машин на вин 98(с выделеным сервером на вин 2000), на одной из которых 1С не хотит запукаться. Пишит что порядок сортировки отличается.Переустонавливать вин нет желания.Вопрос, что в вин 98 нужно поправить и где?
Venture 1 - 16.06.2004 07:01 | Посмотри Панель управления - языки и стандарты -региональные настройки что было значение Русский
kаdr 2 - 16.06.2004 07:06 | Конфигуратор-Администрирование-Кодовая страница ИБ-1251 Русский...
BorisG 3 - 16.06.2004 07:08 | Какой раз за эту неделю этот вопрос возникает на форуме? Вот, например... http://www.forum.mista.ru/topic.php?id=1799 Ну и последняя... не далее, как вчера... http://www.forum.mista.ru/topic.php?id=5443
kаdr 4 - 16.06.2004 07:08 | +2 http://www.forum.mista.ru/topic.php?id=5443
lam 10 - 18.06.2004 15:48 | Прошу прощение что пришлось тему заново поднять. Дело в том что, ничего не вышло. Придеться описать проблему более подробно: после установки виндов на данном комп. кодовая страница стояла польская, еще помимо этого был установлен дополнительнный язык-казахский.Варианты: смены полькой на русскую код.стр. ничего недали и удаление казахского языка ничего недал, а так же установка казахского на другие комп., результат тот же. Вопрос где, в вин 98 можно посмотреть какая кодовая страница используется?
igorluk 11 - 18.06.2004 15:55 | "кодовая страница по-умолчанию". Найди такое словосочетание в настройках Контрол панел - Языки и стандарты. Винда должна захотеть перегрузится. а какая кодовая страница на всех остальных машинах?
igorluk 13 - 18.06.2004 16:04 | какой язык стоит абсолютно до лампочки. важно кодовая страница по-умолчанию
It is me 14 - 18.06.2004 16:33 | Еще раз: смотришь путь в (1), путь в (2), проверяешь чтобы совпадали языки, если совпадают, но все равно не работает, поставь в (2) любую другую кодовую страницу, дождись конца ее изменения, верни кодовую страницу на место и жди конца изменения. Если после этого не заработает, зови специалиста...
koshechka 17 - 19.06.2004 11:54 | при чем тут кодовая страница? у меня такое было. просто иногда юзеры, ставят вместо сетевой однопользовательскую версию и тада тоже комп ругается на порядок сортировки :) попробуй, может тебе поможет


Почему после измений в конфигураторе исчезли все данные | База знаний | mista.ru

Почему после измений в конфигураторе исчезли все данные

Zalex_UA 18.06.2004 12:31 | 1с владею хорошо, знаю конфигурирование. Но вот вчера зашел в конфигуратор и в свойствах базы изменил способ округления 1,5 руб. с 2 на 1, сделал сохранение конфигурации, она сообщила что изменения конфигурации НЕ привели к изменению данных, но вот когда я запустил программу то обнаружил, что нету практически всех данных в конфигурации, кроме в справочнике фирмы 1-ой записи и тоже практически пустой. Я в шоке как такое может быть. Натолкните на мысль. Раньше никогда не пробывал изменять этот параметр.
Gavrila 1 - 18.06.2004 12:35 | на копии: тестирование и исправление
romix 2 - 18.06.2004 12:35 | Способ округления тут не при чем. :-) Может, сработало Автовосстановление в XP? (его надо вырубать)
Zalex_UA 4 - 18.06.2004 13:05 | (1) - вопрос не в тестировании, понятно что бекап делосвятое. Вопрос в глюке! (2) - что означает автовостановление в ХР? Может ты имел в виду точку восстановления системы, так это ни при чем. Сегодня попробую на разных дистрибутивах 1с сделать тоже самое (есть подозрения). А какието- конструктивные ответы ?
gr13 5 - 18.06.2004 13:16 | (2) надо... и еще желательно прописать темповский каталог покороче... например c:\temp
romix 6 - 19.06.2004 22:41 | Про Автовосстановление можно почитать в справке Windows. Я захожу в свойства диска и выключаю эту возможность. А также Индексирование. И антивирус. Это те вещи, которые постоянно висят в памяти и лишний раз вмешиваются в файловые операции с диском. От греха подальше лучше, чтобы их не было. Посмотри также в DBF остались ли данные (визуально там видно ли чего-нибудь)?


Невосстановимая ошибка базы данных!!! Please HELP!!!!!! | База знаний | mista.ru

Невосстановимая ошибка базы данных!!! Please HELP!!!!!!

Boomerang 19.06.2004 05:25 | При перепроведении всех документов, в момент переноса остатков (в строке сообщений: "перенос остатков на 01.10.02") выскакивает окошко со страшным сообщением: "Невосстановимая ошибка базы данных. Код: -4. Таблица RG328 (ПартииНаличие). Общая ошибка ввода-вывода." Как с этим жить?
ramstar 1 - 19.06.2004 07:42 | Да никак если просто винда глючит а может чего то не того делаешь а может повреждена структура таблицы RG328 попробуй просто каким - нибудь DBF редактором посмотреть например Visual Fox PRO
SnarkHunter 2 - 19.06.2004 11:08 | Для начала запусти "Тестирование и Исправление"...
koshechka 3 - 19.06.2004 11:42 | надо просто эту таблицу перенести в другой каталог (только для того, чтобы она не пропала безвозвратно), зайти в прогу через конфигуратор, а потом пересчитать итоги. прога сама должна создать новую таблицу RG328, если этого не произойдет то действуй как написал ramstar


Использование встроенного архиватора | База знаний | mista.ru

Использование встроенного архиватора

3V 18.06.2004 07:37 | при выгрузке или сохранении данных в пофиугараторе формируется zip-файл, какими программными средствами можно использовать встроенный архиватор?
Волшебник 2 - 18.06.2004 11:46 | см. Пакетный запуск конфигуратора
Волшебник 3 - 18.06.2004 11:47 | (2)+ http://mista.ru/articles1c/hare/article.24.html
3V 4 - 18.06.2004 12:05 | Станислав, тут просто проблема не в бакапе, требуется архивировать несколько файликов из базы а не всю ее. щас с опциями покапаюсь, спасибо заранее
Волшебник 5 - 18.06.2004 12:10 | Пользуйся обычным pkzip или rar.exe с передачей параметров через командную строку.
romix 6 - 18.06.2004 12:24 | Я всегда запускаю внешний rar.exe. Только в 1С с этим подстава - надо юзать так: ////_______________________________________________________________________ Функция ЗапуститьПриложениеМодально(cmdLine) WshShell = CreateObject("WScript.Shell"); Возврат WshShell.Run(cmdLine, 1, -1); КонецФункции В cmdLine пишешь строку запуска архиватора. Функция возвращает код возврата (Errorlevel).
3V 7 - 18.06.2004 12:26 | (6)ну в принципе сейчас так и делаем, просто думали может есть вариант использовать встроенный архиватор и юзать его в разделенном режиме предприятия, а нет случаем какой либо внешней компоненты для этих целей?
romix 8 - 18.06.2004 12:33 | (7) А оно надо? Кстати, WinRar.exe тоже работает из командной строки...


Терминал расскажите чайнику | База знаний | mista.ru

Терминал расскажите чайнику

nemo1966 18.06.2004 09:49 | Хотелось бы пообщаться кто пользовал интересует несколько вопросов: 1. Будет ли работать это на модемном соединении. Сильно тормозить будет? 2. На клиенте могут выполняться другие приложения установленные на нем? 3. На сервере может работать одновременно терминал и proxy. 4. база должна располагаться на сервере с терминалом или возможно подключение sql базы на другом сервере? 5. возможно ли один клиент в терминале остальные обычным образом или все в терминале сидеть должны?
Черт 1 - 18.06.2004 10:01 | 1 Будет, но тоскливо 2 могут 3 не совсем понятно, ты хочешь модем одновременно использовать под терминал и интернет? 4 база может находится где угодно :) 5 можно
vcv 2 - 18.06.2004 10:02 | 1. Будет. Тормозить будет в зависимости от скорости модема. При фактической в 3-5 и более килобайт в секунду достаточно комфортно работает все, кроме листания длинных отчетов. 2. Да 3. Да 4. Как угодно. Рекомендуют для большего быстродействия не нагружать SQL-сервер ничем кроме самого SQL, но если нет возможности сделать два отдельных сервера (SQL и терминалов), можно все и на одном. 5. Возможно. Только путь к ИБ в 1С-ке должен быть одинаков для всех. То есть у тех, кто ходит через терминал путь не C:\..., а \\SERVER\...


Помогите дилетанту | База знаний | mista.ru

Помогите дилетанту

grir 17.06.2004 09:54 | Наверное вопрос для вас будет совсем глупый, но прошу очень не издеваться. Работаю сама в Торговле+Склад типовой конфигурации 933 на релизе 18 сетевой версии. Возникла необходимость проконтролировать клиентов. Знала, что они работают в той же типовой конфигурации, но, каюсь, даже не подумала про версию релиза. Взяла копию базы, а она у меня не открылась. Стала разбираться, оказалось, что они под SQL-версией работают. Это из-за этого их база у меня не открывается? И что можно сделать, чтобы ее открыть? Очень надеюсь на помощь!
Vser1 2 - 17.06.2004 10:04 | (0) Копию бызы SQL или выгрузку сделанную через конфигуратор? У меня проблем с переходом SQL->DBF и обратно проблем нет, правда релиз программных файлов 19 под SQL. Может и тебе нужны программные файлы взять для SQL-версии и тогда все будет тип-топ.
SiMazx 3 - 17.06.2004 10:23 | Я так понимаю, что девушка просто скопировала папку базы, а база SQL-ная... Тогда сделать ничего нельзя... Надо базу снова забирать... Но через выгрузку... В конфигураторе меню Администрирование->Выгрузить данные... А у себя ее загрузить в пустую папку в дбф-формате, меню Администрирование->Загрузить данные...


Неисправимая ошибка | База знаний | mista.ru

Неисправимая ошибка

omega2 16.06.2004 15:28 | При исправлении и тестировании базы выскакивает табло с надписью: Проверка конфигурации.. - Неисправимая ошибка. Как это можно вылечить?
omega2 7 - 16.06.2004 16:05 | Для особо "одаренных" объясняю: Что эта ошибка выскакивает тогда, когда в Конфигураторе 1с запускаешь "Тестирование и исправление ИБ" Что еще не понятно?
SnarkHunter 8 - 16.06.2004 16:06 | Да понятно все... МДшник у тебя битый...
omega2 9 - 16.06.2004 16:09 | А как его можно реанимировать?
SnarkHunter 10 - 16.06.2004 16:11 | http://www.gendin.ru/md/
Aнтон 14 - 16.06.2004 16:37 | Я знаю как исправить. Надо запустить программу конфигуратор и в падающем подокошке "Админестрированье" кликнуть на исправлении баз. В окошке ничего не менять и нажать ОК. После того, как программа потарахтит несколько минут - сделать резервную копию базы с данными. После этого всё будет работать.
gr13 17 - 16.06.2004 16:48 | (14) мдааа... а может быть лучше до? до Тестирования и Исправления? сделать копию базы?...


Ошибка при анализе изменений структуры данных | База знаний | mista.ru

Ошибка при анализе изменений структуры данных

Asmodeus 16.06.2004 16:13 | Может кто подскажет или на умную мысль наведет? Я вчера вышел на новое место работы. Захотел проверить отличия от типовой комплексной конфигурации... Вываливается вот такая штука: C:\DOCUME~1\ALLENA~1.RUP\LOCALS~1\Temp\~mg27.tmp\TypedText\CalcAlg_Number7510 Затем сабж и конфигуратор закрывается. Пробовал и в базе, восстановленной из последнего архива и в текущей - одно и то же. Даже при объединении с самим собой... Хм.. Первая часть (до Temp\) это просто путь к временной папке локального пользователя... А дальше, наверное, ссылка по структуре .md файла (только я в нем внешними средствами никогда не лазил) Это можно как-то исправить (не залезая в .md)?
SnarkHunter 1 - 16.06.2004 16:14 | 1. Укороти путь временного каталога 2. Установи релиз не ниже 21 3. Делай это под в98. Это варианты...
gr13 2 - 16.06.2004 16:16 | опять ХР?
Asmodeus 3 - 16.06.2004 16:21 | (3) Опять... Но мне, вообще, пока выделили чужой комп (я только второй день на работе) (2) Согласен по всем трем пунктам! :-) (Я только что на сайт Гендина залазил.) Только 98 мне сейчас взять негде, релиз пока не обновлял - тут ситуация несколько мутная - мне, по сути, никто не передавал дела. С одной стороны, говорят, что никто ничего не трогал, а с другой - что-то все-таки трогали, только что - неизвестно. Например, релиз комплексной - 423!! Однако, 18% НДС уже есть и т.п.
gr13 5 - 16.06.2004 16:26 | плюс ко 2- отключи автоматическое восстановление на дисках с базами
LOSS 6 - 16.06.2004 16:26 | Будет и дальше гемор с таким путём. Дельные советы дают
sheale 7 - 16.06.2004 16:31 | У тебя есть права админа на этой машине?
Asmodeus 8 - 16.06.2004 16:33 | (3) :-) (6) Насчет пути - это уже к 1С. А советы дельные - я и сам вижу... Действительно, пересел даже на МЕ - все работает... (6) А гемор, наверное, и безо всяких путей будет... Самое смешное, что я, в первую очередь, заинтересовался этой вакансией потому что сказали, что ничего не трогали и надо, как раз, не за кем-то г.. разгребать, а самому выполнить проектную работу - определиться со всеми проблемами, пожеланиями, составить ТЗ и вперед...


Кнопка Восстановить недоступна | База знаний | mista.ru

Кнопка Восстановить недоступна

?&? 10.06.2004 16:07 | в п.Администрировании- Восстановить данные недоступна кнопка Восстановить. Как лечить?
lexa 1 - 10.06.2004 16:09 | проверь права
?&? 2 - 10.06.2004 16:12 | списка пользователей вообще нет
lexa 3 - 10.06.2004 16:13 | (2) создай
?&? 4 - 10.06.2004 16:15 | на другой машине и без него все нормально работает ядро - 20 релиз, ИБ - 458 редакция
?&? 5 - 10.06.2004 16:27 | есть пользователь с правами Администратор, права полные. Проблема осталась, кнопка недоступна.
?&? 6 - 10.06.2004 16:41 | может есть файл, который отвечает за этот процесс? наподобие того, что используется для хранения списка сохраняемых файлов.


Помогите нужна программа автосохранения 1С | База знаний | mista.ru

Помогите нужна программа автосохранения 1С

Александр 10.06.2004 16:18 | Помогите нужна программа автосохранения 1С
gr13 2 - 10.06.2004 16:20 | хранитель
lexa 3 - 10.06.2004 16:22 | http://www.forum.mista.ru/topic.php?id=5289
HexSys 4 - 10.06.2004 16:23 | (0) Это наверно когда спецификацию заполняешь позиций на 1000, чтобы она сохраняла документ периодически... =)))) ...(Сорри)
Александр 5 - 10.06.2004 16:26 | (1) Это значит что на сколько я помню то в компании 1С была сделана специальная программа (не в оболочке 1С, не конфигурация) которая сохраняла автоматически в заданное время базу данных и саму конфигурацию
gr13 6 - 10.06.2004 16:34 | http://www.gendalf.ru/news/040422-001.html (5) эта ссылка к примеру, разработка Ростовского франча (насколько я знаю) именно этим и занимается
lexa 8 - 10.06.2004 17:07 | стандартный виндовый бэкап
* 10 - 10.06.2004 17:09 | http://v7backup.narod.ru/


запуск конфигуратора в пакетном режиме из VB | База знаний | mista.ru

запуск конфигуратора в пакетном режиме из VB

sam_sam 10.06.2004 16:12 | кто нибудь знает какая команда в VB запускает любое приложение, типа как ВыполнитьКомандуСистемы в 1С
lexa 1 - 10.06.2004 16:14 | http://www.forum.mista.ru/topic.php?id=5289
Черт 2 - 10.06.2004 16:27 | shell
sam_sam 4 - 10.06.2004 16:35 | меня вот эта штука очень заинтересовала AutoExchange1C.vbs
lexa 5 - 10.06.2004 16:36 | http://small.h12.ru/index.html


VB-cкрипты, обработки для 1С | База знаний | mista.ru

VB-cкрипты, обработки для 1С

Волшебник
09.06.2004 13:46 		http://small.h12.ru/index.html

------------------------------------
BatchBackup1C.vbs

Пример пакетного запуска 1С:Предприятия v7.7 (скрипт для резервного копирования баз данных 1С:Предприятия). При запуске скрипт определяет текущий день недели и осуществляет резервное копирование баз данных в папку, соответствующую этому дню недели.

------------------------------------
Processes1C.vbs

Скрипт демонстрирует возможность принудительного завершения процессов "1cv7s.exe" на всех компьютерах указанного домена. Данный код можно применять непосредственно перед пакетным запуском 1С:Предприятия, требующим монопольного входа в базу данных (например, при резервном копировании).

------------------------------------
KillProcessesSQLServer.vbs

Скрипт демонстрирует возможность принудительного завершения процессов MS SQL Server, работающих с указанными базами данных. Если у вас SQL-версия 1С:Предприятия, данный код можно применять непосредственно перед пакетным запуском 1С:Предприятия, требующим монопольного входа в базу данных (например, при резервном копировании). Примечание: иногда принудительного завершения процессов "1cv7s.exe" (см. соотв. скрипт выше) может оказаться недостаточно. Например, если SQL-база 1С:Предприятия просматривается средствами Microsoft SQL Enterprise Manager, в этот момент в неё нельзя зайти монопольно.

------------------------------------
AutoExchange1C.vbs

Скрипт демонстрирует возможность автообмена данными между базами 1С:Предприятия v7.7, входящими в распределённую базу данных, постоенную средствами компоненты 1С:Предприятия УРИБ (Управление распределенными информационными базами). Автообмен осуществляется путём пакетного запуска 1С:Предприятия в режиме Конфигуратора.

------------------------------------
sql.ert

Обработка демонстрирует возможность построения запроса к базе данных MS SQL Server средствами "ADODB.Connection" на встроенном языке 1С:Предприятия. Работает в любой конфигурации 1С:Предприятия.

------------------------------------
excel.ert

Обработка демонстрирует простейший пример вывода из 1С:Предприятия в MS Excel. Обеспечение наличия у рабочей книги единственного листа, установка размера, жирности и цвета шрифта, ширины колонок, установка рамок и заливки ячеек. Выравнивание текста ячеек, группировка строк, установка числового формата ячеек, закрепление области. Работает в любой конфигурации 1С:Предприятия.

------------------------------------
TotalBackUp.sql

SQL-скрипт для MSSQLServer2000. Скрипт осуществляет резервное копирование всех баз данных текущего SQL-сервера в указанную папку. Резервные копии запаковываются в cab-файлы. Cab-файл получает имя, состоящее из имени базы данных и текущей даты.

------------------------------------
BackUp1С.sql

SQL-скрипт для MSSQLServer2000. Скрипт осуществляет резервное копирование указанных баз данных 1С:Предприятия в указанную папку. Резервные копии запаковываются в cab-файлы. Cab-файл получает имя, состоящее из имени базы данных и текущей даты. Cab-файл будет содержать резервную копию SQL-базы (.bak), файл конфигурации 1С:Предприятия (1Cv7.MD) и файл 1С:Предприятия со списком пользователей (users.usr).

------------------------------------
SampleImportOLE.ert

Пример обработки переноса данных между информационными базами 1С:Предприятия средствами OLE-Automation. Описание методики здесь - http://small.h12.ru/import.html


Ошибка: abnormal program termination | База знаний | mista.ru

Ошибка: abnormal program termination

Sagsoft 08.06.2004 06:05 | При открытии базы выдает ошибку, в остальных базах все нормально, что можно сделать? Вот ошибка: Runtime Error! Program C:\1CV77\Bin\1cv7.exe abnormal program termination
SnarkHunter 1 - 08.06.2004 06:12 | Файл 1cv7.mlg из каталога Syslog перенеси куда-нить и будет тебе счастье...
VladZagorsky 2 - 08.06.2004 07:16 | Один из DBF-файлов у тебя "покрошился".
427 3 - 08.06.2004 07:23 | (2) при покрошенном дбф другое сообщение
spock 4 - 08.06.2004 07:30 | там еще может быть "только чтение".
SnarkHunter 5 - 08.06.2004 07:39 | Когда "только чтение" тоже другое сообщение - "Ошибка доступа к таблице"...
unior 6 - 08.06.2004 07:45 | Иногда помогает удаление каталога SYSLOG.
unior 8 - 08.06.2004 07:48 | см. http://www.sinor.ru:8100/~my1c/knowhow/err_msg.html
AlexP 9 - 08.06.2004 07:49 | (1) Файл 1cv7.mlg из каталога Syslog это журнал регистрации "телодвижений юзеров". Каким образом он поможет при такой ошибке. (0) У тебя действительно разрушились DBF-файлы в базе, это происходит если юзеры часто некорректно вываливаются из базы, а базу никто не индексирует. То что у тебя нет архивной копии, это очень погано, придется DBF-файлы ремонтировать вручную (как это сделать не знаю, не спец) и не факт, что получится. Как вариант можешь попробовать скопировать каталог с базой в другой каталог, загрузить копию в конфигуратор и если у тебя это получится, то запусти "Проверка и исправление ИБ". Может тебе и повезет.
Shadal 11 - 08.06.2004 07:58 | Всё это фигня. Это произошло у тебя из-за того что не устойчивое напряжение в сети. И на хабе не стоит бесперебойник. В соответствии с этим у тебя ошибка в реестре виндов. Самый лёгкий простой и надёжный способ избавиться это скопировать (не перенести!!!) базу в другое место. И всё будет работать :-). Пожалуйста!!!
cardy 13 - 08.06.2004 08:03 | Попробуй запустить NDD или ScanDisk - мне обычно помогало в таких случаях
427 14 - 08.06.2004 08:05 | (9) еще раз - для .... ну непонятливых... При покрошенном ДБФ выдается достаточно ясная диагностика с указанием имени файла... "Файл 1cv7.mlg из каталога Syslog это журнал регистрации" - да, это журнал регистрации. И иногда в нем в конце ошибка - недостает толи ВК, толи ПС... толи обоих символов вместе... Полечить его просто, еще проще - удалить... В первый момент 1с лезет туда прописать запуск .... и нарывается .... Но при этой ошибке в млг именна такая реакция 1С - она падает... Фича у нее такая... Странная...


Выгрузка из DBF в SQL | База знаний | mista.ru

Выгрузка из DBF в SQL

graf 08.06.2004 11:47 | Выгрузил данные из базы данных фортата DBF в архив, через Администрирование -> Выгрузить данные. Затем загрузил из архива в базу данных формата SQL. Перестали строиться отчеты, сообщает, что "The coloumn prefix 'SC 33' does not match with a table name or alias name used in the query". SC 33 - это НОМЕНКЛАТУРА.
SiMazx 7 - 08.06.2004 12:39 | Вылетает на конкретных отчетах? В конкретных местах? Отладчиком прошел-посмотрел? Сообщение говорит о том (насколько я понял), что либо глюк в структуре таблиц, либо глюк в запросе отчета... Первое определяется тестированием (дбф, затем скл), второе... смотреть запрос надо...
graf 8 - 08.06.2004 12:55 | Да вылетает на одном конкретном отчете. Отладчиком не проверял. Еще выдавал ошибку при выполнении: "Операции -> Проведение документов", теперь просто закрывает 1С. При Выборе: "Администрирование -> Тестирование и исправление ИБ", сообщает: "Проверка конфигурации... - Неисправимая ошибка." Вгрузил из SQL в DBF, работает как надо. Че за х..ня не пойму.
graf 15 - 08.06.2004 13:35 | Стал тестировать старую копию DBF там тоже при Выборе: "Администрирование -> Тестирование и исправление ИБ", сообщает: "Проверка конфигурации... - Неисправимая ошибка." При выборе или удаление пункта из списка проверки все одно...
SnarkHunter 17 - 08.06.2004 13:36 | Дык... У тебя мд-шник битый что ли...
graf 18 - 08.06.2004 13:38 | Похоже на то, до меня тут другие программеры сидели, я в этой базе токо начал возиться.
iceTiger 19 - 08.06.2004 15:12 | Если при тестировании базы ДБФ вылетает "Неисправимая ошибка" вообще непонятно как она под SQL пыхтит. Как шаманство можеш попробовать найти на каком файле слетает тестирование (перед сообщением о неисправимой ошибке должно быть написано имя файла типа), открыть его (хоть тем-же DBU.exe), и визуально проверить на мусор. (перед этим пробекапится раз 5-ть) Хотя это из разряда нейрохирургии. И пользователей на такую базу я бы садить не стал...
romix 20 - 08.06.2004 15:40 | Сделай бэкап (всю папку копирни куда-нибудь). У тебя ск. всего попорчено соответствие файлов DBF и DD. Можно попробовать восстановить (откатить) изменения конфигурации, скопировав все в базу из New_stru. Если не поможет, то надо вручную смотреть таблицы, на которых ошибка, и их описание в файле DD. А может, в системе права какие на доступ к файлам не те стоят. Перед загрузкой в SQL никаких ошибок в базе DBF/DD, безусловно, не допускается.
SnarkHunter 22 - 08.06.2004 15:42 | Если бы не было соответствия - база вообще бы не загружалась...
romix 23 - 08.06.2004 15:49 | (22) При старте вроде нет проверки всей базы... Она стартует, но глючит в неожиданных местах (если я ничего не путаю).
romix 25 - 08.06.2004 16:41 | (24) Попробовал в пустой базе создать два разных справочника. Скопировал DBF одного справочника в другой. 1С это съела. Все отлично - работа продолжается. Запускаю тестирование и исправление - "Таблица - SC12. Не сходится количество полей Проверка физической целостности таблиц ИБ. Неисправимая ошибка.". Так что 1с не особо проверяет что-либо при старте и во время работы.


Как создать DD-файл? | База знаний | mista.ru

Как создать DD-файл?

kаdr 08.06.2004 10:28 | Господа! Имею конфигурацию Торговля и склад. Отстутствует файл 1Cv7.DD. Видимо по этому при загрузке вылетает с ошибкой: Код -10. Ошибка открытия словаря базы данных. Как создать DD-файл?
Gavrila 2 - 08.06.2004 10:30 | Открыть конфигурацию, добавить константу, удалить константу, сохранить конфигурацию, на вопрос "Отсутствует словарь данных, создать?" нажать "Да" :)
SnarkHunter 6 - 08.06.2004 11:03 | Извращенцы... В конфигураторе загрузи свой же МДшник как изменный... Ничего менять не нужно...


Проблема с сервором терминалов. | База знаний | mista.ru

Проблема с сервором терминалов.

D01
12.05.2004 17:21 		Как узнать из 1С как запущена программа, через терминал или локально?
Gavrila
2 - 12.05.2004 17:28 		штатными средствами нияк, а не штатными V7Plus ВерсияОС
D01
3 - 12.05.2004 21:28 		Спасибо, попробую через V7Plus
Gavrila
5 - 12.05.2004 22:32 		(4)
На 98(SE) - Microsoft Windows 98 A
На NT4 - Microsoft Windows NT version 4.0 Service Pack 6 (Build 1381)
Думаю что по ключевым словам можно попробовать понять что за ОС-система, ну там дальше по обстоятельствам :))
Gavrila
7 - 13.05.2004 10:12 		(6) если сидишь в терминале (не важно что у тебя стоит локально), то вернется ВерсияОС терминала, т.к. 1С-на реально работает в терминале (грубоватое пояснение конечно:)). Естесственно предложенный вариант не есть универсальный...
mszsuz
8 - 13.05.2004 10:20 		Можно анализировать "переменные окружения" ч/з SET, н-р SESSIONNAME.
Роман
10 - 07.06.2004 09:30 		Тут я смотрю все настоящие эксперты мне довас далеко.
Но я попробую предложить функцию ИмяКомпьютера() если имя сервак то наверно ты в терминале ну у некоторых возможен вариант что ты прям на сервере:).
DimG
11 - 07.06.2004 09:35 		wshShell=createObject("wScript.shell");
РабочееМесто = wshShell.expandEnvironmentStrings("%CLIENTNAME%");
РабочееМесто = ?(РабочееМесто = "%CLIENTNAME%", shShell.expandEnvironmentStrings("%COMPUTERNAME%"), РабочееМесто);

Вот примерчик, возвращает или имя компутера или имя терминала


Как дистанционно кикнуть юзера ? | База знаний | mista.ru

Как дистанционно кикнуть юзера ?

stalker_kz 07.06.2004 13:45 | Вопрос следующий. У меня сетевая 1с, все компьютеры установлены по разным комнатам. Очень неудобно бегать и просить всех выйти из программы когда мне необходимо запустить ее монопольно или выключить сервер. Можно ли администратору предупреждать и при необходимости отключать пользователей сети дистанционно, и безопасно для программы, с сохранением и закрытием их текущих документов (над которыми они работают в момент отключения).
Gavrila 1 - 07.06.2004 13:52 | через 1С - Чат(7.7).ert средствами сервака - ищи на форуме, уже об этом говорилось
SiMazx 3 - 07.06.2004 13:53 | На http://www.1c.hippo.ru/ есть куча выгонялок... Из тех, что попроще - в разделе остальные - чат+выгонялка... Понавороченее - в разделе универсальные - Admin1C+ВК...
SiMazx 4 - 07.06.2004 13:56 | На крайняк сам напиши - ключевое слово - ЗавершитьРаботуСистемы()... Модальные окна по таймауту закрывай... Не без косяков... Но обычно хватает и этого...


проблема с открытием базы. Need help!!! | База знаний | mista.ru

проблема с открытием базы. Need help!!!

AndrewZ 04.06.2004 19:34 | При открытии рабочей базы, возникает ошибка runtime eror Program C\programe files\1CV77\BIN\1CV7S.EXE abnormal program termination Что делать?? как спасти базу? резервной копии нима(((
AndrewZ 1 - 04.06.2004 20:11 | есть утилиты для восстановления поврежденной базы???
427 2 - 04.06.2004 20:16 | есть.... драйвер Руки.Sys в комплекте с программой Мозги.ехе .... Скопируй куда нибудь каталог Syslog и убей его в базе .... после этого попробуй запустись.. P.S. Специально для дятлов ..... Больших дятлов, у которых "резервной копии нима".... Сделай две... не... лучше три копии.... И ПРоБУЙ В КОПИИ....
igorluk 3 - 04.06.2004 20:22 | Попробуй перенеси куданить syslog


Переиндексация при запуске... | База знаний | mista.ru

Переиндексация при запуске...

Snejok 04.06.2004 11:33 | Привет всем, возникла пролема: при запуске 1С Торговля и склад постоянно приходится переиндексировать программу. Нормально ли это? С чем это может быть связано? В базе по сети работает около 10-15 человек. Заранее спасибо
lexa 2 - 04.06.2004 11:39 | http://www.forum.mista.ru/topic.php?id=5086
kаdr 3 - 04.06.2004 11:43 | Ненормально. Связано с некорректным выходом из программы
lexa 4 - 04.06.2004 11:45 | (3) не факт, если база лежит на разделе NTFS
lexa 9 - 04.06.2004 12:18 | 8+ хотя пробовал на 2003, на котором все, что можно отключено и после cjyfignt ( спасибо BorisG), а на ноутбуке с ХР пример срабатывает а то я уже начал думать, что у меня склероз (чего вдруг автоматически загружаю откопированную базу в монопольном режиме)
lexa 10 - 04.06.2004 12:19 | не cjyfignt а confignt
Snejok 11 - 04.06.2004 13:08 | так, по-порядку, даза лежит на Win 2000 server, все работают под win 2000 пользователи квалифицированные, выходят из программы вроде правильно... да, на сервере NTFS неужели из-за этого каждый день такой глюк происходит?
lexa 12 - 04.06.2004 13:27 | (11) попробуй отключи службу восстановление системы и индексирование, создай в корне любого диска папку TEMP и переадресуй переменную среды TEMP на нее, и посмотри http://1c.alterplast.ru/faq/saved.html
lexa 17 - 04.06.2004 13:52 | (13)(15) опять был не внимателен, хотя посмотри в службах(сервисы) если запущены останови (14) панель управления - система - дополнительно - кнопка "переменные среды" и на сервере и на остальных машинах тоже
Snejok 18 - 04.06.2004 14:06 | lexa, а, ага... вижу.. значит, должно помочь...а вот по сути, индексация-то ведь для чего-то важного нужна... какие проблемы могут возникнуть после отключения?
lexa 19 - 04.06.2004 14:14 | (18) наверное да, зачем не скажу точно - вроде бы для поиска
Snejok 21 - 04.06.2004 14:16 | lexa,а поиска чего? или где можно найти что-нибудь по этому вопросу, не знаешь?
lexa 22 - 04.06.2004 14:18 | посмотри описание службы (посмотрел и сам типа для быстрого доступа к файлам)


ошибка при загруке данных из DBF в SQL в конфигураторе 1С | База знаний | mista.ru

ошибка при загруке данных из DBF в SQL в конфигураторе 1С

Mish154 03.06.2004 13:14 | В момент загрузки данных, в середине процесса в конфигураторе вылетает сообщение "SQL State: 23000 Native: 1505 Message: [Microsoft][ODBC SQL Server Driver][SQL Server]CREATE UNIQUE INDEX terminated because a duplicate key was found for index ID 2. Most significant primary key is ' 9H '. SQL State: 01000 Native: 3621 Message: [Microsoft][ODBC SQL Server Driver][SQL Server]The statement has been terminated." В строке состояния при этом стоит "Coздaниe индeкcoв тaблицы: Cпpaвoчник Пpoeкты ..." Должен сказать что загрузку я пытался проделать на двух разных серверах в обоих случаях одна и та же ошибка. Помогите, плз. разобраться. С уважением! Михаил
SnarkHunter 1 - 03.06.2004 13:37 | Чего тут разбираться... Тебе же английским языком говорят - обнаружен дубль уникального индекса... Тестирование/Исправление своих дбфок сделай...


Трабла с запуском 1С :-( | База знаний | mista.ru

Трабла с запуском 1С :-(

ФАКОэмульсификатор 01.06.2004 19:59 | Привет всем. Надеюсь не оставите в стороне. Есть типа сервер под ХП, на нем лежат базы 1С. Есть пару пользовательских машин под вынь 98. Запускаем 1С у пользователя - все рулит. Выходим и пытаемся войти еще раз - труба, зависает. Когда перед вторым запуском смотрю процесы - вижу, что от первого запуска в памяти висит процес 1С. При связке сервер 98 + клиенты 98 такой проблемы не было, была другая - кол-во одновременно открытых файлов. Как быть, почему остается процес? Заранее благодарен.
ФАКОэмульсификатор 3 - 02.06.2004 10:16 | Внешние компоненты не использую. to(2) что за сохранение системы Вы имели ввиду? Подобная лажа появилась только при связке ХП+98.
SiMazx 4 - 02.06.2004 10:18 | Смотри: http://www.sinor.ru/~my1c/knowhow/XP&1C.htm
ФАКОэмульсификатор 5 - 02.06.2004 10:23 | to (4) Буду пробовать. А не влияет ли на работу 1С длинный путь ко временной директории типа Doc&Settings\бла-бла\TMP?
SiMazx 8 - 02.06.2004 10:32 | Короч, что-то вроде D:\Temp - оптимально...
lexa 12 - 02.06.2004 10:42 | останови на ХР службы восстановления системы, индексация, в свойствах диска отключи кэш, измени переменную среды TEMP на более короткий путь(8), зашаренную папку с ИБ подключи как сетевой диск и путь к ИБ измени на путь через сетевой диск
ФАКОэмульсификатор 15 - 02.06.2004 13:01 | И снова привет! Только от заказчика. Проблема решена с помощью следующего рецепта: 1. Отключено востановление системы 2. Отключено кеширование дисков 3. В качестве временной директории прописано c:\tmp Большое СПАСИБО всем за помощь.


Вываливается периодически 1С с ошибками о невозможности записать файлы??? | База знаний | mista.ru

Вываливается периодически 1С с ошибками о невозможности записать файлы???

MikeStav 27.05.2004 10:17 | Ситуация следующая есть 2 сервера, работающих как файл серверы на одном около 40 баз (ЗиК, бухгалтерия, производство) и на втором около 5 баз. Периодически некоторые пользователи отваливаются - 1С ругается то на невозможность записи временных файлов, то индексов и в конце концов отваливается. Сетка 100 Мбитная на циске (мониторили - проблем вроде нет) Сервер - 2003 P4 2 Ггц, 2Гб памяти зеркальный рэйд на Seagate-ах 80 Гиг. принтеры НР Вроде и грешить не на что а все равно отваливаются пользователи, причем далеко не все а лишь некоторые.
SnarkHunter 1 - 27.05.2004 10:20 | Терминал вас спасет...
KALEX 2 - 27.05.2004 10:26 | На всех 45 базах отваливаются?
MikeStav 3 - 27.05.2004 11:24 | to (2) да нет только на некоторых и более того не у всех пользователей.
Макс 4 - 27.05.2004 11:36 | (3) Часто непонятные проблемы такого рода решались удалением файлов в пользовательском каталоге.
MikeStav 5 - 27.05.2004 11:37 | т.е. просто забить все файлы и все?
KALEX 6 - 27.05.2004 11:39 | На клиентах какая винда? И еще временные файлы потереть надо попробовать.
MikeStav 7 - 27.05.2004 11:41 | клиенты 2000 отваливаются какие именно файлы потереть следует?
lexa 8 - 27.05.2004 11:44 | Порробуй изменить имена проблемных пользователей
MikeStav 9 - 27.05.2004 11:45 | Изменить имена в 1С? или в домене?
lexa 10 - 27.05.2004 11:49 | в 1С и проследи, чтобы доменные юзера не заходили одновременно на разные машины (когда один юзер домена заходит в 1с с разных машин начинаются тормоза и глюки, почему не знаю - "спецы" конечно скажут про кривые руки)
MikeStav 11 - 27.05.2004 11:51 | Да не заходят вроде бы
lexa 12 - 27.05.2004 12:18 | а имена менял?
MikeStav 13 - 27.05.2004 12:39 | поменял - буду ждать результатов
MikeStav 14 - 27.05.2004 16:37 | Не помогает :((( Видмо все-таки дело в чем-то другом Может еще кто что посоветует?
Valery 15 - 27.05.2004 16:43 | Если не может записать TMP скорее всего не хватает места на дисках на рабочих станциях
MikeStav 16 - 27.05.2004 16:48 | Да хватает всего - причем ругается не только на tmp ругается и на невозможность записи других фалов - в т.ч. dbf Вываливается иногда ошибка -4 и - 5
MikeStav 17 - 27.05.2004 16:49 | и кроме того ругается на невозможность записи по сети а не на локальной машине :(
Черт 18 - 27.05.2004 16:51 | Путь к TMP?
Евгений 19 - 27.05.2004 16:55 | У меня было нечто подобное, когда файл справочника номенклатуры превысил 800МВ. Пришлось переходить на SQL.
Valery 20 - 27.05.2004 16:58 | но временные файлы создаются на локальной машине. значит не сеть
MikeStav 21 - 27.05.2004 17:20 | это смотря куда прописаны пути в каталоге пользователя у меня туда же где и база - т.е. на сервак. объемы баз не слишком большие.
Crystalizer 22 - 27.05.2004 17:25 | ограничение на кол-во открытых файлов? %)
MikeStav 23 - 27.05.2004 17:42 | Где - на сервере? на 2003 думаешь есть?
lexa 24 - 27.05.2004 17:47 | посмотри http://www.mista.ru/articles1c/admin1c_w2k.htm может поможет
MikeStav 25 - 27.05.2004 17:53 | вот тока недавно вывалилась со следующей ошибкой "Общая файловая ошибка при доступе к файлу \\fin-buhserver\PKP.1C\Buh\1SBDB\1cv7.md\sublist\sublist_Number132"
lexa 26 - 27.05.2004 18:07 | а сервер через дефис и папку с точкой обязательно было обзывать?
cooler 29 - 27.05.2004 20:34 | Попробуй пути временных файлов сделать покороче (например c:\temp)и локально. я где то слышал, что некоторые программы глючат, если путь к TMP прописан в Documents and Settings\...\...\temp.
MikeStav 30 - 28.05.2004 10:14 | to (427) не знаю насчет дефиса - но больше полгода работало все и намана - а теперь оказывается оно не могло работать пути конечно можно попробовать перепрописать но ошибки то вываливаются не только доступа к временным файлам например смотри пост (25)
lexa 31 - 28.05.2004 10:43 | а 2003 давно стоит? у меня проблемы были пр изменении конфигурации с клиента, попробуй отключить индексирование, кэширование и воостановление
denis_12 32 - 28.05.2004 10:48 | а если проверить целостность файла 1cv7.md и вообще винты на предмет наличя бэдов
MikeStav 33 - 28.05.2004 10:57 | Да уже с полгода стоит и в принципе не было проблем - но с какого-то периода начались - трудно даже точно сказать когда. Я поотключал на паки с базами - но результатов пока нет. Кстати проблем с изменением конф нет.
MikeStav 34 - 28.05.2004 10:58 | чем проверить целостность md? тестирование базы проводил - все нормально. насчет бэдов посмотрим
denis_12 35 - 28.05.2004 11:01 | примерно такое было при битом 1cv7.md. тем более путь в (25) явно указывает на него
lexa 36 - 28.05.2004 11:02 | а квотирование, права доступа и разрешения смотрел? попробуй папку с базами подключить как сетевой диск на краяйняк слей временно все на 1 сервак, а второй переставь
denis_12 37 - 28.05.2004 11:05 | чем проверить целостность сейчас не скажу. сам факт можно найти сделав поиск символьной строки по всей конфигурации, если поставить все галки в "Искать в..."
MikeStav 38 - 28.05.2004 11:47 | права доступа, квотирование и разрешения смотрел - все нормально сетевой диск подключал - не помогает. вот насчет битости проверить бы
lexa 39 - 28.05.2004 11:49 | а какой размер md
MikeStav 40 - 28.05.2004 11:54 | около 12 Мб
MikeStav 41 - 28.05.2004 11:55 | Думаю все таки и не в битости md дело, хотя конечно проверить не помешало бы
lexa 42 - 28.05.2004 11:59 | т.е. у тебя только на одной базе отваливаются несколько юзеров?
romix 43 - 28.05.2004 12:03 | Обычно если такие глюки то в настройках папки вырубают индексирование и автовосстановление. По хорошему надо ставить либо терминал либо SQL - а с файлами DBF по сети всегда что-нибудь происходит...
MikeStav 44 - 28.05.2004 13:56 | да с терминалом все понятно да и с SQL тоже - хотя пользователей в базе не больше 5 так что тогда надо даже для 2-3 пользователей ставить SQL и терминал - накладно однако, особенно если учесть что покупать тоже по идее надо софт. Глюки идут на нескольких машинах на 4 базах остальные нормально работают.
427 45 - 28.05.2004 14:17 | Я и говорю... что дефис - это куня.... На самом деле тормоза в двух палках впереди... увы, так работает этот механизмЪ... Если под этим же пользователем работают с другой машины нормально - тогда рой сетку, сетевухи... винды, дрова, антивиря и прочую хрень ... т.е. внешнее окружение... Если тоже начинает валиться - просто создай новых юзеров и все ....
Рустам 46 - 01.06.2004 21:51 | Проверить MD на целостность можно программой "Soaron's MD Diagnostic Wizard" по этой ссылке: http://1c.realnet.ru/soaron/mddiags.htm Похоже проблема именно в битом MDшнике.


Ошибка загрузки данных | База знаний | mista.ru

Ошибка загрузки данных

maloy 1 - 01.06.2004 03:49 | Типа, наверное, нет. Речь идет, я так понял, о восстановлении данных из архива. Открой архив в каком-нибудь WinRar'е и потестируй. Если архив битый, то шансов у тебя немного.
DAY 2 - 01.06.2004 04:16 | WinRar пишет "ошибок не обнаружено"
427 3 - 01.06.2004 06:28 | Архив мог быть многотомным... Винрар в этом случае не ругается ....
DAY 6 - 01.06.2004 13:49 | Файл с MD полностью менял.Ошибка та же.
cooler 7 - 01.06.2004 22:05 | Встречалось мне нечто подобное. База выгружается, а назад никак. В общем там оказались попорченные данные в DBF (поле тип число, а вместо чисел буквы). Вручную поправили и заработало.


Как исправить ошибку -210? | База знаний | mista.ru

Как исправить ошибку -210?

Таня 2 - 01.06.2004 12:23 | изменила в Приходном кассовом ордере код с Текстового на числовой, при запуске программы выдает ошибку -210
Таня 3 - 01.06.2004 12:28 | В приходниках нумерация сбилась, после 0000113 выдает номер 10.
BorisG 4 - 01.06.2004 12:34 | Ну... наверное не только это зацепила... ;-)) Ошибка 210 - Неопознанное имя поля
Press 12 - 01.06.2004 13:03 | (11)Судя по молчанию, дело обстоит иначе. Сделай тестирование и исправление, посмотри на что сругнется(про копию не забудь).
Таня 13 - 01.06.2004 14:27 | просто тестирование выдало, что несовпадение каких-то имен полей. и неисправимая ошибка базы данных Сделала только одну реиндексацию с исправлением и больше ошибок не выдает.


Удаленное управление 1с | База знаний | mista.ru

Удаленное управление 1с

Timur
03.05.2004 11:30 		Задача-магазин находится в другом городе - главный директор хочет их контролить по полной то есть отчеты смотреть
Решение мое - коннект по телефонной линии и удаленный раб стол и или радмин или терминал -- все бы ничего - работает но скорости -- маловато -- телефония:(
Есть ли решение данной проблемы через инет --быстрее хочется и как это на безопасности скажется?
Заранее спасибо
Просьба объяснять все поподробнее:)
GrayT
1 - 03.05.2004 12:14 		А инет опять же через телефон?
Dionisious
2 - 03.05.2004 12:17 		ИМХО Через УРИБ вроде будет лучше.
GrayT
3 - 03.05.2004 12:22 		Это если RealTime не нужон. А он кстати нужен?
Timur
4 - 03.05.2004 13:34 		инет выделенный - летает
реал тайм нужон обязон
что такое УРИБ ?
BorisG
5 - 03.05.2004 13:41 		Есть решение через Интернет... VPN называется...
Можно УРБД... это не реал... но для отчетов сгодится...
Только лучше спецов пригласи...
Timur
6 - 03.05.2004 14:05 		Только что с совещания - задача изменилась:(
По модему уже не катит им видети ли он лайн нужен:(
Смысл такой - есть два магазина в разных городах- номенклатуру ввели в одном и она перешла в другой:( расстояние 200км(между магазинами) выделенка мощьная есть решение онлаин 1с через инет?
Timur
7 - 03.05.2004 14:07 		BorisG
Что такое VPN ссылочку для чтения дай - мне очень очень надо -профессионалов звать не охота-- сам попробую посмотрю почитаю
427
8 - 03.05.2004 14:12 		VPN - virtual private network

Лучше все таки хотя бы на первый раз пригласить спеца - он поставит и заодно научит (только об обучении с ним договориться надо)...

С налета этот пласт ты не поднимешь... А там еще защиту надо по полной строить... ибо это выход в инет ... в котором полно грамотных идиотов ....
Timur
9 - 03.05.2004 14:16 		Насколько опасно это через?
Timur
10 - 03.05.2004 14:32 		Только что читал про VPN этож не так и сложно-- зачем меня пугал то?
Я оказывается это же самое дома делал:) только не знал как называется:)
но советы всетаки жду
Всем спасибо
cardy
11 - 03.05.2004 14:48 		Была подобная проблема, правда магазины были в одном городе, но нужен был он-лайн (т.к. склад был общий у обоих магазинов). Проблему решили так- поставили модемы ASDL, удаленный магазин работает в терминальном режиме. Скорость линии 1 Мб, на 1,5 Мб шли потери пакетов. Все работает без проблем. Правда через пару дней после установки из за скачка напряжения сгорел один модем. Модем поменяли и подключили его через APS.
Правда не знаю - 200 км они потянут или нет?
BorisG
12 - 03.05.2004 14:52 		(11) Да хоть через все страну. Для терминала за глаза хватает 64К.
Только ты путаешь выделенку физическую с каналом ТЧ.
cardy
13 - 03.05.2004 14:55 		Что есть канал ТЧ?
И если модемы потянут- почему не сделать также?
Timur
14 - 04.05.2004 11:35 		то есть по идеи скорости выделенки хватит для работы да?
Timur
15 - 04.05.2004 11:38 		заранее извените ASDL через инет работает или по телефонной линии?:)
что такое APS ?
cardy
16 - 06.05.2004 08:39 		ASDL - это модемы такие, они работают по телефонной линии. Точные подробности не скажу, суть в том что линия свободна для разговора и на этой же линии компы общаются. Правда гемор что вы в разных городах. У нас пришлось ставить 4 (!!!) модема. Схема такая- один модем в одном магазине, второй в электросвязи, т.е. по телефонной линии сигнал идет до электросвязи, и вторая пара модемов- второй магазин и электросвязь. И в электросвязи модемы соеденины можду собой. Подробнее не скажу, так как сами модемы нам спецы из электросвязи настроивали.
APS- это бесперебойник, такая прямоугольная штука, когда свет выключают он держит напряжение еще некоторое время.
Timur
17 - 06.05.2004 19:26 		какая скорость передачи ? Хватит ли ее для постоянной связи в 1с?
lexa
18 - 06.05.2004 19:51 		Если между магазинами есть документооборот то не все так просто. Наверняка директор не захочет, чтобы в удаленном магазине видели документы и остатки по центральному. В случае с терминалом если проблемы со связью хотя бы у одного из магазинов, то удаленный не сможет работать. В принципе УРИБ вполне подходит, если не нужен он лайн. Можно организовать автообмен каждые 15 мин. Трафик небольшой. Если связи нет, то удаленный магазин работает. Только в начале опредились, что нужно:
- единая база у двух магазинов;
- или достаточно свежая копия удаленного;
- или он лайн доступ к удаленному магазину.
Автообмен организуется через элект. почту. В принципе сам все сделать можешь.
А терминал если раньше не настраивал, то спеца надо.
lexa
19 - 06.05.2004 19:53 		Урибд смотри здесь http://www.mista.ru/articles1c/urbd.htm
BorisG
20 - 06.05.2004 20:16 		(16) "APS- это бесперебойник"
Да... все буквы перепутали... ;-)

Правильно:
"Бесперебойник" - Uninterruptible Power Supplies (UPS),
А АРС, или American Power Conversion - фирма, владеющая значительной частью рынка этих источников ;-)
rick
22 - 06.05.2004 21:39 		Собственно занимаюсь аналогичным вопросом и могу сказать следующее:
для организации связи типа склад-магазин в условиях среднестатистического российского города(городов) реально использовать два варианта:

1) ADSL подключается на существующей телефонной линии - линия между АТС и модемом абонента, подключение стоит около 3000+18% руб. Модем, например Zyxel Prestige 645R (или M), примерно 150$, но можно и другой (см. каталоги ADSL модемов).
2) SHDSL, соединяется АТС и модем абонента, например Zyxel Prestige 782r (300$), только уже не на имеющейся у абонента телефонной линии, линию (медную пару) придется у провайдера услуг подключать (примерно 7200+18% руб. за подключение).

В обоих вариантах организуются две линии АТС-офис и АТС-магазин, то есть расходы умножаются на 2. Остальные коммуникации - забота провайдера. Естественно, ежемесячная оплата трафика. Есть еще момент - не всегда на атс имеются свободные adsl порты, и тогда приходится использовать 2 вариант. Еще рекомендую в качестве провайдера использовать ГТС, ибо в конечном счете почти все коммуникации в городе принадлежат ей, субпровайдеры просто арендуют их.
cardy
24 - 07.05.2004 10:07 		(18) вообще мы эту систему и делали что бы были видны остатки по обоим магазинам.
Насчет проблем со связью: если не считать того что на второй день вылетел модем из-за скачка напряжения, то можно сказать что их не было вообще. То, что иногда забывали включать модемы - не считается (хотя часто такое бывало). Так что система вполне надежна. Уже где-то полгода прошло, если не больше (не помню точно когда настраивали) и все без проблем.
тимур
25 - 15.05.2004 11:25 		короче лучший выбор- ADSL модемы да?
DVS
28 - 27.05.2004 08:21 		(12)цитата "Для терминала за глаза хватает 64К."
скажите пожалуйста, а этой скорости хватит для скольки пользователей, нигде не могу найти четкой информации. У нас 2003 сервер терминал, какой ширины должен быть канал чтоб одновременно смогли работать 7 удаленных пользователей.
AlexDash
29 - 27.05.2004 10:26 		У меня три магазина - 1й - сервер 2003(В роли терминал-сервера),
остальные 2маг - клиенты на выделенных линиях до 1го, оборудование - 4 SHDSL модема AVIV (смотрите на www.converter.ru)- каждый по $160, но доставка у них (до Новороссийска) за каждый по 750р :(
у всех Term.клиентов ещё висит локально принтер и сканер шк.+ стоят карты ACECOP для удаленного видеонаблюдения.
И всё это работает.
P.S.> Один раз заказать прокладку выделенки (у нас 8000р) дешевле, чем постоянно платить ГУСУ за ADSL (IMHO)
DVS
30 - 27.05.2004 10:48 		Мои пользователи в других городах, вот я и пытаюсь выяснить какую полосу мне заказывать необходимо, предлагают 64, 128 и 256, но цены :-(, собственно вопрос 128 на скольких пользователей хватит, чтоб неочень тормознуто было.
Dok
31 - 27.05.2004 17:42 		(29) а какую версию 2003 сервера лучше использовать Standart или Enterprise для терминал севера?
Можно ли использовать одну общую базу для всех магазинов с разбивкой по складам, если все маг. в разных городах.
alxkorvin
32 - 27.05.2004 18:25 		(28) Для 7 пользователей будет достаточно канал 202Kb
DeiMos
33 - 28.05.2004 17:31 		Заказывай 128Кбит
shura
34 - 28.05.2004 18:05 		Не забывайте, что ADSL на сколько я знаю асинхронный.
И для работы очень критичны задержки. Если в другом городе разные провайдеры, то пакет может идти через пару десятков маршрутизаторов. А для работы критична не столько скорость, сколько задержки пакетов и их потери.
Для примера могу показать нашу трассировку: на фабрике один провайдер, на офисе - другой. Расстояние 10 км. У нас выделенка 2 Мб, на фабрике - 256 кБит.

>tracert -d х.х.х.х

Трассировка маршрута к х.х.х.х с максимальным числом прыжков 30

1 <1 мс <1 мс <1 мс х.х.х.х
2 2 ms 2 ms 2 ms х.х.х.х
3 4 ms 4 ms 4 ms х.х.х.х
4 5 ms 4 ms 4 ms 213.59.159.17
5 5 ms 5 ms 5 ms 213.59.159.1
6 6 ms 5 ms 5 ms 195.161.157.113
7 190 ms 88 ms 90 ms 217.106.23.17
8 89 ms 93 ms 88 ms 217.106.7.21
9 85 ms 96 ms 83 ms 217.106.6.166
10 91 ms 79 ms 85 ms 146.188.66.49
11 85 ms 90 ms 79 ms 158.43.188.1
12 79 ms 87 ms 82 ms 158.43.254.149
13 81 ms 85 ms 79 ms 158.43.233.242
14 90 ms 87 ms 89 ms 146.188.7.222
15 129 ms 118 ms 121 ms 146.188.7.30
16 120 ms 120 ms 120 ms 146.188.11.229
17 123 ms 125 ms 125 ms 146.188.7.78
18 148 ms 151 ms 150 ms 146.188.68.122
19 185 ms 178 ms 164 ms 217.150.41.233
20 176 ms 183 ms 168 ms 80.237.11.36
21 195 ms 190 ms 179 ms 80.237.11.190
22 123 ms 126 ms 125 ms х.х.х.х
23 195 ms 212 ms 185 ms х.х.х.х

Трассировка завершена. ;)

И это при том, что сейчас уже не совсем рабочее время. Днем иногда приходится подключаться к удаленному терминалу... Работать не возможно это как минимум и каждые 5-10 минут связь обрывается.


Вывод на печать | База знаний | mista.ru

Вывод на печать

NINA 28.05.2004 04:00 | Как можно решить такую проблему: При выводе на печать выдается сообщение "Программа выполнила недопустимую операцию и будет закрыта." Но когда печатаешь через "Свойства" все проходит нормально.
427 1 - 28.05.2004 06:18 | Почистить каталог юзера от всякого г.... если не поможет - почистить реестр у данного юзера если не поможет - сделать нового юзера ... если не поможет - переустановить принтер если не поможет - переустановить 1С


Сетевая 1С БАГ | База знаний | mista.ru

Сетевая 1С БАГ

LOSS 27.05.2004 05:38 | В сети четыре компа в однораноговой сети. При открытии на трех компах 1с (сетевая весрия, все работают с одной базой), четвертый комп выдает ОШИБКУ ОТКРЫТИЯ ИНДЕКСНОГО ФАЙЛА sc5419. ДЛЯ ВОССТАНОВЛЕНИЯ ЗАПУСТИТЕ ВМОНОПОЛЬНОМ РЕЖИМЕ. бАГ в том что, любой из четырех не запустится 1с, если на трех уже запущена база, и четвертый по очереди выдаст опять такую фигню ОШИБКУ ОТКРЫТИЯ ИНДЕКСНОГО ФАЙЛА sc5419. ДЛЯ ВОССТАНОВЛЕНИЯ ЗАПУСТИТЕ ВМОНОПОЛЬНОМ РЕЖИМЕ. Пробовал с лицензинной с ключом сетевой рел 018, с патченной пробовал SQL21, SQL20. ГДЕ БАГ?????? У всех пользователей права были одинаковые и разные. Пробовал всё. Везде 98 мастдай
SnarkHunter 1 - 27.05.2004 05:50 | И незачем так орать... Просто уткнулся в ограничение количества одновременно открытых файлов для в98... Это не баг и даже не баг 1С...
SnarkHunter 3 - 27.05.2004 06:54 | Что делать? Поставить другую ОС на комп, где база лежит...
LOSS 4 - 27.05.2004 07:42 | 2000 стояла на одной машине и база тама лежала, я снес потому как сетки совсем не видно было сколько не заводи пользователей с правами надоступ к этой папке, а 2000 всех видела. Поставил XP и базу туда, поможет? На что лучше фат32 или нтфс
BorisG 5 - 27.05.2004 07:48 | Да... а поик уже не катит? http://1c.alterplast.ru/faq/start.html
SiMazx 12 - 27.05.2004 14:45 | (11)Ага, неправильно... Используй ХРюшу как файл-сервер для 1С-овских баз, включи восстановление системы на диске с базами и кэширование записи на диск... И будет тебе щастье... Ну чего ты прикалываешься...
mthr 13 - 27.05.2004 14:48 | вчера решал такую граблю. решилось установкой Win 2000 Server :) кстати, в систем логе 2000 проф ясно написано, что она втыкается в предел non-paged memory
alxkorvin 17 - 27.05.2004 15:45 | (16) Все дело в том, что если человек, который занимается администрированием системы, не может настроить ОС для работы 1С, то почему он этим занимается? Указанная проблема решается размещением базы на любой ОС семейства Win2k, WinXP и Win2003.
BorisG 20 - 27.05.2004 16:26 | (19) Ты путаешь количество подключений и ограничение на количество открытых файлов. Согласно ЛС Win 2000 Prof и Win XP Prof имеют отграничение в 10 подключений.
alxkorvin 23 - 27.05.2004 18:32 | (21) У (0) проблема открытия ИБ одновременно 4мя пользователями. Они решаются установкой любой ОС семейства win2k winxp win2003. У тебя проблема (20). Очевидно, что для ее решения необходимо поставить ОС, где разрешено больше 10 подключений. Это позволяет сделать любая серверная ОС семейства windows.


Не работают кнопки на стандартных панелях! | База знаний | mista.ru

Не работают кнопки на стандартных панелях!

Asmody 26.05.2004 22:59 | Сегодня у клиента увидел subj. Т.е. выглядит это так - подводим курсор мыши к кнопке, кнокпа "пухнет", но не нажимается. Причем не нажимается только на стандартных панелях, ну которые над списками и в документах. Кнопки на обыных панельках (которые двигаются) нажимаются, меню выбирается. В общем, довольно занятный глюк. Лечится перезапуском 1С... А, чуть не забыл, релиз 21, Win XP Pro RUS SP1. А теперь, собственно, вопрос: такое кто-нибудь встречал? И от чего оно может быть?
It is me 1 - 26.05.2004 23:23 | Клиент звонит "Запускаю 1С и кнопочка ОК в диалоге выбора баз недоступна". Угадайте, что у нее было?
Asmody 2 - 26.05.2004 23:59 | (1) скорее, чего у нее не было :)
It is me 3 - 27.05.2004 00:06 | Точно!


Ошибка блокировки данных, а в базе нет никого... | База знаний | mista.ru

Ошибка блокировки данных, а в базе нет никого...

BorisBiz 25.05.2004 14:34 | При сохранении данных (или конфигурации) в конфигураторе «Ошибка блокировки данных» притом, что реально в базе никого нет (в мониторе пусто). В монопольном режиме в базу пускает нормально. Обнаружилось, что заблокирован 1Cv7.LCK. База на сервере (Win2000), локальные машины полный салат: 98, Me, XP Известно, что при перезагрузке сервера проблема устраняется. Предполагаю, что при перезагрузке локального компа, который держит 1Cv7.LCK проблема также устранится. Вопрос: есть ли способ узнать, какой именно компьютер держит 1Cv7.LCK ? И вообще как с такой проблемой бороться ?
ss20 1 - 25.05.2004 15:03 | .LCK - один на всех, как узнаешь, кто подвесил? Просто удалить его и путь свободен. Если в это время кто-то сидит в базе, то этот .LCK неспроста, система его не даст удалить. Вообще-то такое случается из-за сбоев в сети, когда комп отрубился внезапно, а сервер всё ещё думает, что комп к нему подключен.
lexa 2 - 25.05.2004 15:05 | Администрирование - Управление компьютером - общие папки
SnarkHunter 3 - 25.05.2004 15:09 | (1)С какой это радости один на всех?


"!!!Неустранимая ошибка" при тестировании и исправлении ИБ | База знаний | mista.ru

"!!!Неустранимая ошибка" при тестировании и исправлении ИБ

Frol 18.05.2004 15:25 | Пытаюсь обновить клиентскую базу(Пр+Бух+Усл 282), ругается на какойто "безымянный" файл. Делаю "Тестирование и исправление ИБ", выдает "!!!Неустранимая ошибка" и прекращает тестирование. Что можно с этим сделать? Подскажите, кто знает.
kvm 5 - 18.05.2004 23:47 | Был такой случай. Оказалось, что как-то хитро поврежден MD. Не открывался справочник налоги и отчисления. Поставили пустую базу и перегнали все, что смогли через OLE.
Frol 8 - 19.05.2004 13:28 | На ИТС есть обработка "Export77.ert" и "Import77.ert", можно осуществлять обмен между идентичными конфигурациями через текстовый файлик. Вчера выгрузил из "глючной" всё что можно. Поставил на ночь загружаться в чистую 282, так она всё ещё загружается... Надеюсь это поможет мне в этой проблеме. (7) мастер не понадобиться... тем более из ателье
Foma 10 - 19.05.2004 13:56 | (9) с безимянный файл сообщением не сталкивался. А на 8.7 с компонентой УРБД пару раз неустранимая ошибка выскакивала. попробуй поигрть с галочками при тестировании/исправлении. не все подряд поставь а сначала третью. потом только 1. потом 1 со 2 и с 3 вместе. у меня срабатывало. причем, когда делал ТиИсправление со всеми кроме последней, в итоге, ошибок не было. Лучше, конечно, если спец. глянет. т.к. по большому счету действия, приведенные выше, как гадание. пропрет/непропрет. лечить надо однако.


По совместной работе в WIN2000-98 | База знаний | mista.ru

По совместной работе в WIN2000-98

Виталик 17.05.2004 22:30 | База стоит на W2, клиент - на W98. После завершения работы 1С клиент не освобождает файлы таблиц Что можно сделать?
Митя 3 - 18.05.2004 11:38 | У меня тоже самое. База DBF. При включении идет на переиндексацию
SnarkHunter 4 - 18.05.2004 11:53 | "Не освобождает" и "идет на переиндексацию" - это две большие разницы...
kvm 5 - 19.05.2004 00:28 | Перед выключением 98-ой пойти покурить минут несколько, только после этого завершать работу.


Перезагружается компьютер при работе в 1С | База знаний | mista.ru

Перезагружается компьютер при работе в 1С

Arhitektor
18.05.2004 10:19 		Здраствуйте!

Win2000 Pro Sp4 Rus
1C:Предприятие 7.70.021
1С:Торговля и склад 7.70.933

При работе с базой (работают три пользователя) иногда компьютер отправляется на перезагрузку, выдавая сообщение

"Невостановимая ошибка базы данных. Код-56. Таблица 1susers. Ошибка захвата таблицы для чтения или записи"

В чем может быть проблема?
SnarkHunter
1 - 18.05.2004 10:19 		Сеть кривая...
SnarkHunter
3 - 18.05.2004 10:50 		Вирус, битый винт, кривая база, кривые руки...
Черт
8 - 18.05.2004 12:18 		(6) уточняю
Windows 2000/XP:
Уже неоднократно было замечены сбои при конфигурировании - в системе есть "ограничение на количество потоков в compound файле" (не совсем уверен в правильности терминологии, позже уточню), т.е. на больших MD. Решением проблемы, уже официально подтвержденной фирмой 1С, является переход на работу в Конфигураторе (Объединение конфигураций, Загрузка измененных конфигураций) под Win95/98.
Также, в W2KProf существует ограничение на количество подключений к расшаренной папке - не более 10.

Вот что написано про это и не только про это на ИТС:
Пpи иcпoльзoвaнии 1C:Пpeдпpиятия 7.x нa кoмпьютepax c oпepaциoнными cиcтeмaми Windows NT/2000 вcтpeчaютcя oпpeдeлeнныe пpoблeмы, cвязaнныe c кoнcтpyктивными ocoбeннocтями yкaзaнныx oпepaциoнныx cиcтeм.
Oднa из ниx пpoявляeтcя пpи выпoлнeнии aвтoмaтичecкoгo oбъeдинeния двyx кoнфигypaций дocтaтoчнo бoльшoгo paзмepa. Пpи этoм мoжeт пoявитьcя cooбщeниe "Oшибкa oткpытия дoкyмeнтa". Этa пpoблeмa cвязaнa c ocoбeннocтями peaлизaции пoдcиcтeмы yпpaвлeния cocтaвными дoкyмeнтaми (OLE Compound Storage) кoтopaя иcпoльзyeтcя 1C:Пpeдпpиятиeм для paбoты c фaйлoм кoнфигypaции. Peaлизaция дaннoй пoдcиcтeмы в Windows NT/2000 имeeт бoлee низкoe, пo cpaвнeнию c Windows 95/98, oгpaничeниe нa oбъeм мoдифициpoвaнныx в пpeдeлax oднoй ceccии дaнныx. Для peшeния дaннoй пpoблeмы мoжнo peкoмeндoвaть пpoизвoдить oбъeдинeниe тaкиx кoнфигypaций пo чacтям или жe пpoизвoдить тaкиe oпepaции нa кoмпьютepax paбoтaющиx пoд yпpaвлeниeм Windows 95/98.
Пpoявлeниeм дpyгoй пpoблeмы являeтcя пoлнoe или чacтичнoe иcчeзнoвeниe пpoгpaммнoгo мeню пpи oднoвpeмeннoй paбoтe нecкoлькиx экзeмпляpoв cиcтeмы 1C:Пpeдпpиятиe. Пpи дaльнeйшeй paбoтe этo мoжeт пpивoдить к нeвoзмoжнocти oткpытия нoвыx oкoн кaк в пpoгpaммe 1C:Пpeдпpиятиe тaк и в дpyгиx пpoгpaммax. Дaннaя пpoблeмa пpoявляeтcя тoлькo пpи paбoтe c кoнфигypaциями, coдepжaщими знaчитeльнoe кoличecтвo пyнктoв мeню в пoльзoвaтeльcкoм интepфeйce и cвязaнa c пpинципиaльными oгpaничeниями cиcтeм Windows NT/2000 нa кoличecтвo oднoвpeмeннo зaдeйcтвoвaнныx пyнктoв мeню, c yчeтoм иepapxичecкиx пoд-мeню. Пpи пoявлeнии вышeyпoмянyтыx пpoблeм cлeдyeт зaкpыть нeиcпoльзyeмыe экзeмпляpы 1C:Пpeдпpиятия.
BorisG
11 - 18.05.2004 12:37 		(8) Цитировать ИТС не надо, я про это не один раз писал, в том числе и на этом форуме. Пункты меню, потоки и буфера под ввод-вывод... вещи вообще-то сильно разные... Где там написано про ограничение на количество открытых файлов по сети под Win2000Prof? Ты считаешь, что по Win98 оно больше? Ну ну...
lexa
12 - 18.05.2004 12:45 		Если только на одной машине, то проблема с этой машиной или с сетью http://www.mista.ru/articles1c/netbugs.htm
Если содним пользователем (виндовым, под которым он входит в винды), то возможно проблема с правами доступа и разрешениями


Как перевести базу из dbf в sql со всеми справониками и документами? | База знаний | mista.ru

Как перевести базу из dbf в sql со всеми справониками и документами?

kortun 17.05.2004 12:56 | Здравствуйте. Поскажите, как перевести рабочую базу со всеми данными из dbf в sql без потери данных?
NastyFrog 1 - 17.05.2004 12:57 | из ДБФ выгрузить - в СКЛ загрузить
MAAlekseev 2 - 17.05.2004 13:39 | 1 Сделать выгрузку (администрирование-выгрузить данные) в конфигураторе dbf 2 Создать пустую базу данных, при входе в конфигураторе выбрать формат SQL 3 Зарегистрировать новую базу (Администрирование-параметры базы данных SQL): сервер - (serverSQL или как он у вас называется), база данных - (Buch_1 или как вы ее завели на sql сервере), пользователь (sa), пароль (оставить пустой) 4 Создать нового пользователя - любого с правами администратора 5 Сделать загрузку из файла, который сделали в пункте 1
NastyFrog 3 - 17.05.2004 13:59 | (2)А если sa у них с паролем? Под sa логинится на сервер - пагубная практика. (0) Завести стандартного юзера в SQL-servere, выполнить sp_changedbowner для этой базы на вновь созданного юзера (сделать его dbo для этой базы) и его же указать в конфигураторе в параметрах базы SQL.
kortun 4 - 17.05.2004 18:46 | Спасибо помогло, можете еще подсказать где взять документацию по настройке и администрированию 1с+sql 7, впринципе я все настроил, но хотелось бы узнать побольше на эту тему.
iceTiger 5 - 17.05.2004 19:34 | http://1csql.udmnet.ru/index.shtml Вроде ничего.


Как исправить БД? | База знаний | mista.ru

Как исправить БД?

vf_01 17.05.2004 10:41 | Комплексная конфигурация 4.4 База работает, но при обновлении на 4.5 выдает "ошибка при анализе изменений в структуре данных" Темтирование и исправление ИБ
vf_01 1 - 17.05.2004 10:42 | Тестирование и исправление ИБ выдает "Неисправимая ошибка"
SnarkHunter 4 - 17.05.2004 11:02 | http://www.gendin.ru/md/


Спецы по 1С (SQL) отзовитесь! | База знаний | mista.ru

Спецы по 1С (SQL) отзовитесь!

iceTiger
14.05.2004 20:09 		Ситуация такая:
LAN 4PC(W98)+Server(W2000+1С21+SQL7.0)
В один прекрасный момент на одной из машин слетает Win98. Чистим машину, ставим по новой Win98 и 1С(SQL) 21 релиз. Запускаем 1С, прописываем путь к базе, настройки SQL-сервера. Запускаем и видим веселое окошко такого содержания:

SQL State: 42000
Native: 4062
Messege: [Microsoft][ODBC SQL Server Driver][SQL Server] Cannot
open user default database '<ID>'. Using master database instead.

Вроде как проблема с ODBC драйвером, но что конкретно он хочет?
Настройки РС остались прежними...
За помощь вагон пива.
Gavrila
2 - 14.05.2004 20:42 		(1) Руководство по установке и запуску, правда не знаю есть ли для СКЛ такая книжечка :))
Gavrila
3 - 14.05.2004 20:44 		(0) Во нашел, совершенно случайно у нас в сети валялось, откуда взялось незнаю

Почему, если при работе с "1С:Предприятием 7.7 для SQL" в монопольном режиме запустить backup этой базы, появляется сообщение об ошибке?

Если система "1С:Предприятие для SQL" используется совместно с MS SQL Server 7.0, то при работе "1С:Предприятия" в монопольном режиме может наблюдаться следующий эффект. При попытке доступа со стороны какой-либо программы к базе данных в среде MS SQL Server 7.0, с которой уже работает "1С:Предприятие", "1С:Предприятие" может аварийно завершаться с сообщением об ошибке:

SQL State: 42000
Native: 924
Message: [Microsoft][ODBC SQL Server Driver][SQL Server]Database 'DB' is already open and can only have one user at a time

или

SQL State: 42000
...
Message: [Microsoft][ODBC SQL Server Driver][SQL Server]SELECT permission denied on column ...

Причина обусловлена особенностями поведения MS SQL Server 7.0 . Если какое-либо приложение установило соединение и выполняет запрос к базе данных, размещенной в среде MS SQL Server 7.0 и находящейся в режиме "single user", то попытка из другого приложения обратиться к этой же базе данных, приводит к тому, что запрос к базе данных, выполняемый первым приложением, завершается ошибкой. Поэтому не рекомендуется совмещать во времени регламентные процедуры MS SQL Server 7.0 (например, выполнение backup, проверку целостности и т. п.) и работу "1С:Предприятия" в монопольном режиме (пересчет итогов, перепроведение документов и т.п.).
MS SQL Server 6.5 не имеет данной особенности.

Замечание (атор Вячеслав): Ответ на данный вопрос в принципе правильный но неполный, на мой взгляд. Мы долго мучались с этой проблемой. Ошибки выскакивали при внутренних (SQL Server) обращениях к базе, без всяких джобов и пр. Потом в доке на 1С откопали, что на SQL Server 7.0 нужно ставить 2-ой Service Pack. Теперь работаем без проблем. :))))) В 2000-ном SQL всё нормально.

:)
iceTiger
5 - 14.05.2004 20:59 		Да я уже всех пользователей выгнал, сервер и локальную машину перегружал, Фигушки....
Может с ODBC проблема, он у меня стал вместе с Win98. Хотя я уже полностью клиентскую часть SQL загнал на машину, дрова ODBC SQL ставил заново...
Вообще изменение IP машины играет роль?
Черт
6 - 14.05.2004 22:23 		Изменение IP роли не играет, попробуй поставить SP под 98, возможна проблема действительно в драйвере ODBC
GrayT
7 - 15.05.2004 00:00 		Я вообще то не спец, так может как катализатор сработаю :)
а почему на ОДБС грешите, он вроде просто честно сообщает что не может открыть какую то базу данных по умолчанию. Под другим пользователем или новым таже песня?
Vser1
8 - 15.05.2004 02:55 		(0)Если обратить внимание на строчку: "Cannot
open user default database '<ID>'. Using master database instead.", то похоже у тебя проблемка не с клиентом, а на серваке с настройками SQL сервака или с доступом к серваку.
На всякий случай проверь в параметрах своей бызы SQL права пользователя "sa" (стандартно используемый по умолчанию)+ права данного пользователя в винде и является ли он используемым логином для твоей базы (на сервеке через Энтпризе менеджер конектишься к своему SQL-серваку, и в настройках своей базы смотришь есть ли в юзерах: Name=dbo, Login name=sa, Database Access=Permit.
Больше тоже ничего умного сказать не могу, не супер спец в данном вопросе :((((

(2) Есть от 1С "1С:Предприятие Версия 7.7 для SQL Особенности установки и использования" на 48 листов, но там нет даже полного описания (со всеми тонкостями и особенностями) как правильно SQL сервак под 1С поставить...
ramstar
9 - 15.05.2004 04:43 		Если внимательно прочитать это не ОДБЦ грешит просто попробй в службых винды запустьт SQL у меня возникала такая ошибка при установке SQL сервака надо в сетапе прописать определенные заклинания а именно
setup INSTANCENAME="InstanceName" SECURITYMODE=SQL SAPWD="AStrongSAPwd"
то есть значит пространство имен сервак а также пысворд по умолчанию но можно и свои значения поставить потом простонапросто надо настроить ODBC драйвер
указав адрес к свему серваку и протестить и все будет тип топ :)
а инструкцию по юзанью сервак можно прочитатьпрям редми ели он поставляется е сли такого нет могу прислать давай свой адрес только учти все на английском придеться переводить :_)
ramstar
10 - 15.05.2004 04:46 		кстатьи забыл по 98 сервак лучше не ставить наиболее подходящей системой для негопойдет 2000 сервак или 2003 а еще в дополнение к нему ппостваь Isa сервер Enterprise Edition вот тебе будет и брендмауэр и прокся и вообще класная штука вот кода Yukon выйдет на .Net платформе тогда вообще рульно будет там наваротов до фига =)
Tassadar
11 - 17.05.2004 09:58 		Я так понял, что на остальных все работает... Не работает только один, переустановленный win98. Он ставился с теми же прогами (Например, версии Office и наборы компонентов идентичны)?
iceTiger
12 - 17.05.2004 14:05 		Всем спасибо, РЕШИЛ!!!

Р.S. Ответ на вопрос см. в ветке с темой: "И снова SQL... (II)"
Там же ссылка на неплохой русский ресурс по SQL.


И опять SQL.... (II) | База знаний | mista.ru

И опять SQL.... (II)

iceTiger
16.05.2004 12:14 		Всем спасибо за участие, но приколы продолжаются.... :(
Такого шаманства, какое я тут творю, еще никто не видел !..

Извините за повторы, просто уж очень хочется решить вопрос. Клиент рвет и мечет...
//--------------------(1)
Как я уже писал ситуация такая:
LAN 4PC(W98)+Server(W2000+1С21+SQL7.0)
В один прекрасный момент на одной из машин слетает Win98. Чистим машину, ставим по новой Win98 и 1С(SQL) 21 релиз. Запускаем 1С, прописываем путь к базе, настройки SQL-сервера. Запускаем и видим веселое окошко такого содержания:

SQL State: 42000
Native: 4062
Messege: [Microsoft][ODBC SQL Server Driver][SQL Server] Cannot
open user default database '<ID>'. Using master database instead.

Вроде как проблема с ODBC драйвером, но что конкретно он хочет?
Настройки РС остались прежними...
За помощь вагон пива.

//------------------- (2)
Вопрос еще интересней: данная сеть досталась в наследство, пароль SA никто не знает, владельцем (dbo) является некий самописный пользователь "1С", под которым логинятся все РС к SQL...

Да, еще, при попытке настройки пользовательского DNS в ODBC (когда ввожу логин "1С" и его пароль) выскакивает сообщение типа: "Сервер отклонил запрос..."
iceTiger
1 - 16.05.2004 12:16 		Да, забыл, если кто-то может поделиться чтивом по данному вопросу, буду безмерно благодарен...
iceTiger
2 - 16.05.2004 13:45 		Все, РЕШИЛ!!! :)
Все настолько банально, просто зло берет!
Хотя без примеси неизвестности...
Данный рукотворный пользователь "1С", по неизвестным причинам, при входе с данной РС, не являлся dbo базы master. Хотя при входе с остальных "Полет нормальный!"..
После изменения настроек пользователя в 1С на sa/pw_sa - все работает...
Правда пришлось и на остальных машинах корректировать пароль, но это фигня.
Всем кто отозвался Благодарность!
iceTiger
3 - 16.05.2004 13:50 		А вообще круто я сам с собой пообщался! :)

Р.S. А по поводу доков по настройке, все равно буду рад, если кто-то оставит ссылку на ресурс - это поможет не только мне.
iceTiger
4 - 16.05.2004 14:58 		Сам нашел... может кому-то пригодится.
http://1csql.udmnet.ru/articles/article.shtml?firststep/st0001


откуда md в 123 метра??? | База знаний | mista.ru

откуда md в 123 метра???

Igrik 14.05.2004 16:21 | операционка win2000s+1C. Без всяких видимых причин мдешник разбух до 123 мегабайт. В нем не ковырялись это точно. Восстановился из резервной копии, но все таки откуда он такой взялся??? Тормоза естественно были жуткие. Заранее благодарен.
427 1 - 14.05.2004 17:09 | Глюк платформы.... Надо было его сам в себя загрузить...


Как выйти из ... | База знаний | mista.ru

Как выйти из ...

Haron 14.05.2004 10:01 | Что делать если при пересчете бух итогов конфигуратором во время принятия изменений погас свет и вырубился комп на котором все это сохраняли? База весит 4,8 Гб
kadr 1 - 14.05.2004 10:04 | И что??? К чему это привело? Если база не слетела - "Забей, Сеня" (с)
SnarkHunter 3 - 14.05.2004 10:08 | УПС для этих случаев имеется...
mszsuz 5 - 14.05.2004 10:39 | Достать базу из предусмотрительно сделанного архива и повторить обновление ...
427 6 - 14.05.2004 11:57 | (5) ты не совсем прав... Это ж только идиоты... делают резервную копию базы... особенно размером почти 5 гектар... (0) а ниюуя не будет... По идее нужно просто запустить пересчет повторно... Ибо возможность сбоя в принципе предусмотрена фирмой 1С... причем автоматически... Технология описана в ЖКК...
wolfy 7 - 14.05.2004 12:17 | ну по идее если обновление файлов до конца не прошло то при запуске 1с скажет что надо зайти в конфигуратор и заакончит обновление. ну можно потом проверить тестированием и исправлением. PS архивы делать надо


Автоматическая архивация 1С | База знаний | mista.ru

Автоматическая архивация 1С

Victor Vlad 13.05.2004 07:39 | Доброго времени суток всем. Подскажите, какие файлы 1С ДЕЙСТВИТЕЛЬНО необходимо сохранять. Проблема в том, что база очень большая, причём не одна. Архиив должен влазить на RW.
427 1 - 13.05.2004 07:47 | Все.... кроме СДХ.... Вставь соломинку в Ж RW..... Он станет толще .....
Victor Vlad 2 - 13.05.2004 07:58 | Про *.cdx я и сам знаю. Не помогает. Есть ещё варианты?
Vser1 4 - 13.05.2004 08:05 | (3) То есть не влазят на одну болванку :)) (2) Архиваторы используешь? И каков размер базы (DBF-файлов)?
Slayyyer 6 - 13.05.2004 08:14 | Есть замечательная штука Rar, я просто не поверю, что есть такая база, которая после пожима невлазеет на болванку
Victor Vlad 7 - 13.05.2004 08:43 | (4) Архивирую WinRar с максимальным сжатием.Вся папка с базами весит 4,5 ГБ, dbf и md - 3,15 ГБ
Vser1 9 - 13.05.2004 09:13 | (7) Мдя, не мелкая база... Как сказал Пит (1) из коневого каталога архивируй все за исключением индексов + обязательно папки: usrdef и SYSLOG (возможно есть еще что-то обязательное я не вкурсе, надеюсь старшие товариши уточнят), с остальными разберись что там есть ценного, скорее всего в пользовательских папках много мусора + выгрузки базы валяются в ZIP или XML файлах... По параметрам должна влазить и даже без особых проблем.
kiwi 10 - 13.05.2004 09:56 | new_stru мона не архивировать, да и наличие syslog не обязательно, если не анализируешь log
Victor Vlad 11 - 13.05.2004 10:20 | Всем спасибо за конструктивные ответы. Результат - 22 минуты - архив 520 Мб. Кстати, ничего, что у меня в 1С куча народа токалось, когда я архивировал?
Vser1 12 - 13.05.2004 11:05 | (11) Очень даже плохо...:((( Часть файлов наверняка оказалась заблокированна, такие весчи делаются тока когда с базой никто не работает, и пользователей в ней нет, то есть как правило ночью :))) А результат хороший, сервак двухголовый? :))) (10) Логи лучше тоже сохранять, а то всякое может быть, потом совсем не докажешь, что ты не верблюд...
Has 13 - 13.05.2004 11:32 | об архиваторах: взял базу 526 Мб (в т.ч. *.cdx) в WinRar(макс. сжатие) - 48Mb в 7-zip (макс. сжатие) - 36Mb в 7-zip (Ultra) - 34Mb
Fynjy 14 - 13.05.2004 13:04 | Логично считая: 500м -> 50м (х10) не влазит на CD 700м архив (х10) 7гиг без архива база + .cdx (14 гиг)... не верится что то ...
Fynjy 16 - 13.05.2004 13:23 | Объем базы, если правильно посчитал составляет 10 - 14 гиг...
Fynjy 18 - 13.05.2004 13:43 | Ну в принципе представить такую базу можно(у самого база 2,8 г за 8 мес), но вот скорость работы пользователей?
Цветок 19 - 13.05.2004 14:14 | *.dbf,1cv7.dd,1cv7.md,*.spl,1cv7.ord,1cv7.spl,usrdef\users.usr
Victor Vlad 20 - 14.05.2004 09:27 | (12) То, что плохо - это я догадывался :) Архивировать буду ночью, само собой. Вопрос исключительно академический - какова вероятность, что я не смогу восстановить базу, если в момент архивации она открыта у клиента? 1С стоит на сервере, клиенты ходят в неё через Win2000 TS. (19) Сенкс, то, что доктор прописал :)


Ошибка при загрузке модуля config.dll ??? | База знаний | mista.ru

Ошибка при загрузке модуля config.dll ???

OW 10.05.2004 00:37 | Обновил экзешник с 19 до 21 - при входе в конфигуратор появляется такая объява.... может кто сталкивался ???
unior 2 - 14.05.2004 05:57 | Телепат – это плагин для OpenConf, расширяющий возможности Конфигуратора 1С-Предприятия 7.7, а именно пытающийся реализовать систему, более известную как IntelliSense или CodeComplete. Для работы плагина необходимо наличие в системе Microsoft XML Parser. Чтобы установить плагин, проделайте следующие шаги: 1. В каталоге “Bin” 1С-Предприятия создайте каталог “config”. 2. Переместите стандартный файл config.dll из каталога bin в каталог config. 3. Вместо него запишите в каталог bin файл config.dll из скачаного архива. 4. Разместите в каталоге config файл telepat.dll 5. Разместите в каталоге bin файл 1cv7lang.xml 6. Запускайте Конфигуратор. Корень зла наверное в этом. Верни назад родную dll.


Проблема с сохранением конфигурации | База знаний | mista.ru

Проблема с сохранением конфигурации

Willhelm 10.05.2004 17:29 | Взял у клиента его настройку на доработку. Два часа полёта мысли, а потом решил-таки сохраниться. 1с v7.7.021 для SQL порадовал надписью "Ошибка совместного файлового доступа к НазваниеКонфигурации.md". Всё бы хорошо, но: 1) Такого прикола раньше никогда не было; 2) Моя машина локальная (к моей настройки никто кроме меня не подключается). 3) В момент сохранения ни одного 1с-приложения кроме моего конфигуратора запущено не было. 4) Самое интересное - в одном из десяти случаев конфигурация всё же сохраняется!!! Люди, взываю к Вашему милосердию, помогите кто знает, как с этим бороться! Сил моих больше нет :(
IceTiger 1 - 10.05.2004 18:51 | На SQL незнаю, он под DBF 1С при завершении работы своих приложений оставляет висящий процесс. Вообще такое возможно только если еще что-то работает с МДшником. Смотри в диспетчере. Или пробуй "Выгрузку/Загрузку" в другую папку... Или перегрузись :)
Willhelm 3 - 11.05.2004 18:29 | Для BorisBiz Да на компьютере XP
Глазья 5 - 11.05.2004 19:21 | Смею предположить, что переменная TEMP описана типа - C:\Documents and Settings\..\Local Settings\Temp
Rider 12 - 12.05.2004 15:20 | У меня такое тоже было с SQL. Посмотри в мониторе пользователей. Там наверное конфигуратор не виден. Снимай задачу-это песец.
Willhelm 14 - 12.05.2004 15:44 | для Rider А у тебя какой build? У меня 7.70.021
lexa 15 - 12.05.2004 15:46 | http://www.sinor.ru/~my1c/knowhow/XP&1C.htm


Ламерская проблема с запуском 1С | База знаний | mista.ru

Ламерская проблема с запуском 1С

fil514 06.05.2004 22:14 | Господа, вопрос м/б дурацкий, но найти решение крайне необходимо!!! В организации заведена база данных по клиентам. Завели еще одну базу (по учету чего-то там). Пока база по учету чего-там лежит на локальном диске все работает как надо, после выноса базы на сеть при запуске появляется сообщение ОШИБКА ДОСТУПА К ТАБЛИЦЕ DH1230. Помогите кто чем может.
427 1 - 06.05.2004 22:26 | Поймай того админа, который разместил базу на Вин98.... Набей морду.... Пусть ставит нормальный сервер (НТ, вин2000, вин2003, новель) и не пудрит мозги.... P.S. - если очень постараться, до 10 мест можно на 2000 проф или ХР проф базу держать.... Только покорячиться с настройкой.... P.S. - Вин98 не может открыть более 1024 файла с сети.... Вот при каком то подключении файл DH1230 становится 1025 ..... и бздец ....
gr13 2 - 07.05.2004 08:55 | (1) на итс диске, есть Новельная прога, для подключения более 3 пользователей в 98, ни разу не ставил, сколько она пользователей позволяет подключать?
Земляк 8 - 09.05.2004 17:39 | Впринципе в вин 98 моно расширить количество открываемых файлов ... В 2000 барада на ентот счет если она проф ... а не сервер естественно ...
BorisG 9 - 09.05.2004 17:56 | Да..... еще один "знаток" Windows 2000 Prof.... И какое же, уважаемый, количество открытых файлов в Win 2K Prof? ................ "Человек - это существо, которое охотнее всего рассуждает о том, в чем меньше всего разбирается" (с) Станислав Лем
Земляк 11 - 09.05.2004 19:08 | Борис ... Хех вижу нам до вас "профи" далекооооо но если серьездно точно не помню но максимум что из нее возможно выжать если не ошибаюсь что то около 3000 с чем то ... я давно ентим занимался ... Хех проще 2003 сервак поставить ... А прога та редактор рееста обычная так что смотри ... плюс к етном на 2000 стоит ограничение до 10 пользователей причем ... до в торого сервис пака помоему там вообще до трех было ... (ента инфа не проверенная ...но вроде такой баг был )
BorisG 13 - 09.05.2004 19:28 | (11) Да... И откуда же ты взял 3 тыс... "...если не ошибаюсь..." Ошибаешься... Так вот запомни... Ограничение Win2K Prof 16 тыс. файлов... Относительно 10 подключений верно... Но тем, у кого меньше... Win 2K Prof, как правило достаточен... Относительно второго SP тоже неверно... Увы... Это вообще просто... лицензионное соглашение просто почитай... Так что перед тем, как утверждать что-то... хоть тут поиск набери... хоть на других форумах...


Глюки в 1С | База знаний | mista.ru

Глюки в 1С

ramstar 05.05.2004 08:32 | Сегодня ездил к клиету У него стоит 1с усн-базовая и торговля и склад проф Причем при формировании цен в Торговле вылетает ошибка ошибка в Fserve() 1cv7l.exe допустила ошибку и сождает журнал ошибок а потом вываливается и все да и прикол нельзя покопаться в конфигураторе так как стоит базовая усн что делать в таких ситуациях и как объяснить ламеру который считает себя продвинутым пользоваетем что проблема не в 1с а в его винде и кривых руках в которых собирали его комп ??
3V 1 - 05.05.2004 08:38 | (0) ну торговля-то у тя проф, поэтому в пофигуратор залезть можно, а на счет кривых рук того, кто устанавливал, то есть два варианта: 1. переставить все самому 2. послать клиента в индивидуальный эротический пеший тур :)
fabrikant 2 - 05.05.2004 08:41 | Нужно чтобы компоненты базовая бухгалтерия и оперативный учет были установлены в разных каталогах. И вызывать запуск нужно с помощью соответствующих ярлыков, хотя в списке выбора базы будут доступны все прописанные базы. Тогда можно будет копаться в отладчике торговли. И проблема скорей всего исчезнет. Так что проблема в 1С, вернее в кривых рученках установщика оной, а вовсе не в винде.
ramstar 3 - 08.05.2004 04:19 | Про блема заключалась в том чтобы убить спайдера а потом переставил 1С и все пошло тип топ но все равно я этого юзверя послал на три эротических буквы
It is me 5 - 09.05.2004 00:56 | А никто не пробовал при таком раскладе делать административную установку, а затем из систем32 в бин все скопировать?
427 6 - 09.05.2004 13:22 | (5) После такой фишки кое что отвалится... в 1С... Оно, конечно,не критично... Но некоторые это юзают ....
ramstar 7 - 10.05.2004 12:00 | смысл в административной установке если всего на этой фирме одно машина ?


Изменение кодовой страницы таблий информационной базы | База знаний | mista.ru

Изменение кодовой страницы таблий информационной базы

Серг 07.05.2004 21:55 | Скажите пожалуйста что произойдет если изменить кодовую страницу таблиц информационной базы с украинской на русскую и т.д.в ТиС для Украины? Я попробовал изменить - вроде никаких изменений в дальнейшей работе с этой конфой не заметил??? Но иногда последствия выскакивают позже. Подскажите пожалуйста. Заранее огромное спасибо
It is me 1 - 08.05.2004 00:12 | Можешь спать спокойно


Как оживить базу | База знаний | mista.ru

Как оживить базу

FAR 22.04.2004 11:06 | Мне привезли базу 1С. При тестировании и исправлении вываливается на кучу ошибок типа Таблица - 1SJOURN. Не сошлось наименование поля номер 15 - SP13687 Таблица - SC696. Не сошлось наименование поля номер 28 - SP13661 Не удалось открыть файл SC13619 Проверка физической целостности таблиц ИБ. Неисправимая ошибка. Соответственно невозможно обновить на новую конфигурацию. Это расхождение между md и dd? Как лечить?
Valery 1 - 22.04.2004 11:14 | В данном случае лечить нечего.Дело в том сто словарь 1cv7.dd от другой конф. Поэтому или в резервных копиях его поискать, бывает в папочке New_stru.
12345 2 - 22.04.2004 11:14 | 1.Пускай привезут к тебе ВСЕ копии что у них есть. Тогда можно смотреть с толком. 2. Если данные таблицы справочника SC13619 не суть как важны, заходим в конфигуратор, дбавляем новую константу и удаляем новую константу. Сохраняем изменения. Вуаля - 1С ЗАГРУЖАЕТЬСЯ! Смотрим, что пропало. 3. А полями надо смотреть, что там. 4. 90% что у тебя (у них то есть) MD подменили на *неудачно* доработанный ...
FAR 3 - 26.04.2004 11:21 | Архив данных есть старый. В нем нормальные MD и DD, за одну дату, база тестирование и исправлние проходит ОК. В тепершней базе: MD от одной даты (явно не даты обновления, а с датой, когда его сваяли программеры (и я в т.ч.)). DD - с датой обновления. То есть , скорее всего, просто перекинули MD, вместо Загрузить изм.конф. Или еше чего наизвращались.После чего работали 2 недели. В общем, например, сейчас в DD вытаскивается информация с названием последнего поля SP14571, а в DBF - это поле носит название SP14569. Вижу 2 варианта: - менять название поля в dbf; - удалять поля в dbf, на которые ругается тестирование и исправление, кидать в базу md старой нормальной конфигурации, тестировать и исправлять базу. А уж потом переходить на новый MD. Мне этот вариант кажется более надежным. Данные в убранных полях набьют по новому. Всвязи с этим вопрос: как из внутр.языка 1С удалить/переименовать поле DBF?
kadr 4 - 26.04.2004 11:26 | Если я не ошибаюсь, то никак. Воспользуюся утилитами для работы с DBF (поищи или давай мыло) или, например, FoX Pro как это делал я.
FAR 5 - 26.04.2004 11:35 | Просто удобнее было бы написать для несчастных обработку, чтобы они у себя запустили и вуяля- все готово. Буду очень рад хорошему редактору DBF. Access не тянет, после него 1С ругается на неправильную ожидаемую длину заголовка. Excel вроде пашет, но пользоваться неудобно. Мыло zan@kengu.ru
SnarkHunter 6 - 26.04.2004 12:07 | Несчастным руки надо править, а не обработку для них писать... А Экселем дбфы править - это конечно "куль и руль"...
skunk 8 - 26.04.2004 12:32 | у гэндальфа не плохой редактор для dbf... прям с их сайта и закачивай
FAR 9 - 26.04.2004 12:45 | Че то я там в упор не вижу возможности редактирования структуры таблиц -(
SnarkHunter 10 - 26.04.2004 12:49 | (9)И не увидишь... Бери FP... Или VFP...
SnarkHunter 12 - 26.04.2004 12:56 | Неа... там объем большой... Лучше тогда dbu из дистрибутива клиппера... Вот тут она есть http://1c.alterplast.ru/download.html
427 13 - 26.04.2004 13:03 | (3) плохие идеи... Редактор ДБФ - wdbfview поищи... Нормально работает... Махонький ... "Просто удобнее было бы написать для несчастных обработку, чтобы они у себя запустили и вуяля- все готово. " Не взлетит.... ХХХХХХХХХХХХХ ...
FAR 14 - 26.04.2004 13:05 | Блин, когда то я его юзал, этот dbu. Но из головывылетело - а как там редактировать структуру?
FAR 15 - 26.04.2004 13:07 | wdbfview не редактирует структуру. Очень обрадуюсь, если меня в этом разубедят. Взлетит. Кинуть им пустые dbf с правильной структурой и обработку, которая копирует в них записи из рабочих таблиц.
427 16 - 26.04.2004 13:49 | (15) Вообще принципиально неверно убивать колонки в ДБФах - нужно стараться восстановить МД под ДБФ файлы, чтобы не потерять информацию.... не завидую тем, кого ты обслуживаешь .... если у тебя такие подходы во всем ....
FAR 17 - 26.04.2004 14:40 | Критично еще и то, чтобы не глючило в дальнейшем. Тем более, что именно в добавленные поля вряд ли успели внести многое. Значит, твое мнение - менять названия полей в dbf? Иля я неправильно понял? Менять ID объектов метаданных?
SnarkHunter 18 - 26.04.2004 14:50 | А при чем тут ИД объектов?
FAR 19 - 26.04.2004 16:02 | Насколько я понимаю, названия полей и самих таблиц отражают ID объектов md-шника. Я ошибаюсь? Киньте в меня НОРМАЛЬНЫМ редактором dfb, способным редактировать структуру dbf, ПЛИЗ. Или ссылкой. zan@kengu.ru
FAR 20 - 26.04.2004 16:03 | Стоп. Klom мне прислал dbfNavigator! Сейчас обпробую.
FAR 21 - 26.04.2004 21:16 | По почте спасибо сказать не могу -(. Поэтому, пишу на сайте : спасибо за DBF Navigator. Откорректировал структуру dbf под dd, кажись поехало. Глюки увидим позднее ;-)
SnarkHunter 22 - 26.04.2004 21:45 | Нравятся мне поклонники экстрима... Когда по телевизору за ними наблюдаешь...
b-52 23 - 29.04.2004 12:28 | FAR у меня была похожая проблема. после долгих мучений с попытками править dbf. использовал стандартные фозможности конфигуратора 1с-ки: Администрирование / "Выгрузить данные", а потом "Загрузить данные".
FAR 24 - 30.04.2004 19:09 | Тут все было (кажется было тьфу, тьфу) хуже. Данные даже не выгружались.
kvm 25 - 01.05.2004 16:36 | А dd удалить не пробовал? Иногда поиогает.
ramstar 26 - 02.05.2004 07:51 | В данном случа на лицо не правильное обновление скорее всего товю бд без файлов конфигурации просто тупо скоприровали а не обновили. Следовательно тебе надо стрести с них бабки или просто подать в суд. Но если у тебя сохранилась архивная копия просто востонови свою базу установи обновление и в конфигураторе сделай обединение конфигурация потом нажми кнопку принять и сохрани метаданный потом прочитай update.txt и следуй инструкциям вот и все дела и не стоит платить бабки за обслуживание а то бывают ламеры которы пытаются что то сообразить а потом и справляй за них ошибки


автоматическое создание резервной копии | База знаний | mista.ru

автоматическое создание резервной копии

Den
22.04.2004 15:00 		Может кому пригодится.
создаем текстовый файл ( например backup.bat) (содержимое файлика прилагается).
и добавляем в планировщик задание ( например выполнить в 23:00, чтобы в это время никто не работал).
и в указанной папке будут сохранятся копии базы вида :
22.04.2004_save.rar и 22.04.2004_unload.rar

rem ================содержимое backup.bat ==========================
REM ! - ОБЯЗАТЕЛЬНО заполнить
REM * - По необходимости
REM ---------------------------
REM ! Путь к файлу step.txt
SET step_PATH=C:\backup\step.txt
REM ---------------------------
REM удаляем старый step.txt
DEL %step_PATH%
REM ---------------------------
REM ! куда сохранять ?
SET DIST=d:\backup_
REM ---------------------------
REM * Пользователь 1С
SET USER=Admin
REM ---------------------------
REM * Пароль пользователя 1С
SET PASSWORD=advizer
REM ---------------------------
REM ! Путь к файлу 1cv7.exe
SET EXE_PATH=C:\1Cv77\BIN\1cv7s.exe
REM ---------------------------
REM ! Путь к базе 1С
SET xPATH=C:\1Cv77\complexSQL
REM ---------------------------

REM --------- параметры для 1С -----------------------
ECHO [General] >>%step_PATH%
ECHO Quit=1 >>%step_PATH%

REM * выполнить сохранение данных 1-Да 0-Нет
ECHO SaveData=1 >>%step_PATH%

REM * выполнить выгрузку данных 1-Да 0-Нет
ECHO UnloadData=1 >>%step_PATH%

ECHO [SaveData] >>%step_PATH%
ECHO SaveToFile=%DIST%\%DATE%_save.rar >>%step_PATH%
ECHO [UnloadData] >>%step_PATH%
ECHO UnloadToFile=%DIST%\%DATE%_unload.rar >>%step_PATH%
REM * сохранять инф.о пользователях 1-Да 0-нет
ECHO IncludeUserDef=1 >>%step_PATH%
REM --------- параметры для 1С -----------------------

%EXE_PATH% CONFIG /D%xPATH% /N%USER% /P%PASSWORD% /@%step_PATH%
rem ==================================================================
Черт
1 - 22.04.2004 15:09 		уже с полгода использую MyBackup, отличная прога,гибко настраивается, интерфейс русский, бесплатна.
Den
2 - 23.04.2004 05:36 		MyBackup-прога, а енто коммандный файл выполняющий резервирование штатными средствами 1С, с русским интерфейсом :) и естественно бесплатно :) !
и кстати тоже гибко настраиваемый.
Единственный недостаток который я вижу это-то,что нужен монопольный доступ( чтобы никого небыло в базе).
Дуч
3 - 23.04.2004 09:24 		Молодец конечно. Тока вот ExtForm ты не сохранишь так. ПОльзуйтесь WinRarом консольной версии.
gr13
4 - 23.04.2004 09:26 		либо программой "Хранитель"
valich
5 - 27.04.2004 10:16 		Den, правильно ли я понял, что так можно выгрузить серверную (SQL) версию конфигурации?
Valery
6 - 27.04.2004 11:05 		3) верно winrarотличная штука
мой батник
"C:\Program Files\WinRAR\Rar.exe" a -agddmmyy -dh -x*.cdx C:\1c\arh1c\prp Z:\np
работает отлично и главное в раздельном режиме.
User63
7 - 28.04.2004 17:53 		Попробовал запустить bat-файл, но есть проблема с параметром %DATE% в имени архивного файла - получается в виде: Ср 28.04.2004_save.rar. И этот день недели нечитабельный при просмотре имени файла. Можно ли как-то исключить эти символы?
valich
8 - 28.04.2004 18:57 		(7) Счас разбираюсь с этим на работе. Чуть позже сообщу результаты...
GrayT
9 - 28.04.2004 22:45 		(7)А что за операционка? Откуда "Ср" взялось? У меня в ХР поумолчанию dd.mm.gg стояло. Когда я в региональных настройках изменил на gggg-MM-dd. Стало чуть по-приятней.
И еще в тему
http://www.sinor.ru/%7Efilez/hare/cfg_prm.html
http://www.mista.ru/articles1c/tips.htm
Den
10 - 29.04.2004 07:11 		valich
Да, именно с переходом на SQL версию и пришлось такое родить.Естественно, чтобы спать спокойно надо еще держать копию самой конфигурации ( она не так часто меняется ).
User63
правильно GrayT говорит, в Региональных настройках посмотри формат даты.
User63
11 - 29.04.2004 09:47 		(9) MS Windows 2000. Когда просматриваю дату командой date, то у меня перед датой показывается еще день недели. Пн , Вт, Ср ... ну и так далее...
Спасибо за совет, сейчас покопаюсь в настройках...
User63
12 - 29.04.2004 15:59 		В дополнение к предыдущему: Что-то не нашел я у себя пункт Региональные настройки. Есть у меня Язык и стандарты в ПанелиУправления.Там смог изменить только символ-разделитель в дате.А вот чтоб день недели не высвечивался... Не получается никак. Может кто знает?
valich
13 - 01.05.2004 07:33 		(12) Точно, пишет две первые буквы имени дня на русском языке (у нас на работе Windows 2000 Advanced Server), но в какой-то странной кодировке, потом в архив не попадешь :-( Все наши попытки перенастроить были безуспешны...
Мы тут с нашим админом поизгалялись немного, результатом чего стал скрипт. Он еще пока не обкатанный, опробовали на локальной машине, на демо-базе. Но, в общем сетевые пути поддерживаются...
Я не очень силен в JScript, 1С да и в WSH тоже... В общем, просьба сильно не пинать ;-) Буду очень рад услышать комментарии, пожелания, критику и проч.

P.S.: Дэну отдельное спасибо за идею ;-)

P.P.S.: Чуть не забыл, скрипт выполняется на операционках с поддержкой технологии WSH (Windows Script Hosting). По-моему на 98 надо отдельно что-то качать... И еще момент, Norton Antivirus впервые с ним (скриптом) сталкиваясь, запрашивает действие, и по-умолчанию предлагает заблокировать выполнение. Там надо выбрать - Autorize (по-моему). Но это только первый раз, или после изменения. На других антивирусниках не испытывалось, но вроде как Касперский пропускает...
valich
14 - 01.05.2004 07:36 		//**********************************************************************//
// //
// Универсальный скрипт резервного копирования для 1С //
// (backup.js) //
// Язык реализации - JScript с применением технологии //
// Windows Script Host. Скрипт позволяет автоматически //
// выполнять 1С (v7.7) в пакетном режиме для реализации //
// задач выгрузки данных и создания резервных копий. //
// Для создания резервной копии в главном каталоге должен //
// лежать файл mask.lst для хранения списка масок файлов. //
// //
//**********************************************************************//

// Путь до главного каталога
var MainPath = "d:\\backup";

// Имя файла настройки сеанса
var INIFile = "backup.ini";

// Наработка имени очередного каталога
var ToDay = new Date();
var cDay = ((ToDay.getDate()) > 9) ? (ToDay.getDate() + 1) : "0" +
+ (ToDay.getDate());
var cMonth = ((ToDay.getMonth() + 1) > 9) ? (ToDay.getMonth() + 1) : "0" +
+ (ToDay.getMonth() + 1);
var curDate = cDay + "." + cMonth + "." + ToDay.getFullYear();

// Каталог для текущей даты
var currentPath = MainPath + "\\" + "Mnfctr_" + curDate;

// Логин и пароль для 1С
var User = "admin";
var Passwd = "god";

// Путь до запускаемого файла 1С
var ExePath = "d:\\Programs\\1Cv77\\BIN\\1cv7s.exe";

// Путь до рабочей базы обрабатываемой конфигурации
var BasePath = "d:\\Programs\\1Cv77\\MnfcDemo";

// Имя файла журнала проводимых операций
var LogFile = "backup.log";

// Коммандная строка для запуска 1С в пакетном режиме
var commandLine = "\"" + ExePath + "\"" + " CONFIG /D" + BasePath + " /N" + User;
commandLine = commandLine + " /P" + Passwd + " /\@" + MainPath + "\\" + INIFile;

// Чтение из файла масок копируемых файлов
var mfo = new ActiveXObject("Scripting.FileSystemObject");
if (mfo.FileExists(MainPath + "\\mask.lst")){
Mask = mfo.OpenTextFile(MainPath + "\\mask.lst");
Masks = "FileList=" + Mask.ReadAll();
Mask.Close();
} else {
Masks = "";
}

// Создаем каталог с именем по текущей дате
var fso = new ActiveXObject("Scripting.FileSystemObject");
if (!fso.FolderExists(currentPath)){
fso.CreateFolder(currentPath);
}

// Копируем журнал
if (fso.FileExists(BasePath + "\\" + "syslog" + "\\" + "1cv7.mlg")){
sl = fso.GetFile(BasePath + "\\" + "syslog" + "\\" + "1cv7.mlg");
sl.Copy(currentPath + "\\" + "1cv7.mlg");
}

// Удаляем старый файл настройки сеанса
if (fso.FileExists(MainPath + "\\" + INIFile)){
tmpfile = fso.GetFile(MainPath + "\\" + INIFile);
tmpfile.Delete();
}
// Запись файла настройки сеанса
var Conf = fso.CreateTextFile(MainPath + "\\" + INIFile);
Conf.write("\[General\]\n");
Conf.write("Quit=1\n");
Conf.write("Output\=" + currentPath + "\\" + LogFile + "\n");
Conf.write("SaveData\=1\nUnloadData\=1\n");
Conf.write("\[UnloadData\]\n");
Conf.write("UnloadToFile\=\"" + currentPath + "\\" + "unload.zip\"\n");
Conf.write("IncludeUserDef=1\n");
Conf.write("\[saveData\]\n");
Conf.write("SaveToFile\=\"" + currentPath + "\\" + "save.zip\"\n");
Conf.write(Masks + "\n");
Conf.Close();

// Запускаем 1С
run1c = new ActiveXObject("WScript.Shell");
run1c.Run(commandLine);

//**********************************************************************//
// //
// Комментарий: скрипт написан для резервирования базы //
// SQL-версии. Сначала копируется файл журнала конфгурации, //
// затем идет выгрузка данных и наконец сохранение служебных //
// файлов конфигурации. //
// //
//**********************************************************************//
valich
15 - 01.05.2004 07:39 		Да, немного некрасиво получилось, но в блокноте все будет нормально...
И чуть не забыл. У нас на работе две конфигурации - Производство(SQL) и Зарплата(dbf).
В принципе с двумя такими скриптами очень удобно... Выполняем по времени ночью...
Den
16 - 01.05.2004 19:45 		... для тех кому не удается избавится от (Когда просматриваю дату командой date, то у меня перед датой показывается еще день недели. Пн , Вт, Ср ... ну и так далее), нужно заключить в ковычки
пример:
SaveToFile="%DIST%\%DATE%_save.rar"
тогда день недели просто будет в имени файла
d:\backup_\Сб 01.05.2004_save.rar
у меня заработало...а у Вас !? :)
Den
17 - 01.05.2004 20:14 		oooops ! :(
попробовал на другой машине (тоже win200), 1С из (Сб 01.05.2004_save.rar) делает (‘Ў 01.05.2004_save.rar ). странно..
буду разбиратся дальше.
и ещё !!!!! при задании переменных типа
DIST=d:\backup_
нужно быть внимательнее, чтобы в конце небыло пробелов
(т.е. 'DIST=d:\backup_' и 'DIST=d:\backup_ ')
а то их сразу не видно, а строка формируется не правильно.


Выдается соб - База данных не может быть открыта в однопользовательском реж | База знаний | mista.ru

Выдается соб - База данных не может быть открыта в однопользовательском реж

Олег 07.07.2004 11:48 | Пытаюсь загрузисть данные выгруженные из сетевой версии 1с в sql. Создал базу. В конфигураторе в параметрах подключения указано имя sa и пароль. В процессе выгрузки выдается ошибка - База данных не может быть открыта в однопользовательском режиме.
SnarkHunter 1 - 07.07.2004 12:01 | EM закрой...
SnarkHunter 3 - 07.07.2004 12:37 | EM - это Enterprise Manager...


Возможно ли запретить запуск конфигуратора определенным пользователям | База знаний | mista.ru

Возможно ли запретить запуск конфигуратора определенным пользователям

povar 03.12.2004 07:01 | Собственно сабж.
SnarkHunter 1 - 03.12.2004 07:05 | Ключи enterprise и /d в строке запуска - и никаких проблем...
Де Лопа де Вега 2 - 03.12.2004 07:09 | +(1) Пароль. Отменить права на административные функции
povar 3 - 03.12.2004 07:10 | Блин точно, спасибо !


v7.7 Как програмно можно определить активных пользователей (база dbf)? | База знаний | mista.ru

v7.7 Как програмно можно определить активных пользователей (база dbf)?

_Mr 19.11.2004 19:00 | v7.7 Как програмно можно определить активных пользователей (база dbf)?
NiGMa 2 - 19.11.2004 21:05 | (0) На WildHare в свое время было решение - через метод Блокировка(). Примерно так: Создаешь служебный Справочник.АктивныеПользователи(). ПриНачалеРаботыСистемы() для текущего пользователя находишь или создаешь элемент этого справочника и делаешь на него Блокировка(1). Прелесть в том, что при завершении сеанса (даже аварийном) блокировка снимается без всяких дополнительных телодвижений. Теперь - для построения списка активных пользователей делаем: АктПольз = СоздатьОбъект("Справочник.АктивныеПользователи"); АктПольз.ВыбратьЭлементы(); Пока АктПольз.ПолучитьЭлемент() = 1 Цикл Если АктПольз.Блокировка() = 1 Тогда // пользователь активен // сюда добавить код по вкусу КонецЕсли; КонецЦикла;
GrayT 3 - 19.11.2004 22:35 | Странная активность по поводу определения пользователей. На территории недавно большая ветка была, и тут уже вроде третья. UserDef.dll вроде рекоментовали
HanProg 7 - 20.11.2004 09:47 | Для получения возможности выкидывать из 1С пользователей которые не хотят выходить, для обновления базы, или удаления помеченых объектов, а так вызываешь на их компьютерах выход без сохранения, предупредив их скажем за 5 минут до этого :-)
NiGMa 8 - 20.11.2004 11:50 | (7) как выгонять пользователей - на любом ИТС посмотри Методическую Конфигурацию. Это уже 4 года (или больше?) как придумано.


Как получить список паролей пользоватей и файла users.usr? | База знаний | mista.ru

Как получить список паролей пользоватей и файла users.usr?

THawk 11.11.2004 11:28 | Нужно внести нового пользователя в новую независимую базу дочерней компании со старым паролем в ИБ 1С Бухгатерия. Человека нет, по требованию руководства пользователям давать одинаковый пароль на все ИБ 1С. Программист забыл пароль доступа сотрудника.
psk21office 6 - 11.11.2004 11:35 | Можно так: открываешь базу где есть этот пользователь в конфигураторе. Открываешь список пользователей. Копируешь нужного пользователя. Открываешь базу в которую нужно перенести. Открываешь список пользователей. Вставляешь пользователя.


Пакетный режим | База знаний | mista.ru

Пакетный режим

Rider 08.06.2004 11:01 | Создал ярлык "C:\Program Files\1Cv77\BIN\1cv7s.exe" CONFIG /Dc:\Base\Tractor /NОльга /P1954 /@С:\Base\Tractor\Backup Запускаю. В журнале регистрации пишет, что файл С:\Base\Tractor\Backup не найден. В указанном каталоге имеется текстовый файл Backup.prm. Помогите
Rider 2 - 08.06.2004 11:20 | Я уже разобрался. Надо указывать Backup.prm.txt
lexa 3 - 08.06.2004 11:26 | (2) в свойствах папки убери "скрывать расширения"
Rovan 9 - 03.11.2004 08:45 | (4) http://www.firststeps.ru/msoffice/win/bats/r.php?2
Rovan 10 - 03.11.2004 08:48 | (7) http://service-orel.narod.ru/support/aldoc/manual/urbd/urbdadd.html
oleg_r 12 - 03.11.2004 09:16 | Используй скрипты. (WSH, JScript, VBScript).


Как распечатать журнал регистрации? | База знаний | mista.ru

Как распечатать журнал регистрации?

FAR 25.05.2004 12:50 | На журнал наложено несколько условий, журнал НЕОБХОДИМО распечатать. Вариант печатать mlg файл "как он есть" некрасивый, делать скриншоты - муторный. Что посоветуете?
Valery 1 - 25.05.2004 13:02 | Сканировать его как текстовый файл по строкам и отбирать по условию нужные для печати
FAR 2 - 25.05.2004 13:05 | Просто в журнале хорошо: там уже все нужные ссылочки найдены, типы действий - по русски написаны. В текстовом все это изменять надо.
Valery 3 - 25.05.2004 13:10 | Конечно в журнале хорошо, но если часто придётся печатать, то есть смысл свою обработку сочинить.
Guk 6 - 20.07.2004 16:30 | (0) Ссылка на формат журнала регистрации: http://www.sinor.ru/~my1c/knowhow/form_mlg.html Чтобы распечатать ЖР, необходимо просто пробежатьсь по файлу 1cv7.mlg (лучше с помощью V7Plus, если файл большой) и в соотвествии с форматом выводить строки в таблицу в соответствующие ячейки.
NS 9 - 01.11.2004 20:02 | Например - http://1c.proclub.ru/modules/mydownloads/personal.php?cid=5&lid=1675 http://1c.proclub.ru/modules/mydownloads/personal.php?cid=5&lid=3868
NS 10 - 01.11.2004 20:04 | http://1c.proclub.ru/search.php?query=%C6%F3%F0%ED%E0%EB+%F0%E5%E3%E8%F1%F2%F0%E0%F6%E8%E9&mid=21&action=showall&andor=AND


Вылетает 1С при вводе нового документа | База знаний | mista.ru

Вылетает 1С при вводе нового документа

Albert_Nas 20.10.2004 10:40 | Конфа: 1С Бух.460+MSSQL2000+MSServer2000 Создаю в конфе новый документ - любой. Сохраняю. Запускаю 1С. Пытаюсь создать документ - вылетаю к чертовой бабушке. Тестировал БД - не помогает. Кто знает в чем проблема?
Мелена 2 - 20.10.2004 10:49 | Нет общего реквизита типа "документ" с галкой "Отбор" ? У меня при таком реквизите в SQL вылетало на создании новой операции.
Albert_Nas 3 - 20.10.2004 10:57 | Есть общий реквизит типа "Автор" и "Редактор" с галкой "Отбор". А в чем проблема?
Мелена 4 - 20.10.2004 11:03 | Не знаю, Ваша проблема может и не в этом. Но у меня из-за этих галок и загрузка в SQL вылетала. Уберите галки или попробуйте поставить эти реквизиты в конец списка.


1С + SQL не подключается | База знаний | mista.ru

1С + SQL не подключается

ernest2000 15.10.2004 23:48 | Не подключается 1С к SQL2000. Выдается сообщение сервер отсутствует или нет доступа. Что можно посмотреть? Сеть обязательно должна быть доменная?
MMF 1 - 15.10.2004 23:51 | посмотри какой на сервере режим аутентификации и какие сетевые протоколы выбраны доступными на сервере и на клиентах
ernest2000 2 - 15.10.2004 23:56 | Режим аутентификации - как в Windows. Протокол TCP/IP. При подключении пробовал пароль администратора сервера.
Warlock 4 - 16.10.2004 00:36 | 2 ernest2000: Даже если ты сделал аутентификацию - как в Windows, в поле пользователь надо прописать "sa"(или может другого пользователя SQL с нужными правами на SQL базу). Пароль к "sa" задается в Enterprise Manager/ Security/ Logins. Можешь поставить Named pipes - должно заработать, но будет медленнее, чем при TCP/IP. Чтобы настроить TCP/IP для SQL поставь на клиенте SQL Client Tools и в Client Network Utility задай нужные протоколы. ЗЫ Проверь правильность указания имени сервера и базы. Кстати, а как ты их прописал?
ernest2000 6 - 17.10.2004 00:51 | Получилось! На клиенте поставил SQL Client Tools и в Client Network Utility. Прописал протоколы. В SQL сервере создал нового пользователя. Прописал параметры в 1С. 1С выдал сообщение, что к базе может обращаться только ее владелец. Через Query Analyzer с помощью хранимой процедуры sp_changedbowner поменял владельца на того пользователя, которого создал. В 1С в поле пользователь указал не "sa", а этого пользователя. И все получилось.


При загрузке дает ошибку доступа к таблице DH(номер) | База знаний | mista.ru

При загрузке дает ошибку доступа к таблице DH(номер)

Васисуалий
26.09.2004 14:05 		Здрасьте вам. У меня такая проблема - при загрузке 1С 7.7 сетевой дает ошибку доступа к таблице DH и какой то номер. Шо за фигня и что с этим делать??
SKrin
4 - 26.09.2004 14:16 		Шо за система, конфигурация сети, пробовал ли ты запускать базу локально, монопольно?
Васисуалий
5 - 26.09.2004 14:20 		Итак, по порядку - 1С 7.7 релиз 15, сеть - на НОвелл Нетваре 5.1 клиенты - 95, 98, 2000 винды. Под 2000 и одной из 98 все в порядке а еще на 3-х компах (98 на них) ругается на ошибку. Локально базу запускал на 98 - все путем. Только переиндексироваться попросила. Сейчас идет тестирование и исправление БД, посмотрю что будет.
Васисуалий
8 - 26.09.2004 14:51 		На серваке лежит. А вот насчет кэширования - гм. Знал бы я где это посмотреть (админ в отпуске). Если кто поможет - зело благодарен буду.
F427
9 - 26.09.2004 15:50 		(7) Кеширование - отдыхает... Хотя для скорости - надо крутить...

(0) надо на консоли сервера выполнить след команды
SET Maximum Service Processes = 500
SET Maximum Packet Receive Buffers = 5000
SET Minimum File Cache Buffers = 2000
SET Minimum Directory Cache Buffers = 5000
SET Minimum File Cache Report Threshold = 2000
SET Maximum File Locks = 100000
SET Maximum File Locks Per Connection = 1000
SET Maximum Record Locks = 400000
SET Maximum Record Locks Per Connection = 100000
SET Maximum Concurrent Disk Cache Writes = 4000
SET Maximum Concurrent Directory Cache Writes = 250
SET Maximum Directory Cache Buffers = 100000
SET Directory Cache Buffer NonReferenced Delay = 60
SET Maximum Number Of Directory Handles = 1000
SET Maximum Number Of Internal Directory Handles = 500
SET Maximum Extended Attributes per File or Path = 256
SET Dirty Disk Cache Delay Time = 2.5
SET Directory Cache Allocation Wait Time = 5
SET Read Ahead LRU Sitting Time Threshold = 1800
SET Load Balance Local LAN = On

SET Enable File Compression = Off
SET Maximum Concurrent Compressions = 1
SET Deleted Files Compression Option = 0
SET Dirty Directory Cache Delay Time = 5
SET Maximum Pending TCP Connection Requests = 4096

некоторые установки к твоей проблеме отношения не имеют... Но лучше сделать...
И добавить эти установки в файл автозагрузки, чтобы они отрабатывали всегда при загрузке...

для проверки достаточно выполнить команды
SET Maximum File Locks = 100000
SET Maximum File Locks Per Connection = 1000
SET Maximum Record Locks = 400000
SET Maximum Record Locks Per Connection = 100000

и главное - команду типа (написание уточни в нелпе - там отличный хелп)

Set maximum file open per connection = 1000
F427
10 - 26.09.2004 15:51 		главное - последняя строка из (9)
макс количество открытых файлов на соединение....
GrayT
11 - 26.09.2004 16:30 		Была такая проблема, когда один из пользователей коряво вылетал из сети. Проще всего отключить всех пользователей и посмотреть, какое соединение держит данный файл и прибить это соедиенение. Правда я иногда по другому извращался (без изгнания пользователей)
F427
12 - 26.09.2004 17:27 		в мониторе на консоли и так поглядеть можно...
Xelon
13 - 10.10.2004 20:36 		У меня такую ошибку выдавал, когда в винде ХП (настройки сетевого подключения) стояла фишка, что все неизвестные регистрируются как гости. После того, как я завел учетные записи на машине с базами для всех пользователей в сети, больше такая ошибка не появлялась. Может и в Нетваре такая фишка есть.


1С под Линукс. Не пинайте | База знаний | mista.ru

1С под Линукс. Не пинайте

Старуха Юзергиль 08.10.2004 16:51 | На Кубани с 4-го октября уверяют, что появился. Кто видел\щупал?
Рупор абсурда 10 - 08.10.2004 17:10 | http://www.kuban.ru/forum_new/forum9/files/202601.html
Таня 12 - 08.10.2004 17:11 | http://www.linux.org.ru/profile/MoS/view-message.jsp?msgid=672428


Ожидание блокровки журнала | База знаний | mista.ru

Ожидание блокровки журнала

truck 04.10.2004 10:07 | Уважаемые профи, помогите советом неопытному! 20 пользователей, при формировании доков сообщение " ожидание блокировки журнала", и соотв. ошибка транзакции после периода времени, перезагрузка сервера дает эффект мин. на 10, работа в ступоре, куда копать, помогите советом, плиз.
Волшебник 1 - 04.10.2004 10:10 | Сокращай время записи и проведения документов. Переводи часть пользователей на терминал. Расскажи, что за конфигурация? Какое железо на сервере и клиентах? Какая сеть?
truck 3 - 04.10.2004 12:19 | Как сокращать время записи и проведения документов? Такая проблема возникает периодически, с чем связана не понятно. Может что 3 пользователя подключаются удаленно, по модему? Рабчие станции неплохие, сервер: проц. 2 Ghz, 2 гб память, Windows 2000; v7.7 Бухгалтерия, масса доработок, сделанных предшественником, MSSQL сервер. Сделал архивирование журнала регистрации, вроде пока нормально, но в целом понимаю, что не выход.
Волшебник 4 - 04.10.2004 12:22 | (3) Проблема возникает из-за архитектуры 7.7. При записи и проведении любого документа блокируется таблица 1sjourn. На время блокировки другой документ не может быть записан или проведен. Удаленные пользователи на модеме работают через терминал?
Fеникс 6 - 04.10.2004 13:16 | (3) "3 пользователя... по модему" - ИМХО, суицид чистой воды. Как вариант облегчения жизни можешь посмотреть http://1c.proclub.ru/modules/mydownloads/personal.php?cid=5&lid=3931
Warlock 11 - 04.10.2004 23:12 | Транзакции возникают не только при проведении документов, а и при НачатьТранзакцию(); ЗафиксироватьТранзакцию(); Тебе нужно поискать длительные(по времени) транзакции. А также недопустимо в транзакции(можно читать и: модуле проведения документа) использовать элементы, останавливающие выполнение кода, например, Предупреждение(), Вопрос() и др.


Помогите! Как ограничить доступ к элементам справочника? | База знаний | mista.ru

Помогите! Как ограничить доступ к элементам справочника?

Ольга 01.10.2004 13:49 | Как в справочнике сделать элементы доступными для открытия только если их пытается открыть определенный пользователь, т.е. если, например, значение реквизта <менеджер> совпадает с именем пользователя.
SnarkHunter 1 - 01.10.2004 13:52 | СтатусВозврата(0) в ПриОткрытии()
1С: Новичок 2 - 01.10.2004 13:55 | Процедура ПриОткрытии() Если ИмяПользователя() <> <реквизит справочника> Тогда СтатусВозврата(0); КонецЕсли; КонецПроцедуры


Архивация базы | База знаний | mista.ru

Архивация базы

psk21office 20.09.2004 18:42 | Как часто и куда лучше делать архив базы? * несколько раз в день, раз в день, раз в неделю или реже * на жеский диск, на СД, на ленту, другое От чего это зависит?
psk21office 17 - 21.09.2004 14:32 | В общем обобщаю: Архивация баз: * раз в день (можно меньше при малом документообороте, но не реже 1 раза в месяц); * обязательно перед обновлением базы; * желательно после обновления базы; * желательно указывать в названии архива Наименование организации и дату архива; Местоположение архивов баз: * на другой жеский диск (отличный от диска баз и только для временного хранения) на срок не более 1 недели; * на другой компьютер; * на CD/DVD (не реже 1 раза в месяц (перед сдачей отчетности)); * на ленту (1 раз в день). Спасибо всем за ответы и пожелания.


Подавление вопроса "Вы действительно хотите закончить работу с программой" | База знаний | mista.ru

Подавление вопроса "Вы действительно хотите закончить работу с программой"

ken_gd 17.09.2004 09:16 | Не подскажете как подавить выдачу вопроса "Вы действительно хотите закончить работу с программой"?
YamMike 1 - 17.09.2004 09:18 | Если в ТиСе, то Справочники - Структура компании - Пользователи - Значения по умолчанию - убери галочку
Никитос 7 - 17.09.2004 09:26 | В Бухгалтерии: Сервис - Индивидуальная настройка - "Запрашивать подтверждение при выходе из программы".
Ну раз 8 - 17.09.2004 09:30 | ... пошла такая пьянка, то в ЗиКе Сервис->Настройки пользователя->Запрашивать подтверждение при выходе из программы


Ошибка SQL State: 23000 Native: 1505 - мое решение проблемы | База знаний | mista.ru

Ошибка SQL State: 23000 Native: 1505 - мое решение проблемы

Arhitektor
15.09.2004 13:30 		Это проблема возникла у нас вчера и сегодня закончилась нашей победой. Я изложу ход решения проблемы, может кому и пригодиться.

При загрузке в монопольном режиме SQL ругается:
SQL State: 23000
Native: 1505
Message: [Microsoft][ODBC SQL Server Driver][SQL Server]CREATE UNIQUE INDEX terminated because a duplicate key was found for index ID 2. Most significant primary key is ' 6OJ '.

SQL State: 01000
Native: 3621
Message: [Microsoft][ODBC SQL Server Driver][SQL Server]The statement has ben terminated.

При загрузке в обычном режиме выскакивает ошибка:
Нарушена структура индексного файла 1scrdoc. Запустите программу в монопольном режиме.

Действовал я следующим образом:
1) Открыл файл 1Cv7.DDS и нашел в нем описание индексов таблицы 1scrdoc:
#----Indexes------
# Name |Descr |Unique |Indexed |Type I=PK__1SCRDOC |ROW_ID |1 |ROW_ID |1
I=CHILD |Child Referenc|1 |CHILDID,MDID,PARENTVAL |1 I=PARENT |Parent Referen|1 |MDID, PARENTVAL, CHILD_DATE_TIME_IDDOC |0

Насколько я понял
ID1 = ROW_ID
ID2 = CHILDID
ID3 = MDID
ID4 = PARENTVAL
ID5 = MDID
ID6 = PARENTVAL
ID7 = CHILD_DATE_TIME_IDDOC

2) Поскольку ошибка в ID 2, то в Query Analyzer выполняю следующий код
SELECT [ROW_ID],
[MDID],
[PARENTVAL],
[CHILD_DATE_TIME_IDDOC],
[CHILDID],
[FLAGS]
FROM [Buh].[dbo].[_1SCRDOC]
WHERE [CHILDID] like '%6OJ%'

P.S. Можно, конечно, и без [FLAGS], но...

3) В получившейся выборке нахожу одинаковые записи, т.е. записи, в которых различаются только 2 поля [ROW_ID] и [FLAGS] и одну из них удаляю.
P.S. Я удалял записи с большим [ROW_ID].

4) Снова запускаю в монопольном режиме. У меня снова выругалось:
SQL State: 23000
Native: 1505
Message: [Microsoft][ODBC SQL Server Driver][SQL Server]CREATE UNIQUE INDEX terminated because a duplicate key was found for index ID 7. Most significant primary key is ' 6OJ '.

SQL State: 01000
Native: 3621
Message: [Microsoft][ODBC SQL Server Driver][SQL Server]The statement has ben terminated.

т.е. теперь тоже самое только в поле [CHILD_DATE_TIME_IDDOC]. Делаем 2). Запрос в данном случае имеет вид
SELECT [ROW_ID],
[MDID],
[PARENTVAL],
[CHILD_DATE_TIME_IDDOC],
[CHILDID],
[FLAGS]
FROM [Buh].[dbo].[_1SCRDOC]
WHERE [CHILD_DATE_TIME_IDDOC] like '%6OJ%'

и дальше по пункту 3)
Потом снова 4), у меня выдало тоже ID7, только ' 6WI ' и т.д., пока не запустится :)

Прошу прощения если что-то не так, но думаю более опытные подправят если что не так.

С уважением,
Arhitektor


Можно ли в терминале установить больше, чем 256 цветов? | База знаний | mista.ru

Можно ли в терминале установить больше, чем 256 цветов?

Вик 15.09.2004 08:47 | Просмотрел все настройки - ничего... Дело в том, что в системе есть фото номенклатуры, и в терминале не все разглядеть удается
Черт 2 - 15.09.2004 08:53 | Можно, в настройках подключения к удаленному компу
Мулька 3 - 15.09.2004 08:56 | (2) Это начиная с ХР, в 2000-ой/НТ - в актив директори
SKrin 4 - 15.09.2004 08:57 | на 2000 server-до 8бит, на 2003 - до 16бит
F427 5 - 15.09.2004 09:00 | нагрузка на сетку возрастет и нехило... Но если надо - подними только для тех, кому это надо реально....
laeg 6 - 15.09.2004 09:01 | Протокол RDP для В2К - 256 цветов Протокол RDP для В2К3 - Hi Color 16 Bit Протокол ICA - В2К, В2К3, возможно установка до Hi Color 24 bita (Если память не изменяет)
Вик 7 - 15.09.2004 09:05 | А как установить этот протокол ICA - у меня W2K (2) - нет там выбора кроме 256
laeg 8 - 15.09.2004 09:11 | Citrix MetaFrame Вешь эта в обще-то платная, но лекарство уже давно найдено (да простят меня модераторы) Поищи в интернете.


Не ведется журнал регистрации в V8 (он пустой) - в чем может быть причина? | База знаний | mista.ru

Не ведется журнал регистрации в V8 (он пустой) - в чем может быть причина?

Andrey_Kukanov 01.10.2004 20:55 | Управление торговлей 8.10.1.9 на программных файлах 8.0.8.7 журнал регистрации не заполняется... (сразу оговорю: смотреть журнал умею, кряк на 1Су надежный - ключ, просьба не кидаться пустыми словами - только по делу)
Волшебник 1 - 01.10.2004 20:58 | Его надо включить в Конфигураторе. По умолчанию он выключен.
cons_adm 3 - 01.10.2004 20:59 | В режиме конфигуратора, в меню: Администрирование->Настройка журнала регистрации...


Чем ремонтировать файл БД? | База знаний | mista.ru

Чем ремонтировать файл БД?

tim 20.09.2004 16:18 | Существует несколько программ работы с MD файлом, а как обстоит дело с v8. Как например извлечь какую-нибуть таблицу из 1CD?
Волшебник 1 - 20.09.2004 16:19 | Есть штатная утилита, лежит в каталоге BIN
Волшебник 2 - 20.09.2004 16:19 | Утилита для тестирования и исправления. Еще можно через конфигуратор и меню Администрирование Извлечь таблицу из 1cd пока никто не может.


v8 Вылетает при обновлении | База знаний | mista.ru

v8 Вылетает при обновлении

Nikulin 10.09.2004 10:23 | Помнится удалил какойто реквизит, только не помню какой... Теперь не могу запустить пользовательский режим. Вылетает с ошибкой: Ошибка SDBL Таблица или поле ParentID не содержится вразделе FROM (pos=37) И че теперь делать? :(
Nikulin 4 - 10.09.2004 10:40 | Изменения в справочнике: "Иерархия элементов" Была изменена на "Иерархия групп и элементов" Вернул все в зад .. ошибка исчезла
Nikulin 5 - 10.09.2004 10:43 | Дополнение. В этом справочнике уже были элементы. Удалил все элементы, изменил вид иерархии => все получилось без ошибки. Выводы: На рабочей базе такое сделать не получится.


Установка 1С | База знаний | mista.ru

Установка 1С

Linux1987 01.06.2004 18:58 | Как установить 1С Бухгалтерию на Windows XP
Волшебник 1 - 01.06.2004 18:59 | setup.exe
lexa 3 - 01.06.2004 19:01 | идеологически парвильно - панель управления - установка и удаление программ - установка новой программы
Ром 4 - 01.06.2004 19:01 | Устанавливаешь платформу, а затем ставишь нужные конфигурации.
Волшебник 5 - 01.06.2004 19:08 | (4) А в 8.0 платформу и конфигурации можно ставить в любом порядке. Только после установки конфигурации нужно создавать новую информационную базу ПО ОБРАЗЦУ (из установленного шаблона).


Ошибка открытия словаря базы данных?!??! | База знаний | mista.ru

Ошибка открытия словаря базы данных?!??!

Sash 12.07.2004 17:39 | Беру md-ник пишу в чистый каталог, создаю новую базу, конфигуратор открывает, а в режиме 1с Предприятия вылетает ошибочка с кодом -10(Ошибка открытия словаря базы данных?!??!) Пробовал менять кодовые Иб, не помогает :(( Что делать?
427 2 - 12.07.2004 18:25 | (1) неверно. Надо тронуть метаданные или синоним в них... прсото текст в модуле - не канает
SnarkHunter 6 - 13.07.2004 07:01 | (5)Рано еще... Ибо создать словарь можно (и нужно) без изменения метаданных... Достаточно просто использовать пункт меню "Загрузить измененную конфигурацию", указав исходный файл 1cv7.md...


1C по сети | База знаний | mista.ru

1C по сети

Pacifist 06.07.2004 23:08 | Сабж покажется смешным для гуру, НО Я вот 1С(7.7) поставил, 2 недели бился с ним при помощи научного тык, метода пристального взглядывания и различной литературы.....Все бы хорошо, однако работал я с 1С локально(читай на 1-м компьютере).... А вот и вопрос: как работать с 1С по сети, и как правильно его по сети ставить(клиент-сервер?)
Warlock 1 - 06.07.2004 23:27 | В сетевой версии есть "Административная" установка - вот ее и выбираешь. Потом ту папку, куда ты ее поставил, надо расшарить(можно только на чтение). Потом с другого компа запускаешь из расшареного каталога "setup.exe" - далее как обычно. На сервере надо запусить сервер защиты HASP ключа, чтобы другие машины видели ключ защиты. Осталось только настроить пути к базам. Все.
gr13 2 - 07.07.2004 08:57 | (0) 1. устанавливаешь конфу, на свое усмотрение локальную установку или административную, никогда не ставлю административную установку, т.к. ИМХО больше загружается сеть. 2. Устанавливаешь драйвер ключа. 3. на компе на котором у тебя ключ запускаешь менеджер лицензий, Пуск/Программы/1С Предприятие/... 4. устанавливаешь остальные компы точно также, только менеджер лицензий не запускаешь. 5. на серваке (не суть где) устанавливаешь базу. Расшариваешь каталог с базой, делаешь полный доступ. а. если на компе с базой стоит win98, то будет ограничение на количество подключений: не более 3 из-за ограничение виндов на открытие файлов 1024. пользуйся
Warlock 3 - 07.07.2004 09:05 | (2,0)Преимущества административной установки: в каталог BIN с установленной 1С административно, ложишь дополнительные dll-ки, файлы прописи spl и т.д. и они становятся виды сразу во _всех_ конфах... При установке 1С локально надо или в каждую базу запихивать это все или на каждую машину...
BorisG 8 - 07.07.2004 09:21 | (3) Недостатки административной установки... Дополнительно нагружается и без того нагруженная сеть... В случае проблем с сетевыми картами, что вообще-то не редкость в силу "особой" любви к некоторым марким (чтобы не рекламировать, называть не буду)... повляются дополнительные глюки...
saser 14 - 07.07.2004 10:57 | По администрированию 1с в сети см. http://mista.ru/articles1c/admin.htm#_Toc503983565 как работать с 1с в терминальном режиме см. http://mista.ru/articles1c/terminal.htm как установить 1с "клиент-сервер" см. http://zone1c.narod.ru/docs/dbf2sql/index.htm


Требуется помощь: НеМогуУстановить1С:Булгалтерию 6.0 на WindowsXP | База знаний | mista.ru

Требуется помощь: НеМогуУстановить1С:Булгалтерию 6.0 на WindowsXP

romix 7 - 02.07.2004 01:32 | Под Windows 2000 шестерка работает, но глючат шрифты. Надо идти в Сервис-Параметры (кажется так) и перенастраивать там шрифты с Иврита на Кириллицу. Под XP тоже должна работать - попробуй короче устанавливать ее под именем пользователя Admin (длинные русские имена наподобие Администратор со старыми установщиками InstallShield иногда глючат - это проявляется тем, что программа падает где-то в конце установки, и ничего не происходит).
fillex 8 - 02.07.2004 09:21 | ***Под XP тоже должна работать - попробуй короче устанавливать ее под именем пользователя Admin (длинные русские имена наподобие Администратор со старыми установщиками InstallShield иногда глючат - это проявляется тем, что программа падает где-то в конце установки, и ничего не происходит).*** это лечится изменением переменной среды пользователя, берешь там и пишешь c:\temp для обеих переменных и все должно быть ок.
gr13 9 - 02.07.2004 10:22 | (8) плюс отключить автоматическое восстановление системы на дисках с базами, потом в свойствах ярлыка для запуска 6.0 можно поставить режим совместимости с системой WIn NT
romix 10 - 03.07.2004 01:15 | (8) Про переименование переменной temp я знаю, но никогда это делать не советую. Когда новички начнут юзать терминал (а вдруг?), потом концов не найдут, а откуда же глюки и взаимные конфликты.


Конфигурация | База знаний | mista.ru

Конфигурация

VladZagorsky 1 - 02.06.2004 04:59 | Че-то я не совсем понял, что тебе нужно: создать пустую конфигурацию (такую, как в другой организации) или посмотреть данные с другой организации??? Если тебе нужна их конфигурация (без их данных) - перепиши себе файл *.dd и *.md. Если тебе нужна конфигурация с данными - у них сохрани, у себя восстанови. Примечание: это в том случае, если 1С "крутится" на DBF.
meet 2 - 02.06.2004 05:38 | Спасибо, вроде все получилось.Создали новый каталог, скопировали МДшник(кстати вопрос МДшник можно из любой конфигурации? (зарплата, бухгалтерия, торговля). Зашли в конфигуратор и сразу восстановили данные из зип файла.
VladZagorsky 3 - 02.06.2004 06:49 | Хм. Рад за тебя. Воообще-то когда в конфигураторе сохраняешь данные, в архив записывается и МДшник, и ДДшник. Т.е. достаточно сохранения/восстановления. Повторюсь еще раз: "Если тебе нужна их конфигурация (ЧИСТАЯ !!! БЕЗ ДАННЫХ !!!) - перепиши МДшник и ДДшник".
SnarkHunter 4 - 02.06.2004 06:51 | Достаточно md...
gr13 5 - 02.06.2004 08:46 | после этого запусти в монополном режиме... а вообще все просто: 1. зайди в конфигуратор 2. администрирование/ сохранить данные 3. переносишь архив себе 4. создаешь пустую базу а) создаешь пустой каталог б) добавляешь новую базу (в окне по выбору базы для загрузки), в этом каталоге в) открываешь ее через конфигуратор 5. администрирование/восстановить данные и так каждый раз, кроме пункта 4, тогда просто открываешь эту базу через конфигуратор и делаешь пункт 5
meet 6 - 03.06.2004 11:59 | Вот незадача. Привезли архивы баз, а у них в отличии от нас комплексная конфигурация. У нас отдельные конфигурации. Как быть?


Подключение SQL-базы | База знаний | mista.ru

Подключение SQL-базы

Zerg 28.05.2004 07:27 | Подскажите плиз чайнику :) Как готовую SQL-базу подцепить в 1С? Создал пустой каталог, захожу в режиме Конфигуратор, выбираю SQL. Затем в Администрировании указываю SQL-сервер, SQL-базу, имя и пароль, нажимаю ОК. И что дальше-то? ничего не происходит...
SnarkHunter 1 - 28.05.2004 07:28 | А чего ты ждешь-то?
Zerg 2 - 28.05.2004 07:34 | Ну как чего? Структура-то не загрузилась! :)
Zerg 4 - 28.05.2004 07:41 | Какую выгрузку? Я на SQL-сервере создал новую базу и загнал в нее бэкап SQL-ной базы. Восстановил типа. Как теперь ЭСкой достучаться???
Vser1 5 - 28.05.2004 07:55 | Что-то сложно, я так не безобразничаю, если надо изменить базу: делаю выгрузку из конфигуратора, а затем загружаю ее заново в чистую базу, бекапы SQL не востанавливал еще ни разу. Подожди может кто и подскажит чего хорошего...
spock 7 - 28.05.2004 08:18 | Если базу восстановил из бекапа прально, то все должно работать... Вопрос: ты про структуру таблиц говоришь или про МД? Есть мнение, что второе. А если второе, то кинь в папку МД :)
very-mary 8 - 28.05.2004 08:21 | еще надо в каталог 1с скопировать (из архива восстановить) базу (не SQL сервера *.dat, а которая в каталоге 1с *.md содержит)
Zerg 9 - 28.05.2004 08:34 | spock Базу восстановил правильно. Как про какую структуру? Дерево МД должно обновиться или нет как я с сервером законнектился? А где я md-шник возьму? Есть всего один файл - Trade_1C_2ver_db_200405270100.BAK ВСЁ! При восстановлении образовались 2 файла: Trade_1C_2ver_log.ldf и Trade_1C_2ver_data.mdf very-mary Читай выше, ничего такого нету!
spock 10 - 28.05.2004 08:37 | 2(9)Ты наверно что-то не понял в этой жизни... Сервер SQL даже понятия не имеет, что на свете есть такая программа 1с и уж тем более не знает, что есть такой файл MD, который нужно бекапить. Намек ясен?
BorisG 11 - 28.05.2004 08:40 | (10) Не... не дошло, он ЖКК не читал, и структуру не знает. Посему эти файлы скорее не сохранил...
Zerg 12 - 28.05.2004 08:52 | (10)(11) Бэкап делал не я, мне принесли один файл - Trade_1C_2ver_db_200405270100.BAK и сказали - "Здесь бэкап SQL-базы, восстанови у нас" Т.е. восстановить не реально?
SnarkHunter 13 - 28.05.2004 08:56 | Реально... Только не факт, что 1С будет с ней работать...
spock 14 - 28.05.2004 08:57 | Андрей, факт, что не будет работать :)
SnarkHunter 15 - 28.05.2004 08:57 | Я так и думал...
Zerg 16 - 28.05.2004 09:06 | Не правильно снят бэкап? А как правильно надо?
spock 17 - 28.05.2004 09:10 | Бекап сделан правильно, но не весь. :-) Базы архивируются средствами сервера... программные файлы средствами 1с. Рассказать как? зы: злой я сегодня...
spock 19 - 28.05.2004 09:33 | так я злой не на тебя .... :-) Это к слову просто. Че не хватает?... Сделай в конфигураторе архив... всего будет хватать. А вообще проще попросить MD and DD. Если конфа не меняется, ьак его вообще положить в сторонку и помнить, что оно там есть.
Zerg 20 - 28.05.2004 09:36 | Мне нужна ВСЯ база, а не толькао МД и ДД. Ты скажи ЭТОТ бэкап можно выкинуть? Сама база ведь восстановилась млин...
spock 21 - 28.05.2004 09:41 | таак. До меня дошло. Так бы и сказал, что понятия не имеешь, что делать. Бекап выкидывать не нужно! Он нормальный. Просто после того как восстановил на сервере базу нужно создать пустой каталог для 1с. Бросить туду мд и дд. Укзать 1с, что это ее новое место. Зайти в конф-р. Прописать настройки до сервера. Все.
Asmody 24 - 28.05.2004 10:38 | только не DD а DDS
Zerg 26 - 28.05.2004 11:26 | Короче выслали мне один МДшник. Бросил я его в пустой каталог, загружаю конфигуратор, завожу пользователя, делаю соединение с сервером, запускаю предприятие и опа - "Не определены параметры базы данных! Для определения следует воспользоваться Конфигуратором"... Что еще определять-то???
SiMazx 27 - 28.05.2004 11:32 | В пофигураторе Администрирование->Параметры базы SQL Дальше сообразишь...
Zerg 28 - 28.05.2004 11:33 | (27) Я же писал "делаю соединение с сервером" ! :\ Прописано всё...
SnarkHunter 29 - 28.05.2004 11:34 | Значит не все...
Zerg 30 - 28.05.2004 11:38 | (29) Прописано: СЕРВЕР, БАЗА ДАННЫХ, ПОЛЬЗОВАТЕЛЬ и ПАРОЛЬ. Подскажи что же я "пропустил"?
SiMazx 31 - 28.05.2004 11:41 | Какого пользователя пишешь?
Zerg 32 - 28.05.2004 11:44 | (31) Своего. Мне users.usr не прислали...
SiMazx 33 - 28.05.2004 11:46 | Я не про это... В пользователе в параметрах базы SQL прописываешь пользователя sa, которого прописывал в SQL сервере...
Zerg 34 - 28.05.2004 11:48 | (33) Да, пишу sa и пароль... На это конфигуратор не ругается, он ваще молчит :)
SiMazx 35 - 28.05.2004 11:53 | Тэээкс... В каталоге базы файл .dds есть?
Zerg 36 - 28.05.2004 12:03 | (35) Нету... Только DBA и MD
SiMazx 37 - 28.05.2004 12:05 | Тэээкс... Попробуй зайди в конфигурацию... Сделай какое нибудь изменение... Типа пробел лишний в модуле... И сохраняй...
SnarkHunter 38 - 28.05.2004 12:08 | Попроще можно - просто загрузить свой же мдшник как измененный...
SiMazx 39 - 28.05.2004 12:10 | Тож вариант...
Zerg 40 - 28.05.2004 12:14 | 3 ошибки: SQL State: 42000 Native: 5070 Message: [Microsoft][ODBC SQL Server Driver][SQL Server]Database state cannot be changed while other users are using the database 'имябазы' SQL State: 42000 Native: 5069 Message: [Microsoft][ODBC SQL Server Driver][SQL Server]ALTER DATABASE statement failed. SQL State: 42000 Native: 15627 Message: [Microsoft][ODBC SQL Server Driver][SQL Server]sp_dboption command failed.
Zerg 41 - 28.05.2004 12:20 | (38) Загрузить измененную получилось, но при старте Предприятия теже 3 ошибки...
Vser1 42 - 28.05.2004 12:25 | Проверь параметры юзера "sa" на скульном серваке, похоже он не является dbo (владельцем базы с полными правами) для базы востановленной из бекапа.
spock 43 - 28.05.2004 12:31 | Снять галку с базы: "Restrict access" Закрыть EM и QA. Агента потушить.
Zerg 44 - 28.05.2004 12:33 | (42) Вроде все нормально...
Zerg 45 - 28.05.2004 12:38 | (43) Галка снята... EM закрыт, что за QA я не знаю :) короче все закрыто. Агнет какой? SQL Server Agent? Не запущен...
spock 46 - 28.05.2004 12:44 | Из расчета, что СКЛ 2к. Какой сервис-пак? а может и не 2к?
spock 47 - 28.05.2004 20:26 | Ну а если честно, то моя фантазия кончилась....


Переинстоляция сервера? | База знаний | mista.ru

Переинстоляция сервера?

Makalu 18.05.2004 14:57 | Сам администратор и программист со стажем 30 лет. С 1с никогда не связывался. Есть : 2-а сервера , на одном sql на другом сам софт + клиенты на станциях. Нужно: Вместо 2-х серверов оставить один , без потери данных. Требуется: Как это все проделать? Если можно подробнее или где это можно посмотреть, прочитать? Спасибо.
Inside 1 - 18.05.2004 16:29 | а что такое САМ СОФТ? Сервер защиты штоль? Или у тебя там терминал поднят? Если терминал, то объединять серваки категорически не советую.
Inside 2 - 18.05.2004 16:33 | А! Догнал! САМ СОФТ это наверное конфа с юзерскими каталогами... Дык перекинь енту шару на скульный сервак и дело с концом, правда в настройках на станциях придётся перепрописать путь к "информационной базе".


Настройки 1с+Терминал2000 | База знаний | mista.ru

Настройки 1с+Терминал2000

Timur 23.04.2004 13:06 | Подскажите пожалуйста какие настройки должны быть у сервера для оптимальной работы 1с - может есть какие то мелкие хитрости
Черт 1 - 23.04.2004 13:21 | настройка хасп.ini
Timur 3 - 23.04.2004 14:27 | Грабли собственно как всегда в ТОРМОЗАХ то есть всякого рода отчеты проводки и тд. Были у нас представители других магазинов с аналогичной базой и говорят что все летает у них а у нас тормоза:( чувство такое что гдето я с настройками сервака перепутал ключа - нет поставил Sable Принтер HP laser 100 series а собственно есть ли разница (про принтер) И настройки вышли если можеш
Черт 4 - 23.04.2004 14:46 | Для точного установления диагноза и получения помощи, необходимо доп.информация, типа 1 лицензионная 1С? 2 какая сеть? со всеми параметрами 3 ?
Igrik 5 - 23.04.2004 14:46 | Разница про принтер еще и какая! некоторые принтера наглухо отказываются работать с ключом, приходится на лицензионную конфигурацию саблю ставить, никакие изменения в настройках принтера не помогают. Ко мне уже человек пять с этим обращались. Настройки терминала высылаю, там здорово админить то и не надо, в основном все по умолчанию нормально бегает. Обрати внимание на то, что бы у всех пользователей были прописаны пути к их рабочей среде и профилям, если вделенка есть не забудь с знаменитым диапазоном адресов по сети, а то глючить будет. У меня база уже 700мб, 18 юзеров и никто вроде бы не жалуется и машинка так себе, почти, что клиентская и никаких SQL. Если что пиши!
SnarkHunter 10 - 13.05.2004 13:05 | (5)Ставь ключ на машину, у которой не подцеплено принтеров...


Установка 1С | База знаний | mista.ru

Установка 1С

Вася 13.05.2004 14:18 | Помогите разобраться! Где можно почитать про установку 1с. Какие ресурсы используются Сервера или Клиента если ядро установленно на Сервере.
Вася 2 - 13.05.2004 14:32 | Про ядро. Интересно сравнить установку сетевой и локальной. Если есть различия. Просто проблемма, устанвлена сетевая на одном компе, а все остальные с него ее качают. Нужно узнать чьи ресурсы задействованы.
Вася 5 - 13.05.2004 14:54 | Перевод: На ПК №1 стоит сетевая 1с (ключ тоже здесь, Вопрос: Можно ключь поставить на другой ПК?)на ПК №2 ... №N есть ярлык (на сетевую 1с ПК №1) Когда пользователь с ПК №K запускает 1с какие ресурсы используются (ПК №1 или ПК №K)? Можно сетевую 1с установить на каждый ПК №2 .. ПК №N при этом использовав только один ключ?
gr13 9 - 13.05.2004 14:57 | мдааа... началось. 1. Напиши версию программы. (не знаю тоже подходит как ответ) 2. Просто так ключь переставить низзя, нужно еще дополнительные проги на ПК2 устанавливать
Valery 13 - 13.05.2004 15:01 | Сделай как все. Поставь не каждое рабочее место 1С (локальная установка) базу на сервер. ключ на любой. В сети все компы должны его видеть.
SnarkHunter 14 - 13.05.2004 15:02 | (9)Почему же нельзя... В вопросе нигде не говорится, что 1С после переустановки ключа на другой комп должна работать...
Вася 17 - 13.05.2004 15:07 | Больше всего интересно: Когда пользователь с ПК №K запускает 1с какие ресурсы используются (ПК №1 или ПК №K)?
Вася 20 - 13.05.2004 15:38 | (19) Ты действительно не понял что имеется в виду или решил пошутить? ядро = сетевая или локальная 1с ресурсы = ЦП, ОЗУ ...
SnarkHunter 21 - 13.05.2004 15:38 | (18)И те, и другие... Но разные и в разных пропорциях...
Вася 22 - 13.05.2004 15:42 | (21)А когда ядро стоит на каждом ПК 1с работает (выполняются обработки) быстрее или нет? Мне кажется должна быстрее и при том не загружается сеть.
Вася 28 - 13.05.2004 16:22 | Есть несколько компов. Что будет работать быстрее: - Когда ядро сетевой 1с стоит на одном ПК - Когда на каждом компе установленно ядро сетевой 1с
BorisBiz 30 - 13.05.2004 16:29 | 2Вася 7ка на сервере держит только базу, локальные ПК "тянут" всё себе и работают на своих "ресурсах". Если есть желание напрячь сервер - работаете через терминал.


Пожалуйста помогите создать чистую базу. | База знаний | mista.ru

Пожалуйста помогите создать чистую базу.

Bronson 14.01.2004 12:18 | Как создать в 1С чистую базу для нового предприятия. Заранее благодарю бывалых товарищей.
Tani 1 - 14.01.2004 12:27 | Я делала так: запускаю конфигуратор в пустом каталоге, делаю объединение конфигураций (выбираю файл конфигурации, на основе которой надо создать новую), сохраняю изменения. Если есть более правильный метод создания пустой базы, хотелось бы узнать.
lexa 2 - 14.01.2004 12:32 | Если есть дистрибутив конфигурации, установить с нег , причем лучше выбрать демо базу и там все потереть, а что нельзя изменить. В демо базе много полезных настроек, а в пустой надо все руками прописывать
skunk 3 - 14.01.2004 12:44 | (1)можно сделать проще кидаешь в пустой каталог md пускаешь на него конфигуратор, там чего нибудь меняешь, типа ставишь пробел и тут же забиваешь, сохраняешь. Ну а правильно сказал (2), только с демкой я не согласен, иногда убивать надо довольно таки много, а настройки меня в большинстве случаев все равно приходиться.
BorisG 4 - 14.01.2004 12:48 | (2) Ты... это... серьезно? демо базу? Влетишь как-нибудь... разработчики не всегда успевают тем поправить... заполнение справочников и настроек... особенно в зарплате... (0) А чем установка с нуля чистой конфигурации не катит?
lexa 5 - 14.01.2004 12:53 | Как правило конечные пользователи (главным образом бухгалтеры) ни 1С не знают, ни свой родной бух и налоговый учет. И когда начинают работать с базой им влом забивать все. Потом ессно что то не так считается или не работает. Сразу крик до небес
BorisG 6 - 14.01.2004 13:03 | (5) Видно мало ставил... и не наступал... Я за это своих НАКАЗЫВАЮ. Лень до добра не доведет... примеров масса... Ставь отдельно чистую, и демо, в которой пусть тренируются, но предупреди, что это всеж ДЕМО...
WhiteCat 10 - 14.01.2004 16:35 | Ставить в качестве пустой базы демо - гемор, еще больше работы нужно, чтобы вычистить ненужные данные. Нужно делать как в (3), конда конфа видит, что она установлена в пустой каталог, то сама создает элементы справочников, необходимые для нормальной работы, зато левого ничего нет
Жанна 20 - 11.05.2004 08:11 | Пишет ОШИБКА ЗАГРУЗКИ МЕТАДАННЫХ!!!Копировала с Демобазы 2 каталога NEW_STRU,SUSLOG в новый каталог и в него же скаченную чистую конфигу!Помоги пожалуйста!!!
SnarkHunter 21 - 11.05.2004 08:15 | Каталоги-то зачем... В конфигураторе выполни "Загрузить измененную конфигурацию..." для мд-шника из твоей "чистой конфиги"...
vdi 23 - 11.05.2004 08:46 | У меня попадались клиенты, которые пытались вести учет в демо-базе. Более того, документы формировали через (...), извиняюсь, путеводитель по конфигурации. Естественно считали, что это единственно правильный способ. Экономят на обучении, потом, как и положено, приходиться переплачивать.
Жанна 25 - 11.05.2004 10:09 | Демо-база используется для обучения и всегда поставляется в коробке Комплексной поставки 1С:предприятия.Запусти 1С ,затем жми кнопочку Добавить,выбери в пути каталог 1SBDEMO и всё увидишь своими глазами!
Марь Ванна 26 - 11.05.2004 10:47 | Я уже смотрела в коробке - там вообще баз нету. Запускала 1С, нажала на добавить, а она мне говорит про Информационную базу какую-то. А мне нужна демо-база. И не нашла я каталог по имени 1SBDEMO
Таня 27 - 11.05.2004 11:04 | Если тебе 1С ставили из коробки, то этот каталог должен быть. Попробуй найти его по Пуск-Поиск-Файлы и папки.
Марь Ванна 29 - 11.05.2004 11:08 | 1С точно ставили из желтой коробки, но кроме книжек я там ничегошеньки не нашла. Я уже как только не искала, даже копировала 1SBDEMO и втыкала в графу поиск - безуспешно.


Ошибка при регистрации COM-объекта при установке (вер. 8.0.6.3) | База знаний | mista.ru

Ошибка при регистрации COM-объекта при установке (вер. 8.0.6.3)

Demiurg 11.03.2004 21:48 | Дяденьки добрые :-) подскажите темному, ставлю лиценционную восьмерку, HASP драйвера (и сам ключ) уже уставнолены. Предлагает зарегестрировать COM класс вручную! Что за ерундовина, извиняюсь, не успел поставить сразу в 1С названивать придеться? Помогите, кто решал такую проблему.
Demiurg 2 - 28.03.2004 20:29 | я почистил профиль и реестр, заработало


Немогу установить сервер 1С:Предприятия 8,0 | База знаний | mista.ru

Немогу установить сервер 1С:Предприятия 8,0

DVS 24.06.2004 13:40 | Все перечитал и руководство и с диска ИТС, но не могу подключиться к серверу с другой машины пишет ошибку 80004027. Как локализовать проблему? Сервер Win 2003
DVS 3 - 24.06.2004 14:16 | Все спасибо разобрались. Оказалось что надо в "Установке компонентов" выбрать "Сервер приложений" и там установить "поддержка доступа по протоколу СОМ+"
fobus 5 - 28.09.2004 21:35 | Да, проблема, с которой сталкиваются многие... Всё что нужно сделать - это перед установкой 1сСервера зайти ПанельУправления-> Установка/Удаление программ -> Установка компонент Виндовs -> IIS(Internet Information Service) нажать кнопочку [Состав] и выбрать флаг "поддержка доступа по протоколу СОМ+". Грустно, что авторы выдали обалденное описание к самому процессу установки, но не описали минимальные конфигурационные требования к серверу...


Вопрос для собаку съевшего на хаспах, БорисаГ | База знаний | mista.ru

Вопрос для собаку съевшего на хаспах, БорисаГ

Wizard 11.05.2004 08:40 | Есть сетевая 1С-ина, ключик хасп сетевой, на машинах ВинХР. После установки драйвера защиты и запуска сервера защиты всё прекрасно заработало. Но, после перезагрузки машины, на которой стоит ключик, во время старта ОС появляется сообщение НЕ ОБНАРУЖЕН КЛЮЧ ЗАЩИТЫ ошибка -100. и не стартует сервер защиты. В результате машины по сети не видят ключ и нет работы. Пришлось написать CMD-шник для принудительного запуска hinstal.exe -i и сервера защиты при старте ОС. Но ведь это не дело, каждый раз устанавливать драйвер. Подскажи, почему драйвер хаспа не устанавливается как положено. (А он ведь и в автозагрузку был прописан нормально) ??????
Vozhd 3 - 11.05.2004 09:15 | (0) А почему бы не поставить менеджер лицензий как сервис?
Vozhd 5 - 11.05.2004 09:24 | (4) При установке, менеджер лицензий спрашивает как его устанавливать, надо просто указать, что он должен быть сервисом...
BorisG 8 - 11.05.2004 11:00 | Ну вообще-то надо приводить версии системы, программы 1С и версии менеджера лицензий и драйвера защиты. Для ХР весьма желательно поставить 20 или 21 релиз, а вот драйверы и медеджер лицензий действительно нужно скачивать с сайта Аладдина. http://www.aladdin.ru/downloads/hasp/haspdownloads.php Менеджер лицензий 8.20, файл LMSETUP.EXE (в него и новый драйвер входит), это для машины, где ключик должен стоять. Драйвер защиты 4.95, файл HDD32.ZIP PS: Только вот подсказывает мне telepat.dll, что у тебя не только с этим проблемы. Ибо сервис по новой устанавливать обычно не нужно... И ветку, весьма вероятно, надо бы было назвать "Почему долго грузится Windows ХР"... Только вот 1С к этому вопросу никаким боком.
BorisG 10 - 11.05.2004 11:21 | (9) Да грузится то она быстро... но не горит ли светодиод жесткого диска после загрузки еще несколько минут... и медленный старт приложений? Ибо такие ошибки возникают, если старый драйвер, но гораздо чаще по другой причине...
Wizard 11 - 11.05.2004 11:26 | Нет, обращений к диску при старте минимум (и после). Приложения быстро стартуют. Только при выполнении моего батника подтормаживает, т.к. хинсталл ставится похоже....
BorisG 12 - 11.05.2004 11:31 | (11) Ну... батник с установкой то точно не стоило писАть. Бывают, вообще-то случаи, когда много сервисов стартует в автозагрузке, и ключик опаздывает... в этом случае просто сам сервис надо было заставить по новой стартонуть... Но в твоем случае... похоже просто новый релиз программы надо поставить и новый драйвер. Кстати, так и не ответил на вопросы... Версия системы какая? Prof или Home и сервиспак стоит? Версия программных файлов 1С? Версия драйверов из поставки?
Gavrila 14 - 11.05.2004 12:11 | Была похожая проблема: Win XP Prof 1C - комплексная 3-х (релиз 21) Народным методом "Тыка" проблема была успешно решена отключением AVP Monitor. :)
alxkorvin 27 - 11.05.2004 19:06 | У меня на WinXP такое было на неактивированной XP.


Установка HASP-ключей | База знаний | mista.ru

Установка HASP-ключей

Perepechin 04.06.2004 20:27 | Можно ли установить на сервер три ключа HASP для 8-ки? (на сервере физически два USB порта) Используются следующие ключи: - HASP для 1С:Сервер (установлен на сервере) - HASP на 5 рабочих мест (установлен на сервере) - HASP на 5 рабочих мест (установлен на рабочем ПК) Использую HUB для USB D-LINK DUB-D7 (7 портов), но ничего не выходит.
BorisG 5 - 04.06.2004 21:14 | (4) Понятно. Специально прямо сейчас еще раз проверил, ключики через D-LINK работают. Попробуй теперь объяснить, почему у тебя два ключа 5+5 вместо одного на 10? Тогда скажу, почему у тебя не работает. ;-))) PS: Кстати, ответ есть на сайте Аладдина, и 1С тут никаким боким, как и D-LINK ;-)) Да на этом форуме не далее, как вчера я писал об этом.
Perepechin 6 - 04.06.2004 21:18 | для BorisG: 2 по 5 дешевле, чем 1 по 10 готов "вывернуться наизнанку" и предъявить счета франча ключей 2 по 5, т.к. покупал в два захода :))
igorluk 7 - 04.06.2004 21:22 | фигня это все, что значит "жду" пригласи франча пускай, млин, подключает шоб работало. Ну нифига себе жду, заплатил бабки а тут нате...
Perepechin 8 - 04.06.2004 21:24 | так я ж не простаиваю, у меня же работает с разных ПК, как закат солнца из анегдота про программиста ... хочу оптимизировать расположение HASP, т.к. когда ПК не работает, начинается веселая история ...
Perepechin 9 - 04.06.2004 21:29 | да, у меня везде Win2000
BorisG 10 - 04.06.2004 21:34 | (9) Этот мой вчерашний ответ не спасет отца русской демократии? ;-)) http://www.forum.mista.ru/topic.php?id=5060#msg24
igorluk 11 - 04.06.2004 21:35 | ну в принципе все правильно. но это не порядок ты ж покупал не ключи защиты... так шо это "святое" дело - наехать, пускай думают. я не против самого продукта но против такого способа защиты...
BorisG 13 - 04.06.2004 21:44 | (11) Наехать не получится. Ты покупаешь продукт, и ключики его неотъемлемая часть. Единственное, что можно было сделать при покупке второго ключа, это попросить сделать апгрейд с 5 на 10. Обещали решить, но не знаю решили ли этот вопрос. Можно еще попробовать заменить 5 + 5 на один 10. Но это тоже нестандартная ситуация. Это увы, все.


Ключ для 1С:Предприятие 7.7.17 | База знаний | mista.ru

Ключ для 1С:Предприятие 7.7.17

Denizzz 03.06.2004 06:57 | Доброго времени специалистам по 1С!!! Поставил 1С.ADM на сервер, туда же воткнул ключик (LPT) - все нормально и все юзают. Но, для запуска сервера лицензий приходится заходить с учетной записью на сервере, что крайне неудобно. Ну ладно - оставил так. Но потом когда я 1)поставил на свой комп вторую сетевуху 2)настроил шлюз и винроуте 4.2.5 3)Перевел сервер в режим сервера приложений (W2000Server) - появилась неприятная особенность: когда я запускаю на своем компе 1С (ярлык на сетевой экзешник), сразу слетает этот самый сервер лицензий. Скачал с сайта алладина последние версии дров и сервера. Подскажите, можно мне будет их поставить без подводных камней и вообще возможно ли их поставить? Пробовать на своей шкуре шибко не хочется - юзеры работают.
Denizzz 3 - 03.06.2004 07:10 | а если без эмулятора, а все-таки с ключом? (я в др. местах безключие практикую) :-) Очень интересно - примет ли моя версия 1С новую версию дров и сервера или нет?
VladZagorsky 6 - 03.06.2004 07:18 | Проблемы есть всегда. Помнится года 3 назад была похожая проблема: если после выхода в Инет (модемная связь) запускать 1С - слетал сервер лицензий. На сколько я помню, тут какие-то заморочки с настройками сети.
SnarkHunter 7 - 03.06.2004 07:22 | Куда слетал? Менеджер лицензий устанавливается как служба с настройкой перезапуска при сбое... Все.
BorisG 8 - 03.06.2004 07:24 | (3) 1C новый драйвер примет точно, более того, это вообще лучше сделать, но тебе еще настраивать нужно будет nethasp.ini, лучше выключить широковещательные запросы, прописять явно IP на менеджер лицензий, и, если две карты с разными подсетями на машине, где ключик, лучше настроить и nhsrv.ini. И второй вопрос. А что, поставить менеджер лицензий как сервис религия не позволяет?
BorisG 9 - 03.06.2004 07:25 | (6) Если руки кривые, сервер лицензий чем тут виноват?
Denizzz 10 - 03.06.2004 07:31 | Для этого и скачал чтоб как сервис его зарулить. Вот и спрашиваю перед тем как поставить - может кто с опытом даст рекомендации. BorisG, спасибо за совет! На серваке карточки стоит две, одна не используется, но и не отключена, т.к. после её отключения почему-то пропадает связь с сервером УПСы.


Проблемма нахождения HASP в VPN | База знаний | mista.ru

Проблемма нахождения HASP в VPN

3ton 05.08.2004 17:23 | Суть следующая есть несколько распределенных филиалов: 4 фил. по одному комьютеру 3 фил. - сети (3-8 комп.) и оффис На гейте (IP-статический) стоят все ключики Суть вопроса в том, что при подключении через VPN на одноранговых компьютерах ключики находятся, а на сетевых (даже на ГЕЙтевых) ключ не обноруживается, причем, что пингуется все ОК! Может, кто подскажет, где ковыряться?
Warlock 5 - 05.08.2004 17:46 | (0)Нужно правильно настроить файлы nhsrv.ini и nethasp.ini - т.е. убрать все запросы broadcast'ом и выставить все по IPшникам. Т.е. NH_SERVER_ADDR = IP сервера. Ну и заодно за счет других параметров можно оптимизировать нахождение ключа.
Warlock 6 - 05.08.2004 17:47 | (+5)Если живет на SQL, то в свойствах подключения к базе нужно указывать SQL Server через IP адрес.
Warlock 9 - 05.08.2004 17:56 | (8)В каталоге <папка с 1С>\BIN обычно лежит nethasp.ini. Это обычный ini-файл(для клиентов), все закоментировано и подробно расписано. Читай, настраивай... nhsrv.ini типа nethasp.ini(только для сервера), обычно в системе он отсутствует при установке... Все файлики и примеры можешь скачать с сайта аладдина http://www.ealaddin.com/support/hasp/enduser.asp
3ton 11 - 05.08.2004 18:27 | nethasp.ini : [nh_tcpip] nh_server_addr = xx.xx.xx.xx (тут мой гейт) nh_tcpip_method = UDP nh_use_broadcast = Disabled И, о чудо, все заработало !!! :)


Проблема со службой ключа 1С | База знаний | mista.ru

Проблема со службой ключа 1С

Vser1
15.12.2003 03:43 		Help me!!!
Помогите кто сталкивался с такой проблемой: на сервере Win2000 Advanced Server упала сетевая служба Hasp ключа. Локально (на сервере) все работает нормально, пользователям в сети после долгих поисков выдается сообщение: не обнаружен ключ защиты. Поднять службу на сервере не удается отвечает: 1053 превышен интервал ожидания.
Ключ ИТРП с данного сервера (Eutron drive) работает без проблем (с ключом 1С не конфликтует).
skunk
1 - 15.12.2003 04:33 		Правой кнопой хлопаешь по мыши Свойства - Оборудование - Диспечер устройств. В меню окна выбираешь Вид - Скрытые устройства. Далее в дереве ишешь Драйверы устройств не Plug and Play - haspnt. По нему правой кнопкой и смотришь свойства. Свотришь вкладку Драйвер. В атозагрузке ставишь система. Переобуваешь. Если Опять не фига, значит что то самим драйвером "haspnt.sys". Восстанавливаешь с дистрибутива.
EvgenA
2 - 15.12.2003 05:32 		По каким протоколам передается? Может протоколы в NetHASP License Manager выключил.
skunk
4 - 15.12.2003 05:57 		1)Тогда залазь в Администрирование - Службы. Смотри от чего зависит служба.
2)Администрирование - События - Журнал системы смотри ошибки и предупреждения при запуске. Лучше всего сначала все отуда удали, а потом компьютер перезапусти.
3)Точнее первое - попробуй пустить не как службу.
Vser1
5 - 15.12.2003 07:39 		(1) а)Не отчего не зависит, что довольно странно, и обозвана данная служба по имени сервера.
б)В журналах сервера и 1С ничего не осталось или небыло.
в)Тоже вариант испробованный сервер лицензий на сервере работает, а клиенты его не видят.

В общем ошущение такое что что-то блокирует порт сервера по которому вкалывает hasp.
skunk
6 - 15.12.2003 07:44 		Может в натуре com порт завернулся. Попробуй принтер повесь и попечатай.
Vser1
7 - 15.12.2003 08:04 		В том то и прикол порт рабочий, на нем висит второй ключ ИТРП, тот определяется по сети и работает без проблем. А кроме того локально на серваке 1С запускается, что говорит о том что с ключом все ОК.
skunk
8 - 15.12.2003 08:38 		Попробуй ИТРП загасить, может они конфликтуют между собой. Если они работали раньше вместе, то после чего начались проблемы.
Vser1
9 - 15.12.2003 09:10 		(8) Пробовал останавливал службу ключа ИТРП, непомогло. Скачал и поставил все самые свежие драйвера для Hasp ключа v4.95 и обновленный менеждер лицензий с http://www.aladdin.ru/, результат тот же, похоже ночка будет тяжелой %((
skunk
10 - 15.12.2003 09:13 		После чего все началось!
Vser1
11 - 15.12.2003 09:18 		Если бы это знать, было б намного легче. Извесно что в воскресенье локально работали с 1С примерно до двух часов, потом и случилось несчастье, в логах сервера все чисто, так же как и логах самой 1С.
skunk
12 - 15.12.2003 09:21 		Блин очисть все из журналов системы и приложений, ребутнись и сбрось мне копии журналов на ящик.
kinder
13 - 15.12.2003 12:05 		у нас была похожая проблема
ключ 1С умер
Локально работал, а по сети нет
Заменили (на usb) все стало ок
Львенок
14 - 15.12.2003 15:58 		Я слышал, что люди покупают лицензионную 1С, а потом ломают ее и используют сломанную лицензионную 1С, только вот из-за таких проблем с HASP. Проблема, на самом деле, весьма распространенная.
___
Искренне Ваш, Львенок.
Vser1
15 - 16.12.2003 02:32 		Обзвонил все службы поддержки, все действительно ссылаются на ключ. Придется конторе сидеть без работы недельку, а может и больше, пока новый ключ не сделают.
Пока вышел из данной проблемы: запустив драйвер зашиты на каждой машине и с подключенным ключем, запустил по паре 1С, лишь бы не по закрывали по запарке и не потухли машины :(
skunk
16 - 16.12.2003 02:50 		А почему бы ни сделать, как Львенок предложил. Ни каких нарушений прав. Зато геморроя намного меньше.
Vser1
18 - 16.12.2003 04:35 		(17) Меня тоже теперь интересует данный вопрос, на сайте www.alladin.ru есть прога монитор ключа, для проверки локального и сетевого ключа, но что-то у меня она не считывала никаких данных с самого ключа, кроме версии менеджера лицензии и определения машины на которой он установлен. Там еще есть утилитка для проверки в дос-сессии, но скачать ее не удалось, видать нет на самом сайте.
(16) Ломать возможно придется, но это опять проблема где наити проверенное лекарство для 1С:Предприятие 7.7 Комплексная поставка под SQL, желательно 19 релиз.
PS. буду очень благодарен если по этому поводу будут дельные предложения на мыло.
Vser1
28 - 19.01.2004 02:06 		Раз уж разгорелась такая жаркая битва, за которой я почему-то не уследил, да еще по моей вине невинно пострадал человек, приведу окончание данной истории.

В общем когда оканчательно пришли к мнению что ключ в сети не работает (прошли бессонные сутки, поднятие на уши служб поддержки 1С и ИТРП и куча программ скачанных с инета: новые дрова на ключ, менеджер лицензий... про чай кофе и пиво я промолчу...), было принято решение отправлять ключ в Москву. Вся подготовка свелась к запуску 1С на локальных машинах (надо сказать локально он почему-то работал, в смысле ключ...). Бедные машины, должны были неделю как минимум работать без передыху. Вобщем кое как разобрались, запустили все что можно и нельзя, попутно нашли в инете необходимые лекарства (ссылку не привожу, правила форума). Но самое интересное началось на следующий день после отправки ключа... когда, начали вылетать машины, то выключат, то окошки с 1С позакрывают, то машина зависнет, в общем спасались только антибиотиками...

ЗЫ: мораль сей истории такова, чем более распостранена программа и круче на ней защита (а следовательно стоимость), тем больше неприятностей может создать защита лицензионным пользователеям и больше будет желающих наити лекарство...
Да и большое спасибо фирме 1С за оперативность, ключь обратно получили к новому году, и положили под елочку... Теперь осталось избавиться от последствий лекарства и стать законопослушными гражданами.
BorisG
29 - 19.01.2004 02:16 		(28) Относительно проверки ключей. Я не один раз писал и на форуме 1С, и на Т1С, есть такие глюки сетевых ключей, локально они видятся, по сети нет. Программами диагностики они не отлавливаются. Не лечится и перепрошивкой. Сия проблема сильно актуальна была где-то год назад, партия ключей была с бракованной памятью, проявлялясь чаще всего через год-два работы. Сие признал и Аладдин, знает об этом и Хотлайн 1С, посему ключи меняют без проблем.
Относительно проверок.
К сожалению, программы проверки от Аладдина не проверяют память ключей, 1С тоже не выпускает программ проверки, так что рядовому пользователю только и остается менять ключ..., дружите с франчами, у многих есть НФР для решения этих проблем...
Относительно морали неверно. Что до неприятностей - да. А вот причина появления лекарства совсем другая, частично я об этом писал... но правила форума не позволяют... Аладдин тут совсем никаким боком.
Vser1
30 - 19.01.2004 03:33 		(29)Борис у Вас видать большая практика работы с 1С, нам до ентого еще далеко, но в службе поддержки как 1С так и фирмы ИТРП, конкретно ничего сказать не смогли (а Вы говорите что проблема известная...). А учитавая отдаленность нашего региона (+6 к Москве), о нормальных фра нам приходиться только мечтать, всего с пол года назад появилась первая...
P.S.: на будуешее если возможно подскажите какими прогами можно тестировать ключи 1С.
Bismark
31 - 05.02.2004 14:26 		бли ну и система видит меня только как некоего Бисмарка, крутой парень наверное :)
теперь вопрос: какие протоколы надо прикрутить(открутить) чтобы из AdvSer2000sp4(юзер) на AdvSer2000sp3(сервер) увидеть ключ, 21 релизом(обычным).
При этом на старых(ранее установленных) машинах все ОК.
А на новые W немогу прикрутить прогу и все тут :(
Может мой ключ тоже "навернулся"?


Ключ защиты | База знаний | mista.ru

Ключ защиты

Alex99 25.06.2004 12:00 | Alex99-3-х месячная чайница. Легла машина, которая была сервером 1С. Сделала администратором другую. После ремонта поставили 1С на старую и при запуске не обнаружила ключа защиты. Сдуру, воспользовалась "левой" инсталяшкой. Заработала - но 1CV7.exe стал другой. Удаляла и ставила ключ защиты, крякала - но версии отличные от "левой" не обнаруживают ключ защиты. Короче. Запутался реестр. Где можно ручками вычистить установленный левый ключ защиты.
SiMazx 2 - 25.06.2004 13:05 | Сервер защиты запустить на машине с ключом. Пуск->1С Предприятие->Сервер защиты
Petr 6 - 25.06.2004 16:06 | Так, на серваке для начала удаляешь драйвер защиты, потом снова ставишь, потом запускаешь сервер защиты.. Возможно между этими процедурами прийдется перезагружаться, система сама скажет об этом..
Petr 7 - 25.06.2004 16:12 | Левый ключ защиты автоматически заменяется на нормальный при установке драйвера защиты, тут дело не в реестре... Сам этот драйвер лежит (если Вин98) C:\Wintows\System\hasp95dl.vxd, в принципе в диспетчере устройств можно его увидеть,и даже отключить


NHSRV.ini - что это за файл такой | База знаний | mista.ru

NHSRV.ini - что это за файл такой

Gavrila 23.06.2004 18:43 | или где можно прочитать о формате, настройках или содержимом этого файла
Warlock 3 - 23.06.2004 18:58 | Там есть ini-шки прописанные под разные конфигурации сети: http://www.aladdin.co.il/support/hasp/enduser.asp
Gavrila 4 - 23.06.2004 19:06 | (3) Спасибо, но там NetHASP.ini Files
Warlock 5 - 23.06.2004 19:13 | А в каждом файле помимо параметров закоментарены их(параметров) характеристики! Если по аглицки шурупаешь...
Gavrila 6 - 23.06.2004 19:28 | NetHASP.ini <> NHSRV.ini или я не прав, или по содержанию они одинаковы?
Warlock 7 - 23.06.2004 19:35 | Вот NetHASP.ini: ; NetHASP License Manager configuration file. ; ; ; Note: ; All text lines are commented. ; Remove comments in the lines you want to use. ; [NHS_SERVER] ;NHS_IP_LIMIT = <IpAddr> [, <IpAddr>...] ; Specify the range of stations ; the License Manager serves. ; ; Examples: 10.1.1.1, 10.1.1.* ; 10.1.1.1/24 ; Applicable for the Win32 and ; MacOS X License Managers. ;NHS_ADAPTER_IP = <IpAddr-SubMask> [, <IpAddr-SubMask> ...] ; Specify the network adapter(s) ; to which the server listens. ; ; Example: 10.1.1.111-255.255.0.0 ; Applicable only for the Win32 ; License Manager. [NHS_IP] ;NHS_USE_UDP=enabled/disabled ;Do not disable UDP if your application ;is protected with API v8.0 and above. ;Disabling UDP, will prevent your application ;from finding the HASP License Manager. ;NHS_USE_TCP=enabled/disabled
Тупой Мля 8 - 23.06.2004 19:57 | HhSrv.ini <> NetHASP.ini И формат у них разный.
Warlock 10 - 23.06.2004 20:00 | (7) Sorry, это был nhsrv.ini, а nethasp.ini должен лежать в BIN каталоге 1С-ки
BorisG 14 - 24.06.2004 08:52 | В (7) неверная только первая строка. Это действительно nhsrv.ini, и он должен быть в каталоге запуска Менеджера лицензий. Но... если у сервера одна сетевая карта (одна VLAN), и нет ограничения по обслуживаемым станциям... этот файл... не нужен ;-) PS: Вообще-то последовательность поиска этого файла и описание приведены на стр. 255-256 HASP Руководство разработчика, в (7) - фактически полностью все поля.
Hron`итель 15 - 24.06.2004 10:34 | nhsrv.ini - файл настроек аладдиновского сервера защиты, менеджера лицензий и как он там еще называется.. nethasp.ini - файл настроек клиента (обычно 1С), должен лежать в одном каталоге с исполняемым файлом клиента.. ;o) Поля в nhsrv те же, что и и в nethasp, за исключением дополнительной секции [NHS_SERVER]
Gavrila 16 - 24.06.2004 10:43 | Тобто я так понял, что если в секции [NHS_SERVER] я укажу IP некоторых машин, то те машины IP которых я не указал не будут видеть ключа ?
BorisG 17 - 24.06.2004 10:57 | (15) "Поля в nhsrv те же, что и и в nethasp" Неужели? А доку почитать, перед тем, как писать, религия не позволяет? (16) Да.


1С + WIN 2003 | База знаний | mista.ru

1С + WIN 2003

Кирил 16.06.2004 15:16 | "Слетает" 1С на ОС Win 2003, если Hasp в сети. Как только устанавливаешь ключ локально, всё нормально. Прописывал IP адресс ключа, не помогает :(
SnarkHunter 1 - 16.06.2004 15:17 | Менеджер лицензий поставь уже...
Кирил 2 - 16.06.2004 15:22 | Где можно попростому прочитать о менеджере лицензии?
Черт 3 - 16.06.2004 15:28 | http://lrn.ru/image.php/lrnbig1202.jpg?imageid=1202&size=1 это уже столько раз было


Менеджер лицензий | База знаний | mista.ru

Менеджер лицензий

Tatav 12.06.2004 22:06 | Подскажите зачем нужен менеджер лицензий и что это такое , вопрос связан с использованием терминального сервера Win2003 и 1С v77.
SnarkHunter 1 - 12.06.2004 22:11 | Он громко кричит на всю сеть, что у тебя есть ключ... Все слышат этот крик и разрешают запускают 1С...
SnarkHunter 6 - 12.06.2004 22:27 | Если ты на Т1С писАл как Misha, то я тебе и советовал... http://www.aladdin.ru/downloads/hasp/haspdownloads.php


2003 сервер и HASP | База знаний | mista.ru

2003 сервер и HASP

Oksa 10.06.2004 11:55 | очень уважаю все права собственности, но трабл в том что хасп у меня под 2003 сервером не устанавливается. караул!!! вся бухия стоит. про эту проблему читала, что только с...ль лечит и то как-то замудренно. кто как решил эту проблему? что делать-то?
Batman 2 - 10.06.2004 12:00 | (0) глянь тута, http://www.aladdin.ru/downloads/hasp/haspdownloads.php


Ключ+Принтер Не печатает | База знаний | mista.ru

Ключ+Принтер Не печатает

Молодая 10.06.2004 09:11 | Господа, подскажите, пожалуйста. Есть Win Me, 1С-7.7(21) Принтер Samsung ML1210, и вот этот самый принтер печатать не хочет :(. Надоело грузить 1С, а потом выдергивать ключик и вставлять принтер. Как лечить?
Vser1 1 - 10.06.2004 09:18 | Лучше всего если на принтере есть USB-порт, перекинь его на него. А если нету попробуй поиграться настройками порта в сетапе (попасть туда можно нажав кл. Del после проверки памяти при загрузке).
GrayT 2 - 10.06.2004 09:20 | А что там смотреть в сетапе? ЗЫ: это я наткнулся на проблему - пароль лень набирать было :)
Vser1 3 - 10.06.2004 09:29 | Поиграйся решимами работы порта ECP-EPP-Normal, может в каком-то и заработает, плюс посмотри выделено ли прерывание на LPT - порт. По моему личному опыту наиболее продвинутый режим работы LPT-порта: ECP, с выделенным прерыванием + если он поддерживает версию 1.9 этого протокола (еще есть 1.7, из возможных установок). Ну и плюс проверь прерывание в диспетчере устройст если стоит w2k/ХР.
HexSys 4 - 10.06.2004 09:30 | (Знаю что сейчас получу за такую идею... =) Принципиально - ключ есть, значит 1С лецинзионная, так. Как вариант... 1. вынь ключ, положие его в коробочку 2. поставь Sable 3. спокойно работай.
Vser1 5 - 10.06.2004 09:39 | (4) Ну вот ты и попал.... Придет BorisG и за такие слова... А если серьезно обсуждалово по этому поводу было большое (поиск рулит если интересно), вывод таков: по головке не погладят, если поймают...
GrayT 6 - 10.06.2004 09:49 | Vserl, спасибо - все работает (параметры лпт)
HexSys 7 - 10.06.2004 09:50 | (5) ...принципиально, даже в некоторых ФранЧах... так делаю. И нее же ключ есть! Конечно это не выход, нужно разбираться почему не печатает... Но как вариант, если срочно надо работать. Можно использовать.


Можно ли ограничить доступ к ключу HASP | База знаний | mista.ru

Можно ли ограничить доступ к ключу HASP

DVS 07.06.2004 14:05 | Возможно ли ограничить доступ к ключу HASP, т.е. каким либо образом отклонить для какой-то машины или лучше пользователя, на обнаружение ключа.
Killgur 1 - 07.06.2004 14:40 | Да. Можно. Для настройки менеджера лицензий применяется файлик nhsrv.ini. В нем можно например настроить диапазон IP адресов клиентов. Для IPX тоже есть свои настройки. Только работает это все на уровне машины, а не пользователя. У меня где то были описания настроек, но быстро не нашел. Скорее всего брал с www.alladin.ru
DVS 2 - 07.06.2004 14:46 | а если IP выдаются динамически - то нельзя?
Killgur 3 - 07.06.2004 15:31 | Настроечный файл nhsrv.ini ; ; NetHASP License Manager configuration file syntax. ; ; ; Note: ; ; All text lines are commented. ; Remove comments in the lines you want to use. ; [NHS_SERVER] ;NHS_IP_LIMIT = < IpAddr > [, <IpAddr>...] ; Specify the range of stations ; the License Manager serves. ; ; Examples: 10.1.1.1, 10.1.1.* ; Applicable for the Win16 and ; Win32 License Managers. ;NHS_ADAPTER_IP = < IpAddr-SubMask > [, <IpAddr-SubMask>...] ; Specify the adapter(s) to ; which the server listens. ; ; Example: 10.1.1.111-255.255.0.0 ; Applicable only for the Win32 ; License Manager. Похоже то нет.
BorisG 4 - 07.06.2004 23:40 | Проще запретить этому пользователю запускать 1С ;-)) Или запретить доступ к базе.


Работа в сети | База знаний | mista.ru

Работа в сети

mak 07.06.2004 12:12 | Сервер на W2 клиенты на W98. Проблема в том, что иногда 1с на клиентских машинах выдает сообщение: ключ защиты не обнаружен. В чем прблема??
SnarkHunter 1 - 07.06.2004 12:24 | Проблема в необнаружении ключа... Время поиска ключа увеличь в настройках...
SnarkHunter 3 - 07.06.2004 12:34 | Последний LM и драйвер...
aleks_ru 4 - 07.06.2004 12:35 | в каталоге 1c есть файлик hasp.ini измени на клиентских машинах в файле IP адрес сервера тоже помогает... :)
SnarkHunter 5 - 07.06.2004 12:38 | (4)Если берешься подсказывать, то правильно указывай имя файла... nethasp.ini он называется... Таймауты, кстати, там же настраиваются...


Server Hasp не видит драйвер после рестарта | База знаний | mista.ru

Server Hasp не видит драйвер после рестарта

Сергеев 05.06.2004 17:09 | 1С Предприятие (сетевая), ОС - WinXP, на сервере в автозагрузке висит Server Hasp, после перезагрузки Server Hasp выдает сообщение, что драйвер Хасп вообще не установлен. Что делать?
Волшебник 6 - 05.06.2004 18:04 | http://www.forum.mista.ru/topic.php?id=5132 http://www.forum.mista.ru/topic.php?id=4615 http://www.forum.mista.ru/topic.php?id=4146 http://www.forum.mista.ru/topic.php?id=4006 http://www.forum.mista.ru/topic.php?id=3859 http://www.forum.mista.ru/topic.php?id=3728 http://www.forum.mista.ru/topic.php?id=1920 http://www.forum.mista.ru/topic.php?id=1161 http://www.forum.mista.ru/topic.php?id=459 http://www.forum.mista.ru/topic.php?id=3083


1C+SQL Не обнаружен ключ защиты программы!!! | База знаний | mista.ru

1C+SQL Не обнаружен ключ защиты программы!!!

Arhitektor 27.01.2004 15:19 | Установлены: Windows 2003 Server Enterprise Edition Eng SQL Server 2000 SP3 1C: Предприятие 7.7 SQL Установил все как полагается (драйвер защиты и т.д.), создал базу данных. При загрузке на сервере все пашет на ура, но при запуске 1С с клиентской машины иногда запуск проходит удачно (затем выходим), а после этого удачного запуска начинает валиться ошибка: Не обнаружен ключ защиты программы!!! Сервер включен, ключ защиты воткнут, HASP запущен... Жду комментариев
Черт 2 - 27.01.2004 16:35 | Драйвер на алладине для 2003сервера скачай
Волшебник 5 - 05.06.2004 13:52 | Вероятно здесь: http://www.aladdin.ru/downloads/


ЮСБи ключи в чем отличие от ключей ЛПТэ? | База знаний | mista.ru

ЮСБи ключи в чем отличие от ключей ЛПТэ?

Gavrila 03.06.2004 15:12 | Сгорел ключик (сетевая комплексная) у клиента - надо поменять. Слышал как-то, что USB-ые ключи надежнее (в огне не горят, в воде не тонут и по медным трубам бегают со скоростью света:). Вот теперь думаю, может поменять сразу на USB... У кого опыт был работы с этими ключами поделитесь впечатлениями,плз
SnarkHunter 1 - 03.06.2004 15:13 | Отличия?.. Их в разные дырки вставляют ИМХО...
Gavrila 3 - 03.06.2004 15:19 | (1)ну да, ну да... это понятно, а с сервером защиты как дела, отличий нет?
alxkorvin 5 - 03.06.2004 15:22 | (0) Самое большое отличие, что один ключ USB в другой не воткнешь. А из LPT можно лепить такие композиции. Например можно воткнуть 5 LPT ключей, в них воткнуть ZIP Drive, а к ZIP Drive еще и принтер подключить.
Gavrila 10 - 03.06.2004 15:30 | По поводу железа ясно, а как с ПО? К примеру стоял у людей "сервер защиты"(Nhsrvw32.exe(8.08)) для LPT-ключа, будет ли он работать с USB-ключом?
alxkorvin 11 - 03.06.2004 15:32 | www.alladin.ru
BorisG 13 - 03.06.2004 15:37 | (10) А франчи чего говорят? ;-)) (5) USB несколько штук тоже не проблема подключить. Для этого набы есть ;-))
BorisG 21 - 03.06.2004 18:36 | (20) Гораздо больше пяти ключей можно увидеть во франчазариуме 1С на Селезневской 21 ;-)) У представителя Раруса. Ключи в перегородку упираются. ;-))) А вот 50 ключей Аладдина работать не будут... RFTM однако... В технической спецификации Аладдина написано... до 10 ключей. И по каким, по твоему мнению, причинам, не будут работать 50 ключей USB?
BorisG 24 - 03.06.2004 19:42 | (23) Нельзя втыкать два ключа ОДНОЙ серии, неважно, LPT, или USB. Если ключи разные, например от разных программ, то можно. И неважно, локальные они, или сетевые. Так что... если поизощряться... вполне можно больше десятка набрать... Все к тому и идет. ;-))
alxkorvin 25 - 03.06.2004 20:27 | (24) Ну изначально мы все таки говорили про продукты 1с :) Вообще для 7.7 что LPT, что USB ключ одинаково безполезен :) Выход отучалок 1с от хаспа в тот же день что и выход очередного релиза платформы лишнее тому подтверждение :)
BorisG 26 - 03.06.2004 20:49 | Ну у 1С тоже запросто можно к десятку приблизиться... Даже если брать красные (сетевые) ключи... Бухия, ЗиК, ТиС, УРБД, Web... это только семерочные, плюс восьмерка, шестерка, плюс ключи от партнерских решений...
BorisG 27 - 03.06.2004 20:51 | +26 Эти все сетевые ключики БУДУТ совместно работать...


W2003Server Не устанавливается драйвер для Hasp (lpt) | База знаний | mista.ru

W2003Server Не устанавливается драйвер для Hasp (lpt)

InGrid 23.05.2004 02:40 | Господа, при установке сетевой ТиС 932 не устанавливается драйвер Hasp. LMHasp не помогает :( Подскажите, что нужно сделать для его корректной работы.
SnarkHunter 2 - 23.05.2004 05:52 | Нужно его правильно установить...
Romik K 4 - 23.05.2004 16:08 | Вчера поднял Server 2003 Пролил 21 релиз 1С и пришлось скачать обновленный HASP License Manager: ftp://ftp.ealaddin.com/pub/hasp/new_releases/utility/servers/win32/LM_Setup_Win32.zip И только после этого заработало.... пропробуй может поможет


Номер на Hasp | База знаний | mista.ru

Номер на Hasp

Valentin_Azheronok 22.05.2004 15:49 | Если утеряли рег. карточку поможет ли номер на хаспе, не одно ли это и тоже?
427 1 - 22.05.2004 17:40 | Номер на карточке, номер на дискетах, номер на книгах - совпадают Насчет хаспа - не обращал внимания.... По моему, это другое... По номеру можно восстановить карточку ... Обратись в 1С
BorisG 2 - 22.05.2004 18:41 | (0) Нет, номер на ключе к карточке отнощения не имеет. Он лишь указывает тип ключа и код разработчика, читай: код компоненты, и все. Если программа зарезистрирована в 1С (т.е. вторую половину туда отослали), восстановить дубликат карточки дело пяти минут.


Ключ защиты | База знаний | mista.ru

Ключ защиты

Term2 07.05.2004 06:36 | Ключ защиты стоит на серваке. При этом половина компов в сети его видят, а другая половина не может его обнаружить, хотя сам сервак и все компы в сети видят, соответственно 1с не запускается. В чем может быть дело?
Term2 6 - 07.05.2004 08:03 | Окакзалось WINS был выключен, хотя причем он здесь не понимаю.


HASP HASP | База знаний | mista.ru

HASP HASP

ramstar 04.05.2004 04:55 | конечно обидно что мою тему закрыли но ведь HASP это самая главная составляющая 1С и граздо интереснее разобраться как он работает а вы в курсе что знаминитый Sable всего лишь эмулирует работу haspa и к разделу крякерства не считается а всего лишь я вляется эмулятором аппаратного устройства а ведь в системе защиты 1С77 довольно много брешей ведь SEVEN.dll наиболее открытой ведь если по адресу 00...Е800 на конфигурацию пароли на внешние отчеты можно просто обходить с помошщью плюхи для Fara ?? А строка haspa не могу обнаружить ключ защиты гольным текстом светиться в дизасемблированном коде 1С в добавок если вы хотите чтоб форум процветал необходимо размещать информацию подобного рода.
ramstar 2 - 04.05.2004 05:48 | Кажддый exeшник начинается с букв MZ это так называемый MZ-заголовок юзается для ДОС В нем описываются такие фички как скока проге надо места в памяти скока стека и т.д. Все эти байты идущие после MZ заголовка называются MZ-поля на азме все выглядит так model small .386 .stack 100h .data var db 0010010100111010b .code ..............
ramstar 3 - 04.05.2004 05:51 | далее PE заголовок Entypoint size of image imagebaze далее Directory а там каки ресурсы таблици импортов и т.д.
skunk 4 - 04.05.2004 06:07 | а почему именно MZ
ramstar 5 - 04.05.2004 06:28 | Mark Zbikovski (один из разработчиков MS-DOS )если мне память не изменяет
ramstar 7 - 04.05.2004 06:36 | а еще можешь сходить сюда http://jumper.by.ru/read/win32_faq.html
BorisG 9 - 04.05.2004 08:33 | Да... пристрастие модераторов... (0) Наличие плохого замка на квартире не дает оснований для его взлома. Соответствующая статья УК светит в любом случае, плохой там замок, или хороший. Точно так же и взлом программ... Почему 1С заняла такую позицию, что взломать НАСП может даже школьник, это ее вопрос и ее право... Посему обсуждения эти неуместны в любом случае, да и правила форума нарушают. Относительно того, как работает НАСП. Купи комплект разработчика... там есть подробное описание...


Помогите с ограничением прав доступа | База знаний | mista.ru

Помогите с ограничением прав доступа

Appon 27.06.2004 15:44 | Как добавить в стандартные ограничение прав, например, запрет просмотра проведенной накладной.Или хотя бы подскажите в какой стороне искать?
Орк 1 - 27.06.2004 16:01 | Например запрет просмотра проведенного документа: Процедура ПриОткрытии() Если Проведен()=1 Тогда // А можно-ли Расчипупкину смотреть документ? Если ИмяПользователя()="Расчипупкин" Тогда Предупреждение("Расчипупкин - №;%:?*"); СтатусВозврата(0); //Скажем документу - не моги открываться Возврат; КонецЕсли; КонецЕсли; КонецПроцедуры Аналогично можно использовать ИмяКомпъютера(), НазваниеНабораПрав()... Вставляешь СтатусВозврата(0) в процедуры, называемые предопределенными (суть - события в других языках) и получаешь отказ в выполнении оных.
427 2 - 27.06.2004 16:52 | Запрет просмотра проведенной накладной.... хм... мудро Только вот в отчетах то она полностью в развернутом виде видна ....
Appon 4 - 27.06.2004 18:10 | А по поводу отчетов.Это все делаеться для продавцов, а им стандартной функцией запрещены отчеты.Делаеться это только от того что бы от нечего делать они не начали шариться по накладным других магазинов и потом не обсасывать всем косточки
427 5 - 27.06.2004 18:51 | К сожалению, вынужден огорчить.... Если отчеты запрещены, это не значит, что их нельзя запустить.... Уже на всех форумах растрезвонили..... если среди знакомых у продавцов есть программист - они давно уже все посмотрели... Там все так просто... И кстати, зачем в одном магазине - доки другого? Они вроде как (чужие) не нужны....


Как быстро прописать права пользователей? | База знаний | mista.ru

Как быстро прописать права пользователей?

Hass 25.07.2004 11:47 | В базе около 20 наборов прав пользователей, описание прав есть в отдельной Ексель таблице, как автоматом прописать права в базе, т.е. загрузить их из фала, а то вручную долго ??
Волшебник 1 - 25.07.2004 11:56 | В версии 8.0 изменять права для конкретных пользователей можно средствами встроенного языка.
Hass 2 - 25.07.2004 11:57 | Забыл.. .. v7.7
Hass 3 - 25.07.2004 11:59 | А вообще в каком виде они (права) в базе (7.7) хранятся?
Волшебник 4 - 25.07.2004 12:01 | Файл списка пользователей USRDEF\USERS.USR
Hass 6 - 25.07.2004 12:06 | Но в этом файле только пользователи и соответствующие им наборы прав, а мне необходимы сами права где расписаны доступы к каждому объекту, это где-то в mD хранится но чем туда залезть??
Волшебник 7 - 25.07.2004 12:08 | Эти права прописаны в MD. Тебе нужно зайти на http://gendin.ru/md/index.html и еще рекомендую http://1c.alterplast.ru/ Еще проблему можно решить организационно. Проставить флажки на основе файла Excel можно поручить какой-нибудь девочке.
Hass 8 - 25.07.2004 12:10 | Спасибо за ссылки, пойду посмотрю. А девочку хотел привлечь, но воскресенье :( а завтра уже права надо всем иметь
Волшебник 9 - 25.07.2004 12:20 | (8) Надо было раньше думать. За отведенное время, я думаю, освоить эти новые технологии очень сложно. Можно выставить пока всем максимальные права, а затем понемногу их ограничивать (более рискованный путь, но наименее болезненный). Можно пойти от обратного - давать права только по мере необходимости (будут крики и нервы, но это наиболее безопасный путь).


Защита баз в одноранговой сети - 2 | База знаний | mista.ru

Защита баз в одноранговой сети - 2

327
21.03.2004 08:19 		Какой то идет.... закрыл ту ветку....

Твои ответы по поводу применения ип/секюрити и прочего ... не имеют смысла ... НА ЛОКАЛЬНОЙ СЕТИ....
Ибо НА ЛОКАЛЬНОЙ СЕТИ в пределах одного здания значительно проще контролировать физический доступ к носителю....

В приложении к 1С ВСЯ внешняя защита - полное фуфло...
С любой системой работают люди.... И анализ краж показывает - в 99,99% крадут инфу те, кто имеет доступ к системе... Так что правильно сказал Борис... положи базу на ПЖП диск, закрой каналы - чел все равно получит доступ к базе.... Просто ему нужно РАБОТАТЬ С БАЗОЙ..... Вот и все...

А средств 1С версии 7.7 просто недостаточно.... К тому же все они обходятся настолько элементарно ...

В версии 8 теоретически средств больше.... но дыры уже в общем то видны... И причина крайне проста - красть будут те, кто имеет доступ к системе....

А учитывая нежелание 1С закрывать известные дыры ...
В той же 7 есть дыра (в ЛЮБОЙ ТИПОВОЙ от 1С), которая не закрывается уже несколько лет.... И ОНА НЕ БУДЕТ ЗАКРЫТА....

Чтобы украсть инфу - не нужно тащить всю базу.... на ....цать гигов.... Слив инфы размером в 3-4 дискеты - достаточно....

Успехов в применении ип/сек ..... особенно в одноранговой сети ....
Волшебник
1 - 21.03.2004 09:54 		2.6 Сделает ли IPSEC брандмауэры ненужными?

Некоторые считают именно так. Прежде чем делать такие серьезные прогнозы, однако, стоит разобраться, что же такое IPSEC и что он делает. После этого можно будет решить, сможет ли IPSEC решить проблемы, которые сейчас пытаются решить с помощью брандмауэров.

IPSEC (IP SECurity -- защита IP) -- это набор стандартов, разработанных Internet Engineering Task Force (IETF). Есть несколько документов, совместно определяющих, что же такое "IPSEC" [4]. IPSEC решает две проблемы, от которых многие годы страдает стек протоколов IP: взаимная аутентификация хостов (позволяющая хостам знать, что они взаимодействуют именно с теми хостами, с которыми предполагают) и шифрование (которое не позволит атакующим следить за информацией, передаваемой между машинами).

Обратите внимание, что ни одна из этих проблем не относится к тем, для решения которых создавались брандмауэры. Хотя брандмауэры могут помочь снизить некоторые из рисков при работе в Internet без аутентификации или шифрования, на самом деле речь идет о двух классах проблем: целостность и конфиденциальность информации, передаваемой между хостами, и ограничения на виды подключений, допустимых между различными сетями. Первый класс проблем решает IPSEC, а второй -- брандмауэры.

Это означает, что решение одного класса проблем не избавляет от необходимости решать проблемы другого класса, но сочетание брандмауэра и хостов, поддерживающих IPSEC, дает ряд интересных возможностей. В частности, это универсальные виртуальные приватные сети (VPNs), улучшенное фильтрование пакетов (за счет фильтрования по признаку наличия в пакетах заголовка аутентификации IPSEC), и брандмауэры уровня приложений, которые смогут точнее проверять хосты, используя заголовок аутентификации IPSEC вместо "принятия на веру" указанного IP-адреса.

Большая книга по брандмауэрам:
http://ln.com.ua/~openxs/articles/fwfaq.html

Содержание
0 Словарь терминов
1 Административные вопросы
1.1 О документе
1.2 Для кого предназначен этот документ?
1.3 Прежде чем слать сообщения
1.4 Где можно найти последнюю версию этого документа?
1.5 Где можно найти версии этого документа на других языках?
1.6 Соавторы
1.7 Авторское право и условия использования
2 Основы технологии брандмауэров
2.1 Что такое сетевой брандмауэр?
2.2 Зачем нужен брандмауэр?
2.3 От чего может защитить брандмауэр?
2.4 От чего не может защитить брандмауэр?
2.5 А как насчет вирусов?
2.6 Сделает ли IPSEC брандмауэры ненужными?
2.7 Хорошие печатные источники информации о брандмауэрах
2.8 Дополнительные источники информации о брандмауэрах в Internet
3 Вопросы проектирования и реализации
3.1 Какие основные проектные решения необходимо принять при создании брандмауэра?
3.2 Основные типы брандмауэров
3.2.1 Брандмауэры сетевого уровня
3.2.2 Брандмауэры прикладного уровня
3.3 Что такое промежуточные серверы и как они работают?
3.4 Есть ли недорогие средства экранирования пакетов?
3.5 Какие основные правила фильтрования необходимо задавать для экранирования пакетов на базе ядра?
3.5.1 Реализация
3.5.2 Объяснение
3.6 Какие основные правила фильтрования необходимо задавать для маршрутизаторов Cisco?
3.6.1 Реализация
3.6.2 Объяснение
3.6.3 Недостатки
3.7 Какие ресурсы являются критичными для брандмауэра?
3.8 Что такое DMZ (демилитаризованная зона) и зачем она нужна?
3.9 Как можно повысить защищенность и масштабируемость демилитаризованной зоны?
3.10 Что такое уязвимая точка и как ее избежать?
3.11 Как заблокировать все возможные угрозы?
3.12 Как ограничить доступ к Web так, чтобы пользователи не могли просматривать сайты, не имеющие отношения к работе?
4 Различные атаки
4.1 Что такое пакеты с внутренней маршрутизацией и почему они представляют угрозу?
4.2 Что такое перенаправления ICMP и "бомбы" перенаправления?
4.3 Что такое атаки на службы?
4.4 Какие атаки наиболее типичны и как защитить от них систему?
4.4.1 Перехват сервера SMTP (незаконная пересылка)
4.4.2 Использование ошибок в приложениях
4.4.3 Ошибки в операционных системах
5 Как сделать...
5.1 Надо ли разрешать все, о чем просят пользователи?
5.2 Как обеспечить работу Web-сервера/HTTP через брандмауэр?
5.3 Как обеспечить работу протокола SSL через брандмауэр?
5.4 Как обеспечить работу службы DNS с брандмауэром?
5.5 Как обеспечить работу FTP через брандмауэр?
5.6 Как обеспечить работу Telnet через брандмауэр?
5.7 Как обеспечить работу программ Finger и whois через брандмауэр?
5.8 Как обеспечить работу gopher, archie и других служб через брандмауэр?
5.9 Какие проблемы возникают при поддержке протокола X11 через брандмауэр?
5.10 Как обеспечить работу RealAudio через брандмауэр?
5.11 Как сделать Web-сервер пользовательским интерфейсом к базе данных, находящейся в приватной сети?
5.12 Но моя база данных включает интегрированный Web-сервер, и я хочу его использовать. Нельзя ли просто сделать дырку в брандмауэре и передавать запросы на соответствующий порт?
5.13 Как обеспечить работу многоадресной IP-передачи с брандмауэром?
Приложение А. Некоторые коммерческие решения и их поставщики
Приложение Б. Глоссарий понятий, связанных с брандмауэрами
Приложение В. Порты TCP и UDP
В.1 Что такое порт?
В.2 Как узнать, какие порты используют приложения?
В.3 Что такое прослушивающие (LISTENING) порты?
В.4 Как определить, для какой службы предназначен конкретный порт?
В.5 Обращения к каким портам можно безопасно пропускать через брандмауэр?
В.6 Особенности протокола FTP
В.7 Какой режим FTP поддерживает та или иная программа?
В.8 Пытается ли мой брандмауэр подключаться к внешним серверам?
В.9 Анатомия подключения по протоколу TCP
327
2 - 21.03.2004 10:49 		Типовое применение 1С - локальная сеть без выхода в инет....

Брадмауэр - как зайцу стоп-сигнал..... Про ИП/сек - аналогично в таких условиях....
Demiurg
3 - 21.03.2004 11:08 		(2) потерпи до моей третьей статьи, а уж тогда и обсудим этот вопрос - а пока могу сказать, что из твоей логики можно вообще ни чего не защищать, если "куплен" главбух :-)
327
4 - 21.03.2004 11:40 		Вот именно....
Только "покупают" обычно не главбуха... Ему достаточно платят.... Покупают обычно рядового исполнителя... имеющего доступ к базе.....

Вот он и крадет инфу.... И никакие методы защиты здесь практически не работают.... Из-за большого количества дыр в самой 1С...... Так что решение в большинстве контор - чисто административные меры....

То, что ты говоришь - имеет смысл для систем, работающих через Инет в онлайне.... Что достаточно редко вообще, и в 1С в частности....

И самое главное - достаточно просто рубится указанными тобой средствами... туннелированием, VPN.....

В случае использования же 1С применяются другие методы - они просто дешевле и проще ....

А цеплять контору к инету через выделенку, не ставя средств защиты ..... ну это просто маразм ....
BorisG
5 - 21.03.2004 11:43 		(3) Как все просто...
На самом деле все еще проще... Система безопасности - это КОМПЛЕКС мер... Истина, специалистам общеизвестная...
И бессмысленно рассуждать непосредственно о защите сети, базы и пр., если есть возможность, например, загрузить файлик на рабочей станции... или сохранить отчет на рабочую станцию...
И практически ВСЕ известные способы получения информации (читай: кражи) из 1С лишь подтверждают эту истину... Печально, но, увы, так.

Все разговоры о защите в 1С на популярных ресурсах сосредоточены исключительно в части защиты на уровне системы...

Еще один аспект... психологический... создав один барьер защиты, у неспециалиста возникает ощущение успокоенности от сделанного... каково же бывает разочарование... Как? Я же все сделал...

И последний аспект... человеку, задающий элементарный вопрос в области безопасности ОПАСНО и ВРЕДНО давать ответ только на поставленный вопрос, ибо на 100% можно сказать, что другого он не знает... О последствиях сказал выше...
327
6 - 21.03.2004 11:48 		Фигня все, Борь.... Когда ему вставят клизму на полведра скипидара .... с патефонными иголками .... после кражи, совершенной ламером при всех работающих защитах ..... вот тогда он поймет.... Что такое нормальное административное решение .....
Demiurg
7 - 21.03.2004 11:56 		Могу к вышесказанному добавить, что тут уместно упомянуть ОЦЕНКУ РИСКОВ - т.е. не надо гадать :-)
ниже приведенные ссылки не касаются 1С, однако суть для тех хочеть понять будет видна:
"оценка рисков защиты интернета"
http://www.securitylab.ru/?ID=34907
http://www.securitylab.ru/?ID=35756
http://www.securitylab.ru/?ID=36342
http://www.securitylab.ru/37248.html
:-)
skunk
8 - 21.03.2004 12:01 		(7)да... сложно конечно... ну все же да... конечно после администрирования винды картинками... ожидать подобное стоило... к сожалению жизнь... это не администрирование "картинками"
327
11 - 21.03.2004 13:27 		Ладно....

Плиз, изложи методы защиты информации на сети... При следующих УСЛОВИЯХ.....

-- локальная сеть небольшой фирмы..... (скажем, до 20 пользователей)....

-- территориально - 3-4 соседние комнаты, кабель проложен по стене, визуально контролируется весь....

-- доступа в интернет НЕТ.... выделенки нет, диалап на отдельной машине вне сети (т.е. внешние угрозы отсутствуют в принципе и их можно не рассматривать)....
--------------------------------------------------------
Вариант А - одноранговая сеть
Вариант Б - сеть с выделенным сервером

Вот на базе этих исходных положений и будем спорить....
Все остальное - это навороты, которые у многих отсутствуют.....
Demiurg
12 - 21.03.2004 13:34 		327, я спорить не буду, у меня проблем с этим нет, но если ты не знаешь, как это делается, мог просто и спросить...
Как и Борису, еще раз повторюсь, человек всего знать не может, но это моя работа, мне за это платят, устраиваю начальство, поставленные задачи выполняются - это ли не критерий?

Как ты думаешь, твое мнение отразиться на моей зарплате, или какая другая будет польза мне лично?

Не хвастаюсь, но считаю, что знаю свою работу ХОРОШО - и она мне очень нравиться :-) !!!
327
13 - 21.03.2004 14:08 		Спорить с тобой при наличии выделенки в инет я не буду... Это действительно нужно...

Я хотел показать другое - что при наличии условий из 11 ВСЕ твои методы просто оказываются бессмысленными ....

А то, что есть опасность проникновения извне при выделенке - мне объяснять не нужно...

Более того, всегда говорю клиенту, что если у него выделенка и компов более 20 - нужен отдельный грамотный админ, отвечающий за локалку и защиту ....

Приходящий на полставки тут уже не рулит ....

Плиз... все таки рассмотри варианты защиты информации при условиях (11).... без ВНЕШНИХ УГРОЗ ....
Demiurg
14 - 21.03.2004 14:18 		именно об этих условиях и будет статья - но учту твои пожеланию, рассмотрю не только домен, но и рабочую группу, на вскидку защиту сетевых соединений можно контролировать в плане аутентификации можно сертификатами PKI-технологий, сделав скажем локальный CA. Инсайдеров я рассматривать не буду, т.е. как с ними бороться ближе к HR-работе, но постаюсь ни чего не упустить и не буду брать большую организацию для примера. Кстати, сразу о кабеле - при небольшом метраже кинул бы оптику, т.е. конечно параноидальная защита - вряд ли кто будет подключаться к кабелю - фирма то не большая, но береженого бог бережет. Еще что?
BorisG
15 - 21.03.2004 15:11 		(14) "...при небольшом метраже кинул бы оптику..."
Ну и... оптику то зачем в небольшом офисе?
Нужно для начала отпределить аудиторию статьи и условия.
Если в приложении 1С, то, для сведения... нет НИ ОДНОГО случая серьезных съемов информации через систему, кабели и пр. ибо это просто НЕ НАДО. Практически во всех известных случаях тащили НЕПОСРЕДСТВЕННО через дыры 1С.
Если общая информация, то да. Есть причины, когда оптика нужна до рабочего места...
Но есть и оборудование съема информации и с оптического кабеля... Правда, в основном, нужен непосредственный контакт с волокном...
Demiurg
16 - 21.03.2004 15:34 		Можно тащить не только 1С, да и в любом деле разумность и все меру ни кто не отменял. Давайте сразу решим, тащить будут бухи, или посторонние?
BorisG
20 - 21.03.2004 15:52 		+19 Случайно клавищу зацепил... ;-)
Давай все-таки определимся, для кого этот форум.
Если для людей, работающих с 1С, это одно... Им технологии и технические тонкости защиты, применяемые на больших предприятиях врядли им нужны и интересны...
Если сисадминов крупных предприятий, это совсем дело другое... Но врядли кворум для полноценной дискуссии наберем ;-) Я, кстати, с большими предприятиями, в основном, работаю...
Но ветка помещена в раздел 1С:Предприятие...
Demiurg
21 - 21.03.2004 15:55 		Переформулирую, защита от бухгалтеров, которые по определению ДОЛЖНЫ получать информацию - это защита в первую очередь Не техническими мероприятиями, а административными - та же зарплата много значит, но это не входит в задачи. Из технических можно сказать о заблаговременном прогнозе (если хотите контроле действий бухгалтера), например Ideal Administrator позволяет наблюдать за действиями бухгалтера "вживую его экрана", логи, аудит, запрет на съемные носители, т.е. совокупность мер различного уровня.
Об внешних "нарушителях" отделная песня. Потенциально это может уборщица, правда звучит нелепо - однако такие случаи были :-).
Тогда поднимается вопрос об обучении персонала элементарным правилам безопасности при работе с информацией, теже инструкции.
Немаловажен контроль за исполнением их же.
Далее....
Demiurg
23 - 21.03.2004 16:00 		Из технических же мер прежде всего сказал бы об анализе рисков, который является составной частью разрабатываемой политикой безопасности (кстати, составление правильно последней с учетом решаемых задач и не делая иллюзий защищенности является гарантом успеха).
BorisG
26 - 21.03.2004 16:29 		(22) Конечно, отличаются. И сильно отличаются. У каждого форума своя аудитория.
(24) Однозначной оценки нет и на западе...
У нас, на мой взгляд, к разряду крупных надо относить предприяти с числом работающих от 1 тыс. чел, численностью автоматизированных рабочих мест от 30-50, а вот оборот оценивать не буду, у нас его оценка очень неоднозначна.
При этом могут быть и есть исключения, типа предприятий с численностью 30-50 чел, но ОЧЕНЬ значительными оборотами, где принимаемые меры безопасности при обработке информации аналогичны крупным предприятиям...
(25) Не понял юмора.
Demiurg
27 - 21.03.2004 16:45 		набрал в поисковике "BorisG"
http://www.livejournal.com/userinfo.bml?user=38th
http://geo.web.ru/bards/1addressbook/pers000658.htm

если расскажите о себе на самом деле, мне было интересно

об аудитории, по той же самой неоднозначности, мне кроме вопросов администрирования еще приходиться внедрять проекты (пусть небольшие, так как пишем не большим количеством народа), но это же не обязанности сисадмина в чистом виде
BorisG
28 - 21.03.2004 17:00 		(27) Случайное совпадение, я и не знал, что у него такой же ник на других сайтах ;-)

Относительно аудитории. Для полноценной дискуссии нужно хотябы 5-10 спецов в конкретной области, чтобы она была конструктивна.
Тут же получается, что мы с pit'ом являемся для тебя вынужденными оппонентами, и вовсе не о того, что интересен сам предмет обсуждения, а из-за того, что применение его в этой области в большинстве случаев неоправдано... со всеми вытекающими...
BorisG
29 - 21.03.2004 17:06 		Еще относительно аудитории...
Если взять область 1С, то отвечают на форумах на серьезные вопросы одни и те же... Однако контингент спрашивающих сильно разный... Поведение владельцев форумов тоже разное... Этим и определяется активность и поведение отвечающих...
Demiurg
30 - 21.03.2004 17:07 		мне все думается, что мы скорее все таки просто коллеги, и делить то нечего :-)
К тому же мне еще предстоить "подружиться" с Cisco, пока сфокусирован на других задачах.
И все таки в двух словах о себе, можем через MSN например (MSN: gilev_slava (@) mail.ru).
Если нужна аудитория, то мой "родной" сайт CCNA.RU :-)
327
31 - 21.03.2004 17:41 		(30) если говорить об областях защиты.... то ты говоришь о внешних злоумышленниках.... по отношению в БД.... которые по определению не имеют к ней доступа... Тогда описываемые тобой методы - .... ну они для этого и предназначены...

Я же говорю о злоумышленниках "внутренних" - т.е. сотрудниках, которым по работе открыт доступ к той или иной информации в БД.... Тогда описываемые тобой методы не рулят.... не, часть вполне применима... аутентификация, например, нужна однозначно.... Но когда штатно сотр имеет доступ к БД - внешними по отношению к этой БД средствами контроль невозможен ....

А средства внутр контроля в 1С 7.7 слабы.... О 8 речь не идет.... (к тому же в ней, хотя бы по описанию.... контроль усилен)....

В абсолютном большинстве контор кража выполняется собственными сотрами.... Самое прикольное - чтобы утащить существенную коммерческую инфу из базы размером 5 Гигабайт (!!!) надо всего 4-5-6 дискет.....
Кстати, тот же Бест-4 имеет гораздо более сильную защиту ....

Вот как раз эта область освещена крайне слабо...
В основном решения только административные....

Свод правил по защите в таких условиях - это было бы актуально и интересно для всех .....

Та же часть, о которой говоришь ты (защита внешних соединений) - достаточно хорошо освещена в литературе... Ну по крайней мере пяток хороших книг любой поисковик выдаст сразу ....
Demiurg
32 - 21.03.2004 18:28 		уф, утомил если честно уже (31): "Я ГОВОРЮ О ВНУТРЕННЕМ КОНТРОЛЕ", см. внимательно тот же (21), тока не спеши...
327
33 - 21.03.2004 20:37 		Ну читал я этот пост... Если по пунктам

"например Ideal Administrator позволяет наблюдать за действиями бухгалтера "вживую его экрана" - если в конторе более 20 компов - мил человек.... никто ничего смотреть не будет...

"логи" - см предыдущее

"аудит" - это весЧ.... подняв АД, можно нехило порулить групповухой... Это очень даже ....

"запрет на съемные носители" - практически нереализуем... Если не учитывать экзотику типа внешнего зипа.... то флопики ты не вырубишь .... сразу всплывет масса всяких фондов.... куда надо носить дискеты...

а усб тоже не отключишь.... часто принтера висят там.... и поверь, некоторые оченьбыстро доходят - выдернуть принтер, вставить флешку.... записать и воткнуть принтер взад ....

Все это проходили... очень геморойно, трудозатратно... и поверь мне, тебя за те же снятые флопики поимеет начальство - достаточно буху один раз отмазаться.... типа информация не сдана - админ отключил дисковод... и прощай защита..... Второй клизмы ты не захочешь... Доказать же начальству - не докажешь.... Ему плевать на защиту - текучка важнее....
Demiurg
34 - 21.03.2004 20:46 		(3)
Ознакомься с такими понятиями как "разграничение ответственности", когда бух отвечает за то, что пишет пароль на самом мониторе;
Ideal Administrator может и не потянет (а точнее комп) слежение за всеми одновременно, дык и ты не сможешь уследить, не надо палку перегибать;
логи - есть средства для автоматичского сбора и анализа логов, если ты не знал, извиняй;
"запрет на съемные" еще как реализуем, только не путай с тем, что эти правила - корпоративная политика, которую должны выполнять все, к примеру мой директор не задается вопросом, почему он не имеет административных прав сети, а если у тебя такой будет, лучше беги от таких :-)
заблокировать флешку - ЛЕГКО!!!
а слова "геморойно, трудозатрадно" - от лени и незнания (к тебе не относиться) возникают когда не можешь правильно организовать работу в сети так, чтобы твоего личного присутствия не требовалось...
skunk
36 - 21.03.2004 20:51 		+33 у 90% контор этой проблемы нет, или она надумана... а там где это проблема есть... рулит безопасностью не админ только закончивший коледж, институт или универстет (по выбору), а специально натасканый спец... как правило человек проработавший в специфических органах не один год... и знает методику ведения допроса военопленных в полевых условиях... (не путать с мордобоем)

не твоя это забота мил человек, если ты администратор сети
skunk
41 - 21.03.2004 21:05 		(34)парочка вопросов
1.Как запретить пользователю печатать отчет, когда этот отчет не нужен, то есть во время кражи информации...
2.Повысить права в винде(и не только) имея физический доступ как два пальца... и локальная политика не поможет... не надо кричать бух на это не способен... при краже достаточно интересной инфы буха проконсультируют как это делать... и дадут ему то что надо для того что бы это сделать
3.из два следует что флэшку ты не отключешь ни как, как и сом порт на который тоже можно вешать устройства...
4.если на тачке стоит сидюк, то дело решается вообще все просто... путем подготовки специального диска... пароль на биос тут не рулит... достается не просто а очень просто...
5. и много чего еще продолжить...
BorisG
42 - 21.03.2004 21:12 		(40) Об уровне ответственности на предприятии и допуске к информации... Вопрос предельно простой...
Еще одна весьма деликатная тема... Любой способ контроля экрана буха, особенно ГБ... RAdmin, Ideal Administrator и пр. рулят до тех пор, пока бух не понимает, а поймет...
Demiurg
43 - 21.03.2004 21:14 		Ну для начала, хочу сказать большое спасибо, так как давно так не смеялся :-)

---
почему вы так настойчиво давите на то, как подкупите буха - тут нельзя спорить, тогда сразу подкупите админа и не парьтесь...
даже на печатающем принтере USB для дисковых устройств блокируется!!!
в рабочее время посторонний человек не получит физический доступ, там сидит бух (если вы про это любите акцентировать :-), в не рабочее комп выключен, кабинеты закрыты, подкуп охранника - тожа история "инсайдера" что и с админом.
Еще что?
(Вообще это даже хорошо, уже есть новые разделы в статье)
Demiurg
44 - 21.03.2004 21:15 		Борис, а контроль за безопасностью компании, кажись сотрудники должны заниматься только работой на работе, извиняюсь за коламбур...
327
45 - 21.03.2004 21:18 		(35) Милай! Проще надо быть... проще ... и народ к тебе потянется...

Ты явно работаешь в конторе, где компов штук 200... или поболее.... И у конторы есть деньги на содержание админа... И есть понимание этой необходимости ....

Только вот таких контор то немного... А основная масса - 15-30 машин... и один человек на обслуге... Который и админ сети, и админ 1С, и программист.... и ремонтер... и частенько на него еще АТС вешают ... с копировалкой ...

И в такой конторе все твои рекомендации - по боку... Ну нет у них желания тратиться на безопасность отдельно... Не понимают они этого... И доказывать таким конторам что либо бесполезно - они не поймут... пока сами не поимеют все удовольствия.

И техника в таких конторах часто старая... А как известно, в98 можно очень простенько проколоть...

И тут групповичек НА БЛОКИРОВАНИЕ ФЛЕШКИ (и вообще на установку новых девайсов) - обходится.... ЛЕГКО! Так же и с логами...

Так что основная проблема, как говорится, не в деньгах... А в их количестве...

Ну об этой ситуации, я думаю, лучше расскажет Борис...
О том, что нет понимания проблемы... и НЕТ желания понять.... И ЕСТ желание сэкономить...

И не надо говорить, что заблокировать ЛЕГКО.... Уж как порулить юзером через сервант - я знаю.... Можно даже порулить автономной в98 при желании... Реестрик то доступен... Тоже можно много чего сотворить .... если разобраться с реестром...

P.S. насчет вопроса в письме .. (кстати, а зачем письмо дважды?).... Пороюсь в архивах... если найду статью ... перешлю... Но не гарантирую... Я такое барахло долго не храню.... на компакты не пишу.... только на текущие архивы на магнитооптике ...
Demiurg
48 - 21.03.2004 21:24 		про письмо, я не знаю статьи, хочу ознакомиться со всем что уже было, может найду что то новое

если заниматься безопасностью компания не желает, значит нет смысла поднимать вопрос о безопасности

а на счет компов правы, действительно у меня их не десяток

делать что в 98 - я пас (не приходилось работать как админу с ней):-)

на 2000-м права при граммотном поднять права очень сложно при граммотной настройке - тут уже скорее вопрос о целесообразности затрат на обеспечение безопасности которая при определенных условиях рискует превысить стоимость того, ради чего все задумывалось :-)
skunk
50 - 21.03.2004 21:31 		(48)поверь, поднять права на локальной машине не просто, а очень просто... об этом говорилось ни раз... поищи если интересно... найдешь много полезного...
Demiurg
51 - 21.03.2004 21:33 		я чувствую, если еще пару постов... :-)
локальная машина на то и локальная, лучше вот посмотри, думаю пригодиться тебе
http://www.jsiinc.com/SUBO/tip7000/rh7093.htm
BorisG
52 - 21.03.2004 21:36 		(44) Да... явно ты еще не сталкивался с грамотными бухами... ;-)
Редко какой бух потерпит, чтобы за его экраном наблюдали... Грамотный ГБ админа подставит на раз... Кстати, так не только у нас... была одна статейка об английском банке... но... не храню такие ссылки...

PS: На самом деле разговор, в общем то беспредметный...
Ибо обсуждать политику безопасности безотносительно конкретного объекта бессмысленно... Еще раз, это КОМПЛЕКС мер...
И на самом деле цель этого разговора развеять твои иллюзии о том, что все можно решить средствами системы и админа... И не надо буха подкупать...

PSS: Недавно писали заключение для одной немаленькой компании... торговля нефтепродуктами... админ сразу уволился...
Demiurg
54 - 21.03.2004 21:40 		(52) у меня нет иллюзий - взлом и защита, пожалуй как курица и яйцо, почти философский вопрос - это борьба знаний разных людей...
skunk
55 - 21.03.2004 21:43 		Слав, если по серьезному, то ты просто не имел пока, проблем по этому поводу (отсюда и был, сделал вывод, может быть не верный относительно компьютеров)... поверь, обламывались и более крутые спецы... которые не мучаются с "контролерами" и знают ад как отче наш...

удачи...
Demiurg
56 - 21.03.2004 21:44 		(52) А с граммотным бухами (если в смысле "продвинутыми пользователями" действительно не имел дела к сожалению), неужели их так мало :-(?
Demiurg
57 - 21.03.2004 21:46 		AD ни какого отношения к этому посту не имеет, это не вопрос операционнки или технологий, это вполне "человеческий" вопрос
---
Кстати, еще одна вещь (ИМХО) важная для админа, уметь остоять свою точку зрения перед начальником, бухом, да не важно, иначе какой ты админ :-)
BorisG
58 - 21.03.2004 21:50 		(56) Нет, Слава, не продвинутыми, это само собой... а со стервозными..., это если женщина... О том, что сделает мужчина ГБ, если узнает, что за ним админ через RAdmin следил, я вообще помолчу... ;-)
Не забудь, ГБ на предприятии, как правило, лицо особо доверенное... со всеми вытекающими...
327
60 - 21.03.2004 21:53 		(48) вот в том и дело... что не десяток... И есть корпоративная политика ... и деньги на поддержание корпоративной политики...

Почитай о новеловском продукте ZenWorks .... мечта ленивого админа ... Но поднимать его на 50-60 машин ... смысла нет... трудозатратно..

Управлять групповыми политиками через сервант... можно... но делать это должен специально выделенный и грамотный чел ... опять таки деньги в виде ЗП....

Вертеть 98ми - проще некуда... Такой же реестр... Когда мне надоели бухи и манагеры, лазящие где попало... вылез в инет, вытянул пару описаний реестра и за день сваял свою програмку на делфях... Конкретно для 98...

Запрет изменений установок принтера

Запрет сноса принтеров и установки новых

Запрет правки реестра через регЭдит

Запрет запоминания паролей виндой (злобная кара для некоторых ... особ) а без ввода пароля - прощай, сетка ...

Запрет на ввод простых паролей (особым .... чудам выставлялось требование на алфавитно цифровой пароль для символов 15-20).... Вместе с запретом на запоминание -- это хорошая розга....

Запрет на изменение настроек экрана... в том числе заставок и прочего - свойства экрана можно было закрыть полностью...

Куча вспомогательных установок... Типа запрета автозапуска с СД...

Запрет на установку нового железа....

и еще чего то - уж и не помню...

А, вот еще - не показывать диски в проводнике....
Убрать иконку СетевоеОкружение со стола...
Убрать некоторые возможности в панели управления....

Конкретно для 98 - мне лень было проверять на 2000 и ХР.

По моему, даже исходники остались... В принципе можно и для 2000 переделать.... Хотя особой нужды нет....

А ключики реестра многие совпадают .... в 98 и 2000 и ХР

(49)... не, у него, судя по его высказываниям, машин много....
327
64 - 21.03.2004 22:19 		Да такую прогу пофих на чем писать.... Лишь бы WinApi (функции чтения записи реестра доступны были)...

Кстати, исходники точно есть... Вместе с хелпом. по которому писал...

Вообще админством стараюсь последнее время не заниматься... особого дохода с него нет... Так, по минимуму настроить сервант, минимум настройки прав... Пусть заказчики сами делают это... Я строю только то, что мне надо... И безопасность сюда не входит... Но способы кражи известны... и методы их затыкания в 1С... Хотя там особо то и не закнешь... Гораздо актуальнее - кража денег с помощью 1С....

А насчет того, что будет скандал, когда узнают о наблюдении - это так.... Видел такие заварушки.... Вот где бабы пену поднимали ... Ну а так как в руках ГБ много возжей - все, к админу - пушной зверь..... северный ... приходил...
А у меня между прочим.... семилетний опыт работы в нехилом институте ... и НИ ОДНОГО конфликта с тамошними мегерами .... коих было большинство ... и все эти ... были программистками .... А это - вдвойне ...
yret
65 - 21.03.2004 22:20 		Почитал 45 и 60 прав на все 100. (Даже 45+60=105)
Тебя бы к нашему начальнику объяснить чем занимается программист!
skunk
66 - 21.03.2004 22:22 		(63)Слав это не есть задача админа, отстаивать чего перед начальником... это есть обязаность начальника тех отдела... не много разницы есть... если контора действительно большая...
И еще... но в принципе не важно... честно...
(60)Я тоже могу сказать что в газпроме работаю... работаю ли на самом деле... вот в чем вопрос...
Demiurg
67 - 21.03.2004 22:23 		ну на счет реестра на этом большая часть защиты и строиться в том же домене, можно не только на обращение доступ закрыть, но и на хэш-код проги, и сервисы запретить, но вот только на Visual C++ хоть и старенький, но мне ближе чем дельфя...
Demiurg
68 - 21.03.2004 22:26 		о действиях: не верно в корне вмешиваться буху в управление сетью, и где это не так, ну чтож... слава богу что не в моей сетке 6-)
327
69 - 21.03.2004 22:36 		(67) а какая разница... на чем писать.... Писать надо на том, что удобней.... для тебя...

Так они не вмешиваются... Они просто ковыряют мышкой что попало... и давят что под палец попало .... а попадает почему то клавиша ДЕЛ.....

Вот это самые страшные враги админа.... Убил бы любопытных ... За их любимое занятие .... скачать и поставить новые обои ....
Леонид
73 - 22.03.2004 01:51 		(60) У меня в классе Вин98 стоит. И никаким
способом Вин НТ и др. не ставятся. Железо...
Если не трудно (и не жалко) сбрось файл на емелю.
А то админа не допросишься.

Интересная ветка получилась. И в смысле темы, и в смысле психологии. Столкновение мнений и достаточно вежливое "противостояние".

ИМХО вообще-то наблюдать за ПК ГлБуха запрещено априори. Админ не та фигура, и даже нач конразведки не та фигура. "Жена Цезаря вне подозрений". Если же ГБ начнет уводить инфу, то ему это удастся и под наблюдением. А все учебники говорят, что КОМПЛЕКС мер
должен состоять из программно-технических и АДМИНИСТРАТИВНЫХ мер. Иногда мне кажется, что вторые - важнее.
Vser1
74 - 22.03.2004 02:42 		Вот еще вопросик на засыпку.
В большинстве контор сотрудникам разрешен выход на электронную почту, а как защитить информацию 1С, от попыток передачи ее через мыло?
в плане: "В абсолютном большинстве контор кража выполняется собственными сотрами.... Самое прикольное - чтобы утащить существенную коммерческую инфу из базы размером 5 Гигабайт (!!!) надо всего 4-5-6 дискет..... " (с) Pit
(73) Для 98 винды есть специализированный комплект для этих целей, как называется уже и не вспомню (что типа Polices), когда-то попадался на диске...
Леонид
75 - 22.03.2004 03:11 		(74) Да, есть такой, только интерфейс у него ОЧЕНЬ неудобный. Я пытался пользоваться X-Setup, но даже
в этой прекрасной программе требуется много времени.
А у меня 40(!!!) часов в неделю. Еще же и к урокам готовиться надо, так как в этом году сунули 80% новых предметов. Поэтому и попросил. Так то у меня мелкие заплатки есть, но работать в режиме "сломали - восстановил - закрыл" уже достало. А штатный админ
мух не ловит. Ему с Вин2К и ХР интереснее.
romix
77 - 22.03.2004 03:31 		SQL сервер поддерживает обычный авторизованный доступ.
Соарон вроде бы патчил 7.7, чтобы она умела юзать авторизацию. Обидно что система не получает развития в угоду 8-ке (и еще не факт, если отбросить искусственные трюки), что 8.0 чем-то хороша. Типа не обновить ли всем парк ИТ и выкинуть ранее написанное ПО, просто потому что вышла 8-ка, которая умеет таки юзать SQL-ный логин и пароль...
327
79 - 22.03.2004 06:45 		(72) хе-хе.... а студенты на что?... Изъял у них штук пять дисков.... и заливаю потихоньку.... Благо кто то привел все это г.... в структурированный вид ... иначе возился бы я с этим ....

(73) сегодня вечером ....

(74) копия писем с аттачем.... Эпизодический контроль...

(77) у 8 другая область ...
BorisG
80 - 22.03.2004 08:16 		(73) В классе ничего не надо ставить... Есть такая штука, Norton Ghost называется... Она и рулит...
После установки системы и всех необходимых приложений просто сбрасываешь образ системного диска на сеть или компакт... На восстановление машины нужно несколько минут, что бы злобные студенты с ней ни сделали...
У меня есть клиент, где более 200 компов в учебном процессе... Девочка класс восстанавливает за 15-20 мин...
skunk
81 - 22.03.2004 08:29 		(74)а я бы даже не рисковал электронкой...
(76-79)можно слать картинки... и котроль по фиг...
Demiurg
82 - 22.03.2004 09:48 		почту почти не возможно контролировать - это такое поле для изобретательности ...
BorisG
83 - 22.03.2004 11:22 		(73) Относительно интересной ветки и психологии...
На самом деле в этой ветке нет столконовени мнений, как и нет противостояния. И пользы, на самом деле не много...
Да и дискуссия то поддержана только ради читающих, чтоб не было иллюзий относительно решений этих вопросов только методами администрирования системы... одно из самых больших заблуждений... хотя и достаточно часто встречающееся...
Ибо для нас с pit'ом это давно пройденный этап... и историй можно рассказать десятки...
romix
87 - 22.03.2004 15:34 		(79) Ага, другая ... Ну прямо совсем другая рыночная ниша, те кто сидит в 7 не могут даже и думать про логин и пароль в SQL. А должны для этой простейшей вещи уничтожить ранее наработанный код, и еще раз заплатить бабло за все - в т.ч. разработчикам системы учета.
Имхо искусственно заморозили 7, чтобы заставлять людей при масштабировании решения платить за все дважды. Только вот смасштабироваться можно и на совсем другую платформу, которая не славится таким хитрож. маркетингом для выкачивания бабок. Раньше им славилась IBM.
327
88 - 22.03.2004 16:28 		(87) Да. Явно заморозили... Народу мало... на все явно не хватает...

А ниша у них явно разная ... Ставить на 10 юзеров сервер под sql и отдельную машину под сервер приложений ... хм... По деньгам дороговато будет...

К тому же 8 явно требует уже 8 программеров 1С (админ + прог) ....
romix
89 - 22.03.2004 17:37 		(88) 8-ку можно ставить локально на 1 пользователя. Так что и она полностью масштабируется - от 1 юзера до любого их числа. Сервер приложений - это просто подсистема, которую решили вынести на сервер, чтобы не гонять по сети большой объем данных. А то, что 1С решила забить на простейшие изменения в 7.7 - ну не знаю, видимо хочет не пролететь над гнездом кукушки с 8-кой. Хотя такие нечестные приемы по околпачиванию потребителя хорошо видны невооруженным глазом. :-)
oldis
90 - 01.04.2004 22:47 		Интересное чтиво, вот только переливаем из пустого в порожнее. Риторический вопрос о том, как защитить данные, которые хранятся в файлах формата dbf (SQL не в счет).
До тех пор, пока организация использует общераспространненный софт, всегда найдется чел, который разбирается в нем лучше, чем её сотрудники.
Может весь фокус в том, что перед тем, как взламывать (красть) софт или его часть сначала придется разобраться "Чё ж это такое, и с чем это едят?", и без всякого описания и Хелпа. (Это так, лирика насчёт специализированных решений).
А если ближе к теме, то, господа, зайдите в ближайший игровой компьютерный клуб, что вы увидите. Ассоциация прямая - есть сервер и игровые (т.е. рабочие) компы,на которых установлены обычные WinLook-еры и им подобные программы. И поверьте, что-то скопировать или сохранить на диск, когда при старте системы автоматом запускается 1-С Предприятие, а при выходе из него - комп вообще отключается - довольно проблематично даже в 98-й Винде. Проблемы с ГБ и ему подобными решается элементарно. На рабочих станциях физически отсутствуют CD-ROM и флоппики, а также принтер, но они есть на выделенной для этих целей машине, где намного проще проконтролировать, кто и что печатает на принтере или пишет на диск.
Как говоорил классик "Разделяй и властвуй!". Да, кстати, в WINLook можно добавить еще пару ярлыков для Ворда и Почтового клиента. Почта настраивается таким образом, что рядовой юзверь только читает почту и создаёт письма, а отправляет их уже другой человек (предварительно ознакомившись с содержимым).

P.S. И всё равно это не панацея, а информация к размышлению...
BorisG
91 - 01.04.2004 23:28 		(90) Ну ну... Видно с "воровством" при помощи 1С ты еще почти не сталкивался ;-)
И проблемы с бухами тебя стороной обошли...
Demiurg
92 - 02.04.2004 00:18 		Борис, ты это гришь, потому что тебя эти проблемы не обошли стороной, расскажи поподробней
BorisG
93 - 02.04.2004 00:32 		(92) Пособие начинающему хакеру написать?
327
94 - 02.04.2004 06:10 		(90).... насмешила фраза .....

"И поверьте, что-то скопировать или сохранить на диск, когда при старте системы автоматом запускается 1-С Предприятие, а при выходе из него - комп вообще отключается"........

И да простят меня комоды .... При работе в среде 1С в любой типовой конфе есть не менее ЧЕТЫРЕХ дыр... а в нетиповой не менее ДВУХ ... через которые я могу настолько примитивно добраться до системы ....

Причем две из них затыкаются очень сложно... А многие админы вообще заткнуть их не в состоянии... уровень не позволяет...

P.S. замечание действительно для любой оси - 98, 2к, ХР...

А вот это вообще бред ....

"Почта настраивается таким образом, что рядовой юзверь только читает почту и создаёт письма, а отправляет их уже другой человек (предварительно ознакомившись с содержимым). "

В условиях, когда на каждого возлагается куча обязанностей, держать специально выделенных людей для отправки почты никто НЕ БУДЕТ....
Demiurg
95 - 02.04.2004 12:20 		(93) Хотя бы просто ответь да или нет
BorisG
96 - 02.04.2004 13:04 		(95) Чего да или нет?
Если лично меня, то не касались... Как правило эти проблемы наблюдаю, когда прихожу к новому клиенту...
Если интересуют дыры в учете... сие лучше в открытом доступе не давать...
Пользы никому от этого нет...
Информационная безопасность - это, еще раз, комплекс мер...
В 1С просто отсутствует контроль целосности данных... учитывающих отраслевую специфику... посему самые изощренные методы администрирования сетей становятся просто бессмысленными...
BorisG
98 - 02.04.2004 13:12 		В продолжение (96)...
Простой пример... и вроде уж совсем безобидный...
Градуировочная таблица нефтяного резервуара... казалось бы, чего проще... уровень - объем...
Однако контроль отклонений поверг заказчика в шок...
Вынужден был принимать меры по срочной повторной калибровке резервуаров... а также искать виновных... это всеж документ...
До этого была другая настройка 1С...
Demiurg
99 - 02.05.2004 02:17 		Обещанное продолжение:
http://www.gilev.ru/1c/sec/sec.htm
http://www.gilev.ru/1c/sec/ipsec.htm
http://www.gilev.ru/1c/sec2/sec2.htm


Как сделать так, чтобы пользователь(менеджер) видел только своих клиентов? | База знаний | mista.ru

Как сделать так, чтобы пользователь(менеджер) видел только своих клиентов?

Михаил 21.06.2004 15:16 | Собственно, сабж и работал только с документами, автором которых является. 7.7, не сиквел. Кикие будут мысли по этому вопросу?
Рупор абсурда 1 - 21.06.2004 15:18 | Всяческие отборы для этого существуют ...
Gavrila 2 - 21.06.2004 15:18 | по справочникам ИспользоватьСписокЭлементов() в журналах отбор по пользователь(менеджер)
smdv1000 3 - 21.06.2004 15:20 | Сделать справочник менеджеров. Сделать подчинененный справочник с элементами из спр. контрагентов. Как ещё?
Волшебник 3 - 21.06.2004 15:20 | Вот здесь кое-что есть: http://mista.ru/articles1c/hare/article.61.html
Михаил 5 - 21.06.2004 15:53 | Господа, спасибо! А есть ли смысл добавлять в справочник контрагенты графу манагер или можно как-то по другому указать, чей это клиент? Заранее прошу прощения за бестолковость, мне поставили задачу по 1С, я раньше с ней не сталкивался ;( К сожалению, приходится очень многое переделывать "на лету", так что во многом просто не успеваю разобраться. 2 АДМИН: А как насчет того, чтобы на моих примерах разобрать типовые решения типовых проблем (для совсем ужначинающих)? ;)
Gavrila 6 - 21.06.2004 15:59 | (5)В комплексной у контрагента есть реквизит "Менеджер", вот по нему и можно отфильтровать клиентов(см(2)), если у тебя нет то ничего лучшего чем добавить не скажу :)
crashdevice 7 - 21.06.2004 16:50 | Посмотри на любом ИТС - "методическая конфигурация". Там отбор по остаткам в справочнике номенклатуры сделан, наверняка поможет.


Есть компонента для скрытия системных меню? | База знаний | mista.ru

Есть компонента для скрытия системных меню?

Хочу знать... 21.06.2004 15:28 | Привет всем! Есть компонента для скрытия системных менюшек "Файл", "Сервис", "Операции"? На Хиппо не нашел.
alxkorvin 1 - 21.06.2004 15:29 | Меню операции можно скрыть из настроек интерфейса пользователя


Конфигурирование пользователей в Торговле (проблема) | База знаний | mista.ru

Конфигурирование пользователей в Торговле (проблема)

Danila 08.06.2004 10:56 | Проблема: Создаю нового пользователя, даю ему права "администратор" в конфигурации "Торговля + склад" редакция 9.22 релид 933. Захожу эти пользователем в программу открываю общий журнал счетов, выбираю неподтвержденную заявку (документ проведен) и пытаюсь редактировать цены, получаю сообщение что нельзя в соответствии с праваму доступа. Но ведь раньше я создавал таких пользователей и проблем не было, правдо это было до поднятия релиза. Причем старые пользователи с аналогичными правами без проблем редактируют цены в проведенных документах. Как решить эту проблему? Спасибо!
maloy 3 - 08.06.2004 11:03 | 1С-ники добавили в торговлю в справочнике "Пользователи" реквизит "Полномочия", чё бы можно было разруливать кой-какими вещами которые нельзя задать параметрически в наборах прав в конфигурации. Каждому новому надоть чё-то выбрать в этот реквизит.
Danila 4 - 08.06.2004 11:12 | [3] А где посмотреть что означают эти полномочия. Т.е. какие действия разрешены (запрешены) заданным полномочием, хочется понимать что пользователь может делать, а что нет.
Danila 5 - 08.06.2004 11:15 | [3,4] Все нашел. Это Справочники -> Структура компании -> Полномочия пользователей Спасибо!


ПравоДоступа("Название права") | База знаний | mista.ru

ПравоДоступа("Название права")

Sin_f 03.06.2004 07:24 | Для того, чтобы узнать есть ли право у пользователя делать архивную копию базы использую функцию ПравоДоступа("Название права"), но вопрос в том, что вписать в "Название права"? Есть предложения?
SnarkHunter 1 - 03.06.2004 07:27 | <НазваниеПрава> - строка с названием права доступа, как оно выводится в конфигурации (без пробелов).
427 2 - 03.06.2004 08:30 | АдминистративныеФункции СохранениеИВыгрузкаДанных УправлениеОперативнымиИтогами УправлениеБухгалтерскимиИтогами Монитор OLEAutomationServer УдалениеПомеченныхОбъектов ПоискСсылокНаОбъекты ИспользованиеЛюбыхВнешнихОтчетов ИспользованиеОбщихВнешнихОтчетов ИспользованиеФункцийВТабло ГрупповоеПроведениеДокументов ИспользованиеТаблоСчетов МонопольныйРежим АвтообменВРаспределеннойИБ


Защита данных в 1С | База знаний | mista.ru

Защита данных в 1С

Sasha
31.05.2004 03:50 		Кто что использует для защиты данных?
PGP защищает только если комп выключен. Как защитить 1C'овскую базу, что бы ее не могли "слить" с работающего сервака?
FAM
5 - 31.05.2004 08:10 		Если у юзверя есть доступ к базе, то никак не защитить...
разве что повыдергивать флопари, пишущие СД, порты СОМ, LPT, USB, залить эпоксидкой корпус и опечатать его, заодно отрубить весь инет, доступ пользователя в сеть полько с одного компьютера по отпечатку пальца (чтоб сосед свой пароль не выдал).
427
7 - 31.05.2004 08:32 		Ну скажем, (5) это уже последняя стадия ... к психиатру...

кстати, привет ФАМам... как собачка?

Чтобы "слить" базу, не обязательно сливать ее всю...
В любом случае для выноса инфы потребуется максимум 5 дискет... Вне зависимости от объема базы... Потому что всю ее тащить - и не требуется ....

Для "сдачи" в налоговую достаточно слить
- справочник контрагентов с адресами и ИНН
- название дока (ПН,РН,ПКО,РКО), дата дока, сумма дока..
и все - первая же встречная проверка накрывает фирму

Для "сдачи" конкурентам достаточно слить
- справочник товаров
- справочник контрагентов с адресами и ИНН (база клиентов)
- название дока (ПН,РН,ПКО,РКО), дата дока, сумма дока..
- товары в документах + анализ продаж по товарам (если требуется анализ продаж для выяснения прибыльности и продаваемости товаров - эта инфа стоит денег... и хороших денег)
- взаиморасчеты (если требуется анализ контрагентов)

Причем все описанное можно вынести не только на дискетах или по почте, но и на бумажке... в виде отпечатанного отчета...

Вот по сути и все.... Основная проблема в том, что надо и дать людям доступ к базе и защититься от "слива"... Вне зависимости от типа базы (ДБФ, Sql) все поставленные задачи выполняются на раз-два... ибо в самой 1С нет средств защиты и масса дыр...

И даже терминал прошибается средствами самой 1С... тут я тащусь кАнкретна ...

Успехов ...

P.S. могу рассказать о методике защиты на 99%....
Утром набираем новых юзеров...
В течении дня никуда не выпускаем...
Вечером в 18-05 их расстреливаем.... чтобы ничего не вынесли...
Черт
11 - 31.05.2004 10:36 		(7) а если они успели почту отпраить? (возможно даже голубиную)
тогда придется всех держать в помещении без окон, каждого юзера в отдельном , и "отрезанным" от всего
lexa
13 - 31.05.2004 11:26 		Если у руководства паранойя в осложненной форме, то пусть сами за нее расплачиваются. Хотят полной секъюрности, пусть ищут разработчиков, которые сделают решение под ключ. Ну естественно, что стоить это будет порядка на два дороже 1С.
Композитор
14 - 31.05.2004 11:29 		Уберечь базу от воровства невозможно. Уберечь от чужих глаз данные о финансовом положении фирмы, рентабельности продаж и прочих "вкусных" вещах можно.
427
15 - 31.05.2004 12:39 		3 причины кражи базы

- сдача в налоговую
- продажа клиентской базы и инфы о продаваемости товаров конкурентам
- продажа инфы о финансовом состоянии фирмы конкурентам (спасибо 14, я упустил этот момент)

Последний пункт можно пародийно закрыть, ограничив круг лиц к той базе, где находится реальная информация... Но ктото же должен вести эту базу....

Информацию от маски-шоу скрыть очень сложно...
1 -- не надо считать их тупее себя...
2 -- они приходят после предварительной разведки
3 -- изымаются в первую очередь бумаги, во вторую - компы...
4 -- на компах в первую очередь смотрится не база, а рабочие каталоги ... ворда.. а там интересного - гораздо больше ...
5 -- обнаружение средств типа ПЖП - подсудное дело... И админ сам расскажет о паролях... Иначе - яй...ца в дверь и ... сам расскажет ...
6 -- все технические и прочие средства защиты мало того что под запретом, ежедневное и ежечасное соблюдение защиты - очень накладно... и через месяц после ввода их в эксплуатацию - в реалиях многое тихо херится...
Sasha
16 - 31.05.2004 13:16 		Привет!
Да, ребята, добрые вы :))

1. Почему использовать PGP нельзя?
Она до 8 версии была freeware. В крайнем случаее можно использовать платный Secret Disk от Aladdin.

2. Может ли решить эту проблему SQL'ный вариант 1С? Или, скажем, серверный вариант 8-ки? Т.е. задача простая: чтобы у пользователей не было прямого доступа к файлам базы данных.

Спасибо.
427
18 - 31.05.2004 13:56 		У тебя позднее зажигание?

1. Почитай о лицензировании средств шифрования... И о применении средств шифрования в России/Украине. И соотнеси со статусом ПЖП... А не с шароварностью...

2. Sql вариант не даст возможности выгрузить саму базу... Но выгрузка данных НЕ ЗАВИСИТ от SQL / DBF варианта 1С - она везде одинаковая ...
Sasha
19 - 31.05.2004 22:47 		Я правильно понял:
1. Ставим Secret Disk от Aladdin'а
2. Ставим SQLный вариант v7
3. Закрываем конфигуратор
и непродвинутый пользователь ничего слить не сможет?
427
20 - 31.05.2004 22:59 		Мдя... Точно как до жирафа

можно даже не так...
1. Ставим Secret Disk от Aladdin'а
2. Ставим SQLный вариант v7
3. Закрываем конфигуратор
4. Настраиваем права доступа к документам и отчетам....
5. Закрываем все внешние обработки
6. Делаем все возможное по ограничению доступа ...

имеем желаемое... но это будет работать только 3 дня... Ибо любой непродвинутый пользователь за 3 дня проконсультируется ... и выкачает все данные...

В этом то вся и проблема ... что СЛИШКОМ МНОГО ДЫР в самой в7....
BorisG
21 - 31.05.2004 23:50 		(19) Давай по всем пунктам не будем?
Secret Disk спасает только от внутренних разборок... когда машина выключена ;-))
или срочно надо отключить диск (тревожная кнопка)... Маски-шоу не в счет, об этом уже писали ;-))
"Закрываем конфигуратор"
Мда... Закрытие конфигуратора есть средство от шаловливых ручек пользователей и (или) обусловлено лицензионным соглашением, но никак не средство защиты данных ;-))
Как думаешь, за сколько постов на известном форуме знакомый студент непродвинутого юзера, не знакомый со средствами взлома получит способ его открытия? ;-)))

PS: Патчи и кряки я не публиковал и не распространял ;-))

PSS: Можно продолжить, но надо ли?
Sasha
22 - 01.06.2004 00:49 		Привет!

(20) Пунты 4-6 подразумевались...
(21) Маски шоу, вообщем-то не подразумеваются. Как я смотрю, сейчас тенденция к тому, чтобы можно было все показать. Это выходит дешевле черно-белых схем. Нужна защита от конкурентов, чтобы неблагонадежный сотрудник не мог слить базу.

Хорошо, я понял, что с v7 непродвинутый пользователь имея явную цель стащить базу и получив точные инструкции от продвинутого пользователя :) по-любому может слить базу, потому что "СЛИШКОМ МНОГО ДЫР в самой в7".

А что по поводу v8? Поможет ли она решить эту проблему. И использованием, скажем SQL-сервера и сервера 1С?
427
25 - 01.06.2004 06:08 		По поводу 8... Теоретически 8 более закрытая система... с более развитой системой контроля прав. Опять таки теоретически 8 должна быть более гибкой и стойкой к взлому...

Но это только теоретически... Реального опыта практически еще нет...

Ну и опять таки практический опыт говорит о том, что наличие многих механизмов доступа (Оле, сом) потенциально дает большое количество ошибок и проколов...
Много штатных возможностей (про дырки пока помолчим), которыми нужно рулить.. и контролировать доступ... И глядя на количество пользователей в системе и реалии - можно сказать, что на 50-100 пользователей нужно специально держать (помимо админа и эникейщика) на сопровождении системы

1 - одного - двух программистов - на доработке и настройке самой функциональной части
2 - одного человека на установке 1С в8, настройке рабочей машины под в8, настройке доступа к ключам защиты ...
3 - минимум одного человека на настройке прав пользователей и настройке системы контроля доступа...

По реалиям в силу российского менталитета и желании сэкономить на всем человека из пункта 3 практически не будет... На его зарплате сэкономят ...

После чего начнутся крики об отсутствии защиты в в8....

Ну а если добавить еще те баги в защите, которые всплывут в дальнейшем.... то что можно сказать о такой защите ....


Механизм Row Level Security - проблемы... | База знаний | mista.ru

Механизм Row Level Security - проблемы...

Eugene G
25.05.2004 06:18 		Подмимал данную тему на Т1С, но там народ, что-то не активно мне отвечал, и в основном "чем бы дитя не тешилось...", может Волшебник чем поможет, цитирую полностью:
-----------------------------
Тема: "Как я сделал убогую RLS"
Сразу отмечу, что слово "убогую" относится не к "RLS", а к "сделал".
Для тех, кто еще не в курсе про механизм Row Level Security - читайте в инете (www.polikom.ru/main/stati/stat_security_rls.htm).
Я расскажу о том, что у меня получилось, не с целью похвалится, а с надеждой, что кто-нибудь подскажет как сделать лучше.
По шагам:
1) Патчим bkend.dll, чтобы пользователи могли коннектится к SQL серваку под своими NT логинами - в текстом редакторе открываем bkend.dll и заменяем строку "UID=%s;PWD=%s;"
на "UID=;PWD=; " (так как написано в статье ToyPaul, http://1csql.udmnet.ru/articles/article.shtml?admin/st0006)
2) Патчим 1cv7.exе: отключаем верификацию таблиц на входе первого пользователя, с помощью Soaron'a
Дальше собственно RLS, вначале на справочники:
1) переименовываем нужные справочники, с помощью EM, например, sc33 в _sc33
2) создаем новое поле в этих справочниках, скажем, User_ID, типа Varbinary(85)
3) создаем для наших справочников view: в select выбираем все колонки, кроме вновь созданной
4) накладываем на view условие: WHERE User_ID=SUSER_SID(SUSER_SNAME())
(SUSER_SID - возвращает "код" пользователя, типа varbinary(85))
5) для таблиц _scXX, создаем триггер на вставку, который при вставке записи, записывает
пользователя, которым произведено добавление. Код триггера:
CREATE TRIGGER TestTrigerSC33 ON [dbo].[_SC33]
AFTER INSERT
AS
set nocount on
UPDATE _SC33
SET User_ID = SUser_SID(SUser_SName())
FROM _SC33
JOIN INSERTED ON _SC33.ID = INSERTED.ID
6) все. наслаждаемся эффектом, теперь пользователи могут работать только со своими записями.
На подчиненных справочниках, как я и думал, тоже все отработало без проблем.
Теперь RLS по документам, собственно все тоже самое:
1) переименовываем _1sjourn, например, в __1sjourn
2) добавляем поле User_ID
3) Создаем на основе __1sjourn view - _1sjourn с условием
4) вставляем триггер
5) вот и все - пользователи видят только свои документы.
Теперь проблемы:
1) То что, патчится dll и exe - это очень плохо. Товарищи Поликомовцы как-то это обошли.
Вопрос как?
2) При любой модификации md файла (c turboMD только при изменении структуры базы)
потребуется восстанавливать исходную структуру базы - удалять лишние поле, и назад
переименовывать их. Для этого можно написать автоматическое средство.
А может можно как-то лучше?
Вот такая лажа получилась у меня. Замутил это я для сдачи диплома, т.е. диплом это конфа
под 1С, а специальность требует, чтобы в разработанном программном продукте была подсистема
защиты.
Кто понял о чем была речь, просьба высказаться. Любая критика или замечания (а лучше советы) приветствуются.
зы. Предзащита в среду.
зыы. Возможно сразу не смогу ответить, поскольку буду ездить по работам, да в ВУЗ, но
-----------------------------
+ еще косяк - поиск по индексированному полю не работает, 1С вываливается с ошикой состояния курсора :((


Защита информации в 1С | База знаний | mista.ru

Защита информации в 1С

Сергей 01.05.2004 17:37 | Как организована защита информации в 1С? Может кто знает на статьи на эту тему или способы улучшения зашиты?
Demiurg 5 - 02.05.2004 01:36 | http://www.gilev.ru/1c/open.html
Demiurg 6 - 02.05.2004 01:46 | http://www.forum.mista.ru/topic.php?id=2462 http://www.forum.mista.ru/topic.php?id=2697
427 8 - 02.05.2004 15:51 | не могешь пользоваться яндексом - отдыхай.... А в указанных статьях о защите информации в 1С ровно столько же, сколько в навозе золота... так, общие подходы в виндах.. и не более... К тому же применять это в 99% случаев - выбрасывать деньги на ветер... А вообще интересно - какой ч(м)удак дает темы типа "Защита инфы в 1С".... если этой самой защиты там нет в принципе ....
kvm 9 - 02.05.2004 18:13 | Ну как-же, а пароли? Мне особенно нравятся пароли пользователей, снес один файл, и нет паролей.
skunk 10 - 02.05.2004 23:50 | +9 вместе с пользователями...
Сергей 11 - 03.05.2004 12:00 | 427. Да могу я пользовать чем угодно, только времени уже нет, поэтому и спросил раз уж попал к таким великим (но жадным!) спецам! И это не тема диплома, а только один раздел! В том и проблема, что все знают что нет никакой защиты, а ты вот (как самый умный что-ли)пиши какие меры предлагаешь для усиления того, чего в нет!
BorisG 12 - 03.05.2004 12:05 | (11) Пора бы понять одну простую штуку... меры безопасности бывают только комплексные... Бессмысленно укреплять ворота... если рядом огромная дыра в заборе... Непонимание первой истины приводит к иллюзиям заказчика... что гораздо опаснее...
kvm 13 - 03.05.2004 23:18 | (10) А Потом вернул на место. Был у нас такой прецедент. Правда все равно отловиди, там еще файлик есть - последний вход. (11) Рарусовские конфы есть под руками? Вот тебе и путь защиты.
427 14 - 03.05.2004 23:26 | (13) если не считать ключа защиты (защита самого МД от пиратского копирования)... конфы от раруса ничем не отличаются от конф 1С.... Кстати, сперев базу раруса, через 5 минут ее можно запустить в режиме просмотра инфы... новых доков (только некоторых!) ты не сможешь делать (защита ключом).... но просмотреть результаты старых - да завсегда заходите ....
BorisG 15 - 03.05.2004 23:30 | (13) У Раруса разные методы защиты в разных конфах ;-)


Контроль безалаберности пользователей | База знаний | mista.ru

Контроль безалаберности пользователей

Sergei 15.03.2004 12:05 | У меня вопрос - можно ли средствами встроенного языка контролировать изменение пользователями уже проведенных документов, чтобы настучать им потом по башке, потому что они меняют только основной документ, причем делют это через несколько дней, а то и недель. Журнал регистраций не удобен, хочется отчет - кто, что и когда
Рупор абсурда 1 - 15.03.2004 12:19 | ПриЗаписи() Если Выбран()=1 Тогда КонтрольБезалаберности() ...
327 1 - 15.03.2004 12:19 | Можно встроенными ... Но надо программировать .... Можно просто запретить править - Константа ДатаЗапретаРедактирования ....
Sergei 3 - 15.03.2004 12:22 | (2) Это надо все документы менять - лобово
Sergei 4 - 15.03.2004 12:25 | (2) Это надо все документы менять - лобовой путь, неинтересный, хотя должен сработать наверняка. Просто есть же этот Журнал регистраций, нужна инфа аналогичная той, только "в руки", чтобы ее обработать. (3) Запретить, к сожалению, нельзя, иначе юзера будут прибегать постоянно с просьбами исправить их ошибки
Рупор абсурда 7 - 15.03.2004 12:32 | (4) Парсинг журнала регистрации - интересный путь?
Sergei 8 - 15.03.2004 12:39 | (7) Интересный, только хочется это сделать средствами 1С Ну так можно или как?
Patriot 11 - 15.03.2004 12:47 | видел разработку по ведению логов действий с документами, вроде бы на хиппо, не плохая штука, я себе поставил, правда пришлось малость переделать, зато один раз устроил разбор полетов , и ошибок стали меньше делать
Рупор абсурда 12 - 15.03.2004 12:49 | (10) Страшный секрет: mlg - текстовый файл ... Только никому больше не рассказывай!
GrayT 16 - 15.03.2004 14:04 | (4)На хипо есть программулина - позволяет разом во все документы, в какую-либо предопределенную процедуру вставить набор строчек.
Рупор абсурда 18 - 15.03.2004 14:17 | Прога называется Inserter, автор АЛьФ ... Пошукай её в "кладовочке": http://consult.legion.ru/alf/ Только, имхо, на фиг она тебе не нужна ...
Evgen-76 19 - 16.03.2004 05:21 | Если для тебя еще актуальна эта тема, то есть код программы который добавляется в гл. модуль, и в те доки за которыми тебе надо следить две проци.Его скачал с нета, могу выслать на мыло т.к. ссылки не помню.Код поставил на торг 9.32. проблем с установкой вообще никаких не возникло. Все просматривается в \"мониторе\". Следишь за теми реквизитами которые тебе нужны и в шапке, и табл.части.


Разграничение доступа на группы номенклатуры | База знаний | mista.ru

Разграничение доступа на группы номенклатуры

Borziy 11.11.2004 13:23 | Как сделать так чтобы определённый пользователь мог просматривать в номенклатуре только определённые группы элементов ине мог просматривать другие, т. е. не имел к ним доступа вообще?
YF 3 - 11.11.2004 14:04 | У меня ето сделано так Процедура ПриВыбореРодителя() Если НазваниеНабораПрав()<>"Администратор" Тогда Автор=ИмяПользователя(); Наименование_=СокрЛП(ТекущийЭлемент().Наименование); СпрП=СоздатьОбъект("Справочник.Пользователи"); Если СпрП.НайтипоНаименованию(Наименование_)=1 Тогда Если Автор<>Наименование_ Тогда Строка_="У вас нет прав на просмотр текущей группы справочника!"; Предупреждение(Строка_, 25); СтатусВозврата(0); Возврат; КонецЕсли; //Автор<>Наименование_ КонецЕсли; //СпрП.НайтипоНаименованию()=1 КонецЕсли; //НазваниеНабораПрав()<>"Администратор" КонецПроцедуры
YF 4 - 11.11.2004 14:05 | + Сдесь это сделано для того, чтобы при ситуации когда Группа элементов названа именем одного из пользователей никто другой не мог в нее залезть.
Таня 7 - 11.11.2004 14:24 | (4) а если этот кто-то возмет и переименует папку?
YF 10 - 11.11.2004 14:42 | ++ На самом деле как у меня делать наверное не надо, ето мягко говоря не гибко. Ну проц. ПриВыбореРодителя() использовать придется конечно. Но лучше создать например реквизит группы справочника, где будут перечислены имена пользователей которым можно, или которым нельзя. А можно создать и отдельный справочник разрешений, где хранить разрешения для разных объектов. Если так пойдет то можно свой домен в 1С нарисовать :))
1С: Новичок 13 - 11.11.2004 14:44 | А если просто убрать иерархический список?
1С: Новичок 15 - 11.11.2004 14:47 | Тогда все содержимое групп окажется как на ладони и никакие запреты не сработают.
1С: Новичок 16 - 11.11.2004 14:48 | Запрет надо ставить не на группы, а на элементы и при открытии элемента проверять к какой группе он относится. Если пользователю разрешается эта группа, то смотрим, если нет, то СтатусВозврата(0).
YF 17 - 11.11.2004 14:52 | (16) Ты чо говоришь-то, нужно запретить смотреть элемент челу (см. 0). А так как ты говоришь, то все видно будет. ++ //------- © YF -------------------- Процедура ПриОткрытии() форма.ОбработкаВыбораСтроки(1); ИерархическийСписок(1,0); КонецПроцедуры //ПриОткрытии Таня, почему ты об этом не сказала. Скрытность не украшает женщину-программиста.
1С: Новичок 18 - 11.11.2004 14:56 | (17) Ну вот это уже похоже на правду ИерархическийСписок(1, 0). Если эту строчку не добавлять, то все запреты на просмотр группы равны нулю.
bsg 22 - 13.11.2004 01:42 | Я делаю по-другому. Добавляю реквизит с флажком "Отбор по реквизиту". При открытии списка проверяю ИмяПользователя()/НазваниеИнтерфейса()/... и устанавливаю соответствующий отбор. В процедуре ПриУстановкеОтбора(ТипОтбора) объявляю СтатусВозврата(0) В отличие от (3) пользователь даже не видит в списке тот объект, который ему не положен.


Разграничение прав на группу элементов списка справочника? | База знаний | mista.ru

Разграничение прав на группу элементов списка справочника?

THawk 16.09.2004 17:43 | Может кто знает - Как скрыть (организовать права доступа на) отдельные группы элементов в списке справочника элементов? Чтобы люди с пределенными правами не смогли открыть группу элементов т.е. принадлежащие к определенному группу элементы были невидимы?
Волшебник 1 - 16.09.2004 17:47 | В 7.7 обрабатывай событие выбора текущего родителя, проверяй права и делай СтатусВозврата(0);
THawk 2 - 16.09.2004 17:52 | А если человек воспользуется кнопкой «Установка(Отключение) режима вывода списка по группам» будут ли(?) видны элементы в уже раскрытом списке?
Press 4 - 16.09.2004 18:10 | Процедура ПриСменеИерархии(Способ) Если Права=НеТе Тогда Сообщить("И так нормально!"); Статусвозврата(0); КонецЕсли; КонецПроцедуры


Вопрос: Проблема безопасности в терминальном режиме | База знаний | mista.ru

Вопрос: Проблема безопасности в терминальном режиме

Alex2401 18.10.2004 18:40 | Уважаемые коллеги, кто не спит и на работе! Работает терминал. 77. Одновременная работа пользователей с двумя БД (Бухгалтерия). Входят пользователи в терминал, запускают одну или две разных БД и работают. Проблема: при входе в терминал любой из пользователей получает доступ к файловой системе терминал-сервера и МОЖЕТ, к примеру удалить все файлы, запросто. Это неправильно. Попробовали, организовали вход с запуском 1С на старте, но, при запуске ДВУХ БД у пользователя на экране ДВА сеанса терминала, он путается.(ему надо переключаться между сеансами постоянно. Кто даст совет, можно ли как-то еще обеспечить безопасность? С уважением всем, Алексей
Crew 1 - 18.10.2004 18:58 | (0) А политики безопасности настраивать не пробывали? Может это поможет: http://www.mista.ru/articles1c/terminal.htm
Alex2401 7 - 19.10.2004 12:20 | Уважаемые коллеги! Если запускать только одну БД, как start в терминальной сессии, проблема, как хорошо было сказано, "С точки зрения ламера", исчезает. Пользователь видит только свою 1С и не задумывается о другом. После завершения работы 1С пользователь автоматически вываливается из сессии и все ОК. Другая тема, работа с двумя БД одновременно. Получается - две сессии, тоже нормально, но, пользователю трудно переключаться между сессиями, он путается. Как бы в рамках одной сессии запустить сразу две 1cv7.exe со своими командными строками? А впереди стоит и третья одновременно подключаемая база. С уважением всем, Алексей
SKrin 9 - 19.10.2004 12:33 | Можно попробовать использовать WSH. 1. Запуск еще одной 1с: Синтаксис: Run(<Command>,<WindowStyle>,<WaitOnReturn>) Назначение: Создаёт новый независимый процесс, который запускает заданное приложение. 2. Активирование окна по названию: AppActivate(<Title>) Назначение: Активизирует указанное окно какого-либо приложения. Возвращает True в случае успеха и False в случае неудачи. что получается: -две разные конфы с разными названиями в титуле окна (ВАЖНО!) -при в ходе в сеанс открывается 1с-ка -на панели инструментов иконка для запуска скрипта, запускающий вторую 1с-ку -тоже но переключение между окнами (по титулу окна)


Пароли пользователей в 7.7 - фикция? | База знаний | mista.ru

Пароли пользователей в 7.7 - фикция?

romix 07.07.2004 17:17 | Начало в http://forum.mista.ru/topic.php?id=5571 Подстава в следующем: патченная 1С, которая не проверяет пароли, позволяет заходить под любым юзером, не вводя пароль. Патченную 1С любой менеджер может принести с собой (например, чтобы поправить финансовые документы или получить отчет для уноса с фирмы). Есть ли технический способ это побороть? Я его не вижу в принципе...
alxkorvin 1 - 07.07.2004 17:26 | Уходи из этой фирмы.
Asmody 2 - 07.07.2004 17:27 | просто идея: получить имя исполняемого файла (КаталогПрограммы()+"1cv7?.exe" и посчитать его CRC (как - отдельный вопрос). ну дальше понятно
alxkorvin 3 - 07.07.2004 17:29 | (2) Проще тогда настроить политику безопасности так, что бы можно было запускать только программу 1с, причем только с сервера.
BorisG 4 - 07.07.2004 18:25 | (0) "Заведу-ка я новую ветку - тема вроде серьезная..." Нет... несерьезная это тема... Уж сколько раз твердили миру... Нет RLS в семерке. Что будет в восьмерке, посмотрим. Пока говорить рано. А посему... нет смысла это еще раз обсуждать... написано и говорено про это уйма... Еще раз, система безопасности - это КОМПЛЕКС мер, и в отрыве от остальных обсуждать это бессмысленно.
Z1 5 - 07.07.2004 18:40 | (0) Да вроде в той ветке уже было все сказано. Читай мои посты внимательно. Кто может тот защищает если оно того надо. Кто не может курит бамбук и кивает на дырявый забор. От сноса паролей 1c-sql. (4) rls не спасет если унесут всю базу целиком
Z1 6 - 07.07.2004 18:42 | (0) Опять же против твоей патченой 1с - запуск 1с только из своего "родного" стартовщика.
romix 7 - 07.07.2004 19:52 | (1) Вопрос гипотетический - я не говорю, что это происходит именно так и именно у нас. Хотя все может быть. :-) (2) Прикольно... Надо будет взять на заметку. (3) А что, в виндах можно запрещать запуск левых программ? Если бы это было, то было бы здорово... Все вирусы бы не смогли работать. :-) (4) Если есть дыра - ее надо закрыть. Разве не так? Вот (2) предложил работающий способ. (5) "От сноса паролей 1c-sql." Надо будет заценить. Я проверял только в DBF. (6) Да вряд ли это поможет... Стартовщики какие-то... Я говорю, принесут папку с 1cv7.exe + *.dll, и оттуда запустят. Хотя, вот вроде бы в (2) предусмотрено закрывание. Кстати, и проверка на устаревшие релизы...
Demiurg 8 - 07.07.2004 20:35 | (6) млин, молчал долго, но не выдержал чета - хэш-код еще ни кто не отменял Простейший пример, запрет на запуск через GPO в винде начиная с Windows XP, 2003 и далее. У этого метода есть некоторый гемор, если не приминять других ограничений: т.е. ограничет доступ вообще к файловой системе и реестру. Если разгребусь с работой, надо будет дописать статьи :)))
427 9 - 07.07.2004 21:00 | (7) В каждом случае - нужно защащаться отдельно.. Да, в виндах можно запретить запуск левых программ... Как ни странно, это можно сделать элементарно даже на 98... И так же элементарно обойти... Читайте доку по виндам... А то, что описано в (0), делается элементарно даже на не патченой... Опять таки надо знать винды... и возможности 1С...
Z1 10 - 08.07.2004 09:32 | (7) GetComandLine+ стартовщик хотя бы. Примеры стартовщиков можешь посмотреть на hippo. Там правда цель их другая - отображать базы деревом, стартовщик в трее лежит и.т.д. Интересно как Вы контрольную сумму будете считать на 1с. Тогда уж надо проверять и контрольную сумму всех библиотек а не только exe. Первые версии FormExp у АльФа были сделаны через подмену dll - этим достигалось что компонента автоматически стартовала и не надо было запускать ВК в коде 1с. Вот тебе еще один способ защиты - делай так же как Альф напиши старт только со своей подменой библеотек будет хорошим. (8) Статью будет интересно почитать. 1с требует полного доступа на папку с 1с базой. Да и в реестр все время прописывает свои значения.
Filippych 11 - 08.07.2004 09:37 | Проблемма решается на уровне Админа. Запретить ставить новые программы. Не давать прав на это.
Z1 12 - 08.07.2004 09:41 | (11) Не взлетит. Запустит со своей флешки пропатченную 1с.
Filippych 13 - 08.07.2004 09:45 | Отключи службу USB дисков.
Z1 14 - 08.07.2004 09:51 | (13) Почту тоже отключить ? Может и клаву отобрать ?
laeg 15 - 08.07.2004 10:02 | Народ, есть очень простой но надежный способ, 1. размещайте 1с на ТС и небудет ни каких проблем. Ставтье Цитрикс, запускайте 1с как приложение, закройте доступ к дискам из вне и будет вам счастье :о))) 2. Можно завести в 1с (если нету) справочник пользователи и при входе спрашивать пароль и хранить его там, поставить еще таймер и будет ляпота ... Тема потеряла свою актульность пару лет назад ....
Filippych 16 - 08.07.2004 10:02 | 2(14) И мышь безклавишную. Написать ВК с функцией qwe(), бросить её в папку с платформой, в глобальнике в ПриЗапуске сделать такое Попытка ё = qwe(); Исключение Сообщить ("не та платформа"); <Добавить в справочник комп пользователя который захотел не санкционированного доступа, дату и время оного> ЗавершитьработуСистемы(); КонецПопытки
Z1 17 - 08.07.2004 10:10 | (15) спроси pit он тебе раскажет про дыры в терминале. (16) ну это уже другое дело - значительно лучше.
laeg 18 - 08.07.2004 10:16 | (16) Дыры они везде есть ... если их нет то их просто не нашли. На ТС можно максимально защитить базы .... кроме конечно распечатки данных :о))). Я два года в одной конторе отработал на ТС, сделал бухам и манегерам тонких клиентов, так что весь слив и залив инфы (ЛЮБОЙ !!!) кроме распечатки шел через меня ...
Z1 19 - 08.07.2004 10:19 | (18) про тонких клиентов - можно поподробней.
romix 20 - 08.07.2004 10:42 | (9) Не помню такого в виндах... Может, подскажете? Конечно, хакер должен обладать богатой эрудицией и все знать... (11) Копирнет папку с 1С, пропатчит ее и вперед... Достаточно поправить несколько байт в двух dll... Надо написать Касперскому, чтобы сделал антивирус, который удаляет все новые exe, pif, bat, ... которые появляются в системе с момента старта антивируса. :-) И назвать его Зверский Касперский. :-)
DimG 21 - 08.07.2004 10:46 | (20) для 98 надо править реестр. Ищи в интернете.
romix 22 - 08.07.2004 10:47 | (16) копирнет папку с платформой, пропатчит - и вуаля. Надо проверять именно exe/dll
Z1 23 - 08.07.2004 10:50 | (22) qwe может отваливаться если запускается не из той папки.так что все нормально. Не сказал как будешь проверять из самой 1с.
Z1 24 - 08.07.2004 10:51 | PS Не сказал как будешь проверять из самой 1с exe/dll
BorisG 25 - 08.07.2004 10:55 | (24) Так а в чем пробрема проверить из ВК контрольные суммы заданных файлов, в том числе МД?
Asmody 26 - 08.07.2004 10:58 | насколько я помню, Admin1C.dll умеет считать CRC32 любой строки. чем не выход?
Z1 27 - 08.07.2004 11:00 | (25) см выше там речь шла именно из 1с - из ВК вообще проблемы нет никакой.
Asmody 28 - 08.07.2004 11:05 | (27) а что алгоритмы расчета CRC большая тайна? или средствами 1С их реализовать невозможно? и, потом, если оно уже есть (см. 26), зачем изобретать велосипед? "все уже придумано до нас"
Z1 29 - 08.07.2004 11:11 | (28) Ну и раскажи как ты средствами 1с будешь читать бинарный файл ? Ну что-то отклоняемся от subj.
romix 30 - 08.07.2004 11:35 | (24) ВК писать. Но не CRC32 (!!!), а MD5. CRC32 легко подделать дописыванием в конец 4 байт.
romix 31 - 08.07.2004 11:40 | (+30) Хотя, наверное, весь файл проверять - слишком долго - можно проверить только нужный фрагмент на пропатченность... Тогда будет раздельно ругаться на старые релизы etc и патчинг. Точнее, на патчинг не ругаться, а сразу включать сирену и вызывать секьюрити. :-)
427 32 - 08.07.2004 20:26 | ...... СКИП ...... Ключ HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer "NoRun" - скрывает команду "Выполнить" в меню "Пуск", что не позволяет пользователям запускать программы или процессы из меню "Пуск", однако если пользователь имеет доступ к командной строке MS-DOS, он всё равно сможет запускать любые программы; надо отключить РЕЖИМ ВХОДА В MS DOS... "RestrictRun" - при =1 будет разрешён только запуск программ,определённых в ключе [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun] с помощью строковых параметров с именами в виде чисел по возрастанию, например: "1"="c:\windows\notepad.exe" "2"="c:\program files\msoffice\winword.exe" . . . "NoDrives" - определяет, какие из дисков скрыть
Warlock 33 - 08.07.2004 23:40 | (32)Заготовленный reg-файлик, очищающий "Policies\Explorer" вынесет не только эту защиту... Хотя можно ограничить юзера совсем... Например(только это совсем жестоко), когда я сдавал экзамен на знание теории правил догожного движения, в зале были терминалы, причем юзеру дотупен только монитор и мышь (!)без шарика(!). Т.е. всего две кнопки - перебор и выбор. Вот это - действенная защита!!!
427 34 - 09.07.2004 07:31 | заранее заготовленный ответ админа сделает reg файло просто ненужным.... Защита - это КОМПЛЕКС мер...
romix 35 - 09.07.2004 09:07 | (32) Так это блокируется меню пуск, а что мне помешает запустить просто exe: 1cv7.exe из нужной папки? Ну или косвенно, не просто exe, а через bat/cmd/vbs? Имхо, если бы такая блокировка была, то о файловых вирусах можно было бы уже забыть... (33) На реестр начиная с Windows 2000 можно ставить ограничения на доступ как на файлы.
Warlock 35 - 09.07.2004 09:07 | (34)Если применять подобный КОМПЛЕКС к одной машине - еще ничего... Если компьютеров несколько, то это становится довольно геморно... А если их более десяти - то хана...
romix 37 - 09.07.2004 09:09 | (35) В терминале все будет хорошо.
427 38 - 09.07.2004 09:16 | (35-1) предложенные тобой формы запуска тоже блокировать надо. (35-2) нормальная защита - это окуенный геморой в эксплуатации. Причем очень затратный... Причем возрастание затрат идет непропорционально увеличению машин, а в геометрической прогресии...
Warlock 39 - 09.07.2004 09:17 | (38)Вот именно!
romix 40 - 09.07.2004 09:31 | (38) хм, я смотрю в виндах есть запрет выполнения. Правда там написано Обзор папок/выполнение файлов. Ставлю запрет - обзор работает, выполнение - теперь нет. Пишет, ацесс денайед. (38-2) Терминал на что? Представляете назащищенный банк? Там везде терминалы.
romix 41 - 09.07.2004 09:33 | (+40) - В смысле, все банки (если я не ошибаюсь) работают через терминал, иначе они стали бы незащищенными.


Есть ли ограничения на число клиентов в XP Professional? | База знаний | mista.ru

Есть ли ограничения на число клиентов в XP Professional?

Большая черепаха 10.09.2004 18:57 | И что будет, если это ограничение превышено (падает только последний клиент, или все клиенты)?
F427 1 - 10.09.2004 18:57 | 10 пинают последнего...
Большая черепаха 2 - 10.09.2004 19:02 | (1) Ну а сами при этом падают или не замечают, что последний отвалился? И еще: а если на 5 компах запущено 10 баз, то загрузится ли, в общем случае, на 6-м компе 11-я база?
BorisG 3 - 10.09.2004 19:05 | Действительно, 10 по лицензионному соглашению. Цитата из eula.txt: "Максимальное количество подключений, равное 10 (десяти), включает любые косвенные подключения..." Часто проблема в том, что некоторые компьютеры создают дополнительные фиктивные подключения. Т.е. реально это означает, что работать смогут на 1-2 пользователей меньше.
Нифига себе сабж 4 - 10.09.2004 19:05 | (2) Просто 11 не подключится к ней.
BorisG 5 - 10.09.2004 19:10 | (2) Этот вопрос совсем из другой оперы. Если не загрузиться, нужно посмотреть, какое сообщение выдаст... оно будет совсем другим... Что-то типа ошибки доступа к файлу. Об этом есть и в этом форуме, и в FAQ http://1c.alterplast.ru/faq/saved.html
BorisG 6 - 10.09.2004 19:11 | +5 При этом памяти на этом "сервере" желательно не менее 256Mb.
Большая черепаха 7 - 10.09.2004 19:13 | (3) Ну я короче в виндоусе 98 (та тачка, на которую бухи жаловались, что она вешала всех остальных при подключении к 1С) отрубил NetBEUI, а на XP отключил Автовосстановление диска, где лежит база и преобразовал файловую систему в NTFS. Вот думаю, может еще Server им надо вместо Professional - хотя вот сейчас вижу, что вряд ли. Я правильно понимаю, что 11-й комп при попытке подключения просто напишет "база не обнаружена", но не испортит в ней ничего, например, индексы?
F427 8 - 10.09.2004 19:50 | выдаст ошибку открытия какого нибудь файла и вывалится... Потребуется переиндексация... И все... P.S. сами индексы будут целыми- но механизм даст сбой учета входов-выходов...
Большая черепаха 9 - 10.09.2004 19:50 | (5) Скачал прогу http://confignt.ixbt.com/ Очень прикольная!!! ConfigNT.exe - закладка Memory Management: Устанавливаем перекл. Maximize Throughput for file sharing (default for servers). Устанавливаем флажок Use large system cashe. В группе переключателей I/O page lock... выбираем 2048 kb


Стала тормозить SQL база на 1-м компьютере в сети | База знаний | mista.ru

Стала тормозить SQL база на 1-м компьютере в сети

Crew 02.08.2004 10:57 | Система W2K. При работе с 1С идет постоянное обращение к винчестеру. Рагьше все работало нормально. Где могут быть грабли?
Valery 1 - 02.08.2004 11:18 | Посмотри в диспетчере, может какой-то процесс работает.
SnarkHunter 3 - 02.08.2004 11:23 | Недостаточно ОЗУ - своппинг?
Crew 4 - 02.08.2004 11:28 | (3) 256 Mb До этого работала нормально. AVP и Canon LBP-810 нету.
SnarkHunter 5 - 02.08.2004 11:30 | В диспетчере задач посмотри какой процесс читает/пишет на диск...
Crew 8 - 02.08.2004 12:18 | Дополнение: процессы бездействие системы 97-98%. При выполнении какого-либо действия в 1С все делается с большими тормозами и непрекращающейся работой винта. :(
ИВМ35 9 - 02.08.2004 12:24 | Советую, но верю в помощь слабо.. дефрагментация. Файлов около 350 штук, со временем они дробятся по винту на атомы..
ИВМ35 10 - 02.08.2004 12:26 | +9 посмотри, что там с назначениями виртуальной памяти.. не всё-же в ОП сидит.. а ресурсов 1С жрет много..
Crew 11 - 02.08.2004 13:26 | (All) Повбывав бы ! Какая то сволочь включила в ODBC трассировку запросов. На настройки системы безопасности пальцами не показывать, я их контору не обслуживаю, просто попросили помочь.


НайтиСсылки() - как увеличить скорость выполнения этой функции | База знаний | mista.ru

НайтиСсылки() - как увеличить скорость выполнения этой функции

Gavrila 30.06.2004 12:13 | если это вообще возможно
Волшебник 1 - 30.06.2004 12:14 | Запустить 1С локально в монопольном режиме на быстром компьютере с большим количеством оперативной памяти и быстрыми дисками.
SnarkHunter 2 - 30.06.2004 12:14 | Прямые запросы к СКЛ-серверу...
Волшебник 3 - 30.06.2004 12:16 | Можно решить какую-то частную задачу путем формирования списка ссылок ЗАРАНЕЕ при записи документов и элементов справочников. Принцип: "знал бы где упаду, соломки бы подстелил".
Gavrila 3 - 30.06.2004 12:17 | Так и думал, спасибо. А программно, тобто аналог какойнить придумать, будет ли он быстрее работать, чем системная функция? зы: База dbf
Gavrila 5 - 30.06.2004 12:21 | (3) Уже упал :) , точнее не я, а клиенты, в спр контрагенты куча задвоеных, затренных, учетверенных и т.д. и т.д. до 10 копий каждого контрагента. Теперь вот надо все исправить так чтобы остались только по одному элементу справочника для каждого клиента.
Gavrila 6 - 30.06.2004 12:23 | +(5) из 6 ч выполнения обработки около 4ч времени тратится на поиск ссылок
SnarkHunter 7 - 30.06.2004 12:25 | Я такую же вещь делал по номенклатуре... Около 20000 элементов... Поиск 3 минуты+выгрузка во внешний дбф файл около 5 минут...


Тормоза при прокрутке справочника ОС | База знаний | mista.ru

Тормоза при прокрутке справочника ОС

TASS 21.06.2004 22:02 | При прокрутке или поиске списка основных средств в Бухгалтерии на некоторых инвентарных номерах наблюдается торможение в работе программы. Прога как бы зависает на 30 сек. Релиз exe = 021. Кто нибудь с такой бедой сталкивался? Есть решение?
bazvan 1 - 21.06.2004 22:03 | На 2-ух елементах все ОК что я не так делаю?
Bekas 2 - 21.06.2004 22:03 | Причина: В какой-нить колонке прописана формула, наверное. Что-то типа для показа остатков, например...
DeiMos 4 - 22.06.2004 16:30 | http://www.kuban.ru/forum_new/forum9/files/187195.html
Valery 5 - 22.06.2004 16:33 | Скорее всего не установлены какие-то переодические реквизиты.
mszsuz 6 - 22.06.2004 16:39 | Добавь на форму списка галку с идентификатором "фПоказыватьСведения". И исправь в модуле формы списка: Функция ИнформационнаяСтрока() Перем Стр; // добавляем Если фПоказыватьСведения=0 тогда Возврат ""; КонецЕсли;
TASS 7 - 23.06.2004 12:12 | Спасибо за поддержку!!! Проблема решена. Дело оказалось в переодических реквизитах. Тема закрыта, вроде.
TASS 9 - 25.06.2004 14:14 | Проблема вот в чем: При частичном объединении конфигураций (установка новых релизов) справочник ОС не меняли. При этом некоторые реквизиты остались непереодическими, а в новых релизах они стали периодическими (например, первоначальная стоимость. Как проверил: пернес наш справочник ОС в конфу нового релиза - тормоза исчезли. Выход из ситуации: смотри ответ номер 6. Усё.


Истекло время ожидания в SQL версии | База знаний | mista.ru

Истекло время ожидания в SQL версии

LIW
02.06.2004 11:03 		SQL версия ,база 200 мб ,при обращении к маленьким справочникам у разных пользователей ,в разных местах программы происходит вываливания с радостной надписью "время ожидания истекло" и далее ошибка - SQL State: 40001 Native: 1205 Message: [Microsoft][ODBC SQL Server Driver][SQL Server]Your transaction (process ID #15) was deadlocked with another process and has been chosen as the deadlock victim. Rerun your transaction (транзакции в этом месте модуля отсутствуют)
427
1 - 02.06.2004 11:07 		Не повезло тебе... Наверное, данные густые... надо рахбавить ... чтобы по сетке быстрей текли ....
LIW
3 - 02.06.2004 11:14 		Один Вася считает докумены ,до фига их там ,а другии, но не все вываливаются-вот такая ситуация . Идеи есть ?
Vser1
4 - 02.06.2004 11:17 		Нежнее, еще нежнее... (с) низнамо хто.
Вернее: подробнее, еще подробнее...: параметры сервака, сети, юзеров, ОС, что на серваке кроме Скуля висит, по каким протоколам к Скулю клиенты ходют...
LIW
5 - 02.06.2004 12:07 		SQL State: HYT00 Native: 0 Message: [Microsoft][ODBC SQL Server Driver]Время ожидания истекло или SQL State: HYT00 Native: 0 Message: [Microsoft][ODBC SQL Server Driver]Timeout expired -ещё часто лезла вот такая штука Чаво знаю скажу сейчас остальное потом,потому что админов у нас до хрена ,толку нет. Я занимаюсь програмированием на 1с и у нас УУУзззккая специализация :
1 Серваков несколько стоят 2000 и 2003 параметры потом
2 Юзеров порядка 150 задач на 1с 7 штук (конкретно в моей 20 очень активных пользователей) ходют по NAMED PIPES И TCP/IP CЕТИ 10 и 100 мегабитные
SnarkHunter
6 - 02.06.2004 12:17 		Named Pipes надо ... того...
Vser1
7 - 02.06.2004 12:26 		(6) Угу того, оставь тока хождение через TCP/IP, т.е. настрой его и на клиенте и на серваке, это самый бастрый вариант работы с SQL серваком. Ну плюс посмотри на серваке загруженность проца, выделение памяти... Если хаб отражает коллизии, также по наблюдай, часто ли они прут.
romix
9 - 02.06.2004 19:43 		Короче полезно поставить ВСЕ вышедшие сервис-паки. У тебя какая версия SQL?
И обновить у юзеров драйвер ODBC.
Может у кого-то из юзеров релиз 1С древний, с какой ошибкой.
Надо выявить кто отваливается. И действительно (6) прав, named pipes надо отрубать, хотя это не критично.
Еще я прописывал вместо адреса SQL-сервера в настройках 1С его IP-адрес, тоже помогло устранить то ли тормозню, то ли зависания из-за DNS.
007
10 - 03.06.2004 16:48 		Возможно эффект "зависания" вызван долгим формированием отчета при большом количестве одновременно работающих пользователей. Попробуйте в отладчике оценить производительность выполнения отчета, выяснить, какие операции вызывают наиболее длительное выполнение и попытаться оптимизировать их.
Прежде всего, заметим, что при проектировании конфигураций, предназначенных для
эксплуатации в разделенном режиме на предприятиях с большим объемом информации, в
разработке отчетов следует особое внимание уделять минимизации обращения к информационной базе, так как именно эти действия становятся наиболее критичны по времени при больших объемах данных и одновременной работе нескольких пользователей.
Заметим, что в отличие от алгоритмов выполняемых при проведении документов, отчеты, как правило, формируются вне транзакции. Это означает, что выполнение большинства операций в отчете будет происходить существенно медленнее, чем при проведении документа. Это касается версий 1С:Предприятия работающих в базой данных в формате DBF. При работе с базами данных в формате SQL выполнение операций вне транзакции и внутри транзакции не отличаются по производительности. Однако, очевидно, что при работе в архитектуре клиент-сервер количество обрабатываемой информации полученной из информационной базы также весьма существенно влияет на производительность, поэтому и при работе с базами данных в формате SQL следует оптимизировать, прежде всего, обращения к информационной базе.
Таким образом, при написании алгоритма отчета следует учитывать не столько количество выполняемых строк встроенного языка, сколько объем обращения к информационной базе. Для такой оценки следует использовать информацию, описанную в разделе, посвященном вопросам производительности, на диске ИТС.


Закрытие месяца | База знаний | mista.ru

Закрытие месяца

Oleg_cdv 09.06.2004 14:54 | здравствуйте. железо.SQLSERVER, PIII-1000 2 камня, ОЗУ 1.3 Ггб. 2 скази винта - не зеркальных. Прога - 1С предприятие При запуске autorun'ом (вручную - тот же эффект) документа "закрытие месяца" 3-4 часа перепроводятся документы, затем - таймаут примерно 2-3 часа, и только после этого поисходит закрытие месяца с движением точки актуальности продолжительностью от 4 до 6 часов. Вопрос. почему есть тайм-аут? как его уменьшить? и ускорит ли все процедуры увеличение оперативки до 2 Ггб?
427 2 - 09.06.2004 18:18 | Фиксация транзакции с пересчетом индексов и прочего барахла может занимать длительное время 2ГБ.... Должно ускорить... Но это не выход - скоро их станет мало....


HELP 1C SQL 2000 Бух учет тормозит | База знаний | mista.ru

HELP 1C SQL 2000 Бух учет тормозит

sepwww 07.06.2004 12:12 | Стоит сервак P42.6х2 Xeon,DDR 1Gb,HDD 72Gb 15000prm,сеть 100 mb/c. 1C SQL 21 релиз, Sql200 SP3, Win2003 Server,количество пользователей 8 При выполнении отчета,с таким кодом,сильно тормозит просмотр справочника Номенклатура (кол элементов 6000), почему ??? ИТ.СоздатьОбъект("БухгалтерскиеИтоги"); ИТ.ИспользоватьСубконто(ВидыСубконто.Номенклатура,ВыбСубконто1,1,1); ИТ.ИспользоватьСубконто(ВидыСубконто.МестаХранения,ВыбСубконто2,1,1); ИТ.ВыполнитьЗапрос(,ВыбКонПериода,"41.1,41.3,41.4",,,1,,"СК"); ИТ.ВыбратьСубконто(ВидыСубконто.МестаХранения); Пока ИТ.ПолучитьСубконто(ВидыСубконто.МестаХранения) = 1 Цикл ... ИТ.ВыбратьСубконто(ВидыСубконто.Номенклатура,,,,,"Код"); Пока ИТ.ПолучитьСубконто(ВидыСубконто.Номенклатура) = 1 Цикл ... КонецЦикла КонецЦикла;
sepwww 4 - 07.06.2004 12:29 | Отчет выполняю на одной машине-сетевой, а справочник листаю на другой-сетевой.
SnarkHunter 5 - 07.06.2004 12:33 | От оно как... В справочнике вычисляемые поля есть (остатки и т.п.)?
sepwww 6 - 07.06.2004 12:37 | Есть.Получаем остаток товара. ИТ.СКД(СчетУчета,"К",,ТекущийЭлемент());
sepwww 10 - 07.06.2004 12:48 | Про вычисление остатка тут все понятно, а что на SQL будет медленней работать чем на DBF ???
SnarkHunter 11 - 07.06.2004 12:52 | (10)А ты разве не знал? Если не пользоваться прямыми запросами к СКЛ-серверу, то однозначно медленнее...
sepwww 12 - 07.06.2004 13:02 | Я догадывался, что "БухгалтерскиеИтоги" и "Запрос" на DBF работают одинаково,а на Sql "Запрос" быстрее. Переделали этот отчет с "Запрос" работает шикарно. Делали сравнение выполнения стандартного отчета "Анализ счета по датам" на DBF и SQL. На DBF 7 минут на SQL 20 секунд !!! Почему такая разница на стандартных отчетах.
427 13 - 07.06.2004 13:03 | Да, на сиквеле (6) тормозит.... а вообще то в запросе ИТ.ВыполнитьЗапрос(,ВыбКонПериода,"41.1,41.3,41.4",,,1,,"СК"); указаны счета 41.х - на них в типовой нет суммового учета по местам, поэтому не нужно указывать СК, достаточно просто К.... Нахрена лопатить базу?
sepwww 14 - 07.06.2004 13:05 | На 41 счете установлен признак количественного учета
427 24 - 07.06.2004 13:37 | Да, я работаю... Без терминала.. База больше гига, 13-15 юзеров... Активных 8-9.... Летает... Sql рядом не стоял... маленькая тонкость - все вертится на НетВари... для смеха - рабочие станции от 600, сервер - 400 МГЦ и при этом простаивает ... Проблем нет... Не... есть.... Надо было нового юзера добавить в сервант, так пароль не вспомнил... Благо что УПСина стоит с админскими правами... и пароль там стандартный, я не менял... К серверу уже 4 года никто не подходит... Пора однако его менять...


Настройка сервера под 1С Предприятие | База знаний | mista.ru

Настройка сервера под 1С Предприятие

sach 03.06.2004 16:54 | При работе в конфигурации 1С более одного пользователя происходит коткретное замедление работы в чем причина? Посоветовали разбить сеть на несколько сегментов как это сделать,где найти описание?
427 1 - 03.06.2004 18:20 | Успокойся... На 2000 или NT это не лечится... Сегменты здесь не причем... Вроде бы в 2003 серванте сделали... Но я не проверял... На новеле все полетит .... раза в 3 быстрее на том же самом железе... Но где ты спеца по новелю найдешь - я не знаю...
BorisG 2 - 03.06.2004 18:29 | (1) Петь, действительно под 2003-м работает, там есть две галки... Она по умолчанию включена, и дает прирост 2-3 раза, вторая выключена, она еще 20-30% дает... Но это навскидку, по результатам тестов на нескольких конфигурацих, точно не замеряли... и узкие места не определяли... за ненадобностью.
427 4 - 03.06.2004 19:03 | (2) Да, там две галки... Включаешь одну - дает активизировать вторую... Значит, мягкие все таки сподобились... Долго же они корячились... С момента выпуска NT сервера... Ладно, бум знать... Похоже память надо не менее полгектара... Кстати, реальное ускорение новеля по сравнению с 2000 сервером НА ОДНОМ И ТОМ ЖЕ ЖЕЛЕЗЕ - (я проверял лично, два серванта, два жестких ИДЕ диска 7200 одинаковых, на одном новель, на втором - 2000) - от 3 до 7 раз... в среднем 5. P.S. ну сервант 2003 без активации у меня есть... Эх, надо было сразу писать дистр с активированным сервером терминалов.. чтоб не корячиться ... теперь надо второй раз тащиться.... Говорило же мне мое второе я... возьми еще пару дисков.... Нет бы его послушать ... так просто нах... послал...
Oksa 5 - 04.06.2004 13:42 | народ, где эти галки? собираюсь ставить 2003, еще не в курсе что там почем
lexa 6 - 04.06.2004 13:45 | (5) сегодня BorisG добрый дал ссылки смотри http://www.forum.mista.ru/topic.php?id=5086


Производительность БД & скорость работы отчётов | База знаний | mista.ru

Производительность БД & скорость работы отчётов

Shadal 17.05.2004 07:40 | Доброго время суток! У меня возник такой вопросик: Вот у меня большая база 1С ну пользователей где-то 15-20. Соответственно Для быстроты формирования отчётов работают люди в терминальном режиме. Отчёты бывают разные, в среднем они кушают каждый от 25% до 40% . Ну понятно к чему приводит запуск нескольких отчётов различными пользователями. Так вот соответсвенно вопрос: Можно ли как-то ограничить загрузку сервера, к примеру на один отчёт не более 20% ?
SnarkHunter 1 - 17.05.2004 07:42 | Можно понизить приоритет текущего процесса перед запуском отчета...
Shadal 2 - 17.05.2004 07:59 | и что в ручную понижать? А как угадать что надо понизить? Хотелось бы чтоб для всех приложений 1С либо в 1С либо на серваке указать чтоб приложение(1С) не захва тывало больше 20%? Есть у кого нибудь мысли?
BorisG 3 - 17.05.2004 08:01 | +1 Как ручками, так и из 1С... ВК есть от Александра Орефкова... http://openconf.narod.ru/vk/prior/ И на ниппо еще была, не помню, может и тоже... Хотя проблему это при большой загрузке решает слабо...
SnarkHunter 4 - 17.05.2004 08:02 | Зачем вручную... Подключаешь ВК и рулишь приоритетами...


250 000 наименований товара - это смерть для 1С (дбф) | База знаний | mista.ru

250 000 наименований товара - это смерть для 1С (дбф)

Алексей 2 - 07.05.2004 14:00 | Как можно оптимизировать работу, при удалении просто засыпаю за компом
Valery 4 - 07.05.2004 14:04 | 250000 в справочнике плохо конечно но не смерть. Основная проблеме в документообороте. Если документоборот большой то базу лучше ежегодно обрезать.
Алексей 6 - 07.05.2004 14:10 | интерестно, предельная цифра есть, у меня без документов, база ровно 1 Гигабайт
Valery 8 - 07.05.2004 14:53 | Не в размере дело, а в интенсивности работы базы. Т.е. количество документов в день, количество позиций в документе. Количество пользователей. Вот эти параметры имеют большее значение для принятия решения о смерти.
Рупор абсурда 10 - 07.05.2004 14:58 | Видел номенклатуру ~ 2 000 000 элементов ... Пришлось с поиском в списке справочника муйню мутить, а в остальном никаких проблем ...
Valery 14 - 07.05.2004 15:10 | конечно, из-за справочников отказываться от dbf, не аргумент, но задуматься стоит. что-бы такую номенклатуру продовать, это операторов надо человек 10, и документов каждый шт по 50 будет колбасить.
ramstar 17 - 08.05.2004 04:31 | Если никто умирать не хочет просто перходить на SQL пора ато DBF DBF


Кто блокирует журнал документов в 7.7? | База знаний | mista.ru

Кто блокирует журнал документов в 7.7?

Волшебник
03.10.2004 19:04 		Панаехавший
01.10.2004 - 17:52

Пользователи уже достали вопросом - кто держит журнал документов. Вот наваял запросец вычисляющий виноватого.

ИмяБазы="Mybase";
Коннект="Provider=sqloledb;Data Source=Sevrer;Initial Catalog=master;User Id=sa;Password=123;";
Запрос="select sp.hostname from syslocks lk,"+ИмяБазы+".dbo.sysobjects o,sysprocesses sp, sysdatabases sdb
|where lk.dbid=sdb.dbid and o.id=lk.id and sp.spid=lk.spid and sdb.name='"+ИмяБазы+"' and o.name='_1SJOURN'";
q = СоздатьОбъект("ADODB.RecordSet");
q.CursorLocation=3;
q.Open(Запрос,Коннект);
колво=q.RecordCount();
Если колво<1 Тогда
Сообщить("Никто");
Иначе
q.MoveFirst();
host = q.Fields(0);
Для ъ=1 По колво Цикл
Сообщить("Хост "+host.Value);
q.MoveNext();
КонецЦикла;
КонецЕсли;
Лучше использовать с какой нибудь ODBCшной компонентой - запрос начинает работать гораздо быстрее.

Источник:
http://www.kuban.ru/forum_new/forum9/files/202390.html


Где почитать про глюки 19 релиза | База знаний | mista.ru

Где почитать про глюки 19 релиза

alxkorvin
5 - 04.06.2004 14:07 		http://www.sinor.ru/~my1c/knowhow/relise.html


Релиз 023 программных файлов 1С | База знаний | mista.ru

Релиз 023 программных файлов 1С

Zerg 01.06.2004 10:43 | А вот как бы узнать что там нового/измененного в релизе 023? Где есть такая инфа? ДАвно как-то читал в инете комментарии народа по релизам, а откуда они это брали неизвестно...
mszsuz 2 - 01.06.2004 10:46 | Отзывов по 23-ему что-то не видать. Похоже, ничего не изменилось ;) А вообще информация о релизах есть здесь: http://www.sinor.ru/~my1c/knowhow/relise.html
mszsuz 5 - 01.06.2004 11:06 | Хм, ИспользоватьСубконто(), говорят, стало глючить. Проверю - если правда - выложу ...
BorisG 6 - 01.06.2004 11:17 | (3) Не... не очень. Несколько глюков таки исправили. Вечером посмотрю, где-то было сохранено. На самом деле надо смотреть не это... есть подозрение, что поправили работу с потоками... но это надо серьезно проверять. Т.е. по логике должно еще улучшиться объединение больших конф.


SQL и DBF версиии 7.7 Разные результаты выполнения запроса | База знаний | mista.ru

SQL и DBF версиии 7.7 Разные результаты выполнения запроса

Xelon
28.05.2004 02:28 		Почему в 1С v 7.7 DBF версии такой запрос работает, а в SQL - нет.
Может есть какието особенности в SQL-версии. (С SQL-версией сталкивался мало)
"//{{ЗАПРОС(Сформировать2)
|Период с ВыбНачПериода по ВыбОстаткиТовара;
|Без итогов;
|Товар = Регистр.ОстаткиТоваров.Товар, Документ.ОстаткиТовара.ТМЦ;
|Стоимость = Регистр.ОстаткиТоваров.БазоваяСтоимость;
|НДС = Регистр.ОстаткиТоваров.НДС;
|Количество = Регистр.ОстаткиТоваров.ОстатокТовара;
|Сумм = Документ.ОстаткиТовара.Сумма;
|НДС_Док = Документ.ОстаткиТовара.НДС;
|ТекущийДокумент = Документ.ОстаткиТовара.ТекущийДокумент;
|Функция СтмРасх = Расход(Стоимость);
|Функция НДСРасход = Расход(НДС);
|Функция СтмКонОст = Сумма(Сумм);
|Функция СтмКонОстНДС = Сумма(НДС_Док);
|Функция КоличествоРасход = Расход(Количество);
|Группировка Товар без упорядочивания без групп;
|Условие(ТекущийДокумент = ВыбОстаткиТовара);
|Условие (Товар в СписТоваров);
|"//}}ЗАПРОС
;
ВыбОстаткиТовара - документ, в котором храняться текущие остатки.
Данные по регистру берет, а документ как-будто не замечает, хотя в DBF -версии все нормалек.
Смысл состоит в том, что на текущий момент могут быть в базе еще не актуальные остатки, поскольку операторы не успевают вбить весь расход, поэтому понадобился документ, в который вбивают текущие остатки и от него нужно провести ABC анализ товарных запасов.
SnarkHunter
1 - 28.05.2004 06:05 		В документе хранятся текущие остатки? O tempora, o mores...
VladZagorsky
2 - 28.05.2004 07:22 		Э... Какой глубокомыссленный запрос... Че-то я не понял, что такое ВыбОстаткиТовара? Ну вот не доходит до меня... В DBF, говоришь, работает? Шайтан, батенька... Можа ты какое словечко знаешь, шо бы в DBF ТАКОЕ работало?
Xelon
3 - 28.05.2004 10:39 		(2) Я же написал, что ВыбОстаткиТовара - это документ в котором хранятся актуальные остатки. На складе у них известны остатки каждый день, а расходы вбивать не успевают (добивают по выходным). А ABC-анализ нужно видеть посреди недели.
Outlander
4 - 28.05.2004 11:28 		А что в регистре действительно есть такой ресурс??? :
|Количество = Регистр.ОстаткиТоваров.ОстатокТовара;
Xelon
5 - 28.05.2004 13:59 		Да. Конфу писал не я и она не типовая. Мне нужно лишь сделать эту фичу с документом "ОстаткиТовара".
Outlander
6 - 28.05.2004 14:08 		Нифига не понятно, что тебе нужно сделать.
То ли выбрать какую-то инфу из каких-то документов.
То ли получить остатки и движение товаров (расход).
ИМХО, если нуны движения и остатки товаров - лучше их брать из регистра! Только!
И не трогать документы.
А ты в запросе смешиваешь обращение к регистру и документам.
И структура регистра (судя по коду) какая-то... настораживающая...
Xelon
7 - 28.05.2004 14:16 		Запрос отрабатывает правильно на DBF версии.
В Запросе есть возможность одновременного перебора по документам, регистрам, справочникам, счетам.
Мне нужно получить расход товара по сумме и количество у проанализировать на сколько дней хватит текущего запаса товаров.
В принципе эта задача должна решиться двумя запросами: первый по регистру, а второй по документу (хотя можно и перебором по строк)
alxkorvin
13 - 28.05.2004 14:51 		(12) А ты им объясни что остатки в документе держать это как не иметь данных об остатках совсем.
ChAlex
16 - 28.05.2004 23:56 		Вообще-то запросы в SQL работают по другому, чем в DBF.
Попробуй заменить |ТекущийДокумент=... на |Док=....
Все-таки ТекущийДокумент - зарезервированное слово в запросе.


базовая зарплата и конфигуратор | База знаний | mista.ru

базовая зарплата и конфигуратор

mthr 26.05.2004 09:42 | При попытке открыть базовую ЗиК оно говорит, что конфигурация является специализированной и после изменения работать с компонентой Расчет больше не будет. Очень грустно, потому как надо бы у одного справочника увеличить длину наименования. Кто что видел/слышал/знает?
gr13 1 - 26.05.2004 09:57 | без проблем разберись сначала, что такое "Базовая" версия и тебе все станет ясно
ally 2 - 26.05.2004 10:00 | (0)она станет небазовой, соответственно. И запускать ты ее несможешь на базовом движке
mthr 5 - 27.05.2004 14:44 | хорошо. где почитать про базовые конфиги? что такое и с чем едят? насколько я сам понял, там где-то какой-то флажок стоит... Или я опять не прав?
Emvika 8 - 27.05.2004 15:15 | Ну нельзя вносить изменения в базовую стандартными средствами. Легитимное решение проблемы - переход на ЗиК проф http://www.1c.ru/rus/products/1c/predpr/zarp77b.htm


В чем отличие типовой и базовой конф? | База знаний | mista.ru

В чем отличие типовой и базовой конф?

Ученик ламера 06.05.2004 11:15 | В частности - в УСН. И можно ли релиз типовой на базовую поставить?
BorisG 1 - 06.05.2004 11:19 | Да... выучи сначала формулировки... Базовая она и есть типовая...
Ученик ламера 2 - 06.05.2004 11:31 | А почему в таком случае на диске с апдейтами эти два релиза по отдельности представлены?
BorisG 3 - 06.05.2004 11:48 | Так вначале посмотри, как они называются... Одна для обновления с базовым движком... Другая для версии, которая идет с бухией ПРОФ и комплексной, и называется ПРОФ. А сами конфигурации ОДИНАКОВЫЕ.
Serg_bl 4 - 06.05.2004 11:56 | Если что-то не путаю, базовые конфы работают без ключа и не позволяют редактировать md (выдаст предупреждение на эту тему), для ПРОФ нужен ключ.
BorisG 5 - 06.05.2004 12:19 | (4) Ключ нужен не для конфигурации, а для движка.
kvm 6 - 06.05.2004 22:19 | Базовые не дают редактировать md, точнее на базовой платформе нельзя запустить измененный или Проф md. Базовую нельзя запустиь в Отладчике. По-моему все.


сетевая проблема | База знаний | mista.ru

сетевая проблема

Владимир 04.06.2004 07:54 | В сети Микрософт работают 5 машин. Стали появляться сообщения при загрузке: "Ошибка доступа к таблице DH235", "Ошибка загрузки метаданных", "Каталог пользователя занят"... В чем дело? На 4 машинах 98 Винда , а на одной ХР, может, поэтому? Помогите, пожалуйста, кто знает.
SnarkHunter 1 - 04.06.2004 08:04 | Дело - в ограничении числа одновременно открытых файлов (1024) в в98...
VladZagorsky 3 - 04.06.2004 08:30 | Пиши конкретней. В WIN98 (т.е. на FAT) есть ограничение на количество открытых файлов. Т.е. если торговля открывает 600 (примерно, зависит от конфигурации), бух-рия чуть больше. В общем под WIN98 3 базы (например, 2-е торговли и одну бух-рию) одновременно не откроешь. В NT, WIN2000-WIN_XP (т.е. на NTFS) этой проблемы нет.
VladZagorsky 4 - 04.06.2004 08:31 | P.S. 600 - это перебор, конечно. Если точнее 400 и выше.
BorisG 5 - 04.06.2004 08:33 | (0) А поискать по форуму не пробовал? Не один рраз обсуждалось... (2) Скорее на ХР, ибо пять практически любых типовых превысят ограничение Win98. (0) Почитай... я пока не злой ;-)) http://1c.alterplast.ru/faq/start.html И собственно про твою проблему http://1c.alterplast.ru/faq/saved.html
lexa 6 - 04.06.2004 10:51 | (5) спеасибо за ссылки (0)http://www.sinor.ru/~my1c/knowhow/XP&1C.htm


Canon LBP-1000 печатает вопросы | База знаний | mista.ru

Canon LBP-1000 печатает вопросы

Evgen®
27.07.2004 05:49 		Проблема не нова, но опишу подробнее ....
Установлен принтер Canon LBP-1000 в 1C с некоторых компьютеров он печатает нормально а с некоторых выводит "??????? ?? ??????"( что-то подобное), можно сказать что он ведет себя не предсказуемо иногда захочет и печатает, другой раз ну невкакую.

В 1С фонт стоит Arial
elisabet
6 - 27.07.2004 09:16 		Никаких патчиков не надо - ставишь стандартные драйвера (которые идут с диском), при установке в каком то месте она запрашивает флаг (по умолчанию 1) - надо выставить значение 46, отрубаешь монитор состояния принтера напрочь - и он начинает печатать отосвюду не клядя буквы набок и не выделывая прочие кренделя - сама ставила его таким образом - сейчас благо все работает ...
Соратник
7 - 27.07.2004 09:30 		На тему сабжа http://www.kuban.ru/cgi-bin/forum/forum9.cgi?ask=192042&bit=1000
и еще http://www.kuban.ru/cgi-bin/forum/forum9.cgi?ask=192192&bit=1000,

А вот решение проблемы:

В Microsoft Windows 98 / 98SE / Me при печати документов в альбомной ориентации из программы 1С некоторые символы в заголовках полей оказываются перевёрнутыми ("ложатся на бок").

УСТРАНЕНИЕ ПРОБЛЕМЫ

1. Закройте работающие приложения 1С.
2. С компакт-диска, прилагаемого к Вашему принтеру, запустите программу … \ RUSSIAN \ WIN9X \ CAPAFE.EXE
3. В выпадающем меню "Application" найдите EXE-файл, запускающий программу 1С. Если его нет в списке, добавьте файл самостоятельно с помощью Edit / New application / Browse. В открывшемся диалоговом окне перейдите к папке с программой 1С и выделите её мышью (обычно C:\1C\BIN\). Нажмите ОК.
4. В поле Flags поставьте флажок номер 46.
5. В меню File выберите Save и нажмите ОК.
6. Перезагрузите компьютер.
7. Данную процедуру необходимо провести на всех компьютерах под управлением Windows 98/98SE/Me, использующих LBP-800 / 810.


Кто нибудь помогите настроить сервер??????? | База знаний | mista.ru

Кто нибудь помогите настроить сервер???????

пв 27.05.2004 20:38 | Настраиваю сервер терминалов под программу 1С, по описанию на сайте http://www.mista.ru/articles1c/terminal.htm Дойдя до пункта(Пробуем подключиться к серверу) с компа подключиться не получилось, выдает ошибку, что комп к которому подключаюсь перегружен. Потом пробую поиск компов в сети и нахожу группу (WORKGROUP) И пробую кликнуть по ней, выдаёт, что эта группа не принадлежит ни к одному домену и ни к одному серверу терминалов, хотя на компах прописано что принадлежат именно к этой группе и сервер терминалов настроил. 2. Ещё одна проблема, когда настраиваю на сервере IPадрес в ручную всё вроде нормально, но при открытии окна подключения к сети IPадрес отсутствует, написано что недоступен. Помогите кто сможет, а то я уже бъюсь вторую неделю,все варианты испробовал.
Черт 3 - 31.05.2004 10:26 | Ты сначало опиши как у тебя организована сеть, есть ли AD+DNS+DHCP какой сервер? потом можно будет сказать и про терминальный уже.
пв 5 - 31.05.2004 11:36 | После установки ОС выбрал роль контролёр домена, и запустилась Active Directory, но пройдя пару шагов,пишет что сначала настройте TCP/IP, прописал в ручную на подключении к ЛВС, но при выводе окна подключения IP,шлюз,порт и т.д везде пишет НЕДОСТУПЕН.DNS+DHCP роли не устанавливал,начал сраза устанавливать сервер теминалов,как раз наткнулся на этот сайт и настроил всё по описанию, но подключиться с другой машины не палучилось,действия по подключению описаны выше. Сервер преднозначен для работы с программой 1С на 10 машинах,может что нибудь другое посоветуете.
Черт 7 - 31.05.2004 11:41 | Я тебе посоветую купить книжку про настройку сервера, внимательно почитать, настроить сеть, а потом браться за терминальный сервер
Черт 9 - 31.05.2004 12:04 | почитай http://www.compdoc.by.ru/network/local/lanbuild/index2.shtml#91 http://www.winfaq.com.ru/ http://www.networkdoc.ru/insop/win2003.html


to BorisG... Вопросик по 2003 серванту .... | База знаний | mista.ru

to BorisG... Вопросик по 2003 серванту ....

427 08.05.2004 15:06 | Сервант 2003... Как файлопомойка для всего... Роль - только файл-сервер... Русский МУИ... Из доп софта - только ключ ... долбаный ... Все нормально работает.... Проблема - после загрузки примерно 20 минут можно нормально на консоли ввести имя и пароль... и войти... Через 20 минут клава и мышь отваливаются напрочь... Клава ни на что не реагирует (лампочки Caps Lock и Num Lock не загораются при нажатии)... Фигура из трех пальцев - серванту до нее дела нет .... Только по экрану заставка скачет... ну после загрузки 20 минут висит сообщение пресс контрол-алт-дел .... тут реакция нормальная... Потом оно меняется на заставку по умолчанию ... и все... приплыли ... Вопрос - где что надо повертеть.... Чтобы сервант не отстегивал клаву ... Борь, вроде везде посмотрел... Может, сама клава еще... Надо попробовать поменять.. Оно конечно, не критично - никто по нему не лазит.... Но иногда надо посмотреть .... Я его и УПСом погашу .... Но неудобно...
BorisG 1 - 08.05.2004 15:23 | А мать то какая? Посмотри схемы управления питанием. Что отключается через 20 мин. Скорее некорректно сваливается в спящий режим. Может клаву диковинную поставили... было, правда не на 2003-м, стояла от ноутбука дополнительная, а у нее клавиша специальная есть Fn, только ей и выводит. Петь, только реально, на живом, посмотрю 11... и книжки на работе... и сервер... естественно...
BorisG 2 - 08.05.2004 15:25 | +1 Кстати, тоже относится и к Биосу матери. посмотри и там управление питанием.
427 3 - 08.05.2004 16:17 | Схемы управления питанием - отключение питания вырублено у всех устройств... Спящий режим... Какой спящий режим... Сервант молотит... На нем вовсю колбасятся челов 15.... Насчет диковинной клавы - посмотрю... Она и в самом деле отличается - очень маленькая, но клавиши Фн нету.... Я на ней перетыкал все, когда сервант молчал... Да, кстати, на клаве в системе нет отключения питания... А тут постоит и на ней сама гаснет лампочка Num Lock.... Кстати, если после загрузки на сервенте локально зарегистрироваться - эффект не наблюдается... Только в режиме, когда нет локального юзера... Биос смотрел... Вроде все нормально....
BorisG 7 - 08.05.2004 21:56 | (6) Да я про мать спрашиваю, чтобы точно посмотреть описание. Бывают такие штуки на "серверах" на дешевых платах, когда она "наполовину сваливается" в спящий режим. PS: Честно говоря, сервера мы ставим только Intel и IBM. Консультировать, правда, проходится и по другим...
BorisG 8 - 09.05.2004 15:01 | +7 Клава случаем не USB? Всеж таки сдается мне, что надо смотреть управление электропитанием, сначала в БИОСе, затем в системе... и последний момент... в реесте... HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Controls Folder\PowerCfg И файлик никто не правил? \system32\powercfg.cpl PS: но реально на системе могу глянуть во вторник.
427 9 - 09.05.2004 18:31 | (8) не думаю, чтобы правили... Не тот там админ... Клава точно УСБ... Причем внешний вид весьма смахивает на доп клаву для ноута... Мыша РС/2 но она тож отваливается... Вот что странно... Управление питанием для клавы я смотрел... Там нет закладки управления вообще... Т.е. она нуправляемая... Борь... не грей голову... Я туда ХЗ когда попаду... Недели через 2 точно... Мож админ к тому времени и разберется.... Тольько вряд ли ....
BorisG 10 - 09.05.2004 19:32 | (9) Если USB... закладка у USB-набов, там посмотри. Их там не один... галки надо убрать.


1С, сети. | База знаний | mista.ru

1С, сети.

vf_01 30.04.2004 10:41 | Есть две локальные сети в разных корпусах, как их объединить, предпологается что сервер будет один. Какое оборудование для этого нужно?
gr13 4 - 30.04.2004 11:09 | http://www.forum.mista.ru/topic.php?id=2115
vf_01 5 - 30.04.2004 11:52 | между корпусами 1500-2000 метров. как соеденить эти локалки? В одном корпусе сервер из другого надо к нему подключиться.
BorisG 6 - 30.04.2004 12:22 | (5) В идеале - положить оптику, и совсем забыть про проблему.
SiMazx 11 - 30.04.2004 12:52 | Лучше оптики не найдешь... Можно радиоканал, но гемор...
Поп Гапон 12 - 30.04.2004 13:58 | Народ, а вот про этот слух что скажете? "Есть волшебное слово HPNA - набери его в любимом поисковике, почитай и порадуйся: сет. карточка около 30$ стоит, лапша телефонная - 50коп./метр*300=150руб., адаптер HPNA<->Ethernet - около 25$. Hа 300м я лично строил HPNA сеть по обыкновенной телефонной лапше и получил скорость 11Мегабит. Если эти двое не будут очень много чего качать по сети (например, база .dbf, а они отчёты постоянно делают), то 11Mbit должно хватить. А если база на SQL лежит, то точно хватит и 2Mbit. А уже и "накрайняк" можно и про терминалы подумать." А если вместо лапши пробросить кабель используемый военными для связи, то и до 1000 метров дает около 2Мбит (опять же по слухам).
BorisG 13 - 30.04.2004 14:37 | (12) А не задумывался, как расшифровывается HPNA? Только России, наверное, находятся умники, предлагающие технологии, предназначенные для ДОМАШНЕГО использования для ПРОМЫШЛЕННОГО применения. Для работы по физической паре есть и специальные модемы, так что нет проблем... PS: HPNA - Home Phoneline Networking Allience. Есть два стандарта, HomePNA 1.0, 150м, 1 Мб/с, до 25 устройств, и HomePNA 2.0, до 300m, max 10Mbps
Поп Гапон 14 - 30.04.2004 14:42 | (13) Для построения сети компов, собранных из китайского дерьма на коленке оно самое то. Для бизнеса, ты прав, не бывает "дешевых" решений
BorisG 15 - 30.04.2004 15:02 | (14) Дело не только в цене. Есть и относительно дешевые модемы для физики... Дело в подходе к решению проблемы... ты прав, именно из дерьма и на коленке...
Zyxel 16 - 30.04.2004 15:31 | Борис, а что скажешь по поводу применения для дома модемов Зиксель Омни 56к Мини, Уно и Нео? Твоё мнение по поводу каждгог из них, какие есть у кого на форуме впечатления?
Valery 17 - 30.04.2004 15:49 | (13)прав. лучше оптику. в крайнем случае распределить.
Quazy 18 - 30.04.2004 16:23 | по поводу HPNA: в свое время при низком ИТ-бюджете пришлось объединять две сети по телефонной паре с помощью HPNA 1.0, длина кабеля около 700м, нормально работало все, правда, брали устройства какой-то российско-израильской конторы, типа - модифицированное для дальних растояний. Если на оптику денег не хватает - есть смысл обратиться к хDSL-технологиям, например: http://www.usn.ru/catalog/price/modems/zyxel/?pid=9902460
ramstar 19 - 02.05.2004 08:30 | вы вообще о чем на оптику сеть FastEthernet делай и на два кольца штоб сбоев не было только волокно должнобыть одно модоое так поблем меньше будет просто и дешевле зачем велосипед изобретать
BorisG 20 - 02.05.2004 09:29 | (19) Да... советник... Это где ты на оптике сбои видел? И до двух километров одномод НЕ НУЖЕН, достаточно многомода. Разве что кабель найдешь халявный.
vf_01 22 - 06.05.2004 08:42 | А чем плохи iola? Пока я проверил скорость на расстоянии 3 метра все было нормально. На днях проверю на расстоянии около 2000м.
Mario 23 - 06.05.2004 10:15 | Все зависит от расстояния между зданиями. Если оно не превышает 95 метров ,то можно положить между ним витую пару специально для прокладки по улице(условно. Все зависит от активного оборудования). Если больше ,то рекомендую оптику. Это не дешево, но надежно. HPNA или xDSL -это здорово, но максимум ,что можно выжать -это 10 мбит.сек. Для 1С это не скорость. Уж если припекло ,то можно использовать терминальную сессию. 10-ки хватит, но много памяти с сервера скушается. Будте к этому готовы.
Timur 25 - 06.05.2004 19:28 | а что делать если расстояние между ними 2000 км? есть ли какието решения?
Алексей 27 - 06.05.2004 21:35 | Ну и чего голову ломать? У нас расстояние до корпусов ~2км в прямой видимости, и х.з. сколько по колодцам :) Стоят два ASDSL модема, скорость 2 мбита, к сожалению какие сказать не могу, не помню, помню что стоили по 150 баков каждый, и на пузырь телефонисту :) (Шутка)


*.DBF и *.CDX ?! | База знаний | mista.ru

*.DBF и *.CDX ?!

wind_wail 24.05.2004 15:35 | В каком формате хранятся данные в 1С, где можно достать документацию по этому поводу ? Можно ли непосредственно работать с этими данными в обход 1С ? Почему задаю такой вопрос, в ходе работы приходиться изменять объекты метаданных, соотвественно наработки, которые были до этого могут глюкнуться. Можно ли как нибудь "в ручную" изменить эти файлы данных, чтобы данные не пропали а работали под новые объекты метаданных.
ally 1 - 24.05.2004 15:39 | читай файл .DD
lexa 2 - 24.05.2004 15:42 | Можно, например через ODBC, но лучше не надо. Сделай копию базы и глумись над ней сколько влезет.
SnarkHunter 3 - 24.05.2004 15:46 | Проще так "изменять объекты метаданных", чтобы "наработки, которые были до этого" не "глюкнулись"...
wind_wail 4 - 24.05.2004 15:50 | (1) почитал, походу там все есть, только вот с синтаксисом разобраться. Просто я не шарю в базах данных, и решил это поправить, но с уклоном на 1С. (2) а почему с ODBC лучше не надо ? Ну тык я глумлюся всегда с копиями :) Т.е. насколько я понял все данные 1С баз данных хранятся в формате ODBC ? И если в этой хрени разобраться, можно продуктивно глумиться ?
psk21office 5 - 24.05.2004 15:54 | Обращаться к файлам данных в обход 1С можно, но они там нормализованы. Единственное что приходит - это востановление базы после критического падения, но данная ситуация почти форс-мажор и защита от этого только резервное копирование каждый день, а то и каждый час.
lexa 6 - 24.05.2004 16:05 | ODBC - это драйвера, посредством которых можно подключиться к базе данных. Через ODBC можно к 1С подключиться MS Access. Но тогда все методы работы надо прописывать самому и связи между таблицами тоже. И вообще что ты конкретно хочешь сделать?
wind_wail 7 - 24.05.2004 16:07 | (5) А нормализировать бд сложно ? Ну хотябы теоретически это возможно сделать, обладая определенными знаниями ? Странно... как же тогда вносить изменения в объекты метаданных без потери данных? Ну скажем я поменя тип какого-то реквизита, и что, получается все данные которые были до этого идут коту под хвост?
wind_wail 8 - 24.05.2004 16:19 | (6) Я хочу поменять тип реквизита формы, не потеряв при этом данные. И думаю как это можно сделать. А можно решить вопрос совместимости со старыми данными средствами самой 1С, ну скажем обработку написать какую-нибудь? Я понимаю что структуру метаданных менять это дело весьма нежелательное, что нужно решения подобного рода оставлять про запас, но все же. Бывает ведь всякое в жизни, хочется знать насколько это трудоемко.
SnarkHunter 9 - 24.05.2004 16:42 | Как реквизит формы связан с данными?
wind_wail 10 - 24.05.2004 17:00 | (9) реквизит документа. Когда я сохраняю документ, сохраняются данные по этому реквизиту. Если я измению тип данных реквизита и попытаюсь открыть старый документ, новой формоф, наверняка должен возникнуть глюк ?
lexa 11 - 24.05.2004 17:04 | Ты подробней объясни есть то-то, хочу сделать то-то. Например "Есть справочник "контрагенты", хочу добавить новый реквизит "тип контрагента"".
wind_wail 12 - 24.05.2004 17:09 | (11) Харашо :) Допустим есть справочник юридические лица, нужно изменить его структуру, чтобы внутри него все юри лица делились на собственные и сторонние. Если это сделать, не возникнет глюков со старыми данными, где этот справочник используется ?
lexa 13 - 24.05.2004 17:27 | (12) Если ты добавляешь новый реквизит справочника то скорей всего он нигде не используется. сделай поиск во всехтестах по индентификатору нового реквизита


Как в SQL ouery посмотреть связь таблиц? | База знаний | mista.ru

Как в SQL ouery посмотреть связь таблиц?

Неудачник 13.07.2004 11:56 | Потерял где выводится диаграмма связей, всегда показывалось и не надо было, как её вызвать?
Валентин 1 - 13.07.2004 13:06 | Если речь идет о SQLServer. Может ты имеешь ввиду план выполнения запроса? Тогда Сtrl+K. Диаграммы связей укзываются в менеджере (Entrprise Manаger), элемент дерева Diagrams, но для 1С это бессмысленно.


Максимальное значение ID | База знаний | mista.ru

Максимальное значение ID

tenant 14.06.2004 17:26 | 36^6=2176782336 для одиночной базы в десятеричной с-ме. А что будет потом? понятно, что то же, что козе после семи лет, но все же.
tenant 5 - 14.06.2004 17:56 | Дык, неверно в (2). Формат ID един - девять символов, три - украли для кода распр. базы данных(чтоб проверить, не передохнут ли), шесть оставили для народа. (Что-то это мне напоминает сказки про Кольцо в исполнении 1С) (1) Проверяю (3) А вот это не думаю. (2) С SQL тоже не ахти, ROW_ID он и в африке больше 10^10-1 не вытянет и точка, тут ответ однозначен.
tenant 11 - 16.06.2004 15:27 | Проверил в скл, там очень просто ручками ID поменять. Как и следовало ожидать, ID не может быть больше ZZZZZZ. А потом 000000, а уже потом вылетает. Понятное дело - индекс, а я вот пока не проверил - не верил (не хотел верить). Вот так вот. (3) был прав. Вопрос, конечно, был дурацкий, более двух миллиардов записей, это вполне достаточно для 1С.


Состав ИБ | База знаний | mista.ru

Состав ИБ

Vasilii 15.06.2004 15:02 | Подскажите можно ли прецепится к 1С П 7.7. без ее участия Или есть у кого ее полный состав ИБ Заранее Спасибо !!!!!
Valery 1 - 15.06.2004 15:16 | 1cv7.dd
SnarkHunter 4 - 15.06.2004 15:52 | dds
mszsuz 5 - 15.06.2004 16:56 | Кой-чего можно отсюда взять: http://www.sinor.ru/~my1c/knowhow/fields.html


Вопрос по DBF-ам помогите если это возможно | База знаний | mista.ru

Вопрос по DBF-ам помогите если это возможно

dvtp 12.06.2004 11:28 | Вопрос такого характера: Есть база данных (была), из которой удалаили штук 20 файлов, эти файлы справочники - контрагентов, статей затрат и т.д. Т.е. в документах сейчас нет контрагентов, а написано: объект не найден. Есть та-же база но месячной давности. там соответственно все справочники присутствуют, но нет документов за этот месяц и за 3 месяца прошлого года (за прошлый год НДС восстанавливали). Ну дык можно хотя-бы частично заменить новые (пустые) справочники и будет ли толк. Есть ли список DBF-ок что где хранится? Заранее спасибо.
427 3 - 12.06.2004 12:53 | Да, Снарк прав - от 500 баксов... (0) Список есть. В ДД файле... Но лобовая замена может не покатить - не все так просто.... . В принципе базу можно восстановить, используя обработку, работающую в этой же базе... Но покорячиться придется....
VladZagorsky 5 - 13.06.2004 06:27 | К вопросу где что хранится - см. файл 1Cv7.DD. Если в течении месяца справочники изменялись незначительно - перекопируй файлы sc*.dbf. Только сделай сначала копию базы. И на ней тренируйся, иначе стоимость проблемы значительно возрастет. :) Самый простой (и может быть самый лучший) вариант - найди спеца. Будет "быстро и красиво" :)


Какие средства используете для проектирования конфигураций 1С? | База знаний | mista.ru

Какие средства используете для проектирования конфигураций 1С?

Sasha
31.05.2004 03:43 		Привет!
Кто какие средства (UML, IDEF0...) использует для проектирования при разработке конфигураций? И, соответственно, какие программы?
Волшебник
1 - 31.05.2004 08:35 		Я иногда использую DOT - www.mista.ru/dot
Sasha
3 - 31.05.2004 13:57 		Нда... не популярная тема...

Насколько я понял, DOT - это способ разложить существующую конфигурацию в диаграммы. А нужно наоборот: на основании составленных диаграмм разрабатывать конфигурацию.

Интересно, а какие средства (да хрен с ними, со средствами, хотя бы какую методу) применяют сами 1С\'овцы при разработке своих типовых конфигураций? Потому что разрабатывать такие конфигурации без использования средств проектирования, имхо, просто невозможно.

Работаю, в основном, над большими проектами. И, естественно, столкнулся с проблемой анализа требований заказчика. Пробовал использовать UML\'ные диаграммы business usecases, но почему-то не получается. То-ли я их не понимаю, то-ли они просто не подходят. Хотя по идее должны идеально вписываться в разработки для объектно-ориентированных баз данных (в т.ч. и для 1С).

Прочитал статью Станислава (http://www.mista.ru/obsledov.htm) о предпроектном обследовании. Соответственно, вопросы:
- какую нотацию ты используешь для составления этих диаграмм?
- какую программу ты используешь для составления этих диаграмм?
- что за курс Вендрова? Ты его проходил? Какие впечатления?

Спасибо.
SnarkHunter
4 - 31.05.2004 14:12 		У 1С реляционная база...
Волшебник
5 - 31.05.2004 14:51 		(3) Нотация DFD - Data Flow Diagram или IDEF0
Программа BPWin.
Книга Вендрова лежит на citforum.ru и в других местах интернета.
Впечатления? Какие могут быть впечатления от обычного рабочего инструмента.
Нужная вещь в хозяйстве.
Sasha
6 - 31.05.2004 15:43 		Читал курс Вендрова \"Методы и средства проектирования ПО\" и его книгу \"Проектирование ПО ЭИС\" - и то и другое показалось полной ерундой.
Если на citforum.ru имелась в виду вот эта книга: http://citforum.ru/database/case/index.shtml , то она просто ремейк его курса и предыдущей книги. Вообще такое впечатление, что Вендров писал книгу и учился. В принципе, в дополнение к online-учебнику по 1С можно было бы и вести учебник по анализу и проектированию конфигураций.

Ну, хорошо. Составили диаграммы потоков данных. А что потом? Составлять диаграммы сущность-связь?

2 Волшебник: в запросе на яндексе \"DFD описание методики\" твоя статься - на 2 месте!
Волшебник
7 - 31.05.2004 16:05 		(6) "А что потом? Составлять диаграммы сущность-связь?"
Именно так. Кстати, ER-диаграммы вполне можно составить и для 1С 7.7 или 8.0, ничего сложного нет.

Яндекс меня вообще радует! От него каждый день приходит половина аудитории сайта www.mista.ru.
Sasha
8 - 31.05.2004 22:40 		2 all:

Кто-то использует UML для анализа требований и разработки конфигурации на 1С?

Кажется у "Аналита" была конфигурация как раз для проектирования конфигураций, из которой потом чуть ли не код формировался. Кто-то с ней работал?

2 Волшебник: почему не получила развитие идея написания учебника для программистов? (http://www.mista.ru/community.htm). Хотя вопрос больше риторический, судя по количеству откликов в этой теме...
Я бы с удовольствием принял бы участие, особенно в теме про анализ и проектирование. Заодно и подучился бы (прям как Вендров) :))
Аналитик
9 - 01.06.2004 07:41 		Использую IDEF0 и IDEF1X, на основе моделей - текстовое ТЗ (потому что тоолько текст понятен руководству - заказчику). Для программистов оформляю алгоритмы ТЗ старым добрым методом блок-схем алгоритмов.
PS: конфигурация пишется на 8.0 с нуля в очень сжатые сроки
¶
10 - 01.06.2004 08:21 		(8) А что ты скажешь о книге К.Лармана "Применение UML и шаблонов проектирования"? ИМХО, очень неплохо именно в методологическом плане - не только излагается UML, но и приводится методика проектирования с его использованием.


Сетевая версия 1С 7.7 ? | База знаний | mista.ru

Сетевая версия 1С 7.7 ?

wind_wail 02.06.2004 16:20 | Подскажите пожалуйства по какому принципу работае сетевая 1С ? Клиент-сервер? Общие файлы на сетевом диске? ... или как ? Понимаю, вопрос многим покажется ламерским, поэтому просьба указывать ссылке где можно про это почитать ?\ Заранее благодарен!
GrayT 1 - 02.06.2004 16:24 | Смотря какая - ДБФ, сам понимаешь, ну а SQL опять же файлы на диске, но другие.
wind_wail 2 - 02.06.2004 16:31 | может я не правильно задал вопрос... чем отличается сетевая версия от локальной ? Мне нужно на локальные компы ставить клиентную часть, а на сервер серверную ? как все это делается?
GrayT 3 - 02.06.2004 16:37 | http://www.1c.ru/rus/products/1c/predpr/ Будут вопросы задавай
Рупор абсурда 4 - 02.06.2004 16:37 | Мдя ... А без книжки про ВК тут ващще не разобраться ...
lexa 5 - 02.06.2004 16:37 | если ставишь локально то запускаться с данного компьютера а если ставишь как сервер (административная установка) то с сервера если машин немного ставь локально, на работу не влияет
lexa 7 - 02.06.2004 16:49 | http://www.mista.ru/articles1c/admin.htm
wind_wail 9 - 02.06.2004 17:20 | to (8) Зря ты на Lexa наезжаешь, все он правильно сказал, даже я, не являясь продвинутым пользователем 1С все понял. Задумываюсь не ведет ли наличие звезд у некоторых личностей к "звездной болезни" и желания опускать всех и вся... to (7) Спасибо классная статья, много полезного подчеркнул оттуда.
wind_wail 11 - 02.06.2004 17:26 | to (8) Все правильно: цитата из статьи (7) "Поэтому, в случаях, когда в рамках одной локальной сети для работы с системой 1С:Предприятие используется значительное число компьютеров и сеть не слишком перегружена, рекомендуется использовать сетевую установку 1С:Предприятия" Отсюда делаем вывод: если в сети мало машин и она сильно загружена можно использовать локальную версию.
lexa 12 - 02.06.2004 17:29 | (11) когда у меня франч ставил, то поставил локально. По моему проблема с локальной установкой одна - обновление релизов программы
HanProg 13 - 02.06.2004 17:33 | Только тем что в локальной базе работает всегда только один, как монопольно, а в сетевой можно запустить программу с одной базой несколько раз и никакой разнице база на локальном диске или на сетевом
lexa 14 - 02.06.2004 17:34 | (13) ты не понял, мы про установку программы , а не конфы
wind_wail 15 - 02.06.2004 17:35 | А сама база (файлы *.md, *.dd и проч.) хранится на сервере ? Насколько я понимаю, если в сети стоит локальная версия - любой пользователь может залезть в папку на сервере с базой и напоганить там или просто ее скопировать ? Или я ошибаюсь ? В сетевой версии этот вопрос я так понимаю отпадает потому что не нужно расшаривать папки в сети ?
lexa 16 - 02.06.2004 17:40 | http://www.mista.ru/articles1c/admin1c_w2k.htm
GrayT 18 - 02.06.2004 17:43 | (15) Это уже вопрос из области безопасности в 1С. Поищи на форуме, тут было много дебатов. Скажу сразу в файловом варианте ее практически никакой нет.
SiMazx 21 - 02.06.2004 17:48 | (15)Ой-вей... Ну и каша... А говоришь статью в (7) прочитал... Начнем с того, что мы говорим про семерку, так? Есть два варианта УСТАНОВКИ ПРОГРАММЫ: локальная установка и административная. Первый вариант - исполнемые файлы программы лежат у каждого пользователя на машине, второй вариант - на сервере (на машину пользователю копируются только ярлыки для запуска). Другой аспект - ВЕРСИИ ПРОГРАММЫ: есть локальная и сетевая. Первый вариант - с базой может одновременно работать только(!) один пользователь, второй вариант - несколько. Дальше - папка с базой будет расшарена всегда (если только она не используется локальной версией программы и лежит на том же компьютере, также не рассматриваю вариант с терминалом).
GrayT 23 - 02.06.2004 17:53 | Я не говорил, что статью прочитал - сейчас читаю. Безопасность это не только файлы (имхо) А локальная версия программы есть? Или она однопользовательской называется? :)
wind_wail 27 - 02.06.2004 18:19 | то (21) ясно. Тогда вопрос 1. сетевая ВЕРСИЯ устанавливается только через административную УСТАНОВКУ? 2. отличие сетевой ВЕРСИИ от локальное в том, что локальная блокирует всю базу (получается монопольный режим), а сетевая блокирует только объекты, которые изменяются в данный момент(многопользовательный режим), так? to (23) Запутался я в конец. Там можно использую локальную версию 1С 7.7 с одной базой одновременно работать нескольким пользователям ?
wind_wail 28 - 02.06.2004 18:24 | to (17) я всегда рад все перепонять %)... если бы ты был более конкретным, а не говорил просто "ты не прав".
SiMazx 29 - 02.06.2004 18:25 | (27) 1. Нет 2. Ну... Ладно... Пусть будет так... 3. Мля... Ты разницу между ВЕРСИЕЙ ПРОГРАММЫ и ВАРИАНТОМ УСТАНОВКИ до сих пор не видишь?
lexa 30 - 02.06.2004 18:31 | (27)Сетевая версия программы позволяет работать нескольким пользователям с одной информационной базой (конфигурацией). При установке сетевой версии тебя спрашивают способ установки : локально или административно (см статью). Вне зависимости от способа установки пользователи смогут работать с одной и тойже конфигурацией. По оканчании установки программы тебя спросят установить конфигурацию или нет. Обычно на диске с дистрибутивом программы есть дистрибутив конфигурации. Можешь сразу установить конфигурацию, только сразу выбери место (если файл-сервером будет твой комп то на него, иначе на комп, который будет файл-сервером). Открываешь доступ к папке с конфой. Смотри (16)


общие вопросы 1С: компоненты... | База знаний | mista.ru

общие вопросы 1С: компоненты...

Crystalizer 27.05.2004 18:29 | я парюсь с готовыми конфигурациями, где всё свалено в кучу - по несколько компонент. что из себя представляют эти компоненты и что значит их изучить? Компонента - это набор шаблонов документов и справочников, а также некоторых специальных типов данных (типа "проводка", "операция", "виды расчетов")? и где можно достать общую инфу об этом?
Волшебник 2 - 27.05.2004 18:36 | Компонента Бухгалтерия: * Бухгалтерские счета * Операции и проводки * Бухгалтерские итоги * Бухгалтерский запрос Компонента Расчет: * Журналы расчетов * Виды и группы расчета * Календари * Мини-зарплата Компонента Оперативный учет: * Регистры В 8.0 все компоненты входят в базовую поставку.


метод СохранитьЗначение() куда сохраняет? | База знаний | mista.ru

метод СохранитьЗначение() куда сохраняет?

AlexMan 19.05.2004 19:28 | За возможно дурацкий вопрос но очень интерестно куда сохраняет СохранитьЗначение()? Если сохранение идет в каталог базы данных тогда Cильно ли ее раздувает если часто этим методом пользоватся и сохранять большие таблицы значений? Сохраняется ли все это добро при сохранее БД или выгрузки БД (из конфигуратора)?
Estet 2 - 20.05.2004 11:59 | В момент работы систеты эти данные он держит в памяти при закрытии сохраняет в файл 1Cv7.CFG
AlexMan 4 - 20.05.2004 20:37 | (2) Привет , давно не виделись , значит автоматом не сохраняется но его (этот файл) можно включить в список сохраняемых файлов. Спасибочки.


Диаграмма процессов | База знаний | mista.ru

Диаграмма процессов

sss 19.05.2004 12:42 | Есть ли описание конфигураций УТ, УПП в виде диаграммы процессов, напр. по стандартам IDEF (или хоть как-то)?
Волшебник 1 - 19.05.2004 13:04 | Есть описание структуры базы УПП: Подсистема "Управление продажами" (80К) http://www.mista.ru/upp/diagram_prodaji.png Подсистема "Управление покупками" (83К) http://www.mista.ru/upp/diagram_pokupki.png Подсистема "Управление производством" (20К) http://www.mista.ru/upp/diagram_proizvodstvo.png Еще есть деморолики по этим конфигурациям, в которых есть кое-какие схемы. А больше ничего пока нет.
sss 3 - 19.05.2004 14:13 | 2Волшебник спасибо. случайно для УТ нет? - мы пытаемся изменять ее и может это наглость:), а неграфический формат есть? Общие соображения: 1С неповредила бы открытость в структурах таблиц, создаваемых объектами конфигурации и подробное описание самих конфигураций. Хорошо было бы иметь возможность убедиться(с точки зрения структуры базы), что добавленный тобой объект не будет через некоторое время служить тозмозом. ИМХО, конечно
Волшебник 12 - 20.05.2004 00:06 | (11) Я тоже люблю Visio. После выпуска рассылки тебе представится возможность получить такую же схему в формате Visio, но только нужен обязательно Visio 2003, который понимает SVG. Все спецсредства написаны на С и поставляются с открытыми исходниками.
Asmody 13 - 20.05.2004 00:19 | (12) придется в ближайшие выходные посетить горбушку :) в связи с тем, что спецсредства написаны на С, возникает вопрос: нельзя ли их переписать на VBA под Visio, и получить тем самым возможность делать нормальный Refeng для 1С? И как продолжение, написать обратную процедуру формирования объектов v8 из Visio? Получим достойное CASE-средство для v8
Волшебник 14 - 20.05.2004 00:23 | (13) Обратную процедуру вряд ли получится. Это надо знать структуру 1СD или хотя бы CF. Для 7.7 есть GComp, а для 8.0 пока ничего нет. А по поводу переписать на VBA - флаг тебе в руки, барабан на шею и паравоз навстречу. Проще вызывать это спецсредство, получая от него выходной XML-файл, затем парсить его и выдавать хоть в Visio, хоть в табличный документ 1С. Куда угодно.
Asmody 15 - 20.05.2004 00:30 | (13) у меня, как ты знаешь, на это (переписывание), к сожалению, сейчас времени нет. :( и опять натыкаемся на пресловутый ALTER TABLE, которого в 1С нет
Asmody 22 - 20.05.2004 00:58 | погоди-ка, где хранятся метаданные в клиент-серверной версии? :) если я как-то чего-то понимаю, то часть всего этого возможна, пусть не средствами 1С, но T-SQL...
Волшебник 23 - 20.05.2004 00:59 | Метаданные хранятся в файле 1cd. Если ты что-то изменишь с помощью T-SQL, то нарушишь структуру базы и 1С будет ругаться (как фирма :)
sss 29 - 20.05.2004 11:23 | а получить взаимное соответствие между объектами конфы и физическими таблицами в сикуеловской базе не пробовали? я встречал предложение по созданию триггеров на каждую таблицу, потом обход всех оъектов конфы и изменнение их реквизитов. Проблема, имхо, в том что таким образо получится узнать только реквизиты с простыми типами, а ссылки на другие таблицы (самое интерестное) нет.


Проблема с базами... ругаются на оперативный учет | База знаний | mista.ru

Проблема с базами... ругаются на оперативный учет

Malicious Babai 18.05.2004 10:40 | Дело вот в чем: ОС снес, предварительно бд скопировав, потом все установил, 1с поставил, базы обратно закопил и подключил их к проге, а не работают: говорят, что Оперативный учет не установлен, хотя другие БД (с сервера) работают. А еще когда в Конфигураторе открываю у них конфигурацию - спрашивает об исправлении ошибок, говорю, чтоб исправил, он исправляет, а изменения не сохраняет - говорит, что Оперативный учет отключить нельзя, т.к. есть проведенные доки Что такое случилось - не пойму, ведь раньше все работало :( ПОМОГИТЕ, ЛЮДИ ДОБРЫЕ!!!
SnarkHunter 1 - 18.05.2004 10:43 | trade.dll должна быть в каталоге bin
gr13 3 - 18.05.2004 11:02 | (0) мдааа... 1. не вздумай конфу сохранять, после таких изменений. 2. посмотри в хелпе "О программе" какие компоненты установлены. Должна быть установлена компанента "Оперативный учет", если нет, то установи ее с дистрибутива


Что будет? Если 2-е конфигурации на одну базу. | База знаний | mista.ru

Что будет? Если 2-е конфигурации на одну базу.

valich 17.05.2004 13:32 | Может быть вопрос глуповатый, но что-то я не нашел у себя инфы... Никто не подскажет такой момент... Есть "много" пользователей на клиентских машинах, есть одна сетевая конфигурация (SQL), через которую все клиенты работают с одной базой... Собственно вопрос, что будет, если один из пользователей (я) станет работать на другой конфигурации с той же самой базой? Вторая конфигурация - просто копия первой...
valich 3 - 17.05.2004 14:27 | (1) А можно подробнее? (2) Да собственно никакой затеи нет. Просто тут, чуть по ошибке не влетел в рабочую базу со своей копии конфигурации... А вообще конечно хотелось бы понять принципы работы 1С...
12345 4 - 18.05.2004 11:40 | 21- просто не пустит. Пробовал много раз, и случайно и специально. Другие релизы - не знаю, не пробовал.


Новая статья на сайте www.perlscript.ru | База знаний | mista.ru

Новая статья на сайте www.perlscript.ru

perlscript
17.05.2004 16:39 		Тема: «Анализ производительности 1С: размещение временных файлов в оперативной памяти».
Линк:
http://www.perlscript.ru/v77_32.shtml


Как добавит в меню операции пункт: "Управление оперативными итогами"??? | База знаний | mista.ru

Как добавит в меню операции пункт: "Управление оперативными итогами"???

RommBoss 15.05.2004 22:25 | Почему то в моей конфигурации (или платформе) не данного пункта, но ведь все отчёты строятся на этом пункте, что делать????
DElo 6 - 15.05.2004 23:27 | (2)А открой Помощь - О программе и глянь: а стоит ли у тебя компонента "Оперативный учёт" в установленных? Если нет, то причин дофига: от неправильной установки до недопоставки... И не мешало бы привести ЧТО у тебя - комплексная, 3 по отдельности, ННФ, сеть/локальная, а то разговаривать затруднительно и в причинах ковыряться.
Tassadar 8 - 17.05.2004 09:49 | Проверь наличие trade.dll в папке с экзешником. Если нету, то закинь его туда...


DBF и CDX отдельно | База знаний | mista.ru

DBF и CDX отдельно

mihmih 11.05.2004 18:45 | Есть два винчестера, можно ли сделать так чтоб dbf-ники лежали на одном,а cdx-ники на другом (для увелисения скорости работы).
Fynjy 1 - 11.05.2004 18:51 | Вопрос идет не о ускорении, а скорей о замедлении :)
Антон 3 - 12.05.2004 04:55 | Лучше поставь RAID будет побыстрее
427 5 - 12.05.2004 06:42 | В 1С можно разложить базу по нескольким дискам... каждой паре (и только паре!) дбф+сдх можно указать свой диск.... Будет быстрее.... Но придется париться ручками при каждом изменении МД.... Оно надо?
-morgan- 6 - 12.05.2004 08:57 | (5) и как эт сделать?
SnarkHunter 7 - 12.05.2004 09:00 | Есть такой файл - 1cv7.dd...


1С - список ИБ | База знаний | mista.ru

1С - список ИБ

Luda 06.05.2004 10:49 | При запуске 1С:Предприятия информационная база исчезает из списка. Где хранится список ИБ.
Valery 1 - 06.05.2004 10:53 | Хранятся в реестре. Для каждого пользователя ПК может быть свой. Скорее всего она исчезает по этой причине. Создавал их один пользователь, а ты входиш под другим именем.


В каком файле находится список активных пользователей 1С? | База знаний | mista.ru

В каком файле находится список активных пользователей 1С?

NewLine 01.05.2004 01:47 | В каком файле находится список активных пользователей ?
kadr 2 - 02.05.2004 07:57 | или в userdef есть файл users.usr
GrayT 3 - 02.05.2004 09:39 | И что все активные? Думаю, что NewLine интересовали те пользователи. которые в данный момент работают с базой. За SQL говорить не буду, а в дбф в чистом виде такого списка нет. (на сколько я знаю). Часть инфы можно выдернуть из млг, но это геморойно - фактически анализатор писать надо. Плюс возможна проблема с "отвалившимися" узерами. Я для себя проблему решил при помощи справочника пользователей и сессий. Точнее меня интересовали не активные, а как раз "злостные" нарушители порядка закрытия программы....
kvm 9 - 02.05.2004 18:24 | У пользователя, который сейчас в базе висит в каталоге файл 1cv7.lck... Кажется...


Trial конфигурация 1с | База знаний | mista.ru

Trial конфигурация 1с

Feather 03.05.2004 11:34 | Реально ли за_trial_ить конфигурацию 1с? Есть ли подобные наработки? Что то порыскал по поисковикам - ничего не нашел.
BorisG 1 - 03.05.2004 11:49 | (0) Реально. Если конфа дорогая... Можешь HaspTime от Аладдина... Можно и из кладовочки Альфа...
BorisG 2 - 03.05.2004 12:58 | +1 К последнему ссылка... http://www.consult.legion.ru/alf/encoder.shtml Только спрашивай про сие у автора, я от коментариев воздержусь.


Где храниться информация о зарегистривонных (подключенных) базах | База знаний | mista.ru

Где храниться информация о зарегистривонных (подключенных) базах

THawk 16.09.2004 10:54 | Может кто подскажет - Где храниться информация о зарегистрированных подключенных) базах, который при запуске видим, выбираем, добавляем(подключаем) и удаляем. Дело в том что 1с были деисталирован и установлен снова а список подключенных баз пропал. С уважением, Thawk.
Crew 1 - 16.09.2004 10:55 | в реестре
YamMike 4 - 16.09.2004 10:55 | реестр HKEY_CURRENT_USER\Software\1C\1Cv7\7.7 ЗЫ забил на поиск?
Волшебник 7 - 16.09.2004 10:57 | В 8.0 список баз хранится в профиле пользователя в текстовом файле.
Волшебник 9 - 16.09.2004 11:02 | (8) смотри http://www.forum.mista.ru/topic.php?id=9992 http://www.forum.mista.ru/topic.php?id=8948


Вытаскиваем содержимое синтакс-помощника 8.0 (типа будни) | База знаний | mista.ru

Вытаскиваем содержимое синтакс-помощника 8.0 (типа будни)

Syntax
19.09.2004 14:25 		Используя WSH теоретически можно вытащить синтакс-помощник в текстовый файл, непонятно только зачем это надо... Ну наше дело - технологическое!

-----------------------------
Создаем обработку, в которой пишем:

Shell = Новый COMОбъект("WScript.Shell");
Shell.AppActivate("Конфигуратор - НазваниеКонфигурации");

Shell.SendKeys("^{N}"); //новый документ
Shell.SendKeys("^{HOME}"); //в начало списка - Текстовый Документ
Shell.SendKeys("{ENTER}"); //выбрать

Shell.SendKeys("^+{F1}"); //открыть синтакс-помощник
Shell.SendKeys("{HOME}"); //перейти на начало

Для н=1 По 100 Цикл

ОбработкаПрерыванияПользователя();

Shell.SendKeys("{DOWN}"); //следующая ветка
Shell.SendKeys("^(C)"); //скопировать строку в буфер
Shell.SendKeys("{ESC}"); //скрыть синтакс-помощник
Shell.SendKeys("^(V)"); //вставить строку в текст из буфера
Shell.SendKeys("^{END}"); //перейти в конец
Shell.SendKeys("{ENTER}");//перейти на следующую строку
Shell.SendKeys("^+{F1}"); //активировать синтакс-помощник

КонецЦикла;

Когда в 1С посылается слишком много нажатий клавиш, то Конфигуратор не успевает их обрабатывать и часть игнорирует. Следовательно цикл сбивается. Для борьбы с этим недугом можно вставить паузы после каждого нажатия:

Для к=1 По 1000 Цикл //пауза
ОбработкаПрерыванияПользователя();
КонецЦикла;

Теперь запускаем Конфигуратор и Предприятие.

В Конфигураторе открываем синтакс-помощник, раскрываем его весь (Ctrl-Shift-Серый плюс), ставим курсор на первую тему.

Переходим в Предприятие, запускаем обработку.

-----------------------
-----------------------
Аналогично можно вытащить содержимое тем:

Shell = Новый COMОбъект("WScript.Shell");

Shell.AppActivate("Конфигуратор - НазваниеКонфигурации");

Shell.SendKeys("^{N}"); //новый документ
Shell.SendKeys("{HOME}"); //в начало списка
Shell.SendKeys("{DOWN}"); //следующая
Shell.SendKeys("{DOWN}"); //следующая - Табличный документ
Shell.SendKeys("{ENTER}"); //выбрать

Shell.SendKeys("^+{F1}"); //открыть синтакс-помощник
Shell.SendKeys("{HOME}"); //перейти на начало

Для н=1 По 100 Цикл

ОбработкаПрерыванияПользователя();

Shell.SendKeys("{DOWN}"); //следующая ветка
Shell.SendKeys("{ENTER}"); //активировать ветку
Shell.SendKeys("^(C)"); //скопировать строку в буфер
Shell.SendKeys("{ESC}"); //скрыть синтакс-помощник
Shell.SendKeys("{ENTER}"); //войти в ячейку ТД
Shell.SendKeys("^(V)"); //вставить строку из буфера
Shell.SendKeys("{ENTER}"); //выйти из ячейки и перейти вправо
Shell.SendKeys("^+{F1}"); //активировать синтакс-помощник
Shell.SendKeys("{TAB}"); //перейти в окошко текста СП
Shell.SendKeys("^{A}"); //выделить все
Shell.SendKeys("^(C)"); //скопировать в буфер
Shell.SendKeys("{ESC}"); //скрыть синтакс-помощник
Shell.SendKeys("{ENTER}"); //войти в ячейку ТД
Shell.SendKeys("^(V)"); //вставить строку из буфера
Shell.SendKeys("{ENTER}"); //выйти из ячейки
Shell.SendKeys("{DOWN}"); //перейти на следующую строку
Shell.SendKeys("{HOME}"); //перейти в начало строки
Shell.SendKeys("^+{F1}"); //активировать синтакс-помощник
Shell.SendKeys("+{TAB}"); //перейти обратно в окошко веток

КонецЦикла;
-----------------------------

Это все теория, подтвержденная парой экспериментов. На практике иногда бывают сбои, когда нажатия клавиш посылаются не в том порядке или не в Конфигуратор. Окончательную реализацию оставляю вам.
Kreal
1 - 20.09.2004 10:09 		Файл C:\Program Files\1cv8\bin\ru\shcntx.hbk является файлом синтаксис помощника. Если его расширение переименовать в zip, а затем WinRar - ом восстановить полученный архив, то мы получим архив c html. В нем правдо будут работать не все ссылки. В той же папке храняться еще подобные файлы. 1С умеет переходить между ними по ссылкам.


Отключить пользователя 1С с другого ПК | База знаний | mista.ru

Отключить пользователя 1С с другого ПК

Суворов 11.08.2004 04:47 | Как удаленно отключить пользователя программы 1С с другого компьютера. Приходиться через монитор определять какие ПК работают,звонить им,чтобы вышли из программы.Уходит много времени на определение,где и кто работает на данном ПК.
unior 1 - 11.08.2004 04:56 | поищи там http://1c.proclub.ru/ и там http://www.ya.ru/
Vser1 3 - 11.08.2004 05:12 | 1) Применение средств 1С: http://www.forum.mista.ru/topic.php?id=6274 http://www.forum.mista.ru/topic.php?id=5199 http://www.forum.mista.ru/topic.php?id=7615 2) Применение средств ОС (удаленное администрирование): например, применение Radmin: http://www.forum.mista.ru/topic.php?id=3695 ЗЫ: ну и еще куча инфы можно найти в базе знаний или поиске по ключевым словам.


Почему в 8.0 нет ООП? | База знаний | mista.ru

Почему в 8.0 нет ООП?

Vozhd
2 - 01.06.2004 17:31 		(0) потому что так решили разработчики
alxkorvin
6 - 01.06.2004 17:37 		(4) Я не знаю зачем нужно ООП в 8.0
sss
8 - 01.06.2004 17:45 		надо изменить поведение документа, добавить реквизит и т.д.
если бы было ООП, можно было бы создать СВОЙ док-к на основе ТИПОВОГО
и в случае изменения ТИПОВОГО не надо было бы ломать голову как сохранить СВОИ изменения
Волшебник
9 - 01.06.2004 17:49 		А если в типовом документе удалили реквизит, а твои изменения были на него рассчитаны?
alxkorvin
10 - 01.06.2004 17:50 		(10) Тогда можно будет спросить: почему в 8.0 есть ООП
BorisG
11 - 01.06.2004 17:53 		(8) Это не надо никому ничего грузить. Когда будешь на месте Сергея Нуралиева, тогда и будешь грузить, что должно быть в конфе, а что нет, и как ее продвигать на рынок.
Можешь при желании пообщаться с ним на выставках... и прямо вопрос задать.
А так... только пустой треп.

Можесь сделать сам, если считаешь нужным. Типа 1С++
sss
12 - 01.06.2004 18:00 		2Волшебник
хороший вопрос
но часто ли в случае изменения ТИПОВОГО делаются изменения в сторону уменьшения?

2BorisG
неужели вам не интересно или все, что не касается продаж - пустой треп?
BorisG
13 - 01.06.2004 18:15 		(12) Мне это неинтересно, потому что я считаю, что обсуждать за глаза действия разработчиков и маркетологов - действительно пустой треп. Если есть желание обсудить с ними вопрос, задай его напрямую. У меня такая возможность есть.
В принципе, для этого есть и отдельная конференция, там разработчики отвечают.
Ты же не задаешь вопрос, почему Windows такой. Используешь какой есть. Если не нравится, переходишь на другой продукт.

В конце концов, есть и дрругой способ. Выдвинь проект, что даст твое предложение. Тогда имеет смысл его обсудить и довести до сведения разработчиков.

Пример, кстати, есть. Обсуждение вопроса RLS.
Там автор выдвинул вполне конкретные предложения.
http://itland.ru/forum/index.php?showtopic=2968
sss
14 - 01.06.2004 18:29 		1."В принципе, для этого есть и отдельная конференция, там разработчики отвечают"
можно ссылку?

2."http://itland.ru/forum/index.php?showtopic=2968 "
уже читал, интересно
но, цитируя автора темы:
*******
Причина возникновения топика - на мой запрос типа

QUOTE
В данный момент одним из основных критериев при выборе решения для автоматизации бизнеса среди наших заказчиков является наличие в системе гибкого механизма настройки прав доступа. Причём права доступа должны регулироваться не на уровне объектов метаданных, а на уровне записей (определённые пользователи должны иметь доступ только к определённым элементам справочников, документам, в отчётах информация по объектам, на которые нет доступа, должна пропускаться). В идеале пользователь вообще не должен знать, что кто-то работает в системе кроме него. Планируется ли в релизе УПП реализация подобных механизмов?

пока нет никакого ответа от представителей 1С.

********

сомневаюсь, что фирма 1С понимает, что ответы на вопросы о проблемах нужны не только тем, кто с этими проблемами столкнулся, но и самой 1С(на вопрос, почему Windows такой? специалисты МС отвечают(как могут:)
alxkorvin
17 - 01.06.2004 18:44 		(16) Есть определенная информация, которая сообщается на закрытых форумах и семинарах. Поехать на семинар может любой франч, получить доступ на форум может любой сертифицированный специалист.

Распространять информацию, услышанную на семинаре запрещено фирмой 1С. Доступ на форумы 1С можно получить достаточно просто, поэтому лично я не вижу смысла дублировать эту информацию где либо.


ОБЭП подкрался незаметно... | База знаний | mista.ru

ОБЭП подкрался незаметно...

BorisG 17.05.2004 15:46 | Для "любителей" обслуживать нелицензионные программы 1С... И чем это грозит работнику и его работодателю... Интересное обсуждение на кубани. http://www.kuban.ru/forum_new/forum9/files/181383.html
Черт 3 - 17.05.2004 15:58 | нервотрепкой, ну и если окажется совсем дураком, то могут повесить всех собак и превлечь, хотя хлопотно это
BorisG 4 - 17.05.2004 16:08 | Не... похоже не дошло. Привлекать работника, да и франча в этом случае, если в сабже рассказано верно, не будут с вероятностью около 100%, а вот в отношениях с 1С... Франчу, если информация дойдет до 1С грозит почти на 100% расторжение договора до уплаты штрафа, а работнику... если действовал, не предупредив администрацию франча, возмещение этого штрафа и дополнительных расходов работодателя согласно ст. 238 ТК, что для работника может быть весьма существенно. Причем эти обязательства сохраняются и при увольнении работника. (2) Ты не франч, потому разбираться будешь сам. ;-)


Опять про лит-ру в эл. виде | База знаний | mista.ru

Опять про лит-ру в эл. виде

Сергеев 06.06.2004 17:16 | Что такого противозаконного или нарушающего авторские права разработчика в просьбе предоставить лит-ру по конфигурациям? Я же не сами конфы или крэки к ним прошу, а литературу.
SnarkHunter 2 - 06.06.2004 17:25 | (0)Во всех книгах от 1С на первых страницах написано: "Право тиражирования программных средств и документации принадлежит фирме 1С... Приобретая систему 1С:Предприятие, Вы тем самым даете согласие не допускать копирования программ и документации без письменного разрешения фирмы 1С..."
BorisG 3 - 06.06.2004 17:28 | (0) + к сказанному. Если нужна дополнительная литература, например от Раруса, просто обратись к продавцам, у кого купил. Рарус продает дополнительные книги владельцем сетевых конфигураций, цена 10 зеленых для конечного пользователя.
BorisG 4 - 06.06.2004 17:32 | +3 Правила продажи дополнительных книг есть и в 1С. Там все еще проще. В коробку с сетевыми версиями семогки вложены талоны, по ним и можно приобрести дополнительную литературу. Для восьмерки талоны в коробке с дополнительными лицензиями, по одному талону на одну лицензию. PS: Но тебе, похоже, это не нужно.


О лицензировании УСН | База знаний | mista.ru

О лицензировании УСН

Romik_r 20.05.2004 16:13 | Ответьте, пожалуйста, на следующий вопрос: У меня 2 года назад куплена «Стандартная бухгалтерия 7.7.». Могу ли я (меня интересует законность этой операции), не докупая отдельно, использовать конфигурацию «УСН». Или же мне к моей стандартной докупать еще базовую «УСН». И какими документами это регламентируется?
BorisG 1 - 20.05.2004 16:56 | Нет, не можешь. Письмо 1936. Но, лучше, ИМХО, сделать апгрейд на Проф.
Romik_r 2 - 20.05.2004 17:01 | Спасибо за ответ! А что это за письмо(от кого кому)? И где его можно почитать? А другой вариант: есть "Комплект небольшой фирмы" можно ли на него поставить "Предпринимателя"?
BorisG 3 - 20.05.2004 17:25 | (2) Да... информационное письмо 1С. http://www.1c.ru/news/info.asp?id=1936 Можешь, если купишь коробку.


OFF: Может один сертифициорованный программист 1С работать в двух фра? | База знаний | mista.ru

OFF: Может один сертифициорованный программист 1С работать в двух фра?

Stop 15.05.2004 15:05 | САБЖ + Работать и числится с целью выполнения фра лимита по спец-там?
BorisG 2 - 15.05.2004 15:30 | (0) Работать может. Совместительство никто не отменял, да и это выбор работника, а не руководства. См. ТК. А вот сертификаты, причем ВСЕ должны числиться только на ОДНОЙ фирме. И на это есть соответствующее письмо 1С. Если обнаружится, что один и тот же сертификат числится на двух фирмах, ВСЕ сертификаты данного сотра снимаются с обоих фирм до выяснений... и, возможно штрафов.
Gavrila 3 - 15.05.2004 16:47 | (2) я так понимаю, что один человек может иметь несколько сертификатов(одинаковых) зарегистрированных на разные фирмы?
BorisG 5 - 15.05.2004 17:10 | (3) Нет, НЕ МОЖЕТ. У одного чела может быть несколько сертификатов, по разным компонентам, но ВСЕ ОНИ должны числиться НА ОДНОЙ фирме. Теоретически обмануть 1С можно... сдав дважды экзамен... но последствия за обман... я предсказывать не берусь. Что будет директору франча за неверные сведения о спецах и их сертификатах... написано в письме вполне конкретно.


1c ЖКК | База знаний | mista.ru

1c ЖКК

vdi 05.05.2004 11:23 | Являются ли ЖКК печатными изданиями? __________ С уважением, vdi.
BorisG 2 - 05.05.2004 11:50 | (0) Нет, не являются. Это документация, составная часть изделия.
vdi 5 - 05.05.2004 12:17 | Уточню вопрос. С точки зрения научного сотрудника печатные издания это те издания, на которые можно ссылаться в сових работах. Как правило, для таких изданий характерно наличие УДК, ISBN, объем тиража, они общедоступны (магазин, библиотеак, товарищь и т.п.). Хотелось бы к этому вопросу подойти с юридической точки зрения. То есть каковы юридические критерии признания печатного материала печатным изданием. И обладает хоть одним из этих критерием ЖКК? (2) То что ЖКК являются документацией к программе не снимает вопроса. Например, на западе есть вполне законная практика ссылки на РАБОЧИЕ материалы автора, с которых еще не высохли чернила. Естественно, если он познакомил тебя с ними. ___________ С уважением, vdi.
BorisG 6 - 05.05.2004 13:26 | (5) Именно с этой точки зрения документация, издаваемая 1С не является полноценным печатным изданием, нет у нее ни тиража, ни УДК, ни ISBN, не являются они и общедоступными. Она выпускается в соответствии с со стандартами ЕСПД. В соответствии с чем и требуется для использования этих материалов ПИСЬМЕННОЕ согласие 1С. Что, впрочем и написано в ЖКК. PS: Официальная документация Мicrosoft (doc kit), кстати, имеет такой же статус.
vdi 7 - 06.05.2004 07:50 | В каждой ЖКК дословно написано "... не допускать копирования программ и документации без письменного разрешения фирмы 1с". Как видим, здесь речь идет о праве тиражирования документации. Меня же интересует другой вопрос. Нарушаю ли я права фирмы 1с, если создаю собственное методическое пособие с целью его дальнейшего распространения. Например, в области научных публикаций запросто допускаются статьи (в широком смысле) без ссылок на какие-либо источники. С одной оговоркой: все, что ты предлагаешь в статье, является новым словом в науке. Однако любые предложения рождаются не из воздуха. Они основаны на базовых знаниях, которыми обладает автор. Вот на источники базовых знаний ссылаться совсем не обязательно – это просто инструменты, с помощью которых ты сказал нечто новое. И никого не интересует, откуда ты получил базовые знания.
3V 8 - 06.05.2004 08:35 | (7) а что вы, уважаемый, решили гениального написать? если не секрет конечно? . просто не так давно сам писал две дипломных работы на тему 1С и ознакомился с образцом уже защищенного диплома по ЗиК, дык читал, плякал и смеялся, половина диплома было взято с ЖКК, а остальное своими словами и с www.1C.ru о самой фирме, и нигде в дипломе не было указания на истоник...
BorisG 9 - 06.05.2004 09:47 | (8) Авторское право в России еще не докатилось о дипломных работ ;-) А вот научные уже могут и не прокатить... (7) На самом деле нарушаешь. Но... у юристов 1С просто ПОКА не доходят руки до издательств, выпускающих книги с нарушением их авторских прав... Хотя единичные примеры уже есть. Так что каждый для себя решает сам... нарушать или не нарушать... и как договариваться с издательством. ИМХО, проще получить разрешение.
vdi 10 - 07.05.2004 07:37 | BorisG, честно говоря, я очень надеялся на Вас. Упаси Боже, это не упрек! Ваши замечания достаточно ценны. Тем не менее, все высказанные соображения мне известны. Но они не позволяют найти правильное решение. Нужны четкие юридические критериии. Очевидно, я не могу популяризировать секретные данные. Но, что мешает мне изложить содержание технической документации, например, в стиле русского народного эпоса. Ведь здесь начисто отсутствует какое-либо копирование (тиражирование документации), о котором предупреждает 1с.
BorisG 11 - 07.05.2004 08:00 | (10) На самом деле четких критериев в нашем законодательстве нет. И судебной практики пока очень мало. Экспертизы же - дело весьма субъективное. Почему и без больших проблем выходит фактически плагиат. Относительно написания в стиле... фактически никто этого не запрещает. Да и не может запрещать, ибо нет в практике защиты прототипов.


Условия обмена v7.7 на v8.0 ? | База знаний | mista.ru

Условия обмена v7.7 на v8.0 ?

Denis Nsk 05.05.2004 06:56 | Подскажите какие условия апгрейда с 1С 7.7 на 1С 8.0? Раньше, кажется, требовали Ключ и первые страницы ЖКК. А сейчас как? Еще интересует вопрос, установочные дискеты требуется предъявлять? Мне один чел сказал, что нужно предъявлять хотя бы наклейки. Вот и паримся. Дискет два комплекта и толком использовать боимся после его слов.
kadr 1 - 05.05.2004 07:00 | Помоему нет никаких условий - распространение восьмерки абсолютно не связано с семеркой, по крайней мере мне так франчи говорили...
Denis Nsk 2 - 05.05.2004 07:25 | А цена полная или для владельцев 7.7 разница в цене? Спасибо.
kadr 3 - 05.05.2004 07:26 | (2) Цена абсолютно полная. Я же говорю, что распространение 8-ки не как не связано с 7-кой
BorisG 4 - 05.05.2004 07:29 | (1) Да... Советничек... Это какие же франчи так говорили? Не знаешь, лучше не свисти. (0) Условия апгрейда восьмерки, пока Управление Торговлей, изложены в письме 2329, сдается ТОЛЬКО анкета, а вот ключик и дистрибутивы (в отличие от апгрейда семерки между собой) НЕ СДАЮТСЯ (как в свое время было с шестеркой), и заполняется заявление от организации (форму заявления и образец заполнения см. в Приложении 2 к данному письму). Наклеек, книжек не требовалось сдавать никогда. http://www.1c.ru/news/info.asp?id=2329 Относительно Управления персоналом, для него апгрейды не предусмотрены.
BorisG 6 - 05.05.2004 07:43 | (5) А в (3) что пишешь? Не знаешь, лучше помолчи, и не вводи людей в заблуждение. ............... "Человек - это существо, которое охотнее всего рассуждает о том, в чем меньше всего разбирается" (с) Станислав Лем
BorisG 7 - 05.05.2004 07:47 | +4 К сказанному... На сайте восьмерки есть калькулятор, и можно сразу посчитать стоимость приобретения, с учетом апгрейда с разных продуктов: http://v8.1c.ru/price/calc.htm


Есть ли какой серийник у конфиги? | База знаний | mista.ru

Есть ли какой серийник у конфиги?

YarD 16.09.2004 15:44 | Франч пел что у v8 и сама конфига имеет серийник или идентификатор, поэтому можно вычислить кто ее дал. Так ли это?
Волшебник 1 - 16.09.2004 15:54 | У каждой базы есть уникальный идентификатор. У конфигурации он тоже есть.
Aнтон NEW edit 2 - 16.09.2004 16:11 | А во внутрях конфиги (8.0) у конфиги БД и основной конфиги идентихвикаторы - разныя?
YarD 3 - 16.09.2004 16:19 | И по идентификатору можно вычислить кто ее дал/продал? У 1С есть такая база? Я так понимаю это появилось в v8, потому как в семерке об этом речи не шло.
Волшебник 4 - 16.09.2004 16:26 | (2) сложно сказать. (3) Вряд ли такая база есть, но никто гарантий не дает. Но даже если она есть, то идентификатор можно поменять, пересоздав конфигурацию и объединив с типовой, поэтому смысла в этой базе немного.
Aнтон NEW edit 5 - 16.09.2004 17:33 | Его можно править руцями? Как?
Волшебник 8 - 16.09.2004 17:36 | HEdit
Aнтон NEW edit 9 - 16.09.2004 17:41 | А я уж надеялся на внутр ср-ва платформы :(
BorisG 10 - 16.09.2004 17:42 | Да... приведу несколько тезисов. 1. База серийных номеров у 1С есть, и какому из франчей попал какой номер, 1С может узнать запросто. 2. Каждый ключик имеет уникальный HASPID. Сказанное относится как к семерке, так и к восьмерке. Дальше додумывате сами, на сколько у кого хватает фантазии ;-)
Волшебник 13 - 16.09.2004 18:09 | Не путайте серийный номер, HASPID и идентификатор конфигурации. Это все разные вещи.
YarD 15 - 17.09.2004 13:15 | Да я не платформу спрашивал. И не про HASP. Франч сказал, что сама конфигурация имеет идентификатор. И по нему можно вычислить кому она была передана. Вот я и поинтересовался так ли это.
F427 16 - 17.09.2004 13:39 | Все можно узнать у 1С....
Фокусник 17 - 17.09.2004 13:42 | (16) А скажут ? :)
BorisG 18 - 17.09.2004 13:59 | (17) Нет, не скажут ;-) (15) А франчу надо поставить 5 баллов... за развешивание лапши на уши. Остальное я сказал в (10) ;)))
F427 19 - 17.09.2004 16:55 | Скажут... Но их за это лишат статуса фра, если потом стукнуть в 1С
BorisG 20 - 17.09.2004 16:58 | (19) Что-то ты совсем не читаешь... Кого лишат статуса фра? 1C? LOL.
F427 21 - 17.09.2004 17:19 | Статуса фра лишат тех фра, кто скажет номер... А номер конфы совпадает с номером на регистрационной карточке... Если украдешь конфу - надо перебивать номер...


2 Волшебник - Сертификационные вопросы по 8.0 | База знаний | mista.ru

2 Волшебник - Сертификационные вопросы по 8.0

Львенок 21.05.2004 14:34 | Столкнулся с рядом весьма двусмысленных (на мой взгляд) вопросов в "Комплект вопросов сертификационного экзамена на знание основных механизмов платформы «1С:Предприятие 8.0» с примерами решений". Например мы все разошлись во мнениях по вопросу: 8.22 Какие высказывания о дереве значений верны? 1. Дерево значений - это элемент управления, размещаемый в экранной форме. 2. Дерево значений может выступать как тип значения табличного поля. 3. Верны оба высказывания. Причем тремя разными людьми были высканы три разных варианта. ;) конфигуратор не сильно нам помог. Может быть сам Стас подскажет, правильный ответ? ___ Искренне Ващ, Львенок.
ezh 2 - 21.05.2004 15:51 | элемента управления ДеревоЗначений нет. есть табличное поле с установленным свойством Дерево (свойство доступно тогда, когда тип значения - деревозначений). так что правильный ответ 2.


Задание на 1С:Специалисть 8.0 | База знаний | mista.ru

Задание на 1С:Специалисть 8.0

Kneyp
30.07.2004 21:59 		Задача по 1С:Специалист 8.0

В качестве исходной использовать каркасную конфигурацию. Сделки по покупке и продаже номенклатуры могут быть оформлены в разных валютах. Необходимо добавить в приходные (ПН) и расходные накладные (РН), реквизит Валюта. При проведении ПН и РН все денежные показатели должны приводиться к учетной валюте (доллары). Это касается движений по регистру «ОстаткиНоменклатуры» и «Продажи». Данные для пересчета брать из регистра сведений Валюты. При проведении по регистру «ОстаткиНоменклатуры» контроль остатков товара и себестоимость списывать по партиям принцип ФИФО.

В БухУчете организовать новый вид учета: Валютный. Учет должен предполагать возможность ведения бухучета не только в валюте учета, но и в других валютах на отдельных счетах. Допускается наличие корреспонденции валютного и невалютного счета в одной проводке. Должна быть обеспечена сервисная возможность автоматического расчета суммы проводки по валютной сумме и курсу в документе «Операции». Предусмотреть ведение многовалютного учета на счете «Касса». Сделать новый документ «Расчет курсовых разниц», который в момент проведения должен анализировать валютный остаток по каждой валюте по счету Касса и остаток в валюте учета. В случае, если результат от умножения валютной суммы на курс валюты (на момент проведения документа) больше чем эквивалент в валюте учета, необходимо отразить в учете положительную курсовую разницу:
Дт.Касса/Кт.Капитал
В обратном счлучае – отрицательную курсовую разницу
Дт.Капитал/Кр.Касса
Отчет который поможет проанализировать правильность остатков в кассе в валюте учета на выбранную пользователем дату.

Валюта Остаток в валюте Остаток в валюте учета Курс Расчет остатка в валюте учета Курсовая разница
1 2 3 4 5 6
Доллар
Евро
Итоги Х

1 – Наименование валюты
2 – остаток в валюте на счете касса
3 – остаток в валюте учета на счете касса по выбранной валюте
4 – курс валюты на дату формирования отчета
5 –расчетный остаток в валюте учета, равный значению колонки 2, умноженному на значение колонки 4
6 – Разница, рассчитываемая как значение колонки 5 и значение колонки 3

Зарплата
Сотрудники могут иметь оклад или тариф (начисляются только по отработанным дням) плюс ежемесячная премия процент (от суммы оклада, заработанного в прошлом месяце или суммой)
Для каждого сотрудника начисление З/П ведется в долларах, а выплачивается З/П в любой из валют, следовательно выплату надо автоматически пересчитывать в валюту учета (доллары).
Для каждого расчетного периода надо предусмотреть ввод автоматически расчитываемого начального сальдо (задолжность организации перед сотрудниками в учетной валюте доллары отдельным документом). Отчет расчетныйЛисток для вывода результатов в учетной валюте.

Сотрудник Вид расчета Нач. Сальдо Начислено Выплаты
Иванов 100 200 270
Оклад 120
Премия 80

Петров 150 150
Оклад 150
Итоги 100 350 420


Сертификация 1с:профессионал | База знаний | mista.ru

Сертификация 1с:профессионал

Spiderman 29.07.2004 21:17 | Собираюсь прпоходить сертификацию 1 с профессионал. но из информации на сайтеничего понял. Очно это или заочно. Как это будет происходить ? пожалуй ста расскажите подробнее. Если есть люди из Питера дайте конкретные адреса. заранее спасибо
Волшебник 1 - 29.07.2004 21:43 | Очно. Но пройти ее можно не только в фирме 1С, но также и авторизованных центрах сертификации.
Майк 2 - 29.07.2004 22:05 | Питерские АЦС: http://www.1c.ru/prof/acs-list.jsp?city=%D1%E0%ED%EA%F2-%CF%E5%F2%E5%F0%E1%F3%F0%E3
Тот 13 - 30.07.2004 16:04 | Spiderman, вижу, что ты решил всеръёз заняться 1С. Есть одна вещь, без которой тебе никак не обойтись. Все, кого можно считать специалистами по 1С - её давно имеют. Узнать об этой вещи, а также приобрести её, можно по адресу: http://1c.klim.org/clubcd.php Без неё стать специалистом практически невозможно.


Бухгалтерия для комьютерщика | База знаний | mista.ru

Бухгалтерия для комьютерщика

Ajrat 12.07.2004 11:28 | Видел в продаже книжку "Компьютер для бухгалтера". А нет ли в сети чего либо типа "Бухгалтерия для компьютерщика", что бы разобраться с основами бухгалтерии для програмирования на 1С.
Leo 1 - 12.07.2004 11:34 | Почитай сначала тут: http://businessuchet.ru/ А потом вместо практикума тут: http://firststeps.ru Кстати, еще не кисло купить какой-нить бумажный учебник по названием "Бухгалтерский учет", в ближайшем книжном магазине тебе посоветуют чё-нить
alexk 14 - 12.07.2004 14:36 | Совсем по-простому для чайников в бухгалтерии: http://www.alef.ru/articles/advises/index.html
ws_mason 19 - 13.07.2004 05:25 | Вот посмотри: http://www.erpg.ru/theory/buh4it/index.htm


Задача2 сертификация 1с77 | База знаний | mista.ru

Задача2 сертификация 1с77

MAAlekseev
25.05.2004 15:39 		Люди, кто трудится над решением задач. Как реализовать?
Табличная часть документа может принимать два вида, в зависимости от установленного переключателя. При первом варианте в табличную часть включаются сведения о клиентах-заимодавцах в разрезе заключенных с ними договоров займа (клиент, договор, сумма, валюта, рубл покрытие). При втором варианте в табличную часть включается информация по заимодавцам без раз-бивки по договорам и валютам (клиент, сумма договора). Через видимость не получается обработать суммирование договоров. Извините за бестолковость, но кто решал поймет.....
Если Кратко = Перечисление.Булево.Да Тогда
Форма.Отметить1.Видимость(0);
Форма.Договоры.Видимость(0);
Форма.Отметить2.Видимость(1);
Форма.Сумма2.Видимость(1);
Форма.Сумма.Видимость(0);
ИначеЕсли Кратко = Перечисление.Булево.Нет Тогда
Форма.Отметить1.Видимость(1);
Форма.Договоры.Видимость(1);
Форма.Отметить2.Видимость(0);
Форма.Сумма2.Видимость(0);
Форма.Сумма.Видимость(1);
КонецЕсли;
Таня
1 - 25.05.2004 15:51 		Я делала через ТЗ и сворачивала
MAAlekseev
2 - 25.05.2004 16:01 		Через таблицу значений можно, т.е. вызывать каждый раз метод когда переходим на краткий формат? Тогда не очень понятно как это будет сохраняться при следующем открытии документа и формировать проводки тогда по активной форме? или как... Таня ответь поподробнее если справилась, листинг не прошу :) в общих словах - схему
Таня
5 - 25.05.2004 16:12 		Процедура Заполнить()// я в переключатель вставляла
УдалитьСтроки();
Если Дог = 1 Тогда
Форма.Договор.Видимость(1);
Форма.Сумма.Видимость(1);
Форма.Валюта.Видимость(1);
Формирование();
ЗагрузитьТабличнуюЧасть(Таб);
КонецЕсли;
Если Дог = 2 Тогда
Форма.Договор.Видимость(0);
Форма.Сумма.Видимость(0);
Форма.Валюта.Видимость(0);
Формирование();
Таб.Свернуть("Клиент", "РублевоеПокрытие");
ЗагрузитьТабличнуюЧасть(Таб);
КонецЕсли;
КонецПроцедуры
Таня
6 - 25.05.2004 16:24 		в общих чертах опиши, как изменял Выписку в 1 задании. Через поступлениеПоДокументам делал? если да, то как бороться с повторным выбором договора, если в первой строке уже есть валютный договор, а второй выбираемый будет рублевый?
MAAlekseev
8 - 26.05.2004 10:38 		выписка-поступление по документам модуль формы
545строка УчитыватьНП = ?((ДокВид = "СчетФактура") или (ДокВид = "ДоговорЗайма") , 0, глПризнакУчетаНалога(Док, "НП"));//чтобы не учитывать налог с продаж
586строка ИначеЕсли ДокВид = "ДоговорЗайма" Тогда
Кол = ?(Док.КоличествоСтрок() = 0, 1, Док.КоличествоСтрок());
ТЗ.НоваяСтрока();
ТЗ.КоррСчет = ?(ОплатаДоговора = 2, Сч66_33, Сч66_3);
ТЗ.Субконто1 = Док.Контрагент;
ТЗ.Субконто2 = Док.Договор;
ТЗ.Субконто3 = "";
Если (ЦеныВДоговоре = 2) и (ОплатаДоговора = 1) Тогда
ТЗ.Приход = Док.Сумма*Док.Курс;
Иначе
ТЗ.Приход = Док.Сумма;
КонецЕсли;//заполняем таблицу значений
686строка Меню.ДобавитьЗначение("ДоговорЗайма","Договор займа");//добавляем в меню поступление по документам договор займа
4строка Перем Сч66_33, Сч66_3//добавляем переменные счетов
1023строка Сч66_3 = СчетПоКоду("66.3");
Сч66_33 = СчетПоКоду("66.33");//раскрываем содержание переменных
Вроде все - теперь заполняем выписку по документам, выбирая договор займа (реквизиты шапки: контрагент,договор,курс,валюта,сумма и др). Выбираем рублевый договор займа, а в следующей строке выписки можно выбрать валютный договор займа.
MAAlekseev
10 - 26.05.2004 12:00 		Для обработки курса и изменения даты документа договора займа
Функция Установить()
Если Валюта.Выбран() = 1 Тогда
Курс = Валюта.Курс.Получить(ДатаДок);
КонецЕсли;
КонецФункции
//----------------------------------------------
Процедура ИзменитьДату()
Если Валюта.Выбран() = 1 Тогда
Установить();
КонецЕсли;
КонецПроцедуры
Таня
11 - 04.06.2004 13:55 		MAAlekseev, я тоже сначала так сделала, а потом если вводить операцию по возврату займа, то ты как сделал?
а я все переделала, добавила просто новую кнопку с менюхой и двумя документами - договор займа для поступления и закрытие договора займа - для возврата.
вот теперь сижу думаю, в третьей задаче как делать?


1С: Специалист (платформа v8) - Задача по расчету з/п | База знаний | mista.ru

1С: Специалист (платформа v8) - Задача по расчету з/п

Rom
08.06.2004 17:32 		Кто решал задачу по зарплате на экзамене на специалиста по платформе v8? Подскажите, плз, вариант решения:
Начислить зарплату менеджерам. В организации используется повременно-премиальная система оплаты труда по часам.
Премиальная часть зарплаты зависит от суммы продаж, выполненных данным менеджером в прошлом месяце.
Если менеджер осуществил продаж на сумму больше нормы за месяц, то ему положена премия:
• если норма превышена на 1/2 - 20% от оклада,
• если норма превышена на 3/4 - 30% от оклада,
• если норма превышена на 100 процентов - 50% от оклада.
Результаты расчетов должны выполняться в общем модуле.
Разработать "Отчет по премиям". Формат отчета:

Сотрудник 20% 30% 50%
<Сотрудник> <Сумма> <Сумма> <Сумма>
Итого <Итого> <Итого> <Итого>

Обязательно использовать перерасчет: при изменении результата начисления Оклада, необходимо пересчитать записи регистра расчетов, содержащие вид расчета "Премия". Пересчитывать необходимо только те записи, которые соответствуют сотруднику (работающему в каком-то подразделении на какой-то должности), у которого изменился результат начисления оклада. Проверить результат работы перерасчета с помощью запроса в обработке «ПроизвольныйЗапрос».
mic23
1 - 08.06.2004 17:42 		вот общий модуль
Функция рзРассчитатьНачисления(СтрокаДвижений,Индекс,СуммыБазы ="",ИмяСумРесурса="",ВремяПоФактическомуПериодуДействия="",НормаВремени="")
ОсновныеНач = ПланыВидовРасчета.ПланВидовРасчетаОклад;
ВидРасчета = СтрокаДвижений.ВидРасчета;
Если ВидРасчета=ОсновныеНач.Оклад Тогда
НормаЧасов=НормаВремени[Индекс].Значение;
Возврат СтрокаДвижений.Размер*ВремяПоФактическомуПериодуДействия[Индекс].Значение/НормаЧасов;
Иначе
СтрокаБазы= СуммыБазы.Получить(Индекс);
Возврат СтрокаБазы[ИмяСумРесурса]*СтрокаДвижений.Размер/100;
КонецЕсли;
КонецФункции

Процедура рзРассчитатьЗаписиРегистра(НаборЗаписейРегистра,Тип="") Экспорт
МенеджерРегистра = РегистрыРасчета.ОснНач;
Отбор = НаборЗаписейРегистра.Отбор;
Если Тип="Первичные" Тогда
ТаблицаФактВремени = МенеджерРегистра.ПолучитьДанныеГрафика(Отбор, ВидПериодаРегистраРасчета.ФактическийПериодДействия);
ТаблицаНормВремени = МенеджерРегистра.ПолучитьДанныеГрафика(Отбор, ВидПериодаРегистраРасчета.ПериодДействия);
Для каждого СтрокаРегистра Из НаборЗаписейРегистра Цикл
Если СтрокаРегистра.ВидРасчета=ПланыВидовРасчета.ПланВидовРасчетаОклад.Оклад Тогда
СтрокаРегистра.Результат = рзРассчитатьНачисления(СтрокаРегистра,НаборЗаписейРегистра.Индекс(СтрокаРегистра),,,ТаблицаФактВремени,ТаблицаНормВремени);
КонецЕсли;
КонецЦикла;
Иначе
Ресурсы = Новый Массив(1);
Ресурсы[0]="ОснНач.Результат";

Измерения = Новый Структура("ФизЛицо");
Измерения.физлицо = "ОснНач.ФизЛицо";

ТаблицаБазы = МенеджерРегистра.ПолучитьБазу(Отбор, Ресурсы, Измерения);

Для каждого СтрокаРегистра Из НаборЗаписейРегистра Цикл
Если СтрокаРегистра.ВидРасчета<>ПланыВидовРасчета.ПланВидовРасчетаОклад.Оклад Тогда
СтрокаРегистра.Результат = рзРассчитатьНачисления(СтрокаРегистра,НаборЗаписейРегистра.Индекс(СтрокаРегистра),ТаблицаБазы, "Результат");
КонецЕсли;
КонецЦикла;

КонецЕсли;
КонецПроцедуры

вот обработка перерасчетов
Процедура КнопкаВыполнитьНажатие(Элемент)
Запрос = новый запрос (
"ВЫБРАТЬ
| ОснНачПерерасчет.ВидРасчета как ВР,
| ОснНачПерерасчет.ФизЛицо как ФЛ,
| ОснНачПерерасчет.ОбъектПерерасчета как Док
|ИЗ
| РегистрРасчета.ОснНач.Перерасчет КАК ОснНачПерерасчет");
РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выбрать();

Пока Выборка.Следующий() Цикл
Выборка.Док.ПолучитьОбъект().Перерассчитать(Выборка.фл);
НаборЗаписейПерерасчета = РегистрыРасчета.ОснНач.Перерасчеты.Перерасчет.СоздатьНаборЗаписей();
НаборЗаписейПерерасчета.Отбор.объектПерерасчета.Значение=Выборка.Док;
НаборЗаписейПерерасчета.Отбор.ФизЛицо.Значение=Выборка.ФЛ;
НаборЗаписейПерерасчета.Очистить();
НаборЗаписейПерерасчета.Записать();
КонецЦикла;
КонецПроцедуры

вот модуль объекта дока по расчету з\п
Процедура ОбработкаПроведения(Отказ, Режим)
Если НЕ отказ Тогда
Для Каждого ТекСтрокаСписок Из Список Цикл
// регистр ОснНач
Движение = Движения.ОснНач.Добавить();
//Свойства
Движение.Регистратор = Ссылка;
Движение.ПериодРегистрации = ПериодРегистрации;
Движение.ПериодДействияНачало = ТекСтрокаСписок.ДатаНачала;
Движение.ПериодДействияКонец = ТекСтрокаСписок.ДатаОкончания;
Движение.БазовыйПериодНачало = ТекСтрокаСписок.ДатаНачала;
Движение.БазовыйПериодКонец = ТекСтрокаСписок.ДатаОкончания;
Движение.ВидРасчета = ТекСтрокаСписок.ВидРасчета;
//Измерения
Движение.ФизЛицо = ТекСтрокаСписок.Сотрудник;
//Ресурсы

//Реквизиты
Движение.График = ТекСтрокаСписок.График;
Движение.Размер = ТекСтрокаСписок.Размер;
КонецЦикла;
// записываем движения регистров
Движения.ОснНач.Записать();
НаборЗаписей = Движения.ОснНач;

//Расчет базовых записей
рзРассчитатьЗаписиРегистра(НаборЗаписей,"Первичные");

//Запишем результат
НаборЗаписей.Записать(Истина, Истина);

//Расчет премий и надбавок
рзРассчитатьЗаписиРегистра(НаборЗаписей,"Вторичные");

//Запишем результат
НаборЗаписей.Записать(Истина, Истина);

КонецЕсли;
КонецПроцедуры

Процедура Перерассчитать(ФизЛ) Экспорт
НаборЗаписей = РегистрыРасчета.ОснНач.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.регистратор.значение = Ссылка;
НаборЗаписей.Отбор.Физлицо.Значение = ФизЛ;
НаборЗаписей.Прочитать();

рзРассчитатьЗаписиРегистра(НаборЗаписей, "Вторичные");
НаборЗаписей.Записать(Истина,Истина);
КонецПроцедуры


Литература для первых шагов в 1С | База знаний | mista.ru

Литература для первых шагов в 1С

Cross 16.05.2004 01:28 | Товарищи, душа жаждет чего-то нового. Подскажите литературку ля получения основных знаний для успешной работы. Заранее премного благодарен!!!
It is me 2 - 16.05.2004 01:37 | В любом случае спрашивай Митичкина - не прогадаешь :)
Волшебник 4 - 16.05.2004 02:12 | Тогда все просто, даже покупать ничего не надо. http://www.mista.ru Учебник по 1С - http://www.mista.ru/tutor_1c Курс лекций - http://www.mista.ru/kurs1c Статьи - http://www.mista.ru/articles1c/index.htm Ссылки - http://www.mista.ru/links_1c.htm


Подготовка к экзамену на 1С:Специалист по 8.0 | База знаний | mista.ru

Подготовка к экзамену на 1С:Специалист по 8.0

Том 28.05.2004 20:17 | Вознамерился сдать экзамен на 1С:Специалиста 1С:Предприятия 8.0. Времени на подготовку осталось в обрез, а сдать -то хочется. Подскажите пожалуйста, где в инете можно найти материалы (задачи с примерами решений и т.п., кроме http://www.erpg.ru/(я там уже был).
bazvan 1 - 28.05.2004 20:22 | http://edu.1c.ru/1CEdu/index.asp стоит копейки НО ОЧЕНЬ ПОЛЕЗНЫЙ
bazvan 3 - 28.05.2004 20:31 | Так там курс за неделю можно пройти. Только работай
Непонятливый 8 - 29.05.2004 17:37 | Тока не сдавай Аксенову Д.О. (среднего роста, темный, в очках) Завалил в Новосибе седня кучу народа. Главная формулировка: "Вы не умеете писать запросы, поэтому идите нах!" Фатальное незнание - использование в запросе даты документа вместо момента времени, и использование циклического перебора результатов. Таблицы значений рулять! А. И еще он долго и упорно доказывал, что в требованиях к экзамену на сайте 1С в списке _критических_ ошибок было про запросы. Он долго искал где, но не смог показать ни упоминаний, ни ссылок на методические указания. Послезавтра зае@ним аппеляцию - кроме этих спорных запросей он не придирался ни к чему. А. Такому монстру Торговлю решили просто не сдавать и поэкономить бабло...


С чего начинать изучение 1С | База знаний | mista.ru

С чего начинать изучение 1С

Nata- 25.05.2004 09:43 | Здравствуйте! Подскажите, пожалуйста, с чего начинать изучение 1С, я только недавно познакомилась с этой программой. Спасибо Всем за помощь.
Антон 1 - 25.05.2004 10:12 | Начинать изучение по работе или программированию?
Волшебник 2 - 25.05.2004 10:16 | (0) www.mista.ru/tutor_1c - программирование 7.7
Макс 8 - 26.05.2004 10:38 | (0) Для начала определеись с какой компоненты хочется начать, а потом потиху и во все остальное будешь въезжать... Для меня самым простым оказался оперативный учет. Главное понять это все дело и не бояться. Как говорит директор мой - для начала без 0.5 не въедешь. :) зато потом должно покатить, если понравится.


Нужна конфигурашка 1с | База знаний | mista.ru

Нужна конфигурашка 1с

neon 23.05.2004 23:51 | Люди помогите мне нужна конфигурашка 1с только обязательно с документацией и простую.У меня во вторник защита курсовой на тему Методы и предопределенные процедуры.Я работаю со 2 курса но в другой сфере и в 1с не шарю совсем.Помогите .Заранее благодарен
Волшебник 1 - 23.05.2004 23:52 | Например, Кадровый учет на сайте www.mista.ru/tutor_1c или "Мини-зарплата". Я слышал, что на них даже дипломы делали. Можно еще заглянуть на 1c.hippo.ru и выбрать любую.


Книги по 1С с примерами | База знаний | mista.ru

Книги по 1С с примерами

Arif 19.05.2004 15:27 | Посоветуйте книгу по 1С с примерами. В электронном виде не могу получить полную информацию.
Bzzzzz 1 - 19.05.2004 15:53 | А чем тебя www.mista.ru не устраивает?
psk21office 2 - 19.05.2004 15:53 | Http://1c.hippo.ru/test/lib
¶ 4 - 19.05.2004 20:16 | Бартеньев О.В. "1С:Предприятие. Программирование для всех". М., Диалог-МИФИ, 2002.
connect_ 5 - 19.05.2004 21:30 | Усиков Т.Н. 1С:Предприятие. Эффективное программирование. Сейчас занимаюсь. Все дается с нуля. Разжевывается и в рот кладется. Только глотай. Книга читается за два дня. Потом можно идти дальше. Скоро возьмусь за (4).


Подскажите книжку по 1С | База знаний | mista.ru

Подскажите книжку по 1С

Череп 12.05.2004 12:13 | Нужно научиться программингу в сжатые сроки. Только книжки желательно в электронном варианте если можно высылайте на VSer@ngs.ru
romix 2 - 12.05.2004 12:24 | Если сжатые, то рекомендую попробовать обучающий видеокурс. Если есть родной курс по конфигуратору от 1С, то лучше его. А то один курс другому - рознь, от Медиа-2000 за 150 рублей диск лучше не брать, я обломался на бухии (там девушка чему-то очень четким, красивым и уверенным голосом учит, но сама толком 1С не знает, и просто видимо читает хелп и пытается повторять мышкой то что там написано). :-)
romix 3 - 12.05.2004 12:27 | А вообще надо знать какой-нибудь Вижуал Бейсик или другой простенький язык - 1С использует те же приемы программирования и ключевые слова (только по-русски). Но по документации 1С понять их нельзя - их надо просто изначально знать (быть хотя бы начинающим программером на любом другом языке).
Череп 4 - 12.05.2004 12:27 | Не, в изучении языков программинга и баз данных я уже немного поднаторел - мне просто надо что-нить толковое, где написано как поставить, настроить, создать пару-тройку баз и т.п.
Череп 5 - 12.05.2004 12:30 | (3)Бейсики(разные), Паскаль, Делфи, С++, Билдер, Фортран, яваскрипт, ПХП + майскл для начала хватит?
Череп 6 - 12.05.2004 12:36 | Так что, ни у кого нету? Кстати, если надо, то могу поделиться инфой по другим языкам программирования.
Дудка ахинеи 7 - 12.05.2004 14:47 | Сидит наверно Череп и думает, во я Хироу, ща клич кину, книжек покидают, буду читать и писать на 1с. Гордится наверно от самой идеи... а ты поставь задачу и делай.... ковыряй, ковыряй и еще раз ковыряй... там и научишься... (3)я те скажу ниче там знать не надо...
Череп 8 - 12.05.2004 16:15 | Пардон за наглость, просто меня добил совет (3) - обучающий видеокурс. Интерессно, кто-нить чему нибудь хорошему оттуда научился?
gr13 9 - 12.05.2004 16:22 | пощи по форуму, тут много чего было


А вот скажите, считается ли неэффективным... | База знаний | mista.ru

А вот скажите, считается ли неэффективным...

Львенок 08.05.2004 11:40 | В экзамене по оперативной компоненте 7.7, во второй задаче нужно на основании данных оборотного регистра И: поставщик, отдел, товар; Р колич, стоимость: а) Создать по одной приходной накладной по каждому поставщику, приходующей весь его товар на склад. б) За каждый день создать накладную на перемещение товара проданного за этот день со склада в отдел где оно продавалось. Так вот мне интересно - в пунктах а) и б) берется информация из одного регистра, но с разными группировками. В а) Поставщик, Товар; в б) Дата, Отдел, Товар. В принципе достаточно одного запроса с последующими свертками таблиц. Но удобнее сделать два запроса. При этом удобнее программировать и улучшается читабельность программы. Так вот считается ли это неэффективной реализацией (можно было обойтись одним запросом и геморроем, а можно двумя и обойтись без геморроя)? Т.е. могут ли снять сколько-то там баллов за это? ___ Искренне Ваш, Львенок.
BorisG 1 - 08.05.2004 11:51 | Главное на экзамене - работающий модуль. Поэтоту в первую очередь стоит делать так, как лучше знаешь и меньше проблем. Как можно делать, можешь просто прокомментировать устно... или попробовать реализовать отдельно, если останется время. Преподаватели... они тоже люди... и все понимают, и, между прочим весьма неплохо. Это не институт. Сам слышал не один раз комментарий преподавателей: "Я вижу, что он (она) знает... но задача не выполнена... аттестовать не могу" Да и так уж важны баллы? Сертификат выглядит одинаково, независимо от того, пять получено, или три ;-) Что недопустимо делать, написано в требованиях.
Valery 2 - 08.05.2004 11:52 | Конечно два запроса читать удобно, но несмотря на удобство чтеня однозначно два раза сканировать базу неэффективно и этот аргумент конечноже перевесит удобство чтения. С моей точки зрения за это снять могут, покрайней мере должны.


Вопрос о заключении Договора Франчайзинга (Украина) | База знаний | mista.ru

Вопрос о заключении Договора Франчайзинга (Украина)

Сергей
06.05.2004 12:08 		Фирма АББИ Украина предоставляет возможность заключения Договора Франчайзинга. Есть одна особенность - необходимость преобретения некой NFR версии. Теоритечиске не трудно представить что это за версия, но хотелось бы услышать от людей которые сталкивались с этим.
Заранее огромное спасибо
BorisG
2 - 06.05.2004 14:32 		А что смущает в приобретении NFR версии? Действительно, есть такой пункт в договоре...
"Теоритечиске не трудно представить что это за версия..."
Хотелось бы знать, что подразумевают под этим люди, которые знают это только "теоретически"? ;-)

PS: А договор франчайзинга запросить не судьба?
Просто отправь запрос на fran@1c.ru (кстати, на сайте 1С об этом написано).
Или сами материалы вышлют, или вышлет 1С-Украина.
OctoberHammer
3 - 06.05.2004 15:37 		А в чем проблема?
НФР по-любому покупать нужно. АБИ это, или Альфа-Ком, или Диск.
Сергей
4 - 06.05.2004 20:50 		Ответ BorisG
Теоритечиске не трудно представить что это за версия..."
Хотелось бы знать, что подразумевают под этим люди, которые знают это только "теоретически"? ;-)

Я под этим подразумеваю, то что эта версия предназначина для обучени япользователей и для внутренего использования - внутренего учета.
Но я могу вполне неплохо обучиться и на базовой версии конфигурации, а конфигурация для внутренего использования (ведение внутренего учета) у меня уже есть.

Я просто хотел узнать может ктото видел эти NFR версии и знает в чем их отличие.
Эти ж версии денег стоят. И хотелось бы узнать стоит ли выбрасывать на них деньги???

Ответ OctoberHammer
Есть еще один вариант заключить вместо Договора Франчайзи заключить партнерский договор, который не предусматривает необходимости покупать NFR-версию.
Может кто то скажет что это такая за чудо версия. Может лиона пригодиться, или можно и без нее обойтись и заключить партнерский договор.
Я впринцыпе согласен заплатить за нее деньги, но хотелось бы изнать за что я плачу.
Всем заранее огромное спасибою
BorisG
5 - 06.05.2004 21:01 		(4) "может ктото видел эти NFR версии"
Ну видел ;-) У меня есть почти все, правда украинских нет за ненадобностью ;-)

Не питай иллюзий. Эти версии НИЧЕМ от простых версий не отличаются. Т.е. они ПОЛНОЦЕННЫЕ, только по спец. цене для партнеров. Бери прайс-лист 1C и смотри.
Относительно партнерского договора вместо франчевого... пожалуйста... но есть франчевый ассортимент, продавать который не сможешь без соответствующего договора.


сертификационные задания | База знаний | mista.ru

сертификационные задания

Александра 05.05.2004 14:23 | Здравствуйте, где мне найти тексты сертификационных заданий, чтобы порешать задачки?
NastyFrog 1 - 05.05.2004 14:28 | ИТС
gr13 3 - 05.05.2004 15:24 | www.1c.ru
NastyFrog 6 - 05.05.2004 17:10 | Для Светы. ИТС - исправительно-трудовой санаторий. Душ Шарко, егерское бельё, габер-суп, в мокрые простыни обрачивают, все дела. Вас даже без направления примут - в регистратуре пораспрашайте чё нить - и отдельный бокс.
kvm 7 - 05.05.2004 22:29 | (4) Более простые предлагают при приеме на работу. А на экзамене тебе дадут именно такие.
Dionisious 9 - 06.05.2004 09:23 | Для Светы. ИТС - информационно-техническое сопровождение. Ежемесячный диск выпускаемы 1С. Стоит - вроде 25 у.е. На нем много всякого, только там нету текстов сертификационных заданий. Там только примеры вопросов по проффесионалу. А на последних вроде и их нету.
GrayT 10 - 06.05.2004 09:49 | (9)Тесты есть. И дисков теперь два, кажеться 32 вечно зеленых, но можно и по одному
Marinka 11 - 06.05.2004 09:49 | На Майском есть...
GrayT 13 - 06.05.2004 09:54 | http://www.1c.ru/rus/partners/training/questions.htm


люди добрые поможите 1с професионал сдать | База знаний | mista.ru

люди добрые поможите 1с професионал сдать

Doc83
01.05.2004 21:07 		оно скоро, а результат (8,12), нужен список конкретных(!) вопросов и конкретных ответов(!!!)
427
1 - 01.05.2004 21:17 		ДЯТЛООБРАЗНЫЕ
(Picirormes), отряд птиц; по анатомическим особенностям близок к ракшеобразным и воробьиным. Древесные птицы мелких и средних размеров. Гнездятся в дуплах или норах; яйца белые; у большинства Д. птенцы вылупляются голые. По внешнему виду и образу жизни очень разнообразны. 6 семейств: якамары, ленивки, туканы, медоуказчики, бородастики и дятловые. Около 400 видов. Распространены широко; отсутствуют только на Мадагаскаре, в Австралии, Новой Зеландии, Новой Гвинее и Полинезии. Наиболее богато представлены Д. в тропических лесах.

Лит.: Руководство по зоологии, т. 6, М.—Л., 1940; Шульпин Л. М., Орнитология, Л., 1940.

ДЯТЛОВЫЕ
(Picidae), семейство птиц отряда дятлообразных. Длина тела от 8 до 50 см. 3 подсемейства: дятлы (Picinae), дятелки (Picumninae) и вертишейки. Д. — преимущественно обитатели леса, приспособленные к жизни на деревьях. Ноги короткие, с длинными пальцами и острыми когтями. Крепкий клюв и мощная мускулатура шеи, а также жёсткие рулевые перья хвоста, служащие опорой при лазании по деревьям, позволяют дятлам долбить кору и древесину (в поисках пищи или при постройке дупла для гнезда). Дятелки и вертишейки, имеющие мягкие рулевые перья и слабый клюв, либо совсем не долбят древесину (вертишейки), либо могут справиться лишь с самой мягкой, гнилой древесиной (дятелки). Язык у Д. червеобразный, они могут выдвигать его очень далеко при обследовании ходов насекомых под корой или в древесине. Найденное насекомое либо прилипает к языку, смоченному липкой слюной, либо прокалывается, как острогой, острым концом языка. Зелёные Д. и обитатели пустынь — перуанский дятел Colaptes rupicola и южноафриканский дятел Geocolaptes olivaceus — кормятся преимущественно на земле. Гнездятся Д. в дуплах деревьев и гигантских кактусов, обитатели пустынь — в норах или среди камней. В кладке 3—7 белых яиц. Птенцы вылупляются голыми. Лишь немногие виды перелётны. 224 вида; распространены повсеместно, кроме Мадагаскара, Австралии, Новой Гвинеи, Новой Зеландии и Полинезии. В СССР 15 видов; наиболее известны: желна, зелёный (Picus viridis) и седой дятлы (P. canus), большой пёстрый дятел (Dendrocopos major), широко распространённый в лесной зоне, трёхпалый дятел (Picoides tridactylus) и вертишейка. Основная пища — насекомые, обитающие под корой и в древесине; некоторые Д. поедают муравьёв на муравейниках. В холодное время года питаются также семенами, раздалбливая шишки ели, сосны и др. деревьев; некоторые Д. весной пьют сок деревьев, делая в коре небольшие дырки. В зависимости от обстоятельств преобладает либо польза, либо вред, приносимые Д. лесному хозяйству.

Лит.: Познанин Л. П., Экологическая морфология птиц, приспособленных к древесному образу жизни, М.—Л., 1949 (Тр. Ин-та морфологии животных АН СССР, т. 3, в. 2); Формозов А. Н., Осмоловская В. И., Благосклонов К. Н., Птицы и вредители леса, М., 1950; Птицы Советского Союза, т. 1, М., 1951.

А. И. Иванов.
Троя
2 - 02.05.2004 06:56 		Погоняй ИТС, там встречаются умные вопросы и оригинальные ответы.
А на сайте 1С http://www.1c.ru/rus/products/1c/metod/default.jsp найдёшь метод. материалы, получить которые можно только потратив звонкую монету на их приобретение.
Желаю удачи!
GrayT
13 - 03.05.2004 11:06 		А по какой компоненте ПРофессионал?
Я в свое время "натаскивал" (другого слова не подберешь) народ на сдачу бухгалтерии. Не буду отстаивать авторства данной методики, многое взято из желтой книжки, но многое сам переработал
1 Общие сведения о экзамене 1С:Проффесионал
Порядок прохождения
Методика ответов на вопросы
2 Общие вопросы по работе с программой
Структура 1С:Предприятие
Установка программы
Ключи защиты
Конфигурации
Режимы запуска

3 Общие принципы ведения бухгалтерского учета в конфигурации
Общие механизмы в конфигурации "1С Бухгалтерия"

4 Общие принципы работы в режиме "Предприятие"
Общие принципы работы с формами и диалогами
Настройка параметров системы
Общие: Контроль ссылочной целостности (и в задаче)
Бухгалтерия: Маска счетов;
Работа со справочниками (формы списка и элемента)
Работа с документами
Работа с журналами документов
Ввод операций вручную
Документ "Операция"
Понятие сложной проводки
Работа с типовыми операциями
Работа с корректными проводками
Сервисные возможности
Дополнительные возможности, регламентированные отчеты, календари

5 Конфигурирование
Объекты конфигураций, их создание и настройка
Перечисление, справочники, документы, журналы, отчеты и обработки
Редактирование атрибутов и реквизитов
"Бухгалтерские" объекты конфигурации
Документ Операция
Планы счетов
Субконто
Счет
Операция
Проводка

6 Администрирование
Настройка прав и интерфейсов
Ведение списка пользователей
Создание архивных копий
Объединение и загрузка конфигураций

7 Работа с типовыми операциями
Работа со списком операций
Создание шаблона типовой
Администрирование типовой операции(использование и изменение состава проводок

8 Формульный язык
Общие понятия
Функции - Математические, строковые, форматирования, среды исполнение
Бухгалтерские процедуры и функции
Использование данных Операций, Проводок, Счетов, Справочников, Документов и пр.

Может "Курсом лекций разродиться"?
GrayT
14 - 03.05.2004 11:08 		И еще. Ту книжку я не сразу нашел, а ответы.... взял ИТС за полтора года, да и крякнул екселевский файлик - Написал на ВБА приблуду, которая считывает вопросы и расшифровывает ответы. Вопросы потом рассортировал и получилось (13). Вот так по вопросам и натаскивал. Вопросы там иногда и впрямь....
Интересно, а есть нарушения правил форума в этом посте?
Да? - рубите топ!
kvm
21 - 03.05.2004 22:57 		(0)Могу поделиться опытом, как сам сдавал профессионала. Берется несколько ИТС и отвечается на вопросы. Потом проверяется, на какие вопросы неправильно. Дальше идет итерация. Я понимаю, что взломать файл проще, но для запоминания тупых ответов, а на мой взгляд вопросы на Профессионал - тупые, лучше зубрежки ничего не придумали. Да, кстати, ни один из клиентов не интересовался моими сертификатами - все спрашивают:"А ты вот это знаешь?". Так что сам думай...
GrayT
22 - 04.05.2004 00:44 		(17) Ради доки и покупал, но она там дрянная (имхо), особенно по языку. Читаеться хуже чем в семерке. Без книги Волшебника, вообще потух бы интузиазим на корню.... А поп поводу "дешевле купить", эт ты точно заметил. Я ведь как в 16 так и сделал. Но наверное не умею их готовить... пришлось все снести и с ключиком ходить.

(19)А чего стесняешься? Из сурьезных еще ни кто ни чего не сказал. Думаю твой вопрос будет многим интересен.
BorisG, выскажите, пожалуйста, мнение является ли нарушением каких-либо прав взлом ТЕСТОВЫХ примеров?

(20) Были - времени не было, да и так ... "ради искуства"

(21)Вопросы то тупые, но вот я только когда сам внимательно разобрался многое для себя узнал нового и интересного :)) . Например у меня сложилось убеждение, что стандартная бухня использует только процентов 75 от всей мощи.
Не видел ни одного буха, который бы использовал типовые проводки и сложные
А по поводу взлома - за торговлю не скажу, а вот в бухне были вопросы где ответь просто ЗНАТЬ надо. И если книжки нет...
А так действительно процентов 80 нормальных вопросов, а 20 - развод какой то. Впрочем соотношение привычное, да и 12 ответов вполне хватит
kvm
23 - 04.05.2004 00:54 		(22) Сложные я использовал сам, но в 7.5. Типовые оказалось проще делать ручками. В 7.7 если чего нет в документах, то лучше его написать, а то видел я, как люди расход и закрытие месяца вручную делали, ой! о поводу 75% согласен, а кому оно надо? Правило 80/20.
GrayT
31 - 04.05.2004 15:20 		Кстати, сами тесты лежат даже в незащищенном разделе ИТС
vdi
34 - 05.05.2004 10:31 		Запомнить правильные ответы на все вопросы не самый лучший способ подготовиться к экзамену. Если вы начинающий пользователь, то наличие ответов при отсутствии развернутых к ним комментариев вряд ли поможет. Если же вы все таки специалист в 1с, то без чтения ЖКК не обойтись. При подготовке к экзамену хорошо помогает знание того, что большую часть ответов на вопросы можно распределить по слуюшим группам.

1) Твердое знание предмета.
Есть вопросы, на которые правильный ответ можно дать, твердо зная предмет. Это основа!!! Твердое знание предмета скажем на 70 % гарантируем сдачу экзамена с вероятностью 99%. Цифры условные.

2) Метод исключения.
В некоторых вопросах есть такие варианты ответов, что правильный ответ можно найти путем исключения неправильных.

3) Полнота ответа.
Среди вариантов ответов есть правильные, но не полные ответы. С точки зрения 1с правильным считается наиболее полный ответ из предложенных правильных вариантов.

4) Несколько правильных ответов.
Среди вариантов ответов может быть два или более правильных ответов. В этом случае правильным может быть объединяющий ответ. Например, «Все вышеперечисленные ответы правильны» или «Правильными являются ответы 1, 3 и 5».

5) Невнимательность.
Есть варианты ответов, явно рассчитанные на невнимательность экзаменуемого. Не торопитесь с ответом, особенно, если ответ кажется очевидным. Не разглядев какой-нибудь точечки, вы рискеуете провалить экзамен.

6) Не спешить.
Обязательно прочитайте все варианты ответов и проанализируйте их. Могут быть ловушки.

7) Ввести в заблуждение.
Некоторые ответы рассчитаны на nj? чтобы ввести экзаменуемого в заблуждение.

_________
Желаю удачи, vdi.


Компенсация за неиспользованный отпуск | База знаний | mista.ru

Компенсация за неиспользованный отпуск

Sector04
28.05.2004 10:19 		Люди, кто скажет, работаю с 4 января 2003, в отпуске не был, и чувствую ни буду в этой конторе. Должны ли мне выплатить компенсацию за неиспользованный отпуск, и какие документы являются основанием для выплаты, чтобы мне показать нашему руководству, может кто подскажет? Спасибо.
SnarkHunter
1 - 28.05.2004 10:27 		Не должны...
Sector04
2 - 28.05.2004 10:37 		SnarkHunter, объясни !!!
Vser1
3 - 28.05.2004 10:59 		А ТК почитать слабо...
Там четко написано, раз в год тебя просто обязанны выгонять в отпуск хотя-бы на обязательные (кажется 28 дней), все что сверх по твоему желанию можешь получить деньгами... Но для достоверности рекомендую почитать ТК и коментарии к нему, могу и ошибаться...

===========================================
Глава 19. ОТПУСКА

Статья 114. Ежегодные оплачиваемые отпуска

Работникам предоставляются ежегодные отпуска с сохранением места работы (должности) и среднего заработка.

Статья 115. Продолжительность ежегодного основного оплачиваемого отпуска

Ежегодный основной оплачиваемый отпуск предоставляется работникам продолжительностью 28 календарных дней.
Ежегодный основной оплачиваемый отпуск продолжительностью более 28 календарных дней (удлиненный основной отпуск) предоставляется работникам в соответствии с настоящим Кодексом и иными федеральными законами.

Статья 122. Порядок предоставления ежегодных оплачиваемых отпусков

Оплачиваемый отпуск должен предоставляться работнику ежегодно.
Право на использование отпуска за первый год работы возникает у работника по истечении шести месяцев его непрерывной работы в данной организации. По соглашению сторон оплачиваемый отпуск работнику может быть предоставлен и до истечения шести месяцев.
До истечения шести месяцев непрерывной работы оплачиваемый отпуск по заявлению работника должен быть предоставлен:
женщинам - перед отпуском по беременности и родам или непосредственно после него;
работникам в возрасте до восемнадцати лет;
работникам, усыновившим ребенка (детей) в возрасте до трех месяцев;
в других случаях, предусмотренных федеральными законами.
Отпуск за второй и последующие годы работы может предоставляться в любое время рабочего года в соответствии с очередностью предоставления ежегодных оплачиваемых отпусков, установленной в данной организации.

Статья 123. Очередность предоставления ежегодных оплачиваемых отпусков

Очередность предоставления оплачиваемых отпусков определяется ежегодно в соответствии с графиком отпусков, утверждаемым работодателем с учетом мнения выборного профсоюзного органа данной организации не позднее чем за две недели до наступления календарного года.
График отпусков обязателен как для работодателя, так и для работника.
О времени начала отпуска работник должен быть извещен не позднее чем за две недели до его начала.
Отдельным категориям работников в случаях, предусмотренных федеральными законами, ежегодный оплачиваемый отпуск предоставляется по их желанию в удобное для них время. По желанию мужа ежегодный отпуск ему предоставляется в период нахождения его жены в отпуске по беременности и родам независимо от времени его непрерывной работы в данной организации.

Статья 124. Продление или перенесение ежегодного оплачиваемого отпуска

Ежегодный оплачиваемый отпуск должен быть продлен в случаях:
временной нетрудоспособности работника;
исполнения работником во время ежегодного оплачиваемого отпуска государственных обязанностей, если для этого законом предусмотрено освобождение от работы;
в других случаях, предусмотренных законами, локальными нормативными актами организации.
Ежегодный оплачиваемый отпуск по соглашению между работником и работодателем переносится на другой срок, если работнику своевременно не была произведена оплата за время этого отпуска либо работник был предупрежден о времени начала отпуска позднее чем за две недели до его начала.
В исключительных случаях, когда предоставление отпуска работнику в текущем рабочем году может неблагоприятно отразиться на нормальном ходе работы организации, допускается с согласия работника перенесение отпуска на следующий рабочий год. При этом отпуск должен быть использован не позднее 12 месяцев после окончания того рабочего года, за который он предоставляется.
Запрещается непредоставление ежегодного оплачиваемого отпуска в течение двух лет подряд, а также непредоставление ежегодного оплачиваемого отпуска работникам в возрасте до восемнадцати лет и работникам, занятым на работах с вредными и (или) опасными условиями труда.

Статья 125. Разделение ежегодного оплачиваемого отпуска на части. Отзыв из отпуска

По соглашению между работником и работодателем ежегодный оплачиваемый отпуск может быть разделен на части. При этом хотя бы одна из частей этого отпуска должна быть не менее 14 календарных дней.
Отзыв работника из отпуска допускается только с его согласия. Неиспользованная в связи с этим часть отпуска должна быть предоставлена по выбору работника в удобное для него время в течение текущего рабочего года или присоединена к отпуску за следующий рабочий год.
Не допускается отзыв из отпуска работников в возрасте до восемнадцати лет, беременных женщин и работников, занятых на работах с вредными и (или) опасными условиями труда.

Статья 126. Замена ежегодного оплачиваемого отпуска денежной компенсацией

Часть отпуска, превышающая 28 календарных дней, по письменному заявлению работника может быть заменена денежной компенсацией.
Замена отпуска денежной компенсацией беременным женщинам и работникам в возрасте до восемнадцати лет, а также работникам, занятым на тяжелых работах и работах с вредными и (или) опасными условиями труда, не допускается.

Статья 127. Реализация права на отпуск при увольнении работника

При увольнении работнику выплачивается денежная компенсация за все неиспользованные отпуска.
По письменному заявлению работника неиспользованные отпуска могут быть предоставлены ему с последующим увольнением (за исключением случаев увольнения за виновные действия). При этом днем увольнения считается последний день отпуска.
При увольнении в связи с истечением срока трудового договора отпуск с последующим увольнением может предоставляться и тогда, когда время отпуска полностью или частично выходит за пределы срока этого договора. В этом случае днем увольнения также считается последний день отпуска.
При предоставлении отпуска с последующим увольнением при расторжении трудового договора по инициативе работника этот работник имеет право отозвать свое заявление об увольнении до дня начала отпуска, если на его место не приглашен в порядке перевода другой работник.
* * *
==================================
(с) ТК РФ № 197-ФЗ в ред от 30.12.2001
Marinka
4 - 28.05.2004 11:21 		(0) По-моему только при увольнении компенсация выплачивается и за часть отпуска, превышающая 28 календарных дней
Marinka
6 - 28.05.2004 15:53 		(5) Ну хоть что-то знаю... :)
(0) Ты работай... работай... по ст 127 ТК РФ \"При увольнении работнику выплачивается денежная компенсация за ВСЕ неиспользованные отпуска\", прикинь сколько там накопиться за несколько лет работы-то :)
bazvan
7 - 28.05.2004 15:57 		(6) Не все так просто. Выплачиватся то она выплачивается только ктож ее (компенсацию) на затраты разрешит взять
bazvan
8 - 28.05.2004 15:58 		Есть разъяснения по этому поводу. Что деньгами отпуск могут отдать только за один период после отгула предидущего. Тоесть:
если у вас есть задолженность по отпускам за 1999, 2000, 2001,2002, 2003 то для того что бы получить за 1999 то нужно отгулять за 2000 ну и так далее
bazvan
10 - 28.05.2004 16:04 		Там вообщем по поводу того что можно выдовать деньгами какоето древние (чета типа 60-70 годов постановление. Токма вот у нас появилась 25 глава которая на енто все клала. В итоге и постановление действует в части не противоречущей НК ну и как бы и выплачивать нуно но вот МНС такую балду и придумала
Marinka
11 - 28.05.2004 16:07 		Вообщем не видать Sector04'у ни отпуска, ни компенсации... так я поняла?
bazvan
12 - 28.05.2004 16:09 		Да нет одну то он при увольнении получит
bazvan
14 - 28.05.2004 16:26 		Такие у нас в стране дела. Вариант за счет прибыли (если не спец режимы)


Где поискать статьи по учету НДС в 1С? | База знаний | mista.ru

Где поискать статьи по учету НДС в 1С?

Denis Nsk 10.06.2004 07:43 | У кого-нибудь есть статьи или другой материал по учету НДС (полностью от первички до декларации) в 1С? Кинте ссылку или файлик. P.S. Если тема повторяется прошу прощения, что с форумом или я пропустил новые правила. Но своей темы не вижу
vdi 1 - 10.06.2004 07:49 | На диске ИТС достаточно много информаци.
Valery 3 - 10.06.2004 08:53 | может здесь что найдешь http://www.garant.ru/nav.php?pid=1233&ssid=365


ЗиК Досрочный выход из отпуска по уходу за ребенком | База знаний | mista.ru

ЗиК Досрочный выход из отпуска по уходу за ребенком

Ksana 07.06.2004 11:35 | Женщина выходит досрочно из отпуска по уходу за ребенком и работает на пол-ставки. В документе начисление отпуска ставим Дату досрочного выхода из отпуска (с сохранением пособия). В результате получаем с нужной даты начисление оклада - здесь все правильно, но вот пособие начисляется только с даты начала месяца до указанной в документе даты выхода на работу, а дальше нет... А так хотелось бы получить и дальнейшее начисление пособия... Или может мы не правы... или делаем что-то не так... или не надо вообще им эти пособия платить за счет ФСС... Подскажите, пожалуйста.
Emvika 2 - 08.06.2004 00:11 | Пособие по уходу за ребенком за счет средств ФСС (500 рублей) выплачивается с даты рождения ребенка до достижения ребенком 1.5 лет, а в данном случае наступление 1.5 лет совпадет с датой выхода на работу по документу, поэтому всё правильно, дальше предприятие может платить пособие только за счет собственных средств, но это уже совсем другая история. Здесь есть информация по пособию http://forum.advocat-ac.ru/viewtopic/t/4349/ Закон вроде как этот: Федеральный закон от 19.05.95г. N 81-ФЗ "О государственных пособиях гражданам, имеющим детей"


себестоимость = ? | База знаний | mista.ru

себестоимость = ?

Crystalizer 04.06.2004 18:23 | мне дали кое шо подкорректировать... нужно использовать себестоимость но её как таковой нет где она может быть спратана? вроде шото такое бывает на 281 счете, но наверное в данном случае не подходит т.к. фирма вроде перепродает а не производит. в тмц поля по этой теме: - УчётнаяЦена - УслугиНаСебестоимость учётная цена это и есть себестоимость??
mszsuz 1 - 04.06.2004 18:32 | "Учетная цена" это скорее ПЛАНОВАЯ себестоимость. Если нужна ФАКТИЧЕСКАЯ, то в большинстве случаев не подойдет. Хотя, смотря что за конфа ...
Crystalizer 2 - 04.06.2004 18:33 | а фактическая как получается?
mszsuz 3 - 04.06.2004 18:36 | Суммированием всех затрат по конкретной партии товара.
Gavrila 4 - 04.06.2004 18:40 | (0) Насколько помню на Дт 281 сч. как раз и хранится себестоимость товаров без НДС, а на Дт 26 - готовой продукции
Crystalizer 5 - 04.06.2004 18:45 | Gavrila: для торговли или производства?
Crystalizer 6 - 04.06.2004 18:46 | mszuz: Фактическая = УчётнаяЦена + УслугиНаСебестоимость ???
mszsuz 7 - 04.06.2004 18:50 | Нет. Фактическая = Затраты на приобретение + транспортировку + хранение + зарплата + ... etc.
Crystalizer 8 - 04.06.2004 18:54 | так может это и есть услуги на себестоимость?
Gavrila 9 - 04.06.2004 19:44 | (5) если тебе нужна себестоимость товаров, то берешь ее с Дт 281, если готовой продукции - с Дт 26.


Способы расчета заработной платы | База знаний | mista.ru

Способы расчета заработной платы

Arhitektor 23.05.2004 11:55 | Всем привет! Объясните, пожалуйста, как рассчитывать зарплату по следующим способам начисления: 1) суммированный учет рабочего времени 2) методом отклонений
Влад 1 - 24.05.2004 04:42 | Задачки по компоненте Расчет решаем? ;) В общем, суммированный учет рабочего времени подразумевает расчет зарплаты в зависимости от общего количества отработанного времени. метод отклонений подразумевает оклад за месяц, например, а в случае невыхода или сверхурочной работы (т.е. в случае отклонений) - удержания или начисления соответственно.
Влад 3 - 24.05.2004 08:23 | я все задачки решил, но когда попытался сдать 1с:профессионал, то ответил на 11 вопросов из 12 нужных, следовательно к аттестации меня не допустили. было страшно обидно, да и не было, а до сих пор обидно. надеюсь летом еще счастья попытать. специально выписал книжку для подготовки к этим тестам - г...но редкое - не вздумайте купить. никаких пояснений и ответов там нет, хотя нет в конце книжки есть два(!) теста (по 14 вопросов) с пояснениями и ответами, а перед ними вопросов штук 300 (не знаю может больше, может меньше) и ни одного ответа или пояснения. ко свему прочему год выпуски этой книжки - 2002, думаю не стоит говорить, что она к тому же еще и сильно устарела. лучше всего прорешивать вопросы с дисков ИТС.
BorisG 5 - 24.05.2004 09:38 | Да... советнички... И эти люди настраивают 1С... "суммированный учет рабочего времени подразумевает расчет зарплаты в зависимости от общего количества отработанного времени." А разве обычные системы оплаты труда по-другому? Может для приличия стоит хотябы ст. 104 ТК почитать?
Влад 10 - 25.05.2004 05:52 | Ст. 104 ТК: В организациях или при выполнении отдельных видов работ, где по условиям производства (работы) не может быть соблюдена установленная для данной категории работников ежедневная или еженедельная продолжительность рабочего времени, допускается введение суммированного учета рабочего времени с тем, чтобы /*продолжительность рабочего времени за учетный период (месяц, квартал и другие) не превышала нормального числа рабочих часов*/. Учетный период не может превышать одного года. Вы и теперь будете утверждать, что я не знаю что такое суммированный учет рабочего времени? Смысл тот же, а то что не привел текст статьи дословно - великодушно извинте. И не надо строить из себя самого крутого.


Многосменные графики | База знаний | mista.ru

Многосменные графики

vdi
11.05.2004 14:35 		Многосменные графики относятся к так называемому суммрованному учету рабочего времени. Но при таком учете продолжительность рабочей недели часто и близко не стоит к нормативному ряду: 40, 36 и т.д.

Так какую продолжительность рабочей недели устанавливать, если реально она значительно больше 40 часов. Или здесь налицо нарушение ТК?
BorisG
1 - 11.05.2004 15:02 		Во-первых, не факт, что многосменные графики относятся к суммированному учету.
И во-вторых, зачем устанавливать неделю? Суммированный учет как раз и предназначен для случаев, когда ежедевный или еженедельный учет нарушаются.
Из комментария к ст. 104 ТК:
"Устанавливается учетный период рабочего времени, который превышает неделю, в нем СУММАРНАЯ продолжительность рабочего времени не должна превышать НОРМАЛЬНОГО числа рабочих часов за этот период..."
vdi
2 - 11.05.2004 16:12 		Согласен. Но вопрос остается. Насколько я понимаю реквизит "Продолжительность рабочей недели" используется при расчете среднего. Если не так, то где он используется?
BorisG
3 - 11.05.2004 17:59 		(2) А п. 13 пост. правительства N 213 от 11 апреля 2003 г почитать?
Там все подробно написано.
BorisG
4 - 11.05.2004 18:13 		Кстати, так и не понял, что надо.
Для начала надо выяснить, действительно ли для данного работника (или данной категории работников) установлен суммированный учет рабочего времени. В (1) я уже сказал, что многосменность еще не факт его установки.
А во-вторых, согласно п.13 указанного в (3) постановления для расчета среднего действительно используется продолжительность рабочей недели, установленная для данной профессии, но вовсе с ней НЕ НАДО сравнивать переработку в пределах недели.
Переработка контролируется согласно ст. 104 ТК в исключительно в пределах учетного периода, а он может быть и месяц, квартал и другие.
vdi
5 - 11.05.2004 22:02 		Извиняюсьза непонятливость - мудренно что-то. Попробуем на пальцах.

1) Сотрудник Иванов работает первые четыре дня недели по 4 часа в день. Итого 16 часов в неделю.

2) Сотрудники такие-то работают по 3-сменному графику: сутки работаем, 2-е суток отдыхаем. В мае у сотрудников скажем первой смены набегает 360 часов.

Вопросы для 1) и 2).
а) Какой "Тип рабочего графика": Пятидневка, Шестидневка или суммированный учет?
б) Какова "Продолжительность рабочей недели": 40, 36, 30 или 24?
в) Какие устанавливать выходные дни?
BorisG
6 - 11.05.2004 23:26 		(5) Вопросы ни о чем... в них просто нет необходимых данных...
Встречные вопросы, без которых НЕЛЬЗЯ ответить на поставленные вопросы:
1. Для каких работников ПРИКАЗОМ по предприятию, коллективным договором или правилами внутреннего распорядка установлен суммированный рабочий день и почему?
2. Какова продолжительность для данной категории работников, если бы не было сменных графиков? Надеюсь понятно, почему устанавливается сокращенная рабочая неделя, см. ст. 92 ТК.
3. Какова продолжительность рабочей недели установлена на предприятии для данной категории работников?
4. Если для какой-то категории работников установлен суммированный учет рабочего времени, то каков его учетный период? Он может быть установлен и равным году ;-), а уж кварталу - часто. При этом и 16 и 360 час. в одном месяце НИ О ЧЕМ не говорят.
5. Какая отрасль? Ибо для отдельных отраслей могут быть свои особенности, например см. пр. Минсвязи РФ от 8 сентября 2003 г. N 112.

Ответив на эти вопросы, надеюсь сам ответишь и на свои... они из них вытекают.
vdi
7 - 12.05.2004 11:09 		(6) Хоть моя мама и русская, да папа не юрист! Давай брать интеграл по частям.

В соответствии со ст. 100 ТК РФ на предприятии установлена пятидневная рабочая неделя с двумя выходными днями: суббота и всокресенье.

1) Студентке Журавлевой, 17 лет, по согласованию с дирекцией предприятия установленна в соответствии со ст.92 ТК РФ сокращенная продолжительность рабочего времени: 18 часов в неделю. В ст. 91 и 92 вводится понятие нормальной продолжительности рабочего времени, но ничего не говорится, как распределяется это время в течении недели. Поэтому руководство считает возможным устанавить следующий график работы: Понедельник-6 часов, Вт., Ср. и Чт по 4 часа в день. Пятница, суббота воскресенье - нерабочие дни.

Создаем для Журавлевой 18-часовой календарь. На его основе формируем "График работы".

"Тип рабочего графика" - "Пятидневная рабочая неделя".
"Выходные дни" - "Суббота". "Воскресенье".
"Продолжительность рабочей недели" - ?????????????????

Если ориентироваться на возраст, то 36 часов. Если учесть, что Журавлева еще и студентка, то 18 часов.

Так какова же продолжительность рабочей недели для Журавлевой?


ЗиК. Чем отличается отпуск без сохранения краткосрочный и долгосрочный? | База знаний | mista.ru

ЗиК. Чем отличается отпуск без сохранения краткосрочный и долгосрочный?

Denis Nsk
17.05.2004 08:57 		Подскажите, пожалуйста, чем отличается отпуск без сохранения заработной платы краткосрочный и долгосрочный? В каких случаях используется какой отпуск за свой счет?

Спасибо
vdi
4 - 19.05.2004 19:44 		(2) сделал вид, что ответил.
(3) сделал вид, что понял.

Ст. 121 ТК РФ "Исчисление стажа работы, дающего право на ежегодный основной оплачиваемый отпуск".

1) В ст. 121 ТК РФ речь идет об оплачиваемых отпусках, а вопрос то о неоплачиваемых.
2) В ТК РФ отсутствует понятие краткосрочного и догосрочного отпусков. По крайней мере я не нашел этих определений.
3) В ст. 121 ТК РФ говорится, что "время предоставляемых по просьбе работника отпусков без сохранения заработной платы продолжительностью более семи календарных дней" не входит "В стаж работы, дающий право на ежегодный основной оплачиваемый отпуск".

Из этого можно предположить,что краткосрочные - это до 7, а долгосрочные - после 7. Но это наши предположения, и не более того! В ТК РФ отсутствует понятие краткосрочных и долгосрочных отпусков. Вопрос (Denis Nsk) был о том, что под этими терминами понимает фирма 1с?

К сожалению, реакция на ответ была абсолютно безсодержательной. Может быть, кто знает ответ? Пожалуйста, откликнитесь! Ответ типа "а посмотреть в модуле?" не принимается. Не все участники форума с легкостью могут читать программный код!
mike
5 - 19.05.2004 20:47 		из анализа конфигурации было выяснено , что с точки зрения 1с обработка краткосрочного и долгосрочного отпуска проводится совершенно одинаково
я пробовал долгосрочный отпуск длиной 1 день и краткосрочный более 1 года, никаких ошибок и предупреждений не было, скорее всего такое деление было существенно в более ранних конфигурациях.
vdi
6 - 21.05.2004 08:15 		(5) Формально граница между краткосрочным и долгосрочным может быть плавающей. Например, устанавливаться правилами трудового распорядка. Это просто мое предположение. В этом случае программа ругаться не будет. Но это может отражаться в каких-то отчетах, может быть в исчислении стажа и т.д.

В законодательстве о военнослужащих попадается термин "Краткосрочный отпуск".

К сожалению моих познаний не хватает, чтобы разобраться в объекте "ВидРасчета.ОтпускЗаСвойСчетКраткосрочный". Где , как он описан найти не могу.
mike
7 - 21.05.2004 13:22 		это в списках видов расчета : там есть модуль расчета . далее мои знания тоже заканчиваются.


Ключ защиты 1С с точки зрения бухучета | База знаний | mista.ru

Ключ защиты 1С с точки зрения бухучета

lexa 18.05.2004 12:19 | Чем является ключ (свм девайс) защиты 1С с точки зрения бухучета
Bell 1 - 18.05.2004 12:30 | Приложением к лицензии.
lexa 2 - 18.05.2004 12:33 | А лицензия с точки зрения бухучета
GuineaPig 3 - 18.05.2004 13:05 | Всё зависит от того как написана. Обычно НМА.
BorisG 5 - 18.05.2004 13:24 | (3) Программа, точнее ее копия уже давно, 3 года как... не НМА. (4) Ключик как неотъемлемая часть этой программы ;-)) Я серьезно.
lexa 6 - 18.05.2004 13:37 | (5) я в бух учете не силен, это как? программа по логике - софт, а девайс -хард Получается 1С - это програмно-аппаратный комплекс
BorisG 7 - 18.05.2004 13:49 | (6) Так. С точки зрения учета - это одно целое и неделимое ;-))
GuineaPig 8 - 18.05.2004 14:10 | (5) Я бы не стал утверждать так категорично: http://www.pravcons.ru/publik-24-11-03-1.htm
lexa 9 - 18.05.2004 14:34 | Т.е. если с ключом что-то случается, я иду к франчу - он мне выкатывает счет и на основании его я могу уже определить меру ответственности
BorisG 10 - 18.05.2004 20:29 | (9) Не можешь. Ибо ключ реально цены не имеет. В зависимости от причины, по которой ключик пропал, цена на него разная. ;-) (8) А может, чем ссылки на популярные ресурсы давать самому норматиные почитать... и посмотреть... какие программы в ПБУ 14/2000 относятся к НМА? И относятся ли к НМА программы 1С у конечного пользователя... Можно еще и автора этих ПБУ, Александра Сергеевича Бакаева почитать или послушать ;-)) Он то уж точно не любит программы, на которые у пользователи НЕИСКЛЮЧИТЕЛЬНОЕ ПРАВО на 04-м счете ;-))
kvm 11 - 18.05.2004 23:50 | (10) Вот-вот. Все, на что права собственности не имеешь, а имеешь право пользования, это расходы будущих периодов, счет 97. Ключ, кстати, обычно меняют бесплатно, если он сломан и предъявлен.
BorisG 12 - 19.05.2004 00:37 | (11) А если не предъявлен. Какова его цена?
Морская свинка 13 - 19.05.2004 10:03 | (10) Да слушал я его на партнерском семинаре года три назад. Окончание семинара понравилось, особенно анекдоты по ПБУ на пандусе :))
Bell 14 - 19.05.2004 20:12 | (2)Возвращаюсь. Пока ты используешь программу она числится в бухучете(лицензия вместе с ключем), хотя ее стоимость списана на затраты.


Как взять на приход животных? | База знаний | mista.ru

Как взять на приход животных?

Lyolik 13.05.2004 10:20 | Подскажите, пожалуйста,каким образом взять на приход животных.
Lyolik 3 - 13.05.2004 10:33 | 2 - Бухучет для Украины релиз 253.
Lyolik 4 - 13.05.2004 10:37 | 1 - От товара отличаются тем, что вторым субконто у них является Справочник "Животные". В конфе вообще по-моему нету документов, которые работают с этим справочником(кроме Операций, конечно).
Vser1 5 - 13.05.2004 10:56 | Вот опсуждение по собакам :))) http://www.forum.mista.ru/topic.php?id=3690
Valery 8 - 13.05.2004 11:11 | Главное, зависит от цели приобретения. Если дальнейшая перепродажа значит товар, если для производства, то основные
Lyolik 10 - 13.05.2004 11:20 | По ПСБУ учет животных ведется на счету 21 "Животные на выращивании и откорме". В 1С у счета 21 2 вида субконто: 1-е Место хранения(Справочник Места хранения), 2-е Животные(Справочник Животные), так вот каким образом сделать проводку на счет 21 по обеим субконто, каким документом, кроме как ручной операцией?
BorisG 11 - 13.05.2004 11:22 | Да..... советники... Животные животным рознь... могут быть и ОС... могут и нет..., например на выращивании...
Bell 13 - 13.05.2004 18:02 | (0) Скопируй документ прихода. Присвой новое имя (Приход животных) и исправь счет прихода (на нужный) у нового документа. Счатливо!


Как принять в квычету НДС при расходах будущих периодов? | База знаний | mista.ru

Как принять в квычету НДС при расходах будущих периодов?

vdi 07.05.2004 22:56 | Произведена полная разовая оплата, скажем, аренды, подписки или НМА. Данная оплата отнесены на счет 97 "Расходы будущих периодов" и затем периодически равными долями списывается на затраты. Не могу понять: в этом случае НДС принимается к вычету сразу в полной сумме, или также равными долями. Вдвойне буду благодарен за ответ со ссылочкой на нормативный акт.
Naumov 1 - 07.05.2004 23:27 | Если есть полная оплата и с-ф предъявлена, то сразу принимаем НДС к вычету
Naumov 2 - 07.05.2004 23:41 | см.ст.171 НК: "Вычетам подлежат суммы налога, предъявленные налогоплательщику и уплаченные им при приобретении товаров (работ, услуг) на территории Российской Федерации ..."


Учетная политика | База знаний | mista.ru

Учетная политика

Сергей 05.05.2004 10:46 | Люди, не бросите ссылочку. Главбуху хочеца учетную политику по налогооблажению и по бух.учету на 2004. Может кто знает, где есть эти вещи. Она хочет из чужих примеров что-то взять для себя. И ещё ЛЮДИ, я работаю с января прошлого года, в отпуске не был. В праве требовать компенсацию за неиспользованный отпуск, и обязаны ли мне они забашлять денешку за енто. А то главбух что-то мне протерла, типа эта компенсация выплачивается в случае, если человек увольняется. За ранее спасибо.
SnarkHunter 1 - 05.05.2004 10:50 | Какая учетная политика на 2004... Май месяц на дворе...
Marinka 3 - 05.05.2004 10:56 | (0) бери лучше отпуск в двухкратном размере...
BorisG 4 - 05.05.2004 11:06 | (1) Да правильно он спрашивает... Приказ об учетной политике, если он меняется, должен представляться в МНС вместе с годовым отчетом за предыдущий год. Ну опоздал на месяц ;-) (0) Вообще-то это прямая обязанность буха... писать приказ об учетной политике... и никак не прога.
vdi 5 - 05.05.2004 11:18 | Насчет компенсации отпусков в законодательстве говорится приблизительно следующее. Денежная компенсация за неиспользованный отпуск выплачивается только при увольнениии сотрудника. Работающий сотрудник в конце концов отпуск должен свой отгулять - хорошо отдохнуть. Если отпуск удлиненный, то есть более 28 дней, то компенсировать законодательство разрешает только ту часть, которая превышает эти самые 28 дней. ___________ С уаженеием, vdi.
Marinka 6 - 05.05.2004 11:22 | Вот я и говорю... бери лучше отпуск :)
Bell 7 - 05.05.2004 13:20 | (4) По закону не требует предоставления в МНС. (0)В инете есть!


Смещение элементов диалога при обновлении конфигурации | База знаний | mista.ru

Смещение элементов диалога при обновлении конфигурации

clg 03.06.2004 16:39 | Есть два компьютера - Рабочий,Домашний. ОС и релизы платформы 1С 7.7 идентичны (XP,21).Конфигурация постоянно модифицируется на обоих: с измененным на Р md-файлом объединяется md на Д. При этом в окне сравнения конфигураций отражены реальные изменения объектов, а вот в обратном случае, при объединении конфигурации на Р с md полученным на Д, помимо прочего, изменяются формы диалогов НЕИЗМЕНЕННЫХ объектов (элементы диалога "уползают" вверх). Помогите,пожайлуста, понять причину и подскажите методы устранения проблемы.
Gavrila 1 - 03.06.2004 16:45 | (0) слухи ходят, что из-за разрешения монитора такое бывает (хотя не проверял)
Oksa 3 - 03.06.2004 17:43 | работаю в копии, потом объединяю с рабочей базой. все на одном компе при одном разрешении. но постоянно такая фигня. сбивает с толку. может правда кто знает из-за чего может быть такая фигня и как ее вылечить?
427 4 - 03.06.2004 18:21 | Приколы ХРюшиного оформления экрана. Поставь офорление классической винды
Vantala 5 - 04.06.2004 13:36 | У меня похожий глюк. Правда вроде ничего не уползает. И проблема возникает не всегда. К тому же в большинстве случаев на разных ОС (у меня W2KServer)а у клиентов разные винды - от 95 до XP. А так весьма похоже - приносишь MD-шник, обновляешь - пишет, что менялись формы диалога (а они не менялись). Правишь, несешь к клиенту - то же самое. Может это глюк такой, вроде слета представлений субконто ?
Oksa 6 - 04.06.2004 13:53 | ладно бы этот глюк был бы только на XP, а то на 2000 с классическим оформлением таже фигня, я на 2000 работаю
427 7 - 04.06.2004 15:04 | (5) вроде на старших релизах 1с баги в 2000 пофиксили ....
Vantala 8 - 04.06.2004 15:55 | Релиз семерки у меня 021. Причем у меня на машине все без проблем. Такое возникает когда приносишь конфу с другого компьютера.


Странная продажа коробок 1С (часть2, серьёзная) | База знаний | mista.ru

Странная продажа коробок 1С (часть2, серьёзная)

Aнтон 09.08.2004 14:00 | Конторка приобрела у франча коробку с 1С+Бух типовая проф. В коробке всё гуд, но диски с дистриб 1С и конфигурацией... самопальные CD-R... Этот факт вызвал сомнения у руководства конторки... Нормальное ли это явление? Какие должны быть диски (дискеты) в дистрибутиве? Алли, я серьёзный вопрос задал, конторка бабули в это дело вложила, а их по-видимомоу "поимели". Не кусай меня, плиз... Я же Антон...
Gary 1 - 09.08.2004 14:08 | Возможно, что франчи решили Вам помочь, т.к. в типовой коробке часто лежат дискеты (!), вот и катнули последние релизы и все, что нужно для установки на компакт.
Aнтон 3 - 09.08.2004 14:16 | По идее, должны быть дискеты с желтыми наклейками, но франч заявил, что всем щас всё идёть ТОЛЬКО на CD-R... Вот и хочется узнать, не самодеятельность ли это? У всех ли такое? Как быть?
BorisG 15 - 09.08.2004 15:24 | Да... Странного тут ничего нет. Антон, перед тем, как поднимать такую ветку стоит выяснить несколько моментов. Момент первый. 1С действительно перешла на CD в комплектации типовых коробок. И это отражено в информационных письмах 1993, 1650 и др. Момент второй. Если выходит новый релиз, то действительно до получения основного тиража 1С выпускает релиз на CD-R. Нужно только определить его внешний вид. На нем должен быть нанесен серийный номер продукта, совпадающий с номером на регистрационной карточке.
Aнтон 16 - 09.08.2004 15:44 | Серийник есть, в виде оттиска штемпельным аппаратом. Совпадает. Но вся эта ситуация очень напоминает извращённый слоган: "Дорого (сердито) и несерьёзно"...
BorisG 17 - 09.08.2004 15:53 | (16) Нет, Антон, ничего это не напоминает... Производство... знаете ли ;-)) На сегодняшний момент комплектация бухгалтерии: Базовая - на CD-ROM Стандартная - на дискетах Проф - на CD-ROM


Обновление сильно правленной конфигурации. Help! | База знаний | mista.ru

Обновление сильно правленной конфигурации. Help!

Том 10.06.2004 21:38 | Обновляю сильно правленную конфигурацию бюджетной бухгалтерии. Сильно замаялся сравнивать изменения. Не знает ли кто, есть ли какие обработки, программки, чтобы труд немного облегчить?
SnarkHunter 1 - 10.06.2004 21:41 | Изменения надо документировать... Тогда все будет гораздо проще...
yaret 2 - 10.06.2004 21:48 | Найди того, кто правил, возьми его за одно место и не отпускай, пока не скажет на кой черт он правил бюджетную конфигурацию! BorisG тебе много чего за это может рассказать! Он из-за бюджетников на океанские острова летает отдыхать. Так что лучше, если не сам делал - ну ее эту правленную конфигурацию на фих.
Том 3 - 10.06.2004 22:13 | Да хрен знает кто правит. Сменилось столько, что не отыскать. Так там еще и припаяли автоформирование книг покупок и книг продаж. Если бы было задокументировано, тогда и проблем бы не было.
SnarkHunter 4 - 10.06.2004 22:21 | У меня есть примочка для сравнения форм. Завтра могу кинуть. Ветку подними.
BorisG 5 - 10.06.2004 22:32 | Да... (0) А знаешь, yaret прав. Ну... на острова не летаю, но лучше брось ее нафиг... либо проверь, все ли чисто... а то попадется такой, как я, так и шкуру спустит... Как раз у меня юристы сейчас над таким вопросом работают ;-)) Я вполне серьезно. А если по делу, то при наличии технологической документации обновление даже сильно измененной конфы штука не такая уж и страшная. У меня, например, это делает девочка, которая совсем почти не разбирается в бухучете, но делает это аккуратно. Чистый прог. Вот только сильно измененная конфа в бюджете... это почему? Отрасль какая? Может легче и лучше к типовой привести? Ибо совсем немного сфер, где типовая бюджетка не укладывается.
Том 6 - 10.06.2004 22:39 | Вневедомственная охрана. Конфиги сравнил: Различия - 8 кусков в глобальнике, 3 общие таблицы, библиотека картинок, 5 справочников, 4 графы отбора, 21 правленный журнал, 5 отчетов, 3 обработки, 103 правленных счета, 3 субконто. Короче, видимо над нею я и сдохну.
yaret 7 - 10.06.2004 23:08 | (6) Ни себе чего!!! И это все на ставку фикси? Если умудришься обновить, да еще и правильно, тогда медаль "10 лет отличной службы" тебе точно светит. Ну а если ты у франча работаешь, тогда вопрос почему франч занимается обновлениями не у своих клиентов?
BorisG 8 - 10.06.2004 23:09 | (6) Сколько обособленных подразделений?
BorisG 9 - 10.06.2004 23:23 | +8 А за столь измененный план счетов точно голову и бухам, и тем, кто делал откручивать надо. Скорее детализация по счетам... от большого ума..., лени и незнания 107н. Ибо излишнюю аналитику не сворачивают по завершении периода... и бардак... А что-то документов не видно... они то как?
Том 10 - 10.06.2004 23:34 | Про документы извиняюсь забыл. 23 правленных. Обособленных подразделений 5. В основном функции распорядителя. Внедряла другая фирма. Клиентов не устроила, решили сменить. Вот в наследство это барахло и осталось. Директор думает, что я до утра разгребу, но похоже, работы здесь не на один день, так, что лучше пойду спать - здоровее буду. Наворотили в основном какие-то Н счета (налоговый учет?) пока не разобрался. Опять таки там ЗПК с ЗПРами светят. В общем ужас.
BorisG 11 - 10.06.2004 23:44 | (5) Что то мне кажется, что с функциями распорядителя ты напутал... И тогда, в общем, я тебе не завидую. Да и попроси директора показать договора с той фирмой... мало ли что там написано... Так ты франч или фикси? И насколько хорошо знаешь 107н?
BorisG 12 - 10.06.2004 23:44 | Извиняюсь... 11 -> 10
Valery 13 - 11.06.2004 09:23 | Попробуй сделать такич чудом: Переименуй все исправления тогда при обновлении у тебя просто добавятся новые документы и отчеты и старые остануться. ну а с планом счетов и глоб придется руками поработать.


где располагается справочник валют на ИТС? | База знаний | mista.ru

где располагается справочник валют на ИТС?

3V 08.06.2004 14:16 | собственно сабж, нужно товарисчу скинуть справочник, а ИТС-ку нет возможности закинуть... заранее спасибо!
ally 1 - 08.06.2004 14:17 | На ИТС есть хороший поиск, поискать трудно?
3V 2 - 08.06.2004 15:17 | спасибо конечно за совет, но с поиском туговато оказалось найти пришлось обработку копать, нашел на диске в D:\1CIts\EXE\EXTDB\VAL.EXE можно терь к Станиславу в БЗ добавлять :)


Обновление настроенной конфигурации на след. релиз в v8 | База знаний | mista.ru

Обновление настроенной конфигурации на след. релиз в v8

Foma 04.06.2004 14:46 | в 8-ке пользователям поставляется только файл с обновлением конфигурации, причем типовой. Ежели конфа донастроена, то .. каков же механизм обновления в этом случае, ведь настройки надо сохранить? у меня 2 решения: 1. Обновить копию до стандартной, затем внести в эту копию настройки и обновить уже рабочую базу. 2. Найти все таки файл с расширением CF и овнести в него изменения для послед. обновления раб. конфигурации.
alxkorvin 2 - 04.06.2004 14:54 | Ну во первых изначальное утверждение не верно. Пользователи могут получить файл cf последней типовой конфигурации.
¶ 3 - 04.06.2004 14:54 | А чё .cf искать-то долго? Выгрузил из стандартной - вот тебе и .cf
427 4 - 04.06.2004 14:58 | Вопрос то не в СФ, ДФ, или ЖПА.... Вопрос в сохранении добавленного кода ...
¶ 5 - 04.06.2004 15:09 | (4) Дык что ж тебе здесь возразить? Ясно, сначала юзаем "объединение конфигураций" (имени великого М.З.), выжимаем из него все возможное и невозможное, затем дотачиваем на коленке...
Foma 6 - 04.06.2004 15:20 | (2) в Е-бурге как минимум 1 фра сказал, что для пользователя только обновление на/со стандартной. (3) где стандартная то? по-твоему получается надо вести как минимум 2 базы, рабочу и стандартную (для обновлений). зачем? или такой механизм неужели еще никто не "сталкивался"?
¶ 7 - 04.06.2004 15:35 | А мож так? 1. Обновляем стандартную. 2. Выгружаем в .cf обновленную стандартную. 3. Делаем "сравнение и объединение конфигураций" с нашей (доработанной), ставим "с приоритетом загружаемой" (насчет приоритета, правда, сомневаюсь).
insert 8 - 04.06.2004 16:09 | Типа официальный ответ хотлайна фирмы на одну букву: "Обратитеть к сертифицированным специалистам фирмы-франчайзи, которая вас обслуживает". О как! По сабжу: если есть время, поковыряйся с приоритетом объединеня. Хороший механизм, если юзать аккуратно.


Как лучше обновить? | База знаний | mista.ru

Как лучше обновить?

Katy 01.06.2004 14:24 | Хотелось бы обновить конфу, где изменены некоторые параметры в справочнике и документах. Как это сделать с сохранением накопленных данных?У меня упрощенка.
Valery 3 - 01.06.2004 14:33 | Можно просто этот справочник не обновлять, а можно обновить, а потом поправить изменения
Katy 4 - 01.06.2004 14:34 | Изменения в контрагенте(добавлены новые реквизиты), добавлены документы, формы, новые таблицы.
ally 5 - 01.06.2004 14:36 | Cправочник контрагенты не обновлять, изменения добавлять руками - теперь всегда Новые документы не тронет, но проверить.
Press 6 - 01.06.2004 14:47 | В мд которым обновляешь, добавь в спр Контрагенты, все те реквизиты что есть в обновляемом. В документах все зависит от что конкретно изменено. А вообще, обновлять должен тот кто изменял (конфигурацию).
ГореПрограммист 7 - 01.06.2004 14:50 | а что делать если пишет что субконто превышает максимально возможное? если все субконты в норме
PANAtlant 9 - 01.06.2004 15:11 | Я при обновлении конфигурации, делаю изменения в новой конфигурации, которые уже сделаны в обновляемой, изменяю реквизиты, формы, которые есть и в новой, затем, когда конфигурации идентичны в старом варианте - обновляю.
tenant 10 - 01.06.2004 15:13 | Определенно должно помочь заведение тринадцатого субсчета заместо максимального в норме субконты.
lexa 11 - 01.06.2004 16:30 | http://www.sinor.ru/~my1c/knowhow/mtd_upd.html


Релиз Предприятия | База знаний | mista.ru

Релиз Предприятия

Сергей 31.05.2004 20:52 | Ребята, подскажите, где можно узнать о выходе нового релиза 1С Предприятие, и может от куда можно скачать? Спасибо.
SnarkHunter 1 - 31.05.2004 21:02 | Релизы - http://www.1c.ru/rus/support/release/default.jsp Скачать - у франча...
BorisG 2 - 31.05.2004 21:07 | А вот откуда скачать... это зависит от статуса... (1) У франча не скачаешь... контрольная группа пресекает... С помощью ИТС... С сайта 1С...
Сергей 3 - 31.05.2004 21:11 | SnarkHunter, что я теряю, если обновляю конфу имея у себя только новый мдшник?
Сергей 4 - 31.05.2004 21:16 | BorisG, я конечно, не профи, но сколько ИТС-ок не видел, что-то ни на одной не замечал обновления Предприятия. Конечно ИТС у меня не залёживались (2-4 часа), но кроме релизов конф и отчетности ни чего не брал с дисков. Подскажи пожалуйста, на каком диске ИТС точно есть обновление Предприятия и где его искать. Спасибо.
SnarkHunter 5 - 31.05.2004 21:20 | (2)Ну почему же... Если подписан на ИТС... (3)Да ничего практически...
SnarkHunter 6 - 31.05.2004 21:22 | (6)Тебе обновление-то конфигурации нужно или программных файлов?
Сергей 7 - 31.05.2004 21:24 | SnarkHunter, программных файлов !
Сергей 8 - 31.05.2004 21:36 | Сейчас есть ИТС-ки с января. Где чё посмотреть?
BorisG 9 - 31.05.2004 21:55 | Да... давно не задумывался, что действительно уже давно 1С не публикует постоянно платформу... Где взять... Во-первых точно есть на каждом партнерском... ;-), поэтому и не задумывался ;-) Во-вторых... 021 релиз - только на июльском 2003 года, это на обычном... Ну а 023... я так понимаю, будет на июньском этого года.
BorisG 10 - 31.05.2004 22:00 | (5) Даже если подписан на что угодно, 1С пресекает обезличенное скачивание с сайта партнеров... вспомни, недавно на Т1С были вопли украинских коллег... Посему платформу только письмом... или лично. Ну и... никто не отменял сделать запрос в 1С с указанием организации, регистрационного номера, текущего релиза и запрашиваемого релиза от Хотлайна 1С с адреса hotline@1c.ru, или release@1c.ru (предпочтительно). Для партнеров - тоже самое, только надо указать код партнера.
427 11 - 31.05.2004 22:01 | На ИТС есть раздел, где описано содержимое (обновления платформы и конф) всех предыдущих выпусков.... Найди и смотри.... Январский - старый ... сильно... В этом плане качать с сайта 1с - более актуально.... Разделы по советам линии консультаций и по программированию в 7.5/7.7 меняются очень мало от диска к диску ....
BorisG 12 - 31.05.2004 22:18 | (11) Петь, ему платформа нужна... а ее действительно убрали с диска ;( И оставили только в момент ее выхода, посему... я все сказал в (9).
BorisG 14 - 31.05.2004 23:40 | (13) Верно, но раньше была на каждом ;-))


Где брать актуальный справочник БИК? | База знаний | mista.ru

Где брать актуальный справочник БИК?

BorisG 21.05.2004 00:29 | Часто задают вопрос, где брать справочник БИК, ибо на ИТС он неактуален? Действительно, он актуален только 2-3 дня, ибо обновляется два раза в неделю. Ответ прост до безобразия: В банке, в котором обслуживаетесь. . Основание: УКАЗАНИЕ ЦБ РФ № 1193-У от 9 сентября 2002 года. О порядке обновления “Справочника банковских идентификационных кодов участников расчетов на территории Российской Федерации” ... 1. Обновление информации, включенной в Справочник БИК РФ, осуществляется с периодичностью два раза в неделю. ... 8. Кредитные организации (филиалы) доводят до своих клиентов сведения об изменении информации, содержащейся в Справочнике БИК РФ. . "Вестник Банка России” от 18 сент. 2002 года
Волшебник 1 - 21.05.2004 00:30 | А еще его можно загрузить из Интернета и найти на ИТС.
BorisG 2 - 21.05.2004 00:32 | (1) Еще раз, на ИТС он НЕАКТУАЛЕН. С Интернета, если имеешь в виду РБК, то тоже. Некоторые банки действительно в своем формате выкладывают.
BorisG 5 - 21.05.2004 01:03 | Выложил сюда... просто за 2 дня четыре раза этот вопрос задавали, в том числе на Т1С... Они возникают, либо когда большие изменения, либо когда у клиента много контрагентов... но... достаточно одного несовпадения корсчета... и платежка возвращается. (4) Нормальные банки так и поступают, но, к сожалению, очень немногие... Если стоит система клиент-банк, там справочник, естественно, обновляется с такой же регулярностью.


управление торговлей 8.0 | База знаний | mista.ru

управление торговлей 8.0

maks 18.05.2004 05:25 | Здраствуйте! Установил предприятие 8.0 (8,0,6,3) затем управление торговлей (8,10,1,6) все вроде прошло нормально, но кагда заходишь в конфигуратор то нельзя редактировать торговлю. Пишет что конфигурация открыта только для чтения, а очень нужно изменить один документ. Если работаешь с пустым конфигуратором то все нормально можно создавать свою базу и все такое.
cowa 1 - 18.05.2004 06:43 | Конфигурация\Подержка\НастройкаПодержки\СнятятьСПодержки
BorisG 2 - 18.05.2004 06:50 | А ЖКК есть? Там все написано. Ключевое слово "поддержка конфигурации". Дабы не быть обвиненным, что я отвечаю чужимы словами.


Открыти базы после обновления 1с | База знаний | mista.ru

Открыти базы после обновления 1с

Dobpiy 11.05.2004 09:38 | Сделали обновление 1с. После этого пытаемся открыть старую базу. Она открывается, пишет внизу ошибку(что-то типа не может быть субсчёта), и вроде работает .Но через минуту аварийно закрывается. Как быть?
SnarkHunter 1 - 11.05.2004 09:49 | Что есть "обновление 1с", которое вы сделали?
vva 2 - 11.05.2004 18:10 | У меня было такое. Пришел к клиентам обновлять бухгалтерию стандартную. Сохранил базу. Запустил Объединение конфигураций, приоритет загружаемой конфы, метод замещать объекты (короче как обычно). Короче обновилось все вроде, я сохранил опять базу. Начал загружать в режиме предприятия: снизу надписи ... идет проверка обновления ИБ. ...Субсчет такой-то некорректен (что-то в этом роде) База пашет, но каждый раз при запуске вот такая ерунда. Пробовал всяко, тестировал, видимо косяк в самой базе, может быть Юзеры эти (клиенты) неправильно как то пользуются прогой, а ЧТО ИМЕННО НЕ ЗНАЮ.


1C стоит того чтобы начать изучать? Чем она лучше Фокса? | База знаний | mista.ru

1C стоит того чтобы начать изучать? Чем она лучше Фокса?

Orion 09.06.2004 09:25 | Услышал недавно о существовании СУБД 1С. Пошарился по интеру. Инфы о ней совсем мало. Язык с виду не сложен в освоении. Фокс 8-й гораздо сложнее по сравнению с 1С будет. Но документации по нему больше и говорят возможностей он предоставляет несравнимо больше. Что выбрать для изучения?
¶ 3 - 09.06.2004 09:37 | Никакой 1С в природе не существует. Это выдумка неких братьев Нуралиевых, которых, как показали последние исследования, тоже никогда не было. Миф о существовании некой 1С - широкомастштабная мистификация неудачливых конкурентов Майкрософт, использовавших его, чтобы вытеснить с российского пространства Фокс и другие неспециализированные среды разработки. Что, надо сказать, им неплохо удается.
Rom 4 - 09.06.2004 09:43 | (0) Продукты 1С кормят сегодня огромную армию программеров. Средний заработок в отрасли (г. Москва) 700 - 1500 у.е. Эта была информация к размышлению...
VladZagorsky 5 - 09.06.2004 09:46 | 2Orion: Не стоит, однозначно ! Если все начнут изучать 1С, средний заработок программиста 1С упадёт (конкуренция, понимаешь). Мне это совсем не нравится! Так что занимайся Фоксом!
Rom 6 - 09.06.2004 09:51 | (5) Не согласен. Спрос на 1С растет с каждым днем...
VladZagorsky 7 - 09.06.2004 09:53 | Хм... Для большого города это, конечно, не актуально...
Orion 8 - 09.06.2004 09:57 | Я вообщето серьёзно спросил. В чём преимущества 1С перед Фоксом?
Rom 9 - 09.06.2004 10:03 | (8) Нужно обсуждать не преимущества, а перспективы и тенденции. В ближайщее время 1С значительно потеснит своих конкурентов на российском рынке. И дело здесь не сколько в технологической платформе, сколько в уровне и качестве поддержки (обслуживании) конечных пользователей. А техническая документация по 1С действительно хромает... :(
Orion 10 - 09.06.2004 10:11 | Если о тенденциях, то как быть в такой ситуации: Если я напишу учётную программу на 1С 8,0 то заказчик может отказаться у меня её приобрести, мотивируя это высоими ценами на платформу (1С). Хотя стоимость моей разработки в 1С будет ниже, чем в Фоксе (предполагаю). Писать на 1С 7,7 - вроде бы уже не актуально (судя по статьям на 1С-направленных сайтах - не перспективно, но платформа 7,7 недорогая) Напиши я ехе-шник на Фоксе - для заказчика это обошлось бы дешевле, чем моя надстройка + 1С 8,0 платформа.
SnarkHunter 11 - 09.06.2004 10:13 | (10)Не забывай про поддержку... Где потом тебя будет искать заказчик?
Rom 12 - 09.06.2004 10:23 | На фоксе в свое время начинал "Парус". Решения получались сложными для восприятия и закрытыми для изменения. Для отображения многих отчетов использовался Excel - что тоже очень не удобно. На сегодняшний день Парус автоматизирует в основном бюджетные организации... Вероятно, хорошие связи в "верхах"...
Orion 13 - 09.06.2004 10:23 | Я слышал, что надстройки на 1С успешно паролятся. Т.о. код закрывается для всех кроме разработчика. Если какая-либо фирма разработает надстройку для 1С и запаролит её, то где её будет искать заказчик в случае чего?
SnarkHunter 14 - 09.06.2004 10:24 | (13)Слышал звон...
Rom 15 - 09.06.2004 10:24 | (13) Большинство конфигураций 1С поставляются с открытым кодом. Использование защиты - право любого программиста.
VladZagorsky 16 - 09.06.2004 10:27 | Ну раз серьезно спрашиваешь - отвечаю. Для заказчика лучше всего будет, если ты напишешь на 1С. Потому как, всегда можно найти специалиста. По поводу дороговизны 8-ки. Ну что тебе сказать. Пиши на 7.7. Самый оптимальный вариант. .."Писать на 1С 7,7 - вроде бы уже не актуально"... Кто тебе это сказал? Плюнь тому в глаз ! Для тебя, как я понимаю, лучше на Фоксе. Потому как без тебя потом никто ничего не сделает. :) Это, конечно, хорошо... Но, если заказчики не лохи, то к этому варианту отнесутся с опасением...
427 17 - 09.06.2004 11:01 | "Если какая-либо фирма разработает надстройку для 1С и запаролит её, то где её будет искать заказчик в случае чего? " На 8-ке это становится реальностью... И будет реальностью... Так что про открытость можно забЫть ... или забИть Для решений фиск учета - 1С рулит... Хорошая методологическая постановка фиск и бух учета. Для решений упр учета - ответ неоднозначнвый... Регения не на 1С могут быть на порядок проще и всегда они более эффективные... Стоимость - почти всегда выше...
Valery 18 - 09.06.2004 11:42 | Как старый Фоксист скажу в чем осное преймущество 1С которое особенно мне понравилось. Реализация сетевой версии. На фоксе это такой геморой все это реализовать. На 1С об этом вообще думать не надо. По написанию программ: На Фоксе 10 строк - прикладной задачи 50 строк - служебнвх примочек (типа переключить индекс, создать связь и др. заморочки) В 1С об этом можно забыть и работать только над прикладной задачей. Но это не значит, что Фокс надо забыть. Он может где-то и пригодится. Я им всегда пользуюсь для просмотра и конвертации баз
427 19 - 09.06.2004 11:48 | Почему то отсутствие именно вот этого - 50 строк - служебнвх примочек (типа переключить индекс, создать связь и др. заморочки) - так не хватает в 1С... По большому счету только одно отличие существенно... Остальное - шелуха...


Слышали ли вы про комплекс "Бухта"? | База знаний | mista.ru

Слышали ли вы про комплекс "Бухта"?

Волшебник
03.06.2004 23:38 		Интересное название... :)
Насколько это сильный конкурент 1С? Или они работают на разных рынках и нельзя их считать конкурентами?

---------------------------------------
Платформа БУХта

Подразумевается, что платформа является таковой, если она позволяет сторонним разработчикам создавать, распространять и поддерживать свои готовые решения. Платформа должна оперировать бизнес-объектами, поведение и взаимодействие которых программируется с использованием встроенного языка программирования. Состав и функциональность этих бизнес-объектов должны быть достаточны для создания работающей информационной системы в разумные сроки (месяцы, а не годы).

http://www.buhta.ru/platform.html

---------------------------------------

Функциональный состав и возможности Финансово - Управленческого Комплекса БУХта.

- Полнофункциональный бухгалтерский учет.
- Автоматизация бизнес-процессов. Система продаж.
- Контур управленческого учета.
- Складской учет.
- Система развозки (логистика).
- Использование элементов методологии MRP и ERP.
- Работа с несколькими юридическими лицами.
- Индивидуальная настройка конфигурации для клиента.
- Система разграничения доступа.
- Удаленный доступ, работа с филиалами, складами.
- Мощные средства анализа информации.

http://www.buhta.ru/generalinf.html

---------------------------------------
Волшебник
1 - 03.06.2004 23:41 		Цитирую:

Планы разработок
"Ведутся исследовательские разработки по созданию нового поколения платформы БУХта 2.0"

http://www.buhta.ru/plans.html
-------------------------------------------

Цены вот такие: http://www.buhta.ru/price.html
Волшебник
2 - 03.06.2004 23:42 		Обзор здесь:
http://www.buhta.ru/obzor.html

Введение
Интерфейс пользователя. Просмотр, редактирование и печать информации.
- Главное меню, рабочий стол, панель инструментов, панель задач.
- Работа со списками. Редактор запросов.
- Предварительно настроенные фильтры, редактор фильтров.
- Шаблоны печатных форм. Дизайнер шаблонов.
- Ввод и редактирование информации.
- Дизайнер форм. Встроенные языки VBScript и PascalScript.
- Дизайнер схемы данных. Добавление новых полей. Добавление таблиц.
Информационная модель учета.
- План счетов.
- Документы. Виды документов.
- Система отчетности.
Прайс-лист. Система выписки заказов.
Система безопасности.
- Система разграничения доступа.
- Журнал событий.
- Система блокировки договоров, документов, проводок.
Конфигуратор.
GrayT
5 - 04.06.2004 00:07 		ИМХО тяжеловато и дороговато - (первое впечатление)
Еще интересно:

БУХта Генератор отчетов для 1С версия 0.9 beta

“БУХта Генератор отчетов для 1С SQL” – новейший программный продукт компании БУХта, представляющий собой специализированный генератор отчетов, для популярной линейки продуктов “1C:Предприятие 7.7” фирмы 1С. Генератор не производит какой-либо конвертации данных, а подключается к базам 1С в реальном режиме времени. Поскольку генератор отчетов использует всю мощь языка SQL (в реализации Microsoft), то он работает только на тех инсталляциях “1C:Предприятие 7.7”, которые хранят данные в формате MS SQL Server 2000.
...........................
При ознакомлении со структурой баз данных 1С оказалось, что ключевые принципы организации и обработки Документов, Проводок, Сальдо и Справочников субконто в БУХте и 1С очень похожи. Основное неудобство при конвертации данных было в том, что часть информации 1С хранит не в базе данных SQL, а в файле метаданных “1CV7.MD”, структура которого недокументированна и прямая работа, с которым не приветствуется самой фирмой 1С.

Тем не менее, мы изучили внутреннюю структуру файла метаданных (спасибо всем, кто уже сделал это до нас и поделился своими знаниями на “Территории 1С”) и создали конвертер, который, используя этот файл, создает и заполняет в базе данных SQL все таблицы (перечисления, субконто и т.п.), на которые есть ссылки из документов, проводок и регистров 1С. Для документов и справочников, которые присутствуют в базе данных SQL, (и имеют загадочные названия DH1001б,SCЗ234,SC13…), наш конвертер создает так называемые представления (VIEW) с нормальными названиями, как в конфигураторе 1С.

http://www.buhta.ru/1c_sql.html
ЗЫ: Есть демоверсия


Может ли 1С Предприятие 8.0 соперничать с Axapta? | База знаний | mista.ru

Может ли 1С Предприятие 8.0 соперничать с Axapta?

Sever 17.12.2003 14:22 | Может ли 1С Предприятие 8.0 соперничать с Axapta?
insert 73 - 05.05.2004 14:46 | На Территории ветка была про нехилые аппратнве требования восьмерки. Как всегда, много шума, каждый при своем. Свелось к замеру PC у участников. Так все-таки интересно, реально ли удовлетворить ее(восьмерки) аппаратные требования именно к клиентским машинам, а не к серверам (с ними все понятно). У меня к примеру 256 Мб 1100Ггц конфигурить можно, но в целом работать неприятно. "Тонкого" клиента нет и скорее всего не будет. УПП не видел, достаточно УТ.
BorisG 74 - 05.05.2004 14:59 | (73) На самом деле не совсем верные сравнения... без сервера предприятия. С сервером предприятия, и, соответственно с SQL, картина несколько другая ;-)
insert 75 - 05.05.2004 15:15 | Борис, вопрос к Вам к матерому волку-франчу. Планируется ли реально оптимизация V8? "Быстродействие пожертвовано ради функционала", так кажется, было заявлено фирмой-гегемоном. Что-то не видно в прикладных решениях, с которыми и работает конечный пользователь, никакого "функционала". Интересен он только разработчикам. Да, V8 на порядок сильнее семерки хотя бы языку. SQL-запросы тоже порадовали. Но остается непонятным, как все-таки создатели восьмерки ее позиционируют? Есть ли у большинства средних фирм (ЛВС 5-15 р/мест) стимул для дорогостоящего перехода. Или это официальный вызов MBS?
427 76 - 05.05.2004 16:28 | Борь, в ближайшие 2-3 года 8-ка соперничать не сможет... Ибо нет функционала... Его надо делать... Торопятся... Однако... Дырок в 8 будет - мама, не горюй .... Настраиваться она не будет - получим туже ахапту.... Под которую надо крутить предприятие... Развитие функционала приведет в повышению цены... и нехило... Систем такого уровня надо на два порядка меньше, чем на 7.7. Так что смена шила на мыло ....
insert 77 - 05.05.2004 16:35 | Что ж, придется согласиться с грустным, но справедливым мнением уважаемого Пита. Эх, последний стимул ночами в восьмерке ковыряться пропал... А как все красиво начиналось: новые супервозможности, большие внедрения, почти ООП, ERP епта :(
427 78 - 05.05.2004 18:26 | ERP - это в общем то функционал.... А 8 - это платформа... Очередная подмена понятий... Конечно, 1С будет стремиться к занятию этого рынка... Но нужны Инвестии (много...) Идеологи (грамотные... Это тоже деньги) Программеры ....(как гуана.... но хорошие - искать надо) Тестеры .... Время (которого катастрофически не хватает) ... Вопрос в том - хватит ли у фирмы всего, что потребно... в достаточном количестве.... или сдуются на полдороге.... P.S. разрыв между началом продаж ознакомительной (!!!) и по сути дела беты - больше года.... P.S. когда в якобы "финальном" релизе меняют структуру метаданных ...
BorisG 79 - 05.05.2004 18:32 | (76) Петь, меня ни в чем не надо убеждать... ибо слишком хорошо многое знаю... Увы. (77) Ну, предположим, красиво... для тех, кто только прессрелизы читал... Пока плюс восьмерки только в меньших первоначальных вложениях... что в условиях жадности некоторых руководителей... далее no comment... Более, чем 20-летний стаж работы с производством не позволяет выразиться более резко...
Разочаровавшийся 80 - 27.05.2004 14:03 | Да уж думал попал в нужную ветку. Одна трепня. Аксапту люди в глаза не видели, как можно говорить о том, чего НЕ ЗНАЕШЬ? В этом беда идеи форума, как такового.
Никто не занет, кто 81 - 28.05.2004 04:24 | Народ. Поднимите правую ручную лапу те, кто работал с Ахапкой. А теперь те, кто внедрял. Что, я в гордом адыночестве? Тогда поехали: + Да, Аксапта может в трехзвенке весело бегать на 300 целке-клиенте с 64 м оперативки. + Да, в ней java унутрях вся вусмерть объектно-ориентированная. Кстати. Цена лицензии за место, ТОЛЬКО лицензии - 1200 $. Плюс железки, плюс сервер БД, плюс лицензии на функци-анал, плюс... А! И еще внедрение. НО: - Стандартный функционал не умеет убивать операцию после ее проведения. (Что это такое, понять можно только поработав - какая это задница на словах объяснить принципиально невозможно). - Нет функции слияния конфигураций в принципе; - Лабать склад там - времени стока же, скока и на голой Яве. НЕТУ ТАМ предметно-ориентированных объектов, НЕТУ!!!!!! P.S. А интерфейс 8-ки... ВКУСНААААА!!!!
427 82 - 28.05.2004 06:35 | Типичная подмена агрессии проституцией .... "Стандартный функционал не умеет убивать операцию после ее проведения" .... можно и убить... но это принципиальный подход... Так называемый "аудиторский след" ... И этот подход во многих вопросах правильный ...
DimG 83 - 28.05.2004 09:13 | Вот вчера был на конференции по Навижн. Ну и что? Да ничего. При внедрении на производстве сплошные компромисы. Виртуальные склады. Очень много ручной работы. Рецептуры как таковой нет. Осталось впечатление что все это просто развод лохов и гнутье пальцев. Сможет ли восьмерка соперничать? Однозначно да! При грамотной постановке и внедрении. Кроме того не понравился интерфейс, дали демку, посмотрел. Напоминает какую-то самописку на фохпро. Все, имхо...
Морская свинка 84 - 28.05.2004 10:00 | (83) Мне вчера там же с учетом моего бюджета и того что хочется (производство поролона и т.д.) там же посоветовали поставить 1С. Крутые ребята ошибаютя только в пределах +/- 50000.
Маст Дай 85 - 28.05.2004 10:11 | А не кажется ли вам, что Ахапту разработали еврушки для достижения своих сионистских целей по контролю финансового состояния приедприятий им не принадлежащих ?
DimG 86 - 28.05.2004 10:16 | Мне кажется, что разработали они ее, в микрософте, сначала для себя, и один из докладчиков ляпнул что-то на этот счет, а потом решили это правильное "решение" (а позиционируют они ее именно как решение, а не программу) впарить всему миру...
BorisG 87 - 28.05.2004 10:24 | (85, 86) Видите ли, если не знаете истории , не стоит об этом говорить... Microsoft и Аксапту, и Аттейн НЕ РАЗРАБАТЫВАЛ... "...очень немногие люди, и притом самые замечательные, способны просто и откровенно сказать: "не знаю"... (с) Д.Рокфеллер ...
Маст Дай 88 - 28.05.2004 10:32 | Таки я опять прав. ЦЕО Навижн - из южан. Билли Гейтс - из подобной семьи. Рокфеллер - в н-ном поколении южный человек. Борух Гончаров - и подавно.
DimG 89 - 28.05.2004 10:37 | (87) не важно кто разрабатывал, на самом деле, просто говорил он что-то на счет того что они на ней работают, если я правильно понял т.к. говорил на ненашем, отсюда и вывод. А суть ответа в том, что считают они ее, ну... чуть ли единственно правильной, и поэтому решили "делится" со всеми, чтобы всем было хорошо, как и им.
Никто не занет, кто 90 - 28.05.2004 15:24 | (82) Я же говорил - на словах это не так ощутимо. Я знаю, зачем нужен аудиторский след. НО видно ты не понимаешь, как это работать с ним - когда ВОООБЩЕ не можешь удалить операцию. Только через таблицы. И видимо ты считаешь, что Аксапта не умеет пороть чушь типа Дт51-Кт51 - ишшо как умеет... Вот тока удалять не умеет.
sss 91 - 31.05.2004 12:34 | 2Никто не занет, кто 1.а про структуру базы можете подсказать: используются ли триггеры, хр, связи между таблицами - foriegn key, constains,...? 2.Что хзначит: "НЕТУ ТАМ предметно-ориентированных объектов" ? В смыссле аналогичных объекма Справочник, Документ..?
Никто не занет, кто 92 - 31.05.2004 18:58 | 1) Т.к. Ахапка живет и на M$ $QL, и на ораклине, все изыски типа триггеров смастерены на объектном слое. Нихрена кроме как индексей там нету. 2) Угу. Ты верно мыслишь.


1C+Linux | База знаний | mista.ru

1C+Linux

OffRoader 11.05.2004 13:56 | Кто- нибудь что- нибудь слышал о возможности работы 1С на Linux- сервере? Любая информация о положительном опыте использования эмуляторов, использования Sybase вместо SQL и любых других конструктивных идеях будет принята с благодарностью!
Черт 1 - 11.05.2004 14:56 | только если поднять самбу и складывать базы, а в остальном через VM но енто такой гем.........ой
OffRoader 2 - 11.05.2004 17:13 | Самба- это на поверхности, хотелось бы о реальном опыте использования VM или мож еще какого линуксового софта. Согласитесь, вопрос не праздный


Что лучше Акцент или 1С | База знаний | mista.ru

Что лучше Акцент или 1С

Максвер 04.08.2004 12:18 | Подскажите пожалуйста что лучше директр сказал узнать мне интересно ваше мнение
@LoNg 4 - 04.08.2004 12:33 | 3 ну и при чём здесь навиженовские продукты? насколько я понимаю в сабже речь идет о системе "Акцент" производства донецкой фирмы Импакт http://www.accent6.com/
Андрей Гринев 22 - 04.08.2004 13:59 | Мое сильно предвзятое IMHO :) Кратко : 1. Акцент - очень гибкий инструмент. Гибкий и для пользователя и для программиста. 2. Акцент - это очень прозрачный инструмент. Никаких промежуточных сумм, никаких "тибличных частей", никаких шансов на то, что документ несделает проводки. 3. Акцент - мощный аналитический инструмент. Количество планов счетов и аналитических направлений (субконто по вашему) не ограничено, аналитика не привязана к счету. Присутствует система ярлыков, которая позволяет оргинизовать неограниченное количество классификаторов для одного и того же набора элементов справочника или плана счетов. 4. Наличие инструментария для пользователя, которые позволяют формировать отчеты, менять учетную политику и пр. без программирование. 5. Средства для разделения прав доступа. 6. Надежность, правильный клиент-серверный вариант. По каждому тезису можно дать расшифровку в сравнении с 1С, например.
SFG 23 - 04.08.2004 14:06 | 22. Имеется свой встроеный язык?
НеМногоПродвинут 25 - 04.08.2004 14:09 | Не возникает ли больших проблем при пользовании инструментами самим пользователем, а то юзвери на многое способны...
sashat 26 - 04.08.2004 14:10 | 4. Наличие инструментария для пользователя, которые позволяют формировать отчеты, ___менять учетную политику и пр.___без программирование А вот это может быть большим минусом. Особенно для некоторых ОЧЕНЬ ИНТЕЛЕКТУАЛЬНЫХ бухгалтеров.
Тот 27 - 04.08.2004 14:12 | На мой взгляд, с точки зрения пользователя, преимущества 1С в количестве и доступности специалистов по ней. И по "донастройке" и бухов-пользователей. Правда, это имеет и "минус" - безграмотных 1С-ников в абсолютном выражении - гораздо больше. Другое преимущество, на мой взгляд, это быстрая реакция на "нововведения". Хотя это Андрей Гринев сможет опровергнуть, если возьмет статистику по обновлениям Акцента и 1С. У меня её просто нет. Интересно бы получить объективную информацию по скорости реакции на законотворчества 1С и Акцента. С точки зрения Акцента как средства разработки, обсуждать даже не хочу. На мой взгляд 1С здесь вне конкуренции.
Андрей Гринев 30 - 04.08.2004 14:18 | (23) Средства конструирования : формы первичных документов (многостраничные), диалоги а-ля MS, встроенная электронная таблица, программные модули. Встроенный язык MS Visual BASIC Script. Но, если сравнивать с 1С, объем кода на нем существенно ниже из-за того, что объектная модель более функциональна. Есть доступ к базе напрямик через DAO или ADO, в зависимости от используемой СУБД. Формы и диалоги поддерживают ActiveX
Андрей Гринев 32 - 04.08.2004 14:24 | (25, 26) Дело в том, что основной костяк пользователей Акцента - бухгалтеры, которые предпочитают быть уверенными в правильности поведения программы и, соответственно, отвечают за свои действия. Вместо того, чтобы кивать в сторону программы, какой бы она не была именитой. Гибкость всегда можно ограничить.
Groks 33 - 04.08.2004 14:26 | (29) Завсисимость от изменения констант - это особенность конкретной КОНФИГУРАЦИИ 1С:Предприятия, а не самого 1С:ПРЕДПРИЯТИЯ. Не нравится такая заисимость - никто и ничто не мешает в КОНФИГУРАЦИИ такие зависимости поустранять.
Groks 37 - 04.08.2004 14:30 | Вопрос к Андрею Гриневу - в чем реализван Акцент? (среда программирования)
Андрей Гринев 38 - 04.08.2004 14:38 | (27) Извини, но ты и не компенетен обсуждать средства разработки, поскольку ты никогда не программировал в Акценте. Для меня показателем есть объем кода и время разработки с нуля для одного и того же функционала. Чем меньше код и время, тем лучше инструментарий. Акцент проектировался с учетом того, что 1С уже есть, спецов по ней прорва. Поэтому инструмент должен быть производительным, а клиенты должны платить не за визиты программера, а за то, что программа работает.
sashat 39 - 04.08.2004 14:39 | (33) - Я говорю про бухов. ТО, что изменять нужно все, что ненравиться в конфигурации с этим я согласен. Но вот сможет ли САМ бухгалтер правильно разобраться и исправить? ВОТ в чем вопрос.
OctoberHammer 41 - 04.08.2004 14:41 | У меня такой вопрос - объем кода в Акценте сравнивается с аналогичным показателем в 1С в77 или 1С в8?
Андрей Гринев 42 - 04.08.2004 14:42 | (33) Можно долго и нужно спорить. Но ! В Акценте пользователь волен поменять правила проведения так, как ему заблогорассудится. В 1С этого нет.
Андрей Гринев 43 - 04.08.2004 14:44 | (37) VC++
sashat 45 - 04.08.2004 14:45 | (42) - Ладно будем считать это как факт. Ответ про скорость обновления будет?
Андрей Гринев 47 - 04.08.2004 14:50 | (39) Есть контрольный пример, есть линия консультаций, в том числе и по методике. Я уверен, что поступаю честно, когда даю пользователю право выбора между моей методикой и его собственной. Решить все проблемы одним махом не получится даже у 1С. К тому же напороть бока можно и на 1С с жесткой учетной политикой.
Андрей Гринев 48 - 04.08.2004 14:55 | (41) Молочный дом (т/м "Фанни"), ЗАО Геркулес, СП Гефест, заводы ИСД, МАУ, много страховых компаний, "Майский чай" и пр. Достаточно много. Сходите на сайт www.accent6.com - там есть небольшой список.
sashat 50 - 04.08.2004 14:57 | Вопрос по ценам. СКОЛЬКО СТОИТ И КАК СКЛАДЫВАЕТСЯ ЦЕНОВАЯ ПОЛИТИКА? И как распространяются обновления? бесплатно или за плату?
Андрей Гринев 52 - 04.08.2004 14:58 | (45) Мы стараемся успеть вовремя :) Пока получалось чуть быстрее 1С :) "Потупив взгляд и ковыряя землю носком ботинка" (с) не помню кто.
OctoberHammer 53 - 04.08.2004 15:01 | Давайте еще рассмотрим вопросы защиты ПО от несанкционированного копирования и бесплатных (или условно-бесплатных) версий для разработчиков
Kopyl 55 - 04.08.2004 15:02 | (0) Не равняй две разные программы, это все равно что 98-ю с XP сравнивать, (хотя и можно попробывать) (22) Уточню 1. только для программиста 2. табличных частей - море (просто нужно расшифровывать) 3. Без ОЛАП приложений "ни в дугу" А вот с "ярлыками" конечно прорыв, по сравнению с 1С 4. "Визард отчета" прямо в программе а не в конфигураторе, это круто, но опять же правильно его настраивают только программисты 5. и особенно 6. 100% согласен А вот с Внешними (независимыми) компонентами - промах, простой XML обмен чего стоит, (и в деньгах тоже)...
Kopyl 57 - 04.08.2004 15:06 | (45) Я отвечу (надеюсь андрея не обижу) Обновления мелкие (исправления багов), ежемесячно а то и чаще Обновления крупные (новые релизы) раз в дра года, при чем, посмотрите на сайте прайс, чтобы из 6 на 7 перейти, плати 50% стоимости
Тот 58 - 04.08.2004 15:11 | 52. А в цифрах - не изучали вопрос? Т.е. - принято изменение законодательства - дней - выпущено обновление.
Kopyl 60 - 04.08.2004 15:15 | (56) только дело привычки....
OctoberHammer 63 - 04.08.2004 15:25 | Вопрос еще к Гриневу - можно ли по-прежнему заказать компакт с 60-дневной копией Акцента, который пришлют почтой бесплатно?
Андрей Гринев 66 - 04.08.2004 15:29 | (50) на сайте www.accent6.com все есть (53) аппаратной защиты нет. Есть защита на уровне лицензий, т.е. количество лицензий и количество компьютеров с Акцентом в сети. Для того, чтобы попробовать есть триал версия на 60 дней. Допускается выдача лицензий с ограниченным временем. Опять таки, чтобы попобовать.
skunk 67 - 04.08.2004 15:35 | и чего-то не нашел где компакт-закзывать
Андрей Гринев 68 - 04.08.2004 15:36 | (55) 1. только для программиста Чем для пользователя 1С гибче Акцента ? 2. табличных частей - море (просто нужно расшифровывать) Акцент хранит всю информацию в проводках. Оттуда же и ведутся рассчеты. У 1С есть документы, есть проводки по ним и есть промежуточные данные. 3. Без ОЛАП приложений "ни в дугу" Да, у мастеров отчетов есть ограничение в 4 уровня показателей. Но что есть подобного в 1С ? 4. "Визард отчета" прямо в программе а не в конфигураторе, это круто, но опять же правильно его настраивают только программисты Ну, если бухи не в состоянии расставить "птички" или выбрать показатели ... Опять таки, в 1С этого просто нет
Андрей Гринев 69 - 04.08.2004 15:37 | (60) Не только. В Акценте много чего получается одинм движением мыши, когда как в 1С для этого нужно попотеть.
Андрей Гринев 70 - 04.08.2004 15:39 | (63) Да, по Украине. Если заказывают в городе, где есть представительство, то принесут и покажут бесплатно (диск останется).
Kopyl 72 - 04.08.2004 15:41 | (68) а 64 класно получилось 1. согласен 2. Следствие, при больших "оборотах", остатки рассчитываются медленно 3. набор готовых, (посторонних) отчетов 4. Программа для продажи долна быть "готовым решением", а не "конструктором"
Kopyl 73 - 04.08.2004 15:43 | (70) А мы платили за 60 дневную демо версию в представительство 120грн. Ни о какой безплатной версии никто и речь не вел, когда мы захотели попробывать прогу.
Андрей Гринев 85 - 04.08.2004 16:07 | (67) форма заявки была на сайте www.accent6.com.ua. Он сейчас в дауне :( Можно писать мне : почтовый адрес и название предприятия. (57) Немного не так. Есть обновление самой программы, а есть обновление типовой. И то и другое - не чаще раза в неделю. При чем обновление программы происходят с убыванием частоты. Обновление типовой зависит от законодательства, ошибок и расширения функционала. Переход 6->7 начал стоить не менее 65% версии 7 только с марта. До этого времени переход стоил разницу между стоимостью программ. (58) Почему ты считаешь, что 1С занимается законотворчеством или, по крайней мере, сидит к законодателям ближе ? Я гарантирую, что, например, для страховых компаний, мы делаем обновления быстрее того же Форта.
Андрей Гринев 86 - 04.08.2004 16:10 | (70) Извини, но ты взял демо вместе с книгой и, по сути, платил за книгу. Может и дорого, но никто не напрягал. Сейчас мы триальщиков даже консультируем бесплатно. А в Днепре им лекции читают тоже бесплатно.
OctoberHammer 87 - 04.08.2004 16:12 | (86) - (70) это кому, простите.
Андрей Гринев 88 - 04.08.2004 16:24 | Предыдущий пост не (70), а (73) (71)7.7. У меня есть 8.0 на машине, но я не нахожу принципиальных отличий от 7.7. Те же шашечки можно было и там сделать. Что касается файл-сервера в одном файле и 3-х звенки - поживем увидим. (72) 4. Да, но только для стандартных отчетов. Все остальное - можно максимально оптимизировать. Средств полно. (75) Судя по этому посту ты и OLAP не спец :) (84) Есть конвертилка 7.7 -> Акцент
OctoberHammer 89 - 04.08.2004 16:27 | 2(88) Как вы считаете, почему 1сники предпочитают для домашнего использования ломать 1С Соболем и другими крэками, вместо того, чтобы переводить своих клиентов на Акцент, и самим пользоваться условно-бесплатной версией для разработчика?
Андрей Гринев 91 - 04.08.2004 16:34 | Доминирование продукта на рынке есть основное, что определяет поведение пользователей. Все остальное - не существенно.
Андрей Гринев 92 - 04.08.2004 16:38 | (90) Приведи цифры 1С, например по зарплате. В этом году до апреля месяца законодательство менялось не менее раза в неделю. Сколько за это время вышло обновлений 1С ?
Kopyl 93 - 04.08.2004 16:45 | Мне вот это понравилось, особенно "про дома" http://www.accent6.com/humor.php
Тот 94 - 04.08.2004 16:52 | 92. Если не коммерческая тайна - сколько человек работает на фирме и сколько у неё партнеров? Сколько продаж?
Kopyl 95 - 04.08.2004 16:55 | Ах. да. вспомнил. Администратор (по аналогии с 1С-Конфигуратор)продается отдельно. SQL server отдельно (на нелицензионный нехотят ставить). и опять (86) http://www.accent6.com/products.php- прайс 60 дневка-100грн
OctoberHammer 96 - 04.08.2004 17:03 | 2(95) А я-таки получил бесплатно. Я попал под акцию? Правда без книжки, голый компакт.
OctoberHammer 97 - 04.08.2004 17:06 | 2(92) Как получить конвертилку 1Св77-> Акцент 6.0 Это конвертилка конфигураций, или конвертилка данных. Для каких конфигураций? Типовых, или все равно каких?
Андрей Гринев 98 - 04.08.2004 17:07 | (94) Ответ вопросом на вопрос говорит о том, что на мой пост (92) ответ не в пользу 1С ? Партнеры есть на сайте. Количество персонала 30-40 человек. Но мерять аршином 1С не нужно. Столько клиентов, сколько обслуживает один дилер Акцента, одному 1С-нику просто не снилось :) Без обид - это факт.
Андрей Гринев 99 - 04.08.2004 17:22 | (95) Акцент-администратор - это не конфигуратор. Это администратор прав доступа. (96) Компакт всегда был и есть бесплатный. В прайсе его нет. (97) Это конвертилка данных. Настраивается на любую конфигурацию.
Тот 100 - 04.08.2004 17:25 | 98. Я же говорил ранее (27) что не располагаю данными на эту тему. Интересно бы узнать цифры и по второй части поста.
Андрей Гринев 101 - 04.08.2004 17:31 | (100) Сходи на наш сайт, посмотри WhatNew для типовой Акцент 6.0. Потом сходи на сайт 1С , где есть перечень обновлений за этот же период. Потом результат тут опубликуй. Людям сделаешь приятное и удовлетворишь свой интерес. В общем лишнее время потратишь с пользой :)
Андрей Гринев 111 - 05.08.2004 10:25 | (107) VBS - это упрощенный VB, поэтому конструкции одинаковы. Что касается 1С 7.7, то конструкции ее внутреннего языка обременены файл-серверным истоком. Ну, например, нет понятия "коллекция", соответственно нет свойства "количество в коллекции". В 8.0 такой термин появился, но я сейчас специально посмотрел - это не то. (105) На здоровье. Я уже умолкаю :) Желающие могут пообщаться ICQ:156989059


Продажа 1С -Предприятия | База знаний | mista.ru

Продажа 1С -Предприятия

здысь 30.07.2004 10:29 | Собственно такая ситуяция. Наша компания мирно накрылась и возникает такой вопрос по 1С, а куда ее родимую. Франчу отнести назад и попросить денег наверное глюпо. А как с юридической точки зрения мы имеем право продать ее третьему лицу, и будет ли в этом случае действовать лицензия на программу?
BorisG 2 - 30.07.2004 10:35 | А что, ГК кто-то отменил? Просто продайте, и все, проблема то в чем? С регистрационной анкетой сложнее, надо ее перерегистрировать в 1С на нового владельца... Это все.


Увязать 1С и ОЛАП | База знаний | mista.ru

Увязать 1С и ОЛАП

Валентин 25.07.2004 16:33 | subj собственно. Где и что можно почитать по этому поводу? Может кто уже занимался? Что одскажет о граблях?
Валентин 3 - 25.07.2004 17:41 | Ну ни как еще не представляю. Вижу всю эту ерунду только 2 неделю. В голове - хаос. Единственное что понимаю - неэффективность многих вещей в 1С (типовых конфигурациях торговли). На http://sql.ru/forum/actualtopics.aspx?bid=26 есть много умных мыслей. Но как их привязать к моей ситуации - не понимаю. Тут пытаюсь изобразить куб для финотчетности (кто, сколько, когда, какого товара, каким из сотрудников) - ни фига не получается. Уперся в MDX для просроченного долга и дальше никуда. А представляю это себе примерно следующим образом - 1. Выгрузка данных/преобразование к нужным форматам (думаю неэффективно использовать 36-ричное представление (строки долго обрабатывать)) 2. Фильтрация/устаовление значений по умолчанию 3. Собственно загрузка в куб/кубы (отражение финсостояния, склад, затраты)
Матрейя 4 - 25.07.2004 17:47 | 3. Может в SQL создать большую многоуровневую таблицу (внешнюю по отношению к 1с), во время проведения доков - производить движения в этой внешней таблице. Потом, используя ее иеархичность, строить по ней всякие многоуровневые отчеты.
Валентин 5 - 25.07.2004 17:55 | То ест использовать INSTEAD OF тригерры. Для 1c на SQL это смерть. Рычаги. И кроме этого надо помнить обовсем при написании проведения/перепроведения документа. А уж если рискнешь поменять структуру регистра - абзац Да и не в этом проблема если честно. Для меня сейчас более важно вообще понять что есть ОЛАП. Какая польза моему предприятию от использования этой технологии. Насколько мои данные готовы к data mining. Вот тут есть люди с гордым титулом "Инженеры знаний". Оказывается есть и другое назначение у них, не только ветки сортировать
Матрейя 6 - 25.07.2004 18:00 | 5. Ты не совсем правильно понял мою мысль. OLAP - предполагает получение любой аналитики в любых разрезах. Реализовать это на 1с достаточно сложно. Просто можно использовать внешнюю SQL таблицу, средствами ADO записывать в нее данные и извлекать. Универсальные процедуры и функции для одной единственной таблицы описать не сложно.
Валентин 7 - 25.07.2004 18:11 | Мне кажется более просто делать выгрузку. Не заморачиваться с выяснением внутренних идов на ходу а ночью тихонечко пересчитать все как надо. Другой вопрос что не представляю что пересчитывать. Да и опять же вопрос совметимости выгрузки при изменении конфигурации. Короче куда ни кинь ...
Матрейя 8 - 25.07.2004 18:16 | 7. То же самое тогда можно получить и сложными отчетами с каким-нибудь самоформирующимся составным запросом. В случае с SQL таблицей - возможно получение аналитик в реальном времени.
Валентин 9 - 25.07.2004 18:21 | В случае 1С я сильно сомневаюсь вообще в возможностях работы в реальном времени. ROLAP убьет базу. MOLAP - производительность. Опять же регистры эти убогие. Все же мне кажется что нужно просто как-то умудриться описать бизнес процесс предприятия не в термнах конфигурации 1С, а каким-то более общим образом. Вот по этому вопросу бы что-то найти почитать
Матрейя 10 - 25.07.2004 18:24 | 9. Не обращаясь к таблицам 1с, а просто создай внешнюю таблицу (не в составе конфигурации) средствами SQL. Типа XBase, только для SQL.
Валентин 11 - 25.07.2004 18:27 | Не обращаясь к 1С потеряю справочники/документы Стоимость запроса к серверу из ADO все же ощутима, и использовать эту фишку при проведении/перепроведении/создании и т.д. не хочу. Но коль пошла такая пьянка, то вопрос по существу В таблице фактов есть поля 1. ДатаОперации (день когда прошла операция) 2. ОплатитьДо (день после котрого оплата считается просроченной) 3. Сумма (сумма денег) 4. ЭтоОплата (1 если оплата, 0 если закуп) В итоге надо получить 1. сумму просроченного/непросроченного долга на дату 2. Количество дней просрочки на дату Использую MS AS В качестве клиента - Excel Вопрос - как построить вычисляемый мембер, для 1 и 2 На самом деле даже немного проще - как сравнить даты? Когда пишу datediff("d",[ДатаОперации].currentMember,[Оплатитьдо].currentMember) для выснения сколько дней в прошло просрочке - выдает #ERR Почему?
Матрейя 12 - 25.07.2004 18:41 | 11. Не потеряешь - ведь можешь ввести сквозную кодировку всех нужных объектом метаданных - типа как в MOD, только попроще.
Матрейя 13 - 25.07.2004 18:45 | +12. Поиск 1с объектов попавших в выборку искать средствами 1с.
Матрейя 14 - 25.07.2004 18:47 | Дату лучше изначально записывать в числовом представлении: 20040814(можно добавить и время, тогда так 20040814015247)
Матрейя 16 - 25.07.2004 18:57 | 15. 12. - у справочников - единый реквизит IDD, для доков не нужен - достаточно записывать числовое представление вида, номер и дату. То есть имея эти идентификаторы - всегда найдешь нужный 1с объект. 13. Допустим запрос OLAP вернул тебе выборку из ста элементов, где значения элементов - это IDD значения справочников + набор идентификаторов дока. Пройдясь по рекордсету - формируешь ТЗ, где стороковое представление элементов заменяешь на представление элементов 1с (типа Спр.НайтиПоРеквизту("IDD",ЗначениеРекордсета);
Валентин 17 - 25.07.2004 19:00 | Т.е. В качестве клиента для ОЛАП использовать 1С? Есть ли в этом смысл?
Матрейя 18 - 25.07.2004 19:10 | 17. Совершенно верно. Смысл наверное есть, поскольку не привязан к сторонним разработкам. ADO- в составе WIn, SQL сервер можно вязть и бесплатный (MySQL), а 1с- просто удобная среда для быстрого программирования.
Валентин 19 - 25.07.2004 19:13 | Может по (11) что подскажешь? Если честно, то при таких раскладах лучше 2С. Удобная (правда временами глючная) среда. Больше возможностей. Ни к чему не привязан. И бесплатно.
Матрейя 20 - 25.07.2004 20:02 | 19. Посмотри ветку (насчет 11) "Посоветуйте структуру регистров". Что касается 2с - я юзаю в качестве эксперимента, но пока не могу уверенно судить о возможности практического применения.
Валентин 21 - 25.07.2004 20:08 | Вопрос если честно не в реализации на 1С. Не буду менять конфу. Вопрос в MDX запросе. Где хотя бы про это написано?
Валентин 23 - 25.07.2004 20:17 | MDX - язык запросов в ОЛАП. Позволяет формировать выходной рекордсет так, так тебе нужно (накладывать условия, пересечения, объединения, выбирать нужные множества) Не похож на SQL
Матрейя 24 - 25.07.2004 20:23 | 23. Я лично вижу реализацию только на SQL, когда иеархичность (система координат куба) достигается за счет сквозного многоуровнего классификатора событий (каждое событие вдобавок имеет состав аналитик). Элемент классификатора - для каждой записи в таблицу данных.
Валентин 25 - 25.07.2004 20:28 | Хочу уйти от SQL. Сильно зависит от конфигурации. А писать свои отчеты под каждого клиента - глупо. Кажется более реальным - нормальная структра кубов + человеческий клиент. Кстати, сейчас посмотрел подключение через DSO (http://rom1c.narod.ru/adomd.html) катит в 1С, так что твоя идея не лишена смысла. Еще бы бесплатный OLAP сервер где надыбать.
NS 26 - 25.07.2004 21:45 | никто не в курсе, что такое PivotTable?
Валентин 27 - 25.07.2004 21:47 | Компонет такой в офисе. Чаще всего используется для отображения сводных данных. А о MDX ты не в курсе? Скоро уже спать, а (11) все никак победить не могу...
Матрейя 28 - 25.07.2004 22:08 | 27. Это тебе NS подсказку решения дает, а не спрашивает.
Валентин 29 - 25.07.2004 22:18 | А вот теперь эту подсказку мне бы еще понять. Задача ведь конкретна. Проникся твоей идеей, хочу запихать все в 1С. OWB ложить не хочу. Хочу запросом!!!!! with member [Measures].[ПросроченныйДолг] as 'что здесь надо написать?' with member [Measures].[НаСколькоДнейПросроченно] as 'что здесь надо написать?' Как найти множество от ДатаОперации до ОплатитьДо?
Матрейя 30 - 25.07.2004 22:23 | 29. Переведи дату в числовой формат 2004.08.12 = 20040812 - универсальный формат. Where _Dat<=ЧисловоеПредставлениеДатыОперации and _Dat>ЧисловоеЗначениеОплатитьДо. Разница - просроченость - легко вычисляется арифметически и возвращает число дней.
Валентин 31 - 25.07.2004 22:26 | Разница в днях/месяцах/годах считается datediff. Вопрос в получении множества дат лежащих в пределах от дата1 до дата2. В вычислении просроченного/непросроченного долга на заданную дату
Матрейя 32 - 25.07.2004 22:34 | 31. Будешь смеяться, но структуру регистра я привел в ветке "Посоветуйте струтктуру регистра...", пост №4. Множество дат в том случае - список значений фильтра регистра, который вычисляется в цикле(прибавление 1 на число раз разницы) - поскольку значения даты - число - то очень быстро.
Валентин 33 - 25.07.2004 22:41 | Да не спорю что быстро. Но вот беда - не катит такое объявление регистра. Конфа у клиента - типовая. ТиС 9.2 Объем базы большой вот и хочет быстро получать отчеты. Понимаю что могу хранить даты как заблагорассудиться. Числом, строкой, хоть varchar(4000). Запрос от этого не меняется очень уж сильно. Не будет datediff, будет просто разность. В 31 описано что нужно. И формат хранения даты здесь ни причем...


FAQ и полезности по 1С | База знаний | mista.ru

FAQ и полезности по 1С

Волшебник
21.06.2004 10:21 		FAQ1C - часто задаваемые вопросы по 1С: Предприятие 7.7:
о SQL-версии
о терминальным сервером
о распределенных базах (пока небольшой раздел)
Вопросы подчерпнуты из эхо-конференции fido7.ru.f1csoft

http://www.mycgiserver.com/~gorbunov/faq1c/index.htm

=========================================
Объект "Метаданные": программным путем можно получать описания структур метаданных конфигурации. Однако документация от фирмы 1С более чем неполна. Здесь содержится дополнение к документации.
Просто киньте als-файл в каталог программы (157 килобайт).

Автор: (с) - 2001,2002 Моисеенко П.П. и куча соавторов. Редакция от июля 2002.

http://www.mycgiserver.com/~gorbunov/files/metals154.zip
=========================================

УРИБ - Описание функций языка программирования для распределенных баз данных:

Файл в формате "Синтакс-помощника". Просто киньте als-файл в каталог программы (1,4 килобайт).

http://www.mycgiserver.com/~gorbunov/files/rbd.zip
=========================================

Автоматическое склонение фамилий в разных падежах - функция на языках 1С, Pascal (Delphi) и Basic:

Это возможно!!! В большинстве случаев работает правильно.

Автор - Юрий Железняков, 2002 г.

http://superjur.narod.ru/padeg.htm

=====================================================

Мастер пакетных файлов: Умеет готовить и запускать пакетные файлы в формате 1С: Предприятие 7.7.
Задачи резервного копирования и обмена данными в распределенной БД выполняются полу- или полностью автоматически (117 килобайт).

http://www.mycgiserver.com/~gorbunov/files/eb.zip

=================================================

Механизм слежения: дополнение к конфигурации для детального отслеживания изменений пользователем любых реквизитов документов.
Записывает в журнал регистрации очень подробно - "что было, что изменили, что стало".

Встраивается небольшими усилиями в любую конфигурацию.

http://www.mycgiserver.com/~gorbunov/doclog.htm


Удалить помеченные объекты | База знаний | mista.ru

Удалить помеченные объекты

Diletant
06.07.2004 11:57 		Хотелось почистить справочник сотрудников. Есть объекты, помеченные на удаление, но имеющие ссылки на системный справочник "налоговая карточка".
Как можно все же удалить эти объекты?
bets
1 - 06.07.2004 12:04 		Удалить ссылки у элементов спр."Сотруднки" (Shift+F4) и заново сделать "Удаление помеченных объектов"
Asmody
2 - 06.07.2004 12:05 		см. НайтиСсылки() и УдалитьОбъекты()
Warlock
3 - 06.07.2004 19:36 		(0)Если чистить не программным методом - то (1)
Если программным, то
Спр = СоздатьОбъект("Справочник.Сотрудники");
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент() = 1 Цикл
Если Спр.ПометкаУдаления() = 1 Тогда
Спр.НалоговаяКарточка = "";
Спр.Записать();
КонецЕсли;
КонецЦикла;
Warlock
4 - 06.07.2004 19:38 		(2)Это в данном случае не катит. Разве что УдалитьОбъекты(<Объекты>,<Проверять>,<Ссылки>), где Проверять = 0, но контроль ссылочной целостности...
Diletant
6 - 07.07.2004 05:20 		Нет, не совсем получилось...
Те элементы справочника сотрудников создавались при тестировании ИБ.И если я их удаляю прямым удалением, то при тестировании они вновь создаются...

"Неразрешенная ссылка. Создан новый элемент. Справочник Список приказов длительного действия выбранного сотрудника"

Это безнадежно?
Warlock
7 - 07.07.2004 08:16 		(6)Ну если уже повыносил их без контроля, то зайди в настройки ТиИ и поставь "При наличии ссылок на несуществующие объекты" - "Очищать ссылки" и "При частичной потере данных объектов" - "Удалять данные объектов".


общмй вопросы по 1С | База знаний | mista.ru

общмй вопросы по 1С

gleb64
26.05.2004 15:38 		Уважаемое, сообщество.
Я работаю на фирме разработчиком баз данных (VB + SQL server 2000). Фирма не бедная и не жадная, и я решил взять на себя и 1С (в первую очередь для увеличения зарплаты).
Но оказывается наша фирма отказалась, от каких либо изменений в базовой конфигураций (кроме, естественно общих). Всё потому, что раньше пользовались услугами фирмы поставщика, и каждый раз при плановых обновлениях, получалась путаница, особенно, когда уволился человек делавший эти доработки. Потому, фирма пришла к выводу, нужно пользоваться только базой, а тот бухгалтер, который не решает свои задача в ней, плохой бухгалтер. Понятно, что методами 1С нельзя разработать серьёзные экономические программы (отсутствует поддержка SQL, ADO, обработка событий клавиатуры, мыши, остальные заменены одним: формула, и т.д., и т.п.).
В связи с этим у меня вопросы: во-первых, зачем вообще нужны программисты 1С, и, во-вторых, зачем переходить с DBF версии на SQL версию, если 1С не использует и десятой части возможности MS SQL Server.
С уважением, Глеб.
Волшебник
1 - 26.05.2004 15:40 		"методами 1С нельзя разработать серьёзные экономические программы"

Движенья нет, сказал мудрец брадатый.
Другой смолчал и стал пред ним ходить.
Сильнее бы не мог он возразить;
Хвалили все ответ замысловатый.
Но, господа, забавный случай сей
Другой пример на память мне приводит:
Ведь каждый день пред нами солнце ходит,
Однако ж прав упрямый Галилей.
SnarkHunter
2 - 26.05.2004 15:45 		Как связаны "отсутствие поддержки SQL, ADO, обработки событий клавиатуры, мыши, остальные заменены одним: формула, и т.д., и т.п." и разработка серьезных ЭКОНОМИЧЕСКИХ программ?
lexa
3 - 26.05.2004 15:46 		VB - конечно супер (особенно для баз данных), ну а если сами разработчики, так напишите свою бух. прогу
gleb64
7 - 26.05.2004 16:30 		Уважаемое, сообщество.
Я не ставлю перед собой задачу охаять 1С. Это программа завоевала большую популярность в бухгалтерии, за что ей респект.
Отсутствие поддержки SQL не даёт возможности писать собственные процедуры, а это единственный язык для работы с базами, Запрос в 1С его примитивная копия.
Пример. Я написал программу для авиакомпании по обработке билетов, при отчётах и анализе нужно фильтровать по рейса, точнее разным вариантам: внутренним, своим, чужим и т.д. Я в Stored Procedure я пишу типа: dbo.Rout.Rout LIKE @Rout1 и пользователь в поле ввода пишет типа или %(все рейсы), UF%(только наши), UF20[1-2](туда и обратно) и т.д., вариантов море и все они нужные. Похожая программа, написанная на 1С (реально существует в той же компании) выглядит смешением всевозможных переключателей, плюс, сложный код обработки. Отсутствие ADO (XBASE в 1С), например непозволяет указать, где находится, где должен обрабатываться запрос на сервере или клиенте, для немощного сервера очень существенно, тоесть реализовать технологию клиент-сервер. В программах приходится постоянно обрабатывать события типа Load, Unload, Click, DblClick, LostFocus,GotFocus, Change и т.д. Если интересно я и дальше могу описывать всё это. Вывод сам напрашивается, малые возможности программы не позволяют писать серьёзные экономические программы. Хотя для бухучёта она прекрасна. Но мой вопрос не о том, а зачем нужны вообще программисты 1С?
С уважением, Глеб.
P.S. Уважаемый, но поэт совершенно не знаком с греческой философией, тем более парадоксами Зенона и написал, полную глупость.
gleb64
9 - 26.05.2004 17:37 		Уважаемое, сообщество. С вашего разрешения продолжу.
Отсутствие обработки клавиатуры не позволяет работать с ANSII кодами (запрет на ввод каких-то клавиш, реакция на нажатие и т.д.). Пример: бестолковому юсеру для ввода номер счёт фактуры разрешить ввод только цифр и "/", после ввода её подставить номер следующей с/ф (20/25), на 1С такое вообще нельзя сделать, обработка событий мыши не позволяет эффективно использовать правую кнопку (например, для PopMenu). Для прихожу к выводу, что на предприятии, должна стоять 1С только бухгалтерия и только типовая конфигурация, что бы не было проблем с обновлением, а все экономические программы должны писаться под конкретную экономическую модель на других программах. SQL версия 1С позволит легко их согласовывать и транспортировать данные. Но при такой структуре программисты 1С вообще не нужны (кроме разработчиков ТК). Или я в чёт-то ошибаюсь?
С уважением, Глеб.
P.S. Даже великие поэты, а Пушкин безусловно великий, попадают впросак когда пишут о том, в чём не разбираются.
Волшебник
12 - 26.05.2004 17:55 		1С:Предприятие - это специализированная система автоматизации для быстрой разработки экономических программ. Используя 1С:Предприятие 7.7 или 8.0, разработчик может не вникать в технические сложности программирования, обработки сообщений Windows, общение с сервером базы данных на T-SQL. При реализации проекта программист на 1С в основном думает не о технических моментах, а о бизнес-логике, правилах компании, решаемой задаче, алгоритме решения.

Вместо этого программисту предлагается набор объектов конфигурации (справочники, документы, регистры и т.д.) и свой собственный язык программирования (аналогичный Basic). Эти объекты позволяют быстро и достаточно эффективно решить практически любую экономическую задачу.
Волшебник
14 - 26.05.2004 18:00 		Всех программистов 1С можно условно поделить на следующие типы:

1. Разработчики платформы 7.7 и 8.0
2. Разработчики типовых конфигураций фирмы 1С
3. Программисты фирм 1С-франчайзи (фра)
4. Штатные программисты на предприятиях (фикси)
5. Вольные стрелки (фри)

Какая категория программистов 1С по вашему мнению не нужна?
gleb64
16 - 26.05.2004 18:42 		(12) Безусловно, простые вещи в 1С пишутся быстро и приятно. Но, пытаясь облегчить жизнь программисту, и тем самым продвинуть свою программу, разработчики лишили программиста многих важных возможностей. Во-первых, создать эффективную, нормализованную БД. Лишили возможность оптимизировать, таблицы и связи. В SQL Server 25 типов данных в 1С только 3 (4 в восьмёрке). Как представит СУБД число с 0 знаков после запятой? Как float,integer, money или как ещё, а от этого зависит величина таблицы, вид представления данных и скорость обработки. Убрав ADO, как создать нормальную структуру клиент-сервер? Значит, программы, написанные на 1С обречены, работать медленно, а для серьёзной экономической программы это не допустимо. Чем заменить LIKE, IN, ТОР и др.? Значит, программист лишается возможность делать эффективные запросы, и программа будет ограничена в возможностях. Убрав обработку событий и заменив его одним (формула), программиста связали порукам и ногам лишив многих возможностей, которые присутствую по всех структурных языках. А потому программы на 1С, всегда будут медленные, не эффективные и ограниченные в возможностях. У меня было возможность сравнивать программы для ведущих авиакомпаний Украины. Та, что была написана на 1С, смотрелась очень плохо, какой-то улучшенный полуручной Excel.
С уважением.
Волшебник
17 - 26.05.2004 18:46 		Посмотри версию 8.0, там многое есть из того, что ты перечисляешь.
lexa
23 - 26.05.2004 18:59 		(16) попробуй аксапту
Да у 1С не очень хорошая платформа, да много глюков, но по соотношению цена/функциональность/гибкость конкурентов нет. С типовой конфигурацией может работать любое предприятие. Конечно всем хочется "под себя". Но чтобы доаботать другую программу "под себя" - потребуется намного больше денег и усилий (если это вообще возможно). С типовыми работает большое кол-во человек (пользователи, программисты, франчайзеры) - соответственно быстрее выявляются и исправляются ошибки. Новый релиз типовой получаешь бесплатно ну и т.п. и т.д. Работад я с другой торговой системой - там все наоборот платформа чумовая (юникс и прогресс - правда старые), а сама система без слез не взглянешь (глюки ловили до последнего). А в итоге слабый сервер тянул большую базу, а информация обрабатывалась криво.
gleb64
24 - 26.05.2004 19:08 		(17) Признаюсь, 8.0 ещё не видел, знаю только, что новый интерфейс и добавлет тип данных boolen. Но, если вы правы, то это противоречит политики 1С. В своё время при переходе на SQL версию, вместо толмудо по оптимизации и нормализации БД, языка SQL, интегрированное с SQL server адитнтстрирование и т.д. увидел тоненькую брошюрку ни о чём.
lexa
26 - 26.05.2004 19:13 		(14) на этом форуме скорей всего 3,4,5, но программисты бывают хорошие и плохие (плохих намного больше), так что проблема не в категориях , а вконкретных программистах
(16) пример с авиалинями - некорректный, если есть автопоезда, это не означает, что не нужны микроавтобусы, если есть микроавтобусы Мерседес - это не означает, что Газели нет места под солнцем
1С никогда не позиционировалась как система автоматизации для больших предприятий
OctoberHammer
28 - 26.05.2004 19:15 		2(26) Корректный-коректный пример. Просто он говорит, что 1С-конфы были жалкими на его взгляд. А клиенты массово выбирали их, потому что они легко настраивались, не нужждались в содержании программеров на других языках и СКЛ-админов и стоили в 10-ки раз дешевле конкурентов.
gleb64
29 - 26.05.2004 19:21 		(19) Спасибо, за ответ. Во-многом с Вами согласен. Сдесь решили, что я наезжаю на 1С и их программеров, но я пытаюсь только определится с её местом в общей структуре программных продуктов фирмы. Я пришёл к выводу, что я на правильном пути (а именно я сейчас строю систему учёта фирмы). Путь такой: типовая конфигурация бухгалтерии (SQl версия)+ группа экономических программ связанная с нею и постоянно развивающаяся (VB+sql server 2000). Для их совместимости при совместной работе (платёжки и т.д.) создаются stored procedure и методами VB идёт обмен данными. Если предложите другой вариант, буду признателен.
С уважением.
lexa
30 - 26.05.2004 19:22 		(0) Любой продукт надо поддерживать и проще держать своего специалиста (при этом не отказываясь от услуг других). Переход на SQL версию необходим в том случае, если есть проблемы с быстродействием из-за большого количества пользователей. А Oracle со своими средствами разработки позволяет реализовать побольше, чем VB + SQL server 2000.
gleb64
31 - 26.05.2004 19:28 		(25)А программист 1С денег хочет. И если он увольняется, то другому трудно разобраться в его программирование и знать, где, какие он внёс изменения, а значит, при обновлении они могут потеряться. И их нужно делать заново и нужно заново платить. Проще заставить бухгалтеров работать с ТП и самим решать проблемы, без привлечения 1Сников.
С уважением.
lexa
33 - 26.05.2004 19:29 		(29) Так бы сразу и сказал, что хочу побольше денег срубить, но поскольку кроме VB + SQL server 2000 ничего не знаю , давайка родную контору выставлю на 3000$. А на счет "строю систему учёта фирмы" - флаг тебе в руки. Лучше закажите на стороне, или адаптируйте готовые продукты. Тут когда строишь на типовых продуктах 1С - сплошной гимор. А когда несколько разных продуктов - безумству храбрых поем мы песню
gleb64
35 - 26.05.2004 19:36 		(30) Oracle по круче и нравиться мне больше, но 1С нет на нём и, скорей всего, не будет. Я тоже думал, что SQL версия, ускоряет работу, вот здесь написано, что это не так: http://www.mista.ru/articles1c/sql.htm Переходить на SQL нужно, что бы связать 1С и экономические программы, и для нормального администрирование. В 1С оно намного слабее.
С уважением.
колодина
37 - 27.05.2004 07:38 		(31) а если вы наваяете "систему учета фирмы" на VB и уволитесь? тогда уж точно конец пришел. зря фирма закладывается под такую систему, плохо им придется.
(30) есть много инструментов и каждый нужен для своего дела. банковскую систему, например, никто на 1с писать не будет, а для торговли - самое то.
Alexandr Ch
38 - 27.05.2004 09:41 		А о чем спор-то собственно?
Как известно из экономики, предложение (в данном случае услуг программистов 1С) не появилось на пустом месте. Вероятно, сначало появилось много пользователей, которые хотели сначала вот-там чуть-чуть, да там немного, а потом и совсем по-другому сделать. А сколько лет прошло с тех пор, как зародилась платформа 7.7 ? Так что это естественный процесс. Ну и удачный маркетинг самой фирмы 1С, конечно.
SteveD
40 - 27.05.2004 10:46 		(0) А кто собственно мешает строить таблицы и запросы SQL, хранить в них данные и получать отчеты через ADO? Кто мешает подключать внешние компоненты для вызова POPUP Menu (если уж программный интерфейс без этого никак не идет)? И все это делать непосредственно внутри 1С? За свой немалый опыт работы с 1С я убедился, что тот кто кричит "1С - г***но и для больших предприятий не подходит" - просто не знает саму 1С или по наслышке. Разберись сначала с ее возможностями, а потом уже что-то утверждай!
gleb64
41 - 27.05.2004 12:24 		Уважаемое, сообщество.
По моему мнению, с переходом на SQL server, разработчики 1С не провели ряд важных изменений. Главное, что вместо ограниченного и медленного “Запроса” необходимо было создать что-то типа: “execute @Parameter” (в Xbase или подобном) с передачей обработки запроса в SQL server, что даст возможность строить клиент-серверную технологию, в десятки раз увеличить скорость работы баз, даст возможность делать сложные запросы для отчётов и анализа, что значительно повысит эффективность программ. Попытка файл-серверную технологию впихнуть в SQL server, выглядит нелогично (всё равно, что купить дорогой грузовой Мерс и возить на нём мешок картошки). Конечно, придётся учить SQL, но что делать, люди не придумали, пока, ничего лучшего для работы с базами.

Второе, было бы хорошо, что вместо «Формулы», ввести обработку событий, хотя бы , LostFocus,GotFocus, Change (потеря, получение фокуса, изменения), есть же обработка событий для форм: предопределённые процедуры. Что даст возможность разрабатывать удобные и эффективные программы.

Для лучшего совмещения доработок программистов 2 и 3,4,5 нужно, что бы при объединении конфигураций, проверялось отклонения от ТК или как-то фиксировались изменения ТК, типа журнала транзакций для запросов (в своих программах я использую log file для фиксации всех изменений в таблицах баз данных).
Есть ещё ряд пожеланий и доработок, но они не столь существенны. Все эти изменения 1С позволит серьёзно повысить конкурентно способность и ценность программистов 1С

К сожалению, я вынужден уйти с форума, если у кого есть вопросы, идеи, пожелания прошу обращаться. Мой E-mail: gleb@dsnews.com.ua, сайт: www.umair-ua.com/my
Желаю всем успехов и процветания.
Черт
44 - 27.05.2004 13:25 		Он еще в (41) не указал, что 1С плохо работает с картинками и многими другими фичами, НО не учел что 1С это бухгалтерский софт (и не более ИМХО)хотя на него вешают уже....... мама не горюй
Тот
45 - 27.05.2004 13:35 		На самом деле он просто в плену мифов. То, что необходимость работы одного и того же кода в SQL и dbf не позволяла эффективно использовать первый - это факт, с которым спорить трудно. В то же время он не видел ни 8.0 ни ВК. Не видел и конфигураций, использующих ADO. Ведь он искренне верит, что такого не может быть, потому что не может быть никогда.
Он искренен в своих заблуждениях. Поэтому напрасно вы на него нападаете. А развеять заблуждения можно только познакомившись с продуктами.
alegrig
46 - 27.05.2004 14:06 		Я ушел с SQL (Is-Bilder+ Бизнес-Люкс) на 1с и сделал вывод:
Программисты 1С (3,4,5)не были бы нужны, если КАЖДЫЙ Бух был бы проффесионалом своего дела и не боялся разбираться. Не в программировании - нет просто в рядовых изменениях конф фирмы 1С. (то бишь задача сводится к поиску наиболее приближенных к идеалу бухов, после этого - у тебя куча времени на себя, любимого)
Кстати существует Toy-SQL который завалил бы gleb64. А в прочем - фиг с ним.
BorisG
47 - 27.05.2004 14:25 		(46) Каждый должен заниматься СВОИМ делом профессионально, поэтому вывод "Программисты 1С (3,4,5)не были бы нужны" не верен по определению.
(45) Анатолий, да нет, это не заблуждения. Судя по постам в ветке, автору НЕ НУЖЕН диалог. Он этих технологий не только не видел, но и НЕ ХОЧЕТ видеть. Ибо не последовало вопроса, где посмотреть, что почти всегда присутствовало при подобных топиках на Т1С.
gleb64
48 - 27.05.2004 16:18 		Уважаемое, сообщество.
Извинения, за несвоевременную реакцию на ремарки, нет времени. Итак.
(11) Маска здесь не поможет (с/ф и 123/1 и 1/123), но главное нет обработки события «нажатие клавиши».
(21) Этот мир сложился из практики, а не искусственно. Пример не корректен: от расизма мы не можем избавиться, а вот программиста 1С да.
(23) Наличие ТК огромный плюс 1С (и залог её успеха), но наличие большого количества часто не квалифицированных программистов плюс плановые изменения ТК часто путают ситуацию.
(26) полностью согласен
(28) насчёт цены так, но остальное не так.
(33) ошибаетесь, я больше люблю Delphi+Oracle, но в Sql Server и 1С плюс с появлением Access 2000, можно использовать мощность и удобства конструктора Access, Enterprise manager я использую в основном при администрирование, а Stored Procedure, Views и т.д., работа с таблицами удобнее в Access.
(36) 64 это IQ (шутка, конечно год рождения)
(38) удачный маркетинг да, но он не определяет качество продукта.
(40) (А кто собственно мешает строить таблицы и запросы SQL, хранить в них данные и получать отчеты через ADO?) – с помощью чего. Как, скажем, передать параметр в Stored Procedure? Что реализуется методами типа “execute @Parameter” с дальнейшей обработкой записей?
(44) полностью согласен!!! В этом и вся фишка, стремясь собрать побольше денег 1С позицируют, как платформу для создания мощных экономических программ. (Даже как-то не удобно вымолвить: согласен с Чертом)
(45) делом не в том, что я верю-неверю, я их не видел и о них не слышал и, изучая 1С я их не увидел в ТК SQL версии, а ТК это важнейшая фишка 1С.
(46) Согласен.
(47) полностью ошибаетесь. Моя задача сформировать систему учёта на фирме, а не покрасоваться на форуме.

Теперь о SQL версии. В своё время, перейдя с Access на SQL server 2000. Я был поражён открывшимися возможностям, такое ощущение, что из жигулей пересел в реактивный самолёт. Но! Пришлось полностью переделывать базы данных, это и понятно совсем другие технологии. Что сделала 1С при переходе? Практически ничего. Необходимо было программистам 1 группы, разработать платформу с возможностями ADO (вот почему я был поражён тонкости книжки), программистам 2 не обходимо было разработать на этой платформе новое ТК с клиент-серверной технологии, заложив в нём возможность, использовать мощь SQL server (в том числе и аминистрирование, которое надёжнне), для программистов 3, 4, 5 организовать обучение СУБД и языка SQL. Вот вы всё говорите о новой версии 8.0, но почему никто не сказал о двух различных ТК: отдельную для DBF и отдельную для SQL? А ведь это принципиально разные технологии! Но при переходе на SQL версию, что делать с наработками программистов 3,4,5? Вот я и писал, что должно происходить сравнение с ТК, для дальнейших изменений конфигурации под клиента.

Складывается такое ощущение, что всё всех устраивает: Microsoft тем, что продвигает свой недешёвый продукт и её не волнует, что он используется не эффективно, продавцов 1С, что можно без проблем рубить бабки, программистов 1, что можно ограничиваться косметическими изменениями, 2 - что не надо возиться с двумя ТК, 3,4,5, что не надо учить реалиционные базы и T-SQL. И никого не волнует, что пользователь заплатив приличные деньги, получает тормознутый (нет клиент-серверной технологии и возможности оптимизации таблиц), не до конца защищённый (нет администрирование методами SQL, триггеры и т.д.), не очень удобный и функциональный (нет поддержки SQL , отсутвуют обработка событий объектов и т.д.)продукт
С уважением.
lexa
50 - 27.05.2004 17:11 		(48) Значит начинал на Access ( который стабильно и быстро работает без глюков) и на нем создавал "экономические программы". А теперь VB через ODBC и SQL server 2000. Большинство крупных разработчиков СУБД используют свои методы доступа к СУБД и создают свои средства разработки (языкм программирования высокого уровня) для того, чтобы увеличить эффективную работу СУБД. А Access и VB для создания серьезных приложений - это анекдот. Не нравится платформа 1С - не работай. На этом форуме много чего могут сказать про недостатки и чего бы хотелось. Но попробуй создай свою платформу за те же деньги и раскрути ее.
Deosfen
51 - 30.05.2004 06:54 		Прочитал посты эмоционального gleb64, может быть он действительно хороший специалист.Что-то я не могу понять, хочешь использовать stored procedure SQL Server в 1С , сделав вызов процедуры через ADO, так сделай это, нет проблем.
gleb64 писал "Вот вы всё говорите о новой версии 8.0, но почему никто не сказал о двух различных ТК: отдельную для DBF и отдельную для SQL?" не используется больше DBF. Я не фанат 1С, программирую на ПО от Sybase, но хотелось бы сказать, что написание программ на 1С в области учета и не только, все таки удобная вещь.


Ошибка загрузки метаданных | База знаний | mista.ru

Ошибка загрузки метаданных

OffRoader 25.06.2004 18:39 | Есть ли какая нибудь возможность побороть сабж? Предварительно еще запрашивается ~mdXX.tmp, и наличествует "общая файловая ошибка при доступе" к несчастному.
lexa 1 - 25.06.2004 18:43 | http://www.forum.mista.ru/topic.php?id=5866
OffRoader 2 - 25.06.2004 19:08 | Преогромное мерси, ей- богу, первый раз со мной такое. Вытаскивание tmp спасло на все 100 :)


Предлагаю собрать ссылки на 1С-сайты | База знаний | mista.ru

Предлагаю собрать ссылки на 1С-сайты

Волшебник 09.06.2004 07:50 | Начну с известных: http://www.1c.ru http://www.v8.1c.ru http://www.itland.ru http://1c.hippo.ru/ (Клуб профессионалов 1С) http://1c.klim.org (Клуб любителей 1С) http://www.sinor.ru/~my1c (FAQ по 1С) http://zone1c.narod.ru/ http://thebeautiful.narod.ru/ Другие сайты: http://www.erpg.ru/ http://www.1csql.ru/ http://gendin.ru/ http://1c.alterplast.ru/ http://1cworld.com/ http://www.1c-school.ru (давно не обновлялся) Другие форумы по 1С: http://itland.ru/map.html http://www.kuban.ru/cgi-bin/forum/forum9.cgi (Т1С) http://1c.realnet.ru/cgi-bin/forum.cgi (Одинэсия) ------------------- Предлагаю вам продолжить. Просьба не повторяться и не приводить здесь сайты фирм-франчайзи.
Волшебник 1 - 09.06.2004 07:53 | Вот еще: http://www.firststeps.ru/ http://www.1cvportal.by.ru/
SnarkHunter 3 - 09.06.2004 07:58 | http://avb1c.narod.ru/ http://1csql.udmnet.ru/ http://www.consult.legion.ru/alf/ http://camino.narod.ru/1C/idiot.html
mszsuz 6 - 09.06.2004 08:16 | Здесь ссылки на 381 сайт: http://1c.klim.org/topsites/rating.php
Valery 8 - 09.06.2004 11:51 | http://flashc.nm.ru http://www.firststeps.ru/1c/1cbuh1.html
3V 10 - 10.06.2004 10:25 | http://www.1c-school.ru/ http://openconf.narod.ru/ http://62.213.67.94/ http://mdeditor.narod.ru/ http://klerk.ru/soft/1c/ http://lev1c.narod.ru/ http://www.rarus.ru/


Информационные технологии в торговле 2004 (Обзор CNews.ru) | База знаний | mista.ru

Информационные технологии в торговле 2004 (Обзор CNews.ru)

Волшебник
09.06.2004 21:05 		В информатизации розничной торговли идет бурная перестройка. Двумя рычагами этого процесса стали рост масштаба бизнеса торговых сетей и приход крупных западных торговцев. На возрастающий спрос откликаются и поставщики решений. Места под солнцем в автоматизации торговли пока хватает всем, но уровень конкуренции в этом сегменте за последние годы резко возрос. Отечественным разработчикам ПО, захватившим значительную долю рынка, предстоит подтвердить уровень своих систем и качество сервиса. Маркетинговая атака иностранных компаний скорее всего будет весьма стремительной.

http://www.cnews.ru/trade/

===========================================================
Цитата из статьи http://www.cnews.ru/trade/soft/
"
Параллельно в этом секторе растут обороты 1С — по данным компании, только за январь- апрель 2004 г. суммарные продажи решений 1С:Управление торговлей 8.0 и 1С:Торговля и склад 7.7 (ежемесячные тиражи которого стабильно превышают 1200 экз.) увеличились на 93%, по сравнению с показателями аналогичного периода 2003 г. При этом в среднем по рынку показатели роста почти в два раза ниже. Количество пользователей 1С:Управление торговлей 8.0 с января этого года ежемесячно увеличивается в среднем на 150 организаций, из которых около 23% приходятся на сектор розничной торговли.
"
-------------------------------------

Достаточно подробный обзор "1C:Предприятие 8.0. Управление торговлей" приведен здесь:
http://www.cnews.ru/trade/s/1c/

===========================================================
Содержание:

ИТ-инфраструктура торгового предприятия будущего
http://www.cnews.ru/trade/infrastructure/

* Покупатель в электронной оболочке
* Супермаркет образца 2010 года
* Gartner: главные тенденции в автоматизации торговли на 2006-2013 гг.

-------------------------------------
Рынок информатизации торговли и ИТ-стратегии компаний
http://www.cnews.ru/trade/strategy/

* Великий переход
* Мы и они
* Лидеры и тенденции

-------------------------------------
Мотивация торговых компаний при выборе ИТ-решения
http://www.cnews.ru/trade/itmotiv/

* Информационная поддержка торгового бизнеса
* Критерии выбора системного интегратора

-------------------------------------
ПО для автоматизации бизнеса торговой компании
http://www.cnews.ru/trade/soft/

* ERP: за, против, воздержаться?
* Пути ERP в России
* Системы управления складами

-------------------------------------
Аппаратные и сетевые технологии в автоматизации торговли
http://www.cnews.ru/trade/hard/

* Распределенные сети: от технофобии к техноцентризму
* Торговая инфраструктура: тенденции 2004
* Технология RFID: Принципы работы
* Радиоволны на благо торговле
* Препятствия на пути RFID
* Электронные ценники
* Сенсорные технологии в торговле

-------------------------------------
Торговые предприятия и интернет
http://www.cnews.ru/trade/internet/

* Торговый бизнес в интернете
* Преимущества и проблемы онлайна
* 2 плоскости интернета: бизнес-потребителю и бизнес-бизнесу
* Электронные продажи в мире


Что выбрать: v77 или v8 | База знаний | mista.ru

Что выбрать: v77 или v8

very-mary 02.06.2004 13:26 | Возникает вопрос автоматизации хоз. деятельности предприятия. Возможно, выбор будет за 1с. Что посоветуете, господа профессионалы, исходя из опыта внедрения? Покупать 77 или дождаться 3го квартала и сразу же 8?
very-mary 4 - 02.06.2004 13:38 | "...Выпуск комплексного решения такого уровня – процесс постепенный. На первом этапе выпущена бета-версия конфигурации "Управление производственным предприятием", которая предназначена для ознакомления партнеров с возможностями нового продукта, бета-тестирования, а также для реализации пилотных проектов внедрения у конечных пользователей. По мере освоения партнерами функционала конфигурации и бета-тестирования основных управленческо-учетных механизмов, конфигурация будет совершенствоваться. Выпуск финального релиза планируется в третьем квартале 2004 г. " -Цитата с сайта v8
SA 6 - 02.06.2004 13:50 | to 4: Некоторые лица приближенные к кругам 1С, в беседе без галстуков и протоколов - очень сомневаются насчет этих планов. К тому-же наша фирма (просто частная контора) купила версию 8.0 - так дай бог, что-бы они к третьему кварталу хотя-бы движок довели до ума - переодически слетает без видимых причин (в основном конфликты памяти). А вообще как говорили выше - решение очень индивидуальное, но мое мнение, что покупать 8.0 стоит только если собираетесь принципиально переписывать типовую конфигурацию, причем предъявляются серьезные требования к интерфейсной части - и ожидаются огромные объемы информации ... и т.д. и т.п. в общем если все ожидается "очень" :) - т.к. возможностей для программистов - там существенно больше.
427 7 - 02.06.2004 13:52 | На заборе тоже много чего пишут.... А этот сайт - это тот же забор .... вокруг сортира ... Не все так однозначно... Реально УПП более менее будет доведена до состояния, которое можно назвать "почти рабочим", летом-осенью будущего года... Пока нет базы и клиентов - исправить многие ошибки нереально... Если готовы трах-ся... прыгайте этой осенью... P.S. а вообще то обследование нужно...
SA 8 - 02.06.2004 13:58 | А вообще меня как программиста восьмерка очень радует своими возможностями - но когда читаю документацию - плачу. Какой калека это писал. И хелп стал на порядок хуже... продираюсь как могу :( Кстати - очень удивляет фраза, в книгах "Не используется в модуле внешнего соединения. Недоступен на сервере" Она пишется после описания большинства операторов. Неужели нельзя было это оформить какой-то сноской, и в 1300 страниц съекономить страниц 100-200 ;)


Исчезли все кнопки | База знаний | mista.ru

Исчезли все кнопки

Прог 28.05.2004 14:53 | В 1с поисчезали все кнопки сверху. Остались только выпадающие надписи, но по ним неудобно работать нашим бухгалтерам. Чё делать? Помогите!
bazvan 1 - 28.05.2004 14:55 | В сад или ищи серваис понель инструментов
SiMazx 3 - 28.05.2004 14:57 | Прог говоришь? Сервис->панели инструментов... Поиграйся с галочками... Мож найдешь...


1C 8.0 перейти не перейти? | База знаний | mista.ru

1C 8.0 перейти не перейти?

Karachee 29.05.2004 19:02 | Люди, те кто реально осуществлял переход на 8.0 и те кто сопровождает. Подскажите пожалуйста все таки когда переход обоснован. При каких условиях переход с 7.7 на 8.0 дает реальную выгоду. Что там такого есть уже готового, что оправдывает покупку? Скорость, возможности, удобство, навороты? Для каких задач, для какого железа? Не то, что декларируется, а реально полезное сразу. Конкретно интересует больше по "Торговле и складу". Для небольших и средних предприятий.
SnarkHunter 1 - 29.05.2004 19:13 | Это все очень индивидуально...
ChAlex 2 - 29.05.2004 20:03 | Скорость формирования отчетов значительно выше! Можно создать более удобный и красивый интерфейс (даже с цветом, что многим нравится). Правда тяжеловесный!!!. Даже на хорошем железе интерфейс без особых наворотов тормознутый. Документация оставляет желать лучшего..., ну и так кучка мелких и не мелких нюансов. Короче за красоту и увеличение скорости нужно заплатить немалым потраченным временем. Правда на типовом решении можно сэкономить. Глюки (и просто некоторая непродуманность объектов) в последствии несколько охлаждает первые впечатления. Ну а в остальном действительно все индивидуально и не однозначно.
427 3 - 29.05.2004 20:13 | Для небольших предприятий - нет резона вообще... Для средних.... ну ЕЩЕ ПОКА тоже нет резона... Только после появления вкусного функционала...
Karachee 8 - 30.05.2004 12:10 | Хорошо, отчеты на восьмерке скорее всего будут идти быстрее на толстых базах, особенно если сравнивать с семеркой на dbf, и наоборот. Тяжеловесный интерфейс можно поподробнее. Скажем если использовать WIN2000 клиент-сервер, там у клиента 800*600 и 256 цветов, это критично? Как нагрузка на сетевухи? Ещё, если кто знает. Есть там что-нибудь в типовых, чего нет в типовых 7.7 и что реально будет полезно и прибыльно. Хоть что-нибудь принципиально новое они в типовую конфу зарядили?
Волшебник 9 - 30.05.2004 12:15 | (8) Для 8.0 желателен True Color и для типовых конфигураций - желательно разрешение 1024х768.
BorisG 11 - 30.05.2004 12:33 | (8) Для начала... просто прочти... Сайт по восьмерке... (он, кстанти и в ссылках этого сайта есть): http://v8.1c.ru/ И отличие восьмерки от семерки http://v8.1c.ru/disctinct7/ Там же и "Оценка производительности и масштабируемости клиент-серверной версии 1С:Предприятия 8.0" Косвенно из него можно кое-что понять... http://v8.1c.ru/tests/ Относительно небольших предприятий, 2-3 рабочих места без выделенного сервера, если НЕ ТРЕБУЕТСЯ функционал, имеющийся только в восьмерке, и НЕ ПЛАНИРУЕТСЯ быстрое развитие, я бы пока поостерегся с оценкой...


Тупые бухгалтеры | База знаний | mista.ru

Тупые бухгалтеры

Demetry 28.05.2004 09:04 | Народ не кто знает линков на хорошие бухгалтерские сайты или книги в инете. А то благодаря разделению труда у бухариков ,никто нечего до конца не знает, а глБухарик вечно то в разъедах то жутко занята. --------------- А вопрос уменя такой : При сдаче собственного ОС в аренду-Насколько отличаются проводки от стандартного ввода в эксплотацию. Куда начис.Армот? Как отр. на нал. учете. И какая форма акта(на печать) используется при вводе в эксплотацию?
GoldMax1 3 - 28.05.2004 23:42 | Для решения твоих задач надо изучать самомостоятельно бухучет. Посмотри сайт www.aksenov.ru. Из-за Аксенова С. Л. не могу забросить бухучет и заняться чем то более интересным. Пришлось в этот институт второй раз поступать. В первый раз (5-7 лет тому назад) не хватило терпения его закончить. А сейчас без знаний бух учета невозможно работать и пришлось учебу начинать с самого начала
Asmody 4 - 29.05.2004 00:09 | http://www.buh.ru/ :) http://www.klerk.ru/
vdi 6 - 29.05.2004 07:35 | (0) Например, Тумасян Р.З. Бухгалтерский учет. М.: ООО "НИТАР АЛЬЯНС", 2003, с. 799. Здесь есть большой раздел по учету ОС. В том числе и учет аренды ОС у арендатора. ____________ С уважением, vdi.


1С в пингвине | База знаний | mista.ru

1С в пингвине

ado 27.05.2004 18:57 | Люди, кому нибудь реально удавалось запускать 1С в linux через wine. В каком то форуме слышал об удачном эксперименте, но без подробностей.
miha_root 1 - 27.05.2004 22:38 | http://mdlin.by.ru/lin1c.html
Морская свинка 5 - 28.05.2004 10:06 | Тут есть и очень неплохо. http://chin.dataltd.ru/index2.php?id=samba
ado 6 - 28.05.2004 12:41 | (3)lin4win это не то. Там все равно винду надо ставить. Хочется лицензионно чисто.
miha_root 8 - 28.05.2004 14:44 | по поводу (5): такие вещи имеет смысл делать на samba3.x.x (по быстрее она несколько), а там конфиг будет в ключевых местах другой.


Инструменты для локализации МД-шника | База знаний | mista.ru

Инструменты для локализации МД-шника

miamy 26.05.2004 13:46 | Доброго времени суток всем! Возникла такая задача. Необходимо локализировать конфигурацию 7.7, т.е. перевести весь интерфейс на английский язык. С меню и перечислениями проблем нет, но переписывать вручную все текстовые подписи на каждой форме не хочется... Возможно, существуют инструменты, позволяющие осуществить что-то вроде глобального поиска и замены, например все вхождения слова "Счет" на "Account". И еще по ходу: не могу поменять кодовую таблицу для базы, 1251 ставится без проблем, а 1252 никак, пробовал региональные настройки для Великобритании, Германии и Франции - сообщение "Порядок сортировки для базы данных отличается от системного". Буду очень признателен за помощь. Можно на мыло miamy2000@mail.ru.
Z1 1 - 26.05.2004 14:02 | (0) посмотри на Itlande есть проэкты http://itland.ru/forum/index.php?showforum=32 Можно ( и даже нужно - ведь база обна) разрулить через УРБД. Т.е каждая переф. база работает только на одном языке. Для каждой базы берешь md копируешь его в чистую базу. Далее автоматически или вручную изменяешь заголовки - далее копируешь новый md обратно. Правдо придеться это проделывать после каждой смены конфигурации но после нескольких переделок руками тебе это надоест и придумаешь как все автоматизировать. Печатные формы выноси во внешние. Каждый язык в отдельную папку. Кодовую страницу желательно выбрать одну ( хотя с помощью тех же подмен md ) вроде все должно проходить.


Построитель графов DOT - анализ структуры любой конфигурации 7.7 и 8.0 | База знаний | mista.ru

Построитель графов DOT - анализ структуры любой конфигурации 7.7 и 8.0

Волшебник 23.05.2004 04:05 | Вашему вниманию предлагается программа DOT, которая принимает на вход текстовый файл со структурой графа, а на выходе формирует граф в виде графического, векторного или текстового файла. Этот механизм очень удобно применять для анализа структуры любой конфигурации для 1С:Предприятия 7.7 и 8.0. Описание программы DOT приведено на этой странице http://www.mista.ru/dot ------------------------------------------ В этой ветке предлагается обсудить возможности применения этой программы, возникающие проблемы и решения, другие ценные мысли.
vittor 1 - 23.05.2004 13:36 | Вещь безусловно интересная!А вот можно ли решить обратную задачу - по графу создать конфигурацию(хотя бы каркас с последующей детализацией)?
Волшебник 2 - 23.05.2004 13:43 | Если для версии 7.7, то можно. Для этого можно сформировать текстовые файлы и собрать из в md-файл с помощью GComp. А для версии 8.0 формат файла 1cd|cf не известен.
vittor 3 - 23.05.2004 14:55 | Я имел ввиду из графического представления,а не через текстовые файлы.Что-то аналогичное разным там CASE.
Волшебник 4 - 23.05.2004 15:22 | (3) "разным там"... Хорошо бы изучить, как например, работает ERWin - CASE-средство для проектирования и генерации баз данных. На выходе он создает именно текстовый файл на SQL (или VBA для Access), который и создает базу данных: таблицы, поля, индексы и т.д.
vittor 5 - 23.05.2004 16:01 | Я понял,что DOT формирует файл,основанный на XML нотации? (т.е. XML подобный файл описывает этот рисунок).Если это так,то используя XLST этот файл можно преобразовать в любой XML файл(например,конфигурации) и его уже каким-либо образом загружать в 1С.Я не имел ввиду описывать саму базу(это уже на этапе детализации в конфигураторе),а вот бизнес-логику и потоки обработок - это было бы прекрасно.Меня бухгалтера(не операторы 1С) просят именно такое описание,ибо программирование им не нужно,а понимать,что делает 1С,они хотят.
GrayT 6 - 23.05.2004 16:15 | 5 - как совместить "бизнес логику" и "загружать в 1С"? Прежде чем вступать в дискуссию желательно внимательно посмотреть на то что обсуждается. На сколько я понял - при помощи обработок есть возможность представить в виде графа СТРУКТУРУ базы данных. А уж как использовать эту структуру - думайте сами. А в целом весчь полезная - будет время обязательно поковыряю. Одно время хоте прикруть к 1С конвертер в хмл чтоб в ервин загружать.
vittor 8 - 23.05.2004 19:12 | (6)Я думаю мы обсуждаем систему DOT и чем она м.б.полезна для 1С... (7)Я попробовал Вашу программу GComp - мало что сформировала и закончилась с ошибкой "abnormal error" - что это может быть.Было сформировано всего 4 поддиректории в \SRC.Файл .1cv7.md размером около 20М. Я не пробовал переносить данные между конфигурациями через XML,но думаю,что перенос без данных должен переносить конфигурацию.Или я не прав?
Xelon 10 - 24.05.2004 01:21 | Я попробовал обработку, но почему-то она сформировала граф без подписей, только фигуры. Не подскажите, как можно это исправить?
Xelon 12 - 24.05.2004 01:30 | Извиняюсь, забыл написать: АнализМетаданных для 1С v77
sss 27 - 24.05.2004 17:46 | 1. не в качестве наезда:) - в обработке для 8.0 нет сохранения в файл, надо сохранять из окна Сообщения 2. формат SVG не похоже чтобы поддерживался Визио
Волшебник 28 - 24.05.2004 17:51 | (27) все верно. Нужен Visio 2003, не меньше
Волшебник 30 - 24.05.2004 18:06 | wingraphviz нужен не Unicode, а 866 codepage. UTF-8 без первых трех байтов нужен для чистого DOT (интерактивно или через command promt) 61К для текстовика - это много. Перешли мне напиши еще, какая у тебя ОС
Волшебник 31 - 25.05.2004 10:26 | (29) Важно: в системе должен существовать шрифт Times New Roman (файл times.ttf). Если такого файла нет, то на графе будут пустые фигуры без подписей.
sss 32 - 25.05.2004 15:01 | неплохо было бы иметь возможность выбора отдельного объекта и получения всех его связей(зависимые и зависящие объекты)
Волшебник 35 - 25.05.2004 17:12 | (33) В обработке Анализ метаданных 7.7 нащелкиваете те объекты, которые вам нужны и граф строится только по ним. Или я чего-то не понял?
Волшебник 37 - 25.05.2004 17:39 | В обработке Структура конфигурации 8.0 нужно на закладке "фильтр" в текстовое поле написать имена несколько объектов каждый на новой строке. Можно также вписать имя подсистемы
Asmody 38 - 25.05.2004 22:56 | (31) и далее... Сгадил вчера форум, а сегодня некогда было. В общем, я вчера нашел обходной маневр. Файлик, что ваша обработка вываливает конвертнул в UTF-8, скачал полный дистриб DOT'а под винду, а нем есть GUI-запускалка. С ней все получилось. Построил СуперГраф почти на мегабайт в PNG. Хотел распечатать, но он страниц 40 занимал... Почти как в рекламе Visio :)


Как прервать поиск по конфигурации в v8.0 | База знаний | mista.ru

Как прервать поиск по конфигурации в v8.0

Foma 20.05.2004 14:20 | Косяк однако. пока все не найдет не остановится. Что за ... . Увидел что нашла ссылку, хочешь прервать а ... нет, однако, сиди жди.
¶ 1 - 20.05.2004 14:29 | Глобальный поиск я прерываю Ctrl+Break. По ссылкам не работает?


Испоьлзование клавиатуры в 1С | База знаний | mista.ru

Испоьлзование клавиатуры в 1С

Serg_bl
01.05.2004 13:09 		Привет всем! Проблема: где-то видел список клавиш для работы с 1С, а найти не могу:( Кто знает ссылку, просьба подскажите...
427
1 - 01.05.2004 15:14 		Горячие клавиши при работе в 1С:Предприятии, с конфигуратором и Windows 95/98/NT

Конфигуратор

Конфигурация
Alt + К + Enter Открыть конфигурацию
Alt + К + Т Поиск во всех текстах
Alt + К + О Объединение конфигураций
Alt + K + З Загрузить измененную конфигурацию
Alt + К + Е Конвертирование данных
Администрирование
Alt + А + П Пользователи
Alt + А + Х Сохранить данные
Alt + А + В Восстановить данные
Alt + А + Ы Выгрузить данные
Alt + А + Г Загрузить данные
Alt + А + Н Настройка журнала регистрации
Alt + А + Р Распределенная ИБ
Alt + А + Р + У Управление
Alt + А + Р + А Автообмен

Действия
Alt + Д + Т Открыть в отладчике
Alt + Д + К Синтаксический контроль запросов
Alt + Д + И Синтаксический контроль
Alt + Д + Р Процедуры и функции модуля

Файл
Ctrl + N Новый
Ctrl + O Открыть
Ctrl + S Сохранить
Ctrl + P Печать
Alt + Ф + Р Сравнить файлы
Alt + Ф + З Закрыть
Ctrl + P Печать
Alt + Ф + Р + Р + Enter Просмотр
Alt + Ф + М Параметры страницы

Работа с закладками
Shift + F2 Предыдущая закладка
Alt + F2 Закладка
F2 Следующая закладка

Работа с блоком
Ctrl + Shift +F Форматировать
Tab Сдвинуть вправо
Shift + Tab Сдвинуть влево
Ctrl + Num / Добавить комментарий
Ctrl + Shift + Num / Удалить комментарий

Окна
Ctrl + F4 Закрыть окно
Ctrl + Shift + F6 Следующее окно
Ctrl + F6 Предыдущее окно
Alt + О + К Каскадом
Ctrl + Shift + z Закрыть окно сообщений
Ctrl + Alt + F Следующая страница
Ctrl + Alt + B Предыдущая страница
Alt + О + Р Разделить окно

Поиск и замена
Ctrl + Shift + F3 Заменить
Ctrl + F3 Искать
F3 Повторить поиск
Alt + F3 Искать назад
Shift + F3 Искать вперед
Ctrl + Shift + L Переход к строке

Сервис
Ctrl + F2 Калькулятор
Alt + С + С Синтаксис помощник
Alt + С + Н Настройка шаблонов
Alt + С + В Временная блокировка
F11 Запуск предприятия
F12 Запуск отладчика

Помощь
F1 Помощь
Shift + F1 Содержание
Ctrl + F1 Поиск в Синтакс-Помощнике
Alt + П + О О программе

Общие
Alt + Enter Свойства
Alt + F4 Выход

Предприятие

Документ
Ctrl + Enter Кнопка по умолчанию
F4 Выбор поля (альтернатива мыши)
Tab Прямой обход полей
Shift + Tab Обратный обход полей

Справочник
Действия
Ins Новый элемент
Ctrl + F9 Новая группа
Shift + Enter Изменить элемент
Alt + Д + Р Просмотр элемента или группы
F9 Копировать элемент или группу
Del Пометить элемент/Снять пометку
F5 История значения
Alt + Д + А Найти в дереве
Ctrl + F5 Перенести в другую группу
Alt + Д + Ч Подчиненный справочник

Сортировка
Ctrl + 1 Сортировка справочника по коду
Ctrl + 2 Сортировка справочника по наименованию
Ctrl + 3 Сортировка справочника по реквизиту
Ctrl + стрелка вверх На уровень вверх
Ctrl + стрелка вниз На уровень вниз
Управление иерархией справочника
GrayT
2 - 01.05.2004 22:24 		http://www.sinor.ru/~my1c/knowhow/hotkey.html
Кстати, в этом списке нет пары полезных сочетаний...
427
3 - 02.05.2004 07:53 		Вырезано при копировании ....

Как можно заметить, в заголовке "и Windows 95/98/NT"
виндовозные клавиши вАще обрезаны....
GrayT
4 - 02.05.2004 09:33 		Я не про виндовые. Ctrl+[ & Cntrl+] в текстах модуля


ЖР юзеров | База знаний | mista.ru

ЖР юзеров

Мариша 6 - 13.10.2004 18:50 | Помогите! В пр-ме ЗиК хотела посмотреть журнал регистрации (надо узнать кто из сотрудников создал док-т, кто исправил, я гл.бух). История как у Вас - запрашивает пароль. Где он устанавливается? Я никаких изменений не вносила, сотрудники тоже не сознаются. Т.к. в этом вопросе я не специалист, думала может это во всех пр-мах 1С. Зашла в Бух - там все нормально работает, никакого пароля на Журнал регистрации не запрашивает. Заранее спасибо за ответ.
graham 17 - 15.10.2004 13:16 | Может кому будет интересно. Была такая ситуация - на журнале регистрации стоял пароль и его знали главбух и админ 1С. В один прекрасный момент пришел главбух и сказал, что при просмотре ЖР 1С требует от него ввести пароль, но старый пароль не проходит. После долгих выяснений оказалось, что одна строка в ЖР повреждена. Пришлось открыть в Word'е ЖР, удалить из него корявую строку и сохранить. После этого журнал открылся со старым паролем без проблем.
Мариша 18 - 15.10.2004 15:11 | Спасибо ОГРОМНОЕ, Graham!!!!! Открыла WordPad'ом ЖР, нашла строку с датой, которая стояла на неизвестом мне первоначальном пароле (09.04.2020). Удалила ее и, заодно все строки, в которых сама пароль заводила. ВСЕ РАБОТАЕТ, ничего не запрашивается. P.S.: кажется никто этот пароль не заводил. Эта строка появилась сразу после обновления конфигурации. Обновляемся по сети с сервера, очень может быть что в этот момент пр-ма повисла и появился этот пароль. Еще раз: всем большое СПАСИБО за советы!


Журнал регистрации: как получить объект? | База знаний | mista.ru

Журнал регистрации: как получить объект?

Krio
04.10.2004 13:05 		Кто-нибудь обращался из модулей к журналу регистрации в 1С:Предприятии 7.7 ? Может где-то расшифрован его формат? Конкретно мне нужно по строке файла журнала определить объект данных, к которому относится строка. Инфо об этом объекте думается содержится в полях вида "O/196/62336". Как по такой строке получить ссылку на документ?
Волшебник
1 - 04.10.2004 13:08 		http://www.sinor.ru/~my1c/knowhow/form_mlg.html
Krio
2 - 04.10.2004 13:13 		Спасибо! яндексом искал, но в его сети столь полезная страница не попалась.
MMF
3 - 04.10.2004 13:14 		//*******************************************
Функция ДокументПоИд(Ид)
СЗ=СоздатьОбъект("СписокЗначений");
КодИБ=" ";
ПозОткр= Найти(Ид, "(");
Если ПозОткр<>0 Тогда
ПозЗакр=Найти(Ид, ")");
Если ПозЗакр<>0 Тогда
КодИБ=Сред(Ид, ПозОткр+1, ПозЗакр-1-ПозОткр);
Ид=Лев(Ид, ПозОткр-1) + Прав(Ид, СтрДлина(Ид)-ПозЗакр);
КонецЕсли;
КонецЕсли;
Стр=СтрЗаменить(Ид, "/", ",");
СЗ.ИзСтрокиСРазделителями(Стр);
ТипДок=СЗ.ПолучитьЗначение(2);
ИдДок=СЗ.ПолучитьЗначение(3);
СтрВнутр="{""O"",""0"",""0"",""ТипДок"",""0"",""0"",""ИдДок""}";
СтрВнутр=СтрЗаменить(СтрВнутр, "ТипДок", ТипДок);

ИдДок=Формат("", "С"+Строка(10-СтрДлина(ИдДок)))+ИдДок;
СтрВнутр=СтрЗаменить(СтрВнутр, "ИдДок", ИдДок+ КодИБ);
Возврат(ЗначениеИзСтрокиВнутр(СтрВнутр));
КонецФункции


1С это язык скриптов или все же программирования? | База знаний | mista.ru

1С это язык скриптов или все же программирования?

Vser1 29.06.2004 10:31 | Если исходить из того, что модуль программного кода 1С интерпретируется во время выполнения, то C и басик NET тоже скриптами можно обозвать, ведь они интерпретируются через фреймворк (== типа среда 1С). ООП можно организовать через компоненту 1С++. ============================================= ЗЫ: встретил на одном форуме, возник вопрос какие мнения будут на специализированном форуме по данному вопросу, ссылку на исходник дам попозже.
SnarkHunter 1 - 29.06.2004 10:33 | Не все ли равно... Для начала дай точное определение что такое "скрипт" и что такое его язык...
Valery 2 - 29.06.2004 10:36 | Ты имееш ввиду, что язык программирования это с компилятором, скрипт - интерпретатор?
SiMazx 3 - 29.06.2004 10:43 | Вот на что может повлиять любой вариант ответа? Вот мне лично глубоко пофих... Шашлык-машлык, не видишь - мы кющаем...
Valery 4 - 29.06.2004 10:52 | (3) Конечно совершенно по барабану. Компилятор интерпретатор. раньше было foxpro и clipper. Все один к одному только один интерпретатор другой компилятор. Как тут понять в таком случае?
SnarkHunter 5 - 29.06.2004 10:53 | Да и клиппер не совсем компилятор...
Матрейя 7 - 29.06.2004 18:23 | Все реальные 1с-ники давно перешли на 2с :)
Матрейя 10 - 29.06.2004 18:27 | 9. http://www.vtools.ru/2c.htm
romix 16 - 29.06.2004 19:50 | 1С - это не скрипты!!!! Скрипты автоматизируют/имитируют работу пользователя в "юниксовой" текстовой консоли. В противном случае это приложение. :-)
Волшебник 17 - 29.06.2004 22:02 | Очень даже возможно, что встроенный язык 1С:Предприятия 7.7 - скриптовый язык, аналогично PHP или JavaScript. И в этом нет ничего плохого. Он изначально не задумывался как универсальный язык программирования, типа C++. Как говорит доктор Александр Червоненко: "Не важно, что ты делаешь и во что веришь. Важно, как это изменяет тебя". Хоть горшком назови... Если инструмент помогает быстро и качественно решать поставленные задачи, интересен, дает свободу творчеству, наконец, обеспечивает пропитание, то это хороший инструмент.
Warlock 18 - 29.06.2004 22:19 | ИМХО Язык 1С можно называть скриптовым пока рассчитываются формулы типа Итог("Сумма") или процедурки типа Если ПустоеЗначение(Цена)=1 Тогда Предупреждение("ВведитеЦену!!!"); СтатусВозврата(0); КонецЕсли; Но если реализована обработка загрузки выписки банка, то какие тут скрипты?! А вообще, все равно, как называть, язык 1С:Предприятие решает (пытается решать) задачи, для которых был создан...
Матрейя 21 - 29.06.2004 23:22 | 20. А чем 1с-язык не язык высокого уровня? Отличия основные только в том, что нельзя создавать свои классы не используя ВК.
Матрейя 23 - 29.06.2004 23:42 | Тем не менее, созданный набор классов достаточен для большинства экономических задач. Если интересует что-то более продвинутое, тогда пробуй 2с. У меня лично возникло очень приятное чувство, когда я сам создал объект ТЗ и описал его свойства и методы. А потом сравнил с ТЗ 1с на скорость: ввод 50000 строк по 3 столбцам (значения 1,2,3) в 1с на моем компе - 4,5 сек, моя ТЗ-3 сек.
Матрейя 25 - 29.06.2004 23:54 | 24. Вот смотри код метода ТЗ.НоваяСтрока() Функция НоваяСтрока() Экспорт ЕстьСтрок=ЕстьСтрок+1; НомерСтроки=ЕстьСтрок; Для П=1 По ЕстьАтрибутов Цикл Данные[П].ДобавитьЗначение(); КонецЦикла; КонецФункции И это все :)) Данные[П] - столбцы ТЗ, выполненные в виде СЗ. То есть ТЗ - массив СЗ.
Матрейя 26 - 29.06.2004 23:56 | Вот так происходит опеределение СоздатьОбъект("ТаблицаЗначений"): Функция ПолучитьТипОбъекта()Экспорт Возврат "ТаблицаЗначений"; КонецФункции
Матрейя 27 - 29.06.2004 23:57 | И последний пример, который показывает реализацию метода Знач=ТЗ.ИмяКолонки в переборе: Функция ПолучитьАтрибут(Имя) Экспорт НомКол=ПолучитьИмяАтрибута(Имя); Если Число(НомерСтроки)>0 Тогда Если НомКол>0 Тогда Возврат (Данные[НомКол].ПолучитьЗначение(НомерСтроки)); Иначе Ошибка("Неизвестный идентификатор колонки : "+Имя); КонецЕсли Иначе Ошибка("Не было выборки строк"); КонецЕсли; КонецФункции
Матрейя 29 - 30.06.2004 00:09 | 28. Краткое состояние проекта 2с: 1. Ядро (уровень 0 - интерпретатор) практически завершена функциональность. Глюки есть, их больше чем в v77, но меньше чем в v8. В ближайшее время будет начата работа по "вылизыванию" уровня 0. 2. Уровень 1 - классы - прилагается демо-конфигурация с примитивным и кривым набором объектов (они просто создавались в спешке для тестирования уровня 0), но их достаточно чтобы вникнуть и начать создавать свои. 3. Уровень 2 - конфигурация из объектов уровня 1 пока еще никто не создал, поскольку нет качественных объектов 1 уровня. 4. Нормальная дока - выйдет в ближайшее время. 5. Скорее всего на следующей недели или около этого выйдет конвертор данных из 1с v7 в 2с. Будут конвертироваться только объекты конфигурации, без кода.
Vser1 32 - 30.06.2004 02:22 | Похоже серьезного обсуждалаво не получиться ;))) так что привожу ссылку на источник вопроса: http://www.ykt.ru/cgi-bin/forum/iforum.isa?f=13&a=rx&id=884943


Индекс размером > 2G | База знаний | mista.ru

Индекс размером > 2G

Женя 14.05.2004 07:57 | Привет всем! При обновлении конфигурации, создается файл индекса 2 гига и после этого 1С начинает на него ругаться что не может его прочитать! Конфа сетевая, заказная - континент-страхование + свои исправления. 1с-ка релиз 21, каталоги пользователей на сервере (терминал). Сеть коммутируемая 100MB. Сервер выделенный, 2xXEON 2.5GHz, 2GB RAM, SCSI RAID5, Windows 2003 Server + TS. Справочник "ОбъектыСтрахования", размер dbf-ки 16,5 МБ, рабочего индекса 3,6МБ в справочнике изменены некоторые атрибуты, что то удалено, что то добавлено, несколько ранее существующих атрибутов стало периодическими. После объединения конфигурации и анализа изменнений, при попытке сохранить конфигу создается индекс на эту dbf - ку размером 2 гига и конфигуратор начинает ругаться то не может прочитать файл индекса. Если отвечать "ОК" (раз 500) то конфига сохраняется, но из справочника теряется гдето процентов 5 информации Вот подробности. Ваше мнение?
427 1 - 14.05.2004 08:19 | Ты уперся в ограничение ДБФ.... Либо отползай на сиквел.... либо реж базу ... Отползать тебе тоже сложно будет... чтобы без потерь данных...
это не ограничение 2 - 22.08.2004 18:41 | это небольшой глюк. Нужно у справочник "ОбъектыСтрахования" поле наименование уменьшить хотя бы до 50, а поле код лучше вообще убрать. Ошибка появляется после обновления на релиз Континента в котором у одного из реквизитов была установлена сортировка. Данная проблема обсуждалась и была успешна решена на Т1С.


"Error#:-210", Help!!! | База знаний | mista.ru

"Error#:-210", Help!!!

Grigorry 05.05.2004 08:32 | Обновили 1С Предприятие с 4.4 на 4.5. Программа зпускалась с базой но стала выдавать предупреждение об ошибке связаной с отсутствующем субсчетом. После чего запустили в канфигурации проверку базы без исправлений, в итоге много несовпадений по строкам. После этого программа не подключает базу. Выдает ошибки "Unrecognized Field Name SP40395" и "Error#:-210".Базу выгружали и загружали обратно в новую, это не помогло. Как это исправить?
SnarkHunter 1 - 05.05.2004 08:41 | Копию поднять, которая сделана до "обновления", а после этого пригласить специалиста, который сделает обновление так, как нужно...
vdi 2 - 05.05.2004 09:26 | Следовали ли вы указаниям файла Conv44.txt, который располагается в папке ExtForms? При переходе с 4.4 на 4.5 были какие-то изменения с субсчетом 98.2. _________ С уважением, vdi.


"Закрытие месяца" сторнирует остатки сч. 69!!! | База знаний | mista.ru

"Закрытие месяца" сторнирует остатки сч. 69!!!

vdi 09.05.2004 22:46 | Дамы и господа с днем Победы Вас. Желаю здоровья, успехов, счастья и больших и малых побед на фронте 1с. Помогите и мне одолеть одну проблемку. 1сБухУчет-релиз457. На 31 марта введены остатки по субсчетам счета 69. В апреле документ "Закрытие месяца" сторнирует их. В результате после перечисления в бюджет этих остатков возникают остаток по дебету счета 69. Не могу понять: дело в конфигурации или во мне.
DElo 1 - 09.05.2004 23:00 | Не могли бы Вы уточнить: закрытие какого месяца сторнирует 69 счёт? Марта или апреля?
vdi 2 - 09.05.2004 23:09 | Апрельский документ Закрытие месяца" сторнирует остатки введенные на 31 марта.
DElo 3 - 09.05.2004 23:44 | А обороты на сч.ДФЛ.1 введены?
427 4 - 09.05.2004 23:57 | (3) в точку
DElo 5 - 10.05.2004 00:00 | (4)В запятую, блин! Если не введены, то Эска считает, что доходов не было, и нефиг начислять налоги с ФОТ. Поентому потрудитесь ввести обороты по сч.ДФЛ.1, равные К70 на 31 марта. Всё будет - ок.
DElo 8 - 10.05.2004 01:04 | То-то же. Это описывалось в UPDATE.TXT 4.4 на 4.5.


что такое "обработка" ? | База знаний | mista.ru

что такое "обработка" ?

Crystalizer
28.05.2004 15:12 		//тема
SnarkHunter
1 - 28.05.2004 15:14 		Это то, что обрабатывает...
lexa
5 - 28.05.2004 15:21 		Обработка - Объекты метаданных этого вида используются для выполнения различных действий над информационной базой.
lexa
6 - 28.05.2004 15:23 		Для получения сводной выходной информации в системе 1С:Предприятие используются объекты метаданных, называемые «Отчет» и «Обработка». Объект данных этого типа представляет собой алгоритм обработки информации на внутреннем языке системы 1С:Предприятие. К алгоритму «прикрепляется» диалог, при помощи которого, при необходимости, можно организовать ввод каких-либо параметров, влияющих на ход его алгоритма. Обычно алгоритм имеет и сделанное в табличном редакторе описание печатной формы, которое используется для вывода результатов выполнения алгоритма на экран и принтер. В некоторых случаях одна и та же таблица используется и для ввода параметров, и для вывода результатов.

Название «Отчеты» и «Обработка» отражает два вида задач, которые могут выполняться объектами метаданных этих типов.

Во-первых, это получение разнообразных отчетных документов. В этом случае информация, накопленная в системе, используется для обобщения и формирования итоговых результатов в различных раз. резах.

Во-вторых, это выполнение различных действий над информацией. Например, с их помощью можно выполнять удаление из системы устаревших данных, импорт информации из других систем и многое другое. Характер выполняемых в этом случае действий отражает название объекта метаданных — «Обработка», так как в результате информация, хранящаяся в системе, претерпевает какие-либо изменения.

С точки зрения настройки, эти два типа объектов метаданных совершенно одинаковы. Однако рекомендуется алгоритмы, выполняющие какие-либо изменения в информационной базе, размещать на ветви «Обработка» и назначать права на использование обработок только наиболее подготовленным пользователям системы.
Crystalizer
7 - 28.05.2004 15:23 		ух!
это программа или это тип данных?
приведити пример обработки, пожалуйста ?!
lexa
9 - 28.05.2004 15:25 		зайди в конфигуратор, открой конфигурацию или открой файл с расширением ert из папки extforms
Рупор абсурда
14 - 28.05.2004 15:35 		(13) Ну-ка, ну-ка, в чём разница между отчётом и обработкой?
Паскудник
15 - 28.05.2004 15:37 		Отчёт - отчитывает
Обработка - обрабатывает

Я прав? :)


"Сделать документ не проведенным" как отменить изменения в документах? | База знаний | mista.ru

"Сделать документ не проведенным" как отменить изменения в документах?

Таня 28.05.2004 18:15 | если при проведении документа1, в документе2 записывается дата проведения документа1, то если в журнале документов для документа1 выбрать Сделать не проведенным, то как убрать из документа2 эту самую дату?
shura 1 - 28.05.2004 18:23 | Предопределенная процедура ПриОтменеПроведения() (кажется так)
Таня 2 - 28.05.2004 18:25 | а ее надо в модуль документа?
Press 3 - 28.05.2004 18:25 | Ня - ОбработкаУдаленияПроведения()
Таня 4 - 28.05.2004 18:26 | "может располагаться только в глобальном программном модуле" в глобальном модуле дописывать?
Таня 7 - 28.05.2004 18:32 | Спасибо :) все получилось


Подскажите пожалуйста, синтаксис конструкции? Метод СуществуетФайл. | База знаний | mista.ru

Подскажите пожалуйста, синтаксис конструкции? Метод СуществуетФайл.

Denis Nsk 02.06.2004 14:47 | В ЗиК 7.7 отчет Подготовка сведений для ИНМС в модуле формы есть процедура: //****************************************************************************** // Предопределенная процедура // Процедура ПриНачалеВыбораЗначения(ИдентЭлемДиалога, ФлагСтандОбр) Если ИдентЭлемДиалога = "Каталог" Тогда ФлагСтандОбр = 0; Если ФС.СуществуетФайл(Каталог+"\NUL")=1 Тогда Кат = Каталог; Иначе Кат = "C:\"; КонецЕсли; ФС.ВыбратьКаталог(Кат,"Выбор каталога для вывода файла данных"); Каталог = Кат; КонецЕсли; КонецПроцедуры // ПриНачалеВыбораЗначения() Интуитивно понимаю все операторы и параметры. Но точно не могу понять что делает в строке Если ФС.СуществуетФайл(Каталог+"\NUL")=1 Тогда вещица +"\NUL"? Хочется понять, а не выучить. Если не труд объясните пожалуйста.
SnarkHunter 2 - 02.06.2004 15:08 | (1)Нет... (0)Это проверка наличия дискеты в дисководе http://www.sinor.ru/~my1c/knowhow/chk_flop.html
mszsuz 3 - 02.06.2004 15:11 | Это тянется ещё со времен DOS - "NUL - это специальный файл: все, что записывается в файл NUL не доступно и не может быть восстановлено. Файл NUL относится к файлам типа WOF (write=only file - файл только для записи)" Подобной конструкцией проверяется именно наличие каталога, т.к. если есть каталог, то и файл NUL там тоже есть ;)


"Редактирование в диалоге" - Заблокировано! Почему? // список элементов с | База знаний | mista.ru

"Редактирование в диалоге" - Заблокировано! Почему? // список элементов с

Crystalizer 04.06.2004 14:05 | ?
Crystalizer 3 - 04.06.2004 14:16 | в предприятии в форме списка of справочника выбрано редактировать в диалоге, и изменить нельзя... :/
NastyFrog 4 - 04.06.2004 14:19 | В конфигураторе не меняется?
NastyFrog 8 - 04.06.2004 14:25 | В конф-ре открой справочник - Редактирование: в списке, в диалоге, обоими способами


"время проведения документа" и "уникальный номер"... почему не само-соб | База знаний | mista.ru

"время проведения документа" и "уникальный номер"... почему не само-соб

Crystalizer 07.06.2004 12:05 | в конфигурации с к-й я щас парюсь при проведении документа приходица самому изменить номер документа (иначе говорит что номер не уникальный), и выбирать время проведения документа... почему это всё не работает по умолчанию как в других "нормальных" конфигурациях?
DimG 1 - 07.06.2004 12:07 | номер руками меняли
DimG 3 - 07.06.2004 12:25 | если изменили неправильно, да менять, или перенумеровывать правильно, например обработкой...


Что это "Общая файловая ошибка при доступе к C:\...\ Main metadata Strea | База знаний | mista.ru

Что это "Общая файловая ошибка при доступе к C:\...\ Main metadata Strea

Heretic 25.06.2004 10:52 | Пытаюсь загрузить конфигуратор базы - выскакивает окно: "Общая файловая ошибка при доступе к C:\Путь\~md23.tmp\Metadata\Main metadata Stream"? После чего 1С закрывается. Что это и можно ли все восстановить?
Heretic 2 - 25.06.2004 11:02 | Да, XP. Но вчера все работало. А сегодня все конфигурации запускаются нормально, кроме одной. :(((
Zubr 3 - 25.06.2004 11:03 | 1. Битый МД - ищи архив. 2. Конфу 1С:Предприниматель пытаешься открыть релизом младше 20. 3. Еще чего-нибудь...
Stra 4 - 25.06.2004 11:04 | Нет доступа к катологу временных файлов этой базы. Проверь существование "C:\Путь\"
Heretic 5 - 25.06.2004 11:07 | > Zubr Т.е. если первый вариант - то п%;№; конфе? Никак нельзя ее восстановить, хотябы частично? Хотябы алгоритмы обработчика...?
Heretic 6 - 25.06.2004 11:10 | > Stra Путь существует и при запуске 1С прописывает туда файл ~md23.tmp. После ошибки и закрытия этот файл исчезает...
Stra 7 - 25.06.2004 11:15 | Попробуй скопировать весть католог ИБ в другое место (машину), без индексов и открыть конфигуратором оттуда. Может помочь
Heretic 8 - 25.06.2004 11:22 | Скопировал. Убрал *.cdx Не получается... та же ошибка, только теперь ругается на ~md2c.tmp. Ничего больше нельзя сделать?
Stra 9 - 25.06.2004 11:28 | А на другой машине нет возможности проверить? Жел-но без XP
Heretic 10 - 25.06.2004 11:48 | Ниче не выходит. Короче я понял, что конфе тапки. А можно ее как-то восстановить, можно частично.
SiMazx 11 - 25.06.2004 11:59 | http://www.gendin.ru/md/index.html
SiMazx 12 - 25.06.2004 12:00 | http://soaron.fromru.com/mddiags.htm
427 13 - 25.06.2004 12:05 | Можно. Практически полностью..
Valery 14 - 25.06.2004 13:51 | См New_Stru
It is me 15 - 25.06.2004 15:11 | А также все темпы на всех машинах, где юзал Конфигуратор для этой конфигурации. Ищи файлы известного тебе типа ~md2c.tmp, переименовывай в 1cv7.md и пытайся открыть и понять, насколько это старая версия конфы...
povar 27 - 12.07.2004 08:50 | (0) Была похожая проблема на сетевой версии. База лежала на серваке, 30 пользователей, одному поменяли комп. и у него при загрузке начала появляться такая же ошибка. При чем с других компов (с той же операционкой ХР) все шло нормально. Помогло только замена оперативной памяти у данного компа.


Ошибка "Не задан вид" | База знаний | mista.ru

Ошибка "Не задан вид"

UltraViolet 25.06.2004 17:48 | Подскажите, пожалуйста, почему при открытии документа выскакивает сообщение об ошибке "Не задан вид". В табличной части документа есть текстовое поле, выражение в котором равно "Сотрудник.Код", где Сотрудник - это реквизит табличной части типа "Справочник". Сообщение выводится один раз, а не после каждой строки. Если убрать это выражение - не ругается. Как избавиться от сообщения?
lexa 2 - 25.06.2004 18:02 | а текстовое поле - реквизит справочника, или текстовое поле на форме документа?
UltraViolet 3 - 25.06.2004 18:18 | не реквизит, а именно текстовое поле
lexa 4 - 25.06.2004 18:20 | убери знак равенства
UltraViolet 5 - 29.06.2004 10:08 | а в выражении и не стоит знак равенства...
SnarkHunter 6 - 29.06.2004 10:17 | Вместо "Сотрудник.Код" попробуй "?(Сотрудник.Выбран()=1,Сотрудник.Код,"")"...


"ИерархияГруппИЭлементов" или "ИерархияЭлементов" | База знаний | mista.ru

"ИерархияГруппИЭлементов" или "ИерархияЭлементов"

kabazЯba 09.12.2004 10:18 | Вот вопрос! Как программно определить какой вид иерархии установлен в справочнике? Определить иерархический он или нет - легко .Иерархический (Истина/Ложь), а вот вид иерархии как определеить? Код к вопросу... Для Каждого Спр Из Метаданные.Справочники Цикл СтрокаСообщ = Спр.Имя + " " + ?(Спр.Иерархический,"Иерархия " + ?(Спр.ВидИерархии = ?????,"групп и элементов", "элементов"),"Не иерархический"); Сообщить(СтрокаСообщ); КонецЦикла;
Волшебник 9 - 09.12.2004 11:52 | Метаданные.СвойстваОбъектов.ВидИерархии.ИерархияГруппИЭлементов